© Foxit Software Incorporated. All Rights Reserved.

No part of this document can be reproduced, transferred, distributed or stored in any format without the prior written permission of Foxit.

Anti-Grain Geometry - Version 2.4

© Maxim Shemanarev (http://www.antigrain.com)

Portions of this product Copyright [2001-2020] Solid Documents

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears in all copies. This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.
Contents

Chapter 1 – Introduction ................................................................. 7
PhantomPDF Overview ................................................................ 7
What’s New? ................................................................................. 8
About the User Manual .............................................................. 11
Quick Installation Guide ............................................................... 11
Online Help .................................................................................. 12
Foxit Plug-In Platform ................................................................. 12

Chapter 2 – Get Started ................................................................. 15
Workspace Basics ....................................................................... 15
Customize the toolbar .............................................................. 19
Customize the Skin .................................................................. 22
Mouse/Touch Mode .................................................................. 22
Set Preferences ......................................................................... 22

Chapter 3 – Read ......................................................................... 48
Open PDFs ............................................................................... 48
Save PDFs ............................................................................... 49
Close a PDF ............................................................................. 51
Export PDFs ........................................................................... 51
View PDFs .............................................................................. 56
View 3D Content in PDFs .......................................................... 71
Select & Copy .......................................................................... 72
Search & Index in PDFs ............................................................ 75
Compare PDF Files ................................................................. 84
Word Count ............................................................................. 85

Chapter 4 – Create ..................................................................... 86
Create a PDF in Different Ways .................................................. 86
Create and customize a PDF portfolio ...................................... 106
OCR PDFs and PDF Portfolios .................................................. 108
Create a table of contents from bookmarks ............................ 111
Industry Standard Validation and Creation .............................. 112
Chapter 5 – Edit ................................................................. 118
Undo and Redo ........................................................................ 118
Links ..................................................................................... 118
Bookmarks ............................................................................. 124
Page thumbnails ..................................................................... 128
Destinations .......................................................................... 129
File Attachments .................................................................... 130
Images ................................................................................... 133
PDF Optimizer ......................................................................... 140
Action Wizard (Business Edition Only) ...................................... 146
Work with Video & Audio .......................................................... 148
Search and Replace Text ........................................................... 152
Paragraph Editing ................................................................... 153
Objects ................................................................................... 154
Articles ................................................................................... 179
Spelling Check ....................................................................... 183
Working with Layers ................................................................. 184
PDF Properties ......................................................................... 188

Chapter 6 – Organize ............................................................... 191
Insert Pages ............................................................................ 191
Rotate, Move, Swap and Delete Pages ......................................... 194
Extract, Duplicate and Replace Pages ........................................ 196
Split PDFs into multiple files .................................................... 199
Crop Pages .............................................................................. 200
Flatten Pages .......................................................................... 201
Reverse Pages ........................................................................ 202
Header & Footer, Watermark & Background to PDFs .................. 203
Bates Numbering (Business Edition Only) ................................. 207
Change the format of page numbering ....................................... 208

Chapter 7 – Comment .............................................................. 209
Commenting tools .................................................................... 209
About pop-up notes .................................................................. 225
Change the Appearance of Comments ....................................... 226
Managing Comments ............................................................... 228

Chapter 8 – Share PDFs ............................................................ 239
Email Documents ..................................................................... 239
Send to Evernote ................................................................. 239
Send to OneNote ............................................................... 240
SharePoint Integration ......................................................... 240
Shared Review and Email Review ......................................... 242
ndOffice Integration .......................................................... 247
iManage Work Integration .................................................. 248
OpenText eDOCS Integration ............................................... 252
OpenText Documentum Integration ....................................... 253
OpenText Content Suite Integration ...................................... 254
Worldox Integration ........................................................... 255
ShareFile Integration .......................................................... 256
Epona DMSforLegal Integration ........................................... 257
Alfresco ................................................................................ 258

Chapter 9 – Forms ................................................................. 260
Interactive Form and Non-interactive form ................................. 260
Fill in PDF Forms .................................................................. 261
Comment on Forms ............................................................. 264
Manage Form Data ................................................................ 264
Form Fields ........................................................................... 267
JavaScript .............................................................................. 297

Chapter 10 – Security ............................................................... 301
Check PDF security ............................................................... 301
Password Protection & Certificate Protection ............................ 301
AIP Protect (Business Edition Only) ........................................ 307
Remove hidden data ............................................................. 321
Redaction (Business Edition Only) .......................................... 322
Windows Information Protection (WIP) .................................... 327
FIPS mode ............................................................................. 330
Trust settings ....................................................................... 330

Chapter 11 – ConnectedPDF .................................................... 335

Chapter 12 – Signature ............................................................. 336
Digital Signature .................................................................... 336
Sign PDFs with DocuSign® .................................................... 349
Quick PDF Signature ............................................................. 351
Chapter 13 – Accessibility .................................................................354
Accessibility Check and Fixes .................................................................354
Accessible reading and navigation through accessibility preference setting and
shortcut keys ...........................................................................................363
Create accessible PDFs (Business only) .................................................365

Chapter 14 – Foxit Admin Console .........................................................379

Chapter 15 – Print ..................................................................................380
Print PDF documents ..................................................................................380
The Print dialog box ..................................................................................382
Set Foxit PhantomPDF Printer Properties .................................................385

Chapter 16 – Appendices .......................................................................390
Quick Installation Guide ...........................................................................390
SharePoint Configuration ..........................................................................401
Web Service Configuration ........................................................................402
Work with PhantomPDF via VBA scripts in Microsoft Office .....................414
Keyboard Shortcuts ..................................................................................417
Single-key Accelerators ...........................................................................420
Command Lines .......................................................................................426

Contact Us ..............................................................................................427
Chapter 1 – Introduction

PhantomPDF Overview

Welcome to Foxit PhantomPDF™- Business Ready PDF! Award-winning Foxit PhantomPDF provides the right features at the right price, allowing you to produce great looking PDF document and forms quickly, affordably, and securely. Foxit PhantomPDF comes in two editions: Foxit PhantomPDF Standard to fit the small and medium sized businesses, and Foxit PhantomPDF Business to fit the large enterprises.

Foxit PhantomPDF Standard

Foxit PhantomPDF Standard enables businesses to create, edit, and secure reliable PDF documents quickly, easily, and at a cost you can afford.

- XFA Form Filling
- Direct Editing
- Read out Loud
- Robust Document Security
- Form Fields
- Optical Character Recognition (OCR)
- Export PDF to Image
- Industry Validation
- PDF Optimizer
- SharePoint Integration
- DocuSign
- Participate in a Shared Review

Foxit PhantomPDF Business

Foxit PhantomPDF Business provides business the security that ensures regulatory compliance and corporate governance of their important documents and archives and to ensure documents don't change after they are approved. It stands up to the demands of large enterprises but lightweight enough to easily deploy to thousands of users without exhausting resources. Supports the right features at the right price with the quality and support you expect from an enterprise solution.

- Redaction
- Document Certification
Chapter 1: Introduction

What’s New?

What’s new in Foxit PhantomPDF 10.0?

New features and Improvements in Foxit PhantomPDF 10.0:

- **Foxit Admin Console** provides IT administrators the ability to easily manage large numbers of PhantomPDF licenses.
  - Manage users, create user groups, add and remove users. It can connect to SSO (single sign-on) systems, including Active Directory, to securely gain access to user information.
  - Assign and remove licenses from users and user groups.
  - View the total number of Foxit licenses you own and currently have assigned. Update licenses on the fly.
  - Configure multiple administrators that can use the Admin Console.
  - Log admin operations and login/logout info, as well as use by end-users.

- **Foxit Update Server** provides IT the ability to better manage and automate the software upgrade process and to ensure users upgrade to the exact release that IT has tested, without having to access an external server.
  - Automatically download updates from Foxit servers and make them available on a local network.
  - Automatically approve updates for users to download, or restrict users to only download approved updates.
  - Set times when all users, or specific users/groups, can download updates.
  - Push updates to users, requiring them to install them.

- **PhantomPDF Online** delivers more features and enhancements.
  - A new UI to better match the PhantomPDF Windows user interface, and improved support on mobile devices. This makes it easier for internal
support and training organizations to support mixed Windows, Mac, and cloud environments.

- **Support more form field types and JavaScript to support complex form workflows.**
  - New form field support includes barcode, date, and image form fields. Support for using an external JavaScript editor, as well as JavaScript functions for page numbering/transitions, search/indexing, web links, and more.

- **Fill & Sign**
  - Fill & Sign provides a convenient workflow of filling flat forms (i.e. non-interactive) and quick signing by typing or drawing your signature, or using an image. With the Fill & Sign tools, you can add text and other symbols anywhere on a flat form.

- **Create USPTO-ready PDF documents using any creation method.**
  - Use virtual printer, Office add-ins, etc., to create US Patent and Trademark Office compatible PDF documents. Sets defaults for properties like page size, fonts, etc. per requirements to submit to the USPTO.

- **Modify backgrounds, watermarks, and headers/footers on multiple PDFs at once through batch Add.**
  - Enhancement to the Add function which provides a popup window which allows you to choose multiple files and add a watermark, background, etc. to all files simultaneously.

- **Additional GPO settings for enterprise administration.**
  - GPO is Group Policy, a Windows capability for IT admins to set various options, features, preferences, etc. using templates.
  - New capabilities include customization of support links displayed to user, and locking down some additional settings, such as default PDF viewer and ability to create self-signed digital IDs.

- **Multiple enhancements to bookmark and tag editing and reading**
  - Improvements to bookmark/tag integration, multiple UI improvements for Bookmarks panel including highlighting, resizing, etc.

- **More functions in Action Wizard, including support for everything in Adobe Acrobat’s default actions.**
  - New actions include: Save As, Remove hidden info, view logs, batch conversion, etc.

- **Display all comments in a desired font for better accessibility**
  - Users can choose the desired font and font size for all comments in all documents they read, overriding the document’s settings.
• **Classify and protect with labels in Microsoft Azure Information Protection (AIP)**
  o The feature is helpful for enterprises to classify and protect documents by applying labels that are configured by administrators with protection settings such as which people can read and use protected documents. *(Business Only)*
  o Can be applied to multiple files simultaneously. *(Business Only)*

• **More seamless integration with ECM**
  o Add Bates numbering to files from SharePoint, ShareFile, iManage 9, andOffice, OneDrive-Personal, Google Drive, Box, Dropbox, eDOCs DM, and DMSforLegal. *(Business Only)*
  o Convert files to PDF in batches from iManage 9.

• **More preference options for Advanced Search**
  o A new option to make subsequent searches faster by storing a cache of information from PDF files that you search.
  o Support proximity searching, which searches for two or more words that are separated by no more than a certain number of words. The feature is useful when you are looking for concepts that might be expressed by multiple different phrases.
  o More advanced options allow you to find words that share the same word stem of the specified search word, or ignore Asian character width, diacritics, and accents.

• **PDF Optimizer improvements**
  o A new simplified interface combining Reduce File Size, PDF Optimizer, and Optimize Scanned PDF features into the new PDF Optimizer in the File tab.
  o Allow you to reduce file size in batch with default settings, and support more professional options for advanced PDF optimization.

• **Improvements for indexing**
  o Create a batch XML file (a text file that contains a list of platform-dependent catalog index file paths and flags) with Notepad and use a scheduling application such as Windows Task Scheduler to schedule when and how often to automatically update a full-text index.
  o Provide an option to allow you not to change long PDF filenames to MS-DOS filenames as you prepare documents for indexing, and more options to specify advanced criteria such as custom document properties to be indexed.

• **Support more actions in a PDF portfolio**
  o Select one or more PDFs in a PDF Portfolio and reduce the file size.
Chapter 1: Introduction

- Sort and order files and folders in a PDF portfolio by name, modified time, or other customizable categories.

- **OCR enhancements**
  - Enhanced “Find All Suspect” for streamlined OCR experience, which shows all OCR suspected results in a panel and allows selecting and correcting multiple suspects at once.
  - Edit scanned PDFs.

- **Automatically search all instances of a text string and then highlight them.**

- **Better support for 4K and other high-resolution displays.**

- **Customize a profile that specifies the text strings you want to search and redact, and apply that profile to documents, which improves the productivity of your document workflows that require the same protection. (Business Only)**

- **Support Hindi Digits to allow you to input numbers in Hindi using Add Text, Edit Text, and Reflow Editing features.**

- **Support more file types, more ways to add files, and more options for conversion settings when you combine multiple files to a single PDF.**

- **Add an option to embed page thumbnails into documents, which can make the thumbnails appear faster in large PDFs.**

- **Adds search patterns that are commonly used in Canada for the Advanced Search and Search & Redact features.**

---

**About the User Manual**

This user manual covers all features included in Foxit PhantomPDF. For information on the deployment of Foxit PhantomPDF in an enterprise environment, please refer to Foxit PhantomPDF Deployment and Configuration.

**Quick Installation Guide**

To get installation, registration, uninstallation and update instructions step by step, please refer to Foxit PhantomPDF Quick Installation Guide.
Online Help

You can get online help about how to read and work with PDF files from within Foxit PhantomPDF using the Help Center and Content-sensitive Help features. (The online help is only available in English version.)

Help Center

Help Center helps you navigate top help topics and get help online. To access the Help Center, please click Help > Help Center. In the Help Center, you can input a keyword in the Search box to search for any desired topic. While reading the help contents, you can click to move back to the previous view, or click to return to the Home Page of the Help Center.

Content-sensitive Help

Content-sensitive Help assists users by providing help based on a specific task they perform. This enables users to get specific information about whatever feature of the application they are using at the given moment.

To access Content-sensitive Help:

Hover your mouse over a button, and you will see the tip which gives you the basic instruction of the feature. If Foxit PhantomPDF contains additional help about the feature, you can click Tell me more to learn more about it in Help Center.

Foxit Plug-In Platform

For flexible and convenient management of plugins, Foxit PhantomPDF offers a Plug-in Platform, in which you can view the plug-in status, learn the information about the plugins installed, as well as manage the plug-ins as needed.

To open Foxit Plug-in Platform, please choose Help > Foxit Plug-Ins.

Plug-in Status

- Certified: Shows whether the signature of the plug-in is valid or not.
- Loaded: Shows whether the plug-in has been loaded successfully or not.
**Note:** Some plug-ins are not loaded immediately (i.e. the Certified and Loaded items are unchecked). These plug-ins will be loaded and certified after you use the related features.

### Plug-in Information

In addition to plug-in status, you can learn more information about the plug-in installed, including the name, date, description and legal copyright.

To learn the details of a plug-in, please click **More...** under the general description of the plug-in in the Foxit Plug-in Platform.

### Plug-in Management

Within Foxit Plug-in Platform, you can manage the plug-ins as needed, including installing, enabling, disabling and uninstalling plug-ins.

### Installing a Plug-in

To install a plug-in, please follow the steps below:

- Select **Help > Foxit Plug-Ins** to open Foxit Plug-In Platform;
- Click **Install Plugin** > choose the plug-in file (in .xml format) > click **Open**.

Then Foxit PhantomPDF will verify whether the signature of the plug-in to be installed is valid or not. If it is valid, Foxit PhantomPDF will load the plug-in directly; if not, a prompt message will pop up (as shown below), and the installation will be terminated.

![Install failure message](image)

**Note:** The .xml and .fpi files of a plug-in to be installed should be placed in the same folder, otherwise, installation will fail.

### Disabling a Plug-in

To disable a plug-in, please follow the steps below:

- Select **Help > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
Select the plug-in you want to disable, and click the **Disable** button 📡 to disable it.

**Enabling a plug-in**

To enable a plug-in, please follow the steps below:

- Select **Help > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
- Select the plug-in to be enabled, and click the **Undo Disable** button 📡 to enable it.

**Uninstalling a custom plug-in**

To uninstall a custom plug-in (not built by Foxit), please follow the steps below:

- Select **Help > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
- Select the plug-in to be uninstalled, and click the **Uninstall** button 🗑️ to uninstall it.

**Note:**

1. *All the operations to the plug-ins will take effect after you restart Foxit PhantomPDF.*

2. *Foxit PhantomPDF includes plug-ins that are necessary for the realization of its functionalities or are necessarily required for maintenance. To ensure normal operation, you are not allowed to disable or uninstall these plug-ins (such as Foxit Updater plugin, Foxit Plug-in Platform plugin, etc.)*
Chapter 2 – Get Started

The Foxit PhantomPDF workspace is packed with commands that help make working with PDF files easier, and is organized into a toolbar (ribbon mode), a document pane, a navigation pane, and a status bar. A good way to get up to speed in using Foxit PhantomPDF is by familiarizing yourself with its workspace.

Workspace Basics

Foxit has integrated the collective commands in the ribbon interface and created a new way of working, namely Ribbon Mode. Ribbon Mode is developed based on Microsoft Office 2013 (Office 15) to provide you with a familiar and intuitive user experience. In this mode, commands are arranged by groups and tasks.

User Interface

A. Quick Access Toolbar  B. The File tab  C. Ribbon tabs  D. Groups and Commands
E. Tab Bar  F. Navigation Pane (the Pages panel displayed)  G. Document Pane
H. Status bar

- **Quick Access Toolbar**: shows the basic commands, such as Open, Save, and Print. You can add or replace the commands so as to ensure that the commonly used
ones are close at hand.

- **The File tab**: Click File to create, open, save to manage your PDF files.
- **Ribbon tabs**: shows the major tabs of Foxit PhantomPDF, including File, Home, Edit, Comment, View, Form, Protect, Share, Connect, etc.
- **Tab Bar**: shows the document tabs when multiple documents are open in one instance. See also Multi-tab Reading & Single Document Reading.
- **Groups and Commands**: categorizes the commands by groups according to the function under each ribbon tab.
- **Navigation Pane**: contains various navigation panels. See also Navigation Panels.
- **Status bar**: shows the status information about the current open document. See also Status Bar.
- **Document Pane**: shows the document content.

### Toolbar

The toolbar displays the File tab (the backstage view like Office 2013) and other ribbon tabs with different commands. Position the pointer over a command to see a description of the command. The **Hand** command (Hand) and the **Select** tools (Select Text and Image T and Select Annotation H), which are used quite often, are accessible on the left of most tabs on the ribbon.

### Search and Find Commands

You can easily and quickly find the command you need by clicking in the **Tell me what you want to do**... box (or press Alt +Q) near a bubble ▲ on the ribbon and typing the name or description of the command you need. Then Foxit PhantomPDF will display a list of matching commands from which you can select and activate the desired feature.

### Show/Hide Toolbar

To show/hide all toolbars, please do the following:

- To hide the toolbar, please click the arrow ▼ located on the lower-right corner of the ribbon. To show the toolbar, choose a tab and click the pushpin icon ◀ located on the lower-right corner of the ribbon.
Right-click toolbar and check **Minimize the Ribbon** option to hide the ribbon toolbar and uncheck the option to have the ribbon displayed.

**Navigation Panels**

**Show or hide the navigation panels**

The buttons on the left side of the navigation pane provides easy access to various panels, such as the Bookmarks panel button and the Pages thumbnails button. After right-clicking the navigation pane, you can select and open more panels.

- To show the navigation panels, use keyboard shortcut F4, or click View > Navigation Panels > Show Navigation Panels, or right-click on the page and choose Show Navigation Panels.
- To hide the navigation panels, use keyboard shortcut F4, or click View > Navigation Panels > Hide Navigation Panels, or right-click on the page and choose Hide Navigation Panels.
- To open a navigation panel, click its button on the left side of the navigation pane.
- To close a navigation panel, click its button on the left side of the navigation pane.

**Adjust the navigation pane**

Like the toolbars, the navigation pane can be docked in the navigation pane or float anywhere in the workspace. You can choose to hide or close the panels that you don't need and open the ones you do. What's more, you can also adjust the width of the navigation pane easily.

1. Viewing a panel in the navigation pane
   - By default, all the panels dock in the navigation pane with a set of panel buttons appearing on the left side of the work area. Do the following:
     - Select the button for the panel on the left side of the navigation pane.

2. Changing the display area for navigation pane
   - To change the view area of the navigation pane, drag its right border to adjust the width.
To minimize or maximize the navigation pane, click on the button at the top right corner of the navigation pane.

3. Docking or floating a navigation pane
   - To float a navigation panel, drag the panel button into the document pane.
   - To move a panel, drag it by its panel button to another location.
   - To dock a floating panel, double-click its title bar.

**Status Bar**

The status bar is an area of the workspace that displays the page number where you are, the number of total pages, page transition buttons, zoom buttons, etc. for view setting. The status bar is open by default when you open a PDF. In the View tab, the items on the View Setting group help you to show or hide the status bar.

![Show Status Bar: If you check it, the status bar will appear in the bottom of the workspace.](image)

**About Start Page**

By default, the Start page appears when you start Foxit PhantomPDF and includes the list of recent documents opened, helpful product tutorials, and Tool Wizard for some most frequently used features to help you get started with Foxit PhantomPDF.

The Start Page will continue to appear every time you start the program until you uncheck the Show Start Page at File > Preferences > General > Application Startup.
Customize the toolbar

The Ribbon is designed to help you find the commands in an easy and convenient way. Foxit PhantomPDF gives you the capability to personalize and fine-tune the Ribbon in the way you want. With this feature, you can customize Quick Access Toolbar and the default Ribbon, and create custom tabs or groups with your favorite commands.

Customize Quick Access Toolbar

Quick Access Toolbar displays all your bookmarked commands. You can add commands that will let you view and search content easily to your Quick Access Toolbar. This is another way for you to arrange and manage all the commands.

To add a command to Quick Access Toolbar, please follow the steps bellow:

1. Click on the Quick Access Toolbar, and select More Commands. Or right-click the ribbon area and choose Quick Access Toolbar....
2. In the Customize Tools dialog box, choose the Customize Quick Access Toolbar tab.
3. Select the commands or separators you preferred to be shown on Quick Access Toolbar and add them to the Quick Access Toolbar list. Click Up or Down to arrange the command order and then click OK.

To return toolbars to default configuration, please click on the Quick Access Toolbar, choose More Commands and click Reset on the pop-up context or press Alt+F8.

**Tips:** You can also right-click a command in the ribbon and choose **Add to Quick Access Toolbar** to add the command to Quick Access Toolbar.

Show Quick Access Toolbar below/above the Ribbon

To show Quick Access Toolbar below/above the ribbon area, do any of the following:

1. Click on Quick Access Toolbar, and select Show Below the Ribbon or Show Above the Ribbon.
2. Right-click the ribbon area and choose Show Quick Access Toolbar Below the Ribbon or Show Quick Access Toolbar Above the Ribbon.
3. Open the Customize Tools dialog box. In the Customize Quick Access Toolbar
tab, select or unselect the **Show Quick Access Toolbar below the Ribbon** option.

**Customize the ribbon**

To customize the Ribbon, you can right click the Ribbon, choose **Customize the Ribbon** from the context menu to bring out the **Customize Tools** dialog box first, and then follow the steps below.

**Create a new tab**

To create a new tab, please do one of the following:

- Select the tab after which you want to add the new tab, and then click **New Tab**.
- (Alternatively) Right-click the tab after which you want to add the new tab, and then choose **New Tab** from the context menu.

**Add a new group to a tab**

To add a new group to a tab, please do one of the following:

- Select the tab to which you want to add the group, and then click **New Group**.
- (Alternatively) Right-click the tab to which you want to add the group, and then choose **New Group** from the context menu.

**Rename a tab or group**

- Select the tab or group to be renamed, and click **Rename**.
- (Alternatively) Right-click the tab or group to be renamed, and choose **Rename** from the context menu.
- In the **Rename** dialog box, input the new name and click **OK**.
- For a custom group, you can also choose the display symbol from the **Rename** dialog box.

**Add commands to a group**

- Select the group under which you want to add a command.
- Choose the command category and the desired command from the **Choose command from** list.
- Click **Add** to add the selected command to the desired group.

**Remove a tab, group or command**
To remove a tab, group or command, please do one of the following:

- Select the tab, group or command to be removed, and click Remove.
- (Alternatively) Right-click the tab, group or command to be removed, and choose Delete from the context menu.

**Reorder the tabs or groups**

To reorder the tabs or groups, please do one of the following:

- Select the tab or group you want to reorder, then click the Up or Down arrow to move accordingly.
- (Alternatively) Right-click the tab or group you want to reorder, and then select Move Item Up or Move Item Down to move accordingly.

**Reset the Ribbon**

- Click Reset in the Customize Tools dialog box to reset the Ribbon to the default settings.

**Import a customized Ribbon**

- Click Import.
- In the Open dialog box, select the Ribbon customization file (.xml file), and click Open.

*Note:* After importing a Ribbon customization file, you will lose all the arrangements you have customized previously. If you want to revert to the customization you currently have, it is easier to export the customized Ribbon before importing any customization.

**Export a customized Ribbon**

- Click Export.
- In the Save As dialog box, specify the file name and path and click Save.

*Note:*

1. After customization, you need to click OK in the Customize Ribbon tab to save and apply your customizations to the Ribbon.
2. To help you distinguish a default tab or group from the customized ones, the custom tabs or groups in the Customize the Ribbon list are tabbed with “(Custom)” after the name (like this: ☑ New Tab (Custom)), but the word “(Custom)” will not appear on the Ribbon.

3. The commands in the default group under a default tab are displayed in grey, and they cannot be renamed, reordered, or removed.

4. You cannot remove default tabs in Foxit PhantomPDF.

**Customize the Skin**

There are five kinds of skin, **Classic, Black, Blue, Orange and Purple** that allow the user to change the look of the software.

To change the skin of the workspace, please do the following:

- Go to *File > Change Skin*.
- Check the skin you like and click OK.

**Mouse/Touch Mode**

Foxit PhantomPDF adds a Mouse/Touch Mode button on the **Quick Access** toolbar. In **Touch Mode**, the buttons within the Ribbon and Quick Access toolbar will appear with more space surrounding them onscreen, making it easier to work on touch devices.

To toggle between **Mouse Mode** and **Touch Mode**, please click the button on the **Quick Access** toolbar.

**Set Preferences**

Many program settings are specified in the Preferences dialog box, including settings for File Associations, Forms, Full Screen, General, History, JavaScript, Languages, OCR, Page Display, PDF/A, Reading, RMS Setting, Security, Signature, and Trust Manager. Once you set preferences, they remain in effect until you change them.

1. Choose **File > Preferences**.
2. Select the type of preference you want to change under the list of categories.
Accessibility

- **Document Colors Options**
  - Replace document colors: Check to activate other options to change the document colors.
    - Use Windows color scheme: Sets document colors according to the color scheme of your Windows preferences.
    - Use High-Contrast colors: Choose the high-contrast color combination for page background and document text to improve readability.
    - Custom color: Changes the color of Page Background and Document Text.
    - Only change the color of black text: Change only the black text and leave the colored text unchanged when you replace document colors.
    - Change the color of text or black line art: Change the color of text or black line arts when you replace document colors.

- **Override Page Display**
  - Always use Page Layout Style: Set a page layout as default for all PDF documents and override other page display settings.
  - Always use Zoom Setting: Specify a default zoom setting for all PDF documents and override other page display settings.

- **Other Accessibility Options**
  - Use document structure for tab order when no explicit tab order is specified: Improve the navigation of form fields and links in documents that don't specify a tab order.
  - Always display the keyboard selection cursor: Select this option and the Select Text and Image command will be selected automatically when you open a PDF. If you are using a screen magnifier, it's recommended to select this option.
  - Always use the system selection color: Override the default selection color (blue) with a color that the system specified.
  - Show Portfolios in Files mode: Display PDF Portfolio component files and file details in a list. Please note that if you set the default view for PDF portfolios in Portfolio > View > Default view setting, that default view setting will prevail over this accessibility setting.

- **Accessibility Checker Option**
  Show accessibility checker options dialog when the checker start: check this option to show the Accessibility Checker Options dialog box when you run Full Check.

**Action Wizard**

When running PhantomPDF's predefined actions, select the Save warning and errors in log file option to create a log file that contains the detailed report for the action.
results. Click **Browse** to select the location to save the log file.

### Commenting

- **Viewing Comments**
  - Font and Font Size: Specifies the default font and size for text in the comment pop-up notes. These settings apply to all new and existing pop-up notes (including replies to pop-up notes), and will take effect after you restart Foxit PhantomPDF.
  - Pop-up opacity: Sets the opacity of pop-up notes for annotation commands.
  - Print notes and pop-ups: Specify whether or not to print sticky notes and pop-up notes associated with comments in PDF as they appear on the page. Please note that if you want to print the pop-up notes associated with comments, you should open the pop-up notes that you want to print in the PDF file, and adjust their placement on the page before printing to ensure that they don't overlap or spill off the page. While printing, make sure that you select the **Document and markups** option in **Print What** group in the **Print** dialog box.
  - Ensure that pop-ups are visible as the document is scrolled: Ensure that the pop-up boxes float along with the page as the document is scrolled. This option is checked by default.

- **Making Comments**
  - Always use User Name of the log-in account for Author name: Use the user name of the log-in account as the author name while making comments. If a user does not set the user name for the Foxit log-in account, the prefix of the email address will be used as the author name instead.
  - Copy selected text into Highlight, Squiggly Underline, Underline, and Strikeout comment pop-ups: Check this option to copy and paste the selected text to comment pop-up notes automatically when you highlight, squiggly underline, underline, or strikeout annotation in PDF documents.

- **Pencil Setting**:
  - Enable to select pencil annotation when drawing: when the Pencil command is selected, the cursor changes into a pencil 📂. If this option is selected, the pencil changes into an arrow ➤ when you put it over a pencil annotation, and you can click the annotation to select it. If the option is not selected, the pencil will not change into an arrow.
  - Click to create annotations: if selected, you start to draw with the pencil when you click on the page, and in other words, only one click creates a pencil
annotation; if not selected, you do not start to draw until you click and drag the pencil.

C. Set Timeout: specifies a period of time within which all of the drawings/plans completed is one pencil annotation, after which what you draw is another pencil annotation.

- **Editing**: Sets the text direction for text comments, including left to right and right to left.

**ConnectedPDF**

- **Data Collection**

Allow usage data to be used in ConnectedPDF features: If this option is checked, the document usage data will be shared with Foxit servers when you are using ConnectedPDF features. This data will be used for development purposes and enhancing the user experience only. You can click [here](#) to learn about the privacy policy.

- **Use ConnectedPDF Format**

1. Automatically save PDF files in ConnectedPDF format (including those created from plugins) only when signed in: If this option is checked, Foxit PhantomPDF will automatically convert the files into ConnectedPDF format when creating or saving PDF files.

2. Automatically convert Office files to Connected when converting to PDF via Office add-in: If this option is checked, after converting the Office document to ConnectedPDF format, the Office document will become connected, and you will then be able to view the document homepage of the converted ConnectedPDF by clicking the **Document Homepage** button under the **FOXIT PDF** tab in Microsoft Office.

- **How to show web pages**

When using ConnectedPDF, Foxit PhantomPDF will display ConnectedPDF-related information (such as the Document Homepage and Personal Homepage) in web pages. You can choose to display the web pages in the tabs within the application, or in your default browser.

- **Default Permissions**

Document owners can restrict some features, including **Register New Version** and **Start Connected Review**, to better control documents by adding default permission settings. By default, **Started Connected Review** is restricted and other users who
want to start a Connected Review session will need to apply to the document owner.

**Create PDF**

Create PDF feature allows users to set the Page Size of PDF to be created.

A. **Fixed size:** Sets the size and direction of PDF through drop-down list.
B. **Custom:** Customizes the Page Size of PDF to be created. You can select the units first and then set the width and height of page as needed.
C. **Insert printed PDFs into previously generated documents, except those created by Foxit PhantomPDF:** Check it to append newly generated PDF files to a previously generated one which are created by **Print** command in other application using Foxit PhantomPDF Printer.
D. **Allow pop up alert when creating PDF:** Check this option to show message when converting PDFs in Microsoft Office by the **Foxit PDF** add-in.
E. **Create a Table of Contents in Cover Sheet when creating a PDF portfolio:** If this option is selected, a table of contents (TOC) will be automatically created and displayed following the cover sheet when you create a PDF portfolio.

**Documents**

The Document of the Preferences dialog provides several ways to browse PDF documents.

- **Open Settings**

  1. **Allow multiple instances:** Creates a new Foxit PhantomPDF window when double-clicked to open a PDF file.
  2. **Alert user when documents request Full Screen:** A message box will pop up to confirm the operation when opening a PDF which has been defined to be opened in full screen mode.
  3. **In Web Browser, display PDF in Read Mode by default:** Opens a PDF in Read Mode automatically in web browser.
  4. **In Foxit PhantomPDF, please choose the mode for Display PDF Mode:** Display the PDFs in Read Mode or Full Screen Mode or normal way automatically when opening PDFs with Foxit PhantomPDF.

- **Prompt Messages**
1. Display a prompt before closing all tabs: When you close a window with multiple tabs, Foxit PhantomPDF will ask you to confirm your choice. This prevents you from accidentally closing the whole window when you intend to close only the current tab.

2. Automatically save document as e-mail attachment: Automatically save the changes you made to a document and attach the modified document to your email system for sending.

3. Allow to choose the page range when attaching the tab to a new email message: If this option is selected, you can specify the page range you want to send when emailing the current PDF file to others.

- **PDF/A View mode**

  Sets to view documents in PDF/A view mode (i.e. read-only mode) to prevent modifications to the documents.

  1. Never: Never open documents in PDF/A view mode.
  2. Only for PDF/A documents: Switch to read-only mode automatically when a PDF/A document is opened.

- **Save Setting**

  Configure the time intervals for when the document will be automatically saved. Check **Save As optimizes for Fast Web View** to save documents as linearized PDFs that can be opened and viewed from web browsers even before the whole file is downloaded.

- **Preferred Save As Location**

  If you have configured a preferred save as location, when prompted to specify a location to save a document, the configured location will be automatically chosen in the **Save As** dialog box. To add a preferred save as location, click **Browse** to select the location, or input the location in the **Preferred Save As Location** field. If you need to remove the configured output location, just delete the directory path in the **Preferred Save As Location** field.

- **Redaction**

  After applying redaction, you can save the redacted file as a new file with the preconfigured name automatically. To configure the name, select **Adjust filename when saving applied redaction marks**, and input text in the **Prefix** and **Suffix** boxes to configure the name.
ECM Integration

SharePoint

Choose a method to open a document when you try to open a document on SharePoint. You can choose just to open the document, check it out when opening, or ask you when opening a document.

iManage 9

By default, a document is checked out when you open it from PhantomPDF. You can change the setting as needed. This setting only works for iManage Work 9.X.

Editing

- **Show changed text in**: Select a color the modified text will appear in when using the Edit Text command.
- **Alert when there's no editable text when using ‘Edit Text’ tool**: An alert will pop up notifying the user when there's no editable text while using the Edit Text command. By default, this option is selected.
- **Recognize Text**: Select this option to run OCR automatically when you use the Edit Text command in a scanned PDF.
- **Scanned Document Editing Settings**: Click it to open a dialog box to specify the OCR settings when recognizing text in a scanned PDF. You can select the language used to recognize text, and the two options:
  - **Use available system font**: Select this option to convert text in the scanned PDF to editable text using a substitution font available in your system that is similar to that of the original text. This option is selected by default.
  - **Make all the pages editable**: Select this option to recognize and convert text in all pages of the scanned PDF to editable text at once.

File Associations

This option allows you to set the default PDF Viewer.

- **Make Foxit PhantomPDF the default PDF viewer**:
1. Include browser when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in browser.
2. Include preview when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in preview.
3. Include thumbnail when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in thumbnail view.
4. Use Foxit PhantomPDF to open embedded Acrobat files and embedded Foxit Reader PDF files in Microsoft Office if Acrobat and Foxit Reader is not installed: check this option to set Foxit PhantomPDF as the default PDF viewer in Microsoft Office for opening embedded Acrobat files and Foxit Reader PDF files.

- **Make default PDF viewer**: click the button to set Foxit PhantomPDF as the default PDF viewer.
- **Restore file associations**: Restores settings in File Associations.

- **Always perform check when starting Foxit PhantomPDF**: If the default PDF viewer is not Foxit PhantomPDF, a message box will appear for the options to set it as your default viewer every time you run Foxit PhantomPDF.

**Forms**

The form tab enables you to set the preferences of the interactive form display.

- Automatically calculate field values: Specify whether to automatically perform all field calculations right after users input the entries. This option is checked by default. The setting for the option only applies to your current session, and it will revert to the default setting after the application is restarted.
- Manage Barcode Parameters: Lists all the decode conditions including the seven presets. You can create, edit, remove, import, and export custom decode conditions. See also [Decode Condition for Barcode Field](#).
- Show focus rectangle: With the option selected, a dotted rectangle appears around a form field if the form field currently has the focus. The option is selected by default.
- Show text field overflow indicator: Select this option to show the plus (+) sign if the text in a text field exceeds the bound of the field.
- Always hide document message bar: You can decide whether to show or hide the document message bar that appears below the toolbar area when opening an interactive PDF form.
- Highlight all fields: Checking this option allows you to highlight all form fields in the PDF document. You can click the color palette to change the highlight color for ordinary fields as well as required fields.
- Open Properties box after creating field: The properties box appears when
creating a form field.

- Run form recognition when creating PDF in Foxit PhantomPDF: Foxit PhantomPDF will run form recognition automatically when a PDF is created and opened in Foxit PhantomPDF.

- Auto-Complete: Auto-Complete includes three options that allow you to turn on or off the auto-complete feature. When enabled, Foxit PhantomPDF will store your entries and provide relevant suggestions as you fill in an interactive PDF form.
  - Off: Turn off the auto-complete feature. No suggestion will be provided when you fill in an interactive PDF form.
  - Basic: Enable auto-complete feature, and provide relevant suggestions when you enter a character in the interactive form field.
  - Advanced: Enable auto-complete feature, and automatically display a list of suggestions when you tab into a form field.
  - Remember numerical data: This option is available when you choose Basic or Advanced in the Auto-Complete drop-down list. If it is enabled, Foxit PhantomPDF will store numerical entries as well, otherwise, only text entries will be remembered.
  - Edit Entry list: Remove the saved entries from the auto-complete memory.

- Email: You can edit the default subject and contents which will be sent with the PDF form.

**Full Screen**

- Full Screen Navigation
  
  A. Select to show Scroll bar, Status bar, Tab bar (ribbon tabs), or Navigation Panels in Full Screen mode.
  B. Show Exit button – Check or uncheck this option to show or hide Exit button in Full Screen mode.
  C. One page at a time – Displays a single page at a time in Full Screen mode.
  D. Left click to go forward one page; right click to go back one page -- Lets you page through a PDF document by clicking the mouse. You can also page through a document by pressing Space, Shift + Space, or the arrow keys.
  E. Loop after last page – Reverts to the first page after the last, allowing you to page through a PDF document continuously.
  F. Advance every * seconds – Select this option and type a number to specify the frequency to automatically advance from page to page in Full Screen mode. With this setting enabled, you can still page through a document manually using your mouse or keyboard shortcuts.

- Full Screen Appearance
Background – Click the color pane and choose the color you like to be the background color in Full Screen mode.

- Full Screen Transitions

Foxit PhantomPDF supports page transition in Full Screen mode. There are 11 transition types: Split, Blinds, Box, Wipe, Dissolve, Glitter, Fly, Push, Cover, Uncover and Fade. Also, you could set the direction for the transition.

A. Ignore all transitions: Check to ignore page transition in Full Screen mode.
B. Default transition – Choose page transition for one document in the drop-down window.
C. Direction - Set the direction for the transition.
D. Navigation control direction: If selected, the direction of page transition will be based on your navigation direction in the document. For instance, if you turn to the next page, the page will transition from top to bottom; to the previous page, the page will transition from bottom to top. For some transitions without directions, the option is not available.

General

The General Preferences setting provides options on Basic Tools, Tab Bar, Status Bar, and Application Startup, etc.

- Basic Tools

A. Use single-key accelerators to access tools: Enable single-key accelerators to select some commands and perform some actions with single-key shortcuts. Please refer to Single-Key Accelerators for more details.
B. Use fixed resolution for snapshots - Sets the resolution used to copy the image captured with the Snapshot command. Automatically uses 72 pixels as default resolution.
C. Create links from URLs - Detects the text links in PDF documents and change the non-clickable links into clickable ones.
D. Minimize to system tray - You can save space on your task bar by minimizing Foxit PhantomPDF to the system tray. Check this selection to minimize Foxit PhantomPDF to the system tray when clicking the Minimize button.
E. Screen word-capturing - Check it to turn on this function that enables you to use your mouse to capture words inside a PDF file and have it translated if you are using dictionary software.
F. Make Hand Tool select text - Check it to enable the Hand command to become
text selection tool when moving it to the selectable content.

G. Make Hand Tool read articles – Check it to enable the navigation of an article with the help of the pointer. After you start the article viewing mode, with the Hand tool selected, the pointer will automatically change to a Hand tool with an arrow in it when over an article thread. Then the clicks with the pointer will follow the article thread, making the article navigation effective. See also View articles. The option is checked by default.

H. Make Hand Tool use mouse-wheel zooming: Select this option to zoom through documents while scrolling using the mouse wheel. This option is useful for users to browse large drawings.

- **Tab Bar**

  A. Max tab size: Allows you to specify a maximum tab size.

  B. Double-click to close Tab: Checking this option allows you to close tabs by double-clicking.

  C. Use recent order when switching tabs with Ctrl + Tab: In multi-tab reading, use Ctrl + Tab to switch through open tabs in recent order you viewed them. With the option unselected, using Ctrl + Tab to switch the tabs in the order they appear in the application window.

  D. Quickly switch between tabs by using mouse wheel: In multi-tab reading, switch through open tabs by scrolling the mouse in the tab bar. Scroll up to the previous tab, and down to the next tab.

- **Status Bar**

  A. Auto-hide Status Bar – Hides the status bar when opening a PDF, and enables it to float at the bottom of the page only when the cursor is moved to the bottom.

  B. Show scroll lock button: Displays the scroll lock icons in the status bar.

- **Notification Messages**

  Notification messages appear at the top right corner of the document pane when you work with interactive PDF forms, PDF/A files, or PDF files under shared review or email review, etc. You can configure the notification message settings as required:

  A. Show the message which affects the next step: Specify whether or not to show the procedure-related notification messages which usually contain action buttons for you to move forward to the next step. This option is checked by default. And it is recommended to keep the option checked so that you can work on documents during OCR, Shared Review, or Email Review normally.
B. Show the notification related message: Specify whether or not to show the notification related messages which inform you that a PDF file contains such elements as interactive form fields, 3D contents, etc.

C. Show PDF/A message again: Specify whether or not to show the message when opening a PDF/A document.

Tip: You can also change the notification message settings by clicking the gear icon on the message shown on the document pane. The changes of settings you made in the notification message will be applied accordingly in the Notification Message preferences.

User Experience Improvement

Turn on or off data collection. The collected data will be used to improve the user experience only.

- Features which Require Internet Connection

Specify whether to disable all features that require Internet connection. The setting will take effect after you restart the application.

- Application Startup

A. Show Start Page: Check this option to show the start page when running Foxit PhantomPDF.

B. Disable ConnectedPDF features: If checked, all of the ConnectedPDF features will be unavailable and all related commands will disappear on the ribbon.

C. Show floating promotion page: Check this option to show the latest promotion offering from Foxit if you have not activated Foxit PhantomPDF.

D. Launch in debug mode: This option is unchecked by default. Checking this option will enable Foxit PhantomPDF to be launched in debug mode and log file will be generated during your operation. Log file will be saved in “%userprofile%\AppData\Local\Foxit PhantomPDF\glog”. When you encounter issues while using Foxit PhantomPDF, you can send the log file to Foxit and the log file will be used for checking and solving your issues only.

History

- History
A. Restore last session when application starts: Determines whether documents start automatically with the last viewed session.

B. Restore last view settings when reopening: Determines whether documents open automatically with the last viewed settings.

C. Maximum number of documents in history list: Sets the maximum number of PDF documents you read in history list. The default is 50 PDF documents.

D. Maximum number of documents in Recent Documents list: Sets the maximum number of PDF documents you have viewed recently in the File page. The default setting is 10 PDF documents.

E. Show this number of unpinned Recent Folders: Set the number of unpinned recent folders listed in File > Open > Computer or SharePoint/OneDrive for Personal or Business/Google Drive/Dropbox. The default setting is 10 folders.

Note: Foxit PhantomPDF allows users to set “maximum number of documents in history list”, “maximum number of documents in Recent Documents list”, and the “number of unpinned Recent Folders” to 0.

Identity

Shows the identity of your application, including Login Name, Name, Title, Organization Name, Organization Unit, and Email Address. The identify information is quite useful in PDF reviews. It will help other review participants recognize your comments easily. The Login Name is set by default (using the username of the current operation system) and cannot be changed. Except for Login Name, you can change or complete your identity information in Identify Preferences.

Index

- Indexing

A. Enable embedded index: Select this option to enable the search with the embedded index in the document.

B. Allow indexing on separate drives: For a full-text index, you can select this option to allow defining a collection of PDF files you want to index from different drives. See also Create a full-text index.

C. Force ISO 9660 compatibility on folders: As you prepare documents for indexing, select it to use MS-DOS file-naming conventions for the folder names which must include 8 characters or fewer, not more than one dot, and no accented characters and non-English characters.

D. Enable logging: With this option selected, a log file is created automatically when you create a full-text index. See also Create a full-text index. The log file
describes the processing for each file indexed and includes the information about the indexed files and their directory paths, as well as any errors occurring during the index building.

E. Allow Index batch files (.bxml) to be run: Select it to allow running the batch file (.bxml) for the execution of the index updates scheduled in the scheduling application such as Task Scheduler. See also Schedule index updates.

● Index Defaults (applied to new indexes)

A. Do not include numbers: If you don't need to search for numbers in the document, select this option to exclude all numbers in the document text content from a PDF index, which can help make the search faster. If you change the current setting, the new setting only applies to new indexes created afterwards.

B. Do not warn for changed documents when searching: With this option unselected, if you search an index after any of the indexed documents have been changed, a message pops up when you click on the search results in the Search panel. If you change the current setting, the new setting only applies to new indexes created afterwards.

C. Custom Properties: This option allows you to include existing custom document properties in the index. Click Custom Properties, and a dialog box pops up. Then type the custom property, select a type (Date should be in yyyymmdd format in the property, e.g. 20190919), and click Add. Repeat the steps to add more custom properties. These properties will appear as search options in the additional criteria in the Search panel so that you can limit search by specifying the properties when you search the index.

D. XMP Fields: This option allows you to include custom XMP fields in the index. The custom XMP fields will also appear in the additional criteria in the Search panel when you search the index.

E. Stop Words: Allows you to specify words that you want to be excluded from the index search results. You can only add one stop word at a time. A stop word is case sensitive, and contains up to 128 characters. (Tip: In case users trying to search strings that contain the stop words, you are recommended to remind users of the stop words.)

F. Structure Tags: Use this option to make specific leaf-element tag nodes searchable in tagged documents when you search the index.

JavaScript

● Enable JavaScript Actions

See also Run Script Right Control.
• **Use external JavaScript editor**

By default, you can use the built-in JavaScript editor in PhantomPDF to edit your code. Foxit PhantomPDF supports calling an external JavaScript editor for coding including WebStorm, Sublime Text, and more.

To use an external JavaScript editor, select this option to add a JavaScript editor as the default JavaScript editor in PhantomPDF. Note that when editing JavaScript code in an external editor, Foxit PhantomPDF is inaccessible.

**Languages**

Foxit PhantomPDF provides the commonly used languages to meet customers’ needs to the upmost. Usually, Foxit PhantomPDF will automatically choose the language applied to your OS as its default during your installation. But changing languages after installation is supportable. To change the UI language of Foxit PhantomPDF, please go to **File > Preferences > Languages**, and select an option from the following:

• Use system local language—Makes the system locale language the UI language.
• Choose custom language—Selects your desired UI language from the list. (Tip: Foxit PhantomPDF has been localized in German, Spanish, French, Italian, Dutch, Polish, Portuguese, Russian, Danish, Finnish, Norwegian, and Swedish. You can click [here](#) to download the official multilingual version from Foxit website.)
• Choose languages provided by the community—Selects the language translated by volunteers on [Foxit multi-language translation system](#). A prompt message will pop up giving you a notice that you can get the UI language package on our website. In addition, you can also help us to do some translation so that we can localize Foxit PhantomPDF into your own language. To visit our multi-language translation system, please [click here](#).

**Default Reading Direction:** Choose a default reading direction when you’re reading a document in [Facing](#) or [Continuous Facing](#) mode. With **Left to Right** or **Right to Left** selected in **Default Reading Direction**, the reading direction is based on the setting here in Preferences; with **Infer direction from document** selected, then the binding direction in **File > Properties > Advanced** prevails.

**Hindi Digits:** Select this option to allow you to input numbers in Hindi using Add Text, Edit Text, and Reflow Editing features.
Layout Grid

You can also customize the grid appearance.

- **Width/Height between lines**: sets the spacing between grid lines.
- **Grid offset from left/top edge**: sets the origin of the grid.
- **Subdivisions**: sets the number of subdivisions within each grid square. Subdivision lines are lighter than grid lines.
- **Grid line color**: sets the color of grid lines.

Measuring

- **Measurement Units**

  Sets unit of page dimensions given in the status bar and print dialog.

- **Measurement Label**

  Choose to use the default measurement label or specify your own label.

- **Measurement Markup**

  **Use Default Leader for Distance Measurement**: Specify whether to show the line leader on both sides of the measurement points or not while measuring the distance.

- **Use Scale and Units From Document (When present)**

  Select the option to use the scale and units embedded in the document, if any. Deselect the option to specify the scale and units manually. The option is unselected by default.

Multimedia (Legacy)

Do not use QuickTime Player for multimedia items: This option is checked by default. As Apple does not provide security updates for its legacy QuickTime for Windows software any more, it is recommended to keep this option checked for security purpose. When checked, Foxit PhantomPDF will invoke a multimedia player other than QuickTime Player in your Windows system to run the multimedia inserted in PDF files, but will not play the video if it has been specified to use QuickTime as the required player.
Page Display

The Page Display panel of the Preferences dialog box includes the following options:

- **Default Layout and Zoom**

  A. **Navigation tab:** specifies the panel to be displayed in the opening view.
    
    a) **Use Initial View:** minimizes the Navigation panel and hides all panels.
    b) **Page Only:** displays Pages panel by default in opening view.
    c) **Bookmarks Panel and Page:** displays Bookmarks panel by default in opening view.
    d) **Pages Panel and Page:** displays Pages panel by default in opening view.
    e) **Attachments Panel and Page:** displays Attachments panel by default in opening view.
    f) **Layers Panel and Page:** displays Layers panel by default in opening view.

  B. **Default page layout:** You can view PDFs in following layouts:
    
    a) **Automatic:** With this option selected, in a multi-page document, displays pages in Continuous mode, or in Single mode if the page width is larger than the page height. If you change the page display in the View tab, the document will display in the page layout the last time you set.
    b) **Single Page** -- Displays one page at a time, with no portion on other pages visible.
    c) **Continuous** -- Displays pages in a continuous vertical column that is one page wide.
    d) **Facing** -- Displays each two-page spread with no portion of other pages visible.
    e) **Continuous Facing** -- Displays facing pages side by side in a continuous vertical column.

  See also “Changing the Page layout”.

  C. **Zoom:** Sets the magnification level for PDF documents when they are first opened. This value overrides document settings. The default uses the settings of the PDF document.

  D. **Custom facing:** The Default Facing for page layout is 2 pages. You can check the Custom Facing box and set the facing layout to your own preference.

  E. **Custom margin:** Sets the margins between different pages with Facing or Continuous Facing page layout. The default is a margin of 8 pixels.

- **Rendering**
A. Smooth text: Optimally adjusts text display that best suits your monitor.
B. Smooth line art: Removes the abrupt angles in lines to make them smoother.

● Page Content
A. Display transparency grid: Displays a grid behind transparent objects.
B. Use logical page numbers: Opens PDFs with the logical page numbers. This option is selected by default. It is used to match the position (or the physical page number) of the page in the PDF to the printed page number of the document. For instance, for a document with 100 pages, when you turn to the second page, the page number displayed in the status bar will be 2/100 (the physical page number) theoretically. However, if the PDF contains four-page front matter (such as the cover page and the copyright page) which is numbered in lowercase Roman numbers (i-iv) while the main content is numbered in Arabic numbers starting from 1 (1-96), PhantomPDF will display the logical page number, followed by the physical page number in parentheses, i.e. 2(6/100) when you turn to the sixth page of the PDF. With this option unselected, only the physical page number is displayed in the status bar, i.e. 6/100 for the sixth page. See also Change the format of page numbering on how to modify the format of page numbering for your PDFs.

● Forbid the change of the current Zoom factor during execution of ‘Go to Destination’ actions (these actions can be launched from bookmarks): Check to forbid user to change the current Zoom factor during execution of ‘Go to Destination’.

See also “Adjust Page Magnification”.

PDF Sign

Flatten the document when applying all signatures: Flattening the document when applying all signatures will make all the signatures, forms, and annotations become text, image, and shape objects of the PDF.

Print

● Printer
Print text as graphics (ignore font substitution) – Sets the text font as graphics and printout fonts are exactly the same as the text fonts. Automatically allows quick print where Printer Font is substituted.

Use GDI + Output for all types of printer: Specify whether to use GDI + output or
not for PS driver printers (excluding PCL driver printer) during printing.

- **Batch Print**
  A. Show print settings before printing document: Check it to show the Print dialog box before printing a document.
  B. Require confirmation when printing multiple documents: Check it to show the confirmation message before starting batch printing.

- **Prompt Foxit PhantomPDF when printing in silent print mode**

Specify whether to close Foxit PhantomPDF instance or not when finishing silent printing using the command line.

### Reading

- **Page vs Document**
  This preference determines how much of a document is delivered to a screen reader at a time. If a PDF isn't tagged, Foxit PhantomPDF may analyze the document and attempt to infer its structure, which can take a long time for a long document. You may want to set Foxit PhantomPDF to deliver only the currently visible page so that it analyzes only a small piece of the document at a time. This consideration will vary depending on the size and complexity of the document and on the features of the screen reader.

  A. Only read the currently visible pages - This option is usually best when using a screen magnifier. It improves performance by eliminating the need for the software to process parts of the document that aren't visible. When Foxit PhantomPDF sends only the currently visible pages of a PDF to the memory buffer, the assistive technology has access to those pages only. It cannot go to another page until the next page is visible and Foxit PhantomPDF has sent the page information to the memory buffer. Therefore, if this option is selected, you must use the navigation features of Foxit PhantomPDF, not those of the assistive technology, to navigate from page to page in the document. You should also set the Default Page Display option in preferences to Single Page if you choose to have PhantomPDF send only the currently visible pages to the assistive technology.

  B. Read the entire document - This option can be best if you use a screen reader that has its own navigation and search tools and that is more familiar to you than the commands in Foxit PhantomPDF.

  C. For large documents, only read the currently visible pages - This option is selected by default and is usually best if you use a screen reader with long or complex PDFs. It allows Foxit PhantomPDF to deliver an entire small
document but revert to page-by-page delivery for large documents.

- **Minimum number of pages in a large document**
  When the “For large documents, only read the currently visible pages” option is selected, it allows you to set this minimum value.

- **Enable assistive technology support**: Check this option to allow assistive technology products, such as screen readers, to provide information about the UI and document to end users.

- **Confirm before preparing untagged PDF for reading with assistive technology**: Select the option, and if any assistive technology is detected in your system, a dialog box pops up when you open an untagged PDF to ask you whether to set the reading order options for the PDF for reading with assistive technology.

- **Reading Order**
  Set reading order as appropriate for your assistive software and devices.

  A. **Infer reading order from document (recommended)**: Interpret the reading order of untagged documents by using an advanced method of structure-inference layout analysis.

  B. **Left-to-right, top-to-bottom reading order**: Deliver the text according to its placement on the page, reading from left to right and then top to bottom. This method is faster than “Infer reading order from document”. This method analyzes text only; form fields are ignored and tables aren't recognized as such.

  C. **Use reading order in raw print stream**: Deliver text in the order in which it was recorded in the print stream. This method is faster than “Infer reading order from document”. This method analyzes text only; form fields are ignored and tables aren't recognized as such.

- **Override the reading order in tagged documents**: Use the reading order specified in the Reading preferences instead of what the tag structure of the document specifies. Use this preference only when you encounter problems in poorly tagged PDFs.

**Reviewing**

- **Automatically check for new comments**: Set the time interval to automatically check for new comments during shared review. By default, Foxit PhantomPDF will check for new comments every five minutes during shared review.
**Shared Review Options**

A. Show welcome dialog when opening file: Check it to show the welcome dialog when opening a shared review. In the welcome dialog, you can view the general information for the shared review, including the initiator, deadline, review server and so on.

B. Show server connection warning when opening file: Check it to show the server connection warning when opening a shared review.

C. Remind before review expiration: If you check this option, a prompt message will pop up before the shared review expires.

**Review Options**

A. Show prompt messages for Shared Review: Determines whether to show prompt message for Shared Review when publishing comments in a shared review that contains several comments from other reviewers that have not yet been published to the command server. You can take ownership of these comments and publish them on behalf of the reviewers.

B. Show prompt messages for Email Review: Check this option to show prompt messages during email review.

**Send Messages**

A. Use Auto-Complete List to suggest names when typing in the “To” and “Cc” fields: Checking this option will enable Auto-Complete feature, which recognizes and suggests contacts based on the previously entered email addresses when you send back your comments during a shared review by email.

B. Empty auto-complete list: Click this option to remove all the email address entries from the Auto-Complete memory.

**Remove Custom Server Locations**

Select a custom server location (i.e. the shared network folder you specified) and click Remove Server Profile to remove it from Foxit PhantomPDF.

**RMS Settings (Business Edition Only)**

**RMS Settings**

*Save encrypted file as a copy named ‘filename(protected)’* – saves an encrypted PDF file automatically as a copy named “filename(protected).pdf” after adding AIP encryption to the file.
Encrypt metadata – encrypts the metadata when encrypting PDF documents.

- Open Settings

If an AIP-protected PDF contains a link that opens another AIP-protected PDF, you can select where to open the link.

Search

- Search

Ignore Asia character width: With this option selected, both half-width and full-width instances of the Asian language characters in the document will be found.

Ignore Diacritics and Accents: Ignore the diacritics and accents to find items with any variation of the alphabetical characters. For example, if you type “resume”, both “resume” and “résumé” will be found.

Always show more options in advanced search: Select this option to show the additional search criteria options available besides the basic options in the Search panel.

Show document title in search results: Check this option to display document titles in search results. However, if a document does not contain a title, its file path will be displayed in search results. If this option is unchecked, Foxit PhantomPDF will display file paths in search results.

Maximum number of documents returned in Results: Specify the number of documents to be displayed in the search results. You can input any integer between 1 and 10,000.

Range of words for Proximity searches: Specify the number of words between which the search terms occur from each other when executing proximity searches. It is set as 900 by default, and you can input any integer between 1 and 10,000.

- Fast Find: Enable fast find to make future searches faster by storing information about your frequently used PDF files.

  - Maximum Cache Size: Specify the maximum cache of search information for the Fast Find. The default value is 100 MB. You can input any integer between 5 and 100,000.
  - Purge Cache Contents: Delete all the caches of search information.
If fast find is enabled, the cache of search information will be generated when you perform a search. When the cache reaches the limit size you specified, the earlier cache contents will be deleted automatically. And if you execute searches in PDFs that include both index and fast find cache, index will be used as the priority for searching.

Security

- **Protected View**

  To protect your computer from files originating from the Internet or other potentially unsafe locations, turn on **Protected View** to open these files to reduce risks. In Protected View, files are read only and most editing actions are not allowed.

- **Privileged Locations**

  Some professional documents contain complex elements like interactive form fields, multimedia content, attachments, and layering. These elements may leave PDFs vulnerable to malicious actions and threaten data security. Foxit PhantomPDF enables users to specify privileged locations to selectively trust files, folders and hosts in order to bypass security restrictions.

More information about security settings, please refer to [Trust settings](#).

Signature

- **Default Signing Format**: Choose a default signing format based on PKCS#7 or CAdES standard. **PKCS #7 - Detached** is selected by default.

- **Appearance Styles**: Manage the signature appearance templates.

- **Signing & Verifications**

  A. **Sign the document immediately after the signature is placed**; Check this option to sign the document immediately when you place the signature on the document. By default, this option is checked. When it is unchecked, you will need to click **Sign Document** to apply the signature after placing it on the document. You can still modify the document before applying the signature.

  B. **Control how and when signatures are verified**; click **Change Settings** to choose options.

    - **Verify signatures when the document is opened**: If this option is checked, Foxit PhantomPDF will verify the signatures when the document is opened,
and will display the signature verification results in the Digital Signatures panel. By default, the option is checked.

- When document has valid but untrusted signatures, prompt to review and trust signers: With the option selected, if the signature (not including certified signatures) is verified as valid but is applied by an untrusted signer with a certificate that doesn't chain up to a trust anchor, a message box appears in the top-right corner of the application window to inform you the document includes signatures from signers that you haven't trusted yet. You can click Manage Trust in the message box to trust the signer. More information, please refer to Trusted Certificates. To make sure that the notification message is displayed successfully, please check the Show the message which affects the next step option in the preferences about Notification Messages.

- Verification Behavior

  - Require certificate revocation checking to succeed whenever possible during signature verification: Specify whether or not to check the revocation status of certificates while verifying signatures.
  - Use expired timestamps: Uses the secure time provided by the document timestamp or the timestamp embedded in the signature, even if the timestamp's certificate has expired. The option is selected by default. With the option unselected, the time provided by the expired timestamps will be discarded and the verification time will be the time at which signature was applied or the current time in the system based on your setting on Verification Time.
  - Ignore document validation information: Specify whether to ignore the related certificate revocation information embedded in the document when validating signatures.

- Verification Time

Verify Signature Using: You can check the digital signature for validity based on the time when the signature was created, the time provided by the timestamp embedded in the signature, or the current time in your system.

- Verification Information: Select an option to specify whether to add verification information to the signed PDF. Ask when verification information is too big is selected by default.

- Windows Integration: Specify whether to trust all root certificates in the Windows Certificate Store when validating signatures and certified
Documents. Checking these options may compromise security. Please make sure that you trust all the root certificates before enabling these features.

- **Saving Settings**
  
  Save signed file as a copy named ‘filename_signed.pdf’: Check this option to save the signed file as a copy named ‘filename_signed.pdf’ after applying the digital signature. When you sign multiple PDF files, you can also specify the file name in **Output Options**. The file name you specified in Output Options during signing will take precedence over the settings in Signature preferences.

**Speech**

- **Volume**: Sets the reading volume of Read out Loud.
- **Use default voice**: Check it to read content with default language, or you can select the required one from the combo box.
- **Use default speech attribute**: Check it to read with default pitch and rate, or you can uncheck it and then set pitch and rate in the combo box as needed.
- **Read comments**: Check it to enable the application to read out the comments when executing Read out Loud.
- **Read form fields**: Check it to enable the application to read out the form fields when executing Read out Loud. Please refer to **Read PDF Form Fields Out Loud** for details.

**Spelling**

- **Enable check spelling**: Check **Enable check spelling** to avoid spelling error.
- **Dictionaries for Spell Check**: Add, remove, or reorder the dictionaries for spell check.

**Tablet**

- **Enable pressure sensitive**: Enable pressure sensitive so that you can add free-form annotations with PSI in PDFs by supported touchscreen devices.

**Time Stamp Servers**

Configure the default Time Stamp Server to embed a trusted time stamp while signing.
Trust Manager

Please refer to Trust settings.

Updater

- Automatically install updates: For the plugin updates, PhantomPDF will download and install them automatically when a new version is available. When the installation is finished, a message appears in the system tray to tell you that the plugin has been updated. For the application updates, they will be downloaded automatically and then you will be prompted whether to start the installation.
- Automatically download updates, but let me choose when to install them (recommended): PhantomPDF will automatically download and display a message informing you of the upgrade and allow you to choose to upgrade to the new version. This option is checked by default.
- Do not download or install updates automatically: Never download or install updates automatically.
Chapter 3 – Read

After getting acquainted with the workspace and the basic tools, you can start the journey of PDF reading. You can open a PDF, reach a specific page easily, adjust the view of a document, read pure texts by the text viewer tool, view documents while listening to them, and more. Foxit PhantomPDF also provides a new feature to view PDF portfolios.

Open PDFs

Open PDFs in Foxit PhantomPDF

You can open PDFs within Foxit Phantom in many different ways. The easiest method is to drag and drop a PDF file into the Foxit PhantomPDF window. You can also use Foxit PhantomPDF’s Open command to open a recent document, local document, or PDFs in ECM systems (including eDOCS DM, SharePoint, Documentum, ndOffice, iManage Work, Enterprise Connect, Worldox, ShareFile, Epona DMSforLegal, and Alfresco) and cloud services (including OneDrive for Personal or Business, Google Drive, Dropbox, Box, and Egnyte).

To open PDFs with the Open command, do one of the following:

- Click the Open button 📄 on the Quick Access toolbar. In the Open dialog box, select the file name, and click Open. PDF documents are usually identified with a .pdf extension.
- (Optional) You are also allowed to preview non-PDF files on the above-mentioned cloud services in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.
- Click File > Open. To open a recent document or a document stored in the local drive, click Recent Documents/Computer. To open PDFs in ECM systems and cloud services like SharePoint, OpenText, ndOffice, iManage Work, Egnyte, OneDrive for Personal or Business, Google Drive, Dropbox, or Box (See also the ECM Integration in the Share PDFs chapter), please select Add a place, sign into your account, and then you can open your PDF file. The connected Cloud account will be listed in the Open history and the PDF file will be in the Recent Documents list, which will help you open files quickly in the future. To remove an account, just click the Delete icon  that appears when you place your cursor over the account name.

Tips:
Chapter 3: Read

1. In Recent Documents tab, Computer tab, or cloud service tab (like Google Drive tab), you can right-click any file or folder, and then choose the corresponding option from the context menu to open the file/folder, pin the file/folder to list, remove the file/folder from the list, or copy the path of the file/folder to clipboard. To pin or unpin a file or folder, you can also hover the cursor over a file or folder and click the Pin icon 🖼 or Unpin icon 🖼 alternatively.

2. To customize the number of documents or folders in the recently used list, please navigate to File > Preferences > History.

Open PDFs from Desktop or within Other Applications

If you set Foxit PhantomPDF as your default viewer for PDF files, you are able to launch and open PDF files in the following applications:

- Email Application: in your email applications, you can double-click the attachment icon to open the document.
- Web Application: you can open a PDF document by clicking on the PDF file link in your web browser. In a web browser, Foxit PhantomPDF will display PDFs in Read Mode by default, hiding the toolbars to maximize the document pane. You can right-click the document pane and uncheck Read Mode to show the toolbars and work on PDFs as desired. Also, you can view the PDF content embedded in the HTML. For security purposes, if you try to open an AIP-protected PDF file in your web browser, the file will be opened in the stand-alone Foxit PhantomPDF (desktop application) outside the browser.
- File System: double-click the PDF file icon in your file system.

Open a secured PDF document

If you receive a PDF that is protected by security features, you may need a password to open the document. Some protected documents have other restrictions that prevent you from printing, editing, copying, etc.

- When opening a protected PDF, you will be prompted to enter the password.
- When trying to copy or edit a secured PDF, you will be notified that you are prohibited to do it without the owner’s permission.
- If you open a PDF that is encrypted by AIP feature of PhantomPDF, please refer to AIP Protect.

Save PDFs

After modifying your PDF, you can save the changes to the original PDF or save as a
new copy of a PDF. You can also save PDFs as HTML, RTF, TXT and Microsoft Office files. Foxit PhantomPDF enables you to save your PDFs in ECM systems (including eDOCS DM, SharePoint, Documentum, ndOffice, iManage Work, Enterprise Connect, Worldox, ShareFile, Epona DMSforLegal, and Alfresco) and cloud services (including OneDrive for Personal or Business, Google Drive, Dropbox, Box, and Egnyte), as well as to local drives. When saving or saving as PDFs, Foxit PhantomPDF will optimize PDFs by removing redundant data including deleted pages, objects, and annotations.

Tip: By default, Foxit PhantomPDF saves the changes to a file every 5 minutes automatically in case of system crash or power failure. If the application closes abnormally before you can save changes to a file, PhantomPDF opens the recovery file automatically the next time you open it. The recovery file contains your changes up until the last time PhantomPDF saved the document. You can change the time interval settings in Preferences > Documents > Save Setting > Automatically save file every x minutes.

Save a copy of a PDF

1. Select File > Save As.
2. In the Save As dialog box, enter the filename and location, and click Save.

Save a PDF as a HTML, RTF, TXT, or Microsoft Office File

1. Select File > Save As.
2. Specify the filename and location in the Save As dialog box.
3. Choose a format from the Save as type list and click Save.

Save PDFs in ECM systems or cloud services

Click File > Save As > Add a place > eDOCS DM/ Documentum/ ndOffice/ iManage Work/ SharePoint/ Egnyte/ OneDrive for Personal or Business/ Google Drive/ Dropbox/ Box/ Enterprise Connect/ Worldox/ ShareFile/ DMSforLegal/ Alfresco then sign in your account and choose a folder to save to. (See also the ECM Integration in the Share PDFs chapter) The account will be listed in the Save-as history for your convenience. Click the Delete icon near the account name to remove the account from the list.

Tip:
1. You can also pin the frequently-used folder under local drives, OneDrive for Personal or Business, Google Drive, SharePoint, Dropbox, or Box to the Recent Folders list or unpin it, which allows you to save your documents with just one click.
2. To customize the number of documents or folders in the recently used list, please navigate to File > Preferences > History.
Close a PDF

Close the current PDF file by doing any of the following:

- Click the file's Close button in the tab bar.
- Double-click the tab. (Tip: You can also disable this option in File > Preferences > General.)
- Click File > Close.
- Click the Close button on the Foxit PhantomPDF application window if you are in single document interface mode.

To close all PDF files in multi-tab browsing, click the Close button on the Foxit PhantomPDF application window.

Tip: Right-click a file tab in the tab bar, and choose Open Containing Folder to open the directory of the file, or choose Copy Path to Clipboard to copy the file path to the clipboard.

Export PDFs

Export PDF to Word, PowerPoint, RTF, or plain text files

1. Click File > Export or Save As. Or navigate to the Convert tab.
2. Select the format you want to convert the PDF to.
3. In the pop-up dialog box, specify the file name and location for the output file. Optionally, you can click Save to ECM to save the output file to ECM systems and cloud services including SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM. Select View Result to open the output file after the conversion process is completed.
4. (Optional) You can select more options from “Settings” in the Save As dialog box before saving the file. Take exporting PDF to Word files for instance. In the Save as docx setting dialog box, select the exporting options:

   - **Page Range**: chooses the page range you want to export.
   - **Content Settings**: specifies whether to include the comments and images in the output. This option is not available for exporting to plain text files or if you choose Image-based document in Export Engine Settings.
   - **Layout Settings**: which is only available when you export PDF to Word and RTF files, specify whether to retain the text flow or page layout in the output. This option is not available for exporting to plain text files.
Export Engine Settings: If the PDF is primarily images and non-text objects, the Image-based document option is recommended. If you choose Image-based document, click Set Language to select the language for OCR.

Restore Default: reverts to the original default settings.

5. Click Save.

Note: To convert a PDF to Word, you can directly right-click the file and choose Convert to Microsoft Office with Foxit PhantomPDF.

Export PDF to spreadsheets

1. Click File > Export, or navigate to the Convert tab.
2. Choose To MS Office > (To) Excel or XML Spreadsheet 2003. (Tip: You can also export it through File > Save As.)
3. In the pop-up dialog box, specify the file name and location for the output file. (Tip: When exporting PDF to Excel files, you can click Save to ECM to save the output file to ECM systems and cloud services including SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.) Select View Result to open the output file after the conversion process is completed.
4. (Optional) You can select more options from “Settings” in the Save As dialog box before saving the file. Take exporting PDF to Excel files for instance. In the Save as xlsx setting dialog box, select options as needed.

Page Range: chooses the page range you want to export.

Numeric Settings: specifies the decimal and thousands separators, so that Foxit PhantomPDF will recognize the numeric data based on your setting. The settings are not available if you choose Image-based document in Export Engine Settings.

Auto detect decimal and thousands separators – detects the numeric settings based on the document.

Treat the following as decimal and thousands separators – selects this option and select symbols for the decimal and thousands separators.

Excel Workbook Settings: chooses an option to create worksheets. The settings are not available if you choose Image-based document in Export Engine Settings.

Create single Worksheet for the Document – The PDF will be exported to a
single Worksheet.

Create Worksheet for each Table – Each table in the PDF will be exported to a separate Worksheet. (Note: A table in a PDF is not always displayed in Table form with columns and rows. The application sometimes considers the head and tail of the page as virtual tables, so there is also a situation where non-Table content is displayed separately on a Worksheet).

Create Worksheet for each Page – Each PDF page is exported to a single Worksheet.

*Note:* The exported Worksheets are automatically named as “Table1”, “Table2”, “Table3” ...

**Export Engine Settings:** If the PDF is primarily images and non-text objects, the Image-based document option is recommended. If you choose Image-based document, click Set Language to select the language for OCR.

**Restore Default:** reverts to the original default settings.

5. Click Save, and the Excel file will be created and opened in Microsoft Office.

**Export PDF to XPS files**

1. Click File > Export, or navigate to the Convert tab.
2. Choose To MS Office > (To) XPS. (Tip: You can also export it through File > Save As.)
3. In the pop-up dialog box, specify the file name and location for the output file. Select View Result to open the output file after the conversion process is completed.
4. (Optional) You can select more options from “Settings” in the Save As dialog box before saving the file. In the Save As XPS Settings dialog box, select options as needed.

**Page Range:** chooses the page range you want to export.

**File Format:** select the Use .oxps format option to convert the PDF to an .oxps file. This option is available for Windows 8 and higher versions, and is unselected by default.

**Restore Default:** reverts to the original default settings.

5. Click Save, and the XPS file will be created and opened in XPS Viewer.
Export PDF to HTML files

1. Click File > Export, or navigate to the Convert tab.
2. Choose To HTML. *(Tip: You can also export it through File > Save As.)*
3. In the pop-up dialog box, specify the file name and location. Select View Result to open the output file after the conversion process is completed.
4. (Optional) You can select more options from “Settings” in the Save As dialog box before saving the file. In the Save as htm setting dialog box, select options as needed.

   **Page Range:** chooses the page range you want to export.

   **Content Setting:** selects Include Images to export images in the PDF. The setting is not available if you choose Image-based document in Export Engine Settings.

   **File and Navigation Pane Settings:** chooses Single HTML Page to export the PDF to a single HTML file, and you can add headings and bookmarks in the navigation pane of the output HTML file; or choose Multiple HTML Pages to split the PDF by its headings or bookmarks into several HTML files. The settings are not available if you choose Image-based document in Export Engine Settings.

   **Export Engine Settings:** If the PDF is primarily images and non-text objects, the Image-based document option is recommended. If you choose Image-based document, click Setting Language to select the language for OCR.

   **Restore Default:** reverts to the original default settings.

5. Click Save, and the HTML file will be created and opened in your default web browser.

Export PDF to accessible text

If the document is an accessible PDF, you can save it as accessible text which can contain assistive information (such as alternate text descriptions) for images or multimedia objects in the PDF. Accessible text is often used for a braille printer by which accessible text can be imported and printed out as a form that vision-impaired people can use.

To export PDF to accessible text,

1. Click File > Export, or navigate to the Convert tab.
2. Choose To Other > (To) Accessible Text. *(Tip: You can also export it through File >
Save As.)

3. In the pop-up dialog box, specify the file name and location for the output file. (Tip: You can click Save to ECM to save the output file to ECM systems and cloud services including SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.) Select View Result to open the output file after the conversion process is completed.

4. Click Save.

Export a PDF as an image

1. Click File > Export, or navigate to the Convert tab.
2. Choose To Image and select a file type of images. (Tip: You can also export it through File > Save As.)
3. Specify the page range (all pages, current page, a range of pages), and click OK.
4. You can set the quality, color space, and resolution from “Settings” in the Save As dialog box before you save the file. Click OK to continue.
5. Specify the location, and click Save.

Export PDF to XML 1.0 files

1. Click File > Export, or navigate to the Convert tab.
2. Choose To Other > (To) XML 1.0. (Tip: You can also export it through File > Save As.)
3. In the pop-up dialog box, specify the file name and location. Select View Result to open the output file after the conversion process is completed.
4. Click Save.

Export all images in the PDFs

With one click of “Export All Images”, Foxit PhantomPDF enables you to export all images in your document to separate image files. Please click Convert > Export All Images, choose an image format, and configure the settings before exporting via the Export to Images dialog box.

See also the tutorial on Export PDF to Word & Other Formats.

Export Selected Area to Other Formats

You can also select an area with the Select Text and Image command in PDF and export the content in the area to formats including Microsoft Word, Excel, and PowerPoint.
Chapter 3: Read

1. Choose the **Select Text and Image** command.
2. Click and drag an area in your PDF you want export. Then right-click the selected area and choose **Export Selection As**....
3. In the pop-up **Save As** dialog box, choose the file format you want to export to, and specify the filename and location. *(Tip: You can click **Save to ECM** to save the output file to ECM systems and cloud services including SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.)* Select **View Result** to open the output file after the conversion process is completed.
4. (Optional) You can select more options from “Settings” in the **Save As** dialog box before saving the file. For details about the options, please refer to the corresponding instructions in the **Export PDFs** section according to the file format you want to export to.
5. Click **Save**.

**View PDFs**

Foxit PhantomPDF enables you to retrieve recently opened documents, as well as read PDF documents in different view settings: multi-tab reading and single document reading.

**Multi-tab Reading & Single Document Reading**

**Multi-tab Reading**

The multi-tab browsing feature enables you to open multiple files in a single instance. Newly opened PDFs will be displayed in tabs by default.

In multi-tab reading mode, you can drag and drop a file tab outside of the existing window to create a new instance and view the PDF file in that individual window. To recombine the file tab to the main interface, click on the file tab and then drag and drop it in reverse to the main interface.

To switch between open tabs in multi-tab reading, do one of the following:

- Switch between open tabs in the most recently viewed order by using **Ctrl + Tab**. Before this, make sure you have selected the option **Use recent order when switching tabs with Ctrl + Tab** in **File > Preferences > General**.
- Scroll the mouse in the tab bar up to the previous tab and down to the next tab. Before this, make sure you have selected the option **Quickly switch between tabs by using mouse wheel** in **File > Preferences > General**.
- By default, use **Ctrl + Shift + Page Up** to switch to the previous tab and **Ctrl + Shift + Page Down** to the next tab. You can also change the shortcut keys. See
Single Document Reading

Create a new window when you double-click to open a new PDF file.

- To enable single document interface mode, go to File > Preferences > Documents > Open Setting > check Allow Multiple Instances.

Page through a document

Open a PDF document with Foxit PhantomPDF, and you can then start viewing PDFs by scrolling throughout the entire document with your mouse vertically, or by holding Shift to scroll horizontally. You can also page through a document by the following methods.

Scroll through Documents

Do either of the following:

- **Using mouse actions or keystrokes**
  - To navigate around the documents vertically, scroll the mouse wheel or press the Down or Up Arrows on the keyboard.
  - To navigate around the document horizontally, press Shift and scroll the mouse wheel.

While scrolling in a document, you can lock the scroll direction to prevent the document from being scrolled out of place, especially when the document is zoomed in and scrolled within tablets. The steps are as follows:

  - Choose File > Preferences > General, and check the Show scroll lock button option under the Status Bar to enable scroll lock. Once enabled, the scroll lock icons will be displayed in the Status Bar.
  
  - Click [ ] on the Status Bar to lock the scroll horizontally.
  
  - Click [ ] on the Status Bar to lock the scroll vertically.
  
  - Click both [ ] and [ ] on the Status Bar to freeze the screen so that you can read the current view of the document.
Scroll automatically

Automatic scrolling allows users to view documents without using mouse actions or keystrokes. Foxit PhantomPDF also enables you to change the scrolling speed with ease.

A. Choose View > AutoScroll.

B. Do one of the following:

- To increase or decrease the scrolling speed, press the Up Arrow or Down Arrow key, depending on the direction of scrolling. To change the scrolling speed to a specific speed, press a number key (9 for the fastest, 0 for the slowest).
- To reverse the direction of scrolling, press the minus sign (-) key.
- To jump to the next or previous page, press the Right Arrow key or Left Arrow key respectively.
- To stop automatic scrolling and go back to Hand Command mode, click AutoScroll again or press the Esc key.
- To pause automatic scrolling, press the Space key.

Tip: To perform auto-scrolling, you can also click the Hand Command, hold the middle mouse button/wheel mouse button down, and then move the mouse to scroll the pages. You can press the middle mouse button/wheel mouse button again to exit AutoScroll mode.

Go to Specified Page

Click the First Page, Last Page, Previous Page and Next Page buttons in the Go To group under the View tab, which is also located in the status bar. You can also input the page number to go to that specific page. Previous View lets you return to the previous viewed instance and Next View goes to the next viewed instance.

Note: If your PDF contains formatted page numbers, and the Use logical page numbers option is enabled in File > Preferences > Page Display, you should input the numbers that match the numbering on the pages rather than the physical page numbers. For instance, if you want to view the second page of your document which is numbered ii, you should enter ii to go to the page. See also the preference setting on logical page numbers.
Read with Bookmark

To jump to a topic using bookmarks, click the **Bookmark** button on the left Navigation pane to open the **Bookmarks** panel. And then click the bookmark or right-click the bookmark and choose "Go to Bookmark".

If you want to hide the **Bookmarks** panel after you click a bookmark, click the **Options** menu at the top of the **Bookmarks** panel and select **Hide After Use**, which makes the document area wider and improves the reading experience. To keep showing the **Bookmarks** panel after you click a bookmark, deselect **Hide After Use**.

**Tips:**

1. **If a bookmark is too long to be displayed in the Bookmarks panel, you can right click the bookmark (or click the Options menu at the top of the Bookmarks panel) and select **Wrap Long Bookmarks** to wrap it to multiple lines for a better view. To unwrap, deselect **Wrap Long Bookmarks**.

2. **Clicking the Find Current Bookmark icon at the top of the Bookmarks panel highlights the bookmark corresponding to the content in the current document view, which can be helpful to find a bookmark as well as show you where you are.**

Read with Page Thumbnail

To jump to a page with page thumbnails, click the **Page Thumbnails** button on the left Navigation pane and click its thumbnail. To move to another location on the current page, drag and move the red box in the thumbnail. More information about page thumbnails, please refer to **Page thumbnails**.

Read with Article Thread

Article threads are defined for navigating articles in PDF files as skimming through a traditional print newspaper or magazine, allowing you to focus on a specific article and ignore the rest. To navigate an article in the document, open the **Articles** panel, and double-click the article you want to view. More information about viewing articles, please refer to **View articles** in the Articles section.
View PDF Portfolios

PDF portfolios are a combination of folders and files with different formats such as Word Office files, text documents and Excel files. Foxit PhantomPDF provides viewing and printing PDF portfolios, as well as searching keywords in PDFs in the portfolio.

A Sample PDF Portfolio

- Open a PDF portfolio in Foxit PhantomPDF by right-clicking it and choosing “Open with Foxit PhantomPDF”.
- You can view the coversheet, details and layout of the portfolio. To open and read the files in the portfolio, please do any of the following:
  - Double-click a file.
  - Select a file and click button in the upper right corner of the document area.
  - Right-click a file and choose Open File in Native Application.
- Click Portfolio > Preview Pane > Right/Bottom, and the document area will be divided into two parts: the original area that displays the portfolio content, and a preview pane which allows you to preview the corresponding content when you click and choose a file.
- Click Portfolio > Default View > Retain Original/Layout/Details/Cover Sheet to set the default view for PDF portfolios in PhantomPDF.
- Right-click a document in the portfolio and choose Show Information or click the button in the upper right corner of the document area to view the properties of the document.
- Search in portfolio by typing keywords in Search box or using shortcut keys.
Adjust Page View

Foxit PhantomPDF provides multiple commands that help you adjust the view of your PDF documents, such as the page magnification and the display of pages.

Adjust Page Magnification

Do one of the following procedures:

1. Click the **Zoom In** command or **Zoom Out** command in the **Home** tab.
2. Right-click the document pane and select **Zoom In** or **Zoom Out**.
3. Select or input a magnification percentage in the **Zoom To Area** on the same tab.
4. Adjust a magnification percentage in the Magnification Percentage Area on the status bar.
5. Using the **Marquee** command
   - Choose the **Marquee** command in the **View** tab.
   - The cursor changes into , drag a rectangle on the page or just click on the page to increase the magnification by one preset level, centering on the point where you clicked.
   - Choose the **Marquee** command, the cursor changes to as Ctrl-click on the page. Drag a rectangle on the page or just click on the page to decrease the magnification
6. Using the Loupe command
   - Choose the Loupe command in the **View** tab.
   - Move the Loupe command to the places you want to view, you will see the amplificatory or decreased objects in the Loupe Tool dialog box.
   - (Optional) Select the Lock option in the Loupe Tool dialog box. Click the area of the document you want to view in closer detail. A red rectangle appears in the document, corresponding to the area shown in the Loupe Tool window. You can drag or resize the rectangle to change the Loupe command view.
   - To change the scale ratio of the Loupe Tool, you can either enter a value in the zoom text box, or drag the slider in the Loupe Tool dialog box.
7. Using the **Magnifier** command

You can easily magnify areas of the PDF files as you work on Foxit PhantomPDF with this free command. It is especially useful for visually impaired people with some functional vision.

- Choose the **Magnifier** command in the **View** tab.
- Move the Magnifier to the places you want to view.
- To switch between Magnifier and Fisheye Magnifier, press the left mouse button.
- To change the size of magnifier window, press the right mouse button.
- To turn off the Magnifier, choose any other commands.

**Resizing a Page to Fit the Window**

There are four types for you to choose:

- To resize the page to fit entirely in the document pane, click the **Fit Page** button in the **Home** tab, or right-click the Document Pane and choose Fit Page.
- To resize the page to fit the width of the window, click the **Fit Width** button in the **Home** tab, or right-click the Document Pane and choose **Fit Width**. Part of the page may be out of view.
- To resize the page to its actual size, click the **Actual Size** button in the **Home** tab, or right-click the Document Pane and choose **Actual Size**.

- To resize the page to fit the visible width of the window, removing the margins, click the **Fit Visible** button in the **Home** tab.

**Adjust the Page Display**

To change the Page Orientation, do one of the following:
Click the **Rotate View** button in the **View** tab.

Click the **Rotate Left** button or the **Rotate Right** button in the **Home** tab.

Right-click the document pane and choose the **Rotate Right** command.

**Note:** You can change the page view in 90-degree increments, but the change only affects screen display instead of its actual orientation. You cannot save the changes in page view.

To change the page layout, Foxit PhantomPDF provides the following page layouts:

- **Single Page** - Displays one page in the document pane at a time.
- **Continuous** - Arranges the pages in the document pane in a continuous vertical column.
- **Facing** - Arranges the pages side by side, displaying only two pages at a time.
- **Continuous Facing** - Arranges the pages side by side in a continuous vertical column.
- **Show Cover Page During Facing** - If a document has more than two pages, the first page can be displayed alone on the right side of the document pane in **Facing** and **Continuous Facing** views.
- **Split** - View a PDF with the document pane divided into two panes (Vertically/ Horizontally Split command) or four panes (Spreadsheet Split command).

**Note:** To revert back to single-pane view, choose **View >** deselect **Vertically/ Horizontally/ Spreadsheet Split**.

With the **Vertically/Horizontally Split** view, you can scroll, change the magnification level, or turn to different pages in the active pane, as it will not change the other panes (above or below it).

The **Spreadsheet Split** view is useful if you want to keep column headings and row labels visible while scrolling through a large spreadsheet or table. In this mode, changing the magnification in one pane changes the magnification in all panes. Also, scrolling is coordinated between the panes. Scrolling a pane horizontally scrolls the pane above or below it; scrolling vertically also scrolls the pane to the left or right of that pane.
View Mode

Read Mode

User interface settings, such as the navigation pane, toolbar, and status bar, will be hidden when a PDF is displayed in Read Mode. The document pane is enlarged, reducing wasted reading space while leaving the ribbon tabs available for necessary operations.

To view a document in Read Mode, please choose one of the following:

- Click the Read Mode button in View > Document Views.
- Press the shortcut key “Ctrl + H” on the keyboard.
- Right-click the document pane and select Read Mode.

In Read Mode, a basic toolbar will float when the cursor is put at the bottom of the screen or when you scroll through the document by dragging the slider. This offers basic commands, such as save, print, zoom in/out, etc.

If you open multiple PDFs, please press “Ctrl + Tab” on the keyboard to switch through them in Read Mode.

To exit the Read Mode, please do any of the following:

- Click the Read Mode button in the View tab.
- Press the shortcut key “Ctrl + H” on the keyboard.
- Click the Read Mode button on the floating basic toolbar at the bottom of the screen.

Full Screen Mode

In Full Screen mode, Foxit PhantomPDF Document Pane fills the entire screen, with the toolbar, Status bar, and Bookmarks pane hidden behind. The mouse pointer remains active in Full Screen mode so that you can click links.

1. To set Full Screen preferences, please go to File > Preferences > Full Screen.
2. To enter Full Screen mode, please do one of the following:

    - Right-click the Document Pane and select Full Screen.
• Press the shortcut key **F11**.

3. To adjust the view in Full Screen mode, right-click the document and work with the Context Menu.

   **Note:** This feature will not be available unless you clear **Left click to go forward one page; right click to go back one page** checkbox in the Preference > Full Screen.

4. To exit Full Screen mode:
   • Press **Esc** key.
   • Press the shortcut key **F11**.

5. Page Transition in Full Screen

Foxit PhantomPDF supports page transition to turn pages in Full Screen mode. It helps you to turn pages as the transition feature in Microsoft Power Point. There are 10 transition types: Split, Blinds, Box, Wipe, Dissolve, Glitter, Push, Cover, Uncover and Fade. Also, you could set the direction, speed and page range for the transition.

To edit page transition, click the **Page Transitions** in the View tab, or right-click any page thumbnail in the Pages panel.

   **Note:**
   - This change only works for the current PDF.
   - The pages will be turned in the same way the next time you open and view the document in full screen mode.
   - If you want to set page transition to all PDF documents opened by Foxit PhantomPDF, please choose **File > Preferences > Full Screen**.

**Reverse View**

To read documents in a backward order, please do one of the following:

• Choose **View > Reverse View**.
• Right-click on the document pane and choose **Reverse View**.
Text Viewer

With Foxit Text Viewer, you can work on all PDF documents in pure text view mode. It allows you to easily reuse the texts scattered among images and tables, and acts like Notepad. Also, you can adjust some settings to meet your needs.

To Enter Text View mode, do one of the following:

- Choose View > Text Viewer.
- Press the shortcut key Ctrl + 6.

✦ Customizing Text Viewer

As soon as Text Viewer is activated, you can use the Font Setting commands to customize your own work area. Right-click the text area to select Font Setting.

1. To change text font when reading with Text Viewer

   - Right-click and choose Font Setting > Font....
   - Choose Font name, Font Style, Font Size, Effects, Color and Script from respective fields in Font dialog box. The suggested font for best screen display is Courier New.

2. Toggle between regular style and Bold style, choose Font Setting > Bold.

3. Toggle between regular style and Italic style, choose Font Setting > Italic.

4. Change the text color and the background color

   - Right-click and choose Font Setting > Color....
   - Text Viewer Colors dialog box pops up.
   - Drag respective sliders or type the value to change the Foreground (Font) Color and Background (page) Color. You can preview the changes in the box with a word “Sample”.
   - Click OK to complete the procedure, or click Cancel to abandon the changes.

5. Change Text Viewer settings

   - Right click the text area > select Setting...
   - The text Viewer Settings dialog box pops up.
   - Below are the text viewer settings:

     A. Set page width at three different levels: Current page width, Current
document width and System default width.
B. Minimal width – the valid value for this field is 0-1024. It is set to 78 by default.
C. Keep Column – for PDF tables or text columns, you can check Keep Column to retain appropriate column in text viewer mode. It is checked by default.
D. Auto Width – for PDF tables or text columns, you can check Auto Width to keep proper width between texts automatically. It is checked by default.
E. Auto Rotate – you can check Auto Rotate to ensure consistent orientation with that of the printer. It is checked by default.

*Note:* The Zoom To box in the Home tab is unavailable in Text Viewer mode.

✧ Finding text in Text Viewer mode

To find text you are looking for, please refer to Find Text.

✧ Copying and pasting text in Text Viewer mode

1. Select text
   - Select a word: Double-click the word you want to select.
   - Select a line of text: Click and drag the cursor on the line of text you want to select.
   - Select all the text: Press Ctrl + A or right-click the Document Pane > choose Select All.

2. Copying text, do one of the following:
   - Right-click the selected text > choose Copy.
   - Select the text and then press shortcut key Ctrl + C.

3. Pasting text
   To paste the selected text on Clipboard to another application, please follow the paste command of the specific application.

**Night Mode**

The Night Mode in Foxit PhantomPDF allows you to invert black and white to reduce eye strain in low light conditions. In the Document Views group under the View tab, click Night Mode to enable or disable the Night Mode.
Read Out Loud

What’s Read Out Loud?

Read Out Loud is a Text-to-Speech (TTS) tool. It reads the text in a PDF aloud, including the text in comments and alternate text descriptions for images, tables, and fillable fields. Text is read based on the order of the page content. With this feature, you can obtain information without viewing the pages, helping to effectively relief eyestrain. It also enables you to view other materials while listening to the content.

Read Out Loud uses the available voices installed on your system. If you have SAPI 5 voices installed from text-to-speech or language applications, you can choose them to read your PDFs.

*Note: Read Out Loud isn't a screen reader, it may not be available in some operating systems.*

Set Reading and Speech Preferences

Please go to **File > Preferences > Reading** or **Speech**. For more information, please refer to [Reading preferences](#) and [Speech preferences](#).

Activate or deactivate Read Out Loud

You need to activate Read Out Loud before using it.

- To activate Read Out Loud: select **View > Read > Activate Read**.
- To deactivate Read Out Loud: select **View > Read > Deactivate Read**.

Tip: You can press the shortcut key Ctrl + Shift + Y to activate or deactivate Read Out Loud, based on the current status of the feature. After activating Read Out Loud, you can **read a PDF file** and **PDF form field** out Loud.

Read a PDF Out Loud

- Navigate to the page that you want to read out.
- Choose **View > Read > Read Current Page** or **Read from Current Page**.

*Tips:*
Chapter 3: Read

1. If you need to read the text in the comments while reading a PDF out loud, please make sure you have checked **Read comments** option in the *Speech preferences*.

2. When you try to read an image-based PDF document out loud, Foxit PhantomPDF will prompt you to run text recognition to make it searchable or editable. You can choose **Yes** and follow the steps in *OCR PDFs* to recognize text.

**Read PDF Form Fields Out Loud**

- Go to **File > Preferences > Speech**, and check **Read form fields** option.
- In the PDF form, press **Tab** to select the first form field that you want to read out loud, and then press **Tab** to move to the next form field. Foxit PhantomPDF will read out the form field as well as the state of selected check boxes and radio buttons.

**Control Reading**

While reading a PDF file or form field, you can interrupt the reading and adjust reading volume and speed as needed.

- To adjust the reading speed: choose **View > Rate** > drag the slider.
- To adjust the reading volume: choose **View > Volume** > drag the slider.
- To pause reading: choose **View > Pause**.
- To stop reading: choose **View > Read > Stop**.

**Rulers, Guides, Grids & Line Weights**

**Using Rulers & Guides**

Foxit PhantomPDF provides horizontal and vertical ruler guides to help you align and position text, graphics or other objects on the page. They can also be used to check the size and margins of your documents.
Rulers & Guides

A. Rulers  B. Guides

To show or hide rulers/guides, select View > check or uncheck Rulers/Guides.

To create ruler guides, follow the steps below:

- Drag down the horizontal ruler to create a horizontal guide, or drag to the right of the vertical ruler to create a vertical guide.
- Double-click a location on the horizontal ruler to create a vertical guide, or double-click a location on the vertical ruler to create a horizontal guide.

To move ruler guides, select the Hand command, click and hold the guide, and then drag it to a new location.

To change the unit of measurement, right-click the horizontal ruler or the vertical ruler, and select a measurement system for the rulers.

To delete ruler guides, please do one of the following:

- To delete a guide, click the guide to select it, and then press the Delete key.
- To delete all guides on a certain page, scroll to the page, right-click the ruler area and choose Clear Guides on Page.
- To delete all guides, right-click in the ruler area and choose Clear All Guides.

Grids

You can use grids to line up form fields and objects (including text, image, path, and shading objects) in a PDF document. When you create or move a form field or object, Snap to Grid can align the form field or object with the nearest grid line.

To show or hide the grid, navigate to View > check/uncheck Grid.
To turn on or off the Snap to Grid option, navigate to View > check/uncheck Snap to Grid.

You can also customize the grid appearance from File > Preferences > Layout Grid.

**Line Weights View**

In Line Weights View, the lines will be displayed with the weights defined in the PDF file. When Line Weights View is turned off, the lines will be displayed with the constant stroke width (1 pixel), regardless of zoom. The following screenshots show the comparison of the PDF file displayed in Line Weights View and Non-Line Weights View.

- To enter Line Weights View, please choose the View tab, and then check Line Weights option.
- To exit Line Weights View, please choose the View tab, and then uncheck Line Weights option.

**View 3D Content in PDFs**

Foxit PhantomPDF lets you view, navigate, and comment on 3D content in PDF documents. Before using these features, you need to download the plugin from Foxit Server and install it in Foxit PhantomPDF. The 3D Content Navigation panel, allows you to show/hide parts of a 3D model and add 3D comments to the 3D model, including text, linear, angular, and radial. You can also rotate/pan/zoom a 3D model in different views.
Show/hide parts of a 3D model

From the 3D Content Navigation panel, you can view the 3D scene structure and the preset views. Check/uncheck the appropriate checkbox to show/hide the corresponding part of the 3D content. Click on the Default view button to go to the initial view. Select the desired view name in the list to switch between preset named views.

Add a 3D comment/measurement to a 3D model

You can add a 3D comment/measurement to any part of a 3D model with the options on the 3D Content Navigation panel.

1. Select Add Comment on the 3D Content Navigation panel, and then put the cursor over the desired position and click to add a note comment. Then you’ll be prompted to enter a comment string in the pop-up dialog box.
2. (Optional) select Add Linear/Add Angular/Add Radial on the 3D Content Navigation panel, and then put the cursor over the desired position and click to add a measurement.
3. In the Default View, a new view will be created after you add a 3D comment/measurement, either called 3DCommentView1 or MeasurementView1, respectively. If added to other preset views, the 3D comments/measurements will be listed under that view.

Rotate, pan, and zoom a 3D model

You can directly use the mouse to rotate, pan, and zoom in/out a 3D model.

- Rotate – click the model, hold the left mouse button, and move the mouse.
- Pan – click the model, hold the left mouse button, and CTRL button, and move the mouse.
- Zoom – click the model, hold the right mouse button, and move the mouse. Or click the model, hold the left mouse button and SHIFT button, and move the mouse.

Select & Copy

With Foxit PhantomPDF, you can copy texts and images to other applications.
Select and Copy Text and Image

The Select Text and Image command lets you select horizontal and vertical text or columns of text, and image in a PDF. PhantomPDF sets each ribbon with the Hand command and Select commands for user's convenience. To copy text or image, click the Select Text and Image command and do the following:

Select text and image

To select an image, please click on the image in a PDF file directly. To select text, please do any of the following:

• Select a word: Double-click the word you want to select.
• Select a line of text: Drag the cursor toward a line of text you want to select.
• Select a column of text: Put the cursor between the lines and the cursor changes into . Then press Alt and drag the cursor toward a column of text you want to select.
• Select text only in a rectangle box without images: Press Alt and drag a rectangle at the desired position you want to select.
• Select multiple paragraphs through pages: Click at the start of the selection, scroll to the end of the selection without releasing your mouse.
• Select all the text: Press Ctrl + A, or select some text, right-click it and then choose Select All.
• Deselect all the text: Click any area of the text.

Copy text and image

After selecting the text or image, do one of the following:

• Right-click the selected text, and choose Copy to copy text with content stream order or choose Copy with Format to copy text with display order.
• Right-click the selected image, and choose Copy.
• Press shortcut key Ctrl + C.

Tip: The style (including font, bold, color, etc.) of the text will be copied to the clipboard as well when you copy text in PDF.

Paste text and image

To paste the selected text on Clipboard to PDF file, please select the Hand command
in Foxit PhantomPDF, use the shortcut key Ctrl + V, or right-click on the document where you want to paste the text and select **Paste**.

To paste the selected image on Clipboard to PDF file, please select the Hand command in Foxit PhantomPDF, use the shortcut key Ctrl + V or right-click on the document and select **Paste**. You will see the image preview as you hover your mouse over the document. Then click on the document where you want to add the image to add it in the PDF file.

To paste the selected text or image on Clipboard to another application, please follow the paste command of the specific application.

### Copy Content Using Snapshot Command

You can use the snapshot command ![Snapshot](image.png) to copy individual images or selected content (text, images, or both) to the clipboard or other applications. Text and images will be copied as an image.

To copy an image or a combination of text and images, do the following:

- Select the **Snapshot** command by choosing **Home > Snapshot**.
- The cursor changes into a Cross “⁻⁻” automatically.
- Click and drag the mouse to draw a rectangle around the content you want to copy.
- You will be prompted that the selected area has been copied to the clipboard. To deselect it, click anywhere on the page.
- (Optional) Right-click the selected area, and then choose **Copy Select Graphic**.
- Paste the selected image to desired destinations.

**Note:**

1. *The selected area will be highlighted in blue.*
2. *With the snapshot command, click anywhere or right-click anywhere in the page and choose “Select All” to copy the entire page.*
3. *You can also copy the selected area and paste it to a PDF document as a stamp annotation.*
4. *To paste images or a combination of text and image on clipboard from another application to PDF file in Foxit PhantomPDF, please select the Hand command ![Hand](image.png) in Foxit PhantomPDF, use the shortcut key Ctrl + V, or right-click on the document where you want to paste the object and select **Paste**.*
Search & Index in PDFs

Find text in the current PDF

- Select the Find Field on the ribbon. Click to set the search criteria.
  A. Whole words only -- limits the search to match only whole words. For example, if you search for the word Read, the word Reader will not be found.
  B. Case-Sensitive -- makes the search case-sensitive. For example, if you search for the word text, the words Text and TEXT will not be found.
  C. Include Bookmarks -- enables you to search for a word in the whole text, including bookmarks.
  D. Include Comments -- enables you to search for a word in the whole text, including comments.
  E. Highlight All Text – Highlight all the text search results in the document.
  F. Properties – enables you to specify the color and opacity of the highlighting of the search results.

- Type the text in the field and press the Enter button. Foxit PhantomPDF jumps to the first instance of the search term, which appears highlighted.
- Click or press shortcut keys Shift+F3 and F3 to find previous or next result, or press Enter to find the next result.

Advanced search

Foxit PhantomPDF supports the advanced search function, which enables you to do the following: search a string in a single PDF file, multiple PDF files under a specified folder, PDFs in a PDF portfolio, or a PDF index. When the search finishes, all occurrences will be listed in a tree view. This will allow you to quickly preview the context and jump to specific locations. You can also save the search results as a CSV or PDF file for further reference.

Before doing an advanced search, you can go to File > Preferences > Search to specify search preferences. For more information, please refer to the Search preferences.

Searching for text and patterns

1. Click Search command next to Find box, and choose Advanced Search.
2. Below “Where would you like to search?” check one of the following to define the search field.

A. To search the text in the current PDF document, select “In the current PDF document”. This option will be grayed out if no document is open.
B. To search the text in all PDF documents in a specific folder or disk, select **All PDF Documents in** > choose one of the disks or user-selected search paths. Foxit PhantomPDF will show the path of the currently opened document for easier location.
C. To search the text in selected documents in PDF portfolio, please select **Selected PDFs in portfolio**. This option is only available when a PDF portfolio is opened.
D. To search text in the PDF portfolio, please select **All PDFs in portfolio**. This option is only available when a PDF portfolio is opened.
E. To search PDF indexes, please choose **Select Index**. This option helps you search the index of the entire set of documents quickly if your PDF document or document collections include a full-text index. If you have added indexes in Foxit PhantomPDF before, you can also choose **Currently Selected Indexes** option directly to search your currently selected indexes. For more information, please refer to “Searching PDF indexes”.

3. Select one of the following search criteria from the dropdown list under the file location box:

A. Match exact word or phrase: Search for instances that match the entire word or phrase (including the spaces) you specified in the text search box.
B. Match any of the words: Search for any instances that match at least one of the words.
C. Looks like search pattern: Search for patterns like phone number, social security number, or email address in the PDF file. This option is not available when you search PDF indexes.
D. Match All of the words: Search for any instances that match at least one of the words, but not necessarily in the order you type the words. If the document does not contain all of the words you type, no matched results will be found. This option is available only for searching a full-text PDF index.

4. For text search, input the word you would like to search in “What word or phrase would you like to search for” box. For pattern search, select the pattern you want to search from the **Select your pattern** dropdown list, and choose the specific county and region from the **Country/Region** dropdown list.

5. (Optional) Check any of the following options to specify the additional search criteria, if needed.
a) To limit the search to match only whole words, check **Whole Words Only**. For example, if you search for the word *Read*, the word *Reader* will not be found. This criterion is only available for text search.

b) To make the search case-sensitive, check **Case-Sensitive**. For example, if you search for the word *text*, the words *Text* and *TEXT* will not be found. This criterion is only available for text search.

c) To search words in comments, please check **Include Comments**.

d) To search words in bookmarks, please check **Include Bookmarks**. This criterion is only available for text search.

e) To search words in attachments, please check **Include Attachments**.

f) To search for two or more words that are separated by no more than a specified number of words specified in the Search preferences, please check **Proximity**. This option is available in index search when **Match of All of the words** is selected.

g) To find instances that contain the stem of the specified search word, please check **Stemming**. For example, if you search for “opening” with **Stemming** option checked, instances of “open”, “opened”, “opens”, and “opening” will be found. This criterion applies to text search and index search, and is not available if either **Whole Words Only** or **Case-Sensitive** is selected.

h) To highlight all the text search results, please check **Highlight All Text**.

i) To limit search in order to match criteria such as document properties and metadata, check the option in **Use these additional criteria** group, and specify the additional criteria, including Author, Date Created, Subject, etc. These options are only available when you execute advanced text search in multiple PDF files.

Tip: The additional search criteria options are collapsed by default. You can click **More** to show all the options.

6. Click **Search** button.

7. Each item listed includes a few words of context and an icon that indicates the type of occurrence. Check the search results with the following steps:

- If necessary, click the plus sign (+) to expand the search results.
- (Optional) For advanced search in multiple documents or portfolios, you can select an option from the **Sort By** drop-down list near the bottom of the **Search** panel to sort the search results by date modified, filename, or location.
- To collapse the file path and have a quick view about the file name, check **Collapse File Path** option at the bottom of the **Search** panel.
- Click a search result directly to view it in the PDF file.

8. (Optional) Click the Save button in the **Search** panel, and choose **Save**
results to PDF or Save results to CSV to save the search results.
9. (Optional) Click New Search button to start a new search task.

Note:

1. For each search, layers, form fields, and digital signatures in the document will also be searched automatically. If some of the search results occurs on a hidden layer, when selecting the results in the Search panel you will be prompted whether to make that layer visible.
2. To find or edit text in a scanned or image-based PDF, you need to convert the content into searchable or editable text using the OCR feature. See also OCR PDFs.

Search and highlight

After searching, users may need to mark up the searched text strings in a highlight color. With Foxit PhantomPDF’s Search & Highlight feature, users can perform an advanced search and highlight the searched text strings with one click.

1. Choose Comment > Search & Highlight.
2. The Search panel opens. Search the text strings or search by patterns as needed.
3. After the search completes, you can see a Highlight icon next to the Save button in the Search panel, a check box in front of each searched instance and each file path, and the Check All option above the New Search button.
4. Select the check box of the instance you want to highlight and click the Highlight icon. (Tip: Click the check box in front of a file path to select all instances found in the file; select the Check All option to select all instances found in the search.)
5. (Optional) you can also change the highlight color as needed. Change the color from the appearance properties of the markup and set the properties as default. (For details, please refer to Change the appearance of Text Markups.) Then perform a new search to apply the new color to searched results.

Searching PDF indexes

If your PDF document or document collections include a full-text index, you can improve your search efficiency by simply searching the index for target words rather than each document separately. Steps are as follows:

• Click Search command next to Find box and choose Advanced Search to open
the **Search** panel.

- From the **Where would you like to search** dropdown list, choose **Select Index** to add indexes.

- In the pop-up **Index selection** dialog box, click **Add** to add an index. All the indexes you added will be displayed in the index list in **Index selection** dialog box. You can select an index, and click **Info** to get its file information, or click **Remove** to remove it from the list, if necessary. Once added, the index files will be marked as checked for you to execute index search by default. Before application, review the indexes in the list, and uncheck the unnecessary one. Upon completion, click **OK** to close the **Index selection** dialog box.

- When you have successfully added the indexes, the **Currently Selected Indexes** option will be selected by default. If you want to search the currently selected indexes next time, you can also choose this option from the **Where would you like to search** dropdown list directly.

- Follow the steps in “**Searching text and patterns**“ to proceed with your search.

**Note:** If the index file is not available or does not work, the search will fail. To create or revise an index, please refer to **Create PDF indexes**.

### Moving and resizing the Search panel

The Search panel that appears when you are doing the advanced search can float or be docked. You can also resize the panel with ease.

- To float the docked Search panel, please double-click the title bar.
- To move the floating Search panel, drag it by its title bar to another location in the work area.
- To resize the Search panel, drag any corner point to adjust.
- To dock the floating Search panel, double-click on the title bar.

### Create PDF indexes

When you are trying to search text in a long PDF document or multiple PDF files, it is much faster to search a PDF index, instead of searching the document(s). With Foxit PhantomPDF, you can create an embedded index for a single PDF, or create a full-text index for multiple PDFs.
Create an embedded index in a PDF

For a PDF document that includes an embedded index, you can search the document as you always do through the Advanced Search feature, but it will be much faster than you search a regular PDF without an embedded index. *(Note: Before searching a document with an embedded index, you need to select the Enable embed index option in File > Preferences > Index.)*

✧ **Add an embedded index to a PDF**

1. Open the PDF with Foxit PhantomPDF.
2. Choose File > Index > Manage Embedded Index > Manage Embedded Index.
3. In the pop-up dialog box, click Embed Index....
4. When the embedding progress is completed, click OK.

✧ **Update or remove the embedded index in a PDF**

You can update or remove the embedded index if the document has been changed.

1. Open the PDF with Foxit PhantomPDF.
2. Choose File > Index > Manage Embedded Index > Manage Embedded Index.
3. In the pop-up dialog box, click Update Index... or Remove Index....
4. When the progress is completed, click OK.

Create a full-text index for multiple PDFs

Foxit PhantomPDF enables you to define a collection of PDFs as a catalog and create a full-text index for the cataloged PDFs, allowing you to search that index through the Advanced Search feature. See also Searching PDF indexes.

✧ **Create a full-text index**

1. Click File > Index > click the Full Text Index with Catalog button.
2. In the New Index Definition dialog box, input the index title and description.
3. (Optional) Click the Options... button next to the Index Description box to do more settings.

A. Do not include numbers: If you don't need to search for numbers in the document, select this option to exclude all numbers in the document text content from a PDF index, which can help make the search faster. If you change the current setting, the new setting only applies to new indexes created afterwards.
B. Do not warn for changed documents when searching: With this option unselected, if you search an index after any of the indexed documents have been changed, a message pops up when you click on the search results in the Search panel. If you change the current setting, the new setting only applies to new indexes created afterwards.

C. Custom Properties: This option allows you to include existing custom document properties in the index. Click Custom Properties, and a dialog box pops up. Then type the custom property, select a type and click Add. Repeat the steps to add more custom properties. These properties will appear as search options in the additional criteria in the Search panel so that you can limit the search by specifying the properties when you search the index.

D. XMP Fields: This option allows you to include custom XMP fields in the index. The custom XMP fields will also appear in the additional criteria in the Search panel when you search the index.

E. Stop Words: Allows you to specify words that you want to be excluded from the index search results. You can only add one stop word at a time. A stop word is case sensitive and contains up to 128 characters. (Tip: In case users trying to search strings that contain the stop words, you are recommended to remind users of the stop words.)

F. Structure Tags: Use this option to make specific leaf-element tag nodes searchable in tagged documents when you search the index.

Note: The settings above apply to the current index only. To apply these settings to all indexes, please do the settings in File > Preferences > Index.

4. Under Include these directories, click Add to select folders that contain PDF files to be indexed. The paths to the selected folders will be added to the box next to the Add button. To remove a folder from the box, select the folder path and click Remove. (Note: The subfolders nested the selected folders will also be indexed. If you want to add files or folders from different drives, make sure you have enabled the Allow indexing on separate drives option in File > Preferences > Index.)

5. Under Exclude these directories, click Add to select folders that contain PDF files you do not want to be indexed. The paths to the selected folders will be added to the box next to the Add button. To remove a folder from the box, select the folder path and click Remove.

6. Click Build. Specify the location for the index file and click Save.

7. The Index dialog box pops up, displaying the indexing process. Click Close when the process finishes. (Optionally, you can click Stop to cancel the indexing process, which will create a partially finished index. You can complete it by revising the index file later.)

8. In the specified location, PhantomPDF creates an index file (an XML file), a log file, and a folder which contains support files about the index contents. (Note: You can unselect the Enable logging option in File > Preferences > Index if you don't want to
create a log file.)

✧ **Revise an existing index**

1. Click **File > Index > click the Full Text Index with Catalog** button.
2. In the **New Index Definition** dialog box, click **Open** to select an index you want to revise. After making changes to the index, do any of the following:
   - After modifying the index title and description, click **Save** to save the changes to the index file itself.
   - Click **Save As** to save the modified index file as a new index file. You can use it to build a new index.
   - Click **Build** to create new index contents in the support folder to update the index, which may increase searching time if you make a large number of changes or repeat this action to update the index for many times.
   - Click **Rebuild** to create a new index, overwriting the existing index file and the index contents in the support folder.
   - Click **Purge** to delete the index contents in the support folder without deleting the index file. You can build a new index after making changes to the index file.

✧ **Schedule index updates**

You can create a batch XML file (a text file that contains a list of platform-dependent catalog index file paths and flags) with Notepad and then use a scheduling application such as Windows Task Scheduler to schedule when and how often to automatically update a full-text index.

To create a batch XML file, do as the following:

1. Open Notepad.
2. Type the file paths of Foxit PhantomPDF.exe and the index file, and the flags (including /build, /rebuild, and /purge) to update the index. For example, to rebuild an index:
   
   “C:\Program Files (x86)\Foxit Software\Foxit PhantomPDF\Foxit PhantomPDF.exe”
   
   C: \Users\Administrator\Desktop\Index-1\Product Manuals.xml /rebuild
3. Save the text as a .bxml file.

*Note: You need to select the **Allow Index batch files (.bxml) to be run** option in **File > Index** to successfully schedule index updates.*

✧ **Move indexed PDFs and their indexes**

You may need to move some or all of the indexed PDF documents to another location. In an index, if the index file and the indexed PDF documents are stored in the same
drive, relative paths exist between the index file and the folders that contain the indexed PDFs. If these relative paths remain unchanged, the index still works after moving the indexed PDF documents.

A relative path is a way to specify the location of a directory relative to another directory. For example, suppose one of the indexed documents (butterflies.pdf) are in “C:\Sample\A”, and the index file is in “C:\Sample\B”. Then the relative path to “butterflies.pdf” is “..\A\butterflies.pdf”. The relative path is more flexible, because if you move the entire “C:\Sample” directory to another location such as “E:\Sample” or “C:\Smith\Sample”, the relative paths to the indexed documents would remain valid, which makes the index still work.

Note: If the index file and the indexed PDF documents are stored in different drives, after you move the indexed PDF documents, the index will not work and you need to create a new index.

Whether the index file and the indexed PDFs are stored in the same drive or not, if the index does not work after you move the index file or the indexed PDFs, you need to create a new index. However, you can still use the original index file. First, move the indexed documents to the target location. Then put the index file in the new index folder, edit options and the directories in Include these directories and Exclude these directories as needed, and create a new index.

Integrate with IFilter

Foxit PhantomPDF is now integrated and packaged together with Foxit PDF IFilter–Desktop, which allows users to index a large amount of PDF documents and then quickly find text within these documents on the desktop system. You can trigger Foxit PDF IFilter in the installation directory of Foxit PhantomPDF. For more information, please refer to the user manual for Foxit PDF IFilter.

Note:

1. If you are in Safe Reading Mode, a dialog box will pop up when you are trying to open an attached file. Check Disable Safe Reading Mode and Open file, and then double click the File Attachment icon to open the attached user manual for Foxit PDF IFilter.

2. If Foxit PDF IFilter didn’t appear in PhantomPDF installation setup, you need to go to Help > Check for Updates to download and install Foxit PDF IFilter; or after downloading the Foxit PDF IFilter plugin from the Foxit website, click Help > Install Update to install it.
Compare PDF Files

The Document Compare feature lets you see the difference in two versions of a PDF, as well as select the type of differences you're looking for to verify that the appropriate changes have been made. The Document Compare feature does not compare comments in the PDF.

Comparing a revised PDF to an earlier version

1. Choose View > Compare.
2. Specify Old File and New File to be compared. Click Choose... to select the file. In the pop-up Open dialog box, you can select a local file or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMforLegal, Dropbox, Box, and eDOCS DM.
3. You can preview the pages of both files. Choose the specific page you want to preview by dragging the slider or clicking the list box to select the page number.
4. Choose the specific pages you want to compare.
5. Click Options and select options as needed:

   - Include
     - Compare Text Only: Select it to compare the text content only.
     - Compare Table: Select it to compare tables. This option is recommended for documents that contain tables.
     - Detect Page Deletions or Inserts: In documents where some contents are removed or inserted, select it to mark the removed or inserted contents only in the comparison results, rather than mark them along with their following contents.

   - Color
     Select the desired highlight color for the markups that indicate the replaced, inserted, and deleted objects in the comparison results.

   - Opacity
     Specify the opacity for the markups that indicate the replaced, inserted, and deleted objects in the comparison results.

   - Line Thickness
     Specify the line thickness for the markups that indicate the replaced, inserted, and deleted objects in the comparison results.

   - Set current properties as default
     Select it to apply the current settings to future comparison.

6. Click OK. And then a PDF document named “The result of Comparison.pdf*” will be automatically created and opened in a new tab within the application window, and the Compare Results tab appears on the ribbon.
The result document arranges pages side by side showing Old File and New File with the changes marked by different icons and colors. The first page shows a summary of the comparison results including the total number and the marks for different changes. The second page shows the detailed comparison results including the names and sizes of Old File and New File, time compared, and the classification of changes, with a color legend in the upper right corner. You can click Go to the First Change (page *) on the second page to jump to the first change.

7. In the Compare Results tab, do any of the following:
   - Click Next/Previous Change to navigate through the changes in the document pane in both files.
   - Click Filter and select items to show specific changes you need by text, images, annotations, and formatting. Or click Filter > Everything to show all changes.
   - Click Show and select items to show/hide the results and the color legend. Clicking Show > Show Summary navigates to the summary page.

8. You can also use the Comments panel in the navigation pane to see each change. Click a change to quickly locate it in both documents. See also View all comments.

9. You can save the results document as needed.

Word Count

Similar to Microsoft Word, Foxit PhantomPDF counts words, characters, pages, lines and other information in all or part of your document. With no text selected, click View > Word Count, and you will see a pop-up Word Count box for the statistics of the entire document. For a partial word count, just select the text you want to count, and then click View > Word Count; or right click the selected text and choose Word Count from the context menu.
Chapter 4 – Create

Up to 3 times faster than other PDF tools, Foxit PhantomPDF makes creating PDF and PDF/A documents simple and streamlined. With a click you can quickly convert virtually any kind of file to PDF without having to open the source application.

Create a PDF in Different Ways

With Foxit PhantomPDF, you can easily create PDFs from files in other formats.

See also the tutorial on how to Create Industry-Standard PDFs.

One-click PDF Creation from Any File

Foxit PhantomPDF can create any kind of printable files to PDF simply by dragging the file into the program window; alternatively, you can use Foxit PhantomPDF to quickly convert files to PDF directly from within Windows® Explorer.

To create a PDF with one click:

- Drag the document you want to convert on to the Foxit PhantomPDF desktop icon.
- If the Foxit PhantomPDF is open, drag the file directly into the application window.
- Right-click the document(s) you want to convert, and choose Convert to PDF in Foxit PhantomPDF. The created files will be opened in Foxit PhantomPDF, and you can save them manually. If you have selected the Keep original file names and locations option in the Convert Multiple Files dialog box in the previous conversion, the created files will be saved in the same names and locations as the original files.
- Right-click the document(s) you want to convert, and choose Combine files in Foxit PhantomPDF... to convert multiple files into a single PDF. See also Create PDFs from multiple files.

Tip: When right-clicking a folder, if you choose Convert to PDF in Foxit PhantomPDF, all files in the folder and the sub-folders will be converted to PDFs separately; if you choose Combine files in Foxit PhantomPDF..., you can add more files/folders and convert all of them to PDFs. See also Create PDFs from multiple files.
Create PDFs in the Foxit PhantomPDF Application Window

Create a PDF from a file

You can create a PDF from Office, email, a web site, or from any file that prints.

1. Launch Foxit PhantomPDF, choose File > Create > From File, or choose Convert > From Files > From File.

2. In the Open dialog box, navigate through your local disk to select a local file, or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM. Then click Open to start the conversion.

3. The converted PDF file will be opened in Foxit PhantomPDF automatically. Click the Save button or choose File > Save to save the PDF file.

4. Type a filename and specify a location in the pop-up Save dialog box.

Note: Depending on the type of file being converted, a progress dialog box appears and Foxit PhantomPDF opens automatically.

Create PDFs from multiple files

You can easily merge files of different types into a single PDF, or you can also convert them into separate PDFs.

Convert and combine multiple files into a single PDF

1. Choose File > Create > Combine Files, or choose Convert > Combine Files, or right-click a file you want to convert to PDF and choose Combine files in Foxit PhantomPDF....

2. In the Combine files into a single PDF dialog box, add files you want to combine by directly dragging and dropping files to the file list in the box, or by clicking Add files and selecting one of the following options:

   - Add Files: You can choose files from local drives or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.
   - Add Folder: Choose a folder that contains the files you want to combine.
• **Add WebPage**: Input a URL, or browse and select an HTML file you want to combine. Then click **Create**.

• **Add PDF from Scanner**: Scan documents to PDFs and add the scanned PDFs to the file list you want to combine. For the details about how to scan documents to PDF, please refer to [Create PDFs using Scanner](#).

• **Add From Clipboard**: Create a PDF from the clipboard and add it to the file list you want to combine.

• **Add Open Files to**: Choose currently opened PDF files to add to the file list you want to combine.

**Tips**: If you add a PDF portfolio, each file in the PDF portfolio will be extracted and added in the file list. By default, the files will be listed in an ascending order by the file name.

3. (Optional) You can right-click any file in the dialog box and choose **Edit Bookmark for File** (or just double-click the file) and modify the bookmark title that will be one of the bookmarks in the combined PDF after conversion. By default, the bookmarks in the combined PDF are the names of each file.

4. (Optional) You can adjust the order of files to be displayed in the combined PDF by the files’ name, modified time, size, or bates numbering by clicking the corresponding column name. Click the column name again to reverse the order. *(Note: To order by bates numbering, all files in the dialog box should be PDFs and use the same bates numbering formatting.)* Or, adjust the order of files manually as desired by using **Move Up/Down**, or drag and drop a file to change the file order. Select a file and click the **Remove** button to delete it.

5. (Optional) When you select a Microsoft Word, PowerPoint, or PDF file, the button named “Choose Pages” appears next to the **Remove** button; if you select an Excel file, the “Choose Sheets” button appears. You can specify a page range or choose sheets to convert.

6. Check the following option as desired and click **Combine**:

   ✷ **Add a new table of contents page converted from bookmarks**: creates a table of contents (TOC) from the bookmarks of the selected files in the beginning of the merged PDF file. The original filename of each file will be the first TOC level, each of which is followed by the bookmarks of the file. By default, the TOC includes up to 5 levels with the corresponding page numbers in the PDF. For a file without any bookmarks, only the filename will be inserted to the table of contents.

   ✷ **Retain the logic page numbers during combination**: selects it, and the combined PDF file will keep the logic page numbers in the original files.
Tip: Foxit PhantomPDF combines the bookmarks of the selected files as the bookmarks of the combined PDF, with the first level of the combined bookmarks named with the original filename of each file.

Convert multiple files into separate PDF files

1. Choose File > Create > From Multiple Files, or choose Convert > From Files > From Multiple Files.
2. In the Convert Multiple Files dialog box, click Add files, and choose Add Files or Add Folder to select the files or folder you want to convert.
3. Files will be converted in a sequence as they are ordered in the Convert Multiple Files dialog box. You can reorder the files by name, modified time, or size by clicking the corresponding column name. Alternatively, reorder the files manually as desired by clicking the Move Up/Down button, or by dragging and dropping the file in the list. Select a file and click the Remove button to delete it, if necessary.
4. (Optional) If you need to save the converted PDF files in the same location as the original file, check the Keep original file names and locations option.
5. Click Convert.
6. (Optional) If you did not check the Keep original file names and locations option, the Browse For Folder dialog box will pop up. Choose the folder in which you want to save the converted PDF files, and click OK.

When you create PDFs from Microsoft Office files in the PhantomPDF application window, by dragging and dropping, or from the context menu of the files, you can specify the default conversion settings in advance. Go to Convert > From Files > Convert to PDF Settings and specify the conversion settings in the pop-up Convert to PDF dialog box.

- Choose a set of default conversion settings from the drop-down menu, or click Edit to modify settings. See also Setting Foxit PhantomPDF Printer Properties.
- Add bookmarks to Foxit PhantomPDF file – Keeps the bookmarks of Word files or converts the headings of Word files to bookmarks in the converted PDFs; In Excel/PPT, the sheet name and the slide title (or the slide page number) will be converted to bookmarks in the generated PDFs.
- Tagged PDF – Creates a tagged PDF for accessibility. (Microsoft Office 2010 or a later version is required.)
- Convert entire Excel workbook – Select this option to convert all sheets of the Excel file to a single PDF. If this option is deselected, only the most recent sheet that you opened will be converted.
Create a PDF from a blank page

You can create a PDF from a blank page rather than beginning with a file, a clipboard image, or scanning.

1. Choose File > Create > Blank, or choose Convert > Blank.
2. Choose Edit > Add Text or Comment > Typewriter > Typewriter.
3. Click on the blank page to start typing the text you want to add to the blank page.
4. As needed, select other commands and options that you want to apply to the PDF.
5. Choose File > Save, and select a name and location for the PDF file.

Create a PDF from Clipboard

You can create a PDF directly from your clipboard.

1. Choose File > Create > From Clipboard, or choose Convert > From Clipboard.
2. The texts or images in the clipboard will be converted to a new PDF file.

Create a PDF from Web Page

To create PDF from web pages:

2. Input the URL of the web page in the box in the Create PDF From Web Page dialog box, or click Browse to choose an HTML file.
3. Click Settings to set more conversion options.
   The General tab:
   - **Conversion Level**: specify the number of levels of the website to convert to PDF, or check Convert the entire site.
   - **Convert webpages on the same path**: convert the webpages subordinate to the input URL.
   - **Convert webpages on the same server**: convert the webpages stored on the same server.
   - **PDF Setting**: set the timeout to load the whole web page. Loading that takes longer will be aborted automatically, and only the loaded content will be converted to PDF. The default value is 120s.
   - **Disable all hyperlinks in the generated PDFs**: check this item, and all hyperlinks will be invalid in the generated PDF.
Convert each web page into a single PDF page: check this item, and all the related content will be converted to one PDF page.

Create bookmarks: check this item, and bookmarks for converted web pages will be created automatically after conversion. The created bookmarks are named with the domain names of the web pages. If the web pages share the same domain name, sub-bookmarks will be created and named with the page titles. If the page has no title, the URL is used instead.

Create PDF Tags: check this item to create a tagged PDF that includes tags and other accessible information such as alt-text for images.

The Page Layout tab: specify the page size, margins and orientation for the generated PDF as needed.

Media style:
- Screen: convert the web page exactly as how it is displayed on the screen to PDF. This option is selected by default.
- Print: convert the web page based on the Print setting in the web page itself.

Scaling:
- Fixed page with no scale: convert the web page without scaling. However, if the web page is too wide and exceeds the PDF page size specified above, the generated PDF will be truncated.
- Scale: With this option selected, PhantomPDF will scale the web page if necessary to fit the width of the PDF page size specified above. This option is selected by default.
- Enlarge: With this option selected, if the web page is too wide and exceeds the PDF page size specified above, PhantomPDF will enlarge the PDF page size automatically.

To create PDF from a linked web page:

If your PDF document contains linked text which links to a web page, you can also convert the linked web page to PDF from within Foxit PhantomPDF application.

1. Make sure you have selected the Hand command.
2. Right-click on the linked text, and choose Open Weblink as New Document.
3. Then the linked web page will be converted to PDF and opened in Foxit PhantomPDF. You can click the save button to save it as desired.

Tip: While creating a PDF from a webpage which requires login, only the login page will be converted to PDF.
Create a PDF form from an existing file

You can create a PDF form directly from an existing file during which Foxit PhantomPDF will detect and recognize the form fields automatically, with no need to use the Run Form Field Recognition command.

1. Choose File > Create > Form > From a file, or choose Convert > Form > From a file.
2. In the Open dialog box, navigate through your local disk to select a local file, or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM. Then click Open to start the conversion.
3. A PDF with form fields if any is created and opened with Foxit PhantomPDF.
4. Specify the file name and save path.

Create PDFs in Microsoft Word, Excel and PowerPoint

Foxit PhantomPDF enables you to create professional and secure PDF files from Microsoft Office (Word, Excel, and PowerPoint), automatically keeping bookmarks, links, hyperlinks, outline and more of the source files in the created PDF.

In Microsoft Office 2007/2010/2013/2016, Foxit PhantomPDF appears as a tab, which allows you to quickly create PDF files and change your conversion settings in just a few clicks.

Microsoft Word 2013 Foxit PDF Tab in Business Edition

Create PDF

To create a PDF in Microsoft Word, Excel and PowerPoint, please do as below:

Open a file in Microsoft Word, Excel or PowerPoint, click the Foxit PDF tab and do one of the following:
To create a PDF using the current settings, click the Create PDF button. Then enter the file name, specify the location and click Save.

To create and email a PDF using the current settings, click Create PDF and Email. Then enter the file name, specify the location and click Save. The created PDF file will be attached to your mail system automatically for you to send out.

To create a PDF and save it to SharePoint, click Create to ECM. Please refer to “Save the created PDF to ECM” for more information.

To customize your PDF conversion settings before creating a PDF, click the Advanced button and the Foxit PhantomPDF Add-in dialog box pops up. Some options depend on the application in which you are using the add-in.

In the Settings tab, you can specify the conversion settings and the following options. For the conversion settings, please refer to Setting Foxit PhantomPDF Printer Properties.

Create Bookmark – In Word, keeps the bookmarks of the source file in the converted PDF; In Excel/PPT, the sheet name and the slide title (or the slide page number) will be converted to bookmarks in the generated PDF. This option is checked by default.

Tagged PDF – Creates a tagged PDF for accessibility. (Microsoft Office 2010 or a later version is required.)

Page Range – Specifies a page range that you want to convert.

For the Bookmarks tab:

Convert Word headings to bookmarks in PDF – Check this option to convert all the headings in the Word document into bookmarks in the PDF document. You can deselect some headings that you don't want converted in the heading list below.

Convert Word styles to bookmarks in PDF – Check this option to convert the selected text styles in the Element list to PDF bookmarks.

Element list – Specify which Word headings and styles are converted to PDF bookmarks. The Element list includes the following categories:
Chapter 4: Create

- **Element**: List the names of all available Word headings and styles.
- **Type**: Indicate the type of the element in the Word document, Heading or Style.
- **Level**: Specify the level of an element that fits in the hierarchy structure of the PDF bookmark. For the style elements, you can click on the Level number to change their levels.

**Convert the bookmarks in Word to PDF bookmarks** – Check this option to convert all the bookmarks in the Word document into bookmarks in the PDF document.

- For the **Document Homepage**, **Remove ConnectedID**, and **Sign In** buttons, please refer to **ConnectedPDF User Manual**.

**Create PDFs Using Word’s Mail Merge**

Foxit PhantomPDF allows you to convert personalized email messages, letters, or labels created from Microsoft Word’s **Mail Merge** function to PDFs all at once. You can also change the settings to send the PDFs via email attachments to a number of individuals if needed.

1. To create PDFs from **Mail Merge**, open the Word file and click **Mail Merge** in the Foxit PDF tab or click **Merge to Foxit PDF** in the MAILINGS tab. *(Note: The Word file must be a mail merge document before you merge them to PDFs. For information on how to create a mail merge document, please refer to Microsoft Word Help.)*

2. In the **Mail Merge Settings** dialog box, you can specify the set by a range of record numbers. Then specify the name of the PDFs by filling in the field for the file name or by choosing a field from the list of fields available in your data source. *(Note: If you type ReplyLetter in the Name box, the mail-merged PDFs will be named ReplyLetter1, ReplyLetter2, ReplyLetter3, and so on.)* Click **OK** to continue.

3. (Optional) If you need to email the created PDFs as attachments, check the **Automatically send PDF files by email** option and adjust the relevant settings as needed.

4. Specify a save path for the PDFs and click **OK**.

5. If you checked the **Automatically send PDF files by email** option, you will be prompted to choose an email profile. Click **OK** to send the PDF files.

6. A message box will pop up to prompt you if the process was successful.
Create a redacted PDF *(Business Edition Only)*

The Foxit PhantomPDF plugin in Microsoft Word, PPT and Excel also enables users to quickly create a redacted PDF, which can be encrypted into an AIP-protected PDF as well. For a redacted and AIP-protected PDF, authorized users are granted access to view the full document while unauthorized users are only able to view the redacted document. PDF redaction permanently removes visible text and images from PDF documents to protect confidential information. This feature allows for improved sharing of non-sensitive information within a protected document.

To create a redacted PDF or a redacted and AIP-protected PDF, select the text you want to redact and click **Mark for Redaction**. Click the **Create Redacted** button and choose **Standard Redaction** to create a redacted PDF document, or choose **RMS Redaction** to create a redacted and AIP-protected PDF document. Then enter the file name, specify the location, and click **Save**.

For more detailed information about redaction and AIP integration, please refer to **Redaction** and **Template Creation and Editing**.

Save the created PDF to ECM

You can create a PDF and save it in ECM (iManage Work, SharePoint, ndOffice, OneDrive-Personal, and Google Drive) using Foxit PhantomPDF add-on in Microsoft Word, Excel, and PowerPoint 2010 and higher versions.

1. Open a file in Microsoft Word, Excel or PowerPoint, and click the **FOXIT PDF** tab.
2. Customize your conversion settings as needed. For more information, please refer to “**Conversion Settings in Microsoft Word**”.
3. Click **Create to ECM**, select an ECM system, and log in to your account. Then choose a location to save the output PDF file.

Create PDFs or PDF Portfolios with Microsoft Outlook

You can quickly convert or combine .msg files (emails) into PDFs using the right-click menu with Foxit PhantomPDF installed. Right-click a message file, and choose **Convert to PDF in Foxit PhantomPDF** to convert the file to a new PDF; or choose **Combine files in Foxit PhantomPDF**... to convert multiple files. See also **One-click PDF Creation from Any File**.

Foxit PhantomPDF also adds a plugin in Microsoft Outlook when installed and appears as a tab entitled **FOXIT PDF** in the Outlook toolbar. The commands in the tab allow you to create a PDF file or PDF portfolio from the selected email message(s) or folder(s).
To create a new PDF or PDF portfolio from the selected message(s), please select the message(s) you want to convert and click **Selected Message > Create New PDF...**, or right-click the selected message(s) and choose **Convert to Foxit PDF**. Then specify the name and the location of the created PDF or PDF portfolio to begin the conversion.

**Note:**

1) **To create a new PDF portfolio, the Output PDF Portfolio option should be checked in General Settings group. Each message will be converted to a single PDF.**

2) **If the Output PDF Portfolio option is not checked, the selected message(s) will be merged into one continuous PDF according to the time of each message was sent or received, i.e. the latest message is on the first page.**

3) **The default name of the created PDF or PDF portfolio will be the title of the selected message or the folder name of the selected messages.**

To create a new PDF or PDF portfolio from the selected folder(s), please click **Selected Folder > Create New PDF...**, or right-click a folder and choose **Convert to Foxit PDF**. Select folders you want to convert in the pop-up **Convert folder(s) to PDF** dialog box. Then specify the name and the location of the created PDF or PDF portfolio to begin the conversion.

**Note:**

1) **To create a new PDF portfolio, the Output PDF Portfolio option should be checked in General Settings group. Each message will be converted to a single PDF and then the created PDF will be put into corresponding folders in the portfolio.**

2) **If the Output PDF Portfolio option is not checked, all messages in the selected folders will be merged into one continuous PDF. If you create a PDF file from one folder, the latest email message will be arranged on the first pages of the created PDF file. If you create from multiple folders, the order is based on the order how each folder is displayed on the Convert folder(s) to PDF dialog box first and then the time each message was sent or received.**
To append to an existing PDF or PDF portfolio from the selected message(s), please select the message(s) you want to convert and click **Selected Message > Append to Existing PDF...**, or right-click the selected message(s) and choose **Append to Foxit PDF**. Select the existing PDF or PDF portfolio you want to append to and click **Open**. The selected message(s) will be appended to the end of the existing PDF. If the existing PDF is a PDF portfolio, the selected messages will be created to single PDF files and then put into corresponding folders in the existing PDF portfolio.

To append to an existing PDF or PDF portfolio from the selected folder(s), please click **Selected Folder > Append to Existing PDF...**, or right-click a folder and choose **Append to Foxit PDF**. Select folders you want to convert in the pop-up **Convert folder(s) to PDF** dialog box. Select the existing PDF or PDF portfolio you want to append to and click **Open**. All messages of the selected folder(s) will be appended to the end of the existing PDF. If the existing PDF is a PDF portfolio, each message of the selected folders will be created to single PDF files and then put into corresponding folders in the existing PDF portfolio.

To customize your PDF conversion settings before creating PDF, check desired options in **General Settings** group.

- **View PDF Result** – Once the conversion finishes, the converted PDF will be opened with PhantomPDF automatically.
- **Output PDF Portfolio** – Creates a new PDF portfolio from the selected email message(s) or folder(s) and keeps the folder information of the selected folders in the created PDF portfolio (i.e., the location path information of the folder in your email system). If you don't want to keep the folder information during conversion, please click the **Advanced** button and uncheck **Convert folder information** option in the Settings tab. For instructions on how to modify a PDF portfolio, please refer to **Customize PDF Portfolios**.
- **Include Attachment** – Keeps the attachments of the selected email messages or folders as the created PDF's attachments, with the file types of the attachments unchanged.
- **Support PDF/A-1b Standard** – Creates a PDF that is compliant with PDF/A-1b standard.

For more settings, click **Advanced** button and a Foxit PhantomPDF Add-in dialog box pops up. You can add headers/footers, watermarks, security, etc. See also **Setting Foxit PhantomPDF Printer Properties**. In the Security tab, you can also add AIP protection. For instructions on how to add AIP protection, please refer to **AIP Protect**.

Foxit PhantomPDF supports automatic email archiving based on your settings. Click **Automatic Archival** and check **Enable Automatic Archival** in the pop-up Automatic Archival dialog box to do archival settings:

- Specify the frequency and the time of the day to do the automatic archiving.
. (Optional) Enable “Maintain Log of Archival” to create a record for each archiving. Click Choose File ... to name the log file and specify its storage location.
. In Choose Folders for Automatic Archival box, click Add to select email folders you need to archive and specify the name (Check the box for Append the archive date to the specified archive file name so that the older archived files will not be overwritten) and location of the archived email PDF. You can also click Delete to remove folders from the list or click Change Archive File... to modify the name and location of the archived email PDF.
. (Optional) You can start archiving email right after you choose the folders for automatic archival by clicking Run Archival Now button in the top right corner of the Automatic Archival dialog box.
. Click OK to complete setting.

Note: All archived email PDFs are PDF portfolios.

- Sign In: You can sign in your Foxit account to directly create your own ConnectedPDF document. Before creation, you need to go to Preferences > ConnectedPDF > check Automatically save PDF files in ConnectedPDF format (including those created from plugins) only when signed in. More information about ConnectedPDF, please refer to ConnectedPDF User Manual.

With Foxit PhantomPDF installed, you can quickly convert a file to a PDF and send it with Microsoft Outlook.

1. Create a new email, and click the Foxit PDF tab in the Outlook ribbon.
2. Click Attach as Foxit PDF, a dialog box pops up for you to choose a file, and click Open.
3. Specify a location in the dialog box to save the PDF to be generated and click Save. The generated PDF will be automatically attached to the email.
4. (Optional) Click Sign In to sign into your Foxit account and then click Protect Attachment to add ConnectedPDF protection to the generated PDF. The protected PDF can only be viewed by others. More information about ConnectedPDF, please refer to ConnectedPDF User Manual.
5. After typing recipients and message, click Send.
Create PDFs in Microsoft Visio (Business Edition Only)

PhantomPDF Creator Plugin in Microsoft Visio provides quick and easy PDF creation from Visio files, while preserving the document properties in the created PDFs depending on the conversion settings.

To create a PDF in Microsoft Visio, please open a file in Microsoft Visio, click the Foxit PDF tab and do one of the following:

- To create a PDF using the current settings, click the Create PDF button. Then enter the file name, specify the location, and then click Save.
- To create and email a PDF using the current settings, click the Create and Email button. Then enter the file name, specify the location, and click Save. The created PDF file will be attached to your mail system automatically for you to send out.
- To create a PDF and save it to SharePoint, click Create to SharePoint. Please refer to “Save the created PDF to ECM” for more information.
- To customize your PDF conversion settings before creating PDFs, please refer to Conversion Settings in Microsoft Word. You can retain all layers or flatten all layers in the created PDFs by choosing Retain All or Flatten All for the Layers setting. If you choose to flatten layers, the created PDF will seem like the original Visio drawing, but without any layer information.
- For the Document Homepage, Remove ConnectedID, and Sign In buttons, please refer to ConnectedPDF User Manual.

Note:

1. If you check Create Bookmarks, the created bookmarks will be named after the page name in Visio files.
2. Only shapes and guides that are printable and visible in the Visio drawing will be converted and will appear in the created PDF.
Create PDFs in Microsoft Project (Business Edition Only)

Foxit PhantomPDF Business enables you to create professional and secure PDF files from Project files in Microsoft Project. For details, please refer to Create PDFs in Microsoft Word, Excel, and PowerPoint.

Create PDFs using the Print command

Foxit PhantomPDF Printer works like a standard printer, so you can use it to print your files from any windows applications (such as Notepad and Outlook Express) as if you would print to a real printer.

1. Open the file in its authoring application.

2. Choose File > Print.

3. Select the printer named Foxit PhantomPDF Printer, and click the Print button. If you need to deploy print settings, click the Preferences button (See also Setting Foxit PhantomPDF Printer Properties).

4. Specify the name and the storage location in the pop-up dialog box and click Save to start printing. After the printing is finished, the generated PDF file will be opened directly.

Foxit PhantomPDF supports to append newly generated PDF files to a previously generated one which are created by Print command in other application using Foxit PhantomPDF Printer. More details please refer to the steps below.

1. Change settings in Foxit PhantomPDF. Run and open the application window. Click File > Preferences > Documents > uncheck Allow Multiple Instances, if it is checked. And click File > Preferences > Create PDF > check Insert printed PDFs into previously generated documents, except those created by Foxit PhantomPDF.

2. Open the file you want to convert to PDF and use the Print command to generate a new PDF. The generated PDF file will be opened automatically with PhantomPDF. A Print Job pane appears in navigation pane and the name of the file will be displayed on the pane. Do not close or save the PDF file.
3. Open another file you want to append to the PDF file generated on Step 2. Convert the file with Print command to PDF.

4. You will see that the name of the file in Step 3 is also added to the Print Job pane. That is to say, the generated PDF file on Step 3 is appended to the generated PDF file on Step 2.

5. Click File > Save. In the pop-up Save As dialog box, specify the name and location and click Save.
Create PDFs within web browsers

Foxit PhantomPDF allows you to convert webpages to PDFs using the Foxit Convert commands in the toolbar within Google Chrome, Internet Explorer, and Firefox. You can convert the current webpage to a new PDF or append to an existing PDF, or send the new PDF as an email attachment with one click.

For more about how to create PDFs within web browsers, see also Create PDFs in Microsoft Word.

Click Preferences for more settings. See also Create a PDF from Web Page and Conversion Settings in Microsoft Word.

Create PDFs using Print to Evernote

Foxit PhantomPDF adds a new printer “Print to Evernote” after installation. This feature enables the user to send the PDF file as an attachment to Evernote, as well as the option to create a PDF the same as Foxit’s PDF printer does.

To create a PDF using Print to Evernote, see below:

1. Install the Evernote application and sign in to an Evernote account.

2. Open the file you want to convert to PDF, and choose File > Print > Print to Evernote.

3. Set the print properties and then click Print. Name the PDF file and specify the storage location.

4. You will see that the PDF file is created and also attached in Evernote.

Create PDFs using Scanner

Foxit PhantomPDF allows you to create a PDF directly from a paper document using your scanner. You can scan a document to PDF directly with custom settings or by using preset preferences that you configured before.

See also the tutorial on Scan Documents into PDF.
Scan with custom settings

To scan a document to PDF with custom settings, please follow as below:

- Choose **File > Create > From Scanner** > the **From Scanner...** button > the **Scan** command, or choose **Convert > From Scanner > Scan**, or choose **Home > the Scan** button > the **Scan** command.
- Select a scanner and related options in the **Scan** dialog box.
  
  **Note:** You must have the manufacturer's scanning software installed on your computer.

**Advanced Options:** clicks to open the Scanner Options dialog box. (Available only after you select a scanner.)

  **Transfer Mechanism:** Native mode transfers data by default in your scanner. Buffered memory mode scans in resolutions of over 600DPI.

**Configure scanner:**

  **Configure scanner using scanner interface:** Checks this option and directly use the scanner interface to scan. Then the following items (i.e. Source, Color Mode, Paper Size and Resolution) will not be available and the settings in the scanner interface will not be able to saved as a preset.

  **Prompt to scan more pages:** selects this option, a dialog box will pop up to ask you whether to scan more pages whenever the scanning completes. If the option is unselected, for single-sided printing, you'll not be prompted once the scanning completes.

  **Sides:** Specify single or double-sided scanning. If you select Both Sides but the settings of the scanner are for only one side, the scanner setting overrides the Foxit settings.

  **Source:** select the input source for scanning, including Auto Detect, Feeder, and Flatbed. If you select **Auto Detect**, Foxit PhantomPDF will detect the input source for scanning automatically. If documents are placed in both feeder and flatbed, both of them will be scanned, but the one in feeder will be scanned first by default.

  **Color Mode (Windows only):** selects a basic color mode (Black and White, Grayscale, Color or Auto Detect) supported by your scanner.

  **Paper Size (Windows only):** selects a paper size.

  **Resolution (Windows only):** selects a resolution supported by your scanner.

**Output:**

  **New PDF Document:** Output the scanning results as a new PDF document.

  **Append:** Append the scanning results to an existing PDF file. After selecting
this option, click **Browse** to find and select an existing PDF file from your local disk.

**Save Multiple Files:** Save the scanning results as multiple PDF documents. Click the Options button to specify the number of pages for each PDF document, the file name prefix, and whether to create a portfolio where all scanning results will be saved.

**Optimize Scanned PDF:**
- **Reduce size and optimize:** checks this item and clicks **Options** to customize compression and filtering. The **Optimization Options** dialog box for image settings controls how scanned images are compressed for the PDF. Default settings are suitable for a wide range of document pages, but you may want to customize settings for higher quality images and smaller file sizes.

- **Color/Gray settings:** when scanning color or gray pages, select **JPEG**, **JPEG2000(Lossless)** or **JPEG2000(Lossy)** to apply JPEG compression to the entire gray or RGB input page. Select **High-Compression** to apply image compression in high-quality with small size (Available in **Business Edition Only**).
  - **Low/High Quality:** drags the slider to set the balance point between file size and quality.
  - **Monochrome:** when scanning black-and-white or monotone images, select one of the following:
    - **JBIG 2(Lossless)/ JBIG2(Lossy):** apply an image compression standard for bi-level images which is suitable for lossless or lossy compression.
    - **CCITT Group 4:** applies CCITT Group 4 compression to black-and-white input page images.
    - **High-Compression:** applies to high-quality with small size compression. (Available in **Business Edition Only**)

- **Deskew:** chooses **On** to automatically rotate any page so that the text is vertically aligned, which is of great use for cleaning up scanned PDFs.
- **Remove blank pages:** removes the blank pages from the scanned PDF after scanning.

- **Make Searchable(run OCR):** checks this item and clicks **Options** to run OCR in scanned PDFs. See also “**Recognize Text**”.

**Save as Preset:** saves the current scanning settings as a preset with which you can quickly start a scan next time. In the pop-up **Save Preset** dialog box, rename the preset as needed and click **Save**.
Click **Scan**. If you checked **Configure scanner using scanner interface** previously, specify the scan settings as needed and then scan the document based on your scanner’s settings.

- A dialog box pops up, asking you whether to scan more pages, or to scan the reverse sides if you chose both sides in the **Sides** option previously. Choose a desired option.
- When the scanning is complete, the new scanned PDF or the existing PDF with the scanned pages appended at the end will automatically be opened, with a new tab named “**POST-SCAN**” on the ribbon.

The **Post-Scan Options** tab:

- **Optimize Scanned PDF**: optimizes the scanned PDF for a smaller size and better display effect. See also “**Custom Scan**”.
- **OCR Current File**: runs OCR in the current scanned PDF after saving the document. See also “**Recognize Text**”.
- **Page Organize**: navigates to the **Organize** tab where you can apply these commands on the PDF pages.
- **Grayscale/ Black & White**: adjusts the color mode of the scanned PDF. You can change the mode from Color to Grayscale/ Black & White, or from Grayscale to Black & White; but not the reverse.
- **Edit Document Information**: modifies the scanned document information including Author, Title and File name.
- **Close**: closes the **Post-Scan Options** tab.

Choose **File > Save**, and specify a name and location for the scanned PDF file.

**Scan with a Configured Preset (Windows)**

You can configure scan parameters or options and save as presets. When you are ready to scan you can choose one of them with just one click. To scan a paper document to PDF using a configured preset, from **File > Create > From Scanner > From Scanner…** button, or **Convert > From Scanner**, or **Home > Scan**, select a preset to scan documents. See also “**Configure presets**”.
Configure presets

To configure a new preset, please do the following:

- Choose **File > Create > From Scanner** > the **From Scanner...** button, or choose **Convert > From Scanner**, or choose **Home > the Scan button** > the **Scan** command.
- Select a scanner and then complete the settings (See also “Custom Scan”).
- Click **Save as Preset** to save the preset. Or click **Scan** to start a scan with the preset.

To modify presets, please do the following:

- Choose **File > Create > From Scanner** > the **From Scanner...** button > the **Manage presets** command, or choose **Convert > From Scanner > Manage presets**, or choose **Home > Scan > Manage presets**.
- Edit, delete and move the existing presets in the **Manage Scan Presets** dialog box.
  You can also create a preset by clicking **Create**.

Create and customize a PDF portfolio

PDF portfolios are a combination of files with different formats such as Microsoft Office files, text documents and Excel files. Foxit PhantomPDF lets you quickly create and customize a PDF portfolio.

Create a PDF portfolio

You can use Foxit PhantomPDF to quickly create a blank PDF portfolio or a new PDF portfolio from any file. After creation, you can also add more files/folders, create folders, delete files/folders and more within the PDF portfolio.

To create a blank PDF portfolio, please click **Convert > PDF Portfolio > Create a blank PDF portfolio**, or click **File > Create > PDF Portfolio > Blank Portfolio**. On the ribbon appears the **Portfolio** tab where you can change the view mode, add files from local drives or ECM (including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM), add currently open files, add folders, and create folders. By default, there are two panes in the document area. All the files are displayed in Layout view in the left pane and the Preview of the selected file is displayed in the right pane.

To create a new PDF portfolio from files, please click **Convert > PDF Portfolio > Create a new PDF portfolio**, or click **File > Create > PDF Portfolio > Portfolio**. In the pop-up
Open dialog box, select files from local drives or ECM (including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM) you want to attach to a PDF portfolio and click Open. You can also add more files or folders after creation.

Tip: To quickly add files/folders, you can also copy-and-paste or drag-and-drop files/folders to the portfolio.

When creating a new PDF portfolio (not blank), you can create a Table of Contents (TOC) which will be displayed following the cover sheet of portfolio. Before that, you need to select the Create a Table of Contents in Cover Sheet when creating a PDF portfolio option in File > Preferences > Create PDF.

The headings of the TOC generated is made up of the names of folders (including the subfolders) and files in the portfolio, arranged in an order that the files and folders are displayed in the portfolio. For a folder which is nested with multiple levels of subfolders, in the TOC the folder names are displayed up to five levels. Clicking on a file in the TOC page, you can open the file. For a PDF portfolio with TOC, if any file/folder is added or removed, you can click Regenerate TOC in the Portfolio tab to update the TOC; for a PDF portfolio without TOC, you can click Regenerate TOC to create a TOC.

Customize and modify a PDF portfolio

You can customize and modify component files and folders in the portfolio using the PDF Portfolio toolbar at the top of the files list pane in the Details view (or the left pane in the Layout view) and the Portfolio Properties dialog box as needed.

- To delete a file, select it and click the button on the PDF Portfolio toolbar, or right-click it and choose Delete.
- To extract a file from the portfolio, select it and click the button on the PDF Portfolio toolbar, or right-click the file and choose Extract from Portfolio.... Then specify the name and location of the extracted file.
- To edit the description of the portfolio, please navigate to File > Properties > Description.
- To reduce the size of PDF files in the portfolio, select one or more PDF files, right-click them and choose Reduce File Size.... In the pop-up dialog box, choose a PDF version and click OK.
- To edit the properties of the portfolio, right-click anywhere in the portfolio and choose Portfolio Properties. In the Portfolio Properties dialog box, you can:
  o Specify fields (columns) you want to show in the list of component files
and folders in the portfolio window. Select the check boxes of the fields, or click on the field names and click the Show button. The field names are displayed under the PDF Portfolio toolbar. To hide fields, unselect the check boxes, or click on the field names and click the Hide button.

- Add an optional field. Click Add, enter the field name and click OK. To delete an optional field, select the field and click Delete. The required fields such as Name cannot be deleted.
- Arrange the field order by selecting the field name and clicking Up or Down.
- Specify the order of the files and folders in the portfolio when the portfolio is opened. To do this, select a field name in the Sort By menu and then choose an order in Sort Order. By default, the component files and folders in a PDF portfolio are displayed alphabetically by filename.
- Specify the initial view of the document by choosing an option from Initial View.
- If the Portfolio Properties dialog box pops up after you right-click a component file and choose Portfolio Properties, the Show current document when opening portfolio option is available. You can select this option so that the file will be opened in the preview pane next time you open the portfolio.

**Tip:** You are allowed to drag and drop files/folders to the desired position or into a folder in the portfolio. You can do more actions by right-clicking a file in the portfolio.

### OCR PDFs and PDF Portfolios

Optical Character Recognition, or OCR, is a software process that enables images or printed text to be translated into machine-readable text. OCR is most commonly used when scanning paper documents to create electronic copies, but can also be performed on existing electronic documents (e.g. PDF or PDF portfolio).

- **Recognize text**

Foxit PhantomPDF can detect whether a PDF file is scanned or image-based and make corresponding suggestions to initiate OCR when opening a scanned or image-based PDF.

To recognize image-based or scanned text in a file, perform the following steps:

1. Click Convert > OCR > Current File, in the Select OCR Engine dialog box, specify the range you need.
2. Choose the language used in your document. You can select multiple languages as well.

3. In the output type, check **Searchable Text Image** to make the image text searchable (or check **Editable Text** to enable the image text to be edited with Foxit PhantomPDF). Click **OK** to recognize the text.

   **Note:** If you are prompted to download the OCR component after clicking **OK**, please click **Yes** to download and install it, or download it later from the link provided and install it by clicking **Install Update** in the **Help** tab. To get the full version of Foxit PhantomPDF, please [contact us](#).

4. (Optional) if you check **Find All Suspect (Show all OCR results that may need to be changed.)**, the **OCR Suspects** dialog box pops up for you to check and correct right after the recognition completes. (OCR suspects refer to the text that can hardly be recognized or may not be recognized correctly and need to be corrected manually.) How to correct OCR suspects, please refer to [Find and Correct OCR Suspects](#).

5. A recognition text process bar will pop up to show the progress.

6. Do the search function, the text on your image or scanned document will be searchable.

   **Tip:** Foxit PhantomPDF provides a **Quick OCR** command under **Home/Convert** tab to recognize all pages of a scanned or image-based PDF with default or previous settings by one-click.

To recognize text in multiple files:

1. Click **Convert > OCR > Multiple Files**.
2. In the **OCR Multiple Files** dialog box, click **Add Files** to add files, folders, or currently opened files. Use **Move up**, **Move down**, and **Remove** to adjust the order of the files.
3. Click **Output Options...**. In the **Output Options** dialog box, select the destination folder, choose how to name the new file and whether to overwrite an existing one, and then click **OK**.
4. Click **OK**. After recognition, a message box will pop up to prompt you the recognition is finished.

   **Note:**

   1. *When you are using the CJK OCR engine for the first time, the system will remind you to download and install the engine from the Foxit server.*
   2. *If there is any unsupported file added, a “Remove unsupported file(s)” button will appear in the **OCR Multiple Files** dialog box. Click the button to remove the unsupported file(s) and then continue. While recognizing a PDF portfolio, Foxit
PhantomPDF will only extract and recognize PDF files in the portfolio.

Find and Correct OCR Suspects

After recognizing image-based or scanned texts in the PDF file, you can pick out and correct the texts or characters that are uncertain as the steps below:

1. Click Convert > Suspect Results > First Suspect. A pop-up Find OCR Suspects dialog box appears and all the OCR suspects are enclosed in red boxes in the document.

2. The Find OCR Suspects dialog box shows both the original document text and the OCR text. You can edit text in the OCR text box directly if needed. If some content that is originally not text is incorrectly identified, click Not Text. Click Find Next to find the next suspect or click Accept and Find to accept the OCR text and find next.

3. (Optional) You can also directly click on the text in the document where it is incorrect and input the correct text in the OCR text box in the Find OCR Suspects dialog box.

4. Click Close to exit the Find OCR Suspects dialog box.

5. (Optional) If you choose Convert > Suspect Results > All Suspects. The OCR Suspects dialog box pops up and allows you to select and correct multiple suspect results at once, with all the OCR suspects enclosed with red boxes.
Create a table of contents from bookmarks

You may want to conveniently create a table of contents (TOC) from existing bookmarks for a hierarchy structure when viewing a PDF file. Foxit PhantomPDF offers two ways to create a table of contents. The new TOC page will be inserted in the beginning of the PDF.

- To create a TOC page when merging multiple files into a single PDF file, please select “Add a new table of contents page converted from bookmarks” in the Combine files into a single PDF dialogue box. The TOC page will be created from the bookmarks of the selected files. The original filename of each file will be the first-level heading of TOC, each of which is followed by the bookmark hierarchy of the file. The hierarchy of headings are numbered such as 1, 1.1, 1.2, 2, 2.1, 2.2, and so on. By default, the TOC includes up to 5 levels with the corresponding page numbers in the PDF. The second, third, fourth, and fifth level headings are indented. For a file without any bookmarks, only the filename will be inserted to the table of contents as the first-level heading of TOC.

- To create a table of contents in a current PDF, please select New TOC from bookmarks from the Options menu on the Bookmarks panel. Select the bookmark levels you want converted in the Add a new content of table dialog box. The TOC page will be created from the bookmarks of the current PDF, displaying a hierarchy of headings and their corresponding page numbers in the PDF. Heading levels are based on the bookmark hierarchy, with the second and
lower level headings indented. If you select **Convert all bookmark level into items in the table of contents**, the entire hierarchy of bookmarks will be converted to the headings of TOC, but the tenth and lower level headings are not indented.

## Industry Standard Validation and Creation

You can use the **Preflight** command in Foxit PhantomPDF to run a preflight inspection to analyze whether PDF documents are compliant with PDF’s standards (including PDF/A, PDF/E, PDF/X, PDF/UA, and PDF/VT) or valid for print production, and correct fixable errors in the documents. Foxit PhantomPDF allows you to view detailed preflight results and create a report in a PDF, .xml, .txt, or .html file. Foxit PhantomPDF Business also supports PDF/A, PDF/E and PDF/X creation.

### The Preflight dialog box

When you click the **Preflight** command, the **Preflight** dialog box pops up, allowing you to run a preflight inspection, fix errors in documents, view preflight results, and more. There are three tabs in the **Preflight** dialog box: **Profiles**, **Results**, and **Standards**.

### The Profiles tab

The **Profiles** tab lists groups of preflight profiles for different inspection criteria. You can expand or collapse a group to show or hide the profiles in the group. A preflight profile may include one or more checks, fixups, or both checks and fixups.
A preflight profile with available fixups has a filled-in gray wrench icon next to it and can correct the related errors in documents; for an outline of a wrench icon, no available fixups are associated with the profile. Click on a profile/check/fixup, and the description about it appears in the dialog box.

When you select a profile/check/fixup, a white heart icon appears next to it. Click on the icon to mark the profile/check/fixup as a favorite, and the icon will change to a filled-in red heart icon.

Sets of preflight profiles, checks, and fixups are organized in libraries for different workstations, functions, or workflows. At the top of the Preflight dialog box, choose a library to view the set of profiles.

There are three buttons for you to view profiles, checks, or fixups.

- The Select profiles button: click it to show a list of available profiles.
- The Select single checks button: click it to show a list of available single checks with no fixups.
- The Select single fixups button: click it to show a list of available single fixups.
Next to the three buttons is a menu. Click on the menu and select an option as needed to view all associated or your favorite items, or other categories.

Use the **Find** box next to the menu to search for a profile/check/fixup in the current library. Click the **Search all Libraries** button to search for a profile/check/fixup in all libraries.

**Display Analysis Result When you Analyze and fix**: With this option selected, if you choose **Analyze and fix**, the **Preflight** dialog box will pop up displaying the preflight results in the **Results** tab after the **Analyze and fix** process completes. This option is selected by default.

**Preflight only page**: Specify a range of pages for the preflight inspection.

**Analyze**: Click the button to run the inspection without fixing errors if any.

**Analyze and fix**: Click the button to run the inspection and fix errors if any. This button is greyed out or not available when you select a profile without available fixups or a single check.

**Fix**: If you select a single fixup, click the button to run the inspection and fix the errors if any.

**The Results tab**

The **Results** tab shows the detailed results for the preflight inspection. Different icons appear next to each item for different results:

- The green check mark : No problems were found.
- The red X error icon : Errors occurred in the check and you need to correct them before final output.
- The blue Info icon : Informs you that some mismatches were found in the check, but you do not have to correct them before final output.
- The filled-in gray wrench icon : The errors occurred in the check was fixed successfully.
- The filled-in gray wrench icon with a red X : The errors occurred in the check was not fixed successfully.

You can click **Create Report...** to save the results as a PDF, .xml, .txt, or .html file.
The Standards tab

In the Standards tab, which acts as a wizard, you can see detailed information on PDF/A, PDF/E, or PDF/X standards and follow the onscreen instructions to convert your PDFs to standard-compliant PDF files.

Run a preflight inspection

1. Open the document you want to inspect, and click Convert > Preflight.
2. In the Preflight dialog box, select a preflight profile/check/fixup and other options in the Profiles tab as needed. See also the Preflight dialog box.
3. Click Analyze, Analyze and fix, or Fix depending on what you selected in the previous step.

Tip: You can also directly double-click a preflight profile/check/fixup to run the preflight inspection. If you double-click a single fixup or a profile that contains available fixups, the fixups will be applied.

View preflight results and create reports

After running a preflight inspection, you can view the preflight results and create reports in a PDF, .xml, .txt, or .html file in the Results tab in the Preflight dialog box.

1. In the Preflight dialog box, click the Results tab to view the detailed preflight results. See also The Results tab.
2. To create a report file for the results, click Create Report....
3. In the Save As dialog box, specify the filename, file format, and location for the report file.
4. (Optional) When you create a PDF report, you can click Settings in the Save As dialog box to select more options for the report. In the pop-up Create Report dialog box:
   - Overview: select it to summarize the preflight inspection and results in a short report that includes the applied preflight profile and fixups, a results summary, document information, and more.
   - Details: select it to report additional information about each problem, such as the location of the problems. Select Problems Highlighted By Transparent Masks to place a colored mask over the problem areas to highlight the areas. Select Problems Highlighted By Layers to show the file separated into layers of mismatches and layers of other found objects according to the criteria used in the profile itself.
5. Click **Save**.

**Convert PDFs to standard-compliant PDFs (Business Edition only)**

With Foxit PhantomPDF Business, you can convert PDFs as PDF/A, PDF/E, or PDF/X files if they are compliant with the specified requirements. There are three methods you can use to convert PDFs to standard-compliant PDFs: the **Standards** wizard (i.e. the **Standards** tab in the **Preflight** dialog box), a preflight profile, and the **Save As** command. The **Standards** wizard contains detailed information on PDF/A, PDF/E, or PDF/X standards and you can follow the onscreen instructions to complete the conversion. If you are familiar with standards, you can use the other two methods.

**Convert to PDF/A, PDF/E, or PDF/X using the Standards wizard**

1. Click **Convert > Preflight**.
2. Click the **Standards** tab in the **Preflight** dialog box.
3. Select the standard you want to convert to, and click **Continue**.
4. Select a desired version of the selected standard, and click **Continue**. (Or click **Back** to return to the previous step.)
5. Select other options as appropriate, and click **Save as...**. (Or click **Back** to return to the previous step.)
6. Specify the filename and location for the output file and click **Save** in the pop-up **Save As** dialog box.

If the conversion succeeds, a green check mark appears at the top of the **Results** tab in the **Preflight** dialog box, with detailed information below; if the conversion fails, a red X appears with the detailed information in the **Results** tab of the **Preflight** dialog box.

**Convert to PDF/A, PDF/E, or PDF/X using a preflight profile**

1. Click **Convert > Preflight**.
2. Click the **Profile** tab in the **Preflight** dialog box.
3. Choose the profile you need from the compliance profile groups, and click **Analyze and fix**.
4. Specify the filename and location for the output file and click **Save** in the pop-up **Save As** dialog box.
Chapter 4: Create

If the conversion succeeds, a green check mark appears at the top of the Results tab in the Preflight dialog box, with detailed information below; if the conversion fails, a red X appears with the detailed information in the Results tab of the Preflight dialog box.

**Convert to PDF/A, PDF/E, or PDF/X using the Save As command**

1. Click File > Save As.
2. In the Save As dialog box, select PDF/A, PDF/E, or PDF/X from the file types. Optionally, click Settings... to select more options for the conversion.
3. Specify the filename and location for the output file and click Save.

If the conversion fails, a message pops up telling you the generated document is not compliant with the selected standard and you can use the Preflight command to identify the problems that prevent the document from being compliant.

**The Standards panel in the navigation pane**

When you open a PDF file that conforms to PDF/A, PDF/E, PDF/X, or PDF/UA standard, the Standards panel icon automatically appears on the left side of the navigation pane, giving you a quick way to view the standards information of the PDF. You can choose View > Navigation Panels > Standards or click in the navigation panel to open the Standards panel. In the Standards panel, you will find the following information:

- **Conformance**: shows the standard used to create the file, the ISO name, and whether the file has been verified as standard compliant. If the file has not been verified yet, you can click Verify Conformance in the Standards panel to start the conformance verification. If the verification fails, click Open Preflight under the standards information in the Standards panel to open the Preflight dialog box to run preflight inspections as needed. See also the Preflight dialog box.

- **OutputIntent**: indicates the color settings associated with the file.
Chapter 5 – Edit

Foxit PhantomPDF provides not only general editing features to create bookmarks, add links, attach files, add images, play and insert multimedia files on PDF files, but also advanced editing features to select, insert, modify, remove and rotate texts, images, graphics and shadings. You can go to the Edit tab directly to use different editing features to easily and efficiently change contents in any existing PDF files.

Right-click any PDF file and choose Edit with Foxit PhantomPDF, then the PDF will be opened with the toolbar automatically navigating to the Edit tab, ready for your editing.

Undo and Redo

When making quick adjustments to your document, you may want to undo or redo the most recent action performed. You can undo and redo up to 10,000 actions in Foxit PhantomPDF.

Undo your last action

- Click Undo on the Quick Access toolbar of Foxit PhantomPDF window.
- Press Ctrl + Z.

Note: Some actions can't be undone, such as clicking any command on the File menu. If you can't undo an action, the Undo command will be grayed out.

Redo actions

- Click Redo on the Quick Access toolbar of the Foxit PhantomPDF window.
- Press Shift + Ctrl + Z.

Links

This function helps you to lead the readers to related articles, references, or the intended web page. If you are reading a PDF file which contains text that links to a webpage, you will see the URL address displayed when you hover your mouse over
the text. When you right-click on the linked text with the Hand command selected, you can choose to open the linked web page, copy the URL address, or convert the linked web page to PDF.

You can also add links in PDF files with Foxit PhantomPDF. Generally speaking, there are three commands of links for you: Link, Web Links, and Bookmark in Foxit PhantomPDF.

**Link**

**Add a link**

The Link command enables you to add a link with the shape of rectangle on the PDFs.

To add a rectangle link, please do the following:

- Choose **Edit > Link**.
- Position the cursor on the place you want to add the link, hold and drag your mouse button to draw a rectangle. (*Tip: In a tagged PDF, you can create a link directly from selected text by right-clicking the selected text and choosing Create Link... from the context menu, with the link tag automatically created at the same time.*)

*Tip: To draw a square link, press Shift key when you hold and drag your mouse button.*

- Pops up the **Create Link** dialog box. Specify the appearance and destination of the link.

  - **Appearance**

    A. Thickness – the thickness of the four sides of the rectangle. The higher of the value, the thicker of the sides. You can choose the thickness from 0-12, while the default is 1.
    B. Border Style – the style of the rectangle's border. There are three types of the border styles:

      * **Solid**: the border is solid, but not hollowed out.
      * **Dashed**: the border is drawn as a dashed line.
      * **Underline**: the sides are visible except the underline.
Solid Style  Dashed Style  Underline Style

Three types of border style

C. Highlight - the effect when you click the rectangle link. There are four types of the highlighting effects:

**None:** doesn’t change the appearance of the link.

**Invert:** changes the link’s color to its opposite.

**Outline:** changes the link’s outline color to its opposite.

**Inset:** creates the appearance of an embossed rectangle.

None  Invert  Outline  Inset

Four types of highlight

D. Color - the border color of the rectangle. Click the color button to choose any colors you like, or you may choose Other Color to add a customized color. The default color is red.

• **Destination**

The destination refers to any point or location, for example, a web page, a named file or position the link goes to. There are four options for you to choose:

A. Go to a page view – designate the link to a specific page view. Not only can you designate the link to a page in the current PDF, but you can also set the link to the page in another PDF. Also, you may change the current zoom setting and then set the position.

To go to a page view, choose this option, click the **Next** button and do one of the following:
Set the position in current document – scroll the current document, go to a new position where you want to set and click **Set this position**.

Set the position in a local PDF document – click the **Open** button 📖 on the Quick Access toolbar of the application window > select the PDF you want to set position to > scroll this document and go to a position where you want to set > click **Set this position**.

Set the position in a PDF file attachment – open the PDF file that contains PDF file attachments > click the Attachments icon in the Navigation pane to open the Attachments panel > open the file attachment by double click > scroll through the file attachment and go to a position where you want to set > click **Set this position**.

**Note:**

1. *The new PDF document should be opened in a new tab in the existing window but not a new window.* While setting the position, you can press `Ctrl + mouse scroll` to change the page magnification. Before setting the position, you can click **Cancel** to cancel your operation, if necessary.

2. *The linked local PDF documents are saved in your local disks.* You need to send the parent PDF document and the linked documents to users to ensure that the linked documents can be opened. However, the linked PDF file attachments are always saved with the PDF document.

Change the view magnification -- scroll in the current document or another document > go to a new position where you want to set > change the magnification of the position > click **Set this position**.

Click **Cancel** to cancel out of your operation.

B. Go to a named position – designate the link to a named position that has been set by the creator of the current document.

To go to a named position, choose this option and click the Next button > select a named position for the pop-up list > click **OK**.

**Note:** *An empty pop-up list indicates that no position has been named by the document’s creator.*

C. Open/execute a file – designate the link to open another file. To do this, please follow the steps below:

Choose **Open/execute a file** > click the **Next** button > select the destination file and click **Select**.
D. Open a web page – designate the link to open a web page. Do the following:

✧ Choose **Open a web page** > click the **Next** button > enter the URL of the destination web page or click the drop-down button to select a web site you have opened before.

E. Others (use action property page) – add an action to the link. Please refer to “Actions tab for the button properties” for more details.

**Move or resize a link**

You can move and resize the link after you create it.

- Select one of the link commands or the Select Annotation command [Select Annotation], and then move the cursor over the link until the cursor turns into an arrow [Link Arrow].
- Then do one of the following:
  
  A. To move the link, drag it to the desired area.
  B. To resize the link, drag any corner point to adjust.

**Delete a link**

- Select the Link command or the Select Annotation command [Select Annotation], and then move the cursor over the link until the cursor turns into an arrow [Link Arrow].
- Select the link you want to delete.
- Press the **Delete** key.

**Web Links**

Foxit PhantomPDF allows users to check URLs in the PDF document automatically and add link annotations directly to the related URLs.

**Create web links from URLs**

To create web links, please do as following:

1. Click **Edit** > **Web Links** > **Create links from URLs** [Create links from URLs]. A message box will pop up to prompt you whether to proceed because the operation cannot be undone. Click **Yes**
Chapter 5: Edit

To continue.

2. In the pop-up **Create web links** dialog box, choose **All** to create links from all URL in the document, or choose **From ...To** and enter a page range to create links on selected pages. Click **OK**.

3. A message box will pop up to prompt you how many web links were added to the document.

**Remove all web links**

To remove all web links, choose **Edit > Web Links > Remove all links**  

**Append all web links on the current page**

You can download all web links on the current page and convert the linked web pages to PDF pages that will be appended to the end of the current PDF. This feature is helpful when some of the content in the linked web pages is not accessible for visually impaired users.

To append all web links on the current page, choose **Edit > Web Links > Append All Web Links on Current Page**. The converted pages are appended to the end of the current PDF. By default, only one level of the linked websites is converted to PDF pages with bookmarks created. The created bookmarks are named with the domain names of the web pages. If the web pages share the same domain name, sub-bookmarks will be created and named with the page titles. Please note that after conversion the downloaded links in the document will change to internal links that will jump to the converted pages in the document when you click them.

**View all web links on a page**

You can not only view all web links on a page, but also download selected links to convert the linked web pages with custom settings to PDFs that will be appended to the end of the current PDF.

1. Choose **Edit > Web Links > View Web Links**. In the pop-up dialog box, you can view all web links in the current page.
2. Choose a link and click **Properties...** to customize conversion settings. See also **Create a PDF from Web Page**.
3. (Optional) click **Select All** to select all web links in the dialog box, or click **Clear All**
to unselect them.
4. Select the links you want to download, and click **Download**. Then a progress dialog box pops up.
5. After the downloading completes, you can see the linked web pages are successfully converted and appended to the end of the current document. Please note that after conversion the downloaded links in the document will change to internal links that will jump to the converted pages in the document when you click them.

### Web links in a PDF opened with PhantomPDF within a web browser

When you open a PDF document with PhantomPDF within a web browser, right-click the web link in the document and choose an option from the context menu:

- **Open Weblink in current Tab**: directly open the link in the current tab in the web browser.
- **Open Weblink in a new Tab**: open the link in a new tab in the web browser.
- **Copy Link Location**: copy the link address to the clipboard.

### Bookmarks

Please refer to [Bookmarks](#).

#### Bookmarks

Bookmarks are navigational tools that make your PDF files easier to read. They are usually generated automatically during the PDF creation.

Bookmarks are useful for users to mark a place in a PDF file so users can return to it with ease. Or you may like to have your own bookmark structure and new bookmark names. With Foxit PhantomPDF, you can easily nest, edit, or delete bookmarks in a PDF file if the security settings allow.

### Add a bookmark

1. Go to the page where you want the bookmark to link to.

2. (Optional) If there is no bookmark in the document, click **Edit > Bookmark**, or
click the New Bookmark icon at the top of the Bookmarks panel.

3. Select the bookmark after which you want to place the new bookmark. If you don't select a bookmark, the new bookmark is automatically added at the end of the bookmark list. Click Edit > Bookmark, or click the New Bookmark icon at the top of the Bookmarks panel, or right-click the selected bookmark and choose Add Bookmark.

4. Type or edit the name of the new bookmark, and press Enter.

**Tip:** To add a bookmark, you can also right-click on the page where you want the bookmark to link to and choose Add Bookmark. Before this, if you have chosen an existing bookmark (if any) in the Bookmarks panel, the newly added bookmark will automatically be added right behind the existing bookmark (in the same hierarchy); if you haven't selected any existing bookmark, the new bookmark will be added at the end of the bookmark list.

### Add tagged bookmarks

If your document is a tagged PDF document, you can add bookmarks from the structural information of the document elements (such as headings and paragraphs), which will help you easily navigate and work on the document. You can create a tagged PDF from a document that can be structured in its authoring application (such as Microsoft Word); but if you do not have access to an authoring application, you can tag a PDF any time with Foxit PhantomPDF. See also [Tagged PDF](#).

To add tagged bookmarks, do as the following:

1. Go to the Bookmarks panel in the navigation pane.
2. Click the Options menu and choose New Bookmarks from Structure.... If your document is not a tagged PDF, the option is greyed out and not available.
3. In the pop-up dialog box, select the structure element you want to create tagged bookmarks from. To select multiple elements, Ctrl-click or Shift-click the elements you need; to select all elements, click the Select All button in the dialog box. To unselect all the elements you selected, click Clear All.
4. Click OK. Then the tagged bookmarks are created and nested under a new bookmark named “Untitled” by default.

**Tip:** For tagged bookmarks, you can extract the corresponding pages in the PDF to generate a new PDF document, or remove the corresponding pages from the PDF. Please do as the following:
1. In the **Bookmarks** panel, select the target bookmark(s).

2. Click the **Options** menu and choose **Extract Page(s)/Delete Page(s)**, or right-click the selected bookmark and choose **Extract Page(s)/Delete Page(s)**.

3. If you choose **Extract Page(s)** in Step 2, a new PDF is created from the extracted pages and opened in PhantomPDF. The new document is named “Extracted pages from [original document name].pdf”. You can rename and save it manually.

4. If you choose **Delete Page(s)** in Step 2, a dialog box prompts to tell you the operation cannot be undone. Click **OK** and the corresponding pages are removed from the PDF.

### Edit a bookmark

In Foxit PhantomPDF, you are able to rename a bookmark, reset a bookmark's destination, or customize the text appearance of a bookmark with ease if the security settings allow.

✧ **To rename a bookmark**

Right-click the bookmark you want to rename in the Bookmarks panel > Rename > type the new bookmark name. Or you double click the bookmark you want to rename and then type the new name.

✧ **To reset a bookmark’s destination**

- In the document pane, move to the location you want to specify as the new destination.
- (Optional) Adjust the view magnification.
- Right-click the bookmark, choose **Set Destination**, and select **Yes** in the pop-up dialog box. If you do not want to see the dialog box the next time you reset a bookmark’s destination, select the **Don’t show again** option in the dialog box.

✧ **To customize the text appearance of a bookmark**

- In the **Bookmarks** panel, click on a bookmark to select one bookmark, press Ctrl/Shift + click to select multiple bookmarks, or press Ctrl + A to select all the bookmarks.
- At the top of the **Bookmarks** panel, click the **A** or **A** icon to enlarge or reduce the text size of all the bookmarks.
- Right-click the selected bookmark and choose **Properties**.
- In the Bookmark Properties dialog box, click the Appearance tab, and select the font style and color for the text.
Note: After defining a bookmark’s appearance, you can set it as bookmarks’ default property by right-clicking the bookmark and then selecting the option of Use Current Appearance as New Default.

✧ To add an action to a bookmark

- Right-click a bookmark, and choose Properties.
- In the Bookmark Properties dialog box, click Actions.
- Choose an action from the Select Action menu and click Add, and then refer to the section of “Actions tab for the button properties”.

✧ To delete a bookmark, please do one of the following:

- Select the bookmark you want to delete and click the Delete button at the top of the Bookmarks panel. (Ctrl-click to select more than one bookmark. To select a continuous group of bookmarks, click one bookmark, then hold the Shift key and click the last bookmark.)
- Right-click the bookmark you want to delete and choose Delete.

Note: Deleting a bookmark deletes all the bookmarks that are subordinate to it.

Move a bookmark

Select the bookmark (named “Bookmark A”) you want to move, and then do one of the following:

- Hold the mouse button down and then drag “Bookmark A” icon directly to the desired place. The Line icon shows the place where the icon will be located.
- Right-click “Bookmark A” icon and choose the Cut option > right-click the bookmark(named “Bookmark B”) under which you want to place “Bookmark A”, choose “Paste after Selected Bookmark” if you want to put “Bookmark A” after “Bookmark B”, which will be in the same hierarchy with “Bookmark A”; or choose “Paste under Selected Bookmark” if you want to put “Bookmark A” under the “Bookmark B”, which will be the parent bookmark.

Note:

1. The bookmark links to its original destination in the document although it is moved.
2. You can press Shift or Ctrl + Click to select multiple bookmarks at once, or press Ctrl + A to select all bookmarks.
Organize a bookmark hierarchy

A bookmark hierarchy is an outline or stratified structure that places some bookmarks within others. In Foxit PhantomPDF, multilevel bookmark hierarchy can be defined by properly dragging the bookmark icon in the Bookmark panel.

To nest a bookmark or move a bookmark out of nested position, please refer to Move a bookmark.

To expand or collapse a bookmark

In a bookmark hierarchy, to expand a bookmark (a parent bookmark with child bookmarks) and show the child bookmarks, directly click the plus sign (+) next to the parent bookmark. Click the minus sign (-) to collapse the parent bookmark and hide its child bookmarks. To collapse all bookmarks, right-click any bookmark in the Bookmarks panel (or click the Options menu at the top of the Bookmarks panel) and choose Expand/ Collapse All Bookmarks. When no bookmarks are expanded in the Bookmarks panel, you can right-click any bookmark (or click the Options menu at the top of the Bookmarks panel) and choose Expand/ Collapse All Bookmarks to expand all bookmarks.

Page thumbnails

Page thumbnails, which are miniature portraits of pages in a document, are displayed in the Pages panel in the Navigation pane. Clicking on a page thumbnail takes you to the corresponding page in the document. Page thumbnails are useful for performing whole-page operations such as reorganizing PDF pages. For more information, please refer to Chapter 6 – Organize.

You can also resize, embed, and unembed thumbnails.

Resize page thumbnails

You can click the Pages panel in the Navigation pane to view the page thumbnails. To resize a page thumbnail, do either of the following:

- Right-click any thumbnail and choose Enlarge Page Thumbnails or Reduce Page Thumbnails.
• Click the or icon at the top of the Pages panel to enlarge or reduce page thumbnails.

Note: Page thumbnails revert to their default size if you close and reopen the PDF document.

**Embed page thumbnails**

By default, in an opened PDF document, you can see the page thumbnail in the Pages panel in the Navigation pane. These page thumbnails are created on-the-fly whenever you open the Pages panel. For large documents, generating the page thumbnails can take several seconds.

Embedding page thumbnails into the document makes them appear faster, but increases the file size. Page thumbnails are not embedded by default. To embed page thumbnails, do as the following:

1. Right-click any thumbnail and choose Embed All Page Thumbnails….
2. Click OK in the pop-up message box.
3. Save the file.

**Remove embedded page thumbnails**

You can remove the embedded page thumbnails from the document, which reduces the file size of the document.

1. Right-click any thumbnail and choose Remove Embedded Page Thumbnails….
2. Click OK in the pop-up message box.
3. Save the file.

**Destinations**

When creating a link in a PDF, you can link to a specified destination in the document. With Foxit PhantomPDF, you can create and manage destinations in the Destinations panel in the navigation pane.

**Create and link a destination**

1. Navigate to the location in the document you want to set as the destination.
2. In the Destinations panel, click the Create new destination icon or choose the...
New Destination command from the Options menu. Name the destination.

3. Save the document.

4. Create a link in the document with the Link command under the Edit tab. In the Create Link dialog box, select Go to a named position and click Next....

5. Select a position from the list in the pop-up Go to a named position dialog box, and click OK.

6. Save the document.

Manage destinations

You can sort, change, and delete destinations in the Destinations panel.

Sort destinations

To sort destinations, choose Sort by Name or Sort by Page from the Options menu in the Destinations panel.

Change destinations

To move to the target location, double-click the destination. Or right-click the destination and choose Go To Destination.

To reset the location of the destination, navigate to the desired location, right-click the destination and choose Set Destination.

To rename a destination, select the destination, click on the name of destination and type a new name. Or right-click the destination and choose Rename.

Delete destinations

To delete a destination, right-click a destination and choose Delete. Or choose the destination and press Delete on the keyboard.

File Attachments

You can attach PDF files and other types of files to a PDF. There are two options for you to add an attachment: attaching a file as a comment and attaching a file to the entire PDF. An attached file as a comment will appear in the page with the File
Attachment icon  by default, while the attached file to the PDF file acts invisible and only can be seen when you click the Attachment panel in the navigation pane.

**Add a file as a comment**

1. Choose **Comment > File**.
2. Position the cursor to the place where you want to attach a file as a comment > click the selected position.
3. In the Open dialog box, select the file you want to attach, and click **Open**.
4. The File Attachment Icon appears at the place you designated in the PDF file.

**Work on the attachment comment**

You can open the attachment, add a description, move and delete it, and set the preferences.

✧ **Open an attachment**

Select the Hand command or the Select Annotation command and do the following:

1. Double-click the File Attachment icon.
2. In Open file attachment dialog box, select one of the three options and click **OK**.
   
   A. Open the file attachment – open this file attachment and the dialog box will always pop up when you double-click the File Attachment icon.
   B. Always open file attachments of this type – open this file attachment and the files of this type will be opened automatically when you double-click the File Attachment Icon next time.
   C. Never open file attachments of this type – forbid to open the file attachments of this type. Whenever you double-click the File Attachment Icon, the files of this type will be forbidden to open and you'll be prompted that “File attachment of this type cannot be opened because of your security settings”.

**See also** "Doing security settings".

**Note:** If you are in **Safe Reading Mode**, a dialog box will pop up when you open an attachment. Check **Disable Safe Reading Mode and Open file**, and then double click the **File Attachment icon** to open the attached file.
Move a file attachment icon

Select the Hand command or the Select Annotation command, click and drag the File Attachment Icon to move it to other place.

Delete an attachment comment

Select the Hand command or the Select Annotation command, and do one of the following:

- Right-click the File Attachment icon and choose Delete.
- Click the File Attachment icon and press Delete key.

More options with an attachment comment

You are able to work on an attachment comment just like an ordinary comment, including setting status, marking with checkmarks, opening pop-up notes and adding some descriptions, replying to the comment, and changing the icon's appearance. For all the operations, please refer to “Chapter 7 – Comment”.

Add a file to the entire PDF as an attachment

1. Click the attachment button on the navigation pane and click Add button, or choose Edit > File Attachment.
2. In the File Attachment dialog box, click the Add Files... button. Choose Add Files... or Add Folder... to select the files or folders you want to attach. If choosing Add Files..., in the Open dialog box, you can navigate through your local disk to select local files or click Open from ECM to select files from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM, and click Open.
3. Click OK after adding the desired files.
4. The added document will be displayed in the attachment panel.

Tip:

1. An easy method to add a file attachment to PDFs, you can just drag and drop the file you want to attach to the attachment panel. Foxit PhantomPDF will pop up a window to ask you whether to attach the selected file to current PDF document. Click OK to complete the operation. Check “Always attach file when dragging files to the attachment
panel" option and the next time the file will be attached directly without this pop-up window.

2. Save the document after adding file attachments, and a red dot appears on the icon of the attachment panel in the navigation pane.

✧ **Work on the attachments**

You can open, save, edit descriptions, delete and do settings to the attachments. Click the attachment button on the navigation pane > Open button /Save button /Add button /Edit Description button /Settings /Delete button.

✧ **Security settings**

To change the security settings you have set when you open the attachment file as a comment, Click the Settings button in the Attachment Panel and do one of the following:

- To add a new extension, click the Add button to input the file extension in the Security Settings dialog box.
- To delete an extension, click one of the existing extensions and click the Delete button.
- To change the settings of how to open the attachments of the type, choose one of the three options listed.

**Images**

You can specify a rectangle on any part of a PDF page and then insert an image into that rectangle. This feature is helpful when you want to explain or show something more dynamically.

**Add an image**

You can add an image to a PDF with the Image Annotation command . After you insert a new image, you can adjust its size and position, change the appearance and other settings, etc.

To add an image, do the following:
• Choose **Edit > Image Annotation**.

• Drag a rectangle on the page to define the canvas area for the image.

• In the Add Image dialog box, click the **Browse** button to select the image that you want to insert and click the **Open** button. You will see the URL of this image has been added to the Location field.

• Click the **Advanced...** button to edit the setting of the image.

  A. When to scale – choose when to scale the image you insert.

  B. Scale – choose to scale the image non-proportionally or proportionally. This option will be disabled when you select **Never** in the field of **When to scale**.

  C. Border – drag and move the scroll bar to change image's position in the rectangle. The coordinates change when you move the scroll bar.

• Click **OK** for your changes to take effect, or click **Reset** to reset the data to the original settings.

• Click **OK**.

**Apply an image to other pages**

After adding an image, you may want to place the same image on additional pages while maintaining the original location and settings.

To apply an image to other pages, please do the following:

1. Right click on the image you wish to apply to other pages.
2. Choose the option **Place on Multiple Pages** in the menu.
3. Specify the page range.
4. Click **OK**.

**Move and resize an image**

To move an image, please do the following:

1. Select the Select Annotation command or the Image Annotation command, put the cursor over the image and the cursor changes into an arrow.
2. Click and drag the image to another place you like.
To resize an image, please do the following:

1. Select the Select Annotation command or the Image Annotation command, put the cursor over the image and the cursor turns into an arrow, and then click the image.
2. Place the cursor on any corner point. The cursor changes into the cursor showing the direction at which the rectangle will be resized.

![To resize the image]

3. Drag the cursor outside, it will increase the size of the rectangle proportionally. Drag the cursor inside and it will decrease the size of the rectangle proportionally.

**Set properties of an image**

1. Double-click the image or right-click it and select Properties.
2. In the Appearance tab, do any of the following:

   - **Annotation is hidden from view** – The image annotation will be invisible in Hand command mode.
   - **Border** – Select the border width of the image and the border’s style and color.
   - **Locked** – When selected, prevents any further changes to any image properties.
   - **Close** – Applies and saves the current properties, and closes the image properties dialog box.

3. In the Settings tab, follow the steps in “To add an image”.
4. For the Actions tab, please refer to “Actions tab for the button properties”.

**Delete an image**

1. Select the Select Annotation command or the Image Annotation command
Arrange images

When you select one or more images with the Select Annotation command or the Image Annotation command, the Arrange context tab appears on the ribbon automatically. To select multiple images, do as the following:

1. Select the Select Annotation command or the Image Annotation command.
2. Press and hold Shift or Ctrl and click the images you want to edit.

**Note:** When you right-click or Ctrl-click one of the selected images, it will be highlighted in red, indicating that it's the anchor image.

Align images

- Select two or more images that you want to align.
- Select a type of alignment in the Arrange context tab, or right-click the anchor image and choose Align. Then choose a type of alignment.
  - A. To align a column of images, choose Left, Right, or Vertically to align them respectively to the left edge, right edge, or vertical axis of the anchor image.
  - B. To align a row of images, choose Top, Bottom, or Horizontally to align them respectively to the top edge, bottom edge, or horizontal axis of the anchor image.

**Note:** The alignment commands move the other selected images to line up with the edges of the anchor image.

Below is an example:
Center images

This function enables you to center the selected images as a whole vertically, horizontally, or both. To center the selected images, select a type of centering from the Arrange context tab, or right-click the anchor image > Center > choose a type of centering.

Below is an example:

1. Suppose that you want to set A as the anchor image.

2. Select these two images > right-click A and choose Align > Left. You will see the other image is placed to the left edge of A.
1. Select two images. (Imagine the selected images are enclosed by a rectangle.)

2. Right-click one of the images > Center > Vertically. You will find that the selected images are centered vertically as a whole in the page.

**Distribute images**

This function will be available when selecting three or more images.

- To distribute the images evenly between the topmost and bottommost images, click Arrange > Vertically in the Distribute group.
- To distribute the images evenly between the leftmost and rightmost images, click Arrange > Horizontally in the Distribute group.

Below is an example:
1. Select three images A, B and C. A is the topmost image and C is the bottommost image.

2. Right-click any one of the images > Distribute > Vertically. And you will see that B is distributed evenly between A and C.

**Resize multiple images**

You can adjust multiple images with the same height, width, or both. Select one of the images as the anchor, and the rest of the images will be resized with the same height or width as that of the anchor image.

Below is an example:
Setting properties of multiple images

- Select multiple images > right-click one of them > Properties...
- A dialog pops up with an Appearance tab. Follow the steps specified in “Setting properties of an image”.

PDF Optimizer

With PDF optimizer, users can update the PDF version and reduce file size by compressing contents, unembedding fonts, and clearing out the data redundancy of PDF objects. Users can optimize PDFs with custom advanced settings, or reduce file size quickly with the default settings.
**Note:** During the optimization, PDF Optimizer doesn't optimize file attachments in the document, including attachments added to the PDF as comments.

**Reduce file size with default settings**

You can use the **Reduce File Size** command to quickly optimize documents with the default settings, which are suitable for a wide range of documents. With this command, you can also reduce file size for multiple files at the same time. To reduce file size with default settings, do as the following:

1. Choose **File > PDF Optimizer > Reduce File Size**.
2. To apply the settings to the current file, choose **Current File**. A dialog box pops up. For **PDF Version Compatibility**, choose **Retain existing** to keep the current PDF version, or choose a desired PDF version from the drop-down menu. Then click **OK**.
3. (Optional) To apply the settings to multiple files, choose **Multiple Files**. In the pop-up dialog box, click **Add Files** to add files, folders, or currently opened files. *(Tip: You can also add files by dragging and dropping the PDF files you want to optimize to the box.)* Use **Move up**, **Move down**, and **Remove** to adjust the order of the files. Click **Output Options...**, and the **Output Options** dialog box pops up where you can select the destination folder and choose how to name the new files and whether to overwrite existing ones. Then click **OK** to start the optimization.
4. Specify the file name and the location to save the optimized file in the pop-up dialog box. Then click **Save** to start the optimization.

**Advanced optimization**

With the **Advanced Optimization** command, you can select professional settings to achieve advanced PDF optimization. To optimize PDF with advanced settings, please do as the following:

1. Choose **File > PDF Optimizer > Advanced Optimization > Advanced Optimization**.
2. The PDF Optimizer dialogue box pops up.
3. Click **Audit space usage** to see the space usage of the current PDF file and then you can decide which items are needed to be optimized.
4. In **Make compatible with**, select a PDF version to save the current file under. The settings available in the following steps vary from different PDF versions.
5. Select the check box next to an item on the left and do the corresponding settings as needed on the right. If you deselect the check box for an item, all the settings associated with the item will not be applied. For the detailed options in each item,
please refer to Advanced optimization options.

6. Click OK and save the optimized PDF file. Or, you can discard all the settings above and revert to the original default settings by clicking Restore Default.

Advanced optimization options

There are five panels where you select advanced options for PDF optimization: Compress Images, Unembed Fonts, Discard Objects, Discard User Data, and Clean Up.

✧ The Compress Images panel

In the Compress Images panel, you can select options to specify downsampling and compression for color, grayscale, and monochrome images.

Downsample: Select a downsampling method, and set the appropriate image resolution values. For images with higher resolution than the For Images Above value you input, reduce the image resolutions to the specified resolution by merging pixels in a sample area of the image to make one larger pixel.

◆ Off – Turn off downsampling.
◆ Average Downsampling - Average the pixels in a sample area and then substitute the entire area with the average pixel color at the resolution you specified.
◆ Subsampling - Select a pixel from a sample area and then substitute an entire area with the selected pixel at the specified resolution. This method reduces conversion time as compared with downsampling, but the generated images are less smooth and continuous.
◆ Bicubic Downsampling - Use a weighted average, instead of a simple average (as in Average Downsampling) to decide pixel color. This method increases conversion time but produces the smoothest tonal gradations.

Compression: Reduces file size by removing unnecessary pixel data. You can specify a compression standard to process images. Generally, apply ZIP, JPEG, or JPEG 2000 compression to color/grayscale images, and ZIP, JBIG2, CCITT Group 3 or 4, or Run Length compression to Monochrome images. You can make your choices by following these rules:

- JPEG and JPEG 2000 compression give better results on images like photographs with gradual transitions from color to color. JPEG 2000 produces a higher quality final image, even when using lossy compression.
- Because JPEG compression eliminates data, it can achieve much smaller file sizes than ZIP compression.
- ZIP is the better choice for illustrations with large areas of single colors or
repeating patterns, and for monochrome images that contain repeating patterns.

- **CCITT (Consultative Committee on International Telegraphy and Telephony)** compression is available only for monochrome bitmap images. CCITT Group 4 is a general-purpose method that produces good compression for most monochrome images. CCITT Group 3, used by most fax machines, compresses monochrome images one row at a time.

- **JBIG2 (Lossless)/ JBIG2 (Lossy)** is appropriate for bi-level or monochrome images which is suitable for lossless or lossy compression. For monochrome images, JBIG2 compression is superior to CCITT.

- **Run Length** produces the best results for images that contain large areas of solid white or black.

- **High Compression** applies to almost all images. If you intend for small-size images and don't care about the quality, High Compression can produce smaller images than other compression methods do. (Available in Business Edition Only)

**Tile Size:** Divides the image being compressed into tiles of the specified size. (If the image height or width is not an even multiple of the tile size, partial tiles are used on the edges.) Image data for each tile is individually compressed and can be individually decompressed. The default value of 256 is recommended. This option is available only for JPEG 2000 format.

**Quality:** Available only for JPEG compression, JPEG 2000 compression, High Compression, and JBIG2 compression. You can apply JPEG compression, JPEG 2000 compression, or High Compression to color and grayscale images at various levels (Minimum, Low, Medium, High, Maximum). JPEG and JPEG 2000 compression methods are typically lossy, which permanently remove some pixel data and may reduce image quality. JPEG 2000 compression also offers lossless compression which means no pixel data is removed. Compression for monochrome images is lossless, except for JBIG2 compression, which provides both lossy and lossless compression.

**Optimize images only if there is a reduction in size:** With the option selected, images will not be optimized if there are no reductions in file size from the image setting.

- ✧ **Unembed Fonts**

Embedding all fonts allows anyone who opens your file to see the document as you intended it to be seen. Without embedding fonts, the PDF viewer will substitute a font with a close match or a default font which is available on the computer, and the display results may be not exactly what you intended. If you don't mind the difference and prefer a smaller file, you can unembed fonts.
This panel contains two lists for fonts: fonts that are available for unembedding, and fonts to unembed. To unembed fonts in a document, do as the following:

1. Select the checkbox for the panel first.
2. Select one or more fonts you want to unembed in the Embedded fonts list, and click the Unembed>> button to add the fonts to the Fonts to unembed list.
3. (Optional) To remove the added fonts from the Fonts to unembed list, select the font and click the <<Retain button. If you don't want to unembed any font in the document, select Do not unembed any font.

Discard Objects

The Discard Objects panel lists options that allow you to remove objects from the PDF.

Discard all form submission, import and reset actions: Disables all actions related to submitting/importing form data and resetting form fields. This option retains form objects to which actions are linked.

Flatten form fields: After flattening, all form fields can no longer be filled or modified. Only the items that are visible with Hand command selected remain and change into shape objects.

Discard all JavaScript actions: Removes all actions in the PDF that use JavaScript. This option is selected by default.

Discard all alternate images: For an image that includes multiple versions, removes all versions except the one used for on-screen viewing. Different versions may be used for different purposes, such as low-resolution on-screen viewing and high-resolution printing.

Discard embedded page thumbnails: Removes page thumbnails embedded in the document. See also Embed page thumbnails.

Discard document tags: Removes all tags from the document, which will have an impact on the document accessibility. See also the Accessibility chapter.

Detect and merge image fragment: Detects image fragments in the document, and merge the adjacent image fragments with the same image properties into an image object if the number of fragments is more than 25.

Discard embedded print settings: Removes print settings embedded in the PDF, such as page scaling and duplex mode.
Discard embedded search index: Removes the search indexes embedded in the document.

Discard bookmarks: Removes all bookmarks from the document.

Discard User Data

This panel allows you to specify whether to remove personal information including comments, attachments, layers, and document metadata.

Discard all comments, forms and multimedia: Removes all comments, forms, form fields, and multimedia from the document.

Discard external cross references: Removes links to other documents, not including the links that go to pages within the PDF.

Discard document information and metadata: Removes data in the document information dictionary and all metadata streams, such as the information in the File > Properties > Description.

Discard file attachments: Removes all file attachments, including the attachments that are added to the PDF as comments.

Discard private data of other applications: Removes the information in PDF documents that is related only to the application that created the PDF documents.

Discard hidden layer content and flatten visible layers: Remove all layers’ information. All layers in the Layers panel will be removed.

Clean Up

Use the Clean Up panel to remove useless items (obsolete or unnecessary elements) from the document. Removing certain elements can seriously affect the functionality of the PDF. By default, only elements that do not affect document functionality are selected.

Use Flate to encode streams that are not encoded: Applies the Flate compression to all streams that aren’t encoded in the document.

In streams that use LZW encoding, use Flate instead: Applies the Flate compression to all content streams and images that use LZW encoding in the document.

Remove invalid bookmarks: Removes invalid bookmarks that go to the pages that
have been deleted in the document.

**Remove invalid links**: Removes links that jump to the destinations that no longer exist.

**Discard unreferenced named destinations**: Discards named destinations that are not being referenced internally from within the document.

**Optimize the PDF for fast web view**: Restructures the document for page-at-a-time downloading from web servers, which allows users to open and view the PDF even before the whole file is downloaded.

**Optimize Scanned PDF**

Foxit PhantomPDF supports the size optimization of scanned PDFs during PDF creation from a scanner or by choosing **File > PDF Optimizer > Optimize Scanned PDF** in an existing scanned or image-based PDF. See also [The Optimization Options in Custom Scan](#).

**Action Wizard (Business Edition Only)**

For users who need to work on PDF documents through a series of routine tasks, PhantomPDF’s Action Wizard can help them to automate it with a predefined action. What users need to do is just create an action that includes all the tasks to be applied to the PDFs, and then run the action to process the PDFs in a single step.

**Create an action**

To streamline your work using Action Wizard, please follow the steps below to create an action:

1. Choose **Action Wizard** in the **File** tab, and click **Create New Action > Create**. The **Create New Action** dialog box appears.
2. By default, the current open file will be the file processed by the action. You can add more files or folders to be processed by clicking **Add Files, Add Folder**, or **Add Open Files**. You can also re-order the files/folders you selected, and the action will be run in that order.
3. Then choose the commands needed for the tasks from the left column and add them to the right column. You can reorder the tasks by clicking **Move Up/Down** or delete a task by clicking **Remove**. The tasks will be executed in the order you set.
4. For some tasks (such as header and footer, and watermark), you can redefine
options by clicking *Specify Settings*. If you check *Prompt User* you'll be prompted to select options or specify settings when running the action.

5. More settings:
   1. Rename the panel by double-clicking the *Untitled* label. Click *Add Panel* to add more panels to group tasks.
   2. Choose a task and click *Add Instruction* to add an instruction below it.
   3. Add a divider line below the selected task by clicking *Add Divider*.
   4. Click *Move Up/Down* to move the selected task/instruction/divider line/panel, or click *Remove* to delete them.

6. Click *Save*.

7. Name the action and input the description for the action in the dialog box. Then click *OK*.

### Run an action

After you create your action, you can run the action without opening any PDF file.

1. Click *File > Action Wizard > Run Action* and select an action.
2. A pane appears in the right of the application window, showing all the tasks in the action.
3. (Optional) In addition to the files/folders specified in the action, you can add more files/folders to be processed by clicking *Add Files, Add Folder, or Add Open Files*.
4. Click *Start*.
5. You may be prompted to provide information like the storage location. A check mark will be added to each task after the task is completed.
6. (Optional) you can click *Stop* in the panel to stop processing the action. All tasks that have been executed will be saved. Click *Resume* to continue the action. Or click the *Close* button of the panel to exit the action.
7. After all tasks in the action are completed, the *Done* button will appear in the panel.

**Tip:** Foxit PhantomPDF provides several predefined ready-to-use actions that include common tasks like file distribution, PDF optimization, sensitive information protection, and document archive.

### Manage actions

Click *File > Action Wizard > Manage Actions > Manage*, and the *Manage Actions* dialog box pops up and lists all the available actions. You can edit, rename, copy, delete, reorder, or import/export actions in the *Manage Actions* dialog box.

In the *Manage Actions* dialog box, do any of the following:
• Select the action you want to edit and click **Edit**. Click **Save** after the modification, and then close the **Manage Actions** dialog box.
• Select the action you want to rename and click **Rename**. Update the name and the description for the action, and click **OK**. Then close the **Manage Actions** dialog box.
• Select the action you want to copy and click **Copy**. Type the name and the description for the action, and then click **OK**. The new copy of the selected action will appear in the actions list. Then close the **Manage Actions** dialog box.
• Select the action you want to delete, click **Remove**. Then close the **Manage Actions** dialog box.
• Select the action you want to move and click **Move Up/Down** to reorder the action. Then close the **Manage Actions** dialog box.
• Select the action you want to export and click **Export**. In the **Save As** dialog box, specify the name and the location, and then click **Save**. Then close the **Manage Actions** dialog box.
• Click **Import**, choose the action in the **Open** dialog box, and click **Open**. The imported action will appear in the actions list. Then close the **Manage Actions** dialog box.

### Work with Video & Audio

Foxit PhantomPDF not only supports playing videos and audios in PDFs, but also allows users to add and edit multimedia files to a PDF.

#### Play a Movie or a Sound Clip

Some PDF files may be multifaceted with multimedia, including sound, music, and video clips. Each movie and sound file usually includes a play area from which the media can be activated. The play area typically appears on the PDF page as an image or a blank rectangle, but can also be invisible. To play the media files, please make sure you have the necessary media player installed on your computer.

To play a movie or a sound, please do the following:

- Select the Hand command, and click the play area of the movie or sound file.

**Note:** To protect your computer from viruses, Foxit PhantomPDF pops up a dialog box soliciting your approval before playing multimedia files. If you trust the document and the media source, check the options: **Disable Safe Reading Mode and play media** and **Add current file to privileged locations**.
Adding a movie or a sound clip

Adding movies or sounds to PDFs is as easy as inserting an image. "Movies" are desktop video files with formats such as FLV, AVI, QuickTime, and MPEG, and file extensions such as .avi, .wmv, .mov, .qt, .mpg, and .mpeg. An animated GIF file always has a .gif file extension, while “Sounds” are like midis, wavs, and mp3 files.

Note: If an alert message tells you that no media handler is available, you must install the appropriate player before you can add clips to the PDF. For example, you must install QuickTime if you want to embed an MOV file in a PDF.

Adding movies or sounds

2. Press and hold mouse button down, drag to select an area on the page where you want the movie or sound to appear. For movies, the play area is the exact size of the movie frame.
3. In the pop-up Add Video & Audio dialog box, you will see some options listed below:
   - Location: click the Browse button to select the movie file you want to insert.
   - Content type: the type of the media you insert. It is selected automatically. But you can also specify the clip type if you want. Please note that changing the Content Type setting may cause problems playing the media.
   - Embed content in document: includes the media file into the PDF file. This option will increase the file size of the PDF. It is selected by default. If the check box is cleared, you will not be able to play it if you open this PDF file on other computers.
   - Poster Settings: choose whether to display an image in the play area when the movie isn't playing. You can choose to use no poster, or create poster from file.

Edit the play area

To move, resize, align, center or distribute a multiple clip, please refer to “Images”.

Set Video & Audio properties

In Foxit PhantomPDF, you can specify properties for the multimedia files you added, such as the appearance of a movie's play area, whether the movie plays once or continuously, create alternate renditions, etc.

To set video & audio properties, please do the following:
1. Select the Video & Audio command  
   , or the Select Annotation command  .
2. Double-click the play area or right-click the play area > Properties.
3. For the Appearance tab, please refer to “Setting properties of an image”.

Note: If you select Locked on any tab, it will lock all options for this multimedia file, but not just the options on that tab.

4. In the Settings tab, there are many options listed below:
   
   - **Annotation Title** -- Type the title of the movie or sound in the Annotation Title box. This title does not determine which media file is played.
   - **Alternate Text** -- Type a description of the media file in the Alternate Text box.
   - **Renditions** -- Allows you to create alternate or other renditions to ensure that users can play the movie or sound clip on their systems.

   A. List Renditions for Event -- You can assign different renditions to different actions but Mouse Up is chosen by default. **Mouse Up** means that when the mouse button is clicked and released, the rendition is played.
   B. Add Rendition -- There're three ways for you to choose: **Use a File**, **Use a URL**, **By Copying an Existing Rendition**
   C. Edit Rendition -- When clicking the Edit Rendition button, the Rendition Settings dialog box appears, which allows you to specify the playback location, and other settings to differentiate it from other renditions.

**Media Settings -- Specifies the general properties for the movie or sound clip:**

   - **Rendition Name**: Enter the name for the rendition, which will appear in the list of renditions. (This name does not determine which media file is played.)
   - **Media Clip Location**: Specify the clip by typing or navigating to it.
   - **Content Type**: Will be selected automatically when you specify the clip location. Changing the Content Type setting may cause problems playing the media.
   - **Embed content in document**: Includes the media file into the PDF file. This option will increase the file size of the PDF. It is selected by default. If the check box is cleared, you will not be able to play it if you open this PDF file on other computers.
   - **Rendition Alternate Text**: Type a description of the rendition.
   - **Allow temp File**: Specify whether writing a temp file is allowed and when. Some media players write a temp file when they play a movie or sound clip. If you want to prevent users from easily copying the media content in a
secure document, you may want to disallow the creation of temp files. However, selecting this setting may prevent the movie from being played by media players that require the use of temp files.

*Playback Settings – Use this tab to determine how the movie or sound clip is played.*

- **Keep Player Open**: Select whether you want the player to close after it plays the movie or sound clip.
- **Volume**: Lets you specify how loud the movie will be played.
- **Show Player Controls**: Select to display a controller bar at the bottom of the play area allowing users to stop, pause, or play the media, provided the media player supports player controls.
- **Repeat**: Lets you replay a clip two or more times, or continuously.
- **Player List**: Click Add to specify a player and the settings that are required, preferred, or disallowed to play the movie or sound clip. Select the name of the player and the status. If you set the status of more than one player to Required, only one of the required players may be used to play the rendition. If you set the status of players to Preferred, these players are selected over nonpreferred players (but not over required players). If you set the status of players to Disallowed, they are not used to play the rendition.
- **Add/Edit/Delete button**: Allows you to add a new player, as well as edit or delete the selected player in the Player List.

*Playback Location – Determines whether a movie or sound clip is played in the PDF, remains hidden while played (recommended for sound clips), is played in a floating window, or is played full screen. The options for Floating Window Settings are unavailable except when you choose Floating Window.*

- **Playback Location**: Selects the location for playing a movie or sound clip.
- **Background Color**: Selects the background color for the media player.
- **Show title bar**: Selects to show or hide title bar when playing the media in a floating window.
- **Show control closing window**: Selects to show or hide the close button at the top right corner in a floating window.
- **Title Text**: Adds a title for the media that will be showed on the title bar when playing the media in a floating window.
- **Resize**: Determines to allow or forbid users to resize the floating window. There are three options for you to choose: **Don’t allow user to resize window**, **Allow user to resize window but maintain original aspect ratio**, or **Allow user to resize window**.
- **Window Position**: The window position is determined relative to the document window, application window, the virtual desktop or document.
monitor.

- **Width/Height**: Specifies the width and height of the floating window.
- **If Window is Off-screen**: Selects to play, do not play, or move window onto screen to play the media file if the floating window is off-screen.

**Use current playback settings as default for this type of media**: Set your settings as the new default for all the multimedia files you create in future.

D. Delete Renditions – Deletes the selected renditions.

E. Up/Down – Arranges the order of the renditions. If the first rendition cannot be played, the next available rendition is played.

5. **Actions tab for the Video & Audio properties**

Please refer to “Actions tab for the button properties”.

### Search and Replace Text

The **Search & Replace** function allows you to quickly update text that occurs multiple times in the document. PhantomPDF will find the next occurrence of your specified text and replace it with your new text.

1. On the **Edit** tab, click the Search & Replace icon in the **Edit Content** group. Or click the Search button on the ribbon and choose **Search & Replace** in the dropdown list. Or press Ctrl + T on your keyboard.

2. The **Replace** panel appears on the right side of application window.

3. Type the text that you want to find and replace in the **Initial Text** box, and the replacement text in the **Replace With** box. Only text objects in the document will be found, not including text in a bookmark, a comment, or form data.

4. There are two options:
   - **Whole Words Only**: When selected, only instances that match the complete words specified in the **Initial Text** box will be found.
   - **Case Sensitive**: When selected, only instances that match the capitalization of the string specified in the **Initial Text** box will be found.

5. Choose **Find Previous** and **Find Next** to locate the instance you need to replace, and click **Replace** to replace it with the replacement text.

6. (Optional) **Replace All**: Replaces all instances of the search text in the document with the replacement text.
Paragraph Editing

With the Edit Text command, you can edit texts in a paragraph like Microsoft Office Word as well as changing their font, font size and color.

To edit texts in a paragraph, please do the following:

- Select Edit > Edit Text. (Tip: You can also right-click the selected text with the Select Text and Image command and choose Edit Text to start editing text in the paragraph quickly.)

- Click on the desired paragraph to start editing. Foxit PhantomPDF will automatically change a line when the text comes to the margin of it. You can also start a new line by pressing Enter. See also the tutorial on Edit PDF.

- In the Edit tab, you can choose the font and font size from the drop-down menus or type in them directly in the boxes, and do other formatting as needed. Refer to the tables below for the instructions about the buttons. More editing features please refer to Edit Objects.

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>B</td>
<td>Bold</td>
<td>Text with bold formatting has thicker strokes than its ordinary form.</td>
</tr>
<tr>
<td>I</td>
<td>Italic</td>
<td>Text with italic formatting leans to the right.</td>
</tr>
<tr>
<td>U</td>
<td>Underline</td>
<td>Draw a line under the text.</td>
</tr>
<tr>
<td>abc</td>
<td>Strikethrough</td>
<td>Draw a line to cross out text, making others know the text is deleted.</td>
</tr>
<tr>
<td>X²</td>
<td>Superscript</td>
<td>Decrease the font size proportionally and raise the baseline, like the trademark.</td>
</tr>
<tr>
<td>X₃</td>
<td>Subscript</td>
<td>Decrease the font size proportionally and lower the baseline, like a footnote.</td>
</tr>
<tr>
<td>A</td>
<td>Font Color</td>
<td>Simply click on the font color button to apply the color shown to the text, or click on the drop-down menu to select a color for the</td>
</tr>
</tbody>
</table>
Character Spacing  Set the space between each individual character that you type.

Writing Direction  Set the writing direction (left-to-right or right-to-left) in which you type text.

### Buttons in the Paragraph group

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Bullets</td>
<td>Create a bulleted list for paragraphs. Click on the drop-down menu to choose a bullet style.</td>
</tr>
<tr>
<td></td>
<td>Numbering</td>
<td>Create a numbered list for paragraphs. Click on the drop-down menu to choose a number style.</td>
</tr>
<tr>
<td></td>
<td>Align Left</td>
<td>Align the left edge of the paragraph to the left margin.</td>
</tr>
<tr>
<td></td>
<td>Center</td>
<td>Center each line of the paragraph with even space on both sides.</td>
</tr>
<tr>
<td></td>
<td>Align Right</td>
<td>Align the right edge of the paragraph to the right margin.</td>
</tr>
<tr>
<td></td>
<td>Justify</td>
<td>Align both sides of the paragraph with both margins.</td>
</tr>
<tr>
<td></td>
<td>Increase Indent</td>
<td>Move the paragraph farther away from the left margin.</td>
</tr>
<tr>
<td></td>
<td>Decrease Indent</td>
<td>Move the paragraph closer to the left margin.</td>
</tr>
<tr>
<td></td>
<td>Line Spacing</td>
<td>Set the space between each line in a paragraph.</td>
</tr>
<tr>
<td></td>
<td>Paragraph Spacing</td>
<td>Set the space between two paragraphs.</td>
</tr>
<tr>
<td></td>
<td>Word Spacing</td>
<td>Set the space between each word.</td>
</tr>
<tr>
<td></td>
<td>Character Scale</td>
<td>Set the width of each character.</td>
</tr>
</tbody>
</table>

**Note:** Clicking on a scanned or image-based PDF with **Edit Text** command, a message prompts where you can click **Recognize Text** to run OCR, or click **Settings** to specify OCR settings before recognizing text. (See also the Editing preference setting.) To not show the prompted message again, you can go to **File > Preference > Editing >** uncheck the option “Alert when there’s no editable text when using ‘Edit Text’ tool”.

### Objects

When reading a PDF, you may need to frequently edit text, image, or other objects in this PDF file. With Foxit PhantomPDF, you can add, edit, modify, join and split objects.
Add New Objects

You can add or insert new text, image or shape objects into a PDF using respective commands in Edit tab.

Add new text objects

To add text objects, please do the following:

- Select Edit > Add Text T.
- Click on the specific page you want to input the text and type new text in the position where the cursor is blinking. You can also paste or delete the text you input.
- You can choose the text font format as you want in the Font group. In the Paragraph group, you can also align the text and set other paragraph formats including word spacing, character scale, line spacing, etc.

Add new image objects (Business Edition Only)

To add image objects, please do one of the following:

- To add a self-created image or embed an image from the clipboard, locate the page where you want to insert the image in the document, and choose Edit > Add Images Image > Draw New Image. Add New Image dialog box pops up as below. You may specify the parameters and click OK. Then you are switched to the Image Editor window.

A. In the IMAGE tab, draw your image from scratch. Or click Paste button in the toolbar to insert an image from the clipboard and then edit the image. Click Save as Image to save the image content in the window as an image file. Click Copy to copy the image content which can be pasted to a PDF document.
B. To draw or edit image, you can use the commands on the toolbar and the Image Editor Function Panel at the right side of the window. For more information on the Image Editor, please refer to “About the Image Editor”.

C. Click **Apply Changes** button to save the changes and exit the Image Editor. Or click **Exit Image Editor** button to exit ignoring the changes on the image and to go back to the Document window. After the image is successfully inserted, you can resize the image and drag it to any place you want.

* To add an image from file, locate the page where you want to insert the image in your document, and choose **Edit > Add Images** > **Image From File**. Choose the target image file in the Open dialog box and click **Open**. Then the image will be added to the document. You can double-click the image, or right-click the image and choose **Edit Object**, to open the **Image Editor** and edit the image with the commands in the **Image** context tab. How to edit image objects, please refer to “To Add a Self-created Image”.

**Add new shape objects (Business Edition Only)**

With Foxit PhantomPDF, you can also directly insert path and shading objects like rectangles, curve, straight line, etc. into your PDF as well as text objects and image objects. Shading objects are generally used to make shadows or nice backgrounds.

**Add a path object**
Add a shading object

✧ Add a path object

To add a path object, please do the following:

- Locate the page where you want to insert the path in the document, and choose Edit > Add Shapes > Add Path > choose one path you need. The cursor changes into a cross ✿. Click and drag the cursor to draw the path you want. If you click on the path, the Format context tab and the Arrange context tab will appear on the ribbon for you to modify the path with the commands.

- When you are drawing a path, it stays selected until you click elsewhere on the page and a wireframe with sizing handles appears to let you adjust the size and shape.

Note: Sizing handles are the small circles or squares that appear at the corners and sides of a selected object. You drag these handles to change the size of the object.

- When drawing a path, you can press the Ctrl + Z or Ctrl+ Y to undo or redo your operation. After creating the path you intended, click anywhere outside the path.

A. The Line command    B. The Rectangle command    C. The Round Rectangle command
D. The Ellipse command   E. The Polyline command    F. The Polygon command    G. The Bezier command   H. The Close Bezier command   I. The Free Paint command

To draw a straight line

1. Choose the Line command /.

2. Click a region in the document where you want to create the drawing and draw the line.

3. Drag the handles to adjust the line size if necessary.

4. Click outside the path when you are done to set the line.

To draw a rectangle

1. Choose the Rectangle command □ to create a square-cornered path, or click
the Rounded Rectangle command to create a round-cornered path.

2. Click a region in the document where you want to create the drawing and draw a rectangle.
3. Drag the sizing handle diagonally in the direction you want.

To draw an ellipse

1. Choose the Ellipse command.
2. Drag the pointer to draw an ellipse, or draw a circle with Shift.
3. Click outside the path when you are done to set the ellipse.

To draw a polygon, polyline, Bezier, or Close Bezier

1. Choose the Polygon command, Polyline command, Bezier command or Close Bezier command.
2. Drag the pointer to draw a straight line.
3. Click once at each position where you want a new line segment to appear.
4. To end a polyline or a Bezier, double-click the last point to complete the drawing.

To end a polygon or a Close Bezier, do either of the following:

- Double-click or right-click a point to draw the second to the last line of the polygon/Close Bezier, and an additional line will be automatically drawn from this point to the start point.
- Double-click the start point to finish drawing.

To draw a custom path

1. Choose the Free Paint command.
2. Draw a path you want by dragging the pointer.
3. Click outside the path when you are done to set the path.

Add a shading object

To add a shading object, please do the following:

- Locate the page where you want to insert the shading in your PDF document, and choose Edit > Add Shapes > Add Shading > choose the shading you need. The cursor changes into a cross. Click and drag the cursor to draw
the shading you want. If you click on the shading, the Format context tab and
the Arrange context tab will appear on the ribbon for you to modify the
shading with the commands.

- When you are adding a shading (See also Drawing a path), it stays selected until
  you click elsewhere on the page and a wireframe with sizing handles appears
to let you adjust the size and shape.

In the Format context tab, you can choose a shading style to preset different shading
colors and do any of the following to move the colors and change the shading effect:

1) **Opacity**: Drag the slider to change the opacity.

2) **Gradient Stops**: Describes the location and color of a transition point in a gradient.
   After choosing a shading style, you can also edit the shading color, like add new colors,
delete existing colors, etc.

   - **Move colors**

     Each color can be moved by clicking and dragging the slider 🔷.

   - **Change colors to a shading**

     Double-click one color 🔷 you want to change, select the color you like in the
     Color dialog box and click OK.

   - **Add colors to a shading**

     Select one color you like and click between any two sliders underneath the
     preview bar. There will be new colors added to the shading.

   - **Delete colors to a shading**

     Click the slider 🔷 of the color you want to delete, and click **Delete** button
     ❌. Also, you can move it away from the preview bar. The color will be
removed from shading.

**3) Reference Line:** A line along which the field of shading varies between the start and end coordinates and from which the field of shading extends infinitely away. The start and end point are shown, connected by a line. The transition from one color to another varies linearly along the line. The color gradient begins at the start point and finishes at the end point.

You can drag either start or end point to move it individually, or drag the line to move them both at the same time. This movement will change the shading effect. Compared with Shading 1, Shading 2 is dragging the start point to move, Shading 3 is dragging the end point to move, and Shading 4 is dragging the line to move.

**Link and Join Text Objects**

To make editing easier, Foxit PhantomPDF supports linking multiple text blocks together or connecting separate text blocks into one single paragraph.
Link and Unlink Text Objects

Using the Link command, you can link multiple text blocks together and then editing text in these blocks will be treated as editing one paragraph. You can link text blocks not only in one page but also across pages. Text will reflow in these linked blocks and will not cover the page contents that are located among these blocks.

To link text blocks, please do the following:

• Click Edit > Link & Join Text and a Format context tab appears on the ribbon. Select text blocks you need to link together and the selected blocks will be marked with numbers as you click them.
• Click the Link command in the Format context tab, or right-click the selected blocks and choose Link Text Boxes. Then the three blocks will be linked together.
• Then when you add or edit text in these blocks with the Edit Text command, the text will reflow in these linked blocks and will not cover the image among them. And when the text added exceeds the final block, content followed the linked blocks will be covered because they have not been linked together.

To unlink a text block, please click Edit > Link & Join Text, select the text block you need to unlink and then click the Unlink command in the Format context tab. You can also right-click the selected block and choose Unlink Text Blocks.

Note:

You can select and link text blocks which are discontinuous or in different columns, or that are not arranged from top to bottom or from left to right on the page.

Join and Split Text Objects

With the Join command, you can connect blocks of text into one single paragraph in a block to improve text reflow. Blocks of text may be joined together when you need to join text as one object. Otherwise, a block of text can be divided up into several parts with the Split command.

To join text blocks, do the following:
1. Click **Edit > Link & Join Text** button.

2. Click the text blocks you want to join. The text blocks you selected will be numbered.

3. Click the **Join** command in the **Format** context tab, or right-click the selected blocks and select **Join Text Boxes**. Then the selected blocks will be joined together as one block.

To split a text block, please click **Edit > Link & Join Text** button and click the text block you want to split. Click the **Split** command in the **Format** context tab, or right-click the selected block and select **Split Text Boxes**. Then the selected block will be divided.

**Note:** *All selected blocks should be on the same page.*

See also the tutorial on **Advanced Text Editing**.

### Edit Objects

You can freely edit any selected object(s) by the related commands.

#### Edit Text Objects

To edit text objects, click **Edit > Edit Object ➔ Text**. And click on the text you want to edit. A selected object usually is outlined by a bounding box. Double-click the box or choose **Edit** in the context menu. Then the cursor will be blinking, and you can add, paste or replace text only if the font used for that text is installed on your system. More editing information, please refer to “**Add New Text Objects**”.

#### Merge and Split Text Objects (Business Edition Only)

You can also merge and split text objects by using **Merge Text** tool and **Split Text** tool. To remove the space between the letters of words to improve the appearance of text content, you can click **Edit > Merge Text ➔ Remove Kerning**.

To merge text objects, Shift-click the objects with the **Edit Object** command and click **Edit > Merge Text**. To split a text object, please do the following:
Chapter 5: Edit

Foxit PhantomPDF
User Manual

- Select the object and click **Edit > Split Text**. The **Split Text** dialog box pops up.
- Drag the slider and click the position you want to split. Click OK and the text object will split into parts.

**Convert Text Objects to Shape Objects (Business Edition Only)**

Foxit PhantomPDF supports to convert the selected text object(s) into path(s), which will meet the pre-press requirement. For those computers that do not support or display certain embedded fonts, this new feature helps to overcome that issue. To convert text objects to paths, please do the following:

- Select the text objects that you want to convert to paths.
- Select the **Convert to Shape** button to convert.

**Edit Image and Shape Objects (Business Edition Only)**

To edit image objects, click **Edit > Edit Object > Image**. Double-click an image or choose **Edit Object** in its context menu. Your current main window is switched to the Image Editor window. For further information about editing image objects, please refer to “Add New Image Objects”.

To edit shape/shading objects, click **Edit > Edit Object > Shape/Shading**. Click a shape/shading and edit it with the commands in the **Format/Arrange** context tab. Further information about editing shape/shading objects, please refer to “Add New Shape Objects”.

**Tip:** When editing text, image, shape and shading objects together, you can edit all the objects by choosing **Edit > Edit Object > All**.

**Reflow Editing (Business Only)**

The commands **Edit Text** and **Edit Object** can only allow you to edit text in one text block in one page. To edit text in a continuous mode like Word, you can use the **Reflow Editing** command. When you are in reflow editing mode, text will reflow automatically in pages in the document as you add or edit text content.
To edit PDF with the **Reflow Editing** command,

1. Choose **Edit > Reflow Editing**, and a dialog box pops up to inform you about the benefits and notes about the reflow editing mode. Click **Continue** if you need to edit content in the Reflow Editing mode.

2. The **Reflow Editing** tab appears on the ribbon, allowing you to edit text format and paragraph styles.

3. When you complete editing, click **Apply Changes** to save the changes, or click **Exit Reflow Editing** to exit the Reflow Editing mode without applying any change.

### Modify, Arrange and Delete Objects

A selected object is usually outlined by a bounding box. And the corresponding **Format** or **Arrange** context tab on the ribbon will appear after you select objects. With the commands in the **Format** or **Arrange** context tab, you can modify and arrange objects.

Select **Edit > Edit Object** > select **All/Text/Image/Shape/Shading**, and do one of the following:

1. To select one or multiple objects, please do one of the following:
   
   - Click the object to select it, or press **Ctrl/Shift** and select more objects.
   - Hold the pointer over the objects and drag a rectangle around them.
   - Press **Ctrl + A** on keyboard. All objects on the current page are selected.

   *Note: To deselect all the objects, click any blank area in the document.*

2. Move and resize an object

   - To move an object, select the object and drag the object to the desired place. Or right-click the object and choose **Cut** from the context menu and then right-click the desired place and choose **Paste**. You can also move multiple objects at the same time with the methods above.
   - To resize an object, drag a handle of the object. Drag the handles of the four corners to retain the original aspect ratio. You can also resize multiple objects at the same time with the same magnification by dragging the handles, or choosing **Properties...** from the context menu of the selected objects and entering a percentage value in the **Scale X** or **Scale Y** box in the properties dialog box.

3. Rotate an object
To rotate an object, select the object and then do one of the following:

- In the **Arrange** context tab, click **Rotate ** > **Clockwise/Counter-clockwise** by 90 degrees.
- Click and drag **** to rotate the image as you need.
- Right-click the selected and choose **Rotate**.

To rotate multiple objects at the same time, select multiple objects and rotate them with the methods above. Or, you can select multiple objects, click the **Arrange** context tab > the **Rotate** button > **More Rotation Options** and enter a percentage value in the dialog box.

4. Shear an object (**Business Edition Only**)

To shear an object, select the object and do the following:

Click **Edit > Shear** (or click **Shear** in the **Format** context tab when shearing a shape/shading object), or right-click the object and choose **Shear** in the context menu. Enter a value in the pop-up dialog box to shear the object and click **OK** to finish.

5. Arrange objects

After selecting multiple objects, you can arrange them in the documents. In the **Arrange** context tab you can align, page-center or distribute objects. Or choose **Align/Center/ Distribute** after right-clicking one of the selected objects. (See also “**Align Images**”, “**Center Images**” and “**Distribute Images**”.)


- Select the object and click **Edit > Clipping** (or click **Clipping** in the **Format** context tab when clipping a shape/shading object), or right-click the object and choose **Add clip path** in the context menu. Choose one clipping shape in the drop-down list.
- Click on the object and it will turn to the clipping mode where the selected object will be enlarged and the cursor changes to a cross **. Drag the cursor to draw a clipping shape. The cursor then changes to **. You can adjust the shape's position by dragging the cursor ** to move.
- Drag the dots of the clipping shape in the direction you want until the clipping
shape displays the results you want.

- (Optional) You can choose other clipping shapes to do further clipping on the object if needed.

- (Optional) To delete clipping shapes, click Edit > Clipping ➔ > Edit Clipping (or click Clipping ➔ > Edit Clipping in the Format context tab), select one clipping shape and press Del or right-click the clipping shape and select Delete. To remove all clipping shapes, please click Edit > Clipping ➔ > Clear Clipping (or click Clipping ➔ > Clear Clipping in the Format context tab).

- Click on the area outside the objects to exit the clipping mode.

7. Move an object in front or behind other elements

Select an object and click Send to Back or Bring to Front in the Arrange context tab to send it to the front or back of the other elements on the page.

8. Delete an object

- Select one or more objects, press the Delete key or right-click and choose Delete from the context menu.

**Object Properties**

When you right-click an object or multiple objects with the same type, and choose Properties..., you can view and change the options in it.

**Set objects properties**

1. With the Edit Object command, right-click text objects, images objects, shape objects (or path objects) and shading objects, and choose Properties....

2. There are General tab and Appearance tab in the properties dialog box. The general tab is as below: (Take image objects properties for example.)

You can specify a number of properties that are common to all objects in the General properties.

- **Position X and Y:** Allow you to set the precise horizontal and vertical position of the objects.
- **Width and Height:** Displays the selected object's width and height values.
3. In Image Object Properties dialog box, in the Appearance tab, drag the slider or enter a value to specify the opacity of the image object. Opacity can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

4. In shape object properties dialog box, please do any of the following:

- **Stroke Color**: The stroke color is used to paint the border of paths and text that are stroked.
- **Fill Color**: The fill color is used to paint the interior of paths and text characters that are filled.
- **Line Width**: The line width specifies the thickness of the line used to stroke a path and is measured in user space units. A line width of 0 specifies the thinnest line that can be rendered on the output device. The default value is 1.

*Note*: A line width of 0 is an inherently device-dependent value. Its use is discouraged because the line may be nearly invisible when printing on high-resolution devices.

- **Miter limit**: When two line segments meet at a sharp angle it is called a Miter join and has been specified as the line join style. It is possible for the miter to extend far beyond the thickness of the line stroking the path. The miter limit imposes a maximum on the ratio of the miter length to the line width, as shown in the following figure. When the limit is exceeded, the join is converted from a miter to a bevel.

The value for miter limit is a number that must be greater than or equal to 1, and has a default value of 10.

![Miter length](image)

- **Line Join Style**: The line join style specifies the shape to be used at the corners of paths that are stroked. The allowed values are Miter joins, Round joins and Bevel joins.

  - **Miter** — the outer edges of the strokes for the two segments are
continued until they meet. If the extension projects too far, as determined by the miter limit, a bevel join is used instead.

- **Round** — a circular arc with a diameter equal to the line width is drawn around the point where the segments meet and filled in, producing a rounded corner.
- **Bevel** — the two path segments are drawn with butt end caps (see the discussion of line cap style), and the resulting notch beyond the ends of the segments is filled in with a triangle.

![Miter Round Bevel](image)

- **Line Cap Style**: The line cap style specifies the shape to be used at the ends of open sub paths when they are stroked. Allowed values are Butt end caps, Round end caps, and Projecting Square End.

  - **Square**: --- the stroke is squared off at the endpoint of the path.
  - **Round**: --- a semicircular arc with a diameter equal to the line width is drawn around the endpoint and filled in.
  - **Flat**: --- the stroke extends beyond the end of the line by a distance that is half the line width and is squared off.

![Square Round Flat](image)

- **Dash**: Select a type of line, dashed or solid.
- **Opacity**: Enter a value, or drag the slider to specify the opacity. Opacity can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

5. In text object properties dialog box, please do any of the following:

  - **Font Name**— Changes the font used by the selected text to the font you specify.
Font Size – changes the font size to the size that you specify.

Horizontal Scaling – adjusts the width of characters by stretching or shrinking them in the horizontal direction. The scaling is specified as a percent of normal width of the characters, with 100 being the normal width. The scaling always applies to the x coordinate. The following figure shows the effect of horizontal scaling.

<table>
<thead>
<tr>
<th>Word</th>
<th>100 (default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>WordWord</td>
<td>50</td>
</tr>
</tbody>
</table>

Text Mode – determines whether text is stroked or filled. There are four types of text modes: Fill Text, Stroke text, Fill then stroke text, and Text with no fill and no stroke.

1. Fill text  2. Stroke text  3. Fill then stroke text  4. Text with no fill and no stroke

Character Space – inserts uniform spacing between two or more characters in selected text.

<table>
<thead>
<tr>
<th>Character</th>
<th>0 (default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td>2.5</td>
</tr>
</tbody>
</table>

Word Space – inserts uniform spacing between two or more words in selected text.
For stroke color, fill color, and opacity; please refer to Path Object Properties.

About the Image Editor (Business Edition Only)

When you draw a new image object with the Draw New Image command, or edit an image object with the Edit Object command, the Image Editor (the Image context tab) appears on the ribbon. Image Editor is an image-editing program that includes various commands and the function panel.

The Tools group

You can select a command by clicking its icon in the Tools group in the Image context tab. Positioning the pointer over a command will display a tool tip with the command's name. There are selecting commands and painting commands.

♦ The Selecting tools

The Selecting tools include the Rectangular Marquee command, the Magic Wand command, the lasso commands (the Lasso command and the Polygonal Lasso command), etc. To see how to use these commands, please follow the steps as below.

The Rectangular Marquee command:

- Select the rectangle command  from the Tools group.
- Drag over the area you want to select.

The Magic Wand command:

- Select the magic wand command .
- In the Image Editor Function Panel, drag the slider to specify the Tolerance, or enter a value ranging from 0 to 255.
- To select only adjacent areas using the same colors, select Contiguous. Otherwise, all pixels using the same colors will be selected.
- In the image, click the color you want to select. If Contiguous is selected, all
adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.

**Tip:** The magic wand command lets you select a consistently colored area without having to trace its outline. You can specify the tolerance for the magic wand command’s selection.

The **Lasso** command:

- Select the lasso command from the Tools group.
- Drag to draw a freehand selection border.

The **Polygonal Lasso** command:

- Select the Polygonal Lasso command from the Tools group.
- Click in the image to set the starting point.
- Double click the image to close the selection.

**Cutting, copying, and pasting selections:**

- Select the area you want to cut/copy.

- Choose the **Cut Out** command or the **Copy** command from the Clipboard tab.
- Paste the selection into the same image or another application.

❖ **The Painting tools**

The Painting tools include the Eyedropper command, the Brush command, the Paint Bucket command, the Dodge command, the Burn command and the Eraser command, etc. These commands are generally used in combination with the options in the Image Editor Function Panel.

1. **Setting options for painting**

You can set options for a painting tool in the Function Panel.

**Selecting a blending mode**

The blending mode controls how pixels in the image are affected by a painting or editing tool.

To select a blending mode for a tool, choose from the Mode drop-down menu.
- **Normal**

Edits or paints each pixel to make it the result color. This is the default mode.

- **Color Burn**

Looks at the color information in each channel and darkens the base color to reflect the blend color by increasing the contrast. Blending with white produces no change.

- **Color Dodge**

Looks at the color information in each channel and brightens the base color to reflect the blend color by decreasing the contrast. Blending with black produces no change.

- **Darken**

Looks at the color information in each channel and selects the base or blend color—whichever is darker—as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change.

- **Difference**

Looks at the color information in each channel and subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value. Blending with white inverts the base color values; blending with black produces no change.

- **Exclusion**

Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts the base color values. Blending with black produces no change.

- **Hard Light**

Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the image.

- **Lighten**
Looks at the color information in each channel and selects the base or blend color—whichever is lighter—as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change.

- **Hard Mix**

The result of Hard Mix is either 0 or 255 for each channel. If the sum of upper layer value and lower layer value is greater than 255, then it is 255, otherwise the result will be 0. This mode is useful for color enhancement or special effects. See the Example shown below:

- **Linear Dark/Light**

Burns or dodges the colors by decreasing or increasing the brightness, depending on the blend color. If the blend color (light source) is lighter than 50% gray, the image is lightened by increasing the brightness. If the blend color is darker than 50% gray, the image is darkened by decreasing the brightness.

- **Multiply**

Looks at the color information in each channel and multiplies the base color by the blend color. The result color is always a darker color. Multiplying any color with black produces black. Multiplying any color with white leaves the color unchanged. When you're painting with a color other than black or white, successive strokes with a painting tool produce progressively darker colors. The effect is similar to drawing on the image with multiple magic markers.

- **Overlay**
Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing pixels while preserving the highlights and shadows of the base color. The base color is not replaced but is mixed with the blend color to reflect the lightness or darkness of the original color.

- **Pin Light**

Replaces the colors, depending on the blend color. If the blend color (light source) is lighter than 50% gray, pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change. If the blend color is darker than 50% gray, pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change. This is useful for adding special effects to an image.

- **Screen**

Looks at each channel’s color information and multiplies the inverse of the blend and base colors. The result color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white. The effect is similar to projecting multiple photographic slides on top of each other.

- **Soft Light**

Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the image.

**Specifying opacity or flow**

You can specify opacity or flow in the Function Panel for the following tools:

- Opacity specifies the maximum amount of paint coverage applied by the brush, clone stamp, and paint bucket tools.
- Flow specifies how quickly paint is applied by the brush tool.

**To specify opacity or flow**

Enter a value, or drag the slider for Opacity or Flow in the Function Panel.

Opacity or flow can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

2. **Using the Eyedropper command**
Chapter 5: Edit

The eyedropper command samples color to designate a new foreground or background color. You can sample from the active image. You can also specify the area sampled by the eyedropper command. For example, you can set the eyedropper to sample the color values of a 3-by-3-pixel area under the pointer.

To sample color with the eyedropper command:

- Select the eyedropper command from the Tools tab.
- In the Pipette palette of Function Panel, choose an option from the Sample Size menu.
  
  Note: 3 by 3 Average or 5 by 5 Average to read the average value of the specified number of pixels within the area you click.

- Click the area containing the color you want to copy.

3. Using the Brush command

Image Editor provides the brush command to let you paint with the current foreground color.

- Select the Brush command from the Tools tab.
- Do one of the following:
  - Click the triangle , and set brush options: Diameter to control the size of the brush. Hardness to control the size of the brush's hard center.
  - Specify a blending mode (See “Selecting a blending mode”)
  - Specify an opacity and a flow rate (See “Specifying opacity or flow”)
- Drag the image to paint.

4. Using the Paint Bucket command

The paint bucket command fills adjacent pixels that are similar in color value to the pixels you click.

- Select the paint bucket command from the Tools tab.
- Do one of the following in the Function Panel:
  - Specify a blending mode (See “Selecting a blending mode”)
  - Specify an opacity (See “Specifying opacity or flow”)
  - Specify a tolerance
**Note:** The tolerance defines how similar in color a pixel must be to be filled. Values can range from 0 to 255. A low tolerance fills pixels within a range of color values very similar to the pixel you click. A high tolerance fills pixels within a broader range.

- Click the part of the image you want to fill.

5. **Using the Dodge command**

The dodge command is used to lighten areas of the image.

**To use the dodge command:**

- Select the dodge command 🎨.
- Do the following in the Function Panel:
  - Set brush options: Diameter to control the size of the brush. (See “Using the brush command”)
  - Select what to change in the image: Shadows to change the dark areas; Highlights to change the light areas.
- Drag over the part of the image you want to modify.

6. **Using the Burn command**

The burn command is used to darken areas of the image.

**To use the burn command:**

- Select the burn command ☁.
- Do the following in the Function Panel:
  - Set brush options: Diameter to control the size of the brush. Hardness to control the size of the brush’s hard center (See “Using the brush command”).
  - Select what to change in the image: Shadows to change the dark areas; Highlights to change the light areas.
- Drag over the part of the image you want to modify.

7. **Using the Eraser command**

- Select the Eraser command 🪞 from the Tools tab.
- Do one of the following in the Function Panel:
  - Specify opacity and a flow rate (See “Specifying opacity or flow”).
8. Using the Spot Healing Brush command

The spot healing brush command effortlessly removes dust, scratches, blemishes, and other flaws and automatically preserves the shading, lighting, and texture of the original image.

To use the healing brush command:

- Select the spot healing brush command 🌹.
- Do the following in the Function Panel:
  - Specify the diameter option to control the size of the brush.
  - Specify the roundness option to control the ratio between the brush's short and long axes.
- Press down Ctrl key and click an area to define a source to repair.

9. Using the Clone Stamp command

The clone stamp command takes a sample of an image, which you can then apply over another image or part of the same image. Each stroke of the tool paints on more of the sample.

To use the clone stamp command:

- Select the clone stamp command 🎨.
- Do one of the following in the Function Panel:
  - Set brush options: Diameter to control the size of the brush. Hardness to control the size of the brush's hard center (See “Using the brush command”).
  - Specify a blending mode (See “Selecting a blending mode”)
  - Specify opacity and a flow rate (See “Specifying opacity or flow”).
  - Aline: If selected, the position of the source remains fixed relative to the spot where your first brush stroke was, and each brush stroke you paint is cloning an area of the image that is the same distance and direction from the start of the previous stroke; if deselected, every new brush stroke will return to initial clone source spot, and you are making a new copy of your image with each brush stroke.
- Press down Ctrl key and click an area to define a resource. Then move the cursor to copy the located image.

10. Choosing foreground and background colors
You can use the Levels palette to select the foreground or background color by choosing from a color spectrum or by defining colors numerically.

You can designate a new foreground or background color using the eyedropper command (See “Using the eyedropper command”) and the Levels palette.

The default foreground color is black, and the default background color is white.

Levels palette:

The Levels palette displays the color values for the current foreground and background colors. Entering the value in the Levels palette or clicking the arrows to increase or decrease the value, you can edit the foreground and background colors according to several different color models.

Note: Image Editor uses RGB mode to work with images.

11. Using the Layer palette

The Layers palette lets you set layer opacity, fill layers and choose a blending mode.

Setting layer opacity

A layer’s opacity determines to what degree it obscures or reveals the layer beneath it. A layer with 1% opacity appears nearly transparent, while one with 100% opacity appears completely opaque.

To specify opacity for a layer

1. Select a layer or layer set in the Layers palette.
2. In the Layer palette, enter a value in the Opacity text box or drag the Opacity slider.

12. Hiding/Displaying the Function Panel

To hide/display the Function Panel, please select Hide Function Panel button, or Show Function Panel button.
The Filter group

Using filters, please select an item from the Filter tab to add an effect to the image. Move the cursor over one type of filter to preview how the image will look after adding the filter. The filter will be applied only when you click it. And the image with the applied filter will be the original one to be added another filter later if any. To undo the application, you can click Undo button on the Quick Access toolbar.

Flipping and Replacing Images

Flipping tools are to flip images horizontally or vertically. And you can also replace the original image with other images with the Replace command.

To flip images, please do one of the following:

- From the Image context tab, click or to flip the entire image horizontally or vertically.
- To flip the image you select, click the Rectangle command or the Lasso command to select an area, and click the Flip command or.

To replace images, please do the following:

1. From the Image context tab, click Replace button.
2. In the pop-up Open dialog box, search the image file you want and click Open button.

   Note: Only BMP, PCX, TIF, and JPEG format file can be opened.

3. You get a confirmation message asking you if you want to continue to replace the current active image. If yes, click the Ok button to finish.

   Note: The replaced image will never be recovered.

Articles

For PDF documents that include articles and arrange text content in multiple columns
and across several pages, you may need lots of scrolling or zooming to navigate the articles. To make article viewing effective, Foxit PhantomPDF allows you to define a navigational path (or an article thread) for an article in the document by marking out a series of boxes around the article content in the order you want the content to be viewed in. With article threads, you can skim through a document, focusing on a specific article and ignoring the rest, as you do in a traditional print newspaper or magazine.

**Define articles**

To define an article, please follow the steps:

1. Choose *Edit > Add Article Box*. The cursor changes into a Cross automatically.
2. Click and drag a rectangle around the content to be the first article box. A black rectangle appears around the content with a label, and the cursor changes into the article pointer.

   The label for each article box is made up of the article number and the sequence number within the article. For instance, the first box for the first article in the document is labelled 1-1, the second box 1-2, the third box 1-3, and so on. And the boxes for the second article in the same document are labelled 2-1, 2-2, 2-3, and so on.
3. Repeat the operation in Step 2 to mark out the rest of article boxes followed. (*Note: If you need to resize or move an article box during the article defining, you must end the article first.*)
4. When you have defined the entire article, press *Enter* to end the article.
5. Type the information in the pop-up article property dialog box as needed and then click *OK*.
6. Then in the *Articles* panel in the navigation pane you can see the article defined. The *Articles* panel lists all of the articles included in the document.

**View articles**

1. To view the articles in the document, open the *Articles* panel in the navigation pane and do any of the following to start viewing:
   - Double-click the article you want to view.
   - Right-click the article you want to view and choose *Read Article* from the context menu.
   - Select the article you want to view and choose *Read Article* from the options menu in the upper right corner of the *Articles* panel.
2. The pointer will change into and you will be switched to the beginning of the article (the area of the first defined article box). The page view may zoom in or out automatically so that the current part of the article fills the screen, with the first line appearing in the upper left corner.

3. During the article viewing, do any of the following:
   • Click in the article or press Enter to navigate to the area of next article box.
   • Shift-click in the article or press Shift + Enter to navigate to the area of previous article box.
   • Ctrl-click within the article to go to the beginning of the article.

4. At the end of the article (the area of the last defined article box), the pointer will change into and clicking in the article will return to the beginning of the article.

Note:

1. Before viewing an article, make sure you have selected the Hand tool and the option Make Hand Tool read articles in the File > Preferences > General.
2. You can select Hide After Use in the options menu in the upper right corner of the Articles panel to hide the panel after the article viewing starts.

Modify articles

You can rename and delete articles, move and resize article boxes, edit article properties, and more.

Rename articles

To rename an article, click the article name directly in the Articles panel and type a new name for it, or right-click the article and choose Rename to rename it.

Move and resize an article box

To move an article box, select the article box with the Add Article Box command. Then drag the box to the desired position.

To resize an article box, select the article box with the Add Article Box command. Then drag a handle of the box.

Note: To select an article box with the Add Article Box command, you need to click on the
When an article box is selected, you can see the selection handles of box appear with a plus sign at the bottom. After you select an article box, press **Enter** to jump to next box within the article; if the selected box is the last one within the article, press **Enter** to jump back to the first box of the article.

**Delete an article or article box**

To delete an entire article, do any of the following:

- Select the article in the **Articles** panel and press **Delete**.
- Right-click the article in the **Articles** panel and choose **Delete**.
- With the **Add Article Box** command select any article box of the article in the document. Then right-click the selected article box and choose **Delete**. In the pop-up dialog box, choose **Article** to delete the article.

To delete an article box, select the article box you want to delete with the **Add Article Box** command. Then right-click the box and choose **Delete**. In the pop-up dialog box, choose **Box**.

After an article or an article box is deleted, the remaining articles or article boxes in the document will be automatically renumbered.

**Edit article properties**

You can edit the article title, subject, author, and keywords in the article property dialog box. To open the article property dialog box, do any of the following:

- Select the article, and choose **Properties...** from the options menu in the **Articles** panel.
- Right-click the article, and choose **Properties...** from the context menu in the **Articles** panel.
- Double-click any article box of the article in the document with the **Add Article Box** command.
- Select any article box of the article in the document with the **Add Article Box** command. Then right-click the article box and choose **Properties...** from the context menu.

**Insert article boxes into an article thread**

1. With the **Add Article Box** command select the article box that you want to the new article box to follow in the document.
2. Click the plus sign at the bottom of the box and the pointer changes into \( \text{\textcircled{+}} \).

   Then you can click and drag a rectangle around the desired content to be the new article box. If you click without dragging, a prompt pops up telling you to click and drag out to create a new article box.

3. (Optional) You can continue dragging to insert more article boxes as needed.

4. Press Enter after you insert all the content you need.

5. Then you can see the sequence number of the new box follows that of the box selected in Step 1, and all following article boxes are renumbered automatically.

### Combine two articles

1. With the Add Article Box command select any article box of Article 1 in the document.

2. Click the plus sign at the bottom of the box and the pointer changes into \( \text{\textcircled{+}} \).

3. Ctrl-click any article box of Article 2.

4. Then you can see Article 2 is appended to the end of Article 1, and all article boxes are renumbered automatically. In the Articles panel, the two articles are combined to one article named with the title of Article 1 by default. Rename the combined article as needed.

### Spelling Check

Foxit PhantomPDF allows users to check the spelling of PDF files and provides suggestions to correct misspelled words. This feature is useful when users want to proofread text. You can check for possible mistakes and then confirm each correction.

By default, PhantomPDF automatically checks the spelling when you edit text or use the typewriter tools. You can disable the automatic spelling check by unchecking Enable spell check from File > Preferences > Spelling.

To check spelling within an entire document, please do the following:

- Click Edit > Check Spelling button \( \text{\textcircled{+}} \).

- In the pop-up Check Spelling dialog box, you will see the suspect word and suggestions for correction.
  - Ignore – Click Ignore if no correction is needed.
  - Ignore All – Click Ignore All to skip all further occurrences of the current “misspelling”.


Change – Click Change after selecting one suggestion to make the suggested correction.

Add To Dictionary – Click Add to Dictionary if the suspect word is spelled correctly but doesn't appear in Foxit PhantomPDF's dictionary. Choosing Add to Dictionary adds the word to Foxit PhantomPDF's custom dictionary, which is a supplemental list of spelled-correctly words used to proofread a document.

Cancel – Click Cancel to exit the Check Spelling dialog box.

Tip: You can add, remove, or reorder dictionaries in File > Preferences > Spelling.

Working with Layers

A layer or as it is more formally known Optional Content Groups (OCG) is a dictionary representing a collection of graphics that can be made visible or invisible dynamically by users of viewer applications. In a PDF file, each layer may hold any portion of the document's objects, and layers may be made visible or invisible, showing or hiding their contained objects, in any combination.

With Foxit PhantomPDF, you can control the display of PDF layers with the Layers panel. For example, you may divide background imagery, main content areas, and advertisements amongst their own top-level layers, and easily hide the layers that you don't want others to view.

Show /hide PDF Layers

In a PDF, information can be stored on different layers. To show or hide related content stored in a variable number of separate layers, you can simply refer to the Layers panel on the left side of the work area. You can view layers and choose to show or hide the content associated with each layer.
The Layers Panel

A. A checkmark indicates a displayed layer  B. Hidden layer

1. Open the Layers panel, and then do one of the following:
   - To hide a layer, uncheck the layer.
   - To show a hidden layer, click the empty box and a checkmark will appear.

2. From the Options menu at the top right corner of the Layers panel, choose one of the following:
   - List Layers for All Pages – Shows every layer across every page of the document.
   - List Layers for Visible Pages – Shows layers only on the visible pages.
   - Reset to Initial Visibility – Resets layers to their default state.
   - Expand All – Expands all layers.
   - Collapse All – Collapses all of the current layers in the view.
   - Apply Print Overrides – Determines whether to display a layer according to its corresponding Print setting in the Layer Properties dialog box. The option is available when Never Prints or Always Print is selected.
   - Apply Export Overrides – Determines whether to display a layer according to its corresponding Export setting in the Layer Properties dialog box. The option is available when Never Exports or Always Exports is selected.
   - Apply Layer Overrides – Displays all layers in the document regardless of the settings in the Layer Properties dialog box, and you cannot change layer visibility until you deselect this command or choose Reset To Initial Visibility in the Options menu. However, you are still allowed to rename layers when the command is selected.

Import Layers (Business Only)

You can import layers from a PDF file or import images as layers into a target PDF file.

1. In the navigation pane, click the menu button  in the top right corner of the Layers panel, and choose Import as Layer....
2. In the Import as Layer dialog box, click Browse to choose a PDF file or an image file (Formats like BMP, GIF, JPEG, JPEG 2000, PCX, PNG, and TIFF, are supported.). If you import from a PDF file, choose a page number you want to import from.
3. Import Options:  
   Create new layer: creates a new layer from the source file. Specify a layer name, and add it to an existing layer group in the target document as needed.
Add to existing layer: adds the imported content to an existing layer in the target document. The imported layer will have the same properties as the existing one. This option is available only when the target document contains layers.

Copy layers from source: imports the layers from the source PDF file. This option is available only when the source PDF file contains layers.

4. In the right part of the dialog box, select a target page number to import the layers to, and preview the result.
5. Complete the settings in Position and Appearance as needed.
6. Then click OK.

Merge Layers (Business Only)

1. In the navigation pane, click the menu button in the top right corner of the Layers panel, and choose Merge Layers....
2. In the Merge Layers dialog box, select one or more layers you want to merge and the target layer to merge the selected layers into.
3. Then click OK.

Note: Merged layers will have the same properties of the target layer. After you merge the layers, you cannot undo the operation.

Flatten Layers (Business Only)

1. In the navigation pane, click the menu button in the top right corner of the Layers panel, and choose Flatten Layers.
2. A warning message pops up, telling you that the flattening operation cannot be cancelled or undone.
3. Then click OK.

Note: After the flattening operation, all layers will be consolidated, while the layers that are originally not visible will be removed. After you flatten the layers, you cannot undo the operation.

Delete Layers

1. In the navigation pane, select the layer you want to delete.
2. Click the menu button in the top right corner of the Layers panel, and choose Delete Layer, or press Delete on the keyboard. Or, right-click the layer and choose Delete Layer from the context menu.
Note: When you delete a layer, its corresponding content will be removed.

Reorder Layers

You may need to change the order of layers in the list, or move a layer from one layer group to another. In the navigation pane, to reorder a layer, just press Alt while you click the layer’s name and drag it to the desired location. You can undo or redo the operation. (Note: You cannot reorder locked layers or layers in nested layer groups.)

Layer Properties

By editing layer properties in the Layer Properties dialog box, you can control the visibility of layers and set whether to print or export layers. For example, you can hide a layer whenever the document is displayed on screen, while ensuring that the layer always prints. You can view but cannot edit the layer properties in Standard edition.

1. To open the Layer Properties dialog box, select the layer, click the Options menu and choose Layer Properties... Or just right-click the layer and choose Properties... to open the Layer Properties dialog box.
2. Edit the layer name or any of the following:

   Intent – selects View and the visibility and properties of the layer can be edited any time. Or, selects Reference to keep the current visibility and setting at all times until you switch to View.

   Default State – Defines the initial visibility state when Visibility in Initial State is set to Visible When On.

   Visibility – Defines the visibility of the layer when the document is opened or when the initial visibility is reset. If you choose Visible When On, the layer is visible only when Default State is On.

   Print – Defines whether the layer will be printed when you print the PDF. If you choose Print When Visible, the layer will print only when the layer is visible.

   Export – Defines whether the layer will appear in the resulting document when the PDF is exported to an application or file format that supports layers. If you choose Export When Visible, the layer will appear in the resulting document only when the layer is visible.

   The previous settings in Initial State like the states of Print, View, and Export, are shown in the box at the bottom of the Layer Properties dialog box.
PDF Properties

To view and modify the PDF properties, please navigate to **File > Properties.**

**Description**

This tab shows some basic information about the document. The person who created the document in the source application may have set the title, subject, author, and keywords. Click **Custom**, and the pop-up **Custom Properties** dialog box shows some document information (such as comments and the company name). You can easily edit the document information within the PDF document, a useful way for searching and indexing files.

You can also customize document properties by clicking **Custom**. In the pop-up **Custom Properties** dialog box, input the property name and the value, and then click **Add** to add a custom property. To change the value of a property, select it and update the value, and then click **Change**. To change the name of a custom property, you need to delete the property and create a new custom property. To delete a property, select it and click **Delete**.

**Initial View**

When a user opens your PDF document, they see the initial view of the PDF. You can set the initial view to the magnification level, page and page layout that you want.

- **Layout and Destination**

  **Navigation Tab**: Chooses desired panels to be displayed in the navigation pane.

  **Page Layout**: Chooses a page layout option to view the document. The default is **Continuous**.

  **Magnification**: Chooses a zoom level that the document will appear at when opened. The default is the magnification set in **File > Preferences > Page Display > Zoom**.

  **Open to page**: Specifies the page that appears when you open the document.

- **Window Options**

  **Display document title**: Shows the document title in the title bar of the application window. You can view the document title in **File > Properties > Description**.
Open in Full Screen mode: Opens the document in Full Screen mode. The document pane fills the entire screen, with the toolbar, the navigation pane, and the status bar hidden behind.

Center window on screen: Places the application window in the center of the screen area.

Resize window to initial page: Adjusts the application window size to the default magnification set in File > Preferences > Page Display > Zoom.

✧ User Interface Options

Choose options to hide parts of the interface as needed.

Define the initial view as Full Screen mode

If your PDF is a presentation, you may want to set the initial view to Full Screen Mode. After you define the initial view of the PDF, you can add page transitions to selected pages of the entire document. When setting the initial view of a PDF to Full Screen mode, you must define how the document opens.

2. For best results, do the following:
   ✧ Choose Page Only from the Navigation tab menu.
   ✧ Choose Single Page from the Page layout menu.
   ✧ Set Open to page to the page on which you want to start the presentation.

3. Select Open in Full Screen mode to open the document without the toolbar displayed. Click OK. (You have to save and reopen the file to see the effects.)

Note: Users can exit Full Screen mode by pressing Esc if their preferences are set this way. However, in Full Screen mode, users cannot apply commands and select tools unless they know the keyboard shortcuts. You may set up page actions in the document to provide this functionality.

Security

This tab describes security permissions and what functionality is allowed within a PDF. See also “Checking PDF Security”
Fonts

The Fonts tab lists the fonts and the font types used in the original document, as well as the encoding used to display the original fonts.

Advanced

This tab lists the items of Print Dialog Presets which prevail over the settings in the Print dialog box during printing.

Page Scaling: Chooses Default to scale the page with the application default setting when printing, which is Fit to printer margins. Or choose None to preserve the scale in the documents. To print with additional page scaling types as shown in the Print dialog box, you need to choose one of them when printing.

DuplexMode: Chooses Simplex to print on one side of the page. Or choose Duplex Flip Long/Short Edge to print a document double sided and flip pages on long/short edges.

Paper Source by Page Size: Automatically selects the paper type according to the page size of the PDFs when printing.

Pages: Specifies the page range you want to print.

Number of Copies: Chooses the number of copies you want to print. Or choose Default to use the application default copies, which is one copy.

Binding: Choose a reading direction in which you read a document in Facing or Continuous Facing mode. Choose Left Edge to read from left to right, or choose Right Edge to read from right to left.

Language: Specifies the document language that screen readers use to read the document. You can select languages by typing ISO 639 Code.
Chapter 6 – Organize

Foxit PhantomPDF comes with a built in functionality to combine various PDF files & split one PDF into various small single & multiple page PDF files according to page numbers as well as page range. You can rearrange pages and composing page outlines with the commands under the ORGANIZE tab, which allow you to insert, move, replace and crop pages, split documents, add page marks (such as header & footer) to PDFs, and more.

See also the tutorial on Organize PDF Documents.

Insert Pages

Foxit PhantomPDF enables you to insert pages from files (either from a page range or the entire file), a folder, a scanner, clipboard and a blank page. You can also insert pages into multiple documents at a time.

Insert pages from file

Foxit PhantomPDF allows you to insert pages from a file or multiple files into a PDF.

To insert pages from a file or multiple files (not limited to PDFs) into a PDF, do either of the following:

- Directly drag and drop the page thumbnails from a PDF file to the Pages panel of the navigation pane of the other PDF file. (Tip: If you click on a page thumbnail and press the shortcut keys Ctrl-A, all page thumbnails will be selected.) To insert certain pages from a non-PDF file, please choose the other method.

- Choose Organize/Home > Insert > From File, or click the Insert button on the Pages panel of navigation pane, or right-click a page thumbnail and choose Insert Pages... > From File. In the Open dialog box, navigate through your local disk to select a local file or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM, and click Open. If the files are non-PDF files, you can select Yes in the pop-up Foxit PhantomPDF message to temporarily convert them into PDFs so that you can preview them in the following steps. Then do the following steps:

  1. In the Insert Pages From dialog box, you can add more files, folders and
open files by clicking the Add Files... button. When clicking the button and choosing Add Files, you can choose files from local drives or click Open from ECM to select files from ECM systems and cloud services.

2. In the files list, select a file and click Move Up/Down to change the order you insert the files, or click Remove to delete the file.

3. Then choose one file you added, specify where you want to insert to the current PDF document (at the beginning or the end, or before or after a designated), and page range (insert from ...to ...) of the file that you want to insert.

4. Check Show Preview in the lower left corner, and you can preview the target page and the insert page in preview boxes. Click OK to insert the pages.

5. To leave the original PDF intact as a separate file, choose File > Save As, and type a new name for the merged PDF.

Note:

1. When a whole file is inserted, its bookmarks and file attachments will be inserted as well. The bookmarks will be inserted at the end of the bookmarks of the original PDF by default. The links of the bookmarks inserted remain unchanged. And the combined bookmarks will be the bookmarks of the combined PDF file.

2. With a mouse with a scroll wheel, you can press and hold Ctrl while scrolling up/down to zoom in or out the page thumbnails in the Pages panel.

Insert pages from folder

1. Open a PDF file, and choose Organize > Insert > From Folder, or right-click one page thumbnail and choose Insert Pages... > From Folder.

2. The Browse For Folder dialog box pops up. Select the folder that you want to insert into the target document, and click OK. (See also “Insert pages from file”.)

Insert pages from open files

1. Open a PDF file, and choose Organize/Home > Insert > From Open Files, or right-click one page thumbnail and choose Insert Pages... > From Open Files.

2. (Optional) directly drag the page thumbnails from an open PDF file and drop at the target place of the current PDF file.

3. In the pop-up Open PDF Files dialog box, select files you want to insert and click Add
Files to continue. (See also “Insert pages from file”.)

Insert pages from a scanner

You can insert pages from a paper document using Foxit PhantomPDF and your scanner.

1. Open the PDF that you want to serve as the basis of the combined file, and choose Organize > Insert > From Scanner (if you have configured presets, you can choose a predefined preset or choose Organize > Insert > From Scanner > Scan to scan pages with new settings), or right-click one page thumbnail and choose Insert Pages… > From Scanner. See also Scan with a Configured Preset.
2. In the pop-up From Scanner dialog box, specify the place you want to insert pages.
3. Then select a scanner, the input and documents options in the Custom Scan dialog box, and then click Scan.

See also “Create a PDF Using Scanner”

4. To leave the original PDF intact as a separate file, choose File > Save As, and type a new name for the merged PDF.

Insert pages from clipboard

1. Open a PDF file, and choose Organize > Insert > From Clipboard, or right-click one page thumbnail and choose Insert Pages… > From Clipboard.

2. In the pop-up From Clipboard dialog box, specify the place you want to insert pages. Then the content in the clipboard will be inserted.

3. To leave the original PDF intact as a separate file, choose File > Save As, and type a new name for the merged PDF.

Insert pages from a blank page

1. Open the PDF that you want to use as the basis of the combined file, and choose Organize > Insert > Blank Page, or right-click a page thumbnail and choose Insert Pages… > Blank Page.

2. In the Insert Blank Pages dialog box, specify where in the document you want to insert the blank pages (as well as how many blank pages you want to insert), and click OK.

3. To leave the original PDF intact as a separate file, choose Save As, and type a new
name for the merged PDF.

**Insert pages into files**

1. Open the PDF file (i.e. source file) from which you want to choose a range of pages (i.e. source pages) to be inserted into other files. Click Organize > Insert > Into File, or right-click a page thumbnail and choose Insert Pages... > Into File.
2. In the pop-up Open dialog box, choose the file (i.e. target file) to which you want to insert the source pages and click Open.
3. In the pop-up Insert Pages Into dialog box, you can add more target files by clicking Add Files....
4. Then specify the page range to be inserted and the destination in the target files.
5. Choose whether to keep the source pages in the source PDF file after inserting.
6. Click Output Options to specify the output folder and the file names.
7. Check Show Preview in the lower left corner, and you can preview the target page and the insert page in preview boxes. Click OK to insert the pages.

**Rotate, Move, Swap and Delete Pages**

**Rotate Pages**

You can rotate all or selected pages in a document.

1. Open the PDF document within which you want to rotate pages.
2. (Optional) To rotate one page, choose Organize > Rotate Pages > Left/Right. Rotation is based on 90° increments.
3. To rotate one or more pages, please use one of the following methods:

   ✷ Choose Organize > Rotate Pages > Multi-page rotate.
   ✷ Right-click the selected page thumbnails and choose Rotate Pages.
   ✷ Select multiple page thumbnails in the Pages panel and click the Rotate Counterclockwise button and Rotate Clockwise button. Rotation is based on 90° increments.
4. In the pop-up Rotate Pages dialog box, specify the direction you want to rotate the pages and the page range.
5. Click **OK**.

*Note:* To temporarily change your view of the page, choose **View > Rotate View > Rotate Left** or **Right**. The original page orientation is restored the next time you open the PDF.

### Move Pages

The Move Pages feature allows you to move pages within a PDF document.

**Move one or more pages within a PDF document**

1. Open the PDF document within which you want to move pages.
2. Choose **Organize > Move**, or right-click the page thumbnail and choose **Move Pages**....
3. In the Move Pages dialog box, specify where you want to move pages within the document, and page range that you want to move.
4. Click **OK**.

**Move one or more pages within a PDF, using page thumbnails**

1. Click the Pages button to open the Pages panel, and select one or more page thumbnails.
2. To move a page, drag the page thumbnail(s) to the new location.

*Tip:* Press “Ctrl/Shift + click/arrow” to select multiple page thumbnails at one time. If you need to select all the page thumbnails, select one page thumbnail first, and then press Ctrl + A.

### Swap Two Pages

The Swap feature is useful sometimes if you want to swap two different pages within a PDF document.

1. Open the PDF document within which you want to swap pages.
2. (Optional) Directly drag and drop the page thumbnail to the target location in the Pages panel of navigation pane.
3. Choose **Organize > Swap**, or right-click the page thumbnail and choose **Swap Pages**....
4. In the Swap Two Pages dialog box, select or enter two different page numbers in the **Swap** and **For** options.
5. Click **OK**.

**Delete Pages**

After combining PDF files, you can delete unwanted or blank pages.

**Delete Pages using the Delete command**

1. Open the PDF document where you want to delete pages.
2. Choose **Organize > Delete**.
3. Specify a page range and click **OK** to delete the selected pages. If your PDF contains formatted page numbers, and the **Use logical page numbers** option is enabled in **File > Preferences > Page Display**, you should enter the numbers that match the numbering on the pages rather than the physical page numbers. For instance, if you want to remove the second page of your document which is numbered ii, you should enter ii to remove the page. See also the preference setting on **logical page numbers**.

**Note:** If you want to retain a copy of the original PDF, make sure that you save the new document using **Save As** rather than **Save**.

**Delete Pages using page thumbnails**

1. In the Pages panel, select a page or group of pages:
   - Drag the mouse to select the page thumbnails.
   - Shift-click or Ctrl-click to select a range of page thumbnails.
2. Press **Delete** to delete the selected pages. Or right-click the selected pages, choose “Delete Pages...” in the context menu and click **OK**.

**Extract, Duplicate and Replace Pages**

**Extract Pages**

Extraction is the process of reusing selected pages of one PDF in a different PDF. Extracted pages contain not only the content but also all form fields, comments, and links associated with the original page content.
You can leave the extracted pages in the original document and create a new PDF that includes all of the extracted pages during the extraction process - comparable to the familiar processes of cutting-and-pasting or copying-and-pasting, but on the page level.

**Note:** Any bookmarks or article threading associated with pages are not extracted.

1. Open the PDF in Foxit PhantomPDF and choose **Organize > Extract**. Check **Show Preview** to preview the current document in the pop-up **Extract Pages** dialog box.
2. (Optional) Right-click the page thumbnails that you want to extract and choose **Extract Pages**... to open **Extract Pages** dialog box.
3. In the **Extract Pages** dialog box, specify the page range to be extracted. To extract even or odd pages, the page range should include both one even page and one odd page at least.
4. Choose a type of **Extract Mode**:

   **Extract pages as one PDF:** The extracted pages will be placed in a new PDF document named “Extracted pages from [original document name].pdf”.

   **Extract pages as several PDFs by comma (,) sign:** With this option selected, if you have specified several page ranges separated by comma, pages in each page range will be extracted and placed in a separate PDF document. The generated PDFs will be named “[original document name]_1.pdf”, “[original document name]_2.pdf”, and so on.

   **Extract each page as a PDF:** Each extracted page will be placed in a separate PDF named “[original document name]_1.pdf”, “[original document name]_2.pdf”, and so on.

5. Select the following options as needed:

   **Immediately save extracted pages:** save the extracted pages into a new PDF file after you click **OK**. The saved file will not be opened in Foxit PhantomPDF automatically. If the item is not checked, a new PDF file that includes the extracted pages will be opened without being saved. You will have to manually save it.

   **Delete the pages after extraction:** delete the selected pages from the original document.

6. Click **OK** after setting.

**Note:**
Chapter 6: Organize

1. The creator of a PDF document can set the security to prevent the extraction of pages. To view the security settings for a document, choose File > Properties, and select Security tab.

2. If you choose Extract pages as several PDFs by comma (,) sign or Extract each page as a PDF, the Immediately save extracted pages option is not available. You will need to choose a folder to store the generated PDFs after clicking OK.

Duplicate Pages

The Duplicate Pages feature allows you to copy pages within a PDF document.

1. Open the PDF document within which you want to copy pages.

2. Choose Organize > Duplicate, or right-click the page thumbnail and choose Duplicate Pages....

3. In the Duplicate Pages dialog box, specify where you want to copy pages within the document and the page range that you want to copy.

4. Click OK.

Tip: You can also duplicate page(s) within a document or in different documents by dragging and dropping, or using the Copy and Paste commands.

- Dragging and dropping: To duplicate pages within a document, drag the page thumbnails of the pages you want to duplicate while pressing and holding down the Ctrl key in the Pages panel, and drop at the desired place (The Line icon shows the place where the pages will be located. ). To duplicate pages in different documents, drag and drop the page thumbnails you want to duplicate to the other document, and drop at the desired place.
- Copy and Paste: Right-click the page thumbnail(s) you want to copy and choose Copy from the context menu, or select the page thumbnail(s) you want to copy and press Ctrl + C. Then select the desired page thumbnail you want to paste the page(s) after, and choose Paste from the right-click menu, or press Ctrl + V.

Replace Pages

You can replace an entire PDF page with another PDF page. The text, images and comments on the original page will be replaced.

To quickly update a PDF, you can replace individual pages.
1. Open the PDF that contains the pages you want to replace. Choose Organize > Replace or right-click the page thumbnails that you want to replace and choose Replace Pages....

2. In the Open dialog box, select the PDF document containing the replacement pages, then click Open. (Tip: In the Open dialog box, you can also click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, ndOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.)

3. In the pop-up Replace Pages dialog box, from the original PDF file select pages you want to replace and select replacement pages from the selected file. You can click Browse to change the selected file.

4. Click OK to finish.

**Note:** The bookmarks associated with the original pages will be unavailable after the replacement.

### Split PDFs into multiple files

The Split Document feature is a process of splitting one or more documents into multiple smaller-size documents.

1. Open the PDF document you want to split.

2. Choose Organize > Split , or right-click on the target page thumbnails and choose Split Document in the context menu.

3. In the Split Document dialog box, enter the maximum number of pages or file size after splitting, or choose whether to split by the top-level bookmarks if the document has bookmarks. You can also specify the specific page range you want to split by in the current PDF.

4. Select Blank Page, and the document will be split each time a blank page is encountered. Blank pages will be discarded when splitting.

5. (Optional) Click Select More Files... to split more files using the splitting setting in the step above.

6. Click Output Options to specify the storage location, the file names, and other settings.

7. Click OK.
Crop Pages

The Crop Pages feature allows you to adjust the visible page area. You can create a PDF document with pages of different sizes.

**Crop one or more pages**

1. Open the PDF document you want to crop.
2. Right click the target page(s) on the Pages thumbnails, choose **Crop Pages**.
3. In the pop-up Crop Pages dialog box, specify the settings in the Margin Control: select CropBox, ArtBox, TrimBox, or BleedBox (they are displayed in the preview box in black, red, green and blue respectively) and adjust the proportions to crop. You can preview all the boxes on the right after checking the item **Show All Boxes**.

**CropBox** – Defines the content boundary of the page when it's displayed or printed.

**ArtBox** – Defines the meaningful content of the page including blank space.

**TrimBox** – Defines the final dimensions of the page after trimming.

**BleedBox** – Defines the clipping path when the page is printed professionally to allow for paper trimming and folding. Printing marks may fall outside the bleed area.

**Constrain Proportions** – Locks the cropped proportions and each margin will have the same distance from each side to the border.

**Remove White Margins** – Crops the page to the artwork boundary, which is useful for trimming the edges of presentation slides saved as PDFs.

**Set To Zero** – Restores all the crop margins to zero.

**Reset** – Resets all the margins to the original dimensions.

4. A rectangle in the page thumbnail showed in the preview box shows the boundaries of the cropped area.
5. Set the page size and adjust the center of the page content if needed.
6. Choose the page range you want to crop.
7. Choose the unit of the margin cropping values.
8. Click **OK**.
Crop one page

1. Choose **Organize > Crop Pages** , the cursor will change to . Drag the cursor to select an area you want to crop. Then double-click the area you cropped.

2. In the pop-up Crop Pages dialog box, the margin measurement indicates the size of the area you selected. You can directly click **OK** or provide new settings in the dialog box.

*Note*: **Cropping does not reduce file size because information is not discarded but merely hidden. So you can restore the page and its content to its original dimensions by resetting the page size.**

Flatten Pages

The Flatten Pages feature can make annotations and form fields in the PDF file become part of objects of the PDF pages. This feature is often used when you want all the comments and form fields to be permanent so that the document receivers cannot modify them (unless they change them with editing tools), or when you want to lock the PDF document after completing the form fields to ensure that the document can be viewed consistently on all devices.

After flattening, many items in the document are changed:

- Text Markup, Note comments, and Drawing markup comments: The markups and Note comment icons change into shape objects. However, the text in their pop-up notes is lost.
- Typewriter, Callout, Text Box: the boxes or frames change into shape objects, while the text in the comment changes into text object.
- File attachments: For a file attachment added with the **File** command under the **Comment** tab as a comment, only the icon remains (which also changes into a shape object), while the file is removed from the document and can no longer be opened. *(Note: The file attachments added with the **File Attachment** command in the **Edit** tab are not changed after flattening.)*
- Stamps: The stamps in the stamp palette provided by Foxit change into shape objects and the dynamic information (if any) embedded in the stamps
changes into text objects. The stamps that are created with images change into image objects; stamps created with a PDF page change into text/image/shape objects based on the content on that page.

- Form fields: All form fields can no longer be filled or modified. Only the items that are visible with Hand command selected remain and change into shape objects.
- Movies: The movies are no longer available. Only the items that are visible with Hand command selected remain and change into shape objects.
- Redaction: For the redaction that has been applied, only the black (or other colors) rectangle that blocks out redacted content remains and changes into a shape object, while the redacted content (the underlying content) cannot be seen or searched. For the content that has been marked for redaction (the redaction has not been applied yet), flattening the file does not remove the content and the black rectangle changes into a shape object.

To flatten pages, do as the following:

1. Open the PDF document where you want to flatten pages.
2. Choose Organize > Flatten.
3. In the Flatten Pages dialog box, specify the page range (current page, all pages, a range of pages), and click OK.

*Note: The flattening operation cannot be undone. If you want to retain a copy of the original PDF, make sure that you save the new document using Save As rather than Save.*

**Reverse Pages**

You may need to reverse a range of pages that are created in reverse order, which happens a lot when you are scanning paper to PDF. If the PDF contains a large number of pages, reordering them manually will cost you a lot of time. With Foxit PhantomPDF, you can reverse a range of pages in a few quick steps.

1. Open the PDF document where you want to reverse pages.
2. Choose Organize > Reverse, or right-click any page thumbnail and choose Reverse Pages.
3. In the Reverse Page Order dialog box, specify a range of pages you want to reverse.
4. Click OK.
Header & Footer, Watermark & Background to PDFs

Add Header/Footer, Watermark/Background to PDFs with Text, image and PDF, making your PDFs more professional and easy to view, navigate watermark and place marks on documents.

See also the tutorial on Professionalize Documents.

Header & Footer

To add a new header & footer, please do the following:

With a document open in the application window, do the following:

1. Choose Organize > Header &Footer > Add.
2. Specify the Font and Margin settings and type the text of header & footer in the text boxes in the “Add Headers and Footers” dialogue box.
3. (Optional) You can insert page numbers, the filename, or the current date to the text of header & footer. Click in a text box, select a corresponding option and click Insert. To change the formatting, click Page number and date format. To specify the page range where you want to add the header & footer, click Page Range Options....
4. (Optional) Click Save Settings at the top of the dialog box to save the current settings as a profile that can be applied directly to future documents.
5. Click OK to activate the operation.

With no document open (or when you are on the Start page) in the current application window, do the following:

1. Choose Organize > Header &Footer > Add.
2. In the “Add Header and Footer” dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. (Tip: You can also add files by directly dragging and dropping them to the box.) In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click Output Options. Here, you can set the target output folder and name the file in the pop-up Output Options dialogue box. Click OK to exit the Output Options dialog box after completing these settings.
4. In the “Add Headers and Footers” dialog box, click OK to continue.
5. Specify the settings as needed in the pop-up “Add Headers and Footers”
dialogue box. See also the steps for adding headers & footers with a document open. Then click OK to activate the operation.

**To update the header & footer, please do the following:**

1. Choose Organize > Header &Footer > Update.
2. Update the content in the "Update Headers and Footers" dialogue box.
3. Click OK to activate it.

**To remove the header & footer, please do the following:**

To remove the header and footer from the current document, choose Organize > Header &Footer > Remove All. Click “Yes” in the pop-up message box. To remove headers and footers from multiple documents, do the following:

1. Close any open documents or switch to the Start page in the current application window, and then choose Organize > Header &Footer > Remove All.
2. In the pop-up dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. (*Tip: You can also add files by directly dragging and dropping them to the box.*) In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click Output Options. Here, you can set the target output folder, name the file and create the log file in the dialogue box. Click OK to exit the box after completing these settings.
4. Click OK to activate it.

**Background**

**To add a new background, please do the following:**

1. Open a document where you want to add a background and choose Organize > Background > Add.
2. Edit the background in the “Add Background” dialogue box.
   - Choose one color as the background, or add the file from your computer via clicking the browse button. If the file has many pages, you can select one of them.
• Set the appearance by choosing the rotation degree, the opacity. You can also choose to make the scale relative to the target page or not. Click “Appearance Options” to set when to display the background.
• Set the vertical and horizontal distance between the target page and the background.
• Choose the page range to play the background. You can select all pages or specify the page range, or choose even pages or odd pages via clicking the right items in the subset list.
• Check or uncheck the Show Preview option to preview the changes or not.

3. (Optional) Click Save Settings at the top of the dialog box to save the current settings as a profile that can be applied directly to future documents.
4. Click OK to activate it.

Note: If there is no document open or you are on the Start page in the current application window, a dialog box will pop up after you choose Organize > Background > Add. In the dialog box, you can add files where you want to add backgrounds and set the output options as needed. See also Add header & footer with no document open.

To update the background, please do the following:

1. Choose Organize > Background > Update.
2. Update the content in the “Update Background” dialogue box.
3. Click OK to activate it.

To remove the background, please do the following:

To remove the background from the current document, choose Organize > Background > Remove All. Click “Yes” in the pop-up message box. To remove backgrounds from multiple documents, do the following:

1. Close any open documents or switch to the Start page in the current application window, and then choose Organize > Background > Remove All.
2. In the pop-up dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. (Tip: You can also add files by directly dragging and dropping them to the box.) In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click Output Options. Here, you can set the target output folder, name the file and create the log file in the dialogue box. Click OK to exit the box after completing these settings.
Watermark

To add a new watermark, please do the following:

1. Open a document where you want to add a watermark and choose Organize > Watermark > Add.
2. Edit the watermark in the “Add Watermark” dialogue box.

   - Input the text as the background and choose the font, size and the color, or add the file from your computer via clicking the Browse button. If the file has many pages, you can select one of them.
   - Set the appearance by choosing the rotation degree and the opacity. You can also choose to make the scale relative to target page or not. Click “Appearance Options” to set when to display the watermark.
     - If you choose the “appear behind page”, the page content will obstruct your view of some part of the watermark.
     - If you choose the “appear on the top of page”, the watermark will cover some content, but you can adjust it via setting the opacity of the watermark.
   - Set the vertical and horizontal distance between the target page and the watermark.
   - Choose the page range to play the watermark. You can select all pages or specify the page range, or choose even pages or odd pages via clicking the right items in the subset list.
   - Check or uncheck the Show Preview option to preview the changes or not.

3. Click Save Settings at the top of the dialog box to save your current settings as a profile that can be applied to other documents directly next time.
4. Click OK to activate it.

Note: If there is no document open or you are on the Start page currently in the current application window, a dialog box will pop up after you choose Organize > Watermark > Add. In the dialog box, you can add files where you want to add watermarks and set the output options as needed. See also Add header & footer with no document open.
To update the watermark, please do the following:

1. Choose Organize > Watermark > Update.
2. Update the content in the “Update Watermark” dialogue box.
3. Click OK to activate it.

To remove the watermark, please do the following:

To remove the watermark from the current document, choose Organize > Watermark > Remove All. Click “Yes” in the pop-up message box. To remove watermarks from multiple documents, do the following:

1. Close any open documents or switch to the Start page in the current application window, and then choose Organize > Watermark > Remove All.
2. In the pop-up dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. (Tip: You can also add files by directly dragging and dropping them to the box.) In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click Output Options. Here, you can set the target output folder, name the file and create the log file in the dialogue box. Click OK to exit the box after completing these settings.
4. Click OK to activate it.

Bates Numbering (Business Edition Only)

What’s Bates Numbering?
Bates numbering is used in the legal, medical, and business fields to place identifying numbers and/or date/time-marks on images and documents. These numbers may be solely numeric or may contain a combination of letters and numbers. It is a unique serial number attached to every page of a document collected and is also a method of indexing legal documents for easy identification and retrieval.

Add Bates Numbering

2. In the “Add Bates Numbering” dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. (Tip: You can also add files by directly dragging and dropping them to the box.) In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click **Output Options**. Here, you can set the target output folder, name the file and create the log file in the dialogue box. Click **OK** to exit the box after completing these settings.

4. Click **OK** and a dialog box to add Headers and Footers will pop up for you to insert Bates Numbering on the PDF documents.

5. Select **Bates Number** in the **Macro** menu, and then click **Insert**.

6. Another dialog box will appear for setting the number of digits (any number from 3 to 15), the increment, the start number, rotate angle and the prefix/suffix, if needed. **(Tip: Setting the value of the increment to a negative number reverses the order of the Bates numbering.)** Click **OK** to finalize the setting.

7. Click **OK**.

**Remove Bates Numbering**

Choose Organize > Bates Numbering > Remove All.

**Change the format of page numbering**

If your PDF file contains front matter like document cover and copyright page, the page numbers on the document pages (i.e. the printed page number) may not start from the document cover but from the body pages. You may need to synchronize the page numbers displayed below the page thumbnails in PDF viewers with the printed page numbers. Foxit PhantomPDF enables users to change the format of page numbering displayed in PDF viewers to meet different needs.

To change the format of page numbering, please do as below:

1. Click **Organize > Format Page Numbers**. Or right-click a page thumbnail and select **Format Page Numbers**.

2. In the Page Numbers dialog box, specify a range of pages you want to number and set the style of page number and the number you want to start at. You can also add a prefix to the number, like adding a letter “P” before the number. You can preview the result in the **Sample** at the bottom of the dialog box.

3. If you need to continue the numbering sequence from previous pages without interruption, please check **Extend numbering used in preceding section to selected pages**.

4. Click **OK** to finish.

**Note:** Make sure the **Use logical page numbers** option is enabled in **File > Preferences > Page display** to display the customized page numbering.
Chapter 7 – Comment

Foxit PhantomPDF provides you with various commenting tools to add comments in PDF documents. Comments can be notes or drawings that are intended as an opinion, an explanation, an illustration, or a statement of fact or opinion, especially a remark that expresses a personal reaction or attitude. You can type a text message or add a line, circle, or other shape to make comments on PDFs you are reading with Foxit PhantomPDF commenting commands. You can also edit, reply, delete, and move the comments with ease.

Commenting tools

There are various annotation tools with different functions for you to choose: Text Markup Tools, Pin Tools, Typewriter Tools, Drawing Tools, Measure Tools and Stamp Tools. You can add different comments by selecting the annotation tools from the Comments tab or Toolbar. See also the tutorial on Commenting Tools.

*Note: If you want to add multiple comments without reselecting the same tool, you can check Keep Tool Selected at Comment > Manage Comments.*

Text Markup Tools

You can use Text Markup tools to indicate where text should be edited or noticed. Text Markups fall within the comments category and can be made visible/invisible by clicking Comment > Comments > Show All/Hide All. They do not change the actual text in the PDF. Instead, they indicate which text should be deleted, inserted, highlighted or underlined. Text Markup tools include Highlight, Squiggly, Underline, Strikeout, Replace, and Insert.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="highlight.png" alt="Highlight" /></td>
<td>Highlight</td>
<td>To mark important passages of text with a fluorescent (usually) marker as a means of memory retention or for later reference.</td>
</tr>
<tr>
<td><img src="squiggly_underline.png" alt="Squiggly Underline" /></td>
<td>Squiggly Underline</td>
<td>To draw a squiggly line under. Similar to the Underline command.</td>
</tr>
<tr>
<td><img src="underline.png" alt="Underline" /></td>
<td>Underline</td>
<td>To draw a line under to indicate emphasis.</td>
</tr>
<tr>
<td><img src="strikeout.png" alt="Strikeout" /></td>
<td>Strikeout</td>
<td>To draw a line to cross out text, making others know the text is deleted.</td>
</tr>
</tbody>
</table>
### Chapter 7: Comment

#### Table of Markups

<table>
<thead>
<tr>
<th>Markup</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📝</td>
<td><strong>Replace Text</strong> To draw a line to cross out text and provide a substitute for it.</td>
</tr>
<tr>
<td>📝</td>
<td><strong>Insert Text</strong> A proofreading symbol (^) used to indicate where something is to be inserted in a line.</td>
</tr>
</tbody>
</table>

#### Add a text markup comment

1. In the **Comment** tab, select a type of text markup. Then click and drag from the beginning of the text you want to mark up.

2. (Optional) Select the Hand command 🖋️, Select Annotation command 📝, or the corresponding Text Markup tool, right-click the markup and choose **Open Popup Note** (Alternatively, just double-click the markup to open the pop-up note). Type text in the pop-up note. You can also use the Select Text and Image command to copy and paste text from a PDF into the note, or copy the note using Ctrl + C in other applications. Text that you input in the pop-up note will be shown in the default font and size specified in the **Comment preferences**. If you need to format the text in the pop-up note, select the text and choose the desired option in the **Comment Format** context tab. When you change the font and size for text in the current pop-up note, Foxit PhantomPDF will remember the font and size, and apply them in the new pop-up notes until you change it or restart the application. After you change the font and size, the text format for the pop-up notes listed in the **Comments** panel will be changed accordingly as well. For highlighted text, a small sticky note will be shown around the text if it includes text comments in its pop-up note.

3. (Optional) Change the appearance of text markup comments in the **Comment Format** context tab that appears when you choose a text markup tool.

4. (Optional) Do one of the following to close the pop-up note.
   - Click the close button in the pop-up note.
   - Double-click the markup.
   - Right-click the markup, and choose **Close Popup Note**.
   - Choose **Close Popup Note** from the **Options** menu of the pop-up note.

#### Remove a text markup comment

If you need to remove a text markup comment, select the **Hand** command, the **Select Annotation** command 📝, or the corresponding commenting tool, and do either of...
the following:

- Right-click the comment and choose **Delete**.
- Select the comment and press **Delete** on the keyboard.

**Pin Tools**

You can use pin tools to add comments by adding notes and attaching a file. A note comment leaves a note icon on the page where you placed it, and a pop-up note for your text message (If the pop-up note disappears, you can double-click the note icon to show it.). Using the **File** command, you can attach a file in the document as a comment.

**Add a Note Comment**

1. To add a note comment, please click the **Note** command, click where you want to place the note and enter text in the box.
2. (Optional) Change the appearance of note comments in the **Comment Format** context tab that appears when you select a commenting tool.
3. (Optional) Text that you input in the pop-up note will be shown in the default font and size specified in the **Comment preferences**. If you need to format the text in the pop-up note, select the text and choose the desired option in the **Comment Format** context tab. When you change the font and size for text in the current pop-up note, Foxit PhantomPDF will remember the font and size, and apply them in the new pop-up notes until you change it or restart the application. After you change the font and size, the text format for the pop-up notes listed in the **Comments** panel will be changed accordingly as well.

**Add a file attachment**

To add a file attachment as a comment, do the following:

1. Click the button on the Pin group under the Comment tab.
2. Position the pointer to the place where you want to attach a file as a comment > click the selected position.
3. In the **Open** dialog box, select the file you want to attach, and click **Open**.
**Note:** If you try to attach certain file formats (such as EXE), Foxit PhantomPDF will provide you with a warning that your attachment will be denied due to your security settings.

4. The File Attachment Icon 📁 appears at the place you designated.

**Remove a note comment or a file attachment**

If you need to remove a note comment or a file attachment, select the Hand command, the Select Annotation command 📀, or the corresponding commenting tool, and do either of the following:

- Right-click the comment and choose **Delete**.
- Select the comment and press **Delete** on the keyboard.

**Typewriter Tools**

The Typewriter tools include Typewriter, Callout, and Textbox.

**Typewriter**

You can use the Typewriter command to add comments anywhere on a PDF.

*Note:* The Typewriter command can be used to fill forms. See also “Filling non-interactive forms”.

**I'm using the Typewriter Tool.**

**Add comments with typewriter**

- Choose **Comment > Typewriter**.
- Put the cursor on the area to type any text you want. The **Comment Format** context tab appears for you to specify the font format, add bulleted/numbered lists to paragraphs, align text, etc. See also the buttons in the **Font/Paragraph groups** in the **Edit** tab.
- Press **Enter** if you want to start a new line.
- To finish typing, click anywhere outside the text you have inputted.
Tip: It's easy to copy-and-paste text to PDF document as a typewriter annotation from a text document or webpage.

✧ Editing the typewriter comment

- Choose **Comment > Typewriter**.
- Put the pointer between the letters and double-click to activate the typewriter text field.
- Do any changes to the text you have inputted by using the **Comment Format** context tab. Use **Backspace** or **Delete** keys to delete the characters before or after the pointer.
- To finish editing, click anywhere outside the text field.

Tip: You can use the Arrow Keys to move the pointer right and left or up and down.

✧ Spell Checking Typewriter Input

You are able to use the Spell Checker to check your typewriter input and give you correcting suggestions if the security settings allow. The Spell Checker component has been integrated into Foxit PhantomPDF. However, in the future when an update of this component is available on the Foxit server, you have to manually download the component by going to **Check for Updates** in the Help menu of Foxit PhantomPDF.

If you have installed Spell Checker, when you use typewriter to insert any English text, this tool will try to find any spelling errors and highlight them with squiggly lines.

- Right click on the misspelled words, and you will see a list of suggested words.
- Choose one of the suggested words to correct your input or ignore the squiggly line.

✧ Move the typewriter comment

Do one of the following:

- Choose **Comment > Typewriter** and put the cursor on the typewriter comment when the cursor turns to be an arrow, hold down the mouse and drag the typewriter comment to the intended place.

**Tips:**

- You can use Home, End or Arrow Key to move the cursor among characters.
- When moving the typewriter comment, a rectangle appears.

- Select the Hand command or the Select Annotation command, click the typewriter comment, and move it to the intended place.
Delete the typewriter comment

- Choose **Comment > Typewriter**. Position the cursor to the ending or the beginning of the text, drag the cursor to select them all, and press the **Delete** key.

- *(Recommended method)* Click the Select Annotation command 🔄 or the Hand command 🧠, right-click the comment, and choose **Delete**.

### Callout and Textbox

Callout and Textbox are designed for users to create comments in a callout text box or a box.

A callout text box contains a text box and an arrow, which is especially useful when you want to single out (but not obscure) a particular area of a document.

![Callout example]

A textbox is a rectangle of any size, possibly with a border that separates the text box from the rest of the interface, allowing the user to input text information. A text box usually remains visible on the document page. It doesn’t close like a pop-up note.

![Textbox example]

*Note*: Callout text boxes and Textboxes allow for horizontal text only.

Add a callout or textbox

- Choose **Comment > Callout/Textbox**.
- Click the place where you want to insert the callout or text box. The **Comment Format** context tab appears for you to specify the font format, add bulleted/numbered lists to paragraphs, align text, etc. See also the buttons in
the **Font/Paragraph groups** in the **Edit** tab.

- Type the text. Text wraps automatically when it reaches the right edge of the box.

✧ **Resize, move, edit or delete a callout or textbox**

Select the **Hand** command  ![hand](), the **Select Annotation** command ![select] or the corresponding annotation tool, and do one of the following:

- To resize the callout or textbox, select it and drag any of the handles to resize it.
- To move the textbox only, click inside the box (the cursor changes to an **across**), and drag it to the intended place. To move the entire callout, click on the arrow or the edge of the box (the cursor changes to an **arrow**), and drag it to the desired place.
- To edit the callout or textbox, double-click it and do the editing by using the **Comment Format** context tab.
- To delete the callout or textbox, select it and press **Delete**, or right-click it and then choose **Delete**.

✧ **Setting callout or textbox preferences**

Please refer to “**Editing the typewriter comment**”.

### Drawing Tools

Drawing Tools allow you to mark up a document with rectangles, ovals, polygons, clouds, arrows, lines, polylines, etc. It is quite useful when you have to make some shapes to mark the text or image.

To add a drawing markup comment,

1. In the **Comment** tab, select a type of drawing markup. Then click and drag to make a shape you want to mark up.
2. (Optional) Change the appearance of drawing markup comments in the **Comment Format** context tab that appears when you choose a drawing markup tool.
3. (Optional) To add text message in the pop-up note for the markup, refer to **Text Markup Tools** for details.
### Button Tool Name Description

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>To draw a four-sided plane figure with four right angles. Press Shift key to draw a square.</td>
<td></td>
</tr>
<tr>
<td>Oval</td>
<td>To draw an oval shape or a circle with pressing Shift key.</td>
<td></td>
</tr>
<tr>
<td>Polygon</td>
<td>To draw a closed plane figure bounded by three or more line segments.</td>
<td></td>
</tr>
<tr>
<td>Cloudy</td>
<td>To draw cloudy shapes.</td>
<td></td>
</tr>
<tr>
<td>Arrow</td>
<td>To draw something, such as a directional symbol, that is similar to an arrow in form or function.</td>
<td></td>
</tr>
<tr>
<td>Line</td>
<td>To mark with a line.</td>
<td></td>
</tr>
<tr>
<td>PolyLine</td>
<td>To draw an open plane figure with three or more line segments.</td>
<td></td>
</tr>
<tr>
<td>Pencil</td>
<td>To draw free-form shapes.</td>
<td></td>
</tr>
<tr>
<td>Eraser</td>
<td>An implement, acts as a piece of rubber, used for erasing the pencil markups.</td>
<td></td>
</tr>
<tr>
<td>Area Highlight</td>
<td>To mark important area as a means of memory retention or for later reference.</td>
<td></td>
</tr>
<tr>
<td>Search &amp; Highlight</td>
<td>To mark the search results as a means of memory retention or for later reference. See also Search and highlight.</td>
<td></td>
</tr>
</tbody>
</table>

**Note:**
If you draw a cloud shape in a counterclockwise direction, the cloud comes out inward 🌈. If you draw the lines forming the shape in a clockwise direction, the cloud is created with the points outward 🌈.

**Tips:**
- To draw a line in horizontal, vertical, or at a 45 degree angle, press Shift while you draw with the Line command.
- To draw a square or circle with the Oval command or the Rectangle command, press Shift while you draw.

**Adding Free-form Annotation with PSI (Pressure Sensitive Ink)**

Foxit PhantomPDF adds PSI support for free-form annotation. You can use Surface Pro Pen or Wacom Pen to add free-form annotations with PSI in PDFs. Detailed steps are as follows:

- (For Surface Pro users) Choose **Comment > Pencil**, and then add free-form...
annotation as needed with Surface Pro Pen;

- (For Wacom tablet users) Connect your Wacom tablet to the computer, choose Comment > Pencil, and then add free-form annotation as needed with Wacom Pen.

**Edit, resize or move the markup**

Use the Hand command """, the Select Annotation command """, or the corresponding Drawing Tool to select a drawing markup.

- To edit the drawing markup, right-click, select **Properties** and do settings as needed.
- To resize the drawing markup, select it, put the cursor on one of the green points, and drag one of the handles to make your adjustments.
- To move the drawing markup, select it and drag it to the target place.
- To add a pop-up note to the markup, select it and double-click the markup or right-click it and choose **Open Popup Note**.
- If you draw a line or arrow, you can enable the comment to be shown on the line or arrow by checking **Show text in line** in the line properties box.
- Check **Set Current Properties as Default** so that the current settings can be applied next time by default.

**Delete the markup**

Select the markup and press the Delete key. Or right-click the markup and select **Delete**.

**Group the markups**

Grouping drawing markups enables you to combine them so that you can work with them as though they were a single object. You can move or delete the group, set its status, change its appearance, etc.

Select the Hand command """, or the Select Annotation command """, and do one of the following:

- To group/ungroup markups, select the markups you want to group/ungroup by pressing Ctrl > right-click **group/ungroup**.
- To work with a group, select one of the markups and then work with the group as other comments.
Measure Tools

The Measure Tools enable you to measure distances and areas of objects in PDF documents. The measure tools are especially useful when you need to know the distances or areas associated with objects in a form or computer-aided design (CAD) drawing or when you want to measure certain areas of a document before sending to a professional printer. The measure tools are available to users only if the PDF creator enables measuring functionality.

When you use a measure tool, the tool dialog box displays the measurements of the line segments you draw.

Measuring the objects

- Select the **Distance** command in the **Comment** tab to measure the distance between two points. While measuring the distance, you can specify whether to show the default leader on both side of the measurement points or not in **Measuring Preferences**. Click the first point, move the pointer to the second point, and click again. If you choose to use the default leader, move your mouse to determine the leader length, and then click on the document again to finish measuring. The measurements will appear on the page.

- Select the **Perimeter** command in the **Comment** tab to measure a set of distance between multiple points. Click the first point to start, and then click each point you want to measure. Double-click the last point to end measuring.

- Select the **Area** command in the **Comment** tab to measure the area within the line segments that you draw. Click the first point to start, and then click each point you want to measure. After you have clicked at least two points, click the first point or double-click the last point to complete the area measurement.

**Note:**

1. **When measuring, you can hold down** **SHIFT to snap the two points horizontally, vertically, or diagonally (in 45 degrees).**
2. **You can also choose to complete or cancel measurement by right-clicking the measurement and choosing options from the context menu.**

After you select the measuring tool, the **Comment Format** context tab appears, which
allows you to calibrate the scale ratio, snap measurement, export measurement markup, etc.

- If your PDF file includes embedded scale ratio, you can measure distance/perimeter/area using the embedded scale ratio. Before that, you need to select the **Use Scale and Units From Document (When present)** option in **File > Preferences > Measuring**. Then all the following measuring will use the embedded scale ratio. To calibrate the scale ratio for your document for an accurate result, choose either method of the following:

  ➢ With the **Use Scale and Units From Document (When present)** option selected:
    1) Click **Calibrate** in the **Scale Ratio** group and then click the two points of the line whose actual length has already been known. *(Tips: When drawing, you can hold down **SHIFT** to snap the two points horizontally, vertically, or diagonally. You can also click **Snap to Paths** in the **Snap group** to capture the path in the page.)*
    2) When the second point is selected, the **Calibration** dialog box pops up.
    3) Type the actual length that the line represents and choose the appropriate unit, which will set a new scale ratio.
    4) (Optional) If you already have the correct scale ratio, directly define the measurement value and choose the appropriate unit in the **Scale Ratio** group.
    5) Then in the **Scale Ratio** group or the pop-up **Calibration** dialog box, click **Store Scale in Page** to apply the new scale ratio to the current page, or click **Apply to All Pages** to apply it to all pages. The new scale ratio will be embedded into the page or all pages respectively, replacing the original embedded scale ratio.
    6) As the scale ratio is embedded into the document, the measurements in the document change accordingly.

  ➢ With the **Use Scale and Units From Document (When present)** option unselected, directly define a custom scale ratio in the **Scale Ratio** group, or click **Calibrate** in the **Scale Ratio** group to define a new scale ratio. The defined scale ratio will only be applied to the current page.

- Check **Show result information** if you want to see the current measuring result, including real distance, angle, horizontal and vertical position, etc.
- Check **Measurement markup** to add and show the measurement lines you draw in the PDF file. When this option is checked, you can add a label to measurement markups either by using the one specified in **measuring preferences** or inputting a new one in the **Add Label** box. The label for Distance markup will be shown in the distance measurement line, while the label for Perimeter and Area markups will be shown in their pop-up notes. When you put the pointer over the
measurement markups with the Hand command selected, you can also view the measurement result and label.

- Check **Rulers** to show the rulers.
- Choose one or more snapping types from the **Snap** group. For precise measurements, position the key points when moving the cursor.

1. **Moving the measurement markup**

   - With the Hand command 🧐 or the Select Annotation command ✍️ selected, click the measurement markup you want to move.
   - Place the cursor over the object when the pointer changes into ➝, hold and drag the mouse to move it to the intended place.
   - (For distance measurement markup only) To move the label as well as the measurement result shown on the distance measurement markup: click on the text shown on the markup to activate the text cursor 📝 > drag the label directly to a desired position.

---

*Note:* The object you draw will disappear when the Measurement Markup is deselected in the Distance dialog box.

---

**Working on the measurement markup**

After you complete the measurement, you are able to do further operations on it, such as move, resize, flip, and even work on it the way you work on comments.
2. **Changing the length and orientation of the line segment**
   - With the Hand command or the Select Annotation command selected, select one of the resize corners, you will see the pointer change into.
   - Hold and drag the mouse to change the length and orientation of the line segment.

3. **Flipping the measurement markup and the annotation**
   - Select the Hand command or the Select Annotation command.
   - Right-click the object you draw > select Flip.

4. **Adding, editing, or deleting the measurement label**

   Measurement labels will be added and shown in the measurement markups as you specified in Measuring Preferences or as what you set while adding a measurement markup. If a measurement markup does not contain a label, you can easily add a label to it with Foxit PhantomPDF. For existing labels, you can also edit or delete them. Steps are as follow:

   - Select the Hand command or the Select Annotation command.
   - To add a label to a measurement markup without label: right-click the measurement markup > select Add Label > input the label > click OK.
   - To edit an existing label: right-click the measurement markup > select Edit Label > input the label as desired > click OK.
   - To delete a label: right click the measurement markup > select Delete Label.

**Stamps**

The Stamp Tools in Foxit PhantomPDF are a group of advanced tools that enable you to stamp content and watermarks into a PDF document. Foxit PhantomPDF supports image stamps with various image formats (JPEG, GIF, BMP, WMF, etc.) and PDF file stamps. You can either create dynamic stamps which can obtain information from your system including name, date and time, or import existing dynamic stamps. Stamping PDF files is a very useful feature especially when you need to give reviewers some advices about the document's status or sensitivity.

**Stamp a PDF**

You can choose from a list of predefined stamps, or create custom stamps before stamping a PDF. All the stamps that you import or create are listed in the drop-down
menu of the Stamp command and Stamps Palette. To apply a stamp, please do the following:

1. Choose **Comment > Stamp > choose a stamp from the menu.** Or choose **Comment > Create > Show Stamps Palette**. In the Stamps window, select a category from the menu, and then select a stamp.
2. The cursor changes into a rectangle with the appearance preview of the stamp. Click on the position where you want to place the stamp, or drag a rectangle on the document page to define the size and placement.
3. (Optional) To apply the stamp to multiple pages, please right-click the stamp and choose **Place on Multiple Pages**. Specify the page range to place the stamp and click **OK**.

**Notes:**

1. **All the stamps that you import or customize will be listed after you click Stamp button,** you can choose directly a stamp from the menu. If you need to import Monteith stamps, please save the Monteith stamp file in “C:\Users\%user profile%\AppData\Roaming\Foxit Software\Foxit PhantomPDF\Stamps\UserStamps”. Before applying a Monteith stamp, you will need to set your identity information in the pop-up **User Identity** dialog box or in **Preferences > Identity tab**.
2. The date format shown on the dynamic stamp is the same as that you set in your system.

**Create a Stamp**

You can create custom stamps and dynamic stamps.

✧ **Creating a Custom Stamp**

1. Choose **Comment > Create > Create Custom Stamp.**
2. In the **Create Custom Stamp** dialog box, click **Browse** and choose an image file or a PDF file. If the selected file contains multiple pages, you can drag the scroll bar to select a page.
3. Type a new category name or choose a category from drop-down menu, name the stamp, and then click **OK**.

**Note:** **If the stamp you choose is an image file, you can adjust the opacity of the image via dragging the scrollbar as needed.** By default, Foxit PhantomPDF will create transparent stamps from images with a white background.

You can also create a stamp from the clipboard. Please do the following:

- Copy the image to the clipboard.
- Choose **Comment > Create > Paste Clipboard Image as Stamp Tool**, the cursor
will be changed into a rectangle.

- Put the cursor over the desired place and you're done.

การออกแบบเครื่องหมาย动态

You can create a Custom Dynamic Stamp to add text, author name and date time on stamps. Please do the following:

1. Choose Comment > Create > Create Custom Dynamic Stamp....
2. In the Create Custom Dynamic Stamp dialog box, choose one stamp template from the left list or create your own stamp template which can be an image file. Choose a category from drop-down menu or name a new one, then name the stamp.
3. Specify Font, Font Size and Font Color. You can drag the Stamp Size slider to change stamp size when Font Size is set as Auto.
4. From the Stamp Text option, please do the following:

- Type the text that you want to show on the stamp in the Stamp Text field directly.
- Choose <author name>, <date and time>, <date>, or <author name, date and time> to add current user, date, and time of your system to the stamp. Please note that the date format shown in the stamp is the same as that you set in your system. When you add the stamp text with <date and time> or <date>, Foxit PhantomPDF will read the date format from your system and apply in on the stamp text you added.
- Click <Custom values when stamp is added> to create custom dynamic stamp with custom values which invoke a prompt window for users to input information while adding a stamp in PDF file. If you select this option, define the Field Name and Example in the pop up window, and click OK to add it to the custom dynamic stamp. If you choose this option, it is recommended to set Font Size as Auto so that the custom values you added in the stamp will be adjusted automatically to adapt to your stamp field. After adding the value, you can also drag the Stamp Size slider to adjust its size, if necessary.
5. You can instantly adjust the added content to fit your needs when you preview current stamp on the right top preview pane.
6. Click OK.

Manage a stamp

To manage a stamp, please do the following:

- Choose Comment > Create > Manage Stamps, open Management Custom Stamps dialog box, and select a stamp.
• Click Create and choose one option from the drop-down menu to create a stamp. Please refer to Creating a stamp.
• Click Edit to edit the selected stamp, such as changing category, stamp name, or replacing the image or PDF files etc. Please refer to Creating a stamp.
• Click Delete to remove the stamp.

Note: Deleting a custom stamp category will delete all stamps that are subordinate to it.

❖ Cut/Copy and Paste a Stamp

To cut/copy and paste a stamp, please do the following:

• Select the stamp you want to cut or copy.
• Right-click the stamp > Cut/Copy. Or use the shortcut keys Ctrl + X/C to cut and copy.
• Right-click on the page you want to paste the stamp and select Paste. Or use the shortcut keys Ctrl + V to paste.

❖ Undo/Redo a Stamp

To undo/redo a Stamp, please click the undo button  and redo button  on the Quick Access toolbar.

❖ Resize/move a stamp

• Select the Hand command  or the Select Annotation command  .
• To resize a stamp, select it, put the cursor on one of the red points, and drag one of the handles to make your adjustments.
• To move a stamp, select it to drag.
• To add a pop-up note to a stamp, select it and double-click the stamp or right-click it and choose Open Popup Note.

❖ Rotate a stamp

• Select the Hand command  or the Select Annotation command  .
• Click the stamp with the command, a handle will appear over the stamp. Put the cursor on the handle and rotate the stamp by dragging the cursor. The rotating degree number will appear as you rotate the stamp.

❖ Delete a stamp

Do one of the following:

• Select the stamp you want to delete and then press the Delete key.
Right-click on the stamp, and choose Delete from the Context Menu.

Set Favorite Stamps

- Choose Comment > Stamps > Create > Set Favorite Stamps....
- Select a stamp in All Stamps panel, and then click Add to Favorite, then the stamp you select will be added to Favorite Stamps panel.
- To remove a stamp from Favorite Stamps panel, select the stamp you want to remove and then click Remove from Favorite.

About pop-up notes

Most comments (except file attachments, Typewriter, Callout, Text Box, and Eraser) include a pop-up note associated with them. You can type text message in their pop-up notes to communicate ideas or provide feedback for the document (See also Reply to comments). This type of pop-up note also includes an Options button which provides various options for more actions. (Note: For all types of comments except the Eraser comment, when you put the cursor over them, a message note appears showing the information about the comment like the author, the text he typed, or the name of the file attachment.)

Sometimes pop-up notes are hidden or closed. To open pop-up notes, select the Hand command, Select Annotation command, or the corresponding commenting tool, and then do any of the following:

- Right-click the comment, and choose Open Popup Note to open the pop-up note of the selected comment or Open All Popups to open the pop-up notes of all the comments in the document.
- Double-click the comment.
- Click Comment > Popup Notes > Open All to open the pop-up notes of all the comments in the document.

To close or hide pop-up notes, select the Hand command, Select Annotation command, or the corresponding commenting tool, and then do any of the following:

- Click the Close button on the pop-up note.
- Right-click the comment, and choose Close Popup Note to close the pop-up note of the selected comment or Close All Popups to close the pop-up notes.
of all the comments in the document.

- Double-click the comment.
- Click **Comment > Popup Notes > Close All** to close the pop-up notes of all the comments in the document.

**Note:**

1. **If you choose Comment > Comments > Hide All,** all comments in the document along with their associated pop-up notes will be hidden; choose **Comment > Comments > Show All,** all comments in the document along with their associated pop-up notes (except any you had closed) will reappear.

2. When viewing comments, the text in pop-up notes will be displayed in the font and size you specified in the **Comment preferences.** To change the default setting, please go to **File > Preferences > Commenting,** and specify the font and size in the **Viewing Comments** group.

### Change the Appearance of Comments

You can change the color and appearances of comments or markups after you create them by right-clicking the comment and choosing **Properties.** Also, you can set the new look as the default appearance for that tool.

In the **Properties** dialog box for each comment, there are two options:

- Check **Locked** at the bottom of the Properties dialog box to prevent the comment from being moved, altered or deleted.
- **Set Current Properties as Default** – check this option to set the current property settings as default so that all the settings can be applied by default next time.

**Note:** You can change the appearance of comments either in the **Comment Format** context tab or in the comment properties dialog box. If you change the appearance through the **Comment Format** context tab, Foxit PhantomPDF will save the properties and apply them in the new comments as well. If you change the appearance via the **Properties** dialog box and **do not check Set Current Properties as Default** option in the dialog, Foxit PhantomPDF will only apply the properties to your currently selected comment.

### Change the appearance of Note Comments

1. After you create a note comment, right-click the note icon and choose **Properties...,** or click **Options** at the top-right corner of the note pop-up box and choose **Properties...**
2. In the Note Properties dialog box, do any of the following, and then click **Close**:

- Click the Appearance tab to change the color and opacity of the comment.
- Click the Note Type tab to change the type of icon used.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of a comment during a review.

**See also** “Set a status”.

### Change the appearance of Text Markups

- Follow the steps of “Change the appearance of Note Comments”.
- There is no Note Type tab in Text Markups settings.

### Change the appearance of Drawing Markups

In the Properties dialog box, do any of the following, and then click **Close**:

- Click the Appearance tab to change such options as the border style, color and opacity. The type of the comment selected determines which options are available.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of a comment during a review.

**See also** “Set a status”.

### Change the appearance of Typewriter Markups

In the Typewriter Properties dialog box, do any of the following, and then click **Close**:

- Click the Appearance tab to change the opacity.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of a comment during a review.

**See also** “Set a status”. 
Chapter 7: Comment

Change the appearance of a textbox or callout

Please refer to “Change the appearance of Drawing Markups”.

Managing Comments

View all comments

The comments panel displays all comments in the PDF so that you can easily find the comments. In addition, it also provides a toolbar with basic options: Expand All, Collapse All, Previous, Next, Sort By, Hide/Show all comments, Search box, and Filter.

- The comment is displayed in the pop-up note or on the markup icon and acts as a tooltip when the pop-up note is closed.
- If you input the comment with too many lines, it will only show some of the comment while the rest will be displayed as suspension points when the cursor is moved outside the pop-up note. Click inside the pop-up note to view it with scroll bar.
- Click the Filter icon to search specific comments you need by the author and status. In the Filter Comments box, select a status or author to show the comments that are in the status and made by the author. If you only want to filter the comments by the original author and ignore all the replies, please check Filter by the original author only as well. Click Clear Selection to clear all filters.
- The Comments Panel displays all the comments in the PDF without any filter; if you have filtered the comments, only the comments that match the filtering criteria appear in the panel. When you navigate through comments, the selected comment will automatically be kept in sync with the current comment being displayed. And you click on a comment to go to the specify comment on page.

To view comments in Comments panel,

- Click the comments button in Navigation pane to open Comments panel.
- In Comments panel, there are the following functions to provide you:
Chapter 7: Comment

✧ Search box - Type a string to search comments that contains the string.

✧ Expand All – Click Expand All button to expand individual comments.

✧ Collapse All – Click Collapse All button to collapse all comments.

✧ Previous/Next – Browse through the comments. Click the Previous button or the Next button to go to the previous or next comment. The two buttons are unavailable if no comment is selected.

✧ Sort By – you can sort comments by author, page, type, date. In a thread of replies, only first message is sorted, and the reply messages are sorted in the same category as first message.

✧ Show/Hide all comments – you can show/hide all comments in the PDF document.

Note:

1. You can click the plus and minus signs next to comment to expand or collapse comments.

2. The page on which comment is located is kept in sync with the selected comment. To go to the page where a comment is located, only simply click the comment in the comment panel.

3. To show/hide all comments on the Comments panel, you can also choose Comment > Manage Comments > Comments > Show All/Hide All.

Cut, copy, paste and delete comments

Cut comments

Cutting removes selected comments from the current location. Once you cut the comments, you can paste within the same document, into a different document.

• Select comments to be cut.
• Select Cut from the right-click menu, or press Ctrl + X.
• You are now ready to paste.

Copy comments

Once you copy the comments, you can paste within the same document, into a different document.
• Select comments to be copied.
• Select **Copy** from the right-click menu, or press **Ctrl + C**.
• You are now ready to paste.

**Paste comments**

You can paste comments within the same document, a different document in Foxit PhantomPDF.

• Copy or cut the selected comments.
• Place your cursor where you want to paste comments within the same document or to another opened document.
• Select **Paste** from the right-click menu, or press **Ctrl + V**.

**Delete comments**

• Select the annotation to be removed with the Hand command \( \text{Hand} \), the **Select Annotation** command \( \text{Select Annotation} \), or the corresponding annotation tool.
• Choose **Delete** from the right-click menu, or press **Delete**.

**Undo and Redo comments**

See also “**Undo and Redo**”

**Set and change a status**

**Set a status**

Setting a status is useful for keeping track of comments that you have read or that require further action. You can use the status to indicate which comments you want to accept, reject, cancel, complete, defer, or mark for future consideration.

By setting the review status, you can show or hide a certain set of comments, and let review participants know how you are going to handle the comment. Once the review status is set, you cannot remove the review status display from history in the Review History list, even if you change the review status to **None**.

**Change the status of a comment**

• With the Hand command, the Select Annotation command or the corresponding
tool selected, right-click a comment in the document pane or Comments panel you want to change the status of, choose Set Status > choose one option from the pop-up Context menu, and then select an option.

To view a markup’s history of changes:
A. Right-click the markup in the document pane or Comments panel, and then choose Properties.
B. In the Properties dialog box, click the Review History tab to view the history of status changes people have made to a markup.

Reply to comments

Replying to comments is useful in shared reviews, when participants can read each other’s comments. They can also be used by review initiators to let reviewers know how their suggestions are being implemented. All replies appear in the pop-up note and are listed below the original comment. You can view the respective reply with the reply title and mark. See also About pop-up notes.

1. To reply to original comments in the pop-up note, do any of the following:
   - Using the Hand command, the Select Annotation command, or the corresponding comment tool, open the pop-up note for the comment and select Reply in the Options. And then type your reply in the textbox that appears in the pop-up window.
   - Right-click the original comment and select Reply. And then type your reply in the textbox that appears in the pop-up window.
2. Replying to Comments in the Comments List
   - Choose View > Navigation Panels > Comments to open the Comments panel if it is hidden.
   - Right-click the comment in the Comments panel and select Reply.
   - Input your reply in the box and click OK.
3. To respond to the reply, please do as below:
   - Using the Hand command, the Select Annotation command, or the corresponding comment tool, and open the pop-up note for the comment.
   - Right-click the title of the reply and select Reply to this Reply. And then type your reply in the textbox that appears in the pop-up window.
4. Delete the reply message, do either of the following:
   - In the note pop-up window, right-click the title of the reply window and click Delete this Reply.
   - In the Comments panel, right-click the reply message, and click Delete.
5. Change the color of reply message window
   - In the note pop-up window, right-click the title of the reply window and choose
Chapter 7: Comment

Change Color.

6. Change the author name of the reply
   Right-click the title of the reply window and select Change Author Name.

7. Flag comments with a checkmark
   You can mark with a comment with a checkmark by right-clicking the comment and selecting Mark with a Checkmark. The checkmark icon will appear in the Comments pane in the navigation pane. Or you can directly make the checkmark for a comment in the Comments pane. With the checkmark you can sort comments.

Note: To open/close all comments' pop-up notes, please choose Comment > Popup notes > Open All/ Close All.

Arrange comments

When you select one or more comments, the Arrange context tab appears on the ribbon, allowing you to arrange the comments. You can arrange multiple comments by aligning, centering and distributing them. Please follow the steps below.

Select multiple comments

1. Select the Select Annotation command .
2. Press and hold Shift or Ctrl and click the comments you want to edit. To select all comments in the document, click on a blank area in the Comments panel and press Ctrl + A.

   Note: When you right-click or Ctrl-click one of the selected comments, it will be highlighted in red, indicating that it's the anchor comment.

Align Comments

Select two or more comments that you want to align. Then do one of the following:

• Choose the Arrange context tab, and then choose a command as follows:

   A. To align a column of comments, choose , , or  to align them respectively to the left edge, right edge, or vertical axis of the anchor comment.
B. To align a row of comments, choose \[\text{alignments}\] to align them respectively to the top edge, bottom edge, or horizontal axis of the anchor comment.

**Note:** The alignment commands move the other selected comments to line up with the edges of the anchor comment.

- Refer to Align Images for more information.

### Center Comments

This function enables you to center comments vertically, horizontally or both.

To center comments, select two or more comments that you want to center. Then do one of the following:

- Choose the Arrange context tab, and then choose \[\text{alignments}\] to center them vertically, horizontally or both.
- Please refer to Center Images for more information.

### Distribute Comments

In the context of laying out comments on a page, you can give a group of comments uniform spacing, based on the centers of adjacent comments. This function will be available when selecting three or more comments.

- To distribute the comments, choose the Arrange context tab, and then choose \[\text{alignments}\] to distribute vertically or horizontally.
- Please refer to Distribute Images for more information.

### Summarize comments

Summarizing comments is an easy way to help you directly obtain a synopsis of comments associated with the PDF. Foxit PhantomPDF supports to create a comment summary PDF. To create a comment summary, do as below:

1. Choose Comment > Summarize Comments.
2. In Create Comment Summary dialog box, do the following:

A. Choose the layout of the summary and there are five types of layouts for you to choose:
   - L1--Document and comment with connector lines on separate pages
   - L2-- Document and comment with connector lines on single pages
   - L3—Comments only
   - L4-- Document and comment with sequence numbers on separate pages
   - L5-- Document and comment with sequence numbers on single pages
L5

B. Comment Type - Choose the comment type you want to summarize.

C. Paper Size - Select the paper size of the summary

D. Font Size - Select the font size of the summary.

E. Sort comments by – Choose how to sort the comments.

F. Include pages – Specify the page range you need to summarize.

3. Click OK and a PDF named “Summary of Comments on [original document name].pdf” will be opened automatically. You can rename it before you save.

Send annotated PDFs

Foxit PhantomPDF makes it easy for users to share reviews. You can send your annotated PDFs to any reviewers to check and respond to your comments.

To send an annotated PDF file, do the following:

- Click on the Save button to save all the comments you have made.

- Choose Share > Email to send it out.

Import/export comments data

This feature is especially useful for PDF reviewing. When you receive an email invitation to a PDF review, the invitation typically includes the PDF as an attachment or provides a URL to the PDF. Alternatively, you may receive a Form Data Format (FDF) attachment. When opened, an FDF file configures your review settings and opens the PDF in a web browser. At this moment, you need to know how to import the comment data from the FDF file. Similarly, you may export comment data and send them as an FDF file to the other participants. Moreover, if you make comments in a PDF file which is created from a Microsoft Word document, you can easily export the comments to revise the original document.

Tip: The users of Foxit PhantomPDF can import the comments data from FDF and PDF files or export the data of PDFs and save in an FDF file. You can also export the data in FDF format and email as an attachment.
Import comments data

Do the following:

- Double-click a FDF file to open it directly with Foxit PhantomPDF.
- Choose **Comment > Import** > navigate to where the desired file is, select it (if you want to import multiple comments file, you can select them by holding Ctrl/Shift or by dragging the mouse to select), and press “Open”. You will be prompted that the comments data has been imported successfully.

Export comments data

To export comments data, please do one of the following:

- To export all comments as an FDF
  A. Choose **Comment > Export > All Comments**.
  B. You will be presented with a standard Windows “Save As” dialog box. Navigate to where you want to save the FDF file (e.g., your Documents folder), specify its name and click **Save** button.
  C. You will be prompted that the data has been exported successfully.

- To export all comments as an FDF file and send it as an e-mail attachment
  A. Choose **Comment > FDF via Email**.
  B. A blank message with the created FDF file included as an attachment will automatically open in your default e-mail program, and the current file name will be the email subject.
  C. Type the e-mail address of users you want to receive the file > click **Send**.

- To export highlighted text as an TXT file
  A. Choose **Comment > Export > Highlighted Text**.
  B. You will be presented with a standard Windows **Save As** dialog. Navigate to where you want to save the TXT file, specify the file name, and click **Save**.
  C. You will be prompted that the data has been exported successfully.

Export comments to Word

Foxit PhantomPDF allows users to revise the original Word document by exporting the
comments from the PDF if the PDF is a tagged PDF and is created from a Microsoft Word document using Foxit PhantomPDF add-on.

- Do one of the following:
  - In Foxit PhantomPDF, open the commented PDF file, and then choose Comment > Export > Export to Word.
  - In Microsoft Word, open the original document, and then choose FOXIT PDF > PhantomPDF Comment > Import Comments from PhantomPDF.

- Read the instruction and click OK to continue. If you do not want to see the dialog box the next time you try to export comments, check Don’t show again option in the dialog box.
- In the Import Comments from Foxit PhantomPDF dialog box, corresponding PDF and Word documents will be selected by default, and you can also click Browse to select the PDF file which contains comments and the Word document which you want to import comments, if necessary. Then select one of the following options, and click Continue.
  - All Comments: Import all comments to the Word document.
  - All Comments with Checkmarks: Import only comments marked with check marks to the Word document.
  - Text Edits Only: Insertions, Deletions and Replaces: Import only comments which are added using the Insert Text, Strikeout, or Replace Text comment tools.

- When the comments are imported to Word successfully, a dialog box will pop up showing you the import summary. If the imported comments include text edits, you can click Integrate Text Edit in the dialog box to review each text edit individually.
- While reviewing text edits, review or modify the text in the New Text box, and then select the following option:
  - Apply: Apply the text edit in the Word document and delete the comment markups.
  - Next: Skip to the next text edit. If you want to skip to the next text edit automatically after applying changes, check the Automatically go to next option.
  - Apply All Remaining: Apply all remaining text edits in the Word document and delete the comment markups.
  - Undo Last: undo the last text edit, including the manual changes you made in the New Text box.
  - Stop: Stop text integration. If you stop text integration, you can still continue to integrate text edits by clicking Continue in the Text Integration
Summary dialog box, or clicking FOXIT PDF > PhantomPDF Comment > Continue Integration Process in Word document.

- When the text integration completes, a dialog box will pop up showing you the text integration summary. Click OK to view import results in the Word document.
- Comments other than text edits will be imported and shown as comment markups in the Word document. Check the comment markups and modify the Word document as needed.
- Upon completion, click FOXIT PDF > PhantomPDF Comment > Delete All Comments in Document to delete the comment markups.
Chapter 8 – Share PDFs

Foxit PhantomPDF supports different methods to share PDF documents with others. You can easily email documents to share with others by one-click and, check out and check in PDFs in your SharePoint server. If you need to collect comments from reviewers as well as sharing documents, Foxit PhantomPDF provides two useful and easily-used methods: Send for Shared Review and Send for Email Review. Integration with cloud services or ECM systems like SharePoint, ndOffice, iManage Work, OpenText eDOCS, and Worldox lets users share and manage documents easily within one application.

Email Documents

E-mailing documents is a useful feature. You may need to send a PDF file you are reading to the customers to speed up your daily work, or an interesting story that you want to share with your friends.

To e-mail a PDF file, please do the following:

• Choose Share > Email > Email Current Tab (Email the PDF file that you are currently reading) or Email All Open Tabs (Email all the PDF files that have been opened in Foxit PhantomPDF). If the option Allow to choose the page range when attaching the tab to a new email message in File > Preferences > Documents > Prompt Messages is selected, you can specify the page range you want to send when choosing Email Current Tab. Foxit PhantomPDF will automatically extract the pages you specified to a new PDF as the email attachment.

• System default e-mail application runs.

• The PDF(s) will be attached in the e-mail automatically, and the current PDF file name will be the email subject.

• Type the subject and e-mail address, and click Send.

Send to Evernote

Directly send current PDF document to Evernote as an attachment.

➢ Prerequisites – You should set up an Evernote account from https://www.evernote.com/Registration.action.


➢ Open a PDF file.
Choose **Share > Evernote**.
You will see the current PDF document is attached to your Evernote ready.

**Send to OneNote**

You can send your PDF document to OneNote quickly within PhantomPDF after edits.

- Open and edit the document with PhantomPDF.
- Save the changes and then click **Share > OneNote**.
- Select a section/page in your notebooks, and click **OK**.
- In the pop-up dialog box, choose **Attach File** or **Insert Printout** to insert your document to the selected section/page in OneNote.

**SharePoint Integration**

Foxit PhantomPDF has been integrated with Microsoft SharePoint, which helps you better manage and share PDFs. You can access PDFs in a SharePoint repository by any of the following:

- Open a PDF file in the SharePoint mapped drive by **Open** dialog box within Foxit PhantomPDF. You can open and check out a PDF, modify it and then check in and save to the SharePoint network drive.
- You can also use Foxit PhantomPDF’s **Open** or **Save As** dialog box to work on PDFs in your SharePoint repository, whether the SharePoint repository is SharePoint online or SharePoint on-premise. More details please refer to **Open and Save As PDFs with Foxit PhantomPDF**.
- Directly check out and check in PDFs in your SharePoint repository on SharePoint on-premise through the SharePoint web interface using a browser after configuring your server. Please refer to **SharePoint Configuration** to configure your server first. More details please refer to **Open and Save As PDFs with a Web Browser**.

**Open and Save As PDFs with Foxit PhantomPDF**

**Open PDF files in a SharePoint repository**

To open PDF files in a SharePoint repository, please do the following: (Take opening PDFs in a SharePoint repository on SharePoint online for example)
Run Foxit PhantomPDF and choose **File > Open > Add a place** > SharePoint.

In the **Add** dialog box, type the SharePoint URL to sign in and click **Next** to continue.

In the pop-up dialog box enter the email address and the password to sign in.

In the **Open** dialog box, select the **Shared Documents** folder and click **Open**.

Choose the PDF file you want to open and click **Open**.

In the **Foxit PhantomPDF** dialog box, if you choose **Check out and Open**, other users cannot edit the PDF at the same time; if you only choose **Open**, others can modify the PDF as well when you are editing. (Check **Don't ask me again** to bypass this dialog box in the future and use the current choice selected the next time you open a PDF. You can change the setting later in **File > Preferences > ECM Integration**.)

(Optional) You are also allowed to preview non-PDF files on SharePoint in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.

(Optional) If you want to cancel the Check Out status, please go to **Share > Discard Check Out**.

Edit the PDF according to your requirements.

To check and set the PDF properties, please do the following steps:

1. Please go to **Share > Prepare Document Properties**.
2. In the **Document Properties** dialogue, you will find the file path and document properties. You can select the file path to copy and paste it, if necessary. To edit a document property, double-click the column name, and edit the value in the **Edit** text box. For example, double-click **Title**, the **Edit** text box will pop up, type the content you want and click **OK** to finish the editing.

Go to **Share > Check In**.

In the Check In dialogue box, select a version number for the modified document along with the appropriate the version comments. To not allow other people to modify the document, you can check **Keep the document checked out after check in this version**.

Click **OK**, the modified PDF will be loaded to the server automatically.
Save as PDF files to a SharePoint repository

To save as PDF files to a SharePoint repository, please do the following: (Take saving as PDFs to a SharePoint repository on SharePoint online for example)

- Choose File > Save As > Add a place + > SharePoint . In the Add dialog box, type the SharePoint URL to sign in and click Next to continue.
- In the pop-up dialog box enter the email address and the password to sign in.
- In the Save As dialog box, select the Shared Documents folder and click Save.

Open and Save As PDFs with a Web Browser

To work on PDFs in your SharePoint repository on SharePoint on-premise with a web browser, you just need to log on to your SharePoint web portal, navigate to a PDF and click it. You will be prompted whether to check out and open the PDF. See also Check Out and Open. Then you can check in to save it back to your SharePoint repository.

**Tip:** If you need to save to your local folder, after editing the PDF you can click File > Save As > Computer and choose a local folder to save.

Shared Review and Email Review

Foxit PhantomPDF enables users to initiate a review by two methods: Shared Review and Email Review. You can set up your review, specify reviewers and review deadlines. You do not need to import and export comment data or manually track reviewer responses. The review Tracker can help review initiators track all reviews and manage the whole review in real time.

See also the tutorial on Shared Review.

Shared Review

Collect Comments on an Internal Server

Shared Review allows document authors to share a document on an internal server with others to gather feedback/comments from the reviewers. The review initiator can specify the document location, invite participants and set the review deadline.
Chapter 8: Share PDFs

After receiving the invitation from the review initiator, reviewers can mark-up PDFs using a full set of commenting tools. Comments from reviewers will be stored in the internal server and synchronized by Foxit PhantomPDF to download them at a regular interval. Reviewers will be notified if new comments are added by others and they can also reply to these comments.

1. (For review initiators) To send a PDF out for shared review (Available in Business Edition Only), please do the following:
   - Choose a document for shared review and open with Foxit PhantomPDF.

   **Note:** To guard against non-reviewers from accessing the document while it is on a shared repository, before sending out for review you can add some security policies to the document such as password/certificate encryption and AIP protection.

   - Choose **Share > Send for Shared Review** > Collect comments on an internal server.
   - In the pop-up **Send for Shared Review** dialog box:
     1) Select the location of the document. The location can be a network folder or a SharePoint Workspace.

        **Tip:** If using a network folder, it must be a Windows machine running Windows 7, Windows Server 2008, or a later version of either. All reviewers must have read and write access to the shared folder and then can make comments with Foxit PhantomPDF or Reader 7.0 or a later release. You can track each reviewer’s comments and reply to them accordingly. Reviewers can also see and reply to each other’s comments.

     2) Select a distribution and display method:

        **Send it automatically as a link within the message** – The path to the shared document will be automatically included in the email message to be sent to reviewers using your installed email client (i.e. Outlook). The shared document will be named “[original document name]_review.pdf” by default.

        **Send it automatically as an attachment to the message** – The shared document will be automatically sent as an email attachment to reviewers with the name “[original document name]_review.pdf”.

        **Save a local copy and manually send it later** – Click **Browse** button to rename the shared document and choose a location to save it and send it to reviewers later manually.

     3) Name this server profile, eg. “S1 (send as attachment)”, for further use in the future. The profile is saved with the options you specified above. In the future, you can select the profile directly from the Ribbon and skip this step.
• Click **Next**. If you haven't set your identity information for your PDF viewers yet, enter your identity information.

• Click **Next** to go on. Enter the email addresses of the desired reviewers. A semicolon or a return can be inserted between each address if there is more than one address. Or click **To...** button to access your contact list in your email system.

• Choose the review deadline and then type in an email message.

• After you send the email or save the shared document to a local copy, the shared document is automatically opened, with a message box in the application window. With the options in the message box, you can publish comments, check for new comments made by reviewers and track the whole review. See also **Review a shared review document** and **Review Tracker**.

2. **(For reviewers)** To review a shared review document:
Upon the review initiator sending out the document, the specified reviewers will receive an email invitation to a PDF review. The email includes an attached document named “[original document name]_review.pdf” or provides a URL to the PDF. To review the document:

1) Download the document and open it with Foxit PhantomPDF.

2) If it is your first time opening a shared review document, you will be prompted for your identity information. Please enter at least your name and email address.

3) Enter an account name and password for the shared folder where the shared review document is located.

4) If the notification message setting is enabled in **File > Preferences > General**, a message box appears in the application window with three options: **Check for New Comments**, **Publish Comments** and a menu with three commands (**Track Reviews**, **Save As Archive Copy**, and **Work Offline**). And the **Manage Shared Review** button in the **Share** tab is available. Clicking on **Manage Shared Review** drops down a menu with the commands: **Publish Comments**, **Check for New Comments**, **Save As Archive Copy**, and **Work Offline**.

5) You can add your comments using annotation tools and then click **Publish Comments** in the message box or click **Share > Manage Shared Review > Publish Comments** to publish your comments which will be saved to the shared server.

6) Click on **Check for New Comments** in the message box or click **Share > Manage Shared Review > Check for New Comments** to check for new comments made by the initiator or other reviewers. You can also reply to the comments. In normal situations, comment publishing and checking will happen automatically. Foxit PhantomPDF supports to configure the interval to check for new comments by selecting a length of time in **File > Preferences > Reviewing > Automatically Check for New Comments**. PhantomPDF icon in the taskbar will flash to prompt you that new comments are checked.

7) Do more actions with the following options:
Track Reviews – To track all reviews you initiated or participated in, which is very useful when you are involved in multiple reviews. See also Review Tracker.

Save As Archive Copy – Saves a copy of the document with review comments to your hard drive when the review has ended.

Work Offline – If you don’t want to publish comments right after you make the comments, this option can keep your work offline, until you click Work Online to be able to publish comments.

Note:

1. Reviewers will not be able to make comments or do other modifications to the shared documents in non-Foxit PDF viewers.

2. Reviewers should save the document as an archive copy to the hard drive using Foxit PDF viewers so as to modify the content.

Email Review

Email Review is useful when reviewers don’t have access to a common server or initiators don’t need collaborative reviews. In an Email Review, the initiator sends PDFs to reviewers as attachments and can view comments only after receiving the commented PDFs from reviewers. Also, the reviewers can only send back the PDFs after adding comments, and they cannot view comments made by others.

1) To send a PDF out for email review (Available in Business Edition Only), please do the following:
   • Choose a document for email review and open with Foxit PhantomPDF. This document becomes the master file into which you can merge comments you receive from reviewers.
   • Choose Share > Send for Email Review.
   • In the pop-up Send for Email Review dialog box, specify the recipients that you want to send the document to for review, type in the message in the text box and click Send Invitation button.
   • A new email with the document attached will appear for you to send. Click Send to send out the email.
   • You can track the review status with the review tracker. Please refer to Review Tracker.

Note: Recipients of the shared document can review it and send it back with Foxit PhantomPDF or Reader 7.0 or a later release, as well as Foxit PDF Reader Mobile (for Android).
2) To participate in an email review:

The recipients can download the document sent from the initiator and open it with Foxit PhantomPDF, add their comments and click the Send Comments button in the message box (if the notification message setting is enabled in File > Preferences > General) or choose Share > Manage Email Review > Send Comments to send their comments back to the initiator.

Likewise, you can manage your reviews by using the Tracker. See also Review Tracker.

3) To merge comments:

After receiving the document with comments from reviewers, the initiator open it and will be prompted with a message box about whether to merge comments from this document into the master file or not.

If you choose No, open this copy only button, you can still merge comments after you open it by clicking Merge Comments button in the message box (if notification message is enabled) or choose Share > Manage Email Review > Merge Comments.

**Review Tracker**

The review Tracker helps you easily manage document reviews in real time. The tracker shows all the reviews you sent and joined and the detailed review status including review deadlines, reviewers, comments, etc. You can also email reviewers/initiators and add reviewers with the tracker. If you are the review initiator in a Shared Review, you can also change the deadline, end the review and start a new review with the same reviewers.

To track all of your reviews, please click Share > Tracker. In the Tracker window, you are enabled to save the review details in the Tracker as a PDF file by right-clicking the document name in the Tracker and choosing Create PDF From Tracker Details from the context menu. You can also categorize your reviews by folders in order to find reviews easily. Steps are as follows:

- To create a new folder in the tracker, right-click the Sent/Joined group or any review listed under the Sent/Joined group > choose Create New Folder > enter the name for the new folder > click OK.
- To list a review in your created folder, right-click the review, select Send to Folder, and choose the folder to which you want to move the review. To change the folder for a review, redo the operation, and choose the desired folder from the Send to
Folder context menu. The Top Level option in Sent to Folder context menu allows you to move the selected review out of its current folder, and list it in the Sent/Joined group.

- To remove a created folder from the tracker, right-click the folder, and choose Remove Folder from Tracker. Please note that removing a folder from the tracker will remove all the reviews listed under it.

**ndOffice Integration**

Foxit PhantomPDF allows you to open, edit, save, and check out/in PDFs on ndOffice, which offers you efficient document management.

**Open PDFs on ndOffice within PhantomPDF**

1. Click File > Open > Add a place > ndOffice. Before using PhantomPDF to open PDFs on ndOffice, you are required to install ndOffice in your system if you haven’t.
2. Log in to your ndOffice account.
3. (Optional) If you have logged in before, the NdOffice item will be listed under the Open menu. Then click File > Open > Open.
4. In the Open dialog box, click the document you want to open and then it will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.
5. (Optional) You are also allowed to preview non-PDF files on ndOffice in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.
6. After modification, you can save the changes to check back in to ndOffice or to local drives.

*Tip: You can open ndOffice with one-click by adding the Ndoffice Open command to Quick Access Toolbar:*

- Click on the Quick Access Toolbar, and select More Commands. Or right-click the ribbon area and choose Customize Quick Access Toolbar....
- In the Customize Tools dialog box, choose the Customize Quick Access Toolbar tab. See also Customize Quick Access Toolbar.
- Choose Other in the Choose commands box, and select Ndoffice Open from the Commands list below.
- Click Add to add the command to Quick Access Toolbar.
iManage Work Integration

Integration with iManage Work, the popular and intelligent document and email management solution, enables you to directly open, modify, and save PDF documents in your Work account using PhantomPDF, which streamlines your PDF document management. Foxit PhantomPDF integrates with both iManage Work 9.X (hereafter, the “iManage Work”) and iManage Work 10.X (hereafter, the “iManage10”).

Integration with iManage Work

Register/Unregister servers

Before you work on PDF documents in iManage Work, please add the server your iManage Work Server is installed on and log in your account.

Note:

1. The DeskSite client or iManage Filesite is required in your system before registering servers. For better document management, Foxit PhantomPDF enables you to convert non-PDF files to PDF via the context menu within the DeskSite or iManage Filesite.
2. If you try to install iManage Filesite in a 64-bit operating system, some configuration is necessary for successful installation. Visit here for details.

❖ Register servers

1. Click File > Open > Add a place > iManage Work, or click Share > Register/Unregister.
2. In the pop-up Server Connection dialog box, click Add.
3. Enter the server name and the login information in the Register and Login dialog box. Then click Save. (Tip: You can check Auto Login to automatically log in to your iManage account the next time you launch PhantomPDF.)
4. Close the Server Connection dialog box. Then you can open your documents in your iManage Work account.

   Note: The server you added will be listed in File > Open and stored until you delete or unregister it.

❖ Delete or unregister servers

Click Share > Register/Unregister. In the pop-up Server Connection dialog box, select the server you want to unregister and click Delete.
Open and check out PDFs on iManage Work

1. Go to File > Open, click the server you registered previously and click Open. Or click Share > Open after you register and connect to the server.
2. In the Open dialog box, select the document you need and click Open.
3. (Optional) You are also allowed to preview non-PDF files on iManage Work in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.

*Note:* By default, the document in iManage Work will be checked out when opened in Foxit PhantomPDF. You can specify whether to check out a document in iManage Work when opening it with PhantomPDF in File > Preferences > ECM Integration.

Save

To save a local PDF document to the iManage Work repository, or if you open and edit a document in the iManage Work without checking it out and need to save it to the iManage Work repository, save the changes you made in the document and then do the following:

✧ To save as a new document in iManage Work repository:

1. Go to File > Save As, click the server you registered previously and click Save As. Or click Share > Save As > Save As.
2. In the Save As dialog box, choose a target folder and enter the name/description of the document. Enter the Author name, or click the button next to the text box and choose a user. You can also choose a class and a subclass for the document.
3. After completing all of the settings, click Detail... to display the details of the document information. You can also edit the information in this dialog box.
4. When you're done, click Save to save the document to the iManage Work.

✧ To save as a new version of an existing Work document:

1. Go to Share > Save As > Save As Work Version.
2. In the pop-up dialog box, select a document in iManage Work, and click New Version.
3. Specify the document properties in the New Version Profile dialog box, and click Save to save it as a new version of the selected document.

To save a checked-out PDF document, you can choose to replace the original document in the iManage Work or save it as a new version or a new document.
After modification, go to File > Save As, click the server you registered previously and click Save As. Or click Share > Save As > Save As. In the Save As Options dialog box, choose any of the following:

- **New Version**: Click OK, set the document profile for the new version, and the modified document will be saved as a new version, leaving the original document unchanged.
- **New Document**: Click OK and the modified document will be saved as a new document, leaving the original document unchanged. In the pop-up Save As dialog box, complete the settings and click Save. See also [Save a local document to the iManage Work](#).
- **Replace Original**: Click OK and the modified document will overwrite the original document in the iManage Work.

**Note**: By default, only New Version and New Document are displayed in the Save As Options dialog box. To show the Replace Original option in the dialog box, add a new key to the Registry:

```plaintext
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Foxit\PhantomPDF 8.0\iManage\Preferences
```

Key Name: ReplaceOriginal

Type: DWORD Value: 1

Set the value data to 1 to display the Replace Original option; with the value of 0 or null, the option will not be displayed.

**Document properties**

When you have checked out and opened a PDF document, you can click Share > Properties to view the properties of the document.

**Integration with iManage10**

**Open and check out PDFs on iManage 10**

1. Go to File > Open > Add a place > iManage 10, and log in to your account.
2. (Optional) If you have logged in before, the iManage10 item will be listed under the Open menu, and the iManage10 context tab will be displayed on the ribbon. You can click File > Open > iManage10 > Open or select the iManage10 context tab > Open to open a file from iManage10.
3. After you sign in successfully, the **iManage10** context tab appears on the ribbon. Click **Open** in the tab.
4. In the **Open** dialog box, select the document you need and click **Open**. The document is also checked out when opened.

**Save**

To save a local PDF document to the iManage10 repository save the changes you made in the document and then do the following:

✧ **To save as a new document in iManage10 repository:**

1. Go to **File > Save As > iManage10 > Save As...** Or click **iManage10 > Save As > Save As**.
2. In the **Save As** dialog box, choose a target folder and enter the name for the document. Enter the Author name, or click the button next to the text box and choose a name. You can also type your comments in the **Comments** text field.
3. After completing all of the settings, click **Save** to save the document to the iManage10.

✧ **To save as a new version of an existing Work document:**

1. Go to **iManage10 > Save As > Save As New Version**.
2. In the pop up dialog box, select a document in iManage10.
3. Specify the document properties in the pop-up **New Version** dialog box, and click **Save** to save it as a new version of the selected document.

To save a PDF document in iManage10, you can choose to replace the original document, or save it as a new version or a new document in the iManage10. After modification, do any of the following:

- Directly save the document in PhantomPDF to replace the original document with modified document. (**Note:** If the document has been checked out by others, you can't replace the original document.)
- Go to **File > Save As > iManage10 > Save As**, or click **iManage10 > Save As > Save As**. In the pop-up dialog box, choose a location, and specify the document properties in the right part of the dialog box. Then click **Save**, and the modified document will be saved as a new document, leaving the original document unchanged.
- Click **iManage10 > Save As > Save As New Version**. In the pop-up dialog box, set the document profile for the new version, and the modified document will be saved as a new version, leaving the original document unchanged.
Document properties

When you have checked out and opened a PDF document, you can click Properties in the iManage10 context tab to view the properties of the document. You can also click Timeline that shows the information involved with the document, including activities, users, and versions.

OpenText eDOCS Integration

Within Foxit PhantomPDF, you can open, modify, and save PDF documents on eDOCS DM — the ECM solution used by many organizations to manage content, giving you quick and easy access to documents on eDOCS DM to increase productivity.

Open PDFs on eDOCS DM

1. Click File > Open > Add a place > eDOCS DM. Before using PhantomPDF to open PDFs on eDOCS DM, you are required to install DM Extension in your system if you haven’t.
2. Log in to your eDOCS DM account.
3. (Optional) If you have logged in before, the eDOCS DM item will be listed under the Open menu. Then click File > Open > eDOCS DM > Open from DM.
4. In the Quick Retrieve dialog box, select the document you want to open and then it will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

Save

To save a checked-out PDF document, you can choose to replace the original document in the eDOCS DM, or save it as a new version, a new sub-version, or a new document.

1. After modification, go to File > Save As, click the eDOCS DM item listed under the Save As menu and then click Save As. Or click Share > Save As (> Save As...).
2. In the Save As dialog box:
   - Choose New Version/ New Sub-version/ New Document: the modified document will be saved as a new version/sub-version/document, leaving the original document unchanged.
   - Choose Replace Original: the modified document will overwrite the original document in eDOCS DM.
You can save a local PDF document as a new document or a new version to the eDOCS DM. Save the changes you made in the document and then do the following:

- To save as a new document, go to **File > Save As**, click the **eDOCS DM** item listed under the **Save As** menu and then click **Save As**. Or click **Share > Save As > Save As...**. Then type the document information as needed and click **Save**.
- To save as a new version or sub-version, click **Share > Save As > Save As DM Version**. Select a document in eDOCS DM and save as a new version or sub-version of the document.
- To add a password protection when saving a document, click **Share > Save As > Save with Options**, and save the document to the eDOCS DM.

**Document properties**

When you have checked out and opened a PDF document in eDOCS DM, you can click **Share > Document Information** to view the properties of the document.

**OpenText Documentum Integration**

Integration with OpenText Documentum, an enterprise content management platform, enables you to open, modify, and save PDF documents in your OpenText Documentum account, which streamlines your document management.

**Open PDFs on OpenText Documentum**

1. Click **File > Open > Add a place > Documentum**. Before using PhantomPDF to open PDFs on OpenText Documentum, you are required to install DFC Client in your system if you haven't.
2. Log in to your OpenText Documentum account.
3. (Optional) If you have logged in before, the **Documentum** item will be listed under the **Open** menu. Then click **File > Open > Documentum > Open**.
4. After you sign in successfully, the **Documentum** context tab appears on the ribbon. Click **Open** in the tab.
5. In the **Open** dialog box, select the document you want to open, and click **Open**. By default, the PDF document will be locked for editing while you open a PDF file which has not been checked out with Foxit PhantomPDF. Then make your edits as needed with advanced tool in PhantomPDF. If you do not want to lock it, uncheck the **Locked file for editing** option in the **Open** dialog box.
Save

To save a locked PDF document, you can choose to replace the original document in the OpenText Documentum, or save it as a new version, a new sub-version, or a new document.

1. After modification, go to File > Save As, click the Documentum item listed under the Save As menu and then click Save As. Or click Documentum > Save As > Save As.
2. In the Save As dialog box:
   - Choose **New Version*/ **New Sub-version*/ **New Document**: the modified document will be saved as a new version/sub-version/document, leaving the original document unchanged.
   - Choose **Replace Original**: the modified document will overwrite the original document in Documentum.

You can save a local PDF document as a new document or a new version to the Documentum. Save the changes you made in the document and then do the following:

- To save as a new document, go to File > Save As, click the Documentum item listed under the Save As menu and then click Save As. Or click Documentum > Save As > Save As. Then type the document name as needed and click Save.
- To save as a new version or sub-version, click Documentum > Save As > Save As Repository Version. In the Save As dialog box, select **New Version** or **New Sub-version**, and click OK. Select a document in Documentum to save the local PDF document as a new version or sub-version of the document.

Document properties

When you have opened a PDF document in Documentum, you can click Documentum > Document Information to view the properties of the document.

OpenText Content Suite Integration

Within Foxit PhantomPDF, you can open, modify, and save PDF documents on OpenText Content Suite.

Open PDFs on OpenText Content Suite

1. Click File > Open > Add a place > Enterprise Connect. Before using PhantomPDF
to open PDFs on OpenText Content Suite, you are required to install Enterprise Connect Framework in your system if you haven't.

2. (Optional) If you have added Enterprise Connect in PhantomPDF before, the Enterprise Connect item will be listed under the Open menu, and the Enterprise Connect context tab will be displayed. You can click File > Open > Enterprise Connect > Browse or select Enterprise Connect > Open to open a file from OpenText Content Suite.

3. In the Enterprise Connect Open dialog box, select the document you want to open, and click Open. The document will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

Tip: You need to set Foxit PhantomPDF as the default PDF viewer if you want to open PDFs on OpenText Content Suite with Foxit PhantomPDF.

Save

To save a check-out document, do any of the following:

• Click File > Save to save and replace the original document in OpenText Content Suite.
• Go to File > Save As > Enterprise Connect > Browse or Enterprise Connect > Save As, and follow the Enterprise Connect onscreen instructions to save it as a new document or new version.

To save a local PDF document to OpenText Content Suite, follow the steps below:

• Click Enterprise Connect > Save As, or go to File > Save As > Enterprise Connect > Browse, and then follow the Enterprise Connect onscreen instructions to save it in OpenText Content Suite.

Worldox Integration

Integration with Worldox enables you to open, modify, and save PDF documents in your Worldox account, which streamlines your document management.

Open PDFs on Worldox

1. Click File > Open > Add a place > Worldox. Before using PhantomPDF to open PDFs on Worldox, you are required to install Worldox client in your system if you haven't.
2. (Optional) If you have added Worldox in PhantomPDF before, the **Worldox** item will be listed under the **Open** menu, and the **Worldox** context tab will be displayed. Then click **File > Open > Worldox > Open**, or select **Worldox > Open**.

3. In the **GX-Open** dialog box, double-click the document you want to open, and then it will be opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

**Save**

To save an opened PDF document back to Worldox, do any of the following:

- Click **File > Save**, or **Worldox > Save** to save and replace the original document in the Worldox.
- Click **File > Save As > Worldox > Save As**, or **Worldox > Save As**, and then follow the GX onscreen instructions to save and replace the original document, or save it as a new version or new document.

To save a local PDF document to Worldox, follow the steps below:

- Click **Worldox > Save** or **Save As**, or go to **File > Save As > Worldox > Save As**, and then follow the GX onscreen instructions to save it as a new document or a new version in Worldox.

**ShareFile Integration**

Foxit PhantomPDF allows you to open, edit, and save PDFs on ShareFile, which offers you efficient document management.

**Open PDFs on ShareFile**

1. Click **File > Open > Add a place > ShareFile**.
2. (Optional) If you have logged in before, the **ShareFile** item will be listed under the **Open** menu. Click **File > Open > ShareFile > Browse**.
3. In the **Open** dialog box, select the document you want to open and click **Open**. Then it will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.
Save

To save a checked-out and opened PDF document back to ShareFile, do any of the following:

- Click **File > Save** to save and replace the original document in ShareFile.
- Click **File > Save As > ShareFile > Browse**, and then specify the filename and location to save and replace the original document, or save it as a new document in ShareFile.

To save a local PDF document to ShareFile, follow the steps below:

- Click **File > Save As > ShareFile > Browse**, and then specify the filename and location to save it to ShareFile.

**Epona DMSforLegal Integration**

Within Foxit PhantomPDF, you can open, modify, and save PDF documents on Epona DMSforLegal.

**Open PDFs on Epona DMSforLegal**

1. Click **File > Open > Add a place > DMSforLegal**. Before using Foxit PhantomPDF to open PDFs on Epona DMSforLegal, you are required to install Epona DMSforLegal client in your system if you haven't.
2. (Optional) If you have added Epona DMSforLegal in Foxit PhantomPDF before, the **DMSforLegal** item will be listed under the **Open** menu, and the **DMSforLegal** context tab will be displayed. You can click **File > Open > DMSforLegal > Browse** to open a file from Epona DMSforLegal.
3. In the **DMSforLegal Open** dialog box, select the document you want to open, and click **OK**.
4. Choose how you want to open the PDF document:
   - Check Out and Open: Open the PDF file and check it out so that others cannot modify the PDF when you are working on it.
   - Open: Open the PDF file without checking out.
   - (Optional) If necessary, check **Don't ask me again** so that Foxit PhantomPDF will remember your selection and save it as the default way to open a file from the Epona DMSforLegal. Once checked and applied, **Foxit PhantomPDF** dialog box will not show up the next time you open a file from the Epona DMSforLegal.
Check In, Check Out, and Discard Check Out a PDF File on Epona DMSforLegal

To change the status of a PDF file opened from Epona DMSforLegal, please select the DMSforLegal context tab, and choose any of the following option as desired:

- Check In: Check in the PDF document that you have currently checked out, and save it on Epona DMSforLegal. While checking in the PDF document, select a version number for the modified document and type the appropriate version comment in the Check In dialog box. To prevent other users from modifying the document, check Keep the document checked out after checking in this version option in the Check In dialog box.
- Check Out: Check out the PDF document from Epona DMSforLegal library. A checked-out PDF document cannot be edited by other users.
- Discard Check Out: Check in the PDF document that you have currently checked out, discarding any changes you have made to the document.

Check and Edit the Document Properties

To check the document properties of a PDF file opened from Epona DMSforLegal, go to DMSforLegal context menu, and choose Document Properties. The Document properties dialog box will pop up for you to view and edit the document properties.

Save a PDF File on Epona DMSforLegal

- Click File > Save to save and replace the original document on Epona DMSforLegal.
- Go to File > Save As > DMSforLegal > Browse, and follow the DMSforLegal onscreen instructions to save it as a new document on DMSforLegal.

Alfresco

Alfresco is a popular ECM (Enterprise Content Management) platform, providing robust document management capabilities. Foxit PhantomPDF users can seamlessly connect to their Alfresco accounts to open, edit and save PDF documents.

Open and save documents in Alfresco

- Run Foxit PhantomPDF and choose File > Open > Add a place > Alfresco. In the
**Alfresco Login** dialog box, sign in your Alfresco account.

- In the **Open** dialog box, select a document from a repository.
- Click **Open** or **Check Out and Open** to open the document. If you choose **Check out and Open**, other users cannot edit the PDF at the same time; if you only choose **Open**, others are able to modify the PDF at the same time when you are editing.
- When you open a document, the **Alfresco** context tab appears on the ribbon. You can click **Check Out** to check out the open document, or click **Discard Checkout** to cancel the Check Out status. If you check out the document, after editing it, you can click **File > Save** to save the changes to your Alfresco account, or click **Check In** to save the document as a new version back to your Alfresco account.
- If opening a document without checking out, you are allowed to modify the description of the document in the Document Properties dialog box which pops up when you click **Document Properties** in the **Alfresco** context tab.
Chapter 9 – Forms

Foxit PhantomPDF is extremely useful for form filling and form designing. Please read below for more information.

Interactive Form and Non-interactive form

There are two kinds of “form” files. One is a PDF file with fillable fields, which enables you to fill the form directly by clicking the form fields without using other features. This is called an Interactive PDF Form. The other kind of form is a plain PDF file with lines and texts, which can be filled using the Fill & Sign tools in Foxit PhantomPDF. This is called a Non-interactive PDF Form.

Interactive Form

For interactive forms, you will see a message box appear in the top-right corner of the application window. The message box informs you that this document is a fillable form.

Click to collapse the notification message. If you do not want to see the notification message again when reopening this file, check Don’t show again option in the notification message. Clicking the gear icon in the notification message can change the preferences about notification message setting. Please refer to Notification Messages preferences for more information.

Foxit PhantomPDF highlights the form fields in the document by default, which colors the backgrounds of all blanks to be filled in and outlines any required blanks, making it easy to see them at a glance. If you don’t need to highlight the fields, navigate to Form > Edit > uncheck Highlight Fields.

AcroForm and XFA (XML Forms Architecture) Form
Foxit PhantomPDF now supports both AcroForm and XFA Form. You can fill in XFA forms with the Hand command, the same which you were able to do with normal fillable forms (also known as AcroForm).

**Non-interactive Form**

The document message box will not appear. This kind of form acts like an ordinary PDF document that has plain text and you will need to use the Fill & Sign tools to fill in this form. For more information, please refer to “Filling Non-interactive Forms”.

**Fill in PDF Forms**

Foxit PhantomPDF not only allows you to fill in PDF forms and print them out, but also supports advanced form operations, such as saving filled-out forms and importing/exporting forms data.

**Fill Interactive Forms**

If a PDF form contains interactive form fields, you can fill in the form with the Hand command. When you place the pointer over an interactive form field, the pointer icon changes to one of the following:

- Hand icon -- Appears when mousing over a button, radio button, check box, or item on a list.
- I-beam icon -- Appears when you can type text into the form field.

**To fill in an interactive form, please do the following:**

- If necessary, select the Hand command.
- (Optional) To make form fields easier to identify, click the Highlight Fields in the document message box. Form fields appear with a colored background (light blue by default).
- (Optional) Before filling in an interactive form, you can also enable auto-complete feature so that Foxit PhantomPDF can store your entries and provide relevant suggestions to help you complete forms quickly and easily. For more information
about auto-complete, please refer to “Auto-Complete in the Forms preferences”.

- Then click on the first form field you want to fill in, either to select that option or to place an I-beam pointer in the field so that you can start typing.
- Right-click the text fields, and choose Paste or Select All to do other operations.
- After making a selection or entering text, you can press Tab or Shift + Tab to accept the form field change and go to the next or previous field.
- After you fill in the form fields, do one of the following:
  
  A. Click the submit button if one exists. Clicking this button sends the form data to a database across the web or over your company intranet.
  B. Click Save icon on the toolbar, or choose File > Save.
  C. Choose File > Save As, and specify a location for the copy.

**Clear a form entry**

Click one of the form fields, and use the Backspace key or Delete key.

**Reset unsaved form entries**

Choose Form > Reset Form.

**Fill lengthy entries in forms**

Some PDF forms can contain dynamic text fields, which changes the text you input in size to accommodate the text fields. The text appears smaller and smaller when the words you type exceed the current size of the field.

**Spell-checking form entries**

You can spell-check the text you typed in form fields after purchasing Foxit PhantomPDF if the security settings allow.

If you have installed the Spell Checker, when you insert any English text in the form fields, the spelling errors will be highlighted and underlined with squiggly lines.

To spell-check entries, do the following:

- Right-click on the misspelled words and you will see a list of five suggested words.
- Choose one of the suggested words to correct your input or ignore the squiggly line.
- If all the suggested words are not the exact words you want to input, try to correct
them with other words.

**Fill Non-interactive Forms**

You can use the Fill & Sign tools to add text and symbols in non-interactive PDF forms. Foxit PhantomPDF will intelligently detect the suspected fillable area and highlight it with a blue rectangle as your mouse moves over the page with a form filling tool selected, which helps you find out the fillable area and fill in non-interactive forms easily. To fill in non-interactive forms with Fill & Sign tools, follow the steps below.

- Choose **Fill & Sign** to expand the Fill & Sign toolbar.
- To add normal text, select **Add Text** in the Fill group. Then click on the form where you want to add text, and input your text.
- To add text in continuous boxes in a line, select **Comb Field** in the Fill group. Then click on the form where you want to add text, and input your text. The comb field will spread text evenly across the width of the text field, which is very useful when you are filling in phone numbers, social security numbers, etc.
- To add predefined text such as name, date or address, click **Predefined Text** in the Fill group, and do the following:
  - By default, Foxit PhantomPDF will detect and display the current date and user name of your system in the predefined text list. If you want to redefine custom text, click **Set Predefined Text**. In the pop-up **Set Predefined Text** dialog box, click **Set Identity** to set your identity information, and save it as predefined text. Or double-click on the blank area in the box to input any text as desired. Upon completion, click **OK** to save your settings. Then all your custom predefined text will be listed in the **Predefined Text** drop-down list.
  - Select a predefined text from the **Predefined Text** drop-down list, and click on the form where you want to add it.
- To add symbols, do the following:
  - Select the Checkmark, Cross Mark, or Dot tool to fill in check boxes or radio buttons. Select the Line tool to strike out text, or Rectangle tool to add rectangles.
  - Then click on the form where you want to place the symbol.
- After adding text or symbols, use the field toolbar floating above them to make appropriate changes, if necessary.
  - Click **A⁻** or **A⁺** to decrease or increase the size. For symbols, you can also drag any of the handles to resize it. For comb fields, dragging the resize handle on the right side of the field can also help you adjust the width of the field. The adjustments to size will be remembered and applied as the default.
  - To convert a normal text field into a comb field or vice versa, click the Comb
Field icon 📝 or Add Text icon ⚪️ correspondingly.

- To replace the current text or symbol, click ⚪️️ and choose a desired option from the toolbar.
- To move the text or symbol, drag it directly to the desired location.
- To delete the text or symbol, click 🗑️.

- After filling in the form, you can sign the form with your handwritten signature. For more information, please refer to “Quick PDF Sign”.

- When you have completed the form, click the Save button 📝️ or choose File > Save to save it.

Tips:

1. The fill tool will be kept as selected by default for you to add the same object continuously. If you need to exit the fill tool, press the ESC key, or select another desired tool directly.
2. You can also recognize form fields with the Run Form Field Recognition command ⬅️ in the Form tab and then fill in forms with the Hand command.

Comment on Forms

You can comment on PDF forms, just like any other PDF. You can add comments only when the form creator has extended these rights to the users.

See also “Chapter 7 - Comments”.

Manage Form Data

You can import form data from other file formats to a PDF form, or export form data on a PDF form to other file formats. You can also export form data from multiple PDF forms to a CSV file. In addition, for PDF forms with Ultraform technology, Foxit PhantomPDF supports to create and display 2D barcode that contains form data you filled in.
Import/Export Form Data

To import and export form data is similar to the way of importing and exporting comment data. However, this function is only for PDF interactive forms. All the options for importing and exporting form data will be unavailable when you open other ordinary PDFs or non-interactive forms.

*Tip:* You can import PDF form data from FDF, XFDF, TXT, XML, or CSV files, or export form data to a FDF, XFDF, TXT, XML, or CSV files.

**Import form data**

Choose **Form > Import ▶ >** navigate to where the desired file is, select it, and press “Open”. You will be prompted that the form data has been imported successfully.

**Export form data**

To export form data, please do either of the following:

- To export all form data to a file
  A. Choose **Form > Export > To File**.
  B. You will be presented with a standard Windows “Save As” dialog box.
  C. Choose a file format, navigate to where you want to save the file (e.g., your Documents folder), specify its name and click **Save** button.
  D. You will be prompted that the data has been exported successfully.

- To export all form data as a file and send it to others as an email attachment
  A. Choose **Form > Export > Via Email**.
  B. Choose a file format you want to export the form data to.
  C. A blank message with the created form data file included as an attachment will automatically open in your default e-mail program, and the default email subject will be “Data from [original document name].pdf”.
  D. Type the e-mail address of users you want to send the file, and click **Send**.

*Note:* The **Import** and **Export** commands are available only when the PDF document contains form data.

You can also export form data to an existing CSV file by clicking **Form > Form to sheet > Append to an Existing Sheet**. In the Open dialog box, select a CSV file you want to append the form data to and click **Open**. A Foxit PhantomPDF message will pop up to prompt that the form data has been exported successfully and let you decide whether to open the file.
Combine forms to a sheet

To export form data from multiple PDF forms to a CSV file, please do as following:

1. Choose **Form > Form to sheet > Combine Forms to a Sheet**.

2. In the Export multi-forms to a sheet dialog box, click **Add Files** to add files that you want to combine into a sheet. You can also click **Close** button 🚫 in the dialog box to remove files.

3. (Optional) Check the option **Contain forms you closed recently** to add the PDF files you closed recently. You can also append the exported form data to an existing file by checking the option **Append to an existing file**.

4. Click **Export**. In the Save As dialog box, specify a folder and file name (“data source.csv” by default) for the CSV file and click **Save**. A Foxit PhantomPDF message will pop up to prompt that the form data has been exported successfully and let you decide whether to open the file.

Generate 2D Barcode

Foxit PhantomPDF supports the generation of 2D barcodes for the forms integrated with Ultraforms technology, making the form data easily scanned, captured and incorporated into a database. Steps are as follows:

- Open and fill in the form.
- Upon completion, click the barcode generation button (if any) on the form file to generate 2D barcode.
- Click the save button 📝 on the Quick Access Toolbar to save the form.
- (If needed) Choose **File > Print** to print the form; and then you can use a supported scanner to scan, read and incorporate the form data into a database.
Form Fields

Foxit PhantomPDF provides a group of buttons that can be used to create and design form fields in interactive PDF forms. You are able to add form fields like push buttons, text fields, check boxes, combo boxes, list boxes and radio buttons to an interactive PDF form and specify their properties. PhantomPDF also offers form field recognition commands to recognize form fields in PDF documents. You can save time and mouse actions by using form field recognition to create form fields.

To add a form field to a PDF, select a type of form field button from the Form tab and the cursor changes to crosshair ‘+’. Drag an area in the desired position to add the form field. For details, please refer to Buttons.

Form field recognition

There are two commands for form field recognition in PDF forms: Designer Assistant and Run Form Field Recognition.

The Designer Assistant command automatically detects form fields that can be created on PDF pages and displays a blue frame where there is a suggested form field. By default, when you select any type of form field button from the Form tab, the
Designer Assistant command will be selected and enabled automatically. With any type of form field button selected, as you move the cursor \( \downarrow \) on the page, a blue frame appears if the cursor is hovering above an area which is detected as a form field. If you want to add a form field at that position, just click on it without dragging an area. And if there are multiple form fields detected, you can complete the form field creation with just a few clicks. (*Tip: You can disable the auto-detection by clicking the Designer Assistant command again when you are creating form fields. Then the command will no longer be selected automatically next time you create form fields. To enable it again, select the command before you create form fields.*)

Alternatively, you can use the Run Form Field Recognition command to recognize form fields through the whole document. To run form field recognition in a PDF document, do as the following:

1. Click Form > Run Form Field Recognition. All fillable fields in the document will be recognized and highlighted.
2. All the corresponding types of form fields will be automatically created and named with the text near the form fields. (Take the text fields for an example as below. With the Text Field command selected, you can see the form fields recognized and created are named with the text near the form fields.)
3. You can edit or delete the created form fields after right-clicking them. To edit the form field further, please refer to the properties of different buttons from “Buttons”.

<table>
<thead>
<tr>
<th>Applicant</th>
<th>Gender</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td></td>
</tr>
</tbody>
</table>

*The text fields created after recognition*

**Buttons**

There are seven basic buttons to add form fields for you to create an interactive PDF form:

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OK</td>
<td>Push Button</td>
<td>Creates an interactive form element to initiate certain predefined actions, such as opening a file, submitting data to a web server, or resetting a form. This button can also be</td>
</tr>
<tr>
<td>Field Type</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>Check Box</td>
<td>Presents yes-or-no choices for individual items. If the form contains multiple check boxes, users can select what they want.</td>
<td></td>
</tr>
<tr>
<td>Radio Button</td>
<td>Presents a group of choices from which the user can select only one item.</td>
<td></td>
</tr>
<tr>
<td>Combo Box</td>
<td>Lets the user either choose an item from a pop-up menu or type in a value.</td>
<td></td>
</tr>
<tr>
<td>List Box</td>
<td>Displays a list of options the user can select.</td>
<td></td>
</tr>
<tr>
<td>Text Field</td>
<td>Lets the user type in text, such as name, address, phone number, etc.</td>
<td></td>
</tr>
<tr>
<td>Signature Field</td>
<td>Creates a blank digital signature field for reviewers to sign the document</td>
<td></td>
</tr>
<tr>
<td>Image Field</td>
<td>Lets the user browse and select an image to add to the field.</td>
<td></td>
</tr>
<tr>
<td>Date Field</td>
<td>Lets the user choose a date.</td>
<td></td>
</tr>
<tr>
<td>Barcode Field</td>
<td>Represents a user’s form entries in a visual pattern that can be scanned, interpreted, and incorporated into a database.</td>
<td></td>
</tr>
</tbody>
</table>
Form Fields

Note: To create the same type of form fields continuously without reselecting the same tool, you can select Keep Tool Selected in the Form tab.
Push Button

✧ Create a new push button

Choose **Form > Form Fields > Push Button** and your cursor changes into ‧. Then do the following:

- Drag an area in the desired place to create a push button.
- A box appears under the button for you to input the button name and the name of label.
- You can also click the **All Properties** to do more settings.

✧ Move and resize a push button

- To move a push button, select the Select Annotation command or push button , click and drag the button to move it to a new location.
- To resize a push button, select the Select Annotation command or push button , click to select the button, and then drag a border handle.

✧ Delete a push button

- Select the Select Annotation command or push button , and click the push button you want to delete.
- Press Delete, or right-click the push button > Delete.

✧ Create multiple copies of a push button

You can create multiple copies of a push button. The new push button names are based on the original push buttons and appended with a number. However, you are able to create them with the same names. In addition, all the new push buttons are created sequentially, using standard array format.

- With the Select Annotation command or push button , select one or more push buttons that you want to copy (press Shift or Ctrl when clicking to select more buttons).
- Right-click one of the buttons > Create Multiple Copies...
• In the Create Multiple Copies of Fields dialog box, do the following:

A. To specify the rows to be created, enter or select a number in Copy Selected fields down (times). The default number is set to 2.
B. To specify the columns to be created, enter or select a number in Copy Selected fields across (times). The default number is set to 2.
C. To specify the width of the area in which the columns of fields appear, enter or select a number in Change Width (in). The default number is set to 0.04.
D. To specify the height of the area in which the columns of fields appear, enter or select a number in Change Height (in). The default number is set to 0.04.

*Note:* The width and height values don’t change the dimensions of individual fields but designate the size of the entire area for all the selected and newly created fields.

E. To change the position of buttons, use the Up, Down, Left, and Right buttons in the dialog box.
F. Click Preview to apply the results.
G. Click Same Name to apply the names of original buttons to the newly created buttons.

• Click OK.

*Note:* Copies of push buttons function independently of each other. You can use a different procedure to duplicate push buttons, creating an information-sharing relationship among these buttons.

🔹 Duplicate a push button across multiple pages

• Select the push button that you want to duplicate.
• Right-click the button > Duplicate…

*Note:* The Duplicate command isn’t available for forms with only one page.

• Then do one of the following:

A. To duplicate the push button on every page in the form, select All, and click OK.
B. To duplicate the push button on odd/even page in the form, select Odd pages or Even pages, and click OK.
C. To duplicate the push button on a limited range of pages, type the starting and ending page on which you want the button to appear. Click OK.

*Note:* Enter the page number including or not including the page on which the button originally appears doesn’t affect the duplication process. Including that page won’t create a second copy on top of the original one, and not including it won’t remove the
original button.

Set tab order

When navigating form fields using the Tab key, you can set the tab order of the buttons you created. By default, the tab order is based on the document structure. There are three ways you can choose to set tab order.

1. Set tab order in the Fields panel

   1) Open the Fields panel in the Navigation Pane.

   2) Click the Display Order icon in the upper-right corner of the Fields panel and select Tab Order (Note: If you select Alphabetic Order, all the form fields will be displayed alphabetically by the field names. Then the Set Order icon next to the Display Order icon disappears.).

   3) (Optional) Select Show Tab Numbers to view the tab order. The order number will show on the top left corner of a field.

   4) Click the Set Order icon and choose any of the following:

      • Order Tabs by Row – Order tabs from the upper-left field, moving first from left to right and then down to the next row.
      • Order Tabs by Column – Order tabs from the upper-left field, moving first from top to bottom and then to the right column.
      • Order Tabs by Structure – For forms with tagged fields, order tabs in the order set up in the tagging based on the document structure.
      • Order Tabs Manually – Order tabs manually by dragging and dropping a field to the desired place within the Fields panel.
      • Order Tabs Unspecified – Order tabs with the current settings in the page properties.

2. Set tab order in Page Properties

   1) Click the page thumbnails panel in the Navigation Pane.

   2) Right-click the page where you need to change the tab order and choose Properties....

   3) In the Page Properties dialog box, select one order in the Tab Order tab.

3. Set tab order in the document area
1) With the Select Annotation command selected, right-click a form field, and choose **Set Tab Order**.

2) Click anywhere in the field that you want it to be the first in the tabbing order. The number in the upper left corner will be set as 1.

3) Click each of the other fields in the order that you want tabbing to occur.

*Note:* You can only set tab order within one page.

✧ **Set push button properties**

You can set properties that apply formatting, determine the appearance and actions, and so forth.

The push button has a General tab, an Appearance tab, a Position tab, an Options tab, and an Actions tab. Besides, there are two items on every tab:

- **Locked** – When selected, prevents any further changes to any push button properties.
- **Close** – Applies and saves the current button properties, and closes the button properties dialog box.

*Note:* If you select Locked on any tab, it will lock all options for the button, but not just the options on that tab.

1. The General tab for the button properties

The General tab in push button properties contains the following options:

- **Name** – Specifies the unique name of the selected push button.
- **Tooltip** – Displays text that the hesitant user may find helpful in clicking the button. Tooltips appear when the pointer hovers over the push button.
- **Form Field** – Specifies whether the push button can be seen, either on screen or in print. There are four choices for you: **Visible, Hidden, Visible but doesn't print,** and **Hidden but printable.**
- **Orientation** – Rotates the push button by 0, 90, 180, or 270 Degrees.
- **Read Only** – Prevents the user from clicking the push button.
- **Required** – This option is not available for the push button.

2. The Appearance tab for the button properties

The Appearance properties determine how the push button looks on the page. The Appearance tab in push button properties contains the following options:
• Line Style – Alters the appearance of the frame. Select **Solid, Dashed, Beveled, Inset or Underline**.

![Solid Dashed Beveled Inset Underline](image)

*The appearances of Push Button with different line styles*

**Note:** You may not see the difference if no color is chosen as the border color.

• Thickness – Specifies the width of the frame surrounding the push button: Thin, Medium, or Thick.

• Border Color – Opens a color picker in which you can select a color for the frame surrounding the button. To leave the button without a frame, select **No color**.

• Fill Color – Opens a color picker in which you can select a color for the button. To leave the button uncolored, select **No color**.

**Note:** A Fill Color choice other than No color will block any images on the PDF page that are behind the button.

• Font Size – Sets the size of the label for the button. You can either choose **Auto**, various preset values, or type in a different value.

• Text Color – Opens a color picker in which you can select a color for the label.

• Font – Lists the fonts available on your computer.

![Label](image)

**Font Size: 18**

**Text Color: Green**

**Font: Open Sans**

*Push Button*

3. The Position tab for the button properties

You can use the Position tab to make accurate adjustments to the position and the size of the button by entering specific values. Select the unit of the values. To move the button, enter values for the position properties (the Left/ Right/ Top/ Bottom options). To change the size of the button, enter values for the Height and Width options. To move the button without changing its size, select the **Do not change height and width when changing the position** option.
4. The Options tab for the button properties

The Options properties determine how labels and icons appear on the button. A button can have a label, an icon, or both. The Options tab in push button properties enables you to add any labels you like. The Options tab in push button properties contains the following options:

- Layout – Specifies the layout of label and icon of the button. There are seven choices:

  A. Label only  
  B. Icon only  
  C. Icon top, label bottom  
  D. Label top, icon bottom  
  E. Icon left, label right  
  F. Label left, icon right  
  G. Label over icon

**Button Layouts**

- Advanced – Does the details settings to the icon.
  
  A. When to scale – choose when to scale the icon you insert. There are four options:

    **Always:** scale the icon to fit the button you draw.

    **Never:** never scale the icon. Show the icon with its original size all the time.

    **Icon is too Big:** zoom out the icon to fit the button if the former one is bigger than the latter one, or show the icon with its original size.

    **Icon is too Small:** zoom in the icon to fit the button if the former one is smaller than the latter one, or show the icon with its original size.

  B. Scale – choose to scale the icon non-proportionally or proportionally. This option will be disabled when you select **Never** in the field of **When to scale**.

    **Proportionally:** scale the icon in its proportion.

    **Non-proportionally:** scale the icon to fit the button when the magnification is changed.

  C. Fit to bounds – check this option to scale the icon to fit fully within the bounds
of the button without taking into consideration the line width of the border.

D. Border – drag and move the scroll bar to change icon's position in the button. The coordinates change when you move the scroll bar.

• Behavior – Specifies the display of the button when clicked. The button behavior options include:

    **None**: Keeps the appearance of the button the same.

    **Push**: Specifies appearances for the Up, Down, and Rollover states of the mouse. Select an option under State, and then specify a label or icon option:

    - **Up**: Determines what the button looks like when the mouse button is not clicked.

    - **Down**: Determines what the button looks like when the mouse is clicked on the button, but before it is released.

    - **Rollover**: Determines what the button looks like when the pointer is held over the button.

   **Outline**: Highlights the button border.

   **Invert**: Reverses the dark and light shades of the button.

The Button Behaviors

• To define the label or icon that appears on the button, do the following:

A. If a label option is selected from the Layout menu, type the text in the Label box.

B. If an icon option is selected from the Layout menu, click Choose icon... > click Browse... > Select the file type from the Objects of Type menu, double-click the file name, and click OK. (To remove the selected icon, click Clear button.)

• Click **Close** to accept these display properties.

5. The Actions tab for the button properties

The Actions properties specify any actions that you want to associate with the push
button, such as jumping to a specific page or going to a web site. The Actions tab in push button properties contains the following options:

- **Select Trigger** – Specifies the user action that initiates an action: **Mouse Up**, **Mouse Down**, **Mouse Enter**, **Mouse Exit**, **On Receiving Focus**, or **On Losing Focus**.
- **Select Action** – Specifies the event that occurs when the user triggers the action: **Go to a page view**, **Open/execute a file**, **Open a web link**, **Show/hide a field**, **Execute a menu item**, **Submit a form**, **Reset a form**, **Import form data**, and **Run a JavaScript**.

A. Go to a page view – designate to a specific page view. You can not only designate to a page in the current PDF, but also to the page in another PDF. Also, you may change the current zoom setting and then set the position.

To go to a page view, choose this option, click **Add** button and do one of the following:

a) **Set the position in current document** – scroll the current document, go to a new position where you want to set and click **Set this position**.

b) **Set the position in another PDF document** – click the **Open** button on the toolbar > select the PDF you want to set position > scroll this document and go to a position where you want to set > click **Set this position**.

d) **Click Cancel** to revoke your operation.

**Note:** The new PDF document should be opened in the existing window but not a new window.

c) **Change the view magnification** -- scroll in the current document or another document > go to a new position where you want to set > change the magnification of the position > click **Set this position**.

d) **Click Cancel** to revoke your operation.

B. Open/execute a file – designate to open another file. To do this, choose **Open/execute a file** > click **Add** button > select the destination file and click **Select**.

C. Open a web link – designate to open a web link. To do this, choose **Open a web link** > click **Add** button > enter the URL of the destination web page.

D. To show/hide a field, select the option > click **Add...** > choose to show or hide the selected button when the user triggers the action, and click **OK**.

E. To execute a menu item, select the option > click **Add...** > select one of the items in Menu Item Selection dialog box, and click **OK**.

F. To submit a form, select the option > click **Add...** > choose the export format, submission method, decide which fields should be submitted, and click **OK**.
G. To reset a form, select the option > click Add… > select the fields that will be reset, and click OK.

H. To import form data, select the option > click Add… > choose the FDF file that contains the form data you want to import, and click Open.

I. To run a JavaScript, select the option > click Add… > enter JavaScript, and click OK. For more details, please refer to the JavaScript section.

J. To read an article, select Read an article > click Add… > choose an article, and click OK.

- Actions – Displays the list of triggers and actions that you have defined.
- Up and down buttons – Change the order in which the selected action appears listed under the trigger. (Available only when you have defined multiple actions for the same trigger.)
- Edit – Opens a dialog box with specific options for the selected action. You can also double-click the actions to open a dialog box.
- Delete – Removes the selected action.

❖ Set push button properties as default

After setting button properties for a new push button, you can set your settings as the new default for all the push buttons you create in future. To set the current properties as default, right-click the push button > select Use Current Properties as New Defaults.

❖ Set properties of multiple form fields

- Select multiple form fields > right-click one of them > Properties....
- There pops up the Button Properties dialog box, and then follow the steps specified above.

Check Box

A check box is a type of form field that presents yes-or-no choices for individual items. For creating, moving, resizing, deleting, creating multiple copies, duplicating a check box and setting tab order, please refer to “Push button”.

❖ Set Check Box Properties

There are also five tabs, a General tab, an Appearance tab, a Position tab, an Options tab, and an Actions tab, for you to set check boxes’ properties.

The General tab
Most items in this tab are the same as the ones in the properties of Push Button. Please refer to Set Push Button Properties for details. For the Required option:

- Required – Forces the user to select the check box. If the user attempts to submit the form while a required check box is not selected, an error message appears.

The Appearance tab

Please refer to Set Push Button Properties.

The Position tab

Please refer to Set Push Button Properties.

The Actions tab

Please refer to Set Push Button Properties.

The Options tab

Check Box Style - Specifies the style of the check box. There are six choices:

A. Check    B. Circle    C. Cross    D. Diamond    E. Square    F. Star

Export Value - Identifies the check box and differentiates it from other check boxes that share the same Name value.

Checked by default – Sets the selection state of the check box when the user first opens the form.

**Note:**

1. If you create multiple copies of the check box, please make sure both the form field names and the export value are all different in related check boxes.

2. If the check boxes in a group have the same form field name but with different export values, the check boxes will present a group of choices from which the user can select only one item.
Radio Button

A radio button is a type of graphical user interface widget that allows you to choose one of a predefined set of options. For creating, moving, resizing, deleting, duplicating the buttons and setting tab order please refer to "Push button".

Tip: How to toggle radio buttons

For the radio buttons in a group, they should have the same form field name but with different export values. This ensures that the radio buttons toggle and that the correct values will be collected in the database.

1. Please use copy-paste to create multiple copies if having more than one form field with the same name. After this, to make the value usable, you have to change the value of the radio buttons to make sure all radio buttons have the same field name but different export value.
2. Please note you cannot use “Create Multiple Copies” option if there is more than one radio button with the same name. A warning message will pop up if you right click and choosing Create Multiple Copies.

_set radio button properties_

How a radio button behaves is determined by settings in the Radio Button Properties dialog box. You can set properties that apply formatting, determine the appearance and actions, and so forth.

The radio button has a General tab, an Appearance tab, a Position tab, an Actions tab, and an Options tab as push button.

1. The General tab

Most items in this tab are the same as the ones in the properties of Push Button. Please refer to Set Push Button Properties for details. For the Required option:

- Required – Forces the user to click the radio button. If the user attempts to submit the form while a required radio button is not chosen, an error message appears.

2. The Appearance tab for the radio button properties

The Appearance properties determine how the radio button looks on the page. The Appearance tab in push button properties contains the following options:

- Line Style – Alters the appearance of the frame. Select Solid, Dashed, Beveled,
Inset or Underline.

Solid          Dashed        Beveled        Inset         Underline

The appearances of Radio Button with different line styles

Note: You may not see the difference if no color is chosen as the border color.

• Thickness – Specifies the width of the frame surrounding the radio button: Thin, Medium, or Thick.
• Border Color – Opens a color picker in which you can select a color for the frame surrounding the button. To leave the button without a frame, select No color.
• Fill Color – Opens a color picker in which you can select a color for the background behind the button. To leave the background uncolored, select No color.

Note: A Fill Color choice other than No color will block any images on the PDF page that are behind the button.

• Text Color – Opens a color picker in which you can select a color for the button.

Radio Button

Note: The items of Font Size and Font are not available in the Appearance tab for the Radio Button properties.

3. The Position tab for the radio button properties

   Please refer to "Position tab for the button properties".

4. The Actions tab for the radio button properties

   Please refer to "Actions tab for the button properties".

5. The Options tab for the radio button properties
The Options tab in radio button properties enables you to change the button style and do other additional settings. The Options tab in radio button properties contains the following options:

- **Button style** – Specifies the shape of the maker that appears inside the button when the user selects it. There are six choices in total: Check, Circle (the default), Cross, Diamond, Square, or Star. This property does not alter the shape of the radio button itself.
- **Export Value** – Identifies the radio button and differentiates it from other radio buttons that share the same Name value. The status of a radio button is “yes”. You can give them other names with this box.
- **Checked by default** – Sets the selection state of the button when the user first opens the form.
- **Radio buttons with the same name and value are selected in unison** – Allows single-click selection of multiple related radio buttons. If the user selects a radio button that has the same field name and export value as another, both radio buttons are selected.
- **Click Close to accept these display properties.**

✧ **Set radio button properties as default**

After setting radio button properties for a new radio button, you can set your settings as the new default for all the radio buttons you create in future.

To set the current properties as default, right-click the radio button, select **Use Current Properties as New Defaults**.

**Combo Box Button**

A combo box is a commonly-used GUI widget. It is a combination of a drop-down list or list box and a single-line textbox, allowing the user either to type a value directly into the control or choose from the list of existing options.

For creating, moving, resizing, deleting, duplicating the combo box and setting tab order, please refer to “Push button”.

✧ **Set combo box properties**

How a combo box behaves is determined by settings in the Combo Box Properties dialog box. You can set properties that apply formatting, determine the appearance and actions, perform mathematical operations, and so forth.

The combo box has a General tab, an Appearance tab, a Position tab, an Options tab,
a Format tab, a Validate tab, a Calculate tab, and an Actions tab.

1. The General tab for the combo box properties

Please refer to “General tab for the radio button properties”.

2. The Appearance tab for the combo box properties

Please refer to “Appearance tab for the button properties”.

3. The Position tab for the combo box properties

Please refer to “Position tab for the button properties”.

4. The Actions tab for the combo box properties

Please refer to “Actions tab for the button properties”.

5. The Options tab for the combo box properties

You can create a list of items from which the user selects with the Options tab.

- Item – Accepts the text and space character that you type for options that you want to appear in the menu for the field.
- Add – Moves the current entry in Item to Item List.
- Export value – Where you type in a value to represent the item if the data will be exported. If left blank, the entry for Name in the General tab is used as the export value.
- Item list – Displays the choices that will be available in the list.

**Note:** The highlighted item in the Item List box appears as the default selected item in the combo box field. To change the default item, highlight another item from the list.

- Delete – Removes the selected item from the list.
- Up/Down – Change the order in which the items are listed in the combo box list. These buttons are not available if Sort Items is selected.
- Sort items – Arranges the listed items numerically and alphabetically. A numerical sort (if applicable) is performed before an alphabetical sort.
- Allow user to enter custom text – Enable users to enter a value other than the ones in the list.
- Commit selected value immediately – Saves the value as soon as the user selects it. If this option is not selected, the value is saved only when the user tabs out of the current field or clicks another form field.
6. The Format tab for the combo box properties

The Format tab in the combo box properties dialog box enables you to format the field values. Select one of the categories listed below:

- None – No additional options are available. The input in a combo box with this property does not require any specific formatting.
- Number – Automatically imposes the selected formatting options on numeric data entries.
  
  A. Decimal places – Sets the number of digits that appear to the right of the decimal point.
  B. Separator style – Sets the placement of commas and periods.
  C. Currency symbol – Sets the type of currency, such as Dollars, Euros, or Pounds.
  D. Negative Number Style – Sets how negative numbers are displayed. You can choose Show parentheses, Use red text, neither, or both.

- Percentage – Automatically imposes the selected formatting options on numeric data expressed as a percentage.
  
  A. Decimal places – Sets the number of digits that appear to the right of the decimal point.
  B. Separator style – Sets the placement of commas and periods.

- Date – The list includes one-, two-, and four-digit variations where d stands for the day, m stands for the month, and y stands for the year. Also, you can choose Custom option and type your format.
- Time – The list includes display variations where h stands for the hour on a 12-hour clock, H stands for the hour on a 24-hour clock, MM stands for minutes, ss stands for the seconds, and tt stands for AM or PM. Also, you can choose the Custom option and type your format.
- Special – There are five options for you:
  A. Zip Code – For a five-digit postal code.
  B. Zip Code + 4 – For a nine-digit postal code.
  C. Phone Number – For a ten-digit telephone number.
  D. Social Security Number – For a nine-digit US Social Security Number.
  E. Arbitrary Mask -- Changes the format category to Custom and makes another text box available, in which you can type a custom format. Use this option to specify which types of characters the user can enter in any given position, and how the data displays in the field.
    a. A -- Accepts only letters (A–Z, a–z).
    b. X -- Accepts spaces and most printable characters, including all characters available on a standard keyboard and ANSI characters in the ranges of 32–
126 and 128–255.

c. O -- The letter “O” accepts alphanumeric characters (A–Z, a–z, and 0–9).
d. 9 -- Accepts only numeric characters (0–9).

For example, a mask setting of AAA--p#999 accepts the input BDF--p#367. A mask setting of OOOOO@XXX accepts the input vad12@3Up.

**Example of an Arbitrary Mask entry**

- Custom -- Makes additional options available to form designers who want to write their own JavaScripts for formatting and keystrokes. For example, a custom script could define a new currency format or limit the user entry to specific keystroke characters.

A. Custom Format Script – Displays any custom scripts you have added for formats. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

B. Custom Keystroke Script – Displays any custom scripts you have added to validate keystrokes. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

7. The Validate tab for the combo box properties

The Validate properties restrict entries to specified ranges, values, or characters, ensuring that users enter the appropriate data for a combo box.

- Field value is not validated – Turns off validation.
Field value is in range – Sets a numeric range for a combo box using values you enter in either as a number or a percentage. It is available only when Number or Percentage is selected in Format tab.

Run custom validation script – Validates by a JavaScript that you create or provide. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

8. The Calculate tab for the combo box properties

With this option, you can perform mathematical operations on existing form field entries and display the result.

- Value is not calculated – Select this option if you want the users to type.
- Value is the – Select this to make further options available:
  
  A. The List includes the mathematical functions to apply to the selected fields. Choose Sum to add the values entered in the selected fields, Product to multiply them, Average, Minimum, or Maximum.
  B. Pick – Opens a Field Selection dialog box with a list of the available fields in the form that you select to add or deselect to remove from the calculation.

- Simplified field notation -- Uses JavaScript with field names and simple arithmetic signs. The Edit button opens a JavaScript Edition dialog box in which you can write, edit, and add scripts.
- Custom calculation script -- Displays any custom scripts you have added for calculations. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

Set combo box properties as default

After setting combo box properties for a new combo box, you can set your settings as the new default for all the combo boxes you create in future.

To set the current properties as default, right-click the combo box > select Use Current Properties as New Defaults.

List Box and Text Field

A list box is a GUI widget that allows the user to select one or more items from a list contained within a static, multiple line text box. Also, you can set a list box property that enables the user to Shift-click or Ctrl-click/Control-click to select multiple items on the list.
A text field is a common element of graphical user interface of computer programs, as well as the corresponding type of widget used when programming GUls, which let the user type in text, such as name, address, phone number, etc.

For creating, moving, resizing, deleting, duplicating the list box and text field and setting tab order please refer to "Push button".

✧ **Set list box properties**

Please refer to “Set combo box properties”.

✧ **Set text field properties**

Although most of the properties are common to those of combo boxes, the Options tab is exclusive.

1. For all the other properties of a text field, please refer to “Set combo box properties”.

2. The Options tab for the text field properties

   - **Alignment** – Aligns the text left, right, or center within the field.
   - **Default Value** – Specifies the text that appears until the user overwrites it by typing in the field. Enter the default value by typing in this option.
   - **Scroll long text** – Compensates for text that extends beyond the boundaries of the text field.
   - **Allow Rich Text Formatting** – Allows users to apply styling information to the text, such as bold or italic. This might be useful in certain text fields where such styling information is important to the meaning of the text, such as an essay.
   - **Limit of Characters** – Allows entries of up to the number of characters you specify.

   **Note:** If you entered a default value, that value is clipped to this limit.

   - **Password** – Displays the user-entered text as a series of asterisks (*). This option is available only if Check Spelling is deselected.
   - **Field is used for file selection** – Allows the user to enter a file path as the field's value when a file is submitted along with the form. This option is available only when Scroll long text is the only selected option in the Options tab.
   - **Check spelling** – Checks the spelling of user-entered text.
   - **Comb of Characters** -- Spreads the user-entered text evenly across the width of the text field. If a border color is specified, **Solid** or **Dashed Line** is selected in the Appearance tab, each character entered in the field is separated by lines of that color. This option is available only when no other check box is selected.
Text fields with and without the Comb property

A. Text field with a border color, using the Comb property

B. Text field without the Comb property

- Multi-line – Allows more than a single-line entry in the text field. Setting line spacing is available in a multi-line text field.

❖ Set text field properties as default

To set the current properties as default, right-click the text field > select Use Current Properties as New Defaults.

Signature Field

The signature field is specially designed by to create blank digital signature fields for reviewers to sign. You can place the field anywhere you want the reviewers to sign.

❖ Create a new Signature field

Choose Form > Signature Field, your cursor will change into and do the following:

- Drag an area in the desired place to create a signature field.
- A box appears under the field for you to input the name.
- You can also click the All Properties to do more settings. Or double-click the field to open the signature Properties dialog box.

For moving, resizing, deleting, duplicating the signature field and setting tab order, please refer to “Push button”.

To set signature field’s General, Appearance, Position, and Actions tab properties, please refer to “Set push button properties”.

Foxit PhantomPDF supports to sign and verify digital signatures on XFA forms created
by Adobe LiveCycle. To sign and verify digital signatures, please refer to [Digital Signature](#).

The Signed tab for the signature field properties:

- Nothing Happens When Signed – it is set as default.
- Mark As Read-Only - Prevents other readers to change the digitally signed form.
  - All Fields - Prevents any changes to any form field.
  - All Fields Except These - Allows changing the selected form fields. Click the Pick button and select check boxes for the fields that you want the reviewers to edit after signing.
  - Just These Fields – Prevent to change the form fields you pick.

- This Script Executes When Field is Signed:

Activate a custom JavaScript when the user digitally signs the form. Click the Edit button to change or create a new JavaScript action.

**Image Field**

An image field is a Push Button with JavaScript prewired, which allows users to quickly browse and select an image to add to the PDF document. For creating and modifying an image field, please refer to the instructions on [Push button](#).

**Date Field**

A date field is a Text Field with the Format set to Date, letting users quickly fill in a date in the PDF. When users click the date field with the Hand command, the Date picker arrow icon appears. Click the arrow icon and choose a date from the Date picker. Then the date is successfully filled in the date field with the specified format. For creating and modifying a date field, please refer to the instructions on [Text Field](#).

**Barcode Field**

Barcode fields represent a user’s form entries in a visual pattern that can be scanned, interpreted, and incorporated into a database. Form authors add barcode fields in PDF forms and distribute the forms to users to fill in and submit to form receivers; the received barcode data can be scanned or interpreted with dedicated hardware that processes barcode data. Using barcodes to collect and process data helps save time...
and avoid errors that can occur during manual data entry.

✦ **Add a barcode field**

1. Open the PDF form with Foxit PhantomPDF and select the **Automatically calculate field values** option in *File > Preferences > Forms*.
2. Click *Form > Barcode Field*, and your cursor changes into "+".
3. Drag an area in the desired place to define a barcode area.
   
   **Tips:**
   
   - Place the barcode in an appropriate position that can be easily seen and scanned. And make sure it’s unlikely to get folded when placed in an envelope and won’t get clipped off during printing or faxing.
   - Make sure that the barcode area is large enough to accommodate the amount of data. Otherwise, it turns a solid gray, and a message “Too Much Data” appears on the barcode field in form editing mode. You can adjust the barcode size by dragging a handle to make the data fit in the barcode area.
   - If you will decode the barcode with a handheld scanner, avoid creating barcodes wider than 4 inches. Tall, narrow barcodes generally work better with handheld scanners.
4. A box appears under the area for you to input the field name.
5. Double-click the barcode area or click the **All Properties** to open the **Barcode Field Properties** dialog box.

**Note:**

1. In addition to the barcode size adjustment, to make the data fit in the barcode area, deselect any fields that don’t need encoding in the *Value* tab of the **Barcode Field Properties** dialog box, or consider creating additional barcode fields in the form and mapping different data to each barcode field.
2. If you add a new form field to the PDF form after you have created the barcode, it is not automatically included in the barcode. Then you need to manually include the field in the barcode by clicking **Pick** in the *Value* tab of the **Barcode Field Properties** dialog box.

✦ **Set Barcode Field properties**

There are also five tabs, a General tab, a Position tab, an Options tab, a Value tab, and an Actions tab, for you to set Barcode Field properties.

1. The General tab
Most items in this tab are the same as the ones in the properties of Push Button. Please refer to Set Push Button Properties for details. The options in Common Properties are not available.

2. The Position tab

Please refer to Set Push Button Properties.

3. The Actions tab

Please refer to Set Push Button Properties.

4. The Options tab

**Symbology:** You can choose a barcode type from PDF417, QR Code, and Data Matrix. Each barcode type follows an algorithm for standardizing the encoding and storing of data. Here are samples of the three barcode types.

![Barcode Samples](image)

**Different types of barcode fields**

**Compress Data Before Encoding to Barcode:** Specify whether to compress data before it is encoded. Compressing data allows more data to be stored in the barcode. Avoid compressing data when using a handheld scanner since most of these scanners cannot decode compressed data. By default, the option is not selected.

**Decode Condition:** Select the type of hardware to process returned forms. Foxit provides you with ready-to-use preset decode conditions. You can also click Custom to create a new decode condition.

**Custom:** Click it to select custom processing parameters that are best for your scanning and faxing hardware. The options available vary from the barcode type you select.
**X Dimension**: Specify the width of the cell.

**Y/X Ratio**: Specify the height-to-width ratio of the cell. This option is only available for PDF417 barcodes.

**Error Correction Level**: PDF417 and QR Code barcodes provide additional data redundancy by using an error correction technique to allow a partially damaged barcode to be scanned or decoded successfully. You can specify the error correction level that corresponds to the level of data redundancy. The error correction levels range from 0 to 8 for PDF417 barcodes (8 is the highest), and L, M, Q, and H for QR Code (H is the highest). A higher Error Correction Level allows a higher percentage of the barcode to be damaged by pen marks, poor print quality, degradation caused by fax transmission, or folds in the document. However, a higher level also increases the overall size of the barcode.

**Manage Barcode Parameters**: Lists all the decode conditions including the seven presets. You can create, edit, remove, import, and export custom decode conditions.

**Settings**: Displays the detailed parameters for the decode condition you selected.

5. **The Value tab**

**Encode using**: Select the format of the barcode data that is automatically scripted. When an option is selected, the associated JavaScript script is automatically generated. XML requires a larger barcode area to encode information than Tab Delimited does.

**XML**: Encodes the form data into the barcode in XML format.

**Tab Delimited**: Encodes the form data into the barcode in a tab-delimited format. If the form is configured to output the data in individual XFDF or XDP files, the data must be encoded in a tab-delimited format with the field names in the first line. This option is also useful if you need to encode more data into a barcode or copy the data into database or spreadsheet tables.

**Pick**: Selects which fields to be encoded into the barcode.

**Include field names**: Encodes field names in the first line of the barcode contents and the field values in the second line, with the specified delimiter between each field. This option is only available when Tab Delimited encoding is selected.
Custom calculation script: Displays the default script. You can click Edit to open the JavaScript Edition dialog box and write custom calculation scripts for your barcode. A script that restricts data to alphanumeric characters and to a single case (either all uppercase or all lowercase) can help make the data occupy less barcode area. Note: The National Association of Computerized Tax Processors (NACTP) guidelines, used by the United States Internal Revenue Service and state tax agencies, recommend using all uppercase characters for 2D barcode data including PDF417 and Data Matrix barcode types.

Reference to published form: Shows the path to the PDF form under the barcode. You can modify the path by typing in the URL to the form. The URL is useful if you need to re-create a digital version of the completed form by merging the form template with an instance of user-supplied data.

Arrange form fields

You can arrange form fields in a page, such as aligning, centering and distributing form fields. Before arranging form fields, select multiple form fields.

Select multiple form fields

To arrange the form fields, you have to select multiple form fields that you want to arrange first.

To select multiple form fields, do one of the following:

- Choose the Select Annotation command > Shift-click or Ctrl-click each form field.
- Choose the Select Annotation command > drag a selection marquee around the area to select them.

To deselect an individual form field, Ctrl-click the specific field.

Note: The form field highlighted in red is the anchor. When you select multiple form fields by clicking, the last field selected is the anchor.

Align/Center/Distribute multiple form fields

Please refer to Arrange comments for details.
Resize multiple form fields

Select one of the form fields as the anchor, and the rest of the form fields will be resized with the same height or width as that of the anchor form field. For example,

- Select form field A and B with the Select Annotation command. Suppose that you want to set A as the anchor form field.
- Right-click A > Size > Height/Width/Both. And you’ll see that the height/width/height and width of B is resized to be the same as that of A.

Set Form-field Tab Order

Please refer to Set Tab Order of Push Button.

Page templates

Page templates can be used to fill a PDF form where users need to add more pages if they still have info to enter. Or, an official organization like Customs creates a page template which contains several buttons with JavaScript actions that corresponding forms will appear when users click on different buttons to fill in forms based on different situations.

Create a page template

1. Navigate to a page that you want to create a page template from.
2. Click Form > Page Template.
3. In the Page Templates dialog box, enter the name and click Add.
4. A message box pops up to ask you whether to create a new page template from the current page. Click OK.
5. The name of the created template will be listed in the dialog box, and you can preview it on the left of the dialog box by checking the box to the left of the template name.
6. Click Close to exit the Page Templates dialog box.

Manage page templates

In the Page Templates dialog box, choose a template and click Goto to navigate to the page. You can also rename, replace, and delete page templates.
Renaming a page template

1. Click **Form > Page Template**.
2. In the **Page Templates** dialog box, choose the template you want to rename, click **Rename** and click **OK**.
3. Type a new name in the pop-up dialog box and click **OK**.
4. Click **Close** to exit the **Page Templates** dialog box.

Replacing a page template

1. Navigate to a desired page you want to replace with.
2. Click **Form > Page Template**.
3. In the **Page Templates** dialog box, choose the template you want to replace, click **Replace** and click **OK**.
4. Click **Close** to exit the **Page Templates** dialog box.

Deleting a page template

1. Click **Form > Page Template**.
2. In the **Page Templates** dialog box, choose the template you want to delete, click **Delete** and click **OK**.
3. Click **Close** to exit the **Page Templates** dialog box.

Setting the field calculation order

When you define two or more calculations in a form, the order in which they are carried out is the order in which you set the calculations. In some cases, you may need to modify the calculation order to obtain correct results.

For example, if you want to use the results obtained from calculating two form fields to calculate the value of a third form field, the first two form fields must be calculated together first to obtain the correct results.

- Choose **Form > Calculation Order**

The Calculation Order dialog box displays all calculable fields in your form and the order in which the calculations are performed.

- To change the field calculation order, select the field from the list, and then click the **Up** or **Down** button as needed.
- Click **OK** to finish.
Edit Static XFA Forms

Foxit PhantomPDF supports editing of static XFA forms.

To edit static XFA forms, please do as below:

1. Open the static XFA form with Foxit PhantomPDF and choose Form > Edit Static XFA Form. You’ll be prompted to save a copy of the original file to continue to edit.

2. Click Yes to edit the form as needed.

JavaScript

JavaScript is a dynamic, prototype-based language with first-class functions, which serves as a means to easily create interactive web pages. In Foxit PhantomPDF, you can easily integrate this level of interactivity into your PDF documents.

With Foxit PhantomPDF, you can invoke JavaScript code using actions associated with documents, bookmarks, links, and pages. Foxit PhantomPDF provides four options – Document JavaScript, Document Action, JavaScript Console, and Edit All JavaScripts. The Document JavaScript lets you create or access document level scripts in Foxit PhantomPDF. The Document Action lets you create document-level JavaScript actions that apply to the entire document. The JavaScript Console provides an interactive and convenient interface for testing portions of JavaScript code and experimenting with object properties and methods. The Edit All JavaScripts option allows you to create and edit all JavaScripts (e.g. bookmark JavaScripts, page JavaScripts, etc.) in the JavaScript Editor.

(Tip: You can modify JavaScript code using other JavaScript editors you are familiar with such as WebStorm and Sublime Text. To do this, you need to add the JavaScript editor first in File > Preferences > JavaScript. See also Use external JavaScript editor.)

Document JavaScript

Document JavaScripts are variable and function definitions that are generally useful to a given document, but are not applicable outside the document.

- Variable definitions: Define variables at the document level to make them visible to any executing script.
- Function definitions: Define functions at the document level that support the user
interaction with the document. These functions may be utility functions for handling common tasks for string or number manipulation, or functions that execute lengthy scripts called by actions initiated by a user interacting with form fields, bookmarks, page changes, etc.

To create or access document level scripts in Foxit PhantomPDF, select **Form > JavaScript > Document JavaScript**. The pop-up JavaScript Functions dialog box (or an external JavaScript editor if you have specified one in **File > Preferences > JavaScript**) enables you to add, edit, or delete document level scripts. All the document level scripts are stored within the PDF document.

In JavaScript Functions dialog box, you will see the following buttons:

- **Close** – Closes the dialog box.
- **Add** – After typing a new Script Name, a JavaScript Editor dialog box pops up. You can create and edit document level scripts here. To change the font of JavaScripts, click the Font button.
- **Edit** – The JavaScript Editor dialog box pops up, enabling you to modify the JavaScripts you create.
- **Delete** – Delete the JavaScript you selected.

**Document Action**

You can create the document-level JavaScript actions that apply to the entire document. For example, selecting Document Did Save runs the JavaScript after a document is saved.

**JavaScript Console**

JavaScript Console is a control panel for the execution and debugging of JavaScript code. Serving as a debugging aid, it is quite useful for displaying debug messages and executing JavaScript. To activate the JavaScript console, select **Form > JavaScript > JavaScript Console**, and do the following:
You can click **Save** to save a copy of your JavaScript code, or click **Cancel** to revoke your operation.

### JavaScript Editor

You can use the built-in JavaScript editor in PhantomPDF (or an external JavaScript editor if you have specified one in **File > Preferences > JavaScript**) to create and edit all the JavaScripts in a PDF file. To open the JavaScript editor, choose **Form > JavaScript > Edit All JavaScripts**. In the **JavaScript Editor** dialog box, click **Go to** to jump to a specific line of code. After editing the JavaScripts, click **OK** to save it.

### Optional Database connectivity to Windows ODBC

The Optional Database Connectivity plug-in is a JavaScript object inside Foxit PhantomPDF, allowing you to connect to Windows ODBC (Open Database Connectivity) data sources. It provides some basic JavaScript properties and methods to gain increased customization options and data accuracy to access to information databases. More importantly, JavaScript can be used to execute SQL commands and retrieve data, which can, in turn, be used to populate a PDF file. Also, developers can
create document level-scripts to connect to a database for the purposes of inserting new data, updating information, and deleting database entries.
Chapter 10 – Security

The security feature of PDF gives you an exceptional control over your PDF files. To provide adequate protection for PDF’s contents, you can encrypt and secure PDF files to prevent unauthorized access, restrict sensitive operations, etc.

Check PDF security

Some PDF files may contain restrictions preventing actions such as printing, editing, copying, etc. To check if you have these permissions, please do the following:

- Choose File > Properties > Security, or Protect > Security Properties.

Password Protection & Certificate Protection

In Foxit PhantomPDF, you can add password protection, certificate protection, and security restrictions to a PDF or PDF portfolio, limiting who can open the file, can copy, edit or print the file, etc. However, the protection in a secured PDF portfolio does not apply to the PDF files in it, so for the component PDFs in a PDF portfolio, if you need to add or remove protection, open the component PDFs and then add/remove protection.

Password Protection

You can add a password to a PDF to limit access and restrict certain features, such as printing, copying and editing.

There are two kinds of passwords that could be applied to a PDF file: a Document Open password and a Permissions password. When you set a Document Open password, anyone who tries to open the PDF must type in the password that you specified. When you set a Permissions password, anyone who wants to change the restrictions must type the Permissions password. Please note that if a PDF is secured with both types of passwords, it can be opened with either password, but only the Permissions password allows you to change the restrictions.

Tip:

1. There’s no way out to recover password from the PDF if you forgot it. To keep a backup copy of the PDF that isn’t password-protected is a good choice.
2. Foxit PhantomPDF allows you to input Unicode password in the password input box when you open a document protected by Unicode password.

Add a password security

1. Choose Protect > Password Protect, or click File > Properties > Security, choose Password Protection from the drop-down list.
2. In the Password Protection dialog box, do the following:

   **Document Open Settings:**

   **Require a password to open the document** – selects to require users to type the password you specify to open the document.

   **Password Input:** specifies a password that users must type to open the document.

   **Password Confirm:** type the password again to confirm the password.

   **Document Restriction Settings:**

   **Add Document Restriction** – restricts actions to PDFs, such as printing, editing, etc.

   **Password Input:** specifies a password that is required to change the permissions settings. If the file is opened in Foxit PhantomPDF, the user can view the file but must enter the permissions password to change the file's security and permissions settings.

   **Password Confirm:** type the password again to confirm the password.

   **Permission Specification:**

   The security details you specified are shown on the left. Click Permission to set the restriction settings. In the Permission Settings dialog box, check **Restrict printing and editing of the document and its security settings** and then select the options as needed.

   **Print Allowed** – specifies the level of printing which users are allowed for the PDF.

   A. Print with low resolution – allows users to print at no higher than 150-dpi resolution.
   B. Print with high resolution – allows users to print with any resolution.

   **Changes Allowed** – defines which editing actions are allowed in the document.
A. **Inserting, deleting, and rotating pages** – allows users to insert, delete, and rotate PDF pages.

B. **Filling in forms and signing existing signature fields** – allows users to fill in forms and sign documents in existing signatures fields.

C. **Commenting, filling in forms and signing existing signature fields** – allows users to add comments, fill in forms and sign documents in existing signatures fields.

D. **Any except extracting pages** – allows users to do any operation but extract pages. If you choose this option when encrypting a PDF portfolio, users are allowed to add, create, and remove files in the PDF portfolio.

**Enable copying of text, images, and other content** – allows users to copy content in PDFs.

**Enable text access for screen reader devices for the visually impaired** – allows the visually impaired users to access text with screen reader devices.

**Encrypt Settings:**

**Encryption Algorithm** - defines data transformations that cannot be easily reversed by unauthorized users. Foxit PhantomPDF supports 128-bit AES, 256-bit AES and 128-bit ARC-FOUR.

**Don’t encrypt metadata** – encrypts the contents of a PDF but still allow search engines access to the document metadata.

**Save the setting as a new policy** – save the current security settings as a policy so that you can apply it to other documents.

3. Click Ok and save the document to make setting take effect.

**Modify password and security settings**

1. Choose **Protect > Security Properties**, or choose **File > Properties**.

2. In the Security tab of the Document Properties dialog box, choose **Document Security > Password Protection**, and then click **Change Settings**...

3. Do the settings as “**Add a password security**” and then click **OK**.
Remove password and security settings

To remove password and security settings from a PDF, you must have the permissions to do so.

1. Open a PDF, and choose either way of the following to remove password and security settings.
   - Choose Protect > Remove Security.
2. A Foxit Security message box will prompt to ask whether you are sure to remove security from this document.

Certification Protection

The advantage of securing documents with certificates is that authors can specify unique permissions for each person. For example, authors can permit a person to fill in forms and comment in document, and permit another person to edit text or delete pages. You can choose certificates from files on disk, or from the Windows certificate store. Only a specific set of users whose identities can be verified and managed can have access to the document. A certificate that contains public key and other identifying information is used to encrypt documents, or verified a digital signature. Only corresponding private key decrypts the document that was encrypting using the certificate.

Generally, if possible, encrypt documents using certificates from third-party provider. If the certificate is lost or stolen, the issuing authority can replace it. If a self-signed certificate is deleted, all PDFs encrypted using the certificate is forever inaccessible.

Add a certificate security

2. In Certificate Protection dialog box, create intended recipient list for the encrypt document:
   - Click New ID to create and store your self-signed digital ID in:
     New PKCS#12 digital ID file – Stores the digital ID information to a file with the extension .pfx on Windows and .p12 on Mac OS. You can use the files
interchangeably across different operating systems.

Windows Certificate Store – Stores the digital ID to a common location. Other Windows applications can also retrieve it.

- Click Import to import certificate from Windows Certificate store.
- Click Browse to import certificate from disk.
- Click Remove to delete a recipient from recipient list.
- Click Permission to set document restriction for the selected recipient. About Permission options, please refer to “Add document restrictions” of Password security options.

3. Select Encryption Algorithm (support 128-bit AES, 256-bit AES and 128 bit ARC-FOUR.
4. Check Don’t Encrypt metadata to encrypt the documents except metadata.
5. (Optional) Check Save the settings as a new policy to save the current security settings as a policy so that you can apply it to other documents.
6. Click OK and save the document.

See also “About digital ID”

Change or remove certificate protection

To change or remove security settings, you must have permission to do so. If you want to change or remove security encrypted with certificate, you must have all access to the document, or you can’t do changes or remove security settings.

To change certificate protection, please do the following:

3. In Certificate Protection dialog box, refer to Add a certificate security.
4. Click OK and save the document to apply your changes.

To remove certificate protection, please do one of the following:

Set Security Policies

If you often apply the same security settings to multiple PDFs, you can save your settings as a policy that you can apply to other PDFs. Security policies include the security method, encryption password, permission settings, etc.

Create a security policy

2. Click New.
3. Choose security method from menu and specify the policy name and description.
4. Click Edit Details to set restriction settings or passwords.
5. Review the policy details, and then click Close.

Secure PDFs using policies

You can apply any security policy to a PDF file. To secure a PDF with a security policy that you specified, do the following:

1. Open a PDF document.
3. In the Manage Security Policies dialog box, select a policy which you want to apply to the PDF file.
4. Click Apply to this Document.
5. Save the document to apply the security policy.

Manage security policies

After you create security policies, you can manage them by copying, editing, and deleting.

2. In the Manage Security Policies dialog box, select a policy from left panel and do one or more of the following:
   • Click New to create a new policy.
   • Click Copy to copy a policy. This option is useful when you create a new policy that's based on the settings of the selected policy.
   • Click Edit Details to edit a policy.
   • Click Delete to delete a policy.
   • Click Close.
AIP Protect *(Business Edition Only)*

Foxit PhantomPDF AIP Protect feature provides seamless integration with Microsoft Windows Rights Management Services to protect PDF documents from unauthorized use and manage rights policy templates. Document authors can restrict users to open, read, modify or redistribute certain information. If you are authorized you can use Foxit PhantomPDF to open an AIP-Protected document to improve information security and meet compliance requirements.

Once installed, Foxit PhantomPDF will extend all Microsoft AIP service to all PDF files.

*Note:* If you open a PDF which is encrypted by the AIP Protect feature of PhantomPDF with other PDF programs, a wrapper (which is actually a PDF page) will prompt you to download Foxit Reader/PhantomPDF to open the PDF.

**AIP Encryption**

1. Click **Protect > Restricted Access**.

2. Choose the template to add AIP encryption. If you have more than one server, please firstly move the cursor to the name of the server, and then the templates on this server will be shown on the submenu. Click **Refresh Templates** to get the latest official templates from the server. You can also create custom templates. For more detailed information, please refer to **Template Creation**.

3. If you do not want to use the template, please click **Restricted Access**.

- Type your account name and password when you login to the AIP server for the first time.
• Click the icon to add users who you want to authorize for reading permission. To authorize anyone to read this file, select the icon on the right side.

(If you have an Outlook Email Client, the contact list of Outlook will pop up when you click the icon. You can choose the email address directly. You can also just type certain letters included in the email address, and then click icon, the system will help you enter the complete address according to the contact list. Then you can go on to the More Options step.)

• Choose the object types (users or group) and the server. Then type the e-mail addresses of the authorized users into the text box or click Advanced to open the e-mail address list on the server to choose an address directly.
• Click **OK** to exit the **Select Users or Groups** dialog box.
• Click **More Options** in the **Permission** dialog box. The users you selected now will be shown on the text box. You can also add or delete users as needed here.
Additional permissions for users:

This document expires on: check it to set the expiration date. The document cannot be opened after the specified date.

Print Content: check this option to allow the users above to print the PDF files.

Allow users with read access to copy content: enable the users who only have read permission to copy content.

Allow users with read access to comment and fill form fields: enable the users who only have Read permission to make comments and fill in form fields.

Access content programmatically: enable users to run the JavaScript in the document.

Extended Policy: complete PDF protection and control of document usage. The policy will allow document owners to control the following items.

Only allow access to these pages: specify the page number(s) that a user is allowed to access.

Only allow access by this IP range: specify an IP range that is allowed to access a document.

Number of accesses: specify the number of times that a user is allowed to access a document.

Number of prints: specify the number of times that a user is allowed to print a document.

Note: To specify the “Number of accesses” and “Number of prints” items in an on-premise environment, please refer to Web Service Configuration to configure the web service and SQL first, and then enable the extended policy with the Foxit PhantomPDF.
Chapter 10: Security

Configuration Tool.

Additional settings:

User can request additional permissions from: if users want to apply for any permission, the application will open the email client and list the email address you typed into the text in the Recipient’s Address automatically. You can type a URL as well.

Require a connection to verify a user’s permission: check this option to let users verify their license every time they open the encrypted file.

Security Watermark: add a security watermark to the PDF files. For the detailed instructions, please refer to Security Watermark.

Set Defaults: set the additional settings as default.

Save as template: the security setting set above can be saved as a template for further use.

4. If users need to request additional permissions for a PDF file, please do the following:

- At the bottom of Security tab, click Request additional permissions ....

Note: Foxit PhantomPDF also supports Microsoft IRM Specification V1, V2, and PPDF, of which Microsoft IRM Specification V2 is the default format when you encrypt PDFs with AIP. The encryption policy of Microsoft IRM Protection does not include dynamic watermark, extended policy, and dynamic revocation. To change the default Microsoft IRM format, do the following:

1. Type regedit.exe in the Run window or in the search box of the Start menu and navigate to the following path:
   \HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Foxit\PhantomPDF 9.0\RMS\Preferences.
2. Create a new REG_DWORD 32 value:
   Name: UseMicrosoftIRMV1.
3. Use the corresponding value to set the format as default as below.
   V1: 1
   V2: 2
   PPDF: 3
Template Creation and Editing

To create a custom template, please see the following steps:

1. Choose Protect > Settings > Custom Templates.

2. Click Create to open the Create Custom Rights Policy Template dialog box.

3. (Optional) If you want to edit the existed template, please click Edit.

4. Click Add to choose the language and edit template name and description. Click OK. The template name and description will be shown in the Template Identification list.

5. Click Next to add user rights. Click Add in Users and Rights.

6. In the pop-up Add User or Group dialog box, choose The e-mail addresses of users or groups, click Browse to simply add a user who you would like to assign the rights. Selecting Anyone allows every user to work with the encrypted PDF files. You can type multiple e-mail addresses as well.

7. Check PDF permissions for the specified users. You can set the permissions for all of the users or set different permissions for different users.

8. User can request additional permissions from: if users want to apply for any permission, the application will launch the email client and list the email addresses you typed into the text in the Recipient's Address automatically. You can type a URL as well.

9. Click Next to specify the expiration policy.

Content expiration

Never expires: the PDF content can be viewed indefinitely.

Expires on the following date: the PDF content will expire on a given date.

Expires after the following duration (days): the PDF content will expire after the desired days selected.

Use license expiration

Requires users to re-verify permissions with the server after the following duration (days): users need to apply for a new license to open the encrypted PDFs several days
(the number you type into) later.

10. Click **Next** to specify security watermark and the extended policy. Please refer to **Security Watermark** and **Extended Policy**. Then click **Finish** to complete creating the template.

11. Click **OK** in the **Manage Custom Rights Policy Templates** dialog box. The template will be added to the template list under **Protect > Restricted Access**.

**Batch protect PDFs with AIP**

You can apply AIP encryption to multiple PDF files at the same time with the Batch Encrypt command.

1. Click **Protect > Batch Encrypt**.
2. In the **Batch Encrypt** dialog box, click **Add Files**... to add the files or folders you want to encrypt. (*Tip: if choosing **Add Files**..., in the **Open** dialog box, you can navigate through your local disk to select local files or click **Open from ECM** to select files from OneDrive-Personal.*) Use **Move up**, **Move down**, and **Remove** to adjust the order of the added files.
3. Click **Output Options**.... In the pop-up dialog box, select the destination folder and click **OK**.
4. Click **OK** in the **Batch Encrypt** dialog box.
5. Choose a rights policy template in the pop-up dialog box and click **Start Encryption**.
6. The encryption-process bar pops up to show the progress. When encryption is complete, the selected files will be encrypted and saved in the specified destination.

**Security Watermark Management**

1. **Creating Profile**

Before adding a watermark, you should create a profile first. The application will apply all of the watermarks in the profile to a PDF.

*Note: you can only choose a profile but not a certain watermark to use. Please create the watermarks you want to add to one PDF in the same profile.*

- Choose **Protect > Settings > Security Watermark**.
- Click **New Profile** to create a profile and name it.

2. **Add Watermark**

To add a new watermark, please do the followings:
Open the Security Watermark Management and select a profile you created and click **Add** to add watermarks in the profile.

- Type the watermark's name.
- Fill in the watermark's content in the text box and set the font, size, color, underline, and alignment.
  
  **Note:** you can only set text as watermark.
  
- Choose the Dynamic Text. When any PDF reader opens the file, the watermark will show the current document information dynamically and you can use multiple text at the same time.

  **Content ID:** shows the content ID of the current document.
  **Document Title:** shows the current document title.
  **Author:** shows the author of current document.
  **Current User:** shows the current user who is reading the document.
  **Date:** shows the current system date when opening the document.
  **Day:** shows the current system day when opening the document.
  **Month:** shows the current system month when opening the document.
  **Year:** shows the current system year when opening the document.
  **Time:** shows the current system time when opening the document.
  **Hour:** shows the current system hours when opening the document.
  **Minute:** shows the current system minutes when opening the document.
  **Second:** shows the current system seconds when opening the document.

- Set the appearance by choosing the rotation degree and the opacity. You also have the option to make the scale relative to the target page.
- Set the vertical and horizontal distance between the target page and the watermark.
- Choose the page range to apply the watermark. You can select the different page range options by selecting from the subset list.
- Preview the watermark in the right pane.
- Click **OK** to finish.

### 3. Edit or Delete Watermark

#### Edit a Watermark

- Open the Security Watermark Management and select a watermark you want to edit.
- Click **Edit** to open the Edit Security Watermark dialog box.
- To edit the watermark, please refer to “Add Watermark”.
- Click **OK** to finish the operation.

#### Delete a Watermark

- Open the Security Watermark Management and select a watermark you want to
delete.

- Click **Delete** to remove the selected watermark.

### 4. Import or Export Watermark

**Import a Watermark**

- Open the Security Watermark Management and click **Import**.
- Choose a watermark with .xml format.
- Click **Open**.

**Export a Watermark**

- Open the Security Watermark Management and select a watermark you want to export.
- Click **Export** and choose a file type and location to save.
- The watermark will be exported as an .xml file or encoded file according to your choice. It can be integrated into AIP policy template and applied to the PDF files by Foxit PhantomPDF.

**Note:**

1. If you want to integrate the watermark to a common policy template, please export it as an .xml file and add it to the template by PhantomPDF directly.

2. If you want to integrate the watermark to an official policy template, please export it as an encoded file (.txt format) and integrate it into the template by AIP Scripting API Architecture. Then you can import the template and apply it to PDFs by PhantomPDF. (Please click [here](#) to see the example and use the value of “appData.Name” and “appData.Value” in the exported encoded file.)

### Foxit Configuration Tool

Foxit PhantomPDF AIP Protect feature provides a handy configuration tool for administrators to better modify the protection settings on an AIP server. Administrators can directly enable/disable each tool, edit the extended policy of official templates, dynamically revoke permissions, audit logs, set valid network printers, and customize wrapper files.

To start to use the configuration tool to encrypt PDFs, please do the following:

- Log on to your AIP server.
- Download the Foxit Configuration Tool from:

  For X86:  
  [http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool](http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool)
Unzip and Run Foxit Configuration Tool, you can use the different tools in Foxit Configuration Tool window. **Note:** Before getting started, you need to configure the VBScript in the unzipped folder by inputting your specific localhost address and port number in the script. The default port number in the script is 80, such as `admin_role = config_manager.Initialize(true,"localhost",80,"","",""`). You need to change the port number to the one your server currently uses.

### Foxit Configuration Tool Window

#### Template Extended Policy

Through the **Foxit Configuration Tool**, administrators can easily edit the extended policy of official templates. Click **Template Extended Policy** tool and choose one template to edit. See also **Extended Policy**.

*Tip:* Click the Back button in the left corner to return to the Foxit Configuration Tool.
Dynamic Revocation

Revocation is a mechanism that revokes a PDF document that has already been issued. A common use of revocation is to remove rights from an individual when he is no longer authorized or remove access to a document when it becomes out of date or invalid.

**Note:** To revoke a PDF document/user in an on-premise environment, please refer to [Web Service Configuration](#) to configure the web service and SQL first. Then choose the Revocation tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

To revoke a PDF document, click **Document Revocation**. Select the PDF document you want to revoke, click **Add** button to add the document to the Revocation List. Or you can click **Browse** to select a document from a local drive to add to the Revocation List. To remove the revocation, please select the document in the Revocation List and click **Remove** button.

To revoke a user, click **User Revocation**. Click **Add** button to add a user to the User Revocation List. To remove the revocation, please select the user in the list and click **Remove** button.

**Extended Policy**

Foxit Configuration Tool provides you with Extended Policy to add complete PDF protection and control to your PDF documents. The policy allows documents owners to control the number of access and the number of prints in an on-premise environment. Before you specify the two permissions, please refer to [Web Service Configuration](#) to configure the web service and SQL first, and then choose the Extended Policy tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

**Auditing Logs**

Foxit PhantomPDF enables you to track on the usage of AIP protected files to record the actions on the files during workflow, including who accessed the document,
what document was accessed, when it was accessed, how it was accessed and the success of that access, and more.

To audit logs, please refer to Web Service Configuration to configure the web service and SQL first, and then choose the Audit Log tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

Choose one log and click on the Export button to export to Foxit Reader’s registry or Foxit PhantomPDF’s to generate a .reg file for the administrator’s configuration. The administrator can distribute the .reg file to client-end computers.

Restrict Local Printing

You can also set the printing permissions by specifying certain network printers to protect the sensitive information from being printed arbitrarily.

✧ Network Printers Configuration

To avoid unauthorized printing of sensitive documents, you can limit the printing permissions to certain network printers. To configure network printers, please refer to Web Service Configuration to configure the web service and SQL first, and then click the Valid Network Printer Setting tool in the “Foxit Configuration Tool” window and click the button to enable this tool.

1. You should get the Printer Port first. Please go to Start > Devices and Printers > right-click a network printer > Printer Properties. In the printer properties dialog box, choose Ports tab and get the information, e.g. the “IP_192.168.3.239” is the printer port.
2. Click **Add** button in the “Foxit Configuration Tool” dialog box to add the Printer Port. You can also remove a printer port by choosing it and clicking **Remove**.

**Note:** About how to add a network printer, please see “Add a Network Printer”.

✧ **Add a Network Printer**

There are two devices to add a network printer as below:

- Go to **Start** > **Devices and Printers** > Click **Add a printer**. In the **Add Printer** dialog box, click **The printer that I want isn’t listed** to go to the next step.

Follow the instructions shown in the **Add Printer** dialog box as below and complete adding a printer.
• Open the Run box by pressing shortcut keys Win + R, enter the printer URL you want to add and click OK.
• In the pop-up dialog box, right-click the printer and choose Connect on the context menu.

Edit Wrapper Content

If you open a PDF which is encrypted by Foxit with other PDF viewers, a wrapper (which is a PDF page) appears with a prompt that you need to download Foxit Reader/PhantomPDF to open the encrypted PDF. With Foxit Configuration Tool, you can customize the wrapper by selecting a desired PDF file.

To apply a custom wrapper, please refer to Web Service Configuration to configure the web service and SQL first. Then choose the Edit Wrapper Content tool in the Foxit Configuration Tool window, enable the tool by clicking the button , and select a desired PDF file.
AIP Settings

You can specify the AIP settings before you encrypt PDFs. To specify AIP settings, please navigate to File > Preferences > RMS Settings.

Classify and protect PDFs with sensibility labels in AIP

With Foxit PhantomPDF, you can classify and protect documents with sensitivity labels configured by the administrator in your organization.

1. Open your PDF with Foxit PhantomPDF.
2. Click Protect > Sensibility. (Sign in with your AIP account if you haven't by clicking Connect to Microsoft Azure Information Protection to get the list of configured sensibility labels.)
3. Select a label from the list to apply to the document.
4. When the labelling process is complete, the document is saved automatically.

Remove hidden data

Foxit PhantomPDF supports the removal of hidden information that is private or sensitive for users from their PDFs, generally including metadata, embedded content,
attached files, and scripts.

In the **Protect** tab, there are two commands you can use to remove hidden information: **Sanitize Document** and **Remove Hidden Information**. To remove all hidden information from a PDF file in one go, use **Sanitize Document**. To select and remove the hidden information you want to remove, choose **Remove Hidden Information**.

### Redaction (Business Edition Only)

The redaction feature allows you to remove sensitive information from your document prior to making it available to others. You are able to mark the text, graphics, text and graphics, or pages for Redaction first, and then apply the redaction. Alternatively, you can use the **Whiteout** feature to remove the content permanently and replace it with white background with one click.

#### Mark for Redaction

To mark text or graphics for redaction, select **Protect > Mark for Redaction > Text & Images**, and the Hand command changes into a Cross automatically. Then do any the following to mark the content:

- Drag a rectangle where you want to add redaction. This method allows you to select and mark both text and images at the same time.
- Double-click an image to mark an entire image.
- Hover the pointer over the text. When the pointer changes into an underline, click and drag to select the text you want to redact.
- If you need to add redaction to the same position on multiple pages, please right-click the marked content and choose **Place on Multiple Pages**.

To mark pages for redaction, select **Protect > Mark for Redaction > Pages**, and choose the page range you want to add redaction to. In the **Extract** drop-down list you can choose even or odd pages from the page range to add redaction to.

The marked content or page will be filled with black color in a red rectangle once moving close the pointer to the selected area. You can move and resize the rectangle before you apply the redaction. *(Note: You can't move or resize the rectangle around the text selected with the pointer.)*
Set Redaction Properties

You can set redaction properties, such as the appearance and the author, and so forth. Only before you apply the redaction can you set the properties.

Right-click the marked area and choose **Properties...** and the Redaction Properties dialog box pops up. The redaction properties have Appearance tab, General tab and Review History tab. There are two additional settings on every tab:

- **Locked** – When selected, prevents any further changes to any redaction properties.
- **Set Current Properties as Default** – sets the current properties as default.

**Appearance** tab:

- Redacted Area Fill Color – select a fill color for the boxes that will replace the redacted items.
- Use Overlay Text – check this item if you need to display some text or code on the redacted area. You can set the font, font size, font color and text alignment.
- Custom Text – check this option and input the text you want to display in the redacted area.
- Redaction Code – check this option to select code entries from corresponding code sets.
- Add Selected Entry – After selecting a code entry, click this option to add the code entry to the box next to the Redaction Code option. When you select a code entry that has been added to the box, the option changes to Remove Selected Entry to allow you to remove the added code entry from the box. (Tip: You can also add/remove code entries by selecting or unselecting items from the context menu of the marked area.) The names of the code entries you added will appear in the marked area when you put your cursor on the area.
- Edit Codes – click it if you need to add, rename, remove, or import/export redaction codes and code sets.

**General** tab:

- You can change the author and subject of the redaction.

**Review History** tab:
You can see the history of changes which have been made to the status of a redaction before applying the redaction.

**Apply Redactions**

You need to apply the redactions after marking the text, graphics, or pages you want to redact. To apply the redaction, do the following:

- Select **Protect > Apply Redactions**. You can also do this by right-clicking the marked content and choosing **Apply** or **Apply All** to redact either the selected content or all of the marked content in the document.
- A dialog box pops up to give a warning message and asks if you are sure to apply the redaction or not.
- Select **OK** after you have marked all content that you want to redact.

When you save the document after applying redaction, you can save the redacted file automatically as a new file with the preconfigured filename. To configure the filename, please select **Adjust filename when saving applied redaction marks** and input text in the **Prefix** and **Suffix** boxes in **File > Preferences > Documents > Redaction**.

**Search and Remove Text**

You can find and remove content either in a single PDF file or in multiple PDF files under a specified folder that contain searchable text with the Search & Redact command.

- Select **Protect > Search and Redact**. Then specify what you want to redact in the Search pane. (For more about the search feature, please refer to “advanced search”.) Please do one of the following:
  - To search and redact an exact word or phrase, select **Match exact word or phrase**. Then type the text you wish to find and redact into the search dialogue box.
  - You can search and redact multiple words or phrases at the same time. Select **Multiple words or phrase**, and click **Select Words**... In the pop-up dialog box, enter the word or phrase you want to search and redact, and click **Add**. Repeat until you add all the words/phrases you want to search for. Or you can click **Import** to import a text file with the list of words or phrases to search for. For the words you have added, click **Export** to export them to a text file.
  - To search and redact a predefined redaction profile, select **Redaction Profiles** and then select an existing redaction profile you want to use. See also **Create and manage redaction profiles**.
  - To search and redact patterns (such as phone numbers and credit card
numbers), select **Looks like search pattern**. Then select the pattern you want to search from the **Select your pattern** drop-down list, and choose the specific country or region from the **Country/Region** drop-down list.

- Click **Search**.
- Check the results you want to redact.
- Click the button **Mark Checked Results for Redaction** at the bottom of the search dialogue box.
- Choose **Protect > Apply Redactions**. Or click the button **Apply Redactions**.

**Note:** *This operation cannot be undone and the selected content will be removed permanently when you select Apply. It is recommended that you save a backup copy of this document before you apply the redaction.*

**Create and manage redaction profiles**

A redaction profile specifies the text to be redacted, the new text that you want to overlay the redacted text with, and the search criteria. When you need to search and redact content in documents that require the same protection, using a redaction profile can improve the productivity in your document workflow.

To create a redaction profile, do as the following:

1. Select **Protect > Search and Redact**, and the **Search** panel opens.
2. From the search criteria drop-down list, choose **Redaction Profiles**.
3. Click **Create**.
4. In the pop-up dialog box, input a name for the profile to be created.
5. In the **New word or phrase** box, type the text you want to redact. In the **Overlay text** box, type the text that will be displayed on the redacted text. Then click **Add**. Repeat as needed. The redacted text and the Overlay text you add will be listed as groups in the **Word/Phrase and overlay text list** box. To remove a group, select it and click **Remove**.
6. (Optional) Select any of the following options to specify the search criteria as needed.
   a) To limit the search to match only whole words, check **Whole Words Only**. For example, if you search for the word *Read*, the word *Reader* will not be found. This criterion is only available for text search.
   b) To make the search case-sensitive, check **Case-Sensitive**. For example, if you search for the word *text*, the words *Text* and *TEXT* will not be found. This criterion is only available for text search.
   c) To highlight all the text search results, please check **Highlight All Text**.
   d) To make the size of the Overlay text fit the redacted area, select **Always Auto-Size text to fit redaction region**. For example, if the Overlay text is too long,
the part that exceeds the redacted area will not be displayed. With this option selected, the text size will automatically shrink and all of the Overlay text will be displayed on the redacted area.

7. Click **Save & Search** to save the profile and search the document immediately, after which you can select the found instances and apply redaction. Or just click **Save** to save the profile.

To manage existing redaction profiles, do as the following:

1. Select **Protect > Search and Redact**, and the **Search** panel opens.
2. From the search criteria drop-down list, choose **Redaction Profiles**.
3. Click **Manage**.
4. In the pop-up dialog box, select a profile and do any of the following:
   - Choose **Edit** to modify the selected profile. For details, please refer to **Create a redaction profile**.
   - Choose **Delete** to remove the selected profile.
   - Choose **Import** to import a redaction profile.
   - Choose **Export** to export the selected profile.

**Generate Redacted and AIP-protected PDFs (Business Edition Only)**

Foxit PhantomPDF enables users to generate a redacted and AIP-protected PDF from an existing PDF. Authorized users are granted access to view the full document while unauthorized users are only able to view the redacted document, which allows for improved knowledge sharing of non-sensitive information within a protected document.

To generate a redacted and AIP-protected PDF, please do the following:

- Mark the content for redaction. See also **Mark for Redaction**.
- Click **Protect > Protect Redactions**, log on your AIP server and then choose an AIP template to encrypt the document.
- Then the document with redaction protected by the AIP template is generated and opened with a message box appearing in the document area. Click **View the full content** to view the full content without redaction. This message box appears only when the document is opened by the document owner.
- After clicking **View the full content**, two messages appear in the message box. Click **Redacted Mode** to exit the full content mode and return to the
document with redaction. Click **View Permission** to view the security properties of the document.

- When the authorized users open this protected document, only the message to view permissions appears in the message box.

**Whiteout**

Foxit PhantomPDF provides the Whiteout feature to enable you to apply redaction with one-click, improving your productivity in the document workflow. You can use the feature to simply and securely erase any content to white background from your PDF file with one click like an eraser, leaving no trace behind of the previous content.

To remove content from your PDF with the **Whiteout** command, do as the following:

1. Choose **Protect > Whiteout**. The cursor changes into a cross \( \Box \).
2. Click and drag a rectangle around the content you want to remove.
3. (Optional) If you put the cursor over text, it changes into \( \overline{I} \) and allows you to select the text you want to remove. Or you can double-click an image to remove the entire image.
4. Click **OK** in the prompt warning you the “Whiteout” cannot be undone. You can click **Don’t ask again** in the prompt so that you won’t be bothered the next time you use the feature. Then you can see the selected content is removed and replaced with the white background.

*Note*: *Like redaction, the whiteout operation is permanent and cannot be reversed.*

**Windows Information Protection (WIP)**

Windows Information Protection (WIP), a feature that enterprises use to protect enterprise data by encrypting it and separating it from personal (or employees') data, provides a way to manage data policy enforcement for enterprise apps and documents. For enterprises that are using WIP policies can include Foxit PhantomPDF and network locations in their policy restriction on PDF documents, which helps to protect enterprise data against potential data leak on enterprise owned-devices and personal devices that employees bring to work.

*Note*: *To run WIP in your system, Windows 10 (version rs2 and later) is required.*

Administrators in enterprises often use Microsoft Intune or MobileIron to define and
deploy WIP policies. Here, we'll use a MobileIron example to explain how to add Foxit PhantomPDF and the network locations to your WIP policies.

2. Go to Configuration > Add to create a WIP configuration (or a WIP policy).
3. (Optionally) You can choose an existing WIP configuration to add PhantomPDF and the network locations where PhantomPDF can access enterprise data.
4. In the left part of the webpage, click on the Windows icon in the OS option. Then select the Windows Information Protection configuration from configuration types in the right part of the webpage.

5. Enter a name and a description for the configuration.
6. In the **Configuration Setup** section, specify the settings as appropriate (For the details, please refer to [MobileIron’s help on WIP](#)). You can add the network locations and Foxit PhantomPDF to the WIP configuration in **Cloud Resources** and **App Control** respectively.

7. Click **Next**.

8. Select a distribution for this configuration.

**Note:** For **Cloud Resources**, add the Enterprise resource domains hosted in the cloud where PhantomPDF can access the enterprise data. You can choose one or multiple network locations to be protected with your WIP policies from the following URLs as needed. If you have multiple resources, separate them using the semicolon.

- **NdOffice**: www.netdocuments.com
- **eDOCS DM**: www.opentext.com
- **iManage Work**: www.imanage.com
- **OneDrive for Personal**: onedrive.live.com
- **OneDrive for Business**: office.live.com
- **Dropbox**: www.dropbox.com
- **Box**: www.box.com
- **Google Drive**: drive.google.com

*(Note: For SharePoint network, you can enter your custom URL.)*
FIPS mode

Foxit PhantomPDF provides a FIPS mode to make data protection compliant with Federal Information Processing Standard (FIPS). FIPS mode uses FIPS 140-2 approved algorithms to establish requirements for various purposes including the cryptographic modules of software and hardware.

The system administrator can configure FIPS mode in the Windows registry by the following steps (Take Foxit PhantomPDF 9.0 for example):

1. Open the Registry Editor and navigate to the registry: HKEY_CURRENT_USER\SOFTWARE\Foxit Software\Foxit PhantomPDF 9.0
2. Right-click Foxit PhantomPDF 9.0, and choose New > DWORD (32-bit) Value.
3. Name the new value “bFIPSMode” and set the value data to 1.

In FIPS mode, the following security options are not available:

- Applying password-based security policies to documents, AIP encryption and ConnectedPDF protection. You can use public key certificates to secure the document.
- Creating self-signed certificates. To create a self-signed digital ID, it must be saved to the Windows certificate store. You cannot create a self-signed digital ID that is saved to a file.
- RC4 encryption. A PDF file can only be encrypted using the AES encryption algorithm when in FIPS mode.
- MD5 or RIPEMD160 digest methods. In FIPS mode, only the SHA-1 and SHA-2 families of digest algorithms can be used when you create a digital signature.

**Note:** In FIPS mode, you can open and view documents that are protected with algorithms that are not FIPS compliant. However, you can't save any changes to the document protected with password, AIP and ConnectedPDF Protection.

Trust settings

You can customize trust settings for PhantomPDF, which is helpful to make your PDF workflow both secure and efficient. To specify the settings, click **File > Preferences > Trust Manager**.
Safe Reading Mode

Safe Reading Mode enables you to control unauthorized actions and data transmissions that efficiently avoid attacks from malicious content and viruses.

Activate Safe Reading Mode

To activate Safe Reading Mode, do the followings:

- Select **File > Preferences > Trust Manager**, and check **Enable Safe Reading Mode** option.
- Click **OK**.

Bypass Security Restrictions in Safe Reading Mode

If you are in Safe Reading Mode, a warning dialog box will appear when a PDF tries to complete a restricted action from an untrusted location or file. However, you may need to execute certain actions under the current restricted security settings. In this case, you can select trusted files, folders, and hosts and exempt them from security restrictions. This security feature ensures that Foxit PhantomPDF operates under security level conditions that meet your working environment.

To specify the trusted files, folders, or hosts, please follow the steps below:

a) Go to **File > Preferences > Security**.
b) Click **Add File** to add trusted files to the privileged locations. Foxit PhantomPDF currently allows you to add the following files: PDF Files (.pdf), Form Data Files (.fdf), XFDF Files (.xfdf), XDP Files (.xdp), and PPDF Files (.ppdf).
c) Click **Add Folder Path** to add a trusted folder of multiple files.
d) Click **Add Host** to add the root URL to trust the files and actions from the trusted host. You can also check the **Secure connections only (https:)** to trust files and actions from secure connections only.
e) (If needed) Click **Remove** to remove trusted items from privileged locations.
f) Click **OK** to confirm and apply the settings.

On-line whitelist management

Foxit PhantomPDF allows users to add trusted URLs to better manage file access.

To set on-line whitelist, please follow the steps below:

Choose **File > Preferences > Trust Manager > click Change Settings in the Internet**
Access from PDF Files outside the web browser group, then Manage Sites dialog box will pop up as shown below:

- Allow PDF files to access all web sites: Select it to allow access to all web sites.
- Block PDF file access to all web sites: Select it to restrict access to all web sites.
- Custom setting: You can customize the trusted URLs to restrict access to only the URLs you customize.

  - Select Custom setting.
  - Input the host name of a website under the Host name field.
  - Click Allow and then click OK.

The URLs that you trusted will be added in the Web Sites List. If you want to delete the trusted URL, please select it and click Delete. For the URLs not included in the Web Sites List, you can check one of the following options to set the default behavior when connecting to the web sites.

- Always ask: When you try to access websites not listed as trusted, Foxit PhantomPDF will always prompt you with a pop up window saying: “If you trust
Application Whitelist Management

By default, Foxit PhantomPDF will show a warning message when an application without a valid digital signature attempts to open it. However, if you trust the application, you can add it to the whitelist. Steps are as follow:

- Choose File > Preferences > Trust Manager.
- Click Change Settings in the Open Foxit PhantomPDF from applications without valid digital signatures group.
- In the Allowed Apps field, specify the application you trusted, and click Allow. The trusted applications will be listed in Apps group. If you want to remove it from the list, please select it first, and then click Delete.
- Click OK to confirm and apply the setting.

Run Script Right Control

Foxit PhantomPDF allows users the rights to run script accordingly, and at the same time making sure the software executes and secures PDF files. There are four levels for users to choose: Disable JavaScript, Enable secured JavaScript, Enable JavaScript secured and verified by DRM, and Enable all JavaScript.

To set the run script rights, please follow the steps below:

Choose File > Preferences > Trust Manager, and then set the rights as required:

- To enable all JavaScript: Check Enable JavaScript Actions and uncheck Enable Safe Reading Mode.
- To disable all JavaScript: Uncheck Enable JavaScript Actions and check Enable Safe Reading Mode.
- To enable secured JavaScript: Check Enable JavaScript Actions and Enable Safe Reading Mode.
- To enable JavaScript verified by DRM:
  - Check Enable JavaScript Actions and Disable Safe Reading Mode for Trusted Documents.
  - Click Advanced Preferences below to check both RMS Encryption and Digital Signature Verification.
Automatic Foxit Approved Trust List updates

The certificates in Foxit Approved Trust List (FATL) are the trusted root certificates that are stored in a Foxit server and have been verified by Foxit and other authorities. You can enable the application to automatically check and download new or updated root certificates in FATL from the server to local trusted certificate list. Any certificate-based signature created with the certificate in FATL is trusted when the signed document is opened in Foxit PhantomPDF 9.6 and later.

To enable the automatic updates from FATL, do the following:

1. Click **File > Preferences > Trust Manager**.
2. In the **Automatic Foxit Approved Trust List updates** group, select **Load trusted certificates from Foxit server**. This option is selected by default and allows PhantomPDF to automatically download new or updated root certificates in FATL from the server to the local trusted certificate list under any of the following circumstances:
   - Every 28 days.
   - When you open a signed PDF and the signature's certificate has never been checked for update before.
   - When you open a signed PDF and the signature's certificate was checked for update more than 28 days ago.
3. Do the following as needed:
   - Ask before updating: Select it and you will be prompted if any new or updated root certificate is available for download and install.
   - Update now: Click it to download and install from the latest FATL immediately.
4. When the installing process completes, a message box will pop up to tell you the update is successful.

**Note:** A connection to the Internet is required for the update.
Chapter 11 – ConnectedPDF

Foxit ConnectedPDF allows each PDF to carry an identity assigned by the ConnectedPDF cloud service, and tracks all the events on the PDF like creation, distribution, and modification. So no matter where the ConnectedPDF document goes, how many distributions and modifications done to it, the document owner can always track the document in real time and collaborate with the document viewers involved. Therefore, ConnectedPDF connects files, people, location, and systems together while ordinary PDF is separate and static.

The Connect tab in Foxit PhantomPDF toolbar provides powerful and easy-to-use tools to create, protect, and track the access to Connected PDFs. You can also start and join a shared review on Connected PDFs based on cloud storage anytime anywhere. The detailed features include:

- Convert PDF to ConnectedPDF
- Convert other formats to ConnectedPDF when creating to PDF
- Configure open messages which appear when other users open a ConnectedPDF document (Business only)
- Clone a document (Business only)
- Enable document enforced tracking (Business only)
- Track any access to ConnectedPDF documents
- Show usage data in document homepage
- Register and upload a new version of ConnectedPDF document
- Send update notification when registering a new version (Business only)
- Online ConnectedPDF protection (Business only)
- Permission configuration
- Dynamically approve and revoke document permission
- Dynamically request document permission and response to the changes of document permission
- Connected shared review without having to set up a shared folder
- Document locator and request

For more information about ConnectedPDF, please refer to ConnectedPDF User Manual.
Chapter 12 – Signature

Foxit PhantomPDF provides robust, secure and quick signature features, including digital signature, DocuSign and quick PDF Sign.

Digital Signature

A digital signature acts as a traditional handwritten signature that can be used to authenticate the identity of a user as well as the document content. It stores information about the signer along with the date, time, and state of the document when it was signed.

About Digital ID

Digital ID is the identity of a person/organization, which contains your name, Email address, a serial number, an expiration date, and the name of the company. A digital ID contains two keys, one is a public key (certificate) that is used to encrypt or lock data, and the other is a private key that is used to decrypt or unlock data that is encrypted.

You can distribute the certificate that contains the public key and other identifying information to those people who need to use it to verify your identity, validate your signature, or encrypt a document for you. Only your private key can unlock information that was encrypted using your certificate, so make sure to store your digital ID in a safe place.

You can not only obtain a digital ID from a trusted third-party provider called a Certificate Authority (CA) but also create a self-signed digital ID with Foxit PhantomPDF. Digital IDs are usually protected by password; you can store it on a computer in PKCS#12 file format, or in the Windows Certificate Store. All the digital IDs available on the computer are listed in the Digital IDs window. You can choose Protect > Digital IDs to check the digital IDs list. In the Digital IDs window, you can also view the certificate details, refresh the ID list, add or remove a digital ID, and export a digital ID to an FDF, PKCS, or CER file.

For company-wide deployment, IT managers can also use the SignITMgr tool to configure which digital ID file is allowed to sign PDF files by users across an organization. Steps are as follow:

1. Create or install the digital ID file on your computer.
2. Click [here](#) to download SignITMgr tool, and open it.

3. You will find that the digital IDs you installed in your computer are listed in the SignITMgr window. In the window, do the following:
   - Check the digital ID file that is allowed to sign a PDF file, click **Generate Configure File**, and save the file.
   - If you want to change the setting which you have configured before, click **Load Configure File** to open the configuration file. Then check the digital ID file that is allowed to sign a PDF file, and click **Generate Configure File** to generate and save the modified configuration file.

4. After generating the configuration file, place it in “C:\Users\USERNAME\AppData\Roaming\Foxit Software\Foxit PhantomPDF\Signature”.

When IT manager has configured it completely, users can only use the specified digital ID(s) to sign PDF files, and will not be allowed to create a new ID.

*Tip: The “Signature” folder is automatically created the first time users sign a PDF file with a digital ID. If it is not found in the specified folder, please create it manually.*

**Sign a PDF**

**Place a signature**

Before you sign a document, you need to draw a signature field where the signature is placed, get a digital ID, and create the signature.

1. Choose **Protect > Sign & Certify > Place Signature**.
2. Press and hold the mouse button down, and drag to draw a signature field for your signature.
3. In Sign Document dialog box, choose a digital ID from drop-down menu. If you can't find the specified digital ID, you will need to get a certificate from the third-party provider or create a self-signed digital ID.
4. (Optional)To create a self-designed digital ID, choose **New ID** from drop-down menu. In the **Add Digital ID** dialog box, select a location to store the digital ID. Click Next to type your identity information such as name, organization unit, e-mail address, etc. to be used when generating the self-signed certificate. In **Use Digital ID for**, choose one option as needed. Click **Next** to enter a file name, storage location and password for your new digital ID file. Confirm your password and click **Finish**. The **New ID** option will not be available if the IT manager has configured and restricted digital IDs to sign PDF files across the company.
5. Input the text or select an option from the drop-down list to specify your location and reason to sign the document in the **Text For Signing** group. Please note that
Location and Reason fields are available only when the signature is defined to include the corresponding option in its appearance type. For the Reason field, Foxit PhantomPDF will save your custom reasons for you to choose from the drop-down list easily in future uses.

6. Choose an appearance type from menu. There are two types to choose, one is Standard Style, and the other is to Create New Style for your signature. Please refer to Creating signature appearance. You can view your signature in Signature Preview panel.

7. Do any of the following to sign PDF files:

- To sign the currently opened PDF file, click Sign, and then specify the location and file name to save the signed document.
- To sign multiple PDF files, click Apply to Multiple File. In the pop-up Sign Multiple Documents dialog box, do the following:
  - Click Add files, and choose Add Files, Add Folder, or Add Open Files to add files, folders or opened files that you want to sign with the same digital signature.
  - By default, the document will be signed in a sequence as they are ordered in the Sign Multiple Documents dialog box. You can adjust the order of files by its name, modified time, or size by clicking the corresponding column name. Alternatively, drag and drop the file in the list to adjust its order. Select a file and click the Remove button to delete it, if necessary.
  - Click Output Options to specify the output folder and file name for the signed PDF document.
  - Click Sign Immediately. And then Foxit PhantomPDF will sign your PDF documents with the same digital signature at the same location as your current document, and saved the signed documents in the folder you specified.

Note: By default, the document is signed after you place the signature and then you will not be able to move or resize it. To change the setting, please uncheck the Sign the document immediately after the signature is placed option in File > Preferences > Signature.

Move, resize and delete an unsigned signature

You can move, resize and delete signatures before signing the document, but you aren’t allowed to change certificate and appearance of certificate.

1. To move a signature
Select the Select Annotation command or the corresponding tool, put the pointer over the signature, click and drag the signature to another place you like.

2. To resize a signature

Select the Select Annotation command or the corresponding Tool, click the signature. Place the cursor on any corner point. Pointer changes into the cursor showing the direction at which the rectangle will be resized.

3. To delete a signature

- Select the Select Annotation command .
- Right-click the signature and choose Delete from context menu, or press Delete key.

Note: If you have checked the Locked option in Signature Properties dialog box, the operations to the signature above are not available.

Create signature appearance

You can set the appearance of your digital signature by selecting different options in Sign Document dialog box. For example, a signature can include an image of your handwritten signature, a company logo, or a photo, date and so on. Furthermore, you can create dynamic signature appearance to user for different purpose. A signature appearance also includes information that helps others verify your signature, such as reason for signing, contact information, and more.

Different appearances of signatures

- Choose Protect > Sign & Certify > Place Signature.
• Press and hold the mouse button down, and drag to draw a signature field for your signature.

• In Sign Document dialog box, choose Create New Style from Appearance Type menu.

• You can configure the graphic for your signature by drawing, setting a name, or importing a file. Check the options that you want to appear in digital signature. A signature appearance can include lots of information showing the users attributes, including name, organization, country, logo, location, etc. You can click Setting to specify the font and font size if necessary. Click OK to save the settings.

• (Optional) After placing the signature, right-click it and choose Properties... to set the properties of the signature field. In the Signature Properties dialog box, you can set the appearance, actions, etc. See also Signature Field Properties. (Note: This operation is not available after signing the document.)

Note: To manage the created styles, go to File > Preferences > Signature.

Sign Documents

A PDF is signed to indicate your approval. The signature is flattened, so it cannot be resized and moved after signing the document. Multiple people can sign a PDF more than once. When you sign a document, your digital signature appears in the signature field. The appearance of the signature depends on your preferences.

1. Sign a PDF after placing, please choose one of the followings to sign the document:

   • Choose Protect > Sign Document.
   • Select the Hand command and right-click the signature, choose Sign Document.
   • Select the Hand command, and click the signature.
   • Set your signature preferences in Preferences dialog box. Choose File > Preferences > Signature, check the option of “Sign the document immediately after the signature is placed” to sign the document immediately when the signature is placed.

2. Type file name and specify location in pop-up Save As dialog box.

Note: By default, the document is signed after you place the signature. To change the setting, please uncheck the Sign the document immediately after signature is placed option in File > Preferences > Signature.
Modify a signed signature

To modify a signature after signing the document:

- Validate the signature first. And right-click the signature with the Hand command and choose **Clear Signature**. The signature will be cleared and only a blank signature field will be left.
- Click the blank signature field with the Hand command, and create a new signature. See also “Creating signature appearance”.

To delete a signed signature:

- Validate the signature first. And right-click the signature with the Hand command and choose **Clear Signature**. The signature will be cleared and only a blank signature field will be left.
- Choose the Select Annotation command or the corresponding tool, right-click the signature field and choose **Delete**.

Validate Signatures

Signature validity is determined by checking the authenticity of the signature's digital ID certificate status and document integrity. Depending on how you have configured your application, validation may occur automatically.

Set Signature Verification Preference

By default, Foxit PhantomPDF will verify signatures when the document is opened, and will check the certificate revocation status while verifying signatures. If you want to change the setting, please go to **File > Preferences > Signature**, and uncheck the corresponding option in **Signing & Verifications** group. For more information, please refer to “Signature Preference”.

Set the Trust Level of a Certificate

The signature of a certified or signed document is valid if you and the signer have a trust relationship. The trust level of the certificate indicates the actions for which you trust the signer.

To set the trust level:
• Choose File > Preferences > Signature.
• Check the option(s) in Windows Integration group to trust all root certificates in the Windows Certificate Store when validating signatures and certified documents.

Tip: You can specify the trust level for a specific certificate in Foxit PhantomPDF Trusted Certificates list while adding and managing the trusted certificate. Please refer to Add Trusted Certificates and Manage Trusted Certificates for more information. If you configure different settings for the same certificate, settings with higher permissions will prevail. Remember that checking trust options may compromise security. Please make sure that you trust all the root certificates before enabling the features.

Check the validity of a signature

By default, Foxit PhantomPDF verifies signatures when the document is opened. An icon appears on the left top of Signature Validation Status message box to indicate the signature status. The signature state appears in the Signature Panel.

• The question mark icon ? indicates the signature is not validated.
• The check mark icon ✓ indicates that the signature is valid.
• The icon ✗ indicates that the signature is invalid. The document has been altered or corrupted since the signature was applied.
• The caution triangle icon ⚠ indicates the document was modified after signature was added; however, the signature is valid.
• The icon 🏷 indicates the signature validity is unknown because the signer's certificate isn't in your list of trusted identities.

If you open a certified PDF file with notification-related message enabled, Foxit PhantomPDF will display a notification message informing you that the document is certified. You can click Signature Panel on the notification message to check the details about the document certification and signatures in the Digital Signatures panel.

Check certificate revocation status

By default, Foxit PhantomPDF will check the certificate revocation status while validating a signature if the certificate used to sign a PDF file chains up to a certificate
designated as a trusted anchor. Revocation checks are performed based on the revocation information embedded in the digitally signed PDF document, the digital signature, or the Certificate Revocation List (CRL). To view the certificate revocation information, please do the following:

1. Do one of the following:
   - Choose **Protect > Trusted Certificates**, and double-click the certificate.
   - In the **Digital Signatures** panel, right-click the signature, choose **Show Signature Properties**, and then click **Show Certificate**.
2. In the **Certificate Viewer** dialog box, click **Revocation** tab to view the revocation information, and click **Signer Details** to get more information on the source of the revocation information.
3. (Optional) If you do not check **Require certificate revocation checking to succeed whenever possible during signature verification** option in **Signature preferences**, you can click **Check Revocation** in the **Revocation** tab to perform revocation check manually.

### Validate a signature

1. Open the PDF containing the signature, do one of the followings:
   - Choose **Protect > Validate**.
   - Right-click the signature with the Hand command, choose **Validate Signature** from context menu.
   - Select the **Hand** command on the toolbar and click the signature.
   - Click the **Digital Signatures** panel, right-click the signature and choose **Validate**
2. Pop-up a Signature Validation Status message box which describes the validity of signature.

Long-term signature validation

Many business or other practical applications need digitally-signed documents to be verifiable for months or years after signing. However, the signed document can be no longer verifiable if the signer’s certificate has expired or been revoked, or with some other reasons. To reduce chances for error or fraud, Long Term Validation (LTV) is introduced for digital signatures in PDF, which is in compliance with Part 4 of the ETSI TS 102778-4 PDF Advanced Electronic Signatures (PAdES) standard.

When LTV is enabled, the document can be validated at any time in the future. To achieve long-term validation, the following are required:

1. The signature is verified using the secure time provided by a timestamp or at which the signature was applied.
2. The signed PDF has not been altered and the certificate has not been revoked or expired.
3. The certificate revocation status is embedded in the signed PDF. Embedding certificate revocation information can occur when the document is signed and saved.

From the Signature panel, you can check whether the signature is LTV enabled or not after validation. In some cases, the certificate revocation information may not be embedded successfully in the document when you sign the document (especially when you are offline) and you will be informed the signature is not LTV enabled. You can right-click the signature and choose Add verification information to add the information to the signature.

*Note: To use secure time for verification, after clicking Change Settings for Singing & Verifications in File > Preferences > Signature, select the Time at which the signature was created, or Secure time (timestamp) embedded in the signature if a trusted timestamp is embedded.*

View signed versions of a digitally signed PDF

A signed version will be automatically saved each time you sign a PDF with a digital signature. If a digitally signed document was modified, you can still view the signed...
version without the modification. For a document digitally signed several times, you can view each signed version without the changes made after each signature was applied. All signed versions along with their corresponding digital signatures are listed in the Digital Signatures panel.

To view a signed version of a digitally signed PDF, do as the following:

1. Open the signed document with Foxit PhantomPDF.
2. In the Digital Signatures panel in the navigation pane, select and expand a signature, and choose Click to view this version. Or right-click the signature in the document pane with the Hand command and choose View Signed Version from the context menu.
3. Then this version will be opened in a new tab in the application window, with the title of “filename.pdf-Signed Version”. (Note: If the document has not been modified since the selected signature was applied, a prompt appears saying you are already viewing the version covered by the selected signature.)
4. (Optional) Following each signed version in the Digital Signatures panel lists the changes made to the signed version. Clicking on one of the changes will jump to the related area in the document.

**Compare versions of a digitally signed document**

For a digitally signed document (which might have been signed several times), you can view the differences (if any) between a signed version and the current version you have.

To compare a signed document with the current version, do as the following:

1. Open the current version you have with Foxit PhantomPDF.
2. Right-click the desired signature in the document pane with the Hand command and choose Compare Signed Version to Current Version from the context menu.
3. A PDF document with the comparison result named “Untitled.pdf*” will be automatically created and opened in a new tab within PhantomPDF, and the Compare Results tab appears on the ribbon. The results document arranges pages side by side showing the two versions with the changes marked by different icons and colors. The first page and the second page show a summary and details of the comparison results respectively. See also Compare PDF Files.

If the document has not been modified since the selected signature was applied, a prompt appears saying you are already viewing the version covered by the selected signature.
Certify a PDF (Business Edition Only)

Only the author can certify his/her own PDF documents. The author can specify what changes can be made to the file after certifying. Whenever approved changes are made, the certificate remains valid. If a reader tries to make changes you haven't allowed, the certificate is invalidated and any subsequent users will be notified that the document was tampered with.

To certify your PDF, please do the following:

1. Open your PDF document you want to certify.
2. Select Protect > Sign & Certify > Certify with visible signature/Certify without visible signature.
3. Press and hold mouse button down, drag to select an area on the document where you want the signature to appear.
4. In the pop-up Certify Document dialog box, choose a digital ID. If you don't find the specified digital ID, you need to get a digital ID from a third-party provider or create a self-signed digital ID.
5. Set authorized actions for your document from the drop-down menu in Permitted Actions After Certifying item.
6. Set the signing reason and choose an appearance type from the menu.
7. Click Sign.
8. To set the properties of the signature, please refer to Signature Field Properties.
9. To sign the document, please see Sign a PDF.
10. To validate the signature, please refer to Validate Signatures.

Add a time stamp to digital signatures and documents

Time stamps are used to specify the date and time you signed a document. A trusted time stamp proves that the contents of your PDFs existed at a point-in-time and have not changed since then. Foxit PhantomPDF allows you to add a trusted time stamp to digital signatures or documents.

To add a time stamp to digital signatures

To add a time stamp to digital signatures, a default time stamp server is required before you make the digital signature. If you have configured a default time stamp server and added it to your trusted certificate list, the time stamp will be embedded with the signature, and the signature properties will show the date/time in the time stamp server when you signed the document; otherwise, the signature properties will
display the local date/time of the computer.

1. Go to File > Preferences > Time Stamp Servers, and set a default time stamp server.
2. Sign the document. See also Sign a PDF.
3. You will be prompted with a pop-up Security Warning to ask you to allow connecting to your time stamp server. Click Allow.
4. Then the signature you made has been successfully embedded with a timestamp. When validating the signature, users need to add the time stamp server into the trusted certificate list so that the signature properties will display the date/time in the time stamp server when the document was signed. See also Trusted Certificates.

Note: By default, if only one time stamp server is available in the system, it will be set as default automatically.

To add a time stamp to documents

- Before adding a time stamp to documents, you need to configure a default time stamp server. Click Protect > Time Stamp Document and create a timestamp server by clicking New... in the pop-up dialog box. Specify the server name and complete other settings of the server on demand. Click OK.
- Select the created server and click Set Default to set the server as the default time stamp server. Click Next to continue.
  (Tip: You can also create, edit, and delete time stamp servers as well as enable/disable the default time stamp server in File > Preferences > Time Stamp Servers. To disable the default time stamp server, select the default time stamp server and click Clear.)
- Specify a name and location for the signed document. Click Save.

Trusted Certificates

When you validate or view properties of a digital signature or an embedded timestamp, the validity status may display “unknown” or “could not be verified”. You need to add the certificate that issued your digital IDs as well as the time stamp server to the Trusted Certificates list.

To add a trusted digital certificate to the Trust Certificates list, please do the following:

- Right-click the digital signature, and choose Show Signature Properties.
- In the Signature Properties dialog box, click Show Certificate.
- In the Certificate Viewer dialog box, specify the trust level for the certificate in the
Trust tab:
- Use this certificate as a trusted root: Use the certificate as a trusted root, and trust all certificates issued by that certificate authority. Once you make a certificate a trust anchor, revocation checking will not be performed on it.
- Validating Signatures or Validating Certified Documents: Trust the certificate when validating signatures or certified documents.

- Click Add to Trusted Certificates, and confirm your operation.

To add a trusted time stamp server to the Trusted Certificates list, please do the following:

- If a time stamp is added to a digital signature, click Timestamp Properties in the lower left corner of the Signature Properties dialog box. If a time stamp is added in the document, right-click the timestamp signature in Digital Signature pane, and choose Show Signature Properties.
- In the pop-up Timestamp Properties dialog box or Signature Properties dialog box, click Show Certificate.
- In the Certificate Viewer dialog box, specify the trust level for the certificate in the Trust tab:
  - Use this certificate as a trusted root: Use the certificate as a trusted root, and trust all certificates issued by that certificate authority. Once you make a certificate a trust anchor, revocation checking will not be performed on it.
  - Validating Signatures or Validating Certified Documents: Trust the certificate when validating signatures or certified documents.
- Click Add to Trusted Certificates, and confirm your operation.

To check all the trusted certificates, choose Protect > Trusted Certificates. In the Trust Certificates window, you can manage all the trusted certificates, including adding & exporting a certificate, viewing certificate details, deleting a certificate, and specifying the trust level for a certificate.

The Signature panel

The Signature panel shows information about each signature and time stamp in the document as well as the change history of the document since the first signature.

Open the Signature panel

Click the Signature button on the left of Navigation Pane.
Chapter 12: Signature

View Signature Properties

Signature Properties dialog box provides basic information about the signature, including the signer, reason, date, location validity summary and details of certificate, etc.

1. Select the Hand command.

2. Right-click the signature field, or right-click the signature in the Digital Signatures panel and choose Show Signature Properties from context menu.

3. In Signature Properties dialog box, you can get the information as follows:
   - **Signed by** – shows the signers that sign the document.
   - **Reason** – displays the reason that you create the signature.
   - **Date** – shows the date time when you signed the document.
   - **Location** - shows which page the signature is located on.
   - **Validity Summary** - checks whether the document was modified after it was signed, and other information.
   - **Show Certificate** – click it to show the details of certificate, such as the validity of certificate, certificate path, etc.
   - **Add to Trusted Certificates** – Click it to add the digital certificate to the Trusted Certificates list.
   - **Timestamp Properties** – Click it to see the properties of the timestamp or add the time stamp to the Trusted Certificates list. (Only available for time stamp signatures or digital signatures embedded with a time stamp.)

*Note:* If the status is unknown, click **Show Certificate... in the Signature Properties dialog box > Show Certificate in the Certificate Viewer dialog box to view the details of the certificate. Check whether the certificate has been included in your list of trusted identities. If your certificate is not trusted, click **Install Certificate** to install it to the trusted Windows Certificate Store. If you use a self-signed digital ID, confirm that the certificate details are valid. If the certificate isn't valid, a valid certificate from signer is requested.

Sign PDFs with DocuSign®

Allows users to easily send, sign and save PDF documents and forms using the industry's most widely used eSignature solution.

Sign a PDF File

To sign a PDF with DocuSign, please refer to the following steps:
Open the PDF document you want to sign. Click the Protect tab, and choose DocuSign > Login to DocuSign. Type your Email and password for DocuSign and click Login. If you do not have an account, please sign up first.

After signing in, choose DocuSign > Sign with DocuSign. The application will upload your PDF to DocuSign and you will enter into the DocuSign user interface.

Sign the Document

On the DocuSign user interface in the PhantomPDF window, you can do the following:

- Sign directly by adding desired fields (including Signature, Initial, Date Signed, and more) to the document. Choose a field and the cursor changes to preview the appearance of the field. Then click on the document to place the field, or click several times to place multiple fields. Click the Close button at the top right corner of a field to delete it. You can resize fields such as Signature, Initial, and Text by dragging the handles of the field box that appear when you click on the field. (Note: You should visit the DocuSign website if you want to change the Signature and Initial appearances.)
- By using the tools at the top of the window, you can change the zoom of the file, download the file, or print the PDF with signatures visible.
- Click FINISH and a message box pops up for you to send the signed document to others.
- (Optional) click OTHER OPTIONS to view history, view certificates, choose FINISH LATER to finish the signing process later, or choose PRINT & SIGN to print the document out so you can sign on paper.

To log out of DocuSign, choose DocuSign > Logout of DocuSign in the Protect tab.

To change the appearance of your signature:

- Visit the DocuSign website (www.docusign.net).
- Click Edit beside MY DOCUSIGN ID under the Home tab. (If you don’t have any signatures, click Create Your Signature.)
- Then find the signature you want to change and click Edit.
- In the Create Your Signature window, change the signature appearance as needed.

  - CHOOSE: select a style as your signature appearance.
  - DRAW: draw a signature appearance using your input device.
  - UPLOAD: you can upload an image as your signature appearance.

- Click CREATE to complete the signature creation process.
Send a PDF via DocuSign

- Open a PDF with PhantomPDF.
- Click the Protect tab, and choose DocuSign > Send via DocuSign.
- Log in to DocuSign.
- Add the recipients, message, and other options as needed.
- Then Click Send to send the PDF.

*Note: For more details about DocuSign, please contact DocuSign support.*

Quick PDF Signature

Quick PDF Sign enables you to create your self-signed signatures and add the signature to the page directly. You don’t need to create different signatures for different roles. See also the tutorial on Sign Documents with PDF Sign.

To create your own handwritten signature and sign a PDF, follow these steps.

1. Choose Fill & Sign.
2. Click ‍ in the signature palette or click ‍ on the lower right corner of the signature palette and choose Create Signature from the drop-down menu.
3. In the Create Signature dialog box, you can draw a signature, import a file, copy from the clipboard, or type text content to create a signature. Or, click Online Signature to choose a signature from the online signatures you saved before.

*TIP: You can sign your signature on a clean white sheet of paper using a black pen, and scan it to an image file. To create the best signature, it is suggested to scan your signature in monochrome at 600 DPI.*

4. You can preview the signature in the Preview box.
5. Check the options as needed:
   - **Convert signature to black & white:** the signature will be created in black and white even if the original image is chromatic.
   - **Keep original size:** selects the option and the signature will be created with the original size. If the signature width/height is greater than the page size, Foxit PhantomPDF will zoom it out to a signature with a width of 100 pixels while maintaining the original proportion. The option is only available when the signature is from an imported file or Clipboard. With the option unselected, the signature will be resized and created with a width of 100 pixels while maintaining the original proportion by default.
   - **Discard the signature when program closes:** the signature will not be listed in
the signature palette the next time you launch PhantomPDF.

**Require password to use this signature:** Specify a password that will be required when users sign the document with the signature. Enter the password again to confirm it.

6. (Optional) Click **Save Online** to save the newly created signature to Foxit ConnectedPDF Web Services, which allows you to sign documents.

7. Click **Save**. The cursor will be changed into a shape with the appearance preview of the signature.

8. (Optional) Select the **Keep Tool Selected** option in the **Sign** group so that you can add the same signature continuously without reselecting the same signature.

9. Place the cursor to the position you want to sign and click. Or drag a rectangle to define the size and placement.

10. Click the signature with the Hand command, and it will be highlighted with a red rectangle. After adding the signature, do any of the following, if necessary.
   - To resize the signature, drag the small red square on the lower right corner of the rectangle. After resizing the signature, you can right-click the signature and choose **Set Current Size as Default** to set the size as default so that Foxit PhantomPDF will remember and apply the same size when you add the same signature in the future.
   - To move the signature, drag the rectangle directly to the desired place.
   - Before applying the signature, you can right-click the signature and choose relevant options from the context menu to copy, cut, paste, or delete the signature.

11. (Optional) When you click the signature with the Hand command, a gray toolbar appears over the rectangle. Click ⬅️ and ➡️ to switch among different signatures if any; click the invert triangle ▼ to drop down the context menu.

12. Right-click the signature you added, and select **Place on Multiple Pages** from the context menu to place the signature to multiple pages.

13. To apply the signature to the document, click the signature and the invert triangle ▼ or right-click the signature, and select **Apply Signature** from the context menu. You can apply all signatures in the document by clicking **Apply All Signatures** in the ribbon. A dialog box will pop up when you click **Apply All Signatures** for the first time to prompt you that applying all signatures will flatten the whole document. You can change the settings by clicking **Change Setting** in the dialog box, or clicking ➘ on the lower right corner of the signature palette and choosing **Preferences**, or directly navigating to **File > Preferences > PDF Sign**.

**Note:** Once applied, the signature can no longer be edited or deleted.

To manage the created signatures, do the following:

In the **Fill & Sign** tab, click ➘ on the lower right corner of the signature palette and choose **Manage Signature** from the drop-down menu.
dialog box, you can create, move and delete the created signatures, and set password for them.
Chapter 13 – Accessibility

Foxit PhantomPDF provides accessibility features to give users with disabilities (such as visually impaired people) greater access to information and technology. With commands in the **Accessibility** tab on the ribbon and the panels related to accessibility in the navigation pane, you can check the accessibility of PDFs, fix accessibility issues, edit document structure, and set accessibility preferences to make PDFs and the setup more accessible.

### Accessibility Check and Fixes

A document is accessible if it can be used by people with disabilities, such as visually impaired people. Foxit PhantomPDF allows users to evaluate the accessibility of your documents and identify areas that may be in conflict with Foxit’s interpretations of referenced guidelines, create accessibility report, view the Full Check results, and fix accessibility problems.

### Check Accessibility with Full Check

Use the Full Check command to check whether a PDF is compliant with accessibility standards of Web Content Accessibility Guidelines (WCAG) 2.0. You can choose which kinds of accessibility items to check for and how to view the results.

To check accessibility with the **Full Check** command, please do as below:

1. Choose **Accessibility > Full Check**.
2. In the **Accessibility Checker Options** dialog box, select options you need to check for. See also the **Accessibility Issues**.
3. In Report Options section, check **Create Accessibility Report** option if needed to save the results as an HTML file and specify the save path. You can also check **Attach report to document** to add the accessibility report as an attachment of the PDF document.
4. **Show this dialog when the Checker starts**: If this option is checked, the **Accessibility Checker Options** dialog box will pop up whenever you run the Full Check. Otherwise, the dialog box won’t appear. If the dialog is hidden, go to **File > Preferences > Accessibility** and change the setting to show the dialog.
5. Click **Options** button and change the setting to do a full check.
6. Click **Start Checking**.
View Full Check Results and Accessibility Report

When the check is completed, the Accessibility Check panel automatically expands in the navigation pane to display the check results.

You can click Accessibility > Accessibility Report, or directly click the Accessibility Report panel in the navigation pane to open the Accessibility Report. You can also open the accessibility report file (if any) in a web browser.

*Note: Because some content types are difficult to be distinguished clearly by the checker, some issues reported may not affect readability. It would be better to review all issues to definitely decide which ones are not accessible.*

The report includes the name of the PDF document, Summary of the result, and Detailed Report for each checking option.

**Summary** lists one of the following statuses for each item check:

- **Needs manual check** – The Full Check feature couldn't check the item automatically. Please verify the item manually.
- **Passed manually** – The item status was changed to Passed Manually by users from Needs manual check.
- **Failed manually** – The item status was changed to Failed Manually by users from Needs manual check.
- **Skipped** – Users chose Skip Rule when verifying the items manually. Or the item was skipped because the corresponding option was not selected in Accessibility Checker Options dialog box when users ran the Full Check.
- **Passed** – The item passed the Full Check.
- **Failed** – The items didn't pass the Full Check.

**Detailed Report** clearly lists the rule name, status, and description for each checking option. You can click the links in the report to view the online Help on fixing issues.

Fix Accessibility Problems

In the Accessibility Check panel where the Full Check results are listed, right-click an item and choose one of the following options from the context menu:

**Fix**: fixes the issue automatically, or prompts a dialog box where you need to fix it manually. *(Business Edition only)*

**Skip Rule**: changes the item status to Skipped.
Explain: opens the online Help on the accessibility issue.

Check Again: checks all the items again.

Show Report: opens the Accessibility Report panel in the navigation pane.

Options: opens the Accessibility Checker Options dialog box for you to select options.

Pass: changes the item status to Passed Manually if you believe the item meets the accessibility standard.

Fail: changes the item status to Failed Manually if you believe the item doesn't meet the accessibility standard.

Accessibility Issues

After the accessibility check based on the options you specified in the Accessibility Checker Options dialog box with the Full Check command, you can view the check results in the Accessibility Check panel and the detailed report in the Accessibility Report panel. The following part on accessibility issues provides explanations and instructions to help you better understand each accessibility rule and easily make a decision on how to deal with the accessibility problems in your document.

Document

Accessibility permission flag

Some documents may be protected by the document authors and no content can be copied, printed, extracted, annotated, or edited. This permission setting could interfere with a screen reader's ability to read the documents because screen readers need to copy or extract the documents' text to convert it to speech.

The flag reports whether the setting is turned off to allow accessibility. If your document failed to pass the rule, to fix the issue automatically, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. You can also fix the issue manually by choosing No Protection in File > Properties > Security to turn off the permission setting.

Image-only PDF

The rule check reports whether the document is an image-only PDF with non-text
content that is not accessible. To fix the issue automatically, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. Or, you can use the OCR tools under the Convert tab on the ribbon to recognize text in images to fix the rule check manually.

Tagged PDF

This rule check reports whether the document is a PDF with tags to specify the reading order, which is important for an accessible PDF. If the check failed, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. Or, you can tag the PDF manually by doing any of the following:

- Re-create the PDF from a file that has been tagged in the authoring application.
- Use the Autotag Document/Form Field commands under the Accessibility tab in PhantomPDF Business.
- Use the Reading Order command under the Accessibility tab in PhantomPDF Business to create the tags tree for the document manually.
- Directly create the tags tree manually in the Tags panel in the navigation pane in PhantomPDF Business.

Logical Reading Order

Check the rule manually to make sure that the reading order in the Tags panel is in accordance with the logical reading order.

Primary language

Some screen readers read the text in the language specified for the document. This rule checks whether the primary text language for the document is specified. If no language was set, only Business Edition allows you to fix this issue. You can set the language by right-clicking the rule in the Accessibility Check panel in the navigation pane and choosing Fix from the context menu, then choose a language in the Set Reading Language dialog box. You can also set the language manually by doing either of the following:

- Set the language for text in a subtree of the tags tree in the Tags panel. Right-click an element, choose Properties..., and select a language in the Object Properties dialog box.
- Set the language for a block of text in the Content panel. Right-click the text element or container element, choose Properties..., and select a language in the Object Properties dialog box.
Title

This rule is to check whether the document contains a title in its document properties. If the check failed, right-click the rule in the Accessibility Check panel in the navigation pane, choose Fix from the context menu in PhantomPDF Business, uncheck Leave as is and enter the document title in the Description dialog box. Or, add the title manually in the Title box in File > Properties > Description, and then select Display document title in Window Options in File > Properties > Initial View.

Bookmarks

If the document contains 21 or more pages, but doesn't have bookmarks that correspond to the document structure, this rule check will fail. To add bookmarks to the tagged document, right-click the rule in the Accessibility Check panel in the navigation pane, choose Fix from the context menu in PhantomPDF Business, and select the elements you want to use as bookmarks in the Structure Elements dialog box.

Color contrast

The check may fail if the document contains content that isn't accessible to people who are color-blind. To fix the issue, ensure that the document's content conforms to the guidelines in WCAG section 1.4.3, or select Replace document colors and set high-contrast colors to the PDF viewer in File > Preferences > Accessibility.

Page Content

Tagged content

The rule check reports whether all content in the document is tagged or marked as an artifact.

Artifacts are graphics objects that are typically not part of the author’s original content but rather are generated by the PDF producer application in the course of pagination, layout, or other strictly mechanical processes. Artifacts are not read by a screen reader. Page numbers, headers, and footers are often tagged as artifacts.

To fix the issue, do any of the following in PhantomPDF Business:

- Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Content panel in the navigation pane.
- Tag the content using the Reading Order command in the Accessibility tab.
- Assign tags for text contents by selecting the text contents with the Select Text and
Image command, and then right-clicking the element in the Tags tree and choosing Create Tag from Selection in the Tags Panel.

Tagged annotations

The check reports whether all annotations in the document are tagged or marked as an artifact. To fix the issue, do either of the following in PhantomPDF Business:

- Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Content panel in the navigation pane.
- Tag the content using the Reading Order command in the Accessibility tab.

Tip: You can enable Tag Annotations in the Tags panel by right-clicking any tag so that all new annotations will be tagged automatically as they are created.

Tab order

The check reports whether the tab order parallels the document structure. To fix the issue automatically, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. You can also click the Pages panel in the navigation pane, right-click the pages that failed in the rule check, choose Properties... and select Use Document Structure in the Tab Order tab to set the tab order manually.

Character encoding

A correct character encoding is required to display readable text in software/hardware. To fix the issue, you need to check whether the necessary fonts have been installed on your system or re-create the PDF from a file that uses a proper font (preferably OpenType).

Tagged multimedia

Checks whether all multimedia objects in the document are tagged or marked as an artifact. To fix the issue, do one of the following in PhantomPDF Business:

- Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Contents panel in the navigation pane.
- Tag the content using the Reading Order command in the Accessibility tab.

Screen flicker

Document content, like animations and scripts that can make the screen flicker, is not accessible for people who have photosensitive epilepsy and can be difficult to see
when the screen is magnified. To fix the issue, you need to remove or modify the content that can make the screen flicker.

**Scripts**

If the document contains scripts, the scripting shouldn't interfere with keyboard navigation or prevent the use of any input device. To fix the issue, you need to remove or modify the script or content that doesn't meet the accessibility rule.

**Timed responses**

If the document contains forms with JavaScript that requires timed response, the check fails. To fix the issue, edit the scripts to give users enough time to read and use the content, or remove the scripts.

**Navigation links**

The check reports whether the URLs in the document are active links that are correctly tagged. To fix the issue, check navigation links manually and make sure that the content doesn't have too many identical links.

**Forms**

**Tagged form fields**

The rule check reports whether all form fields in the document are tagged. If the rule check passes, you can also use the **Tooltip** in a form field's properties to provide users with more information.

If it fails, do either of the following to fix the issue in PhantomPDF Business.

- Tag form fields with the **Autotag Form Field** command in the **Accessibility** tab.
- Right-click the rule in the **Accessibility Check** panel in the navigation pane and choose **Fix** from the context menu.

**Field descriptions**

The check reports whether all form fields have a text description in the document. All form fields need a text description for an accessible PDF. You can add a text description (tooltip) to a form field in its properties by doing any of the following:

- Right-click the form field and choose **Properties**... to add the tooltip for the form field.
You can also click Form > Add Tooltip to add tooltips automatically for all form fields which does not have descriptions.

- Right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu. (Business Edition only)
- Click Accessibility > Reading Order to enable Touch Up Reading Order setting mode. Right-click the form field and choose Edit Form Field Text.... Then type text in the pop-up Form Field Text dialog box.

Alternate Text

Figures alternate text

For accessibility, images in the document either have alternate text, or are marked as artifacts. If the rule check fails, do any of the following in PhantomPDF Business:

- Right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu. Add alternate text in the Set Alternate Text dialog box.
- Open the Tags panel and right-click the image that you want to add alternate text, choose Properties..., and add alternate text in the Object Properties dialog box.
- Click Accessibility > Reading Order to enable Touch Up Reading Order setting mode. Then right-click the image that you want to add alternate text, choose Edit Alternative Text, and add alternate text in the Alternate Text dialog box.
- Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Contents panel in the navigation pane.

Nested alternate text

The check fails if the document contains nested alternate text that screen readers don't read. To fix the issue, right-click the nested element in the Tags panel in PhantomPDF Business, choose Properties..., and remove the alternate text in the Object Properties dialog box.

Associated with content

Alternate text is always associated with the corresponding content on the page. If not, there's no way to determine which page the alternate text is on. If the Screen Reader Options in Preferences > Reading is not set to read the entire document, screen readers don't read the alternate text. To fix the issue, remove the alternate text from any nested item that has no page content by right-clicking the nested elements in the Tags panel in PhantomPDF Business and choosing Properties....
Hides annotation

The rule checks whether there is any annotation in the document that is hidden by alternate text. For an annotation that is nested under a parent element with alternate text, screen readers don’t see it. To fix the issue, right-click the nested element in the Tags panel in PhantomPDF Business, choose Properties..., and remove the alternate text from the Object Properties dialog box.

Other elements alternate text

The content except figures like multimedia, annotations, and 3D models, also requires alternate text for accessibility. And make sure alternate text is always associated with the corresponding content on the page. See also Associated with content.

Tables

For the table structure, which can be complex, PhantomPDF recommends that users check them for accessibility manually.

Rows

If the check fails, open the Tags panel, and make sure that each Table Row in a table is a child of Table, THead, TBody, or TFoot in PhantomPDF Business.

TH and TD

For accessibility, Table Header <TH> and Table Data <TD> are children of Table Row <TR>. If the check fails, verify it in the Tags panel in PhantomPDF Business.

Headers

For accessibility, all tables must have a header. If the check fails, verify it in the Tags panel in PhantomPDF Business.

Regularity

Tables must contain the same number of columns in each row, and rows in each column. If the check fails, verify it in the Tags panel in PhantomPDF Business.

Summary

A table summary is not a must, but it can make the document more accessible. The document author can add or edit the table summary with Foxit PhantomPDF Business.
Choose **Accessibility > Reading Order**.

Right-click on the table, and select **Edit Table Summary**.

In the pop-up **Table Summary** dialog box, input a summary, and click **OK**.

**Lists**

**List items**

The rule check reports whether the list structure in the document is correct. Lists must have the following structure: A list element must contain list item elements; a list item element may have a label element (optional) and a list item body element (required). To fix the issue, do the following steps:

- Right-click the failed element in **List items** in the **Accessibility Check** panel and choose **Show in Tags Panel** from the context menu.
- Create elements, change the types of elements, or reorganize the existing elements by dragging them to the proper position.

**Lbl and LBody**

See also [List items](#).

**Headings**

**Appropriate nesting**

The check reports whether headings are nested properly. If the check fails, do the following steps:

- Right-click the failed element in **Headings** in the **Accessibility Check** panel and choose **Show in Tags Panel** from the context menu.
- Create elements, change the types of elements, or reorganize the existing elements by dragging them to the proper position.

**Accessible reading and navigation through accessibility preference setting and shortcut keys**

Foxit PhantomPDF allows you to set accessibility preferences that control the document colors, document display and reading order, and provides keyboard shortcuts, which are good for visually impaired and motion-impaired users to better
read and navigate PDFs with or without assistive software/hardware.

Set accessibility preferences with Setup Assistant

1. Click **Accessibility > Setup Assistant**.
2. In the **Accessibility Setup Assistant** dialog box, choose options that you need or are suitable for your assistive software/hardware.
3. If you click **Cancel** in any step, all the options you have chosen will be discarded and the original setting will be used.

**Tip:** You can set more accessibility preferences from **File > Preferences > Accessibility/Reading/Forms/History**.

Change reading options for the current document

While using a screen reader to read PDFs, users can change the reading settings for the current document like reading order and mode.

1. Click **Accessibility > Reading Option**.
2. Choose the desired reading options and click **Start**.

**Note:** The preferences set here are only valid for the current document, whereas the settings with **Setup Assistant** are the default for all documents and remain in effect until you change them with **Setup Assistant**.

Read PDF in reflow view

The reflow view allows users to read documents on a mobile device or even a screen magnifier without scrolling horizontally to read text by presenting pages as a single column that is the width of the document pane.

To read PDF in reflow view, choose **Home > Reflow**, or choose **View > Reflow**.

To return to non-reflowed view, click again on the **Reflow** button.

**Note:**

1. Text in comments and form fields does not reflow and vertical text reflows horizontally.
2. The reflow view only provides a view mode, without making any changes to the document.
Read and Interact with PDF with Screen Reader

Foxit PhantomPDF enables visually impaired users to read and interact with PDF using NVDA (NonVisual Desktop Access) and JAWS (Job Access with Speech). While reading and interacting with PDF, you can use the Setup Assistant command in the Accessibility tab to improve how Foxit PhantomPDF interact with your screen reader, or change your reading settings for the current document by choosing Accessibility > Reading Option in Foxit PhantomPDF Business.

Shortcut keys

PhantomPDF provides users with single-key accelerators for accessibility to navigate PDF.

Create accessible PDFs (Business only)

Accessible PDF documents have content and elements including searchable text, alternate text descriptions for images/interactive form fields, reading order, and document tags, to enable people with disabilities to work on them with or without screen readers or other assistive software/hardware. Foxit PhantomPDF provides commands to help make your PDF accessible by tagging PDFs and form fields, setting alternate text, and editing tags. You can also use the Action Wizard in Foxit PhantomPDF Business to create accessible PDFs in batch.

Tag PDF documents and form fields

In PDF files, tags indicate the structure of documents and define the logic that binds the content together including the correct reading order, and the presence and meaning of figures, which can work better with the assistive technology like screen readers. To check whether a PDF is tagged, navigate to File > Properties > Description > Tagged PDF.

It is recommended that you tag a document when converting it to PDF from an authoring application, but if you do not have access to an authoring application that can generate a tagged PDF, you can tag a PDF any time with PhantomPDF Business.

To tag a PDF, open the document and click the Autotag Document command in the Accessibility tab. Then the tags of the document are created and you can view the tags in the Tags panel in the navigation pane. If the document already has tags, you'll
be prompted whether to re-tag the document.

To tag form fields in PDF, please click the **Autotag Form Field** command in the **Accessibility** tab.

After the tagging completes, a tag recognition report is generated in the **Recognition Report** panel in the navigation pane. You can use the report as a guide to repair tagging problems.

*Tip: In the Tags panel, Ctrl-click the plus/minus sign next to a tag to expand/collapse all the child tags that are nested under it; Ctrl-click the plus/minus sign next to the Tags root to expand/collapse all tags in the tags tree.*

### Set alternate text for figures

Alternative text for figures will be displayed when you hover your mouse over the figure to help you understand the figures better.

To set alternative text for all the figures in your PDF one by one with the **Set Alternate Text** command:

1. Click the **Set Alternate Text** command in the **Accessibility** tab.
2. A dialog box pops up to tell you PhantomPDF will detect all figures in the document and display associated alternate text.
3. Click **OK** and type descriptive alternate text for the figure in the **Set Alternate Text** dialog box. If the figure is used only for decorative purposes, check **Decorative figure**.
4. Click the arrows at the top of the **Set Alternate Text** dialog box to set alternate text for the next figure or previous figure.
5. After completing setting for all figures, click **Save & Close**.

To set alternative text for a specific figure in your PDF:

1. Click **Accessibility > Reading Order** to enable Touch Up Reading Order setting mode.
2. Right-click the figure that you want to set alternate text on the document pane, and choose **Edit Alternate Text**.
3. In the pop up **Alternate Text** dialog box, input the information, and click **OK**.
Check reading order and edit tags with the Reading Order command

Reading order and document structure tags are two important characteristics of accessible PDFs. The Reading Order command helps you easily check the reading order and edit tags for PDFs. However, the command is used to fix basic tagging problems for PDFs that were tagged with Foxit PhantomPDF, not for PDFs that were tagged during conversion from an authoring application. If possible, try to return to the source file and add accessibility features in the authoring application.

Check the reading order for a tagged PDF

1. Open a tagged PDF document and click Accessibility > Reading Order, or right-click any tag in the Tags panel and choose Reading Order.
2. The Touch Up Reading Order dialog box pops up, with options including different tag types and the way to show page content groups.
3. In the document area, you can see the page content displays in separate regions highlighted with gray blocks.
4. If you choose Page content order under the Show page content groups option, the regions are ordered with numbers. Choose Structure types, then the regions are labeled by structure tag types, like “P” for paragraph, “H2” for Heading 2, or “Figure”.
5. If the numbered regions don't follow one another, click Show Order Panel in the Touch Up Reading Order dialog box, and reorder them in the Order panel.

Edit tags with the Reading Order command

You can tag a selected region, change the tag type for a region, as well as remove some useless page elements, with the Reading Order command. Since editing tags with the Reading Order command doesn't create the same level of details to the tagging structure as the tools in the Autotag group, you can use this manual tagging if you don't have any better method to edit the tags.

Note:

1. Editing tags with the Reading Order command can't be undone, so it is recommended that you save a backup copy of this document before you edit tags.
2. You can select and edit multiple objects at a time under the Touch Up Reading Order setting mode. To select multiple objects, Ctrl-click (i.e. hold down the Ctrl key as you
Tag a region

1. Click Accessibility > Reading Order to open the Touch Up Reading Order dialog box.
2. Drag to select a region of the page content in the document area.
3. Choose the desired tag type in the Touch Up Reading Order dialog box to tag the selected region, or right-click the selected region and choose the desired tag type from the context menu.
4. Options in the Touch Up Reading Order dialog box:
   - **Text** – Chooses it to tag the selected region as text.
   - **Figure** – Tags the selected region as a figure.
   - **Form Field** - Tags the selected region as a form field.
   - **Figure/Caption** – Tags a selected figure and caption as a single tag. Then all the text content in the tag is the caption, which is useful to tag photos and captions, preventing caption text from being incorrectly added to the text around. For the figures, alternate text may be required.
   - **Heading 1/ Heading 2/ Heading 3/ Heading 4/ Heading 5/ Heading 6** – Tags the selected region as a first/second/third/fourth/fifth/sixth level heading.
   - **Table** – Tags the selected region as a table.
   - **Cell** – Tags the selected region as a table or header cell. The option is often used to merge cells that are incorrectly split.
   - **Formula** – Tags the selected region as a formula. You may need to set alternate text for formula tags for speech software to easily handle them.
   - **Reference** – Tags the selected region as a reference.
   - **Note** – Tags the selected region as a note.
   - **Background/Artifact** – Tags the selected region as a background element or artifact. Background elements and artifacts neither appear in the tags tree nor in the reflowed document, and screen readers don’t read them.

**Table Editor**: Enables table editing mode to edit table cell properties. You can use this command on a table which has been tagged as a table before.

**Show Page Content Groups** – Checks the option to show the page content by the page content order or the structure types. If you choose Page content order under the Show page content groups option, the regions are ordered with a number. Choose Structure types, then the regions are labeled by structure tag types, like “P” for paragraph, “H2” for Heading 2, or “Figure”. You can click the color swatch to change the highlight color.

**Show table cells** – Checks the option to highlight the content of individual table cells. You can click the color swatch to change the highlight color.

**Display like element in single box** – Checks it to display adjacent squares with
the same tag type in a single square with the common tag type.

**Show tables and figures** – Checks the option to outline each table and figure with a crossed-out box. The crossed-out box will also indicate whether the table or figure includes alternate text. You can click the color swatch to change the box color.

**Clear Page Structure** – Clicks it to remove the tagging structure from the page.

**Show Order Panel** – Clicks it to open the **Order** panel in the navigation pane.

5. Click **Close**.

**Change the tag for a region**

1. Click **Accessibility > Reading Order**, the **Touch Up Reading Order** dialog box pops up.
2. Draw a rectangle in the page content or click the number of a highlighted region, and choose a tag type from the **Touch Up Reading Order** dialog box that you want to change to.
3. Click **Close**.

**Tips:**

1. You can also press F2 to quickly modify tag types.
2. To retag content, you can right-click items in the **Order** panel and choose a tag type from the context menu.

**Remove page elements from the tag structure**

Some page elements that don't contain useful or illustrative information and shouldn't be read, like decorative lines, artifacts, or background elements, can make the structure layout untidy and cause some chaos when they are reflowed or read by screen readers. You can remove these page elements from the tagging structure by changing them to the Background tags.

1. Select **Reading Order** in the Accessibility tab.
2. Select the page element in document pane, and choose **Background** in the **Touch Up Reading Order** dialog box to tag the selected page element as Background.

**Check and correct figure tags**

Figures tags should identify image content that is meaningful to the document. Sometimes background elements that are not necessary to be read are incorrectly tagged as figures, and you need to redefine them as background. You can use the **Reading Order** command to check and correct tagging problems for figures.

Select **Reading Order** in the **Accessibility** tab, make sure that you have checked the
Show tables and figures option, and then do one of the following:

- If a figure isn't tagged as a figure, drag to select the content and choose **Figure** or **Figure/Caption** in the **Touch Up Reading Order** dialog box.
- If text is incorrectly combined with a figure, drag to select the content and choose **Text** in the **Touch Up Reading Order** dialog box.
- If a figure and a caption are separated, drag to select the content and choose **Figure/Caption** in the **Touch Up Reading Order** dialog box.

Check and correct table tags

Tables can be a challenge for screen reader or other assistive technology since they may contain complex lists, form fields or paragraphs. You can use the **Reading Order** command to check if a table has been properly recognized and to correct recognition problems. Also, the Table Editor tool can help you edit table cell properties to make it more accessible.

Select **Reading Order** in the **Accessibility** tab, make sure that you have checked the **Show tables and figures** option, and do the following:

- If a table isn't tagged as a table, drag to select the content and choose **Table** in the **Touch Up Reading Order** dialog box.
- Make sure that the **Show table cells** option is checked so that all cells in the table are defined as individual elements. Click **Table Editor** in the **Touch Up Reading Order** dialog box, or right-click the table on the document pane and select **Table Editor**. Alternatively, if you have opened the **Tags** panel, you can also access the Table Editor tool by right-clicking a table tag and choosing **Table Editor** from the context menu. All the table cells will be highlighted in the color set in the Table Editor Options.
- If you want to change the highlight color and display option for table cells, right-click the table cell on the document pane and choose **Table Editor Options**.
- (Optional) Right-click the table cell on the document pane and choose **Auto Generate Header Cell IDs** to generate cell IDs for all the header cells automatically. If you haven't generated header cell IDs automatically, when you try to associate any header ID to any cell, Foxit PhantomPDF will prompt you to generate IDs for header cells if any header cells don't have an ID.
- Right-click the table cell on the document pane and choose **Table Cell Properties** to edit the type and attributes of the table cells. You can use Shift-Click to select multiple cells and bulk edit the table cell properties.

Remove tagging structure from the pages

If the existing structure for a PDF contains too many problems, you can clear it to
create a new one. To clear tagging structure from the page, please do one of the following:

- Click the icon in the navigation pane to open the Order panel. In the Order panel, right-click on the root element and select Clear page structure to clear the tagging structure of all pages. Or right-click on the page element and select Clear page structure to clear the tagging structure of the currently selected page.
- Select Reading Order in the Accessibility tab, click Clear Page Structure in the Touch Up Reading Order dialog box, or right-click on the document pane and choose Clear page structure from the context menu to clear the tag structure from currently visible page.

**Change reading order**

The reading order for a document can be readily apparent when you use the Reading Order command. You may need to change the reading order if page content groups shown are not correctly numbered. To change the reading order, you can move desired items in the Order panel or set area reading order directly in the document pane.

**Change reading order in the Order panel**

Click the icon in the navigation pane to open the Order panel where you can view the reading order. When you click a page in the Order panel, you will be switched to the corresponding page in the document view; when you select a tag in the Order panel, the corresponding content in the document view will be highlighted. In the Order panel, you can also change the reading order of a tagged PDF file without changing the actual appearance of the PDF file if the permission allows. To change the reading order, please do either of the following:

- Select the tag that you want to move and drag it to the desired location. The Line icon shows the place where the tag will be located as you drag the tag.
- Right-click the tag that you want to move and choose Cut from the context menu. Then right-click a destination tag after which you want to move to and choose Paste.

After you drag a tag to a new location, the highlighted regions will be renumbered to show the new reading order.
**Tips:** In the Order panel, you can use Ctrl-Click to select multiple tags as you click, or Shift-Click to select a listed group of tags between the first and the last tag you click. Then you can move them or right-click them to do more actions.

**Set area reading order**

Foxit PhantomPDF provides a visual and more efficient way to change reading order directly in the document view. You just need to draw areas around the desired content in the document pane and reset the reading order for them. For documents with multiple columns or other complicated structure, this feature improves the productivity to set reading order, instead of dragging and dropping tags in the Order panel.

To set area reading order, do the following steps:

1. Choose **Accessibility > Set Area Reading Order**, and click OK in the prompt telling you to draw areas and set the reading order. You can click **Don't show again** in the prompt so that you won't be bothered the next time you set area reading order.
2. The cursor changes into a cross. Drag a rectangle where you define it as a page content group. You can resize the rectangle by dragging the handles, or delete the rectangle by pressing **Delete**.
3. After you finish drawing areas where you want to change the reading order, click **Accessibility > Change Area Order**. You can see each area is numbered in an order that you drew them.
4. You can adjust the order as needed by clicking on the areas. As you click on the areas, numbers and arrows appear in red, indicating the order you set.
5. When you complete setting the order, click **Accessibility > Apply Area Order** to apply the order.
6. In the **Content** and **Order** panels, you can also see the changes of the reading order.

**Edit document structure with the Content and Tags panels**

For the content reflow and tagging problems that cannot be fixed by the Reading Order command, the **Content** and **Tags** panels provide you with more options to handle them.
Check and correct reflow problems with the Content panel

In the **Content** panel in the navigation pane, you can view pages and objects, and correct reflow problems in a PDF. The panel provides a hierarchical view of objects including pages, annotations (like comments, form fields, and links), and containers. In the panel, objects are listed in the order in which they appear on the page. You can move objects in the panel to adjust the content order by dragging and dropping objects.

In the **Content** panel, you can perform actions as below:

- You can move a container or object by selecting it and drag it to the desired location.
- Right-click a page or an object and choose an option from the context menu.

**New Container** – Creates a new container object at the end of the selected page or container.

**Cut** – Cuts and copies the selected object(s).

**Paste** – Pastes content below the selected object at the same hierarchical level.

**Paste Child** – Pastes content into the selected object as a child of the selected object.

**Delete** – Removes the object(s) from the document.

**Save Selection As** – Exports the selected object(s) to PDF.

**Find Content from selection** – Finds the object in the Content panel that corresponds to the selected content in the document pane.

**Find...** – Searches the page or document for artifacts, OCR suspects, unmarked comments/links/annotations/content, and add tags to found items.

**Create Artifact** – Sets the selected object as artifact. Page numbers, headers, and footers are often best tagged as artifacts, which are not read by screen readers or the Read Out Loud feature.

**Show in Tags Panel** – Switches to the **Tags** panel with the tag corresponding to the current content selected.

**Highlight Content** – Checks the option, and the content in the document
corresponding to the selected content in the **Content** panel will be highlighted with a box around.

**Edit Container Dictionary**… – Changes the dictionary for the container. If the container has no dictionary associated with it, this option is unavailable.

**Edit Document Catalog**… – Changes the document catalog. This option is available for the root of the document’s object hierarchy in the Content panel.

**Edit Page Dictionary**… – Changes the dictionary for the page.

**Audit Space Usage** – Gets space information used (bytes) by different types of objects.

**Show Metadata** – Shows the metadata information for the selected image. If the image has no metadata associated with it, this option is unavailable.

**Properties** – Opens the **Object Properties** dialog box.

### View tags in the Tags panel

You can view a logical structure tree of tags in the **Tags** panel that represent the organizational structure of the document and define the reading order. The tags tree shows the document content as page elements (such as headings, paragraphs, and tables) nested at various levels. Assistive software determines how to present and interpret the document content according to the tags tree.

To view tags in the **Tags** panel, click the **Tags** panel in the navigation pane. While viewing tags in the **Tags** panel, you can click 📑 at the top of the **Tags** panel to expand top-level tags, or click 📐 to collapse the expanded top-level tags, if necessary. You can also click the A⁺ or A⁻ icon to enlarge or reduce the text size of all the tags.

### Edit tags with the Tags panel

You can move a tag, and edit the properties (such as title and type) of a tag in the **Tags** panel. By right-clicking a tag, you can choose the following options:

**New Tag**… – Creates a new tag after the selected item in the tags tree. Then specify
the type and title of the new tag.

**Cut** – Cuts and copies the selected tag.

**Paste** – Pastes the copied tag below the selected tag at the same level.

**Paste Child** – Pastes the copied tag as the child tag of the selected tag.

**Delete Tag** – Removes the tag from the tags tree. If you remove the root (topmost) tag, all tags in the document will be removed.

**Delete Empty Tags** – Deletes all empty tags from the subtree of a selected tag, except for valid empty tags such as TD, TH, and Link - OBJR.

**Reading Order(x)** – Opens the Touch Up Reading Order dialog box.

**Table Editor** – Enables table editing mode to edit table cell properties. This option is available when you right-click on a table tag.

**Find Tag from Selection** – Finds the tag in the Tags panel that corresponds to the selected text content in the document pane.

**Create Tag from Selection** – Creates a tag in the logical structure tree for a selected text content in the document pane. Or from the selected tags in the Tags panel, create a tag to be a child tag under the focused tag.

**Find...** – Searches the page or document for artifacts, OCR suspects, unmarked comments/links/content, and add tags to found items.

**Copy contents to clipboard** – Copies the contents of the selected tags to clipboard.

**Edit Class Map**... – Chooses this option to add, change, and delete class maps for the document. Class maps store properties or attributes that are associated with elements.

**Edit Role Map**... – Chooses this option to add, change, and delete role maps for the document. For a document with a uniquely defined tag set which some screen reader or other assistive technology cannot read, you can map its custom tags to predefined tags in PhantomPDF so that these custom tags are easier to identify and edit.

**Tag Annotations** – Checks this option, and all new comments and form fields will be automatically added to the tags tree after the selected tag. The option is not
available for the existing comments and form fields.

**Document is Tagged PDF** – Flags the PDF as a tagged document. If unchecked, the flag will be removed.

**Apply Role Mapping to Tags** – Checks this option to switch to the source tag view to show the role mapped tags.

**Highlight Content** – Checks this option, and the content in the document corresponding to the selected tag in the Tags panel will be highlighted with a box around.

**Properties...** - Opens the **Object Properties** dialog box.

**Move a tag**

To move a tag in the Tags panel, do either of the following:

- Select the tag that you want to move and drag it to the desired location. The Line icon \( \text{•••} \) shows the place where the tag will be located as you drag the tag.
- Right-click the tag you want to move and choose **Cut** from the context menu. Then right-click a tag that you want to paste and choose **Paste** or **Paste Child**.

**Edit the tag properties**

To edit the tag properties, do the following steps:

1. Right-click the tag you want to edit and choose **Properties...**.
2. In the **Object Properties** dialog box, change the information as needed.

**Tips**: In the **Tags** panel, you can use Ctrl-Click to select multiple tags as you click, or Shift-Click to select a listed group of tags between the first and the last tag you click. Then you can move them or right-click them to do more actions.

**Find and tag unmarked elements**

If a PDF document contains untagged or unmarked elements, you can locate them in the logical structure tree and tag them by using the Find command. Steps are as follow:

1. Click the icon [ ] or [ ] on the navigation pane to open the **Content** panel or **Tags** panel.
2. Right-click on an element in the panel, and choose Find from the context menu.
3. In the Find Element dialog box, do the following:
   - Choose the element you want to find in the Find drop-down list.
   - Select where you want to search the element: page or document.
   - Click Find Next to search for the unmarked elements.
   - Click Tag Element to tag the unmarked element. And then click Close upon completion.

Add alternate text to tags for links, figures, and abbreviations

Alternate text, which is often used to make a document more accessible, is a description for document contents like images and interactive form fields. Screen readers cannot read these document contents, but can read the associated alternate text. For accessibility, you need to add alternate text and other supplementary information (like specific language) to tags for links, figures, and abbreviations in the document. With PhantomPDF, you can add the information to a tag in the Tags panel.

1. Right-click the <Link> tag, <Figure> tag, or the abbreviated term in the tags tree in the Tags panel, and choose Properties....
2. In the Object Properties dialog box, click the Tag tab.
3. Type text in the Alternate Text box. You can also edit other information as needed in the dialog box.
4. Click Close.

Tip: For figures, you can also set alternative text by using the Edit Alternative Text tool while in Touch Up Reading Order setting mode. Please refer to “Set Alternate text for figures” for details.

Check and correct table elements

You can view the table elements in the Tags panel and correct elements that are not correctly tagged with the Reading Order command.

1. Find the table tag <Table> in the Tags panel.
2. Check whether it is a correctly structured table which should meet either of the following structuring of table elements:
   - Each Table Row contains Table Header <TH> or Table Data <TD> cells, or both.
   - For <THead>, <TBody>, and <TFoot> sections, each of them contains Table Rows.
3. If the table's rows, columns, and cells appear in the document, but the table tag doesn't contain some of the elements mentioned above, tag the related element
with the **Reading Order** command. Alternatively, re-create the table in the authoring application and then convert it to a tagged PDF.

To set ColSpan and RowSpan attributes for table elements, please do as the following:

1. Right-click a `<TD>` or `<TH>` element in the **Tags** panel and choose **Properties...** from the context menu.
2. In the pop-up **Object Properties** dialog box, click **Edit Attribute Objects** in the **Tag** tab.
3. In the **Attributes** dialog box, select **Attribute Objects** and then click **New Item** to create a new Attribute Object dictionary.
4. Expand the created dictionary, select the Layout attribute, and click **Change Item**.
5. Change the Layout value to “Table” and click **OK**.
6. Then click the created dictionary and click **New Item**.
7. In the Add Key and Value dialog box, type “ColSpan” or “RowSpan” in the Key box, enter the number of columns or rows spanned in the Value box, choose Integer from the Value Type menu, and click **OK**.
Chapter 14 – Foxit Admin Console

Foxit Admin Console is a cloud-based portal that serves as a central location for administrators to manage Foxit products/services and entitled users across their entire organizations. After setting up and activating Admin Console based on the organization environment, the administrator can open the URL provided by Foxit and sign up an account to get started. The Admin Console allows administrators to do the following:

- View the summary of the licenses and products
- Configure the license keys
- Assign license keys to users
- Manage Foxit products
- Configure the internal update of packages (on-premise environments only)
- Configure mail server
- View the detailed reports on the uses and statistics of Foxit products
- Customize enterprise brand information
- View the administrator's action logs

For more information about Foxit Admin Console, please refer to Foxit Admin Console User Manual.
Chapter 15 – Print

Printing is a process for reproducing text and images. When you have finished reading a helpful article or designing a PDF form, you may need to send it to an inkjet or laser printer and print it out with custom page sizes. With this section, you can get the help to set options in the Print dialog box to ensure that the finished document appears as intended.

Print PDF documents

1. Make sure you have installed the printer successfully.
2. To print a single PDF document, open the PDF document with Foxit PhantomPDF, and then do any of the following:
   - Click the Print button on the Quick Access Toolbar.
   - Press the shortcut key Ctrl + P.
   - Choose File > Print.
3. To print multiple PDF documents, open Foxit PhantomPDF, and choose File > Batch print. In the Batch Print dialog box:
   - Click Add files to add PDF files that you want to print. In the Open dialog box, navigate through your local disk to select a local file, or click Open from ECM to select a file from ECM systems and cloud services including iManage Work, SharePoint, andOffice, OneDrive-Personal, Google Drive, ShareFile, DMSforLegal, Dropbox, Box, and eDOCS DM.
   - You can check Included all opened PDF Documents option to add all the opened PDF documents to the printing list.
   - After adding PDF documents, select a PDF document in the file list, and click Page Range Options to specify the page range to be printed. Foxit PhantomPDF allows users to print attachments including PDF, TXT, images and Microsoft Office files. Please check Include all attached option in the Page Range Options dialog box if you need to print the attachments.
   - In the Files for printing list, click Move up or Move down to change the printing order of the selected PDF document, or click Remove to remove the selected file from the list.
4. Specify the printer and other printing options in the pop-up dialog box. For more information, please refer to “Print Dialog”.
5. Click OK to Print.
Print a portion of a page

To print a portion of a page, you need to refer to the Snapshot command.

- Select the Snapshot command by choosing Home > Snapshot.
- Drag around the area you want to print.
- Right-click in the selected area > choose Print...; and then refer to the “Print Dialog”.

Print multiple pages with page thumbnails

To perform a quick print, you can select multiple pages from a document from the thumbnail list.

- Open the document that you want to print, and then click Pages button on the left navigation pane.
- Shift-click / Ctrl-click/ drag the mouse to select a range of page thumbnails from the document.
- Select Print Pages from the right-click menu, and then click OK.

Print from Bookmarks

You can choose to print PDF pages associated with the selected bookmarks from the Bookmarks panel in the navigation pane.

1. In the navigation pane, click the Bookmarks panel and select a bookmark you want to print. (Ctrl-click to choose multiple bookmarks.)
2. Right-click the selected bookmarks and choose Print Page(s) or Print Section(s) from the context menu.
   - Print Page(s): Only print the pages where the selected bookmarks (including child bookmarks) are.
   - Print Section(s): Print all the pages in the bookmarked sections (including child bookmarks).
3. In the Print dialog box, choose Foxit PhantomPDF Printer from the Name box and choose other printing options as needed. See “Print Dialog”.
4. Click Print. In the pop-up dialog box, specify the file name and its storage location, and click Save.
5. The generated PDF will be opened automatically after the printing process completes.
**Print tabs**

You can print one tab you are opening from the tab bar or print out all documents opened in the tab bar at a time.

1. Move the pointer to the tab bar.
2. Right-click it > Choose **Print Current Tab/Print All Tabs**.

**The Print dialog box**

The Print dialog is the final step before printing. You can modify the printer settings in this dialog as well. Be aware that changing the printer may affect the page setup if the new selected printer has a different paper size, for instance.

To open the Print dialog box, choose **File > Print**. Choose a printer from the menu at the top of the Print dialog box and specify the copies to print. Click **Properties** for more settings. (Refer to ”[Set Foxit PhantomPDF Printer Properties](#)”)

- **Collate** – Assembles the printouts in a proper numerical or logical order when printing several copies. This option is checked by default and will be disabled when printing just one copy.
- **Print as Grayscale** – Converts color images in the file to shades of gray.
- **Print as image** – Prints pages as bitmap images. If normal printing doesn’t work or doesn’t produce well, check this option.
- **Bleed Marks** – Places a mark at each of the four corners of the bleed box to indicate the PDF bleed box boundaries.
- **Preview** – Foxit PhantomPDF provides an instant preview in the Print dialog box. Drag the slider to preview each page.

**Print Range**

- ° Current view: Prints the visible page area in the current view.
- ° Current page: Print the current page only.
- ° All pages: Print all pages in the document.
- ° Pages: Specifies the page range you want to print. If your PDF contains formatted page numbers, and the **Use logical page numbers** option is enabled in **File > Preferences > Page Display**, you should enter the numbers that match the numbering on the pages rather than the physical page numbers. For instance, if you want to print the second page of your document which is numbered ii, you should enter ii to print the page. See also the preference setting on **logical page numbers**.
- ° Subset – Provides options for setting noncontiguous page range.
All Pages in Range – Prints all the pages within the specified range.
Odd pages only – Prints only pages with odd numbers within the specified range.
Even pages only – Prints only pages with even numbers within the specified range.

Note: This option is especially helpful for two-side printing.

- Reverse pages – Prints pages in reverse order. If page ranges are entered, the pages print opposite of the order in which they were entered. For example, if you select to print the document from page 5 to page 30, selecting Reverse pages option will print page 30 to page 5.

- Print Handling
  - Scale – None, Fit to Printer Margins, Reduce to Printer Margins and Custom Scale.
  - Choose paper source by PDF page size – Automatically selects the paper type according to the page size of the PDFs when printing.
  - Tile Large Pages – Tile the pages that are larger than the selected paper size at a specified scale.
  - Multiple Pages Per Sheet – multiple pages will be printed on the same sheet of paper. You can specify the settings like Pages Per Sheet, Page Order, Margins, etc.
  - Booklet – Booklet printing enables to print multiple pages on the same sheet of paper in correct order if the pages are folded. This requires the printer support to print on both sides.

- Print on both sides of paper – To print double-sided pages, enable this option and choose the desired orientation.
- Auto-Rotate – Adjusts the PDF document’s orientation to match the orientation specified in the printer properties.
- Auto-Center – Places the PDF pages in the center.
- Orientation – Selects a page orientation to print the document in. If Auto portrait/landscape is selected, the printer will automatically adjust the page orientation based on the page size and the paper size. For example, with the page height larger than the page width, the printer will print the page in portrait orientation, and vice versa. The Choose paper source by PDF page size option in Page Handling overrides the Auto portrait/landscape option here.
- Print What – Specifies to print documents only, annotations only, or both.

- Document – Prints the document contents and form fields, not including annotations.
Document and markups – Prints document contents, form fields, and annotations. If you also need to print notes and pop-ups associated with comments, please make sure that you check the **Print notes and pop-ups** option in **Commenting Preferences**.

Document and stamps – Prints all document contents, form fields, and stamps, not including other markups (like note comments).

Form fields only – Prints interactive form fields only.

- **Summarize Comments** – Prints the summarized comments to a separate and printable PDF file named “CommentsSummaryPrint.pdf”. See also “**Summarize Comments**”.

- **Output**

  Simulate Overprinting – Simulates the blending and overprinting of colors in the color-separated output.

- **Advanced** – Provides an option to auto-detect printers that support PCL for PCL optimization to improve the printing speed.

Print Optimization allows you to optimize print jobs from a PCL driver, for features such as font substitution or scanning for vertical and horizontal rules. Foxit PhantomPDF provides an option to auto-detect printers that support PCL for PCL optimization to improve the printing speed. To enable print optimization, please follow the steps below:

1. Choose **File > Print** to open Print dialog.
2. Click **Advanced** on the left lower corner of the **Print** dialog.
3. In the **Advanced** dialog, do the following:
   - Select a printer from Printers list, and click **Add** to add the selected printer to PCL Drivers list.
   - Check one of the optimization options (**Use <PCL_level> Driver for <PCL_level> Printers** option) based on your printer driver level.
   - Click **OK**.

Then you can execute printings with the optimized driver. And you can also remove the printer from the PCL Drivers list if you are not satisfied with the printing results it delivers. Just select the driver to be removed from the PCL Drivers list, click **Remove** and then choose **OK** to confirmation the operation.

**Tip**: To enable PCL print optimization, please make sure that the **Use GDI+ Output for all types of printer** option in **the Print preferences** is unchecked. Otherwise,
settings in printer preferences will prevail and GDI++ device will be used for printing for all types of printers.

**Set Foxit PhantomPDF Printer Properties**

Before creating a PDF file with Foxit PhantomPDF Printer, you may wish to access PDF printing preferences to set up options for your PDF files. To access PDF printing preferences of Foxit PhantomPDF Printer, you need to open the Foxit PhantomPDF Printer Properties dialog box by doing either of the following:

- **Accessing the PDF printing Preferences from Control Panel:**
  1) For Windows 8 and 10, go to **Start > Windows System > Control Panel > Hardware and Sound > Devices and Printers > Printers**. For Windows 7, go to **Start > Control Panel > Devices and Printers > Printers and Faxes**.
  2) Right-click on the Foxit PhantomPDF Printer and then select **Printing preferences** to open the **Foxit PhantomPDF Printer Properties** dialog box.

- **Accessing the PDF Printing Preferences from the Print dialog box.** When you print a file and open the Print dialog box, simply click on the **Properties** button, you can bring up the **Foxit PhantomPDF Printer Properties** dialog box.

In the **Foxit PhantomPDF Printer Properties** dialog box, specify settings as needed in the **Setting** tab and the **Layout** tab.

**The Setting tab**

- **Foxit Conversion Settings** – Shows the description of the default setting you select in the **Default Settings** menu.
- **Default Settings** - chooses a type of conversion quality as the default setting. There are five predefined sets of default settings shown as below. You can click **Edit** to create and modify your own default settings as needed. See also **Create and modify your own default settings**.
  - **High Quality Print**: creates PDF files for high quality print but with relatively large file sizes.
  - **PDF/A-1b**: creates PDF files in compliance with PDF/A-1b standard.
  - **Smallest File Size**: creates PDF files used for web distribution.
  - **Standard**: creates PDF files with a balance between print quality and file size.
  - **USPTO**: creates PDF files that are compliant with USPTO (the United States Patent and Trademark Office) standards.
- **Target Folder** – You can click **Browse** to specify a default destination folder to
store all of the PDF files generated, and the names of the generated PDF files will be the same as the originals by default. If no target folder is specified, a dialog box will prompt for you to specify a name and location for the PDF.

- **If File Exists** – If a PDF file that has the same name and path as the generated PDF file already exists, you can overwrite the existing file, add a numeric suffix to the name of the generated document automatically to avoid overwriting the existing files, or choose **Prompt User** to be prompted to rename the file.

- **Color** – Prints content in a color PDF file to shades of gray, in colors or only in black and white colors.

- **Resolution** - allows you to input a DPI (dot per inch) level for image resolution. The valid level value is between 72 -2400.

- **View PDF Results** – Once the conversion is finished, the converted PDF will be opened with PhantomPDF automatically. This option is checked by default.

### Create and modify your own default settings

1. In the **Setting** tab of the **Foxit PhantomPDF Printer Properties** dialog box, select a set of default settings.
2. Click the **Edit** button to specify the conversion settings in the seven tabs in the pop-up dialog box. See also **Options of default settings for PDF conversion**.
3. After you complete the settings, click **OK** to save the modification to the current set of default settings or click the **Save As...** button to save the modified settings as a new set of default settings which will be added to the **Default settings** list. The predefined sets of default settings cannot be modified.
4. (Optional) To toggle between different sets of default settings, click the **Edit Settings** button and select one.

### Options of default settings for PDF conversion

- **The General tab**
  - **Description** – Enter a summary for the current conversion setting.
  - **Optimize for fast web view** – Creates a linearized PDF that can be opened and viewed even before the whole file is downloaded.
  - **Compatible With** - With Foxit PhantomPDF, you can choose the version number from 1.3 to 1.7 when creating PDFs. Choosing the right PDF reference version can help the PDFs to be better compatible with different PDF viewers.
  - **Add PDF information to the document** – This option allows you to set PDF document properties, such as Title, Subject, Author, etc. You can add information when it is checked.
The Font tab

Embedding all fonts allows anyone who opens your file to see the document as you intended it to be seen. Select an option as needed to specify whether to embed fonts.

- Embed all fonts – Embed all fonts to generated PDFs. This option is selected by default.
- Embed nonstandard fonts – Embed fonts except the standard fonts (including typically Arial, Times New Roman, Courier, and Symbol).
- Use the font embedding list below – Embed the fonts listed in the box below, where you can select the fonts you want to embed.
- Don’t embed any fonts – No fonts will be embedded into the generated PDFs. Without embedding fonts, the PDF viewer will substitute a font with a close match or a default font which is available on the computer, and the display results may be not exactly what you intended.

Show warning message when the document contains fonts that are not allowed to be embedded: Some font manufacturers place embedding restrictions on their fonts. Foxit PhantomPDF honors these restrictions and will show a warning message when your document contains the fonts that are not allowed to be embedded.

The Images tab

Specify the image conversion settings. See also Compress Images in advanced PDF optimization.

The PDF Standards tab

Select a PDF standard as needed from the menu under which there is the corresponding description for your reference.

The Watermarks tab

Add watermarks to the document – If you want to add watermarks to your document, you can select this option and choose to add Image Watermarks or Text Watermarks.

Image watermarks – You can browse your computer for an image and change the Opacity, Rotation and Offsets of the image which will be added into your document as a watermark.

Text Watermarks

- Font
This option is activated only when Text Watermarks is selected and you can choose the font name, font size and font color from the drop-down menus.

- **Text**
  You can enter text in the **Content** box and change the **Opacity** and **Rotation** of the text which will be added into your document as a watermark.

- **Offsets**
  This option allows you to change the unit of measurement and specify the width, height of the image/text, etc.

- **Scale**
  A. To resize the watermark in relation to the original image size, check **Absolute Scale** and enter a number in the percentage box.
  B. To resize the watermark in relation to the PDF page dimensions, check **Relative Scale** and enter a number in the percentage box.

- **Preview**
  You can see how the watermark will look like with the selected options.

✧ **The Headers/Footers tab**

**Add Headers/Footer to the Document**

This option allows you to add headers/footers to your PDF document. By checking this option, the following options will be activated.

- **Font**
  You can choose the font name, font size and font color from the boxes.

- **Edit**
  This option allows you to edit headers/footers and you can specify their styles. You can enter text in the columns (**Left Column**, **Center Column** and **Right Column**) if needed. Click **Insert Date** to insert date to the PDF document. Click **Insert Page Number** to insert page number to the PDF document.

- **Offsets**
  This option allows you to change the unit of measurement and specify the margins for all 4 sides.

- **Preview**
  You can see how the headers/footers will look with the selected options.
The Security tab

The security feature of PDF gives you exceptional control over PDF files. Choose a protection type.

1. Password Protection

See also Password Protection in the Security chapter.

2. Certificate Protection

See also Certificate Protection in the Security chapter.


See also AIP Protect in the Security chapter.

Layout tab

- **Orientation** - Allows you to change the page orientation.
- **Page Size** - This option is for you to choose one of paper types from the list, or click Custom Page Size and then add a new page size where you can specify the paper size dimensions in the Add/Edit Custom Page Sizes box.
- **Unit of Metrics** - Allows you to change the unit of measurement, including inches, centimeter and millimeters.
- **Image Scaling** – Scale the page content equally based on the specified page size.

You can see how your document layout will look with the selected options.
Chapter 16 – Appendices

This section is a collection of supplementary materials for this user manual as well as Keyboard Shortcuts, and Command Lines.

- Quick Installation Guide
- SharePoint Configuration
- Web Service Configuration
- Shortcut Keys
- Command Lines

Quick Installation Guide

This section gives you an overview of Foxit PhantomPDF, including installation, activation, uninstallation and update.

Installation, Activation, Deactivation, and Uninstallation

Installing Foxit PhantomPDF

- System Requirements

Operating Systems

- Windows 7 (32-bit & 64-bit).
- Windows 8.x Full Version.
- Windows 10.
- Microsoft Office® 2007 or later version (required for some PDF creation features).
- Verified as Citrix Ready® with Citrix XenApp® 7.13.

Recommended Minimum Hardware for Better Performance

- 1.3 GHz or faster processor.
- 512 MB RAM (Recommended: 1 GB RAM or greater).
- 2G of available hard drive space.
- 1024*768 screen resolution.
- Supports 4K and other high-resolution displays.
How to Install

The installer format of Foxit PhantomPDF can be EXE or MSI. Please download the installer to your computer, and then do the following (Take Business Edition for example):

For an EXE installer:

1. Double-click the EXE file, and you will see the setup wizard pop up.
2. Foxit PhantomPDF is protected by copyright law, so in order to proceed, you must accept the License Agreement. Check the Agree with the License Agreement box to continue.
3. You can click Quick Install to start the installation immediately with default settings, or click Advanced Setting and do the followings to customize your installation:
   A) Click on the horizontal three-dot icon to change the installation directory.
   B) (Optional) Choose a language you want to install from the Language box.
   C) In the Settings tab, select the options you would like the setup to perform.
   D) In the Components tab, select the options you want to install.
   E) (Optional) Click Back to go back to the previous step.
   F) Click Install to start the installation.
4. When the process is complete, a dialog box will notify the user that Foxit PhantomPDF is successfully installed. You can click Start now to run the application right after installation.

For an MSI installer:

1. Double click the MSI file, and you will see the setup wizard pop up. Click Next to continue.
2. Foxit PhantomPDF is protected by copyright law, so in order to proceed, you must accept the License Agreement. Check the I accept the terms in the License Agreement box to continue.
3. There are two installation setup types for Foxit PhantomPDF. The user has the ability to change the installation directory or to keep the default settings.
   Typical — Installs all features by default, which requires more disk space.
   Custom — Allows users to choose which program features will be installed.
4. For Typical Setup, just click Install. For Custom Setup, do the following:
   A) Click on “Browse” to change the installation directory of the PDF Viewer plug-in.
   B) Click “Disk Usage” to check the disk space available for the selected features.
   C) Check the options you want to install and click “Next” to continue.
   D) Select the additional tasks you would like the Setup to perform, then click “Install” to start the installation.
5. When the process is complete, a dialog box will notify the user that Foxit PhantomPDF is installed. You can choose to check the **Launch Foxit PhantomPDF** box to run the application right after installation. Click **Finish** to complete the installation.

✧ **Command-line Installation**

You can also use the command-line to install the application:

```command
msiexec /Option <Required Parameter> [Optional Parameter]
[PROPERTY=PropertyValue]
```

For more detailed information on msiexec.exe, as well as required and optional parameters, type “msiexec” in the command line or visit Microsoft TechNet Help Center.

**Public Properties of the Foxit PhantomPDF MSI Installation Package.**

Foxit PhantomPDF installation properties supplement the standard MSI public properties to give administrators greater control over the installation of the application.

For the complete list of standard public properties, please refer to:


The Foxit PhantomPDF properties are:

```
-------------------------------------------------------------------------
| ADDLOCAL             | <list of features> | The value of the ADDLOCAL property is a comma- delimited list of features that the installation of Foxit PhantomPDF will make locally available. Foxit PhantomPDF installer is composed of the following features: |
| FX_PDFVIEWER         | - Foxit PDF Viewer and its components. |
| FX_FIREFOXPLUGIN     | - A plugin used for opening PDF files in Mozilla Firefox, Opera, Safari, and Chrome browsers. This feature requires FX_PDFVIEWER to be installed. |
| FX_SPELLCHECK        | - A tool used for searching any misspelled words in typewriter or form filler mode. This |
```

392
tool also suggests the correct spelling for common mistakes. This feature requires FX_PDFVIEWER to be installed.

**FX_PDFA** – A module used for verifying compliance with PDF/A-1a and PDF/A-1b. This feature requires FX_PDFVIEWER to be installed.

**FX_OCR** – A module used for making scanned or image-based PDF documents selectable and searchable. This feature requires FX_PDFVIEWER to be installed.

**FX CREATOR** - Foxit PhantomPDF Creator installs a virtual printer on your system. Creator can convert any printable documents into high-quality PDFs conveniently and efficiently. This feature requires FX_PDFVIEWER to be installed.

**FX_CONVERTTEXT** - Shell extension used for converting PDFs or combining supported files from the right click menu. This feature requires FX_CREATOR to be installed.

**FX_CREATORWORDADDIN** - MS Word toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATOREXCELADDIN** - MS Excel toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATORPPTADDIN** - MS PPT toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATOROUTLOOKADDIN** - MS Outlook toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_SE** - Plugins for Windows Explorer and Windows shell. These extensions allow PDF thumbnails to be viewed in Windows Explorer, and PDF files to be previewed in Windows OS and Office 2007 (or a later
version). This feature requires FX_PDFVIEWER to be installed.

**FX_IFILTER** – Foxit PDF IFilter is a plugin for Windows search engines that can help search PDF documents quickly.

**FX_CONNECTEDPDF** – A plugin that provides ConnectedPDF features including creation, sharing, securing, and tracking of PDF documents worldwide.

**FX_BROWSERADDIN** - The web browser plugin used for converting web pages to PDFs.

**INSTALLLOCATION** Specifies the folder location of the product installed.

**MAKEDEFAULT** Default value of "1", Foxit PhantomPDF will be set as the default application for opening PDF files.

**VIEW_IN_BROWSER** Default value of "1", Foxit PhantomPDF will be configured to open PDF files inside browsers.

**DESKTOP_SHORTCUT** Default value of "1", installer will place a shortcut for the installed application on the Desktop.

**STARTMENU_SHORTCUT** Default value of "1", installer will create a program menu group for installed application and its components.

**SETDEFAULTPRINTER** Default value of "1", installer will install Foxit PhantomPDF Printer and set it as the system’s default printer.

**LAUNCHCHECKDEFAULT** Default value of "1", Foxit PhantomPDF will check if Foxit PhantomPDF is the default reader when launched.

**KEYPATH** Specifies a license key file and saves it to the PhantomPDF installation folder.

**REMOVENEWVERSION** Forces an installation to overwrite the newer version of Foxit PhantomPDF with the value of “1”.

**CLEAN** Executes with the command “/uninstall”, removing all of PhantomPDF’s registry data and related files with the
value of “1”. (Note: This is a command for uninstallation.)

AUTO_UPDATE

Does not download or install updates automatically with the value of “0”; automatically checks for updates and downloads updates if any, but lets users choose when to install them with the value of “1”; automatically installs updates with the value of “2”. The default value is “1”.

CPDF_DISABLE

Disables the ConnectedPDF features by setting the value to “1”.

EDITION

Specifies an edition to install Foxit PhantomPDF, including Standard and Business.

NOTINSTALLUPDATE

Does not install updates by setting the value to “1”. This will prevent Foxit PhantomPDF from being updated from within the software.

INTERNET_DISABLE

Disables all features that require Internet connection by setting the value to “1”.

READ_MODE

Opens PDF file in Read Mode by default in web browsers by setting the value to “1”.

DISABLE_UNINSTALL_SURVEY

Stops the Uninstall Survey after uninstallation by setting the value to “1”.

KEYCODE

Activates the application by key code.

EMBEDDED_PDF_INOFFICE

With the value of “1”, opens embedded PDF files in Microsoft Office with Foxit PhantomPDF if Acrobat and Foxit Reader is not installed. (For the EXE installation package, inputs the command-line /displayadobeindoc.)

ADVERTISE

Usually used together with "ADDLOCAL" to advertise the specified features.

Command-line Examples:

1. Silently install the application (no user interaction) to folder "C:\Program Files\Foxit
Chapter 16: Appendices

Software:

```
msiexec /i "Foxit PhantomPDF.msi" /quiet INSTALLLOCATION="C:\Program Files\Foxit Software"
```

2. Install the Foxit PDF Viewer only:

```
msiexec /i "Foxit PhantomPDF.msi" /quiet ADDLOCAL="FX_PDFVIEWER"
```

3. Use the license key file saved in disk C to activate the application when running the setup:

```
msiexec /i "Foxit PhantomPDF.msi" KEYPATH="C:\fpmkey.txt"
```

4. No installation of Foxit PhantomPDF Printer:

```
msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL, ADVERTISE="FX_CREATOR" /qn
```

5. Force an installation to overwrite the same or higher version of Foxit PhantomPDF:

```
msiexec /i "Foxit PhantomPDF.msi" REMOVENEWVERSION="1"
```

6. Remove registry and user data when performing silent uninstallation:

```
msiexec /x "Foxit PhantomPDF.msi" /quiet CLEAN="1"
```

7. Install the application without ConnectedPDF related features and services:

```
msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL,
ADVERTISE="FX_CONNECTEDPDF"
```

8. Activate the application by key code:

```
msiexec /i "Foxit PhantomPDF.msi" KEYCODE="your key code"
```

9. Install the application without Foxit PhantomPDF Create PDF Toolbar

```
msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL,
ADVERTISE="FX_BROWSERADDIN"
```
Chapter 16: Appendices

Activating Foxit PhantomPDF

After launching Foxit PhantomPDF, the activation wizard pops up. If you have already purchased a license for Foxit PhantomPDF, click Activate to activate Foxit PhantomPDF. If not, you can click Buy Now to purchase Foxit PhantomPDF from the Foxit website. If you choose Free Trial, you will be given a 14-day free trial period to use Foxit PhantomPDF. When the free-trial period expires, only the free features are available.

- If you have purchased subscription licensing, after clicking Activate, you can choose to sign in your Foxit account. After successfully signed in, the Foxit PhantomPDF will be activated automatically.
- If you have purchased a perpetual license, please follow the steps below to activate Foxit PhantomPDF:
  1. After clicking Activate, input the code of the registration key. (You can activate the key at a later time from Help > Activate when you run Foxit PhantomPDF.) Then click Activate to continue.
  2. (Optional) If you didn't provide your name when purchasing the license, you'll be prompted to type your name.
  3. If the activation is successful, a message box will pop up. Click OK.
  4. You should restart the application for the changes to take effect. To restart it now, please click OK; or click Cancel to restart later.

Note: If your PhantomPDF is managed by Foxit Admin Console (a cloud-based portal that serves for administrators to manage Foxit products/services in an organization), there will be a prompt window to let you activate it for further use, depending on the activation mode defined by Admin Console. You need to contact your administrator for the activation. See also Foxit Admin Console.

Deactivating Foxit PhantomPDF

You can deactivate Foxit PhantomPDF on one machine in order to activate on another. After deactivation, you can still use the features of Foxit PhantomPDF Express. To deactivate Foxit PhantomPDF, click Help > Deactivate.

Uninstalling Foxit PhantomPDF

How to Uninstall

397
Please do one of the following:

- Click **Start > All Programs > Foxit PhantomPDF > Uninstall**.
- For Windows 8 and 10, click **Start > Windows System > Control Panel > Programs > Programs and Features** > Select Foxit PhantomPDF and click **Uninstall**. For Windows 7, click **Start > Control Panel > Programs and Features** to uninstall it.
- Double-click the **Uninstall** shortcut under the Foxit PhantomPDF installation directory drive name: `\..\Foxit Software\Foxit PhantomPDF\`

**Foxit PhantomPDF Add-ons**

Foxit PhantomPDF provides separate add-ons for you to download on demand. These add-ons fall into critical add-ons and advanced add-ons. Most of add-ons, including JPEG2000/JBIG Decoder, Spell Checker and Firefox Plugins, have been integrated into Foxit PhantomPDF package, so users don’t need to install them again after the installation of Foxit PhantomPDF. But if there’re any upgrades of those add-ons, users can go to **Help > Check for Updates** to download and install the latest add-ons.

**Critical Add-ons**

Critical add-ons are essential components for proper display and execution.

**Free Critical Add-ons in Foxit PhantomPDF**

<table>
<thead>
<tr>
<th>Name</th>
<th>Function Description</th>
<th>Size</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi-langue OCR Text Recognition Engines</td>
<td>Enables selecting and searching text in scanned or image-based PDFs. This add-on supports multi-language: Portuguese, Polish, Russian, Japanese, Korean, Simplified Chinese &amp; Traditional Chinese, Turkish and Dutch, etc. (For Chinese, Japanese and Korean, you should download from our website, and the others have been integrated into Foxit PhantomPDF package.)</td>
<td></td>
<td>Download</td>
</tr>
</tbody>
</table>

**NOTE:** To manually install a critical add-on, please extract it to the same directory where you install Foxit PhantomPDF. **See also “Updating Foxit PhantomPDF”**.


**Purchasing Foxit PhantomPDF**

Foxit PhantomPDF provides two licensing models: perpetual licensing and subscription licensing. The former allows users to use PhantomPDF without expiration dates, while the latter enables users to pay for a monthly/yearly usage fee, with full features available for both.

To purchase Foxit PhantomPDF, please do one of the following:

1. Order online: go to Foxit website to order directly: [http://www.foxitsoftware.com/shopping](http://www.foxitsoftware.com/shopping)
2. Email: write an e-mail to the Foxit sales department at sales@foxitsoftware.com with your order information.
3. Click HELP/HOME > Purchase in the PhantomPDF toolbar to purchase a license from the Foxit online store.
4. Click HELP/HOME > Subscribe in the PhantomPDF toolbar to quickly purchase a non-perpetual license or renew the subscription if the previous one ends. The licensee has the rights to manage the authorized machines by clicking Manage to disable current activation(s). (*Note: Internet connection and Foxit account signed-in are required to use the full features for subscribed users.*)

**Updating Foxit PhantomPDF**

Foxit PhantomPDF along with its add-ons can be updated in several ways. Some updates are available if you open a PDF document that triggers the updating process. For example, if you open a file that is encrypted with the FileOpen software, Foxit PhantomPDF will ask if you want to download the FileOpen plugin. Other updates are available only from the Help menu, where you have to manually install them. However, all updates can be downloaded directly from Foxit website. Foxit PhantomPDF supports auto-update checking. By default, with any update to the application or plugins detected, Foxit PhantomPDF will prompt users to update. You can change the default preference setting for updating Foxit PhantomPDF in File > Preferences > Updater.

**Updating from the Help Menu**

You can check for updates yourself anytime by the following steps:

1. Choose Help > Check for Updates.
2. In the pop-up dialog box, select updates from the column on the left, and click
Add to move them to the right column. Only the updates and components appropriate for your product will be listed. Click Next to download and install the update.

Updating from Foxit Website

2. Select and download the files or add-ons you want to update.
3. Extract them to the same directory where you installed Foxit PhantomPDF.
4. Re-run the Foxit PhantomPDF program to implement the update files.

Help & Support

User Manual

If you have trouble finding help for a particular topic or the help provided is not sufficient, enter a trouble ticket via our Support Portal and our support team will contact you. Your feedback helps us to improve our documentation.

Ticket Support

Visit Foxit Ticket Support System by choosing Help > Post Your Idea, to send your bug report/suggestion/comment directly to Foxit Customer Support Center.

On-Line Support

Our ticket support system is staffed with product experts round the clock to provide you with fast and efficient answers to all of your technical questions. Plus, our on-line user forums provide a wealth of information.

Foxit Forum

Visit Foxit forum at http://forums.foxitsoftware.com/ to see if you can find the answer to your questions there immediately.
SharePoint Configuration

Before using the check in/check out features in Foxit PhantomPDF, please configure the SharePoint Server.


- **SharePoint 2007**: Copy the downloaded GIF file to "Drive:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\Images".

**SharePoint 2010**: Copy the downloaded GIF file to "Drive:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\Images"

- **SharePoint 2007**: Edit the file “Drive:\Program Files\Common Files\Microsoft Shared\Web server extensions\12\Template\Xml\DOCICON.XML”.

**SharePoint 2010**: Edit the file “Drive:\Program Files\Common Files\Microsoft Shared\Web server extensions\14\Template\Xml\DOCICON.XML”.

To edit the file, please refer to the following steps:

a. Right-click DOCICON.XML file > click Open With > select Notepad.

b. Add an entry for the file with .pdf extension and take it as the file’s name. For example, type the ICPDF as the name of the .gif file:

   ```xml
   <Mapping Key="pdf" Value="pdficon.gif"
   OpenControl="FoxitPhantomPDF.OpenDocuments"/>
   ```
c. Click Save on the File menu, and then quit Notepad.

- Perform an iisreset:
  
  a. Click Start > Run > type “cmd” in the Open dialog box> click OK > type “iisreset” in the command prompt window> click Enter.
  
  b. Close the windows.

**Web Service Configuration**

To use the features of dynamic revocation, number of accesses and number of prints (additional access rights control), you should configure the web service and SQL first. Please follow the steps as below:
1. Configure the Web Service on your on-premise AIP server.

   a) Log on AIP server as Administrator.
   b) Download the Web Service zip from:

   For X86:
   
   http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/WebService_32.zip

   For X64:
   
   http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/WebService_64.zip

   c) Unzip the Web Service zip and get the fxrmsext from it.
   d) Copy the fxrmsext to C:\inetpub\wwwroot\_wmcs.

   e) Run “Internet Information Services” (IIS).
   f) Right-click “_wmcs”, and then choose “Add Application…”.

   g) Input the following information into the Add Application dialog box.
h) To avoid repeated authentication, we should disable the Windows Authentication and enable the Anonymous Authentication. Click “fxmsext” in Connections Pane, and then double-click “Authentication”.

**NOTE:** For data communication security, PDFs will be encrypted with AES algorithm by default.

i) Enable the “Anonymous Authentication” and disable the “Windows Authentication”.
2. Configure the SQL.

   a) Navigate to C:\inetpub\wwwroot\_wmcs\fxrmsext.
   b) Right-click “Web.config” file -> “Open with” -> “Notepad”.
   c) If you want to log on to the SQL Server through Windows Authentication, you just need to alter the SQL Server information by inputting the IP address or computer name and then saving the change.

   ```xml
   <add key="MyDB" value="Server=SQL2005; DataBase=RMSExtService; Integrated Security=SSPI; Persist Security Info=False" />
   ``

   **NOTE:** If the computer name include '-', please ensure you are using SQL 2012 version or higher.
   d) If you want to log on to the SQL Server through SQL Server Authentication,
please follow the steps:

i. Copy “Server=SQL2005; DataBase=RMSExtService; User ID=myUsername; Password=myPassword”.

ii. Paste and replace “Server=SQL2005; DataBase=RMSExtService; Integrated Security=SSPI; Persist Security Info=False”.

iii. Alter the SQL Server information. You can input the IP address or the computer name.

iv. Alter the “User ID” and “Password”.

v. Save changes.

e) Create the database and tables.
   i. Log on to the SQL Server as Administrator.
   ii. Get the .sql file from the Web Service zip you downloaded before.
   iii. Double-click this file to create the database and tables, and then click “Execute”.

f) Grant AIP administrator the database operations rights.
   i. Open “Internet Information Services” (IIS).
   ii. Click “Application Pools” in Connections Pane. Then you can get the
account information from Identity column.

iii. Open SQL Server management.


v. Check if the AIP administrator account is listed.

If yes, skip to Step vi.
If not, right-click “Logins”, then click “New Login”.
vi. Grant AIP administrator as the database owner.
g) Set up the firewall.
   i. In SQL Server Configuration Manager, expand SQL Native Client Configuration, and click “Client Protocols” and right-click “TCP/IP Properties” to get the default port.

ii. Run “Windows Firewall” and click “Advanced settings”.


iii. Click “Inbound Rules”.

iv. Click “New Rule...”.
v. Select “Port” and then click “Next”.

vi. Select “TCP”, then select “Specific local ports”, type the SQL port number, and click “Next”.
vii. Select “Allow the connection”, and then click “Next”.

viii. Choose when to apply the rule.
ix. Specify the name and description of the rule and then click “Finish”.

![New Inbound Rule Wizard](image)

![New Inbound Rule Wizard](image)
Work with PhantomPDF via VBA scripts in Microsoft Office

Foxit PhantomPDF allows you to use VBA scripts in Microsoft Office to automate PDF tasks, including PDF creation, form filling, and adding watermarks. This section offers instruction on preparation and settings before you use VBA scripts to perform PDF tasks with Foxit PhantomPDF (including PhantomPDF’s add-in in Microsoft Office).

Prepare Microsoft Office

With similar operations in Office versions, take Excel 2016 for example. In Excel 2016, there is no Developer tab on the ribbon by default. To add the tab, click File > Options > Customize Ribbon in Excel 2016, and check Developer in Main Tabs on the right part of the Excel Options dialog box, as the screenshot shown below.
Then you can see the **Developer** tab on the Ribbon.

## Configure the VBA Editor

Open the VBA Editor (i.e. the “Microsoft Visual Basic for Applications” dialog box) in Excel first. There are three methods to open the VBA Editor:

1. Press shortcuts **Alt+F11**.
2. Click **Visual Basic** in the **Developer** tab.
3. Right-click a sheet and choose **View Code** in the context menu.

The VBA Editor pops up to continue.

Click **Tools** > **References**, and check **FoxitPDFCreatorForOffice** and
FoxitPhantomPDF 10.0 Type Library in the pop-up dialog box shown as the screenshot below. Click OK to exit the dialog box.

Click View > Object Browser in the VBA Editor. In the pop-up dialog box, click the <All Libraries> box and you can see FoxitPDFCreatorForOffice and FoxitPhantomPDF have been successfully referenced.

Now we've completed all necessary preparation and settings. For the API reference to communicate with PhantomPDF (including PhantomPDF's add-in in Microsoft Office),
please refer to [API Reference for Application Communication](#).

### Keyboard Shortcuts

There are number of keyboard shortcuts that you can use to speed up your navigation within the Foxit PhantomPDF. You can both use the default keyboard shortcuts and customize your own shortcuts.

To customize the keyboard shortcuts, please do as below:

Right-click any area on the ribbon and choose *Customize Quick Access Toolbar* .... In the pop-up Customize Tools dialog box, choose *Keyboard* tab.

Some particularly important ones are listed here.

#### File Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open File</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Close File</td>
<td>Ctrl + W, or Ctrl + F4</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Close All</td>
<td>Ctrl + Shift + W</td>
</tr>
<tr>
<td>Print a Document</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Exit Foxit PhantomPDF</td>
<td>Ctrl + Q, or Alt+F4</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Create PDF from file</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Document Properties</td>
<td>Ctrl + D</td>
</tr>
</tbody>
</table>

#### View Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Screen</td>
<td>F11</td>
</tr>
<tr>
<td>Exit Full Screen Mode</td>
<td>ESC, or F11</td>
</tr>
<tr>
<td>Switch to Text Viewer</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl + +</td>
</tr>
</tbody>
</table>

---

417
### Chapter 16: Appendices

<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom Out</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td>Zoom To</td>
<td>Ctrl + M</td>
</tr>
<tr>
<td>Actual Size</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>Fit to Page</td>
<td>Ctrl + 0</td>
</tr>
<tr>
<td>Fit Width</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>Fit Visible</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Rotate Clockwise</td>
<td>Ctrl + Shift + Plus</td>
</tr>
<tr>
<td>Rotate Counterclockwise</td>
<td>Ctrl + Shift + Minus</td>
</tr>
<tr>
<td>AutoScroll</td>
<td>Ctrl + Shift + H</td>
</tr>
<tr>
<td>Stop AutoScroll</td>
<td>ESC</td>
</tr>
<tr>
<td>Switch between tabs</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>View file in read mode</td>
<td>Ctrl + H</td>
</tr>
<tr>
<td>Preview page by page in Print Preview</td>
<td>Page Up/Down</td>
</tr>
<tr>
<td>Go to Page</td>
<td>Ctrl + G</td>
</tr>
<tr>
<td>First Page</td>
<td>Ctrl + Home</td>
</tr>
<tr>
<td>Previous Page</td>
<td>Ctrl + Page Up</td>
</tr>
<tr>
<td>Next Page</td>
<td>Ctrl + Page Down</td>
</tr>
<tr>
<td>Last Page</td>
<td>Ctrl + End</td>
</tr>
<tr>
<td>Previous View</td>
<td>Alt + Left</td>
</tr>
<tr>
<td>Next View</td>
<td>Alt + Right</td>
</tr>
<tr>
<td>Marquee Zoom</td>
<td>Alt + 5</td>
</tr>
<tr>
<td>Read Current Page</td>
<td>Ctrl + Shift + V</td>
</tr>
<tr>
<td>Read from Current Page</td>
<td>Ctrl + Shift + B</td>
</tr>
<tr>
<td>Stop</td>
<td>Ctrl + Shift + E</td>
</tr>
<tr>
<td>Rulers</td>
<td>Ctrl + R</td>
</tr>
<tr>
<td>Show or hide Navigation pane</td>
<td>F4</td>
</tr>
</tbody>
</table>

### Edit Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl + C, or Ctrl + Insert</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
</tr>
</tbody>
</table>
Chapter 16: Appendices

<table>
<thead>
<tr>
<th>Tool Keys</th>
<th>Document Keys</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Paste</strong></td>
<td><strong>Result</strong></td>
</tr>
<tr>
<td><strong>Undo (Undo an action)</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Redo (Redo or repeat an action)</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Select All (Select all items in a document or window)</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Add Bookmark</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Preferences</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Go to fillable field by tab order</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Go to fillable field by tab in reversed order</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
<tr>
<td><strong>Duplicate pages</strong></td>
<td><strong>Shortcut</strong></td>
</tr>
</tbody>
</table>

### Tool Keys

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hand Tool</td>
<td>Alt + 3</td>
</tr>
<tr>
<td>Select Text and Image</td>
<td>Alt + 6</td>
</tr>
<tr>
<td>Snapshot</td>
<td>Alt + 7</td>
</tr>
<tr>
<td>Find Text (Open the Navigation task pane to search document.)</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>Find Next</td>
<td>F3</td>
</tr>
<tr>
<td>Find Previous</td>
<td>Shift + F3</td>
</tr>
<tr>
<td>Search</td>
<td>Ctrl + Shift + F</td>
</tr>
</tbody>
</table>

### Document Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Down</td>
<td>Space</td>
</tr>
<tr>
<td>Page Up</td>
<td>Shift + Space</td>
</tr>
<tr>
<td>Expand the selected area to the next character on the right</td>
<td>Shift + Right</td>
</tr>
<tr>
<td>Expand the selected area to the next character on the left</td>
<td>Shift + Left</td>
</tr>
<tr>
<td>Expand the selected area to the end of a word</td>
<td>Ctrl + Shift + Right</td>
</tr>
</tbody>
</table>
Chapter 16: Appendices

<table>
<thead>
<tr>
<th>Expand the selected area to the beginning of a word</th>
<th>Ctrl + Shift + Left</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand the selected area to the end of a row</td>
<td>Shift + End</td>
</tr>
<tr>
<td>Expand the selected area to the beginning of a row</td>
<td>Shift + Home</td>
</tr>
<tr>
<td>Expand the selected area next Row</td>
<td>Shift + Down</td>
</tr>
<tr>
<td>Expand the selected area previous Row</td>
<td>Shift + Up</td>
</tr>
<tr>
<td>Expand the selected area to the beginning of a document</td>
<td>Ctrl + Shift + Home</td>
</tr>
<tr>
<td>Expand the selected area to the end of a document</td>
<td>Ctrl + Shift + End</td>
</tr>
<tr>
<td>Move left by a character</td>
<td>Left</td>
</tr>
<tr>
<td>Move right by a character</td>
<td>Right</td>
</tr>
<tr>
<td>Move left by a word</td>
<td>Ctrl + Left</td>
</tr>
<tr>
<td>Move right by a word</td>
<td>Ctrl + Right</td>
</tr>
<tr>
<td>Move up by a row</td>
<td>Up</td>
</tr>
<tr>
<td>Move down by a row</td>
<td>Down</td>
</tr>
<tr>
<td>Move to the end</td>
<td>End</td>
</tr>
<tr>
<td>Move to the beginning</td>
<td>Home</td>
</tr>
<tr>
<td>Move to the top of next page</td>
<td>Ctrl + Page Down</td>
</tr>
<tr>
<td>Move to the top of previous page</td>
<td>Ctrl + Page Up</td>
</tr>
<tr>
<td>Move to the end of the document</td>
<td>Ctrl + End</td>
</tr>
<tr>
<td>Move to the beginning of the document</td>
<td>Ctrl + Home</td>
</tr>
</tbody>
</table>

**Help Keys**

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
</tbody>
</table>

**Single-key Accelerators**

You can select some commands and perform some actions with single-key accelerators. To enable single-key accelerators, please go to **File > Preferences > General**, and check **Use single-key accelerators to access tools** option in the **Basic Tools** group.
## Keys for Selecting Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hand</td>
<td>H</td>
</tr>
<tr>
<td>Temporarily select Hand</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select Text and Image</td>
<td>V</td>
</tr>
<tr>
<td>Marquee</td>
<td>Z</td>
</tr>
<tr>
<td>Cycle through zoom commands: Marquee, Loupe, Magnifier</td>
<td>Shift + Z</td>
</tr>
<tr>
<td>Temporarily zoom out (when the Marquee command is selected)</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Temporarily select Zoom In</td>
<td>Ctrl + Spacebar</td>
</tr>
<tr>
<td>Select Annotation</td>
<td>R</td>
</tr>
<tr>
<td>Edit Object</td>
<td>O</td>
</tr>
<tr>
<td>Crop Pages</td>
<td>C</td>
</tr>
<tr>
<td>Link</td>
<td>L</td>
</tr>
<tr>
<td>Text Field</td>
<td>F</td>
</tr>
<tr>
<td>Cycle through commands in forms authoring mode: Text Field, Check Box, Radio Button, List Box, Combo Box, Push Button, Signature Field</td>
<td>Shift + F</td>
</tr>
<tr>
<td>Audio &amp; Video</td>
<td>M</td>
</tr>
<tr>
<td>Cycle through Multimedia commands: Audio &amp; Video, Image Annotation</td>
<td>Shift + M</td>
</tr>
<tr>
<td>Edit Text</td>
<td>T</td>
</tr>
<tr>
<td>Text &amp; Images Redaction</td>
<td>Shift + Y</td>
</tr>
<tr>
<td>JavaScript Console</td>
<td>Ctrl + J</td>
</tr>
<tr>
<td>Insert Blank Page</td>
<td>Shift + Ctrl + T</td>
</tr>
<tr>
<td>Insert From File</td>
<td>Ctrl + Shift + I</td>
</tr>
<tr>
<td>Delete pages</td>
<td>Ctrl + Shift + D</td>
</tr>
<tr>
<td>Reading Order</td>
<td>Shift + Ctrl + U</td>
</tr>
</tbody>
</table>

## Keys for Working with Comments

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
</table>
### Keys for Navigating a PDF Document

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous screen</td>
<td>Page Up</td>
</tr>
<tr>
<td>Next screen</td>
<td>Page Down</td>
</tr>
<tr>
<td>First page</td>
<td>Home</td>
</tr>
<tr>
<td>Last page</td>
<td>End</td>
</tr>
<tr>
<td>Previous page</td>
<td>Left Arrow or Ctrl + Page Up</td>
</tr>
<tr>
<td>Next page</td>
<td>Right Arrow or Ctrl + Page Down</td>
</tr>
<tr>
<td>Scroll up</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Scroll down</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Scroll (when Hand command is selected)</td>
<td>Spacebar</td>
</tr>
</tbody>
</table>
### Keys for Working with Forms

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align selected fields left</td>
<td>L</td>
</tr>
<tr>
<td>Align selected fields right</td>
<td>R</td>
</tr>
<tr>
<td>Align selected fields top</td>
<td>T</td>
</tr>
<tr>
<td>Align selected fields bottom</td>
<td>B</td>
</tr>
<tr>
<td>Align selected fields horizontal</td>
<td>H</td>
</tr>
<tr>
<td>Align selected fields vertical</td>
<td>V</td>
</tr>
<tr>
<td>Center fields horizontally</td>
<td>Shift + H</td>
</tr>
<tr>
<td>Center fields vertically</td>
<td>Shift + V</td>
</tr>
<tr>
<td>Highlight fields</td>
<td>Shift + L</td>
</tr>
<tr>
<td>Show tab numbers</td>
<td>Shift + N</td>
</tr>
<tr>
<td>Document JavaScript</td>
<td>Shift + D</td>
</tr>
</tbody>
</table>

### Keys for Working with PDF Portfolios

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move focus to the next or previous row when in the body of the file list on the left</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>If pressed in the body of the file list, navigate one level up from within a folder</td>
<td>Backspace</td>
</tr>
<tr>
<td>If pressed when focus is on a row in the file list representing a subfolder, navigate to a subfolder, or open an attachment in Preview mode.</td>
<td>Enter</td>
</tr>
<tr>
<td>If in the body of the file list, move to the first or last row</td>
<td>Home or End</td>
</tr>
<tr>
<td>If in the body of the file list, move to the next or last set of rows to fit the screen</td>
<td>Page Down or Page Up</td>
</tr>
<tr>
<td>Select or deselect all files</td>
<td>Ctrl + A or Shift + Ctrl + A</td>
</tr>
<tr>
<td>If in the body of the file list, extend the selection by adding the next row above or below the selected row</td>
<td>Shift + Up Arrow or Shift + Down Arrow</td>
</tr>
</tbody>
</table>
### Keys for Navigating Task Panes

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate to the next item in the panel</td>
<td>Tab</td>
</tr>
<tr>
<td>Open or close the Task pane</td>
<td>Shift + F4</td>
</tr>
</tbody>
</table>

### Keys for General Navigating

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move focus to Ribbon</td>
<td>F10</td>
</tr>
<tr>
<td>Move to next open document tab (when multiple documents are open in same window)</td>
<td>Ctrl + Tab, or Ctrl + Shift + Page Down</td>
</tr>
<tr>
<td>Move to previous open document tab (when multiple documents are open in same window)</td>
<td>Ctrl + Shift + Tab, or Ctrl + Shift + Page Up</td>
</tr>
<tr>
<td>Close current document</td>
<td>Ctrl + F4</td>
</tr>
<tr>
<td>Close all open documents</td>
<td>Ctrl + Shift + W</td>
</tr>
<tr>
<td>Move focus to document pane</td>
<td>F5</td>
</tr>
<tr>
<td>Move focus to next comment, link, or form field in the document pane</td>
<td>Tab</td>
</tr>
<tr>
<td>Move focus to previous comment, link, or form field in the document pane</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Activate selected tool, item (such as a movie clip or bookmark), or command</td>
<td>Spacebar or Enter</td>
</tr>
<tr>
<td>Open context menu</td>
<td>Shift + F10</td>
</tr>
<tr>
<td>Close context menu</td>
<td>F10</td>
</tr>
<tr>
<td>Return to Hand command or Select command</td>
<td>Esc</td>
</tr>
<tr>
<td>Move focus to next tab in a tabbed dialog box</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Move to previous search result and highlight it in the document</td>
<td>Shift + F3</td>
</tr>
</tbody>
</table>
### Move to next search result and highlight it in the document

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to next search result and highlight it in the document</td>
<td>F3</td>
</tr>
<tr>
<td>Search previous document (with Search results displaying multiple files)</td>
<td>Alt + Shift + Left Arrow</td>
</tr>
<tr>
<td>Search next document (with Search results displaying multiple files)</td>
<td>Alt + Shift + Right Arrow</td>
</tr>
<tr>
<td>Select text (with Select command selected)</td>
<td>Shift + Arrow Keys</td>
</tr>
<tr>
<td>Select next word or deselect previous word (with Select command selected)</td>
<td>Shift + Ctrl + Right Arrow or Left Arrow</td>
</tr>
</tbody>
</table>

### Keys for Working with Navigation Panels

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open and move focus to navigation pane</td>
<td>Ctrl + Shift + F5</td>
</tr>
<tr>
<td>Move focus among the document, status bar and navigation panels</td>
<td>F6</td>
</tr>
<tr>
<td>Move focus to previous pane or panel</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Move among the elements of the active navigation panel</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous or next navigation panel and make it active (when focus is on the panel button)</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>Move to next navigation panel and make it active (when focus is anywhere in the navigation pane)</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Expand the current bookmark (focus on Bookmarks panel)</td>
<td>Right Arrow, or * (keypad), or Plus Sign (keypad)</td>
</tr>
<tr>
<td>Collapse the current bookmark (focus on Bookmarks panel)</td>
<td>Left Arrow, or Forward Slash (/), or Minus Sign (keypad)</td>
</tr>
<tr>
<td>Expand all bookmarks</td>
<td>Shift + *</td>
</tr>
<tr>
<td>Collapse all bookmarks</td>
<td>Shift + Forward Slash (/) (keypad)</td>
</tr>
<tr>
<td>Move focus to next item in a navigation panel</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Move focus to previous item in a navigation panel</td>
<td>Up Arrow</td>
</tr>
</tbody>
</table>

### Keys for Navigating the Help Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open and move focus to navigation pane</td>
<td>Ctrl + Shift + F5</td>
</tr>
<tr>
<td>Move focus among the document, status bar and navigation panels</td>
<td>F6</td>
</tr>
<tr>
<td>Move focus to previous pane or panel</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Move among the elements of the active navigation panel</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous or next navigation panel and make it active (when focus is on the panel button)</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>Move to next navigation panel and make it active (when focus is anywhere in the navigation pane)</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Expand the current bookmark (focus on Bookmarks panel)</td>
<td>Right Arrow, or * (keypad), or Plus Sign (keypad)</td>
</tr>
<tr>
<td>Collapse the current bookmark (focus on Bookmarks panel)</td>
<td>Left Arrow, or Forward Slash (/), or Minus Sign (keypad)</td>
</tr>
<tr>
<td>Expand all bookmarks</td>
<td>Shift + *</td>
</tr>
<tr>
<td>Collapse all bookmarks</td>
<td>Shift + Forward Slash (/) (keypad)</td>
</tr>
<tr>
<td>Move focus to next item in a navigation panel</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Move focus to previous item in a navigation panel</td>
<td>Up Arrow</td>
</tr>
</tbody>
</table>
Open Help window  F1

**Keys for Accessibility**

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change reading settings for the current document</td>
<td>Shift + Ctrl + 5</td>
</tr>
<tr>
<td>Reflow a tagged PDF, and return to unreflowed view</td>
<td>Ctrl + 4</td>
</tr>
<tr>
<td>Activate and deactivate Read Out Loud</td>
<td>Shift + Ctrl + Y</td>
</tr>
<tr>
<td>Read only the current page out loud</td>
<td>Shift + Ctrl + V</td>
</tr>
<tr>
<td>Read out loud from the current page to the end of the document</td>
<td>Shift + Ctrl + B</td>
</tr>
<tr>
<td>Pause reading out loud</td>
<td>Shift + Ctrl + C</td>
</tr>
<tr>
<td>Stop reading out loud</td>
<td>Shift + Ctrl + E</td>
</tr>
</tbody>
</table>

**Command Lines**

Here are some command lines that can be used to Foxit PhantomPDF:

```
```

<table>
<thead>
<tr>
<th>Command</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>-Register</td>
<td>Set Foxit PhantomPDF as default reader.</td>
</tr>
<tr>
<td>-pwd&lt;password&gt;</td>
<td>Input the password of the protected PDF documents.</td>
</tr>
<tr>
<td>/p &lt;PDF path&gt;</td>
<td>Print the document with default printer</td>
</tr>
<tr>
<td>/t &lt;PDF Path&gt; [Printer]</td>
<td>Print the document with designated printer</td>
</tr>
<tr>
<td>&lt;PDF Path&gt; /A [...] [...].</td>
<td>Open a PDF document with a command to exactly specify what to display and how to display</td>
</tr>
<tr>
<td>&lt;PDF Path&gt; /A reverse=1/0</td>
<td>Read in reverse view with the value of “1”; normal view with “0”.</td>
</tr>
</tbody>
</table>
Contact Us

Feel free to contact us should you need any information or have any problems with our products. We are always here, ready to serve you better.

- **Office Address:**
  Foxit Software Incorporated
  41841 Albrae Street
  Fremont, CA 94538
  USA

- **Sales:**
  1-866-680-3668

- **Support & General:**
  1-866-MYFOXIT, 1-866-693-6948, or 1-510-438-9090

- **Fax:**
  1-510-405-9288

- **Website:**
  www.foxitsoftware.com

- **E-mail:**
  Sales - sales@foxitsoftware.com
  Marketing - marketing@foxitsoftware.com
  Technical Support - enter a trouble ticket via our Support Portal
  Business Development - bd@foxitsoftware.com