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Chapter 1 – Introduction 

About the User Manual 

This user manual covers all features included in Foxit PDF Editor Cloud.  

Foxit PDF Editor Cloud Overview 

Foxit PDF Editor Cloud offers a robust all-in-one online PDF editing and eSigning 

solution. This cost-effective, business-ready tool enables secure collaboration with 

PDF documents and forms from any location without the need for software 

installation. The comprehensive cloud platform allows users to seamlessly view, 

create, edit, collaborate, share, secure, organize, export, eSign, and OCR PDF 

documents. Integrating with popular third-party applications such as Microsoft Office 

365, Teams App, SharePoint Online & OneDrive, and Google Drive, Foxit PDF Editor 

Cloud facilitates efficient collaboration across diverse teams. Additionally, its 

integration with ChatGPT leverages AI-generated content (AIGC) to enhance end-user 

productivity. 

Key features of Foxit PDF Editor Cloud include: 

 Direct Editing 

 Read out Loud 

 Robust Document Security 

 Form Fields 

 Optical Character Recognition (OCR) 

 Export PDF to Image 

 PDF Optimizer 

 Redaction 

 Document Certification 

 Bates Numbering 

 High Compression 

 Cloud Documents 

 Integration with third-party app platforms 

 AI Assistant 

Supported Browsers 

Foxit PDF Editor Cloud supports the following browsers and versions: 
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• Internet Explorer 11 or higher 

• Microsoft Edge 

• Google Chrome 

• Mozilla Firefox 

• Safari 

• Opera 

What’s New?  

Foxit PDF Editor Cloud continuously adds new features and updates to offer users a 

powerful PDF editing and eSigning tool, while also improving the overall user 

experience. To see the latest updates and new features, go to Help > What's New on 

the ribbon. 

Online Help 

You can get online help about how to read and work with PDF files with Foxit PDF 

Editor Cloud using Help Center, Online Tutorial, or Foxit AI Chatbot. You can also send 

us  

Help Center  

Click Help > Help Center to visit Foxit Knowledge Base to immediately find the answer 

to your questions.  

Online Tutorial 

We offer online tutorials to help you get the most out of our product. Go to Help > 

Online Tutorial to watch our product tutorials on the Foxit website. 

Foxit AI Chatbot 

Foxit AI Chatbot is an AI-powered customer support tool that utilizes natural language 

processing and machine learning algorithms to understand user queries and respond 

with answers. It can assist you in using a specific function or performing certain tasks 

by providing step-by-step instructions based on Foxit resources, such as Foxit 

Knowledge Base. 

https://www.foxit.com/kb.html
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To access Foxit AI Chatbot, click  on the lower right corner of the application 

window. Then, you can input your questions and interact with Foxit AI Chatbot in the 

pop-up Support Center panel. 

Share Feedback 

If you have any feedback or suggestions about our product, feel free to send us any 

comments/questions/bug reports by going to Help > Share feedback. Your feedback 

is essential as we strive to improve our product and provide the best possible user 

experience. 
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Chapter 2 – Get Started 

The Foxit PDF Editor Cloud workspace is packed with commands that help make 

working with PDF files easier, and it is organized into a toolbar (ribbon mode), a 

document pane, a navigation pane, and a status bar. An excellent way to get up to 

speed using Foxit PDF Editor Cloud is by familiarizing yourself with its workspace. 

To get started, access Foxit PDF Editor Cloud by navigating to pdfonline.foxit.com (or 

click the "Free Trial" button on the Foxit PDF Editor Cloud page at www.foxit.com/pdf-

editor/cloud/) in your web browser, and then sign in by clicking the avatar icon located 

at the top right corner of the Foxit PDF Editor Cloud window and choosing Sign In 

from the context menu. 

About the homepage 

By default, Foxit PDF Editor Cloud displays its homepage when no PDF file is open. The 

homepage includes a list of recently accessed documents, helpful product tutorials, 

and frequently used features to help you get started with Foxit PDF Editor Cloud. You 

can click on the items (including Home, Open File, Documents, Template, and Tools) 

on the left-hand side of the homepage to start your document workflow quickly.  

• On the Home page, you can see Quick Tools and file lists for 

Recent/Starred/Shared files and eSign agreements. You can click on Manage 

tools to customize and manage the quick tools displayed on the Home page. 

Clicking on All Tools switches to the Tools page, which shows more tools you 

can use to work on your files. 

• Clicking on Open File allows you to open a file from Local Computer/Recent 

Files/Cloud Documents or your cloud services like OneDrive and Box. 

• In the Documents page, you can view and manage your Cloud documents, 

shared/starred files, and eSign agreements. 

• The Template page lists various pre-designed templates to create a PDF 

quickly. 

• The Tools page includes recommended apps and most tools grouped by 

different functional modules. 

Apart from the main items above, the homepage may include additional wizards or 

tools tailored to different user groups, as shown in the screenshots below. Individual 

users can find more related scalable products in the "Recommended" area, including 

the PDF Editor for desktop and the Editor Cloud plug-ins integrated into third-party 

application platforms like Microsoft 365 and Google Drive. For enterprise users, most 

of the homepage displays lists of files they have recently worked on, enabling them 
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to focus more on content. 

 

The homepage for individual users 

 

The homepage for enterprise users 

For detailed information about each tool/function, please refer to the related section 

in this manual. 

Once you open a file in Foxit PDF Editor Cloud, you'll be taken to the workspace, where 

you can perform various document tasks using the available commands and options. 

With its intuitive interface and user-friendly design, Foxit PDF Editor Cloud makes it 

easy to create, edit, and share PDF documents online from anywhere, at any time.  
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When working on a file in Foxit PDF Editor Cloud, clicking on the  icon in the top-

left corner of the tool will take you to the homepage of Foxit PDF Editor Cloud. Note 

that before clicking on this icon, it is important to save any edits you have made to 

your file.  

Workspace Basics 

Foxit PDF Editor Cloud has integrated the collective commands in the ribbon interface 

and created a new way of working, namely Ribbon Mode. Ribbon Mode is developed 

based on Microsoft Office 2013 (Office 15) to provide you with a familiar and intuitive 

user experience. In this mode, commands are arranged by groups and tasks. 

 

User Interface  

A. Title Bar   B. Ribbon tabs  C. Groups of commands    D. Navigation Pane (the Pages 

panel displayed)  E. Document Pane        F. Status bar   G. The right panel 

➢ Title Bar: a horizontal bar at the top of the application window. It displays the 

homepage icon, Quick Access Toolbar, software title, current file name, search 

field, user account button for viewing user profile and signing in/out, buttons to 

undo/redo/download/print files, and more. The search field on the Title Bar allows 

you to search commands and documents.  

➢ Ribbon tabs: shows the major tabs of Foxit PDF Editor Cloud, including File, Home, 
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Edit, Comment, View, Form, Protect, Share, etc.  

➢ Groups of commands: categorizes the commands by groups according to the 

function under each ribbon tab. 

➢ Navigation Pane: contains various navigation panels. See also Navigation Panels. 

➢ Document Pane: shows the document content. 

➢ Status bar: shows the status information about the current open document. See 

also Status Bar. 

➢ The right panel: displays the Search panel or Format tab, depending on what 

feature you are using.  

Toolbar 

The toolbar displays ribbon tabs with different commands. Position the pointer over 

a command to see a description of the command. The Hand command and the 

Select tools (Select Text and Image and Select Annotation ), which are used 

quite often, are accessible on the left of most tabs on the ribbon.  

Navigation Panels 

Show or hide the navigation panels 

The buttons on the left side of the navigation pane provides easy access to various 

panels, such as the Bookmarks panel button  and the Pages panel button . After 

right-clicking the navigation pane, you can select and open more panels.  

 To show the navigation panels, use keyboard shortcut F4, or click View > View 

Settings > Navigation Panels > Show Navigation Panels.  

 To hide the navigation panels, use keyboard shortcut F4, or click View > View 

Settings > Navigation Panels > Hide Navigation Panels. 

 To open a navigation panel, click its button on the left side of the navigation pane. 

 To close a navigation panel, click its button on the left side of the navigation pane. 

Adjust the navigation pane 

Like the toolbars, the navigation pane can be docked in the navigation pane or float 

anywhere in the workspace. You can choose to hide or close the panels that you 
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don't need and open the ones you do. What’s more, you can also adjust the width of 

the navigation pane easily. 

1. Viewing a panel in the navigation pane 

By default, all the panels dock in the navigation pane with a set of panel buttons 

appearing on the left side of the work area. Do either of the following: 

 Select the button for the panel on the left side of the navigation pane. 

 Choose View > View Setting > Navigation Panels > [panel name]. 

2. Changing the display area for navigation pane 

 Put the cursor anywhere along the right border of the navigation pane, you will 

find the cursor turns into . Then drag the right border to adjust the width of 

the navigation pane. 

 To show or hide the navigation pane, click on the button /  on its right border. 

Status Bar 

The status bar is an area of the workspace that displays the page number where you 

are, the number of total pages, page transition buttons, zoom buttons, etc. for view 

setting.  

The status bar is open by default when you open a PDF. In the View tab, click View 

Setting and the Status Bar items help you to show or hide the status bar. 

  

Show Status Bar: If you check it, the status bar will appear at the bottom of the 

workspace. 

Auto-hide Status Bar: If you check it, the status bar is hidden. But if you put the cursor 

near the bottom of the page, the status bar will appear. 

Hide Status Bar: If you check it, the status bar will be hidden. 
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Customize Quick Access Toolbar 

Quick Access Toolbar is located on the Title Bar of Foxit PDF Editor Cloud window and 

displays frequently used commands for document workflow, such as Open, 

Undo/Redo, Save, Download, Print, and more. To customize which commands are 

displayed on Quick Access Toolbar, click the  icon on Quick Access Toolbar, and 

select the commands that you want to appear.  

Set Preferences 

Many preference settings for Foxit PDF Editor Cloud are specified in the Preferences 

dialog box, including settings for Editing, Commenting, Forms, Full Screen, General, 

Languages, Page Display, Security, Signature, and Trust Manager. Once you set 

preferences, they remain in effect until you change them.  

1. Choose File > Preferences.  

2. Select the type of preference you want to change under the list of categories. 

AI Assistant 

Leveraging AI-Generated Content (AIGC), Foxit PDF Editor Cloud seamlessly 

enhances end-user productivity through its integration with ChatGPT. The AI 

Assistant within Foxit PDF Editor Cloud boasts a diverse set of capabilities, 

encompassing document summarization and rewriting, interactive Q&A sessions 

derived from PDF content, content translation and explanation, as well as spelling 

and grammar correction. Users can easily toggle the AI Assistant feature on or off by 

selecting or deselecting the Enable AI Assistant option. 

For enterprise-level control over the AI Assistant, administrators can conveniently 

configure settings through the Foxit Admin Console, providing the flexibility to 

enable or disable this feature as per organizational preferences. 

Commenting  

 Making Comments 

Copy selected text into Highlight, Squiggly Underline, Underline, and Strikeout 

comment pop-ups: Check this option to copy and paste the selected text to 

comment pop-up notes automatically when you highlight, squiggly underline, 
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underline, or strikeout annotation in PDF documents. 

 Floating Toolbar:  

Pop up floating toolbar after comments created: Specify whether to show the 

floating toolbar that allows users to perform further operations (modify 

properties, open pop-up notes, etc.) right after a comment is created. This option 

is selected by default.   

Documents 

The Document of the Preferences dialog provides several ways to browse PDF 

documents. 

 Open Settings 

o Alert user when documents request Full Screen: A message box will pop up to 

confirm the operation when opening a PDF which has been defined to be 

opened in full screen mode. 

o Automatically upload local document to Cloud Documents when the file is 

opened: With this option selected, any local document opened in Foxit PDF 

Editor Cloud is automatically uploaded to Cloud Documents. This feature 

allows users to automatically save PDF files online, making them accessible 

from any location and device, which can significantly enhance productivity.  

 

 PDF/A View mode 

 

Sets to view documents in PDF/A view mode (i.e. read-only mode) to prevent 

modifications to the documents.  

 

o Never: Never open documents in PDF/A view mode. 

o Only for PDF/A documents: Switch to read-only mode automatically when a 

PDF/A document is opened.  

 

 Save Settings 

Save as optimizes for fast web view: Save documents as linearized PDFs that can 

be opened and viewed from web browsers even before the whole file is 

downloaded. 

  

 Redaction 

After applying redaction, you can save the redacted file as a new file with the 

preconfigured name automatically. To configure the name, select Adjust 

filename when saving applied redaction marks, and input text in the Prefix 

and Suffix boxes to configure the name. 
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Editing  

 Alert when there’s no editable text when using ‘Edit Text’ tool: An alert will 

pop up notifying the user when there’s no editable text while using the Edit Text 

command. By default, this option is selected.  

 Recognize Text: Select this option to run OCR automatically when you use the 

Edit Text command in a scanned PDF.     

 Scanned Document Editing Settings: Click it to open a dialog box to specify the 

OCR settings when recognizing text in a scanned PDF. You can select the language 

used to recognize text, and enable the Make all the pages editable option to 

recognize and convert text in all pages of the scanned PDF to editable text at once.   

Forms  

The form tab enables you to set the preferences of the interactive form display. 

 

 Automatically calculate field values: Specify whether to automatically perform all 

field calculations right after users input the entries. This option is checked by 

default. The setting for the option only applies to your current session, and it will 

revert to the default setting after the application is restarted.   

 Always hide document message bar: You can decide whether to show or hide the 

document message bar that appears below the toolbar area when opening an 

interactive PDF form. 

 Highlight all fields: Checking this option allows you to highlight all form fields in 

the PDF document. (Tip: The signature fields will not be highlighted after users 

apply signatures). You can click the color palette to change the highlight color for 

ordinary fields as well as required fields. 

 Open Properties box after creating field: The properties box appears when 

creating a form field.   

 Run form recognition when creating PDF in PDF Editor: Foxit PDF Editor Cloud will 

run form recognition automatically when a PDF is created and opened in Foxit 

PDF Editor.  

 Auto-Complete: Auto-Complete includes two options that allow you to turn on or 

off the auto-complete feature. When enabled, Foxit PDF Editor Cloud will store 

your entries and provide relevant suggestions as you fill in an interactive PDF form. 

➢ Off: Turn off the auto-complete feature. No suggestion will be provided when 

you fill in an interactive PDF form.  

➢ Basic: Enable auto-complete feature, and provide relevant suggestions when 

you enter a character in the interactive form field.  

➢ Remember numerical data: This option is available when you choose Basic 

or Advanced in the Auto-Complete drop-down list. If it is enabled, Foxit PDF 
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Editor will store numerical entries as well, otherwise, only text entries will be 

remembered.  

➢ Edit Entry list: Remove the saved entries from the auto-complete memory.  

Full Screen  

 Full Screen Navigation 

A. Select to show Scroll bar, Status bar, or Navigation Panels in Full Screen mode. 

B. Show Exit button – Check or uncheck this option to show or hide Exit button 

in Full Screen mode. 

C. One page at a time – Displays a single page at a time in Full Screen mode. 

D. Left click to go forward one page; right click to go back one page -- Lets you 

page through a PDF document by clicking the mouse. You can also page 

through a document by pressing Space, Shift + Space, or the arrow keys. 

E. Loop after last page – Reverts to the first page after the last, allowing you to 

page through a PDF document continuously.    

F. Advance every * seconds – Select this option and type a number to specify the 

frequency to automatically advance from page to page in Full Screen mode. 

With this setting enabled, you can still page through a document manually 

using your mouse or keyboard shortcuts.  

 Full Screen Appearance 

Background – Click the color pane and choose the color you like to be the 

background color in Full Screen mode. 

 Full Screen Transitions  

Foxit PDF Editor Cloud supports page transition in Full Screen mode. There are 12 

transition types: Split, Blinds, Box, Wipe, Dissolve, Glitter, Push, Cover, Uncover, 

Fade, Replace, and Fly. Also, you could set the direction for the transition. 

A. Ignore all transitions: Check to ignore page transition in Full Screen mode. 

B. Default transition –Choose page transition for one document in the drop-

down window. 

C. Direction - Set the direction for the transition. 

D. Navigation control direction: If selected, the direction of page transition will 

be based on your navigation direction in the document. For instance, if you 

turn to the next page, the page will transition from top to bottom; to the 

previous page, the page will transition from bottom to top. For some 

transitions without directions, the option is not available. 
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General  

 Basic Tools 

A. Use single-key accelerators to access tools: Enable single-key accelerators to 

select some commands and perform some actions with single-key shortcuts. 

Please refer to Single-Key Accelerators for more details. 

B. Use fixed resolution for snapshots - Sets the resolution used to copy the image 

captured with the Snapshot command. Automatically uses 72 pixels as default 

resolution. 

C. Make Hand Tool select text - Check it to enable the Hand command to become 

text selection tool when moving it to the selectable content. 

D. Make Hand Tool read articles – Check it to enable the navigation of an article 

with the help of the pointer. After you start the article viewing mode, with the 

Hand tool selected, the pointer will automatically change to a Hand tool with 

an arrow in it when over an article thread. Then the clicks with the pointer will 

follow the article thread, making the article navigation effective. See also View 

articles. The option is checked by default.  

E. Make Hand Tool use mouse-wheel zooming: Select this option to zoom 

through documents while scrolling using the mouse wheel. This option is 

useful for users to browse large drawings.   

Identity  

Shows the identity of your application, including Login Name, First/Last Name, Title, 

Organization Name, Organization Unit, and Email Address. The identify information is 

quite useful in PDF reviews. It will help other review participants recognize your 

comments easily. The Login Name is set by default (using the username of the current 

operation system) and cannot be changed. Except for Login Name, you can change or 

complete your identity information in Identify Preferences.  

JavaScript 

 Enable JavaScript Actions 

See also Run Script Right Control. 
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Languages 

Foxit PDF Editor Cloud provides the commonly used languages to meet customers’ 

needs to the upmost. To change the UI language of Foxit PDF Editor Cloud, please go 

to File > Preferences > Languages, and select an option from the following: 

 Use browser languages—Makes the browser language the UI language. 

 Choose custom language—Selects your desired UI language from the list.  

Layout Grid  

You can also customize the grid appearance. 

 Width/Height between lines: sets the spacing between grid lines. 

 Grid offset from left/top edge: sets the origin of the grid. 

 Subdivisions: sets the number of subdivisions within each grid square. 

Subdivision lines are lighter than grid lines. 

 Grid line color: sets the color of grid lines. 

Measuring 

 Measurement Units 

Sets unit of page dimensions given in the status bar and the Print dialog box. The 

unit can also be applied as the default setting for measurement if you specify it 

before using the measure commands. (Tip: The unit defined in the Format tab in 

the right panel prevails over the preference settings. If you do not set the measurement 

unit before using the measure commands or change the unit in the Format tab during 

the measurement, the unit specified in the Format tab will be used as default instead.) 

 Measurement Label  

Choose to use the default measurement label or specify your own label. 

 Measurement Markup  

Use Default Leader for Distance Measurement: Specify whether to show the 

line leader on both sides of the measurement points or not while measuring the 

distance.  

 Use Scale and Units From Document (When present) 
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Select the option to use the scale and units embedded in the document, if any. 

Deselect the option to specify the scale and units manually. The option is 

unselected by default. 

Page Display  

The Page Display panel of the Preferences dialog box includes the following options: 

 Default Layout and Zoom 

A. Navigation tab: specifies the panel to be displayed in the opening view. 

a) Page Only: displays Pages panel by default in opening view.  

b) Bookmarks Panel and Page: displays Bookmarks panel by default in 

opening view. 

c) Pages Panel and Page: displays Pages panel by default in opening view. 

d) Attachments Panel and Page: displays Attachments panel by default in 

opening view.  

e) Layers Panel and Page: displays Layers panel by default in opening view.  

B. Default page layout: You can view PDFs in following layouts: 

a) Automatic: With this option selected, in a multi-page document, displays 

pages in Continuous mode, or in Single mode if the page width is larger 

than the page height. If you change the page display in the View tab, the 

document will display in the page layout the last time you set.  

b) Single Page -- Displays one page at a time, with no portion on other pages 

visible. 

c) Continuous -- Displays pages in a continuous vertical column that is one 

page wide. 

d) Facing -- Displays each two-page spread with no portion of other pages 

visible. 

e) Continuous Facing -- Displays facing pages side by side in a continuous 

vertical column. 

See also “Changing the Page layout”. 

C. Zoom: Sets the magnification level for PDF documents when they are first 

opened. This value overrides document settings. The default uses the settings 

of the PDF document. 

D. Custom facing: The Default Facing for page layout is 2 pages. You can check 

the Custom Facing box and set the facing layout to your own preference. 

E. Custom margin: Sets the margins between different pages with Facing or 
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Continuous Facing page layout. The default is a margin of 8 pixels.  

 Rendering  

A. Smooth text: Optimally adjusts text display that best suits your monitor. 

B. Smooth line art: Removes the abrupt angles in lines to make them smoother.  

C. Enhance thin lines: Enhances the display of thin lines to make them more 

visible. This option is selected by default. 

 Page Content  

A. Display transparency grid: Displays a grid behind transparent objects. 

B. Use logical page numbers: Open PDFs with the logical page numbers. This 

option is selected by default. It is used to match the position (or the physical 

page number) of the page in the PDF to the printed page number of the 

document. For instance, for a document with 100 pages, when you turn to the 

second page, the page number displayed in the status bar will be 2/100 (the 

physical page number) theoretically. However, if the PDF contains four-page 

front matter (such as the cover page and the copyright page) which is 

numbered in lowercase Roman numbers (i-iv) while the main content is 

numbered in Arabic numbers starting from 1 (1-96), Foxit PDF Editor will 

display the logical page number, followed by the physical page number in 

parentheses, i.e. 2(6/100) when you turn to the sixth page of the PDF. With this 

option unselected, only the physical page number is displayed in the status bar, 

i.e. 6/100 for the sixth page. See also Change the format of page numbering 

on how to modify the format of page numbering for your PDFs. 

PDF Sign 

 Ink Sign 

Flatten the document when applying all signatures: Flattening the document 

when applying all signatures will make all the signatures, forms, and annotations 

become text, image, and shape objects of the PDF. 

 Foxit eSign 

Foxit PDF Editor Cloud seamlessly integrates with Foxit eSign, a legally binding 

electronic signature service. With a licensed account, you have the flexibility to 

initiate an eSign workflow not only through the Foxit eSign website but also 

directly within the Foxit PDF Editor Cloud. This streamlined integration enables 

you to edit your documents and gather signatures effortlessly. Activating or 

deactivating this feature is as simple as selecting or deselecting the Disable Foxit 

eSign service option. 
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For enterprise-level management of Foxit eSign service settings, administrators 

can easily configure preferences through the Foxit Admin Console. This 

centralized control ensures efficient and tailored management of the electronic 

signature service for the entire organization. 

Search 

 Search 

Ignore Asia character width: With this option selected, both half-width and full-

width instances of the Asian language characters in the document will be found. 

Ignore Diacritics and Accents: Ignore the diacritics and accents to find items 

with any variation of the alphabetical characters. For example, if you type 

“resume”, both “resume” and “résumé” will be found. 

Always show more options in advanced search: Select this option to show the 

additional search criteria options available besides the basic options in the Search 

panel. 

Security  

 Protected View 

To protect your computer from files originating from the Internet or other 

potentially unsafe locations, turn on Protected View to open these files to reduce 

risks. In Protected View, files are read only and most editing actions are not 

allowed. 

More information about security settings, please refer to Trust settings. 

Signature  

 Signing & Verifications 

A. Sign the document immediately after the signature is placed: Check this 

option to sign the document immediately when you place the signature on 

the document. By default, this option is checked. When it is unchecked, you 

will need to click Sign Document to apply the signature after placing it on the 

document. You can still modify the document before applying the signature.  

B. Control how and when signatures are verified: click Change Settings to 
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choose options. 

▪ Verify signatures when the document is opened: If this option is checked, 

Foxit PDF Editor Cloud will verify the signatures when the document is 

opened, and will display the signature verification results in the Digital 

Signatures panel. By default, the option is checked. 

▪ When document has valid but untrusted signatures, prompt to review and 

trust signers: With the option selected, if the signature (not including 

certified signatures) is verified as valid but is applied by an untrusted 

signer with a certificate that doesn’t chain up to a trust anchor, a message 

box appears in the top-right corner of the application window to inform 

you the document includes signatures from signers that you haven’t 

trusted yet. You can click Manage Trust in the message box to trust the 

signer. More information, please refer to Trusted Certificates. 

▪ Verification Behavior 

o Require certificate revocation checking to succeed whenever 

possible during signature verification: Specify whether or not to 

check the revocation status of certificates while verifying 

signatures. 

o Use expired timestamps: Uses the secure time provided by the 

document timestamp or the timestamp embedded in the 

signature, even if the timestamp’s certificate has expired. The 

option is selected by default. With the option unselected, the time 

provided by the expired timestamps will be discarded and the 

verification time will be the time at which signature was applied or 

the current time in the system based on your setting on 

Verification Time. 

o Ignore document validation information: Specify whether to 

ignore the related certificate revocation information embedded in 

the document when validating signatures.    

▪ Verification Time 

Verify Signature Using: You can check the digital signature for validity 

based on the time when the signature was created, the time provided by 

the timestamp embedded in the signature, or the current time in your 

system.  

Trust Manager 

Please refer to Trust settings.  
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Chapter 3 – Read 

After getting acquainted with the workspace and the basic tools, you can start the 

journey of PDF reading. You can open a PDF, reach a specific page easily, adjust the 

view of a document, read pure texts by the text viewer tool, view documents while 

listening to them, and more. Foxit PDF Editor Cloud also allows you to view PDF 

portfolios, compare PDFs, search for text content in PDFs, and more. 

Open PDFs 

Open PDFs in Foxit PDF Editor Cloud 

You can use Foxit PDF Editor Cloud’s Open File button to open a recent document, 

local document, Cloud Document, or PDFs in cloud services (including OneDrive, 

Google Drive, Dropbox, and Box).   

1. Click the Open File button on the homepage of Foxit PDF Editor Cloud.  

2. In the Open File dialog box, you can choose to do any of the following: 

• Select Local Computer on the left side of the dialog box, and then either click 

the Choose Files button on the right to select a local file to open or directly 

drag and drop the desired file into the specified area. If you do not want to 

upload the local file to Cloud Documents, click Preferences above the Choose 

Files button and deselect the Automatically upload local document to 

Cloud Documents when the file is opened option in the Preferences dialog 

box before you open the file.  

• Select Recent Files/ Cloud Documents on the left side of the dialog box and 

choose a file from the file list on the right to open it. 

• Select OneDrive/Box/Dropbox/Google Drive on the left side of the dialog box 

to open a file from your cloud service account. 

 

Tips:  

1) To quickly tell the location of a file that is open in Foxit PDF Editor Cloud, move 

your cursor over the filename on Title Bar. Informational text will appear, 

indicating whether the file is stored on your Local Computer, in Cloud 

Documents, or in your cloud service account. 

2) You are also allowed to open non-PDF files in Foxit PDF Editor Cloud. The non-

PDF files will be converted to PDF temporarily when you try to open them. 
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Open a secured PDF document 

If you receive a PDF that is protected by security features, you may need a password 

to open the document. Some protected documents have other restrictions that 

prevent you from printing, editing, copying, etc. 

 When opening a protected PDF, you will be prompted to enter the password. 

 When trying to copy or edit a secured PDF, you will be notified that you are 

prohibited to do it without the owner’s permission. 

Set Foxit PDF Editor Cloud as your default PDF viewer 

Foxit PDF Editor Cloud lets you edit PDFs directly in your web browser, anytime and 

anywhere if there’s an internet connection. You can also set Foxit PDF Editor Cloud as 

your default viewer for PDF files saved on your local drive. To do this, open the 

homepage of Foxit PDF Editor Cloud, click on the  icon in the left part of the Title 

Bar, and follow the on-screen instructions. Once Foxit PDF Editor Cloud is set as your 

default viewer, double-clicking on a local PDF file will open the file in Foxit PDF Editor 

Cloud using your default web browser. With this feature, you can seamlessly switch 

between editing cloud-based and local PDFs without the need to download or upload 

files, making it easier to manage your PDF documents.  

Save PDFs 

After modifying your PDF, you can save the changes to the original PDF (or save as a 

new copy of a PDF) and download it to Local Computer or upload it to Cloud 

Documents. You can also save PDFs as HTML, RTF, TXT and Microsoft Office files. Foxit 

PDF Editor Cloud also enables you to save your PDFs to cloud services (including 

OneDrive, Google Drive, Dropbox, and Box).  

Tip: By default, when you are working on a Cloud Document, Foxit PDF Editor Cloud 

automatically saves your changes to the document a little while after each edit, providing 

added protection against system crashes or power failures. 

Before closing the Foxit PDF Editor Cloud window, make sure to save your PDF file. To 

do it, select File > Save File on the ribbon and choose one of the following options: 

• Save to Local Computer: A dialog box will appear, allowing you to download 

the file to your local drive. Specify the file name and location in the dialog box 

as needed before downloading the file. 
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• Save As: In the Save As dialog box, specify the file name and choose a format 

from the Save type drop-down list, and then click OK.  

If you choose the .pdf format from the Save type drop-down list, a pop-up 

dialog box will appear after you click OK, allowing you to download the file to 

your local drive.  

If you choose a non-PDF format from the Save type drop-down list, the 

Settings button in the Save As dialog box will become available. Click the 

button to configure additional settings for the file conversion, as needed. Next 

to the button, you can choose a location to save the file. If you choose to save 

the file to your Local Computer, a message box will appear in the upper right 

corner of the Foxit PDF Editor Cloud window indicating that the conversion is 

taking place when the conversion process starts. You can download the 

converted file after the conversion completes. For more information on the 

conversion settings, you can refer to the Export PDFs section. 

• Save to Cloud Documents: In the Save File dialog box, specify the file name and 

click Save.   

• Save to OneDrive/Box/Dropbox/Google Drive: In the Save File dialog box, 

specify the file name and location to save the file to your cloud service account.  

Close a PDF 

Close the current PDF file by doing either of the following:  

• Click the homepage icon  located in the upper left corner of Foxit PDF 

Editor Cloud window. This will close the current PDF and return you to the 

homepage.  

• Click the icon  on Title Bar (or use the Open File command in the File tab) 

to open another file. This action will also close the current PDF. 

Note: Before closing the PDF file, make sure that you have saved any changes you made 

to the document.  

Export PDFs 

Export PDFs to Word, PowerPoint, RTF, or plain text files 

1. Navigate to the Convert tab. Choose To MS Office or To Other and select the 

format you want to convert the PDF to. 
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Tips: You can also click File > Save File > Save As, and then choose the desired format 

to export the PDF. See also Save PDFs. 

2. In the pop-up dialog box, specify the file name and location for the output file.  

3. (Optional) You can select more options from “Settings” in the Save As dialog box 

before saving the file. Take exporting PDF to Word files for instance.  

In the Save As DOCX Settings dialog box, select the following exporting options 

according to your needs and click OK to exit the dialog box. 

• Page Range: chooses the page range you want to export. 

• Content Settings: specifies whether to include the comments and images 

in the output. This option is not available for exporting to plain text files or 

if you choose Image-based document in Export Engine Settings. 

• Layout Settings: which is only available when you export PDF to Word 

and RTF files, specify whether to retain the text flow or page layout in the 

output. This option is not available for exporting to plain text files. 

• Export Engine Settings: If the PDF is primarily images and non-text 

objects, the Image-based document option is recommended. If you 

choose Image-based document, click Set Languages to select the 

language for OCR.  

• Restore Defaults: reverts to the original default settings.  

4. Click OK. If you choose to save the file to your Local Computer in Step 2, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 

Export PDFs to spreadsheets 

1. Navigate to the Convert tab. Choose To MS Office > To Excel or XML 

Spreadsheet 2003. 

Tips: You can also click File > Save File > Save As, and then choose the desired format 

to export the PDF. See also Save PDFs. 

2. In the pop-up dialog box, specify the file name and location for the output file.   

3. (Optional) You can select more options from “Settings” in the Save As dialog box 

before saving the file. Take exporting PDF to Excel files for instance. In the Save 

as xlsx setting dialog box, select the following exporting options according to 

your needs and click OK to exit the dialog box. 

• Page Range: chooses the page range you want to export. 

• Numeric Settings: specifies the decimal and thousands separators, so 

that Foxit PDF Editor Cloud will recognize the numeric data based on your 

setting. The settings are not available if you choose Image-based 



   Foxit PDF Editor Cloud 

Chapter 3: Read                                                    User Manual 

28 

 

document in Export Engine Settings. 

o Auto detect decimal and thousands separators – detects the numeric 

settings based on the document. 

o Treat the following as decimal and thousands separators – selects this 

option and select symbols for the decimal and thousands separators. 

• Excel Workbook Settings: chooses an option to create worksheets. The 

settings are not available if you choose Image-based document in Export 

Engine Settings. 

o Create single Worksheet for the Document – The PDF will be exported 

to a single Worksheet. 

o Create Worksheet for each Table – Each table in the PDF will be 

exported to a separate Worksheet. (Note: A table in a PDF is not always 

displayed in Table form with columns and rows. The application 

sometimes considers the head and tail of the page as virtual tables, so 

there is also a situation where non-Table content is displayed 

separately on a Worksheet). 

o Create Worksheet for each Page – Each PDF page is exported to a 

single Worksheet. 

Note: The exported Worksheets are automatically named as “Table1”, “Table2”, 

“Table3” … 

•  Export Engine Settings: If the PDF is primarily images and non-text 

objects, the Image-based document option is recommended. If you 

choose Image-based document, click Set Languages to select the 

language for OCR.  

• Restore Defaults: reverts to the original default settings.  

4. Click OK. If you choose to save the file to your Local Computer in Step 2, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 

Export PDFs to HTML files 

1. Navigate to the Convert tab and choose To HTML. (Tip: You can also click File > 

Save File > Save As, and then choose the desired format to export the PDF. See also 

Save PDFs.) 

2. In the pop-up dialog box, specify the file name and location.  

3. (Optional) You can select more options from “Settings” in the Save As dialog box 

before saving the file. In the Save As HTML Settings dialog box, select the 

following exporting options according to your needs and click OK to exit the dialog 

box.  

Page Range: chooses the page range you want to export. 
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Content Setting: selects Include Images to export images in the PDF. The setting 

is not available if you choose Image-based document in Export Engine Settings. 

File and Navigation Pane Settings: chooses Single HTML Page to export the 

PDF to a single HTML file, and you can add headings and bookmarks in the 

navigation pane of the output HTML file; or choose Multiple HTML Pages to split 

the PDF by its headings or bookmarks into several HTML files. The settings are not 

available if you choose Image-based document in Export Engine Settings.  

 Export Engine Settings: If the PDF is primarily images and non-text objects, the 

Image-based document option is recommended. If you choose Image-based 

document, click Set Languages to select the language for OCR. 

Restore Defaults: reverts to the original default settings.    

4. Click OK. If you choose to save the file to your Local Computer in Step 2, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 

Export PDFs to accessible text 

If the document is an accessible PDF, you can save it as accessible text which can 

contain assistive information (such as alternate text descriptions) for images or 

multimedia objects in the PDF. Accessible text is often used for a braille printer by 

which accessible text can be imported and printed out as a form that vision-impaired 

people can use. 

To export PDF to accessible text,  

1. Navigate to the Convert tab and choose To Other > To Accessible Text. (Tip: You 

can also click File > Save File > Save As, and then choose the desired format to export 

the PDF. See also Save PDFs.) 

2. In the pop-up dialog box, specify the file name and location for the output file.   

3. Click OK. If you choose to save the file to your Local Computer in Step 2, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 

Export PDFs to images 

1. Navigate to the Convert tab. Choose To Image and select a file type of images.  
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Tips: You can also click File > Save File > Save As, and then choose the desired format 

to export the PDF. See also Save PDFs. 

2. In the pop-up Save As dialog box, specify the file name and location for the output 

file.  

3. Before you click OK, you can set more options as needed like page range, color 

space, and resolution by clicking the Settings button. In the pop-up dialog box, 

select the exporting options: 

• Page Range: chooses the page range you want to export. 

• File settings: specifies a compression standard according to your 

requirements for the file size and the image quality. 

• Conversion: specifies the color space and resolution for the output file. 

Choose Determine automatically, and Foxit PDF Editor Cloud will determine 

the related settings automatically.  

• Restore Defaults: clicks the Restore Defaults button to discard all the 

settings above and revert to the original default settings. 

4. If you choose to save the file to your Local Computer in Step 2, a message box will 

appear in the upper right corner of the Foxit PDF Editor Cloud window indicating 

that the conversion is taking place when the conversion process starts. You can 

download the converted file after the conversion completes. 

Export PDFs to XML 1.0 files 

1. Navigate to the Convert tab and choose To Other > To XML 1.0. (Tip: You can also 

click File > Save File > Save As, and then choose the desired format to export the PDF. 

See also Save PDFs.) 

2. In the pop-up dialog box, specify the file name and location.   

3. Click OK. If you choose to save the file to your Local Computer in Step 2, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 

Export all images in the PDFs 

With one click of “Export All Images”, Foxit PDF Editor enables you to export all images 

in your document to separate image files.  

1. Click Convert > Export All Images. 

2. In the pop-up Save As dialog box, specify the file name and location for the output 

file.  

3. Before you click OK, you can set more options as needed like page range, color 
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space, and resolution by clicking the Settings button. In the pop-up dialog box, 

select the exporting options: 

For details about most options in the dialog box, please refer to Export PDFs to 

images. In the Extraction settings, for Exclude images smaller than, select the 

smallest size of the image to be extracted, i.e., the image will not be extracted if 

both its width and height are smaller than the selected value. Select No limit to 

extract all images in the document.  

4. Each image in the original PDF document will be saved as a separate image file 

whose name will be the original document name appended with the page number 

and the image’s sequence on the page. For example, when you export all images 

to JPG, the generated images will be named “[original document 

name]_Page1_Image1.jpg”, “[original document name]_Page1_Image2.jpg”, and so 

on. 

5. If you choose to save the file to your Local Computer in Step 2, a message box will 

appear in the upper right corner of the Foxit PDF Editor Cloud window indicating 

that the conversion is taking place when the conversion process starts. You can 

download the converted file after the conversion completes. 

Tip: To export one image in your PDF, select the Select Text and Image command and 

right-click the image and choose Save Image As….  

Export Selected Area to Other Formats  

You can also select an area with the Select Text and Image command in PDF and 

export the content in the area to formats including Microsoft Word, Excel, and 

PowerPoint.  

1. Choose the Select Text and Image command. 

2. Select the text or area (select an area by dragging a rectangle) you want to export. 

Then right-click the selected area and choose Export Selection As…. 

3. In the pop-up Save As dialog box, choose the file format you want to export to, 

and specify the filename and location.  

4. (Optional) You can select more options from “Settings” in the Save As dialog box 

before saving the file. For details about the options, please refer to the 

corresponding instructions in the Export PDFs section according to the file format 

you want to export to.  

5. Click OK. If you choose to save the file to your Local Computer in Step 3, a message 

box will appear in the upper right corner of the Foxit PDF Editor Cloud window 

indicating that the conversion is taking place when the conversion process starts. 

You can download the converted file after the conversion completes. 
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View PDFs 

Page through a document 

Open a PDF document with Foxit PDF Editor Cloud, and you can then start viewing 

PDFs by scrolling throughout the entire document with your mouse vertically, or by 

holding Shift to scroll horizontally. You can also page through a document by the 

following methods. 

Scroll through Documents 

Do either of the following: 

 Using mouse actions or keystrokes 

➢ To navigate around the documents vertically, scroll the mouse wheel or press 

the Down or Up Arrows on the keyboard. 

➢ To navigate around the document horizontally, press Shift and scroll the 

mouse wheel.  

 Scroll automatically 

Automatic scrolling allows users to view documents without using mouse actions 

or keystrokes. Foxit PDF Editor Cloud also enables you to change the scrolling 

speed with ease. 

A. Choose View > AutoScroll. 

B. Do one of the following: 

➢ To increase or decrease the scrolling speed, press the Up Arrow or Down 

Arrow key, depending on the direction of scrolling. To change the scrolling 

speed to a specific speed, press a number key (9 for the fastest, 0 for the 

slowest).  

➢ To reverse the direction of scrolling, press the minus sign (-) key. 

➢ To jump to the next or previous page, press the Right Arrow key or Left 

Arrow key respectively. 

➢ To stop automatic scrolling and go back to Hand Command mode, click 

AutoScroll again or press the Esc key. 

➢ To pause automatic scrolling, press the Space key. 
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Go to Specified Page 

Click the First Page, Last Page, Previous Page and Next Page icon in the status bar 

to view your PDF file. You can also input the page number to go to that specific page. 

The Previous View icon in the status bar lets you return to the previous viewed 

instance and Next View goes to the next viewed instance.  

Note: If your PDF contains formatted page numbers, and the Use logical page numbers 

option is enabled in File > Preferences > Page Display, you should input the numbers that 

match the numbering on the pages rather than the physical page numbers. For instance, if 

you want to view the second page of your document which is numbered ii, you should enter 

ii to go to the page. See also the preference setting on logical page numbers.    

Read with Bookmark 

To jump to a topic using bookmarks, click the icon on the left Navigation pane to 

open the Bookmarks panel. And then click the bookmark or right-click the bookmark 

and choose Go to Bookmark.  

If you want to hide the Bookmarks panel after you click a bookmark, click the Options 

menu at the top of the Bookmarks panel and select Hide After Use, which makes the 

document area wider and improves the reading experience. To keep showing the 

Bookmarks panel after you click a bookmark, deselect Hide After Use. 

Tips:  

1. If a bookmark is too long to be displayed in the Bookmarks panel, you can right 

click the bookmark (or click the Options menu  at the top of the Bookmarks 

panel) and select Wrap Long Bookmarks to wrap it to multiple lines for a better 

view. To unwrap, deselect Wrap Long Bookmarks. 

2. Clicking the Find Current Bookmark  icon at the top of the Bookmarks panel 

highlights the bookmark corresponding to the content in the current document view, 

which can be helpful to find a bookmark as well as show you where you are.  

Read with Page Thumbnail 

To jump to a page with page thumbnails, click the Page Thumbnails button  on 
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the left Navigation pane and click its thumbnail. To move to another location on the 

current page, drag and move the red box in the thumbnail. More information about 

page thumbnails, please refer to Page thumbnails. 

Read with Article Thread 

Article threads are defined for navigating articles in PDF files as skimming through a 

traditional print newspaper or magazine, allowing you to focus on a specific article and 

ignore the rest. To navigate an article in the document, open the Articles panel, and 

double-click the article you want to view. More information about viewing articles, 

please refer to View articles in the Articles section.    

View PDF Portfolios 

PDF portfolios are a combination of folders and files with different formats such as 

Word Office files, text documents and Excel files. Foxit PDF Editor Cloud provides 

viewing and printing PDF portfolios, as well as searching keywords in PDFs in the 

portfolio. 

 

A Sample PDF Portfolio 

A. The secondary toolbar   B. The component files list    C. The preview pane   
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The portfolio window overview 

When you open a PDF portfolio with Foxit PDF Editor Cloud, the Portfolio context tab 

appears on the ribbon with the related commands. And the portfolio window below 

the ribbon may display elements including a component files (files and folders) list, a 

preview pane, and a secondary toolbar. The elements are displayed in different 

positions depending on the view mode you choose. 

There are three portfolio view modes: 

• In the Layout mode, the component files are displayed as small squares with 

icons corresponding to their file types in the portfolio window. Click a file to 

show the preview of the file on the preview pane. The secondary toolbar is 

presented on the component files. 

• In the Details mode, the component files are listed with detailed information 

by displaying various columns in the portfolio window, including Name, 

Description, Size, and Modified. The secondary toolbar is presented on the 

component files list.  

• In the Cover Sheet mode, the portfolio window only shows the cover sheet of 

the portfolio, which is a PDF page displaying the logo of Foxit PDF Editor and 

prompts you to download Foxit PDF Reader/Editor for the best experience.  

You can switch the view mode at any time by clicking Layout, Details, or Cover Sheet 

in the Portfolio context tab as needed. In both the Layout and Details view modes, 

you can: 

• Change the position of the preview pane by clicking Preview Pane and 

choosing Right or Bottom (or choose Off to minimize or hide the preview 

pane).   

• Switch to the Cover Sheet mode by right-clicking on any file or blank area in 

the component files list and choose Cover Sheet in the context menu. 

To set the default view for any PDF portfolio when it is opened in Foxit PDF Editor 

Cloud, choose Default View and select a view mode. If you select Retain Original, the 

initial view of a portfolio will be used when you open the portfolio. For the initial view 

setting of a portfolio, refer to Customize and modify a PDF portfolio.    

View component files in a PDF portfolio 

The preview pane in the portfolio window allows you to quickly preview a file without 

opening it in its native application. To view a component file in the preview pane, go 

to the component files list and select the file you want to view. If you have multiple 
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component files, you can use the /  button above the preview pane to switch 

between them and find the one you need. 

To view the properties of a component file, right-click the file in the portfolio and 

choose Show Information. Or select the component file and click the  button in 

the secondary toolbar. 

Adjust Page View 

Foxit PDF Editor Cloud provides multiple commands that help you adjust the view of 

your PDF documents, such as the page magnification and the display of pages. 

Adjust Page Magnification 

Do one of the following procedures:  

1. Click Zoom In > Zoom In/Zoom Out in the Home tab. 

2. Select or input a magnification percentage in the field on the status 

bar. 

3. Using the Marquee command 

The Marquee command allows you to zoom in or out on a selected area of your 

document for a clear view. To use the Marquee command, please follow the steps 

below: 

• Click Marquee in the View tab. 

• The cursor changes into , drag a rectangle on the page or just click on 

the page to increase the magnification by one preset level, centering on 

the point where you clicked. 

• Choose the Marquee command, the cursor changes to  as Ctrl-click on 

the page. Drag a rectangle on the page or just click on the page to decrease 

the magnification. 

4. Using the Loupe command 

The Loupe command allows you to easily change the magnification of a PDF file. 

It is best used when you want to keep a PDF file at a standard zoom level (like 

100%), but magnify certain areas. To use the Loupe command, please follow the 

steps below: 

• Click Loupe in the View tab. 

• Move the Loupe command to the places you want to view, you will see the 

amplificatory or decreased objects in the Loupe Tool dialog box. 
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• (Optional) Select the Lock option in the Loupe Tool dialog box. Click the 

area of the document you want to view in closer detail. A red rectangle 

appears in the document, corresponding to the area shown in the Loupe 

Tool window. You can drag or resize the rectangle to change the Loupe 

command view. 

• To change the scale ratio of the Loupe Tool, you can either enter a value 

in the zoom text box, or drag the slider in the Loupe Tool dialog box. 

Resizing a Page to Fit the Window 

There are four types for you to choose: 

 To resize the page to fit entirely in the document pane, click Zoom In > Fit Page 

in the Home tab, or right-click the Document Pane and choose Fit Page.  

 To resize the page to fit the width of the window, click Zoom In > Fit Width in the 

Home tab, or right-click the Document Pane and choose Fit Width. Part of the 

page may be out of view. 

 To resize the page to its actual size, click the Zoom In > Actual Size in the Home 

tab, or right-click the Document Pane and choose Actual Size. 

 To resize the page to fit the visible width of the window, removing the margins, 

click the Zoom In > Fit Visible in the Home tab, or right-click the Document Pane 

and choose Fit Visible. 

Adjust the Page Display 

To change the Page Orientation, right-click the document pane and choose the Rotate 

Right or Rotate Left command. 

Note: You can change the page view in 90-degree increments, but the change only affects 

screen display instead of its actual orientation. You cannot save the changes in page view. 

To change the page layout, Foxit PDF Editor Cloud provides the following page layouts:  

 Single Page  - Displays one page in the document pane at a time. 

 Continuous  - Arranges the pages in the document pane in a continuous 

vertical column. 

 Facing  - Arranges the pages side by side, displaying only two pages at a time. 

 Continuous Facing  - Arranges the pages side by side in a continuous 

vertical column. 
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 Show Cover Page During Facing  -If a document has more than two pages, 

the first page can be displayed alone on the right side of the document pane in 

Facing and Continuous Facing views.  

 Horizontal Continuous  – Arranges the pages in the document pane in a 

continuous horizontal column.  

View Mode 

Read Mode 

User interface settings, such as the navigation pane, toolbar, and status bar, will be 

hidden when a PDF is displayed in Read Mode. The document pane is enlarged, 

reducing wasted reading space while leaving the ribbon tabs available for necessary 

operations. 

To view a document in Read Mode, please choose one of the following: 

 Click the Read Mode button in the View tab.  

 Press the shortcut key “Ctrl + H” on the keyboard. 

In Read Mode, a basic toolbar will float at the bottom of the Foxit PDF Editor window . 

This offers basic commands, such as save, print, zoom in/out, etc.  

To exit the Read Mode, please do any of the following: 

⚫ Click the Read Mode button in the View tab. 

⚫ Press the shortcut key “Ctrl + H” on the keyboard. 

⚫ Click the Exit Read Mode button on the floating basic toolbar at the bottom of 

the screen. 

Full Screen Mode 

In Full Screen mode, Foxit PDF Editor Cloud’s Document Pane fills the entire screen, 

with the toolbar, Status bar, and Bookmarks pane hidden behind. The mouse pointer 

remains active in Full Screen mode so that you can click links.  

1. To set Full Screen preferences, please go to File > Preferences > Full Screen. 

2. To enter Full Screen mode, please do one of the following: 
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 Right-click the Document Pane and select Full Screen. 

 Press the shortcut key F11. 

3. To exit Full Screen mode: 

 Press Esc key. 

 Press the shortcut key F11. 

4. Page Transition in Full Screen 

Foxit PDF Editor supports page transition to turn pages in Full Screen mode. It helps 

you to turn pages as the transition feature in Microsoft Power Point. There are 12 

transition types: Split, Blinds, Box, Wipe, Dissolve, Glitter, Push, Cover, Uncover, Fade, 

Replace, and Fly. Also, you could set the direction, speed and page range for the 

transition.  

To edit page transition, right-click any page thumbnail in the Pages panel and choose 

Page Transitions.   

Notes:  

• This change only works for the current PDF.  

• The pages will be turned in the same way the next time you open and view the 

document in full screen mode. 

• If you want to set page transition to all PDF documents opened by Foxit PDF Editor 

Cloud, please choose File > Preferences > Full Screen. 

Text Viewer 

With Foxit Text Viewer, you can work on all PDF documents in pure text view mode. It 

allows you to easily reuse the texts scattered among images and tables, and acts like 

Notepad. Also, you can adjust some settings to meet your needs. 

To Enter Text View mode, choose View > Text Viewer. 

 Customizing Text Viewer  

As soon as Text Viewer is activated, you can use the Font Setting commands to 

customize your own work area. Right-click the text area to select Font Setting. 
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1. To change text font when reading with Text Viewer 

 Right-click and choose Font Setting > Font/Color.  

 Choose Font name, Font Size, and Effects from respective fields in the Font/Color 

dialog box. The suggested font for best screen display is Courier New. 

2. Toggle between regular style and Bold style, choose Font Setting > Bold. 

3. Toggle between regular style and Italic style, choose Font Setting > Italic. 

4. Change the text color and the background color 

 Right-click and choose Font Setting > Font/Color. 

   Change the Foreground (Font) Color and Background (page) Color. You can 

preview the changes in the Sample box. 

   Click OK to complete the procedure, or click Close to abandon the changes. 

5. Change Text Viewer settings 

 Right click the text area > select Setting… 

  The Text Viewer Settings dialog box pops up. 

   Below are the text viewer settings: 

A. Set page width at three different levels: Current page width, Current 

document width and System default width. 

B. Minimal width – the valid value for this field is 0-1024. It is set to 78 by default. 

C. Keep Column – for PDF tables or text columns, you can check Keep Column 

to retain appropriate column in text viewer mode. It is checked by default. 

D. Auto Width – for PDF tables or text columns, you can check Auto Width to 

keep proper width between texts automatically. It is checked by default. 

E. Auto Rotate – you can check Auto Rotate to ensure consistent orientation 

with that of the printer. It is checked by default. 

 Finding text in Text Viewer mode 

To find text you are looking for, please refer to Find Text.   

 Copying and pasting text in Text Viewer mode 

1. Select text 

 Select a word: Double-click the word you want to select. 

 Select a line of text: Click and drag the cursor on the line of text you want to select. 

 Select all the text: Press Ctrl + A or right-click the Document Pane > choose Select 
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All. 

2. Copying text, do one of the following: 

 Right-click the selected text > choose Copy. 

 Select the text and then press shortcut key Ctrl + C. 

3. Pasting text 

To paste the selected text on Clipboard to another application, please follow the paste 

command of the specific application. 

Change the page view color 

Foxit PDF Editor Cloud allows you to add a “background” color to your page view for a 

more personalize look. This feature does not alter your document itself. To change 

the page view color, choose View > Change Color, and select the desired color. To 

restore the default white color, go to View > Change Color, and select the white color. 

Note: If you have set a background color for your document via the Background command 

in the Organize tab, the page view color you set may be overlapped by the document 

background color.  

Read Out Loud 

What’s Read Out Loud? 

Read Out Loud is a Text-to-Speech (TTS) tool. It reads the text in a PDF aloud, including 

the text in comments and alternate text descriptions for images, tables, and fillable 

fields. Text is read based on the order of the page content. With this feature, you can 

obtain information without viewing the pages, helping to effectively relief eyestrain. It 

also enables you to view other materials while listening to the content.  

Read Out Loud uses the available voices installed on your system. If you have SAPI 5 

voices installed from text-to-speech or language applications, you can choose them to 

read your PDFs. 

Note: Read Out Loud isn’t a screen reader, it may not be available in some operating 

systems. 

Activate or deactivate Read Out Loud 
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You need to activate Read Out Loud before using it.  

➢ To activate Read Out Loud: select View > Read > Read > Activate Read.  

➢ To deactivate Read Out Loud: select View > Read > Read > Deactivate Read.  

Tip: You can press the shortcut key Ctrl + Shift + Y to activate or deactivate Read Out 

Loud, based on the current status of the feature. After activating Read Out Loud, you 

can read a PDF file out Loud.  

Read a PDF Out Loud 

➢ Navigate to the page that you want to read out.  

➢ Choose View > Read > Read > Read Current Page or Read from Current Page.  

Control Reading  

While reading a PDF file, you can interrupt the reading and adjust reading volume, 

speed, and voice as needed.  

➢ To adjust the reading speed: choose View > Read > Speed > drag the slider. 

➢ To adjust the reading volume: choose View > Read > Volume > drag the slider.  

➢ To pause reading: choose View > Read > Pause. 

➢ To stop reading: choose View > Read > Read > Stop.  

➢ To select a speech voice for reading aloud: choose View > Read > Voice > choose 

a voice from the context menu that suits your preference or matches the 

document's language. 

Rulers, Guides, Grids & Line Weights 

Using Rulers & Guides 

Foxit PDF Editor Cloud provides horizontal and vertical ruler guides to help you align 

and position text, graphics or other objects on the page. They can also be used to 

check the size and margins of your documents. 
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Rulers & Guides 

A. Rulers  B. Guides 

To show or hide rulers/guides, select View > View Setting > Page Display > check or 

uncheck Rulers/Guides. 

To create ruler guides, follow the steps below:  

 Drag down the horizontal ruler to create a horizontal guide, or drag to the right 

of the vertical ruler to create a vertical guide. 

 Double-click a location on the horizontal ruler to create a vertical guide, or double-

click a location on the vertical ruler to create a horizontal guide. 

To move ruler guides, select the Hand command, click and hold the guide, and then 

drag it to a new location. 

To change the unit of measurement, right-click the horizontal ruler or the vertical ruler, 

and select a measurement system for the rulers. 

To delete ruler guides, please do one of the following: 

 To delete a guide, click the guide to select it, and then press the Delete key. 

 To delete all guides on a certain page, scroll to the page, right-click the ruler area 

and choose Clear Guides on Page. 

 To delete all guides, right-click in the ruler area and choose Clear All Guides. 

Grids  

You can use grids to line up form fields and objects (including text, image, path, and 

shading objects) in a PDF document. When you create or move a form field or object, 

Snap to Grid can align the form field or object with the nearest grid line.  

To show or hide the grid, navigate to View > View Setting > Page Display > 
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check/uncheck Grid. 

To turn on or off the Snap to Grid option, navigate to View > View Setting > Page 

Display > check/uncheck Snap to Grid. 

You can also customize the grid appearance from File > Preferences > Layout Grid. 

Line Weights View 

In Line Weights View, the lines will be displayed with the weights defined in the PDF 

file. When Line Weights View is turned off, the lines will be displayed with the constant 

stroke width (1 pixel), regardless of zoom. The following screenshots show the 

comparison of the PDF file displayed in Line Weights View and Non-Line Weights View.  

 

          

        PDF in Line Weights View                   PDF in Non-Line Weights View 

 To enter Line Weights View, please choose View > View Setting > Page Display > 

check Line Weights option.  

 To exit Line Weights View, please choose View > View Setting > Page Display > 

uncheck Line Weights option.  

Select & Copy 

With Foxit PDF Editor Cloud, you can copy texts and images to other applications. 

Select and Copy Text and Images 

The Select Text and Image command lets you select horizontal and vertical text or 

columns of text, and images in a PDF. Foxit PDF Editor Cloud sets each ribbon with the 

Hand command and Select commands for user’s convenience. To select, copy and 
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paste text or images, click the Select Text and Image command and do the following:   

Select text and images  

To select an image, please click on the image in a PDF file directly. To select text, please 

do any of the following:  

 Select a word: Double-click the word you want to select.  

 Select a line of text: Drag the cursor  toward a line of text you want to select. 

 Select a column of text: Hold down the Alt key as you drag the cursor over the 

desired column of text to select it.   

 Select text only in a rectangle box without images: Press Alt and drag a rectangle 

at the desired position you want to select. 

 Select multiple paragraphs through pages: Click at the start of the selection, scroll 

to the end of the selection without releasing your mouse. 

 Select all the text: Press Ctrl + A, or select some text, right-click it and then choose 

Select All. 

 Deselect all the text: Click any area of the text. 

Tip: If you right-click the selected word(s), options in the context menu allow you to perform 

more tasks like copying and exporting the selected text, adding text markup, looking up a 

word quickly on Dictionary.com online, and more. 

Copy text and images  

After selecting the text or image, do one of the following: 

 Choose the Copy Text icon from the floating toolbar.  

 Right-click the selected text, and choose Copy.  

 Right-click the selected image, and choose Copy.  

 Press shortcut key Ctrl + C. 

Paste text and images  

To paste the selected text on Clipboard to a PDF file, please select the Hand command 

in Foxit PDF Editor Cloud, use the shortcut key Ctrl + V, or right-click on the document 

where you want to paste the text and select Paste.  

To paste the selected image on Clipboard to a PDF file, please select the Hand 

command in Foxit PDF Editor, use the shortcut key Ctrl + V or right-click on the 

document and select Paste. You will see the image preview as you hover your mouse 

over the document. Then click on the document where you want to add the image to 

add it in the PDF file.  
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To paste the selected text or image on Clipboard to another application, please follow 

the paste command of the specific application. 

Copy Content Using the Snapshot Command  

You can use the snapshot command to copy individual images or selected content 

(text, images, or both) to the clipboard or other applications. Text and images will be 

copied as an image. 

To copy an image or a combination of text and images, do the following: 

1. Select the Snapshot command by choosing Home > Snapshot. 

2. The cursor changes into a Cross  automatically. 

3. Click and drag the mouse to draw a rectangle around the content you want to copy. 

4. Three icons appear on the right of the selected area, allowing you to copy the 

selected content to the clipboard, cancel the selection, and download the selected 

content as an image.  

5. Paste the selected image to desired destinations.  

Note: The selected area will be highlighted in blue. 

Search  

Find text in the current PDF 

 Type the text you want to find in the Search box in the top right 

corner of the application window. Click the Filter  icon to set the search criteria.  

A. Whole words only -- limits the search to match only whole words. For example, 

if you search for the word Read, the word Reader will not be found.   

B. Case-Sensitive -- makes the search case-sensitive. For example, if you search 

for the word text, the words Text and TEXT will not be found. 

C. Include Bookmarks -- enables you to search for a word in the whole text, 

including bookmarks.  

D. Include Comments -- enables you to search for a word in the whole text, 

including comments. 

E. Highlight All Text – Highlight all the text search results in the document.  

F. Properties – enables you to specify the color and opacity of the highlighting of 

the search results. 
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 Press Enter to start searching.  

 Foxit PDF Editor Cloud jumps to the first instance of the search term, which 

appears highlighted.  

 Click  and  to find previous or next result, or press Enter to find the next 

result.  

Advanced search 

Foxit PDF Editor Cloud supports the advanced search function, which enables you to 

search for text and pattern (such as phone numbers) in the current PDF. When the 

search finishes, all occurrences will be listed in a tree view. This will allow you to quickly 

preview the context and jump to specific locations. You can also save the search 

results as a CSV or PDF file for further reference.  

Before doing an advanced search, you can go to File > Preferences > Search to specify 

search preferences. For more information, please refer to the Search preferences. 

Searching for text and patterns 

1. Click the Search features icon next to the Search box and choose Advanced 

Search. 

2. Select one of the following search criteria from the drop-down list under the file 

location box:  

A. Match exact word or phrase: Search for instances that match the entire word 

or phrase (including the spaces) you specified in the text search box. 

B. Match any of the words: Search for any instances that match at least one of 

the words.  

C. Looks like search pattern: Search for patterns like phone number, social 

security number, or email address in the PDF file. This option is not available 

when you search PDF indexes.  

3. For text search, input the word you would like to search in “What word or phrase 

would you like to search for” box. For pattern search, select the pattern you want 

to search from the Select your pattern drop-down list, and choose the specific 

county and region from the Country/Region drop-down list.  

4. (Optional) Check any of the following options to specify the additional search 

criteria, if needed.  

a) To limit the search to match only whole words, check Whole Words Only. For 
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example, if you search for the word Read, the word Reader will not be found. 

This criterion is only available for text search.  

b) To make the search case-sensitive, check Case-Sensitive. For example, if you 

search for the word text, the words Text and TEXT will not be found. This 

criterion is only available for text search.  

c) To search words in comments, please check Include Comments.  

d) To search words in bookmarks, please check Include Bookmarks. This 

criterion is only available for text search.  

e) To search words in attachments, please check Include Attachments.  

f) To find instances that contain the stem of the specified search word, please 

check Stemming. For example, if you search for “opening” with Stemming 

option checked, instances of “open”, “opened”, “opens”, and “opening” will be 

found. This criterion applies to text search and index search, and is not 

available if either Whole Words Only or Case-Sensitive is selected.    

g) To highlight all the text search results, please check Highlight All Text.  

5. Click Search button. 

6. Each item listed includes a few words of context and an icon that indicates the type 

of occurrence. Check the search results with the following steps:  

➢ If necessary, click the plus sign (+) to expand the search results. 

➢ Click a search result directly to view it in the PDF file.  

7.  (Optional) Click the Save button  in the Search panel to save the search 

results.  

8. (Optional) Click New Search button to start a new search task. 

Note: To find or edit text in a scanned or image-based PDF, you need to convert the content 

into searchable or editable text using the OCR feature. See also OCR PDFs. 

Search and highlight 

After searching, users may need to mark up the searched text strings in a highlight 

color. With Foxit PDF Editor Cloud’s Search & Highlight feature, users can perform an 

advanced search and highlight the searched text strings with one click. 

1. Click the Search features icon in the upper right corner of the Foxit PDF 

Editor Cloud window and choose Search & Highlight. 

2. The Search panel opens. Search the text strings or search by patterns as needed. 

3. After the search completes, you can see a Highlight icon  next to the Save 



   Foxit PDF Editor Cloud 

Chapter 3: Read                                                    User Manual 

49 

 

button  in the Search panel, a check box in front of each searched instance 

and each file path, and the Check All option above the New Search button.  

4. Select the check box of the instance you want to highlight and click the Highlight 

icon .  

Resizing the Search panel 

The Search panel is displayed on the right of the document pane.  When you put the 

cursor along the left border of the Search panel, the cursor turns into . Then drag 

the border to adjust its width. To show or hide the Search panel, click on the button

/  on its right border. When your search operation completes, click the close 

button  to close the Search panel. 

Compare PDF Files 

The Document Compare feature lets you see the difference in two versions of a PDF, 

as well as select the type of differences you’re looking for to verify that the appropriate 

changes have been made. The Document Compare feature does not compare 

comments in the PDF. 

Comparing a revised PDF to an earlier version 

1. Choose View > Compare. 

2. Specify Old File and New File to be compared. Click Choose… to select the file.  

3. You can preview the pages of both files. Choose the specific page you want to 

preview by dragging the slider or clicking the list box to select the page number.  

4. Choose the specific pages you want to compare. 

5. Click Options and select options as needed:    

• Include 

o Compare Text Only: Select it to compare the text content only.  

o Compare Table: Select it to compare tables. This option is recommended 

for documents that contain tables.  

o Detect Page Deletions or Inserts: With the option selected, when you 

compare documents, if a page is deleted or inserted in a document, the 

application directly marks all text on the page as deletions or insertions 

(rather than comparing the text with the other document) to provide 
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greater accuracy.  

• Color 

Select the desired highlight color for the markups that indicate the replaced, 

inserted, and deleted objects in the comparison results. 

• Opacity 

Specify the opacity for the markups that indicate the replaced, inserted, and 

deleted objects in the comparison results. 

• Line Thickness 

Specify the line thickness for the markups that indicate the replaced, inserted, 

and deleted objects in the comparison results. 

• Set current properties as default 

Select it to apply the current settings to future comparison. 

6. Click OK. And then a PDF document named “The result of Comparison.pdf*” will 

be automatically created and opened in the Foxit PDF Editor Cloud window, and 

the Compare Results context tab appears on the ribbon.  

The result document arranges pages side by side showing Old File and New File 

with the changes marked by different icons and colors. The first page shows a 

summary of the comparison results including the total number and the marks for 

different changes. The second page shows the detailed comparison results 

including the names and sizes of Old File and New File, time compared, and the 

classification of changes, with a color legend in the upper right corner. You can 

click Go to the First Change (page *) on the second page to jump to the first 

change.  

7. In the Compare Results context tab, do any of the following: 

• Click Next/Previous Change to navigate through the changes in the 

document pane in both files.  

• Click Filter and select items to show specific changes you need by text, 

images, annotations, and formatting. Or click Filter > Everything to show all 

changes. 

• Click Show and select items to show/hide the results and the color legend. 

Clicking Show > Show Summary navigates to the summary page. 

8. You can also use the Comments panel in the navigation pane to see each change. 

Click a change to quickly locate it in both documents. See also View all comments. 

9. You can save the results document as needed. 

Word Count 

Similar to Microsoft Word, Foxit PDF Editor Cloud counts words, characters, pages, 

lines and other information in all or part of your document. With no text selected, click 

View > Word Count, and you will see a pop-up Word Count box for the statistics of 

the entire document.  
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Print PDFs 

To print a PDF document, do the following: 

1. Make sure you have installed the printer successfully. 

2. Open the PDF document that you want to print in Foxit PDF Editor Cloud, and then 

do either of the following: 

➢ Click the Print button  on the Quick Access Toolbar. 

➢ Press the shortcut key Ctrl + P.  

3. In the Print dialog box, specify the page range, choose an option from Print What, 

and click OK. 

4. Select a printer and other printing options in the pop-up dialog box, and then 

follow the on-screen instructions to print the document.  

You can choose to print PDF pages associated with the selected bookmarks from the 

Bookmarks panel in the navigation pane. To print from bookmarks, do the following: 

1. In the navigation pane, click the Bookmarks panel and select a bookmark you want 

to print.  

2. Right-click the selected bookmarks and choose Print Page(s) or Print Section(s) 

from the context menu. 

Print Page(s): Only print the pages where the selected bookmarks (including child 

bookmarks) are. 

Print Section(s): Print all the pages in the bookmarked sections (including child 

bookmarks). 

3. Then follow the on-screen instructions to print the pages. See also “Print a PDF 

document”. 
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Chapter 4 – Create 

Up to 3 times faster than other PDF tools, Foxit PDF Editor Cloud makes creating PDF 

and PDF/A documents simple and streamlined. With a click you can quickly convert 

virtually any kind of file to PDF without having to open the source application. 

Create PDFs 

With Foxit PDF Editor Cloud, you can easily create PDFs from files in other formats. 

See also the tutorial on how to Create PDFs. 

Create a PDF from a file 

If you are not currently working on a document (i.e., with no document open in the 

Foxit PDF Editor Cloud window), do the following: 

1. Click the Open File button on the homepage of Foxit PDF Editor Cloud.  

2. In the Open File dialog box, directly drag and drop the desired file into the 

specified area to convert the file to PDF. Note: If you do not want to upload the file 

to Cloud Documents, you can click Preferences above the Choose Files button and 

deselect the Automatically upload local document to Cloud Documents when the 

file is opened option in the Preferences dialog box before dragging and dropping. 

3. A message box will appear in the upper right corner of the Foxit PDF Editor Cloud 

window indicating that the conversion is taking place when the conversion process 

starts.  

4. After the conversion is complete, the converted PDF file will be opened 

automatically in Foxit PDF Editor Cloud. You can download the file to your local 

drive or save it to Foxit Cloud or your cloud service account. 

Alternatively, you can navigate to the Convert to PDF tool on the homepage to create 

PDFs from files. 

With a document open in the Foxit PDF Editor Cloud window, do the following: 

1. Click Convert > From Files > From File. (Tip: You can also directly drag and drop a 

file to the Foxit PDF Editor Cloud window to convert the file to PDF.) 

2. In the Open dialog box, navigate through your local disk to select a local file. Then 

click Open to start the conversion. 

3. A message box will appear in the upper right corner of the Foxit PDF Editor Cloud 

https://www.foxit.com/support/tutorial/
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window indicating that the conversion is taking place when the conversion process 

starts.  

4. After the conversion is complete, the converted PDF file will be opened 

automatically in Foxit PDF Editor Cloud. You can download the file to your local 

drive or save it to Foxit Cloud or your cloud service account.  

Create PDFs from multiple files 

You can easily merge files of different types into a single PDF, or you can also convert 

them into separate PDFs. 

Convert and combine multiple files into a single PDF  

If you are not currently working on a document (i.e., with no document open in the 

Foxit PDF Editor Cloud window), navigate to the Combine PDFs tool on the homepage 

to create PDFs from files.  

With a document open in the Foxit PDF Editor Cloud window, do the following: 

1. Choose Convert > Combine Files.  

2. In the Combine Files dialog box, add files you want to combine by directly 

dragging and dropping files to the file list in the box, or by clicking Add files and 

selecting one of the following options:  

• Local Computer/Cloud Documents/OneDrive/Box/Dropbox/Google 

Drive: You can choose files from local drives, Cloud Documents, or your 

cloud service account.  

• Add WebPage: Input a URL, or browse and select an HTML file you want to 

combine. Then click Create. 

• Add From Clipboard: Create a PDF from the clipboard and add it to the 

file list you want to combine.   

• Add Open File: Choose the currently opened PDF file to add to the file list 

you want to combine. 

3. (Optional) Files you added will be listed in the Combine Files dialog box. You can 

adjust the order of the files to be displayed in the combined PDF by the files’ name 

by clicking the arrows next to the column name in the files list. Or, adjust the order 

of files manually as desired by clicking the /  icon above the file list, or 

dragging and dropping a file to change the file order.  
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4. (Optional) You can specify a page range (odd pages, even pages, or all pages) for a 

PDF file to be converted.  

5. (Optional) If needed, click the  icon to delete the selected files. You can also 

remove the selected files by pressing the Delete key. 

6. (Optional) You can double-click any file in the Combine Files dialog box to open 

the Edit Bookmark for File dialog box, and modify the bookmark title, which will 

be one of the Top-Level bookmarks in the combined PDF after conversion. By 

default, Foxit PDF Editor Cloud combines the bookmarks of the selected files as 

the bookmarks of the combined PDF, with the first level of the combined 

bookmarks named with the original filename of each file. 

7. Select the following options as desired in the Combine Files dialog box.  

 Add a new table of contents page converted from bookmarks: creates a 

table of contents (TOC) from the bookmarks of the selected files in the 

beginning of the merged PDF file. The original filename of each file will be the 

first-level heading of TOC, each of which is followed by the bookmark 

hierarchy of the file.  

 Retain the logic page number during combination: selects it, and the 

combined PDF file will keep the logic page numbers in the original files. 

8. Click Combine to start the combination. (If you want to cancel the combining, 

click the Cancel button.)  

9. After the combination completes, a PDF file is created and opened automatically 

in Foxit PDF Editor Cloud, while the Combine Files dialog box disappears. 

Rename and save the PDF as needed. 

Convert multiple files into separate PDF files 

If you are not currently working on a document (i.e., with no document open in the 

Foxit PDF Editor Cloud window), navigate to the Convert to PDF tool on the homepage 

to create PDFs from files.  

With a document open in the Foxit PDF Editor Cloud window, do the following: 

1. Choose Convert > From Files > From Multiple Files.  

2. In the Convert Multiple Files dialog box, click Add files to select the files you want 

to convert.  

3. Files will be converted in a sequence as they are ordered in the Convert Multiple 

Files dialog box. You can reorder the files by name, modified time, or size by 

clicking the corresponding column name. Alternatively, reorder the files manually 
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as desired by clicking the Move Up/Down button, or by dragging and dropping 

the file in the list. Select a file and click the Remove button to delete it, if necessary. 

4. Click Convert.  

Conversion settings 

When you create PDFs from Microsoft Office files in the Foxit PDF Editor Cloud window, 

you can specify the default conversion settings in advance.  

1. Go to Convert > From Files > Convert to PDF Settings. 

2. In the pop-up Converting to PDF dialog box, select the desired Office file format, 

and choose a set of default conversion settings from the drop-down menu. There 

are five predefined sets of default settings shown as below. You can click Edit to 

create and modify your customized default settings as needed. See also Create 

and modify your customized default settings. 

• High Quality Print: creates PDF files for high quality print but with 

relatively large file sizes. 

• PDF/A-1b: creates PDF files in compliance with the PDF/A-1b standard. 

• Smallest File Size: creates PDF files used for web distribution. 

• Standard: creates PDF files with a balance between print quality and file 

size. 

• USPTO: creates PDF files that are compliant with USPTO (the United States 

Patent and Trademark Office) standards. 

3. Click OK. 

 Create and modify your customized default settings 

1. In the Converting to PDF dialog box, select an Office file type, choose a set of 

default conversion settings from the drop-down menu, and then click Edit. 

2. In the pop-up dialog box, specify the conversion settings in the five tabs in the 

pop-up dialog box. See also Options of default settings for PDF conversion.  

3. After you complete the settings, click OK to save the modification to the current 

set of default settings or click the Save As… button to save the modified settings 

as a new set of default settings which will be added to the default settings list.  

4. The predefined sets of default settings cannot be modified.   

5. (Optional) To toggle between different sets of default settings, click the Edit 

Settings button and select one.  
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Options of default settings for PDF conversion 

 The General tab 

 Description – Enter a summary for the current conversion setting. 

 Compatible With - With Foxit PDF Editor, you can choose the version 

number from 1.3 to 1.7 when creating PDFs. Choosing the right PDF 

reference version can help the PDFs to be better compatible with different 

PDF viewers. See also PDF Versions.  

 Optimize for fast web view – Creates a linearized PDF that can be opened 

and viewed even before the whole file is downloaded.  

 The PDF Standards tab 

Select a PDF standard as needed from the menu under which there is the 

corresponding description for your reference. 

 The Watermarks tab 

Add watermarks to the document – If you want to add watermarks to your 

document, you can select this option and choose to add Image Watermarks or 

Text Watermarks. 

1. Image Watermarks: 

• Image 

You can browse your computer for an image and change the Opacity 

and Rotation of the image which will be added into your document as 

a watermark. 

• Offsets 

This option allows you to adjust the specific position of the watermark 

by specifying the unit of measurement and the distance from the left 

or top edge of the generated PDF page.  

• Scale 

Enter a number in the percentage box to resize the watermark in 

relation to the original image size. 

• Preview 

You can see how the watermark will look like with the selected options. 

2. Text Watermarks: 

• Font 
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This option is activated only when Text Watermarks is selected and 

you can choose the font name, font size and font color from the drop-

down menus. 

• Text 

You can enter text in the Content box and change the Opacity and 

Rotation of the text which will be added into your document as a 

watermark. 

• Offsets 

This option allows you to adjust the specific position of the watermark 

by specifying the unit of measurement and the distance from the left 

or top edge of the generated PDF page. 

• Preview 

You can see how the watermark will look like with the selected options. 

 The Headers/Footers tab 

Add Headers/Footers to the Document 

This option allows you to add headers/footers to your PDF document. By checking 

this option, the following options will be activated. 

Font  

You can choose the font name, font size and font color from the boxes. 

Edit 

This option allows you to edit headers/footers and you can specify their styles. 

You can enter text in the columns (Left Column, Center Column and Right 

Column) if needed. Click Insert Date to insert date to the PDF document. Click 

Insert Page Number to insert page number to the PDF document. 

Offsets 

This option allows you to change the unit of measurement and specify the 

margins for all 4 sides.   

Preview 

You can see how the headers/footers will look with the selected options. 

 The Security tab 

The security feature of PDF gives you exceptional control over PDF files. More 

information about PDF protection, please refer to the Security chapter. 
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Create a PDF from a blank page 

You can create a PDF from a blank page rather than beginning with a file, a clipboard 

image, or scanning. 

1. If you are not currently working on a document (i.e., with no document open in 

the Foxit PDF Editor Cloud window), click the Create Blank PDF button on the 

homepage of the Foxit PDF Editor Cloud window. If you have a document open, 

select Convert > Blank on the ribbon.  

2. Choose Edit > Add Text or Comment > Typewriter. 

3. Click on the blank page to start typing the text you want to add to the blank page.  

4. As needed, select other commands and options that you want to apply to the 

PDF.  

5. Once you have completed you edits, save the PDF file.  

Create a PDF from Clipboard 

You can create a PDF directly from your clipboard. navigate to the Convert to PDF 

tool on the homepage to create PDFs from files. 

1. If you are not currently working on a document (i.e., with no document open in 

the Foxit PDF Editor Cloud window), navigate to the Convert to PDF tool on the 

homepage to create a PDF from Clipboard. If you have a document open, select 

Convert > From Clipboard on the ribbon. 

2. The texts or images in the clipboard will be converted to a new PDF file. 

Create a PDF from Web Page 

To create PDF from web pages: 

1. If you are not currently working on a document (i.e., with no document open in 

the Foxit PDF Editor Cloud window), navigate to the Convert to PDF tool on the 

homepage to create a PDF from Web Page. If you have a document open, select 

Convert > From Web Page on the ribbon. 

2. Input the URL of the web page in the box in the Create PDF From Web Page 

dialog box, or click Browse to choose an HTML file. 

3. Click Settings to set more conversion options. 

The General tab: 
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PDF Settings: set the timeout to load the whole web page. Loading that takes 

longer will be aborted automatically, and only the loaded content will be 

converted to PDF. The default value is 120s. 

Disable all hyperlinks in the generated PDFs: check this item, and all 

hyperlinks will be invalid in the generated PDF. 

Set all the page contents into one single PDF page: check this item, and 

all the related content will be converted to one PDF page. 

Create bookmarks: check this item, and bookmarks for converted web 

pages will be created automatically after conversion. The created 

bookmarks are named with the domain names of the web pages. If the 

web pages share the same domain name, sub-bookmarks will be created 

and named with the page titles. If the page has no title, the URL is used 

instead.   

Create PDF Tags: check this item to create a tagged PDF that includes tags 

and other accessible information such as alt-text for images. With this item 

selected, you can select the Optimize tag tree option to optimize the 

structure tree of the tags in the created PDF, such as by removing some 

unnecessary Div tags. 

The Page Layout tab: specify the page size, margins and orientation for the 

generated PDF as needed. 

Media style:  

Screen: convert the web page exactly as how it is displayed on the screen 

to PDF. This option is selected by default. 

Print: convert the web page based on the Print setting in the web page 

itself.   

Scaling: 

Fixed page with no scale: convert the web page without scaling. 

However, if the web page is too wide and exceeds the PDF page size 

specified above, the generated PDF will be truncated.  

Scale: With this option selected, Foxit PDF Editor Cloud will scale the web 

page if necessary to fit the width of the PDF page size specified above. This 

option is selected by default. 

Enlarge: With this option selected, if the web page is too wide and exceeds 

the PDF page size specified above, Foxit PDF Editor will enlarge the PDF 

page size automatically. 

Create a PDF from a template (Available in Certain 

Languages ) 

Foxit PDF Editor Cloud provides various designed templates including letters, resume, 

invoice, and more. You can choose the desired template and quickly create a PDF from 
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it. (Note: An Internet connection is required to use the feature.) 

1. If you are not currently working on a document (i.e., with no document open 

in the Foxit PDF Editor Cloud window), click the Template button on the 

homepage of the Foxit PDF Editor Cloud window. If you have a document open, 

select Convert > From Template on the ribbon.  

2. In the pop-up Template dialog box, navigate through various templates and 

click on the desired template to open the template in Foxit PDF Editor Cloud 

window. (Tip: To search for a template, enter a search word like letter, resume, or 

invoice in the Search template box. Or, select a category under the search box like 

Business, Marketing, or Human Resources, and choose a desired template.) 

3. Save it as your own PDF document after making edits. 

Create and customize a PDF portfolio 

PDF portfolios are a combination of files with different formats such as Microsoft 

Office files, text documents and Excel files. Foxit PDF Editor lets you quickly create and 

customize a PDF portfolio. 

Create a PDF portfolio 

You can use Foxit PDF Editor Cloud to quickly create a blank PDF portfolio or a new 

PDF portfolio from any file. After creation, you can also add more files, create folders, 

delete files/folders and more within the PDF portfolio. 

To create a new PDF portfolio from files, please do the following:  

1. If you are not currently working on a document (i.e., with no document open 

in the Foxit PDF Editor Cloud window), navigate to the Convert to PDF tool on 

the homepage to create a PDF portfolio. If you have a document open, select 

Convert > PDF Portfolio > Create a new PDF portfolio on the ribbon.  

2. In the pop-up dialog box, select a file you want to attach to a PDF portfolio and 

click Open.  

3. After creation, the generated portfolio will be automatically opened in the 

application, and the Portfolio context tab appears on the ribbon. Then you 

can change the view mode, add more files, and create folders, as needed.  

Tip: To quickly add files, you can copy-and-paste or drag-and-drop files to the 

portfolio. 

You can also choose the Create a blank PDF portfolio option to create a blank PDF 

portfolio from scratch. Once created, you can use the commands in the Portfolio 
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context tab to add files from local drives and create folders.  

For a PDF portfolio without a Table of Contents (TOC), you can click Regenerate TOC 

to create a TOC; for a PDF portfolio with a TOC, if any file/folder is added or removed, 

you can click Regenerate TOC in the Portfolio tab to update the TOC. The headings 

of the TOC generated is made up of the names of folders (including the subfolders) 

and files in the portfolio, arranged in an order that the files and folders are displayed 

in the portfolio. For a folder which is nested with multiple levels of subfolders, in the 

TOC the folder names are displayed up to five levels.   

Customize and modify a PDF portfolio 

You can customize and modify component files and folders in the portfolio using the 

secondary toolbar above the component files list in the Details or Layout view, the 

right-click menu of a component file, and the Portfolio Properties dialog box as 

needed. 

⚫ To delete a file, select it and click the  button in the secondary toolbar, or right-

click it and choose Delete.  

⚫ To extract a file from the portfolio, select it and click the  button in the 

secondary toolbar, or right-click the file and choose Extract from Portfolio…. 

Then specify the name and location of the extracted file. Extracting a file does not 

delete it from the PDF portfolio. 

⚫ To edit the description of the portfolio, please navigate to File > Properties > 

Description.  

⚫ To reduce the size of a PDF file in the portfolio, right-click it and choose Reduce 

File Size…. In the pop-up dialog box, choose a PDF version and click OK. See also 

PDF Versions.   

⚫ To edit the properties of the portfolio, right-click on any file or blank area in the 

portfolio window (except Preview Pane) and choose Portfolio Properties. In the 

Portfolio Properties dialog box, you can: 

o Specify fields (columns) you want to show in the list of component files 

and folders in the portfolio window. Select the check boxes of the fields, 

or click on the field names and click the Show button. The field names are 

displayed under the secondary toolbar. To hide fields, unselect the check 

boxes, or click on the field names and click the Hide button. In the Name 

column, if a folder in the portfolio contains several items, a number in 

parentheses appears after the folder name to indicate the total number 

of the items.  

o Add an optional field. Click Add, enter the field name and click OK. To 
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delete an optional field, select the field and click Delete. The required 

fields such as Name cannot be deleted.  

o Arrange the field order by selecting the field name and clicking Up or 

Down. 

o Specify the order of the files and folders in the portfolio when the portfolio 

is opened. To do this, select a field name in the Sort By menu and then 

choose an order in Sort Order. By default, the component files and folders 

in a PDF portfolio are displayed alphabetically by filename.  

o Specify the initial view of the document by choosing an option from Initial 

View.  

o If the Portfolio Properties dialog box pops up after you right-click a 

component file and choose Portfolio Properties, the Show current 

document when opening portfolio option is available. You can select 

this option so that the file will be opened in the preview pane next time 

you open the portfolio.  

Tip: You can do more actions by right-clicking a file in the portfolio. 

OCR PDFs and PDF Portfolios  

Optical Character Recognition, or OCR, is a software process that enables images or 

printed text to be translated into machine-readable text. OCR is most commonly used 

when scanning paper documents to create electronic copies, but can also be 

performed on existing electronic documents (e.g. PDFs or PDF portfolios).  

Recognize text 

Foxit PDF Editor Cloud can detect whether a PDF file is scanned or image-based and 

make corresponding suggestions to initiate OCR when opening a scanned or image-

based PDF. You can also run OCR anytime to recognize the image-based text in a PDF. 

To recognize image-based or scanned text in a PDF file, perform the following steps: 

1. Click Convert > Recognize Text > Current File.  

2. In the Recognize Text dialog box, specify the page range you need. 

3. Choose the language used in your document. You can select multiple languages 

as well. 

4. In the output type, select Searchable Image Text or Searchable Image Text 

(original image) to make the image text selectable and searchable, or select 

Editable Text to enable the image text to be edited with Foxit PDF Editor. With 

Searchable Image Text or Editable Text selected, you can set a DPI value for the 
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output in the Downsample To item to compress images in the document and 

reduce the file size during the OCR process. 

• Searchable Text Image/Searchable Image Text (original image): 

During the OCR process, Foxit PDF Editor analyzes the image text and 

substitutes words/characters that closely approximates the image text. 

The substitute words/characters will be placed on an invisible layer of text 

in the PDF, which makes the image text selectable and searchable. If the 

substitution is uncertain, the text will be marked as OCR suspects which 

need to be corrected manually. 

• Editable Text: During the OCR process, Foxit PDF Editor compares the 

shape of the image text to the approximate fonts installed on your system, 

and turns the image text into editable text. 

5. (Optional) If you select Editable Text in Step 4, the Recognize the line segments 

as path objects in the PDF option is available. If the image text in your document 

contains tables, selecting this option helps better recognize the line segments, but 

it may take longer to complete recognition.  

6. Click OK. A recognition text process bar will pop up to show the progress. You can 

download the OCRed file after the recognition completes. 

7. Do the search function in the OCRed file, the text on your image or scanned 

document will be searchable or editable.  

Foxit PDF Editor Cloud provides the Quick Recognition command under 

Home/Convert tab to recognize all pages of a scanned or image-based PDF with 

default settings (or the settings you specified in the Recognize Text dialog box last time 

when you use the Recognize Text command) by one-click. 

PDF versions  

When creating or optimizing PDFs, you can choose which PDF version to use by 

selecting a compatibility option (a version from 1.3 to 1.7). The latest version includes 

all the newest features and functionality. Generally, it’s recommended to use the most 

recent version (in this case 1.7) unless you are required to use a backward 

compatibility. Your choice does not affect the functionality in the generated PDFs if 

they are processed in Foxit PDF Editor Cloud, which is designed based on version 1.7 

and supports all the functionality of each version. If processed in non-Foxit PDF 

applications, the generated PDFs may have differences in some of the PDF 

functionality when you choose different versions. For the details about the differences, 

see Help or related documentation for the corresponding application.  
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Chapter 5 – Edit 

Foxit PDF Editor Cloud provides not only general editing features to create bookmarks, 

add links, attach files, add images, play and insert multimedia files on PDF files, but 

also advanced editing features to select, insert, modify, remove and rotate texts, 

images, graphics and shadings. You can go to the Edit tab directly to use different 

editing features to easily and efficiently change contents in any existing PDF files. 

Undo and Redo 

When making quick adjustments to your document, you may want to undo or redo 

the most recent action performed. You can undo and redo up to 10,000 actions in 

Foxit PDF Editor.  

Undo your last action 

 Click Undo  on the Quick Access toolbar of the Foxit PDF Editor Cloud window. 

 Press Ctrl + Z. 

Note: Some actions can’t be undone, such as clicking any command on the File tab. If you 

can’t undo an action, the Undo command will be grayed out . 

Redo actions 

 Click Redo  on the Quick Access toolbar of the Foxit PDF Editor Cloud window. 

 Press Shift + Ctrl + Z.  

Links 

This function helps you to lead the readers to related articles, references, or the 

intended web page. 

You can also add links in PDF files with Foxit PDF Editor Cloud. There are three 

commands of links for you: Link, Web Links, and Bookmark in Foxit PDF Editor Cloud.  
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Link 

Add a link 

The Link command enables you to add a link with the shape of rectangle on the PDFs. 

To add a rectangle link, please do the following: 

1. Choose Edit > Link. 

2. Position the cursor on the place you want to add the link, hold and drag your 

mouse button to draw a rectangle. (Tip: In a tagged PDF, you can create a link directly 

from selected text by right-clicking the selected text and choosing Create Link… from 

the context menu, with the link tag automatically created at the same time.) 

3. Pops up the Create Link dialog box. Specify the appearance and destination of 

the link.  

• Appearance 

A. Thickness – the thickness of the four sides of the rectangle. The higher of the 

value, the thicker of the sides. You can choose the thickness from 0-12, while 

the default is 1. 

B. Border Style – the style of the rectangle’s border. There are three types of the 

border styles: 

Solid: the border is solid, but not hollowed out. 

Dashed: the border is drawn as a dashed line. 

Underline: the sides are visible except the underline. 

                                      

Solid Style              Dashed Style            Underline Style 

Three types of border style 

C. Highlight - the effect when you click the rectangle link. There are four types of 

the highlighting effects: 

None: doesn’t change the appearance of the link. 

Invert: changes the link’s color to its opposite. 

Outline: changes the link’s outline color to its opposite. 
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Inset: creates the appearance of an embossed rectangle. 

                         

None             Invert           Outline           Inset  

Four types of highlight 

D. Color - the border color of the rectangle. Click the color button to choose any 

colors you like, or you may choose Other Color to add a customized color. The 

default color is red. 

• Destination 

The destination refers to any point or location, for example, a web page or a 

position the link goes to. Choose an option from the Select Actions drop-down 

menu: 

A. Go to a page view – designate the link to a specific page view. To go to a page 

view, choose this option, scroll the current document (or type a page number in 

the target box), and go to a position where you want to set. Also, you may change 

the current zoom setting and then set the position. 

B. Open a web link – designate the link to open a web page. Choose this option 

and enter the URL of the destination web page.  

4. Click OK. 

Move or resize a link 

You can move and resize the link after you create it. 

 Choose the Select Annotation command and click on the desired link.   

 Then do one of the following: 

A. To move the link, drag it to the desired area. 

B. To resize the link, drag any corner point to adjust. 

Delete a link 

1. Select the Select Annotation command 
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2. Select the link you want to delete. 

3. Press the Delete key. 

Web Links 

Foxit PDF Editor Cloud allows users to check URLs in the PDF document automatically 

and add link annotations directly to the related URLs. 

Create web links from URLs 

To create web links, please do as following: 

1. Click Edit > Web Links > Create links from URLs.  

2. In the pop-up Create web links dialog box, choose Current Page or All Pages to 

create links from all URL in the current page or all pages in the document, or choose 

From …To and enter a page range to create links on selected pages. Click OK.  

3. A message box will pop up to prompt you how many web links were added to the 

document. 

Remove all web links 

To remove all web links, choose Edit > Web Links > Remove all links. 

Append all web links on the current page  

You can download all web links on the current page and convert the linked web pages 

to PDF pages that will be appended to the end of the current PDF. This feature is 

helpful when some of the content in the linked web pages is not accessible for visually 

impaired users.    

To append all web links on the current page, choose Edit > Web Links > Append All 

Web Links on Current Page. The converted pages are appended to the end of the 

current PDF. By default, only one level of the linked websites is converted to PDF pages 

with bookmarks created. The created bookmarks are named with the domain names 

of the web pages. If the web pages share the same domain name, sub-bookmarks will 

be created and named with the page titles. Please note that after conversion the 

downloaded links in the document will change to internal links that will jump to the 

converted pages in the document when you click them. 
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View all web links on a page 

You can not only view all web links on a page, but also download selected links to 

convert the linked web pages with custom settings to PDFs that will be appended to 

the end of the current PDF.   

1. Choose Edit > Web Links > View Web Links. In the pop-up dialog box, you can 

view all web links in the current page. 

2. Choose a link and click Properties… to customize conversion settings. See also 

Create a PDF from Web Page. 

3. (Optional) click Select All to select all web links in the dialog box, or click Clear All 

to unselect them.  

4. Select the links you want to download, and click Download. Then a progress dialog 

box pops up. 

5. After the downloading completes, you can see the linked web pages are 

successfully converted and appended to the end of the current document. Please 

note that after conversion the downloaded links in the document will change to 

internal links that will jump to the converted pages in the document when you click 

them. 

Bookmarks 

Please refer to Bookmarks. 

Bookmarks 

Bookmarks are navigational tools that make your PDF files easier to read. They are 

usually generated automatically during the PDF creation.  

Bookmarks are useful for users to mark a place in a PDF file so users can return to it 

with ease. Or you may like to have your own bookmark structure and new bookmark 

names. With Foxit PDF Editor Cloud, you can easily nest, edit, or delete bookmarks in 

a PDF file if the security settings allow.  

Add a bookmark 

1. Choose View > View Setting > Navigation Panels > Bookmarks or click the 

Bookmarks icon  on the navigation panel to open the Bookmarks panel. 

2. Go to the page where you want the bookmark to link to. Or select the text that you 
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want to add to a bookmark in the document pane. 

3. Adjust the view settings, if necessary.  

4. Select the bookmark (if any) after which you want to place the new bookmark. If 

you don’t select a bookmark, the new bookmark is automatically added at the end 

of the bookmark list.  

5. Do any of the following: 

 (For selected text only) Click the Bookmarks icon on the toolbar floating 

above the selected text. Or right-click the selected text and choose 

Bookmark. 

 Click Edit > Bookmark.   

 Click the New Bookmark icon  at the top of the Bookmarks panel. 

 Right-click the selected bookmark, and choose Add Bookmark. 

 Click the Options menu  at the top of the Bookmarks panel, and choose 

Add Bookmark.  

 Press the shortcut key Ctrl + B.  

6. Type or edit the name of the new bookmark, and press Enter. 

Add tagged bookmarks 

If your document is a tagged PDF document, you can add bookmarks from the 

structural information of the document elements (such as headings and paragraphs), 

which will help you easily navigate and work on the document. You can create a tagged 

PDF from a document that can be structured in its authoring application (such as 

Microsoft Word).  

To add tagged bookmarks, do as the following: 

1. Go to the Bookmarks panel in the navigation pane. 

2. Click the Options menu and choose New Bookmarks from Structure…. If your 

document is not a tagged PDF, the option is greyed out and not available. 

3. In the pop-up dialog box, select the structure element you want to create tagged 

bookmarks from. To select multiple elements, Ctrl-click or Shift-click the elements 

you need; to select all elements, click the Select All button in the dialog box. To 

unselect all the elements you selected, click Clear All.   

4. Click OK. Then the tagged bookmarks are created and nested under a new 

bookmark named “Untitled” by default.  
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Edit a bookmark 

In Foxit PDF Editor Cloud, you are able to rename a bookmark, reset a bookmark’s 

destination, or customize the text appearance of a bookmark with ease if the security 

settings allow.  

 To rename a bookmark 

Right-click the bookmark you want to rename in the Bookmarks panel > Rename> 

type the new bookmark name. Or you double click the bookmark you want to 

rename and then type the new name. 

 To change a bookmark’s destination 

You can change a bookmark’s destination by doing either of the following: 

 In the document pane, move to the location you want to specify as the new 

destination. Adjust the view magnification as needed. Right-click the 

bookmark, choose Set Destination, and select Yes in the pop-up dialog box. 

If you do not want to see the dialog box the next time you reset a bookmark’s 

destination, select the Don’t show again option in the dialog box. 

 Change a bookmark’s destination via the Properties dialog box: 

1) Right-click the bookmark in the Bookmarks panel and choose 

Properties. Or, select the bookmark, click the Options menu  at the 

top of the Bookmarks panel, and select Properties. 

2) Choose the Actions tab in the pop-up Bookmark Properties dialog box. 

Under Actions, you can see the current trigger and action for the 

bookmark. Select the action Go to a page view and then click the Edit 

button. 

3) Enter the page number in the Target box, set the page view of the new 

destination as needed, and click OK.  

4) Click Close in the Bookmark Properties dialog box.  

 To customize the text appearance of a bookmark 

1. In the Bookmarks panel, click on a bookmark to select one bookmark.  

2. At the top of the Bookmarks panel, click the  or  button to enlarge 

or reduce the text size of all the bookmarks.  

3. Right-click the selected bookmark and choose Properties. 

4. In the Bookmark Properties dialog box, click the Appearance tab, and select 
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the font style and color for the text. 

Note: After defining a bookmark’s appearance, you can set it as bookmarks’ default 

property by right-clicking the bookmark and then selecting the option of Use Current 

Appearance as New Default. 

 To add an action to a bookmark 

1. Right-click a bookmark, and choose Properties. 

2. In the Bookmark Properties dialog box, click Actions. 

3. Choose an action from the Select Action menu and click Add, and then refer 

to the section of “Actions tab for the button properties”. 

 To delete a bookmark, please do one of the following: 

1. Select the bookmark you want to delete and click the Delete button  at 

the top of the Bookmarks panel.  

2. Right-click the bookmark you want to delete and choose Delete. 

Note: Deleting a bookmark deletes all the bookmarks that are subordinate to it. 

Move a bookmark 

Select the bookmark (named “Bookmark A”) you want to move, and then do one of the 

following: 

• Hold the mouse button down and then drag “Bookmark A” directly to the desired 

place. A dashed line shows the place where the bookmark will be located. 

• Right-click “Bookmark A” > choose the Cut option > right-click the bookmark 

(named “Bookmark B”) under which you want to place “Bookmark A” > choose 

“Paste after Selected Bookmark” (“Bookmark B” will be in the same hierarchy with 

“Bookmark A”) or choose “Paste under Selected Bookmark” to put “Bookmark A” 

under the “Bookmark B” (“Bookmark B” will be the parent bookmark). 

Note: The bookmark links to its original destination in the document although it is moved. 

Organize a bookmark hierarchy 

A bookmark hierarchy is an outline or stratified structure that places some bookmarks 

within others. In Foxit PDF Editor Cloud, multilevel bookmark hierarchy can be defined 

by properly dragging the bookmark icon in the Bookmark panel.  
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To nest a bookmark or move a bookmark out of nested position, please refer to Move 

a bookmark. 

 To expand or collapse a bookmark 

In a bookmark hierarchy, to expand a bookmark (a parent bookmark with child 

bookmarks) and show the child bookmarks, directly click the plus sign (+) next to the 

parent bookmark. Click the minus sign (-) to collapse the parent bookmark and hide 

its child bookmarks. To collapse all bookmarks, right-click any bookmark in the 

Bookmarks panel (or click the Options menu  at the top of the Bookmarks panel) 

and choose Expand/ Collapse All Bookmarks. When no bookmarks are expanded in 

the Bookmarks panel, you can right-click any bookmark (or click the Options menu 

at the top of the Bookmarks panel) and choose Expand/ Collapse All Bookmarks to 

expand all bookmarks. 

Page thumbnails 

Page thumbnails, which are miniature portraits of pages in a document, are displayed 

in the Pages panel in the Navigation pane. Clicking on a page thumbnail takes you to 

the corresponding page in the document. Page thumbnails are useful for performing 

whole-page operations such as reorganizing PDF pages. For more information, please 

refer to Chapter 6 – Organize.  

You can also resize, embed, and unembed thumbnails. 

Resize page thumbnails 

You can click the Pages panel in the Navigation pane to view the page thumbnails. To 

resize a page thumbnail, right-click any thumbnail and choose Enlarge Page 

Thumbnails or Reduce Page Thumbnails. 

Note: Page thumbnails revert to their default size if you close and reopen the PDF document. 

Embed page thumbnails 

By default, in an opened PDF document, you can see the page thumbnail in the Pages 

panel in the Navigation pane. These page thumbnails are created on-the-fly whenever 

you open the Pages panel. For large documents, generating the page thumbnails can 

take several seconds.  
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Embedding page thumbnails into the document makes them appear faster, but 

increases the file size. Page thumbnails are not embedded by default. To embed page 

thumbnails, do as the following: 

1. Right-click any thumbnail and choose Embed All Page Thumbnails.   

2. Click OK in the pop-up message box. 

3. Save the file. 

Remove embedded page thumbnails 

You can remove the embedded page thumbnails from the document, which reduces 

the file size of the document. 

1. Right-click any thumbnail and choose Remove Embedded Page Thumbnails.   

2. Click OK in the pop-up message box. 

3. Save the file. 

Destinations 

When creating a link in a PDF, you can link to a specified destination in the document. 

With Foxit PDF Editor Cloud, you can create and manage destinations in the 

Destinations panel in the navigation pane.  

Create a destination 

1. Navigate to the location in the document you want to set as the destination.  

2. In the Destinations panel, click the Create new destination icon or choose the 

New Destination command from the Options menu. Name the destination. 

3. Save the document. 

Manage destinations 

You can sort, change, and delete destinations in the Destinations panel. 

Sort destinations 

To sort destinations, choose Sort by Name or Sort by Page from the Options menu 

in the Destinations panel. 
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Change destinations 

To navigate to the location of a destination in the document, double-click the 

destination in the Destinations panel, or right-click the destination and choose Go To 

Destination. You can change the target location and the name of a destination by 

doing the following: 

• To change the target location of a destination in the document, navigate to the 

desired location, right-click the destination in the Destinations panel, and 

choose Set Destination. 

• To rename a destination, select the destination in the Destinations panel, click 

on the name of destination and type a new name. Or right-click the destination 

in the Destinations panel and choose Rename. 

Delete destinations 

To delete a destination, right-click a destination in the Destinations panel and choose 

Delete. Or choose the destination and press Delete on the keyboard. 

File Attachments 

You can attach PDF files and other types of files to a PDF. There are two options for 

you to add an attachment: attaching a file as a comment and attaching a file to the 

entire PDF. An attached file as a comment will appear in the page with the File 

Attachment icon  by default, while the attached file to the PDF file acts invisible 

and only can be seen when you click the Attachment panel in the navigation pane. 

Add a file as a comment 

1. Choose the File command in the Comment tab. 

2. Position the pointer to the place where you want to attach a file as a comment > 

click the selected position. 

3. In the Open dialog box, select the file you want to attach, and click Open. 

Note: If you try to attach certain file formats (such as EXE), Foxit PDF Editor will provide 

you with a warning that your attachment will be denied due to your security settings. 

4. The File Attachment Icon  appears at the place you designated in the PDF file.  

5. (Optional) When you click the icon , you will find a toolbar floating around the 
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comment, which allows you to change the color of the icon quickly. Or you can 

change the appearance of the icon in the Format tab that appears in the right 

panel when you select a comment or are making a comment.  

6. (Optional) Add a text message to the file attachment comment. To do this, click 

the icon , select the Edit note icon  on the floating toolbar to open the 

pop-up note on the document pane, and then type a text message.  

7. (Optional) You can move the file attachment icon. Select the Hand command or 

the Select Annotation command, click and drag the File Attachment Icon to move 

it to another place you like. 

You are able to work on an attachment comment just like an ordinary comment, 

including setting status, marking with checkmarks, opening pop-up notes and adding 

some descriptions, replying to the comment, and changing the icon’s appearance. For 

all the operations, please refer to “Chapter 7 – Comment”. 

Add a file to the entire PDF as an attachment 

1. Click the attachment button  on the navigation pane and click Add button  

in the Attachments panel, or choose Edit > File Attachment. 

2. In the File Attachment dialog box, click the Add Files… button. Navigate through 

your local disk to select local files, and click Open.  

3. Click OK after adding the desired files.  

4. The added document will be displayed in the attachment panel. 

Tip: Save the document after adding file attachments, and a red dot appears on the icon 

of the attachment panel  in the navigation pane. 

Work on an attachment 

You can save, edit descriptions, delete and do settings to the attachments. Click the 

attachment button  on the navigation pane to open the Attachments panel > 

select the desired attachment(s) > click the Save button /Add button  /Edit 

Description button  / Delete button . 
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Delete an attachment comment 

To delete an attachment, select the attachment and click the Delete button in the 

Attachments panel. For an attachment as a comment, you can also delete it in one 

of the following ways: 

 Select the Hand command, Select Annotation command, or the 

corresponding commenting tool > click the file attachment icon  > press the 

Delete key. 

 Select the Hand command, Select Annotation command, or the 

corresponding commenting tool > right-click the file attachment icon > choose 

Delete from the context menu. 

 Choose Delete from the Options menu (the vertical three-dot icon  in the 

upper right corner of the pop-up note of the comment). 

Images 

You can specify a rectangle on any part of a PDF page and then insert an image into 

that rectangle. This feature is helpful when you want to explain or show something 

more dynamically.  

Add an image 

You can add an image to a PDF with the Image Annotation command. After you insert 

a new image, you can adjust its size and position, change the appearance and other 

settings, etc. 

To add an image, do the following: 

1. Choose Edit > Image Annotation. 

2. Drag a rectangle on the page to define the canvas area for the image. 

3. In the Add Image dialog box, click the Browse button to select the image that you 

want to insert and click the Open button.  
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Move and resize an image 

To move an image, please do the following: 

1. Select the Select Annotation command. 

2. Click and drag the image to another place you like. 

To resize an image, please do the following: 

1. Select the Select Annotation command and then click the image. 

2. Place the cursor on any corner point. The cursor changes into the cursor showing 

the direction at which the rectangle will be resized. 

 

To resize the image 

3. Drag the cursor outside, it will increase the size of the rectangle proportionally. 

Drag the cursor inside and it will decrease the size of the rectangle proportionally. 

Set properties of an image 

1. Right-click the image with the Select Annotation command and select Properties…. 

2. In the Appearance tab, adjust the image's border settings, including its thickness, 

style, color, and opacity, and do any of the following: 

 Locked – When selected, prevents any further changes to any image 

properties.  

 Close – Applies and saves the current properties, and closes the image 

properties dialog box. 

3. For the Actions tab, please refer to “Actions tab for the button properties”. 

Delete an image 

1. Select the Select Annotation command and then click the image. 

2. Press Delete or right-click the image > Delete. 
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Arrange images 

To select multiple images, do as the following: 

1. Select the Select Annotation command. 

2. Press and hold Shift or Ctrl and click the images you want to edit.  

Align images 

 Select two or more images that you want to align. (Tip: When you right-click or Ctrl-

click one of the selected images, it will be the anchor image.) 

 Select a type of alignment from the toolbar floating around the selected images, 

or right-click the anchor image and choose Align. Then choose a type of alignment.  

A. To align a column of images, choose Left, Right, or Vertically to align them 

respectively to the left edge, right edge, or vertical axis of the anchor image. 

B. To align a row of images, choose Top, Bottom, or Horizontally to align them 

respectively to the top edge, bottom edge, or horizontal axis of the anchor 

image. 

Note: The alignment commands move the other selected images to line up with the edges 

of the anchor image. 

Center images 

This function enables you to center the selected images as a whole vertically, 

horizontally, or both. To center the selected images, select a type of centering from 

the toolbar floating around the selected images, or right-click the anchor image > 

Center > choose a type of centering. 

Distribute images 

This function will be available when selecting three or more images. 

 To distribute the images evenly between the topmost and bottommost images, 

choose Vertically from the Distribute group or from the toolbar floating around 

the selected images, or right-click the anchor image > Distribute > Vertically. 

 To distribute the images evenly between the leftmost and rightmost images, 

choose Horizontally from the Distribute group or from the toolbar floating 

around the selected images, or right-click the anchor image > Distribute > 
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Horizontally. 

Resize multiple images 

You can adjust multiple images with the same height, width, or both. Select one of the 

images as the anchor, and the rest of the images will be resized with the same height 

or width as that of the anchor image. To resize the selected images, right-click the 

anchor image > Size > choose Height/Width/Both. 

Setting properties of multiple images 

 Select multiple images > right-click one of them > Properties… 

 A dialog pops up with an Appearance tab. Follow the steps specified in “Setting 

properties of an image”. 

PDF Optimizer 

With PDF optimizer, users can update the PDF version and reduce file size by 

compressing contents, unembedding fonts, and clearing out the data redundancy of 

PDF objects. Users can optimize PDFs with custom advanced settings, or reduce file 

size quickly with the default settings. 

Reduce file size with default settings 

You can use the Reduce File Size command to quickly optimize documents with the 

default settings, which are suitable for a wide range of documents. With this command, 

you can also reduce file size for multiple files at the same time. To reduce file size with 

default settings, do as the following: 

1. Choose File > PDF Optimizer > Reduce File Size. 

2. A dialog box pops up. For PDF Version Compatibility, choose Retain existing to 

keep the current PDF version, or choose a desired PDF version from the drop-

down menu. Then click OK. 

Advanced optimization 

With the Advanced Optimization command, you can select professional settings to 

achieve advanced PDF optimization. To optimize PDF with advanced settings, please 

do as the following: 
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1. Choose File > PDF Optimizer > Advanced Optimization. 

2. The PDF Optimizer dialogue box pops up. 

3. Click Audit space usage to see the space usage of the current PDF file and then 

you can decide which items are needed to be optimized. 

4. In Make compatible with, select a PDF version to save the current file under. See 

also PDF Versions. The settings available in the following steps vary from different 

PDF versions.  

5. Select the check box next to an item on the left and do the corresponding settings 

as needed on the right. If you deselect the check box for an item, all the settings 

associated with the item will not be applied. For the detailed options in each item, 

please refer to Advanced optimization options. 

6. Click OK and save the optimized PDF file.  

Advanced optimization options 

There are five panels where you select advanced options for PDF optimization:  

Color/Grayscale Images, Unembed Fonts, Discard Objects, Discard User Data, and 

Clean Up.  

 The Color/Grayscale Images panel 

In the Color/Grayscale Images panel, you can select options to specify downsampling 

and compression for color, grayscale, and monochrome images. 

Downsample: Select a downsampling method, and set the appropriate image 

resolution values. For images with higher resolution than the For Images Above value 

you input, reduce the image resolutions to the specified resolution by merging pixels 

in a sample area of the image to make one larger pixel. 

◆ Off – Turn off downsampling.  

◆ Average Downsampling - Average the pixels in a sample area and then 

substitute the entire area with the average pixel color at the resolution you 

specified.  

◆ Subsampling - Select a pixel from a sample area and then substitute an entire 

area with the selected pixel at the specified resolution. This method reduces 

conversion time as compared with downsampling, but the generated images are 

less smooth and continuous. 

◆ Bicubic Downsampling - Use a weighted average, instead of a simple average (as 

in Average Downsampling) to decide pixel color. This method increases 

conversion time but produces the smoothest tonal gradations. 
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Compression: Reduces file size by removing unnecessary pixel data. You can specify 

a compression standard to process images. Generally, apply ZIP, JPEG, or JPEG 2000 

compression to color/grayscale images, and ZIP, JBIG2, CCITT Group 3 or 4, or Run 

Length compression to Monochrome images. You can make your choices by following 

these rules: 

⚫ JPEG and JPEG 2000 compression give better results on images like photographs 

with gradual transitions from color to color. JPEG 2000 produces a higher quality 

final image, even when using lossy compression. 

⚫ Because JPEG compression eliminates data, it can achieve much smaller file sizes 

than ZIP compression. 

⚫ ZIP is the better choice for illustrations with large areas of single colors or 

repeating patterns, and for monochrome images that contain repeating patterns.  

⚫ CCITT (Consultative Committee on International Telegraphy and Telephony) 

compression is available only for monochrome bitmap images. CCITT Group 4 is 

a general-purpose method that produces good compression for most 

monochrome images. CCITT Group 3, used by most fax machines, compresses 

monochrome images one row at a time. 

⚫ JBIG2 (Lossless)/ JBIG2 (Lossy) is appropriate for bi-level or monochrome images 

which is suitable for lossless or lossy compression. For monochrome images, 

JBIG2 compression is superior to CCITT.  

⚫ Run Length produces the best results for images that contain large areas of solid 

white or black. 

⚫ High Compression applies to almost all images. If you intend for small-size images 

and don’t care about the quality, High Compression can produce smaller images 

than other compression methods do. (Available in Foxit PDF Editor Pro Only) 

Tile Size: Divides the image being compressed into tiles of the specified size. (If the 

image height or width is not an even multiple of the tile size, partial tiles are used on 

the edges.) Image data for each tile is individually compressed and can be individually 

decompressed. The default value of 256 is recommended. This option is available only 

for JPEG 2000 format. 

Quality: Available only for JPEG compression, JPEG 2000 compression, High 

Compression, and JBIG2 compression. You can apply JPEG compression, JPEG 2000 

compression, or High Compression to color and grayscale images at various levels 

(Minimum, Low, Medium, High, Maximum). JPEG and JPEG 2000 compression methods 

are typically lossy, which permanently remove some pixel data and may reduce image 

quality. JPEG 2000 compression also offers lossless compression which means no pixel 

data is removed. Compression for monochrome images is lossless, except for JBIG2 

compression and High Compression. 
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Optimize images only if there is a reduction in size: With the option selected, 

images will not be optimized if there are no reductions in file size from the image 

setting. 

 The Unembed Fonts panel 

Embedding all fonts allows anyone who opens your file to see the document as you 

intended it to be seen. Without embedding fonts, the PDF viewer will substitute a font 

with a close match or a default font which is available on the computer, and the display 

results may be not exactly what you intended. If you don’t mind the difference and 

prefer a smaller file, you can unembed fonts.  

This panel contains two lists for fonts: fonts that are available for unembedding, and 

fonts to unembed. To unembed fonts in a document, do as the following: 

1. Select the checkbox for the panel first. 

2. Select one or more fonts you want to unembed in the Embedded fonts list, 

and click the Unembed>> button to add the fonts to the Fonts to unembed 

list. If you want to only embed the characters (a subset of a font) used in the 

document, select the Subset all embedded fonts option.  

3. (Optional) To remove the added fonts from the Fonts to unembed list, select 

the font and click the <<Retain button. If you don't want to unembed any font 

in the document, select Do not unembed any font. 

 The Discard Objects panel 

The Discard Objects panel lists options that allow you to remove objects from the 

PDF.  

Discard all form submission, import and reset actions: Disables all actions related 

to submitting/importing form data and resetting form fields. This option retains form 

objects to which actions are linked. 

Flatten form fields: After flattening, all form fields can no longer be filled or modified. 

Only the items that are visible with the Hand command selected remain and change 

into shape objects. 

Discard all JavaScript actions: Removes all actions in the PDF that use JavaScript. 

This option is selected by default. 

Discard all alternate images: For an image that includes multiple versions, removes 

all versions except the one used for on-screen viewing. Different versions may be used 

for different purposes, such as low-resolution on-screen viewing and high-resolution 
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printing. 

Discard embedded page thumbnails: Removes page thumbnails embedded in the 

document. See also Embed page thumbnails. 

Discard document tags: Removes all tags from the document, which will have an 

impact on the document accessibility.  

Detect and merge image fragment: Detects image fragments in the document, and 

merge the adjacent image fragments with the same image properties into an image 

object if the number of fragments is more than 25.    

Discard embedded print settings: Removes print settings embedded in the PDF, 

such as page scaling and duplex mode. 

Discard embedded search index: Removes the search indexes embedded in the 

document. 

Discard bookmarks: Removes all bookmarks from the document. 

 The Discard User Data panel 

This panel allows you to specify whether to remove personal information including 

comments, attachments, layers, and document metadata.  

Discard all comments, forms and multimedia: Removes all comments, forms, form 

fields, and multimedia from the document. 

Discard external cross references: Removes links to other documents, not including 

the links that go to pages within the PDF. 

Discard document information and metadata: Removes data in the document 

information dictionary and all metadata streams, such as the information in the File > 

Properties > Description. 

Discard file attachments: Removes all file attachments, including the attachments 

that are added to the PDF as comments.  

Discard private data of other applications: Removes the information in PDF 

documents that is related only to the application that created the PDF documents.  

Discard hidden layer content and flatten visible layers: Remove all layers’ 

information. All layers in the Layers panel will be removed.  
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 The Clean Up panel 

Use the Clean Up panel to remove useless items (obsolete or unnecessary elements) 

from the document. Removing certain elements can seriously affect the functionality 

of the PDF. By default, only elements that do not affect document functionality are 

selected. 

Use Flate to encode streams that are not encoded: Applies the Flate compression 

to all streams that aren’t encoded in the document. 

In streams that use LZW encoding, use Flate instead: Applies the Flate 

compression to all content streams and images that use LZW encoding in the 

document. 

Remove invalid bookmarks: Removes invalid bookmarks that go to the pages that 

have been deleted in the document. 

Remove invalid links: Removes links that jump to the destinations that no longer 

exist. 

Discard unreferenced named destinations: Discards named destinations that are 

not being referenced internally from within the document.  

Optimize the PDF for fast web view: Restructures the document for page-at-a-time 

downloading from web servers, which allows users to open and view the PDF even 

before the whole file is downloaded. 

Optimize Scanned PDF 

Foxit PDF Editor supports the size optimization of scanned PDFs during PDF creation 

from a scanner or by choosing File > PDF Optimizer > Optimize Scanned PDF in an 

existing scanned or image-based PDF.   

1. Open the PDF you want to optimize in Foxit PDF Editor Cloud, and choose File > 

PDF Optimizer > Optimize Scanned PDF. 

2. In the pop-up dialog box, do the following settings as needed and click OK. 

Page Range: Specifies the page range you want to optimize. 

Optimize Options: 

• Color/Gray settings: when scanning color or gray pages, select JPEG, 

JPEG2000(Lossless) or JPEG2000(Lossy) to apply JPEG compression to the 

entire gray or RGB input page. Select High-Compression to apply image 

compression in high-quality with small size (Available in Foxit PDF Editor Pro 
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Only). 

• Low/High Quality: drags the slider to set the balance point between file size 

and quality. 

• Monochrome: when scanning black-and-white or monotone images, select 

one of the following: 

 JBIG 2(Lossless)/ JBIG2(Lossy): apply an image compression standard for 

bi-level images which is suitable for lossless or lossy compression. 

 CCITT Group 4: applies CCITT Group 4 compression to black-and-white 

input page images. 

 High-Compression: applies to high-quality with small size compression. 

(Available in Foxit PDF Editor Pro Only) 

Make Searchable(run OCR): checks this item and clicks Options to run OCR in 

scanned PDFs. See also “Recognize Text”. 

Work with Video & Audio 

Foxit PDF Editor Cloud not only supports playing videos and audios in PDFs, but also 

allows users to add multimedia files to a PDF. 

Play a Movie or a Sound Clip 

Some PDF files may be multifaceted with multimedia, including sound, music, and 

video clips. Each movie and sound file usually includes a play area from which the 

media can be activated. The play area typically appears on the PDF page as an image 

or a blank rectangle, but can also be invisible. To play the media files, please make 

sure you have the necessary media player installed on your computer. 

To play a movie or a sound, please do the following: 

 Select the Hand command, and click the play area of the movie or sound file. 

Adding a movie or a sound clip 

Adding movies or sounds to PDFs is as easy as inserting an image. "Movies" are 

desktop video files with formats such as AVI, QuickTime, and MPEG, and file 

extensions such as.m4v, .mp4, and .mov. “Sounds” are like .wav and .mp3 files. 

Note: If an alert message tells you that no media handler is available, you must install the 

appropriate player before you can add clips to the PDF. For example, you must install 

RealPlayer if you want to embed an RMVB file in a PDF. 

Adding movies or sounds 
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1. Choose Edit > Video & Audio.  

2. Press and hold mouse button down, drag to select an area on the page where you 

want the movie or sound to appear. For movies, the play area is the exact size of 

the movie frame. 

3. In the pop-up Add Video & Audio dialog box, you will see some options listed 

below: 

• File: click Choose file to select the multimedia file you want to insert. 

• Recorder: click the  icon to record sound with your installed microphone.  

• Poster File: add a poster by clicking Choose file to display an image in the play 

area when the movie isn’t playing.  

Edit the play area 

To move, resize, align, center or distribute a multiple clip, please refer to “Images”. 

Set Video & Audio properties 

In Foxit PDF Editor Cloud, you can specify properties for the multimedia files you 

added, such as the appearance of a movie’s play area, whether the movie plays once 

or continuously, create alternate renditions, etc. 

To set video & audio properties, please do the following: 

1. Select the Select Annotation command. 

2. Right-click the play area > Properties. 

3. For the Appearance tab, please refer to “Setting properties of an image”. 

Note: If you select Locked on any tab, it will lock all options for this multimedia file, but not 

just the options on that tab. 

4. Actions tab for the Video & Audio properties 

Please refer to “Actions tab for the button properties”. 

Search and Replace Text 

The Search & Replace function allows you to quickly update text that occurs multiple 

times in the document. Foxit PDF Editor Cloud allows you to search for specific text 

and replace it with your new text. 
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1. Click the Search features icon in the upper right corner of the Foxit PDF 

Editor Cloud window and choose Search & Replace. 

2. A window appears in the top-right corner of the application window. 

3. Type the text that you want to find and replace in the Find box, and the 

replacement text in the Replace With box. Only text objects in the document will 

be found, not including text in a bookmark, a comment, or form data. 

4. (Optional) You can specify settings for the search by clicking the cog icon in the 

Find box and selecting the following options: 

• Whole Words Only: When selected, only instances that match the complete 

words specified in the Find box will be found. 

• Case Sensitive: When selected, only instances that match the capitalization of 

the string specified in the Find box will be found.  

5. Click Replace (or Replace Next) to replace next occurrence of your specified text 

with the replacement text, or click Replace All to replace all instances of the search 

text in the document with the replacement text.    

Paragraph Editing 

With the Edit Text command, you can edit texts in a paragraph like Microsoft Office 

Word as well as changing their font, font size and color. 

To edit texts in a paragraph, please do the following: 

 Select Edit > Edit Text. (Tip: You can also right-click the selected text with the Select 

Text and Image command and choose Edit Text to start editing text in the paragraph 

quickly.) 

 Click on the desired paragraph to start editing. And you can set the text formatting 

in the Format tab that appears in the right panel. (Refer to the tables below for 

the instructions about the Text Style buttons. More editing features please refer 

to Edit Objects.) Foxit PDF Editor Cloud will automatically change a line when the 

text comes to the margin of it. You can also start a new line by pressing Enter. See 

also the tutorial on Edit PDF. 

https://www.foxit.com/support/tutorial/
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The Text Style buttons in the Format tab 

Button Name Description 

 Bold 
Text with bold formatting has thicker strokes than its ordinary 

form.  

 Italic Text with italic formatting leans to the right.  

 Underline Draw a line under the text. 

 Strikethrough  
Draw a line to cross out text, making others know the text is 

deleted. 

 Superscript  
Decrease the font size proportionally and raise the baseline, like 

the registered trademark symbol ® .  

 Subscript  
Decrease the font size proportionally and lower the baseline, like 

a footnote. 

 
Font Color 

Simply click on the font color button to apply the color shown to 

the text, or click on the drop-down menu to select a color for the 

text. 

 
Character 

Spacing 
Set the space between each individual character that you type. 

/   
Writing 

Direction 

Set the writing direction (left-to-right or right-to-left) in which you 

type text. 

 

Button Name Description 

 Bullets 
Create a bulleted list for paragraphs. Click on the drop-down 

menu to choose a bullet style.  

 Numbering 
Create a numbered list for paragraphs. Click on the drop-down 

menu to choose a number style. 
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 Align Left Align the left edge of the paragraph to the left margin. 

 Center  
Center each line of the paragraph with even space on both sides. 

 Align Right  
Align the right edge of the paragraph to the right margin. 

 Justify  Align both sides of the paragraph with both margins. 

 
Increase 

Indent 
Move the paragraph farther away from the left margin. 

 
Decrease 

Indent 
Move the paragraph closer to the left margin. 

 Line Spacing Set the space between each line in a paragraph. 

 
Paragraph 

Spacing 
Set the space between two paragraphs.  

 Word Spacing Set the space between each word. 

 
Character 

Scale 
Set the width of each character. 

Note: Clicking on a scanned or image-based PDF with Edit Text command, a message 

prompts where you can click Recognize Text to run OCR, or click Settings to specify OCR 

settings before recognizing text. To not show the prompted message again, you can go to 

File > Preference > Editing > uncheck the option “Alert when there’s no editable text when 

using ‘Edit Text’ tool”.  

Objects 

When reading a PDF, you may need to frequently edit text, image, or other objects in 

this PDF file. With Foxit PDF Editor Cloud, you can add, edit, modify, join and split 

objects.  

Add New Objects 

You can add or insert new text, image or shape objects into a PDF using respective 

commands in the Edit tab. 
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Add new text objects 

To add text objects, please do the following:  

1. Select Edit > Add Text, and do either of the following:  

• Click on the specific page you want to input the text and type new text in the 

position where the cursor is blinking. You can also paste or delete the text you 

input. 

• Click and drag an area to define a text box as required, and then type text into 

the box. The text wraps automatically when it reaches the edge of the box you 

defined. 

2. (Optional) With the Add Text command selected, click anywhere in the text box. 

Then move the cursor over the box border and the cursor changes into . As 

you drag the cursor, alignment guides (green lines) appear to help you find a 

location to align it to an existing object on the page.  

3. You can choose the text font format as you want in the Format tab that appears 

in the right panel. In the Format tab, you can also align the text and set other 

paragraph formats including word spacing, character scale, line spacing, etc. 

Add new image objects 

You can add an image object from a file by doing the following:  

1. Locate the page where you want to insert the image in your document, and 

choose Edit > Add Image From File.  

2. Choose the target image file in the Open dialog box and click Open. Then the 

image will be added to the document.  

3. You can right-click the image and choose Edit Object to move or resize the 

image.  

Add new shape objects 

With Foxit PDF Editor Cloud, you can also directly insert path and shading objects like 

rectangles, curve, straight line, etc. into your PDF as well as text objects and image 

objects. Shading objects are generally used to make shadows or nice backgrounds.  

Add a path object 

Add a shading object 
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 Add a path object 

To add a path object, please do the following: 

 Locate the page where you want to insert the path in the document, and 

choose Edit > Add Shapes > choose one path you need. The cursor changes 

into a cross . Click and drag the cursor to draw the path you want. Then 

click on the path, and the Format tab will appear in the right panel for you to 

modify the path with the commands. You can also adjust the size and shape 

by dragging the sizing handles. 

Note: Sizing handles are the small circles or squares that appear at the corners and sides 

of a selected object. You drag these handles to change the size of the object. 

 

                     A   B   C   D    E   F   G   H   I 

A. The Line command   B. The Rectangle command   C. The Round Rectangle command   

D. The Ellipse command   E. The Polyline command   F. The Polygon command   G. The 

Bezier command   H. The Close Bezier command   I. The Free Paint command  

To draw a straight line   

1. Choose the Line command. 

2. Click a region in the document where you want to create the drawing and draw 

the line. 

3. Drag the handles to adjust the line size if necessary. 

4. Click outside the path when you are done to set the line. 

To draw a rectangle  

1. Choose the Rectangle command to create a square-cornered path, or click the 

Rounded Rectangle command to create a round-cornered path. 

2. Click a region in the document where you want to create the drawing and draw a 

rectangle. 

3. Drag the sizing handle diagonally in the direction you want. 

To draw an ellipse 

1. Choose the Ellipse command. 

2. Drag the pointer to draw an ellipse, or draw a circle with Shift.  

3. Click outside the path when you are done to set the ellipse. 
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To draw a polygon, polyline, Bezier, or Close Bezier 

1. Choose the Polygon command, Polyline command, Bezier command or Close 

Bezier command. 

2. Drag the pointer to draw a straight line. 

3. Click once at each position where you want a new line segment to appear.   

4. To end a polyline or a Bezier, double-click the last point to complete the drawing. 

To end a polygon or a Close Bezier, do either of the following:  

• Double-click or right-click a point to draw the second-to-last line of the 

polygon/ Close Bezier, and an additional line will be automatically drawn 

from this point to the start point. 

• Double-click the start point to finish drawing.  

To draw a custom path  

1. Choose the Free Paint command. 

2. Draw a path you want by dragging the pointer.  

3. Click outside the path when you are done to set the path. 

 Add a shading object 

To add a shading object, please do the following: 

 Locate the page where you want to insert the shading in your PDF document, 

and choose Edit > Add Shapes > choose the shading you need. The cursor 

changes into a cross . Click and drag the cursor to draw the shading you 

want. Then click on the shading, and the Format tab will appear in the right 

panel for you to modify the shading with the commands. You can also adjust 

the size and shape by dragging the sizing handles. 

In the Format tab, you can choose a shading style to preset different shading colors 

and do any of the following to move the colors and change the shading effect: 

1) Opacity: Drag the slider to change the opacity.  

2) Gradient Stops: Describes the location and color of a transition point in a gradient. 

After choosing a shading style, you can also edit the shading color, like add new colors, 

delete existing colors, etc. 

 Move colors 

Each color can be moved by clicking and dragging the slider  . 

ms-its:C:/WINDOWS/Help/mspaint.chm::/paint_curves.htmHELP=glossary.hlp%20TOPIC=gls_drag
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 Change colors to a shading 

Double-click one color  you want to change, select the color you like in the 

Color dialog box and click OK.  

           

 Add colors to a shading 

Select one color you like and click between any two sliders underneath the 

preview bar. There will be new colors added to the shading.  

            

 Delete colors to a shading 

Click the slider  of the color you want to delete, and click Delete button 

. Also, you can move it away from the preview bar. The color will be 

removed from shading.  

            

3) Reference Line: A line along which the field of shading varies between the start 

and end coordinates and from which the field of shading extends infinitely away. The 

start and end point are shown, connected by a line. The transition from one color to 

another varies linearly along the line. The color gradient begins at the start point and 

finishes at the end point. 

 

You can drag either start or end point to move it individually, or drag the line 

to move them both at the same time. This movement will change the shading 
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effect. Compared with Shading 1, Shading 2 is dragging the start point to move, 

Shading 3 is dragging the end point to move, and Shading 4 is dragging the line 

to move. 

    

Shading 1             Shading 2           Shading 3            Shading 4              

Link and Join Text Objects 

To make editing easier, Foxit PDF Editor Cloud supports linking multiple text blocks 

together or connecting separate text blocks into one single paragraph. 

Link and Unlink Text Objects 

Using the Link command in the Join & Split context tab (which appears on the ribbon 

after you click Edit > Link & Join Text), you can link multiple text blocks together and 

then editing text in these blocks will be treated as editing one paragraph. You can link 

text blocks not only in one page but also across pages. Text will reflow in these linked 

blocks and will not cover the page contents that are located among these blocks. 

To link text blocks, please do the following: 

 Click Edit > Link & Join Text and the Join & Split context tab appears on the 

ribbon. Select text blocks you need to link together and the selected blocks will be 

marked with numbers as you click them.   

 Click the Link command in the Join & Split context tab, or right-click the selected 

blocks and choose Link Text Boxes. Then the selected blocks will be linked 

together. 

 Then when you add or edit text in these blocks with the Edit Text command, the 

text will reflow in these linked blocks and will not cover the image among them. 

And when the text added exceeds the final block, content followed the linked 

blocks will be covered because they have not been linked together. 

To unlink a text block, please click Edit > Link & Join Text, select the text block you 
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need to unlink and then click the Unlink command in the Join & Split context tab. You 

can also right-click the selected block and choose Unlink Text Blocks. 

Note: You can select and link text blocks which are discontinuous or in different columns, 

or that are not arranged from top to bottom or from left to right on the page.  

Join and Split Text Objects 

With the Join command, you can connect blocks of text into one single paragraph in a 

block to improve text reflow. Blocks of text may be joined together when you need to 

join text as one object. Otherwise, a block of text can be divided up into several parts 

with the Split command.  

To join text blocks, do the following: 

1. Click Edit > Link & Join Text. 

2. Click the text blocks you want to join. The text blocks you selected will be 

numbered. 

3. Click the Join command in the Join & Split context tab, or right-click the selected 

blocks and select Join Text Boxes. Then the selected blocks will be joined together 

as one block. 

To split a text block, please click Edit > Link & Join Text, and click the text block you 

want to split. Click the Split command in the Join & Split context tab, or right-click the 

selected block and select Split Text Boxes. Then the selected block will be divided. 

Note: All selected blocks should be on the same page. 

Edit Objects 

You can freely edit any selected object(s) by the related commands.  

Note: For copying/cutting and pasting an object, after you copy/cut an object, make sure 

that the related editing command (Home/Edit > Edit Object > 

All/Text/Image/Shape/Shading) has been selected before you paste it. Sometimes you 

may not paste an object right after copying it and do other tasks with other commands, or 

you need to paste it in another document where the editing command is not being selected. 

In these cases, you need to select the related editing command again before pasting the 

object.     
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Edit Text Objects 

To edit text objects, click Home/Edit > Edit Object > Text. And click on the text you 

want to edit. A selected object usually is outlined by a bounding box. Double-click the 

box or choose Edit Object in the context menu. Then the cursor will be blinking, and 

you can add, paste or replace text only if the font used for that text is installed on your 

system. More editing information, please refer to “Add New Text Objects”.  

Merge and Split Text Objects 

You can also merge and split text objects by using Merge Text tool and Split Text tool. 

To remove the space between the letters of words to improve the appearance of text 

content, you can click Remove Kerning in the Format tab in the right panel after you 

select the text object.  

To merge text objects, Shift-click the objects with the Edit Object command and click 

Merge Text in the Format tab in the right panel. To split a text object, please do the 

following: 

⚫ Select the object and click Split Text in the Format tab in the right panel. The 

Split Text dialog box pops up. 

⚫ Drag the slider and click the position you want to split. Click OK and the text object 

will split into parts. 

Convert Text Objects to Shape Objects  

Foxit PDF Editor supports to convert the selected text object(s) into path(s), which will 

meet the pre-press requirement. For those computers that do not support or display 

certain embedded fonts, this new feature helps to overcome that issue. To convert 

text objects to paths, please do the following: 

⚫ Select the text objects that you want to convert to paths.  

⚫ Select the Convert to Shape button in the Format tab in the right panel to 

convert. 

Edit Image and Shape Objects  

To edit image objects, click Home/Edit > Edit Object > Image. After clicking on an 

image, you can edit and modify it with the commands in the Format tab in the right 

panel as needed. See also Modify, Arrange and Delete Objects.  

To edit shape/shading objects, click Home/Edit > Edit Object > Shape/Shading. Click 
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a shape/shading and edit it with the commands in the Format tab in the right panel. 

Further information about editing shape/shading objects, please refer to “Add New 

Shape Objects”. 

Tip: When editing text, image, shape and shading objects together, you can edit all the 

objects by choosing Home/Edit > Edit Object > All. 

Modify, Arrange and Delete Objects  

A selected object is usually outlined by a bounding box. And the corresponding 

Format tab will appear in the right panel after you select objects. With groups of 

commands in the Format tab, you can modify and arrange objects. Depending on the 

type of objects you select, the Format tab may contain these groups: 

Text/Shape/Shading Style, Split, Arrange, and Effect. Click the   /   icon of 

each group to expand or collapse the group. 

Select Home/Edit > Edit Object > select All/Text/Image/Shape/Shading, and do one 

of the following: 

1. To select one or multiple objects, please do one of the following: 

 Click the object to select it, or press Ctrl/Shift and select more objects. 

 Hold the pointer over the objects and drag a rectangle around them. 

 Press Ctrl + A on keyboard. All objects on the current page are selected. 

Note: To deselect all the objects, click any blank area in the document. 

2. Move and resize an object 

 To move an object, select the object and drag the object to the desired place. 

Or right-click the object and choose Cut from the context menu and then 

right-click the desired place and choose Paste. You can also move multiple 

objects at the same time with the methods above.  

 To resize an object, drag a handle of the object. Press Shift when dragging to 

retain the original aspect ratio. You can also resize multiple objects at the 

same time with the same magnification by dragging the handles, or choosing 

Properties… from the context menu of the selected objects and entering a 

percentage value in the Scale X or Scale Y box in the properties dialog box.  

Tip: When moving and resizing an object, alignment guides (green lines) appear 

to help you align the object to other ones in the document. 

3. Rotate an object 
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To rotate an object, select the object and then do one of the following: 

 In the Format tab, choose Rotate Clockwise/ Rotate Counter-clockwise 

from the Arrange group to rotate by 90 degrees, or enter a value to specify 

degrees you want to rotate by.  

 Right-click the selected object, and choose Rotate > select Clockwise/ 

Counterclockwise to rotate by 90 degrees. 

To rotate multiple objects at the same time, select multiple objects and rotate them 

with the methods above.  

4. Shear an object 

To shear an object, select the object and do either of the following: 

• Navigate to the Shear item from the Effect group in the Format tab, enter a 

value in the box to specify a shear angle, and press Enter. 

• Right-click the object and choose Shear in the context menu. Then Enter a 

value in the pop-up dialog box to shear the object and click OK to finish. 

5. Flip an object 

To flip an object, select the object, and click Flip Vertical or Flip Horizontal from the 

Arrange group in the Format tab. Or right-click the object and choose Flip > 

Vertically/Horizontally.  

6. Arrange objects 

After selecting multiple objects, you can arrange them in the documents. In the 

Format tab you can align, page-center or distribute objects. Or choose Align/ Center/ 

Distribute after right-clicking one of the selected objects. (See also “Align Images”, 

“Center Images” and “Distribute Images”.)   

7. Clip an object  

 Select the object and choose a clipping shape from the Effect group in the 

Format tab. Or right-click the object, choose Add clip path in the context 

menu, and then choose one clipping shape in the drop-down list. 

 Click on the object and it will turn to the clipping mode where the selected 

object will be enlarged and the cursor changes to a cross . Drag the cursor 

to draw a clipping shape. You can adjust the shape’s position by dragging the 

cursor to move. 

 Drag the dots of the clipping shape in the direction you want until the clipping 
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shape displays the results you want.  

 (Optional) You can choose other clipping shapes to do further clipping on the 

object if needed. 

 (Optional) To delete clipping shapes, choose Edit Clipping  from the 

Effect group in the Format tab, select one clipping shape and press Del or 

right-click the clipping shape and select Delete. To remove all clipping shapes, 

please click Clear Clipping  in the Format tab. 

 Click on the area outside the objects to exit the clipping mode. Or right-click 

the object and choose Exit. 

8. Move an object in front or behind other elements 

• To move an object behind or in front of all other objects on the page, select 

the object and click Send to Back  or Bring to Front  from the 

Arrange group in the Format tab. Or right-click the object and choose 

Arrange > Send to Back or Bring to Front. 

9. Delete an object 

 Select one or more objects, right-click and choose Delete from the context 

menu. 

Object Properties 

When you right-click an object or multiple objects with the same type, and choose 

Properties…, you can view and change the options in it.  

Set objects properties 

1. With the Edit Object command, right-click text objects, images objects, shape 

objects (or path objects) and shading objects, and choose Properties.... 

2. There are General tab and Appearance tab in the properties dialog box. The 

general tab is as below: (Take image objects properties for example.) 

You can specify a number of properties that are common to all objects in the 

General properties. 

⚫ Position X and Y: Allow you to set the precise horizontal and vertical position 

of the objects. 
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⚫ Width and Height: Displays the selected object’s width and height values. 

⚫ Scale X and Y: Allow you to enter a percentage value in the Scale X or Scale 

Y box to resize the object.  

3. In Image Object Properties dialog box, in the Appearance tab, drag the slider or 

enter a value to specify the opacity of the image object. Opacity can range from 

1% to 100%. For transparent paint or a weak effect, specify a low percentage value; 

for more opaque paint or a strong effect, specify a high value. 

4. In shape object properties dialog box, please do any of the following: 

 Line Color: The stroke color is used to paint the border of paths and text that 

are stroked. 

 Fill Color: The fill color is used to paint the interior of paths and text characters 

that are filled. 

 Line Width: The line width specifies the thickness of the line used to stroke a 

path and is measured in user space units. A line width of 0 specifies the 

thinnest line that can be rendered on the output device. The default value is 1. 

Note: A line width of 0 is an inherently device-dependent value. Its use is 

discouraged because the line may be nearly invisible when printing on high-

resolution devices. 

 Miter limit: When two line segments meet at a sharp angle it is called a Miter 

join and has been specified as the line join style. It is possible for the miter to 

extend far beyond the thickness of the line stroking the path. The miter limit 

imposes a maximum on the ratio of the miter length to the line width, as 

shown in the following figure. When the limit is exceeded, the join is 

converted from a miter to a bevel. 

The value for miter limit is a number that must be greater than or equal to 1, 

and has a default value of 10.  

 

Miter length 

 Line Join Style: The line join style specifies the shape to be used at the corners 

of paths that are stroked. The allowed values are Miter joins, Round joins and 
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Bevel joins. 

 Miter — the outer edges of the strokes for the two segments are 

continued until they meet. If the extension projects too far, as 

determined by the miter limit, a bevel join is used instead.  

 Round — a circular arc with a diameter equal to the line width is drawn 

around the point where the segments meet and filled in, producing a 

rounded corner. 

 Bevel — the two path segments are drawn with butt end caps (see the 

discussion of line cap style), and the resulting notch beyond the ends of 

the segments is filled in with a triangle. 

                          

         Miter                     Round                  Bevel  

    Square line cap style          Round line cap style        Flat line cap style 

 Line Cap Style: The line cap style specifies the shape to be used at the ends 

of open sub paths when they are stroked. Allowed values are Butt end caps, 

Round end caps, and Projecting Square End. 

 Square: --- the stroke is squared off at the endpoint of the path. 

 Round: --- a semicircular arc with a diameter equal to the line width is 

drawn around the endpoint and filled in. 

 Flat: --- the stroke extends beyond the end of the line by a distance that 

is half the line width and is squared off. 

                         

          Square                    Round                      Flat 

 Dash: Select a type of line, dashed or solid. 

 Opacity: Enter a value, or drag the slider to specify the opacity. Opacity can 

range from 1% to 100%. For transparent paint or a weak effect, specify a low 

percentage value; for more opaque paint or a strong effect, specify a high 

value. 
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5. In text object properties dialog box, please do any of the following: 

Font Name– Changes the font used by the selected text to the font you specify. 

Font Size – changes the font size to the size that you specify. 

Horizontal Scaling – adjusts the width of characters by stretching or shrinking 

them in the horizontal direction. The scaling is specified as a percent of normal 

width of the characters, with 100 being the normal width. The scaling always 

applies to the x coordinate. The following figure shows the effect of horizontal 

scaling.  

 

Text Mode – determines whether text is stroked or filled. There are four types 

of text modes: Fill Text, Stroke text, Fill then stroke text, and Text with no fill and 

no stroke. 

 

    1        2         3         4 

    1. Fill text   2. Stroke text  3. Fill then stroke text   4. Text with no fill and 

no stroke 

Character Space – inserts uniform spacing between two or more characters in 

selected text. 

 

Word Space – inserts uniform spacing between two or more words in selected 
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text. 

 

For stroke color, fill color, and opacity, please refer to Shape Object Properties.  

Articles 

For PDF documents that include articles and arrange text content in multiple columns 

and across several pages, you may need lots of scrolling or zooming to navigate the 

articles. To make article viewing effective, Foxit PDF Editor Cloud allows you to define 

a navigational path (or an article thread) for an article in the document by marking out 

a series of boxes around the article content in the order you want the content to be 

viewed in. With article threads, you can skim through a document, focusing on a 

specific article and ignoring the rest, as you do in a traditional print newspaper or 

magazine.    

Define articles 

To define an article, please follow the steps: 

1. Choose Edit > Add Article Box.  

2. Click and drag a rectangle around the content to be the first article box. A black 

rectangle appears around the content with a label, and the cursor changes into 

the article pointer . 

The label for each article box is made up of the article number and the sequence 

number within the article. For instance, the first box for the first article in the 

document is labelled 1-1, the second box 1-2, the third box 1-3, and so on. And 

the boxes for the second article in the same document are labelled 2-1, 2-2, 2-3, 

and so on. 

3. Repeat the operation in Step 2 to mark out the rest of article boxes followed. (Note: 

If you need to resize or move an article box during the article defining, you must end 

the article first.) 

4. When you have defined the entire article, press Enter to end the article.  

5. Type the information in the pop-up article property dialog box as needed and 

then click OK. 
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6. Then in the Articles panel in the navigation pane you can see the article defined. 

The Articles panel lists all of the articles included in the document. 

View articles 

1. To view the articles in the document, open the Articles panel in the navigation 

pane and do any of the following to start viewing: 

• Double-click the article you want to view. 

• Right-click the article you want to view and choose Read Article from the 

context menu.  

• Select the article you want to view and choose Read Article from the options 

menu in the upper right corner of the Articles panel. 

2. You will be switched to the beginning of the article (the area of the first defined 

article box). The page view may zoom in or out automatically so that the current 

part of the article fills the screen, with the first line appearing in the upper left 

corner.  

Notes:  

1. Before viewing an article, make sure you have selected the Hand tool and the option 

Make Hand Tool read articles in the File > Preferences > General. 

2. You can select Hide After Use in the options menu in the upper right corner of the 

Articles panel to hide the panel after the article viewing starts. 

Modify articles 

You can rename and delete articles, and edit article properties. 

Rename articles 

To rename an article, click the article name directly in the Articles panel and type a 

new name for it, or right-click the article and choose Rename to rename it.  

Delete an article  

To delete an entire article, do any of the following: 

• Select the article in the Articles panel and press Delete.  

• Right-click the article in the Articles panel and choose Delete.  
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Edit article properties 

You can edit the article title, subject, author, and keywords in the article property 

dialog box. To open the article property dialog box, do any of the following: 

• Select the article, and choose Properties… from the options menu in the 

Articles panel. 

• Right-click the article, and choose Properties… from the context menu in the 

Articles panel.  

• Select any article box of the article in the document with the Add Article Box 

command. Then right-click the article box and choose Properties… from the 

context menu.  

 Working with Layers 

A layer or as it is more formally known Optional Content Groups (OCG) is a dictionary 

representing a collection of graphics that can be made visible or invisible dynamically 

by users of viewer applications. In a PDF file, each layer may hold any portion of the 

document's objects, and layers may be made visible or invisible, showing or hiding 

their contained objects, in any combination.  

With Foxit PDF Editor Cloud, you can control the display of PDF layers with the Layers 

panel. For example, you may divide background imagery, main content areas, and 

advertisements amongst their own top-level layers, and easily hide the layers that you 

don't want others to view. 

Show /hide PDF Layers 

In a PDF, information can be stored on different layers. To show or hide related 

content stored in a variable number of separate layers, you can simply refer to the 

Layers panel on the left side of the work area. You can view layers and choose to show 

or hide the content associated with each layer.  
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The Layers Panel 

A. A checkmark indicates a displayed layer    B. Hidden layer 

1. Open the Layers panel, and then do one of the following: 

 To hide a layer, uncheck the layer. 

 To show a hidden layer, click the empty box and a checkmark will appear. 

 To check the properties of a layer, right-click the layer and select Properties.  

2. From the Options menu at the top right corner of the Layers panel, choose one of 

the following: 

 List Layers for All Pages – Shows every layer across every page of the 

document. 

 List Layers for Visible Pages – Shows layers only on the visible pages. 

 Reset to Initial Visibility – Resets layers to their default state. 

 Expand All – Expands all layers. 

 Collapse All – Collapses all of the current layers in the view. 

 Apply Print Overrides – Determines whether to display a layer according to its 

corresponding Print setting in the Layer Properties dialog box. The option is 

available when Never Prints or Always Print is selected.  

 Apply Export Overrides – Determines whether to display a layer according to 

its corresponding Export setting in the Layer Properties dialog box. The option 

is available when Never Exports or Always Exports is selected. 

 Apply Layer Overrides – Displays all layers in the document regardless of the 

settings in the Layer Properties dialog box, and you cannot change layer 

visibility until you deselect this command or choose Reset To Initial Visibility 

in the Options menu. However, you are still allowed to rename layers when the 
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command is selected.  

Import Layers  

You can import layers from a PDF file or import images as layers into a target PDF file.  

1. In the navigation pane, click the menu button  in the top left corner of the 

Layers panel, and choose Import as Layer…. 

2. In the Import as Layer dialog box, click Browse to choose a PDF file or an image 

file (Formats like BMP, GIF, JPEG, JPEG 2000, PCX, PNG, and TIFF, are supported.). If 

you import from a PDF file, choose a page number you want to import from. 

3. Import Options: 

Create new layer: creates a new layer from the source file. Specify a layer name, 

and add it to an existing layer group in the target document as needed. 

Add to existing layer: adds the imported content to an existing layer in the target 

document. The imported layer will have the same properties as the existing one. 

This option is available only when the target document contains layers. 

Copy layers from source: imports the layers from the source PDF file. This option 

is available only when the source PDF file contains layers. 

4. In the right part of the dialog box, select a target page number to import the layers 

to, and preview the result. 

5. Complete the settings in Position and Appearance as needed. 

6. Then click OK. 

Merge Layers  

1. In the navigation pane, click the menu button  in the top left corner of the 

Layers panel, and choose Merge Layers…. 

2. In the Merge Layers dialog box, select one or more layers you want to merge and 

the target layer to merge the selected layers into. 

3. Then click OK. 

Note: Merged layers will have the same properties of the target layer. After you merge the 

layers, you cannot undo the operation. 

Flatten Layers  

1. In the navigation pane, click the menu button  in the top left corner of the 



   Foxit PDF Editor Cloud 

Chapter 5: Edit                                                     User Manual 

108 

 

Layers panel, and choose Flatten Layers. 

2. A warning message pops up, telling you that the flattening operation cannot be 

cancelled or undone. 

3. Then click OK. 

Note: After the flattening operation, all layers will be consolidated, while the layers that are 

originally not visible will be removed. After you flatten the layers, you cannot undo the 

operation. 

Delete Layers 

1. In the navigation pane, select the layer you want to delete.  

2. Click the menu button  in the top left corner of the Layers panel, and choose 

Delete Layer, or press Delete on the keyboard. Or, right-click the layer and 

choose Delete Layer from the context menu. 

Note: When you delete a layer, its corresponding content will be removed. 

Reorder Layers 

You may need to change the order of layers in the list, or move a layer from one layer 

group to another. In the navigation pane, to reorder a layer, just press Alt while you 

click the layer’s name and drag it to the desired location. You can undo or redo the 

operation. (Note: You cannot reorder locked layers or layers in nested layer groups.) 

Layer Properties 

By editing layer properties in the Layer Properties dialog box, you can control the 

visibility of layers and set whether to print or export layers. For example, you can hide 

a layer whenever the document is displayed on screen, while ensuring that the layer 

always prints.  

1. To open the Layer Properties dialog box, select the layer, click the Options menu 

and choose Layer Properties.... Or just right-click the layer and choose 

Properties... to open the Layer Properties dialog box. 

2. Edit the layer name or any of the following: 

Intent – selects View and the visibility and properties of the layer can be edited 

any time. Or, selects Reference to keep the current visibility and setting at all 
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times until you switch to View. 

Default State – Defines the initial visibility state when Visibility in Initial State 

is set to Visible When On. 

Visibility – Defines the visibility of the layer when the document is opened or 

when the initial visibility is reset. If you choose Visible When On, the layer is 

visible only when Default State is On. 

Print – Defines whether the layer will be printed when you print the PDF. If you 

choose Print When Visible, the layer will print only when the layer is visible. 

Export – Defines whether the layer will appear in the resulting document when 

the PDF is exported to an application or file format that supports layers. If you 

choose Export When Visible, the layer will appear in the resulting document 

only when the layer is visible. 

The previous settings in Initial State like the states of Print, View, and Export, 

are shown in the box at the bottom of the Layer Properties dialog box. 

PDF Properties 

To view and modify the PDF properties, please navigate to File > Properties.  

Description 

This tab shows some basic information about the document. The person who created 

the document in the source application may have set the title, subject, author, and 

keywords. Click Custom, and the pop-up Custom Properties dialog box shows some 

document information (such as comments and the company name). You can easily 

edit the document information within the PDF document, a useful way for searching 

and indexing files.  

You can also customize document properties by clicking Custom. In the pop-up 

Custom Properties dialog box, input the property name and the value, and then click 

Add to add a custom property. To change the value of a property, select it and update 

the value, and then click Change. To change the name of a custom property, you need 

to delete the property and create a new custom property. To delete a property, select 

it and click Delete. 
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Initial View 

When a user opens your PDF document, they see the initial view of the PDF. You can 

set the initial view to the magnification level, page and page layout that you want.  

 Layout and Destination 

Navigation Tab: Chooses desired panels to be displayed in the navigation pane. 

Page Layout: Chooses a page layout option to view the document. The default is 

Continuous. 

Magnification: Chooses a zoom level that the document will appear at when opened. 

The default is the magnification set in File > Preferences > Page Display > Zoom. 

Open to page: Specifies the page that appears when you open the document. 

 Window Options 

Display document title: Shows the document title in the title bar of the application 

window. You can view the document title in File > Properties > Description. 

Open in Full Screen mode: Opens the document in Full Screen mode. The document 

pane fills the entire screen, with the toolbar, the navigation pane, and the status bar 

hidden behind.  

Center window on screen: Places the application window in the center of the screen 

area. 

 User Interface Options 

Choose options to hide parts of the interface as needed. 

Define the initial view as Full Screen mode 

If your PDF is a presentation, you may want to set the initial view to Full Screen 

Mode. After you define the initial view of the PDF, you can add page transitions to 

selected pages of the entire document. When setting the initial view of a PDF to Full 

Screen mode, you must define how the document opens. 

1. Choose File > Properties > Initial View.  

2. For best results, do the following:  

 Choose Page Only from the Navigation tab menu. 
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 Choose Single Page from the Page layout menu. 

 Set Open to page to the page on which you want to start the presentation. 

3. Select Open in Full Screen mode to open the document without the toolbar 

displayed. Click OK. (You have to save and reopen the file to see the effects.)  

Note: Users can exit Full Screen mode by pressing Esc if their preferences are set this way. 

However, in Full Screen mode, users cannot apply commands and select tools unless they 

know the keyboard shortcuts. You may set up page actions in the document to provide this 

functionality.  

Security 

This tab describes security permissions and what functionality is allowed within a PDF. 

See also “Checking PDF Security” 

Fonts 

The Fonts tab lists the fonts and the font types used in the original document, as well 

as the encoding used to display the original fonts. 

Advanced 

This tab lists the items of Print Dialog Presets during printing, and Reading Options 

about reading directions and languages. 

Page Scaling: Chooses Default to scale the page with the application default setting 

when printing, which is Fit to printer margins. Or choose None to preserve the scale 

in the documents. To print with additional page scaling types as shown in the Print 

dialog box, you need to choose one of them when printing.   

DuplexMode: Chooses Simplex to print on one side of the page. Or choose Duplex 

Flip Long/Short Edge to print a document double sided and flip pages on long/short 

edges. 

Paper Source by Page Size: Automatically selects the paper type according to the 

page size of the PDFs when printing. 

Pages: Specifies the page range you want to print. 

Number of Copies: Chooses the number of copies you want to print. Or choose 
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Default to use the application default copies, which is one copy. 

Binding: Choose a reading direction in which you read a document in Facing or 

Continuous Facing mode. Choose Left Edge to read from left to right, or choose 

Right Edge to read from right to left. 

Language: Specifies the document language that screen readers use to read the 

document. You can select languages by typing ISO 639 Code. 
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Chapter 6 – Organize 

Foxit PDF Editor Cloud comes with a built-in functionality to combine various PDF files 

& split one PDF into various small single & multiple page PDF files according to page 

numbers as well as page range. You can rearrange pages and compose page outlines 

with the commands under the Organize tab, which allow you to insert, move, replace 

and crop pages, split documents, add page marks (such as header & footer) to PDFs, 

and more. 

See also the tutorial on Organize PDF. 

Insert Pages 

Foxit PDF Editor Cloud enables you to insert pages from files (either from a page range 

or the entire file), clipboard and a blank page. You can also insert pages into multiple 

documents at a time. 

Insert pages from one or more files 

Foxit PDF Editor Cloud allows you to insert pages from a file or multiple files into a 

PDF. 

To insert pages from a file or multiple files (not limited to PDFs) into a PDF, choose 

Organize/Home > Insert > From File, or right-click a page thumbnail and choose 

Insert Pages… > From File. Then do the following steps: 

1. In the Insert Pages From dialog box, you can add more files by clicking the 

Add Files… button. If the files are non-PDF files, they will be temporarily 

converted into PDFs and added to the files list.   

2. In the files list, select a file and click Move Up/ Down to change the order 

you insert the files, or click Remove to delete the file. 

3. Then choose one file you added, specify where you want to insert to the 

current PDF document (at the beginning or the end, or before or after a 

designated page), and page range (insert from …to …) of the file that you 

want to insert.  

4. Check Show Thumbnails in the lower left corner, and you can preview the 

target page and the insert page in preview boxes. Click OK to insert the 

pages. 

5. To leave the original PDF intact as a separate file, choose File > Save As, 

and type a new name for the merged PDF.  

https://www.foxit.com/support/tutorial/
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Notes:  

1. When a whole file is inserted, its bookmarks and file attachments will be inserted 

as well. The bookmarks will be inserted at the end of the bookmarks of the original 

PDF by default. The links of the bookmarks inserted remain unchanged. And the 

combined bookmarks will be the bookmarks of the combined PDF file.  

2. You can insert a whole PDF file from your local computer by directly dragging and 

dropping the file to the Pages panel in the Foxit PDF Editor Cloud window. 

Insert pages from the clipboard 

1. Open a PDF file, and choose Home/Organize > Insert > From Clipboard, or right-

click one page thumbnail and choose Insert Pages… > From Clipboard.   

2. In the pop-up From Clipboard dialog box, specify the place you want to insert pages. 

Then the content in the clipboard will be inserted. 

3. To leave the original PDF intact as a separate file, choose File > Save As, and type a 

new name for the merged PDF. 

Insert pages from a blank page 

1. Open the PDF that you want to use as the basis of the combined file, and choose 

Home/Organize > Insert > Blank Page, or right-click a page thumbnail and 

choose Insert Pages… > Blank Page. 

2. In the Insert Blank Pages dialog box, specify where in the document you want to 

insert the blank pages (as well as how many blank pages you want to insert), and 

click OK. 

3. To leave the original PDF intact as a separate file, choose Save As, and type a new 

name for the merged PDF. 

Insert pages into files 

1. Open the PDF file (i.e. source file) from which you want to choose a range of pages 

(i.e. source pages) to be inserted into other files. Click Home/Organize > Insert > 

Into File, or right-click a page thumbnail and choose Insert Pages… > Into File.  

2. In the pop-up Insert Pages Into dialog box, you can add more target files by 

clicking Add Files…. 

3. Then specify the page range to be inserted and the destination in the target files.  

4. Choose whether to keep the source pages in the source PDF file after inserting. 
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5. Check Show Thumbnails in the lower left corner, and you can preview the target 

page and the insert page in preview boxes. Click OK to insert the pages.  

Rotate, Move, Swap and Delete Pages 

Rotate Pages 

You can rotate all or selected pages in a document.  

1. Open the PDF document within which you want to rotate pages. 

2. (Optional) To rotate one page, choose Home/Organize > Rotate Pages > 

Left/Right. Rotation is based on 90° increments. 

3. To rotate one or more pages, please use one of the following methods:  

 Choose Home/Organize > Rotate Pages > Multi-page rotate. 

 Right-click the selected page thumbnails in the Pages panel and 

choose Rotate Pages/Rotate 90° Counterclockwise/ Rotate 90° 

Clockwise. 

4. (Optional) In the pop-up Rotate Pages dialog box, specify the direction you 

want to rotate the pages and the page range. 

5. Click OK.  

Note: To temporarily change your view of the page, choose View > Rotate View > 

Rotate Left or Right. The original page orientation is restored the next time you open 

the PDF.  

Move Pages 

The Move Pages feature allows you to move pages within a PDF document. 

Move one or more pages within a PDF document 

1. Open the PDF document within which you want to move pages. 

2. Choose Organize > Move, or right-click the page thumbnail and choose Move 

Pages…. 

3. In the Move Pages dialog box, specify where you want to move pages within the 

document, and page range that you want to move. 

4. Click OK. 

Move one or more pages within a PDF, using page thumbnails 



   Foxit PDF Editor Cloud 

Chapter 6: Organize                                                User Manual 

116 

 

1. Click the Pages button to open the Pages panel, and select one or more page 

thumbnails.  

2. To move a page, drag the page thumbnail(s) to the new location.  

Swap Two Pages 

The Swap feature is useful sometimes if you want to swap two different pages within 

a PDF document.  

1. Open the PDF document within which you want to swap pages. 

2. (Optional) Directly drag and drop the page thumbnail to the target location in the 

Pages panel of navigation pane. 

3. Choose Organize > Swap, or right-click the page thumbnail and choose Swap 

Pages…. 

4. In the Swap Two Pages dialog box, select or enter two different page numbers in 

the Swap and For options.  

5. Click OK.  

Delete Pages 

After combining PDF files, you can delete unwanted or blank pages.  

Delete pages using the Delete command 

1. Open the PDF document where you want to delete pages. 

2. Choose Organize > Delete. 

3. Specify a page range by entering the page number(s) you want to delete. You can 

choose All pages in range, Even pages only, or Odd pages only, to delete the 

related pages in the specified range.  

If your PDF contains formatted page numbers, and the Use logical page 

numbers option is enabled in File > Preferences > Page Display, you should 

enter the numbers that match the numbering on the pages rather than the 

physical page numbers. For instance, if you want to remove the second page of 

your document which is numbered ii, you should enter ii to remove the page. See 

also the preference setting on logical page numbers.  

4. Click OK to delete the selected pages. 

Note: If you want to retain a copy of the original PDF, make sure that you save the new 
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document using Save As rather than Save. 

Delete pages using page thumbnails 

1. In the Pages panel, select a page or group of pages.  

2. Press Delete to delete the selected pages. Or right-click the selected pages, 

choose “Delete Pages…” in the context menu and click OK. 

Extract, Interleave, Duplicate, and Replace Pages 

Extract Pages 

Extraction is the process of reusing selected pages of one PDF in a different PDF. 

Extracted pages contain not only the content but also all form fields, comments, and 

links associated with the original page content. 

You can leave the extracted pages in the original document and create a new PDF that 

includes all of the extracted pages during the extraction process - comparable to the 

familiar processes of cutting-and-pasting or copying-and-pasting, but on the page 

level.  

1. Open the PDF in Foxit PDF Editor Cloud and choose Organize > Extract. Check 

Show Thumbnails to preview the current document in the pop-up Extract Pages 

dialog box. 

2. (Optional) Right-click the page thumbnails that you want to extract and choose 

Extract Pages… to open Extract Pages dialog box.  

3. In the Extract Pages dialog box, specify a page range to extract. You can choose 

All pages in range, Even pages only, or Odd pages only to extract the related 

pages in the specified range. 

4. Choose a type of Extract Mode: 

Extract pages as one PDF: The extracted pages will be placed in a new PDF 

document named “Extracted pages from [original document name].pdf”. 

Extract pages as several PDFs by comma (,) sign: With this option selected, if 

you have specified several page ranges separated by comma, pages in each page 

range will be extracted and placed in a separate PDF document. The generated 

PDFs will be named “[original document name]_1.pdf”, “[original document 

name]_2.pdf”, and so on.    
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Extract each page as a PDF: Each extracted page will be placed in a separate PDF 

named “[original document name]_1.pdf”, “[original document name]_2.pdf”, and so 

on. 

5. Select the Delete the pages after extraction option to delete the selected pages 

from the original document. 

6. Click OK after setting.  

Note: The creator of a PDF document can set the security to prevent the extraction of pages. 

To view the security settings for a document, choose File > Properties, and select Security 

tab. 

Duplicate Pages 

The Duplicate Pages feature allows you to copy pages within a PDF document. 

1. Open the PDF document within which you want to copy pages.  

2. Choose Organize > Duplicate, or right-click the page thumbnail and choose 

Duplicate Pages…. 

3. In the Duplicate Pages dialog box, specify where you want to copy pages within 

the document and the number of copies and page range that you want to copy.  

4. Click OK.  

Tip: You can also duplicate page(s) within a document or in different documents by 

dragging and dropping, or using the Copy and Paste commands.  

• Dragging and dropping: To duplicate pages within a document, drag the page 

thumbnails of the pages you want to duplicate while pressing and holding down 

the Ctrl key in the Pages panel, and drop at the desired place (The Line icon 

 shows the place where the pages will be located.).  

• Copy and Paste: Right-click the page thumbnail(s) you want to copy and choose 

Copy from the context menu. Then select the desired page thumbnail you want to 

paste the page(s) after, and choose Paste from the right-click menu.  

Replace Pages 

You can replace individual pages to quickly update a PDF. The text, images, and 

comments on the original page will be replaced. 

Note: The bookmarks associated with the original pages will be unavailable after the 

replacement. 
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Replace Pages using the Replace command 

1. Open the PDF that contains the pages you want to replace and choose 

Organize > Replace. (Or right-click the page thumbnails that you want to 

replace and choose Replace Pages….)  

2. In the Open dialog box, select the file (not limited to PDF format) containing the 

replacement pages, then click Open.  

3. In the pop-up Replace Pages dialog box, from the original PDF file select the 

pages you want to replace and select replacement pages from the selected file. 

You can click Browse to change the selected file. 

4. Click OK to finish.  

Split Pages 

Split PDFs into multiple files 

The Split Document feature is a process of splitting one or more documents into 

multiple smaller-size documents. 

1. Open the PDF document you want to split. 

2. Choose Organize > Split, or right-click on the target page thumbnails and choose 

Split… in the context menu. 

3. In the Split Document dialog box, choose one of the options for the Split 

documents by item to specify how you want to split the current PDF document. 

• Number of pages: Set the maximum number of pages for each document 

generated during the splitting. 

• Page Range: Manually type the specific page ranges you want to split the 

current PDF by. 

• Top-Level Bookmarks: Split by the top-level bookmarks if the current 

document includes bookmarks.  

• Blank Page: Split the current PDF document each time a blank page is 

encountered. Blank pages will be discarded when splitting. 

4. (Optional) Click Select More Files… to split more files using the splitting setting in 

the step above.  

5. Click Output Options to specify the file names, and other settings. 

6. Click OK. 
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Crop Pages 

The Crop Pages feature allows you to adjust the visible page area, which is helpful if 

you want to create visual consistency in page size within a PDF document that 

contains pages of different sizes.  

Crop one or more pages 

1. Open the PDF document you want to crop. 

2. Right click the target page(s) on the Pages thumbnails, choose Crop Pages. 

Or, choose Organize > Crop Pages, and drag the cursor to select an area 

you want to crop. 

3. In the pop-up Set Page Dimensions dialog box, (the margin measurement 

indicates the size of the selected area if any), you can specify the settings in 

the Margin Control: select CropBox, ArtBox, TrimBox, or BleedBox (they are 

displayed in the preview box in black, red, green and blue respectively) and 

adjust the proportions to crop. You can preview all the boxes on the right 

after checking the item Show All Boxes. 

CropBox – Defines the content boundary of the page when it’s displayed 

or printed. 

ArtBox – Defines the meaningful content of the page including blank 

space. 

TrimBox – Defines the final dimensions of the page after trimming. 

BleedBox – Defines the clipping path when the page is printed 

professionally to allow for paper trimming and folding. Printing marks 

may fall outside the bleed area. 

Constrain Proportions – Locks the cropped proportions and each margin will 

have the same distance from each side to the border. 

Remove White Margins – Crops the page to the artwork boundary, which is 

useful for trimming the edges of presentation slides saved as PDFs. 

Set To Zero – Restores all the crop margins to zero. 

Reset – Resets all the margins to the original dimensions. 

4. A rectangle in the page thumbnail shown in the preview box shows the 

boundaries of the cropped area.  
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5. Set the page size and adjust the center of the page content if needed.  

6. Specify the page range you want to crop. For the Crop item, you can 

choose All pages in range, Even pages only, or Odd pages only to crop 

the related pages in the specified range. 

7. Choose the unit of the margin cropping values. 

8. Click OK. 

Note: Cropping does not reduce file size because information is not discarded but 

merely hidden. And you can restore the page and its content to its original 

dimensions by resetting the page size. 

Flatten Pages 

The Flatten Pages feature can make annotations and form fields in the PDF file 

become part of objects of the PDF pages. This feature is often used when you want 

all the comments and form fields to be permanent so that the document receivers 

cannot modify them (unless they change them with editing tools), or when you want 

to lock the PDF document after completing the form fields to ensure that the 

document can be viewed consistently on all devices.  

After flattening, many items in the document are changed:  

• Text Markup, Note comments, and Drawing markup comments: The markups 

and Note comment icons change into shape objects. However, the text in 

their pop-up notes is lost. 

• Typewriter, Callout, Text Box: the boxes or frames change into shape objects, 

while the text in the comments changes into text objects.  

• File attachments: For a file attachment added with the File command under 

the Comment tab as a comment, only the icon  remains (which also 

changes into a shape object), while the file is removed from the document 

and can no longer be opened. (Note: The file attachments added with the File 

Attachment command in the Edit tab are not changed after flattening.) 

• Stamps: The stamps in the stamp palette provided by Foxit change into shape 

objects and the dynamic information (if any) embedded in the stamps 

changes into text objects. The stamps that are created with images change 

into image objects; stamps created with a PDF page change into 

text/image/shape objects based on the content on that page.  

• Form fields: All form fields can no longer be filled or modified. Only the items 

that are visible with the Hand command selected remain and change into 

shape objects.  
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• Movies: The movies are no longer available. Only the items that are visible 

with the Hand command selected remain and change into shape objects. 

• Redaction: For the redaction that has been applied, only the black (or other 

colors) rectangle that blocks out redacted content remains and changes into 

a shape object, while the redacted content (the underlying content) cannot be 

seen or searched. For the content that has been marked for redaction (the 

redaction has not been applied yet), flattening the file does not remove the 

content and the black rectangle changes into a shape object. 

To flatten pages, do as the following: 

1. Open the PDF document where you want to flatten pages. 

2. Choose Organize > Flatten. 

3. In the Flatten Pages dialog box, specify the page range (current page, all pages, a 

range of pages), and click OK. 

Note: The flattening operation cannot be undone. If you want to retain a copy of the 

original PDF, make sure that you save the new document using Save As rather than Save. 

Reverse Pages 

You may need to reverse a range of pages that are created in reverse order, which 

happens a lot when you are scanning paper to PDF. If the PDF contains a large number 

of pages, reordering them manually will cost you a lot of time. With Foxit PDF Editor 

Cloud, you can reverse a range of pages in a few quick steps.   

1. Open the PDF document where you want to reverse pages. 

2. Choose Organize > Reverse, or right-click any page thumbnail and choose 

Reverse Pages…. 

3. In the Reverse Page Order dialog box, specify a range of pages you want to reverse. 

You can choose All pages in range, Even pages only, or Odd pages only to 

reverse the related pages in the specified range. 

4. Click OK.  

Header & Footer, Watermark & Background to PDFs 

Add Header/Footer, Watermark/Background to PDFs with Text, image and PDF, 

making your PDFs more professional and easier to view, navigate watermark and 

place marks on documents. 

See also the tutorials on “Headers and Footers” and “Watermarks and Backgrounds”. 

https://www.foxit.com/support/tutorial/
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Header & Footer 

To add a new header & footer, please do the following: 

With a document open in the application window, do the following: 

1. Choose Organize > Header & Footer > Add. 

2. Specify the Font and Margin settings and type the text of header & footer in 

the text boxes in the “Add Headers and Footers” dialogue box. 

3. (Optional) You can insert page numbers, the filename, or the current date to 

the text of header & footer. Click in a text box, select a corresponding option 

and click Insert. To change the formatting, click Page number and date 

format. To specify the page range where you want to add the header & 

footer, click Page Range Options…. 

4. Click OK to activate the operation. 

To update the header & footer, please do the following: 

1. Choose Organize > Header & Footer > Update. 

2. Update the content in the “Update Headers and Footers” dialogue box. 

3. Click OK to activate it. 

To remove the header & footer, please do the following: 

To remove the header and footer from the current document, choose Organize > 

Header & Footer > Remove All. Click “Yes” in the pop-up message box.  

Background 

To add a new background, please do the following:  

1. Open a document where you want to add a background and choose Organize > 

Background > Add. 

2. Edit the background in the “Add Background” dialogue box. 

1) Choose one color as the background, or add the file from your computer via 

clicking the browse button. If the file has many pages, you can select one of 

them. 
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2) Set the appearance by choosing the rotation degree and the opacity. To 

resize the background in relation to the PDF page dimensions, select Scale 

relative to target page and enter a number in the percentage box. Click 

“Appearance Options” to set when to display the background. 

3) Set the vertical and horizontal distance between the target page and the 

background. 

4) Choose the page range to play the background. You can select all pages or 

specify the page range, or choose even pages or odd pages via clicking the 

right items in the subset list. 

5) Check or uncheck the Show Preview option to preview the changes or not. 

3. Click OK to activate it. 

To update the background, please do the following: 

1. Choose Organize > Background > Update. 

2. Update the content in the “Update Background” dialogue box. 

3. Click OK to activate it. 

To remove the background, please do the following: 

To remove the background from the current document, choose Organize > 

Background > Remove All. Click “Yes” in the pop-up message box.  

Watermark 

To add a new watermark, please do the following: 

1. Open a document where you want to add a watermark and choose Organize > 

Watermark > Add. 

2. Edit the watermark in the “Add Watermark” dialog box. 

1) You can create a text watermark or an image watermark.  

o To create a text watermark, input the text as the watermark. Then 

choose the font, size, and color for the text watermark.  

o To create an image watermark, click the Browse button, select an 

image file from your computer as the watermark. You can also 

browse a PDF file and select one page from the PDF as the watermark. 
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To resize the watermark in relation to the original image size, select 

Absolute Scale and enter a number in the percentage box. (Note: The 

Absolute Scale option is available only when the Scale relative to 

target page option is not selected in the next step.) 

Note: You are allowed to import a watermark profile (an XML file) and apply it to 

your document by clicking the Import watermark icon  at the top of the 

dialog box. 

2) Set the appearance by choosing the rotation degree and the opacity. To 

resize the watermark in relation to the PDF page dimensions, select Scale 

relative to target page and enter a number in the percentage box. Click 

“Appearance Options” to set when to display the watermark. 

➢ If you choose the “appear behind page”, the page content will obstruct 

your view of some part of the watermark. 

➢ If you choose the “appear on the top of page”, the watermark will cover 

some content, but you can adjust it via setting the opacity of the 

watermark. 

3) Set the vertical and horizontal distance between the target page and the 

watermark. 

4) Choose the page range to play the watermark. You can select all pages or 

specify the page range, or choose even pages or odd pages via clicking the 

right items in the subset list. 

5) Check or uncheck the Show Preview option to preview the changes or not. 

3. (Optional) Click Save Settings at the top of the dialog box, and save your current 

watermark settings as a profile after naming it. You can reuse the watermark by 

selecting the profile directly from the Saved Settings menu. To delete the saved 

watermark, select it from the Saved Settings menu, and click the Delete 

watermark icon  next to the Save Settings button. You can also export the 

saved watermark by clicking the Export watermark icon .  

4. Click OK to activate it. 

To update the watermark, please do the following: 

1. Choose Organize > Watermark > Update. 

2. Update the content in the “Update Watermark” dialogue box. 
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3. Click OK to activate it. 

To remove the watermark, please do the following: 

To remove the watermark from the current document, choose Organize > 

Watermark > Remove All. Click “Yes” in the pop-up message box.  

Bates Numbering  

What’s Bates Numbering? 

Bates numbering is used in the legal, medical, and business fields to place identifying 

numbers and/or date/time-marks on images and documents. These numbers may be 

solely numeric or may contain a combination of letters and numbers. It is a unique 

serial number attached to every page of a document collected and is also a method 

of indexing legal documents for easy identification and retrieval.  

Add Bates Numbering 

1. Choose Organize > Bates Numbering > Add. 

2. In the “Add Bates Numbering” dialog box, add files or opened files by clicking Add 

Files or Add Open Files.  

3. (Optional) In the files list, you can change the order in which Bates numbers are 

assigned. You can reorder the files by Name /Size/Modified Time by clicking the 

corresponding column name. Alternatively, reorder the files manually as desired 

by clicking the Move Up/Down button, or by dragging and dropping the file in the 

list. Select a file and click the Remove button to delete it, if necessary. 

4. Click Output Options. Here, you can set the name for the output file in the 

dialogue box. Click OK to exit the box after completing these settings. 

Tip: When naming output files, if you select Add to original file names, you can enter 

the string “%BATES_NUMBER_KEY%” in the Insert Before or Insert After boxes to add the 

range of Bates number to the filenames (e.g., “0001-0020[original document 

name].pdf”).  

5. Click OK and a dialog box to add Headers and Footers will pop up for you to insert 

Bates Numbering on the PDF documents. 

6. Select Bates Number in the Macro menu, and then click Insert. 

7. Another dialog box will appear for setting the number of digits (any number from 

3 to 15), the increment, the start number, rotate angle and the prefix/suffix, if 

needed. (Tip: Setting the value of the increment to a negative number reverses the 

order of the Bates numbering.) Click OK to finalize the setting.  
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8. Click OK. 

Remove Bates Numbering 

Choose Organize > Bates Numbering > Remove All. 

Change the format of page numbering 

If your PDF file contains front matter likes document cover and copyright page, the 

page numbers on the document pages (i.e. the printed page number) may not start 

from the document cover but from the body pages. You may need to synchronize the 

page numbers displayed below the page thumbnails in PDF viewers with the printed 

page numbers. Foxit PDF Editor Cloud enables users to change the format of page 

numbering displayed in PDF viewers to meet different needs.  

To change the format of page numbering, please do as below: 

1. Click Organize > Format Page Numbers. Or right-click a page thumbnail and 

select Format Page Numbers…. 

2. In the Page Numbers dialog box, specify a range of pages you want to number 

and set the style of page number and the number you want to start at. You can 

also add a prefix to the number, like adding a letter “P” before the number. You 

can preview the result in the Sample at the bottom of the dialog box. 

3. If you need to continue the numbering sequence from previous pages without 

interruption, please check Extend numbering used in preceding section to 

selected pages. 

4. Click OK to finish. 

Note: Make sure the Use logical page numbers option is enabled in File > Preferences > 

Page display to display the customized page numbering. 
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Chapter 7 – Comment 

Foxit PDF Editor Cloud provides you with various commenting tools to add comments 

in PDF documents. Comments can be notes or drawings that are intended as an 

opinion, an explanation, an illustration, or a statement of fact or opinion, especially a 

remark that expresses a personal reaction or attitude. You can type a text message or 

add a line, circle, or other shape to make comments on PDFs you are reading with 

Foxit PDF Editor Cloud commenting commands. You can also edit, reply, delete, and 

move the comments with ease. 

Commenting tools 

There are various annotation tools with different functions for you to choose: Text 

Markup Tools, Pin Tools, Typewriter Tools, Drawing Tools, Measure Tools and Stamp 

Tools. You can add different comments by selecting the annotation tools from the 

Comments tab or Toolbar.  

Note: If you want to add multiple comments without reselecting the same tool, you can 

check Keep Tool Selected in the Comment tab. 

Text Markup Tools 

You can use Text Markup tools to indicate where text should be edited or noticed. Text 

Markups fall within the comments category and can be made visible/invisible by 

clicking Comment > Manage Comments > Comments > Show All/ Hide All. They do 

not change the actual text in the PDF. Instead, they indicate which text should be 

deleted, inserted, highlighted or underlined. Text Markup tools include Highlight, 

Squiggly, Underline, Strikeout, Replace, and Insert. 

Text Markup Tools 

Button Tool Name Description 

 Highlight 
To mark important passages of text with a fluorescent (usually) 

marker as a means of memory retention or for later reference. 

 
Squiggly 

Underline 
To draw a squiggly line under. Similar to the Underline command. 

 Underline  To draw a line under to indicate emphasis. 

 Strikeout 
To draw a line to cross out text, making others know the text is 

deleted. 
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 Replace Text  To draw a line to cross out text and provide a substitute for it. 

 Insert Text  
A proofreading symbol (^) used to indicate where something is to 

be inserted in a line. 

Tip: You can use the Area Highlight command in the Comment tab to mark any area in 

the document with a highlight color. To do this, with the command selected, click and drag 

across a region in the document as needed. For details on how to change the appearance 

of markups added with the Area Highlight command or remove the markups, please refer 

to the related instructions on text markup comments.    

Add a text markup comment 

1. In the Comment tab, select a type of text markup. Then click and drag from the 

beginning of the text you want to mark up. (Tip: After adding text markups with the 

Highlight, Underline, Strikeout, Squiggly Underline, or Replace Text tool, you can still 

drag the handle at the beginning or end of the text to adjust the text range you have 

selected.) 

2. (Optional) Add a text message to the text markup comment. If you have opened 

the Comments panel, the text field associated with the text markup will be 

activated automatically in the Comments panel for you to input a text message 

right after you create a text markup. You can also follow the steps in “Open pop-

up notes” to open the pop-up note on the document pane to input a text message. 

Tips:  

1. At any time, you can add or edit a text message in a text field in the Comments 

panel after double-clicking the corresponding comment in the Comments 

panel. 

2. If you want to add the selected text in PDF document to the pop-up notes of 

text markups automatically, please go to File > Preferences > Commenting 

and check the Copy selected text into Highlight, Squiggly Underline, 

Underline, and Strikeout comment pop-ups option. 

3. (Optional) If you need to format the text in the pop-up note, select the text and 

choose the desired option in the Format tab in the right panel.  

4. (Optional) After inputting the text message, click anywhere outside the pop-up 

note (or click the  icon in the Comments panel) to confirm your input. And if 

necessary, follow the steps in “Close pop-up notes” to close the pop-up note.  

5. (Optional) Change the appearance of a text markup comment. When you select a 
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text markup comment, you will find a toolbar floating around the comment. Select 

the Switch color icon  on the floating toolbar to change the color for the 

comment. Or, you can change the appearance of text markup comments in the 

Format tab that appears in the right panel when you select a comment or are 

making a comment. 

Tips:  

1. When the Format tab in the right panel is closed or hidden, you can click the 

Display comment format panel icon  on the floating toolbar of an existing 

markup. 

2. By default, the floating toolbar appears right after you create a comment. If you do 

not want the floating toolbar to appear upon a comment creation, please go to 

File > Preferences > Commenting, and deselect the Pop up floating toolbar after 

comments created option. 

Remove a text markup comment 

Do one of the following: 

 Select the Hand command, Select Annotation command, or the 

corresponding Text Markup command > click the markup > press the Delete 

key. 

 Select the Hand command, Select Annotation command, or the 

corresponding Text Markup command > right-click the markup > choose Delete 

from the pop-up context menu. 

 Choose Delete from the Options menu of the pop-up note. 

 Pin Tools 

You can use pin tools to add comments by adding notes and attaching a file. A note 

comment leaves a note icon on the page where you placed it, and a pop-up note for 

your text message. Using the File command, you can attach a file in the document as 

a comment. 

Add a Note Comment 

1. To add a note comment, please click the Note command in the Comment tab, 
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click where you want to place the note.  

2. Add a text message to the Note comment and change the appearance of the Note 

comment. See also Add a text markup comment.  

3. Click and drag the title bar of the pop-up note to move its position.  

Remove a note comment  

Do one of the following: 

 Select the Hand command, Select Annotation command, or the 

corresponding commenting tool > click the note icon > press the Delete key. 

 Select the Hand command, Select Annotation command, or the 

corresponding commenting tool > right-click the note icon > choose Delete 

from the context menu. 

 Choose Delete from the Options menu of the pop-up note of the comment. 

Add a file as a comment 

For how to add a file as a comment and work on it, please refer to File Attachments in 

Chapter 5.  

Typewriter Tools 

The Typewriter tools include Typewriter, Callout, and Textbox.  

Typewriter  

You can use the Typewriter command to add comments anywhere on a PDF.  

 

A Typewriter comment  

 Add comments with Typewriter 

 Choose Comment > Typewriter. 

 Click on the area to type any text you want. The Format tab appears in the 

right panel for you to specify the font format, add bulleted/numbered lists to 

paragraphs, align text, etc. See also the buttons in the Text Style group in the 
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Format tab. 

 Press Enter if you want to start a new line. 

 To finish typing, click anywhere outside the text you have inputted. 

Tip: It’s easy to copy-and-paste text to PDF document as a typewriter annotation from 

a text document or webpage. 

 Editing the typewriter comment 

To edit the typewriter comment, do either of the following:  

 On the document pane, double-click the comment with the Hand command, 

Select Annotation command, or the Typewriter command to activate the text 

field. Then follow the steps in “Adding Comments with Typewriter” to edit the 

text.  

 In the Comments panel, double-click the comment that you want to edit. Then 

edit the text in the activated field, and click the  icon.  

Tip: When you select a typewriter comment, you will find a toolbar floating 

around the comment, which allows you to copy the selected typewriter comment, 

change the font size, and open/close the Format tab. 

 Move the typewriter comment 

1. Select the Hand command, the Select Annotation command, or the Typewriter 

command.  

2. Click on the typewriter comment. 

3. The cursor turns to a four-way arrow  when hovering over the comment. 

Hold down the mouse and drag the typewriter comment to the intended place. 

 Delete the typewriter comment 

1. Select the Hand command, the Select Annotation command, or the Typewriter 

command.  

2. Click on the typewriter comment. 

3. The cursor turns to a four-way arrow  when hovering over the comment.  

Click on the comment and press the Delete key. Or, right-click the comment 

and choose Delete from the pop-up context menu. 
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Callout and Textbox  

Callout and Textbox are designed for users to create comments in a callout text box 

or a box. 

A callout text box contains a text box and an arrow, which is especially useful when 

you want to single out (but not obscure) a particular area of a document.  

 

A textbox is a rectangle of any size, possibly with a border that separates the text box 

from the rest of the interface, allowing the user to input text information. A text box 

usually remains visible on the document page. It doesn’t close like a pop-up note. 

 

Note: Callout text boxes and Text boxes allow for horizontal text only. 

 Add a callout or textbox 

⚫ Choose Comment > Callout/Textbox. 

⚫ Click the place where you want to insert the callout or text box. The Format 

tab appears in the right panel for you to specify the font format, add 

bulleted/numbered lists to paragraphs, align text, etc. See also the buttons in 

the Text Style group in the Format tab.  

⚫ Type the text. Text wraps automatically when it reaches the right edge of the 

box. 

 Resize, move, edit or delete a callout or textbox 

Select the Hand command, the Select Annotation command, or the corresponding 

annotation tool, and do one of the following:  
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⚫ To resize the callout or textbox, select it and drag any of the sizing handles to 

resize it. 

⚫ To move a textbox comment, click on it (the cursor changes to a four-way arrow 

), and drag it to the intended place. 

⚫ For a callout comment, select it, then drag the text box to move the text box only, 

drag the line with the arrow to move the entire callout, or drag the arrow only to 

move the arrow to the position you want to point to. 

⚫ To edit the text in the callout or text box, please refer to “Editing the Typewriter 

Comment”. 

⚫ To change the appearance of a callout or textbox comment, select it and use the 

formatting commands on the floating toolbar or in the Format tab.  

⚫ To delete the callout or textbox, select it and press Delete, or right-click it and 

then choose Delete.   

Drawing Tools 

Drawing Tools allow you to mark up a document with rectangles, ovals, polygons, 

clouds, arrows, lines, polylines, etc. It is quite useful when you have to make some 

shapes to mark the text or image.  

Add a drawing markup comment 

1. In the Comment tab, select a type of drawing markup. Then click and drag to 

make a shape you want to mark up.  

2. (Optional) Sizing handles (small circles or squares) appear at the corners and sides 

of a selected drawing markup. You can drag these handles to change the size and 

shape of the markup. 

3. (Optional) When you select a drawing markup comment, you will find a toolbar 

floating around the comment, which allows you to change the color of the 

comment quickly. Or you can change the appearance of drawing markup 

comments in the Format tab that appears in the right panel when you choose a 

drawing markup tool.  

4. (Optional) To add a text message in the pop-up note for the markup, refer to Text 

Markup Tools for details. 

Drawing Tools 

Button 
Tool 

Name 
Description 

 Rectangle  To draw a four-sided plane figure with four right angles. Press 
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the Shift key to draw a square. 

 Oval  To draw an oval shape or a circle with pressing the Shift key. 

 Polygon  
To draw a closed plane figure bounded by three or more line 

segments. 

 Cloud  To draw cloud shapes. 

 Arrow  
To draw something, such as a directional symbol, that is 

similar to an arrow in form or function. 

 Line  To mark with a line. 

 PolyLine  
To draw an open plane figure with three or more line 

segments. 

 Pencil  To draw free-form shapes. 

 Eraser 
An implement, acts as a piece of rubber, used for erasing the 

pencil markups. 

To draw a rectangle  

1. Choose Comment > Drawing > Rectangle. 

2. Click and drag across the region in the document where you want to create the 

drawing. Press the Shift key to draw a square. 

To draw an oval shape 

1. Choose Comment > Drawing > Oval. 

2. Click and drag across the region in the document where you want to create the 

drawing, or draw a circle with Shift.  

To draw a polygon or polyline 

1. Choose Comment > Drawing > Polygon or PolyLine. 

2. Click and drag the cursor, and click again at the desired location to draw a straight 

line. 

3. Move the cursor and click once at each position where you want a new line 

segment to appear. 

4. (Optional) While drawing, right-click a point and choose Cancel Drawing Markup 

from the context menu to discard the drawing.  

5. To end a polyline, double-click the last point to complete the drawing. To end a 

polygon, do either of the following:  

• Right-click a point and choose Complete Drawing Markup from the 

context menu (or directly double-click a point) to draw the second-to-last 

line of the polygon, and an additional line will be automatically drawn from 

this point to the start point to close the polygon. 
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• Double-click the start point to finish the drawing.  

To draw a cloud shape 

1. Choose Comment > Drawing > Cloud. 

2. Click to create the start point, move the pointer, and click once where you want a 

new segment to appear.  

3. (Optional) While drawing, right-click a point and choose Cancel Drawing Markup 

from the context menu to discard the drawing.  

4. To finish drawing the shape, double-click the last point, or right-click the last point 

and choose Complete Drawing Markup from the context menu.  

Note: If you draw a cloud shape in a counterclockwise direction, the cloud comes out 

inward . If you draw the lines forming the shape in a clockwise direction, the cloud 

is created with the points outward . 

To draw a line or an arrow   

1. Choose Comment > Drawing > Line or Arrow. 

2. Click and drag across the region in the document where you want to create the 

drawing. 

Tip: To draw a line or an arrow in horizontal, vertical, or at a 45-degree angle, press 

Shift as you draw. 

To draw with the Pencil and Eraser tools 

You can use the Pencil tool to create free-form drawings as you draw on a piece of 

paper, and the Eraser tool acts as an eraser to allow you to remove the drawings you 

create with the Pencil tool.  

Edit, resize, move, or delete a drawing markup 

Use the Hand command, the Select Annotation command, or the corresponding 

Drawing Tool to select a drawing markup.  

 To edit the drawing markup, right-click it, select Properties and do settings as 

needed. Or you can edit it using the Format tab. 

 To resize the drawing markup, select it, and drag one of the handles to make your 

adjustments. Tip: For markups that are drawn with the Rectangle or Oval command, 

you can resize multiple markups at the same time. To do this, select multiple markups 
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you want to resize, and then right-click the anchor markup (the markup whose sizing 

handles are solid/active squares) > Size > Height/Width/Both, or open the Format 

tab in the right panel and then choose , , or . And you’ll see that the 

height/width/height and width of the selected markups is resized to be the same as 

that of the anchor markup. 

 To move the drawing markup, select it and drag it to the target place.  

 To add or edit a text message for the drawing markup, see the instructions for 

adding a text markup comment.    

 If you draw a line or arrow, you can enable the comment to be shown on the line 

or arrow by checking Show text in line in the line properties box. 

 Check Set Current Properties as Default in the properties box so that the 

current settings can be applied next time by default. 

 To delete a drawing markup, see the instructions for removing a text markup 

comment. 

Group the markups 

Grouping drawing markups enables you to combine them so that you can work with 

them as though they were a single object. You can move or delete the group, set its 

status, change its appearance, etc. 

Select the Hand command or the Select Annotation command, and do one of the 

following: 

⚫ To group/ungroup markups, select the markups you want to group/ungroup by 

pressing Ctrl > right-click on one of the selected markups, and then choose 

Group/Ungroup.  

⚫ To work with a group, select one of the markups and then work with the group 

as other comments. 

Measure Tools 

The Measure Tools enable you to measure distances and areas of objects in PDF 

documents. The measure tools are especially useful when you need to know the 

distances or areas associated with objects in a form or computer-aided design (CAD) 

drawing or when you want to measure certain areas of a document before sending to 

a professional printer. The measure tools are available to users only if the PDF creator 

enables measuring functionality.   

When you use a measure tool, the tool dialog box displays the measurements of the 
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line segments you draw.  

Measuring the objects 

 Select Measure > Distance in the Comment tab to measure the distance 

between two points. While measuring the distance, you can specify whether 

to show the default leader on both side of the measurement points or not in 

Measuring Preferences. Click the first point, move the pointer to the second 

point, and click again. If you choose to use the default leader, move your 

mouse to determine the leader length, and then click on the document again 

to finish measuring. The measurements will appear on the page.  

 Select Measure > Perimeter in the Comment tab to measure a set of 

distances between multiple points. Click the first point to start, and then click 

each point you want to measure. Double-click the last point to end 

measuring. (Tip: When you move the cursor to a position toward the first point, 

a small red circle will appear at the first point, which allows you to click on the 

first point to end measuring and measure a closed perimeter.)   

 Select Measure > Area of Polygon in the Comment tab to measure the area 

within the line segments that you draw. Click the first point to start, and then 

click each point you want to measure. After you have clicked at least two 

points, click the first point or double-click the last point to complete the area 

measurement. 

 Select Measure > Area of Circle in the Comment tab to measure the area 

of circular objects in PDF files. Click and drag to draw an oval (or use Shift + 

drag to draw a circle) across the object that you want to measure, and 

release your mouse to complete measuring. 

Note: When measuring with the Distance, Perimeter, or Area of Polygon command, you 

can hold down SHIFT to snap the two points horizontally, vertically, or diagonally (in 45 

degrees). You can also choose to complete or cancel measurement by right-clicking the 

measurement and choosing options from the context menu. 

After you select the measuring tool, the Format tab appears in the right panel, which 

allows you to calibrate the scale ratio, snap measurement, export measurement 

markup, etc.  

 If your PDF file includes embedded scale ratio, you can measure 

distance/perimeter/area using the embedded scale ratio. Before that, you need 

to select the Use Scale and Units From Document (When present) option in 

File > Preferences > Measuring. Then all the following measuring will use the 

embedded scale ratio. To calibrate the scale ratio for your document for an 

accurate result, choose either method of the following: 
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➢ With the Use Scale and Units From Document (When present) option 

selected:  

1) Choose Calibrate  from the Format tab and then click the two 

points of the line whose actual length has already been known. (Tips: 

When drawing, you can hold down SHIFT to snap the two points horizontally, 

vertically, or diagonally. You can also click Snap to Paths  in the 

Format tab to capture the path in the page.) 

2) When the second point is selected, the Calibration dialog box pops up. 

3) Type the actual length that the line represents and choose the 

appropriate unit, which will set a new scale ratio.  

4) (Optional) If you already have the correct scale ratio, directly define the 

measurement value and choose the appropriate unit in the Format tab. 

5) Then in the pop-up Calibration dialog box, click Store Scale in Page to 

apply the new scale ratio to the current page, or click Apply to All Pages 

to apply it to all pages (Or click the /  icon in the Format tab to 

apply the new scale ratio to the current page or all pages). The new scale 

ratio will be embedded into the page or all pages respectively, replacing 

the original embedded scale ratio. 

6) As the scale ratio is embedded into the document, the measurements 

in the document change accordingly. 

➢ With the Use Scale and Units From Document (When present) option 

unselected, directly define a custom scale ratio in the Format tab, or click 

Calibrate  in the Format tab to define a new scale ratio. The defined 

scale ratio will only be applied to the current page. 

 Check Show result information in the Format tab if you want to see the current 

measuring result, including real distance, angle, horizontal and vertical position, 

etc. 

 Check Measurement markup in the Format tab to add and show the 

measurement lines you draw in the PDF file. When this option is checked, you can 

add a label to measurement markups either by using the one specified in 

measuring preferences or inputting a new one in the Add Label box. The label for 

Distance markup will be shown in the distance measurement line, while the label 

for Perimeter and Area markups will be shown in their pop-up notes. When you 

put the pointer over the measurement markups with the Hand command 

selected, you can also view the measurement result and label.  

 Check Rulers in the Format tab to show the rulers. 

 Choose one or more snapping types from the Format tab. For precise 

measurements, position the key points when moving the cursor. 
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Snap to Endpoints : a small red circle will appear at the endpoint of the path 

when moving the cursor toward the end of the path. 

Snap to Midpoints : a small red triangle will appear at the midpoint of a path 

when moving the cursor over the path. 

Snap to Paths : the cursor will automatically change to a red square box on a 

path when moving the cursor over the path. 

Snap to Intersections : a small red cross will appear at the intersection of two 

paths when moving the cursor over the point of two intersecting paths.  

 Choose Export to Excel  from the Format tab to save all the measurement 

information in your PDF to a CSV file.  

Note: The object you draw will disappear when the Measurement Markup is deselected in 

the Distance dialog box. 

Working on the measurement markup 

After you complete the measurement, you are able to do further operations on it, such 

as move, resize, flip, and even work on it the way you work on comments. 

1. Moving the measurement markup 

1) With the Hand command or the Select Annotation command selected, click the 

measurement markup you want to move. 

2) Place the cursor over the object, hold and drag the mouse to move it to the 

intended place. 

3) (For distance measurement markups only) To move the label as well as the 

measurement result shown on the distance measurement markup: click on 

the text shown on the markup > drag the label directly to a desired position. 

2. Changing the length and orientation of the distance measurement markup 

1) With the Hand command or the Select Annotation command selected, select 

the measurement markup. Move the cursor over one of the handles (the small 

circles or squares) at the endpoints of the markup.  

2) Hold and drag the mouse to change the length and orientation of the distance 

measurement markup. 

3. Flipping the distance measurement markup and the result 

1) Select the Hand command or the Select Annotation command. 
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2) Right-click the markup you draw > select Flip. 

Working on Measurement Markups as Comments 

The measurement markups can also be used as comments. You can set the status, 

open pop-up notes, delete them, reply to the markups, change the properties, and set 

the current properties as default. 

Note: To show measurement markup and the measurement results, right-click on the 

object you draw, and choose Properties > Appearance > then check Show text in line. 

For information on how to work on the measurement markups as comments, please 

refer to the corresponding sections in “Chapter 7 – Comments”. 

Change the appearance of measurement markups 

Foxit PDF Editor Cloud provides multiple ways to change the appearance of 

measurement markups. When you select a measurement markup, a toolbar will float 

above the measurement markup for you to quickly change the line color. You can also 

go to the Format tab in the right panel and the Properties dialog box to specify more 

advanced settings. If you change the appearance through the Format tab, Foxit PDF 

Editor Cloud will save the properties and apply them to any new measurement 

markups as well. If you change the appearance via the Properties dialog box and do 

not check Set Current Properties as Default option in the dialog, Foxit PDF Editor 

Cloud will only apply the properties to your currently selected markup.  

 Change the appearance through the Format tab 

 Select the Hand command or Select Annotation command. 

 Click the measurement markup that you want to change the appearance, and then 

the Format tab will appear in the right panel.  

 Do any of the following as needed:  

➢ Change the line color: Select one of the preset colors in the Shape Style group, 

or click the Custom Color button  to modify the preset style or customize a 

new style.  

➢ Change the opacity: Drag the Opacity slider to change the opacity.  

➢ Set the fill color: Click the Fill Color button , then choose a desired color 

from the color palette.  
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➢ Change the line width: In the Line Width field , input a value, or 

select the desired value from the drop-down list.   

➢ Change the dash type: Click the Dash Type button , and then select a dash 

type as needed.  

➢ Change the shape for the start/end of the line: Select the desired shape in the 

Start of line or End of line group.  

 Change the appearance via the Properties dialog box  

 Select the Hand command or Select Annotation command. 

 Right click the measurement markup that you want to set the appearance, and 

then select Properties from the context menu. See also Change the appearance 

of comments in the Properties dialog box.  

Arrange the measurement markups 

When you select two or more measurement markups, you will find a toolbar floating 

around the markups. Click the corresponding buttons directly to arrange, align, or 

distribute the selected measurement markups. You can also find the 

Arrange/Alignment/Distribute buttons from the Format tab in the right panel or the 

context menu after you right-click them. For more information about the buttons, 

please refer to Arrange comments.    

Stamps 

The Stamp Tools in Foxit PDF Editor Cloud are a group of advanced tools that enable 

you to stamp content and watermarks into a PDF document. Foxit PDF Editor Cloud 

supports image stamps with various image formats (JPEG, GIF, BMP, WMF, etc.) and 

PDF file stamps. You can either create dynamic stamps which can obtain information 

from your system including name, date and time, or import existing dynamic stamps. 

Stamping PDF files is a very useful feature especially when you need to give reviewers 

some advices about the document's status or sensitivity.                                         

Stamp a PDF 

You can choose from a list of predefined stamps, or create custom stamps before 

stamping a PDF. All the stamps that you import or create are listed in the drop-down 

menu of the Stamp command and Stamps Palette. To apply a stamp, please do the 



   Foxit PDF Editor Cloud 

Chapter 7: Comment                                               User Manual 

143 

 

following: 

1. Choose Comment > Stamp > choose a stamp from the menu. In the Stamps 

window, select a category from the menu, and then select a stamp.  

2. The cursor changes into a rectangle with the appearance preview of the stamp. 

Click on the position where you want to place the stamp, or drag a rectangle on 

the document page to define the size and placement. 

Notes:  

1. All the stamps that you import or customize will be listed after you click Stamp button, 

you can choose directly a stamp from the menu.  

2. The date format shown on the dynamic stamp is the same as that you set in your system.  

Create a Stamp 

You can create custom stamps and dynamic stamps. 

 Creating a Custom Stamp 

1. Choose Comment > Create > Create Custom Stamp. 

2. In the Create Custom Stamp dialog box, click File > Browse… and choose an 

image file. 

3. For Category, type a new category name or choose an existing category from the 

drop-down list, name the stamp, set the width and height for the stamp, and then 

click OK.  

Note: If the stamp you choose is an image file, you can adjust the opacity of the image via 

dragging the scrollbar as needed. By default, Foxit PDF Editor Cloud will create transparent 

stamps from images with a white background.  

Manage a stamp 

To manage a stamp, please do the following: 

 Choose Comment > Create > Manage Stamps, open Management Custom 

Stamps dialog box, and select a stamp. 

 Click Create to create a stamp. Please refer to Creating a stamp. 

 Click Delete to remove the stamp. 

Note: Deleting a custom stamp category will delete all stamps that are subordinate to it. 
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 Undo/Redo a Stamp 

To undo/redo a Stamp, please click the undo button  and redo button  on the 

Quick Access toolbar. 

 Resize/move a stamp 

⚫ Select the Hand command or the Select Annotation command. 

⚫ To resize a stamp, select it, and drag one of the handles to make your 

adjustments.  

⚫ To move a stamp, select it to drag.  

⚫ To add a pop-up note to a stamp, select it and double-click the stamp. See 

also “About pop-up notes”. 

 Rotate a stamp  

1) Select the Hand command or the Select Annotation command.  

2) Select the stamp(s) that you want to rotate, and you will find the rotation 

handle at the top of the selected stamp(s). 

3) Drag the rotation handle to rotate the selected stamps at any degree.  

 Delete a stamp 

    Do one of the following: 

⚫ Select the stamp you want to delete and then press the Delete key. 

⚫ Right-click on the stamp, and choose Delete from the Context Menu. 

Set Favorite Stamps 

 Choose Comment > Create > Set Favorite Stamps…. 

 Select a stamp in All Stamps panel, and then click Add to Favorite, then the 

stamp you select will be added to Favorite Stamps panel. 

 To remove a stamp from Favorite Stamps panel, select the stamp you want to 

remove and then click Remove from Favorite. 

Accounting Calculator 

The Accounting Calculator tool in Foxit PDF Editor Cloud gives you an easy way to have 

efficient paperless workflows. When preparing some digital workpapers (such as 

expense reports) or if you are an accountant and tax preparer, you can not only do 

calculations with the tool, but also add the electronic calculator tapes to your PDFs as 
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annotations, the same way you did on paper.  

1. Open your PDF document in Foxit PDF Editor Cloud, and choose Comment > 

Accounting Calculator. 

2. The calculator window pops up. You can see the calculator keypad on the left, the 

calculator tape area on the right, and the related buttons on top of the window. 

The functionality of the calculator is very similar to most hand-held calculators. 

3. (Optional) Before doing your calculation, do the following settings with the buttons 

as needed: 

• Reset: reset the calculator to the default settings. 

• Undo/Redo: undo or redo your last action. 

• Date Time: specify whether to show the current date and time on the calculator 

tape. 

• Add Line/Del Line: click Add Line to insert a blank row above the currently 

selected row in the existing tape and then you can double-click the cells in the 

newly-added row to enter a value and choose an operator. Or click Delete Line 

to delete a row that you want to delete from the tape. As you insert or delete 

a row, the calculation result updates automatically. 

• Clear Tape: discard all the current calculations and then you can start a new 

one.  

• Decimal: specify the number of displayed or rounded decimal places (i.e., the 

number of digits of the decimal part). 

• Rounding: specify the rounding method for the decimal part. For example, with 

the Decimal set to 2 above, the following table shows the different results of 

different rounding methods.  

Number Rounding Method Result 

8.330 

Rounding Up/Down 

8.34 (Rounding Up) 

8.33 (Rounding Down) 

8.331 

…… 

8.338 

8.339 

8.330 

Rounding 8.33 
8.331 

…… 

8.334 

8.335 

Rounding 8.34 
8.336 

…… 

8.339 

 

4. (Optional) Double-click a cell in the Comment column in the tape to add a 
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description for the calculated item. You can also double-click the cells in the 

Amount and Op columns to make changes as needed. 

5. When you complete the calculation, you can type the name for the tape in the 

textbox above the calculator tape area, and save the tape to the document by 

clicking the Create Tape button.    

6. The digital calculator tape is added to the document as a Textbox comment.  

About pop-up notes 

Most comments include a pop-up note associated with them. You can type text 

message in their pop-up notes to communicate ideas or provide feedback for the 

document (See also Reply to comments). This type of pop-up note also includes an 

Options button which provides various options for more actions. (Note: For all types 

of comments except the Eraser comment, when you put the cursor over them, a message 

note appears showing the information about the comment like the author, the text he typed, 

or the name of the file attachment.) 

Sometimes pop-up notes are hidden or closed. To open pop-up notes, select the Hand 

command, Select Annotation command, or the corresponding commenting tool, and 

then do any of the following: 

• Click on the comment, and select the Edit note icon  on the toolbar 

floating above the comment to open its pop-up note. 

• Double-click the comment. Note: When the Comments panel is hidden, double-

clicking the comment opens (or closes) the pop-up note on the document pane. With 

the Comments panel open, double-clicking the comment activates the text field 

associated with the comment in the Comments panel for you to add or edit the 

text message in the pop-up note. However, for a file attachment comment, double-

clicking the file attachment icon opens the file attachment (if you have permissions), 

whether the Comments panel is hidden or open.  

• Right-click the comment, and choose Open Popup Note to open the pop-up 

note of the selected comment or Open All Popups to open the pop-up notes 

of all the comments in the document. 

• Click Comment > Manage Comments > Popup Notes > Open All to open the 

pop-up notes of all the comments in the document. 

To close or hide pop-up notes, select the Hand command, Select Annotation 

command, or the corresponding commenting tool, and then do any of the following: 

• Click the Close button on the pop-up note. 

• Make sure that you have closed the Comments panel, and then double-click 

the comment.   
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• Right-click the comment, and choose Close Popup Note to close the pop-up 

note of the selected comment or Close All Popups to close the pop-up notes 

of all the comments in the document. 

• Click Comment > Manage Comments > Popup Notes > Close All to close the 

pop-up notes of all the comments in the document. 

You can adjust the location of a pop-up note to make sure that it does not overlap the 

contents. To move a pop-up note, directly drag it to the desired position.  

Note: If you choose Comment > Manage Comments > Comments > Hide All, all 

comments in the document along with their associated pop-up notes will be hidden; choose 

Comment > Manage Comments > Comments > Show All, all comments in the document 

along with their associated pop-up notes (except any you had closed) will reappear. 

Change the appearance of comments in the 

Properties dialog box 

You can change the color and appearances of comments or markups after you create 

them by right-clicking the comment and choosing Properties. Also, you can set the 

new look as the default appearance for that tool. 

In the Properties dialog box for each comment, there are two options: 

 Check Locked at the bottom of the Properties dialog box to prevent the comment 

from being moved, altered or deleted. 

 Set Current Properties as Default – check this option to set the current property 

settings as default so that all the settings can be applied by default next time.  

Note: You can change the appearance of comments in the floating toolbar, the Format tab 

in the right panel, or the comment properties dialog box. If you change the appearance 

through the Format tab, Foxit PDF Editor Cloud will save the properties and apply them in 

the new comments as well. If you change the appearance via the Properties dialog box and 

do not check Set Current Properties as Default option in the dialog, Foxit PDF Editor 

Cloud will only apply the properties to your currently selected comment. 

Change the appearance of Note Comments 

1. After you create a note comment, right-click the note icon and choose Properties…, 

or click Options at the top-right corner of the note pop-up box and choose 

Properties…. 
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2. In the Note Properties dialog box, do any of the following, and then click Close: 

 Click the Appearance tab to change the color and opacity of the comment.  

 Click the Note Type tab to change the type of icon used. 

 Click the General tab to change the author’s name and subject of the comment. 

 Click the Review History tab to see the history of changes people have made to 

the status of a comment during a review.  

See also “Set a status”. 

Change the appearance of Text Markups 

 Follow the steps of “Change the appearance of Note Comments”. 

 There is no Note Type tab in Text Markups settings. 

Change the appearance of Drawing Markups 

In the Properties dialog box, do any of the following, and then click Close: 

 Click the Appearance tab to change such options as the border style, color and 

opacity. The type of the comment selected determines which options are available.  

 Click the General tab to change the author’s name and subject of the comment. 

 Click the Review History tab to see the history of changes people have made to 

the status of a comment during a review. 

See also “Set a status”. 

Change the appearance of Typewriter Markups 

In the Typewriter Properties dialog box, do any of the following, and then click Close: 

 Click the Appearance tab to change the opacity.  

 Click the General tab to change the author’s name and subject of the comment. 

 Click the Review History tab to see the history of changes people have made to 

the status of a comment during a review. 

See also “Set a status”. 
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Change the appearance of a textbox or callout 

Please refer to Change the appearance of Drawing Markups. 

Managing Comments 

View all comments 

The comments panel displays all comments in the PDF so that you can easily find the 

comments. In addition, it also provides a toolbar with basic options: Expand 

All/Collapse All, Previous, Next, Sort By, Hide/Show all comments, Search box, 

and Filter. 

 The comment is displayed in the pop-up note or on the markup icon and acts as 

a tooltip when the pop-up note is closed.  

 If you input the comment with too many lines, it will only show some of the 

comment while the rest will be displayed as suspension points when the cursor is 

moved outside the pop-up note. Click inside the pop-up note to view it with scroll 

bar. 

 Click the Filter icon to search specific comments you need by the author, status, 

type, and more. In the Filter Comments dialog box, select a status or author to 

show the comments that are in the status and made by the author. If you only 

want to filter the comments by the original author and ignore all the replies, 

please check Filter by the original author only as well. Click Clear All to clear all 

filters. 

 The Comments Panel displays all the comments in the PDF without any filter; if 

you have filtered the comments, only the comments that match the filtering 

criteria appear in the panel. When you navigate through comments, the selected 

comment will automatically be kept in sync with the current comment being 

displayed. And you click on a comment to go to the corresponding comment on 

the page. 

To view comments in the Comments panel, 

 Click the comments button  in Navigation pane to open the Comments 

panel. 

 In the Comments panel, there are the following functions to provide you: 



   Foxit PDF Editor Cloud 

Chapter 7: Comment                                               User Manual 

150 

 

 

 Search box  - Type a string to search comments that 

contains the string. 

 Expand All  – Click Expand All button to expand individual comments. 

 Collapse All  – Click Collapse All button to collapse all comments. 

 Previous /Next  – Browse through the comments. Click the Previous 

button or the Next button to go to the previous or next comment. The two 

buttons are unavailable if no comment is selected.  

 Sort By  – you can sort comments by author, page, type, date, status, or 

checkmark status. In a thread of replies, only first message is sorted, and the 

reply messages are sorted in the same category as first message. (Tip: When 

you sort comments by Page, Foxit PDF Editor Cloud will list comments on the same 

page based on their positions, from left to right and top to bottom.) 

 Show/Hide all comments – you can show/hide all comments in the PDF 

document. (To show/hide all comments on the Comments panel, you can also 

choose Comment > Manage Comments > Comments > Show All/ Hide All.) 

Tips:  

1. The page on which a comment is located is kept in sync with the selected comment in 

the Comments panel. To go to the page where a comment is located, simply click the 

comment in the Comments panel.  

2. Click on a comment in the Comments panel, and the  icon appears. Clicking the 

icon opens a context menu for you to do more actions.   

Select comments 

1. Select the Select Annotation command, the Hand command, or a commenting 

tool.  

2. Click on a comment to select it. To select multiple comments at the same time, 

Ctrl-click or Shift-click the comments you need. 
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Undo and Redo comments 

See also “Undo and Redo” 

Set and change a status 

Set a status 

Setting a status is useful for keeping track of comments that you have read or that 

require further action. You can use the status to indicate which comments you want 

to accept, reject, cancel, complete, defer, or mark for future consideration.  

By setting the review status, you can show or hide a certain set of comments, and let 

review participants know how you are going to handle the comment. Once the review 

status is set, you cannot remove the review status display from history in the Review 

History list, even if you change the review status to None. 

Change the status of a comment 

 With the Hand command, the Select Annotation command, or the corresponding 

tool selected, right-click a comment in Comments panel you want to change the 

status of, choose Set Status > choose one option from the pop-up Context menu, 

and then select an option. 

 To view a markup’s history of changes: 

A. Right-click the markup in the document pane or Comments panel, and then 

choose Properties. 

B. In the Properties dialog box, click the Review History tab to view the history of 

status changes people have made to a markup.  

Reply to comments 

Replying to comments is useful in shared reviews, when participants can read each 

other’s comments. They can also be used by review initiators to let reviewers know 

how their suggestions are being implemented. All replies appear in the pop-up note 

and are listed below the original comment. You can view the respective reply with the 

reply title and mark. See also About pop-up notes. 

1. To reply to original comments in the pop-up note, do any of the following:  

 Using the Hand command, the Select Annotation command, or the 

corresponding comment tool, open the pop-up note for the comment, click 
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the vertical three-dot icon, and select Reply. And then type your reply in the 

textbox that appears in the pop-up window. 

 Right-click the original comment and select Reply. And then type your reply in 

the textbox that appears in the pop-up window. 

2. Replying to Comments in the Comments List 

 

 Choose View > View Setting > Navigation Panels > Comments (or click the 

Comments icon  in the navigation pane) to open the Comments panel if it 

is hidden.  

 In the Comments panel, select the comment to activate the Add Reply box.  

 Input your reply in the box and click the  icon.  

3. To delete the reply message, do either of the following: 

 In the note pop-up window, click the vertical three-dot icon and click Delete. 

 In the Comments panel, click the vertical three-dot icon, and click Delete. 

4. To flag comments with a checkmark, click the vertical three-dot icon  beside 

the comment in the Comments panel, and choose Mark with Checkmark. You 

can sort the comments with checkmarks. 

Arrange comments 

When you select one or more comments, the Format tab appears in the right panel, 

allowing you to arrange the comments. You can arrange multiple comments by 

aligning, centering and distributing them. Please follow the steps below. 

Select multiple comments 

1. Select the Select Annotation command. 

2. Press and hold Shift or Ctrl and click the comments you want to edit.  

Align Comments 

Select two or more comments that you want to align. Then do one of the following: 

 Navigate to the Format tab in the right panel, and then choose a command as 

follows: 

A. To align a column of comments, choose , , or  to align them 
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respectively to the left edge, right edge, or vertical axis of the anchor comment. 

B. To align a row of comments, choose , , or  to align them 

respectively to the top edge, bottom edge, or horizontal axis of the anchor 

comment. 

Note: The alignment commands move the other selected comments to line up with the 

edges of the anchor comment. 

 Refer to Align Images for more information. 

Center Comments 

This function enables you to center comments vertically, horizontally or both. 

To center comments, select two or more comments that you want to center. Then do 

one of the following: 

 Navigate to the Format tab in the right panel, and then choose , , or  to 

center them vertically, horizontally or both. 

 Please refer to Center Images for more information. 

Distribute Comments 

In the context of laying out comments on a page, you can give a group of comments 

uniform spacing, based on the centers of adjacent comments. This function will be 

available when selecting three or more comments. 

 To distribute the comments, navigate to the Format tab in the right panel, and 

then choose and  to distribute vertically or horizontally. 

 Please refer to Distribute Images for more information. 

Summarize comments 

Summarizing comments is an easy way to help you directly obtain a synopsis of 

comments associated with the PDF. Foxit PDF Editor Cloud supports to create a 

comment summary PDF. To create a comment summary, do as below: 

1. Choose Comment > Summarize Comments. 
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2. In Create Comment Summary dialog box, do the following: 

A. Choose the layout of the summary and there are five types of layouts for you 

to choose: 

 L1--Document and comment with connector lines on separate pages  

 L2-- Document and comment with connector lines on single pages 

 L3—Comments only 

 L4-- Document and comment with sequence numbers on separate pages 

 L5-- Document and comment with sequence numbers on single pages 

       

L1                                                 L2 

                

L3                                               L4 
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L5 

B. Comment Type - Choose the comment type you want to summarize. 

C. Paper Size-Select the paper size of the summary 

D. Font Size - Select the font size of the summary. 

E. Sort comments by – Choose how to sort the comments. 

F. Include pages– Specify the page range you need to summarize. 

3. Click OK and a PDF named “Summary of Comments on [original document 

name].pdf” will be opened automatically. You can rename it before you save. 

Import/export comments data 

This feature is especially useful for PDF reviewing. When you receive an email 

invitation to a PDF review, the invitation typically includes the PDF as an attachment 

or provides a URL to the PDF. Alternatively, you may receive a Form Data Format (FDF) 

attachment. When opened, an FDF file configures your review settings and opens the 

PDF in Foxit PDF Editor. At this moment, you need to know how to import the 

comment data from the FDF file. Similarly, you may export comment data and send 

them as an FDF file to the other participants.  

Tip: The users of Foxit PDF Editor can import the comments data from FDF, XFDF and JSON 

files. You can also export the comments data to FDF, XFDF, and JSON files.  

Import comments data 

 Open the PDF document where you want to import comments data. Choose 

Comment > Import > navigate to where the desired file is, select it, and press 

“Open”. You will be prompted that the comments data has been imported 

successfully. 

Export comments data 

To export comments data as an FDF, XFDF, or JSON file, please do the following; 

1. Choose Comment > Export > select a file format. 

2. You will be prompted to download the file to your local drive.  
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Chapter 8 – Share 

Foxit PDF Editor Cloud supports different methods to share and collaborate on PDF 

documents with others. Its Cloud Documents allows users to save files to the cloud 

and access them at any time in any browser or mobile device, greatly improving users' 

work efficiency. The Share feature enables document owners to share files for 

collaboration in real-time and collect comments from reviewers. The integration with 

different third-party application platforms lets users share and manage documents 

easily within a single application. 

Cloud Documents 

Foxit PDF Editor Cloud provides cloud storage to offer users a secure and seamless 

document workflow. Users can easily upload or save files to the cloud (Cloud 

Documents), allowing access from anywhere, at any time, and on any device. Foxit PDF 

Editor Cloud is certified by Microsoft and SOC2, and uses AWS S3 as its storage 

solution for the uploaded files, ensuring the protection of user data during storage, 

transit, backup, and retention.  

The Cloud Documents feature is also available in Foxit PDF Editor for Windows and 

Mac and Foxit PDF Editor Mobile, which allows users to work on their files across 

different platforms with ease and boost productivity. 

Notes:  

1. For enterprise users, the administrator should enable the Cloud Documents feature 

in Foxit Admin Console before utilizing this functionality.  

2. If the Cloud Documents feature is disabled, all the documents uploaded by users 

and files shared through the Share feature within the enterprise will be deleted, 

and the Share feature will be disabled as well. 

Upload files to Cloud Documents 

Users can upload any file to Cloud Documents automatically by enabling the 

Automatically upload local document to Cloud Documents when the file is 

opened option in File > Preferences > Documents. If the option is disabled and you 

want to upload a file to Cloud Documents, you can do either of the following: 

• Open the file in Foxit PDF Editor Cloud, make any necessary edits, and then 

save it to Cloud Documents. See also Save PDFs. 
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• Go to the homepage of Foxit PDF Editor Cloud and click on Documents on the 

left-hand side of the page. Then, choose Cloud Documents to open the Cloud 

Documents page, where all your uploaded files are listed. Click on Upload 

Files above the file list (if any) at the top-right corner of the page to upload a 

file to Cloud Documents. Alternatively, you can choose Home on the left-hand 

side of the homepage to access the Home page, where you can also find the 

Upload Files command above the file list (if any) to upload a file.     

Work with Cloud Documents 

On the Cloud Documents page, you can work on uploaded documents and create 

new folders to organize and categorize them from any device at any time after logging 

in to Foxit PDF Editor Cloud, without needing to upload the same file repeatedly. 

To quickly edit uploaded documents or perform other operations, move the cursor 

over a file in the file list, and several icons will appear. These icons allow you to share, 

star, and perform other actions on the file. When you move the cursor over the 

horizontal three-dot icon , a menu drops down with several options, allowing you 

to perform actions like editing, annotating, protecting, and more. Alternatively, you 

can click on a file in the file list to open it, and then choose commands and options on 

the workspace to perform necessary tasks. 

Notes:  

1. By default, Foxit PDF Editor Cloud automatically saves changes to Cloud Documents 

a little while after each edit, providing added protection against system crashes or 

power failures. 

2. Deleted files from Cloud Documents cannot be retrieved or recovered. Please make 

sure you have saved a copy of the file before deleting it. 

3. The Recent tab on the Home page displays only the user's recently opened Cloud 

Documents. 

Cloud Document Security 

Product Security 

 Development Practice 

Foxit adheres to the security concept of "shifting left", and continuously intensifies the 

implementation of S-SDLC (Secure Software Development Life Cycle). We improve our 
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product security by introducing necessary and appropriate security activities at all 

stages of the software development life cycle. These security activities include but not 

limited to architecture design review, threat modeling, static code scanning, software 

component analysis, penetration testing, web application vulnerability scanning, 

image scanning, etc. 

 Business logic and process design 

User documents are uploaded to our Cloud Documents service via browsers through 

the HTTPS protocol. The Cloud Documents service is a document management system 

developed by us based on the open-source Apache Chemistry that complies with the 

OASIS Content Management Interoperability Services (CMIS) specification, which 

includes data model (Data Model) and service (Services). It also defines the binding of 

AtomPub, binding of Web Services and binding of browser, and includes the protocol 

of multipart uploading of files in massive size. The Cloud Documents service stores 

user document information in the MySQL database, and binary contents are stored in 

the AWS S3 service. Storage is encrypted both in transit (via the HTTPS protocol) and 

at rest. 

 Acquired Certification 

Foxit PDF Editor Cloud is certified by Microsoft 365 (which demonstrates the 

application is reviewed with controls from leading industry standard frameworks and 

has strong security and compliance practices in place to protect customer data) and 

is SOC2 certified. 

Data Security 

We use the AWS S3 service as the storage solution for user uploaded files. Amazon S3 

provides a highly durable storage infrastructure for mission-critical and primary data 

storage. AWS S3 provides 99.999999999% durability and 99.99% availability. We 

ensure data security with the following specifications. 

 Static Storage Security 

Amazon S3 encrypts objects before saving them to disk in the data center by default. 

Objects are then decrypted during download. 

 Transport Security 

We use industry standard encryption to protect user data in transit, commonly 

referred to as Transport Layer Security (“TLS”) or Secure Sockets Layer (“SSL”) 
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technology while in transit. 

 Data Isolation 

Cloud documents uploaded by users in each region are stored in S3 buckets 

corresponding to their specific region. For example, files uploaded by European users 

are stored in S3 buckets in the European region. Data between regions is isolated. 

 Data Backup and Failure Recovery 

The Cloud Documents service is resilient to failures. We have version control to save, 

retrieve, and restore various versions of documents, which readily recovers data from 

false operations and application failures. There are complete life cycle rules and 

backup rules in place. 

Operational Security 

 Management of Operational Authority 

All S3 storage buckets are private using ACL-based access policies. We have least-

privileged access to allow only specific IPs and IAMs to access bucket resources. 

 Monitoring and Incident Response 

S3 protection and Amazon GuardDuty is in place to allow monitoring of object-level 

API operations, which will identify potential security risks. Amazon CloudTrail is also 

integrated to record actions taken by users, roles, or other Amazon services. 

CloudTrail captures a subset of API calls to Amazon S3 as events, including calls from 

the Amazon S3 console and code calls to the Amazon S3 API. 

CloudTrail events can be delivered to S3 buckets (including Amazon S3 events) 

continuously for further review if a trail is created. Latest events are still available in 

CloudTrail console event history even a trail is not created. Information collected by 

CloudTrail can be used to analyse events such as what requests are made, source IP 

address of the request, who made the request, when it was made etc. 

Collaboration with the Share feature 

The Share feature allows document owners to quickly share a file for collaboration by 

generating a file link or sending an invitation email. Authorized reviewers who receive 

the file link or invitation email can view or add comments to the document in web 

browsers at anytime from anywhere with an internet connection. Document owners 

can also add a deadline for the sharing or end the sharing at any time after sharing.  
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With Foxit PDF Editor Cloud, multiple reviewers can work on the same document 

simultaneously and see comments added by others. All comments from authorized 

users are saved back to the original source document, making collaboration effective. 

Share a file via a link 

1. Open the file in Foxit PDF Editor Cloud and click the Share button on Title Bar.   

2. In the Share files dialog box, click the icon  on the left.  

3. Select an option to grant reviewers (i.e., the users who will receive the file link) 

permissions to access the document. 

• Can Comment: Reviewers can make comments on the shared document. 

• Can View: Reviewers can only view the shared document. 

4. (Optional) Add a deadline for the sharing if necessary. 

5. Click Create a link to generate a link.  

6. After the link generating completes, click Start collaboration in the pop-up dialog 

box to open the uploaded/shared file and start the collaboration, or click Copy 

link and send the file link to the reviewers you want to share with. 

The shared file will also be uploaded to Cloud Documents as you create a link. 

7. (Optional) You can control the review with the options in the menu that appears 

after clicking the three-dot icon on Title Bar. 

• Add deadline – Set a deadline for the sharing if you did not set one in Step 4 

above. 

• Activities – View the records of actions performed by all users (the document 

owner and the reviewers). 

• Share with Email – Share the document by sending invitation emails to 

reviewers. Enter the email address, select the permission option (Can 

Comment or Can View), type a necessary text message in the text box, and click 

Send. See also Share a file via an email. 

• Copy Shared Link – Copy the file link to the clipboard to send it to others.  

• Unshare File – End the sharing, and reviewers can no longer access the file. 

For reviewers, after receiving the file link, they can open the document with Foxit PDF 

Editor Cloud in their web browsers to review the document. They can also perform 

additional operations after clicking the three-dot icon on Title Bar, such as viewing 

activities and copying the shared link. To leave a review, they can choose Remove Me 

from the menu. 

Share a file via an email 

1. Open the file in Foxit PDF Editor Cloud and click the Share button on Title Bar.   
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2. In the Share files dialog box, click the icon  on the left.  

3. Enter the email address and select an option to grant reviewers (i.e., the email 

recipients) permissions to access the document. 

4. (Optional) Add a text message in the text box and set a deadline for the sharing if 

necessary. 

5. Click Send. The shared file will also be uploaded to Cloud Documents as you share 

it. 

6. After sending the file, click Start collaboration in the pop-up dialog box to open 

the uploaded/shared file and start the collaboration, or click Cancel to collaborate 

later. 

7. (Optional) Control the review with the options in the menu that appears after 

clicking the three-dot icon on Title Bar. See also Share a file via a link. 

Reviewers can click the Open in Foxit PDF Editor button in the email they receive to 

open the file in Foxit PDF Editor Cloud and review the document. They can also 

perform additional operations after clicking the three-dot icon on Title Bar, such as 

viewing activities and copying the shared link. To leave a review, they can choose 

Remove Me from the menu. 

Manage shared files 

Both document owners and the reviewers may be involved with multiple reviews 

during daily document workflows. Foxit PDF Editor Cloud’s Share feature provides an 

easy way for document collaboration, but it also enables document owners and 

reviewers to manage shared files in an organized way and track the review status with 

notifications. 

To manage the shared files, do the following: 

1. Open the homepage of Foxit PDF Editor Cloud. 

2. In the left-hand side of the homepage, choose Documents > Shared.  

3. In the Shared page, all files you shared and shared by others are listed in the 

Shared by me tab and the Shared by others tab, respectively. 

4. In the file list, you can view detailed information about the shared file, such as 

reviewers, review status, and more. You can also search for a shared file if you are 

handling multiple document reviews. Perform operations like viewing review 

activities, ending the share, and leaving the review as needed.   

You (both document owners and the reviewers) get notified when others perform 

actions on the shared documents. You receive messages about review activities and 

can view the messages in the notifications box that appears after you click the 



   Foxit PDF Editor Cloud 

Chapter 8: Share                                                    User Manual 

162 

 

Notification icon (a bell icon) on Title Bar of Foxit PDF Editor Cloud. A red dot appears 

on the Notification icon if you have any pending messages. You can quickly mark all 

notifications in the box as read by clicking the horizontal three-dot icon in the upper-

right corner of the box and selecting Mark all as read from the drop-down menu. To 

delete all notifications, choose Delete all from the menu.   

Integration with third-party app platforms 

Foxit PDF Editor Cloud has been integrated with various third-party application 

platforms, such as Microsoft Office 365, Teams App, SharePoint Online & OneDrive, 

and Google Drive. This integration allows users to conveniently view, edit, share, and 

collaborate on PDF files within one application. 

Foxit PDF Editor Cloud for Microsoft Teams 

Foxit PDF Editor Cloud for Microsoft Teams provides a simple and efficient way for you 

to collaborate with members in your channel. The integration allows you to share and 

annotate PDFs to collect feedback on PDF documents without ever leaving the 

Microsoft Teams application. You will receive activity notifications on what documents 

have been uploaded and any actions taken on them. Team members can view and 

comment on each other's feedback (comments) to streamline collaboration.  

Install Foxit PDF Editor Cloud for Microsoft Teams 

To start collaborating on PDFs, you will need to install the Foxit PDF Editor Cloud app 

in Microsoft Teams.  

1. Launch Microsoft Teams and sign in. 

2. Select Apps in the sidebar. 

3. Search for Foxit PDF Editor Cloud under Apps, and select the app. 

4. Click on the Add button.  

5. After installation, the Foxit PDF Editor Cloud app will appear in the sidebar of 

Microsoft Teams. You can use it as a Personal Tab, Bot, Message Action, or 

Messaging extensions in Microsoft Teams to share and collaborate on PDFs. 

To chat with the bot and ask questions or find information about the app, simply click 

the Foxit PDF Editor Cloud app in the sidebar, and follow these steps: 

1. In the message box, press the Space key to bring up a list of options:  

• Notification Off – Stop receiving Foxit PDF Editor Cloud notifications. 
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• Notification On – Start receiving Foxit PDF Editor Cloud notifications. 

• Sign In – Sign in to your Foxit PDF Editor Cloud account. 

• Sign Out – Sign out of your Foxit PDF Editor Cloud account. 

• Feedback – Give us feedback. 

• Help – See the available commands you can use to chat with the bot. 

2. Select an option from the list and click Send to perform the corresponding action. 

Alternatively, you can type the option name (e.g., Notification On) in the message box 

and send it to the bot to perform actions.  

Share and collaborate on a PDF as a Tab from your teams/channels  

1. Select the desired team or chat channel in Microsoft Teams. 

2. Click the Messaging extensions icon  below the text message box, find the 

Foxit PDF Editor Cloud app, and click on it. Alternatively, click the Add a tab icon 

 at the top of on the team/channel. 

 

 
3. Find Foxit PDF Editor Cloud in the list of apps, and click on it. 

4. In the pop-up dialog box, select a PDF from Teams and channels, or upload one 

from your local computer. 

5. The PDF will be opened in Foxit PDF Editor Cloud as a tab in Microsoft Teams. 

6. You can start collaborating on the PDF file with the annotating tools in Foxit PDF 

Editor Cloud after signing in. Any added comments are automatically saved to the 

PDF.  

Share and collaborate on a PDF from a message with a PDF file 

If anyone sends a PDF attachment in a message within your team's channel or chat, 

you can open it and add comments using Foxit PDF Editor Cloud within Microsoft 

Teams. 

1. Select the message and click on the options menu (i.e., the three-dot icon) from 

the floating toolbar to expand the menu.  
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2. Choose (More Actions >) Collaborate in PDF Editor Cloud. 

3. The PDF will be opened in a pop-up window within Microsoft Teams using Foxit 

PDF Editor Cloud. Use the annotation tools to collaborate on the PDF. Any added 

comments are automatically saved to the PDF. 

Tip: All files you shared and shared by others from Microsoft Teams are listed in the Shared 

by me tab and the Shared by others tab in the Shared tab. See also Manage shared files.  

Notifications 

If you have Notification On set in the app, you will receive a notification message in 

both the Foxit PDF Editor Cloud chat bot in Teams app and the Notifications (the bell 

icon) of Foxit PDF Editor Cloud when team members add comments to your shared 

PDF. 

Foxit PDF Editor Cloud for SharePoint Online & OneDrive 

Business users can use Foxit PDF Editor Cloud on SharePoint Online & OneDrive to 

convert non-PDF files into PDF documents, or combine, organize, and export PDF 

documents. 

Tips:  

1. If you're a Microsoft 365 tenant Admin, you can install the Foxit PDF Editor Cloud 

app on SharePoint Online or OneDrive on behalf of all users. The app will be 

available to use 48 hours after you download and deploy it from the Microsoft App 

Store. If you are a user and do not see the add-in in SharePoint Online & OneDrive, 

contact your company’s administrator. 

2. The supported browsers include Microsoft Edge, Chrome, Firefox, and Safari. 

Open a PDF file  

To open and work on a PDF file with Foxit PDF Editor Cloud in SharePoint Online & 
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OneDrive, you can use any of the following methods: 

• Click on the file name to open the file.  

• Open the file from the context menu after you right-click it. To do this, right-

click the file and choose Open > Open in Foxit PDF Editor Cloud.  

• Open the file from the options menu (the three-dot icon ). To do this, select 

the file, click the options menu, and choose Open > Open in Foxit PDF Editor 

Cloud. (Tip: You can find the options menu next to the file name or on the top 

menu bar.) 

• Open the file from the SharePoint or One Drive preview window. To do this, 

right-click the file, choose Preview, and then select Open > Open in Foxit PDF 

Editor Cloud from the top menu bar in the preview window.  

The file will be opened in a new tab in your web browser using Foxit PDF Editor Cloud. 

You can work on the PDF use the various tools in Foxit PDF Editor Cloud. 

Work on files from the context or options menu 

From the context or options menu of one or more files, choose Actions > Foxit PDF 

Editor Cloud for SharePoint Online and OneDrive to access the following options. 

The options displayed may vary depending on the file types you're working on: 

• Convert to PDF by Foxit: convert each of the selected file(s) to a PDF. 

• Combine Files by Foxit: combine the selected file(s) into a PDF. 

• Organize Pages by Foxit: rearrange and compose pages in a PDF. 

• Export PDF by Foxit: export a PDF to other file formats. 

Foxit PDF Editor Cloud for Microsoft 365 

Add Foxit PDF Editor Cloud to Microsoft 365 to easily turn your Excel, Word, and 

PowerPoint documents into PDFs right from your favorite Microsoft 365 apps. 

Tip: If you're a Microsoft 365 tenant Admin, you can install the Foxit PDF Editor Cloud app 

on Microsoft 365 apps on behalf of all users. If you're a user and don't see the add-in in 

your Microsoft 365 apps, contact your company's administrator. 

After installation, you can find the Foxit PDF Editor Cloud command under the Home 

tab in Microsoft 365 apps. For example, in Word on the web, do the following:  

1. Click Home > Foxit PDF Editor Cloud, and the Foxit PDF Editor Cloud panel 

appears in the right panel of the Word window. 



   Foxit PDF Editor Cloud 

Chapter 8: Share                                                    User Manual 

166 

 

2. Specify the filename for the PDF. 

3. (Optional) Add password protection to the PDF.  

4. Click the Convert button. 

Foxit PDF Editor Cloud for Google Drive 

You can save time by opening a PDF file or other supported file formats with "Foxit 

PDF Editor Cloud for Google Drive" to view your file as a PDF directly. Easily view, edit, 

comment, organize, and convert to other formats or combine multiple supported 

format files into one PDF file, all in one place. 

To install Foxit PDF Editor Cloud for Google Drive, go to the Google Workspace 

Marketplace, find the Foxit PDF Editor Cloud app, and click Install. After installation, 

you can start working on your files with Foxit PDF Editor Cloud for Google Drive. Here's 

how to open and work on a file with Foxit PDF Editor Cloud for Google Drive: 

1. Right-click the file you want to open and choose Open with > Foxit PDF Editor. 

Alternatively, select the file, click the options menu (the vertical three-dot icon ) 

at the top menu bar, and choose Open with > Foxit PDF Editor. 

2. After signing in, the file will be opened with Foxit PDF Editor Cloud in a new tab in 

your web browser. Then you can work on the PDF using the various tools in Foxit 

PDF Editor Cloud.  

Note: If you open a non-PDF file, it will be converted to PDF and opened in Foxit PDF 

Editor Cloud.
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Chapter 9 – Forms 

Foxit PDF Editor Cloud is extremely useful for form filling and form designing. Please 

read below for more information. 

Interactive Form and Non-interactive form 

There are two kinds of “form” files. One is a PDF file with fillable fields, which enables 

you to fill the form directly by clicking the form fields without using other features. 

This is called an Interactive PDF Form. The other kind of form is a plain PDF file with 

lines and texts, which can be filled using the tools in the Fill & Sign context tab. This is 

called a Non-interactive PDF Form.  

Interactive Form 

For interactive forms, you will see a message box appear in the top-right corner of the 

application window. The message box informs you that this document is a fillable form.  

Foxit PDF Editor Cloud highlights the form fields in the document by default, which 

colors the backgrounds of all blanks to be filled in and outlines any required blanks, 

making it easy to see them at a glance. If you don’t need to highlight the fields, navigate 

to Form > uncheck Highlight Fields.  

AcroForm and XFA (XML Forms Architecture) Form 

Foxit PDF Editor Cloud now supports both AcroForm and XFA Form. You can fill in XFA 

forms with the Hand command, the same which you were able to do with normal 

fillable forms (also known as AcroForm).   

Non-interactive Form 

The document message box will not appear. This kind of form acts like an ordinary 

PDF document that has plain text and you will need to use the tools in the Fill & Sign 

context tab to fill in this form. For more information, please refer to “Filling Non-

interactive Forms”.  

http://en.wikipedia.org/wiki/XFA
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Fill in PDF Forms 

Foxit PDF Editor Cloud not only allows you to fill in PDF forms and print them out, but 

also supports advanced form operations, such as saving filled-out forms and 

importing/exporting forms data. 

Fill Interactive Forms 

If a PDF form contains interactive form fields, you can fill in the form with the Hand 

command. When you place the pointer over an interactive form field, the pointer icon 

changes to one of the following: 

 Hand icon  -- Appears when mousing over a button, radio button, check box, 

or item on a list. 

 I-beam icon  -- Appears when you can type text into the form field. 

To fill in an interactive form, please do the following: 

 If necessary, select the Hand command. 

 (Optional) Before filling in an interactive form, you can also enable auto-complete 

feature so that Foxit PDF Editor Cloud can store your entries and provide relevant 

suggestions to help you complete forms quickly and easily. For more information 

about auto-complete, please refer to “Auto-Complete in the Forms preferences”.  

 Then click on the first form field you want to fill in, either to select that option or 

to place an I-beam pointer  in the field so that you can start typing. 

 Right-click the text fields, and choose Paste or Select All to do other operations. 

 After making a selection or entering text, you can press Tab or Shift + Tab to accept 

the form field change and go to the next or previous field. 

 After you fill in the form fields, do either of the following: 

A. Click the submit button if one exists. Clicking this button sends the form data 

to a database across the web or over your company intranet. 

B. Save the PDF form. 

Clear a form entry 

Click one of the form fields, and use the Backspace key or Delete key. 
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Reset unsaved form entries 

Choose Form > Reset Form. 

Fill lengthy entries in forms 

Some PDF forms can contain dynamic text fields, which changes the text you input in 

size to accommodate the text fields. The text appears smaller and smaller when the 

words you type exceed the current size of the field. 

Fill Non-interactive Forms 

You can use the tools in the Fill & Sign context tab to add text and symbols in non-

interactive PDF forms. To fill in non-interactive forms, follow the steps below.  

• Click Home/Protect > Fill & Sign. Then you will find the form filling tools in the 

Fill & Sign context tab. 

• To add normal text, select Add Text. Then click on the form where you want to 

add text, and input your text.  

• To add predefined text such as name, date or address, click Predefined Text, and 

do the following: 

➢ By default, Foxit PDF Editor Cloud will detect and display the current date and 

user name of your system in the predefined text list. If you want to predefine 

custom text, click Set Predefined Text. In the pop-up Set Predefined Text 

dialog box, click Set Identity to set your identity information, and save it as 

predefined text. Or double-click on the blank area in the box to input any text 

as desired. Upon completion, click OK to save your settings. Then all your 

custom predefined text will be listed in the Predefined Text drop-down list.  

➢ Select a predefined text from the Predefined Text drop-down list, and click 

on the form where you want to add it.  

• To add symbols, do the following:  

➢ Select the Checkmark, Cross Mark, or Dot tool to fill in check boxes or radio 

buttons. Select the Line tool to strike out text, or Rectangle tool to add 

rectangles.  

➢ Then click on the form where you want to place the symbol.  

• After adding text or symbols, use the field toolbar floating above them to make 

appropriate changes, if necessary.  

➢ Click  or  to decrease or increase the size. For symbols, you can 

also drag any of the handles to resize it.  

➢ To replace the current text or symbol, click , and choose a desired option 
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from the toolbar.  

➢ To move the text or symbol, drag it directly to the desired location.  

➢ To delete the text or symbol, click .  

• After filling in the form, you can sign the form with your handwritten signature. 

For more information, please refer to “Foxit eSign” and “Quick PDF Sign”.  

• When you have completed the form, save the form.  

Tips:  

1. The fill tool will be kept as selected by default for you to add the same object 

continuously. If you need to exit the fill tool, press the ESC key, or select another 

desired tool directly.  

2. You can also recognize form fields with the Run Form Field Recognition command 

in the Form tab and then fill in forms with the Hand command. 

Comment on Forms 

You can comment on PDF forms, just like any other PDF. You can add comments only 

when the form creator has extended these rights to the users. 

See also “Chapter 7 - Comment”. 

Manage Form Data 

You can import form data from other file formats to a PDF form, or export form data 

on a PDF form to other file formats. You can also export form data from multiple PDF 

forms to a CSV file. In addition, for PDF forms with Ultraform technology, Foxit PDF 

Editor Cloud supports to create and display 2D barcode that contains form data you 

filled in.  

Import/Export Form Data 

To import and export form data is similar to the way of importing and exporting 

comment data. However, this function is only for PDF interactive forms. All the options 

for importing and exporting form data will be unavailable when you open other 

ordinary PDFs or non-interactive forms.  

Tip: You can import PDF form data from FDF, XFDF, TXT, XML, or CSV files, or export form 

data to a FDF, XFDF, TXT, XML, or CSV files.  



   Foxit PDF Editor Cloud 

Chapter 9: Forms                                                   User Manual 

171 

 

Import form data 

Choose Form > Import > navigate to where the desired file is, select it, and press 

“Open”.  

Export form data 

To export form data to a file, please do the following: 

1. Choose Form > Export > select a file format to export. 

2. You will be prompted to download the file to your local drive.  

Note: The Import and Export commands are available only when the PDF document 

contains form data. 

You can also export form data to an existing CSV file by clicking Form > Form to sheet > 

Append to an Existing Sheet. In the Open dialog box, select a CSV file you want to 

append the form data to and click Open.  

Combine forms to a sheet 

To export form data from multiple PDF forms to a CSV file, please do as following: 

1. Choose Form > Form to sheet > Combine Forms to a Sheet. 

2. In the Export multiple forms to a sheet dialog box, click Add Files to add files that 

you want to combine into a sheet. You can also click Close button in the dialog 

box to remove files. 

4. Click Export. You will be prompted to download the file to your local drive.  

Form Fields 

Foxit PDF Editor Cloud provides a group of buttons that can be used to create and 

design form fields in interactive PDF forms. You are able to add form fields like push 

buttons, text fields, check boxes, combo boxes, list boxes and radio buttons to an 

interactive PDF form and specify their properties. Foxit PDF Editor Cloud also offers 

form field recognition commands to recognize form fields in PDF documents. You can 

save time and mouse actions by using form field recognition to create form fields. 

To add a form field to a PDF, select a type of form field button from the Form tab and 

the cursor changes to crosshair . Drag an area in the desired position to add the 
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form field. For details, please refer to Buttons. 

Form field recognition 

There are two commands for form field recognition in PDF forms: Designer Assistant 

and Run Form Field Recognition.  

The Designer Assistant command automatically detects form fields that can be 

created on PDF pages and displays a blue frame where there is a suggested form field. 

By default, when you select any type of form field button from the Form tab, the 

Designer Assistant command will be selected and enabled automatically. With any 

type of form field button selected, as you move the cursor on the page, a blue 

frame appears if the cursor is hovering above an area which is detected as a form field. 

If you want to add a form field at that position, just click on it without dragging an area. 

And if there are multiple form fields detected, you can complete the form field creation 

with just a few clicks. (Tip: You can disable the auto-detection by clicking the Designer 

Assistant command again when you are creating form fields. Then the command will no 

longer be selected automatically next time you create form fields. To enable it again, select 

the command before you create form fields.) 

Alternatively, you can use the Run Form Field Recognition command to recognize 

form fields through the whole document. To run form field recognition in a PDF 

document, do as the following: 

1. Click Form > Run Form Field Recognition. All fillable fields in the document 

will be recognized and highlighted.  

2. All the corresponding types of form fields will be automatically created and 

named with the text near the form fields. (Take the text fields for an example 

as below. With the Text Field command selected, you can see the form fields 

recognized and created are named with the text near the form fields.) 

3. You can edit or delete the created form fields after right-clicking them. To edit 

the form field further, please refer to the properties of different buttons from 

“Buttons”. 

 

The text fields created after recognition 
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Buttons 

There are nine basic buttons to add form fields for you to create an interactive PDF 

form: 

Button 
Tool 

Name 
Description 

 
Push 

Button  

Creates an interactive form element to initiate certain 

predefined actions, such as opening a file, submitting data to 

a web server, or resetting a form. This button can also be 

customized with images and text. 

 Check Box 

Presents yes-or-no choices for individual items. If the form 

contains multiple check boxes, users can select what they 

want. 

 
Radio 

Button 

Presents a group of choices from which the user can select 

only one item. 

 
Combo 

Box  

Lets the user either choose an item from a pop-up menu or 

type in a value. 

 List Box  Displays a list of options the user can select. 

 Text Field  
Lets the user type in text, such as name, address, phone 

number, etc. 

 
Signature 

Field 

Creates a blank digital signature field for reviewers to sign the 

document  

 
Image 

Field  
Lets the user browse and select an image to add to the field. 

 Date Field Lets the user choose a date.  
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Form Fields 

Note: To create the same type of form fields continuously without reselecting the same tool, 

you can select Form > Keep Tool Selected. 
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Push Button 

 Create a new push button 

Choose Form > Push Button , and your cursor changes into . Then do the 

following: 

 Drag an area in the desired place to create a push button. 

 A box appears under the button for you to input the button name and the name 

of label. 

 You can also click the All Properties to do more settings. 

 Move and resize a push button 

 To move a push button, select the Select Annotation command or push button

, click and drag the button to move it to a new location. 

 To resize a push button, select the Select Annotation command or push button

, click to select the button, and then drag a border handle.  

 Delete a push button 

 Select the Select Annotation command or push button , and click the push 

button you want to delete. 

 Press Delete, or right-click the push button > Delete. 

 Create multiple copies of a push button 

 You can create multiple copies of a push button. The new push button names are 

the same with the original push button. With the Select Annotation command or 

push button , select the push buttons that you want to.  

 Right-click the button > Create Multiple Copies… 

 In the Create Multiple Copies of Fields dialog box, do the following: 

A. To specify the rows to be created, enter or select a number in Copy Selected 

fields down (times). The default number is set to 2. 

B. To specify the columns to be created, enter or select a number in Copy 

Selected fields across (times). The default number is set to 2. 
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C. To specify the width of the area in which the columns of fields appear, enter 

or select a number in Change Width (px). The default number is set to 10. 

D. To specify the height of the area in which the columns of fields appear, enter 

or select a number in Change Height (px). The default number is set to 5. 

Note: The width and height values don’t change the dimensions of individual fields but 

designate the size of the entire area for all the selected and newly created fields. 

E. To change the position of buttons, use the Up, Down, Left, and Right buttons 

in the dialog box. 

F. Click Preview to preview the result in the document area. 

 Click OK. 

 Duplicate a push button across multiple pages 

 Select the push button that you want to duplicate. 

 Right-click the button > Duplicate… 

Note: The Duplicate command isn’t available for forms with only one page. 

 Then do one of the following: 

A. To duplicate the push button on every page in the form, select All Pages, and 

click OK. 

B. To duplicate the push button on odd/even page in the form, select Odd pages 

or Even pages, and click OK. 

C. To duplicate the push button on a limited range of pages, type the starting and 

ending page on which you want the button to appear. Click OK. 

Note: Enter the page number including or not including the page on which the button 

originally appears doesn’t affect the duplication process. Including that page won’t 

create a second copy on top of the original one, and not including it won’t remove the 

original button. 

 Set tab order   

When navigating form fields using the Tab key, you can set the tab order of the buttons 

you created. By default, the tab order is based on the document structure. There are 

three ways you can choose to set tab order. 

1. Set tab order in the Fields panel 

1) Open the Fields panel in the Navigation Pane. 
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2) Click the Display Order icon  in the upper-right corner of the Fields panel 

and select Tab Order (Note: If you select Alphabetic Order, all the form fields 

will be displayed alphabetically by the field names. Then the Set Order icon next 

to the Display Order icon disappears.).  

3) (Optional) Select Show Tab Numbers to view the tab order. The order 

number will show on the top left corner of a field. 

4) Click the Set Order icon and choose any of the following: 

• Order Tabs by Row – Order tabs from the upper-left field, moving first 

from left to right and then down to the next row. 

• Order Tabs by Column – Order tabs from the upper-left field, moving 

first from top to bottom and then to the right column.   

• Order Tabs by Structure – For forms with tagged fields, order tabs in 

the order set up in the tagging based on the document structure.  

2. Set tab order in Page Properties 

1) Click the page thumbnails panel in in the Navigation Pane.  

2) Right-click the page where you need to change the tab order and choose 

Properties….  

3) In the Page Properties dialog box, select one order in the Tab Order tab. 

3. Set tab order in the document area  

1) With the Select Annotation command selected, right-click a form field, and 

choose Set Tab Order.  

2) Click anywhere in the field that you want it to be the first in the tabbing order. 

The number in the upper left corner will be set as 1.  

3) Click each of the other fields in the order that you want tabbing to occur.  

Note: You can only set tab order within one page.  

 Set push button properties 

You can set properties that apply formatting, determine the appearance and actions, 

and so forth. 

The push button has a General tab, an Appearance tab, a Position tab, an Options tab, 

and an Actions tab. Besides, there are two items on every tab: 

➢ Locked – When selected, prevents any further changes to any push button 

properties. 
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➢ Close – Applies and saves the current button properties, and closes the button 

properties dialog box. 

Note: If you select Locked on any tab, it will lock all options for the button, but not just the 

options on that tab. 

1. The General tab for the button properties 

The General tab in push button properties contains the following options: 

 Name – Specifies the unique name of the selected push button. 

 Tooltip – Displays text that the hesitant user may find helpful in clicking the button. 

Tooltips appear when the pointer hovers over the push button. 

 Form Field – Specifies whether the push button can be seen, either on screen or 

in print. There are four choices for you: Visible, Hidden, Visible but doesn’t print, 

and Hidden but printable. 

 Orientation – Rotates the push button by 0, 90, 180, or 270 Degrees. 

 Read Only – Prevents the user from clicking the push button. 

 Required – This option is not available for the push button. 

2. The Appearance tab for the button properties 

The Appearance properties determine how the push button looks on the page. The 

Appearance tab in push button properties contains the following options: 

 Line Style – Alters the appearance of the frame. Select Solid, Dashed, Beveled, 

Inset or Underline. 

                      

Solid           Dashed        Beveled          Inset        Underline 

The appearances of Push Button with different line styles 

Note: You may not see the difference if no color is chosen as the border color. 

 Thickness – Specifies the width of the frame surrounding the push button: Thin, 

Medium, or Thick. 

 Border Color – Opens a color picker in which you can select a color for the frame 

surrounding the button. To leave the button without a frame, select No color. 

 Fill Color – Opens a color picker in which you can select a color for the button. To 

leave the button uncolored, select No color. 
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Note: A Fill Color choice other than No color will block any images on the PDF page that 

are behind the button. 

 Font Size – Sets the size of the label for the button. You can either choose Auto, 

various preset values, or type in a different value.  

 Text Color – Opens a color picker in which you can select a color for the label. 

 Font – Lists the fonts available on your computer. 

 

Push Button 

3. The Position tab for the button properties 

You can use the Position tab to make accurate adjustments to the position and the 

size of the button by entering specific values. Select the unit of the values. To move 

the button, enter values for the position properties (the Left/ Right/ Top/ Bottom 

options). To change the size of the button, enter values for the Height and Width 

options. To move the button without changing its size, select the Do not change 

height and width when changing the position option.    

4. The Options tab for the button properties 

The Options properties determine how labels and icons appear on the button. A 

button can have a label, an icon, or both. The Options tab in push button properties 

enables you to add any labels you like. The Options tab in push button properties 

contains the following options: 

 Layout – Specifies the layout of label and icon of the button. There are seven 

choices: 

                   

A           B          C          D          E           F          G 

A. Label only  B. Icon only  C. Icon top, label bottom  D. Label top, icon bottom  E. Icon left, label right  

F. Label left, icon right  G. Label over icon 

Button Layouts 

Font Size: 18 

Text Color: Green 

Font: Open Sans 
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 Advanced – Does the details settings to the icon.  

A. When to scale – choose when to scale the icon you insert. There are four 

options: 

Always: scale the icon to fit the button you draw. 

Never: never scale the icon. Show the icon with its original size all the time. 

Icon is too Big: zoom out the icon to fit the button if the former one is bigger 

than the latter one, or show the icon with its original size. 

Icon is too Small: zoom in the icon to fit the button if the former one is smaller 

than the latter one, or show the icon with its original size. 

B. Scale – choose to scale the icon non-proportionally or proportionally. This 

option will be disabled when you select Never in the field of When to scale. 

Proportionally: scale the icon in its proportion. 

Non-proportionally: scale the icon to fit the button when the magnification is 

changed. 

C. Fit to bounds – check this option to scale the icon to fit fully within the bounds 

of the button without taking into consideration the line width of the border. 

D. Border – drag and move the scroll bar to change icon’s position in the button. 

The coordinates change when you move the scroll bar. 

 Behavior – Specifies the display of the button when clicked. The button behavior 

options include: 

None: Keeps the appearance of the button the same. 

Push: Specifies appearances for the Up, Down, and Rollover states of the mouse. 

Select an option under State, and then specify a label or icon option: 

Up: Determines what the button looks like when the mouse button is not 

clicked. 

Down: Determines what the button looks like when the mouse is clicked on 

the button, but before it is released. 

Rollover: Determines what the button looks like when the pointer is held 

over the button. 
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Outline: Highlights the button border. 

Invert: Reverses the dark and light shades of the button. 

 

 
                     The Button Behaviors 

 To define the label or icon that appears on the button, do the following: 

A. If a label option is selected from the Layout menu, type the text in the Label 

box. 

B. If an icon option is selected from the Layout menu, click Choose icon… > click 

Browse… > Select the file type from the Objects of Type menu, double-click 

the file name, and click OK. (To remove the selected icon, click Clear button.) 

 Click Close to accept these display properties. 

5. The Actions tab for the button properties 

The Actions properties specify any actions that you want to associate with the push 

button, such as jumping to a specific page or going to a web site. The Actions tab in 

push button properties contains the following options: 

 Select Trigger – Specifies the user action that initiates an action: Mouse Up, 

Mouse Down, Mouse Enter, Mouse Exit, On Receiving Focus, or On Losing 

Focus. 

 Select Action – Specifies the event that occurs when the user triggers the action: 

Go to a page view, Open/execute a file, Open a web link, Show/hide a field, 

Execute a menu item, Submit a form, Reset a form, Import form data, and 

Run a JavaScript. 

A. Go to a page view – designate to a specific page view. You can not only 

designate to a page in the current PDF, but also to the page in another PDF. 

Also, you may change the current zoom setting and then set the position. 

To go to a page view, choose this option, click Add button and do one of the 

following: 

a) Set the position in current document – scroll the current document, go to a 

new position where you want to set and click Set this position. 

Push 
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b) Set the position in another PDF document – click the Open button on the 

toolbar > select the PDF you want to set position > scroll this document and 

go to a position where you want to set > click Set this position.  

Note: The new PDF document should be opened in the existing window but not a new 

window. 

c) Change the view magnification -- scroll in the current document or another 

document > go to a new position where you want to set > change the 

magnification of the position > click Set this position.  

d) Click Cancel to revoke your operation. 

B. Open/execute a file – designate to open another file. To do this, choose 

Open/execute a file > click Add button > select the destination file and click 

Select. 

C. Open a web link – designate to open a web link. To do this, choose Open a 

web link > click Add button > enter the URL of the destination web page. 

D. To show/hide a field, select the option > click Add… > choose to show or hide 

the selected button when the user triggers the action, and click OK. 

E. To execute a menu item, select the option > click Add… > select one of the 

items in Menu Item Selection dialog box, and click OK. 

F. To submit a form, select the option > click Add… > choose the export format, 

submission method, decide which fields should be submitted, and click OK.  

G. To reset a form, select the option > click Add… > select the fields that will be 

reset, and click OK. 

H. To import form data, select the option > click Add… > choose the FDF file that 

contains the form data you want to import, and click Open. 

I. To run a JavaScript, select the option > click Add… > enter JavaScript, and click 

OK. For more details, please refer to the JavaScript section.  

J. To read an article, select Read an article > click Add… > choose an article, and 

click OK.   

K. To set layer visibility, select the option > click Add… > click OK to set the target 

layer state of the selected action to the current state. 

 Actions – Displays the list of triggers and actions that you have defined. 

 Up and down buttons – Change the order in which the selected action appears 

listed under the trigger. (Available only when you have defined multiple actions 

for the same trigger.) 

 Edit – Opens a dialog box with specific options for the selected action. You can 

also double-click the actions to open a dialog box. 

 Delete – Removes the selected action. 
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 Set push button properties as default 

After setting button properties for a new push button, you can set your settings as the 

new default for all the push buttons you create in future. To set the current properties 

as default, right-click the push button > select Use Current Properties as New 

Defaults. 

 Set properties of multiple form fields 

 Select multiple form fields > right-click one of them > Properties…. 

 There pops up the Button Properties dialog box, and then follow the steps 

specified above. 

Check Box 

A check box is a type of form field that presents yes-or-no choices for individual items. 

For creating, moving, resizing, deleting, creating multiple copies, duplicating a check 

box and setting tab order, please refer to “Push button”. 

 Set Check Box Properties 

There are also five tabs, a General tab, an Appearance tab, a Position tab, an Options 

tab, and an Actions tab, for you to set check boxes’ properties. 

The General tab 

Most items in this tab are the same as the ones in the properties of Push Button. 

Please refer to Set Push Button Properties for details. For the Required option:   

 Required – Forces the user to select the check box. If the user attempts to submit 

the form while a required check box is not selected, an error message appears.  

The Appearance tab 

Please refer to Set Push Button Properties. 

The Position tab 

Please refer to Set Push Button Properties.  

The Actions tab 

Please refer to Set Push Button Properties. 
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The Options tab 

Check Box Style - Specifies the style of the check box. There are six choices: 

           

 A      B      C      D       E      F 

Check Box Style 

A. Check    B. Circle   C. Cross   D. Diamond   E. Square   F. Star 

Export Value - Identifies the check box and differentiates it from other check boxes 

that share the same Name value. 

Checked by default – Sets the selection state of the check box when the user first 

opens the form. 

Notes:  

1. If you create multiple copies of the check box, please make sure both the form field 

names and the export value are all different in related check boxes. 

2. If the check boxes in a group have the same form field name but with different export 

values, the check boxes will present a group of choices from which the user can select 

only one item.  

Radio Button 

A radio button is a type of graphical user interface widget that allows you to choose 

one of a predefined set of options. For creating, moving, resizing, deleting, duplicating 

the buttons and setting tab order please refer to “Push button”. 

Tip: How to toggle radio buttons  

For the radio buttons in a group, they should have the same form field name but with 

different export values. This ensures that the radio buttons toggle and that the correct 

values will be collected in the database. 

1. Please use copy-paste to create multiple copies if having more than one form field with 

the same name. After this, to make the value usable, you have to change the value of 

the radio buttons to make sure all radio buttons have the same field name but different 

export value.  

2. Please note you cannot use “Create Multiple Copies” option if there is more than one 
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radio button with the same name. A warning message will pop up if you right click and 

choosing Create Multiple Copies. 

 Set radio button properties 

How a radio button behaves is determined by settings in the Radio Button Properties 

dialog box. You can set properties that apply formatting, determine the appearance 

and actions, and so forth. 

The radio button has a General tab, an Appearance tab, a Position tab, an Actions tab, 

and an Options tab as push button.  

1. The General tab 

Most items in this tab are the same as the ones in the properties of Push Button. 

Please refer to Set Push Button Properties for details. For the Required option:   

 Required – Forces the user to click the radio button. If the user attempts to submit 

the form while a required radio button is not chosen, an error message appears. 

2. The Appearance tab for the radio button properties 

The Appearance properties determine how the radio button looks on the page. The 

Appearance tab in push button properties contains the following options: 

 Line Style – Alters the appearance of the frame. Select Solid, Dashed, Beveled, 

Inset or Underline. 

                                 

Solid          Dashed        Beveled        Inset         Underline 

The appearances of Radio Button with different line styles 

Note: You may not see the difference if no color is chosen as the border color. 

 Thickness – Specifies the width of the frame surrounding the radio button: Thin, 

Medium, or Thick. 

 Border Color – Opens a color picker in which you can select a color for the frame 

surrounding the button. To leave the button without a frame, select No color. 

 Fill Color – Opens a color picker in which you can select a color for the background 

behind the button. To leave the background uncolored, select No color. 
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Note: A Fill Color choice other than No color will block any images on the PDF page that 

are behind the button. 

 Text Color – Opens a color picker in which you can select a color for the button. 

  

Radio Button 

Note：The items of Font Size and Font are not available in the Appearance tab for the Radio 

Button properties. 

3. The Position tab for the radio button properties 

 Please refer to “Position tab for the button properties”. 

4. The Actions tab for the radio button properties 

 Please refer to “Actions tab for the button properties” . 

5. The Options tab for the radio button properties 

The Options tab in radio button properties enables you to change the button style 

and do other additional settings. The Options tab in radio button properties contains 

the following options: 

 Button style – Specifies the shape of the maker that appears inside the button 

when the user selects it. There’re six choices in total: Check, Circle (the default), 

Cross, Diamond, Square, or Star. This property does not alter the shape of the 

radio button itself. 

 Export Value – Identifies the radio button and differentiates it from other radio 

buttons that share the same Name value. The status of a radio button is “yes”. 

You can give them other names with this box. 

 Checked by default – Sets the selection state of the button when the user first 

opens the form. 

 Radio buttons with the same name and value are selected in unison – Allows 

single-click selection of multiple related radio buttons. If the user selects a radio 

button that has the same field name and export value as another, both radio 

buttons are selected. 

 Click Close to accept these display properties. 

Border color 

Text color 

Fill color 
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 Set radio button properties as default 

After setting radio button properties for a new radio button, you can set your settings 

as the new default for all the radio buttons you create in future. 

To set the current properties as default, right-click the radio button, select Use 

Current Properties as New Defaults. 

Combo Box Button 

A combo box is a commonly-used GUI widget. It is a combination of a drop-down list 

or list box and a single-line textbox, allowing the user either to type a value directly 

into the control or choose from the list of existing options. 

For creating, moving, resizing, deleting, duplicating the combo box and setting tab 

order, please refer to “Push button”. 

 Set combo box properties 

How a combo box behaves is determined by settings in the Combo Box Properties 

dialog box. You can set properties that apply formatting, determine the appearance 

and actions, perform mathematical operations, and so forth. 

The combo box has a General tab, an Appearance tab, a Position tab, an Options tab, 

a Format tab, a Validate tab, a Calculate tab, and an Actions tab.  

1. The General tab for the combo box properties 

Please refer to “General tab for the radio button properties”. 

2. The Appearance tab for the combo box properties 

Please refer to “Appearance tab for the button properties”. 

3. The Position tab for the combo box properties 

Please refer to “Position tab for the button properties”. 

4. The Actions tab for the combo box properties 

Please refer to “Actions tab for the button properties”. 

5. The Options tab for the combo box properties 
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You can create a list of items from which the user selects with the Options tab. 

 Item – Accepts the text and space character that you type for options that you 

want to appear in the menu for the field. 

 Add – Moves the current entry in Item to Item List. 

 Export value – Where you type in a value to represent the item if the data will be 

exported. If left blank, the entry for Name in the General tab is used as the export 

value. 

 Item list – Displays the choices that will be available in the list.  

Note: The highlighted item in the Item List box appears as the default selected item in the 

combo box field. To change the default item, highlight another item from the list. 

 Delete – Removes the selected item from the list. 

 Up/Down – Change the order in which the items are listed in the combo box list. 

These buttons are not available if Sort Items is selected. 

 Allow user to enter custom text – Enable users to enter a value other than the 

ones in the list. 

6. The Format tab for the combo box properties 

The Format tab in the combo box properties dialog box enables you to format the field 

values. Select one of the categories listed below: 

 None – No additional options are available. The input in a combo box with this 

property does not require any specific formatting. 

 Number – Automatically imposes the selected formatting options on numeric 

data entries. 

A. Decimal places – Sets the number of digits that appear to the right of the 

decimal point. 

B. Separator style – Sets the placement of commas and periods. 

C. Currency symbol – Sets the type of currency, such as Dollars, Euros, or Pounds. 

D. Negative Number Style – Sets how negative numbers are displayed. You can 

choose Show parentheses, Use red text, neither, or both. 

 Percentage – Automatically imposes the selected formatting options on numeric 

data expressed as a percentage. 

A. Decimal places – Sets the number of digits that appear to the right of the 

decimal point. 

B. Separator style – Sets the placement of commas and periods. 
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 Date – The list provides different types of date formats and you can choose one 

as desired. Once you select a date format, the format preview with the current 

system date will be displayed. Also, you can choose Custom option and type your 

format. 

 Time – The list includes display variations where h stands for the hour on a 12-

hour clock, H stands for the hour on a 24-hour clock, MM stands for minutes, ss 

stands for the seconds, and tt stands for AM or PM. Also, you can choose the 

Custom option and type your format. 

 Special – There are five options for you: 

A. Zip Code – For a five-digit postal code. 

B. Zip Code + 4 – For a nine-digit postal code. 

C. Phone Number – For a ten-digit telephone number. 

D. Social Security Number – For a nine-digit US Social Security Number.  

E. Arbitrary Mask -- Changes the format category to Custom and makes another 

text box available, in which you can type a custom format. Use this option to 

specify which types of characters the user can enter in any given position, and 

how the data displays in the field. 

a. A -- Accepts only letters (A–Z, a–z). 

b. X -- Accepts spaces and most printable characters, including all characters 

available on a standard keyboard and ANSI characters in the ranges of 

32–126 and 128–255.  

c. O -- The letter “O” accepts alphanumeric characters (A–Z, a–z, and 0–9).  

d. 9 -- Accepts only numeric characters (0–9).  

For example, a mask setting of AAA--p#999 accepts the input BDF--p#367. A 

mask setting of OOOOO@XXX accepts the input vad12@3Up. 
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     Example of an Arbitrary Mask entry 

 Custom -- Makes additional options available to form designers who want to write 

their own JavaScripts for formatting and keystrokes. For example, a custom script 

could define a new currency format or limit the user entry to specific keystroke 

characters. 

A. Custom Format Script – Displays any custom scripts you have added for 

formats. The Edit button opens a JavaScript Edition dialog box in which you 

can write and add new scripts. 

B. Custom Keystroke Script –Displays any custom scripts you have added to 

validate keystrokes. The Edit button opens a JavaScript Edition dialog box in 

which you can write and add new scripts. 

7. The Validate tab for the combo box properties 

The Validate properties restrict entries to specified ranges, values, or characters, 

ensuring that users enter the appropriate data for a combo box. 

 Field value is not validated – Turns off validation. 

 Field value is in range – Sets a numeric range for a combo box using values you 

enter in either as a number or a percentage. It is available only when Number or 

Percentage is selected in Format tab. 

 Run custom validation script – Validates by a JavaScript that you create or provide. 

The Edit button opens a JavaScript Edition dialog box in which you can write and 
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add new scripts. 

8. The Calculate tab for the combo box properties 

With this option, you can perform mathematical operations on existing form field 

entries and display the result. 

 Value is not calculated – Select this option if you want the users to type. 

 Value is the – Select this to make further options available: 

A. The List includes the mathematical functions to apply to the selected fields. 

Choose Sum to add the values entered in the selected fields, Product to 

multiply them, Average, Minimum, or Maximum. 

B. Pick – Opens a Field Selection dialog box with a list of the available fields in 

the form that you select to add or deselect to remove from the calculation. 

 Simplified field notation -- Uses JavaScript with field names and simple arithmetic 

signs. The Edit button opens a JavaScript Edition dialog box in which you can write, 

edit, and add scripts. 

 Custom calculation script -- Displays any custom scripts you have added for 

calculations. The Edit button opens a JavaScript Edition dialog box in which you 

can write and add new scripts. 

 Set combo box properties as default 

After setting combo box properties for a new combo box, you can set your settings as 

the new default for all the combo boxes you create in future. 

To set the current properties as default, right-click the combo box > select Use 

Current Properties as New Defaults. 

List Box and Text Field 

A list box is a GUI widget that allows the user to select one or more items from a list 

contained within a static, multiple line text box. Also, you can set a list box property 

that enables the user to Shift-click or Ctrl-click/Control-click to select multiple items on 

the list. 

A text field is a common element of graphical user interface of computer programs, 

as well as the corresponding type of widget used when programming GUIs, which let 

the user type in text, such as name, address, phone number, etc. 

For creating, moving, resizing, deleting, duplicating the list box and text field and 



   Foxit PDF Editor Cloud 

Chapter 9: Forms                                                   User Manual 

192 

 

setting tab order please refer to “Push button”. 

 Set list box properties 

Please refer to “Set combo box properties”. 

 Set text field properties 

Although most of the properties are common to those of combo boxes, the Options 

tab is exclusive. 

1. For all the other properties of a text field, please refer to “Set combo box properties”. 

2. The Options tab for the text field properties 

 Alignment – Aligns the text left, right, or center within the field. 

 Default Value – Specifies the text that appears until the user overwrites it by typing 

in the field. Enter the default value by typing in this option. 

 Scroll long text – Compensates for text that extends beyond the boundaries of the 

text field. 

 Limit of Characters – Allows entries of up to the number of characters you specify. 

Note: If you entered a default value, that value is clipped to this limit. 

 Password – Displays the user-entered text as a series of asterisks (*). This option 

is available only if Check Spelling is deselected. 

 Check spelling – Checks the spelling of user-entered text. 

 Comb of Characters -- Spreads the user-entered text evenly across the width of 

the text field. If a border color is specified, Solid or Dashed Line is selected in the 

Appearance tab, each character entered in the field is separated by lines of that 

color. This option is available only when no other check box is selected. 

                 

                      A                                B 

Text fields with and without the Comb property 

A. Text field with a border color, using the Comb property 

B. Text field without the Comb property 



   Foxit PDF Editor Cloud 

Chapter 9: Forms                                                   User Manual 

193 

 

 Multi-line – Allows more than a single-line entry in the text field.  

 Set text field properties as default 

To set the current properties as default, right-click the text field > select Use Current 

Properties as New Defaults. 

Signature Field 

The signature field is specially designed by to create blank digital signature fields for 

reviewers to sign. You can place the field anywhere you want the reviewers to sign. 

 Create a new Signature field 

Choose Form > Signature Field , your cursor will change into and do the 

following:  

 Drag an area in the desired place to create a signature field. 

 A box appears under the field for you to input the name. 

 You can also click the All Properties to do more settings. Or double-click the field 

to open the signature Properties dialog box. 

For moving, resizing, deleting, duplicating the signature field and setting tab order, 

please refer to “Push button”. 

To set signature field’s General, Appearance, Position, and Actions tab properties, 

please refer to “Set push button properties”. 

Foxit PDF Editor Cloud supports to sign and verify digital signatures on XFA forms 

created by Adobe LiveCycle. To sign and verify digital signatures, please refer to Digital 

Signature.  

The Signed tab for the signature field properties 

• Nothing Happens When Signed – it is set as default. 

• Mark As Read-Only - Prevents other readers to change the digitally signed form.  

 All Fields - Prevents any changes to any form field. 

 All Fields Except These - Allows changing the selected form fields. Click 

the Pick button and select check boxes for the fields that you want the 

reviewers to edit after signing. 

 Just These Fields – Prevent to change the form fields you pick. 
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• This Script Executes When Field is Signed: 

Activate a custom JavaScript when the user digitally signs the form. Click the Edit 

button to change or create a new JavaScript action. 

Image Field 

An image field is a Push Button with JavaScript prewired, which allows users to 

quickly browse and select an image to add to the PDF document. For creating and 

modifying an image field, please refer to the instructions on Push button. 

Date Field 

A date field is a Text Field with the Format set to Date, letting users quickly fill in a 

date in the PDF. When users click the date field with the Hand command, the Date 

picker arrow icon appears. Click the arrow icon and choose a date from the Date 

picker. Then the date is successfully filled in the date field with the specified format. 

For creating and modifying a date field, please refer to the instructions on the 

instructions on Text Field. 

Arrange form fields 

You can arrange form fields in a page, such as aligning, centering and distributing form 

fields. Before arranging form fields, select multiple form fields. 

Select multiple form fields 

To arrange the form fields, you have to select multiple form fields that you want to 

arrange first. 

To select multiple form fields, do one of the following: 

 Choose the Select Annotation command > Shift-click or Ctrl-click each form field. 

 Choose the Select Annotation command > drag a selection marquee around the 

area to select them.  

To deselect an individual form field, Ctrl-click the specific field. 

Note: The form field highlighted in red is the anchor. When you select multiple form fields 

by clicking, the last field selected is the anchor. 
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Align/Center/Distribute multiple form fields 

Please refer to Arrange comments for details. 

Resize multiple form fields 

Select one of the form fields as the anchor, and the rest of the form fields will be 

resized with the same height or width as that of the anchor form field. For example, 

 Select form field A and B with the Select Annotation command. Suppose that you 

want to set A as the anchor form field.  

 Right-click A > Size > Height/Width/Both. And you’ll see that the 

height/width/height and width of B is resized to be the same as that of A. 

Set Form-field Tab Order  

Please refer to Set Tab Order of Push Button. 

Page templates 

Page templates can be used to fill a PDF form where users need to add more pages if 

they still have info to enter. Or, an official organization like Customs creates a page 

template which contains several buttons with JavaScript actions that corresponding 

forms will appear when users click on different buttons to fill in forms based on 

different situations.  

Create a page template 

1. Navigate to a page that you want to create a page template from. 

2. Click Form > Page Template. 

3. In the Page Templates dialog box, enter the name and click Add. 

4. A message box pops up to ask you whether to create a new page template from 

the current page. Click OK.  

5. The name of the created template will be listed in the dialog box, and you can 

preview it on the left of the dialog box by checking the box to the left of the 

template name.  

6. Click Close to exit the Page Templates dialog box. 
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Manage page templates 

In the Page Templates dialog box, choose a template and click Goto to navigate to 

the page. You can also rename, replace, and delete page templates. 

 Rename a page template 

1. Click Form > Page Template. 

2. In the Page Templates dialog box, choose the template you want to rename, click 

Rename and click OK. 

3. Type a new name in the pop-up dialog box and click OK. 

4. Click Close to exit the Page Templates dialog box. 

 Replace a page template 

1. Navigate to a desired page you want to replace with. 

2. Click Form > Page Template. 

3. In the Page Templates dialog box, choose the template you want to replace, click 

Replace and click OK. 

4. Click Close to exit the Page Templates dialog box. 

 Delete a page template 

1. Click Form > Page Template. 

2. In the Page Templates dialog box, choose the template you want to delete, click 

Delete and click OK. 

3. Click Close to exit the Page Templates dialog box. 

Set the field calculation order 

When you define two or more calculations in a form, the order in which they are 

carried out is the order in which you set the calculations. In some cases, you may need 

to modify the calculation order to obtain correct results.  

For example, if you want to use the results obtained from calculating two form fields 

to calculate the value of a third form field, the first two form fields must be calculated 

together first to obtain the correct results. 

 Choose Form > Calculation Order. 

The Calculation Order dialog box displays all calculable fields in your form and the 

order in which the calculations are performed. 



   Foxit PDF Editor Cloud 

Chapter 9: Forms                                                   User Manual 

197 

 

 To change the field calculation order, select the field from the list, and then click 

the Up or Down button as needed. 

 Click OK to finish. 

Edit Static XFA Forms 

Foxit PDF Editor Cloud supports editing of static XFA forms.  

To edit static XFA forms, please do as below: 

1. Open the static XFA form with Foxit PDF Editor Cloud and choose Form > Edit Static 

XFA Form. You’ll be prompted to save a copy of the original file to continue to edit. 

2. Click OK to edit the form as needed. 

JavaScript 

JavaScript is a dynamic, prototype-based language with first-class functions, which 

serves as a means to easily create interactive web pages. In Foxit PDF Editor Cloud, 

you can easily integrate this level of interactivity into your PDF documents.  

With Foxit PDF Editor Cloud, you can invoke JavaScript code using actions associated 

with documents, bookmarks, links, and pages. Foxit PDF Editor Cloud provides four 

options –Document JavaScript, Document Action, JavaScript Console, and Edit All 

JavaScripts. The Document JavaScript lets you create or access document level scripts 

in Foxit PDF Editor Cloud. The Document Action lets you create document-level 

JavaScript actions that apply to the entire document. The JavaScript Console provides 

an interactive and convenient interface for testing portions of JavaScript code and 

experimenting with object properties and methods. The Edit All JavaScripts option 

allows you to create and edit all JavaScripts (e.g. bookmark JavaScripts, page 

JavaScripts, etc.) in the JavaScript Editor. 

Document JavaScript 

Document JavaScripts are variable and function definitions that are generally useful 

to a given document, but are not applicable outside the document. 

 Variable definitions: Define variables at the document level to make them visible 

to any executing script. 

 Function definitions: Define functions at the document level that support the user 

interaction with the document. These functions may be utility functions for 
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handling common tasks for string or number manipulation, or functions that 

execute lengthy scripts called by actions initiated by a user interacting with form 

fields, bookmarks, page changes, etc. 

To create or access document level scripts in Foxit PDF Editor Cloud, select Form > 

JavaScript > Document JavaScript. The pop-up JavaScript Functions dialog box 

enables you to add, edit, or delete document level scripts. All the document level 

scripts are stored within the PDF document. 

In JavaScript Functions dialog box, you will see the following buttons: 

 Close – Closes the dialog box. 

 Add – After typing a new Script Name, a JavaScript Editor dialog box pops up. You 

can create and edit document level scripts here. To change the font of JavaScripts, 

click the Font button. 

 Edit – The JavaScript Editor dialog box pops up, enabling you to modify the 

JavaScripts you create. 

 Delete – Delete the JavaScript you selected. 

Document Action 

You can create the document-level JavaScript actions that apply to the entire 

document. For example, selecting Document Did Save runs the JavaScript after a 

document is saved. 

JavaScript Console 

JavaScript Console is a control panel for the execution and debugging of JavaScript 

code. Serving as a debugging aid, it is quite useful for displaying debug messages and 

executing JavaScript. To active the JavaScript console, select Form> JavaScript > 

JavaScript Console, and do the following: 

1. In the pop-up JavaScript Console dialog box, type your JavaScript code. 

2. Click Run button to run your JavaScript code. You will be prompted that the 

code has run successfully.  

3. You can click Clear to remove all the contents you input from the dialog box, 

or click Close to discard the contents and exit the dialog box. 
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JavaScript Editor 

You can use the built-in JavaScript editor in Foxit PDF Editor Cloud to create and edit 

all the JavaScripts in a PDF file. To open the JavaScript editor, choose Form > 

JavaScript > Edit All JavaScripts. In the JavaScript Editor dialog box, click Go to to 

jump to a specific line of code. After editing the JavaScripts, click OK to save it.  



   Foxit PDF Editor Cloud 

Chapter 10: Security                                                User Manual 

200 

 

Chapter 10 – Security 

The security feature of PDF gives you an exceptional control over your PDF files. To 

provide adequate protection for PDF’s contents, you can encrypt and secure PDF files 

to prevent unauthorized access, restrict sensitive operations, etc.  

Check PDF security 

Some PDF files may contain restrictions preventing actions such as printing, editing, 

copying, etc. To check if you have these permissions, please do the following: 

• Choose File > Properties > Security, or Protect > Secure Document > 

Security Properties.  

Password Protection & Certificate Protection 

In Foxit PDF Editor Cloud, you can add password protection, certificate protection, and 

security restrictions to a PDF or PDF portfolio, limiting who can open the file, can copy, 

edit or print the file, etc. However, the protection in a secured PDF portfolio does not 

apply to the PDF files in it, so for the component PDFs in a PDF portfolio, if you need 

to add or remove protection, open the component PDFs and then add/remove 

protection. 

Password Protection 

You can add a password to a PDF to limit access and restrict certain features, such as 

printing, copying and editing. 

There are two kinds of passwords that could be applied to a PDF file: a Document 

Open password and a Permissions password. When you set a Document Open 

password, anyone who tries to open the PDF must type in the password that you 

specified. When you set a Permissions password, anyone who wants to change the 

restrictions must type the Permissions password. Please note that if a PDF is secured 

with both types of passwords, it can be opened with either password, but only the 

Permissions password allows you to change the restrictions. 

Tips:  

1. There’s no way out to recover password from the PDF if you forgot it. To keep a 

backup copy of the PDF that isn’t password-protected is a good choice. 
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2. Foxit PDF Editor Cloud allows you to input Unicode password in the password input 

box when you open a document protected by Unicode password.  

Add a password security 

1. Choose Protect > Secure Document > Password Protect, or click File > 

Properties > Security, choose Password Protection from the drop-down list.  

2. In the Password Protection dialog box, do the following: 

Document Open Settings:  

Require a password to open the document – selects to require users to type the 

password you specify to open the document. 

Password Input: specifies a password that users must type to open the document. 

Password Confirm: type the password again to confirm the password. 

Document Restriction Settings: 

Add Document Restriction – restricts actions to PDFs, such as printing, editing, etc. 

Password Input: specifies a password that is required to change the permissions 

settings. If the file is opened in Foxit PDF Editor Cloud, the user can view the file but 

must enter the permissions password to change the file’s security and permissions 

settings. 

Password Confirm: type the password again to confirm the password. 

Permission Specification: 

The security details you specified are shown on the left. Click Permission to set the 

restriction settings. In the Permission Settings dialog box, check Restrict printing 

and editing of the document and its security settings and then select the options 

as needed.  

Print Allowed – specifies the level of printing which users are allowed for the PDF. 

A. Print with low resolution – allows users to print at no higher than 150-dpi 

resolution. 

B. Print with high resolution – allows users to print with any resolution. 

Changes Allowed – defines which editing actions are allowed in the document. 
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A. Inserting, deleting, and rotating pages – allows users to insert, delete, and 

rotate PDF pages. 

B. Filling in forms and signing existing signature fields – allows users to fill 

in forms and sign documents in existing signatures fields. 

C. Commenting, filling in forms and signing existing signature fields – 

allows users to add comments, fill in forms and sign documents in existing 

signatures fields. 

D. Any except extracting pages – allows users to do any operation but extract 

pages. If you choose this option when encrypting a PDF portfolio, users are 

allowed to add, create, and remove files in the PDF portfolio.  

Enable copying of text, images, and other content – allows users to copy 

content in PDFs.  

Enable text access for screen reader devices for the visually impaired – 

allows the visually impaired users to access text with screen reader devices. 

Encrypt Settings: 

Encryption Algorithm- defines data transformations that cannot be easily reversed 

by unauthorized users. Foxit PDF Editor Cloud supports 128-bit AES, 256-bit AES and 

128-bit ARC-FOUR. 

Don’t encrypt metadata – encrypts the contents of a PDF but still allow search 

engines access to the document metadata. 

Save the setting as a new policy – save the current security settings as a policy so 

that you can apply it to other documents. 

3. Click Ok and save the document to make setting take effect. 

Modify password and security settings 

1. Choose Protect > Secure Document > Security Properties, or choose File > 

Properties. 

2. In the Security tab for the document properties, choose Document Security > 

Password Protection, and then click Change Settings… 

3. Do the settings as “Add a password security” and then click OK. 
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Remove password and security settings 

To remove password and security settings from a PDF, you must have the permissions 

to do so. 

1. Open a PDF, and choose either way of the following to remove password and 

security settings. 

 Choose Protect > Secure Document > Remove Security.  

 Choose Protect > Secure Document > Security Properties, or choose File > 

Properties. In the Security tab for the document properties, choose No 

Protection from Security Method menu. 

2. A Foxit Security message box will prompt to ask whether you are sure to remove 

security from this document.  

Certification Protection 

The advantage of securing documents with certificates is that authors can specify 

unique permissions for each person. For example, authors can permit a person to fill 

in forms and comment in document, and permit another person to edit text or delete 

pages. You can choose certificates from files on disk, or from the Windows certificate 

store. Only a specific set of users whose identities can be verified and managed can 

have access to the document. A certificate that contains public key and other 

identifying information is used to encrypt documents, or verified a digital signature. 

Only corresponding private key decrypts the document that was encrypting using the 

certificate. 

Generally, if possible, encrypt documents using certificates from third-party provider. 

If the certificate is lost or stolen, the issuing authority can replace it, if a self-signed 

certificate is deleted, all PDFs encrypted using the certificate is forever inaccessible. 

Add a certificate security 

1. Choose Protect > Secure Document > Certificate Protect. 

2. In Certificate Protection dialog box, create intended recipient list for the encrypt 

document： 

 Click New ID to create and store your self-signed digital ID in: 

New PKCS#12 digital ID file – Stores the digital ID information to a file with 
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the extension .pfx on Windows and .p12 on Mac OS. You can use the files 

interchangeably across different operating systems.  

Windows Certificate Store – Stores the digital ID to a common location. Other 

Windows applications can also retrieve it. 

 Click Import to import a certificate from Windows Certificate store. 

 Click Browse to import a certificate from disk. 

 Click Remove to delete a recipient from recipient list. 

 Click Permission to set document restriction for the selected recipient. About 

Permission options, please refer to “Add document restrictions” of Password 

security options. 

3. Select Encryption Algorithm (support 128-bit AES, 256-bit AES and128 bit ARC-

FOUR. 

4. Check Don’t Encrypt metadata to encrypt the documents except metadata. 

5. (Optional) Check Save the settings as a new policy to save the current security 

settings as a policy so that you can apply it to other documents. 

6. Click OK and save the document. 

See also “About digital ID” 

Change or remove certificate protection 

To change or remove security settings, you must have permission to do so. If you want 

to change or remove security encrypted with certificate, you must have all access to 

the document, or you can’t do changes or remove security settings. 

To change certificate protection, please do the following: 

1. Choose Protect > Secure Document > Security Properties, or choose File > 

Properties. 

2. In the Security tab for the document properties, choose Document Security > 

Certificate Protection, and then click Change Settings… 

3. In Certificate Protection dialog box, refer to Add a certificate security. 

4. Click OK and save the document to apply your changes. 

To remove certificate protection, please do one of the following: 

1. Choose Protect > Secure Document > Remove Security. 

2. Choose Protect > Secure Document >Security Properties or choose File > 

Properties, in the Security tab for the document properties, choose No 



   Foxit PDF Editor Cloud 

Chapter 10: Security                                                User Manual 

205 

 

Protection from Security Method menu. 

Set Security Policies 

If you often apply the same security settings to multiple PDFs, you can save your 

settings as a policy that you can apply to other PDFs. Security policies include the 

security method, encryption password, permission settings, etc. 

Create a security policy 

1. Choose Protect > Secure Document > Security Policies. 

2. Click New. 

3. Choose security method from menu and specify the policy name and description. 

4. Click Edit Details to set restriction settings or passwords. 

5. Review the policy details, and then click Close. 

Secure PDFs using policies 

You can apply any security policy to a PDF file. To secure a PDF with a security policy 

that you specified, do the following: 

1. Open a PDF document. 

2. Choose Protect > Secure Document >Security Policies. 

3. In the Manage Security Policies dialog box, select a policy which you want to apply 

to the PDF file. 

4. Click Apply to this Document. 

5. Save the document to apply the security policy. 

Manage security policies 

After you create security policies, you can manage them by copying, editing, and 

deleting.  

1. Choose Protect > Secure Document > Security Policies. 

2. In the Manage Security Policies dialog box, select a policy from left panel and do 

one or more of the following: 

 Click New to create a new policy. 

 Click Copy to copy a policy. This option is useful when you create a new policy 

that’s based on the settings of the selected policy. 

 Click Edit Details to edit a policy. 

 Click Delete to delete a policy. 

 Click Close. 
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Remove hidden data 

Foxit PDF Editor Cloud supports the removal of hidden information that is private or 

sensitive for users from their PDFs, generally including metadata, embedded content, 

attached files, and scripts.  

There are two commands you can use to remove hidden information: Sanitize 

Document and Remove Hidden Information. To remove all hidden information 

from a PDF file in one go, choose Protect > Hidden Data > Sanitize Document.  

To select and remove the hidden information you want to remove, do the following: 

1. Choose Protect > Hidden Data > Remove Hidden Information.  

2. In the pop-up dialog box, select the document information you want to remove, 

and click OK.   

• Metadata – the data in the document information dictionary and all metadata 

streams, such as the information in the File > Properties > Description. 

• File Attachments – all file attachments in the document, including the ones 

that are added with the File Attachment command in the Edit tab and the 

File command in the Comment tab.  

• Bookmarks – all bookmarks in the document. 

• Embedded search index – the search indexes embedded in the document. 

• Comments and markups – all comments added to the document, including 

files attached as comments.  

• Form fields – all form fields in the document. After the removal, all form fields 

are flattened and can no longer be filled or modified. 

• Hidden text – the text that is transparent, covered up by other content, or has 

the same color as the background in the document. 

• Hidden layers – all layers (including both shown and hidden layers) in the 

document. 

• Deleted or cropped content – the invisible content that has been removed or 

cropped, such as deleted or cropped pages.  

• Links, actions and Javascripts – the links created using the Link command, 

the actions included in the properties of content like form fields and 

bookmarks, and all JavaScripts in the document. 

• Overlapping Objects – If a page includes objects (not including text objects) 

that overlap one another, the whole page will be changed to an image object 

after the removal. 

Note: When you remove hidden information with the Sanitize Document command, the 

multimedia files added using the Audio & Video command will also be removed. 
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Redaction  

The redaction feature allows you to remove sensitive information from your 

document prior to making it available to others. You are able to mark the text, graphics, 

text and graphics, or pages for Redaction first, and then apply the redaction. 

Alternatively, you can use the Whiteout feature to remove the content permanently 

and replace it with white background with one click. 

Mark for Redaction 

To mark text or graphics for redaction, select Protect > Mark for Redaction > Mark 

Text & Images or Mark Area. If you need to add redaction to the same position on 

multiple pages, please right-click the marked content and choose Place on Multiple 

Pages…. 

To mark pages for redaction, select Protect > Mark for Redaction > Mark Page, and 

choose the page range you want to add redaction to.  

The marked content or page will be filled with black color in a red rectangle once 

moving close the pointer to the selected area. You can move and resize the rectangle 

before you apply the redaction. (Note: You can’t move or resize the rectangle around the 

text selected with the pointer .) 

Set Redaction Properties  

You can set redaction properties, such as the appearance and the author, and so forth. 

Only before you apply the redaction can you set the properties. 

Right-click the marked area and choose Properties… and the Redaction Properties 

dialog box pops up. The redaction properties have Appearance tab, General tab and 

Review History tab. There are two additional settings on every tab: 

➢ Locked – When selected, prevents any further changes to any redaction 

properties. 

➢ Set Current Properties as Default – sets the current properties as default. 

Appearance tab: 

Redacted Area Fill Color – select a fill color for the boxes that will replace the redacted 

items. 
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Use Overlay Text – check this item if you need to display some text or code on the 

redacted area. You can set the font, font size, font color and text alignment. 

Custom Text – check this option and input the text you want to display in the redacted 

area. 

Redaction Code – check this option to select code entries from corresponding code 

sets.  

Add Selected Entry – After selecting a code entry, click this option to add the code entry 

to the box next to the Redaction Code option. When you select a code entry that has 

been added to the box, the option changes to Remove Selected Entry to allow you to 

remove the added code entry from the box. (Tip: You can also add/remove code entries 

by selecting or unselecting items from the context menu of the marked area.) The names 

of the code entries you added will appear in the marked area when you put your 

cursor on the area. 

Edit Codes – click it if you need to add, rename, remove, or import/export redaction 

codes and code sets.  

General tab: 

You can change the author and subject of the redaction. 

Review History tab: 

You can see the history of changes which have been made to the status of a redaction 

before applying the redaction. 

Apply Redactions 

You need to apply redactions after marking the text, graphics, or pages you want to 

redact. To apply redactions, do the following:  

1. Select Protect > Apply to redact all of the marked content in the document. You 

can also do this by right-clicking the marked content and choosing Apply or Apply 

All to redact either the selected content or all of the marked content in the 

document. 

2. A dialog box pops up to give a warning message and asks if you are sure to apply 

redactions or not. Select OK to apply redactions. 

When you save the document after applying redactions, you can save the redacted file 

automatically as a new file with the preconfigured filename. To configure the filename, 

please select Adjust filename when saving applied redaction marks and input text 
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in the Prefix and Suffix boxes in File > Preferences > Documents > Redaction.  

Search and Remove Text 

You can find and remove content either in a single PDF file or in multiple PDF files 

under a specified folder that contain searchable text with the Search & Redact 

command. 

1. Select Protect > Search & Redact. (Or click the Search features icon in the 

upper right corner of the Foxit PDF Editor Cloud window and choose Search & 

Redact.) Then specify what you want to redact in the Search panel. (For more 

about the search feature, please refer to “advanced search”.) Please do one of the 

following: 

 To search and redact an exact word or phrase, select Match exact word or 

phrase. Then type the text you wish to find and redact into the search 

dialogue box.  

 You can search and redact multiple words or phrases at the same time. Select 

Multiple words or phrase, and click Select Words…. In the pop-up dialog 

box, enter the word or phrase you want to search and redact, and click Add. 

Repeat until you add all the words/phrases you want to search for. Or you can 

click Import to import a text file with the list of words or phrases to search 

for. For the words you have added, click Export to export them to a text file. 

 To search and redact a predefined redaction profile, select Redaction 

Profiles and then select an existing redaction profile you want to use. See also 

Create and manage redaction profiles.   

 To search and redact patterns (such as phone numbers and credit card 

numbers), select Looks like search pattern. Then select the pattern you 

want to search from the Select your pattern drop-down list, and choose the 

specific country or region from the Country/Region drop-down list. 

2. Click Search. 

3. Check the results you want to redact, and choose Mark whole word(s) for 

redaction to mark all characters of the word(s) you search, or choose Mark 

partial word(s) for redaction to mark the specified characters of the word(s).  

If you choose Mark partial word(s) for redaction, the Settings dialog box pops 

up and allows you to specify the characters you want to mark. To change your 

character settings, click the Settings button in the Search panel. 

4. Click the button Mark Checked Results for Redaction at the bottom of the 

search dialogue box. 

5. Click the Apply Redactions button. Or Choose Protect > Apply. 

Note: This operation cannot be undone and the selected content will be removed 
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permanently after you apply redactions. It is recommended that you save a backup copy of 

this document before you apply the redaction. 

Create and manage redaction profiles  

A redaction profile specifies the text to be redacted, the new text that you want to 

overlay the redacted text with, and the search criteria. When you need to search and 

redact content in documents that require the same protection, using a redaction 

profile can improve the productivity in your document workflow. 

To create a redaction profile, do as the following: 

1. Select Protect > Search & Redact, and the Search panel opens. (Or click the 

Search features icon in the upper right corner of the Foxit PDF Editor Cloud 

window and choose Search & Redact.)  

2. From the search criteria drop-down list, choose Redaction Profiles.   

3. Click Create. 

4. In the pop-up dialog box, input a name for the profile to be created.  

5. In the New word or phrase box, type the text you want to redact. In the Overlay 

text box, type the text that will be displayed on the redacted text. Then click Add. 

Repeat as needed. The redacted text and the Overlay text you add will be listed as 

groups in the Word/Phrase and overlay text list box. To remove a group, select 

it and click Remove. 

6. (Optional) Select any of the following options to specify the search criteria as 

needed. 

a) To limit the search to match only whole words, check Whole Words Only. For 

example, if you search for the word Read, the word Reader will not be found. 

This criterion is only available for text search.  

b) To make the search case-sensitive, check Case-Sensitive. For example, if you 

search for the word text, the words Text and TEXT will not be found. This 

criterion is only available for text search.  

c) To highlight all the text search results, please check Highlight All Text.  

d) To make the size of the Overlay text fit the redacted area, select Always Auto-

Size text to fit redaction region. For example, if the Overlay text is too long, 

the part that exceeds the redacted area will not be displayed. With this option 

selected, the text size will automatically shrink and all of the Overlay text will 

be displayed on the redacted area. 

7. Click Save & Search to save the profile and search the document immediately, 

after which you can select the found instances and apply redaction. Or just click 

Save to save the profile. 
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To manage existing redaction profiles, do as the following:  

1. Select Protect > Search & Redact, and the Search panel opens. (Or click the 

Search features icon in the upper right corner of the Foxit PDF Editor Cloud 

window and choose Search & Redact.) 

2. From the search criteria drop-down list, choose Redaction Profiles.   

3. Click Manage. 

4. In the pop-up dialog box, select a profile and do any of the following: 

• Choose Edit to modify the selected profile. For details, please refer to Create a 

redaction profile.  

• Choose Delete to remove the selected profile. 

• Choose Import to import a redaction profile. 

• Choose Export to export the selected profile.  

Trust settings  

You can customize trust settings for Foxit PDF Editor Cloud, which is helpful to make 

your PDF workflow both secure and efficient. To specify the settings, click File > 

Preferences > Trust Manager. 

Safe Reading Mode  

Safe Reading Mode enables you to control unauthorized actions and data 

transmissions that efficiently avoid attacks from malicious content and viruses.  

Activate Safe Reading Mode 

To activate Safe Reading Mode, do the followings: 

 Select File > Preferences > Trust Manager, and check Enable Safe Reading 

Mode option. 

 Click OK. 

On-line whitelist management 

Foxit PDF Editor Cloud allows users to add trusted URLs to better manage file access. 

To set on-line whitelist, please follow the steps below: 

Choose File > Preferences > Trust Manager > click Change Settings in the Internet 
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Access from PDF Files outside the web browser group, then Manage Sites dialog 

box will pop up as shown below: 

 Allow PDF files to access all web sites: Select it to allow access to all web sites. 

 Block PDF file access to all web sites: Select it to restrict access to all web sites. 

 Custom setting: You can customize the trusted URLs to restrict access to only the 

URLs you customize. 

➢ Select Custom setting. 

➢ Input the host name of a website under the Host name field. 

➢ Click Allow and then click OK. 

The URLs that you trusted will be added in the Web Sites List. If you want to delete the 

trusted URL, please select it and click Delete. For the URLs not included in the Web 

Sites List, you can check one of the following options to set the default behavior when 

connecting to the web sites. 

 Always ask: When you try to access websites not listed as trusted, Foxit PDF Editor 

Cloud will always prompt you with a pop-up window saying: “If you trust this site, 

click Yes; otherwise, click No”. This is selected by default.  

 Allow access: Access to all websites will be available if it is selected. 

 Block access: Access to all websites will be blocked if it is selected. 

Run Script Right Control 

Foxit PDF Editor Cloud allows users the rights to run script accordingly, and at the 

same time making sure the software executes and secures PDF files. To set the run 

script rights, please follow the steps below: 

Choose File > Preferences > JavaScript or Trust Manager, and then set the rights as 

required: 

 To enable all JavaScript: Check Enable JavaScript Actions and uncheck Enable 

Safe Reading Mode. 

 To disable all JavaScript: Uncheck Enable JavaScript Actions and check Enable 

Safe Reading Mode. 

 To enable secured JavaScript: Check Enable JavaScript Actions and Enable Safe 

Reading Mode. 
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Chapter 11 – Signature 

Foxit PDF Editor Cloud provides robust, secure and quick signature features, including 

legally-binding eSignatures, ink signatures, and digital signature.  

Foxit eSign  

Foxit PDF Editor Cloud integrates with Foxit eSign, a legally-binding electronic 

signature service. With a licensed account, you can perform an eSign workflow not 

only on the Foxit eSign website using a web browser but also within Foxit PDF Editor 

Cloud directly, which allows you to edit your documents and collect signatures with 

complete ease. 

With Foxit eSign in Foxit PDF Editor Cloud, after logging in with a licensed account, you 

can create your own signatures and electronically sign documents by placing the 

signatures on PDF pages, which is as easy as signing a paper document with a pen. 

You can also quickly initiate an eSign process to collect signatures from multiple 

people.  

When you electronically sign a PDF within Foxit PDF Editor Cloud, the appearance of 

an applied signature/initials may include information like Signer ID and the date/time 

when you signed, depending on the settings for your Foxit eSign account. In your Foxit 

eSign account, you can use a set number of envelopes based on your license plan, and 

one envelope will be used when you electronically sign a PDF within Foxit PDF Editor 

Cloud. For more information about envelopes and Foxit eSign, you can refer to Foxit 

eSign Knowledge Base.  

Create your own signatures and sign a PDF 

1. Open the document you want to sign.  

2. (Optional) Use the tools in the Foxit eSign tab to add text or symbols to fill your 

PDF as needed.  

3. Click the  sign on the signature palette (or click  on the lower right corner 

of the signature palette and choose Create Signature) in the Foxit eSign tab to 

create a signature (Full Name) and the corresponding initials. Or you can click 

Manage Signatures in the Foxit eSign tab and click Add in the pop-up Manage 

Signatures dialog box to create signatures. (Note: The  sign is displayed when 

there aren’t any signatures created yet or when there aren’t any initials created for the 

https://kb.foxitsoftware.com/hc/en-us/categories/360006273632
https://kb.foxitsoftware.com/hc/en-us/categories/360006273632
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corresponding signature.)  

4. In the Create Signatures dialog box:  

• Draw a signature, import a file, copy a snapshot from the clipboard, or 

type text content to create signatures. When you type text to create a 

signature, you can click Change Style to change the text style for your 

signature. (Tip: You can sign your signature on a clean white sheet of paper 

using a black pen, and scan it to an image file. To create the best signature, it 

is suggested to scan your signature in monochrome at 600 DPI.) 

• Click Online > Download Signature/Download Initials to open the 

Online Signature dialog box, which shows the signatures you have 

previously saved online. Then select and download the desired signatures 

as the signature/initials. You can also delete signatures in the dialog box 

by clicking Delete.    

5. Click the Options button to select the options as needed: 

• Convert signature to black & white: the signature will be created in black 

and white even if the original image is chromatic.  

• Keep original size: selects the option and the signature will be created 

with the original size. If the signature width/height is greater than the page 

size, Foxit PDF Editor Cloud will zoom it out to a signature with a width of 

100 pixels while maintaining the original proportion. The option is only 

available when the signature is from an imported file or Clipboard. With 

the option unselected, the signature will be resized and created with a 

width of 100 pixels while maintaining the original proportion by default.   

• Discard the signature when program closes: the signature will be 

discarded the next time you launch Foxit PDF Editor Cloud. 

• Require password to use this signature: Specify a password that will be 

required when users sign the document with the signature. Enter the 

password again to confirm it. 

6. Click OK.  

7. Select your created signature on the signature palette, and then the cursor will be 

changed into a shape with the appearance preview of the signature.  

8. Place the cursor to the position you want to sign and click. Or drag a rectangle to 

define the size and placement. The signature stays selected until you choose 

another tool. You can place multiple signatures on pages continuously without 

the need to reselect the same signature.  

9. Click the signature with the Hand command, and it will be highlighted with a red 

rectangle. After adding the signature, do any of the following, if necessary. 

 To resize the signature, drag the small blue square on the lower right corner 

of the rectangle. After resizing the signature, you can right-click the signature 

and choose Set Current Size as Default to set the size as default so that Foxit 

PDF Editor Cloud will remember and apply the same size when you add the 

same signature in the future. 
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 To move the signature, drag the rectangle directly to the desired place.  

 Before applying the signature, you can right-click the signature and choose 

relevant options from the context menu to copy, cut, paste, or delete the 

signature.  

10. (Optional) Right-click the signature you added, and select Place on Multiple 

Pages from the context menu to place the signature to multiple pages. 

11. Click Apply All Signatures on the ribbon to apply all signatures in the document.  

Notes:  

1. When you have placed signatures/initials that are from the same group of 

signatures on pages, you need to apply those signatures/initials first if you want to 

place signatures from another group.  

2. Once applied, the signatures/initials can no longer be edited or deleted.  

Manage signatures 

1. Click Manage Signatures in the Foxit eSign tab. 

2. In the Manage Signatures dialog box, do any of the following:  

• Click Add to create signatures and initials. 

• Click the Edit or Delete  icon to edit or delete existing signatures. 

• Click the Upload  icon to upload the signature to Foxit eSign server. 

Please note that Foxit eSign server only saves one group of signatures (full 

name and initials). If you upload multiple groups of signatures, the latest 

group will be kept on Foxit eSign server. 

Note: If you upload a group of signatures to Foxit eSign server through the Manage 

Signatures dialog box, the signature/initials saved in your profile in the Foxit eSign 

website will automatically be changed to the default signatures you set. However, if 

you make changes to the signature/initials in your profile on the Foxit eSign webpage, 

the changes will not be synchronized automatically to Foxit eSign in Foxit PDF Editor 

Cloud, and you can download the modified signature/initials through the Online 

Signature dialog box if needed.  

Initiate an eSign process in Foxit PDF Editor Cloud 

To send your documents for eSignatures within Foxit PDF Editor Cloud, do the 

following to initiate an eSign process: 
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1. Open the document you want to send for eSignatures. 

2. After logging in to your Foxit eSign account, click Request Signature in the Foxit 

eSign tab. 

3. A file tab named “Request Signature” is opened in the application window. The 

current document has been uploaded to the Foxit eSign server and listed in the 

“Request Signature” file tab. Together with the document, you can add more 

documents to send for eSignatures. 

4. Add signers. 

5. Add the fields to the documents for signers to fill in, and assign the properties to 

the fields as required. 

6. Enter the email subject and messages and then send the envelope to the 

recipients. 

7. (Optional) You can view all envelopes you have sent in the “Document Signature” 

file tab, which appears when you click Document Status in the Foxit eSign tab. 

The process to request eSignatures in Foxit PDF Editor Cloud is the same as in the 

Foxit eSign website, and you can refer to Foxit eSign Knowledge Base for detailed 

instructions. 

In the Foxit eSign tab, you can perform additional tasks using the Send in Bulk, 

Create Online Form, and Add E-Sign Branding commands. Clicking on any of these 

commands will take you to the Foxit eSign website to perform the corresponding 

actions. For more information on the commands, please refer to Foxit eSign 

Knowledge Base. 

• Send in Bulk: Send a single document or envelope to a large number of 

recipients with just a few clicks. 

• Create Online Form: Create a web form that can be used to collect mass 

signatures through a link. 

• Add E-Sign Branding: Customize your company’s logo and theme color. This 

branding will appear on all outgoing emails, Signature Certificates, the Online 

Form Success Page, and throughout the User Interface in the top left of every 

page. 

Manage eSign agreements 

You can manage your eSign agreements efficiently and effortlessly with the homepage 

of Foxit PDF Editor Cloud. To do this, navigate to the Documents page, and select the 

eSign agreements tab for a comprehensive overview of all your associated eSign 

agreements. The eSign agreements tab includes sub-tabs containing different 

categories of agreements, such as those waiting for your or others' signatures, saved 

drafts, and completed agreements.  

https://kb.foxitsoftware.com/hc/en-us/categories/360006273632
https://kb.foxitsoftware.com/hc/en-us/categories/360006273632
https://kb.foxitsoftware.com/hc/en-us/categories/360006273632
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You can utilize the filters (such as DRAFT, SHARED, and CANCELLED), Envelope Name, 

or Recipient Name to search for specific agreements in the All agreements sub-tab. 

Clicking on the Request Signatures button in the All agreements sub-tab redirects 

you to the Foxit eSign website in a new tab to initiate an eSign process. 

Quick PDF Sign 

Quick PDF Sign enables you to create your self-signed signatures (ink signatures) and 

add the signature to the page directly. You don’t need to create different signatures 

for different roles. 

To create your own handwritten signature and sign a PDF, follow these steps. 

1. Choose Home/Protect > Fill & Sign. And the Fill & Sign context tab appears on 

the ribbon.  

2. (Optional) Use the tools in the Fill & Sign context tab to add text or symbols to fill 

your PDF as needed. 

3. Click  in the signature palette on the ribbon or click  on the lower right 

corner of the signature palette and choose Create Signature from the drop-down 

menu. Or you can click Manage Signatures in the Fill & Sign context tab and click 

Add in the pop-up Manage Signatures dialog box to create signatures. 

4. In the Create Signature dialog box, you can draw a signature, import a file, copy 

from the clipboard, or type text content to create a signature. Or, click Online to 

choose a signature from the online signatures you saved before. When you type 

text to create a signature, you can click Change Style to change the text style for 

your signature. 

TIP: You can sign your signature on a clean white sheet of paper using a black pen, and 

scan it to an image file. To create the best signature, it is suggested to scan your signature 

in monochrome at 600 DPI. 

5. Click Options to specify how to create and use the signature.  

• Convert signature to black & white: the signature will be created in black 

and white even if the original image is chromatic.  

• Keep original size: selects the option and the signature will be created 

with the original size. If the signature width/height is greater than the page 

size, Foxit PDF Editor Cloud will zoom it out to a signature with a width of 

100 pixels while maintaining the original proportion. The option is only 

available when the signature is from an imported file or Clipboard. With 

the option unselected, the signature will be resized and created with a 

width of 100 pixels while maintaining the original proportion by default.   
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• Discard the signature when program closes: the signature will be 

discarded the next time you launch Foxit PDF Editor Cloud. 

• Require password to use this signature: Specify a password that will be 

required when users sign the document with the signature. Enter the 

password again to confirm it. 

6. Click OK.  

7. Select your created signature on the signature palette, and then the cursor will be 

changed into a shape with the appearance preview of the signature.  

8. Place the cursor to the position you want to sign and click. Or drag a rectangle to 

define the size and placement. The signature stays selected until you choose 

another tool. You can place multiple signatures on pages continuously without the 

need to reselect the same signature. 

9. Click the signature with the Hand command, and it will be highlighted with a red 

rectangle. After adding the signature, do any of the following, if necessary. 

 To resize the signature, drag the small blue square on the lower right corner 

of the rectangle. After resizing the signature, you can right-click the signature 

and choose Set Current Size as Default to set the size as default so that Foxit 

PDF Editor Cloud will remember and apply the same size when you add the 

same signature in the future. 

 To move the signature, drag the rectangle directly to the desired place.  

 Before applying the signature, you can right-click the signature and choose 

relevant options from the context menu to copy, cut, paste, or delete the 

signature.  

10. Right-click the signature you added, and select Place on Multiple Pages from the 

context menu to place the signature to multiple pages. 

11. You can do one of the following to apply signatures to the document as required: 

• To apply the current signature to the document, right-click the signature, and 

select Apply Signature from the context menu.  

• To apply all signatures in the document, click Apply All Signatures on the 

ribbon. 

If you want to flatten the document while applying the signatures, select the 

Flatten the document when applying all signatures option first in File > 

Preferences > PDF Sign (or click  on the lower right corner of the signature 

palette and choose Preferences from the drop-down menu to select the option). 

For details about flattening, please refer to Flatten Pages. 

12. Upon completion, click Close to close the Fill & Sign context tab.   

Note: Once applied, the signature can no longer be edited or deleted. 

To manage the created signatures, do the following: 

1. Click Manage Signatures in the Fill & Sign context tab. 

2. In the Manage Signatures dialog box, do any of the following:  
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• Click Add to create signatures. 

• When hovering the cursor over an existing signature, three icons appear. Click 

the Edit  or Delete  icon to edit or delete the signature. Click the 

Save Online  icon to save the signature to Foxit Web Service. The 

signatures saved in Foxit Web Service can be downloaded to sign PDF files 

from within Foxit PDF Editor Cloud and Foxit PDF Reader/Editor in Windows 

and Mac.  

3. Upon completion, click Close to close the Fill & Sign context tab.   

Digital Signature 

A digital signature acts as a traditional handwritten signature that can be used to 

authenticate the identity of a user as well as the document content. It stores 

information about the signer along with the date, time, and state of the document 

when it was signed.  

About Digital ID 

Digital ID is the identity of a person/organization, which contains your name, Email 

address, a serial number, an expiration date, and the name of the company. A digital 

ID contains two keys, one is a public key (certificate) that is used to encrypt or lock 

data, and the other is a private key that is used to decrypt or unlock data that is 

encrypted. 

You can distribute the certificate that contains the public key and other identifying 

information to those people who need to use it to verify your identity, validate your 

signature, or encrypt a document for you. Only your private key can unlock 

information that was encrypted using your certificate, so make sure to store your 

digital ID in a safe place. 

You can not only obtain a digital ID from a trusted third-party provider called a 

Certificate Authority (CA) but also create a self-signed digital ID with Foxit PDF Editor 

Cloud. Digital IDs are usually protected by password; you can store it on a computer 

in PKCS#12 file format, or in the Windows Certificate Store. All the digital IDs available 

on the computer are listed in the Digital IDs window. You can choose Protect > Digital 

IDs to check the digital IDs list. In the Digital IDs window, you can also view the 

certificate details, refresh the ID list, add or remove a digital ID, and export a digital ID 

to an FDF, PKCS, or CER file. 
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Sign a PDF 

Place a signature 

Before you sign a document, you need to draw a signature field where the signature 

is placed, get a digital ID, and create the signature. 

1. Choose Protect > Sign & Certify > Place Signature. 

2. Press and hold the mouse button down, and drag to draw a signature field for 

your signature. 

3. In Sign Document dialog box, choose a digital ID from drop-down menu. If you 

do not have any digital ID or can’t find the specified digital ID, you will need to get 

a certificate from the third-party provider or create a self-signed digital ID. 

4. (Optional)To create a self-designed digital ID, choose New ID from drop-down 

menu. In the Add Digital ID dialog box, select a location to store the digital ID. 

Click Next to type your identity information such as name, organization unit, e-

mail address, etc. to be used when generating the self-signed certificate. In Use 

Digital ID for, choose one option as needed. Click Next to enter a file name, 

storage location and password for your new digital ID file. Confirm your password 

and click Finish.  

5. For Appearance Type, choose a style from the drop-down list, or click the Create 

button to create a new style for your signature appearance. The created styles will 

be added to the drop-down list for Appearance Type. Please refer to Creating 

signature appearance. You can preview your signature in the Signature Preview 

box. 

6. Under Text For Signing, input text in the field and select an option from the drop-

down list to specify your location and reason to sign the document. Please note 

that Location and Reason fields are available only when the signature is defined 

to include the corresponding option in its appearance type. For the Reason field, 

Foxit PDF Editor Cloud will save your custom reasons for you to choose from the 

drop-down list easily in future uses. 

7. Do any of the following to sign PDF files: 

➢ To sign the currently opened PDF file, click Sign, and then specify the location 

and file name to save the signed document.  

➢ To sign multiple PDF files, click Apply to Multiple Files. In the pop-up Sign 

Multiple Documents dialog box, do the following:  

 Click Add files, and choose Local Computer or Add Open Files to add 

files or opened files that you want to sign with the same digital signature.  

 By default, the document will be signed in a sequence as they are ordered 
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in the Sign Multiple Documents dialog box. You can adjust the order of 

files by its name, modified time, or size by clicking the corresponding 

column name. Alternatively, drag and drop the file in the list to adjust its 

order. Select a file and click the Remove button to delete it, if necessary.  

 Click Output Options to specify the file name for the signed PDF 

document.  

 Click Sign Immediately. And then Foxit PDF Editor Cloud will sign your 

PDF documents with the same digital signature at the same location as 

your current document, and saved the signed documents in the folder 

you specified.  

Note: By default, the document is signed after you place the signature and then you will 

not be able to move or resize it. To change the setting, please uncheck the Sign the 

document immediately after the signature is placed option in File > Preferences > 

Signature.  

Move, resize and delete an unsigned signature 

You can move, resize and delete signatures before signing the document, but you 

aren’t allowed to change certificate and appearance of certificate. 

1. To move a signature 

Select the Select Annotation command or the corresponding tool, put the pointer over 

the signature, click and drag the signature to another place you like. 

2. To resize a signature 

Select the Select Annotation command or the corresponding Tool, click the signature. 

Place the cursor on any corner point. Pointer changes into the cursor showing the 

direction at which the rectangle will be resized. 

3. To delete a signature 

 Select the Select Annotation command.  

 Right-click the signature and choose Delete from context menu, or press Delete 

key. 

Note: If you have checked the Locked option in Signature Properties dialog box, the 

operations to the signature above are not available. 
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Create signature appearance 

You can set the appearance of your digital signature by selecting different options in 

Configure Signature Style dialog box. For example, a signature can include an image 

of your handwritten signature, a company logo, or a photo, date, reasons for signing, 

and so on.  

 Choose Protect > Sign & Certify > Place Signature. 

 Press and hold the mouse button down, and drag to draw a signature field for 

your signature. 

 In Sign Document dialog box, click the Create button to create a new style for 

your signature appearance.  

 In the pop-up Configure Signature Style dialog box, you can configure the 

graphic for your signature by drawing, setting a name, or importing a file. Check 

the options that you want to show in the digital signature. A signature appearance 

can include lots of information showing the users attributes, including Name, 

Logo, Location, etc. Then input a title of the new appearance type in the Title box. 

When you are done, click OK to save the settings. 

  (Optional) After placing the signature, right-click it and choose Properties… to 

set the properties of the signature field. In the Signature Properties dialog box, 

you can set the appearance, actions, etc. See also Signature Field Properties. (Note: 

This operation is not available after signing the document.) 

Sign Documents 

A PDF is signed to indicate your approval. The signature is flattened, so it cannot be 

resized and moved after signing the document. Multiple people can sign a PDF more 

than once. When you sign a document, your digital signature appears in the signature 

field. The appearance of the signature depends on your preferences. 

1. Sign a PDF after placing, please choose one of the followings to sign the 

document: 

 Choose Protect > Sign & Certify > Sign Document. 

 Select the Hand command and right-click the signature, choose Sign 

Document. 

 Select the Hand command, and click the signature. 

2. Type file name and specify location in pop-up Save As dialog box. 

Note: By default, the document is signed after you place the signature. To change the 

setting, please uncheck the Sign the document immediately after signature is placed 

option in File > Preferences > Signature. 
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Validate Signatures 

Signature validity is determined by checking the authenticity of the signature’s digital 

ID certificate status and document integrity. Depending on how you have configured 

your application, validation may occur automatically.  

Set Signature Verification Preference 

By default, Foxit PDF Editor Cloud will verify signatures when the document is opened, 

and will check the certificate revocation status while verifying signatures. If you want 

to change the setting, please go to File > Preferences > Signature, and uncheck the 

corresponding option in Signing & Verifications group. For more information, please 

refer to “Signature Preference”.  

Check the validity of a signature 

By default, Foxit PDF Editor Cloud verifies signatures when the document is opened. 

A message box appears in the top-right corner of the document pane to indicate the 

signature status. You can click Signature Panel on the notification message to check 

the details about the document certification and signatures in the Digital Signatures 

panel. 

Validate a signature 

1. Open the PDF containing the signature, do one of the followings: 

 Choose Protect > Validate.  

 Right-click the signature with the Hand command, choose Validate Signature 

from context menu. 

 Select the Hand command on the toolbar and click the signature. 

 Click the Digital Signatures panel, right-click the signature and choose Validate 

Signature. 

2. Pop-up a Signature Validation Status message box which describes the validity of 

signature.  

View signed versions of a digitally signed PDF 

A signed version will be automatically saved each time you sign a PDF with a digital 
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signature. If a digitally signed document was modified, you can still view the signed 

version without the modification. For a document digitally signed several times, you 

can view each signed version without the changes made after each signature was 

applied. All signed versions along with their corresponding digital signatures are listed 

in the Digital Signatures panel. 

To view a signed version of a digitally signed PDF, do as the following: 

1. Open the signed document with Foxit PDF Editor Cloud.  

2. In the Digital Signatures panel in the navigation pane, select and expand a 

signature, and choose Click to view this version. Or right-click the signature in 

the document pane with the Hand command and choose View Signed Version 

from the context menu. 

3. Then this version will be opened in a new tab in the application window, with the 

title of “filename.pdf-Signed Version”. (Note: If the document has not been modified 

since the selected signature was applied, a prompt appears saying you are already 

viewing the version covered by the selected signature.) 

4. (Optional) Following each signed version in the Digital Signatures panel lists the 

changes made to the signed version. Clicking on one of the changes will jump to 

the related area in the document. 

Compare versions of a digitally signed document 

For a digitally signed document (which might have been signed several times), you can 

view the differences (if any) between a signed version and the current version you 

have. 

To compare a signed document with the current version, do as the following: 

1. Open the current version you have with Foxit PDF Editor Cloud.  

2. Right-click the desired signature in the document pane with the Hand command 

and choose Compare Signed Version to Current Version from the context 

menu. 

3. A PDF document with the comparison result will be automatically created and 

opened in Foxit PDF Editor Cloud, and the Compare Results tab appears on the 

ribbon. The results document arranges pages side by side showing the two 

versions with the changes marked by different icons and colors. The first page 

and the second page show a summary and details of the comparison results 

respectively. See also Compare PDF Files.  
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Certify a PDF (Pro Only) 

Only the author can certify his/her own PDF documents. The author can specify what 

changes can be made to the file after certifying. Whenever approved changes are 

made, the certificate remains valid. If a reader tries to make changes you haven't 

allowed, the certificate is invalidated and any subsequent users will be notified that 

the document was tampered with. 

To certify your PDF, please do the following: 

1. Open your PDF document you want to certify.  

2. Select Protect > Sign & Certify > Certify with visible signature/Certify without 

visible signature. 

3. Press and hold mouse button down, drag to select an area on the document where 

you want the signature to appear. 

4. In the pop-up Certify Document dialog box, choose a digital ID. If you don’t find 

the specified digital ID, you need to get a digital ID from a third-party provider or 

create a self-signed digital ID. 

5. Set authorized actions for your document from the drop-down menu in 

Permitted Actions After Certifying item.  

6. Set the signing reason and choose an appearance type from the menu.   

7. Click Sign. 

8. To set the properties of the signature, please refer to Signature Field Properties.  

9. To sign the document, please see Sign a PDF.  

10. To validate the signature, please refer to Validate Signatures. 

Trusted Certificates 

When you validate or view properties of a digital signature or an embedded 

timestamp, the validity status may display “unknown” or “could not be verified”. You 

need to add the certificate that issued your digital IDs to the Trusted Certificates list.  

To add a trusted digital certificate to the Trust Certificates list, please do the following:  

 Right-click the digital signature, and choose Show Signature Properties.  

 In the Signature Properties dialog box, click Show Certificate.  

 In the Certificate Viewer dialog box, specify the trust level for the certificate in 

the Trust tab: 

 Use this certificate as a trusted root: Use the certificate as a trusted root, and 

trust all certificates issued by that certificate authority. Once you make a 

certificate a trust anchor, revocation checking will not be performed on it.  
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 Validating Signatures or Validating Certified Documents: Trust the certificate 

when validating signatures or certified documents.  

 Click Add to Trusted Certificates, and confirm your operation.  

To check all the trusted certificates, choose Protect > Sign & Certify > Trusted 

Certificates. In the Trust Certificates window, you can manage all the trusted 

certificates, including adding & exporting a certificate, viewing certificate details, 

deleting a certificate, and specifying the trust level for a certificate. 

The Signature panel 

The Signature panel shows information about each signature and time stamp in the 

document as well as the change history of the document since the first signature. 

Open the Signature panel 

Click the Signature button  on the left of Navigation Pane. 

View Signature Properties  

Signature Properties dialog box provides basic information about the signature, 

including the signer, reason, date, location validity summary and details of certificate, 

etc. 

1. Select the Hand command. 

2. Right-click the signature field, or right-click the signature in the Digital Signatures 

panel and choose Show Signature Properties from context menu. 

3. In Signature Properties dialog box, you can get the information as follows: 

 Signed by – shows the signers that sign the document. 

 Reason – displays the reason that you create the signature. 

 Date – shows the date time when you signed the document. 

 Location - shows which page the signature is located on. 

 Validity Summary - checks whether the document was modified after it was 

signed, and other information. 

 Show Certificate – Click it to open the Certificate Viewer dialog box. Click 

Show Certificate in the Certificate Viewer dialog box to view the details of 

the signature certificate (such as the validity of certificate and certificate path) 

and add the certificate to the Trusted Certificates list. See also Add a trusted 
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digital certificate to the Trust Certificates list. 

 Advanced Properties – Click it to open the Advanced Signature Properties 

dialog box where you can view the details about the signature and the 

embedded time stamp (if any). For the time stamp, you can click Show 

Certificate… in the Advanced Signature Properties dialog box to add the 

time stamp server to the Trusted Certificates list. See also Add a trusted 

digital certificate to the Trust Certificates list. 

Note: If the status is unknown, click Show Certificate… in the Signature Properties dialog 

box > Show Certificate in the Certificate Viewer dialog box to view the details of the 

certificate. Check whether the certificate has been included in your list of trusted identities. 

If your certificate is not trusted, click Install Certificate to install it to the trusted Windows 

Certificate Store. If you use a self-signed digital ID, confirm that the certificate details are 

valid. If the certificate isn’t valid, a valid certificate from signer is requested. 
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Chapter 12 – Foxit Admin Console 

Foxit Admin Console is a Cloud-based portal that serves as a central location for 

administrators to manage Foxit products/services and entitled users across their 

entire organizations. After setting up and activating Admin Console based on the 

organization environment, the administrator can open the URL of Foxit Admin Console 

to get started. The Admin Console allows administrators to do the following: 

• View the summary of the licenses and products 

• Configure the license keys   

• Assign license keys to users 

• Manage Foxit products 

• Configure the internal update of packages (on-premise environments only) 

• Configure mail server 

• View the detailed reports on the uses and statistics of Foxit products 

• Customize enterprise brand information 

• View the administrator’s action logs 

For more information about Foxit Admin Console, please refer to Foxit Admin Console 

User Manual here. 

https://www.foxit.com/support/usermanuals.html
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Chapter 13 – Integration with ChatGPT 

Foxit PDF Editor Cloud’s integration with ChatGPT takes advantage of AI-Generated 

Content (AIGC) to make end users more productive. It provides the following 

capabilities: 

• Chat with AI Assistant – Use natural language processing (NLP) to provide users 

with detailed responses to their questions in real-time. 

• Chat about Document – Analyze the document and answer user questions based 

on PDF content. 

• Summarize Text/Document – Generate a concise and accurate summary of a given 

text input or a document. It analyzes the content of the text and identifies the most 

important information to include in the summary, using natural language 

processing and machine learning algorithms. 

• Enhance writing of the text – Use machine learning to automatically paraphrase or 

rewrite text while maintaining its original meaning. This service is designed to help 

users generate new content from existing text, such as for content marketing, SEO, 

or simply to improve the clarity and readability of writing. 

• Content Translation – Translate selected text into corresponding languages. 

• Spelling and Grammar Correction – Automatically detect and correct spelling and 

grammar errors in your content. 

• Content Explanation – Provide concise explanations and definitions for selected 

text. 

• Smart PDF Commands – Automatically execute the associated commands in Editor 

Cloud based on users’ inputs that indicate what tasks they want to perform. 

To access the AI services above, do any of the following: 

• Click Home > AI Assistant. 

• Click the  icon in the lower right corner of the application window.  

• Select any text content in your document and choose a tool from the floating 

toolbar to perform tasks. 

Once you have started the AI services, the AI Assistant tab will appear in the right panel 

of the Foxit PDF Editor Cloud window. In the AI Assistant tab, you can click the Chat 

sub-tab to enter text messages and chat with AI Assistant, choose the Chat about 

document sub-tab to have a conversation specifically about the current document, or 

click More tools to access additional tools as needed.  

To help you familiarize yourself with using AI Assistant, you can click the icons located 

at the top right corner of the AI Assistant tab. (If the AI Assistant tab is narrowed, some 
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icons are hidden, and the vertical three-dot icon  will appear. And you can find the 

hidden icons in the menu that appears when moving your cursor over the vertical 

three-dot icon .) The icons provide the following functions: 

• Quota : By hovering your cursor over this icon, you can view your usage 

statistics for the AI services. This includes the total number of prompts and 

pages you are allowed to use per day/month as well as the number you have 

already used. Foxit PDF Editor Cloud currently offers a free quota, which 

consists of 50 prompts/questions per user per day (with a maximum of 2000 

characters per prompt) and 100 pages per user per month for document 

analysis and summarization. 

• Instruction : Click this icon to quickly access a guide on how to use the AI 

services.  

• Feedback : Click this icon to send us any comments/questions/bug 

reports/suggestions about our product. 

• Full screen : Click this icon to maximize the AI Assistant tab. In full screen 

mode, the AI Assistant tab fill will fill the entire workspace of Foxit PDF Editor 

Cloud, hiding the toolbar, status bar, and navigation pane. To exit full screen 

mode, click the icon at the top right corner of the AI Assistant tab. 

Depending on the specific AI service you are using, you may have additional options 

available. For example, you can click the Output Language  button to set the 

desired output language, and the Clear History  button to delete all the message 

records you previously interacted with AI Assistant. Additionally, you can specify tones 

(Formal, Professional, Funny, etc.) and the desired length for the output text when 

enhancing text writing. 
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Chapter 14 – Appendices 

This section is a collection of supplementary materials for this user manual such as 

Keyboard Shortcuts. 

Keyboard Shortcuts 

There are number of keyboard shortcuts that you can use to speed up your navigation 

within the Foxit PDF Editor Cloud.  

Some particularly important ones are listed here. 

File Keys 

Result Shortcut 

Open File Ctrl + O 

Save As Ctrl + Shift + S 

Print a Document Ctrl + P 

Save Ctrl + S 

Document Properties Ctrl + D 

View Keys 

Result Shortcut 

Full Screen F11 

Exit Full Screen Mode ESC, or F11 

Zoom In Ctrl + +  

Zoom Out Ctrl + - 

Zoom To Ctrl + M 

Actual Size Ctrl + 1 

Fit to Page Ctrl + 0 

Fit Width Ctrl + 2 

Fit Visible Ctrl + 3 

Rotate Clockwise Ctrl + Shift + Plus 
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Rotate Counterclockwise Ctrl + Shift + Minus 

AutoScroll Ctrl + Shift + H 

Stop AutoScroll ESC 

View file in read mode Ctrl + H 

Preview page by page in Print Preview Page Up/Down 

Go to Page Ctrl + G  

First Page Ctrl + Home 

Last Page Ctrl + End 

Previous View Alt + Left 

Next View Alt + Right 

Marquee Zoom Alt + 5 

Rulers Ctrl + R 

Show or hide Navigation pane F4 

Edit Keys 

Result Shortcut 

Copy Ctrl + C, or Ctrl + Insert 

Cut Ctrl + X 

Paste Ctrl + V 

Undo (Undo an action) Ctrl + Z 

Redo (Redo or repeat an action) Ctrl + Shift + Z 

Select All (Select all items in a document or 

window) 
Ctrl + A 

Add Bookmark Ctrl + B 

Preferences Ctrl + K 

Go to fillable field by tab order Tab 

Go to fillable field by tab in reversed order Shift + Tab 

Duplicate pages Ctrl + Alt + D  

Tool Keys 

Tool Shortcut 
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Hand Tool Alt + 3 

Select Text and Image Alt + 6 

Snapshot Alt + 7 

Find Text (Go to the Find box in the top right 

corner of the application window to search 

document.) 

Ctrl + F 

Find Next F3 

Find Previous Shift + F3 

Open the Search panel  Ctrl + Shift + F 

Single-key Accelerators 

You can select some commands and perform some actions with single-key 

accelerators. To enable single-key accelerators, please go to File > Preferences > 

General, and check Use single-key accelerators to access tools option in the Basic 

Tools group. 

Keys for Selecting Commands 

Command Single-key Accelerator 

Hand  H 

Select Text and Image  V 

Marquee  Z 

Select Annotation R 

Edit Object O  

Crop Pages C 

Insert Blank Page Shift + Ctrl + T 

Insert From File Ctrl + Shift + I 

Delete pages Ctrl + Shift + Delete  

Keys for Navigating a PDF Document 

Action Single-key Accelerator 

First page Home 
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Last page End 

Previous page Left Arrow or Ctrl + Page Up 

Next page Right Arrow or Ctrl + Page Down 

Scroll up Up Arrow 

Scroll down Down Arrow 

Zoom in Ctrl+ Equal Sign 

Zoom out Ctrl + Hyphen 
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Contact Us 

Feel free to contact us should you need any information or have any problems with 

our products. We are always here, ready to serve you better. 

• Office Address: 

Foxit Software Incorporated 

39355 California Street 

Suite 302 

Fremont, CA 94538 

USA 

• Sales: 

1-866-680-3668 

• Support & General: 

Support Center 

1-866-MYFOXIT, 1-866-693-6948 

• Website: 

www.foxit.com 

• E-mail: 

Marketing - marketing@foxit.com 

 

https://www.foxit.com/kb.html
http://www.foxit.com/
mailto:marketing@foxit.com
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