© Foxit Software Incorporated. All Rights Reserved.

No part of this document can be reproduced, transferred, distributed or stored in any format without the prior written permission of Foxit.

Anti-Grain Geometry - Version 2.4

© Maxim Shemanarev (http://www.antigrain.com)

Portions of this product Copyright [2001-2018] Solid Documents

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears in all copies. This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.
Contents

Chapter 1 – Introduction ................................................................................................. 6
PhantomPDF Overview ................................................................................................. 6
What's New? .................................................................................................................. 7
About the User Manual ................................................................................................. 8
Quick Installation Guide ............................................................................................... 8
Online Help ................................................................................................................... 8
Foxit Plug-In Platform .................................................................................................... 9
GPO ............................................................................................................................... 11
Using Foxit Setup Customization Tool ........................................................................ 11

Chapter 2 – Get Started .............................................................................................. 12
Workspace Basics ........................................................................................................ 12
Customize the Skin ...................................................................................................... 17
Set Preferences ............................................................................................................ 17

Chapter 3 – Read ......................................................................................................... 35
Open PDFs ................................................................................................................... 35
Save PDFs ................................................................................................................... 36
Close a PDF ................................................................................................................ 37
Export PDFs ................................................................................................................ 38
Integrate with IFilter .................................................................................................. 39
Industry Standard Validation and Creation ................................................................. 39
View PDFs ................................................................................................................... 40
View 3D Content in PDFs .......................................................................................... 56
Select & Copy .............................................................................................................. 57
Word Count ................................................................................................................. 59
Asian Languages ......................................................................................................... 59

Chapter 4 – Create ...................................................................................................... 60
Create a PDF in Different Ways .................................................................................. 60
Create and Customize a PDF Portfolio ....................................................................... 78
OCR PDFs and PDF Portfolios ................................................................................ 79
Create a table of contents from bookmarks .............................................................. 82

Chapter 5 – Edit ......................................................................................................... 83
Undo and Redo ............................................................................................................ 83
Links ............................................................................................................................ 83
Bookmarks .................................................................................................................. 87
Destinations ............................................................................................................... 90
File Attachments ....................................................................................................... 91
Images ......................................................................................................................... 94
PDF Optimizer ............................................................................................................ 100
Action Wizard (Business Edition Only) ................................................................. 101
Work with Video & Audio ................................................................. 103
Search and Replace Text ............................................................... 106
Paragraph Editing ........................................................................ 107
Objects ......................................................................................... 107
About the Image Editor (Business Edition Only) ......................... 122
Spelling Check ............................................................................ 131
Working with Layers .................................................................... 131
PDF Properties ............................................................................. 135
Chapter 6 – Organize .................................................................... 138
Insert Pages .................................................................................. 138
Rotate, Move, Swap and Delete Pages ....................................... 141
Extract, Duplicate and Replace Pages ....................................... 143
Split PDFs into multiple files ...................................................... 144
Crop Pages .................................................................................. 145
Flatten Pages .............................................................................. 146
Header & Footer, Watermark & Background to PDFs .................. 147
Bates Numbering (Business Edition Only) ................................. 149
Adding Format Page Numbers .................................................... 149
Chapter 7 – Comments ............................................................... 151
Commenting Commands .............................................................. 151
Change the Appearance of Comments ....................................... 164
Managing Comments .................................................................. 166
Chapter 8 – Share PDFs ............................................................... 176
Email Documents ......................................................................... 176
Send to Evernote ......................................................................... 176
Send to OneNote ......................................................................... 176
SharePoint Integration ................................................................. 177
Shared Review and Email Review ................................................. 179
NetDocuments Integration ............................................................. 183
iManage Work Integration ............................................................ 184
OpenText eDOCS Integration ....................................................... 186
OpenText Documentum Integration .............................................. 187
OpenText Content Suite Integration ........................................... 189
Worldox Integration ................................................................... 189
Chapter 9 – Forms ....................................................................... 191
Interactive Form and Non-interactive form ................................. 191
Fill in PDF Forms ......................................................................... 192
Comment on Forms ..................................................................... 194
Manage Form Data ...................................................................... 194
Form Fields .................................................................................. 196
JavaScript ..................................................................................... 219
Chapter 10 – Security ................................................................. 222
Check PDF Security ..................................................................... 222
Password Protection & Certificate Protection ............................. 222
Foxit PhantomPDF
User Manual

AD RMS Protection (Business Edition Only)..............................................................227
Remove Hidden Data ..................................................................................................240
Redaction (Business Edition Only)...............................................................................240
Windows Information Protection (WIP) ......................................................................243
FIPS mode......................................................................................................................246
Chapter 11 – ConnectedPDF ......................................................................................248
Chapter 12 – Signature ...............................................................................................249
Digital Signature........................................................................................................249
Sign PDFs with DocuSign® .......................................................................................258
Quick PDF Signature ................................................................................................260
Chapter 13 – Accessibility .........................................................................................262
Accessible reading and navigation through accessibility preference setting and shortcut keys .................................................................271
Create accessible PDFs (Business only) ....................................................................272
Chapter 14 – Print ......................................................................................................282
Print a PDF document ...............................................................................................282
The Print dialog box ....................................................................................................283
Set Foxit PhantomPDF Printer Properties ..................................................................285
Chapter 15 – Appendices ..........................................................................................290
Quick Installation Guide .............................................................................................290
GPO Manual ...............................................................................................................299
SharePoint Configuration ...........................................................................................312
Quick Start for Azure Active Directory Rights Management ........................................314
Web Service Configuration..........................................................................................315
Work with PhantomPDF via VBA scripts in Excel .....................................................326
Keyboard Shortcuts.....................................................................................................329
Single-key Accelerators ..............................................................................................333
Command Lines .........................................................................................................338
Contact Us ................................................................................................................339
Chapter 1 – Introduction

PhantomPDF Overview

Welcome to Foxit PhantomPDF™- Business Ready PDF! Award-winning Foxit PhantomPDF provides the right features at the right price, allowing you to produce great looking PDF document and forms quickly, affordably, and securely. Foxit PhantomPDF comes in two editions: Foxit PhantomPDF Standard to fit the small and medium sized businesses, and Foxit PhantomPDF Business to fit the large enterprises.

Foxit PhantomPDF Standard

Foxit PhantomPDF Standard enables businesses to create, edit, and secure reliable PDF documents quickly, easily, and at a cost you can afford.

- XFA Form Filling
- Direct Editing
- Read out Loud
- Robust Document Security
- Form Fields
- Optical Character Recognition (OCR)
- Export PDF to Image
- Industry Validation
- PDF Optimizer
- SharePoint Integration
- DocuSign
- Participate in a Shared Review

Foxit PhantomPDF Business

Foxit PhantomPDF Business provides business the security that ensures regulatory compliance and corporate governance of their important documents and archives and to ensure documents don’t change after they are approved. It stands up to the demands of large enterprises but lightweight enough to easily deploy to thousands of users without exhausting resources. Supports the right features at the right price with the quality and support you expect from an enterprise solution.

- Redaction
- Document Certification
- XFA Form Filling
- Bates Number
What’s New?

What’s new in Foxit PhantomPDF 9.3?

New features:

- **Accessibility Features**
  Undo and redo with keystrokes in the Tags tree to quickly undo/redo your last action.

  Highlight the current reading content when you use Jaws to read a document, which streamlines your PDF workflow.

  Support right-click menu when selecting multiple items with the Shift/Ctrl key in the Order panel to perform certain actions quickly and with ease.

  Find a tag in the Tags tree more easily with the option Find Tag From Selection from the right-click menu after you select an item in the document pane.

  Select multiple items with the Shift/Ctrl key and then drag and drop them to the desired positions to adjust the order in the Order panel.

  Edit tag types quickly using the F2 key.

  Select multiple tags with the Shift/Ctrl key in the Tags panel to bulk edit tag properties, reorder tags, and perform other actions from the right-click menu.

  Access the Touch Up Reading Order tool quickly from the right-click menu of any tag in the Tags tree.

- **Print PDFs using the custom settings in Print Dialog Presets if any.** You can view and modify the print dialog presets in the Properties in the File tab.
Enhancements in Foxit PhantomPDF 9.3:

- **SharePoint plugin improvements**
  Allows users to pin libraries to the list in the Save As dialog box when creating PDFs from the SharePoint plugin in Microsoft Word, which ensures quick and easy access to frequently used libraries.

  Add an option to navigate back to SharePoint root folders when choosing from recent folders or accessing a new library that is not in the root folder.

  Add an option to pin a folder when you sign in the folder, without the need to open any file or pin the folder from the recent folders list.

  Add an option to overwrite an existing file in SharePoint when creating a file with the same name from the SharePoint plugin.

- **Some other user-friendly enhancements.**

**About the User Manual**

This user manual covers all features included in Foxit PhantomPDF.

**Quick Installation Guide**

To get installation, registration, uninstallation and update instructions step by step, please refer to Foxit PhantomPDF *Quick Installation Guide*.

**Online Help**

You can get online help about how to read and work with PDF files from within Foxit PhantomPDF using the Help Center and Content-sensitive Help features.

**Help Center**

Help Center helps you navigate top help topics and get help online. To access the Help Center, please click **Help tab > Help > Help Center**. In the Help Center, you can input a keyword in the **Search** box to search for any desired topic. While reading the help contents, you can click to move back to the previous view, or click to return to the Home Page of the Help Center.
Content-sensitive Help

Content-sensitive Help assists users by providing help based on a specific task they perform. This enables users to get specific information about whatever feature of the application they are using at the given moment.

To access Content-sensitive Help:

Hover your mouse over a button, and you will see the tip which gives you the basic instruction of the feature. If Foxit PhantomPDF contains additional help about the feature, you can click Tell me more to learn more about it in Help Center.

Foxit Plug-In Platform

For flexible and convenient management of plugins, Foxit PhantomPDF offers a Plug-in Platform, in which you can view the plug-in status, learn the information about the plugins installed, as well as manage the plug-ins as needed.

To open Foxit Plug-in Platform, please choose Help > Product > Foxit Plug-Ins.

Plug-in Status

- Certified: Shows whether the signature of the plug-in is valid or not.
- Loaded: Shows whether the plug-in has been loaded successfully or not.

Note: Some plug-ins are not loaded immediately (i.e. the Certified and Loaded items are unchecked). These plug-ins will be loaded and certified after you use the related features.

Plug-in Information

In addition to plug-in status, you can learn more information about the plug-in installed, including the name, date, description and legal copyright.

To learn the details of a plug-in, please click More... under the general description of the plug-in in the Foxit Plug-in Platform.

Plug-in Management

Within Foxit Plug-in Platform, you can manage the plug-ins as needed, including installing, enabling, disabling and uninstalling plug-ins.

Installing a Plug-in

To install a plug-in, please follow the steps below:
Select **Help > Product > Foxit Plug-Ins** to open Foxit Plug-In Platform;

- Click **Install Plugin** > choose the plug-in file (in .xml format) > click **Open**.

Then Foxit PhantomPDF will verify whether the signature of the plug-in to be installed is valid or not. If it is valid, Foxit PhantomPDF will load the plug-in directly; if not, a prompt message will pop up (as shown below), and the installation will be terminated.

![Failed to install. The signature of the plug-in is invalid or missing. Please contact the plug-in provider.](image)

**Note:** The .xml and .fpi files of a plug-in to be installed should be placed in the same folder, otherwise, installation will fail.

**Disabling a Plug-in**

To disable a plug-in, please follow the steps below:

- Select **Help > Product > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
- Select the plug-in you want to disable, and click the **Disable** button to disable it.

**Enabling a plug-in**

To enable a plug-in, please follow the steps below:

- Select **Help > Product > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
- Select the plug-in to be enabled, and click the **Undo Disable** button to enable it.

**Uninstalling a plug-in**

To uninstall a plug-in, please follow the steps below:

- Select **Help > Product > About Foxit Plug-Ins** to open Foxit Plug-in Platform.
- Select the plug-in to be uninstalled, and click the **Uninstall** button to uninstall it.

**Note:**

1. All the operations to the plug-ins will take effect after you restart Foxit PhantomPDF.
2. Foxit PhantomPDF includes plug-ins that are necessary for the realization of its functionalities or are necessarily required for maintenance. To ensure normal operation, you are not allowed to disable or uninstall these plug-ins (such as Foxit Updater plugin, Foxit Plug-in Platform plugin, etc.)

GPO

Group Policy (GPO), a feature of the Microsoft Windows NT family of operating systems, is a set of rules that control the working environment of user and computer accounts. It offers the centralized management and configuration of operating systems, applications, and users' settings in an Active Directory environment.

For instructions to use group policy of Foxit PhantomPDF, please refer to Foxit PhantomPDF GPO Manual.

Using Foxit Setup Customization Tool

You can use the Foxit Setup Customization Tool to configure the installer prior to deployment for organizations or businesses. For example, you can license the product on a volume scale with the Foxit Setup Customization Tool to prevent the need to register and personalize each copy of the installation.

To configure Foxit PhantomPDF with the Foxit Setup Customization Tool, please follow the steps below:

- Open the Foxit Setup Customization Tool.
- Click File > Open to open the application (MSI file) that you want to customize.
- Open the following panels to customize the related settings in Foxit PhantomPDF.
  - General: Customize the default location and other common settings.
  - Features: Specify which features will be installed by default.
  - Shortcuts: Choose whether to create a specific shortcut.
  - Add File: Add your own files into the MSI package.
- Click File > Save to save the customization. The customized package will be saved as an MST file.
- Use the following command to apply the MST file during deployment:

  msiexec /i Setup.msi TRANSFORMS=xxx.mst

Note:

1. The customized MST file needs to be deployed with the original MSI file.
2. Foxit Setup Customization Tool is only available for Foxit PhantomPDF & Reader 7.3 and newer versions. To ensure successful customization, the version of the Foxit Setup Customization Tool should be the same as that of Foxit Reader & PhantomPDF.
Chapter 2 – Get Started

The Foxit PhantomPDF workspace is packed with commands that help make working with PDF files easier, and is organized into a document pane, a navigation pane, toolbar pane menu bar and status bar. A good way to get up to speed in using Foxit PhantomPDF is by familiarizing yourself with its workspace.

Workspace Basics

Foxit PhantomPDF provides an intuitive user interface with a menu bar, a toolbar, a navigation pane, work area and status bar.

About Start Page

The Start Page appears when you first start Foxit PhantomPDF and shows the recent documents opened, helpful product tutorials, and more. You can click any document you recently opened from the recent document list or choose one tutorial for any feature to learn about our product.

The Start Page will continue to appear every time you start the program until you uncheck the Show Start Page at File > Preferences > General > Application Startup.

Toolbar

The toolbar displays the File page (the backstage view like Office 2013) and other tabs with different commands. You can easily and quickly find the command you need by clicking in the Tell me what you want to do… box (or press Alt +Q) near a bubble on the menu bar and typing the name or description of the command you need. Then Foxit PhantomPDF will display a list of matching commands from which you can select and activate the desired feature.

Note: Position the pointer over a command to see a description of the command.

Click File to create, open, save to manage your PDF files.
Show/Hide Toolbar

To show/hide all toolbars, please do the following:

- To hide the toolbar, please click the arrow located on the lower-right corner of the ribbon.
- To show the toolbar, choose a tab and click the pushpin icon located on the lower-right corner of the ribbon.
- Right-click toolbar and check Minimize the Ribbon option to hide the ribbon toolbar and uncheck the option to have the ribbon displayed.

Set Favorite Toolbar

The Ribbon is designed to help you find the commands in an easy and convenient way. Foxit PhantomPDF gives you the capability to personalize and fine-tune the Ribbon in the way you want. With this feature, you can customize the default Ribbon, and create custom tabs or groups with your favorite commands.

To customize the Ribbon, you can right click the Ribbon, choose Customize the Ribbon from the context menu to bring out the Customize Tools dialog box first, and then follow the steps below.
Create a new tab

To create a new tab, please do one of the following:

- Select the tab after which you want to add the new tab, and then click **New Tab**.
- (Alternatively) Right-click the tab after which you want to add the new tab, and then choose **New Tab** from the context menu.

Add a new group to a tab

To add a new group to a tab, please do one of the following:

- Select the tab to which you want to add the group, and then click **New Group**.
- (Alternatively) Right-click the tab to which you want to add the group, and then choose **New Group** from the context menu.

Rename a tab or group

- Select the tab or group to be renamed, and click **Rename**.
- (Alternatively) Right-click the tab or group to be renamed, and choose **Rename** from the context menu.
- In the **Rename** dialog box, input the new name and click **OK**.
- For a custom group, you can also choose the display symbol from the **Rename** dialog box.

Add commands to a group

- Select the group under which you want to add a command.
- Choose the command category and the desired command from the **Choose command from** list.
- Click **Add** to add the selected command to the desired group.

Remove a tab, group or command

To remove a tab, group or command, please do one of the following:

- Select the tab, group or command to be removed, and click **Remove**.
- (Alternatively) Right-click the tab, group or command to be removed, and choose **Delete** from the context menu.

Reorder the tabs or groups

To reorder the tabs or groups, please do one of the following:
Select the tab or group you want to reorder, then click the Up ▲ or Down ▼ arrow to move accordingly.

(Alternatively) Right-click the tab or group you want to reorder, and then select Move Item Up or Move Item Down to move accordingly.

Reset the Ribbon

Click Reset in the Customize Tools dialog box to reset the Ribbon to the default settings.

Import a customized Ribbon

Click Import.

In the Open dialog box, select the Ribbon customization file (.xml file), and click Open.

Note: After importing a Ribbon customization file, you will lose all the arrangements you have customized previously. If you want to revert to the customization you currently have, it is easier to export the customized Ribbon before importing any customization.

Export a customized Ribbon

Click Export.

In the Save As dialog box, specify the file name and path and click Save.

Note:
1. After customization, you need to click OK in the Customize Ribbon tab to save and apply your customizations to the Ribbon.
2. To help you distinguish a default tab or group from the customized ones, the custom tabs or groups in the Customize the Ribbon list are tabbed with “(Custom)” after the name (like this: New Tab (Custom)), but the word “(Custom)” will not appear in the Ribbon.
3. The commands in the default group under a default tab are displayed in grey, and they cannot be renamed, reordered, or removed.
4. You cannot remove default tabs in Foxit PhantomPDF.

Mouse/Touch Mode

Foxit PhantomPDF adds a Mouse/Touch Mode button on the Quick Access toolbar. In Touch Mode, the buttons within the Ribbon and Quick Access toolbar will appear with more space surrounding them onscreen, making it easier to work on touch devices. To toggle between Mouse Mode and Touch Mode, please click the button on the Quick Access toolbar.
Navigation Panels

Show or hide the navigation panels

The buttons on the left side of the navigation pane provides easy access to various panels, such as the Bookmarks panel button and the Pages thumbnails button.

- To show the navigation panels, use keyboard shortcut F4, or click View > View Setting > Navigation Panels > Show Navigation Panels, or right-click on the page and choose Show Navigation Panels.
- To hide the navigation panels, use keyboard shortcut F4, or click View > View Setting > Navigation Panels > Hide Navigation Panels, or right-click on the page and choose Hide Navigation Panels.
- To open a navigation panel, click its button on the left side of the navigation pane.
- To close a navigation panel, click its button on the left side of the navigation pane.

Adjust the navigation pane

Like the toolbars, the navigation pane can be docked in the navigation pane or float anywhere in the workspace. You can choose to hide or close the panels that you don't need and open the ones you do. What’s more, you can also adjust the width of the navigation pane easily.

1. Viewing a panel in the navigation pane
   By default, all the panels dock in the navigation pane with a set of panel buttons appearing on the left side of the work area. Do the following:
   - Select the button for the panel on the left side of the navigation pane.

2. Changing the display area for navigation pane
   - To change the view area of the navigation pane, drag its right border to adjust the width.
   - To minimize or maximize the navigation pane, click on the button at the top right corner of the navigation pane.

3. Docking or floating a navigation pane
   - To float a navigation panel, drag the panel button into the document pane.
   - To move a panel, drag it by its panel button to another location.
   - To dock a floating panel, double-click its title bar.
Status Bar

The status bar is an area of the workspace that displays the page number where you are, the number of total pages, page transition buttons, zoom buttons, etc. for view setting. The status bar is open by default when you open a PDF. In the View ribbon, the items on the View Setting tab help you to show or hide the status bar.

Show Status Bar: If you check it, the status bar will appear in the bottom of the workspace.

Auto-hide Status Bar: If you check it, the status bar is hidden. But if you put the cursor near the bottom of the page, the status bar will appear.

Hide Status Bar: If you check it, the status bar will be hidden.

Customize the Skin

There are five kinds of skin, Classic, Black, Blue, Orange and Purple that allow the user to change the look of the software.

To change the skin of the workspace, please do the following:

- Go to File > Change Skin.
- Check the skin you like and click OK.

Set Preferences

Many program settings are specified in the Preferences dialog box, including settings for File Associations, Forms, Full Screen, General, History, JavaScript, Languages, OCR, Page Display, PDF/A, Reading, RMS Setting, Security, Signature, and Trust Manager. Once you set preferences, they remain in effect until you change them.

1. Choose File > Preferences.
2. Select the type of preference you want to change under the list of categories.
**Accessibility**

- **Document Colors Options**
  - Replace document colors: Check to activate other options to change the document colors.
  - A. Use Windows color scheme: Sets document colors according to the color scheme of your Windows preferences.
  - B. Use High-Contrast colors: Choose the high-contrast color combination for page background and document text to improve readability.
  - C. Custom color: Changes the color of Page Background and Document Text.
  - D. Only change the color of black text: Change only the black text and leave the colored text unchanged when you replace document colors.
  - E. Change the color of text or black line art: Change the color of text or black line arts when you replace document colors.

- **Override Page Display**
  - A. Always use Page Layout Style: Set a page layout as default for all PDF documents and override other page display settings.
  - B. Always use Zoom Setting: Specify a default zoom setting for all PDF documents and override other page display settings.

- **Other Accessibility Options**
  - A. Use document structure for tab order when no explicit tab order is specified: Improve the navigation of form fields and links in documents that don’t specify a tab order.
  - B. Always use the system selection color: Override the default selection color (blue) with a color that the system specified.
  - C. Show Portfolios in Files mode: Display PDF Portfolio component files and file details in a list. Please note that if you set the default view for PDF portfolios in Portfolio > View > Default view setting, that default view setting will prevail over this accessibility setting.

- **Accessibility Checker Option**
  Show accessibility checker options dialog when the checker start: check this option to show the Accessibility Checker Options dialog box when you run Full Check.

**Commenting**

- **Viewing Comments**
  - A. Pop-up opacity: Sets the opacity of popup notes for annotation commands.
  - B. Print notes and pop-ups: Specify whether or not to print sticky notes and pop-up notes associated with comments in PDF as they appear on the page. Please note that if you want to print the pop-up notes associated with comments, you should open the pop-up notes that you want to print in the PDF file, and adjust their placement on the page before printing to ensure that they don’t overlap or spill off the page. While printing, make sure that you select the Document and markups option in Print What group in the Print dialog box.
C. Ensure that pop-ups are visible as the document is scrolled: Ensure that the pop-up boxes float along with the page as the document is scrolled. This option is checked by default.

- **Making Comments**
  A. Always use User Name of the log-in account for Author name: Use the user name of the log-in account as the author name while making comments. If a user does not set the user name for the Foxit log-in account, the prefix of the email address will be used as the author name instead.
  B. Copy selected text into Highlight, Squiggly Underline, Underline, and Strikeout comment pop-ups: Check this option to copy and paste the selected text to comment pop-up notes automatically when you highlight, squiggly underline, underline, or strikeout annotation in PDF documents.

- **Pencil Setting**
  A. Enable to select pencil annotation when drawing: when the Pencil command is selected, the cursor changes into a pencil 🖊. If this option is selected, the pencil changes into an arrow ⬤ when you put it over a pencil annotation, and you can click the annotation to select it. If the option is not selected, the pencil will not change into an arrow.
  B. Click to create annotations: if selected, you start to draw with the pencil when you click on the page, and in other words, only one click creates a pencil annotation; if not selected, you do not start to draw until you click and drag the pencil.
  C. Set Timeout: specifies a period of time within which all of the drawings/plans completed is one pencil annotation, after which what you draw is another pencil annotation.

- **Editing**: Sets the text direction for text comments, including left to right and right to left.

## ConnectedPDF

- **Data Collection**

  Allow usage data to be used in ConnectedPDF features: If this option is checked, the document usage data will be shared with Foxit servers when you are using ConnectedPDF features. This data will be used for development purposes and enhancing user experience only. You can click [here](#) to learn about the privacy policy.

- **Use ConnectedPDF Format**

  1. Automatically save PDF files in ConnectedPDF format (including those created from plugins) only when signed in: If this option is checked, Foxit PhantomPDF will automatically convert the files into ConnectedPDF format when creating or saving PDF files.
  2. Automatically convert Office files to Connected when converting to PDF via Office add-in: If this option is checked, after converting the Office document to ConnectedPDF format, the Office document will become connected, and you will then be able to view the document
homepage of the converted ConnectedPDF by clicking the Document Homepage button under the FOXIT PDF tab in Microsoft Office.

- How to show web pages

When using ConnectedPDF, Foxit PhantomPDF will display ConnectedPDF-related information (such as the Document Homepage and Personal Homepage) in web pages. You can choose to display the web pages in the tabs within the application, or in your default browser.

- Default Permissions

Document owners can restrict some features, including Register New Version and Start Connected Review, to better control documents by adding default permission settings. By default, Started Connected Review is restricted and other users who want to start a Connected Review session will need to apply to the document owner.

Create PDF

Create PDF feature allows users to set the Page Size of PDF to be created.

A. Fixed size: Sets the size and direction of PDF through drop-down list.
B. Custom: Customizes the Page Size of PDF to be created. You can select the units first and then set the width and height of page as needed.
C. Insert printed PDFs into previously generated documents, except those created by Foxit PhantomPDF: Check it to append newly generated PDF files to a previously generated one which are created by Print command in other application using Foxit PhantomPDF Printer.
D. Allow pop up alert when creating PDF: Check this option to show message when converting PDFs in Microsoft Office by the Foxit PDF add-in.

Documents

The Document of the Preferences dialog provides several ways to browse PDF documents.

- Open Settings

1. Allow multiple instances: Creates a new Foxit PhantomPDF window when double-clicked to open a PDF file.
2. Alert user when documents request Full Screen: A message box will pop up to confirm the operation when opening a PDF which has been defined to be opened in full screen mode.
3. In Web Browser, display PDF in Read Mode by default: Opens a PDF in Read Mode
automatically in web browser.

4. In Foxit PhantomPDF, please choose the mode for Display PDF Mode: Display the PDFs in Read Mode or Full Screen Mode or normal way automatically when opening PDFs with Foxit PhantomPDF.

- **Prompt Messages**
  1. Display a prompt before closing all tabs: When you close a window with multiple tabs, Foxit PhantomPDF will ask you to confirm your choice. This prevents you from accidentally closing the whole window when you intend to close only the current tab.
  2. Automatically save document as e-mail attachment: Automatically save the changes you made to a document and attach the modified document to your email system for sending.

- **PDF/A View mode**
  Sets to view documents in PDF/A view mode (i.e. read-only mode) to prevent modifications to the documents.
  1. Never: Never open documents in PDF/A view mode.
  2. Only for PDF/A documents: Switch to read-only mode automatically when a PDF/A document is opened.

- **Save Setting**
  Configure the time intervals for when the document will be automatically saved. Check **Save As optimizes for Fast Web View** to save documents as linearized PDFs that can be opened and viewed from web browsers even before the whole file is downloaded.

- **Preferred Save As Location**
  If you have configured a preferred save as location, when prompted to specify a location to save a document, the configured location will be automatically chosen in the **Save As** dialog box. To add a preferred save as location, click **Browse** to select the location, or input the location in the **Preferred Save As Location** field. If you need to remove the configured output location, just delete the directory path in the **Preferred Save As Location** field.

- **Redaction**
  After applying redaction, you can save the redacted file as a new file with the preconfigured name automatically. To configure the name, select **Adjust filename when saving applied redaction marks**, and input text in the **Prefix** and **Suffix** boxes to configure the name.
DWG (Business Edition Only)

Choose the type of PDF file to create when converting .dwg and .dxf files.

ECM Integration

NetDocuments

Users who open PDFs on NetDocuments through a browser instead of ndOffice, can return to the legacy NetDocuments integration by checking the option Use NetDocuments integration through browser instead of ndOffice.

SharePoint

Choose a method to open a document when you try to open a document on SharePoint. You can choose just to open the document, check it out when opening, or ask you when opening a document.

iManage

By default, a document is checked out when you open it from PhantomPDF. You can change the setting as needed.

Editing

Show changed text in: Select a color the modified text will appear in when using the Edit Text command.
Alert when there’s no editable text when using ‘Edit Text’ tool: An alert will pop up notifying the user when there’s no editable text while using the Edit Text command.

File Associations

This option allows you to set the default PDF Viewer.

- Make Foxit PhantomPDF the default PDF viewer:
  - Advanced
    1. Include browser when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in browser.
2. Include preview when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in preview.
3. Include thumbnail when setting default PDF viewer: check this option to set Foxit PhantomPDF as the default PDF viewer in thumbnail view.
4. Use Foxit PhantomPDF to open embedded Acrobat files and embedded Foxit Reader PDF files in Microsoft Office if Acrobat and Foxit Reader is not installed: check this option to set Foxit PhantomPDF as the default PDF viewer in Microsoft Office for opening embedded Acrobat files and Foxit Reader PDF files.

- **Restore file associations**: Restores settings in File Associations.
- **Always perform check when starting Foxit PhantomPDF**: If the default PDF viewer is not Foxit PhantomPDF, a message box will appear for the options to set it as your default viewer every time you run Foxit PhantomPDF.

**Forms**

The form tab enables you to set the preferences of the interactive form display.

- Always hide document message bar: You can decide whether to show or hide the document message bar that appears below the toolbar area when opening an interactive PDF form.
- Highlight all fields: Checking this option allows you to highlight all form fields in the PDF document. You can click the color palette to change the highlight color for ordinary fields as well as required fields.
- Enable autocomplete: If you enable the autocomplete feature, the entries you type into an interactive form field will be stored. When filling an interactive PDF form, this feature will suggest keywords that match your typing in the field.
- Open Properties box after creating field: The properties box appears when creating a form field.
- Run form recognition when creating PDF in Foxit PhantomPDF: Foxit PhantomPDF will run form recognition automatically when a PDF is created and opened in Foxit PhantomPDF.
- Email: You can edit the default subject and contents which will be sent with the PDF form.

**Full Screen**

- **Full Screen Navigation**
  
  A. Select to show Scroll bar, Status bar, Tab bar or Navigation Panels in Full Screen mode.
  B. Show Exit button – Check or uncheck this option to show or hide Exit button in Full Screen
mode.
C. One page at a time – Displays a single page at a time in Full Screen mode.
D. Left click to go forward one page; right click to go back one page – Lets you page through
a PDF document by clicking the mouse. You can also page through a document by pressing
Space, Shift + Space, or the arrow keys.

- Full Screen Appearance

Background – Click the color pane and choose the color you like to be the background color
in Full Screen mode.

- Full Screen Transitions

Foxit PhantomPDF supports page transition in Full Screen mode. There are 11 transition types:
Split, Blinds, Box, Wipe, Dissolve, Glitter, Fly, Push, Cover, Uncover and Fade. Also, you could
set the direction for the transition.
A. Ignore all transitions: Check to ignore page transition in Full Screen mode.
B. Default transition – Choose page transition for one document in the drop-down window.
C. Direction – Set the direction for the transition.
D. Navigation control direction: If selected, the direction of page transition will be based on
your navigation direction in the document. For instance, if you turn to the next page, the
page will transition from top to bottom; to the previous page, the page will transition
from bottom to top. For some transitions without directions, the option is not available.

General

The General Preferences setting provides options on Basic Tools, Tab Bar, Status Bar, and
Application Startup, etc.

- Basic Tools

A. Use single-key accelerators to access tools: Enable single-key accelerators to select some
commands and perform some actions with single-key shortcuts. Please refer to single-
Key Accelerators for more details.
B. Use fixed resolution for snapshots - Sets the resolution used to copy the image captured
with the Snapshot command. Automatically uses 72 pixels as default resolution.
C. Create links from URLs - Detects the text links in PDF documents and change the non-
clickable links into clickable ones.
D. Minimize to system tray - You can save space on your task bar by minimizing Foxit
PhantomPDF to the system tray. Check this selection to minimize Foxit PhantomPDF to
the system tray when clicking the Minimize button.
E. Screen word-capturing - Check it to turn on this function that enables you to use your
mouse to capture words inside a PDF file and have it translated if you are using dictionary software.

F. Make Hand Tool select text - Check it to enable the Hand command to become text selection tool when moving it to the selectable content.

● **Tab Bar**

A. Max tab size – Allows you to specify a maximum tab size.
B. Double-click to close Tab: Checking this option allows you to close tabs by double-clicking.

● **Status Bar**

A. Auto-hide Status Bar – Hides the status bar when opening a PDF, and enables it to float at the bottom of the page only when the cursor is moved to the bottom.
B. Show scroll lock button: Displays the scroll lock icons in the status bar.

● **Notification Messages**

Notification messages appear at the top right corner of the document pane when you work with interactive PDF forms, PDF/A files, or PDF files under shared review or email review, etc. You can configure the notification message settings as required:

A. Show the message which affects the next step, such as: “OCR”: Specify whether or not to show the procedure-related notification messages which usually contain action buttons for you to move forward to the next step. This option is checked by default. And it is recommended to keep the option checked so that you can work on documents during OCR, Shared Review, or Email Review normally.
B. Show the notification related message: Specify whether or not to show the notification related messages which inform you that a PDF file contains such elements as interactive form fields, 3D contents, etc.
C. Show PDF/A message again: Specify whether or not to show the message when opening a PDF/A document.

*Tip: You can also change the notification message settings by clicking the gear icon on the message shown on the document pane. The changes of settings you made in the notification message will be applied accordingly in the Notification Message preferences.*

**User Experience Improvement**

Turn on or off data collection. The collected data will be used to improve the user experience only.

● **Features which Require Internet Connection**
Specify whether to disable all features that require Internet connection. The setting will take effect after you restart the application.

**Application Startup**

A. Show Start Page: Check this option to show the start page when running Foxit PhantomPDF.

B. Disable ConnectedPDF features: If checked, all of the ConnectedPDF features will be unavailable and all related commands will disappear in the ribbon.

C. Show floating promotion page: Check this option to show the latest promotion offering from Foxit if you have not activated Foxit PhantomPDF.

D. Launch in debug mode: This option is unchecked by default. Checking this option will enable Foxit PhantomPDF to be launched in debug mode and log file will be generated during your operation. Log file will be saved in “%userprofile%\AppData\Local\Foxit PhantomPDF\glog”. When you encounter issues while using Foxit PhantomPDF, you can send the log file to Foxit and the log file will be used for checking and solving your issues only.

**History**

**History**

A. Restore last section when application starts: Determines whether documents start automatically with the last viewed section.

B. Restore last view settings when reopening: Determines whether documents open automatically with the last viewed settings.

C. Maximum number of documents in history list: Sets the maximum number of PDF documents you read in history list. The default is 50 PDF documents.

D. Maximum number of documents in Recent Documents list: Sets the maximum number of PDF documents you have viewed recently in the File page. The default setting is 10 PDF documents.

E. Show this number of unpinned Recent Folders: Set the number of unpinned recent folders listed in File > Open > Computer or SharePoint/OneDrive for Personal or Business/Google Drive/Dropbox. The default setting is 10 folders.

*Note:* Foxit PhantomPDF allows users to set “maximum number of documents in history list”, “maximum number of documents in Recent Documents list”, and the “number of unpinned Recent Folders” to 0.
Identity

Shows the identity of your application, including Login Name, Name, Title, Organization Name, Organization Unit, and Email Address. The identity information is quite useful in PDF reviews. It will help other review participants recognize your comments easily. The Login Name is set by default (using the username of the current operation system) and cannot be changed. Except for Login Name, you can change or complete your identity information in Identify Preferences.

Languages

Foxit PhantomPDF provides the commonly used languages to meet customers’ needs to the upmost. Usually, Foxit PhantomPDF will automatically choose the language applied to your OS as its default during your installation. But changing languages after installation is supportable.

To change language after installation, please follow the steps below:

- Choose File > Preferences > Languages.
- Select Choose custom language.
- Select the language in either Official Language or Translated by Community.
- Click the website in the pop-up window to download the language package and Foxit PhantomPDF will automatically install the language.
- Click OK in the Preferences dialog box, and then choose Restart in the pop-up window to apply the language.

Default Reading Direction: Choose a default reading direction when you’re reading a document in Facing or Continuous Facing mode.

Layout Grid

You can also customize the grid appearance.

- **Width/Height between lines**: sets the spacing between grid lines.
- **Grid offset from left/top edge**: sets the origin of the grid.
- **Subdivisions**: sets the number of subdivisions within each grid square. Subdivision lines are lighter than grid lines.
- **Grid line color**: sets the color of grid lines.

Measuring

- **Measurement Units**
Sets unit of page dimensions given in the status bar and print dialog.

- **Measurement Label**

  Choose to use the default measurement label or specify your own label.

- **Measurement Markup**

  **Use Default Leader for Distance Measurement**: Specify whether to show the line leader on both sides of the measurement points or not while measuring the distance.

**Page Display**

The Page Display panel of the Preferences dialog box includes the following options:

- **Default Layout and Zoom**

  A. **Navigation tab**: specifies the panel to be displayed in the opening view.
     - a) **Use Initial View**: minimizes the Navigation panel and hides all panels.
     - b) **Page Only**: displays Pages panel by default in opening view.
     - c) **Bookmarks Panel and Page**: displays Bookmarks panel by default in opening view.
     - d) **Pages Panel and Page**: displays Pages panel by default in opening view.
     - e) **Attachments Panel and Page**: displays Attachments panel by default in opening view.
     - f) **Layers Panel and Page**: displays Layers panel by default in opening view.

  B. **Default page layout**: You can view PDFs in following layouts:
     - a) **Automatic**: With this option selected, in a multi-page document, displays pages in Continuous mode, or in Single mode if the page width is larger than the page height. If you change the page display in the View tab, the document will display in the page layout the last time you set.
     - b) **Single Page** -- Displays one page at a time, with no portion on other pages visible.
     - c) **Continuous** -- Displays pages in a continuous vertical column that is one page wide.
     - d) **Facing** -- Displays each two-page spread with no portion of other pages visible.
     - e) **Continuous Facing** -- Displays facing pages side by side in a continuous vertical column.

  **See also** "Changing the Page layout".

  C. **Zoom**: Sets the magnification level for PDF documents when they are first opened. This value overrides document settings. The default uses the settings of the PDF document.

  D. **Custom facing**: The Default Facing for page layout is 2 pages. You can check the Custom Facing box and set the facing layout to your own preference.
E. Custom margin: Sets the margins between different pages with Facing or Continuous Facing page layout. The default is a margin of 8 pixels.

- Rendering
  A. Smooth text: Optimally adjusts text display that best suits your monitor.

- Page Content
  A. Display transparency grid: Displays a grid behind transparent objects.
  B. Use logical page numbers: Open PDFs with the logical page numbers.

- Forbid the change of the current Zoom factor during execution of ‘Go to Destination’ actions (these actions can be launched from bookmarks): Check to forbid user to change the current Zoom factor during execution of ‘Go to Destination’.

  See also “Adjust Page Magnification”.

PDF Sign

Flatten the document when applying all signatures: Flattening the document when applying all signatures will make all the signatures, forms, and annotations become one whole object of the PDF page.

Print

- Printer
  Print text as graphics (ignore font substitution) – Sets the text font as graphics and printout fonts are exactly the same as the text fonts. Automatically allows quick print where Printer Font is substituted.

- Batch Print
  A. Show print settings before printing document: Check it to show the Print dialog box before printing a document.
  B. Require confirmation when printing multiple documents: Check it to show the confirmation message before starting batch printing.

Reading

- Page vs Document
  This preference determines how much of a document is delivered to a screen reader at a time. If a PDF isn’t tagged, Foxit PhantomPDF may analyze the document and attempt to infer its structure, which can take a long time for a long document. You may want to set Foxit PhantomPDF to deliver only the currently visible page so that it analyzes only a small piece of
the document at a time. This consideration will vary depending on the size and complexity of
document and on the features of the screen reader.

A. Only read the currently visible pages - This option is usually best when using a screen
magnifier. It improves performance by eliminating the need for the software to process
deliv the currently visible pages of a PDF to the memory buffer, the assistive technology has access
to those pages only. It cannot go to another page until the next page is visible and Foxit
PhantomPDF has sent the page information to the memory buffer. Therefore, if this
option is selected, you must use the navigation features of Foxit PhantomPDF, not those
of the assistive technology, to navigate from page to page in the document. You should
also set the Default Page Display option in preferences to Single Page if you choose to
have PhantomPDF send only the currently visible pages to the assistive technology.

B. Read the entire document - This option can be best if you use a screen reader that has
its own navigation and search tools and that is more familiar to you than the commands
in Foxit PhantomPDF.

C. For large documents, only read the currently visible pages - This option is selected by
default and is usually best if you use a screen reader with long or complex PDFs. It allows
Foxit PhantomPDF to deliver an entire small document but revert to page-by-page
delivery for large documents.

- **Minimum number of pages in a large document**
  When the “For large documents, only read the currently visible pages” option is selected, it
  allows you to set this minimum value.

- **Enable assistive technology support**: Check this option to allow assistive technology products,
such as screen readers, to provide information about the UI and document to end users.

- **Confirm before preparing untagged PDF for reading with assistive technology**: Select the
  option, and if any assistive technology is detected in your system, a dialog box pops up when
  you open an untagged PDF to ask you whether to set the reading order options for the PDF
  for reading with assistive technology.

- **Reading Order**

  Set reading order as appropriate for your assistive software and devices.

  A. Infer reading order from document (recommended): Interpret the reading order of
     untagged documents by using an advanced method of structure-inference layout
     analysis.

  B. Left-to-right, top-to-bottom reading order: Deliver the text according to its placement
     on the page, reading from left to right and then top to bottom. This method is faster than
     “Infer reading order from document”. This method analyzes text only; form fields are
     ignored and tables aren’t recognized as such.

  C. Use reading order in raw print stream: Deliver text in the order in which it was recorded
     in the print stream. This method is faster than “Infer reading order from document”. This
     method analyzes text only; form fields are ignored and tables aren’t recognized as such.
Override the reading order in tagged documents: Use the reading order specified in the Reading preferences instead of what the tag structure of the document specifies. Use this preference only when you encounter problems in poorly tagged PDFs.

Reviewing

Automatically check for new comments:
Set the time interval to automatically check for new comments during shared review. By default, Foxit PhantomPDF will check for new comments every five minutes during shared review.

Shared Review Options

A. Show welcome dialog when opening file: Check it to show the welcome dialog when opening a shared review. In the welcome dialog, you can view the general information for the shared review, including the initiator, deadline, review server and so on.
B. Show server connection warning when opening file: Check it to show the server connection warning when opening a shared review.
C. Remind before review expiration: If you check this option, a prompt message will pop up before the shared review expires.

Review Options

A. Show prompt messages for Shared Review: Determines whether to show prompt message for Shared Review when publishing comments in a shared review that contains several comments from other reviewers that have not yet been published to the command server. You can take ownership of these comments and publish them on behalf of the reviewers.
B. Show prompt messages for Email Review: Check this option to show prompt messages during email review.

Send Messages

A. Use Auto-Complete List to suggest names when typing in the “To” and “Cc” fields: Checking this option will enable Auto-Complete feature, which recognizes and suggests contacts based on the previously entered email addresses when you send back your comments during a shared review by email.
B. Empty auto-complete list: Click this option to remove all the email address entries from the Auto-Complete memory.

Remove Custom Server Locations

Select a custom server location (i.e. the shared network folder you specified) and click Remove Server Profile to remove it from Foxit PhantomPDF.
RMS Settings *(Business Edition Only)*

Save encrypted file as a copy named ‘filename(protected)’ – saves an encrypted PDF file automatically as a copy named “filename(protected).pdf” after adding RMS encryption to the file.

Encrypt metadata – encrypts the metadata when encrypting PDF documents.

**Security**

- **Protected View**

  To protect your computer from files originating from the Internet or other potentially unsafe locations, turn on **Protected View** to open these files to reduce risks. In Protected View, files are read only and most editing actions are not allowed.

- **Privileged Locations**

  Some professional documents contain complex elements like interactive form fields, multimedia content, attachments, and layering. These elements may leave PDFs vulnerable to malicious actions and threaten data security. Foxit PhantomPDF enables users to specify privileged locations to selectively trust files, folders and hosts in order to bypass security restrictions.

**Signature**

- **Appearance Styles:** Manage the signature appearance templates.
- **Signing & Verifications**

  A. **Verify signatures when the document is opened:** If this option is checked, Foxit PhantomPDF will verify the signatures when the document is opened, and will display the signature verification results in the Digital Signatures panel. By default, the option is checked.

  B. **Sign the document immediately after the signature is placed:** Check this option to sign the document immediately when you place the signature on the document. By default, this option is checked. When it is unchecked, you will need to click **Sign Document** to apply the signature after placing it on the document. You can still modify the document before applying the signature.

  C. **Require certificate revocation checking to succeed whenever possible during signature verification:** Specify whether or not to check the revocation status of certificates while verifying signatures.

- **Windows Integration**
Specify whether to trust all root certificates in the Windows Certificate Store when validating signatures and certified documents. Checking these options may compromise security. Please make sure that you trust all the root certificates before enabling these features.

- **Saving Settings**

  Save signed file as a copy named ‘filename_signed.pdf’: Check this option to save the signed file as a copy named ‘filename_signed.pdf’ after applying the digital signature.

**Speech**

- **Volume**: Sets the reading volume of Read out Loud.
- **Use default voice**: Check it to read content with default language, or you can select the required one from the combo box.
- **Use default speech attribute**: Check it to read with default pitch and rate, or you can uncheck it and then set pitch and rate in the combo box as needed.
- **Read comments**: Check it to enable the application to read out the comments when executing Read out Loud.
- **Read form fields**: Check it to enable the application to read out the form fields when executing Read out Loud. Please refer to [Read PDF Form Fields Out Loud](#) for details.

**Spelling**

- **Enable check spelling**: Check **Enable check spelling** to avoid spelling error.
- **Dictionaries for Spell Check**: Add, remove, or reorder the dictionaries for spell check.

**Tablet**

- **Enable pressure sensitive**: Enable pressure sensitive so that you can add free-form annotations with PSI in PDFs by supported touchscreen devices.

**Time Stamp Servers**

Configure the default Time Stamp Server to embed a trusted time stamp while signing.

**Trust Manager**

You can enable or disable JavaScript Actions, Safe Reading Mode, Internet access, as well as other relevant settings as needed. Foxit PhantomPDF will show a warning message when applications without valid digital signatures open Foxit PhantomPDF. You can add safe applications to the trusted application list to not show the warnings.
Updater

- Automatically install updates: The system will automatically download and replace the original files in the installation folder when there is a new version.
- Automatically download updates, but let me choose when to install them (recommended): The system will automatically download and display a message informing you of the upgrade and allow you to choose to upgrade to the new version. This option is checked by default.
- Do not download or install updates automatically: Never download or install updates automatically.
Chapter 3 – Read

After getting acquainted with the workspace and the basic tools, you can start the journey of PDF reading. You can open a PDF, reach a specific page easily, adjust the view of a document, read pure texts by the text viewer tool, view documents while listening to them, and more. Foxit PhantomPDF also provides a new feature to view PDF portfolios.

Open PDFs

Open PDFs in Foxit PhantomPDF

You can open PDFs within Foxit Phantom in many different ways. The easiest method is to drag and drop a PDF file into the Foxit PhantomPDF window. You can also use Foxit PhantomPDF’s Open command to open a recent document, local document, or PDFs in your SharePoint, OneDrive for Personal or Business, Google Drive, Dropbox, and Box cloud services.

To open PDFs with the Open command, do one of the following:

1. Click the Open button on the Quick Access toolbar. In the Open dialog box, select the file name, and click Open. PDF documents are usually identified with a .pdf extension.
2. (Optional) You are also allowed to preview non-PDF files on the above-mentioned cloud services in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.
3. Click File > Open. To open a recent document or a document stored in the local drive, click Recent Documents/Computer. To open PDFs in ECM systems like SharePoint, OpenText, NetDocuments, iManage Work, and PDFs in cloud drives including Egnyte, OneDrive for Personal or Business, Google Drive, Dropbox, or Box, please select Add a place, sign into your account, and then you can open your PDF file. The connected Cloud account will be listed in the Open history and the PDF file will be in the Recent Documents list, which will help you open files quickly in the future. To remove an account, just click the Delete icon that appears when you place your cursor over the account name.

Tip:

1. If you need to pin a frequently-opened document to the top of the Recent Documents list, click the Pin icon that appears when you hover the cursor over the document name. Likewise, click the Unpin icon to unpin the document from the top of the Recently Used Documents list. You can pin and unpin frequently-opened folders under the local drives, OneDrive for Personal or Business, Google Drive, SharePoint, Dropbox, or Box, to the Recent Folders list.
2. To customize the number of documents or folders in the recently used list, please navigate to File > Preferences > History.
Open PDFs from Desktop or within Other Applications

If you set Foxit PhantomPDF as your default viewer for PDF files, you are able to launch and open PDF files in the following applications:

- **Email Application**: in your email applications, you can double-click the attachment icon to open the document.
- **Web Application**: you can open a PDF document by clicking on the PDF file link in your web browser. Also, you can view the PDF content embedded in the HTML. For security purposes, if you try to open an RMS-protected PDF file in your web browser, the file will be opened in the stand-alone Foxit PhantomPDF (desktop application) outside the browser.
- **File System**: double-click the PDF file icon in your file system.

Open a secured PDF document

If you receive a PDF that is protected by security features, you may need a password to open the document. Some protected documents have other restrictions that prevent you from printing, editing, copying, etc.

- When opening a protected PDF, you will be prompted to enter the password.
- When trying to copy or edit a secured PDF, you will be notified that you are prohibited to do it without the owner’s permission.
- If you open a PDF that is encrypted by AD RMS feature of PhantomPDF, please refer to [AD RMS Protection](#).

Save PDFs

After modifying your PDF, you can save the changes to the original PDF or save as a new copy of a PDF. You can also save PDFs as HTML, RTF, TXT and Microsoft Office files. Foxit PhantomPDF enables you to save your PDFs in SharePoint, OneDrive for Personal or Business, Google Drive, Dropbox, and Box, as well as to local drives. When saving or saving as PDFs, Foxit PhantomPDF will optimize PDFs by removing redundant data including deleted pages, objects, and annotations.

*Tip: By default, Foxit PhantomPDF saves the changes to a file every 5 minutes automatically in case of system crash or power failure. If the application closes abnormally before you can save changes to a file, PhantomPDF opens the recovery file automatically the next time you open it. The recovery file contains your changes up until the last time PhantomPDF saved the document. You can change the time interval settings in Preferences > Documents > Save Setting > Automatically save file every x minutes.*
Save a copy of a PDF

1. Select File > Save As.
2. In the Save As dialog box, enter the filename and location, and click Save.

Save a PDF as a HTML, RTF, TXT, or Microsoft Office File

1. Select File > Save As.
2. Specify the filename and location in the Save As dialog box.
3. Choose a format from the Save as type list and click Save.

Save PDFs in SharePoint, Egnyte, OneDrive for Personal or Business,

Google Drive, Dropbox, or Box

Click File > Save As > Add a place > SharePoint/Egnyte/OneDrive for Personal or Business/Google Drive/Dropbox/Box, then sign in your account and choose a folder to save to. The account will be listed in the Save-as history for your convenience. Click the Delete icon near the account name to remove the account from the list.

Tip:
1. You can also pin the frequently-used folder under local drives, OneDrive for Personal or Business, Google Drive, SharePoint, Dropbox, or Box to the Recent Folders list or unpin it, which allows you to save your documents with just one click.
2. To customize the number of documents or folders in the recently used list, please navigate to File > Preferences > History.

Close a PDF

Close the current PDF file by doing any of the following:

- Click the file’s Close button in the tab bar.
- Double-click the tab. (Tip: You can also disable this option in File > Preferences > General.)
- Click File > Close.
- Click the Close button on the Foxit PhantomPDF application window if you are in single document interface mode.

To close all PDF files in multi-tab browsing, click the Close button on the Foxit PhantomPDF application window.

Tip: Right-click a file tab in the tab bar, and choose Open Containing Folder to open the directory of the file, or choose Copy Path to Clipboard to copy the file path to the clipboard.
Export PDFs

Export PDF to Office, RTF, Excel, PPT or HTML files

1. Click File/Convert > Export. *(Tip: You can also export it through File > Save As.)*
2. Select the format you want to convert the PDF to, and specify the file name and location.
3. (Optional) You can select options from “Settings” in the Save As dialog box before saving the file.
4. Click Save.

*Note:* To convert a PDF to Word, you can directly right-click the file and choose Convert to Microsoft Office with Foxit PhantomPDF.

Export PDF to accessible text

If the document is an accessible PDF, you can save it as accessible text which can contain assistive information (such as alternate text descriptions) for images or multimedia objects in the PDF. Accessible text is often used for a braille printer by which accessible text can be imported and printed out as a form that vision-impaired people can use.

To export PDF to accessible text,

1. Click File/Convert > Export > To Other > To Accessible Text. *(Tip: You can also export it through File > Save As.)*
2. Specify the file name and location.
3. Click Save.

Export a PDF as an image

1. Click File/Convert > Export > To Image > Select a file type of images. *(Tip: You can also export it through File > Save As.)*
2. Specify the page range (all pages, current page, a range of pages), and click OK.
3. You can set the quality, color space, and resolution from “Settings” in the Save As dialog box before you save the file. Click OK to continue.
4. Specify the location, and click Save.

Export all images in the PDFs

With one click of “Export All Images”, Foxit PhantomPDF enables you to export all images in your document to separate image files. Please click Convert > Export > Export All Images, choose an
image format, and configure the settings before exporting via the Export to Images dialog box.

See also the tutorial on Export PDF to Word & Other Formats.

Export Selected Area to Other Formats

You can also select an area in PDF and export the content in the area to formats including Microsoft Word, Excel, and PowerPoint.

1. Click Convert > Export > Export Selected Area.
2. Click and drag an area in your PDF you want export. Then right-click the selected area and choose Export Selection As....
3. In the pop-up Save As dialog box, choose the file format you want to export to, and specify the filename and location.
4. (Optional) To export the comments in the selected area, check Include Comments. The option is not available when you export the area to an Excel file.
5. Click Save.

Integrate with IFilter

Foxit PhantomPDF is now integrated and packaged together with Foxit PDF IFilter—Desktop, which allows users to index a large amount of PDF documents and then quickly find text within these documents on the desktop system. You can trigger Foxit PDF IFilter in the installation directory of Foxit PhantomPDF. For more information, please refer to the user manual for Foxit PDF IFilter.

Note:

1. If you are in Safe Reading Mode, a dialog box will pop up when you are trying to open an attached file. Check Disable Safe Reading Mode and Open file, and then double click the File Attachment icon to open the attached user manual for Foxit PDF IFilter.
2. If Foxit PDF IFilter didn’t appear in PhantomPDF installation setup, you need to go to Help > Check for Update to download and install Foxit PDF IFilter; or after downloading the Foxit PDF IFilter plugin from the Foxit website, click Help > Install Update to install it.

Industry Standard Validation and Creation

With the Industry Standard command in Foxit PhantomPDF, you can specify the PDF's standards
for specific industries and functions. Foxit PhantomPDF has PDF/A, PDF/E and PDF/X compliance validation and creation to meet industry standards. Select Convert > Compliance > Industry Standard, then select one of the industry standards, and then click Analyze or Analyze and Fix in the pop-up dialog box. You can also create standard compliant PDFs by saving them as PDF/X, PDF/A or PDF/E. (Business Edition Only)

**View PDFs**

Foxit PhantomPDF enables you to retrieve recently opened documents, as well as read PDF documents in different view settings: multi-tab reading and single document reading.

**Multi-tab Reading & Single Document Reading**

**Multi-tab Reading**

The multi-tab browsing feature enables you to open multiple files in a single instance. Newly opened PDFs will be displayed in tabs.

To enable tabbed browsing, go to File > Preferences > Documents > Open Setting > uncheck Allow Multiple Instances.

**Single Document Reading**

Create a new window when you double-click to open a new PDF file.

- To enable single document interface mode, go to File > Preferences > Documents > Open Setting > check Allow Multiple Instances.

**Page through a document**

Open a PDF document with Foxit PhantomPDF, and you can then start viewing PDFs by scrolling throughout the entire document with your mouse vertically, or by holding Shift to scroll horizontally. You can also page through a document by the following methods.

**Scroll through Documents**

Do either of the following:

- **Using mouse actions or keystrokes**
  - To navigate around the documents vertically, scroll the mouse wheel or press the Down
or Up Arrows on the keyboard.

- To navigate around the document horizontally, press Shift and scroll the mouse wheel.

While scrolling in a document, you can lock the scroll direction to prevent the document from being scrolled out of place, especially when the document is zoomed in and scrolled within tablets. The steps are as follows:

- Choose **File > Preferences > General**, and check the **Show scroll lock button** option under the Status Bar to enable scroll lock. Once enabled, the scroll lock icons will be displayed in the Status Bar.

- Click  on the Status Bar to lock the scroll horizontally.

- Click  on the Status Bar to lock the scroll vertically.

- Click both  and  on the Status Bar to freeze the screen so that you can read the current view of the document.

**Scroll automatically**

Automatic scrolling allows users to view documents without using mouse actions or keystrokes. Foxit PhantomPDF also enables you to change the scrolling speed with ease.

A. Choose **View > Assistant > AutoScroll**.

B. Do one of the following:

- To increase or decrease the scrolling speed, press the Up Arrow or Down Arrow key, depending on the direction of scrolling. To change the scrolling speed to a specific speed, press a number key (9 for the fastest, 0 for the slowest).
- To reverse the direction of scrolling, press the minus sign (-) key.
- To jump to the next or previous page, press the Right Arrow key or Left Arrow key respectively.
- To stop automatic scrolling and go back to Hand Command mode, click  again or press the Esc key.
- To pause automatic scrolling, press the Space key.

**Tip:** To perform auto-scrolling, you can also click the Hand Command , hold the middle mouse button/wheel mouse button down, and then move the mouse to scroll the pages. You
Go to Specified Page

Click the First Page, Last Page, Previous Page and Next Page buttons in the Go To group under the View tab, which is also located in the status bar. You can also input the page number to go to that specific page. Previous View lets you return to the previous viewed instance and Next View goes to the next viewed instance.

Read with Bookmark

To jump to a topic using bookmarks, click the Bookmark button on the left Navigation pane. And then click the bookmark or right-click the bookmark and choose “Go to Bookmark”. Click the plus (+) or minus (-) signs to expand or collapse the bookmark contents.

Read with Page Thumbnail

To jump to a page with page thumbnails, click the Page Thumbnails button on the left Navigation pane and click its thumbnail. To move to another location on the current page, drag and move the red box in the thumbnail. To resize a page thumbnail, right-click on the thumbnail and choose “Enlarge Page Thumbnails” or “Reduce Page Thumbnails”.

View PDF Portfolios

PDF portfolios are a combination of files with different formats such as Word Office files, text documents and Excel files. Foxit PhantomPDF provides viewing and printing PDF portfolios, as well as searching keywords in PDFs in the portfolio.
A Sample PDF Portfolio

- Open a PDF portfolio in Foxit PhantomPDF by right-clicking it and choosing “Open with Foxit PhantomPDF”.
- You can view the coversheet, details and layout of the portfolio. To open and read the files in the portfolio, please do any of the following:
  - Double-click a file.
  - Select a file and click button in the upper right corner of the document area.
  - Right-click a file and choose Open File in Native Application.
- Click Portfolio > View > Preview Pane > Right/Bottom, and the document area will be divided into two parts: the original area that displays the portfolio content, and a preview pane which allows you to preview the corresponding content when you click and choose a file.
- Click Portfolio > View > Default View > Retain Original/Layout/Details/Cover Sheet to set the default view for PDF portfolios.
- Right-click a document in the portfolio and choose Show Information or click the button in the upper right corner of the document area to view the properties of the document.
- Search in portfolio by typing keywords in Search box or using shortcut keys CTRL+ Shift + F.
Search & Index in PDFs

Find Text

To quickly find text you are looking for, follow the steps below:

- Select the Find Field on the menu bar. Click to set the search criteria.
  - Whole words only -- limits the search to match only whole words. For example, if you search for the word Read, the word Reader will not be found.
  - Case-Sensitive -- makes the search case-sensitive. For example, if you search for the word text, the words Text and TEXT will not be found.
  - Include Bookmarks -- enables you to search for a word in the whole text, including bookmarks.
  - Include Comments -- enables you to search for a word in the whole text, including comments.
  - Include Form Data -- enables you to search for a word in the whole text, including form data.
  - Properties -- enables you to specify the color and opacity of the highlighting of the search results.

- Type the text in the field and press the Enter button. Foxit PhantomPDF jumps to the first instance of the search term, which appears highlighted.

- Click and or press shortcut keys Shift+F3 and F3 to find previous or next result, or press Enter to find the next result.

Foxit PhantomPDF supports the advanced search function, which enables you to do the following: search a string in a single PDF file, multiple PDF files under a specified folder, or PDFs in a PDF portfolio. When the search finishes, all occurrences will be listed in a tree view. This will allow you to quickly preview the context and jump to specific locations. You can also save the search results as a CSV or PDF file for further reference.

To do the advanced searching, do as below:

- Click the search button, and choose Advanced Search. Select a document or folder you want to search in the Search Panel. Then in the Searching box, type the text you want to search for and click the button to set the search criteria. See also Search Criteria.

- (Optional) Check the item Patterns to search for a pattern. You can include form data and comments in the search. Choose Country based on the file you are using.
Click **Search** button. Foxit PhantomPDF jumps to the first instance of the search term, which appears highlighted. And all occurrences will be listed in a tree view, allowing you to preview the contexts and jump to specific locations quickly.

(Optional) Click the save button in the **Search** panel, and choose **Save results to PDF** or **Save results to CSV** to save the search results.

Press **New Search** in the search panel to start a new search or press the close button in the top of the search panel to finish the search.

*Note: To find or edit text in a scanned or image-based PDF, you need to convert the content into searchable or editable text using the OCR feature. See also [OCR PDFs](#).*

**Move and Resize Search Box**

The advanced search box can float or be docked. You can also resize the box with ease.

- To float the docked search box, please double-click the title bar.
- To move the floating search box, drag it by its title bar to another location in the work area.
- To resize the search box, drag any corner point to adjust.
- To dock the floating search box, double-click on the title bar.

**Adjust Page View**

Foxit PhantomPDF provides multiple commands that help you adjust the view of your PDF documents, such as the page magnification and the display of pages.

**Adjust Page Magnification**

Do one of the following procedures:

1. Click the **Zoom In** command or **Zoom Out** command in **Home > View**.
2. Right-click the document pane and select **Zoom In** or **Zoom Out**.
3. Select or input a magnification percentage in the **Zoom To Area** on the same tab.
4. Adjust a magnification percentage in the **Magnification Percentage Area** on the status bar.
5. Using the **Marquee** command
   - Choose the **Marquee** command in **View > Assistant**.
The cursor changes into \[ \text{\textcircled{}} \], drag a rectangle on the page or just click on the page to increase the magnification by one preset level, centering on the point where you clicked.

Choose the Marquee command, the cursor changes to \[ \text{\textcircled{}} \] as Ctrl-click on the page. Drag a rectangle on the page or just click on the page to decrease the magnification.

6. Using the Loupe command

- Choose the Loupe command \[ \text{\textcircled{}} \] in View > Assistant.
- Move the Loupe command to the places you want to view, you will see the amplificatory or decreased objects in the Loupe Tool dialog box.
- (Optional) Select the Lock option in the Loupe Tool dialog box. Click the area of the document you want to view in closer detail. A red rectangle appears in the document, corresponding to the area shown in the Loupe Tool window. You can drag or resize the rectangle to change the Loupe command view.
- To change the scale ratio of the Loupe Tool, you can either enter a value in the zoom text box, or drag the slider in the Loupe Tool dialog box.

7. Using the Magnifier command

You can easily magnify areas of the PDF files as you work on Foxit PhantomPDF with this free command. It is especially useful for visually impaired people with some functional vision.

- Choose the Magnifier \[ \text{\textcircled{}} \] in View > Assistant > Magnifier.
- Move the Magnifier to the places you want to view.
- To switch between Magnifier and Fisheye Magnifier, press the left mouse button.
- To change the size of magnifier window, press the right mouse button.
- To turn off the Magnifier, choose any other commands.

Resizing a Page to Fit the Window

There are four types for you to choose:
To resize the page to fit entirely in the document pane, click the **Fit Page** button in **Home > View**, or right-click the Document Pane and choose **Fit Page**.

To resize the page to fit the width of the window, click the **Fit Width** button in **Home > View**, or right-click the Document Pane and choose **Fit Width**. Part of the page may be out of view.

To resize the page to its actual size, click the **Actual Size** button in **Home > View**, or right-click the Document Pane and choose **Actual Size**.

To resize the page to fit the visible width of the window, removing the margins, click the **Fit Visible** button in **Home > View**.

**Adjust the Page Display**

To change the page orientation, do one of the following:

- Click the **Rotate View** button in **View > Page Display**.
- Click the **Rotate Left** button or the **Rotate Right** button in **Home > View**.
- Right-click the document pane and choose the **Rotate Right** command.

*Note: You can change the page view in 90-degree increments, but the change only affects screen display instead of its actual orientation. You cannot save the changes in page view.*

To change the page layout, Foxit PhantomPDF provides the following page layouts:

- **Single Page** - Displays one page in the document pane at a time.
- **Continuous** - Arranges the pages in the document pane in a continuous vertical column.
- **Facing** - Arranges the pages side by side, displaying only two pages at a time.
- **Continuous Facing** - Arranges the pages side by side in a continuous vertical column.
- **Show Cover Page During Facing** - If a document has more than two pages, the first page can be displayed alone on the right side of the document pane in **Facing** and **Continuous Facing** views.
- **Split** - View a PDF with the document pane divided into two panes (Vertically/Horizontally Split command) or four panes (Spreadsheet Split command).

**Note:** To revert back to single-pane view, choose **View > deselect Vertically/Horizontally/Spreadsheet Split**.

With the Vertically/Horizontally Split view, you can scroll, change the magnification level, or turn to different pages in the active pane, as it will not change the other panes (above or below it).

The Spreadsheet Split view is useful if you want to keep column headings and row labels visible while scrolling through a large spreadsheet or table. In this mode, changing the magnification in one pane changes the magnification in all panes. Also, scrolling is coordinated between the panes. Scrolling a pane horizontally scrolls the pane above or below it; scrolling vertically also scrolls the pane to the left or right of that pane.

**View Mode**

**Read Mode**

User interface settings, such as the navigation pane, toolbar, and status bar, will be hidden when a PDF is displayed in Read Mode. The document pane is enlarged, reducing wasted reading space while leaving the menu bar available for necessary operations.

To view a document in Read Mode, please choose one of the following:

- Click the **Read Mode** button in **View > Document Views**.
- Press the shortcut key “Ctrl + H” on the keyboard.
- Right-click the document pane and select **Read Mode**.

In Read Mode, a basic toolbar will float when the cursor is put at the bottom of the screen or when you scroll through the document by dragging the slider. This offers basic commands, such as save, print, zoom in/out, etc.

If you open multiple PDFs, please press “Ctrl + Tab” on the keyboard to switch through them in Read Mode.

To exit the Read Mode, please do any of the following:

- Click the **Read Mode** button in **View > Document Views**.
- Press the shortcut key “Ctrl + H” on the keyboard.
- Click the **Read Mode** button on the floating basic toolbar at the bottom of the screen.
Full Screen Mode

In Full Screen mode, Foxit PhantomPDF Document Pane fills the entire screen, with Menu Bar, Toolbar, Status bar, and Bookmarks pane hidden behind. The mouse pointer remains active in Full Screen mode so that you can click links.

1. To set Full Screen preferences, please go to File > Preferences > Full Screen.
2. To enter Full Screen mode, please do one of the following:
   - Right-click the Document Pane and select Full Screen.
   - Press the shortcut key F11.
3. To adjust the view in Full Screen mode, right-click the document and work with the Context Menu.

   **Note:** This feature will not be available unless you clear Left click to go forward one page; right click to go back one page checkbox in the Preference > Full Screen.

4. To exit Full Screen mode:
   - Press Esc key.
   - Press the shortcut key F11.
5. Page Transition in Full Screen

Foxit PhantomPDF supports page transition to turn pages in Full Screen mode. It helps you to turn pages as the transition feature in Microsoft Power Point. There are 10 transition types: Split, Blinds, Box, Wipe, Dissolve, Glitter, Push, Cover, Uncover and Fade. Also, you could set the direction, speed and page range for the transition.

To edit page transition, click the Page Transitions in View > Page Display.

**Note:**

- This change only works for the current PDF.
- The pages will be turned in the same way the next time you open and view the document in full screen mode.
- If you want to set page transition to all PDF documents opened by Foxit PhantomPDF, please choose File > Preferences > Full Screen.
Reverse View

To read documents in a backward order, please do one of the following:

• Choose View > Document Views > Reverse View.
• Right-click on the document pane and choose Reverse View.

Text Viewer

With Foxit Text Viewer, you can work on all PDF documents in pure text view mode. It allows you to easily reuse the texts scattered among images and tables, and acts like Notepad. Also, you can adjust some settings to meet your needs.

To Enter Text View mode, do one of the following:

• Choose View > Document Views > Text Viewer.
• Press the shortcut key Ctrl + 6.

△ Customizing Text Viewer

As soon as Text Viewer is activated, you can use the Font Setting commands to customize your own work area. Right-click the text area to select Font Setting.

1. To change text font when reading with Text Viewer

• Right-click and choose Font Setting > Font....
• Choose Font name, Font Style, Font Size, Effects, Color and Script from respective fields in Font dialog box. The suggested font for best screen display is Courier New.

2. Toggle between regular style and Bold style, choose Font Setting > Bold.

3. Toggle between regular style and Italic style, choose Font Setting > Italic.

4. Change the text color and the background color

• Right-click and choose Font Setting > Color....
• Text Viewer Colors dialog box pops up.
• Drag respective sliders or type the value to change the Foreground (Font) Color and Background (page) Color. You can preview the changes in the box with a word “Sample”.
• Click OK to complete the procedure, or click Cancel to abandon the changes.

5. Change Text Viewer settings
Right click the text area > select Setting…
The text Viewer Settings dialog box pops up.
Below are the text viewer settings:

A. Set page width at three different levels: Current page width, Current document width and System default width.
B. Minimal width – the valid value for this field is 0-1024. It is set to 78 by default.
C. Keep Column – for PDF tables or text columns, you can check Keep Column to retain appropriate column in text viewer mode. It is checked by default.
D. Auto Width – for PDF tables or text columns, you can check Auto Width to keep proper width between texts automatically. It is checked by default.
E. Auto Rotate – you can check Auto Rotate to ensure consistent orientation with that of the printer. It is checked by default.

✧ Navigating in text viewer mode

1. To go to next or previous page, do one of the following:

   • Choose View > Go To > Previous Page or Next Page.
   • Click the Previous Page icon or Next Page icon on the Status Bar.
   • Put the cursor in the Document pane, press the Left or Right Arrow on keyboard to move the pages up or down.

2. To go to the first or last page, do one of the following:

   • Choose View > Go To > First Page or Last Page.
   • Click the First Page or Last Page icon on the Status Bar.
   • Press the Home or End keys.

3. To go to a specific page, do one of the following:

   • Choose View > Go To > input the specific page number > press Enter.
   • Input or select the specific page number on the Current Page Number Box on Status Bar, and press Enter.

✧ Changing the magnification level of a document

Do one of the following procedures:
1. Click the **Zoom Out** button or the **Zoom In** button on the status bar.

2. Choose **Home > View > Zoom In** or **Zoom Out**.

*Note: The Zoom To box is unavailable in Text Viewer mode.*

**Finding text in Text Viewer mode**

To find text you are looking for, please refer to **Find Text**.

**Copying and pasting text in Text Viewer mode**

1. Select text
   - Select a word: Double-click the word you want to select.
   - Select a line of text: Click and drag the cursor on the line of text you want to select.
   - Select all the text: Press **Ctrl + A** or right-click the Document Pane > choose **Select All**.

2. Copying text, do one of the following:
   - Right-click the selected text > choose **Copy**.
   - Select the text and then press shortcut key **Ctrl + C**.

3. Pasting text

To paste the selected text on Clipboard to another application, please follow the paste command of the specific application.

**Read Out Loud**

**What’s Read Out Loud?**

Read Out Loud is a Text-to-Speech (TTS) tool. It reads the text in a PDF aloud, including the text in comments and alternate text descriptions for images and fillable fields. Text is read based on the order of the page content. With this feature, you can obtain information without viewing the pages, helping to effectively relief eyestrain. It also enables you to view other materials while listening to the content.

Read Out Loud uses the available voices installed on your system. If you have SAPI 5 voices installed from text-to-speech or language applications, you can choose them to read your PDFs.

*Note: Read Out Loud isn’t a screen reader, it may not be available in some operating systems.*
Set Reading and Speech Preferences

Please go to File > Preferences > Reading or Speech. For more information, please refer to Reading preferences and Speech preferences.

Activate or deactivate Read Out Loud

You need to activate Read Out Loud before using it.

- To activate Read Out Loud: select View > Assistant > Read > Activate Read.
- To deactivate Read Out Loud: select View > Assistant > Read > Deactivate Read.

Tip: You can press the shortcut key Ctrl + Shift + Y to activate or deactivate Read Out Loud, based on the current status of the feature. After activating Read Out Loud, you can read a PDF file and PDF form field out loud.

Read a PDF Out Loud

- Navigate to the page that you want to read out.
- Choose View > Assistant > Read > Read Current Page or Read from Current Page.

Tips:

1. If you need to read the text in the comments while reading a PDF out loud, please make sure you have checked Read comments option in the Speech preferences.

2. When you try to read an image-based PDF document out loud, Foxit PhantomPDF will prompt you to run text recognition to make it searchable or editable. You can choose Yes and follow the steps in OCR PDFs to recognize text.

Read PDF Form Fields Out Loud

- Go to File > Preferences > Speech, and check Read form fields option.
- In the PDF form, press Tab to select the first form field that you want to read out loud, and then press Tab to move to the next form field. Foxit PhantomPDF will read out the form field as well as the state of selected check boxes and radio buttons.

Control Reading

While reading a PDF file or form field, you can interrupt the reading and adjust reading volume and speed as needed.

- To adjust the reading speed: choose View > Assistant > Rate > drag the slider.
- To adjust the reading volume: choose View > Assistant > Volume > drag the slider.
Rulers, Guides, Grids & Line Weights

Using Rulers & Guides

Foxit PhantomPDF provides horizontal and vertical ruler guides to help you align and position text, graphics or other objects on the page. They can also be used to check the size and margins of your documents.

To show or hide rulers/guides, select View > check or uncheck Rulers/Guides.

To create ruler guides, follow the steps below:

• Drag down the horizontal ruler to create a horizontal guide, or drag to the right of the vertical ruler to create a vertical guide.

• Double-click a location on the horizontal ruler to create a vertical guide, or double-click a location on the vertical ruler to create a horizontal guide.

To move ruler guides, select the Hand command, click and hold the guide, and then drag it to a new location.

To change the unit of measurement, right-click the horizontal ruler or the vertical ruler, and select a measurement system for the rulers.

To delete ruler guides, please do one of the following:

• To delete a guide, click the guide to select it, and then press the Delete key.

• To delete all guides on a certain page, scroll to the page, right-click the ruler area and choose
Clear Guides on Page.

- To delete all guides, right-click in the ruler area and choose Clear All Guides.

**Grids**

You can use grids to line up form fields in a PDF document. When you create or move a form field, Snap to Grid can align the form field with the nearest grid line.

To show or hide the grid, navigate to View > Page Display > and check/uncheck Grid.

To turn on or off the Snap to Grid option, navigate to View > Page Display > and check/uncheck Snap to Grid.

You can also customize the grid appearance from File > Preferences > Layout Grid.

**Line Weights View**

In Line Weights View, the lines will be displayed with the weights defined in the PDF file. When Line Weights View is turned off, the lines will be displayed with the constant stroke width (1 pixel), regardless of zoom. The following screenshots show the comparison of the PDF file displayed in Line Weights View and Non-Line Weights View.

- To enter Line Weights View, please choose View > Page Display, and then check Line Weights option.
- To exit Line Weights View, please choose View > Page Display, and then uncheck Line Weights option.

**Compare PDF Files**

The Document Compare feature lets you see the difference in two versions of a PDF, as well as
select the type of differences you’re looking for to verify that the appropriate changes have been made. The Document Compare feature does not compare comments in the PDF.

Comparing a revised PDF to an earlier version

• Choose View tab > Review > Compare.
• Specify the two documents to be compared. Click Choose... to select the file and choose the specific pages you want to compare by dragging the slider or clicking the list box to select the page number.
• Type of Comparison:
  Page by page visual differences – Compares by visual differences, including texts, images, annotations, etc.
  Textual differences – Compares texts only between the two documents, not including comments. Check Include font information (style, size, typeface) if needed. You can also set to highlight differences when documents differ by less than a percentage to easier find out the differences.
  Include page reassembled changes – If you check this option, the application will automatically ignore the textual differences if some of the pages were replaced, deleted, or inserted, and will indicate that the pages were replaced in the comparison result.
• You can preview pages after you check Show preview option. Choose the specific page you want to preview by dragging on the page range bar or select the page number by clicking the list box near the range bar.
• Click OK. And then a PDF document named “The result of Comparison.pdf*” will be automatically created and opened with PhantomPDF. The first page shows a summary of the comparison results and the differences will be classified with different colors.

View 3D Content in PDFs

Foxit PhantomPDF lets you view, navigate, and comment on 3D content in PDF documents. Before using these features, you need to download the plugin from Foxit Server and install it in Foxit PhantomPDF. The 3D Content Navigation panel, allows you to show/hide parts of a 3D model and add 3D comments to the 3D model, including text, linear, angular, and radial. You can also rotate/pan/zoom a 3D model in different views.

Show/hide parts of a 3D model

From the 3D Content Navigation panel, you can view the 3D scene structure and the preset views. Check/uncheck the appropriate checkbox to show/hide the corresponding part of the 3D content. Click on the Default view button to go to the initial view. Select the desired view name in the list to switch between preset named views.
Add a 3D comment/measurement to a 3D model

You can add a 3D comment/measurement to any part of a 3D model with the options on the 3D Content Navigation panel.

1. Select Add Comment on the 3D Content Navigation panel, and then put the cursor over the desired position and click to add a note comment. Then you’ll be prompted to enter a comment string in the pop-up dialog box.
2. (Optional) select Add Add Linear/Add Angular/Add Radial on the 3D Content Navigation panel, and then put the cursor over the desired position and click to add a measurement.
3. In the Default View, a new view will be created after you add a 3D comment/measurement, either called 3DCommentView1 or MeasurementView1, respectively. If added to other preset views, the 3D comments/measurements will be listed under that view.

Rotate, pan, and zoom a 3D model

You can directly use the mouse to rotate, pan, and zoom in/out a 3D model.

- Rotate – click the model, hold the left mouse button, and move the mouse.
- Pan – click the model, hold the left mouse button, and CTRL button, and move the mouse.
- Zoom – click the model, hold the right mouse button, and move the mouse. Or click the model, hold the left mouse button and SHIFT button, and move the mouse.

Select & Copy

With Foxit PhantomPDF, you can copy texts and images to other applications.

Select and Copy Text and Image

The Select Text and Image command lets you select horizontal and vertical text or columns of text, and image in a PDF. PhantomPDF sets each ribbon with the Hand command and Select commands for user’s convenience. To copy text or image, click the Select Text and Image command and do the following:

Select text and image

To select an image, please click on the image in a PDF file directly. To select text, please do any of the following:

- Select a word: Double-click the word you want to select.
Select a line of text: Drag the cursor \( \text{I} \) toward a line of text you want to select.

Select a column of text: Put the cursor between the lines and the cursor changes into \( \text{II} \). Then press Alt and drag the cursor toward a column of text you want to select.

Select text only in a rectangle box without images: Press Alt and drag a rectangle at the desired position you want to select.

Select multiple paragraphs through pages: Click at the start of the selection, scroll to the end of the selection without releasing your mouse.

Select all the text: Press Ctrl + A, or select some text, right-click it and then choose Select All.

Deselect all the text: Click any area of the text.

Copy text and image

After selecting the text or image, do one of the following:

- Right-click the selected text, and choose Copy to copy text with content stream order or choose Copy with Format to copy text with display order.
- Right-click the selected image, and choose Copy.
- Press shortcut key Ctrl + C.

Tip: The style (including font, bold, color, etc.) of the text will be copied to the clipboard as well when you copy text in PDF.

Paste text and image

To paste the selected text on Clipboard to PDF file, please select the Hand command \( \text{Hand} \) in Foxit PhantomPDF, use the shortcut key Ctrl + V, or right-click on the document where you want to paste the text and select Paste.

To paste the selected image on Clipboard to PDF file, please select the Hand command \( \text{Hand} \) in Foxit PhantomPDF, use the shortcut key Ctrl + V or right-click on the document and select Paste. You will see the image preview as you hover your mouse over the document. Then click on the document where you want to add the image to add it in the PDF file.

To paste the selected text or image on Clipboard to another application, please follow the paste command of the specific application.

Copy Content Using Snapshot Command

You can use the snapshot command \( \text{Snapshot} \) to copy individual images or selected content (text, images, or both) to the clipboard or other applications. Text and images will be copied as an
image.

To copy an image or a combination of text and images, do the following:

- Select the **SnapShot** command by choosing Home > **SnapShot**.
- The cursor changes into a Cross automatically.
- Click and drag the mouse to draw a rectangle around the content you want to copy.
- You will be prompted that the selected area has been copied to the clipboard. To deselect it, click anywhere on the page.
- (Optional) Right-click the selected area, and then choose **Copy Select Graphic**.
- Paste the selected image to desired destinations.

**Note:**

1. The selected area will be highlighted in blue.
2. With the snapshot command, click anywhere or right-click anywhere in the page and choose “Select All” to copy the entire page.
3. You can also copy the selected area and paste it to a PDF document as a stamp annotation.
4. To paste images or a combination of text and image on clipboard from another application to PDF file in Foxit PhantomPDF, please select the Hand command \( \text{Hand} \) in Foxit PhantomPDF, use the shortcut key Ctrl + V, or right-click on the document where you want to paste the object and select **Paste**.

**Word Count**

Similar to Microsoft Word, Foxit PhantomPDF counts words, characters, pages, lines and other information in all or part of your document. With no text selected, click View > Review > **Word Count**, and you will see a pop-up **Word Count** box for the statistics of the entire document. For a partial word count, just select the text you want to count, and then click View > Review > **Word Count**; or right click the selected text and choose **Word Count** from the context menu.

**Asian Languages**

If you try opening PDF files directly that contain Eastern Asian Languages such as Traditional and simplified Chinese, Japanese, and Korean, you can open them with Foxit PhantomPDF directly now. The add-on of Eastern Asian Language has been integrated into the Foxit PhantomPDF package, so you won’t be prompted to download and install the required language font kits. Foxit PhantomPDF lets you view, search, and print PDF documents with Asian language text.

**Note:** To update the Eastern Asian Language font kits, users still have to go to Help > Check for Update to download and Help > **Install Update** to install the updated version.
Chapter 4 – Create

Up to 3 times faster than other PDF tools, Foxit PhantomPDF makes creating PDF and PDF/A documents simple and streamlined. With a click you can quickly convert virtually any kind of file to PDF without having to open the source application.

Create a PDF in Different Ways

With Foxit PhantomPDF, you can easily create PDFs from files in other formats.

See also the tutorial on how to Create Industry-Standard PDFs.

One-click PDF Creation from Any File

Foxit PhantomPDF can create any kind of printable files to PDF simply by dragging the file into the program window; alternatively, you can use Foxit PhantomPDF to quickly convert files to PDF directly from within Windows® Explorer.

To create a PDF with one click:

- Drag the document you want to convert on to the Foxit PhantomPDF desktop icon.
- If the Foxit PhantomPDF is open, drag the file directly into the application window.
- Right-click the document icon you want to convert, and choose Convert to PDF in Foxit PhantomPDF. Or you can choose Combine files in Foxit PhantomPDF... to convert multiple files. See also Create PDFs from multiple files.

Tip: When right-clicking a folder, if you choose Convert to PDF in Foxit PhantomPDF, all files in the folder and the sub-folders will be converted to PDFs separately; if you choose Combine files in Foxit PhantomPDF..., you can add more files/folders and convert all of them to PDFs. See also Create PDFs from multiple files.

Create PDFs in the Foxit PhantomPDF Application Window

Create a PDF from a File

You can create a PDF from Office, email, a web site, or from any file that prints.

1. Launch Foxit PhantomPDF, choose File > Create > From File, or choose Convert > Create > From Files > From File.
2. In the **Open** dialog box, select a file. You can browse all file types when you select All Supported Files (*.xls, *.xlt, ...) from the File type menu.

3. Select a file you want to convert and click **Open** to convert the file to a PDF.

4. Type a filename and specify a location in the pop-up **Save** dialog box.

**Note:** Depending on the type of file being converted, a progress dialog box appears and Foxit PhantomPDF opens automatically.

---

### Create PDFs from multiple files

You can easily merge files of different types into a single PDF, or you can also convert them into separate PDFs.

#### Convert and combine multiple files into a single PDF

1. Choose **File > Create > Combine Files**, or choose **Convert > Create > Combine Files**, or right-click a file you want to convert to PDF and choose **Combine files in Foxit PhantomPDF**....

2. In the **Combine files into a single PDF** dialog box, click **Add files**, and choose **Add Files**, **Add Folder**, or **Add Open Files** to add files, folders or opened files you want to combine. (Tip: If you add a PDF portfolio, each file in the PDF portfolio will be extracted and added in the file list. By default, the files will be listed in an ascending order by the file name.)

3. (Optional) You can right-click any file in the dialog box and choose **Edit Bookmark for File** (or just double-click the file) and modify the bookmark title that will be one of the bookmarks in the combined PDF after conversion. By default, the bookmarks in the combined PDF are the names of each file.

4. (Optional) You can adjust the order of files to be displayed in the combined PDF by the files’ name, modified time, size, or bates numbering by clicking the corresponding column name. Click the column name again to reverse the order. (Note: To order by bates numbering, all files in the dialog box should be PDFs and use the same bates numbering formatting.) Or, adjust the order of files manually as desired by using **Move Up/Down**, or drag and drop a file to change the file order. Select a file and click the **Remove** button to delete it.

5. (Optional) When you select a Microsoft Word, PowerPoint, or PDF file, the button named “Choose Pages” appears next to the **Remove** button; if you select an Excel file, the “Choose Sheets” button appears. You can specify a page range or choose sheets to convert.

6. Check the following option as desired and click **Combine**:

   - **Add a new table of contents page converted from bookmarks**: creates a table of contents from the filenames of each file when merging multiple files into a single PDF file.
   - **Retain the logic page numbers during combination**: selects it, and the combined PDF file will keep the logic page numbers in the original files.
Tip: Foxit PhantomPDF uses original filename as a bookmark as default when combining multiple files into a single PDF.

Convert multiple files into separate PDF files

1. Choose File > Create > From Multiple Files, or choose Convert > Create > From Files > From Multiple Files.
2. In the Convert Multiple Files dialog box, click Add files, and choose Add Files or Add Folder to select the files or folder you want to convert.
3. Files will be converted in a sequence as they are ordered in the Convert Multiple Files dialog box. You can reorder the files by name, modified time, or size by clicking the corresponding column name. Alternatively, reorder the files manually as desired by clicking the Move Up/Down button, or by dragging and dropping the file in the list. Select a file and click the Remove button to delete it, if necessary.
4. (Optional) If you need to save the converted PDF files in the same location as the original file, check the Keep original file names and locations option.
5. Click Convert.
6. (Optional) If you did not check the Keep original file names and locations option, the Browse For Folder dialog box will pop up. Choose the folder in which you want to save the converted PDF files, and click OK.

Create a PDF from a blank page

You can create a PDF from a blank page rather than beginning with a file, a clipboard image, or scanning.

1. Choose File > Create > Blank, or choose Convert > Create > Blank.
2. Choose Edit > Edit Content > Add Text or Comment > Typewriter > Typewriter.
3. Click on the blank page to start typing the text you want to add to the blank page.
4. As needed, select other commands and options that you want to apply to the PDF.
5. Choose File > Save, and select a name and location for the PDF file.

Create a PDF from Clipboard

You can create a PDF directly from your clipboard.

1. Choose File > Create > From Clipboard, or choose Convert > Create > From Clipboard.
2. The texts or images in the clipboard will be converted to a new PDF file.

Convert a CAD file to a PDF (Business Only)

Foxit PhantomPDF allows users to convert .dwg and .dxf files to 2D or 3D PDF files.
1. Choose a type of PDF file you want to export in the Preferences of PhantomPDF.
2. Drag and drop the CAD file into the PhantomPDF application window or the desktop icon.
3. Click Save, and specify a name and location for the PDF.

Tip: Before using these features, you need to download the plugin from Foxit Server and install it in Foxit PhantomPDF.

**Create a PDF from Web Page**

To create PDF from web pages:

2. Input the URL of the web page in the box in the Create PDF From Web Page dialog box, or click Browse to choose an HTML file.
3. Click Settings to set more conversion options.
   - **The General tab:**
     - **Conversion Level:** specify the number of levels of the website to convert to PDF, or check Convert the entire site.
     - **Convert webpages on the same path:** convert the webpages subordinate to the input URL.
     - **Convert webpages on the same server:** convert the webpages stored on the same server.
     - **PDF Setting:** set the timeout to load the whole web page. Loading that takes longer will be aborted automatically, and only the loaded content will be converted to PDF. The default value is 120s.
     - **Disable all hyperlinks in the generated PDFs:** check this item, and all hyperlinks will be invalid in the generated PDF.
     - **Set all the page contents to one single PDF page:** check this item, and all the related content will be converted to one PDF page.
   - **The Page Layout tab:** specify the page size, margins and orientation for the generated PDF as needed.

To create PDF from a linked web page:

If your PDF document contains linked text which links to a web page, you can also convert the linked web page to PDF from within Foxit PhantomPDF application.

1. Make sure you have selected the Hand command.
2. Right-click on the linked text, and choose Open Weblink as New Document.
3. Then the linked web page will be converted to PDF and opened in Foxit PhantomPDF. You can click the save button to save it as desired.
Tip: While creating a PDF from a webpage which requires login, only the login page will be converted to PDF. For example, when you try to create a PDF from Foxit Support Ticket webpage (https://tickets.foxitsoftware.com/create.php) which requires you to log in to your Foxit Account, the contents in the login page will be converted to PDF (as shown below).

Create a PDF form from an existing file

You can create a PDF form directly from an existing file during which Foxit PhantomPDF will detect and recognize the form fields automatically, with no need to use the Run Form Field Recognition command.

1. Choose File > Create > Form > From a file, or choose Convert > Create > Form > From a file.
2. Choose a file in the pop-up dialog box.
3. A PDF with form fields if any is created and opened with Foxit PhantomPDF.
4. Specify the file name and save path.

Create PDFs in Microsoft Word, Excel and PowerPoint

Foxit PhantomPDF enables you to create professional and secure PDF files from Microsoft Office (Word, Excel and PowerPoint and Outlook), automatically keeping bookmarks, links, hyperlinks, outline and more of the source files in the created PDF.

In Microsoft Office 2007/2010/2013/2016, Foxit PhantomPDF appears as a tab, which allows you to quickly create PDF files and change your conversion settings in just a few clicks.
Create PDF

To create a PDF in Microsoft Word, Excel and PowerPoint, please do as below:

Open a file in Microsoft Word, Excel or PowerPoint, click the Foxit PDF tab and do one of the following:

- To create a PDF using the current settings, click the Create PDF button. Then enter the file name, specify the location and click Save.
- To create and email a PDF using the current settings, click Create PDF and Email. Then enter the file name, specify the location and click Save. The created PDF file will be attached to your mail system automatically for you to send out.
- To create a PDF and save it to SharePoint, click Create to SharePoint. Please refer to "Save the created PDF to SharePoint" for more information.
- To customize your PDF conversion settings before creating a PDF, check the desired options in the General Settings group.

View PDF Results – Once the conversion is finished, the converted PDF will be opened with PhantomPDF automatically. This option is checked by default.

Prompt for File Name – Before conversion, the PDF file will prompt you with a dialog box to name the file being created. This option is checked by default.

Preserve Document Properties – Keeps the document properties of the source file in the converted PDF during the conversion. This option is checked by default.

For more settings, click the Advanced button and the Foxit PhantomPDF Add-in dialog box pops up. Some options depend on the application in which you are using the add-in.

For the Settings tab:

Support PDF/A-1b Standard – Creates a PDF that is compliant with the PDF/A-1b standard.
Optimize for fast web view – Creates a linearized PDF that can be opened and viewed even before the whole file is downloaded.

Create Bookmark – In Word, keeps the bookmarks of the source file in the converted PDF; In Excel/PPT, the sheet name and the slide title (or the slide page number) will be converted to bookmarks in the generated PDF. This option is checked by default.

Save the created PDF to iManage – Create and save the PDF to iManage directly. This option is only available in the Microsoft Office (Microsoft Word, Excel, PowerPoint, and Visio) with Foxit PhamtomPDF add-in, on the condition that users have registered iManage Server within Foxit PhantomPDF.

Create to SharePoint – Create and save the PDF to SharePoint. If you check this option, “Create to SharePoint” button will be available in the Create PDF group under the FOXIT PDF tab.

Tagged PDF – Creates a tagged PDF for accessibility. *(Microsoft Office 2010 or a later version is required.)*

Page Range – Specifies a page range that you want to convert.

For the Watermarks, Headers/Footers, and Security tabs, please see Setting Foxit PhantomPDF Printer Properties. In the Security tab, you can add RMS protection. For instructions on how to add RMS protection, please refer to AD RMS Protection.

For the Bookmarks tab:

Convert Word headings to bookmarks in PDF – Check this option to convert all the headings in the Word document into bookmarks in the PDF document. You can deselect some headings that you don’t want converted in the heading list below.

Convert Word styles to bookmarks in PDF – Check this option to convert the selected text styles in the Element list to PDF bookmarks.

Element list – Specify which Word headings and styles are converted to PDF bookmarks. The Element list includes the following categories:

- **Element**: List the names of all available Word headings and styles.
- **Type**: Indicate the type of the element in the Word document, Heading or Style.
- **Level**: Specify the level of an element that fits in the hierarchy structure of the PDF bookmark. For the style elements, you can click on the Level number to change their levels.

Convert the bookmarks in Word to PDF bookmarks – Check this option to convert all the bookmarks in the Word document into bookmarks in the PDF document.
**Document Homepage**: If the current Word file was previously converted to a ConnectedPDF document, you can click the Document Homepage button to open the document homepage of the ConnectedPDF document. The document homepage will be opened in your default web browser, containing information of the attributes, version history, events, and connections associated with the ConnectedPDF document.

Each ConnectedPDF document carries a unique identity which can not only be tracked and shared without a server, but can also protected by Foxit’s Connected DRM. This type of control protects PDF documents in real time without any further operation and deployment. For more information about ConnectedPDF documents, please refer to ConnectedPDF.

**Tip:**

1. A Word file will carry a unique cDocID after being converted to a ConnectedPDF document via the Foxit plugin within Microsoft Word. If you want to remove the cDocID from the original Office file, click Remove ConnectedID in the FOXIT PDF tab.
2. Before creating a ConnectedPDF document with the Foxit plugin within Microsoft Word, go to File > Preferences > ConnectedPDF > check Automatically save PDF files in ConnectedPDF format in Foxit PhantomPDF. And you also need to sign in to your Foxit account so that you are the owner of the created ConnectedPDF document. If you didn’t check the Automatically save PDF files in ConnectedPDF format option, a normal PDF document will be created and the Document Homepage button will be greyed out and not available.

**Sign In**: You can sign in your Foxit account to directly create your own ConnectedPDF document. Before creation, you need to go to Preferences > ConnectedPDF > check Automatically convert Office files to Connected when converting to PDF via Office add-in.

**Create PDFs Using Word’s Mail Merge**

Foxit PhantomPDF allows you to convert personalized email messages, letters, or labels created from Microsoft Word’s Mail Merge function to PDFs all at once. You can also change the settings to send the PDFs via email attachments to a number of individuals if needed.

1. To create PDFs from Mail Merge, open the Word file and click Mail Merge in the Foxit PDF tab or click Merge to Foxit PDF in the MAILINGS tab. *(Note: The Word file must be a mail merge document before you merge them to PDFs. For information on how to create a mail merge document, please refer to Microsoft Word Help.)*
2. In the Mail Merge Settings dialog box, you can specify the set by a range of record numbers. Then specify the name of the PDFs by filling in the field for the file name or by choosing a field from the list of fields available in your data source. *(Note: If you type ReplyLetter in the Name box, the mail-merged PDFs will be named ReplyLetter1, ReplyLetter2, ReplyLetter3, and so on.)* Click OK to continue.
3. (Optional) If you need to email the created PDFs as attachments, check the **Automatically send PDF files by email** option and adjust the relevant settings as needed.

4. Specify a save path for the PDFs and click **OK**.

5. If you checked the **Automatically send PDF files by email** option, you will be prompted to choose an email profile. Click **OK** to send the PDF files.

6. A message box will pop up to prompt you if the process was successful.

### Create a redacted PDF *(Business Edition Only)*

The Foxit PhantomPDF plugin in Microsoft Word, PPT and Excel also enables users to quickly create a redacted PDF, which can be encrypted into an RMS-protected PDF as well. For a redacted and RMS-protected PDF, authorized users are granted access to view the full document while unauthorized users are only able to view the redacted document. PDF redaction permanently removes visible text and images from PDF documents to protect confidential information. This feature allows for improved sharing of non-sensitive information within a protected document.

To create a redacted PDF or a redacted and RMS-protected PDF, select the text you want to redact and click **Mark for Redaction**. Click the **Create Redacted** button and choose **Standard Redaction** to create a redacted PDF document, or choose **RMS Redaction** to create a redacted and RMS-protected PDF document. Then enter the file name, specify the location, and click **Save**.

For more detailed information about redaction and AD RMS integration, please refer to **Redaction** and **Template Creation and Editing**.

### Save the created PDF to SharePoint

You can create a PDF and save it in SharePoint using Foxit PhantomPDF add-on in Microsoft Word, Excel, and PowerPoint 2010 and higher versions.

1. Open a file in Microsoft Word, Excel or PowerPoint, and click the **FOXIT PDF** tab.

2. Click **Advanced** to make sure that you have checked the **Create to SharePoint** option so that “Create to SharePoint” button will be available in the **Create PDF** group under the **FOXIT PDF** tab.

3. Customize your conversion settings in **General Settings** group as needed. For more information, please refer to “**Conversion Settings in Microsoft Word**”.

4. Click **Create to SharePoint**, and do one of the following:
   - If the Microsoft Office document that you opened is saved in SharePoint, SharePoint repository will be displayed in the pop-up **Save As** dialog box. Choose a folder from current SharePoint repository, or click **Add SharePoint Site** to open a new SharePoint repository and select the location. *(Tip: You can right-click a folder and choose **Pin to list to pin the folder to the Pin list in the left panel.** Then specify the file name, and click **Save**.)*
   - If the Microsoft Office document you opened is saved in your local disk, input the SharePoint URL address and press **Enter** to open SharePoint repository in the **Save As** dialog box. Then specify the folder and file name, and click **Save**.

5. In the pop-up **Document Properties** dialog box, specify the **document properties**, and click...
Create PDFs or PDF Portfolios with Microsoft Outlook

You can quickly convert or combine .msg files (emails) into PDFs using the right-click menu with Foxit PhantomPDF installed. Right-click a message file, and choose Convert to PDF in Foxit PhantomPDF to convert the file to a new PDF; or choose Combine files in Foxit PhantomPDF... to convert multiple files. See also One-click PDF Creation from Any File.

Foxit PhantomPDF also adds a plugin in Microsoft Outlook when installed and appears as a tab entitled FOXIT PDF in the Outlook toolbar. The commands in the tab allow you to create a PDF file or PDF portfolio from the selected email message(s) or folder(s).

Microsoft Outlook 2013 Foxit PDF Tab

- To create a new PDF or PDF portfolio from the selected message(s), please select the message(s) you want to convert and click Selected Message > Create New PDF..., or right-click the selected message(s) and choose Convert to Foxit PDF. Then specify the name and the location of the created PDF or PDF portfolio to begin the conversion.

Note:

1) To create a new PDF portfolio, the Output PDF Portfolio option should be checked in General Settings group. Each message will be converted to a single PDF.

2) If the Output PDF Portfolio option is not checked, the selected message(s) will be merged into one continuous PDF according to the time of each message was sent or received, i.e. the latest message is on the first page.

3) The default name of the created PDF or PDF portfolio will be the title of the selected message or the folder name of the selected messages.

- To create a new PDF or PDF portfolio from the selected folder(s), please click Selected Folder > Create New PDF..., or right-click a folder and choose Convert to Foxit PDF. Select folders you want to convert in the pop-up Convert folder(s) to PDF dialog box. Then specify the name and the location of the created PDF or PDF portfolio to begin the conversion.

Note:
1) To create a new PDF portfolio, the **Output PDF Portfolio** option should be checked in **General Settings** group. Each message will be converted to a single PDF and then the created PDF will be put into corresponding folders in the portfolio.

2) If the **Output PDF Portfolio** option is not checked, all messages in the selected folders will be merged into one continuous PDF. If you create a PDF file from one folder, the latest email message will be arranged on the first pages of the created PDF file. If you create from multiple folders, the order is based on the order how each folder is displayed on the **Convert folder(s) to PDF** dialog box first and then the time each message was sent or received.

- To append to an existing PDF or PDF portfolio from the selected message(s), please select the message(s) you want to convert and click **Selected Message > Append to Existing PDF**..., or right-click the selected message(s) and choose **Append to Foxit PDF**. Select the existing PDF or PDF portfolio you want to append to and click **Open**. The selected message(s) will be appended to the end of the existing PDF. If the existing PDF is a PDF portfolio, the selected messages will be created to single PDF files and then put into corresponding folders in the existing PDF portfolio.

- To append to an existing PDF or PDF portfolio from the selected folder(s), please click **Selected Folder > Append to Existing PDF**..., or right-click a folder and choose **Append to Foxit PDF**. Select folders you want to convert in the pop-up **Convert folder(s) to PDF** dialog box. Select the existing PDF or PDF portfolio you want to append to and click **Open**. All messages of the selected folder(s) will be appended to the end of the existing PDF. If the existing PDF is a PDF portfolio, each message of the selected folders will be created to single PDF files and then put into corresponding folders in the existing PDF portfolio.

- To customize your PDF conversion settings before creating PDF, check desired options in **General Settings** group.
  - **View PDF Result** – Once the conversion finishes, the converted PDF will be opened with PhantomPDF automatically.
  - **Output PDF Portfolio** – Creates a new PDF portfolio from the selected email message(s) or folder(s) and keeps the folder information of the selected folders in the created PDF portfolio (i.e., the location path information of the folder in your email system). If you don’t want to keep the folder information during conversion, please click the **Advanced** button and uncheck **Convert folder information** option in the Settings tab. For instructions on how to modify a PDF portfolio, please refer to **Customize PDF Portfolios**.
  - **Include Attachment** – Keeps the attachments of the selected email messages or folders as the created PDF’s attachments, with the file types of the attachments unchanged.
  - **Support PDF/A-1b Standard** – Creates a PDF that is compliant with PDF/A-1b standard.

- For more settings, click **Advanced** button and a Foxit PhantomPDF Add-in dialog box pops up. You can add headers/footers, watermarks, security, etc. See also Setting Foxit PhantomPDF Printer Properties. In the Security tab, you can also add RMS protection. For instructions on how to add RMS protection, please refer to AD RMS Protection.
Foxit PhantomPDF supports automatic email archiving based on your settings. Click **Automatic Archival** and check **Enable Automatic Archival** in the pop-up Automatic Archival dialog box to do archival settings:

- Specify the frequency and the time of the day to do the automatic archiving.
- (Optional) Enable "Maintain Log of Archival" to create a record for each archiving. Click Choose File ... to name the log file and specify its storage location.
- In **Choose Folders for Automatic Archival** box, click **Add** to select email folders you need to archive and specify the name (Check the box for **Append the archive date to the specified archive file name** so that the older archived files will not be overwritten) and location of the archived email PDF. You can also click **Delete** to remove folders from the list or click **Change Archive File**... to modify the name and location of the archived email PDF.
- (Optional) You can start archiving email right after you choose the folders for automatic archival by clicking **Run Archival Now** button in the top right corner of the Automatic Archival dialog box.
- Click **OK** to complete setting.

**Note:** All archived email PDFs are PDF portfolios.

**Sign In:** You can sign in your Foxit account to directly create your own ConnectedPDF document. Before creation, you need to go to **Preferences > ConnectedPDF > check Automatically convert Office files to Connected when converting to PDF via Office add-in.**

With Foxit PhantomPDF installed, you can quickly convert a file to a PDF and send it with Microsoft Outlook.

1. Create a new email, and click the **Foxit PDF** tab in the Outlook ribbon.
2. Click **Attach as Foxit PDF**, a dialog box pops up for you to choose a file, and click **Open**.
3. Specify a location in the dialog box to save the PDF to be generated and click **Save**. The generated PDF will be automatically attached to the email.
4. (Optional) Click **Sign In** to sign into your Foxit account and then click **Protect Attachment** to add ConnectedPDF protection to the generated PDF. The protected PDF can only be viewed by others.
5. After typing recipients and message, click **Send**.

**Note:** If you have selected **Automatically save PDF files in ConnectedPDF format (including those created from plugins) only when signed in** in **File > Preferences > ConnectedPDF**, the generated PDF in Step 3 will automatically be converted to a ConnectedPDF file.
Create PDFs in Microsoft Visio (Business Edition Only)

PhantomPDF Creator Plugin in Microsoft Visio provides quick and easy PDF creation from Visio files, while preserving the document properties in the created PDFs depending on the conversion settings.

To create a PDF in Microsoft Visio, please open a file in Microsoft Visio, click the Foxit PDF tab and do one of the following:

- To create a PDF using the current settings, click the Create PDF button. Then enter the file name, specify the location, and then click Save.

- To create and email a PDF using the current settings, click the Create and Email button. Then enter the file name, specify the location, and click Save. The created PDF file will be attached to your mail system automatically for you to send out.

- To create a PDF and save it to SharePoint, click Create to SharePoint. Please refer to "Save the created PDF to SharePoint" for more information.

- To customize your PDF conversion settings before creating PDFs, please refer to Conversion Settings in Microsoft Word. You can retain all layers or flatten all layers in the created PDFs by choosing Retain All or Flatten All for the Layers setting. If you choose to flatten layers, the created PDF will seem like the original Visio drawing, but without any layer information.

- For the Document Homepage, Remove ConnectedID, and Sign In buttons, please refer to Create PDFs from Microsoft Word.

Note:

6. If you check Create Bookmarks, the created bookmarks will be named after the page name in Visio files.

7. Only shapes and guides that are printable and visible in the Visio drawing will be converted and will appear in the created PDF.
Create PDFs using the Print command

Foxit PhantomPDF Printer works like a standard printer, so you can use it to print your files from any windows applications (such as Notepad and Outlook Express) as if you would print to a real printer.

1. Open the file in its authoring application.

2. Choose File > Print.

3. Select the printer named Foxit PhantomPDF Printer, and click the Print button. If you need to deploy print settings, click the Preferences button (See also Setting Foxit PhantomPDF Printer Properties).

4. Specify the name and the storage location in the pop-up dialog box and click Save to start printing. After the printing is finished, the generated PDF file will be opened directly.

Foxit PhantomPDF supports to append newly generated PDF files to a previously generated one which are created by Print command in other application using Foxit PhantomPDF Printer. More details please refer to the steps below.

1. Change settings in Foxit PhantomPDF. Run and open the application window. Click File > Preferences > Documents > uncheck Allow Multiple Instances, if it is checked. And click File > Preferences > Create PDF > check Insert printed PDFs into previously generated documents, except those created by Foxit PhantomPDF.

2. Open the file you want to convert to PDF and use the Print command to generate a new PDF. The generated PDF file will be opened automatically with PhantomPDF. A Print Job pane appears in navigation pane and the name of the file will be displayed on the pane. Do not close or save the PDF file.
3. Open another file you want to append to the PDF file generated on Step 2. Convert the file with Print command to PDF.

4. You will see that the name of the file in Step 3 is also added to the Print Job pane. That is to say, the generated PDF file on Step 3 is appended to the generated PDF file on Step 2.

5. Click File > Save. In the pop-up Save As dialog box, specify the name and location and click Save.
Create PDFs within web browsers

Foxit PhantomPDF allows you to convert webpages to PDFs using the Foxit Convert commands in the toolbar within Google Chrome, Internet Explorer, and Firefox. You can convert the current webpage to a new PDF or append to an existing PDF, or send the new PDF as an email attachment with one click.

For more about how to create PDFs within web browsers, see also Create PDFs in Microsoft Word.

Click Preferences for more settings. See also Create a PDF from Web Page and Conversion Settings in Microsoft Word.

Create PDFs using Print to Evernote

Foxit PhantomPDF adds a new printer “Print to Evernote” after installation. This feature enables the user to send the PDF file as an attachment to Evernote, as well as the option to create a PDF the same as Foxit’s PDF printer does.

To create a PDF using Print to Evernote, see below:

1. Install the Evernote application and sign in to an Evernote account.

2. Open the file you want to convert to PDF, and choose File > Print > Print to Evernote.

3. Set the print properties and then click Print. Name the PDF file and specify the storage location.

4. You will see that the PDF file is created and also attached in Evernote.

Create PDFs using Scanner

Foxit PhantomPDF allows you to create a PDF directly from a paper document using your scanner. You can scan a document to PDF directly with custom settings or by using preset preferences that you configured before.

See also the tutorial on Scan Documents into PDF.

Scan with custom settings

To scan a document to PDF with custom settings, please follow as below:

- Choose File > Create > From Scanner > the From Scanner... button, or choose Convert >
Create > From Scanner, or choose the Home tab > the Convert group > the Scan button > the Scan command.

- Select a scanner and related options in the Scan dialog box.

  **Note:** You must have the manufacturer’s scanning software installed on your computer.

Advanced Options: clicks to open the Scanner Options dialog box. (Available only after you select a scanner.)

  **Transfer Mechanism:** Native mode transfers data by default in your scanner. Buffered memory mode scans in resolutions of over 600DPI.

Configure scanner:

  **Configure scanner using scanner interface:** Checks this option and directly use the scanner interface to scan. Then the following items (i.e. Source, Color Mode, Paper Size and Resolution) will not be available and the settings in the scanner interface will not be able to saved as a preset.

  **Source:** select the input source for scanning, including Auto Detect, Feeder, and Flatbed. If you select Auto Detect, Foxit PhantomPDF will detect the input source for scanning automatically. If documents are placed in both feeder and flatbed, both of them will be scanned, but the one in feeder will be scanned first by default.

  **Sides:** Specify single or double-sided scanning. If you select Both Sides but the settings of the scanner are for only one side, the scanner setting overrides the Foxit settings.

  **Color Mode (Windows only):** selects a basic color mode (Black and White, Grayscale, Color or Auto Detect) supported by your scanner.

  **Paper Size (Windows only):** selects a paper size.

  **Resolution (Windows only):** selects a resolution supported by your scanner.

Output:

  **New PDF Document:** Output the scanning results as a new PDF document.

  **Append:** Append the scanning results to an existing PDF file. After selecting this option, click Browse to find and select an existing PDF file from your local disk.

Optimize Scanned PDF:

  **Reduce size and optimize:** checks this item and clicks Options to customize compression and filtering. The Optimization Options dialog box for image settings controls how scanned images are compressed for the PDF. Default settings are suitable for a wide range of document pages, but you may want to customize settings for higher quality images and smaller file sizes.

  **Color/Gray settings:** when scanning color or gray pages, select JPEG, JPEG2000(Lossless) or JPEG2000(Lossy) to apply JPEG compression to the entire gray or RGB input page. Select High-Compression to apply image compression in high-quality with small size (Available in Business Edition Only).
Low/High Quality: drags the slider to set the balance point between file size and quality.

Monochrome: when scanning black-and-white or monotone images, select one of the following:
- JBIG 2(Lossless)/ JBIG2(Lossy): apply an image compression standard for bi-level images which is suitable for lossless or lossy compression.
- CCITT Group 4: applies CCITT Group 4 compression to black-and-white input page images.
- High-Compression: applies to high-quality with small size compression. (Available in Business Edition Only)

Deskew: chooses On to automatically rotate any page so that the text is vertically aligned, which is of great use for cleaning up scanned PDFs.

Remove blank pages: removes the blank pages from the scanned PDF after scanning.

Make Searchable(run OCR): checks this item and clicks Options to run OCR in scanned PDFs. See also “Recognize Text”.

Save as Preset: saves the current scanning settings as a preset with which you can quickly start a scan next time. In the pop-up Save Preset dialog box, rename the preset as needed and click Save.

- Click Scan. If you checked Configure scanner using scanner interface previously, specify the scan settings as needed and then scan the document based on your scanner’s settings.
- A dialog box pops up, asking you whether to scan more pages, or to scan the reverse sides if you chose both sides in the Sides option previously. Choose a desired option.
- When the scanning is complete, the new scanned PDF or the existing PDF with the scanned pages appended at the end will automatically be opened, with a new tab named “POST-SCAN” in the ribbon.

The Post-Scan Options tab:
- Optimize Scanned PDF: optimizes the scanned PDF for a smaller size and better display effect. See also “Custom Scan”.
- OCR Current File: runs OCR in the current scanned PDF after saving the document. See also “Recognize Text”.
- Page Organize: navigates to the Organize tab where you can apply these commands on the PDF pages.
- Grayscale/ Black & White: adjusts the color mode of the scanned PDF. You can change the mode from Color to Grayscale/ Black & White, or from Grayscale to Black & White;
but not the reverse.

**Edit Document Information**: modifies the scanned document information including Author, Title and File name.

**Close**: closes the **Post-Scan Options** tab.

- Choose **File > Save**, and specify a name and location for the scanned PDF file.

### Scan with a Configured Preset (Windows)

You can configure scan parameters or options and save as presets. When you are ready to scan you can choose one of them with just one click. To scan a paper document to PDF using a configured preset, please choose **Home tab > Convert group > Scan** button > select a preset to scan documents. See also “**Configure presets**”.

### Configure presets

To configure a new preset, please do the following:

- Click **Home > Convert > Scan** and click **Scan**.
- Select a scanner and then complete the settings (See also “**Custom Scan**”).
- Click **Save as Preset** to save the preset. Or click **Scan** to start a scan with the preset.

To modify presets, click **Home > Convert > Scan > Manage presets** to edit, delete and move the existing presets in the **Manage Scan Presets** dialog box. You can also create a preset by clicking Create.

### Optimize Scanned PDF

Foxit PhantomPDF supports the size optimization of scanned PDFs during PDF creation from a scanner or by choosing **File > Optimize Scanned PDF** in an existing scanned or image-based PDF. See also “**POST-SCAN tab**”.

### Create and Customize a PDF Portfolio

You can use Foxit PhantomPDF to quickly create a blank PDF portfolio or a new PDF portfolio from any file. After creation, you can also add more files/folders, create folders, delete files/folders and more within the PDF portfolio.

To create a blank PDF portfolio, please click **Convert > Create > PDF Portfolio > Create a blank PDF portfolio**, or click **File > Create > PDF Portfolio > Create a blank PDF Portfolio**. In the ribbon appears the **Portfolio** tab where you can change the view mode, add files/folders, and create folders. By default, there are two panes in the document area. All the files are displayed in Layout view in the
left pane and the Preview of the selected file is displayed in the right pane.

To create a new PDF portfolio from a file, please click Convert > Create > PDF Portfolio > Create a new PDF portfolio, or click File > Create > PDF Portfolio > Create a new PDF Portfolio from existing files. Select the files you want to attach to a PDF portfolio and click Open. You can also add more files or folders after creation.

Tip: To quickly add files/folders, you can also copy-and-paste or drag-and-drop files/folders to the portfolio.

To customize a PDF portfolio, you can edit PDF files in the portfolio using the toolbar at the top of the left pane as needed and do any of the following:

- To delete a file, select it and click button, or right-click it and choose Delete.
- To extract a file from the portfolio, select it and click button, or right-click the file and choose Extract from Portfolio. Then specify the name and location of the extracted file.
- To edit the description of the portfolio, please navigate to File > Properties > Description.

Tip: You can do more actions by right-clicking a file in the portfolio.

**OCR PDFs and PDF Portfolios**

Optical Character Recognition, or OCR, is a software process that enables images or printed text to be translated into machine-readable text. OCR is most commonly used when scanning paper documents to create electronic copies, but can also be performed on existing electronic documents (e.g. PDF or PDF portfolio).

✧ **Recognize text**

Foxit PhantomPDF can detect whether a PDF file is scanned or image-based and make corresponding suggestions to initiate OCR when opening a scanned or image-based PDF.

To recognize image-based or scanned text in a file, perform the following steps:

1. Click Convert > Convert > OCR > Current File, in the Select OCR Engine dialog box, specify the range you need.
2. Choose the language used in your document. You can select multiple languages as well.
3. In the output type, check Searchable Text Image to make the image text searchable (or check Editable Text to enable the image text to be edited with Foxit PhantomPDF). Click OK to recognize the text.
Note: If you are prompted to download the OCR component after clicking OK, please click Yes to download and install it, or download it later from the link provided and install it by clicking Install Update in the Help tab. To get the full version of Foxit PhantomPDF, please contact us.

4. (Optional) if you check Find All Suspect (Show all OCR results that may need to be changed.), the OCR suspects will be enclosed in red boxes for you to check and correct right after the recognition completes. (OCR suspects refer to the text that can hardly be recognized or may not be recognized correctly and need to be corrected manually.) How to correct OCR suspects, please refer to Find and Correct OCR Suspects.

5. A recognition text process bar will pop up to show the progress.

6. Do the search function, the text on your image or scanned document will be searchable.

Tip: Foxit PhantomPDF provides a Quick OCR command under Home/Convert tab to recognize all pages of a scanned or image-based PDF with default or previous settings by one-click.

To recognize text in multiple files:

1. Click the Convert tab > Convert group > OCR > Multiple Files.
2. In the OCR Multiple Files dialog box, click Add Files to add files, PDF portfolios, or folders. Use Move up, Move down, and Remove to adjust the order of the files.
3. Click Output Options…, in the Output Options dialog box, select the destination folder, and choose how to name the new file and whether to overwrite an existing one. Then click OK.

4. Click OK. After recognition, a message box will pop up to prompt you the recognition is finished.

Note:

1. When you are using the CJK OCR engine for the first time, the system will remind you to download and install the engine from the Foxit server.

2. If there is any unsupported file added, a “Remove unsupported file(s)” button will appear in the OCR Multiple Files dialog box. Click the button to remove the unsupported file(s) and then continue. While recognizing a PDF portfolio, Foxit PhantomPDF will only extract and recognize PDF files in the portfolio.

Find and Correct OCR Suspects

After recognizing image-based or scanned texts in the PDF file, you can pick out and correct the texts or characters that are uncertain as the steps below:

1. Click the Convert tab > Convert group > OCR > Suspect Results > First Suspect. A pop-up Find OCR Suspects dialog box appears with a Foxit PhantomPDF box appearing to prompt you with Find Completed.
2. The Find OCR Suspects dialog box shows both the original document text and the OCR text. You can edit text in the OCR text box directly if needed. If the highlighted text is incorrectly identified, click Not Text. Click Find Next to find the next suspect or click Accept and Find to accept the suspect and find next.

3. If you choose the Convert tab > Convert group > OCR > Suspect Results > All Suspects. The Find OCR Suspects dialog box also pops up and all the OCR suspects will be highlighted with red boxes as below:

Original Document Text in the PDF file

The bird painting is peculiar to China as birds are always appeared with flowers. From of old, all kinds of flowers, plants, and birds were given various symbolic meanings. Flowers and birds can be compared to almost all thoughts and feelings of human being. They can symbolize feminine beauty, virtues, political authority, omens, and lucky niceness. And once established, this tradition became popular in every dynasty. Therefore, their symbolic meaning grow increasingly rich and specific.

Suspect Results of the OCRed Text

You can check the highlighted text by clicking any highlighted parts. Click the place where it is incorrect and input the correct text in the OCR text box in the Find OCR Suspects dialog box.
4. Click **Close** to exit the Find OCR Suspects dialog box.

**Create a table of contents from bookmarks**

You may want to conveniently create a table of contents from existing bookmarks for a hierarchy structure when viewing a PDF file. Foxit PhantomPDF offers two ways to create a table of contents. The new table of contents page will be inserted as the first page of the PDF.

- To create a table of contents when merging multiple files into a single PDF file, please select “Add a new table of contents page converted from bookmarks” in the Convert Multiple Files dialogue box. The table of contents page will be created from the filenames of the selected files.

- To create a table of contents in a current PDF, please click the button on the bookmark panel. Select the bookmark levels you want converted into items in the table of the contents in the **Add a new content of table** dialog box. The table of contents page will be created from the bookmarks of the current PDF.
Chapter 5 – Edit

Foxit PhantomPDF provides not only general editing features to create bookmarks, add links, attach files, add images, play and insert multimedia files on PDF files, but also advanced editing features to select, insert, modify, remove and rotate texts, images, graphics and shadings. You can go to the Edit tab directly to use different editing features to easily and efficiently change contents in any existing PDF files.

Right-click any PDF file and choose Edit with Foxit PhantomPDF, then the PDF will be opened with the toolbar automatically navigating to the Edit tab, ready for your editing.

Undo and Redo

When making quick adjustments to your document, you may want to undo or redo the most recent action performed. You can undo and redo up to 10,000 actions in Foxit PhantomPDF.

Undo your last action

• Click Undo on the Quick Access toolbar of Foxit PhantomPDF window.
• Press Ctrl + Z.

Note: Some actions can’t be undone, such as clicking any command on the File menu. If you can’t undo an action, the Undo command will be grayed out.

Redo actions

• Click Redo on the Quick Access toolbar of the Foxit PhantomPDF window.
• Press Shift + Ctrl + Z.

Links

This function helps you to lead the readers to related articles, references, or the intended web page. If you are reading a PDF file which contains text that links to a webpage, you will see the URL address displayed when you hover your mouse over the text. When you right-click on the linked text with the Hand command selected, you can choose to open the linked web page, copy the URL address, or convert the linked web page to PDF.
You can also add links in PDF files with Foxit PhantomPDF. Generally speaking, there are three commands of links for you: Link, Web Links and Bookmark in Foxit PhantomPDF.

**Link**

**Add a link**

The Link command enables you to add a link with the shape of rectangle on the PDFs.

To add a rectangle link, please do the following:

- Choose **Edit > Links > Link**.
- Position the cursor on the place you want to add the link, hold and drag your mouse button to draw a rectangle.

**Tip:** To draw a square link, press Shift key when you hold and drag your mouse button.

- Pops up the **Create Link** dialog box. Specify the appearance and destination of the link.
  - **Appearance**
    - **Thickness** – the thickness of the four sides of the rectangle. The higher of the value, the thicker of the sides. You can choose the thickness from 0-12, while the default is 1.
    - **Border Style** – the style of the rectangle’s border. There are three types of the border styles:
      - **Solid**: the border is solid, but not hollowed out.
      - **Dashed**: the border is drawn as a dashed line.
      - **Underline**: the sides are visible except the underline.

        ![](Solid Style) ![Dashed Style] ![Underline Style]

        **Three types of border style**

    - **Highlight** - the effect when you click the rectangle link. There are four types of the
highlighting effects:

**None**: doesn’t change the appearance of the link.

**Invert**: changes the link’s color to its opposite.

**Outline**: changes the link’s outline color to its opposite.

**Inset**: creates the appearance of an embossed rectangle.

D. **Color** - the border color of the rectangle. Click the color button to choose any colors you like, or you may choose Other Color to add a customized color. The default color is red.

- **Destination**

The destination refers to any point or location, for example, a web page, a named file or position the link goes to. There are four options for you to choose:

A. Go to a page view – designate the link to a specific page view. Not only can you designate the link to a page in the current PDF, but you can also set the link to the page in another PDF. Also, you may change the current zoom setting and then set the position.

To go to a page view, choose this option, click the **Next** button and do one of the following:

✦ Set the position in current document – scroll the current document, go to a new position where you want to set and click **Set this position**.

✦ Set the position in a local PDF document – click the **Open** button 📁 on the Quick Access toolbar of the application window > select the PDF you want to set position to > scroll this document and go to a position where you want to set > click **Set this position**.

✦ Set the position in a PDF file attachment – click the Attachments icon in the Navigation pane to open the Attachments panel > open the file attachment by double click > scroll through the file attachment and go to a position where you want to set > click **Set this position**.

**Note:**
1. The new PDF document should be opened in a new tab in the existing window but not a new window. While setting the position, you can press Ctrl + mouse scroll to change the page magnification. Before setting the position, you can click Cancel to cancel your operation, if necessary.

2. The linked local PDF documents are saved in your local disks. You need to send the parent PDF document and the linked documents to users to ensure that the linked documents can be opened. However, the linked PDF file attachments are always saved with the PDF document. To link to a position in a PDF file attachment, you should open a PDF file that contains PDF file attachments. If not, please follow the steps in Add a file to the entire PDF as an attachment to add PDF file attachments first.

   ✷ Change the view magnification -- scroll in the current document or another document > go to a new position where you want to set > change the magnification of the position > click Set this position.

   ✷ Click Cancel to cancel out of your operation.

B. Go to a named position – designate the link to a named position that has been set by the creator of the current document.

To go to a named position, choose this option and click the Next button > select a named position for the pop-up list > click OK.

Note: An empty pop-up list indicates that no position has been named by the document’s creator.

C. Open/execute a file – designate the link to open another file. To do this, please follow the steps below:

   ✷ Choose Open/execute a file > click the Next button > select the destination file and click Select.

D. Open a web page – designate the link to open a web page. Do the following:

   ✷ Choose Open a web page > click the Next button > enter the URL of the destination web page or click the drop-down button to select a web site you have opened before.

E. Others (use action property page) – add an action to the link. Please refer to “Actions tab for the button properties” for more details.

Move or resize a link

You can move and resize the link after you create it.

   • Select one of the link commands or the Select Annotation command , and then move
the cursor over the link until the cursor turns into an arrow ➤.

- Then do one of the following:

A. To move the link, drag it to the desired area.
B. To resize the link, drag any corner point to adjust.

Delete a link

- Select the Link command or the Select Annotation command ➤, and then move the cursor over the link until the cursor turns into an arrow ➤.
- Select the link you want to delete.
- Press the Delete key.

Web Links

Foxit PhantomPDF allows users to check URLs in the PDF document automatically and add link annotations directly to the related URLs.

Create web links from URLs

To create web links, please do as following:

1. Click Edit > Links > Create links from URLs ➤. A message box will pop up to prompt you whether to proceed because the operation cannot be undone. Click Yes to continue.

2. In the pop-up Create web links dialog box, choose All to create links from all URL in the document, or choose From ...To and enter a page range to create links on selected pages. Click OK.

3. A message box will pop up to prompt you how many web links were added to the document.

To remove all web links, choose Edit > Links > Remove all links ➤.

Bookmarks

Please refer to Bookmarks.

Bookmarks

Bookmarks are navigational tools that make your PDF files easier to read. They are usually
generated automatically during the PDF creation.

Bookmarks are useful for users to mark a place in a PDF file so users can return to it with ease. Or you may like to have your own bookmark structure and new bookmark names. With Foxit PhantomPDF, you can easily nest, edit, or delete bookmarks in a PDF file if the security settings allow.

**Add a bookmark**

1. Go to the page where you want the bookmark to link to.

2. (Optional) If there is no bookmark in the document, click Edit > Links > Bookmark, or click the New Bookmark icon at the top of the Bookmarks panel.

3. Select the bookmark after which you want to place the new bookmark. If you don’t select a bookmark, the new bookmark is automatically added at the end of the bookmark list. Click Edit > Links > Bookmark, or click the New Bookmark icon at the top of the Bookmarks panel, or right-click the selected bookmark and choose Add Bookmark.

4. Type or edit the name of the new bookmark, and press Enter.

**Tip:**

1. If some of the bookmarks in the document have long names, you can right-click the Bookmarks panel and choose Wrap Long Bookmarks, so that the long bookmark names will appear on multiple lines within the Bookmarks panel. To unwrap, choose Don’t Wrap Long Bookmarks from the right-click menu of the Bookmarks panel.

2. To add a bookmark, you can also right-click on the page where you want the bookmark to link to and choose Add Bookmark. Before this, if you have chosen an existing bookmark (if any) in the Bookmarks panel, the newly added bookmark will automatically be added right behind the existing bookmark (in the same hierarchy); if you haven’t selected any existing bookmark, the new bookmark will be added at the end of the bookmark list.

**Edit a bookmark**

In Foxit PhantomPDF, you are able to rename a bookmark, reset a bookmark’s destination, or customize the text appearance of a bookmark with ease if the security settings allow.

✎ To rename a bookmark
Right-click the bookmark you want to rename in the Bookmarks panel > Rename > type the new bookmark name. Or you double-click the bookmark you want to rename and then type the new name.

✧ To reset a bookmark’s destination

- In the document pane, move to the location you want to specify as the new destination.
- (Optional) Adjust the view magnification.
- Right-click the bookmark, choose Set Destination and select Yes.

✧ To customize the text appearance of a bookmark

- In the Bookmarks panel, right-click the bookmark > choose Properties.
- In the Bookmark Properties dialog box, click the Appearance tab, and select the font style and color for the text.

*Note:* After defining a bookmark’s appearance, you can set it as bookmarks’ default property by right-clicking the bookmark and then selecting the option of Use Current Appearance as New Default.

✧ To add an action to a bookmark

- Right-click a bookmark, and choose Properties.
- In the Bookmark Properties dialog box, click Actions.
- Choose an action from the Select Action menu and click Add, and then refer to the section of “Actions tab for the button properties”.

✧ To delete a bookmark, please do one of the following:

- Select the bookmark you want to delete and click the Delete button at the top of the Bookmarks panel. (Ctrl-click to select more than one bookmark. To select a continuous group of bookmarks, click one bookmark, then hold the Shift key and click the last bookmark.)
- Right-click the bookmark you want to delete and choose Delete.

*Note:* Deleting a bookmark deletes all the bookmarks that are subordinate to it.

**Move a bookmark**

Select the bookmark (named “Bookmark A”) you want to move, and then do one of the following:

- Hold the mouse button down and then drag “Bookmark A” icon directly to the desired place. The Line icon shows the place where the icon will be located.
- Right-click “Bookmark A” icon and choose the Cut option > right-click the bookmark(named “Bookmark B”) under which you want to place “Bookmark A”, choose “Paste after Selected Bookmark” if you want to put “Bookmark A” after “Bookmark B”, which will be in the same hierarchy with “Bookmark A”; or choose “Paste under Selected Bookmark” if you want to put “Bookmark A” under the “Bookmark B”, which will be the parent bookmark.

Note: The bookmark links to its original destination in the document although it is moved.

Organize a bookmark hierarchy

A bookmark hierarchy is an outline or stratified structure that places some bookmarks within others. In Foxit PhantomPDF, multilevel bookmark hierarchy can be defined by properly dragging the bookmark icon in the Bookmark panel.

To nest a bookmark or move a bookmark out of nested position, please refer to Move a bookmark.

To expand or collapse a bookmark

Click the plus sign (+) next to the bookmark icon to show any children. Click the minus sign (-) to collapse the list. To collapse all bookmarks, right-click any bookmark in the Bookmarks panel and choose Expand/Collapse All Bookmarks in the context menu. When no bookmarks are expanded in the Bookmarks panel, you can right-click any bookmark and choose Expand/Collapse All Bookmarks to expand all bookmarks.

Destinations

When creating a link in a PDF, you can link to a specified destination in the document. With Foxit PhantomPDF, you can create and manage destinations in the Destinations panel in the navigation pane.

Create and link a destination

1. Navigate to the location in the document you want to set as the destination.
2. In the Destinations panel, click the Create new destination icon or choose the New Destination command from the Options menu. Name the destination.
3. Save the document.
4. Create a link in the document with the Link command under the Edit tab. In the Create Link dialog box, select Go to a named position and click Next....
5. Select a position from the list in the pop-up Go to a named position dialog box, and click OK.
6. Save the document.
Manage destinations

You can sort, change, and delete destinations in the Destinations panel.

Sort destinations

To sort destinations, choose Sort by Name or Sort by Page from the Options menu in the Destinations panel.

Change destinations

To move to the target location, double-click the destination. Or right-click the destination and choose Go To Destination.

To reset the location of the destination, navigate to the desired location, right-click the destination and choose Set Destination.

To rename a destination, select the destination, click on the name of destination and type a new name. Or right-click the destination and choose Rename.

Delete destinations

To delete a destination, right-click a destination and choose Delete. Or choose the destination and press Delete on the keyboard.

File Attachments

You can attach PDF files and other types of files to a PDF. There are two options for you to add an attachment: attaching a file as a comment and attaching a file to the entire PDF. An attached file as a comment will appear in the page with the File Attachment icon by default, while the attached file to the PDF file acts invisible and only can be seen when you click the Attachment panel in the navigation pane.

Add a file as a comment

1. Choose Comment > Pin > File.
2. Position the cursor to the place where you want to attach a file as a comment > click the selected position.
3. In the Open dialog box, select the file you want to attach, and click Open.
4. The File Attachment Icon  

appears at the place you designated in the PDF file.

**Work on the attachment comment**

You can open the attachment, add a description, move and delete it, and set the preferences.

- **Open an attachment**

Select the Hand command  

or the Select Annotation command  

and do the following:

1. Double-click the File Attachment icon  

2. In Open file attachment dialog box, select one of the three options and click **OK**.

   A. Open the file attachment – open this file attachment and the dialog box will always pop up when you double-click the File Attachment icon.
   
   B. Always open file attachments of this type – open this file attachment and the files of this type will be opened automatically when you double-click the File Attachment Icon next time.
   
   C. Never open file attachments of this type – forbid to open the file attachments of this type. Whenever you double-click the File Attachment Icon, the files of this type will be forbidden to open and you’ll be prompted that “File attachment of this type cannot be opened because of your security settings”.

See also “Doing security settings”.

**Note:** If you are in Safe Reading Mode, a dialog box will pop up when you open an attachment. Check Disable Safe Reading Mode and Open file, and then double click the File Attachment icon  


to open the attached file.

- **Move a file attachment icon**

Select the Hand command  

or the Select Annotation command  

, click and drag the File Attachment Icon to move it to other place.

- **Delete an attachment comment**

Select the Hand command  

or the Select Annotation command  

, and do one of the following:
Right-click the File Attachment icon and choose **Delete**.

Click the File Attachment icon and press **Delete** key.

✧ **More options with an attachment comment**

You are able to work on the attachment comment just like an ordinary comment, including set status, mark with checkmark, open popup note and add some descriptions, reply to the comment, and change the icon's appearance. For all the operations, please refer to "Chapter 7 – Comment”.

**Add a file to the entire PDF as an attachment**

1. Click the attachment button on the navigation pane and click **Add** button, or choose Edit > Insert > File Attachment .
2. In the **File Attachment** dialog box, click the **Add Files...** button.
3. Select the file you want to attach in the pop-up dialog box, and click **Open**.
4. Click **OK** after adding the desired files.
5. The added document will be displayed in the attachment panel.

**Tip:**

1. An easy method to add a file attachment to PDFs, you can just drag and drop the file you want to attach to the attachment panel. Foxit PhantomPDF will pop up a window to ask you whether to attach the selected file to current PDF document. Click **OK** to complete the operation. Check “Always attach file when dragging files to the attachment panel” option and the next time the file will be attached directly without this pop-up window.
2. Save the document after adding file attachments, and a red dot appears on the icon of the attachment panel in the navigation pane.

✧ **Work on the attachments**

You can open, save, edit descriptions, delete and do settings to the attachments. Click the attachment button on the navigation pane > Open button /Save button /Add button /Edit Description button /Settings button /Delete button .

✧ **Security settings**

To change the security settings you have set when you open the attachment file as a comment, Click the **Settings** button in the Attachment Panel and do one of the following:
To add a new extension, click the Add button to input the file extension in the Security Settings dialog box.

To delete an extension, click one of the existing extensions and click the Delete button.

To change the settings of how to open the attachments of the type, choose one of the three options listed.

Images

You can specify a rectangle on any part of a PDF page and then insert an image into that rectangle. This feature is helpful when you want to explain or show something more dynamically.

Add an image

You can add an image to a PDF with the Image Annotation command. After you insert a new image, you can adjust its size and position, change the appearance and other settings, etc.

To add an image, do the following:

• Choose Edit > Insert > Image Annotation.

• Drag a rectangle on the page to define the canvas area for the image.

• In the Add Image dialog box, click the Browse button to select the image that you want to insert and click the Open button. You will see the URL of this image has been added to the Location field.

• Click the Advanced… button to edit the setting of the image.

   A. When to scale – choose when to scale the image you insert.

   B. Scale – choose to scale the image non-proportionally or proportionally. This option will be disabled when you select Never in the field of When to scale.

   C. Border – drag and move the scroll bar to change image’s position in the rectangle. The coordinates change when you move the scroll bar.

• Click OK for your changes to take effect, or click Reset to reset the data to the original settings.

Apply an image to other pages

After adding an image, you may want to place the same image on additional pages while maintaining the original location and settings.

To apply an image to other pages, please do the following:
1. Right click on the image you wish to apply to other pages.
2. Choose the option **Place on Multiple Pages** in the menu.
3. Specify the page range.
4. Click **OK**.

**Move and resize an image**

To move an image, please do the following:

1. Select the Select Annotation command ![Select Annotation](image) or the Image Annotation command ![Image Annotation](image), put the cursor over the image and the cursor changes into an arrow ➤.
2. Click and drag the image to another place you like.

To resize an image, please do the following:

1. Select the Select Annotation command ![Select Annotation](image) or the Image Annotation command ![Image Annotation](image), put the cursor over the image and the cursor turns into an arrow ➤, and then click the image.
2. Place the cursor on any corner point. The cursor changes into the cursor showing the direction at which the rectangle will be resized.

3. Drag the cursor outside, it will increase the size of the rectangle proportionally. Drag the cursor inside and it will decrease the size of the rectangle proportionally.

**Set properties of an image**

1. Double-click the image or right-click it and select **Properties**....
2. In the Appearance tab, do any of the following:

   - **Annotation is hidden from view** – The image annotation will be invisible in Hand command mode.
   - **Border** – Select the border width of the image and the border’s style and color.
   - ![ Locked – When selected, prevents any further changes to any image properties. ]
3. In the Settings tab, follow the steps in “To add an image”.
4. For the Actions tab, please refer to “Actions tab for the button properties”.

Delete an image

1. Select the Select Annotation command or the Image Annotation command, put the cursor over the image and the cursor turns into an arrow , and then click the image.
2. Press Delete or right-click the image > Delete.

Select multiple images

1. Select the Select Annotation command or the Image Annotation command.
2. Press and hold Shift or Ctrl and click the images you want to edit.

Align images

- Select two or more images that you want to align.
- Click Edit tab > Arrange group > Arrange button > select a type of alignment, or right-click the anchor > Align, and then choose a command as follows:
  A. To align a column of images, choose Left, Right, or Vertically to align them respectively to the left edge, right edge, or vertical axis of the anchor image.
  B. To align a row of images, choose Top, Bottom, or Horizontally to align them respectively to the top edge, bottom edge, or horizontal axis of the anchor image.

Note: When you right-click or Ctrl-click one of the selected images, it will be highlighted in red, indicating that it’s the anchor image. The align menu commands move the other selected images to line up with the edges of the anchor image.

Below is an example:
Center images

This function enables you to center the rectangle enclosed by the images you select vertically, horizontally or both.

Below is an example:

A. Suppose that you want to set A as the anchor image.

B. Select these two images > right-click A and choose Align > Left. You will see the other image is placed to the left edge of A.
A. Select two images. You can see these two images consist of an area with the shape of rectangle (marked with red).

B. Right-click one of the images > Center > Vertically. You will find that the red rectangle is centered vertically in the page.

Distribute images

This function will be available when selecting three or more images.

- To distribute the images evenly between the topmost and bottommost images, choose Distribute > Vertically.
- To distribute the images evenly between the leftmost and rightmost images, choose Distribute > Horizontally.

Below is an example:
A. Select three images A, B and C. A is the topmost image and C is the bottommost image.

B. Right-click any one of the images > Distribute > Vertically. And you will see that B is distributed evenly between A and C.

Resize images

You can adjust multiple images with the same height, width, or both. Select one of the images as the anchor, and the rest of the images will be resized with the same height or width as that of the anchor image.

Below is an example:
Setting properties of multiple images

- Select multiple images > right-click one of them > Properties...
- A dialog pops up with an Appearance tab. Follow the steps specified in “Setting properties of an image”.

PDF Optimizer

With the PDF optimizer, users can compress the images, clear out the data redundancy of PDF objects and update your PDFs.

- Choose File > PDF Optimizer.
- Setting the properties in the PDF Optimizer dialogue box.
- Click Audit space usage to see the space usage of the current PDF file and then you can decide which items are needed to be optimized.
In **Make compatible with**, select a PDF version to save the current file under.

For **Compress Images**, you can specify color/grayscale and monochrome image settings, including image downsampling and image compression. Choose the appropriate down sampling method in the Downsample list box (including average the downsampling, subsampling and the bicubic downsampling) or you can choose the **Off** item to turn off the option. Set the right pixels and image compression (including retaining existing, JPEG and high compression). See also “**Custom Scan**”.

*Note: If you check the option “Optimize images only if there is a reduction in size”, the images will not be optimized when there are no reductions.*

- For **Unembed Fonts**, move the embedded fonts to the right list to lift to embed.
- For **Discard Objects**, please check the objects settings you want to discard.
- For **Discard User Data**, please check the user related information you want to discard.
- For **Clean Up**, please check the Cleanup settings you want to optimize the document.
- Click **OK** button and save the optimized PDF file.

**Action Wizard (Business Edition Only)**

For users who need to work on PDF documents through a series of routine tasks, PhantomPDF’s Action Wizard can help them to automate it with a predefined action. What users need to do is just create an action that includes all the tasks to be applied to the PDFs, and then run the action to process the PDFs in a single step.

**Create an action**

To streamline your work using Action Wizard, please follow the steps below to create an action:

1. Choose **Action Wizard** in the **File** tab, and click **Create New Action > Create**. The **Create New Action** dialog box appears.
2. By default, the current open file will be the file processed by the action. You can add more files or folders to be processed by clicking **Add Files, Add Folder, or Add Open Files**. You can also re-order the files/folders you selected, and the action will be run in that order.
3. Then choose the commands needed for the tasks from the left column and add them to the right column. You can reorder the tasks by clicking **Move Up/Down** or delete a task by clicking **Remove**. The tasks will be executed in the order you set.
4. For some tasks (such as header and footer, and watermark), you can predefine options by clicking **Specify Settings**. If you check **Prompt User** you’ll be prompted to select options or specify settings when running the action.
5. More settings:
   (1) Rename the panel by double-clicking the **Untitled** label. Click **Add Panel** to add more panels to group tasks.
(2) Choose a task and click Add Instruction to add an instruction below it.
(3) Add a divider line below the selected task by clicking Add Divider.
(4) Click Move Up/Down to move the selected task/instruction/divider line/panel, or click Remove to delete them.

6. Click Save.
7. Name the action and input the description for the action in the dialog box. Then click OK.

Run an action

After you create your action, you just open the file and run the action.

1. Click File > Action Wizard > Run Action and select an action.
2. A pane appears in the right of the application window, showing all the tasks in the action.
3. (Optional) In addition to the files/folders specified in the action, you can add more files/folders to be processed by clicking Add Files, Add Folder, or Add Open Files.
4. Click Start.
5. You may be prompted to provide information like the storage location. A check mark will be added to each task after the task is completed.
6. (Optional) you can click Stop in the panel to stop processing the action. All tasks that have been executed will be saved. Click Resume to continue the action. Or click the Close button of the panel to exit the action.
7. After all tasks in the action are completed, the Done button will appear in the panel.

**Tip:** Foxit PhantomPDF provides several ready-to-use actions that include common tasks like file distribution, PDF optimization, sensitive information protection, and document archive.

Manage actions

Click File > Action Wizard > Manage Actions > Manage, and the Manage Actions dialog box pops up and lists all the available actions. You can edit, rename, copy, delete, reorder, or import/export actions in the Manage Actions dialog box.

In the Manage Actions dialog box, do any of the following:

- Select the action you want to edit and click Edit. Click Save after the modification, and then close the Manage Actions dialog box.
- Select the action you want to rename and click Rename. Update the name and the description for the action, and click OK. Then close the Manage Actions dialog box.
- Select the action you want to copy and click Copy. Type the name and the description for the action, and then click OK. The new copy of the selected action will appear in the actions list. Then close the Manage Actions dialog box.
- Select the action you want to delete, click Remove. Then close the Manage Actions dialog box.
Work with Video & Audio

Foxit PhantomPDF not only supports playing videos and audios in PDFs, but also allows users to add and edit multimedia files to a PDF.

Play a Movie or a Sound Clip

Some PDF files may be multifaceted with multimedia, including sound, music, and video clips. Each movie and sound file usually includes a play area from which the media can be activated. The play area typically appears on the PDF page as an image or a blank rectangle, but can also be invisible. To play the media files, please make sure you have the necessary media player installed on your computer.

To play a movie or a sound, please do the following:

- Select the Hand command ( ), and click the play area of the movie or sound file.

**Note:** To protect your computer from viruses, Foxit PhantomPDF pops up a dialog box soliciting your approval before playing multimedia files. If you trust the document and the media source, check the options: Disable Safe Reading Mode and play media and Add current file to privileged locations.

Adding a movie or a sound clip

Adding movies or sounds to PDFs is as easy as inserting an image. "Movies" are desktop video files with formats such as FLV, AVI, QuickTime, and MPEG, and file extensions such as .avi, .wmv, .mov, .qt, .mpg, and .mpeg. An animated GIF file always has a .gif file extension, while “Sounds” are like midis, wavs, and mp3 files.

**Note:** If an alert message tells you that no media handler is available, you must install the appropriate player before you can add clips to the PDF. For example, you must install QuickTime if you want to embed an MOV file in a PDF.

Adding movies or sounds
1. Choose **Edit > Insert > Video & Audio**.

2. Press and hold mouse button down, drag to select an area on the page where you want the movie or sound to appear. For movies, the play area is the exact size of the movie frame.

3. In the pop-up Add Video & Audio dialog box, you will see some options listed below:
   - **Location**: click the Browse button to select the movie file you want to insert.
   - **Content type**: the type of the media you insert. It is selected automatically. But you can also specify the clip type if you want. Please note that changing the Content Type setting may cause problems playing the media.
   - **Embed content in document**: includes the media file into the PDF file. This option will increase the file size of the PDF. It is selected by default. If the check box is cleared, you will not be able to play it if you open this PDF file on other computers.
   - **Poster Settings**: choose whether to display an image in the play area when the movie isn’t playing. You can choose to use no poster, or create poster from file.

**Edit the play area**

To move, resize, align, center or distribute a multiple clip, please refer to **“Images”**.

**Set Video & Audio properties**

In Foxit PhantomPDF, you can specify properties for the multimedia files you added, such as the appearance of a movie’s play area, whether the movie plays once or continuously, create alternate renditions, etc.

To set video & audio properties, please do the following:

1. Select the Video & Audio command, or the Select Annotation command.

2. Double-click the play area or right-click the play area > **Properties**.

3. For the Appearance tab, please refer to **“Setting properties of an image”**.

**Note**: If you select Locked on any tab, it will lock all options for this multimedia file, but not just the options on that tab.

4. In the Settings tab, there are many options listed below:
   - **Annotation Title** -- Type the title of the movie or sound in the Annotation Title box. This title does not determine which media file is played.
   - **Alternate Text** -- Type a description of the media file in the Alternate Text box.
   - **Renditions** -- Allows you to create alternate or other renditions to ensure that users can play the movie or sound clip on their systems.

   - **A. List Renditions for Event** -- You can assign different renditions to different actions but **Mouse**
Up is chosen by default. Mouse Up means that when the mouse button is clicked and released, the rendition is played.

B. Add Rendition – There’re three ways for you to choose: Use a File, Use a URL, By Copying an Existing Rendition

C. Edit Rendition – When clicking the Edit Rendition button, the Rendition Settings dialog box appears, which allows you to specify the playback location, and other settings to differentiate it from other renditions.

Media Settings -- Specifies the general properties for the movie or sound clip:

- **Rendition Name**: Enter the name for the rendition, which will appear in the list of renditions. (This name does not determine which media file is played.)
- **Media Clip Location**: Specify the clip by typing or navigating to it.
- **Content Type**: Will be selected automatically when you specify the clip location. Changing the Content Type setting may cause problems playing the media.
- **Embed content in document**: Includes the media file into the PDF file. This option will increase the file size of the PDF. If the check box is cleared, you will not be able to play it if you open this PDF file on other computers.
- **Rendition Alternate Text**: Type a description of the rendition.
- **Allow temp File**: Specify whether writing a temp file is allowed and when. Some media players write a temp file when they play a movie or sound clip. If you want to prevent users from easily copying the media content in a secure document, you may want to disallow the creation of temp files. However, selecting this setting may prevent the movie from being played by media players that require the use of temp files.

Playback Settings -- Use this tab to determine how the movie or sound clip is played.

- **Keep Player Open**: Select whether you want the player to close after it plays the movie or sound clip.
- **Volume**: Lets you specify how loud the movie will be played.
- **Show Player Controls**: Select to display a controller bar at the bottom of the play area allowing users to stop, pause, or play the media, provided the media player supports player controls.
- **Repeat**: Lets you replay a clip two or more times, or continuously.
- **Player List**: Click Add to specify a player and the settings that are required, preferred, or disallowed to play the movie or sound clip. Select the name of the player and the status. If you set the status of more than one player to Required, only one of the required players may be used to play the rendition. If you set the status of players to Preferred, these players are selected over nonpreferred players (but not over required players). If you set the status of players to Disallowed, they are not used to play the rendition.
- **Add/Edit/Delete button**: Allows you to add a new player, as well as edit or delete the selected player in the Player List.
Playback Location – Determines whether a movie or sound clip is played in the PDF, remains hidden while played (recommended for sound clips), is played in a floating window, or is played full screen. The options for Floating Window Settings are unavailable except when you choose Floating Window.

- **Playback Location**: Selects the location for playing a movie or sound clip.
- **Background Color**: Selects the background color for the media player.
- **Show title bar**: Selects to show or hide title bar when playing the media in a floating window.
- **Show control closing window**: Selects to show or hide the close button at the top right corner in a floating window.
- **Title Text**: Adds a title for the media that will be showed on the title bar when playing the media in a floating window.
- **Resize**: Determines to allow or forbid users to resize the floating window. There’re three options for you to choose: Don’t allow user to resize window, Allow user to resize window but maintain original aspect ratio, or Allow user to resize window.
- **Window Position**: The window position is determined relative to the document window, application window, the virtual desktop or document monitor.
- **Width/Height**: Specifies the width and height of the floating window.
- **If Window is Off-screen**: Selects to play, do not play, or move window onto screen to play the media file if the floating window is off-screen.

**Use current playback settings as default for this type of media**: Set your settings as the new default for all the multimedia files you create in future.

D. Delete Renditions – Deletes the selected renditions.

E. Up/Down – Arranges the order of the renditions. If the first rendition cannot be played, the next available rendition is played.

5. **Actions tab for the Video & Audio properties**

Please refer to “Actions tab for the button properties”.

**Search and Replace Text**

The **Search & Replace** function allows you to quickly update text that occurs multiple times in the document. PhantomPDF will find the next occurrence of your specified text and replace it with your new text.

1. On the **Edit** tab, click the Search & Replace icon in the **Edit Content** group. Or click the Search button on the menu bar and choose **Search & Replace** in the dropdown list. Or
2. The Replace panel appears on the right side of application window.

3. Type the text that you want to find and replace in the Initial Text box, and the replacement text in the Replace With box. Only text objects in the document will be found, not including text in a bookmark, a comment, or form data.

4. There are two options:
   - Whole Words Only: When selected, only instances that match the complete words specified in the Initial Text box will be found.
   - Case Sensitive: When selected, only instances that match the capitalization of the string specified in the Initial Text box will be found.

5. Choose Find Previous and Find Next to locate the instance you need to replace, and click Replace to replace it with the replacement text.

**Paragraph Editing**

With the Edit Text command, you can edit texts in a paragraph like Microsoft Office Word as well as changing their font, font size and color.

To edit texts in a paragraph, please do the following:

- Select Edit > Edit Content > Edit Text. *(Tip: You can also right-click the selected text with the Select Text and Image command and choose Edit Text to start editing text in the paragraph quickly.)*
- Click on the desired paragraph to start editing. Foxit PhantomPDF will automatically change a line when the text comes to the margin of it. You can also start a new line by pressing Enter. See also the tutorial on Edit PDF.
- You can set the font and paragraph in the Edit > Font/Paragraph. More editing features please refer to Edit Objects.

**Note:** Clicking on a scanned or image-based PDF with Edit Text command, you’ll be prompted to run OCR or convert this file to other format. To not show the prompted message again, you can go to File > Preference > Editing > uncheck the option “Alert when there’s no editable text when using ‘Edit Text’ tool”.

**Objects**

When reading a PDF, you may need to frequently edit text, image, or other objects in this PDF file. With Foxit PhantomPDF, you can add, edit, modify, join and split objects.
Add New Objects

You can add or insert new text, image or shape objects into a PDF using respective commands in Edit tab.

Add new text objects

To add text objects, please do the following:

- Select Edit > Edit Content > Add Text.
- Click on the specific page you want to input the text and type new text in the position where the cursor is blinking. You can also paste or delete the text you input.
- You can choose the text font format as you want in the Font group. In the Paragraph group, you can also align the text and set other paragraph formats including word spacing, character scale, line spacing, etc.

Add new image objects (Business Edition Only)

To add image objects, please do one of the following:

- To add a self-created image or embed an image from the clipboard, locate the page where you want to insert the image in the document, and choose Edit > Edit Content > Add Image Object > Draw New Image. Add New Image dialog box pops up as below. You may specify the parameters and click OK. Then you are switched to the Image Editor window.

  A. In the IMAGE tab, draw your image from scratch. Or click Paste button in the toolbar to insert an image from the clipboard and then edit the image. Click Save as Image to save the image content in the window as an image file. Click Copy to copy the image content which can be pasted to a PDF document.
B. To draw or edit image, you can use the commands on the toolbar and the Image Editor Function Panel at the right side of the window. For more information on the Image Editor, please refer to “About the Image Editor”.

C. Click Apply Changes button □ to save the changes and exit the Image Editor. Or click Exit Image Editor button × to exit ignoring the changes on the image and to go back to the Document window. After the image is successfully inserted, you can resize the image and drag it to any place you want.

- To add an image from file, locate the page where you want to insert the image in your document, and choose Edit > Edit Content > Add Image Object ➔ > Image From File ➔. Choose the target image file in the Open dialog box and click Open. Then the image will be added to the document. You can double-click the image, or right-click the image and choose Edit Object, to open the Image Editor and edit the image with the commands in the IMAGE tab. How to edit image objects, please refer to “To Add a Self-created Image”.

**Add new shape objects (Business Edition Only)**

With Foxit PhantomPDF, you can also directly insert path and shading objects like rectangles, curve, straight line, etc. into your PDF as well as text objects and image objects. Shading objects are generally used to make shadows or nice backgrounds.

Add a path object

Add a shading object
Add a path object

To add a path object, please do the following:

- Locate the page where you want to insert the path in the document, and choose Edit > Edit Content > Add Shape Objects > Add Path > choose one path you need. The cursor changes into a cross 🎨. Click and drag the cursor to draw the path you want. Then the Format tab and the Arrange tab will appear in the ribbon for you to modify the path with the commands.

- When you are drawing a path, it stays selected until you click elsewhere on the page and a wireframe with sizing handles appears to let you adjust the size and shape.

**Note:** Sizing handles are the small circles or squares that appear at the corners and sides of a selected object. You drag these handles to change the size of the object.

- When drawing a path, you can press the Ctrl + Z or Ctrl+ Y to undo or redo your operation. After creating the path you intended, click anywhere outside the path.

To draw a straight line

1. Choose the Line command 🎨.
2. Click a region in the document where you want to create the drawing and draw the line.
3. Drag the handles to adjust the line size if necessary.
4. Click outside the path when you are done to set the line.

To draw a rectangle

1. Choose the Rectangle command 🟡 to create a square-cornered path, or click the Rounded Rectangle command 🟢 to create a round-cornered path.
2. Click a region in the document where you want to create the drawing and draw a rectangle.
3. Drag the sizing handle diagonally in the direction you want.

To draw an ellipse
1. Choose the **Ellipse** command.

2. Drag the pointer to draw an ellipse, or draw a circle with **Shift**.

3. Click outside the path when you are done to set the ellipse.

**To draw a polygon, polyline, Bezier, or Close Bezier**

1. Choose the **Polygon** command, **Polyline** command, **Bezier** command or **Close Bezier** command.

2. Drag the pointer to draw a straight line.

3. Click once at each position where you want a new line segment to appear.

4. Click outside the path when you are done to set the path.

**To draw a custom path**

1. Choose the **Free Paint** command.

2. Draw a path you want by dragging the pointer.

3. Click outside the path when you are done to set the path.

✧ **Add a shading object**

To add a shading object, please do the following:

- Locate the page where you want to insert the shading in your PDF document, and choose **Edit > Edit Content > Add Shape Objects > Add Shading**. Choose the shading you need. The cursor changes into a cross. Click and drag the cursor to draw the shading you want. The **Format** tab and the **Arrange** tab will appear in the ribbon for you to modify the shading with the commands.

- When you are adding a shading (See also **Drawing a path**), it stays selected until you click elsewhere on the page and a wireframe with sizing handles appears to let you adjust the size and shape.

In the **FORMAT** tab, you can choose a shading style to preset different shading colors and do any of the following to move the colors and change the shading effect:

1) **Opacity**: Drag the slider to change the opacity.

2) **Gradient Stops**: Describes the location and color of a transition point in a gradient. After choosing a shading style, you can also edit the shading color, like add new colors, delete existing colors, etc.
✧ **Move colors**

Each color can be moved by clicking and dragging the slider ⬅️.

✧ **Change colors to a shading**

Double-click one color ⬆️ you want to change, select the color you like in the Color dialog box and click OK.

✧ **Add colors to a shading**

Select one color you like and click between any two sliders underneath the preview bar. There will be new colors added to the shading.

✧ **Delete colors to a shading**

Click the slider ⬆️ of the color you want to delete, and click Delete button ⬅️. Also, you can move it away from the preview bar. The color will be removed from shading.

3) **Reference Line:** A line along which the field of shading varies between the start and end coordinates and from which the field of shading extends infinitely away. The start and end point are shown, connected by a line. The transition from one color to another varies linearly along the line. The color gradient begins at the start point and finishes at the end point.
You can drag either start or end point to move it individually, or drag the line to move them both at the same time. This movement will change the shading effect. Compared with Shading 1, Shading 2 is dragging the start point to move, Shading 3 is dragging the end point to move, and Shading 4 is dragging the line to move.

**Link and Join Text Objects**

To make editing easier, Foxit PhantomPDF supports linking multiple text blocks together or connecting separate text blocks into one single paragraph.

**Link and Unlink Text Objects**

Using the Link command, you can link multiple text blocks together and then editing text in these blocks will be treated as editing one paragraph. You can link text blocks not only in one page but also across pages. Text will reflow in these linked blocks and will not cover the page contents that are located among these blocks.

To link text blocks, please do the following:

- Click Edit > Edit Content > Link & Join Text and a Format tab appears in the ribbon. Select text blocks you need to link together and the selected blocks will be marked with numbers as you click them.
- Click the Link command in the Format tab, or right-click the selected blocks and choose
**Link Text Boxes.** Then the three blocks will be linked together.

- Then when you add or edit text in these blocks with the **Edit Text** command, the text will reflow in these linked blocks and will not cover the image among them. And when the text added exceeds the final block, content followed the linked blocks will be covered because they have not been linked together.

To unlink a text block, please click **Edit > Edit Content > Link & Join Text**, select the text block you need to unlink and then click the **Unlink** command in the **FORMAT** tab. You can also right-click the selected block and choose **Unlink Text Blocks**.

**Note:**

*You can select and link text blocks which are discontinuous or in different columns, or that are not arranged from top to bottom or from left to right on the page.*

**Join and Split Text Objects**

With the **Join** command, you can connect blocks of text into one single paragraph in a block to improve text reflow. Blocks of text may be joined together when you need to join text as one object. Otherwise, a block of text can be divided up into several parts with the **Split** command.

To join text blocks, do the following:

1. Click **Edit > Edit Content > Link & Join Text** button.
2. Click the text blocks you want to join. The text blocks you selected will be numbered.
3. Click the **Join** command in the **FORMAT** tab, or right-click the selected blocks and select **Join Text Boxes**. Then the selected blocks will be joined together as one block.

To split a text block, please click **Edit > Edit Content > Link & Join Text** button and click the text block you want to split. Click the **Split** command in the **FORMAT** tab, or right-click the selected block and select **Split Text Boxes**. Then the selected block will be divided.

**Note:** *All selected blocks should be on the same page.*

See also the tutorial on **Advanced Text Editing**.
Edit Objects

You can freely edit any selected object(s) by the related commands.

Edit Text Objects

To edit text objects, click Edit > Edit Content > Edit Object > Text. And click on the text you want to edit. A selected object usually is outlined by a bounding box. Double-click the box or choose Edit in the context menu. Then the cursor will be blinking, and you can add, paste or replace text only if the font used for that text is installed on your system. More editing information, please refer to "Add New Text Objects".

Merge and Split Text Objects (Business Edition Only)

You can also merge and split text objects by using Merge Text tool and Split Text tool. To remove the space between the letters of words to improve the appearance of text content, you can click Edit > Split > Merge Text > Remove Kerning.

To merge text objects, Shift-click the objects with the Edit Object command and click Edit > Split > Merge Text. To split a text object, please do the following:

- Select the object and click Edit > Split > Split Text. The Split Text dialog box pops up.
- Drag the slider and click the position you want to split. Click OK and the text object will split into parts.

Convert Text Objects to Shape Objects (Business Edition Only)

Foxit PhantomPDF supports to convert the selected text object(s) into path(s), which will meet the pre-press requirement. For those computers that do not support or display certain embedded fonts, this new feature helps to overcome that issue. To convert text objects to paths, please do the following:

- Select the text objects that you want to convert to paths.
- Select the Convert to Shape button to convert.
Edit Image and Shape Objects *(Business Edition Only)*

To edit image objects, click **Edit > Edit Content > Edit Object ➕ > Image**. Double-click an image or choose **Edit Object** in its context menu. Your current main window is switched to the Image Editor window. For further information about editing image objects, please refer to “Add New Image Objects”.

To edit shape/shading objects, click **Edit > Edit Content > Edit Object ➕ > Shape/Shading**. Click a shape/shading and edit it with the commands in **FORMAT/ARRANGE** tab. Further information about editing shape/shading objects, please refer to “Add New Shape Objects”.

*Tip: When editing text, image, shape and shading objects together, you can edit all the objects by choosing **Edit > Edit Content > Edit Object ➕ > All**.*

Reflow Editing

The commands **Edit Text** and **Edit Object** can only allow you to edit text in one text block in one page. To edit text in a continuous mode like Word, you can use the **Reflow Editing** command. When you are in reflow editing mode, text will reflow automatically in pages in the document as you add or edit text content.

To edit PDF with the **Reflow Editing** command,

1. Choose **Edit > Edit Content > Reflow Editing**, and a dialog box pops up to inform you about the benefits and notes about the reflow editing mode. Click **Continue** if you need to edit content in the Reflow Editing mode.
2. The **Reflow Editing** tab appears in the ribbon, allowing you to edit text format and paragraph styles.
3. When you complete editing, click **Apply Changes** to save the changes, or click **Exit Reflow Editing** to exit the Reflow Editing mode without applying any change.

Modify, Arrange and Delete Objects

A selected object is usually outlined by a bounding box. And the corresponding **FORMAT** or **ARRANGE** tab in the ribbon will appear after you select objects. With the commands in **FORMAT** or **ARRANGE** tab, you can modify and arrange objects.

Select **Edit > Edit Content > Edit Object ➕** > select All/Text/Image/Shape/Shading, and do one of the following:
1. To select one or multiple objects, please do one of the following:

- Click the object to select it, or press Ctrl/Shift and select more objects.
- Hold the pointer over the objects and drag a rectangle around them.
- Press Ctrl + A on keyboard. All objects on the current page are selected.

**Note:** To deselect all the objects, click any blank area in the document.

2. Move and resize an object

- To move an object, select the object and drag the object to the desired place. Or right-click the object and choose Cut from the context menu and then right-click the desired place and choose Paste.
- To resize an object, drag a handle of the object. Drag the handles of the four corners to retain the original aspect ratio.

3. Rotate an object

To rotate an object, put the cursor over the selected object, the cursor will change to 

<p>| |</p>
<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
</table>

, then do one of the following:

- In ARRANGE tab, click Rotate group > Rotate > Clockwise/Counter-clockwise by 90 degrees.
- Click and drag to rotate the image as you need.
- Right-click the selected and choose Rotate.

4. Shear an object (Business Edition Only)

To shear an object, select the object and do the following:

Click Edit > Effect > Shear (or click Effect > Shear in FORMAT tab when shearing a shape/shading object), or right-click the object and choose Shear in the context menu. Enter a value in the pop-up dialog box to shear the object and click OK to finish.

5. Arrange objects

After selecting multiple objects, you can arrange them in the documents. In the ARRANGE tab you can align, page-center or distribute objects. Or choose Align/Center/Distribute after right-clicking one of the selected objects. (See also “Align Images”, “Center Images” and “Distribute Images”.)

6. Clip an object (Business Edition Only)
• Select the object and click **Edit > Effect > Clipping** (or click **Effect > Clipping** in the **FORMAT** tab when clipping a shape/shading object), or right-click the object and choose **Add clip path** in the context menu. Choose one clipping shape in the drop-down list.

• Click on the object and it will turn to the clipping mode where the selected object will be enlarged and the cursor changes to a cross. Drag the cursor to draw a clipping shape. The cursor then changes to . You can adjust the shape’s position by dragging the cursor to move.

• Drag the dots of the clipping shape in the direction you want until the clipping shape displays the results you want.

• (Optional) You can choose other clipping shapes to do further clipping on the object if needed.

• (Optional) To delete clipping shapes, click **Edit > Effect > Clipping** > **Edit Clipping** (or click **Effect > Clipping** > **Edit Clipping** in **FORMAT** tab), select one clipping shape and press Del or right-click the clipping shape and select Delete. To remove all clipping shapes, please click **Edit > Effect > Clipping** > **Clear Clipping** (or click **Effect > Clipping** > **Clear Clipping** in **FORMAT** tab).

• Click on the area outside the objects to exit the clipping mode.

7. Move an object in front or behind other elements

Select an object and click **Z-order > Send to Back** or **Bring to Front** in the **ARRANGE** tab to send it to the front or back of the other elements on the page.

8. Delete an object

• Select one or more objects, press the **Delete** key or right-click and choose **Delete** from the context menu.

**Object Properties**

When you right-click an object or multiple objects with the same type, and choose **Properties...**, you can view and change the options in it.

**Set objects properties**
1. With the Edit Object command, right-click text objects, images objects, shape objects (or path objects) and shading objects, and choose Properties....

2. There are General tab and Appearance tab in the properties dialog box. The general tab is as below: (Take image objects properties for example.)

You can specify a number of properties that are common to all objects in the General properties.

- **Position X and Y:** Allow you to set the precise horizontal and vertical position of the objects.
- **Width and Height:** Displays the selected object’s width and height values.

3. In Image Object Properties dialog box, in the Appearance tab, drag the slider or enter a value to specify the opacity of the image object. Opacity can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

4. In shape object properties dialog box, please do any of the following:

- **Stroke Color:** The stroke color is used to paint the border of paths and text that are stroked.
- **Fill Color:** The fill color is used to paint the interior of paths and text characters that are filled.
- **Line Width:** The line width specifies the thickness of the line used to stroke a path and is measured in user space units. A line width of 0 specifies the thinnest line that can be rendered on the output device. The default value is 1.

  **Note:** A line width of 0 is an inherently device-dependent value. Its use is discouraged because the line may be nearly invisible when printing on high-resolution devices.

- **Miter limit:** When two line segments meet at a sharp angle it is called a Miter join and has been specified as the line join style. It is possible for the miter to extend far beyond the thickness of the line stroking the path. The miter limit imposes a maximum on the ratio of the miter length to the line width, as shown in the following figure. When the limit is exceeded, the join is converted from a miter to a bevel.

  The value for miter limit is a number that must be greater than or equal to 1, and has a default value of 10.
• **Line Join Style**: The line join style specifies the shape to be used at the corners of paths that are stroked. The allowed values are Miter joins, Round joins and Bevel joins.
  
  - **Miter** — the outer edges of the strokes for the two segments are continued until they meet. If the extension projects too far, as determined by the miter limit, a bevel join is used instead.
  - **Round** — a circular arc with a diameter equal to the line width is drawn around the point where the segments meet and filled in, producing a rounded corner.
  - **Bevel** — the two path segments are drawn with butt end caps (see the discussion of line cap style), and the resulting notch beyond the ends of the segments is filled in with a triangle.

![Miter](image1) ![Round](image2) ![Bevel](image3)

Square line cap style  Round line cap style  Flat line cap style

• **Line Cap Style**: The line cap style specifies the shape to be used at the ends of open sub paths when they are stroked. Allowed values are Butt end caps, Round end caps, and Projecting Square End.
  
  - **Square**: --- the stroke is squared off at the endpoint of the path.
  - **Round**: --- a semicircular arc with a diameter equal to the line width is drawn around the endpoint and filled in.
  - **Flat**: --- the stroke extends beyond the end of the line by a distance that is half the line width and is squared off.

![Square](image4) ![Round](image5) ![Flat](image6)

Square  Round  Flat

• **Dash**: Select a type of line, dashed or solid.
• **Opacity**: Enter a value, or drag the slider to specify the opacity. Opacity can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

5. In text object properties dialog box, please do any of the following:

  **Font Name**— Changes the font used by the selected text to the font you specify.
Font Size – changes the font size to the size that you specify.

Horizontal Scaling – adjusts the width of characters by stretching or shrinking them in the horizontal direction. The scaling is specified as a percent of normal width of the characters, with 100 being the normal width. The scaling always applies to the x coordinate. The following figure shows the effect of horizontal scaling.

<table>
<thead>
<tr>
<th>Word</th>
<th>100 (default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>WordWord</td>
<td>50</td>
</tr>
</tbody>
</table>

Text Mode – determines whether text is stroked or filled. There are four types of text modes: Fill Text, Stroke text, Fill then stroke text, and Text with no fill and no stroke.

1. Fill text   2. Stroke text   3. Fill then stroke text   4. Text with no fill and no stroke

Character Space – inserts uniform spacing between two or more characters in selected text.

<table>
<thead>
<tr>
<th>Character</th>
<th>0 (default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Character</td>
<td>0.25</td>
</tr>
</tbody>
</table>

Word Space – inserts uniform spacing between two or more words in selected text.

<table>
<thead>
<tr>
<th>Word Space</th>
<th>0 (default)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word Space</td>
<td>2.5</td>
</tr>
</tbody>
</table>

For stroke color, fill color, and opacity; please refer to Path Object Properties.
About the Image Editor (Business Edition Only)

When you draw a new image object with the Draw New Image command, or edit an image object with the Edit Object command, the Image Editor appears in the ribbon. Image Editor is an image-editing program that includes various commands and the function panel.

The Tools group

You can select a command by clicking its icon in the Tools group in IMAGE EDITOR. Positioning the pointer over a command will display a tool tip with the command’s name. There are selecting commands and painting commands.

The Selecting tools

The Selecting tools include the Rectangular Marquee command, the Magic Wand command, the lasso commands (the Lasso command and the Polygonal Lasso command), etc. To see how to use these commands, please follow the steps as below.

The Rectangular Marquee command:

- Select the rectangle command \(\square\) from the Tools group.
- Drag over the area you want to select.

The Magic Wand command:

- Select the magic wand command \(\star\).
- In the Image Editor Function Panel, drag the slider to specify the Tolerance, or enter a value ranging from 0 to 255.
- To select only adjacent areas using the same colors, select Contiguous. Otherwise, all pixels using the same colors will be selected.
- In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.

Tip: The magic wand command lets you select a consistently colored area without having to trace its outline. You can specify the tolerance for the magic wand command’s selection.

The Lasso commands:

The Lasso command:
Select the lasso command from the Tools group.
Drag to draw a freehand selection border.

The **Polygonal Lasso** command:

- Select the lasso command from the Tools group.
- Click in the image to set the starting point.
- Double click the image to close the selection.

**Cutting, copying, and pasting selections:**

- Select the area you want to cut/copy.
- Choose the Cut Out command or the Copy command from the Clipboard tab.
- Paste the selection into the same image or another application.

**The Painting tools**

The Painting tools include the Eyedropper command, the Brush command, the Paint Bucket command, the Dodge command, the Burn command and the Eraser command, etc. These commands are generally used in combination with the options in the Image Editor Function Panel.

1. **Setting options for painting**

You can set options for a painting tool in the Function Panel.

**Selecting a blending mode**

The blending mode controls how pixels in the image are affected by a painting or editing tool.

To select a blending mode for a tool, choose from the Mode drop-down menu.

- **Normal**
  
  Edits or paints each pixel to make it the result color. This is the default mode.

- **Color Burn**
  
  Looks at the color information in each channel and darkens the base color to reflect the blend color by increasing the contrast. Blending with white produces no change.

- **Color Dodge**
Looks at the color information in each channel and brightens the base color to reflect the blend color by decreasing the contrast. Blending with black produces no change.

**Darken**

Looks at the color information in each channel and selects the base or blend color--whichever is darker--as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change.

**Difference**

Looks at the color information in each channel and subtracts either the blend color from the base color or the base color from the blend color, depending on which has the greater brightness value. Blending with white inverts the base color values; blending with black produces no change.

**Exclusion**

Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts the base color values. Blending with black produces no change.

**Hard Light**

Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh spotlight on the image.

**Lighten**

Looks at the color information in each channel and selects the base or blend color--whichever is lighter--as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change.

**Hard Mix**

The result of Hard Mix is either 0 or 255 for each channel. If the sum of upper layer value and lower layer value is greater than 255, then it is 255, otherwise the result will be 0. This mode is useful for color enhancement or special effects. See the Example shown below:
Linear Dark/Light

Burns or dodges the colors by decreasing or increasing the brightness, depending on the blend color. If the blend color (light source) is lighter than 50% gray, the image is lightened by increasing the brightness. If the blend color is darker than 50% gray, the image is darkened by decreasing the brightness.

Multiply

Looks at the color information in each channel and multiplies the base color by the blend color. The result color is always a darker color. Multiplying any color with black produces black. Multiplying any color with white leaves the color unchanged. When you're painting with a color other than black or white, successive strokes with a painting tool produce progressively darker colors. The effect is similar to drawing on the image with multiple magic markers.

Overlay

Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing pixels while preserving the highlights and shadows of the base color. The base color is not replaced but is mixed with the blend color to reflect the lightness or darkness of the original color.

Pin Light

Replaces the colors, depending on the blend color. If the blend color (light source) is lighter than 50% gray, pixels darker than the blend color are replaced, and pixels lighter than the blend color do not change. If the blend color is darker than 50% gray, pixels lighter than the blend color are replaced, and pixels darker than the blend color do not change. This is useful for adding special effects to an image.

Screen
Looks at each channel's color information and multiplies the inverse of the blend and base colors. The result color is always a lighter color. Screening with black leaves the color unchanged. Screening with white produces white. The effect is similar to projecting multiple photographic slides on top of each other.

**Soft Light**

Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused spotlight on the image.

**Specifying opacity or flow**

You can specify opacity or flow in the Function Panel for the following tools:

- Opacity specifies the maximum amount of paint coverage applied by the brush, clone stamp, and paint bucket tools.
- Flow specifies how quickly paint is applied by the brush tool.

**To specify opacity or flow**

Enter a value, or drag the slider for Opacity or Flow in the Function Panel.

Opacity or flow can range from 1% to 100%. For transparent paint or a weak effect, specify a low percentage value; for more opaque paint or a strong effect, specify a high value.

2. **Using the Eyedropper command**

The eyedropper command samples color to designate a new foreground or background color. You can sample from the active image. You can also specify the area sampled by the eyedropper command. For example, you can set the eyedropper to sample the color values of a 3-by-3-pixel area under the pointer.

**To sample color with the eyedropper command:**

- Select the eyedropper command \( \text{} \) from the Tools tab.
- In the Pipette palette of Function Panel, choose an option from the Sample Size menu.

  **Note:** 3 by 3 Average or 5 by 5 Average to read the average value of the specified number of pixels within the area you click.

- Click the area containing the color you want to copy.

3. **Using the Brush command**
Image Editor provides the brush command to let you paint with the current foreground color.

- Select the Brush command \(\text{Brush}\) from the Tools tab.
- Do one of the following:
  - Click the triangle \(\text{Brush}\), and set brush options: Diameter to control the size of the brush.
    - Hardness to control the size of the brush's hard center.
  - Specify a blending mode (See “Selecting a blending mode”)
  - Specify an opacity and a flow rate (See “Specifying opacity or flow”)
- Drag the image to paint.

4. Using the Paint Bucket command

The paint bucket command fills adjacent pixels that are similar in color value to the pixels you click.

- Select the paint bucket command \(\text{Paint Bucket}\) from the Tools tab.
- Do one of the following in the Function Panel:
  - Specify a blending mode (See “Selecting a blending mode”)
  - Specify an opacity (See “Specifying opacity or flow”)
  - Specify a tolerance

Note: The tolerance defines how similar in color a pixel must be to be filled. Values can range from 0 to 255. A low tolerance fills pixels within a range of color values very similar to the pixel you click. A high tolerance fills pixels within a broader range.

- Click the part of the image you want to fill.

5. Using the Dodge command

The dodge command is used to lighten areas of the image.

To use the dodge command:

- Select the dodge command \(\text{Dodge}\).
- Do the following in the Function Panel:
  - Set brush options: Diameter to control the size of the brush. (See “Using the brush command”)
  - Select what to change in the image: Shadows to change the dark areas; Highlights to change the light areas.
- Drag over the part of the image you want to modify.
6. Using the Burn command

The burn command is used to darken areas of the image.

**To use the burn command:**

- Select the burn command.
- Do the following in the Function Panel:
  - Set brush options: Diameter to control the size of the brush. Hardness to control the size of the brush's hard center (see “Using the brush command”).
  - Select what to change in the image: Shadows to change the dark areas; Highlights to change the light areas.
- Drag over the part of the image you want to modify.

7. Using the Eraser command

- Select the Eraser command from the Tools tab.
- Do one of the following in the Function Panel:
  - Specify opacity and a flow rate (see “Specifying opacity or flow”).
- Drag the pointer over the area you want to erase.

8. Using the Spot Healing Brush command

The spot healing brush command effortlessly removes dust, scratches, blemishes, and other flaws and automatically preserves the shading, lighting, and texture of the original image.

**To use the healing brush command:**

- Select the spot healing brush command.
- Do the following in the Function Panel:
  - Specify the diameter option to control the size of the brush.
  - Specify the roundness option to control the ratio between the brush's short and long axes.
- Press down Ctrl key and click an area to define a source to repair.

9. Using the Clone Stamp command

The clone stamp command takes a sample of an image, which you can then apply over another image or part of the same image. Each stroke of the tool paints on more of the sample.

**To use the clone stamp command:**
• Select the clone stamp command 🌳.

• Do one of the following in the Function Panel:
  ■ Set brush options: Diameter to control the size of the brush. Hardness to control the size of the brush's hard center (See “Using the brush command”).
  ■ Specify a blending mode (See “Selecting a blending mode”)
  ■ Specify opacity and a flow rate (See “Specifying opacity or flow”).
  ■ Aline: If selected, the position of the source remains fixed relative to the spot where your first brush stroke was, and each brush stroke you paint is cloning an area of the image that is the same distance and direction from the start of the previous stroke; if deselected, every new brush stroke will return to initial clone source spot, and you are making a new copy of your image with each brush stroke.

• Press down Ctrl key and click an area to define a resource. Then move the cursor to copy the located image.

10. Choosing foreground and background colors

You can use the Levels palette to select the foreground or background color by choosing from a color spectrum or by defining colors numerically.

You can designate a new foreground or background color using the eyedropper command (See “Using the eyedropper command”) and the Levels palette.

The default foreground color is black, and the default background color is white.

Levels palette:

The Levels palette displays the color values for the current foreground and background colors.

Entering the value in the Levels palette or clicking the arrows to increase or decrease the value, you can edit the foreground and background colors according to several different color models.

Note: Image Editor uses RGB mode to work with images.

11. Using the Layer palette

The Layers palette lets you set layer opacity, fill layers and choose a blending mode.

Setting layer opacity

A layer’s opacity determines to what degree it obscures or reveals the layer beneath it. A layer with 1% opacity appears nearly transparent, while one with 100% opacity appears completely opaque.
To specify opacity for a layer

1. Select a layer or layer set in the Layers palette.
2. In the Layer palette, enter a value in the Opacity text box or drag the Opacity slider.

12. Hiding/Displaying the Function Panel

To hide/display the Function Panel, please select **Hide Function Panel** button or **Show Function Panel** button.

**The Filter group**

Using filters, please select an item from the Filter tab to add an effect to the image. Move the cursor over one type of filter to preview how the image will look after adding the filter. The filter will be applied only when you click it. And the image with the applied filter will be the original one to be added another filter later if any. To undo the application, you can click **Undo** button on the Quick Access toolbar.

**Flipping and Replacing Images**

Flipping tools are to flip images horizontally or vertically. And you can also replace the original image with other images with the **Replace** command.

To flip images, please do one of the following:

- In the Toolbox, click or to flip the entire image horizontally or vertically.
- To flip the image you select, click the **Rectangle** command or the **Lasso** command to select an area, and click the **Flip** command or.

To replace images, please do the following:

1. On the Images tab, click **Replace** button.
2. In the pop-up Open dialog box, search the image file you want and click **Open** button.

**Note:** Only BMP, PCX, TIF, and JPEG format file can be opened.
3. You get a confirmation message asking you if you want to continue to replace the current active image. If yes, click the Ok button to finish.

*Note: The replaced image will never be recovered.*

## Spelling Check

Foxit PhantomPDF allows users to check the spelling of PDF files and provides suggestions to correct misspelled words. This feature is useful when users want to proofread text. You can check for possible mistakes and then confirm each correction.

By default, PhantomPDF automatically checks the spelling when you edit text or use the typewriter tools. You can disable the automatic spelling check by unchecking **Enable spell check** from **File > Preferences > Spelling**.

To check spelling within an entire document, please do the following:

- Click **Edit > Edit Content > Check Spelling** button
- In the pop-up **Check Spelling** dialog box, you will see the suspect word and suggestions for correction.
  - **Ignore** – Click **Ignore** if no correction is needed.
  - **Ignore All** – Click **Ignore All** to skip all further occurrences of the current “misspelling”.
  - **Change** – Click **Change** after selecting one suggestion to make the suggested correction.
  - **Add To Dictionary** – Click **Add to Dictionary** if the suspect word is spelled correctly but doesn’t appear in Foxit PhantomPDF’s dictionary. Choosing **Add to Dictionary** adds the word to Foxit PhantomPDF’s custom dictionary, which is a supplemental list of spelled-correctly words used to proofread a document.
  - **Cancel** – Click **Cancel** to exit the **Check Spelling** dialog box.

*Tip: You can add, remove, or reorder dictionaries in **File > Preferences > Spelling**.*

## Working with Layers

A layer or as it is more formally known Optional Content Groups (OCG) is a dictionary representing a collection of graphics that can be made visible or invisible dynamically by users of viewer applications. In a PDF file, each layer may hold any portion of the document’s objects, and layers may be made visible or invisible, showing or hiding their contained objects, in any combination.

With Foxit PhantomPDF, you can control the display of PDF layers with the **Layers** panel. For example, you may divide background imagery, main content areas, and advertisements amongst their own top-level layers, and easily hide the layers that you don’t want others to view.
Show /hide PDF Layers

In a PDF, information can be stored on different layers. To show or hide related content stored in a variable number of separate layers, you can simply refer to the Layers panel on the left side of the work area. You can view layers and choose to show or hide the content associated with each layer.

![Layers Panel]

The Layers Panel

A. A checkmark indicates a displayed layer  B. Hidden layer

1. Open the Layers panel, and then do one of the following:

   • To hide a layer, uncheck the layer.
   • To show a hidden layer, click the empty box and a checkmark will appear.

2. From the Options menu at the top right corner of the Layers panel, choose one of the following:

   • List Layers for All Pages – Shows every layer across every page of the document.
   • List Layers for Visible Pages – Shows layers only on the visible pages.
   • Reset to Initial Visibility – Resets layers to their default state.
   • Expand All – Expands all layers.
   • Collapse All – Collapses all of the current layers in the view.
   • Apply Print Overrides – Determines whether to display a layer according to its corresponding Print setting in the Layer Properties dialog box. The option is available when Never Prints or Always Print is selected.
   • Apply Export Overrides – Determines whether to display a layer according to its corresponding Export setting in the Layer Properties dialog box. The option is available when Never Exports or Always Exports is selected.
   • Apply Layer Overrides – Displays all layers in the document regardless of the settings in the Layer Properties dialog box, and you cannot change layer visibility until you deselect this command or choose Reset To Initial Visibility in the Options menu. However, you are still
allowed to rename layers when the command is selected.

**Import Layers (Business Only)**

You can import layers from a PDF file or import images as layers into a target PDF file.

1. In the navigation pane, click the menu button 📅 in the top right corner of the Layers panel, and choose **Import as Layer**....

2. In the **Import as Layer** dialog box, click **Browse** to choose a PDF file or an image file (Formats like BMP, GIF, JPEG, JPEG 2000, PCX, PNG, and TIFF, are supported.). If you import from a PDF file, choose a page number you want to import from.

3. **Import Options**:
   - **Create new layer**: creates a new layer from the source file. Specify a layer name, and add it to an existing layer group in the target document as needed.
   - **Add to existing layer**: adds the imported content to an existing layer in the target document. The imported layer will have the same properties as the existing one. This option is available only when the target document contains layers.
   - **Copy layers from source**: imports the layers from the source PDF file. This option is available only when the source PDF file contains layers.

4. In the right part of the dialog box, select a target page number to import the layers to, and preview the result.

5. Complete the settings in **Position** and **Appearance** as needed.

6. Then click **OK**.

**Merge Layers (Business Only)**

1. In the navigation pane, click the menu button 📅 in the top right corner of the Layers panel, and choose **Merge Layers**....

2. In the **Merge Layers** dialog box, select one or more layers you want to merge and the target layer to merge the selected layers into.

3. Then click **OK**.

**Note:** Merged layers will have the same properties of the target layer. After you merge the layers, you cannot undo the operation.

**Flatten Layers (Business Only)**

1. In the navigation pane, click the menu button 📅 in the top right corner of the Layers panel, and choose **Flatten Layers**.

2. A warning message pops up, telling you that the flattening operation cannot be cancelled or undone.
3. Then click OK.

Note: After the flattening operation, all layers will be consolidated, while the layers that are originally not visible will be removed. After you flatten the layers, you cannot undo the operation.

Delete Layers

1. In the navigation pane, select the layer you want to delete.
2. Click the menu button in the top right corner of the Layers panel, and choose Delete Layer, or press Delete on the keyboard. Or, right-click the layer and choose Delete Layer from the context menu.

Note: When you delete a layer, its corresponding content will be removed.

Reorder Layers

You may need to change the order of layers in the list, or move a layer from one layer group to another. In the navigation pane, to reorder a layer, just press Alt while you click the layer’s name and drag it to the desired location. You can undo or redo the operation.

Note: You cannot reorder locked layers or layers in nested layer groups.

Layer Properties

By editing layer properties in the Layer Properties dialog box, you can control the visibility of layers and set whether to print or export layers. For example, you can hide a layer whenever the document is displayed on screen, while ensuring that the layer always prints. You can view but cannot edit the layer properties in Standard edition.

1. To open the Layer Properties dialog box, select the layer, click the Options menu and choose Layer Properties.... Or just right-click the layer and choose Properties... to open the Layer Properties dialog box.
2. Edit the layer name or any of the following:

   Intent – selects View and the visibility and properties of the layer can be edited any time. Or, selects Reference to keep the current visibility and setting at all times until you switch to View.

   Default State – Defines the initial visibility state when Visibility in Initial State is set to Visible When On.

   Visibility – Defines the visibility of the layer when the document is opened or when the
initial visibility is reset. If you choose Visible When On, the layer is visible only when Default State is On.

Print – Defines whether the layer will be printed when you print the PDF. If you choose Print When Visible, the layer will print only when the layer is visible.

Export – Defines whether the layer will appear in the resulting document when the PDF is exported to an application or file format that supports layers. If you choose Export When Visible, the layer will appear in the resulting document only when the layer is visible.

The previous settings in Initial State like the states of Print, View, and Export, are shown in the box at the bottom of the Layer Properties dialog box.

PDF Properties

To view and modify the PDF properties, please navigate to File > Properties.

Description

This tab shows some basic information about the document. The person who created the document in the source application may have set the title, subject, author, and keywords. Click Custom, and the pop-up Custom Properties dialog box shows some document information (such as comments and the company name). You can easily edit the document information within the PDF document, a useful way for searching and indexing files.

You can also customize document properties by clicking Custom. In the pop-up Custom Properties dialog box, input the property name and the value, and then click Add to add a custom property. To change the value of a property, select it and update the value, and then click Change. To change the name of a custom property, you need to delete the property and create a new custom property. To delete a property, select it and click Delete.

Initial View

When a user opens your PDF document, they see the initial view of the PDF. You can set the initial view to the magnification level, page and page layout that you want. If your PDF is a presentation, you may want to set the initial view to Full Screen Mode. After you define the initial view of the PDF, you can add page transitions to selected pages of the entire document.

Define the initial view as Full Screen mode

When setting the initial view of a PDF to Full Screen mode, you must define how the document opens.
2. In the Document Properties dialog box, select Initial View.
3. For best results, do the following:
   - Choose Page Only from the Navigation tab menu.
   - Choose Single Page from the Page layout menu.
   - Set Open to page to the page on which you want to start the presentation.
4. Select Open in Full Screen mode to open the document without the menu bar or toolbar displayed. Click OK. (You have to save and reopen the file to see the effects.)

**Note:** Users can exit Full Screen mode by pressing Esc if their preferences are set this way. However, in Full Screen mode, users cannot apply commands and select tools unless they know the keyboard shortcuts. You may set up page actions in the document to provide this functionality.

**Security**

This tab describes security permissions and what functionality is allowed within a PDF.

See also “Checking PDF Security”

**Fonts**

The Fonts tab lists the fonts and the font types used in the original document, as well as the encoding used to display the original fonts.

**Advanced**

This tab lists the items of Print Dialog Presets which prevail over the settings in the Print dialog box during printing.

**Page Scaling:** Chooses Default to scale the page with the application default setting when printing, which is Fit to printer margins. Or choose None to preserve the scale in the documents. To print with additional page scaling types as shown in the Print dialog box, you need to choose one of them when printing.

**DuplexMode:** Chooses Simplex to print on one side of the page. Or choose Duplex Flip Long/Short Edge to print a document double sided and flip pages on long/short edges.

**Paper Source by Page Size:** Automatically selects the paper type according to the page size of the PDFs when printing.

**Print Page Range:** Specifies the page range you want to print.
**Number of Copies:** Chooses the number of copies you want to print. Or choose **Default** to use the application default copies, which is one copy.
Chapter 6 – Organize

Foxit PhantomPDF comes with a built-in functionality to combine various PDF files & split one PDF into various small single & multiple page PDF files according to page numbers as well as page range. You can rearrange pages and composing page outlines with the commands under the ORGANIZE tab, which allow you to insert, move, replace and crop pages, split documents, add page marks (such as header & footer) to PDFs, and more.

See also the tutorial on Organize PDF Documents.

Insert Pages

Foxit PhantomPDF enables you to insert pages from files (either from a page range or the entire file), a folder, a scanner, clipboard and a blank page. You can also insert pages into multiple documents at a time.

Insert pages from file

Foxit PhantomPDF allows you to insert pages from a file or multiple files into a PDF.

To insert pages from a file or multiple files into a PDF, open the PDF and do either of the following:

- Directly drag the page thumbnails from a PDF file or files (not limited to PDFs) to the Pages panel of navigation pane and drop at the place where you want to insert. (Tip: with a mouse with a scroll wheel, you can press and hold Ctrl while scrolling up/down to zoom in or out the page thumbnails in the Pages panel.) If you need to insert certain pages from a non-PDF file, please choose the other method.

- Choose ORGANIZE > Pages > Insert > From File, or click the Insert button on the Pages panel of navigation pane, or right-click one page thumbnail and choose Insert Pages... > From File. In the pop-up dialog box, select the files that you want to insert into the target document, and click Open. If the files are non-PDF files and you only want to add certain pages not the whole files, please choose to preview first in the pop-up Foxit PhantomPDF message. Then do the following steps to finish:

1. In the Insert Files dialog box, you can still add files, folder and open files further by clicking Add Files... button.
2. Then choose one file you added, specify where you want to insert to the current PDF document (at the beginning or the end, or before or after a designated), and page range (insert from ...to ...) of the file that you want to insert. (Tip: If you click on a page thumbnail and press the shortcut keys Ctrl+A, all page thumbnails will be selected.)
3. Check **Show Preview** in the lower left corner, and you can preview the target page and the insert page in preview boxes. Click **OK** to insert the pages.
4. To leave the original PDF intact as a separate file, choose **File > Save As**, and type a new name for the merged PDF.

**Note:** When a whole file is inserted, its bookmarks will be inserted at the end of the bookmarks of the original PDF. The links of the bookmarks inserted remain unchanged. And the combined bookmarks will be the bookmarks of the combined PDF file.

### Insert pages from folder

1. Open a PDF file, and choose **ORGANIZE > Pages > Insert > From Folder**, or right-click one page thumbnail and choose **Insert Pages... > From Folder**.

2. The **Browse For Folder** dialog box pops up. Select the folder that you want to insert into the target document, and click **OK**. (See also “**Insert pages from file**”.)

### Insert pages from open files

1. Open a PDF file, and choose **ORGANIZE > Pages > Insert > From Open Files**, or right-click one page thumbnail and choose **Insert Pages... > From Open Files**.

2. (Optional) Directly drag the page thumbnails from an open PDF file and drop at the target place of the current PDF file.

3. In the pop-up **Open PDF Files** dialog box, select files you want to insert and click **Add Files** to continue. (See also “**Insert pages from file**”.)

### Insert pages from a scanner

You can insert pages from a paper document using Foxit PhantomPDF and your scanner.

1. Open the PDF that you want to serve as the basis of the combined file, and choose **ORGANIZE > Pages > Insert > From Scanner**, or right-click one page thumbnail and choose **Insert Pages... > From Scanner**. In the pop-up From Scanner dialog box, specify the place you want to insert pages.

2. Then select a scanner, the input and documents options in the Custom Scan dialog box, and then click **Scan**.

**See also** “**Create a PDF Using Scanner**”

3. To leave the original PDF intact as a separate file, choose **File > Save As**, and type a new name
for the merged PDF.

**Insert pages from clipboard**

1. Open a PDF file, and choose **ORGANIZE > Pages > Insert > From Clipboard**, or right-click one page thumbnail and choose **Insert Pages... > From Clipboard**.

2. In the pop-up From Clipboard dialog box, specify the place you want to insert pages. Then the content in the clipboard will be inserted.

3. To leave the original PDF intact as a separate file, choose **File > Save As**, and type a new name for the merged PDF.

**Insert pages from a blank page**

1. Open the PDF that you want to use as the basis of the combined file, and choose **ORGANIZE > Pages > Insert > Blank Page**, or right-click a page thumbnail and choose **Insert Pages... > Blank Page**.

2. In the Insert Blank Pages dialog box, specify where in the document you want to insert the blank pages (as well as how many blank pages you want to insert), and click **OK**.

3. To leave the original PDF intact as a separate file, choose **Save As**, and type a new name for the merged PDF.

**Insert pages into files**

1. Open the PDF file (i.e. source file) from which you want to choose a range of pages (i.e. source pages) to be inserted into other files. Click **ORGANIZE > Pages > Insert > Into File**, or right-click a page thumbnail and choose **Insert Pages... > Into File**.

2. In the pop-up **Open** dialog box, choose the file (i.e. target file) to which you want to insert the source pages and click **Open**.

3. In the pop-up **Insert Pages Into** dialog box, you can add more target files by clicking **Add Files...**.

4. Then specify the page range to be inserted and the destination in the target files.

5. Choose whether to keep the source pages in the source PDF file after inserting.

6. Click **Output Options** to specify the output folder and the file names.

7. Check **Show Preview** in the lower left corner, and you can preview the target page and the insert page in preview boxes. Click **OK** to insert the pages.
Rotate, Move, Swap and Delete Pages

Rotate Pages

You can rotate all or selected pages in a document.

1. Open the PDF document within which you want to rotate pages.
2. (Optional) To rotate one page, choose ORGANIZE > Transform > click Rotate Pages
   > Left/Right. Rotation is based on 90° increments.
3. To rotate one or more pages, please use one of the following methods:
   - Choose ORGANIZE > Transform > click Rotate Pages > Multi-page rotate.
   - Right-click the selected page thumbnails and choose Rotate Pages.
   - Select multiple page thumbnails in the Pages panel and click the Rotate
     Counterclockwise button and Rotate Clockwise button. Rotation is
     based on 90° increments.
4. In the pop-up Rotate Pages dialog box, specify the direction you want to rotate the
   pages and the page range.
5. Click OK.

Note: To temporarily change your view of the page, choose View > Page Display > Rotate
View > Rotate Left or Right. The original page orientation is restored the next time you open
the PDF.

Move Pages

The Move Pages feature allows you to move pages within a PDF document.

Move one or more pages within a PDF document

1. Open the PDF document within which you want to move pages.
2. Choose ORGANIZE > Pages > Move , or right-click the page thumbnail and choose
   Move Pages....
3. In the Move Pages dialog box, specify where you want to move pages within the document,
   and page range that you want to move.
4. Click OK.
**Note:** Tagged bookmarks affect the order that reading devices follow, such as devices for the visually impaired. Tagged bookmarks do not change the sequence of pages in a PDF.

### Move one or more pages within a PDF, using page thumbnails

1. Click the Pages button to open the Pages panel, and select one or more page thumbnails.
2. To move a page, drag the page thumbnail(s) to the new location.

### Swap Two Pages

The Swap feature is useful sometimes if you want to swap two different pages within a PDF document.

1. Open the PDF document within which you want to swap pages.
2. (Optional) Directly drag and drop the page thumbnail to the target location in the Pages panel of navigation pane.
3. Choose ORGANIZE > Pages > Swap or right-click the page thumbnail and choose Swap Pages....
4. In the Swap Two Pages dialog box, select or enter two different page numbers in the Swap and For options.
5. Click OK.

### Delete Pages

After combining PDF files, you can delete unwanted or blank pages.

**Delete Pages using the Delete command**

1. Open the PDF document where you want to delete pages.
2. Choose ORGANIZE > Pages > Delete.
3. Specify a page range and click OK to delete the selected pages.

**Note:** If you want to retain a copy of the original PDF, make sure that you save the new document using Save As rather than Save.

**Delete Pages using page thumbnails**

1. In the Pages panel, select a page or group of pages:
   - Drag the mouse to select the page thumbnails.
   - Shift-click or Ctrl-click to select a range of page thumbnails.
2. Press **Delete** to delete the selected pages. Or right-click the selected pages, choose “Delete Pages...” in the context menu and click **OK**.

**Extract, Duplicate and Replace Pages**

**Extract Pages**

Extraction is the process of reusing selected pages of one PDF in a different PDF. Extracted pages contain not only the content but also all form fields, comments, and links associated with the original page content.

You can leave the extracted pages in the original document and create a new PDF that includes all of the extracted pages during the extraction process - comparable to the familiar processes of cutting-and-pasting or copying-and-pasting, but on the page level.

*Note:* Any bookmarks or article threading associated with pages are not extracted.

1. Open the PDF in Foxit PhantomPDF and choose **ORGANIZE > Pages > Extract**. Check **Show Preview** to preview the current document in the pop-up **Extract Pages** dialog box.
2. (Optional) Right-click the page thumbnails that you want to extract and choose **Extract Pages...** to open **Extract Pages** dialog box.
3. In the **Extract Pages** dialog box, specify the page range to be extracted. To extract even or odd pages, the page range should include both one even page and one odd page at least.
4. Choose a type of **Extract Mode** and then check the following options as needed:

   **Immediately save extracted pages**: save the extracted pages into a new PDF file after you click **OK**. The saved file will not be opened in Foxit PhantomPDF automatically. If the item is not checked, a new PDF file that includes the extracted pages will be opened without being saved. You will have to manually save it.

   **Delete the pages after extraction**: delete the selected pages from the original document.

5. Click **OK** after setting.

*Note:*

1. If you choose **Extract pages as one PDF**, the extracted pages will be placed in a new PDF document named “Extracted pages from [original document name].pdf”.
2. If you choose **Extract each page as a PDF**, the **Immediately save extracted pages** option is not available. You will need to choose a folder to store the generated PDFs after clicking **OK**. Each extracted page will be placed in a separate PDF named “[original document name]_1.pdf”, “[original document name]_2.pdf”, and so on.
3. The creator of a PDF document can set the security to prevent the extraction of pages. To view the security settings for a document, choose File > Properties, and select Security tab.

**Duplicate Pages**

The Duplicate Pages feature allows you to copy pages within a PDF document.

1. Open the PDF document within which you want to copy pages.
2. Choose ORGANIZE > Pages > Duplicate, or right-click the page thumbnail and choose Duplicate Pages....
3. In the Duplicate Pages dialog box, specify where you want to copy pages within the document and the page range that you want to copy.
4. Click OK.

*Tip:* To duplicate pages, you can also move the page thumbnails of the page(s) you want to duplicate while pressing and holding down the Ctrl key in the Pages panel.

**Replace Pages**

You can replace an entire PDF page with another PDF page. The text, images and comments on the original page will be replaced.

To quickly update a PDF, you can replace individual pages.

1. Open the PDF that contains the pages you want to replace. Choose ORGANIZE > Pages > Replace, or right-click the page thumbnails that you want to replace and choose Replace Pages....
2. Select the PDF document containing the replacement pages, then click Open.
3. In the pop-up Replace Pages dialog box, from the original PDF file select pages you want to replace and select replacement pages from the selected file. You can click Browse to change the selected file.
4. Click OK to finish.

*Note:* The bookmarks associated with the original pages will be unavailable after the replacement.

**Split PDFs into multiple files**

The Split Document feature is a process of splitting one or more documents into multiple smaller-
size documents.

1. Open the PDF document you want to split.

2. Choose ORGANIZE > Pages > Split , or right-click on the target page thumbnails and choose Split Document in the context menu.

3. In the Split Document dialog box enter the maximum number of pages or file size after splitting, or choose whether to split by the top-level bookmarks if the document has bookmarks. Check Blank Page, and the document will be split each time a blank page is encountered. Blank pages will be discarded when splitting.

4. Click Select More Files... to split more files. Click Output Options to specify the storage location, the file names, and other settings.

5. Click OK.

**Crop Pages**

The Crop Pages feature allows you to adjust the visible page area. You can create a PDF document with pages of different sizes.

**Crop one or more pages**

1. Open the PDF document you want to crop.
2. Right click the target page(s) on the Pages thumbnails, choose Crop Pages.
3. In the pop-up Crop Pages dialog box, specify the settings in the Margin Control: select CropBox, ArtBox, TrimBox, or BleedBox (they are displayed in the preview box in black, red, green and blue respectively) and adjust the proportions to crop. You can preview all the boxes on the right after checking the item Show All Boxes.

   **CropBox** – Defines the content boundary of the page when it’s displayed or printed.

   **ArtBox** – Defines the meaningful content of the page including blank space.

   **TrimBox** – Defines the final dimensions of the page after trimming.

   **BleedBox** – Defines the clipping path when the page is printed professionally to allow for paper trimming and folding. Printing marks may fall outside the bleed area.

   **Constrain Proportions** – Locks the cropped proportions and each margin will have the same distance from each side to the border.
**Remove White Margins** – Crops the page to the artwork boundary, which is useful for trimming the edges of presentation slides saved as PDFs.

**Set To Zero** – Restores all the crop margins to zero.

**Reset** – Resets all the margins to the original dimensions.

4. A rectangle in the page thumbnail showed in the preview box shows the boundaries of the cropped area.
5. Set the page size and adjust the center of the page content if needed.
6. Choose the page range you want to crop.
7. Choose the unit of the margin cropping values.
8. Click **OK**.

**Crop one page**

1. Choose **ORGANIZE > Transform > Crop** , the cursor will change to “”. Drag the cursor to select an area you want to crop. Then double-click the area you cropped.

2. In the pop-up Crop Pages dialog box, the margin measurement indicates the size of the area you selected. You can directly click **OK** or provide new settings in the dialog box.

   **Note:** Cropping does not reduce file size because information is not discarded but merely hidden. So you can restore the page and its content to its original dimensions by resetting the page size.

**Flatten Pages**

The Flatten Pages feature can discard interactive annotations in the PDF file and make them become part of objects of the PDF pages.

1. Open the PDF document where you want to flatten pages.
2. Choose **ORGANIZE > Transform > Flatten** .
3. In the Flatten Pages dialog box, specify the page range (current page, all pages, a range of pages), and click **OK**.

   **Note:** If you want to retain a copy of the original PDF, make sure that you save the new document using **Save As** rather than **Save**.
Header & Footer, Watermark & Background to PDFs

Add Header/Footer, Watermark/Background to PDFs with Text, image and PDF, making your PDFs more professional and easy to view, navigate watermark and place marks on documents.

See also the tutorial on Professionalize Documents.

Header & Footer

✧ To add a new header & footer, please do the following:

2. Edit the text of header & footer in the “Add Headers and Footers” dialogue box.
3. (Optional) Click Save Settings at the top of the dialog box to save the current settings as a profile that can be applied directly to future documents.
4. Click OK to activate the operation.

✧ To update the header & footer, please do the following:

1. Choose ORGANIZE > Page Marks > Header &Footer > Update.
2. Update the content in the “Update Headers and Footers” dialogue box.
3. Click OK to activate it.

✧ To remove the header & footer, please do the following:

1. Choose ORGANIZE > Page Marks > Header &Footer > Remove All.
2. Click “Yes” in the pop-up message box.

Background

✧ To add a new background, please do the following:

1. Choose ORGANIZE > Page Marks > Background > Add.
2. Edit the background in the “Add Background” dialogue box.

- Choose one color as the background, or add the file from your computer via clicking the browse button. If the file has many pages, you can select one of them.
- Set the appearance by choosing the rotation degree, the opacity. You also can choose to make the scale relative to the target page or not. Click “Appearance Options” to set when to display the background.
- Set the vertical and horizontal distance between the target page and the background.
- Choose the page range to play the background. You can select all pages or specify the page range, or choose even pages or odd pages via clicking the right items in the subset list.
• Check or uncheck the **Show Preview** option to preview the changes or not.

3. (Optional) Click **Save Settings** at the top of the dialog box to save the current settings as a profile that can be applied directly to future documents.

4. Click **OK** to activate it.

✧ **To update the background, please do the following:**

1. Choose **ORGANIZE > Page Marks > Background > Update**.
2. Update the content in the “Update Background” dialogue box.
3. Click **OK** to activate it.

✧ **To remove the background, please do the following:**

1. Choose **ORGANIZE > Page Marks > Background > Remove**.
2. Click “Yes” in the pop-up message box.

**Watermark**

✧ **To add a new watermark, please do the following:**

1. Choose **ORGANIZE > Page Marks > Watermark > Add**.
2. Edit the watermark in the “Add Watermark” dialogue box.

• Input the text as the background and choose the font, size and the color, or add the file from your computer via clicking the browser button. If the file has many pages, you can select one of them.
• Set the appearance by choosing the rotation degree and the opacity. You can also choose to make the scale relative to target page or not. Click “Appearance Options” to set when to display the watermark.

➢ If you choose the “appear behind page”, the page content will obstruct your view of some part of the watermark.
➢ If you choose the “appear on the top of page”, the watermark will cover some content, but you can adjust it via setting the opacity of the watermark.

• Set the vertical and horizontal distance between the target page and the watermark.
• Choose the page range to play the watermark. You can select all pages or specify the page range, or choose even pages or odd pages via clicking the right items in the subset list.
• Check or uncheck the **Show Preview** option to preview the changes or not.

3. Click **Save Settings** at the top of the dialog box to save your current settings as a profile that can be applied to other documents directly next time.

4. Click **OK** to activate it.
To update the watermark, please do the following:

1. Choose ORGANIZE > Page Marks > Watermark > Update.
2. Update the content in the “Update Watermark” dialogue box.
3. Click OK to activate it.

To remove the watermark, please do the following:

1. Choose ORGANIZE > Page Marks > Watermark > Remove.
2. Click “Yes” in the pop-up message box.

Bates Numbering (Business Edition Only)

What’s Bates Number?
Bates numbering is used in the legal, medical, and business fields to place identifying numbers and/or date/time-marks on images and documents. These numbers may be solely numeric or may contain a combination of letters and numbers. It is a unique serial number attached to every page of a document collected and is also a method of indexing legal documents for easy identification and retrieval.

Add Bates Number

2. In the “Add Bates Numbering” dialog box, add the files, folders or opened files by clicking Add Files, Add Folders or Add Open Files. In the files list, you can change the order by clicking Move Up or Move Down and delete a file by clicking Remove.
3. Click Output Options. Here, you can set the target output folder, name the file and create the log file in the dialogue box. Click OK to exit the box after completing these settings.
4. Click OK and a dialog box to add Headers and Footers will pop up for you to insert Bates Numbering on the PDF documents.
   - Click Insert Bates Number...
   - Another dialog box will appear for setting the number of digits used, the start number, rotate angle and the prefix/suffix, if needed. Click OK to finalize the setting.
   - Click OK button.

Remove Bates Number

Choose ORGANIZE > Page Marks > Bates Numbering > Remove All.

Adding Format Page Numbers

If your PDF file contains front matter likes document cover and copyright page, the page numbers
on the document pages (i.e. printed page number) may not start from the document cover but from the body pages. You may need to synchronize the page numbers displayed below the page thumbnails (i.e. format page number) with printed page numbers. Foxit PhantomPDF enables users to add format page numbers to meet different needs.

To add custom format page number, please do as below:

1. Click ORGANIZE > Page Marks > Format Page Numbers. Or right-click a page thumbnail and select Format Page Numbers....

2. In the Page Numbers dialog box, specify a range of pages you want to number and set the style of page number and the number you want to start at. You can also add a prefix to the number, like adding a letter “P” before the number. You can preview the result viewing the Sample at the bottom of the dialog box.

3. If you need to continue the numbering sequence from previous pages without interruption, please check Extend numbering used in preceding section to selected pages.

4. Click OK to finish.
Chapter 7 – Comments

A comment is a written note intended as an opinion, an explanation, an illustration, or a statement of fact or opinion, especially a remark that expresses a personal reaction or attitude. You can type a text message or add a line, circle, or other shape to make comments on PDFs you are reading with Foxit PhantomPDF commenting commands. You can also edit, reply, delete, and move the comments with ease.

Commenting Commands

There are various annotation tools with different functions for you to choose: Text Markup Tools, Pin Tools, Typewriter Tools, Drawing Tools, Measure Tools and Stamp Tools. You can add different comments by selecting the annotation tools from the Comments tab or Toolbar. See also the tutorial on Commenting Tools.

Text Markup Tools

You can use Text Markup tools to indicate where text should be edited or noticed. Text Markups do not change the actual text in the PDF. Instead, they indicate which text should be deleted, inserted, highlighted or underlined. Text Markup tools include Highlight, Squiggly, Underline, Strikeout, Replace, and Insert.

To add a text markup comment:

- Choose Comment > Text Markup > select [Markup tools name]. Then click and drag from the beginning of the text you want to mark up.
- (Optional) Select the Hand command , Select Annotation command or the corresponding Text Markup tool > right-click the markup > choose Open Popup Note. Type text in the pop-up note. You can also use the Select Text and Image command to copy and paste text from a PDF into the note, or copy the note using Ctrl + C in other applications.
- (Optional) Change the appearance of text markup comments in the Comment Format tab that appears when you choose a text markup tool. If you need to format the text in the pop-up note, select the text and choose the desired option in the Comment Format context tab.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Highlight Text</td>
<td>To mark important passages of text with a fluorescent (usually) marker as a means of memory retention or for later reference.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>✏️</td>
<td>Squiggly Text</td>
<td>To draw a squiggly line under. Similar to the Underline command.</td>
</tr>
<tr>
<td>✏️</td>
<td>Underline Text</td>
<td>To draw a line under to indicate emphasis.</td>
</tr>
<tr>
<td>✏️</td>
<td>Strikeout Text</td>
<td>To draw a line to cross out text, making others know the text is deleted.</td>
</tr>
<tr>
<td>✏️</td>
<td>Replace Text</td>
<td>To draw a line to cross out text and provide a substitute for it.</td>
</tr>
<tr>
<td>✏️</td>
<td>Insert Text</td>
<td>A proofreading symbol (^) used to indicate where something is to be inserted in a line.</td>
</tr>
</tbody>
</table>

**Note:** If you want to add multiple comments without reselecting the same tool, you can check **Keep Tool Selected** at Comment > Manage Comments.

### Pin Tools

You can use pin tools to add comments by adding notes and attaching a file. In note comments you can type a text message. Using the command ✏️, you can attach a file in the document as a comment.

**Add a Note Comment**

- To add a note comment, please click the Note command ✏️, click where you want to place the note and enter text in the box.
- (Optional) Change the appearance of note comments in the Comment Format tab that appears when you select a commenting tool.
- (Optional) If you need to format the text in the pop-up note, select the text and choose the desired option in the Comment Format context tab.

**Add a file attachment**

To add a file attachment as a comment, do the following:

- Click the button 📄 on the Pin group under the Comment tab.
- Position the pointer to the place where you want to attach a file as a comment > click the selected position.
- In the Add Attachment dialog box, select the file you want to attach, and click Open.

**Note:** If you try to attach certain file formats (such as EXE), Foxit PhantomPDF will provide you with a warning that your attachment will be denied due to your security settings.
The File Attachment Icon appears at the place you designated.

**Typewriter Tools**

The Typewriter tools include Typewriter, Callout, and Textbox.

**Typewriter**

You can use the Typewriter command to add comments anywhere on a PDF, which doesn’t appear as annotations.

*Note: The Typewriter command can be used to fill forms. See also “Filling non-interactive forms”.*

**I'm using the Typewriter Tool.**

- **Add comments with typewriter**
  - Choose the **Comment** tab > the **Typewriter** group > the **Typewriter** command.
  - Put the cursor on the area to type any text you want. The **Comment FORMAT** tab appears for you to specify the font format, add bullets, align text, etc.
  - Press **Enter** if you want to start a new line.
  - To finish typing, click anywhere outside the text you have inputted.

*Tip: It’s easy to copy-and-paste text to PDF document as a typewriter annotation from a text document or webpage.*

- **Editing the typewriter comment**
  - Choose the **Comment** tab > the **Typewriter** group > the **Typewriter** command.
  - Put the pointer between the letters and double-click to activate the typewriter text field.
  - Do any changes to the text you have inputted by using the Comment FORMAT tab. Use **Backspace** or **Delete** keys to delete the characters before or after the pointer.
  - To finish editing, click anywhere outside the text field.

*Tip: You can use the Arrow Keys to move the pointer right and left or up and down.*

- **Spell Checking Typewriter Input**

You are able to use the Spell Checker to check your typewriter input give you correcting suggestions if the security settings allow. The Spell Checker component has been integrated into Foxit.
PhantomPDF. However in the future when an update of this component is available on the Foxit server, you have to manually download the component by going to Check for Updates in the Help menu of Foxit PhantomPDF.

If you have installed Spell Checker, when you use typewriter to insert any English text, this tool will try to find any spelling errors and highlight them with squiggly lines.

- Right click on the misspelled words, and you will see a list of suggested words.
- Choose one of the suggested words to correct your input or ignore the squiggly line.

isión

Do one of the following:

- Choose the Comment tab > the Typewriter group > the Typewriter command and put the cursor on the typewriter comment when the cursor turns to be an arrow ▶, hold down the mouse and drag the typewriter comment to the intended place.

Tips:
- You can use Home, End or Arrow Key to move the cursor among characters.
- When moving the typewriter comment, a rectangle appears.

- Select the Hand command or the Select Annotation command, click the typewriter comment, and move it to the intended place.

- Choose the Comment tab > the Typewriter group > the Typewriter command. Position the cursor to the ending or the beginning of the text, drag the cursor to select them all, and press the Delete key.

- (Recommended method) Click the Select Annotation command or the Hand command , right-click the text field, and choose Delete.

Callout and Textbox

Callout and Textbox are designed for users to create comments in a callout text box or a box.

Callout text boxes are especially useful when you want to single out (but not obscure) a particular area of a document.
A textbox is a rectangle of any size, possibly with a border that separates the text box from the rest of the interface, allowing the user to input text information. A text box usually remains visible on the document page. It doesn’t close like a pop-up note.

**Note:** You can add comments to Japanese, Chinese, and Korean text with the Callout command or Textbox command, but you must have the Eastern Asian Language module installed. Callout text boxes and Text boxes allow for horizontal text only.

- **Add a callout or textbox**
  - Choose Comment > Typewriter > Callout/Textbox.
  - Click the place where you want to insert the callout or text box. The Comment FORMAT tab appears for you to specify the font format, add bullets, align text, etc.
  - Type the text. Text wraps automatically when it reaches the right edge of the box.

- **Resize, move, edit or delete a callout or textbox**

Select the Hand command 😏, the Select Annotation command 🗿 or the corresponding annotation tool, and do one of the following:

- To resize the callout or textbox, select it and drag any of the handles to resize it.
- To move the callout or textbox, select it and drag to the intended place.
- To edit the callout or textbox, double-click it and do the editing by using the Comment
FORMAT tab.

- To delete the callout or textbox, select it and press Delete, or right-click it and then choose Delete.

Setting callout or textbox preferences

Please refer to “Editing the typewriter comment”.

Drawing Tools

Drawing Tools allow you to mark up a document with rectangles, ovals, polygons, clouds, arrows, lines, polylines, etc. It is quite useful when you have to make some shapes to mark the text or image.

To add a drawing markup comment,

- Choose Comment > Drawing Markup > select [Markup tools name]. Then click and drag to make a shape you want to mark up.
- (Optional) Change the appearance of drawing markup comments in the Comment Format tab that appears when you choose a drawing markup tool.
- (Optional) Double-click the markup to write the comment. If you need to format the text in the pop-up note, select the text and choose the desired option in the Comment Format context tab.

### Drawing Tools

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>To draw a four-sided plane figure with four right angles. Press Shift key to draw a square.</td>
<td></td>
</tr>
<tr>
<td>Oval</td>
<td>To draw an oval shape or a circle with pressing Shift key.</td>
<td></td>
</tr>
<tr>
<td>Polygon</td>
<td>To draw a closed plane figure bounded by three or more line segments.</td>
<td></td>
</tr>
<tr>
<td>Cloudy</td>
<td>To draw cloudy shapes.</td>
<td></td>
</tr>
<tr>
<td>Arrow</td>
<td>To draw something, such as a directional symbol, that is similar to an arrow in form or function.</td>
<td></td>
</tr>
<tr>
<td>Line</td>
<td>To mark with a line.</td>
<td></td>
</tr>
<tr>
<td>PolyLine</td>
<td>To draw an open plane figure with three or more line segments.</td>
<td></td>
</tr>
<tr>
<td>Pencil</td>
<td>To draw free-form shapes.</td>
<td></td>
</tr>
<tr>
<td>Eraser</td>
<td>An implement, acts as a piece of rubber, used for erasing the pencil markups.</td>
<td></td>
</tr>
<tr>
<td>Area Highlight</td>
<td>To mark important area as a means of memory retention or for later reference.</td>
<td></td>
</tr>
</tbody>
</table>
**Note:**

*If you draw a cloud shape in a counterclockwise direction, the cloud comes out inward.* If you draw the lines forming the shape in a clockwise direction, the cloud is created with the points outward.

**Tips:**

- To draw a line in horizontal, vertical, or at a 45 degree angle, press Shift while you draw with the Line command.
- To draw a square or circle with the Oval command or the Rectangle command, press Shift while you draw.

**Adding Free-form Annotation with PSI (Pressure Sensitive Ink)**

Foxit PhantomPDF adds PSI support for free-form annotation. You can use Surface Pro Pen or Wacom Pen to add free-form annotations with PSI in PDFs. Detailed steps are as follows:

- (For Surface Pro users) Choose **Comment > Drawing > Pencil**, and then add free-form annotation as needed with Surface Pro Pen;
- (For Wacom tablet users) Connect your Wacom tablet to the computer, choose **Comment > Drawing > Pencil**, and then add free-form annotation as needed with Wacom Pen.

**Edit, resize or move the markup**

Select the **Hand command**, the **Select Annotation command** or the corresponding Drawing Tool.

- To edit the drawing markup, right-click, select **Properties** and do settings as needed.
- To resize the drawing markup, select it, put the cursor on one of the green points, and drag one of the handles to make your adjustments.
- To move the drawing markup, select it and drag it to the target place.
- To add a pop-up note to the markup, select it and double-click the markup or right-click it and choose **Open Popup Note**.
- If you draw a line or arrow, you can enable the comment to be shown on the line or arrow by checking **Show text in line** in the line properties box.
- Check **Set Current Properties as Default** so that the current settings can be applied next time by default.

**Delete the markup**

Select the markup and press the Delete key. Or right-click the markup and select **Delete**.
Group the markups

Grouping drawing markups enables you to combine them so that you can work with them as though they were a single object. You can move or delete the group, set its status, change its appearance, etc.

Select the Hand command 🖍️ or the Select Annotation command 🖋️, and do one of the following:

- To group/ungroup markups, select the markups you want to group/ungroup by pressing Ctrl > right-click group/ungroup.
- To work with a group, select one of the markups and then work with the group as other comments.

Measure Tools

The Measure Tools enable you to measure distances and areas of objects in PDF documents. The measure tools are especially useful when you need to know the distances or areas associated with objects in a form or computer-aided design (CAD) drawing or when you want to measure certain areas of a document before sending to a professional printer. The measure tools are available to Reader users only if the PDFs are measurable.

When you use a measure tool, the tool dialog box displays the measurements of the line segments you draw.

❖ Measuring the objects

Choose Comment > Measure > [measure tool name], and do any of the following:

- Select the Distance command 🔍 to measure the distance between two points. While measuring the distance, you can specify whether to show the default leader on both side of the measurement points or not in Measuring Preferences. Click the first point, move the pointer to the second point, and click again. If you choose to use the default leader, move your mouse to determine the leader length, and then click on the document again to finish measuring. The measurements will appear on the page.

- Select the Perimeter command 🔍 to measure a set of distance between multiple points. Click the first point to start, and then click each point you want to measure. Double-click the last point to end measuring.

- Select the Area command 🔍 to measure the area within the line segments that you draw. Click the first point to start, and then click each point you want to measure. After you have clicked at least two points, click the first point or double-click the last point to complete the
area measurement.

**Note:** You can also choose to complete or cancel measurement by right-clicking the measurement and choosing options from the context menu.

After you select the measuring tool, the **Comment Format** tab appears, which allows you to set the scale ratio, snap measurement, export measurement markup, etc.

- To change the scaling ratio (such as 2:1, say, when the distance on the screen is 2 inch then the actual distance is 1 inch,) on the drawing areas, specify the appropriate numbers. If necessary, change the unit of measurement next to this ratio.
- Check **Show result information** if you want to see the current measuring result, including real distance, angle, horizontal and vertical position, etc.
- Check **Measurement markup** to add and show the measurement lines you draw in the PDF file. When this option is checked, you can add a label to measurement markups either by using the one specified in measuring preferences or inputting a new one in the Add Label box. The label for Distance markup will be shown in the distance measurement line, while the label for Perimeter and Area markups will be shown in their pop-up notes. When you put the pointer over the measurement markups with the Hand command selected, you can also view the measurement result and label.
- Check **Rulers** to show the rulers.
- Choose one or more snapping types from the Snap group. For precise measurements, position the key points when moving the cursor.

Snap to Endpoints : a small red circle will appear at the endpoint of the path when moving the cursor toward the end of the path.

Snap to Midpoints : a small red triangle will appear at the midpoint of a path when moving the cursor over the path.

Snap to Paths : the cursor will automatically change to a red square box on a path when moving the cursor over the path.

Snap to Intersections : a small red cross will appear at the intersection of two paths when moving the cursor over the point of two intersecting paths.

- Choose **Export to Excel** to save all the measurement information in your PDF to a CSV file.

**Note:** The object you draw will disappear when the Measurement Markup is deselected in the Distance dialog box.

**Working on the measurement markup**
After you complete the measurement, you are able to do further operations on it, such as move, resize, flip, and even work on it the way you work on comments.

1. Moving the measurement markup
   - With the Hand command or the Select Annotation command selected, click the measurement markup you want to move.
   - Place the cursor over the object when the pointer changes into , hold and drag the mouse to move it to the intended place.

2. Changing the length and orientation of the line segment
   - With the Hand command or the Select Annotation command selected, select one of the resize corners, you will see the pointer change into .
   - Hold and drag the mouse to change the length and orientation of the line segment.

3. Flipping the measurement markup and the annotation
   You can reverse the measurement markup and the annotation.

   ![Before flipping](Distance: 2.27 inch) ![After flipping](Distance: 2.27 inch)

   To flip the measurement markup and the annotation, do the following:

   - Select the Hand command or the Select Annotation command.
   - Right-click the object you draw > select Flip.

4. Adding, editing, or deleting the measurement label
   Measurement labels will be added and shown in the measurement markups as you specified in Measuring Preferences or as what you set while adding a measurement markup. If a measurement markup does not contain a label, you can easily add a label to it with Foxit PhantomPDF. For existing labels, you can also edit or delete them. Steps are as follow:

   - Select the Hand command or the Select Annotation command.
   - To add a label to a measurement markup without label: right-click the measurement markup >
select Add Label > input the label > click OK.

- To edit an existing label: right-click the measurement markup > select Edit Label > input the label as desired > click OK.
- To delete a label: right click the measurement markup > select Delete Label.

**Stamps**

The Stamp Tools in Foxit PhantomPDF are a group of advanced tools that enable you to stamp content and watermarks into a PDF document. Foxit PhantomPDF supports image stamps with various image formats (JPEG, GIF, BMP, WMF, etc.) and PDF file stamps. You can either create dynamic stamps which can obtain information from your system including name, date and time, or import existing dynamic stamps. Stamping PDF files is a very useful feature especially when you need to give reviewers some advices about the document's status or sensitivity.

![Approved Stamp](image1)

__________ Standard Stamp

![Dynamic Stamp](image2)

__________ Dynamic Stamp

![Create a Custom Stamp](image3)

__________ Create a Custom Stamp

![Custom Dynamic Stamp](image4)

__________ Create a Custom Dynamic stamp

**Stamp a PDF**

You can choose from a list of predefined stamps, or create custom stamps before stamping a PDF. All the stamps that you import or create are listed in the drop-down menu of the Stamp command and Stamps Palette. To apply a stamp, please do the following:

1. Choose Comment tab > Stamps group > Stamp button > choose a stamp from the menu. Or
choose Comment > Stamps > Create > Show Stamps Palette.... In the Stamps window, select a category from the menu, and then select a stamp.

2. The cursor changes into a rectangle with the appearance preview of the stamp. Click on the position where you want to place the stamp.

3. (Optional) To apply the stamp to multiple pages, please right-click the stamp and choose Place on Multiple Pages.... Specify the page range to place the stamp and click OK.

**Notes:**

1. All the stamps that you import or customize will be listed after you click Stamp button, you can choose directly a stamp from the menu.

2. The date format shown on the dynamic stamp is the same as that you set in your system.

Create a Stamp

You can create custom stamps and dynamic stamps.

✧ Creating a Custom Stamp

1. Choose Comment > Stamps > Create > Create Custom Stamp.
2. In the Create Custom Stamp dialog box, click Browse... and choose an image file or a PDF file.
   If the selected file contains multiple pages, you can drag the scroll bar to select a page.
3. Type a new category name or choose a category from drop-down menu, name the stamp, and then click OK.

**Note:** If the stamp you choose is an image file, you can adjust the opacity of the image via dragging the scrollbar as needed.

You can also create a stamp from the clipboard. Please do the following:

- Copy the image to the clipboard.
- Choose Comment > Stamps > Create > Paste Clipboard Image as Stamp Tool, the cursor will be changed into a rectangle.
- Put the cursor over the desired place and you’re done.

✧ Create a Custom Dynamic Stamp

You can create a Custom Dynamic Stamp to add text, author name and date time on stamps. Please do the following:

1. Choose Comment > Stamps > Create > Create Custom Dynamic Stamp....
2. In the Create Custom Dynamic Stamp dialog box, choose one stamp template from the left list or create your own stamp template which can be an image file. Choose a category from drop-down menu or name a new one, then name the stamp.
3. Specify Font, Font Size and Font Color. You can drag the Stamp Size slider to change stamp size
4. From the Stamp Text option, please do the following:

✧ Type the text that you want to show on the stamp in the **Stamp Text** field directly.
✧ Choose <author name>, <date and time>, <date>, or <author name, date and time> to add current user, date, and time of your system to the stamp. Please note that the date format shown in the stamp is the same as that you set in your system. When you add the stamp text with <date and time> or <date>, Foxit PhantomPDF will read the date format from your system and apply it on the stamp text you added.
✧ Click <Custom values when stamp is added> to create custom dynamic stamp with custom values which invoke a prompt window for users to input information while adding a stamp in PDF file. If you select this option, define the Field Name and Example in the pop up window, and click OK to add it to the custom dynamic stamp. If you choose this option, it is recommended to set Font Size as Auto so that the custom values you added in the stamp will be adjusted automatically to adapt to your stamp field. After adding the value, you can also drag the Stamp Size slider to adjust its size, if necessary.

5. You can instantly adjust the added content to fit your needs when you preview current stamp on the right top preview pane.

6. Click **OK**.

**Manage a stamp**

To manage a stamp, please do the following:

- Choose **Comment > Stamps > Create > Manage Stamps**, open **Management Custom Stamps** dialog box, and select a stamp.
- Click **Create** and choose one option from the drop-down menu to create a stamp. Please refer to **Creating a stamp**.
- Click **Edit** to edit the selected stamp, such as changing category, stamp name, or replacing the image or PDF files etc. Please refer to **Creating a stamp**.
- Click **Delete** to remove the stamp.

**Note:** Deleting a custom stamp category will delete all stamps that are subordinate to it.

✧ **Cut/Copy and Paste a Stamp**

To cut/copy and paste a stamp, please do the following:

- Select the stamp you want to cut or copy.
- Right-click the stamp > **Cut/Copy**. Or use the shortcut keys Ctrl + X/C to cut and copy.
- Right-click on the page you want to paste the stamp and select **Paste**. Or use the shortcut keys Ctrl + V to paste.

✧ **Undo/Redo a Stamp**
To undo/redo a Stamp, please click the undo button and redo button on the Quick Access toolbar.

✧ **Resize/move a stamp**

- Select the Hand command or the Select Annotation command.
- To resize a stamp, select it, put the cursor on one of the red points, and drag one of the handles to make your adjustments.
- To move a stamp, select it to drag.
- To add a pop-up note to a stamp, select it and double-click the stamp or right-click it and choose Open Popup Note.

✧ **Rotate a stamp**

- Select the Hand command or the Select Annotation command.
- Click the stamp with the command, a handle will appear over the stamp. Put the cursor on the handle and rotate the stamp by dragging the cursor. The rotating degree number will appear as you rotate the stamp.

✧ **Delete a stamp**

Do one of the following:

- Select the Hand command or the Select Annotation command, select the stamp you want to delete and then press the Delete key.
- Select the Hand command or the Select Annotation command, right-click on the stamp, and choose Delete from the Context Menu.

**Set Favorite Stamps**

- Choose Comment > Stamps > Create > Set Favorite Stamps....
- Select a stamp in All Stamps panel, and then click Add to Favorite, then the stamp you select will be added to Favorite Stamps panel.
- To remove a stamp from Favorite Stamps panel, select the stamp you want to remove and then click Remove from Favorite.

**Change the Appearance of Comments**

You can change the color and appearances of comments or markups after you create them by right-clicking the comment and choosing Properties. Also, you can set the new look as the default appearance for that tool.
In the Properties dialog box for each comment, there are two options:

- Check **Locked** at the bottom of the Properties dialog box to prevent the comment from being moved, altered or deleted.
- **Set Current Properties as Default** – check this option to set the current property settings as default so that all the settings can be applied by default the next time.

*Note*: You can change the appearance of comments either in the **Comment Format** context tab or in the comment properties dialog box. If you change the appearance through the **Comment Format** context tab, Foxit PhantomPDF will save the properties and apply them in the new comments as well. If you change the appearance via the **Properties** dialog box and do not check **Set Current Properties as Default** option in the dialog, Foxit PhantomPDF will only apply the properties to your currently selected comment.

**Change the appearance of Note Comments**

1. After you create a note comment, right-click the note icon and choose **Properties…**, or click **Options** at the top-right corner of the note popup box and choose **Properties…**.

2. In the Note Properties dialog box, do any of the following, and then click **Close**:

- Click the Appearance tab to change the color and opacity of the comment.
- Click the Note Type tab to change the type of icon used.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of a comment during a review.

See also “Set a status”.

**Change the appearance of Text Markups**

- Follow the steps of “Change the appearance of Note Comments”.
- There is no Note Type tab in Text Markups settings.

**Change the appearance of Drawing Markups**

In the Properties dialog box, do any of the following, and then click **Close**:

- Click the Appearance tab to change such options as the border style, color and opacity. The type of the comment selected determines which options are available.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of
a comment during a review.

See also “Set a status”.

Change the appearance of Typewriter Markups

In the Typewriter Properties dialog box, do any of the following, and then click Close:

- Click the Appearance tab to change the opacity.
- Click the General tab to change the author’s name and subject of the comment.
- Click the Review History tab to see the history of changes people have made to the status of a comment during a review.

See also “Set a status”.

Change the appearance of a textbox or callout

Please refer to “Change the appearance of Drawing Markups”.

Managing Comments

View all comments

The comments panel displays all comments in the PDF so that you can easily find the comments. In addition, it also provides a toolbar with basic options: Expand All, Collapse All, Previous, Next, Sort By, Hide/Show all comments, Search box, and Filter.

- The comment is displayed in the popup note or on the markup icon and acts as a tooltip when the popup note is closed.
- If you input the comment with too many lines, it will only show some of the comment while the rest will be displayed as suspension points when the cursor is moved outside the popup note. Click inside the message box to view it with scroll bar.
- Click the Filter icon to search specific comments you need by the author and status. In the Filter Comments box, select a status or author to show the comments that are in the status and made by the author. If you only want to filter the comments by the original author and ignore all the replies, please check Filter by the original author only as well. Click Clear Selection to clear all filters.
- The Comments Panel displays all the comments in the PDF without any filter; if you have filtered the comments, only the comments that match the filtering criteria appear in the panel. When you navigate through comments, the selected comment will automatically be kept in sync with the current comment being displayed. And you click on a comment to go to the
specify comment on page.

To view comments in Comments panel,

- Click the comments button in Navigation pane to open Comments panel.
- In Comments panel, there are the following functions to provide you:
  - **Search box** - Type a string to search comments that contains the string.
  - **Expand All** – Click Expand All button to expand individual comments.
  - **Collapse All** – Click Collapse All button to collapse all comments.
  - **Previous / Next** – Browse through the comments. Click the Previous button or the Next button to go to the previous or next comment. The two buttons are unavailable if no comment is selected.
  - **Sort By** – you can sort comments by author, page, type, date. In a thread of replies, only first message is sorted, and the reply messages are sorted in the same category as first message.
  - **Show/Hide all comments** – you can show/hide all comments in the PDF document.

*Note:*

1. You can click the plus and minus signs next to comment to expand or collapse comments.
2. The page on which comment is located is kept in sync with the selected comment. To go to the page where a comment is located, only simply click the comment in the comment panel.
3. To show/hide all comments on the Comments panel, you can also choose Comment > Manage Comments > Comments > Show All/Hide All.

**Cut, copy, paste and delete comments**

**Cut comments**

Cutting removes selected comments from the current location. Once you cut the comments, you can paste within the same document, into a different document.

- Select comments to be cut.
- Select Cut from the right-click menu, or press Ctrl + X.
You are now ready to paste.

Copy comments

Once you copy the comments, you can paste within the same document, into a different document.

- Select comments to be copied.
- Select Copy from the right-click menu, or press Ctrl + C.
- You are now ready to paste.

Paste comments

You can paste comments within the same document, a different document in Foxit PhantomPDF.

- Copy or cut the selected comments.
- Place your cursor where you want to paste comments within the same document or to another opened document.
- Select Paste from the right-click menu, or press Ctrl + V.

Delete comments

- Select the annotation to be removed with the Hand command 🧠, the Select Annotation command 📋, or the corresponding annotation tool.
- Choose Delete from the right-click menu, or press Delete.

Undo and Redo comments

See also “Undo and Redo”

Set and change a status

Set a status

Setting a status is useful for keeping track of comments that you have read or that require further action. You can use the status to indicate which comments you want to accept, reject, cancel, complete, defer, or mark for future consideration.

By setting the review status, you can show or hide a certain set of comments, and let review participants know how you are going to handle the comment. Once the review status is set, you cannot remove the review status display from history in the Review History list, even if you change the review status to None.
Change the status of a comment

- With the Hand command, the Select Annotation command or the corresponding tool selected, right-click a comment in the document pane or Comments panel you want to change the status of, choose Set Status > choose one option from the pop-up Context menu, and then select an option.
- To view a markup’s history of changes:
  A. Right-click the markup in the document pane or Comments panel, and then choose Properties.
  B. In the Properties dialog box, click the Review History tab to view the history of status changes people have made to a markup.

Reply to comments

Replying to comments is useful in shared reviews, when participants can read each other’s comments. They can also be used by review initiators to let reviewers know how their suggestions are being implemented. All replies appear in the popup note and are listed below the original comment. You can view the respective reply with the reply title and mark.

1. To reply to original comments in the pop-up note, do any of the following:
   - Using the Hand command, the Select Annotation command, or the corresponding comment tool, open the pop-up note for the comment and select Reply in the Options. And then type your reply in the textbox that appears in the pop-up window.
   - Right-click the original comment and select Reply. And then type your reply in the textbox that appears in the pop-up window.
2. Replying to Comments in the Comments List
   - Choose View > View Setting > Navigation Panels > Comments to open the Comments panel if it is hidden.
   - Right-click the comment in the Comments panel and select Reply.
   - Input your reply in the box and click OK.
3. To respond to the reply, please do as below:
   - Using the Hand command, the Select Annotation command, or the corresponding comment tool, and open the pop-up note for the comment.
   - Right-click the title of the reply and select Reply to this Reply. And then type your reply in the textbox that appears in the pop-up window.
4. Delete the reply message, do either of the following:
   - In the note pop-up window, right-click the reply window and click Delete this Reply.
   - In the Comments panel, right-click the reply message, and click Delete.
5. Change the color of reply message window
   - In the note pop-up window, right-click the reply message window and choose Change Color.
6. Flag comments with a checkmark
You can mark with a comment with a checkmark by right-clicking the comment and selecting **Mark with a Checkmark**. The checkmark icon will appear in the Comments pane in the navigation pane. Or you can directly make the checkmark for a comment in the Comments pane. With the checkmark you can sort comments.

7. Change the author name
   Right-click the comment and select **Change Author Name**.

   **Note:** To open/close all comments’ popup notes, please choose **Comment > Manage Comments > Popup notes > Open All/ Close All.**

**Arrange comments**

You can arrange multiple comments by aligning, centering and distributing them. Please follow the steps below.

**Select multiple comments**

1. Select the Select Annotation command.
2. Press and hold Shift or Ctrl and click the comments you want to edit. To select all comments in the document, click on a blank area in the **Comments** panel and press Ctrl + A.

**Align Comments**

Select two or more comments that you want to align. Then do one of the following:

- Choose **Arrange > Alignment**, and then choose a command as follows:
  
  A. To align a column of comments, choose , , or  to align them respectively to the left edge, right edge, or vertical axis of the anchor comment.
  
  B. To align a row of comments, choose , , or  to align them respectively to the top edge, bottom edge, or horizontal axis of the anchor comment.

   **Note:** When you right-click or Ctrl-click one of the selected comments, it will be highlighted in red, indicating that it’s the anchor comment. The align menu commands move the other selected comments to line up with the edges of the anchor comment.

- Refer to **Align Images** for more information.
Center Comments

This function enables you to center comments vertically, horizontally or both.

To center comments, select two or more comments that you want to center. Then do one of the following:

- Choose **Arrange > Page Center**, and then choose ✎, ▪️, or ▪️ to center them vertically, horizontally or both.
- Please refer to **Center Images** for more information.

Distribute Comments

In the context of laying out comments on a page, you can give a group of comments uniform spacing, based on the centers of adjacent comments. This function will be available when selecting three or more comments.

- To distribute the comments, choose **Arrange > Distribute**, and then choose ✎ and ▪️ to distribute vertically or horizontally.
- Please refer to **Distribute Images** for more information.

Summarize comments

Summarizing comments is an easy way to help you directly obtain a synopsis of comments associated with the PDF. Foxit PhantomPDF supports to create a comment summary PDF. To create a comment summary, do as below:

1. Choose **Comment > Manage Comments > Summarize Comments**.
2. In Create Comment Summary dialog box, do the following:
   A. Choose the layout of the summary and there are five types of layouts for you to choose:
      - L1--Document and comment with connector lines on separate pages
      - L2-- Document and comment with connector lines on single pages
      - L3—Comments only
      - L4-- Document and comment with sequence numbers on separate pages
      - L5-- Document and comment with sequence numbers on single pages
B. **Comment Type** - Choose the comment type you want to summarize.

C. **Paper Size** - Select the paper size of the summary

D. **Font Size** - Select the font size of the summary.

E. **Sort comments by** – Choose how to sort the comments.

F. **Include pages** – Specify the page range you need to summarize.

3. **Click OK** and a PDF named “Summary of Comments on [original document name].pdf” will be opened automatically. You can rename it before you save.
Send annotated PDFs

Foxit PhantomPDF makes it easy for users to share reviews. You can send your annotated PDFs to any reviewers to check and respond to your comments.

To send an annotated PDF file, do the following:

- Click on the Save button to save all the comments you have made.
- Choose Share > Send To > Email to send it out.

Import/export comments data

This feature is especially useful for PDF reviewing. When you receive an email invitation to a PDF review, the invitation typically includes the PDF as an attachment or provides a URL to the PDF. Alternatively, you may receive a Form Data Format (FDF) attachment. When opened, an FDF file configures your review settings and opens the PDF in a web browser. At this moment, you need to know how to import the comment data from the FDF file. Similarly, you may export comment data and send them as an FDF file to the other participants. Moreover, if you make comments in a PDF file which is created from a Microsoft Word document, you can easily export the comments to revise the original document.

Import comments data

Do the following:

- Double-click a FDF file to open it directly with Foxit PhantomPDF.
- Choose Comment > Manage Comments > Import > navigate to where the desired file is, select it (if you want to import multiple comments file, you can select them by holding Ctrl/Shift or by dragging the mouse to select), and press “Open”. You will be prompted that the comments data has been imported successfully.

Export comments data

To export comments data, please do one of the following;

- To export all comments as a FDF
  A. Choose Comment > Manage Comments > Export > All Comments.
B. You will be presented with a standard Windows “Save As” dialog box. Navigate to where you want to save the FDF file (e.g., your Documents folder), specify its name and click Save button.
C. You will be prompted that the data has been exported successfully.

• To export all comments as an FDF file and send in an e-mail
  A. Choose Comment > Manage Comments > FDF via Email.
  B. Your default e-mail program will pop up, and the comments data will be exported as a FDF file and attached in the email automatically.
  C. Type the e-mail address and title > click Send.
  D. The comments in FDF will be sent separately.

• To export highlighted text as an TXT file
  A. Choose Comment > Manage Comments > Export > Highlighted Text.
  B. You will be presented with a standard Windows Save As dialog. Navigate to where you want to save the TXT file, specify the file name, and click Save.
  C. You will be prompted that the data has been exported successfully.

**Note:** The option of Export comments data will be available only when the comments have been added to the PDFs.

**Tip:** The users of Foxit PhantomPDF can import the comments data from txt and dbf files or export the data of PDFs and save in FDF formats file. You can also export the data in FDF format and email as an attachment.

**Export comments to Word**

Foxit PhantomPDF allows users to revise the original Word document by exporting the comments from the PDF if the PDF is a tagged PDF and is created from a Microsoft Word document using Foxit PhantomPDF add-on.

• Do one of the following:
  ◆ In Foxit PhantomPDF, open the commented PDF file, and then choose Comment > Manage Comments > Export > Export to Word.
  ◆ In Microsoft Word, open the original document, and then choose FOXIT PDF > Comment > PhantomPDF Comment > Import Comments from PhantomPDF.
• Read the instruction and click OK to continue. If you do not want to see the dialog box the next time you try to export comments, check Don’t show again option in the dialog box.
• In the Import Comments from Foxit PhantomPDF dialog box, corresponding PDF and Word documents will be selected by default, and you can also click Browse to select the PDF file which contains comments and the Word document which you want to import comments, if necessary. Then select one of the following options, and click Continue.
All Comments: Import all comments to the Word document.

All Comments with Checkmarks: Import only comments marked with check marks to the Word document.

Text Edits Only: Insertions, Deletions and Replaces: Import only comments which are added using the Insert Text, Strikeout, or Replace Text comment tools.

- When the comments are imported to Word successfully, a dialog box will pop up showing you the import summary. If the imported comments include text edits, you can click Integrate Text Edit in the dialog box to review each text edit individually.
- While reviewing text edits, review or modify the text in the New Text box, and then select the following option:
  - Apply: Apply the text edit in the Word document and delete the comment markups.
  - Next: Skip to the next text edit. If you want to skip to the next text edit automatically after applying changes, check the Automatically go to next option.
  - Apply all Remaining: Apply all remaining text edits in the Word document and delete the comment markups.
  - Undo Last: undo the last text edit, including the manual changes you made in the New Text box.
  - Stop: Stop text integration. If you stop text integration, you can still continue to integrate text edits by clicking Continue in the Text Integration Summary dialog box, or clicking FOXIT PDF > Comment > PhantomPDF Comment > Continue Integration Process in Word document.

- When the text integration completes, a dialog box will pop up showing you the text integration summary. Click OK to the view import results in the Word document.
- Comments other than text edits will be imported and shown as comment markups in the Word document. Check the comment markups and modify the Word document as needed.
- Upon completion, click FOXIT PDF > Comment > PhantomPDF Comment > Delete All Comments in Document to delete the comment markups.
Chapter 8 – Share PDFs

Foxit PhantomPDF supports different methods to share PDF documents with others. You can easily email documents to share with others by one-click and, check out and check in PDFs in your SharePoint server. If you need to collect comments from reviewers as well as sharing documents, Foxit PhantomPDF provides two useful and easily-used methods: Send for Shared Review and Send for Email Review. Integration with SharePoint, NetDocuments, iManage Work, and OpenText eDOCS lets users share and manage documents easily within one application.

Email Documents

E-mailing documents is a useful feature. You may need to send a PDF file you are reading to the customers to speed up your daily work, or an interesting story that you want to share with your friends.

To e-mail a PDF file, please do the following:

• Choose Share > Send to > Email > Email Current Tab (Email the PDF file that you are currently reading) or Email All Open Tabs (Email all the PDF files that have been opened in Foxit PhantomPDF).
• System default e-mail application runs.
• The PDF(s) will be attached in the e-mail automatically.
• Type the subject and e-mail address, and click Send.

Send to Evernote

Directly send current PDF document to Evernote as an attachment.

➢ Prerequisites – You should set up an Evernote account from https://www.evernote.com/Registration.action.
➢ Open a PDF file.

➢ Choose Share > Send to > Evernote .
➢ You will see the current PDF document is attached to your Evernote ready.

Send to OneNote

You can send your PDF document to OneNote quickly within PhantomPDF after edits.
SharePoint Integration

Foxit PhantomPDF has been integrated with Microsoft SharePoint, which helps you better manage and share PDFs. You can access PDFs in a SharePoint repository by any of the following:

- Open a PDF file in the SharePoint mapped drive by Open dialog box within Foxit PhantomPDF. You can open and check out a PDF, modify it and then check in and save to the SharePoint network drive.
- You can also use Foxit PhantomPDF’s Open or Save As dialog box to work on PDFs in your SharePoint repository, whether the SharePoint repository is SharePoint online or SharePoint on-premise. More details please refer to Open and Save As PDFs with Foxit PhantomPDF.
- Directly check out and check in PDFs in your SharePoint repository on SharePoint on-premise through the SharePoint web interface using a browser after configuring your server. Please refer to SharePoint Configuration to configure your server first. More details please refer to Open and Save As PDFs with a Web Browser.

Open and Save As PDFs with Foxit PhantomPDF

Open PDF files in a SharePoint repository

To open PDF files in a SharePoint repository, please do the following: (Take opening PDFs in a SharePoint repository on SharePoint online for example)

- Run Foxit PhantomPDF and choose File > Open > Add a place ➔ SharePoint ➔ SharePoint. In the Add dialog box, type the SharePoint URL to sign in and click Next to continue.
- In the pop-up dialog box enter the email address and the password to sign in.
- In the Open dialog box, select the Shared Documents folder and click Open.
- Choose the PDF file you want to open and click Open.
- In the Foxit PhantomPDF dialog box, if you choose Check out and Open, other users cannot edit the PDF at the same time; if you only choose Open, others can modify the PDF as well when you are editing. (Check Don’t ask me again to bypass this dialog box in the future and use the current choice selected next time you open a PDF. You can change the setting later in File > Preferences > SharePoint.)
- (Optional) You are also allowed to preview non-PDF files on SharePoint in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.
• (Optional) If you want to cancel the Check Out status, please go to Share > SharePoint Integration > Discard Check Out.

• Edit the PDF according to your requirements.

• To check and set the PDF properties, please do the following steps:

  1. Please go to Share > SharePoint Integration > Prepare Document Properties.

  2. In the Document Properties dialogue, you will find the file path and document properties. You can select the file path to copy and paste it, if necessary. To edit a document property, double-click the column name, and edit the value in the Edit text box. For example, double-click Title, the Edit text box will pop up, type the content you want and click OK to finish the editing.

• Go to SharePoint > Check In.

  In the Check In dialogue box, select a version number for the modified document along with the appropriate the version comments. To not allow other people to modify the document, you can check Keep the document checked out after check in this version.

• Click OK, the modified PDF will be loaded to the server automatically.

Save as PDF files to a SharePoint repository

To save as PDF files to a SharePoint repository, please do the following: (Take saving as PDFs to a SharePoint repository on SharePoint online for example)

• Choose File > Save As > Add a place + > SharePoint $$. In the Add dialog box, type the SharePoint URL to sign in and click Next to continue.

• In the pop-up dialog box enter the email address and the password to sign in.

• In the Save As dialog box, select the Shared Documents folder and click Save.

Open and Save As PDFs with a Web Browser

To work on PDFs in your SharePoint repository on SharePoint on-premise with a web browser, you just need to log on to your SharePoint web portal, navigate to a PDF and click it. You will be prompted whether to check out and open the PDF. See also Check Out and Open. Then you can check in to save it back to your SharePoint repository.

Tip: If you need to save to your local folder, after editing the PDF you can click File > Save As > Computer and choose a local folder to save.
Shared Review and Email Review

Foxit PhantomPDF enables users to initiate a review by two methods: Shared Review and Email Review. You can set up your review, specify reviewers and review deadlines. You do not need to import and export comment data or manually track reviewer responses. The review Tracker can help review initiators track all reviews and manage the whole review in real time.

See also the tutorial on Shared Review.

Shared Review

Collect Comments on an Internal Server

Shared Review allows document authors to share a document on an internal server with others to gather feedback/comments from the reviewers. The review initiator can specify the document location, invite participants and set the review deadline.

After receiving the invitation from the review initiator, reviewers can mark-up PDFs using a full set of commenting tools. Comments from reviewers will be stored in the internal server and synchronized by Foxit PhantomPDF to download them at a regular interval. Reviewers will be notified if new comments are added by others and they can also reply to these comments.

1. (For review initiators) To send a PDF out for shared review (Available in Business Edition Only), please do the following:
   - Choose a document for shared review and open with Foxit PhantomPDF.

   **Note:** To guard against non-reviewers from accessing the document while it is on a shared repository, before sending out for review you can add some security policies to the document such as password/certificate encryption and AD RMS protection.

   - Choose **Share > Review > Send for Shared Review** > Collect comments on an internal server.
   - In the pop-up **Send for Shared Review** dialog box:
     1) Select the location of the document. The location can be a network folder or a SharePoint Workspace.

     **Tip:** If using a network folder, it must be a Windows machine running Windows 7, Windows Server 2008, or a later version of either. All reviewers must have read and write access to the shared folder and then can make comments with Foxit PhantomPDF or Reader 7.0 or a later release. You can track each reviewer’s comments and reply to them accordingly. Reviewers can also see and reply to each other’s comments.
2) Select a distribution and display method:

**Send it automatically as a link within the message** – The path to the shared document will be automatically included in the email message to be sent to reviewers using your installed email client (i.e. Outlook). The shared document will be named “*original document name*_review.pdf” by default.

**Send it automatically as an attachment to the message** – The shared document will be automatically sent as an email attachment to reviewers with the name “*original document name*_review.pdf”.

**Save a local copy and manually send it later** – Click Browse button to rename the shared document and choose a location to save it and send it to reviewers later manually.

3) Name this server profile, eg. “**S1 (send as attachment)**”, for further use in the future. The profile is saved with the options you specified above. In the future, you can select the profile directly from the Ribbon and skip this step.

- Click Next. If you haven’t set your identity information for your PDF viewers yet, enter your identity information.
- Click Next to go on. Enter the email addresses of the desired reviewers. A semicolon or a return can be inserted between each address if there is more than one address. Or click To… button to access your contact list in your email system.
- Choose the review deadline and then type in an email message.
- After you send the email or save the shared document to a local copy, the shared document is automatically opened, with a message box in the application window. With the options in the message box, you can publish comments, check for new comments made by reviewers and track the whole review. See also **Review a shared review document** and **Review Tracker**.

2. **(For reviewers) To review a shared review document:**
Upon the review initiator sending out the document, the specified reviewers will receive an email invitation to a PDF review. The email includes an attached document named “*original document name*_review.pdf” or provides a URL to the PDF. To review the document:

- Download the document and open it with Foxit PhantomPDF.
- If it is your first time opening a shared review document, you will be prompted for your identity information. Please enter at least your name and email address.
- Enter an account name and password for the shared folder where the shared review document is located.
- A message box appears in the application window with three options: **Check for New Comments**, **Publish Comments** and a menu with three commands.
- You can add your comments using annotation tools and then click **Publish Comments** to publish your comments which will be saved to the shared server.
- **Check for New Comments** allows you to view comments made by the initiator or other reviewers. You can also reply to the comments. In normal situations, comment publishing and checking will happen automatically. Foxit PhantomPDF supports to configure the interval to
check for new comments by selecting a length of time in File > Preferences > Reviewing > Automatically Check for New Comments. PhantomPDF icon in the taskbar will flash to prompt you that new comments are checked.

- Click Menu:
  - Track Reviews – To track all reviews you initiated or participated in, which is very useful when you are involved in multiple reviews. See also Review Tracker.
  - Save As Archive Copy – Saves a copy of the document with review comments to your hard drive when the review has ended.
  - Work Offline – If you don’t want to publish comments right after you make the comments, this option can keep your work offline, until you click Work Online to be able to publish comments.

**Note:**

1. Reviewers will not be able to make comments or do other modifications to the shared documents in non-Foxit PDF viewers.

2. Reviewers should save the document as an archive copy to the hard drive using Foxit PDF viewers so as to modify the content.

**Use Connected Review on Foxit Server**

Connected Review allows users to start a review without any deployment or any other server. In Connected Review, each participant can see the comments from the others, which helps document users collaborate by sharing comments on a document in real time. Also with one click, the review initiator can view all participants, and end a review any time.

To start a Connected Review (Available in Business Edition Only), the document for review should be a ConnectedPDF document, and you need to sign in your Foxit account. Then choose Share > Review > Send for Shared Review ➡️ > Use Connected Review on Foxit Server. A message box to introduce Connected Review pops up. Click OK. Then a light bulb icon appears in the upper right corner of the application window, showing that you have started a review of the current file. Other users will also see the bulb when opening the document, and can choose to join the review. The review initiator can also end the review by clicking Connect > Connected Review > End (Available in Business Edition Only).

**Email Review**

Email Review is useful when reviewers don’t have access to a common server or initiators don’t need collaborative reviews. In an Email Review, the initiator sends PDFs to reviewers as attachments and can view comments only after receiving the commented PDFs from reviewers. Also, the reviewers can only send back the PDFs after adding comments, and they cannot view
comments made by others.

1) To send a PDF out for email review (Available in Business Edition Only), please do the following:
   - Choose a document for email review and open with Foxit PhantomPDF. This document becomes the master file into which you can merge comments you receive from reviewers.
   - Choose Share > Review > Send for Email Review.
   - In the pop-up Send for Email Review dialog box, specify the recipients that you want to send the document to for review, type in the message in the text box and click Send Invitation button.
   - A new email with the document attached will appear for you to send. Click Send to send out the email.
   - You can track the review status with the review tracker. Please refer to Review Tracker.

*Note: Recipients of the shared document can review it and send it back with Foxit PhantomPDF or Reader 7.0 or a later release, as well as Foxit MobilePDF Business.*

2) To participate in an email review:

The recipients can download the document sent from the initiator and open it with Foxit PhantomPDF, add their comments and click Send Comments button in the message box to send their comments back to the initiator.

Likewise, you can manage your reviews by using the Tracker. See also Review Tracker.

3) To merge comments:

After receiving the document with comments from reviewers, the initiator open it and will be prompted with a message box about whether to merge comments from this document into the master file or not.

If you choose No, open this copy only button, you can still merge comments after you open it by clicking Merge Comments button in the message box.

**Review Tracker**

The review Tracker helps you easily manage document reviews in real time. The tracker shows all reviews you sent and joined and the detailed review status including review deadlines, reviewers, comments, etc. You can also email reviewers/initiators and add reviewers with the tracker. If you are the review initiator in a Shared Review, you can also change the deadline, end the review and start a new review with the same reviewers.

To track all of your reviews, please click Share > Review > Tracker. You are enabled to save
the review details in the Tracker as a PDF file by right-clicking the document name in the Tracker and choosing **Create PDF From Tracker Details** from the context menu.

### NetDocuments Integration

Foxit PhantomPDF allows you to open, edit, save, and check out/in PDFs on NetDocuments, which offers you efficient document management. You can either open PDFs within PhantomPDF or from web browsers.

#### Open PDFs on NetDocuments within PhantomPDF

1. Click **File > Open > Add a place > NetDocuments**. Before using PhantomPDF to open PDFs on NetDocuments, you are required to install ndOffice in your system if you haven’t.
2. Log in to your NetDocuments account.
3. In the **Open** dialog box, click the document you want to open and then it will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.
4. (Optional) You are also allowed to preview non-PDF files on NetDocuments in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.
5. After modification, you can save the changes to check back in to NetDocuments or to local drives.

**Tip:** Users who don’t use ndOffice to open PDFs on NetDocuments, can return to the legacy NetDocuments integration by changing the setting in **File > Preferences > ECM Integration** or deleting the following registry key(s). This will allow the ActiveX (Check-in List) to handle PDFs opened from IE. Delete both of the following key(s) in both locations:

**X64:**

```plaintext
[HKEY_CURRENT_USER\SOFTWARE\NetVoyage\NetDocuments]
"ndOfficeHandoff"="pdf,ppdf"

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Foxit Software\Foxit PhantomPDF\ndoffice]
"ndOfficeHandoff"=pdf
```

**X86:**

```plaintext
[HKEY_CURRENT_USER\SOFTWARE\NetVoyage\NetDocuments]
"ndOfficeHandoff"="pdf,ppdf"

[HKEY_LOCAL_MACHINE\SOFTWARE\Foxit Software\Foxit PhantomPDF\ndoffice]
"ndOfficeHandoff"=pdf
```
Open PDFs on NetDocuments from web browsers

You may want to open PDFs with PhantomPDF when clicking the document in a web browser like Chrome, Firefox, and IE. To open PDFs with PhantomPDF, you must set PhantomPDF as the default PDF viewer in web browsers and install ndOneClick, a component to give users a one-click method to automatically check out/in documents in the native application without using the ActiveX add-on for IE. Visit [here](#) to download ndOneClick.

After installing ndOneClick, log in to the NetDocuments account in your web browser, and then you can check out and open PDFs within PhantomPDF as well as modify, save and check in PDFs.

iManage Work Integration

Integration with iManage Work, the popular and intelligent document and email management solution, enables you to directly open, modify, and save PDF documents in your Work account using PhantomPDF, which streamlines your PDF document management.

Register/Unregister servers

Before you work on PDF documents in iManage Work, please add the server your iManage Work Server is installed on and log in your account.

*Note: The DeskSite client is required in your system before registering servers. For better document management, Foxit PhantomPDF enables you to convert non-PDF files to PDF via the context menu within the DeskSite.*

Register servers

1. Click **File > Open > Add a place > iManage Work**, or click **SHARE > iManage Work > Register/Unregister**.
2. In the pop-up **Server Connection** dialog box, click **Add**.
3. Enter the server name and the login information in the **Register and Login** dialog box. Then click **Save**. (*Tip: You can check Auto Login to automatically log in to your iManage account next time you launch PhantomPDF.*)
4. Close the **Server Connection** dialog box. Then you can open your documents in your iManage Work account.
   *Note: The server you added will be listed in **File > Open** and stored until you delete or unregister it.*
Delete or unregister servers

Click Share > iManage Work > Register/Unregister. In the pop-up Server Connection dialog box, select the server you want to unregister and click Delete.

Open and check out PDFs on iManage Work

1. Go to File > Open, click the server you registered previously and click Open. Or click Share > iManage Work > Open after you register and connect to the server.
2. In the Open dialog box, select the document you need and click Open.
3. Specify the checkout settings in the Checkout dialog box, then click OK to open and check out the document.
4. (Optional) You are also allowed to preview non-PDF files on iManage Work in PhantomPDF. The non-PDF files will be converted to PDF temporarily when you try to open them.

Save

To save a local PDF document to the iManage Work repository, or if you open and edit a document in the iManage Work without checking it out and need to save it to the iManage Work repository, save the changes you made in the document and then do the following:

To save as a new document in iManage Work repository:

1. Go to File > Save As, click the server you registered previously and click Save. Or click Share > iManage Work > Save As > Save As.
2. In the Save As dialog box, choose a target folder and enter the name/description of the document. Enter the Author name, or click the button next to the text box and choose a name. You can also choose a class and a subclass for the document.
3. After completing all of the settings, click Detail... to display the details of the document information. You can also edit the information in this dialog box.
4. When you’re done, click Save to save the document to the iManage Work.

To save as a new version of an existing Work document:

1. Go to Share > iManage Work > Save As > Save As Work Version.
2. In the pop up dialog box, select a document in iManage Work, and click New Version.
3. Specify the document properties in the New Version Profile dialog box, and click Save to save it as a new version of the selected document.

To save a checked-out PDF document, you can choose to replace the original document in the iManage Work or save it as a new version or a new document.
After modification, go to File > Save As, click the server you registered previously and click Save. Or click Share > iManage Work > Save As > Save As. In the Save As Options dialog box, choose any of the following:

- **New Version**: Click OK, set the document profile for the new version, and the modified document will be saved as a new version, leaving the original document unchanged. And then you can also customize the checkout settings for the document in the pop-up Checkout dialog box. Then click OK.

- **New Document**: Click OK and the modified document will be saved as a new document, leaving the original document unchanged. In the pop-up Save As dialog box, complete the settings and click Save. See also Save a local document to the iManage Work.

- **Replace Original**: Click OK and the modified document will overwrite the original document in the iManage Work.

*Note: By default, only New Version and New Document are displayed in the Save As Options dialog box. To show the Replace Original option in the dialog box, add a new key to the Registry:*

\[
\text{HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Foxit\PhantomPDF 8.0\iManage\Preferences}
\]

*Key Name: ReplaceOriginal*

*Type: DWORD     Value: 1*

Set the value data to 1 to display the Replace Original option; with the value of 0 or null, the option will not be displayed.

**Document properties**

When you have checked out and opened a PDF document, you can click SHARE > iManage Work > Properties to view the properties of the document.

**OpenText eDOCS Integration**

Within Foxit PhantomPDF, you can open, modify, and save PDF documents on eDOCS DM --- the ECM solution used by many organizations to manage content, giving you quick and easy access to documents on eDOCS DM to increase productivity.

**Open PDFs on eDOCS DM**

1. Click File > Open > Add a place > eDOCS DM. Before using PhantomPDF to open PDFs on eDOCS DM, you are required to install DM Extension in your system if you haven’t.
2. Log in to your eDOCS DM account.
3. (Optional) If you have logged in before, the eDOCS DM item will be listed under the Open menu. Then click File > Open > eDOCS DM > Open from DM.
4. In the Quick Retrieve dialog box, select the document you want to open and then it will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

Save

To save a checked-out PDF document, you can choose to replace the original document in the eDOCS DM, or save it as a new version, a new sub-version, or a new document.

1. After modification, go to File > Save As, click the eDOCS DM item listed under the Save As menu and then click Save As. Or click Share > eDOCS DM > Save As (> Save As...).
2. In the Save As dialog box:
   - Choose New Version/ New Sub-version/ New Document: the modified document will be saved as a new version/sub-version/document, leaving the original document unchanged.
   - Choose Replace Original: the modified document will overwrite the original document in eDOCS DM.

You can save a local PDF document as a new document or a new version to the eDOCS DM. Save the changes you made in the document and then do the following:
   - To save as a new document, go to File > Save As, click the eDOCS DM item listed under the Save As menu and then click Save As. Or click Share > eDOCS DM > Save As > Save As... Then type the document information as needed and click Save.
   - To save as a new version, click Share > eDOCS DM > Save As > Save As DM Version. Select a document in eDOCS DM and save as a new version or sub-version of the document.
   - To add a password protection when saving a document, click Share > eDOCS DM > Save As > Save with Options, and save the document to the eDOCS DM.

Document properties

When you have checked out and opened a PDF document in eDOCS DM, you can click Share > eDOCS DM > Document Information to view the properties of the document.

OpenText Documentum Integration

Integration with OpenText Documentum, an enterprise content management platform, enables you to open, modify, and save PDF documents in your OpenText Documentum account, which streamlines your document management.
Open PDFs on OpenText Documentum

1. Click File > Open > Add a place > Documentum. Before using PhantomPDF to open PDFs on OpenText Documentum, you are required to install DFC Client in your system if you haven’t.
2. Log in to your OpenText Documentum account.
3. (Optional) If you have logged in before, the Documentum item will be listed under the Open menu. Then click File > Open > Documentum > Open.
4. In the Open dialog box, select the document you want to open, and click Open. By default, the PDF document will be locked for editing while you open a PDF file which has not been checked out with Foxit PhantomPDF. Then make your edits as needed with advanced tool in PhantomPDF. If you do not want to lock it, uncheck the Locked file for editing option in the Open dialog box.

Save

To save a locked PDF document, you can choose to replace the original document in the OpenText Documentum, or save it as a new version, a new sub-version, or a new document.

1. After modification, go to File > Save As, click the Documentum item listed under the Save As menu and then click Save As. Or click Documentum > Save As > Save As.
2. In the Save As dialog box:
   - Choose New Version/ New Sub-version/ New Document: the modified document will be saved as a new version/sub-version/document, leaving the original document unchanged.
   - Choose Replace Original: the modified document will overwrite the original document in Documentum.

You can save a local PDF document as a new document or a new version to the Documentum. Save the changes you made in the document and then do the following:
   - To save as a new document, go to File > Save As, click the Documentum item listed under the Save As menu and then click Save As. Or click Documentum > Save As > Save As. Then type the document name as needed and click Save.
   - To save as a new version, click Documentum > Save As > Save As Repository Version. In the Save As dialog box, select New Version or New Sub-version, and click OK. Select a document in Documentum to save the local PDF document as a new version or sub-version of the document.

Document properties

When you have opened a PDF document in Documentum, you can click Documentum > Document Information to view the properties of the document.
OpenText Content Suite Integration

Within Foxit PhantomPDF, you can open, modify, and save PDF documents on OpenText Content Suite.

Open PDFs on OpenText Content Suite

1. Click File > Open > Add a place > Enterprise Connect. Before using PhantomPDF to open PDFs on OpenText Content Suite, you are required to install Enterprise Connect Framework in your system if you haven’t.
2. (Optional) If you have added Enterprise Connect in PhantomPDF before, the Enterprise Connect item will be listed under the Open menu, and the Enterprise Connect context tab will be displayed. You can click File > Open > Enterprise Connect > Browse or select Enterprise Connect > Open to open a file from OpenText Content Suite.
3. In the Enterprise Connect Open dialog box, select the document you want to open, and click Open. The document will be checked out and opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

Tip: You need to set Foxit PhantomPDF as the default PDF viewer if you want to open PDFs on OpenText Content Suite with Foxit PhantomPDF.

Save

To save a check-out document, do any of the following:

• Click File > Save to save and replace the original document in OpenText Content Suite.
• Go to File > Save As > Enterprise Connect > Browse or Enterprise Connect > Save As, and follow the Enterprise Connect onscreen instructions to save it as a new document or new version.

To save a local PDF document to OpenText Content Suite, follow the steps below:

• Click Enterprise Connect > Save As, or go to File > Save As > Enterprise Connect > Browse, and then follow the Enterprise Connect onscreen instructions to save it in OpenText Content Suite.

Worldox Integration

Integration with Worldox enables you to open, modify, and save PDF documents in your Worldox account, which streamlines your document management.
Open PDFs on Worldox

1. Click File > Open > Add a place > Worldox. Before using PhantomPDF to open PDFs on Worldox, you are required to install Worldox client in your system if you haven’t.

2. (Optional) If you have added Worldox in PhantomPDF before, the Worldox item will be listed under the Open menu, and the Worldox context tab will be displayed. Then click File > Open > Worldox > Open, or select Worldox > Open.

4. In the GX-Open dialog box, double-click the document you want to open, and then it will be opened with PhantomPDF. Then make your edits as needed with advanced tools in PhantomPDF.

Save

To save an opened PDF document back to Worldox, do any of the following:

- Click File > Save or Worldox > Save to save and replace the original document in the Worldox.
- Click File > Save As > Worldox > Save As or Worldox > Save As, and then follow the GX onscreen instructions to save and replace the original document, or save it as a new version or new document.

To save a local PDF document to Worldox, follow the steps below:

- Click Worldox > Save or Save As, or go to File > Save As > Worldox > Save As, and then follow the GX onscreen instructions to save it as a new document or a new version in Worldox.
Chapter 9 – Forms

Foxit PhantomPDF is extremely useful for form filling and form designing. Please read below for more information.

Interactive Form and Non-interactive form

There are two kinds of “form” files. One is a PDF file with fillable fields, which enables you to fill the form directly by clicking the form fields without using other features. This is called an Interactive PDF Form. The other kind of form is a plain PDF file with lines and texts, which should be filled with the typewriter feature in Foxit PhantomPDF. This is called a Non-interactive PDF Form.

Interactive Form

For interactive forms, you will see a message box appear in the top-right corner of the application window. The message box informs you that this document is a fillable form. Click to collapse the notification message. If you do not want to see the notification message again when reopening this file, check Don't show again option in the notification message. Clicking the gear icon in the notification message can change the preferences about notification message setting. Please refer to Notification Messages preferences for more information.

Foxit PhantomPDF highlights the form fields in the document by default, which colors the backgrounds of all blanks to be filled in and outlines any required blanks, making it easy to see them at a glance. If you don’t need to highlight the fields, navigate to Form > Edit > uncheck Highlight Fields.

Acro Form and XFA (XML Forms Architecture) Form

Foxit PhantomPDF now supports both Acro Form and XFA Form. You can fill in XFA forms with the Hand command, the same which you were able to do with normal fillable forms (also known
as Acro Form).

**Non-interactive Form**

The document message box will not appear. This kind of form acts like an ordinary PDF document that has plain text and you will need to use the Typewriter feature to fill in this form.

**Fill in PDF Forms**

Foxit PhantomPDF not only allows you to fill in PDF forms and print them out, but also supports advanced form operations, such as saving filled-out forms and importing/exporting forms data.

**Fill Interactive Forms**

If a PDF form contains interactive form fields, you can fill in the form with the Hand command \(\text{Hand}\). When you place the pointer over an interactive form field, the pointer icon changes to one of the following:

- **Hand icon \(\text{Hand}\) --** Appears when mousing over a button, radio button, check box, or item on a list.
- **I-beam icon \(\text{I-beam}\) --** Appears when you can type text into the form field.

**To fill in an interactive form, please do the following:**

- If necessary, select the Hand command \(\text{Hand}\).
- (Optional) To make form fields easier to identify, click the **Highlight Fields** in the document message box. Form fields appear with a colored background (light blue by default).
- Choose **Form > Form Recognition > Run Form Field Recognition**. Then click on the first form field you want to fill in, either to select that option or to place an I-beam pointer \(\text{I-beam}\) in the field so that you can start typing.
- Right-click the text fields, and choose **Paste** or **Select All** to do other operations.
- After making a selection or entering text, do any of the following:
  A. Press Tab or Shift + Tab to accept the form field change and go to the next or previous field.
  B. Right-click the form field and press the Up arrow key to select the previous option in an item of list, or press the **Down** arrow key to select the next option.
- After you fill in the form fields, do one of the following:
A. Click the submit button if one exists. Clicking this button sends the form data to a database across the web or over your company intranet.

B. Click Save icon on the toolbar, or choose File > Save.

C. Choose File > Save As, and specify a location for the copy.

Clear a form entry

Click one of the form fields, and use the Backspace key or Delete key.

Reset unsaved form entries

Choose Form > Form Data > Reset Form.

Clear a form in a browser

Do either of the following:

• Select the reset form button if one exists. You can’t undo this action.
• Quit the browser, and start again.

Note: Clicking the web browser’s Reload or Refresh button, the Back or Go Back button, or following a link to another page may not complete clearing the form.

Fill lengthy entries in forms

Some PDF forms can contain dynamic text fields, which changes the text you input in size to accommodate the text fields. The text appears smaller and smaller when the words you type exceed the current size of the field.

Spell-checking form entries

You can spell-check the text you typed in form fields after purchasing Foxit PhantomPDF if the security settings allow.

If you have installed the Spell Checker, when you insert any English text in the form fields, the spelling errors will be highlighted and underlined with squiggly lines.

To spell-check entries, do the following:

• Right-click on the misspelled words and you will see a list of five suggested words.
• Choose one of the suggested words to correct your input or ignore the squiggly line.
• If all the suggested words are not the exact words you want to input, try to correct them with other words.
**Fill Non-interactive Forms**

If a PDF form contains non-interactive form fields, you can fill in the form with the Typewriter command. When you place the pointer over a non-interactive form field, the basic pointer icon doesn't change.

Non-interactive PDF forms can be printed and filled in by hand. Or choose the Comment tab > the Typewriter group > the Typewriter command $\text{T}$ to type information over the blank form fields and then save or print a copy of the completed form. To use the Typewriter command to fill the non-interactive forms and spell-check the entries, please refer to “Typewriter”.

You can also recognize form fields with the Run Form Field Recognition command $\text{ Recognition}$ and then fill in forms with the Hand command.

*Note: To add text before or after the form fields, you can either choose to use Edit > Edit Content > Add Text or refer to the Typewriter.*

**Comment on Forms**

You can comment on PDF forms, just like any other PDF. You can add comments only when the form creator has extended these rights to the users.

Whether or not these comments are included when the form is submitted depends on how it is submitted. For example, if you use Foxit PhantomPDF to print the form for mailing or faxing, the comments do not appear. But if you attach the filled-in form to email as a complete PDF, the comments are included. Also, you can send the comments separately as an email attachment.

*See also “Chapter 7 - Comments”.*

**Manage Form Data**

You can import form data from other file formats to a PDF form, or export form data on a PDF form to other file formats. You can also export form data from multiple PDF forms to a CSV file. In addition, for PDF forms with Ultraform technology, Foxit PhantomPDF supports to create and display 2D barcode that contains form data you filled in.
Import/Export Form Data

To import and export form data is similar to the way of importing and exporting comment data. However, this function is only for PDF interactive forms. All the options for importing and exporting form data will be unavailable when you open other ordinary PDFs or non-interactive forms.

To learn how to import and export form data, please view “Import/Export Comments Data”.

You can also export form data to an existing CSV file by clicking Form > Form Data > Export > Append to an Existing Sheet. In the Open dialog box, select a CSV file you want to append the form data to and click Open. A Foxit PhantomPDF message will pop up to prompt that the form data has been exported successfully and let you decide whether to open the file.

Tip: You can import PDF form data from FDF, XFDF, TXT, XML, or CSV files, or export form data to a FDF, XFDF, TXT, XML, or CSV file.

Combine forms to a sheet

To export form data from multiple PDF forms to a CSV file, please do as following:

1. Choose Form > Form Data > Combine Forms to a Sheet.

2. In the Export multi-forms to a sheet dialog box, click Add Files to add files that you want to combine into a sheet. You can also click Close button in the dialog box to remove files.

3. (Optional) Check the option Contain forms you closed recently to add the PDF files you closed recently. You can also append the exported form data to an existing file by checking the option Append to an existing file.

4. Click Export. In the Save As dialog box, specify a folder and file name (“data source.csv” by default) for the CSV file and click Save. A Foxit PhantomPDF message will pop up to prompt that the form data has been exported successfully and let you decide whether to open the file.

Generate 2D Barcode

For forms integrated with Ultraforms technology, Foxit PhantomPDF supports the generation of 2D barcodes, making the form data easily to be scanned, captured and incorporated into a database. Steps are as follows:

- Open and fill in the form.
- Upon completion, click the barcode generation button (if any) on the form file to generate 2D
Barcode.

- Click the save button on the Quick Access Toolbar to save the form.
- (If needed) Choose File > Print to print the form; and then you can use a supported scanner to scan, read and incorporate the form data into a database.

**Note:**

1. Currently, Foxit PhantomPDF only supports the generation of 2D barcode for forms integrated with Ultraforms technology.
2. The triggering method for 2D barcode generation may vary as the form creator may define when integrating Ultraforms technology into the form file. You can click the barcode generation button (if there is any) on the form file, or choose Print directly to generate 2D barcode.

**Form Fields**

Foxit PhantomPDF uses a group of buttons that can be used to create and design form fields in interactive forms. You are able to add push buttons, text fields, check boxes, combo boxes, list boxes or radio buttons to create an interactive PDF form and specify their properties.

**Create Interactive Forms**

You can either create an entirely new interactive form from a blank page or add form fields to an existing electronic form.

To start from a blank page, please do the following:

- Create a blank PDF from File > Create > Blank, or choose Convert > Create > Blank.
- Open the blank page with Foxit PhantomPDF, and then add form fields.

To create forms from non-interactive table:
Open it with Foxit PhantomPDF and choose **Form > Form Recognition > Run Form Field Recognition**. All fillable fields in the document will be recognized and highlighted.

Add form fields from **Form > Form Fields** > click a type of form field button and the cursor changes to crosshair 🔄. And the **Designer Assistant** 🏡 is selected automatically.

All the corresponding type of form fields will be automatically named with the text near the form fields (Take the text fields for an example as below).

Click the place you want to add the form field. To edit the form field further, please refer to the properties of different buttons from “Buttons”.

---

**Creating Text Fields**

**Buttons**

There are seven basic buttons to add form fields for you to create an interactive PDF form:

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Push Button" /></td>
<td>Push Button</td>
<td>Creates an interactive form element to initiate certain predefined actions, such as opening a file, submitting data to a web server, or resetting a form. This button can also be customized with images and text.</td>
</tr>
<tr>
<td><img src="image" alt="Check Box" /></td>
<td>Check Box</td>
<td>Presents yes-or-no choices for individual items. If the form contains multiple check boxes, users can select what they want.</td>
</tr>
<tr>
<td><img src="image" alt="Radio Button" /></td>
<td>Radio Button</td>
<td>Presents a group of choices from which the user can select only one item.</td>
</tr>
<tr>
<td><img src="image" alt="Combo Box" /></td>
<td>Combo Box</td>
<td>Lets the user either choose an item from a pop-up menu or type in a value.</td>
</tr>
<tr>
<td><img src="image" alt="List Box" /></td>
<td>List Box</td>
<td>Displays a list of options the user can select.</td>
</tr>
<tr>
<td><img src="image" alt="Text Field" /></td>
<td>Text Field</td>
<td>Lets the user type in text, such as name, address, phone number, etc.</td>
</tr>
<tr>
<td><img src="image" alt="Signature Field" /></td>
<td>Signature Field</td>
<td>Creates a blank digital signature field for reviewers to sign the document</td>
</tr>
</tbody>
</table>
Push Button

✧ Create a new push button

Choose **Form > Form Fields > Push Button** [OK], and your cursor changes into «». Then do the following:

- Drag an area in the desired place to create a push button.
- A box appears under the button for you to input the button name and the name of label.
- You can also click the **All Properties** to do more settings.
❖ Move and resize a push button

- To move a push button, select the Select Annotation command or push button, click and drag the button to move it to a new location.
- To resize a push button, select the Select Annotation command or push button, click to select the button, and then drag a border handle.

❖ Delete a push button

- Select the Select Annotation command or push button, and click the push button you want to delete.
- Press Delete, or right-click the push button > Delete.

❖ Create multiple copies of a push button

You can create multiple copies of a push button. The new push button names are based on the original push buttons and appended with a number. However, you are able to create them with the same names. In addition, all the new push buttons are created sequentially, using standard array format.

- With the Select Annotation command or push button, select one or more push buttons that you want to copy (press Shift or Ctrl when clicking to select more buttons).
- Right-click one of the buttons > Create Multiple Copies...
- In the Create Multiple Copies of Fields dialog box, do the following:
  
  A. To specify the rows to be created, enter or select a number in Copy Selected fields down (times). The default number is set to 2.
  B. To specify the columns to be created, enter or select a number in Copy Selected fields across (times). The default number is set to 2.
  C. To specify the width of the area in which the columns of fields appear, enter or select a number in Change Width (in). The default number is set to 0.04.
  D. To specify the height of the area in which the columns of fields appear, enter or select a number in Change Height (in). The default number is set to 0.04.

  **Note:** The width and height values don’t change the dimensions of individual fields but designate the size of the entire area for all the selected and newly created fields.

  E. To change the position of buttons, use the Up, Down, Left, and Right buttons in the dialog box.
  F. Click Preview to apply the results.
  G. Click Same Name to apply the names of original buttons to the newly created buttons.
• Click OK.

**Note:** Copies of push buttons function independently of each other. You can use a different procedure to duplicate push buttons, creating an information-sharing relationship among these buttons.

✧ **Duplicate a push button across multiple pages**

• Select the push button that you want to duplicate.
• Right-click the button > **Duplicate**...

**Note:** The Duplicate command isn’t available for forms with only one page.

• Then do one of the following:

  A. To duplicate the push button on every page in the form, select **All**, and click **OK**.
  B. To duplicate the push button on odd/even page in the form, select **Odd pages** or **Even pages**, and click **OK**.
  C. To duplicate the push button on a limited range of pages, type the starting and ending page on which you want the button to appear. Click **OK**.

**Note:** Enter the page number including or not including the page on which the button originally appears doesn’t affect the duplication process. Including that page won’t create a second copy on top of the original one, and not including it won’t remove the original button.

✧ **Set tab order**

You can set the tab order of the buttons you created. The order number will show on the top left corner. By default, the tab order is based on the document structure. Please do any of the following to set tab order:

• Click the **Manage form fields** panel in the Navigation Pane. Click **Set Order** button in the upper-right corner of the **Manage form fields** panel and choose to order tabs by row/column/structure. Check **Show tab numbers** to view the tab order. You can also change the tab order by dragging and dropping a field to the desired place within the **Manage form fields** panel. You can only move one field at a time.

• Click the page thumbnails panel in the Navigation Pane. Right-click the page where you need to change the tab order and choose **Properties**... In the **Page Properties** dialog box, select one order in the **Tab Order** tab.

• With the Select Annotation command selected, right-click a form field, and choose **Set Tab Order**. Click anywhere in the field that you want it to be the first in the tabbing order. The
number in the upper left corner will be set as 1. Click each of the other fields in the order that you want tabbing to occur.

**Note:** You can only set tab order within one page.

- **Set push button properties**

You can set properties that apply formatting, determine the appearance and actions, and so forth.

The push button has a General tab, Appearance tab, an Options tab, and an Actions tab. Besides, there are two items on every tab:

- **Locked** – When selected, prevents any further changes to any push button properties.
- **Close** – Applies and saves the current button properties, and closes the button properties dialog box.

**Note:** If you select Locked on any tab, it will lock all options for the button, but not just the options on that tab.

1. **General tab for the button properties**

The General tab in push button properties contains the following options:

- **Name** – Specifies the unique name of the selected push button.
- **Tooltip** – Displays text that the hesitant user may find helpful in clicking the button. Tooltips appear when the pointer hovers over the push button.
- **Form Field** – Specifies whether the push button can be seen, either on screen or in print. There are four choices for you: Visible, Hidden, Visible but doesn’t print, and Hidden but printable.
- **Orientation** – Rotates the push button by 0, 90, 180, or 270 Degrees.
- **Read Only** – Prevents the user from clicking the push button.
- **Required** – This option is not available for the push button.

2. **Appearance tab for the button properties**

The Appearance properties determine how the push button looks on the page. The Appearance tab in push button properties contains the following options:

- **Line Style** – Alters the appearance of the frame. Select Solid, Dashed, Beveled, Inset or Underline.

![Solid, Dashed, Beveled, Inset, Underline](image)

Solid    Dashed    Beveled    Inset    Underline
**The appearances of Push Button with different line styles**

**Note:** You may not see the difference if no color is chosen as the border color.

- **Thickness** – Specifies the width of the frame surrounding the push button: Thin, Medium, or Thick.
- **Border Color** – Opens a color picker in which you can select a color for the frame surrounding the button. To leave the button without a frame, select **No color**.
- **Fill Color** – Opens a color picker in which you can select a color for the button. To leave the button uncolored, select **No color**.

**Note:** A Fill Color choice other than No color will block any images on the PDF page that are behind the button.

- **Font Size** – Sets the size of the label for the button. You can either choose **Auto**, various preset values, or type in a different value.
- **Text Color** – Opens a color picker in which you can select a color for the label.
- **Font** – Lists the fonts available on your computer.

---

**Push Button**

3. Options tab for the button properties

The Options properties determine how labels and icons appear on the button. A button can have a label, an icon, or both. The Options tab in push button properties enables you to add any labels you like. The Options tab in push button properties contains the following options:

- **Layout** – Specifies the layout of label and icon of the button. There are seven choices:

  - A. Label only
  - B. Icon only
  - C. Icon top, label bottom
  - D. Label top, icon bottom
  - E. Icon left, label right
  - F. Label left, icon right
  - G. Label over icon

**Button Layouts**

- **Advanced** – Does the details settings to the icon.
A. When to scale – choose when to scale the icon you insert. There are four options:

- **Always:** scale the icon to fit the button you draw.
- **Never:** never scale the icon. Show the icon with its original size all the time.
- **Icon is too Big:** zoom out the icon to fit the button if the former one is bigger than the latter one, or show the icon with its original size.
- **Icon is too Small:** zoom in the icon to fit the button if the former one is smaller than the latter one, or show the icon with its original size.

B. Scale – choose to scale the icon non-proportionally or proportionally. This option will be disabled when you select **Never** in the field of **When to scale**.

- **Proportionally:** scale the icon in its proportion.
- **Non-proportionally:** scale the icon to fit the button when the magnification is changed.

C. Fit to bounds – check this option to scale the icon to fit fully within the bounds of the button without taking into consideration the line width of the border.

D. Border – drag and move the scroll bar to change icon’s position in the button. The coordinates change when you move the scroll bar.

• Behavior – Specifies the display of the button when clicked. The button behavior options include:

- **None:** Keeps the appearance of the button the same.
- **Push:** Specifies appearances for the Up, Down, and Rollover states of the mouse. Select an option under State, and then specify a label or icon option:
  - **Up:** Determines what the button looks like when the mouse button is not clicked.
  - **Down:** Determines what the button looks like when the mouse is clicked on the button, but before it is released.
  - **Rollover:** Determines what the button looks like when the pointer is held over the button.
- **Outline:** Highlights the button border.
- **Invert:** Reverses the dark and light shades of the button.
The Button Behaviors

- To define the label or icon that appears on the button, do the following:
  
  A. If a label option is selected from the Layout menu, type the text in the Label box.
  B. If an icon option is selected from the Layout menu, click Choose icon… > click Browse… > Select the file type from the Objects of Type menu, double-click the file name, and click OK. (To remove the selected icon, click Clear button.)

- Click Close to accept these display properties.

4. Actions tab for the button properties

The Actions properties specify any actions that you want to associate with the push button, such as jumping to a specific page or going to a web site. The Actions tab in push button properties contains the following options:

- Select Trigger – Specifies the user action that initiates an action: Mouse Up, Mouse Down, Mouse Enter, Mouse Exit, On Receiving Focus, or On Losing Focus.
- Select Action – Specifies the event that occurs when the user triggers the action: Go to a page view, Open/execute a file, Open a web link, Show/hide a field, Execute a menu item, Submit a form, Reset a form, Import form data, and Run a JavaScript.

  A. Go to a page view – designate to a specific page view. You can not only designate to a page in the current PDF, but also to the page in another PDF. Also, you may change the current zoom setting and then set the position.

  To go to a page view, choose this option, click Add button and do one of the following:

  a) Set the position in current document – scroll the current document, go to a new position where you want to set and click Set this position.
  b) Set the position in another PDF document – click the Open button on the toolbar > select the PDF you want to set position > scroll this document and go to a position where you want to set > click Set this position.

  Note: The new PDF document should be opened in the existing window but not a new window.

  c) Change the view magnification -- scroll in the current document or another document > go to a new position where you want to set > change the magnification of the position >
click Set this position.

d) Click Cancel to revoke your operation.

B. Open/execute a file – designate to open another file. To do this, choose Open/execute a file > click Add button > select the destination file and click Select.

C. Open a web link – designate to open a web link. To do this, choose Open a web link > click Add button > enter the URL of the destination web page.

D. To show/hide a field, select the option > click Add... > choose to show or hide the selected button when the user triggers the action, and click OK.

E. To execute a menu item, select the option > click Add... > select one of the items in Menu Item Selection dialog box, and click OK.

F. To submit a form, select the option > click Add... > choose the export format, submission method, decide which fields should be submitted, and click OK.

G. To reset a form, select the option > click Add... > select the fields that will be reset, and click OK.

H. To import form data, select the option > click Add... > choose the FDF file that contains the form data you want to import, and click Open.

I. To run a JavaScript, select the option > click Add... > enter JavaScript, and click OK and Close.

- Actions – Displays the list of triggers and actions that you have defined.
- Up and down buttons – Change the order in which the selected action appears listed under the trigger. (Available only when you have defined multiple actions for the same trigger.)
- Edit – Opens a dialog box with specific options for the selected action. You can also double-click the actions to open a dialog box.
- Delete – Removes the selected action.

✧ Set push button properties as default

After setting button properties for a new push button, you can set your settings as the new default for all the push buttons you create in future. To set the current properties as default, right-click the push button > select Use Current Properties as New Defaults.

Check Box Button

A check box button is a button to present yes-or-no choices for individual items. For creating, moving, resizing, deleting, creating multiple copies, duplicating a check box button and setting tab order, please refer to “Push button”.

✧ Set Check Box Button Properties

There are also four tabs a General tab, Appearance tab, an Options tab, and an Actions tab for you to set check box button’s properties.
For General tab, Appearance tab and an Actions tab, please refer to Set Push Button Properties.

Options tab

Check Box Style - Specifies the style of the check box button. There are six choices:

A. Check    B. Circle    C. Cross    D. Diamond    E. Square    F. Star

Export Value - Identifies the check box button and differentiates it from other check box buttons that share the same Name value.
Check by default – Sets the selection state of the button when the user first opens the form.

Note:

1. If you create multiple copies of the check box button, please make sure both the form field names and the export value are all different in related check boxes.
2. If the check box buttons in a group have the same form field name but with different export values, the check box buttons will present a group of choices from which the user can select only one item.

Radio Button

A radio button is a type of graphical user interface widget that allows you to choose one of a predefined set of options. For creating, moving, resizing, deleting, duplicating the buttons and setting tab order please refer to “Push button”.

Tip: How to toggle radio buttons

For the radio buttons in a group, they should have the same form field name but with different export values. This ensures that the radio buttons toggle and that the correct values will be collected in the database.

1. Please use copy-paste to create multiple copies if having more than one form field with the same name. After this, to make the value usable, you have to change the value of the radio buttons to make sure all radio buttons have the same field name but different export value.
2. Please note you cannot use “Create Multiple Copies” option if there is more than one radio button with the same name. A warning message will pop up if you right click and choosing
Create Multiple Copies.

- Set radio button properties

How a radio button behaves is determined by settings in the Radio Button Properties dialog box. You can set properties that apply formatting, determine the appearance and actions, and so forth.

The radio button has a General tab, Appearance tab, Actions tab, and an Options tab as push button. Also, there are two items on every tab:

- **Locked** – When selected, prevents any further changes to any radio button properties.
- **Close** – Applies and saves the current button properties, and closes the button properties dialog box.

**Note:** If you select Locked on any tab, it will lock all options for the button, but not just the options on that tab.

1. General tab for the radio button properties

The General tab in radio button properties contains the following options:

- **Name** – Specifies the unique name of the selected radio button.
- **Tooltip** – Displays text that the hesitant user may find helpful in clicking the button. Tooltips appear when the pointer hovers over the radio button.
- **Form Field** – Specifies whether the radio button can be seen, either on screen or in print. There are four choices for you: **Visible**, **Hidden**, **Visible but does not print**, and **Hidden but printable**.
- **Orientation** – Rotates the radio button by 0, 90, 180, or 270 Degrees.
- **Read Only** – Prevents the user from clicking the radio button.
- **Required** – Forces the user to click the radio button. If the user attempts to submit the form while a required radio button is not chosen, an error message appears.

2. Appearance tab for the radio button properties

The Appearance properties determine how the radio button looks on the page. The Appearance tab in push button properties contains the following options:

- **Line Style** – Alters the appearance of the frame. Select Solid, Dashed, Beveled, Inset or Underline.

![Solid](image1) ![Dashed](image2) ![Beveled](image3) ![Inset](image4) ![Underline](image5)
The appearances of Radio Button with different line styles

**Note:** You may not see the difference if no color is chosen as the border color.

- **Thickness** – Specifies the width of the frame surrounding the radio button: Thin, Medium, or Thick.
- **Border Color** – Opens a color picker in which you can select a color for the frame surrounding the button. To leave the button without a frame, select **No color**.
- **Fill Color** – Opens a color picker in which you can select a color for the background behind the button. To leave the background uncolored, select **No color**.

**Note:** A Fill Color choice other than No color will block any images on the PDF page that are behind the button.

- **Text Color** – Opens a color picker in which you can select a color for the button.

![Radio Button Diagram]

**Note:** The items of Font Size and Font are not available in the Appearance tab for the Radio Button properties.

3. Actions tab for the radio button properties

Please refer to “**Actions tab for the button properties**”.

4. Options tab for the radio button properties

The Options tab in radio button properties enables you to change the button style and do other additional settings. The Options tab in radio button properties contains the following options:

- **Button style** – Specifies the shape of the maker that appears inside the button when the user selects it. There’re six choices in total: Check, Circle (the default), Cross, Diamond, Square, or Star. This property does not alter the shape of the radio button itself.
- **Export Value** – Identifies the radio button and differentiates it from other radio buttons that share the same Name value. The status of a radio button is “yes”. You can give them other names with this box.
- **Checked by default** – Sets the selection state of the button when the user first opens the form.
- **Radio buttons with the same name and value are selected in unison** – Allows single-click selection of multiple related radio buttons. If the user selects a radio button that has the same field name and export value as another, both radio buttons are selected.
• Click Close to accept these display properties.

✓ Set radio button properties as default

After setting radio button properties for a new radio button, you can set your settings as the new default for all the radio buttons you create in future.

To set the current properties as default, right-click the radio button, select Use Current Properties as New Defaults.

Combo Box Button

A combo box is a commonly-used GUI widget. It is a combination of a drop-down list or list box and a single-line textbox, allowing the user either to type a value directly into the control or choose from the list of existing options.

For creating, moving, resizing, deleting, duplicating the combo box and setting tab order, please refer to "Push button".

✓ Set combo box properties

How a combo box behaves is determined by settings in the Combo Box Properties dialog box. You can set properties that apply formatting, determine the appearance and actions, perform mathematical operations, and so forth.

The combo box has a General tab, an Appearance tab, an Options tab, a Format tab, a Validate tab, a Calculate tab and an Actions tab. There are two items on every tab:

➢ Locked – When selected, prevents any further changes to any combo box properties.
➢ Close – Applies and saves the current properties, and closes the combo box properties dialog box.

Note: If you select Locked on any tab, it will lock all options for this combo box, but not just the options on that tab.

1. General tab for the combo box properties

Please refer to “General tab for the radio button properties”.

2. Appearance tab for the combo box properties

Please refer to “Appearance tab for the button properties”.

3. Actions tab for the combo box properties
4. Options tab for the combo box properties

You can create a list of items from which the user selects with the Options tab.

- **Item** – Accepts the text and space character that you type for options that you want to appear in the menu for the field.
- **Add** – Moves the current entry in Item to Item List.
- **Export value** – Where you type in a value to represent the item if the data will be exported. If left blank, the entry for Name in the General tab is used as the export value.
- **Item list** – Displays the choices that will be available in the list.

**Note:** The highlighted item in the Item List box appears as the default selected item in the combo box field. To change the default item, highlight another item from the list.

- **Delete** – Removes the selected item from the list.
- **Up/Down** – Change the order in which the items are listed in the combo box list. These buttons are not available if Sort Items is selected.
- **Sort items** – Arranges the listed items numerically and alphabetically. A numerical sort (if applicable) is performed before an alphabetical sort.
- **Allow user to enter custom text** – Enable users to enter a value other than the ones in the list.
- **Commit selected value immediately** – Saves the value as soon as the user selects it. If this option is not selected, the value is saved only when the user tabs out of the current field or clicks another form field.

5. Format tab for the combo box properties

The Format tab in the combo box properties dialog box enables you to format the field values. Select one of the categories listed below:

- **None** – No additional options are available. The input in a combo box with this property does not require any specific formatting.
- **Number** – Automatically imposes the selected formatting options on numeric data entries.
  
  A. **Decimal places** – Sets the number of digits that appear to the right of the decimal point.
  B. **Separator style** – Sets the placement of commas and periods.
  C. **Currency symbol** – Sets the type of currency, such as Dollars, Euros, or Pounds.
  D. **Negative Number Style** – Sets how negative numbers are displayed. You can choose Show parentheses, Use red text, neither, or both.

- **Percentage** – Automatically imposes the selected formatting options on numeric data expressed as a percentage.
  
  A. **Decimal places** – Sets the number of digits that appear to the right of the decimal point.
B. Separator style – Sets the placement of commas and periods.

- Date – The list includes one-, two-, and four-digit variations where \( d \) stands for the day, \( m \) stands for the month, and \( y \) stands for the year. Also, you can choose Custom option and type your format.
- Time – The list includes display variations where \( h \) stands for the hour on a 12-hour clock, \( H \) stands for the hour on a 24-hour clock, \( MM \) stands for minutes, \( ss \) stands for the seconds, and \( tt \) stands for AM or PM. Also, you can choose the Custom option and type your format.
- Special – There are five options for you:
  A. Zip Code – For a five-digit postal code.
  B. Zip Code + 4 – For a nine-digit postal code.
  C. Phone Number – For a ten-digit telephone number.
  D. Social Security Number – For a nine-digit US Social Security Number.
  E. Arbitrary Mask – Changes the format category to Custom and makes another text box available, in which you can type a custom format. Use this option to specify which types of characters the user can enter in any given position, and how the data displays in the field.
    a. A – Accepts only letters (A–Z, a–z).
    b. X – Accepts spaces and most printable characters, including all characters available on a standard keyboard and ANSI characters in the ranges of 32–126 and 128–255.
    d. 9 – Accepts only numeric characters (0–9).

For example, a mask setting of AAA--p#999 accepts the input BDF--p#367. A mask setting of OOOOO@XXX accepts the input vad12@3Up.
• Custom -- Makes additional options available to form designers who want to write their own JavaScripts for formatting and keystrokes. For example, a custom script could define a new currency format or limit the user entry to specific keystroke characters.

A. Custom Format Script – Displays any custom scripts you have added for formats. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.
B. Custom Keystroke Script – Displays any custom scripts you have added to validate keystrokes. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

6. Validate tab for the combo box properties

The Validate properties restrict entries to specified ranges, values, or characters, ensuring that users enter the appropriate data for a combo box.

• Field value is not validated -- Turns off validation.
• Field value is in range -- Sets a numeric range for a combo box using values you enter in either as a number or a percentage. It is available only when Number or Percentage is selected in Format tab.
• Run custom validation script -- Validates by a JavaScript that you create or provide. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

7. Calculate tab for the combo box properties

With this option, you can perform mathematical operations on existing form field entries and display the result.

• Value is not calculated -- Select this option if you want the users to type.
• Value is the -- Select this to make further options available:
  A. The List includes the mathematical functions to apply to the selected fields. Choose Sum to add the values entered in the selected fields, Product to multiply them, Average, Minimum, or Maximum.
  B. Pick -- Opens a Field Selection dialog box with a list of the available fields in the form that you select to add or deselect to remove from the calculation.

• Simplified field notation -- Uses JavaScript with field names and simple arithmetic signs. The Edit button opens a JavaScript Edition dialog box in which you can write, edit, and add scripts.
• Custom calculation script -- Displays any custom scripts you have added for calculations. The Edit button opens a JavaScript Edition dialog box in which you can write and add new scripts.

◊ Set combo box properties as default

After setting combo box properties for a new combo box, you can set your settings as the new default for all the combo boxes you create in future.
To set the current properties as default, right-click the combo box > select **Use Current Properties as New Defaults**.

**List Box and Text Field Button**

A list box is a GUI widget that allows the user to select one or more items from a list contained within a static, multiple line text box. Also, you can set a list box property that enables the user to Shift-click or Ctrl-click/Control-click to select multiple items on the list.

A text field is a common element of graphical user interface of computer programs, as well as the corresponding type of widget used when programming GUIs, which let the user type in text, such as name, address, phone number, etc.

For creating, moving, resizing, deleting, duplicating the list box and text field and setting tab order please refer to “**Push button**”.

✦ **Set list box properties**

Please refer to “**Set combo box properties**”.

✦ **Set text field properties**

Although most of the properties are common to those of combo boxes, the Options tab is exclusive.

1. For all the other properties of a text field, please refer to “**Set combo box properties**”.

2. Options tab for the text field properties

   • **Alignment** – Aligns the text left, right, or center within the field.
   • **Default Value** – Specifies the text that appears until the user overwrites it by typing in the field. Enter the default value by typing in this option.
   • **Scroll long text** – Compensates for text that extends beyond the boundaries of the text field.
   • **Allow Rich Text Formatting** – Allows users to apply styling information to the text, such as bold or italic. This might be useful in certain text fields where such styling information is important to the meaning of the text, such as an essay.
   • **Limit of Characters** – Allows entries of up to the number of characters you specify.

**Note:** *If you entered a default value, that value is clipped to this limit.*

• **Password** – Displays the user-entered text as a series of asterisks (*). This option is available only if Check Spelling is deselected.
• **Field is used for file selection** – Allows the user to enter a file path as the field’s value when a file is submitted along with the form. This option is available only when Scroll long text is the only selected option in the Options tab.
Check spelling – Checks the spelling of user-entered text.
Comb of Characters -- Spreads the user-entered text evenly across the width of the text field. If a border color is specified, Solid or Dashed Line is selected in the Appearance tab, each character entered in the field is separated by lines of that color. This option is available only when no other check box is selected.

Text fields with and without the Comb property

A. Text field with a border color, using the Comb property

B. Text field without the Comb property

Multi-line – Allows more than a single-line entry in the text field. Setting line spacing is available in a multi-line text field.

Set text field properties as default

To set the current properties as default, right-click the text field > select Use Current Properties as New Defaults.

Signature Field Button

The signature field is specially designed by to create blank digital signature fields for reviewers to sign. You can place the field anywhere you want the reviewers to sign.

Create a new Signature field

Choose Form > Form Fields > Signature Field button , your cursor will change into “+” and do the following:

Drag an area in the desired place to create a signature field button.
A box appears under the button for you to input the name.
You can also click the All Properties to do more settings. Or double-click the button to open the signature Properties dialog box.

For moving, resizing, deleting, duplicating the signature field and setting tab order, please refer to “Push button”.

214
To set signature field’s General, Appearance and Actions tab properties, please refer to “Set push button properties”.

Foxit PhantomPDF supports to sign and verify digital signatures on XFA forms created by Adobe LiveCycle. To sign and verify digital signatures, please refer to Digital Signature.

Signed tab for the signature field properties

- Nothing Happens When Signed – it is set as default.
- Mark As Read-Only - Prevents other readers to change the digitally signed form.
  - All Fields - Prevents any changes to any form field.
  - All Fields Except These - Allows changing the selected form fields. Click the Pick button and select check boxes for the fields that you want the reviewers to edit after signing.
  - Just These Fields – Prevent to change the form fields you pick.

- This Script Executes When Field is Signed:

  Activate a custom JavaScript when the user digitally signs the form. Click the Edit button to change or create a new JavaScript action.

**Arrange form fields**

You can arrange form fields in a page, such as aligning, centering and distributing form fields. Before arranging form fields, select multiple form fields.

**Select multiple form fields**

To arrange the form fields, you have to select multiple form fields that you want to arrange first.

To select multiple form fields, do one of the following:

- Choose the Select Annotation command > Shift-click or Ctrl-click each form field.
- Choose the Select Annotation command > drag a selection marquee around the area to select them.

To deselect an individual form field, Ctrl-click the specific field.

*Note: The form field highlighted in red is the anchor. When you select multiple form fields by clicking, the last field selected is the anchor.*
Align multiple form fields

You can align the selected form fields left, right, top, bottom, vertically or horizontally. Select one of the form fields as the anchor, the rest of the form fields will be placed respectively to the left edge, right edge, top edge, bottom edge, vertical axis or horizontal axis of the anchor form field. Select two or more form fields that you want to align and do one of the following:

- Right-click the anchor, choose **Form > Edit > Arrange**, and in the Alignment category select one to align the form fields.
- Right-click the anchor, and then choose a command as follows:
  A. To align a column of form fields, choose **Left, Right, or Vertically** to align them respectively to the left edge, right edge, or vertical axis of the anchor form field.
  B. To align a row of form fields, choose **Top, Bottom, or Horizontally** to align them respectively to the top edge, bottom edge, or horizontal axis of the anchor form field.

**Note:** When you right-click or Ctrl-click one of the selected form fields, it will be highlighted in red, indicating that it's the anchor form field. The align menu commands move the other selected form fields to line up with the edges of the anchor form fields.

Center multiple form fields

This function enables you to center the rectangle enclosed by form. Select form fields. You can imagine that these form fields consist of an area with the shape of rectangle. Then do one of the following:

- Choose **Form > Edit > Arrange**, in the Page Center category select one as the anchor to center the form fields.
- Right-click one of the form fields > **Center > Vertically/ Horizontally/ Both**. You will find that the rectangle is centered respectively vertically, horizontally or both in the page.

Distribute multiple form fields

This function will be available when selecting three or more form fields. Select the form fields to be distributed, and do one of following:

- Choose **Form > Edit > Arrange**, in the Distribute category select one as the anchor to distribute the form fields.
- To distribute the form fields evenly between the topmost and bottommost form fields, choose **Distribute > Vertically.** To distribute the form fields evenly between the leftmost and rightmost form fields, choose **Distribute > Horizontally.**
Resize multiple form fields

Select one of the form fields as the anchor, and the rest of the form fields will be resized with the same height or width as that of the anchor form field. For example,

- Select form field A and B with the Select Annotation command. Suppose that you want to set A as the anchor form field.
- Right-click A > Size > Height/Width/Both. And you’ll see that the height/width/height and width of B is resized to be the same as that of A.

Set Form-field Tab Order

Please refer to Set Tab Order of Push Button.

Page templates

Page templates can be used to fill a PDF form where users need to add more pages if they still have info to enter. Or, an official organization like Customs creates a page template which contains several buttons with JavaScript actions that corresponding forms will appear when users click on different buttons to fill in forms based on different situations.

Create a page template

1. Navigate to a page that you want to create a page template from.
2. Click Form > Edit > Page Template.
3. In the Page Templates dialog box, enter the name and click Add.
4. A message box pops up to ask you whether to create a new page template from the current page. Click OK.
5. The name of the created template will be listed in the dialog box, and you can preview it on the left of the dialog box by checking the box to the left of the template name.
6. Click Close to exit the Page Templates dialog box.

Manage page templates

In the Page Templates dialog box, choose a template and click Goto to navigate to the page. You can also rename, replace, and delete page templates.

 Rename a page template

1. Click Form > Edit > Page Template.
2. In the **Page Templates** dialog box, choose the template you want to rename, click **Rename** and click **OK**.
3. Type a new name in the pop-up dialog box and click **OK**.
4. Click **Close** to exit the **Page Templates** dialog box.

- **Replace a page template**

1. Navigate to a desired page you want to replace with.
2. Click **Form > Edit > Page Template**.
3. In the **Page Templates** dialog box, choose the template you want to replace, click **Replace** and click **OK**.
4. Click **Close** to exit the **Page Templates** dialog box.

- **Delete a page template**

1. Click **Form > Edit > Page Template**.
2. In the **Page Templates** dialog box, choose the template you want to delete, click **Delete** and click **OK**.
3. Click **Close** to exit the **Page Templates** dialog box.

**Set the field calculation order**

When you define two or more calculations in a form, the order in which they are carried out is the order in which you set the calculations. In some cases, you may need to modify the calculation order to obtain correct results.

For example, if you want to use the results obtained from calculating two form fields to calculate the value of a third form field, the first two form fields must be calculated together first to obtain the correct results.

- Choose **Form > Edit > Calculation Order**.

The Calculation Order dialog box displays all calculable fields in your form and the order in which the calculations are performed.

- To change the field calculation order, select the field from the list, and then click the **Up** or **Down** button as needed.
- Click **OK** to finish.

**Edit Static XFA Forms**

Foxit PhantomPDF supports editing of static XFA forms.
To edit static XFA forms, please do as below:

1. Open the static XFA form with Foxit PhantomPDF and choose Form > Edit > Edit Static XFA Form. You’ll be prompted to save a copy of the original file to continue to edit.

2. Click Yes to edit the form as needed.

**Set properties of multiple form fields**

- Select multiple form fields > right-click one of them > Properties....
- There pops up a dialog with a General tab and an Appearance tab, and then follow the steps specified above.

**JavaScript**

JavaScript is a dynamic, prototype-based language with first-class functions, which serves as a means to easily create interactive web pages. In Foxit PhantomPDF, you can easily integrate this level of interactivity into your PDF documents.

With Foxit PhantomPDF, you can invoke JavaScript code using actions associated with documents, bookmarks, links, and pages. Foxit PhantomPDF provides four options – Document JavaScript, Document Action, JavaScript Console, and Edit All JavaScripts. The Document JavaScript lets you create or access document level scripts in Foxit PhantomPDF. The Document Action lets you create document-level JavaScript actions that apply to the entire document. The JavaScript Console provides an interactive and convenient interface for testing portions of JavaScript code and experimenting with object properties and methods. The Edit All JavaScripts option allows you to create and edit all JavaScripts (e.g. bookmark JavaScripts, page JavaScripts, etc.) in the JavaScript Editor.

**Document JavaScript**

Document JavaScripts are variable and function definitions that are generally useful to a given document, but are not applicable outside the document.

- Variable definitions: Define variables at the document level to make them visible to any executing script.
- Function definitions: Define functions at the document level that support the user interaction with the document. These functions may be utility functions for handling common tasks for string or number manipulation, or functions that execute lengthy scripts called by actions initiated by a user interacting with form fields, bookmarks, page changes, etc.
To create or access document level scripts in Foxit PhantomPDF, select **Form > JavaScript > Document JavaScript**. The pop-up Java Script Functions dialog box enables you to add, edit, or delete document level scripts. All the document level scripts are stored within the PDF document.

In Java Script Functions dialog box, you will see the following buttons:

- Close – Closes the dialog box.
- Add – After typing a new Script Name, a JavaScript Editor dialog box pops up. You can create and edit document level scripts here. To change the font of JavaScripts, click the Font button.
- Edit – The JavaScript Editor dialog box pops up, enabling you to modify the JavaScripts you create.
- Delete – Delete the JavaScript you selected.

**Document Action**

You can create the document-level JavaScript actions that apply to the entire document. For example, selecting Document Did Save runs the JavaScript after a document is saved.

**JavaScript Console**

JavaScript Console is a control panel for the execution and debugging of JavaScript code. Serving as a debugging aid, it is quite useful for displaying debug messages and executing JavaScript. To active the JavaScript console, select **Form > JavaScript > JavaScript Console**, and do the following:

A. In the pop-up JavaScript Console dialog box, type your JavaScript code, or click Open and select one of the file with JS format.
You can click **Save** to save a copy of your JavaScript code, or click **Cancel** to revoke your operation.

### JavaScript Editor

You can use the JavaScript Editor to create and edit all the JavaScripts in a PDF file. To open the JavaScript Editor, choose **Form > JavaScript group > JavaScript > Edit All JavaScripts**. In the **JavaScript Editor** dialog box, click **Go to** to jump to a specific line of code. After editing the JavaScripts, click **OK** to save it.

### Optional Database connectivity to Windows ODBC

The Optional Database Connectivity plug-in is a JavaScript object inside Foxit PhantomPDF, allowing you to connect to Windows ODBC (Open Database Connectivity) data sources. It provides some basic JavaScript properties and methods to gain increased customization options and data accuracy to access to information databases. More importantly, JavaScript can be used to execute SQL commands and retrieve data, which can, in turn, be used to populate a PDF file. Also, developers can create document level-scripts to connect to a database for the purposes of inserting new data, updating information, and deleting database entries.

B. Click **Run** button to run your JavaScript code. You will be prompted that the code has run successfully. When the code goes wrong, it gives you an error message.
Chapter 10 – Security

The security feature of PDF gives you an exceptional control over your PDF files. To provide adequate protection for PDF’s contents, you can encrypt and secure PDF files to prevent unauthorized access, restrict sensitive operations, etc.

Check PDF Security

Some PDF files may contain restrictions preventing actions such as printing, editing, copying, etc. To check if you have these permissions, please do the following:


Password Protection & Certificate Protection

In Foxit PhantomPDF, you can add password protection, certificate protection, and security restrictions to a PDF or PDF portfolio, limiting who can open the file, can copy, edit or print the file, etc. However, the protection in a secured PDF portfolio does not apply to the PDF files in it, so for the component PDFs in a PDF portfolio, if you need to add or remove protection, open the component PDFs and then add/remove protection.

Password Protection

You can add a password to a PDF to limit access and restrict certain features, such as printing, copying and editing.

There are two kinds of passwords that could be applied to a PDF file: a Document Open password and a Permissions password. When you set a Document Open password, anyone who tries to open the PDF must type in the password that you specified. When you set a Permissions password, anyone who wants to change the restrictions must type the Permissions password. Please note that if a PDF is secured with both types of passwords, it can be opened with either password, but only the Permissions password allows you to change the restrictions.

Tip:

1. There’s no way out to recover password from the PDF if you forgot it. To keep a backup copy of the PDF that isn’t password-protected is a good choice.
2. Foxit PhantomPDF allows you to input Unicode password in the password input box when you open a document protected by Unicode password.
Add a password security

2. In the Password Protection dialog box, do the following:

Document Open Settings:

Require a password to open the document – selects to require users to type the password you specify to open the document.

Password Input: specifies a password that users must type to open the document.

Password Confirm: type the password again to confirm the password.

Document Restriction Settings:

Add Document Restriction – restricts actions to PDFs, such as printing, editing, etc.

Password Input: specifies a password that is required to change the permissions settings. If the file is opened in Foxit PhantomPDF, the user can view the file but must enter the permissions password to change the file’s security and permissions settings.

Password Confirm: type the password again to confirm the password.

Permission Specification:

The security details you specified are shown on the left. Click Permission to set the restriction settings. In the Permission Settings dialog box, check Restrict printing and editing of the document and its security settings and then select the options as needed.

Print Allowed – specifies the level of printing which users are allowed for the PDF.

A. Print with low resolution – allows users to print at no higher than 150-dpi resolution.
B. Print with high resolution – allows users to print with any resolution.

Changes Allowed – defines which editing actions are allowed in the document.

A. Inserting, deleting, and rotating pages – allows users to insert, delete, and rotate PDF pages.
B. Filling in forms and signing existing signature fields – allows users to fill in forms and sign documents in existing signatures fields.
C. Commenting, filling in forms and signing existing signature fields – allows users to add comments, fill in forms and sign documents in existing signatures fields.
D. Any except extracting pages – allows users to do any operation but extract pages. If you
choose this option when encrypting a PDF portfolio, users are allowed to add, create, and remove files in the PDF portfolio.

**Enable copying of text, images, and other content** – allows users to copy content in PDFs.

**Enable text access for screen reader devices for the visually impaired** – allows the visually impaired users to access text with screen reader devices.

**Encrypt Settings:**

**Encryption Algorithm** - defines data transformations that cannot be easily reversed by unauthorized users. Foxit PhantomPDF supports 128-bit AES, 256-bit AES and 128-bit ARC-FOUR.

**Don’t encrypt metadata** – encrypts the contents of a PDF but still allow search engines access to the document metadata.

**Save the setting as a new policy** – save the current security settings as a policy so that you can apply it to other documents.

3. Click Ok and save the document to make setting take effect.

### Modify password and security settings


2. In the Security tab of the Document Properties dialog box, choose **Document Security > Password Protection**, and then click **Change Settings**...

3. Do the settings as “**Add a password security**” and then click **OK**.

### Remove password and security settings

To remove password and security settings from a PDF, you must have the permissions to do so.

1. Open a PDF, and choose either way of the following to remove password and security settings.

   - Choose **Protect > Secure Document > Remove Security**.

2. A **Foxit Security** message box will prompt to ask whether you are sure to remove security from this document.
**Certification Protection**

The advantage of securing documents with certificates is that authors can specify unique permissions for each person. For example, authors can permit a person to fill in forms and comment in document, and permit another person to edit text or delete pages. You can choose certificates from files on disk, or from the Windows certificate store. Only a specific set of users whose identities can be verified and managed can have access to the document. A certificate that contains public key and other identifying information is used to encrypt documents, or verified a digital signature. Only corresponding private key decrypts the document that was encrypting using the certificate.

Generally, if possible, encrypt documents using certificates from third-party provider. If the certificate is lost or stolen, the issuing authority can replace it, if a self-signed certificate is deleted, all PDFs encrypted using the certificate is forever inaccessible.

**Add a certificate security**

2. In Certificate Protection dialog box, create intended recipient list for the encrypt document:
   - Click **New ID** to create and store your self-signed digital ID in:
     - **New PKCS#12 digital ID file** – Stores the digital ID information to a file with the extension `.pfx` on Windows and `.p12` on Mac OS. You can use the files interchangeably across different operating systems.
     - **Windows Certificate Store** – Stores the digital ID to a common location. Other Windows applications can also retrieve it.
   - Click **Import** to import certificate from Windows Certificate store.
   - Click **Browse** to import certificate from disk.
   - Click **Remove** to delete a recipient from recipient list.
   - Click **Permission** to set document restriction for the selected recipient. About Permission options, please refer to “Add document restrictions” of **Password security options**.
3. Select **Encryption Algorithm** (support 128-bit AES, 256-bit AES and 128 bit ARC-FOUR).
4. Check **Don’t Encrypt metadata** to encrypt the documents except metadata.
5. (Optional) Check **Save the settings as a new policy** to save the current security settings as a policy so that you can apply it to other documents.
6. Click **OK** and save the document.

See also “**About digital ID**”
Change or remove certificate protection

To change or remove security settings, you must have permission to do so. If you want to change or remove security encrypted with certificate, you must have all access to the document, or you can’t do changes or remove security settings.

To change certificate protection, please do the following:

3. In Certificate Protection dialog box, refer to Add a certificate security.
4. Click OK and save the document to apply your changes.

To remove certificate protection, please do one of the following:


Set Security Policies

If you often apply the same security settings to multiple PDFs, you can save your settings as a policy that you can apply to other PDFs. Security policies include the security method, encryption password, permission settings, etc.

Create a security policy

2. Click New.
3. Choose security method from menu and specify the policy name and description.
4. Click Edit Details to set restriction settings or passwords.
5. Review the policy details, and then click Close.

Secure PDFs using policies

You can apply any security policy to a PDF file. To secure a PDF with a security policy that you specified, do the following:

1. Open a PDF document.
3. In the Manage Security Policies dialog box, select a policy which you want to apply to the PDF
4. Click **Apply to this Document**.
5. Save the document to apply the security policy.

**Manage security policies**

After you create security policies, you can manage them by copying, editing, and deleting.

2. In the Manage Security Policies dialog box, select a policy from left panel and do one or more of the following:
   - Click **New** to create a new policy.
   - Click **Copy** to copy a policy. This option is useful when you create a new policy that’s based on the settings of the selected policy.
   - Click **Edit Details** to edit a policy.
   - Click **Delete** to delete a policy.
   - Click **Close**.

**AD RMS Protection (Business Edition Only)**

Microsoft Windows Rights Management Services is an information technology that works with AD RMS enabled applications to help safeguard digital information from unauthorized use. Users can restrict users to open, read, modify or redistribute certain information. Foxit PhantomPDF RMS protector provides seamless integration with Microsoft Windows Rights Management Services to protect PDF documents and manage policy templates. If you are authorized you can use Foxit PhantomPDF to open an RMS-Protected document to improve information security and meet compliance requirements.

Once installed, Foxit PhantomPDF will extend all Microsoft AD RMS service to all PDF files.

*Note:* If you open a PDF which is encrypted by AD RMS feature of PhantomPDF with other PDF programs, a wrapper (which is actually a PDF page) will prompt you to download Foxit PhantomPDF to open the PDF. If you want to edit the wrapper content, please save the updated content as a PDF file named “wrapperPDF.pdf” and place it within the Foxit PhantomPDF installation directory.

As for using Windows Azure AD Right Management (AAD RMS), please refer to the [Quick Start for Windows Azure AD Right Management](#).

**RMS Encryption**

1. Click **Protect > AD RMS Protect > Restricted Access**.
2. Choose the template to add RMS encryption. If you have more than one server, please firstly move the cursor to the name of the server, and then the templates on this server will be shown on the submenu. Click **Refresh Templates** to get the latest official templates from the server. You also can create custom templates. For more detailed information, please refer to **Template Creation**.

3. If you do not want to use the template, please click **Restricted Access**.

   - Type your account name and password when you login to the RMS server for the first time.
   - Click the icon ![Read...](image) to add users who you want to authorize for reading permission. To authorize anyone to read this file, select the icon ![Read...](image) on the right side.

   (If you have an Outlook Email Client, the contact list of Outlook will pop up when you click the icon ![Read...](image). You can choose the email address directly. You can also just type certain letters included in the email address, and then click icon ![Read...](image), the system will help you enter the complete address according to the contact list. Then you can go on to the **More Options** step.)
Choose the object types (users or group) and the server. Then type the e-mail addresses of the authorized users into the text box or click Advanced to open the e-mail address list on the server to choose an address directly.

Click OK to exit the Select Users or Groups dialog box.
Click More Options in the Permission dialog box. The users you selected now will be shown on the text box. You can also add or delete users as needed here.
Additional permissions for users:

**This document expires on**: check it to set the expiration date. The document cannot be opened after the specified date.

**Print Content**: check this option to allow the users above to print the PDF files.

**Allow users with read access to copy content**: enable the users who only have read permission to copy content.

**Allow users with read access to comment and fill form fields**: enable the users who only have reading permission to make comments and fill in form fields.

**Access content programmatically**: enable users to run the JavaScript in the document.

**Extended Policy**: complete PDF protection and control of document usage. The policy will allow document owners to control the following items.

- **Only allow access to these pages**: specify the page number(s) that a user is allowed to access.
- **Only allow access by this IP range**: specify an IP range that is allowed to access a document.
- **Number of accesses**: specify the number of times that a user is allowed to access a
Number of prints: specify the number of times that a user is allowed to print a document.

![Extended Policy](image)

**Note:** To specify the “Number of accesses” and “Number of prints” items in an on-premise environment, please refer to [Web Service Configuration](#) to configure the web service and SQL first, and then enable the extended policy with the [Foxit Configuration Tool](#).

**Additional settings:**

- **User can request additional permissions from:** if users want to apply for any permission, the application will open the email client and list the email address you typed into the text in the Recipient’s Address automatically. You can type a URL as well.

- **Require a connection to verify a user’s permission:** check this option to let users verify their license every time they open the encrypted file.

- **Security Watermark:** add a security watermark to the PDF files. For the detailed instructions, please refer to [Security Watermark](#).

- **Set Defaults:** set the additional settings as default.

- **Save as template:** the security setting set above can be saved as a template for further use.

4. If users need to request additional permissions for a PDF file, please do the following:

   - Open the file and choose **File > Properties.** In the **Document Properties** dialog box, click **Security** tab.
   - At the bottom of **Security** tab, click **Request additional permissions ....**

**Note:** Foxit PhantomPDF also supports Microsoft IRM Specification V1, V2, and PPDF, of which
Microsoft IRM Specification V2 is the default format when you encrypt PDFs with RMS. The encryption policy of Microsoft IRM Protection does not include dynamic watermark, extended policy, and dynamic revocation. To change the default Microsoft IRM format, do the following:

1. Type regedit.exe in the Run window or in the search box of the Start menu and navigate to the following path: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Foxit\PhantomPDF 9.0\RMS\Preferences.

2. Create a new REG_DWORD 32 value:

   Name: UseMicrosoftIRMV1.

3. Use the corresponding value to set the format as default as below.

   PPDF: 0
   V1: 1
   V2: 2

Template Creation and Editing

To create a custom template, please see the following steps:

1. Choose Protect > AD RMS > Settings > Custom Templates.

2. Click Create to open the Create Custom Rights Policy Template dialog box.

3. (Optional) If you want to edit the existed template, please click Edit.

4. Click Add to choose the language and edit template name and description. Click OK. The template name and description will be shown in the Template Identification list.

5. Click Next to add user rights. Click Add in Users and Rights.

6. In the pop-up Add User or Group dialog box, choose The e-mail addresses of users or groups, click Browse to simply add a user who you would like to assign the rights. Selecting Anyone allows every user to work with the encrypted PDF files. You can type multiple e-mail addresses as well.

7. Check PDF permissions for the specified users. You can set the permissions for all of the users or set different permissions for different users.

8. User can request additional permissions from: if users want to apply for any permission, the application will launch the email client and list the email addresses you typed into the text in the Recipient's Address automatically. You can type a URL as well.

9. Click Next to specify the expiration policy.
Content expiration

Never expires: the PDF content can be viewed indefinitely.

Expires on the following date: the PDF content will expire on a given date.

Expires after the following duration (days): the PDF content will expire after the desired days selected.

Use license expiration

Requires users to re-verify permissions with the server after the following duration (days): users need to apply for a new license to open the encrypted PDFs several days (the number you type into) later.

10. Click Next to specify security watermark and the extended policy. Please refer to Security Watermark and Extended Policy. Then click Finish to complete creating the template.

11. Click OK in the Manage Custom Rights Policy Templates dialog box. The template will be added to the template list under Protect > AD RMS Protect > Restricted Access.

Security Watermark Management

1. Creating Profile

Before adding a watermark, you should create a profile first. The application will apply all of the watermarks in the profile to a PDF.

Note: you can only choose a profile but not a certain watermark to use. Please create the watermarks you want to add to one PDF in the same profile.

• Choose Protect > Settings > Security Watermark Management.
• Click New Profile to create a profile and name it.

2. Add Watermark

To add a new watermark, please do the followings:

• Open the Security Watermark Management and select a profile you created and click Add to add watermarks in the profile.
• Type the watermark's name.
• Fill in the watermark's content in the text box and set the font, size, color, underline, and alignment.
  Note: you can only set text as watermark.
• Choose the Dynamic Text. When any PDF reader opens the file, the watermark will show the current document information dynamically and you can use multiple text at the same time.
Content ID: shows the content ID of the current document.
Document Title: shows the current document title.
Author: shows the author of current document.
Current User: shows the current user who is reading the document.
Date: shows the current system date when opening the document.
Day: shows the current system day when opening the document.
Month: shows the current system month when opening the document.
Year: shows the current system year when opening the document.
Time: shows the current system time when opening the document.
Hour: shows the current system hours when opening the document.
Minute: shows the current system minutes when opening the document.
Second: shows the current system seconds when opening the document.

- Set the appearance by choosing the rotation degree and the opacity. You also have the option to make the scale relative to the target page.
- Set the vertical and horizontal distance between the target page and the watermark.
- Choose the page range to apply the watermark. You can select the different page range options by selecting from the subset list.
- Preview the watermark in the right pane.
- Click OK to finish.

3. Edit or Delete Watermark

Edit a Watermark
- Open the Security Watermark Management and select a watermark you want to edit.
- Click Edit to open the Edit Security Watermark dialog box.
- To edit the watermark, please refer to “Add Watermark”.
- Click OK to finish the operation.

Delete a Watermark
- Open the Security Watermark Management and select a watermark you want to delete.
- Click Delete to remove the selected watermark.

4. Import or Export Watermark

Import a Watermark
- Open the Security Watermark Management and click Import.
- Choose a watermark with .xml format.
- Click Open.

Export a Watermark
- Open the Security Watermark Management and select a watermark you want to export.
- Click Export and choose a file type and location to save.
- The watermark will be exported as an .xml file or encoded file according to your choice. It can
be integrated into AD RMS policy template and applied to the PDF files by Foxit PhantomPDF.

**Note:**

1. If you want to integrate the watermark to a common policy template, please export it as an .xml file and add it to the template by PhantomPDF directly.

2. If you want to integrate the watermark to an official policy template, please export it as an encoded file (.txt format) and integrate it into the template by AD RMS Scripting API Architecture. Then you can import the template and apply it to PDFs by PhantomPDF. (Please click [here](#) to see the example and use the value of “appData.Name” and “appData.Value” in the exported encoded file.)

**Foxit Configuration Tool**

Foxit PhantomPDF RMS protector provides a handy configuration tool for administrators to better modify the protection settings on an RMS server. Administrators can directly enable/disable each tool, edit the extended policy of official templates, dynamically revoke permissions, audit logs, set valid network printers, and customize wrapper files.

To start to use the configuration tool to encrypt PDFs, please do the following:

- Log on to your RMS server.
- Download the Foxit Configuration Tool from:

  For X86:
  
  [http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool_32.zip](http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool_32.zip)

  For X64:
  
  [http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool_64.zip](http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/FoxitConfigurationTool_64.zip)

- Unzip and Run Foxit Configuration Tool, you can use the different tools in Foxit Configuration Tool window.
Through the **Foxit Configuration Tool**, administrators can easily edit the extended policy of official templates. Click **Template Extended Policy** tool and choose one template to edit. See also **Extended Policy**.

**Tip:** Click the Back button in the left corner to return to the Foxit Configuration Tool window.

**Dynamic Revocation**

Revocation is a mechanism that revokes a PDF document that has already been issued. A common use of revocation is to remove rights from an individual when he is no longer authorized or remove access to a document when it becomes out of date or invalid.

**Note:** To revoke a PDF document/user in an on-premise environment, please refer to **Web Service Configuration** to configure the web service and SQL first. Then choose the **Revocation** tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

To revoke a PDF document, click **Document Revocation**. Select the PDF document you want to revoke, click **Add** button to add the document to the Revocation List. Or you can click **Browse** to select a document from a local drive to add to the Revocation List. To remove the revocation, please
select the document in the Revocation List and click **Remove** button.

To revoke a user, click **User Revocation**. Click **Add** button to add a user to the User Revocation List. To remove the revocation, please select the user in the list and click **Remove** button.

**Extended Policy**

Foxit Configuration Tool provides you with Extended Policy to add complete PDF protection and control to your PDF documents. The policy allows documents owners to control the number of access and the number of prints in an on-premise environment. Before you specify the two permissions, please refer to [Web Service Configuration](#) to configure the web service and SQL first, and then choose the **Extended Policy** tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

**Auditing Logs**

Foxit PhantomPDF enables you to track on the usage of RMS protected files to record the actions on the files during workflow, including who accessed the document, what document was accessed, when it was accessed, how it was accessed and the success of that access, and more.

To audit logs, please refer to [Web Service Configuration](#) to configure the web service and SQL first, and then choose the **Audit Log** tool in the Foxit Configuration Tool window and enable the tool by clicking the button.

Choose one log and click on the **Export** button to export to Foxit Reader’s registry or Foxit PhantomPDF’s to generate a .reg file for the administrator’s configuration. The administrator can distribute the .reg file to client-end computers.

**Restrict Local Printing**

You can also set the printing permissions by specifying certain network printers to protect the sensitive information from being printed arbitrarily.

✧ **Network Printers Configuration**

To avoid unauthorized printing of sensitive documents, you can limit the printing permissions to certain network printers. To configure network printers, please refer to [Web Service Configuration](#) to configure the web service and SQL first, and then click the **Valid Network Printer Setting** tool in the “Foxit Configuration Tool” window and click the button to enable this tool.
1. You should get the Printer Port first. Please go to Start > Devices and Printers > right-click a network printer > Printer Properties. In the printer properties dialog box, choose Ports tab and get the information, e.g. the “IP_192.168.3.239” is the printer port.

![Printer Properties Dialog Box](image)

2. Click Add button in the “Foxit Configuration Tool” dialog box to add the Printer Port. You can also remove a printer port by choosing it and clicking Remove.

   **Note:** About how to add a network printer, please see “Add a Network Printer”.

   ✤ **Add a Network Printer**

   There are two devices to add a network printer as below:

   - Go to Start > Devices and Printers > Click Add a printer. In the Add Printer dialog box, click The printer that I want isn’t listed to go to the next step.

     Follow the instructions shown in the Add Printer dialog box as below and complete adding a printer.
• Open the Run box by pressing shortcut keys Win + R, enter the printer URL you want to add and click OK.
• In the pop-up dialog box, right-click the printer and choose Connect on the context menu.

**Edit Wrapper Content**

If you open a PDF which is encrypted by Foxit with other PDF viewers, a wrapper (which is a PDF page) appears with a prompt that you need to download Foxit Reader/PhantomPDF to open the encrypted PDF. With Foxit Configuration Tool, you can customize the wrapper by selecting a desired PDF file.

To apply a custom wrapper, please refer to Web Service Configuration to configure the web service and SQL first. Then choose the Edit Wrapper Content tool in the Foxit Configuration Tool window, enable the tool by clicking the button , and select a desired PDF file.
RMS Settings

You can specify the RMS settings before you encrypt PDFs. To specify RMS settings, please navigate to File > Preferences > RMS Settings.

Remove Hidden Data

Foxit PhantomPDF supports to sanitize documents by removing the hidden information that is private or sensitive for users from their PDFs, generally including metadata, embedded content and attached files, scripts, etc.

You can remove hidden data from a PDF by one-click, please go to Protect > Hidden Data > Sanitize Document.

Redaction (Business Edition Only)

The redaction feature allows you to remove sensitive information from your document prior to making it available to others. You are able to mark the text or graphics for Redaction first, and then apply the redaction.
Mark for Redaction

To mark the text or graphics for redaction, do the following:

- Select Protect > Redaction > Mark for Redaction, and the Hand command changes into a Cross ‘×’ automatically.
- (Optional) Double-click an image to mark an entire image which will be in a red rectangle.
- (Optional) Hold the pointer over the text you want to redact and drag a rectangle around it.
- The rectangle will be filled with black color once moving close the pointer to the selected area.

Set Redaction Properties

You can set redaction properties, such as the appearance and the author, and so forth. Only before you apply the redaction can you set the properties.

Right-click the marked area and choose Properties... and the Redaction Properties dialog box pops up. The redaction properties have Appearance tab, General tab and Review History tab. There are two additional settings on every tab:

- Locked – When selected, prevents any further changes to any redaction properties.
- Set Current Properties as Default – sets the current properties as default.

Appearance tab:

Redacted Area Fill Color – select a fill color for the boxes that will replace the redacted items.

Use Overlay Text – check this item if you need to display some text or code on the redacted area. You can set the font, font size, font color and text alignment.

Custom Text – check this option and input the text you want to display in the redacted area.

Redaction Code – check this option and select a code set from the existing sets and then choose a corresponding code entry.

General tab:

You can change the author and subject of the redaction.

Review History tab:

You can see the history of changes which have been made to the status of a redaction before applying the redaction.
Apply Redactions

You need to apply the redactions after marking the text or graphics you want to redact. To apply the redaction, do the following:

- Select **Protect > Redaction > Apply Redactions**. You can also do this by right-clicking the marked content and choosing **Apply** or **Apply All** to redact either the selected content or all of the marked content in the document.
- A dialog box pops up to give a warning message and asks if you are sure to apply the redaction or not.
- Select **OK** after you have marked all content that you want to redact.

When you save the document after applying redaction, you can save the redacted file automatically as a new file with the preconfigured filename. To configure the filename, please select **Adjust filename when saving applied redaction marks** and input text in the **Prefix** and **Suffix** boxes in **File > Preferences > Documents > Redaction**.

Search and Remove Text

You can find and remove content either in a single PDF file or in multiple PDF files under a specified folder that contain searchable text with the Search & Redact command.

- Select **Protect > Redaction > Search and Redact**. Then specify what you want to redact in the Search pane. Please do one of the following:
  - Type the text you wish to find and redact into the search dialogue box. For more about the search feature, please refer to “advanced search”.
  - Check the item **Patterns** and select a pattern. The patterns vary with different countries. Choose **Country** based on the file you are using.
- Click **Search and Redact**.
- Check the results you want to redact.
- Click the button **Mark Checked Results for Redaction** at the bottom of the search dialogue box.
- Choose **Protect > Redaction > Apply Redactions**. Or click the button **Apply Redactions**.

*Note: This operation cannot be undone and the selected content will be removed permanently when you select Apply. It is recommended that you save a backup copy of this document before you apply the redaction.*

Generate Redacted and RMS-protected PDFs (*Business Edition Only*)

Foxit PhantomPDF enables users to generate a redacted and RMS-protected PDF from an existing PDF. Authorized users are granted access to view the full document while unauthorized users are
only able to view the redacted document, which allows for improved knowledge sharing of non-sensitive information within a protected document.

To generate a redacted and RMS-protected PDF, please do the following:

- Mark the content for redaction. See also Mark for Redaction.
- Click Protect > Redaction > Protect Redactions, log on your RMS server and then choose an RMS template to encrypt the document.
- Then the document with redaction protected by the RMS template is generated and opened with a message box appearing in the document area. Click View the full content to view the full content without redaction. This message box appears only when the document is opened by the document owner.
- After clicking View the full content, two messages appear in the message box. Click Redacted Mode to exit the full content mode and return to the document with redaction. Click View Permission to view the security properties of the document.
- When the authorized users open this protected document, only the message to view permissions appears in the message box.

Windows Information Protection (WIP)

Windows Information Protection (WIP), a feature that enterprises use to protect enterprise data by encrypting it and separating it from personal (or employees’) data, provides a way to manage data policy enforcement for enterprise apps and documents. For enterprises that are using WIP policies can include Foxit PhantomPDF and network locations in their policy restriction on PDF documents, which helps to protect enterprise data against potential data leak on enterprise owned-devices and personal devices that employees bring to work.

Note: To run WIP in your system, Windows 10 (version rs2 and later) is required.

Add Foxit PhantomPDF to your WIP policies

Administrators in enterprises often use Microsoft Intune or MobileIron to define and deploy WIP policies. Here, we’ll use a Microsoft Intune example to explain how to add Foxit PhantomPDF to your WIP policies.

1. Sign in Microsoft Intune at https://admin.manage.microsoft.com in the Internet Explorer or Microsoft Edge.
2. Click POLICY > Overview > Add Policy to create a WIP policy. (Or, if you already have one, edit the policy to add PhantomPDF.)
3. In the pop-up Create a New Policy dialog box, choose Windows > Windows Information Protection (Windows 10 Desktop and Mobile and later), choose Create and Deploy a
4. Type a name and an optional description for your WIP policy.

5. In App Rules, click Add.

In the Add App Rule dialog box:

- **Title** – Types a name, e.g. Foxit PhantomPDF.
- **Windows Information Protection mode** – Chooses Allow to turn on WIP to protect Foxit PhantomPDF’s corporate data through the enforcement of WIP restrictions.
- **Rule template** – Chooses Desktop App from the drop-down list.
Publisher – You can run the PowerShell command: Get-AppLockerFileInformation -Path "<path of the exe>". For example, run Get-AppLockerFileInformation -Path "C:\Program Files (x86)\Foxit Software\Foxit PhantomPDF\FoxitPhantomPDF.exe" and get the following:

Then the publisher name in the Publisher box is:

**Product name** – Checks the box, and enter the product name.

**Binary name** – Checks the box, and enter the Binary name “FoxitPhantomPDF.exe”.

**Version** – Checks the box, and specify a version range.

6. Click OK. At this point, Foxit PhantomPDF has been successfully added to your WIP policies. Then follow the instructions to complete the WIP policy creation.

Add network locations to be protected by WIP

After you have added Foxit PhantomPDF to your WIP policies, you can define where PhantomPDF can access enterprise data on your network.

1. To add network locations where PhantomPDF can access, click Add. The Add corporate network definition dialog box appears.

2. Enter a name for your corporate network element in the Name box, and choose Enterprise Cloud Resources from the Network element drop-down list.

3. Choose one or multiple network locations to be protected with your WIP policies from the following URLs as needed. If you have multiple resources, separate them using the semicolon.

   *NdOffice*: www.netdocuments.com
4. Click **OK**.

**FIPS mode**

Foxit PhantomPDF provides a FIPS mode to make data protection compliant with Federal Information Processing Standard (FIPS). FIPS mode uses FIPS 140-2 approved algorithms to establish requirements for various purposes including the cryptographic modules of software and hardware.

The system administrator can configure FIPS mode in the Windows registry by the following steps (Take Foxit PhantomPDF 9.0 for example):

1. Open the Registry Editor and navigate to the registry: HKEY_CURRENT_USER\SOFTWARE\Foxit Software\Foxit PhantomPDF 9.0
2. Right-click Foxit PhantomPDF 9.0, and choose **New > DWORD (32-bit) Value**.
3. Name the new value “bFIPSMode” and set the value data to 1.

In FIPS mode, the following security options are not available:

- Applying password-based security policies to documents, RMS encryption and ConnectedPDF protection. You can use public key certificates to secure the document.
- Creating self-signed certificates. To create a self-signed digital ID, it must be saved to the Windows certificate store. You cannot create a self-signed digital ID that is saved to a file.
- RC4 encryption. A PDF file can only be encrypted using the AES encryption algorithm when in FIPS mode.
- MDS or RIPEMD160 digest methods. In FIPS mode, only the SHA-1 and SHA-2 families of digest algorithms can be used when you create a digital signature.
**Note:** In FIPS mode, you can open and view documents that are protected with algorithms that are not FIPS compliant. However, you can’t save any changes to the document protected with password, RMS and ConnectedPDF Protection.
Foxit ConnectedPDF allows each PDF to carry an identity assigned by the cPDF cloud service, and tracks all the events on the PDF like creation, distribution, and modification. So no matter where the ConnectedPDF document goes, how many distributions and modifications done to it, the document owner can always track the document in real time and collaborate with the document viewers involved. Therefore, ConnectedPDF connects files, people, location, and systems together while ordinary PDF is separate and static.

The **Connect** tab in Foxit PhantomPDF toolbar provides powerful and easy-to-use tools to create, protect, and track the access to Connected PDFs. You can also start and join a shared review on Connected PDFs without any server anytime anywhere. The detailed features include:

- Convert PDF to ConnectedPDF
- Convert other formats to cPDF when creating to PDF
- Configure open messages which appear when other users open a ConnectedPDF document (*Business* only)
- Clone a document (*Business* only)
- Enable document enforced tracking (*Business* only)
- Track any access to cPDF documents
- Show usage data in document homepage
- Register and upload a new version of cPDF document
- Send update notification when registering a new version (*Business* only)
- Online ConnectedPDF protection (*Business* only)
- Permission configuration
- Dynamically approve and revoke document permission
- Dynamically request document permission and response to the changes of document permission
- Connected shared review without having to set up a shared folder
- Document locator and request

For more information about ConnectedPDF, please refer to [ConnectedPDF User Manual](#).
Chapter 12 – Signature

Foxit PhantomPDF provides robust, secure and quick signature features, including digital signature, DocuSign and quick PDF Sign.

Digital Signature

A digital signature acts as a traditional handwritten signature that can be used to authenticate the identity of a user as well as the document content. It stores information about the signers along with the date, time, and state of the document when it was signed.

About Digital ID

Digital ID is the identity of a person/organization, which contains your name, Email address, a serial number, an expiration date, and the name of the company. A digital ID contains two keys, one is a public key (certificate) that is used to encrypt or lock data, and the other is a private key that is used to decrypt or unlock data that is encrypted.

You can distribute the certificate that contains the public key and other identifying information to those people who need to use it to verify your identity, validate your signature, or encrypt a document for you. Only your private key can unlock information that was encrypted using your certificate, so make sure to store your digital ID in a safe place.

You can not only obtain a digital ID from a trusted third-party provider called a Certificate Authority (CA) but also create a self-signed digital ID with Foxit PhantomPDF. Digital IDs are usually protected by password; you can store it on a computer in PKCS#12 file format, or in the Windows Certificate Store. All the digital IDs available on the computer are listed in the Digital IDs window. You can choose the Protect tab > Protect > Digital IDs to check the digital IDs list. In the Digital IDs window, you can also view the certificate details, refresh the ID list, add or remove a digital ID, and export a digital ID to an FDF, PKCS, or CER file.

For company-wide deployment, IT managers can also use the SignITMgr tool to configure which digital ID file is allowed to sign PDF files by users across an organization. Steps are as follow:

1. Create or install the digital ID file on your computer.
2. Click here to download SignITMgr tool, and open it.
3. You will find that the digital IDs you installed in your computer are listed in the SignITMgr window. In the window, do the following:
   - Check the digital ID file that is allowed to sign a PDF file, click Generate Configure File, and save the file.
   - If you want to change the setting which you have configured before, click Load Configure
File to open the configuration file. Then check the digital ID file that is allowed to sign a PDF file, and click Generate Configure File to generate and save the modified configuration file.

4. After generating the configuration file, place it in “C:\Users\USERNAME\AppData\Roaming\Foxit Software\Foxit PhantomPDF\Signature”.

When IT manager has configured it completely, users can only use the specified digital ID(s) to sign PDF files, and will not be allowed to create a new ID.

Tip: The “Signature” folder is automatically created the first time users sign a PDF file with a digital ID. If it is not found in the specified folder, please create it manually.

Sign a PDF

Place a signature

Before you sign a document, you need to draw a signature field where the signature is placed, get a digital ID, and create the signature.

1. Choose Protect > Protect > Sign & Certify > Place Signature.
2. Press and hold the mouse button down, and drag to draw a signature field for your signature.
3. In Sign Document dialog box, choose a digital ID from drop-down menu. If you can’t find the specified digital ID, you will need to get a certificate from the third-party provider or create a self-signed digital ID.
4. (Optional) To create a self-designed digital ID, choose New ID from drop-down menu. In the Add Digital ID dialog box, select a location to store the digital ID. Click Next to type your identity information such as name, organization unit, e-mail address, etc. to be used when generating the self-signed certificate. In Use Digital ID for, choose one option as needed. Click Next to enter a file name, storage location and password for your new digital ID file. Confirm your password and click Finish. The New ID option will not be available if the IT manager has configured and restricted digital IDs to sign PDF files across the company.
5. Choose an appearance type from menu. There are two types to choose, one is Standard Style, and the other is to Create New Style for your signature. Please refer to Creating signature appearance. You can view your signature in Signature Preview panel.
6. Click Sign. In the Save As window, input the password of the signature, specify the location and file name of the signed document.

Note: By default, the document is signed after you place the signature and then you will not be able to move or resize it. To change the setting, please uncheck the Sign the document immediately after the signature is placed option in File > Preferences > Signature.
Create signature appearance

You can set the appearance of your digital signature by selecting different options in Sign Document dialog box. For example, a signature can include an image of your handwritten signature, a company logo, or a photo, date and so on. Furthermore, you can create dynamic signature appearance to user for different purpose. A signature appearance also includes information that helps others verify your signature, such as reason for signing, contact information, and more.

Different appearances of signatures

• Choose Protect > Protect > Sign & Certify > Place Signature.
• Press and hold the mouse button down, and drag to draw a signature field for your signature.
• In Sign Document dialog box, choose Create New Style from Appearance Type menu.
• Check the options that you want to appear in digital signature. A signature appearance can include lots of information showing the users attributes, including name, organization, country, logo, location, etc. You can click Setting to specify the font and font size if necessary. Click OK to save the settings.
• (Optional) After placing the signature, right-click it and choose Properties... to set the properties of the signature field. In the Signature Properties dialog box, you can set the appearance, actions, etc. See also Signature Field Properties. (Note: This operation is not available after signing the document.)

Note: To manage the created styles, go to File > Preferences > Signature.

Move, resize and delete an unsigned signature

You can move, resize and delete signatures before signing the document, but you aren’t allowed to change certificate and appearance of certificate.

1. To move a signature

Select the Select Annotation command or the corresponding tool, put the pointer over the signature, click and drag the signature to another place you like.
2. To resize a signature

Select the Select Annotation command or the corresponding Tool, click the signature. Place the cursor on any corner point. Pointer changes into the cursor showing the direction at which the rectangle will be resized.

3. To delete a signature

- Select the Select Annotation command.
- Right-click the signature and choose Delete from context menu, or press Delete key.

*Note: If you have checked the Locked option in Signature Properties dialog box, the operations to the signature above are not available.*

**Sign Documents**

A PDF is signed to indicate your approval. The signature is flattened, so it cannot be resized and moved after signing the document. Multiple people can sign a PDF more than once. When you sign a document, your digital signature appears in the signature field. The appearance of the signature depends on your preferences.

1. Sign a PDF after placing, please choose one of the followings to sign the document:
   - Choose Protect > Protect > Sign Document.
   - Select the Hand command and right-click the signature, choose Sign Document.
   - Select the Hand command, and click the signature.
   - Set your signature preferences in Preferences dialog box. Choose File > Preferences > Signature, check the option of “Sign the document immediately after the signature is placed” to sign the document immediately when the signature is placed.

2. Type file name and specify location in pop-up Save As dialog box.

*Note: By default, the document is signed after you place the signature. To change the setting, please uncheck the Sign the document immediately after signature is placed option in File > Preferences > Signature.*

**Validate Signatures**

Signature validity is determined by checking the authenticity of the signature’s digital ID certificate status and document integrity. Depending on how you have configured your application, validation may occur automatically.

**Set Signature Verification Preference**
By default, Foxit PhantomPDF will verify signatures when the document is opened, and will check the certificate revocation status while verifying signatures. If you want to change the setting, please go to File > Preferences > Signature, and uncheck the corresponding option in Signing & Verifications group. For more information, please refer to “Signature Preference”.

Set the Trust Level of a Certificate

The signature of a certified or signed document is valid if you and the signer have a trust relationship. The trust level of the certificate indicates the actions for which you trust the signer.

To set the trust level:

- Choose File > Preferences > Signature.
- Check the option(s) in Windows Integration group to trust all root certificates in the Windows Certificate Store when validating signatures and certified documents.

Tip: You can specify the trust level for a specific certificate in Foxit PhantomPDF Trusted Certificates list while adding and managing the trusted certificate. Please refer to Add Trusted Certificates and Manage Trusted Certificates for more information. If you configure different settings for the same certificate, settings with higher permissions will prevail. Remember that checking trust options may compromise security. Please make sure that you trust all the root certificates before enabling the features.

Check the validity of a signature

By default, Foxit PhantomPDF verifies signatures when the document is opened. An icon appears on the left top of Signature Validation Status message box to indicate the signature status. The signature state appears in the Signature Panel.

- The question mark icon ? indicates the signature is not validated.
- The check mark icon ✔ indicates that the signature is valid.
- The icon ✗ indicates that the signature is invalid. The document has been altered or corrupted since the signature was applied.
- The caution triangle icon ✱ indicates the document was modified after signature was added; however, the signature is valid.
- The icon ✝ indicates the signature validity is unknown because the signer’s certificate isn’t in your list of trusted identities.

Check certificate revocation status
By default, Foxit PhantomPDF will check the certificate revocation status while validating a signature if the certificate used to sign a PDF file chains up to a certificate designated as a trusted anchor. Revocation checks are performed based on the revocation information embedded in the digitally signed PDF document, the digital signature, or the Certificate Revocation List (CRL). To view the certificate revocation information, please do the following:

1. Do one of the following:
   • Choose Protect > Protect group > Trusted Certificates, and double-click the certificate.
   • In the Digital Signatures panel, right-click the signature, choose Show Signature Properties, and then click Show Certificate.
2. In the Certificate Viewer dialog box, click Revocation tab to view the revocation information, and click Signer Details to get more information on the source of the revocation information.
3. (Optional) If you do not check Require certificate revocation checking to succeed whenever possible during signature verification option in Signature preferences, you can click Check Revocation in the Revocation tab to perform revocation check manually.

Validate a signature

1. Open the PDF containing the signature, do one of the followings:
   • Choose Protect > Protect > Validate.
   • Right-click the signature with the Hand command, choose Validate Signature from context menu.
   • Select the Hand command on the toolbar and click the signature.
   • Click the Digital Signatures panel, right-click the signature and choose Validate Signature.
2. Pop-up a Signature Validation Status message box which describes the validity of signature.

**Modify a signed signature**

To modify a signature after signing the document:

- Validate the signature first. And right-click the signature with the Hand command and choose **Clear Signature**. The signature will be cleared and only a blank signature field will be left.
- Click the blank signature field with the Hand command, and create a new signature. See also “Creating signature appearance”.

To delete a signed signature:

- Validate the signature first. And right-click the signature with the Hand command and choose **Clear Signature**. The signature will be cleared and only a blank signature field will be left.
- Choose the Select Annotation command or the corresponding tool, right-click the signature field and choose **Delete**.

**Certify a PDF (Business Edition Only)**

Only the author can certify his/her own PDF documents. The author can specify what changes can be made to the file after certifying. Whenever approved changes are made, the certificate remains valid. If a reader tries to make changes you haven’t allowed, the certificate is invalidated and any subsequent users will be notified that the document was tampered with.

To certify your PDF, please do the following:

1. Open your PDF document you want to certify.
2. Select **Protect > Protect > Sign & Certify > Certify with visible signature/Certify without visible signature**.
3. Press and hold mouse button down, drag to select an area on the document where you want the signature to appear.
4. In the pop-up Certify Document dialog box, choose a digital ID. If you don’t find the specified digital ID, you need to get a digital ID from a third-party provider or create a self-signed digital ID.
5. Set authorized actions for your document from the drop-down menu in **Permitted Actions After Certifying** item.
6. Set the signing reason and choose an appearance type from the menu.
7. Click **Sign**.
8. To set the properties of the signature, please refer to **Signature Field Properties**.
9. To sign the document, please see **Sign a PDF**.
10. To validate the signature, please refer to **Validate Signatures**.
Add a time stamp to digital signatures and documents

Time stamps are used to specify the date and time you signed a document. A trusted time stamp proves that the contents of your PDFs existed at a point-in-time and have not changed since then. Foxit PhantomPDF allows you to add a trusted time stamp to digital signatures or documents.

To add a time stamp to digital signatures

To add a time stamp to digital signatures, a default time stamp server is required before you make the digital signature. If you have configured a default time stamp server and added it to your trusted certificate list, the time stamp will be embedded with the signature, and the signature properties will show the date/time in the time stamp server when you signed the document; otherwise, the signature properties will display the local date/time of the computer.

1. Go to File > Preferences > Time Stamp Servers, and set a default time stamp server.
2. Sign the document. See also Sign a PDF.
3. You will be prompted with a pop-up Security Warning to ask you to allow connecting to your time stamp server. Click Allow.
4. Then the signature you made has been successfully embedded with a timestamp. When validating the signature, users need to add the time stamp server into the trusted certificate list so that the signature properties will display the date/time in the time stamp server when the document was signed. See also Trusted Certificates.

Note: By default, if only one time stamp server is available in the system, it will be set as default automatically.

To add a time stamp to documents

- Before adding a time stamp to documents, you need to configure a default time stamp server. Click Protect > Protect > Time Stamp Document and create a timestamp server by clicking New... in the pop-up dialog box. Specify the server name and complete other settings of the server on demand. Click OK.
- Select the created server and click Set Default to set the server as the default time stamp server. Click Next to continue.
  (Tip: You can also create, edit, and delete time stamp servers as well as enable/disable the default time server in File > Preferences > Time Stamp Servers. To disable the default time stamp server, select the default time stamp server and click Clear.)
- Specify a name and location for the signed document. Click Save.
Trusted Certificates

When you validate or view properties of a digital signature or an embedded timestamp, the validity status may display “unknown” or “could not be verified”. You need to add the certificate that issued your digital IDs as well as the time stamp server to the Trusted Certificates list.

To add a trusted digital certificate to the Trust Certificates list, please do the following:

- Right-click the digital signature, and choose Show Signature Properties.
- In the Signature Properties dialog box, click Show Certificate.
- In the Certificate Viewer dialog box, specify the trust level for the certificate in the Trust tab:
  - Use this certificate as a trusted root: Use the certificate as a trusted root, and trust all certificates issued by that certificate authority. Once you make a certificate a trust anchor, revocation checking will not be performed on it.
  - Validating Signatures or Validating Certified Documents: Trust the certificate when validating signatures or certified documents.
- Click Add to Trusted Certificates, and confirm your operation.

To add a trusted time stamp server to the Trusted Certificates list, please do the following:

- If a time stamp is added to a digital signature, click Timestamp Properties in the lower left corner of the Signature Properties dialog box. If a time stamp is added in the document, right-click the timestamp signature in Digital Signature pane, and choose Show Signature Properties.
- In the pop-up Timestamp Properties dialog box or Signature Properties dialog box, click Show Certificate.
- In the Certificate Viewer dialog box, specify the trust level for the certificate in the Trust tab:
  - Use this certificate as a trusted root: Use the certificate as a trusted root, and trust all certificates issued by that certificate authority. Once you make a certificate a trust anchor, revocation checking will not be performed on it.
  - Validating Signatures or Validating Certified Documents: Trust the certificate when validating signatures or certified documents.
- Click Add to Trusted Certificates, and confirm your operation.

To check all the trusted certificates, choose Protect tab > Protect > Trusted Certificates. In the Trust Certificates window, you can manage all the trusted certificates, including adding & exporting a certificate, viewing certificate details, deleting a certificate, and specifying the trust level for a certificate.

Signature Panels

The signature panel shows information about each signature and time stamp in the document as
well as the change history of the document since the first signature.

Open the signature panel

Click Signature button on the left of Navigation Pane.

**View Signature Properties**

Signature Properties dialog box provides basic information about the signature, including the signer, reason, date, location validity summary and details of certificate, etc.

1. Select the **Hand** command.

2. Right-click the signature field, or right-click the signature in the **Digital Signatures** panel and choose **Show Signature Properties** from context menu.

3. In Signature Properties dialog box, you can get the information as follows:

   - **Signed by** – shows the signers that sign the document.
   - **Reason** – displays the reason that you create the signature.
   - **Date** – shows the date time when you signed the document.
   - **Location** - shows which page the signature is located on.
   - **Validity Summary** - checks whether the document was modified after it was signed, and other information.
   - **Show Certificate** – click it to show the details of certificate, such as the validity of certificate, certificate path, etc.
   - **Add to Trusted Certificates** – Click it to add the digital certificate to the **Trusted Certificates** list.
   - **Timestamp Properties** – Click it to see the properties of the timestamp or add the time stamp to the **Trusted Certificates** list. (Only available for time stamp signatures or digital signatures embedded with a time stamp.)

**Note:** If the status is unknown, click **Show Certificate**... in the **Signature Properties** dialog box > **Show Certificate** in the **Certificate Viewer** dialog box to view the details of the certificate. Check whether the certificate has been included in your list of trusted identities. If your certificate is not trusted, click **Install Certificate** to install it to the trusted Windows Certificate Store. If you use a self-signed digital ID, confirm that the certificate details are valid. If the certificate isn’t valid, a valid certificate from signer is requested.

**Sign PDFs with DocuSign®**

Allows users to easily send, sign and save PDF documents and forms using the industry’s most
widely used eSignature solution.

Sign a PDF File

To sign a PDF with DocuSign, please refer to the following steps:

- Open the PDF document you want to sign. Click the Protect tab, and choose **DocuSign > Login to DocuSign**. Type your Email and password for DocuSign and click Login. If you do not have an account, please sign up first.
- After signing in, choose **DocuSign > Sign with DocuSign**. The application will upload your PDF to DocuSign and you will enter into the DocuSign user interface.
- Sign the Document

On the DocuSign user interface in the PhantomPDF window, you can do the following:

- Sign directly by adding desired fields (including Signature, Initial, Date Signed, and more) to the document. Choose a field and the cursor changes to preview the appearance of the field. Then click on the document to place the field, or click several times to place multiple fields. Click the **Close** button at the top right corner of a field to delete it. You can resize fields such as Signature, Initial, and Text by dragging the handles of the field box that appear when you click on the field. **(Note: You should visit the DocuSign website if you want to change the Signature and Initial appearances.)**
- By using the tools at the top of the window, you can change the zoom of the file, download the file, or print the PDF with signatures visible.
- Click **FINISH** and a message box pops up for you to send the signed document to others.
- (Optional) click **OTHER OPTIONS** to view history, view certificates, choose **FINISH LATER** to finish the signing process later, or choose **PRINT & SIGN** to print the document out so you can sign on paper.

- To log out of DocuSign, choose **DocuSign > Logout of DocuSign** in the Protect tab.
- To change the appearance of your signature:
  - Visit the DocuSign website (www.docusign.net).
  - Click **Edit** beside **MY DOCUSIGN ID** under the **Home** tab. (If you don’t have any signatures, click **Create Your Signature**.)
  - Then find the signature you want to change and click **Edit**.
  - In the **Create Your Signature** window, change the signature appearance as needed.
    - **CHOOSE**: select a style as your signature appearance.
    - **DRAW**: draw a signature appearance using your input device.
    - **UPLOAD**: you can upload an image as your signature appearance.
  - Click **CREATE** to complete the signature creation process.
Send a PDF via DocuSign

- Open a PDF with PhantomPDF.
- Click the Protect tab, and choose DocuSign > Send via DocuSign.
- Log in to DocuSign.
- Add the recipients, message, and other options as needed.
- Then Click Send to send the PDF.

Note: For more details about DocuSign, please contact DocuSign support.

Quick PDF Signature

Quick PDF Sign enables you to create your self-signed signatures and add the signature to the page directly. You don’t need to create different signatures for different roles.

See also the tutorial on Sign Documents with PDF Sign.

To create your own handwritten signature and sign a PDF, follow these steps.

1. Choose Protect > Protect > PDF Sign. The PDF SIGN tab appears on the toolbar.
2. Click + in the signature palette or click − on the lower right corner of the signature palette and choose Create Signature from the drop down menu.
3. In the Create Signature dialog box, you can draw a signature, import a file, copy from the clipboard, or type text content to create a signature. Or, click Online Signature to choose a signature from the online signatures you saved before.

TIP: You can sign your signature on a clean white sheet of paper using a black pen, and scan it to an image file. To create the best signature, it is suggested to scan your signature in monochrome at 600 DPI.

4. You can preview the signature in the Preview box.
5. Check the options as needed:
   Convert signature to black & white: the signature will be created in black and white even if the original image is chromatic.
   Discard the signature when program closes: the signature will not be listed in the signature palette next time you launch PhantomPDF.
   Require password to use this signature: Specify a password that will be required when users sign the document with the signature. Enter the password again to confirm it.
6. (Optional) Click Save Online to save the newly created signature to Foxit ConnectedPDF Web Services, which allows you to sign documents.
7. Click Save. The cursor will be changed into a shape with the appearance preview of the signature.
8. Place the cursor to the position you want to sign and click. Click the signature, and it will be
highlighted with a red rectangle. You can move the signature by dragging the rectangle to
other places. You can also resize it by clicking and dragging the handle in the lower right corner
of the rectangle. When you click the signature, a gray toolbar appears over the rectangle. Click
and to switch among different signatures if any; click the invert triangle to drop
down the context menu.

9. (Optional) Click Predefined Text > Set Predefined Text to define text that can be integrated in
the signature. Using the Typewriter command and the predefined text, you can quickly add
some static information (like the full names of the signature owner and the company) which
can be integrated in the signature. Flatten the document when applying the signature to
prevent the information from being edited. By default, the identity information has been
saved as predefined text.

10. Select Place on Multiple Pages from the context menu to place the signature to multiple
pages.

11. To apply the signature to the document, click the rectangle and the invert triangle or
right-click the signature, and select Apply Current Signature from the context menu. You can
apply all signatures in the document by clicking Apply All Signatures. A dialog box will pop up
when you click Apply All Signatures for the first time to prompt you that applying all
signatures will flatten the whole document. You can change the settings by clicking Change
Setting in the dialog box, or clicking the invert triangle in the signature palette and
choosing Setting, or directly navigating to File > Preferences > PDF Sign.

12. Click the Close button to exit the PDF SIGN tab.

Note: Once applied, the signature can no longer be edited or deleted.

To manage the created signatures, do the following:

In the PDF SIGN tab, click on the lower right corner of the signature palette and choose
Manage Signature from the drop down menu. In the Manage Signature dialog box, you can create,
move and delete the created signatures, and set password for them.
Chapter 13 – Accessibility

Foxit PhantomPDF provides accessibility features to give users with disabilities (such as visually impaired people) greater access to information and technology. With commands in the Accessibility tab in the ribbon and the panels related to accessibility in the navigation pane, you can check the accessibility of PDFs, fix accessibility issues, edit document structure, and set accessibility preferences to make PDFs and the setup more accessible.

Accessibility Check and Fixes

A document is accessible if it can be used by people with disabilities, such as visually impaired people. Foxit PhantomPDF allows users to evaluate the accessibility of your documents and identify areas that may be in conflict with Foxit’s interpretations of referenced guidelines, create accessibility report, view the Full Check results, and fix accessibility problems.

Check Accessibility with Full Check

Use the Full Check command to check whether a PDF is compliant with accessibility standards of Web Content Accessibility Guidelines (WCAG) 2.0. You can choose which kinds of accessibility items to check for and how to view the results.

To check accessibility with the Full Check command, please do as below:

1. Choose Accessibility > Accessibility Checker > Full Check.
2. In the Accessibility Checker Options dialog box, select options you need to check for. See also the Accessibility Issues.
3. In Report Options section, check Create Accessibility Report option if needed to save the results as an HTML file and specify the save path. You can also check Attach report to document to add the accessibility report as an attachment of the PDF document.
4. Show this dialog when the Checker starts: If this option is checked, the Accessibility Checker Options dialog box will pop up whenever you run the Full Check. Otherwise, the dialog box won’t appear. If the dialog is hidden, go to File > Preferences > Accessibility and change the setting to show the dialog.
5. Click Options button and specify the page range to do a full check.
6. Click Start Checking.

View Full Check Results and Accessibility Report

When the check is completed, the Accessibility Check panel automatically expands in the
navigation pane to display the check results.

You can click Accessibility > Accessibility Checker > Accessibility Report, or directly click the Accessibility Report panel in the navigation pane to open the Accessibility Report. You can also open the accessibility report file (if any) in a web browser.

Note: Because some content types are difficult to be distinguished clearly by the checker, some issues reported may not affect readability. It would be better to review all issues to definitely decide which ones are not accessible.

The report includes the name of the PDF document, Summary of the result, and Detailed Report for each checking option.

Summary lists one of the following statuses for each item check:

- **Needs manual check** – The Full Check feature couldn’t check the item automatically. Please verify the item manually.
- **Passed manually** – The item status was changed to Passed Manually by users from Needs manual check.
- **Failed manually** – The item status was changed to Failed Manually by users from Needs manual check.
- **Skipped** – Users chose Skip Rule when verifying the items manually. Or the item was skipped because the corresponding option was not selected in Accessibility Checker Options dialog box when users ran the Full Check.
- **Passed** – The item passed the Full Check.
- **Failed** – The items didn’t pass the Full Check.

Detailed Report clearly lists the rule name, status, and description for each checking option. You can click the links in the report to view the online Help on fixing issues.

**Fix Accessibility Problems**

In the Accessibility Check panel where the Full Check results are listed, right-click an item and choose one of the following options from the context menu:

- **Fix**: fixes the issue automatically, or prompts a dialog box where you need to fix it manually. *(Business Edition only)*
- **Skip Rule**: changes the item status to Skipped.
- **Explain**: opens the online Help on the accessibility issue.
- **Check Again**: checks all the items again.
**Show Report**: opens the **Accessibility Report** panel in the navigation pane.

**Options**: opens the **Accessibility Checker Options** dialog box for you to select options.

**Pass**: changes the item status to **Passed Manually** if you believe the item meets the accessibility standard.

**Fail**: changes the item status to **Failed Manually** if you believe the item doesn’t meet the accessibility standard.

### Accessibility Issues

After the accessibility check based on the options you specified in the **Accessibility Checker Options** dialog box with the **Full Check** command, you can view the check results in the **Accessibility Check** panel and the detailed report in the **Accessibility Report** panel. The following part on accessibility issues provides explanations and instructions to help you better understand each accessibility rule and easily make a decision on how to deal with the accessibility problems in your document.

**Document**

**Accessibility permission flag**

Some documents may be protected by the document authors and no content can be copied, printed, extracted, annotated, or edited. This permission setting could interfere with a screen reader’s ability to read the documents because screen readers need to copy or extract the documents’ text to convert it to speech.

The flag reports whether the setting is turned off to allow accessibility. If your document failed to pass the rule, to fix the issue automatically, right-click the rule in the **Accessibility Check** panel in the navigation pane and choose **Fix** from the context menu in PhantomPDF **Business**. You can also fix the issue manually by choosing **No Protection** in **File > Properties > Security** to turn off the permission setting.

**Image-only PDF**

The rule check reports whether the document is an image-only PDF with non-text content that is not accessible. To fix the issue automatically, right-click the rule in the **Accessibility Check** panel in the navigation pane and choose **Fix** from the context menu in PhantomPDF **Business**. Or, you can use the OCR tools under the **Convert** tab in the ribbon to recognize text in images to fix the rule check manually.

**Tagged PDF**
This rule check reports whether the document is a PDF with tags to specify the reading order, which is important for an accessible PDF. If the check failed, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. Or, you can tag the PDF manually by doing any of the following:

- Re-create the PDF from a file that has been tagged in the authoring application.
- Use the Autotag Document/Form Field commands under the Accessibility tab in PhantomPDF Business.
- Use the Reading Order command under the Accessibility tab in PhantomPDF Business to create the tags tree for the document manually.
- Directly create the tags tree manually in the Tags panel in the navigation pane in PhantomPDF Business.

Logical Reading Order

Check the rule manually to make sure that the reading order in the Tags panel is in accordance with the logical reading order.

Primary language

Some screen readers read the text in the language specified for the document. This rule checks whether the primary text language for the document is specified. If no language was set, only Business Edition allows you to fix this issue. You can set the language by right-clicking the rule in the Accessibility Check panel in the navigation pane and choosing Fix from the context menu, then choose a language in the Set Reading Language dialog box. You can also set the language manually by doing either of the following:

- Set the language for text in a subtree of the tags tree in the Tags panel. Right-click an element, choose Properties..., and select a language in the Object Properties dialog box.
- Set the language for a block of text in the Content panel. Right-click the text element or container element, choose Properties..., and select a language in the Object Properties dialog box.

Title

This rule is to check whether the document contains a title in its document properties. If the check failed, right-click the rule in the Accessibility Check panel in the navigation pane, choose Fix from the context menu in PhantomPDF Business, uncheck Leave as is and enter the document title in the Description dialog box. Or, add the title manually in the Title box in File > Properties > Description, and then select Display document title in Window Options in File > Properties > Initial View.

Bookmarks

If the document contains 21 or more pages, but doesn’t have bookmarks that correspond to the
document structure, this rule check will fail. To add bookmarks to the tagged document, right-click the rule in the Accessibility Check panel in the navigation pane, choose Fix from the context menu in PhantomPDF Business, and select the elements you want to use as bookmarks in the Structure Elements dialog box.

Color contrast

The check may fail if the document contains content that isn’t accessible to people who are color-blind. To fix the issue, ensure that the document’s content conforms to the guidelines in WCAG section 1.4.3, or select Replace document colors and set high-contrast colors to the PDF viewer in File > Preferences > Accessibility.

Page Content

Tagged content

The rule check reports whether all content in the document is tagged or marked as an artifact.

Artifacts are graphics objects that are typically not part of the author’s original content but rather are generated by the PDF producer application in the course of pagination, layout, or other strictly mechanical processes. Artifacts are not read by a screen reader. Page numbers, headers, and footers are often tagged as artifacts.

To fix the issue, do any of the following in PhantomPDF Business:

• Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Content panel in the navigation pane.
• Tag the content using the Reading Order command in the Accessibility tab.
• Assign tags for text contents by selecting the text contents with the Select Text and Image command, and then right-clicking the element in the Tags tree and choosing Create Tag from Selection in the Tags Panel.

Tagged annotations

The check reports whether all annotations in the document are tagged or marked as an artifact. To fix the issue, do either of the following in PhantomPDF Business:

• Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Content panel in the navigation pane.
• Tag the content using the Reading Order command in the Accessibility tab.

Tip: You can enable Tag Annotations in the Tags panel by right-clicking any tag so that all new annotations will be tagged automatically as they are created.
Tab order

The check reports whether the tab order parallels the document structure. To fix the issue automatically, right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu in PhantomPDF Business. You can also click the Pages panel in the navigation pane, right-click the pages that failed in the rule check, choose Properties... and select Use Document Structure in the Tab Order tab to set the tab order manually.

Character encoding

A correct character encoding is required to display readable text in software/hardware. To fix the issue, you need to check whether the necessary fonts have been installed on your system or re-create the PDF from a file that uses a proper font (preferably OpenType).

Tagged multimedia

Checks whether all multimedia objects in the document are tagged or marked as an artifact. To fix the issue, do one of the following in PhantomPDF Business:

- Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Contents panel in the navigation pane.
- Tag the content using the Reading Order command in the Accessibility tab.

Screen flicker

Document content, like animations and scripts that can make the screen flicker, is not accessible for people who have photosensitive epilepsy and can be difficult to see when the screen is magnified. To fix the issue, you need to remove or modify the content that can make the screen flicker.

Scripts

If the document contains scripts, the scripting shouldn't interfere with keyboard navigation or prevent the use of any input device. To fix the issue, you need to remove or modify the script or content that doesn’t meet the accessibility rule.

Timed responses

If the document contains forms with JavaScript that requires timed response, the check fails. To fix the issue, edit the scripts to give users enough time to read and use the content, or remove the scripts.

Navigation links

The check reports whether the URLs in the document are active links that are correctly tagged. To
fix the issue, check navigation links manually and make sure that the content doesn’t have too many identical links. If some items appear multiple times, provide a way for users to skip over them. For example, if the same links appear on each page of the document, you can also include a “Skip navigation” link.

Forms

Tagged form fields

The rule check reports whether all form fields in the document are tagged. If the rule check passes, you can also use the Tooltip in a form field’s properties to provide users with more information.

If it fails, do either of the following to fix the issue in PhantomPDF Business.

- Tag form fields with the Autotag Form Field command in the Accessibility tab.
- Right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu.

Field descriptions

The check reports whether all form fields have a text description in the document. All form fields need a text description for an accessible PDF. You can add a text description (tooltip) to a form field in its properties by doing any of the following:

- Right-click the form field and choose Properties... to add the tooltip for the form field.
- You can also click Form > Edit > Add Tooltip to add tooltips automatically for all form fields which does not have descriptions.
- Right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu. (Business Edition only)

Alternate Text

Figures alternate text

For accessibility, images in the document either have alternate text, or are marked as artifacts. If the rule check fails, do any of the following in PhantomPDF Business:

- Right-click the rule in the Accessibility Check panel in the navigation pane and choose Fix from the context menu. Add alternate text in the Set Alternate Text dialog box.
- Open the Tags panel and right-click the image that you want to add alternate text, choose Properties..., and add alternate text in the Object Properties dialog box.
- Click Accessibility > Reading Order to enable Touch Up Reading Order setting mode. Then right-click the image that you want to add alternate text, choose Edit Alternative Text, and add alternate text in the Alternate Text dialog box.
Mark the content as an artifact by right-clicking it and choosing Create Artifact in the Contents panel in the navigation pane.

Nested alternate text

The check fails if the document contains nested alternate text that screen readers don’t read. To fix the issue, right-click the nested element in the Tags panel in PhantomPDF Business, choose Properties..., and remove the alternate text in the Object Properties dialog box.

Associated with content

Alternate text is always associated with the corresponding content on the page. If not, there’s no way to determine which page the alternate text is on. If the Screen Reader Options in Preferences > Reading is not set to read the entire document, screen readers don’t read the alternate text. To fix the issue, remove the alternate text from any nested item that has no page content by right-clicking the nested elements in the Tags panel in PhantomPDF Business and choosing Properties....

Hides annotation

The rule checks whether there is any annotation in the document is hidden by alternate text. For an annotation that is nested under a parent element with alternate text, screen readers don’t see it. To fix the issue, right-click the nested element in the Tags panel in PhantomPDF Business, choose Properties..., and remove the alternate text from the Object Properties dialog box.

Other elements alternate text

The content except figures like multimedia, annotations, and 3D models, also requires alternate text for accessibility. And make sure alternate text is always associated with the corresponding content on the page. See also Associated with content.

Tables

For the table structure, which can be complex, PhantomPDF recommends that users check them for accessibility manually.

Rows

If the check fails, open the Tags panel, and make sure that each Table Row in a table is a child of Table, THead, TBody, or TFoot in PhantomPDF Business.

TH and TD

For accessibility, Table Header <TH> and Table Data <TD> are children of Table Row <TR>. If the check fails, verify it in the Tags panel in PhantomPDF Business.
Headers

For accessibility, all tables must have a header. If the check fails, verify it in the **Tags** panel in PhantomPDF Business.

Regularity

Tables must contain the same number of columns in each row, and rows in each column. If the check fails, verify it in the **Tags** panel in PhantomPDF Business.

Summary

A table summary is not a must, but it can make the document more accessible. The document author can add or edit the table summary with Foxit PhantomPDF Business.

- Choose **Accessibility > Setup > Reading Order**.
- Right-click on the table, and select **Edit Table Summary**.
- In the popup **Table Summary** dialog box, input a summary, and click **OK**.

Lists

List items

The rule check reports whether the list structure in the document is correct. Lists must have the following structure: A list element must contain list item elements; a list item element may have a label element (optional) and a list item body element (required). To fix the issue, do the following steps:

- Right-click the failed element in **List items** in the **Accessibility Check** panel and choose **Show in Tags Panel** from the context menu.
- Create elements, change the types of elements, or reorganize the existing elements by dragging them to the proper position.

Lbl and LBody

See also **List items**.

Headings

Appropriate nesting

The check reports whether headings are nested properly. If the check fails, do the following steps:

- Right-click the failed element in **Headings** in the **Accessibility Check** panel and choose **Show in Tags Panel** from the context menu.
in Tags Panel from the context menu.

- Create elements, change the types of elements, or reorganize the existing elements by dragging them to the proper position.

## Accessible reading and navigation through accessibility preference setting and shortcut keys

Foxit PhantomPDF allows you to set accessibility preferences that control the document colors, document display and reading order, and provides keyboard shortcuts, which are good for visually impaired and motion-impaired users to better read and navigate PDFs with or without assistive software/hardware.

### Set accessibility preferences with Setup Assistant

1. Click **Accessibility > Setup > Setup Assistant**.
2. In the **Accessibility Setup Assistant** dialog box, choose options that you need or are suitable for your assistive software/hardware.
3. If you click **Cancel** in any step, all the options you have chosen will be discarded and the original setting will be used.

   **Tip:** You can set more accessibility preferences from **File > Preferences > Accessibility**.

### Change reading options for the current document

While using a screen reader to read PDFs, users can change the reading settings for the current document like reading order and mode.

1. Click **Accessibility > Setup > Reading Option**.
2. Choose the desired reading options and click **Start**.

   **Note:** The preferences set here are only valid for the current document, whereas the settings with **Setup Assistant** are the default for all documents and remain in effect until you change them with **Setup Assistant**.

### Read PDF in reflow view

The reflow view allows users to read documents on a mobile device or even a screen magnifier without scrolling horizontally to read text by presenting pages as a single column that is the width of the document pane.
To read PDF in reflow view, choose **Home > View > Reflow**, or choose **View > Document Views > Reflow**.

To return to non-reflowed view, click again on the **Reflow** button.

**Note:**

1. *Text in comments and form fields does not reflow and vertical text reflows horizontally.*
2. *The reflow view only provides a view mode, without making any changes to the document.*

**Read and Interact with PDF with Screen Reader**

Foxit PhantomPDF enables visually impaired users to read and interact with PDF using NVDA (NonVisual Desktop Access) and JAWS (Job Access with Speech). While reading and interacting with PDF, you can use the **Setup Assistant** command in the **Accessibility** tab to improve how Foxit PhantomPDF interact with your screen reader, or change your reading settings for the current document by choosing **Accessibility > Setup > Reading Option** in Foxit PhantomPDF Business.

**Shortcut keys**

PhantomPDF provides users with **single-key accelerators for accessibility** to navigate PDF.

**Create accessible PDFs (Business only)**

Accessible PDF documents have content and elements including searchable text, alternate text descriptions for images/interactive form fields, reading order, and document tags, to enable people with disabilities to work on them with or without screen readers or other assistive software/hardware. Foxit PhantomPDF provides commands to help make your PDF accessible by tagging PDFs and form fields, setting alternate text, and editing tags. You can also use the **Action Wizard** in Foxit PhantomPDF Business to create accessible PDFs in batch.

**Tag PDF documents and form fields**

In PDF files, tags indicate the structure of documents and define the logic that binds the content together including the correct reading order, and the presence and meaning of figures, which can work better with the assistive technology like screen readers. To check whether a PDF is tagged, navigate to **File > Properties > Description > Tagged PDF**.

It is recommended that you tag a document when converting it to PDF from an authoring application, but if you do not have access to an authoring application that can generate a tagged PDF, you can tag a PDF any time with PhantomPDF Business.
To tag a PDF, open the document and click the **Autotag Document** command in the **Accessibility** tab. Then the tags of the document are created and you can view the tags in the **Tags** panel in the navigation pane. If the document already has tags, you’ll be prompted whether to re-tag the document.

To tag form fields in PDF, please click the **Autotag Form Field** command in the **Accessibility** tab.

After the tagging completes, a tag recognition report is generated in the **Recognition Report** panel in the navigation pane. You can use the report as a guide to repair tagging problems.

**Set alternate text for figures**

Alternative text for figures will be displayed when you hover your mouse over the figure to help you understand the figures better.

To set alternative text for all the figures in your PDF one by one with the **Set Alternate Text** command:

1. Click the **Set Alternate Text** command in the **Accessibility** tab.
2. A dialog box pops up to tell you PhantomPDF will detect all figures in the document and display associated alternate text.
3. Click **OK** and type descriptive alternate text for the figure in the **Set Alternate Text** dialog box. If the figure is used only for decorative purposes, check **Decorative figure**.
4. Click the arrows at the top of the **Set Alternate Text** dialog box to set alternate text for the next figure or previous figure.
5. After completing setting for all figures, click **Save & Close**.

To set alternative text for a specific figure in your PDF:

1. Click **Accessibility > Setup > Reading Order** to enable Touch Up Reading Order setting mode.
2. Right-click the figure that you want to set alternate text on the document pane, and choose **Edit Alternate Text**.
3. In the pop up **Alternate Text** dialog box, input the information, and click **OK**.

**Check reading order and edit tags with the Reading Order command**

Reading order and document structure tags are two important characteristics of accessible PDFs. The **Reading Order** command helps you easily check the reading order and edit tags for PDFs. However, the command is used to fix basic tagging problems for PDFs that were tagged with Foxit PhantomPDF, not for PDFs that were tagged during conversion from an authoring application. If possible, try to return to the source file and add accessibility features in the authoring application.
Check the reading order for a tagged PDF

1. Open a tagged PDF document and click Accessibility > Setup > Reading Order, or right-click any tag in the Tags panel and choose Reading Order.
2. The Touch Up Reading Order dialog box pops up, with options including different tag types and the way to show page content groups.
3. In the document area, you can see the page content displays in separate regions highlighted with gray blocks.
4. If you choose Page content order under the Show page content groups option, the regions are ordered with numbers. Choose Structure types, then the regions are labeled by structure tag types, like “P” for paragraph, “H2” for Heading 2, or “Figure”.
5. If the numbered regions don’t follow one another, click Show Order Panel in the Touch Up Reading Order dialog box, and reorder them in the Order panel.

Edit tags with the Reading Order command

You can tag a selected region, change the tag type for a region, as well as remove some useless page elements, with the Reading Order command. Since editing tags with the Reading Order command doesn’t create the same level of details to the tagging structure as the tools in the Autotag group, you can use this manual tagging if you don’t have any better method to edit the tags.

Note: Editing tags with the Reading Order command can’t be undone, so it is recommended that you save a backup copy of this document before you edit tags.

Tag a region

1. Click Accessibility > Setup > Reading Order to open the Touch Up Reading Order dialog box.
2. Drag to select a region of the page content in the document area.
3. Choose the desired tag type in the Touch Up Reading Order dialog box to tag the selected region.
4. Options in the Touch Up Reading Order dialog box:
   - Text – Chooses it to tag the selected region as text.
   - Figure – Tags the selected region as a figure.
   - Form Field - Tags the selected region as a form field.
   - Figure/Caption – Tags a selected figure and caption as a single tag. Then all the text content in the tag is the caption, which is useful to tag photos and captions, preventing caption text from being incorrectly added to the text around. For the figures, alternate text may be required.
   - Heading 1/ Heading 2/ Heading 3/ Heading 4/ Heading 5/ Heading 6 – Tags the selected region as a first/second/third/fourth/fifth/sixth level heading.
   - Table – Tags the selected region as a table.
   - Cell – Tags the selected region as a table or header cell. The option is often used to merge cells that are incorrectly split.
Formula – Tags the selected region as a formula. You may need to set alternate text for formula tags for speech software to easily handle them.

Background – Tags the selected region as a background element. A background element neither appears in the tags tree nor in the reflowed document, and screen readers don’t read it.

Table Editor: Enables table editing mode to edit table cell properties. You can use this command on a table which has been tagged as a table before.

Show Page Content Groups – Checks the option to show the page content by the page content order or the structure types. If you choose Page content order under the Show page content groups option, the regions are ordered with a number. Choose Structure types, then the regions are labeled by structure tag types, like “P” for paragraph, “H2” for Heading 2, or “Figure”. You can click the color swatch to change the highlight color.

Show table cells – Checks the option to highlight the content of individual table cells. You can click the color swatch to change the highlight color.

Display like element in single box – Checks it to display adjacent squares with the same tag type in a single square with the common tag type.

Show tables and figures – Checks the option to outline each table and figure with a crossed-out box. The crossed-out box will also indicate whether the table or figure includes alternate text. You can click the color swatch to change the box color.

Clear Page Structure – Clicks it to remove the tagging structure from the page.

Show Order Panel – Clicks it to open the Order panel in the navigation pane.

5. Click Close.

Change the tag for a region

1. Click Accessibility > Setup > Reading Order, the Touch Up Reading Order dialog box pops up.
2. Draw a rectangle in the page content or click the number of a highlighted region, and choose a tag type from the Touch Up Reading Order dialog box that you want to change to.
3. (Optional) Click Show Order Panel in the Touch Up Reading Order dialog box to open the Order panel in the navigation pane. See also The Order panel.
4. Click Close.

Tips: You can also press F2 to quickly modify tag types.

Remove page elements from the tag structure

Some page elements that don’t contain useful or illustrative information and shouldn’t be read, like decorative lines, artifacts, or background elements, can make the structure layout untidy and cause some chaos when they are reflowed or read by screen readers. You can remove these page elements from the tagging structure by changing them to the Background tags.

1. Select Reading Order in the Accessibility tab.
2. Select the page element in document pane, and choose Background in the Touch Up Reading Order dialog box to tag the selected page element as Background.
Check and correct figure tags

Figures tags should identify image content that is meaningful to the document. Sometimes background elements that are not necessary to be read are incorrectly tagged as figures, and you need to redefine them as background. You can use the Reading Order command to check and correct tagging problems for figures.

Select Reading Order in the Accessibility tab, make sure that you have checked the Show tables and figures option, and then do one of the following:

- If a figure isn’t tagged as a figure, drag to select the content and choose Figure or Figure/Caption in the Touch Up Reading Order dialog box.
- If text is incorrectly combined with a figure, drag to select the content and choose Text in the Touch Up Reading Order dialog box.
- If a figure and a caption are separated, drag to select the content and choose Figure/Caption in the Touch Up Reading Order dialog box.

Check and correct table tags

Tables can be a challenge for screen reader or other assistive technology since they may contain complex lists, form fields or paragraphs. You can use the Reading Order command to check if a table has been properly recognized and to correct recognition problems. Also, the Table Editor tool can help you edit table cell properties to make it more accessible.

Select Reading Order in the Accessibility tab, make sure that you have checked the Show tables and figures option, and do the following:

- If a table isn’t tagged as a table, drag to select the content and choose Table in the Touch Up Reading Order dialog box.
- Make sure that the Show table cells option is checked so that all cells in the table are defined as individual elements. Click Table Editor in the Touch Up Reading Order dialog box, or right-click the table on the document pane and select Table Editor. Alternatively, if you have opened the Tags panel, you can also access the Table Editor tool by right-clicking a table tag and choosing Table Editor from the context menu. All the table cells will be highlighted in the color set in the Table Editor Options.
- If you want to change the highlight color and display option for table cells, right-click the table cell on the document pane and choose Table Editor Options.
- (Optional) Right-click the table cell on the document pane and choose Auto Generate Header Cell IDs to generate cell IDs for all the header cells automatically. If you haven’t generated header cell IDs automatically, when you try to associate any header ID to any cell, Foxit PhantomPDF will prompt you to generate IDs for header cells if any header cells don’t have an ID.
- Right-click the table cell on the document pane and choose Table Cell Properties to edit the type and attributes of the table cells. You can use Shift-Click to select multiple cells and bulk
edit the table cell properties.

Remove tagging structure from the pages

If the existing structure for a PDF contains too many problems, you can clear it to create a new one.

To clear tagging structure from the page, please do one of the following:

- Click the icon in the navigation pane to open the Order panel. In the Order panel, right-click on the root element and select Clear page structure to clear the tagging structure of all pages. Or right-click on the page element and select Clear page structure to clear the tagging structure of the currently selected page.
- Select Reading Order in the Accessibility tab, click Clear Page Structure in the Touch Up Reading Order dialog box, or right-click on the document pane and choose Clear page structure from the context menu to clear the tag structure from currently visible page.

The Order panel

Click the icon in the navigation pane to open the Order panel where you can view the reading order and retag content by right-clicking the content and choosing desired command in the context menu. For details, please refer to the Reading Order command.

When you click a page in the Order panel, you will be switched to the corresponding page in the document view. In the Order panel, you can also change the reading order of a tagged PDF file without changing the actual appearance of the PDF file if the permission allows. To change the reading order, please do any of the following:

- Select the tag for a highlighted region that you want to move and drag it to the desired location. The Line icon  Shows the place where the tag will be located as you drag the tag.
- Right-click the tag for a highlighted region that you want to move and choose Cut from the context menu. Then right-click a destination tag after which you want to move to and choose Paste.

After you drag a tag to a new location, the highlighted regions will be renumbered to show the new reading order.

**Tips:** In the Order panel, you can use Ctrl-Click to select multiple tags as you click, or Shift-Click to select a listed group of tags between the first and the last tag you click. Then you can move them or right-click them to do more actions.
Edit document structure with the Content and Tags panels

For the content reflow and tagging problems that cannot be fixed by the Reading Order command, the Content and Tags panels provide you with more options to handle them.

Check and correct reflow problems with the Content panel

In the Content panel in the navigation pane, you can view pages and objects, and correct reflow problems in a PDF. The panel provides a hierarchical view of objects including pages, annotations (like comments, form fields, and links), and containers. In the panel, objects are listed in the order in which they appear on the page.

In the Content panel, you can perform actions as below:

- You can move a container or object by selecting it and drag it to the desired location.
- Right-click a page or an object and choose an option from the context menu.

  New Container – Creates a new container object at the end of the selected page or container.

  Find – Searches the page or document for artifacts, OCR suspects, unmarked comments/links/annotations/content, and add tags to found items.

  Create Artifact – Sets the selected object as artifact. Page numbers, headers, and footers are often best tagged as artifacts, which are not read by screen readers or the Read Out Loud feature.

  Show in Tags Panel – Switches to the Tags panel with the tag corresponding to the current content selected.

  Highlight Content – Checks the option, and the content in the document corresponding to the selected content in the Content panel will be highlighted with a box around.

  Properties – Opens the Object Properties dialog box.

View tags in the Tags panel

You can view a logical structure tree of tags in the Tags panel that represent the organizational structure of the document and define the reading order. The tags tree shows the document content as page elements (such as headings, paragraphs, and tables) nested at various levels. Assistive software determines how to present and interpret the document content according to the tags tree.

To view tags in the Tags panel, click the Tags panel in the navigation pane. While viewing tags in
the Tags panel, you can click 📌 to expand top-level tags, or click ⏐ to collapse the expanded top-level tags, if necessary.

**Edit tags with the Tags panel**

You can move a tag, and edit the properties (such as title and type) of a tag in the Tags panel. By right-clicking a tag, you can choose the following options:

- **New Tag...** – Creates a new tag after the selected item in the tags tree. Then specify the type and title of the new tag.
- **Cut** – Cuts and copies the selected tag.
- **Paste** – Pastes the copied tag below the selected tag at the same level.
- **Paste Child** – Pastes the copied tag as the child tag of the selected tag.
- **Delete Tag** – Removes the tag from the tags tree. If you remove the root (topmost) tag, all tags in the document will be removed.
- **Delete Empty Tags** – Deletes all empty tags from the subtree of a selected tag, except for valid empty tags such as TD, TH, and Link - OBJR.
- **Table Editor** – Enables table editing mode to edit table cell properties. This option is available when you right-click on a table tag.
- **Find Tag from Selection** – Finds the tag in the Tags panel that corresponds to the selected text content in the document pane.
- **Create Tag from Selection** – Creates a tag in the logical structure tree for a selected text content in the document pane.
- **Find** – Searches the page or document for artifacts, OCR suspects, unmarked comments/links/content, and add tags to found items.
- **Copy contents to clipboard** – Copies the contents of the selected tags to clipboard.
- **Tag Annotations** – Checks this option, and all new comments and form fields will be automatically added to the tags tree after the selected tag. The option is not available for the existing comments and form fields.
- **Document is Tagged PDF** – Flags the PDF as a tagged document. If unchecked, the flag will be removed.
Highlight Content – Checks this option, and the content in the document corresponding to the selected tag in the Tags panel will be highlighted with a box around.

Properties... - Opens the Object Properties dialog box.

Move a tag

To move a tag in the Tags panel, do either of the following:

- Select the tag that you want to move and drag it to the desired location. The Line icon shows the place where the tag will be located as you drag the tag.
- Right-click the tag you want to move and choose Cut from the context menu. Then right-click a tag that you want to paste and choose Paste or Paste Child.

Edit the tag properties

To edit the tag properties, do the following steps:

1. Right-click the tag you want to edit and choose Properties....
2. In the Object Properties dialog box, change the information as needed.

Tips: In the Tags panel, you can use Ctrl-Click to select multiple tags as you click, or Shift-Click to select a listed group of tags between the first and the last tag you click. Then you can move them or right-click them to do more actions.

Find and tag unmarked elements

If a PDF document contains untagged or unmarked elements, you can locate them in the logical structure tree and tag them by using the Find command. Steps are as follow:

1. Click the icon or on the navigation pane to open the Content panel or Tags panel.
2. Right-click on an element in the panel, and choose Find from the context menu.
3. In the Find Element dialog box, do the following:
   - Choose the element you want to find in the Find drop-down list.
   - Select where you want to search the element: page or document.
   - Click Find Next to search for the unmarked elements.
   - Click Tag Element to tag the unmarked element. And then click Close upon completion.

Add alternate text to tags for links, figures, and abbreviations

For accessibility, you need to add alternate text and other supplementary information (like specific language) to tags for links, figures, and abbreviations in the document. You can add the information to a tag in the Tags panel.
1. Right-click the <Link> tag, <Figure> tag, or the abbreviated term in the tags tree in the Tags panel, and choose Properties....

2. In the Object Properties dialog box, click the Tag tab.

3. Type text in the Alternate Text box. You can also edit other information as needed in the dialog box.

4. Click Close.

Tip: For figures, you can also set alternative text by using the Edit Alternative Text tool while in Touch Up Reading Order setting mode. Please refer to “Set Alternate text for figures” for details.

Check and correct table elements

You can view the table elements in the Tags panel and correct elements that are not correctly tagged with the Reading Order command.

1. Find the table tag <Table> in the Tags panel.

2. Check whether it is a correctly structured table which should meet either of the following structuring of table elements:
   - Each Table Row contains Table Header <TH> or Table Data <TD> cells, or both.
   - For <THead>, <TBody>, and <TFoot> sections, each of them contains Table Rows.

3. If the table’s rows, columns, and cells appear in the document, but the table tag doesn’t contain some of the elements mentioned above, tag the related element with the Reading Order command. Alternatively, re-create the table in the authoring application and then convert it to a tagged PDF.
Chapter 14 – Print

Printing is a process for reproducing text and images. When you have finished reading a helpful article or designing a PDF form, you may need to send it to an inkjet or laser printer and print it out with custom page sizes. With this section, you can get the help to set options in the Print dialog box to ensure that the finished document appears as intended.

Print a PDF document

1. Make sure you have installed the printer successfully.
2. Choose Print from the File page.
3. Specify the printer or plotter, page range, number of copies, and other options.
4. Click Print.

Print a portion of a page

To print a portion of a page, you need to refer to the Snapshot command.

- Select the Snapshot command by choosing Home > Tools > Snapshot.
- Drag around the area you want to print.
- Right-click in the selected area > choose Print..., and then refer to the “Print Dialog”.

Print multiple pages with page thumbnails

To perform a quick print, you can select multiple pages from a document from the thumbnail list.

- Open the document that you want to print, and then click Pages button on the left navigation pane.
- Shift-click / Ctrl-click/ drag the mouse to select a range of page thumbnails from the document.
- Select Print Pages from the right-click menu, and then click OK.

Print from Bookmarks

You can choose to print PDF pages associated with the selected bookmarks from the Bookmarks panel in the navigation pane.

4. In the navigation pane, click the Bookmarks panel and select a bookmark you want to print. (Ctrl-click to choose multiple bookmarks.)
5. Right-click the selected bookmarks and choose **Print Page(s)** or **Print Section(s)** from the context menu.

   **Print Page(s):** Only print the pages where the selected bookmarks (including child bookmarks) are.

   **Print Section(s):** Print all the pages in the bookmarked sections (including child bookmarks).

6. In the **Print** dialog box, choose Foxit PhantomPDF Printer from the **Name** box and choose other printing options as needed. See “**Print Dialog**”.

7. Click **Print**. In the pop-up dialog box, specify the file name and its storage location, and click **Save**.

8. The generated PDF will be opened automatically after the printing process completes.

**Print tabs**

You can print one tab you are opening from the tab bar or print out all documents opened in the tab bar at a time.

1. Move the pointer to the tab bar.
2. Right-click it > Choose **Print Current Tab/Print All Tabs**.

**The Print dialog box**

The Print dialog is the final step before printing. You can modify the printer settings in this dialog as well. Be aware that changing the printer may affect the page setup if the new selected printer has a different paper size, for instance.

To open the Print dialog box, choose **File > Print**. Choose a printer from the menu at the top of the Print dialog box and specify the copies to print. Click **Properties** for more settings. (Refer to “**Set Foxit PhantomPDF Printer Properties**”)

- **Collate** – Assembles the printouts in a proper numerical or logical order when printing several copies. This option is checked by default and will be disabled when printing just one copy.
- **Print as Grayscale** – Converts color images in the file to shades of gray.
- **Print as image** – Prints pages as bitmap images. If normal printing doesn’t work or doesn’t produce well, check this option.
- **Print Range**

  Specify the page range you want to print.

- **Subset** – Provides options for setting noncontiguous page range.

  - **All Pages in Range** – Prints all the pages within the specified range.
  - **Odd pages only** – Prints only pages with odd numbers within the specified range.
Even pages only – Prints only pages with even numbers within the specified range.

**Note:** This option is especially helpful for two-side printing.

- **Reverse pages** – Prints pages in reverse order. If page ranges are entered, the pages print opposite of the order in which they were entered. For example, if you select to print the document from page 5 to page 30, selecting Reverse pages option will print page 30 to page 5.

**Print Handling**

- **Scale** – None, Fit to Printer Margins, Reduce to Printer Margins and Custom Scale.
  Choose Paper Source by PDF Page Size – Automatically selects the paper type according to the page size of the PDFs when printing.
- **Tile Large Pages** – means to tile the pages that are larger than the selected paper size at a specified scale.
- **Multiple Pages Per Sheet** – multiple pages will be printed on the same sheet of paper. You can specify the settings like Pages Per Sheet, Page Order, Margins, etc.
- **Booklet** – Booklet printing enables to print multiple pages on the same sheet of paper in correct order if the pages are folded. This requires the printer support to print on both sides.

**Orientation** – Selects a page orientation to print the document in.

**Print on both sides of paper** – To print double-sided pages, enable this option and choose the desired orientation.

**Auto-Rotate** – Adjusts the PDF document’s orientation to match the orientation specified in the printer properties.

**Auto-Center** – Places the PDF pages in the center.

**Advanced** – Provides an option to auto-detect printers that support PCL for PCL optimization to improve the printing speed.

Print Optimization allows you to optimize print jobs from a PCL driver, for features such as font substitution or scanning for vertical and horizontal rules. Foxit PhantomPDF provides an option to auto-detect printers that support PCL for PCL optimization to improve the printing speed. To enable print optimization, please follow the steps below:

1. Choose **File > Print** to open Print dialog.
2. Click **Advanced** on the left lower corner of the **Print** dialog.
3. In the **Advanced** dialog, do the following:
   - Check **PCL Optimization** option;
   - Select a printer from Printers list, and click **Add** to add the selected printer to PCL Optimization Drivers list.
   - Click **OK**.

Then you can execute printings with the optimized driver. And you can also remove the printer
from the PCL Optimization Drivers list if you are not satisfied with the printing results it delivers. Just select the driver to be removed from the PCL Optimization Drivers list, click **Remove** and then choose **OK** to confirmation the operation.

- **Print What** – Specifies to print documents only, annotations only, or both.

  - **Document** – Prints the document contents without annotations.
  - **Document and markups** – Prints document contents and annotations. If you also need to print notes and popups associated with comments, please make sure that you check the **Print notes and pop-ups** option in Commenting Preferences.
  - **Document and stamps** – Prints document contents and stamps.
  - **Form fields only** – Prints interactive form fields only.

- **Summarize Comments** – Prints the summarized comments to a separate and printable PDF file named “CommentsSummaryPrint.pdf”. See also “**Summarize Comments**”.

- **Preview** – Foxit PhantomPDF provides an instant preview in the Print dialog box. Drag the slider to preview each page.

### Set Foxit PhantomPDF Printer Properties

Before you create a PDF file, you may wish to access PDF Printing Preferences to set up options for your PDF files, there are two ways to access PDF Printing Preferences.

1. Accessing the PDF printing Preferences from Control Panel:
   - For Windows 8 and 10, go to **Start > Windows System > Control Panel > Hardware and Sound > Devices and Printers > Printers**. For Windows 7, go to **Start > Control Panel > Devices and Printers > Printers and Faxes**.
   - Right-click on the Foxit PhantomPDF Printer and then select **Printing Preferences**.

2. Accessing the PDF Printing Preferences from the Print dialog box.
   - When you print a file and open the Print dialog box, simply click on the **Properties** button, you can bring up the PDF Printing Preferences.

### General tab

- **Target Folder** – You can click **Browse** to specify a default destination folder to store all of the PDF files generated, and the names of the generated PDF files will be the same as the originals.
by default. If no target folder is specified, a dialog box will prompt for you to specify a name and location for the PDF.

- **If File Exists** – If a PDF file that has the same name and path as the generated PDF file already exists, you can overwrite the existing file, add a numeric suffix to the name of the generated document automatically to avoid overwriting the existing files, or choose **Prompt User** to be prompted to rename the file.

- **Compatible With** - With Foxit PhantomPDF, you can choose the version number from 1.3 to 1.7 when creating PDFs. Choosing the right PDF reference version can help the PDFs to be better compatible with different PDF viewers.

- **View PDF Results** – Once the conversion is finished, the converted PDF will be opened with PhantomPDF automatically. This option is checked by default.

- **Optimize for fast web view** – Creates a linearized PDF that can be opened and viewed even before the whole file is downloaded.

- **Conversion Quality**
  - **Default settings** – chooses a type of conversion quality as the default setting.
    - **High Quality Print**: creates PDF files for high quality print but with relatively large file sizes.
    - **PDF/A-1b**: creates PDF files in compliance with PDF/A-1b standard.
    - **Smallest File Size**: creates PDF files used for web distribution.
    - **Standard**: creates PDF files with a balance between print quality and file size.
  - Click **Edit** button to modify the conversion quality and save the modified settings as a new printing setting which will be added to **Default settings list**. (See also “Custom Scan”)
  - **Color** – Prints content in a color PDF file to shades of gray, in colors or only in black and white colors.
  - **Image Resolution** - allows you to input a DPI (dot per inch) level for image resolution. The valid level value is between 72 -2400.

- **Save As Default** - If you hope all your settings can be applied to all documents, you must keep the option checked. If you uncheck it, your settings will be effective for the current document only.

**Advanced settings...** - In the pop-up **Advanced settings** dialog box, there are three tabs: Watermarks, Headers/Footers and Security.

**Watermarks tab**

**Add watermarks to the document** – If you want to add watermarks to your document, you can select this option and choose to add **Image Watermarks** or **Text Watermarks**.

**Image watermarks** – You can browse your computer for an image and change the **Opacity**, **Rotation** and **Offsets** of the image which will be added into your document as a watermark.

**Text Watermarks**

- **Font**
This option is activated only when Text Watermarks is selected and you can choose the font name, font size and font color from the drop-down menus.

- **Text**

You can enter text in the **Content** box and change the **Opacity** and **Rotation** of the text which will be added into your document as a watermark.

- **Offsets**

This option allows you to change the unit of measurement and specify the width, height of the image/text, etc.

- **Scale**

A. To resize the watermark in relation to the original image size, check **Absolute Scale** and enter a number in the percentage box.

B. To resize the watermark in relation to the PDF page dimensions, check **Relative Scale** and enter a number in the percentage box.

- **Preview**

You can see how the watermark will look like with the selected options.

- **Save As Default**

Check to apply all of your watermark settings to all documents. If you uncheck it, your settings will be effective for the current document only.

**Headers/Footers tab**

**Add Headers/Footers to the Document**

This option allows you to add headers/footers to your PDF document. By checking this option, the following options will be activated.

- **Font**

You can choose the font name, font size and font color from the boxes.

- **Edit**

This option allows you to edit headers/footers and you can specify their styles.
Click **Insert Date** to insert date to the PDF document.

Click **Insert Page Num** to insert page number to the PDF document.

You can enter text in the columns (**Left Column**, **Center Column** and **Right Column**) if needed.

**Offsets**

This option allows you to change the unit of measurement and specify the margins for all 4 sides.

**Preview**

You can see how the headers/footers will look with the selected options.

**Save As Default**

Check to apply all of your headers/footers settings to all documents. If you uncheck it, your settings will be effective for the current document only.

**Security tab**

The security feature of PDF gives you exceptional control over PDF files. Choose a protection type.

1. **Password Protection**

See also **Password Protection** in the **Security** chapter.

2. **Certificate Protection**

See also **Certificate Protection** in the **Security** chapter.

3. **RMS Protection** (Available in **Business Edition Only**)

See also **AD RMS Protection** in the **Security** chapter.

**Save As Default**

Check to apply all your security settings to all documents. If you uncheck it, your settings will be effective for the current document only.

**Layout tab**

- **Orientation** - Allows you to change the page orientation.
- **Page Size** - This option is for you to choose one of paper types from the list, or click **Custom Page Size** and then add a new page size where you can specify the paper size dimensions in
the Add/Edit Custom Page Sizes box.
• Unit of Metrics - Allows you to change the unit of measurement, including inches, centimeter and millimeters.
• Image Scaling – Scale the page content equally based on the specified page size.

You can see how your document layout will look with the selected options.

Document Info tab

Add information to the document – This option allows you to set PDF document properties, such as Title, Subject, Author, etc. You can add information when it is checked.

PDF Information – You can enter the title, subject, author, keywords and creator of the document. Producer is the Foxit PhantomPDF.

About tab

This tab shows the information of Foxit PhantomPDF and the related copyrights and information.
Chapter 15 – Appendices

This section is a collection of supplementary materials for this user manual as well as Keyboard Shortcuts, and Command Lines.

- Quick Installation Guide
- GPO Manual
- SharePoint Configuration
- Quick Start for Azure Active Directory Rights Management
- Web Service Configuration
- Shortcut Keys
- Command Lines

Quick Installation Guide

This section gives you an overview of Foxit PhantomPDF, including installation, activation, uninstallation and update.

Installation, Activation, Deactivation, and Uninstallation

Installing Foxit PhantomPDF

- System Requirements

  Operating Systems

  - Windows 7 (32-bit & 64-bit).
  - Windows 8.x Full Version.
  - Windows 10.
  - Microsoft Office® 2007 or later version (required for some PDF creation features).
  - Verified as Citrix Ready® with Citrix XenApp® 7.13.

Recommended Minimum Hardware for Better Performance

  - 1.3 GHz or faster processor.
  - 512 MB RAM (Recommended: 1 GB RAM or greater).
  - 2G of available hard drive space.
  - 1024*768 screen resolution.
How to Install

The installer format of Foxit PhantomPDF is MSI. Please download the installer to your computer, and then do the following (Take Business Edition for example):

1. Double click the “FoxitPhantomPDF_Business_enu_Setup.msi” file, and you will see the setup wizard pop up. Click Next to continue.
2. Foxit PhantomPDF is protected by copyright law, so in order to proceed, you must accept the License Agreement. Check the I accept the terms in the License Agreement box to continue.
3. There are two installation setup types for Foxit PhantomPDF. The user has the ability to change the installation directory or to keep the default settings.
   - Typical — Installs all features by default, which requires more disk space.
   - Custom — Allows users to choose which program features will be installed.
4. For Typical Setup, just click Install. For Custom Setup, do the following:
   A) Click on “Browse” to change the installation directory of the PDF Viewer plug-in.
   B) Click “Disk Usage” to check the disk space available for the selected features.
   C) Check the options you want to install and click “Next” to continue.
   D) Select the additional tasks you would like the Setup to perform, then click “Install” to start the installation.
5. When the process is complete, a dialog box will notify the user that Foxit PhantomPDF is installed. You can choose to check the Launch Foxit PhantomPDF box to run the application right after installation. Click Finish to complete the installation.

Command-line Installation

You can also use the command-line to install the application:

msiexec /Option <Required Parameter> [Optional Parameter] [PROPERTY=PropertyValue]

For more detailed information on msiexec.exe, as well as required and optional parameters, type “msiexec” in the command line or visit Microsoft TechNet Help Center.

Public Properties of the Foxit PhantomPDF MSI Installation Package.

Foxit PhantomPDF installation properties supplement the standard MSI public properties to give administrators greater control over the installation of the application.

For the complete list of standard public properties, please refer to: http://msdn.microsoft.com/en-gb/library/aa370905(VS.85).aspx

The Foxit PhantomPDF properties are:

ADDLOCAL  <list of features> The value of the ADDLOCAL property is a comma-delimited list
of features that the installation of Foxit PhantomPDF will make locally available. Foxit PhantomPDF installer is composed of the following features:

**FX_PDFVIEWER** - Foxit PDF Viewer and its components.

**FX_FIREFOXPLUGIN** – A plugin used for opening PDF files in Mozilla Firefox, Opera, Safari, and Chrome browsers. This feature requires FX_PDFVIEWER to be installed.

**FX_EALS** – A module used for displaying Eastern Asian Languages. Eastern Asian Languages can’t be displayed properly without it. This feature requires FX_PDFVIEWER to be installed.

**FX_SPELLCHECK** - A tool used for searching any misspelled words in typewriter or form filler mode. This tool also suggests the correct spelling for common mistakes. This feature requires FX_PDFVIEWER to be installed.

**FX_PDFA** – A module used for verifying compliance with PDF/A-1a and PDF/A-1b. This feature requires FX_PDFVIEWER to be installed.

**FX_OCR** – A module used for making scanned or image-based PDF documents selectable and searchable. This feature requires FX_PDFVIEWER to be installed.

**FX_CREATOR** - Foxit PhantomPDF Creator installs a virtual printer on your system. Creator can convert any printable documents into high-quality PDFs conveniently and efficiently. This feature requires FX_PDFVIEWER to be installed.

**FX_CONVERTEXT** - Shell extension used for converting PDFs or combining supported files from the right click menu. This feature requires FX_CREATOR to be installed.

**FX_CREATORWORDADDIN** - MS Word toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATOREXCELADDIN** - MS Excel toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATORPPTADDIN** - MS PPT toolbar add-in to create PDFs
in just one click. This feature requires FX_CREATOR to be installed.

**FX_CREATOROUTLOOKADDIN** - MS Outlook toolbar add-in to create PDFs in just one click. This feature requires FX_CREATOR to be installed.

**FX_SE** - Plugins for Windows Explorer and Windows shell. These extensions allow PDF thumbnails to be viewed in Windows Explorer, and PDF files to be previewed in Windows OS and Office 2007 (or a later version). This feature requires FX_PDFVIEWER to be installed.

**FX_IFILTER** – Foxit PDF iFilter is a plugin for Windows search engines that can help search PDF documents quickly.

**FX_CONNECTEDPDF** – A plugin that provides ConnectedPDF features including creation, sharing, securing, and tracking of PDF documents worldwide.

**FX_BROWSERADDIN** - The web browser plugin used for converting web pages to PDFs.

**INSTALLLOCATION** Specifies the folder location of the product installed.

**MAKEDEFAULT** Default value of "1", Foxit PhantomPDF will be set as the default application for opening PDF files.

**VIEW_IN_BROWSER** Default value of "1", Foxit PhantomPDF will be configured to open PDF files inside browsers.

**DESKTOP_SHORTCUT** Default value of "1", installer will place a shortcut for the installed application on the Desktop.

**STARTMENU_SHORTCUT** Default value of "1", installer will create a program menu group for installed application and its components.

**SETDEFAULTPRINTER** Default value of "1", installer will install Foxit PhantomPDF Printer and set it as the system’s default printer.

**LAUNCHCHECKDEFAULT** Default value of "1", Foxit PhantomPDF will check if Foxit PhantomPDF is the default reader when launched.

**KEYPATH** Specifies a license key file and saves it to the PhantomPDF installation folder.
REMOVENEWVERSION Forces an installation to overwrite the newer version of Foxit PhantomPDF with the value of “1”.

CLEAN Executes with the command “/uninstall”, removing all of PhantomPDF’s registry data and related files with the value of “1”. (Note: This is a command for uninstallation.)

AUTO_UPDATE Does not download or install updates automatically with the value of “0”; Automatically checks for updates and downloads updates if any, but lets users choose when to install them with the value of “1”; Automatically installs updates with the value of “2”. The default value is “1”.

CPDF_DISABLE Disables the ConnectedPDF features by setting the value to “1”.

EDITION Specifies an edition to install Foxit PhantomPDF, including Standard and Business.

NOTINSTALLUPDATE Does not install updates by setting the value to “1”. This will prevent Foxit PhantomPDF from being updated from within the software.

INTERNET_DISABLE Disables all features that require Internet connection by setting the value to “1”.

READ_MODE Opens PDF file in Read Mode by default in web browsers by setting the value to “1”.

DISABLE_UNINSTALL_SURVEY Stops the Uninstall Survey after uninstallation by setting the value to “1”.

KEYCODE Activates the application by key code.

EMBEDDED_PDF_INOFFICE With the value of “1”, opens embedded PDF files in Microsoft Office with Foxit PhantomPDF if Acrobat and Foxit Reader is not installed. (For the EXE installation package, inputs the command-line /displayadobeindoc.)

Command-line Examples:

1. Silently install the application (no user interaction) to folder "C:\Program Files\Foxit Software":

294
msiexec /i "Foxit PhantomPDF.msi" /quiet INSTALLLOCATION="C:\Program Files\Foxit Software"

2. Install the Foxit PDF Viewer only:

   msiexec /i "Foxit PhantomPDF.msi" /quiet ADDLOCAL="FX_PDFVIEWER"

3. Use the license key file saved in disk C to activate the application when running the setup:

   msiexec /i "Foxit PhantomPDF.msi" KEYPATH="C:\fpmkey.txt"

4. No installation of Foxit PhantomPDF Printer:

   msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL, ADVERTISE="FX_CREATOR" /qn

5. Force an installation to overwrite the same or higher version of Foxit PhantomPDF:

   msiexec /i "Foxit PhantomPDF.msi" REMOVENEWVERSION="1"

6. Remove registry and user data when performing silent uninstallation:

   msiexec /x "Foxit PhantomPDF.msi" /quiet CLEAN="1"

7. Install the application without ConnectedPDF related features and services:

   msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL, ADVERTISE="FX_CONNECTEDPDF"

8. Activate the application by key code:

   msiexec /i "Foxit PhantomPDF.msi" KEYCODE="your key code"

9. Install the application without Foxit PhantomPDF Create PDF Toolbar

   msiexec /i "Foxit PhantomPDF.msi" ADDLOCAL=ALL, ADVERTISE="FX_BROWSERADDIN"

**Activating Foxit PhantomPDF**

After launching Foxit PhantomPDF, the activation wizard pops up. If you have already purchased a license for Foxit PhantomPDF, click **Activate** to activate Foxit PhantomPDF. If not, you can click **Buy Now** to purchase Foxit PhantomPDF from the Foxit website. If you choose **Free Trial**, you will be given a 14-day free trial period to use Foxit PhantomPDF. When the free-trial period expires, only the free features are available.
Foxit PhantomPDF
User Manual




If you have purchased subscription licensing, after clicking Activate, you can choose to sign in
your Foxit account. After successfully signed in, the Foxit PhantomPDF will be activated
automatically.
If you have purchased a perpetual license, please follow the steps below to activate Foxit
PhantomPDF:
1. After clicking Activate, input the code of the registration key. (You can activate the key at
a later time from Help > Activate when you run Foxit PhantomPDF.) Then click Activate to
continue.
2. (Optional) If you didn’t provide your name when purchasing the license, you’ll be
prompted to type your name.
3. If the activation is successful, a message box will pop up. Click OK.
4. You should restart the application for the changes to take effect. To restart it now, please
click OK; or click Cancel to restart later.

Deactivating Foxit PhantomPDF
You can deactivate Foxit PhantomPDF in one machine to activate another. After deactivation you
can still use the features of Foxit PhantomPDF Express. To deactivate Foxit PhantomPDF, click Help >
Deactivate.

Uninstalling Foxit PhantomPDF
How to Uninstall
Please do one of the following:

Click Start > All Programs > Foxit PhantomPDF > Uninstall.
For Windows 8 and 10, click Start > Windows System > Control Panel > Programs > Programs
and Features > Select Foxit PhantomPDF and click Uninstall. For Windows 7, click Start >
Control Panel > Programs and Features to uninstall it.
Double click the file uninstall.exe under the Foxit PhantomPDF installation directory drive
name: \...\Foxit Software\Foxit PhantomPDF\.

Foxit PhantomPDF Add-ons
Foxit PhantomPDF provides separate add-ons for you to download on demand. These add-ons fall
into critical add-ons and advanced add-ons. Most of add-ons, including JPEG2000/JBIG Decoder,
Eastern Asian Language Support, Spell Checker and Firefox Plugins, have been integrated into Foxit

296


PhantomPDF package, so users don’t need to install them again after the installation of Foxit PhantomPDF. But if there’re any upgrades of those add-ons, users can go to Help > Check for Update to download and install the latest add-ons.

Critical Add-ons

Critical add-ons are essential components for proper display and execution.

### Free Critical Add-ons in Foxit PhantomPDF

<table>
<thead>
<tr>
<th>Name</th>
<th>Function Description</th>
<th>Size</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi-langue OCR Text Recognition Engines</td>
<td>Enables selecting and searching text in scanned or image-based PDFs. This add-on supports multi-language: Portuguese, Polish, Russian, Japanese, Korean, Simplified Chinese &amp; Traditional Chinese, Turkish and Dutch, etc. (For Chinese, Japanese and Korean, you should download from our website, and the others have been integrated into Foxit PhantomPDF package.)</td>
<td></td>
<td>Download</td>
</tr>
</tbody>
</table>

**NOTE:** To manually install a critical add-on, please extract it to the same directory where you install Foxit PhantomPDF. See also "Updating Foxit PhantomPDF".

Purchasing Foxit PhantomPDF

Foxit PhantomPDF provides two licensing models: perpetual licensing and subscription licensing. The former allows users to use PhantomPDF without expiration dates, while the latter enables users to pay for a monthly/yearly usage fee, with full features available for both.

To purchase Foxit PhantomPDF, please do one of the following:

1. Order online: go to Foxit website to order directly: [http://www.foxitsoftware.com/shopping](http://www.foxitsoftware.com/shopping)
2. Email: write an e-mail to the Foxit sales department at sales@foxitsoftware.com with your order information.
3. Click HELP/HOME > Purchase in the PhantomPDF toolbar to purchase a license from the Foxit online store.
4. Click HELP/HOME > Subscribe in the PhantomPDF toolbar to quickly purchase a non-perpetual license or renew the subscription if the previous one ends. The licensee has the rights to manage the authorized machines by clicking Manage to disable current activation(s). *(Note: Internet connection and Foxit account signed-in are required to use the full features for subscribed users.)*
Updating Foxit PhantomPDF

Foxit files along with add-ons can be updated in several ways. Some updates are available if you open a PDF document that triggers the updating process. For example, if you open a file that contains Chinese characters, Foxit PhantomPDF will ask if you want to download the Eastern Asian Language Support. Other updates are available only from the Help menu, where you have to manually install them. However, all updates can be downloaded directly from Foxit website. Foxit PhantomPDF supports auto-update checking. When there is a new version detected, Foxit PhantomPDF will prompt users to update.

Updating from the Help Menu

1. Choose Help > Check for Update.
2. In the pop-up dialog box, select updates from the column on the left, and click Add to move them to the right column. Only the updates and components appropriate for your product will be listed. Click Next to download and install the update.

Updating from Foxit Website

2. Select and download the files or add-ons you want to update.
3. Extract them to the same directory where you installed Foxit PhantomPDF.
4. Re-run the Foxit PhantomPDF program to implement the update files.

Help & Support

User Manual

If you have trouble finding help for a particular topic or the help provided is not sufficient, enter a trouble ticket via our Support Portal and our support team will contact you. Your feedback helps us to improve our documentation.

Ticket Support

Visit Foxit Ticket Support System by choosing Help > Help > Post Your Idea, to send your bug report/suggestion/comment directly to Foxit Customer Support Center.

On-Line Support

Our ticket support system is staffed with product experts round the clock to provide you with fast
and efficient answers to all of your technical questions. Plus, our on-line user forums provide a wealth of information.

Foxit Forum

Visit Foxit forum at http://forums.foxitsoftware.com/ to see if you can find the answer to your questions there immediately.

GPO Manual

What is Group Policy?

Group Policy (GPO), a feature of the Microsoft Windows NT family of operating systems, is a set of rules that control the working environment of user accounts and computer accounts. It offers the centralized management and configuration of operating systems, applications, and users' settings in an Active Directory environment.

Group Policy can configure most system settings, save power by utilizing smart power settings, give individual users more control over their machines with administrator privileges and increase system security.

This guide will introduce steps to help you master how to quickly add and modify the new GPO template for configuring your installation of Foxit PhantomPDF.

Personal Computer Setting

There are two file types of group policy template of Foxit PhantomPDF: .adm and .admx. Different types are compatible with different operation systems, but have the same settings. The template of .adm file type is compatible with Windows XP and later, while .admx is compatible with Server 2008, Server 2012, Windows 7 and later.

Set Template Preference

For .adm file, follow the steps as below:

- Please click Start > Run or use the shortcut key Ctrl + R and type gedit.msc to open Group Policy Editor.
- Right-click the management template and choose Add/Remove Template in the context menu. In the opened dialogue box, add the group policy template of Foxit PhantomPDF. The Foxit PhantomPDF template will appear in the left navigation pane and you can set its template preferences.
For .admx file, put the .admx file in C:\Windows\PolicyDefinitions and do the setting. The .admx file should be used in combination with an .adml file. And the .adml file should be put in C:\Windows\PolicyDefinitions\language. For example, if in the English OS, the .adml file should be put in C:\Windows\PolicyDefinitions\en_us.

**Example: Not Show Community Language**

- Choose Foxit PhantomPDF > Preferences > Application Language.
- Double-click Application Language to open the dialog box and check the option Enabled and check Not Show Community Language. Then only the official languages will show in the File > Preferences > Language.
- If the option Not Configured or Disabled is checked, the languages translated by community will be displayed.
Other settings can be configured in the same way.

**Note:** Group Policy setting includes computer configuration and user configuration.

Computer configuration takes precedence over user configuration. The application will use the computer configuration if both the computer and user configure a specific function at the same time. Please note that if the option **Disabled** is a valid configuration, the setting will be shown in the help information. Otherwise, the corresponding registry entry will be removed as selecting Unconfigured. (The value of the option Disabled in the Group Policy Template of Foxit PhantomPDF is invalid.)

**GPO Deployment (for Server)**

**Create GPO Management**

- If you already have an Active Directory domain and organizational unit configured, please skip to “Apply the Foxit Template” section.
- Choose **Start > Administration Tools** > open “Active Directory Users and Computers” > right-click the field “wx.com” > choose **New > Organization Unit**.
In the opened New Object - Organization Unit dialogue box, type the unit name (For this example, we have named the unit “qa”) and click **OK**.
• Right click the created organization unit “qa” and choose **New > User.** For this example, we have named the user “King”.

• Click **Start > Programs > Administration Tools** > open the Group Policy Management console
and right-click the created organization unit “qa” and choose Create a GPO in this domain, and Link it here....

If you cannot find the Group Policy Management in Administration Tools, please install the application package GPMC.MSI. You can download the package by clicking the link http://www.microsoft.com/en-us/download/details.aspx?id=21895.
Apply the Foxit Template

- Type the GPO name in the “New GPO” dialogue box and click **OK**.

- Right-click the new GPO and choose **Edit...** in the right-click menu to open Group Policy Editor.
Right-click the Template Management and choose Add/Remove Template to add Foxit PhantomPDF template. Please refer to Set Template Preference.

For configuring options, please refer to Example: Not Show Community language.

GPO Items

The following table introduces some simple manipulations in GPO to speed up your working process.
## Items in GPO Template

<table>
<thead>
<tr>
<th>Folder Path</th>
<th>Item</th>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Foxit PhantomPDF &gt; Plugins</td>
<td>Remove Specific Plugins</td>
<td></td>
<td>Input the plugin name which needs to be removed. Only applications with .fpi extensions can be removed from Foxit PhantomPDF.</td>
</tr>
<tr>
<td>Remove Plugins</td>
<td>Updater</td>
<td></td>
<td>Remove the selected plugins.</td>
</tr>
<tr>
<td></td>
<td>FoxitAccountManagement</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Speech</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>RMSV2</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>SharePoint</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>DocuSign</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>CommentsSummary</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ComparePDF</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PageEditor</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ShareReview</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>GoogleDrivePlugin</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OneDrivePlugin</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OneDrive For Business</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>ActionWizard</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>DropboxPlugin</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>LicenseManager</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>BoxPlugin</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>U3DBrowser</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>iManage Work</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>OpenText eDOCS DM</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>NetDocuments ActiveX</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>NetDocuments ndOffice</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dwg2Pdf</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Foxit Drive</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>WIP</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Content Suite</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Worldox</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Documentum</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Egnyte</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt;</td>
<td>‘About Foxit</td>
<td>Copyright</td>
<td>Set the new contents in</td>
</tr>
<tr>
<td>Preferences</td>
<td>PhantomPDF’ Dialog</td>
<td>Copyright Content</td>
<td>'About Foxit PhantomPDF' dialog.</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------------</td>
<td>------------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Default PDF Viewer</td>
<td>Web Browser PDF Viewer</td>
<td>Set Foxit PhantomPDF as the default PDF viewer for 'System PDF Viewer' and 'Web Browser PDF Viewer'. This setting requires Administrator permission. In a domain environment, if the client doesn’t have the Administrator permission, there will be a UAC prompt after the boot.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Forbid Checking of Default PDF Viewer</td>
<td></td>
<td>Hide the 'Set to Default PDF PhantomPDF' dialog when Foxit PhantomPDF isn’t the default PDF viewer.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Program Name</td>
<td>Program Name</td>
<td>Change the program’s name. The default is 'Foxit PhantomPDF'.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Start Page</td>
<td>Hide Start Page</td>
<td>Change the settings of Start Page.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Enable Safe Reading Mode</td>
<td></td>
<td>Change the settings of Safe Reading Mode.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Application Language</td>
<td>Not Show Community Language</td>
<td>Change the application language settings. This will change the setting item in Preferences &gt; Languages.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Insert Printed PDF into Previously Generated PDF</td>
<td></td>
<td>Set to append PDF files generated with Foxit PhantomPDF Printer to previously generated files.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Status Bar</td>
<td>Setting (Auto-hide Status Bar, Hide Status Bar, or Show)</td>
<td>Change the settings of Status Bar.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Status Bar</td>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Preferences</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------</td>
<td>--------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Notification Messages</td>
<td>Enable this option and choose how to deal with the different notification messages. If you unchecked all the options, the notification messages will never be shown. This will change the corresponding setting in Preferences &gt; General.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Share the PDF file that caused crash</td>
<td>Enable this option to always share the PDF file that caused crash. This will change the corresponding setting of ‘Share the PDF file that caused this crash’ option in Crash Report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change The Link For User Manual</td>
<td>Enable this option to change the link of User Manual to the local link you want.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Disable the Automatically Update</td>
<td>With this option enabled, the automatic update will be disabled.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Disable Security Warning</td>
<td>Enable this option to disable the security warning when Foxit PhantomPDF is launched by a third-party application without a valid digital signature.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock Read Mode in web browsers</td>
<td>Enable this option to use Read Mode by default in Foxit PhantomPDF browser plugins, and disallow users from exiting this mode. This will change the corresponding</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Features which require internet connection</td>
<td>Enable this option to enable all the features which require internet connection. This will change the corresponding setting in Preferences &gt; General.</td>
<td></td>
</tr>
<tr>
<td>--------------------------------</td>
<td>--------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Filter Comments by the original author only</td>
<td>Enable this option to filter comments by the original author only. This will change the corresponding setting in Comment &gt; Filter window.</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>User Experience Improvement</td>
<td>Enable this option to allow anonymous data collection. This will change the corresponding setting in Preferences &gt; General.</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Hide Activation Code</td>
<td>Enable this option to hide activation code in the application.</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Trusted Applications</td>
<td>Enable this option and input the name of the trusted application in the list. The listed application will be adding in the Trusted Apps in Preferences &gt; Trust Manager settings.</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; Preferences</td>
<td>Protected View</td>
<td>Enable this option to turn on protected view in order to protect your computers from being harmed by files originated from potentially unsafe locations. This will change the setting in Preferences &gt; General.</td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF</td>
<td>Preferences &gt; Security &gt; Protected View.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------------</td>
<td>-----------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Foxit PhantomPDF Preferences</strong></td>
<td>Require password to use signatures</td>
<td>Enable this option to require users to set a password for the signature while creating a new signature. This will change the setting of ‘Require password to use this signature’ in PDF Sign &gt; Create Signature &gt; Options.</td>
<td></td>
</tr>
<tr>
<td><strong>Foxit PhantomPDF &gt; Ribbon</strong></td>
<td>TabElements (the button items in Quick Access Toolbar and menu bar)</td>
<td>Hide the selected button items in Ribbon Mode.</td>
<td></td>
</tr>
<tr>
<td><strong>RibbonCategory</strong> (the button items in each tab)</td>
<td>Encrypt Metadata</td>
<td>Encrypt document metadata. This disables the setting in 'Preferences &gt; RMS Setting'.</td>
<td></td>
</tr>
<tr>
<td><strong>Foxit PhantomPDF &gt; RMS &gt; Preferences</strong></td>
<td>Add ‘protected’ to the name of encrypted files</td>
<td>Append “(protected)” to the end of the file name of encrypted files.</td>
<td></td>
</tr>
<tr>
<td><strong>Save As</strong></td>
<td>Turn on the Save As feature for RMS protected files.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Microsoft IRM Protection</strong></td>
<td>Enable this option to choose Microsoft IRM Protection Version for document encryption. If not enabled, Microsoft</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foxit PhantomPDF</td>
<td>IRM Protection Version 2(PPDF) is used.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RMS Interoperability</td>
<td>Enable this option, all encrypted PDF will conform to Microsoft IRM Protection for PDF Specification and hence be able to be decrypted by other RMS Viewer.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Foxit PhantomPDF &gt; ConnectedPDF</th>
<th>Disable ConnectedPDF features</th>
<th>Enable this setting to disable all ConnectedPDF features.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Foxit PhantomPDF &gt; ConnectedPDF</td>
<td>Default ConnectedPDF server</td>
<td>Server URL Set the default ConnectedPDF server, the end user can use this server URL to connect your enterprise ConnectedPDF server.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; ConnectedPDF &gt; Preferences</td>
<td>Allow usage data to be used in ConnectedPDF features</td>
<td>Enable this option to disable sharing usage data when using ConnectedPDF features.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; ConnectedPDF &gt; Preferences</td>
<td>Automatically save PDF files in ConnectedPDF format (including those created from plugins) only when signed in</td>
<td>Enable this option to forbid the application automatically save PDF files in ConnectedPDF format.</td>
</tr>
<tr>
<td>Foxit PhantomPDF &gt; ConnectedPDF &gt; Preferences</td>
<td>Automatically convert Office files to Connected when converting to PDF via Office add-in</td>
<td>Enable this option to forbid the application automatically convert Office files to ConnectedPDF format when converting to PDF files.</td>
</tr>
</tbody>
</table>

**SharePoint Configuration**

Before using the check in/check out features in Foxit PhantomPDF, please configure the SharePoint Server.

- **SharePoint 2007**: Copy the downloaded GIF file to "Drive: \Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\images".

- **SharePoint 2010**: Copy the downloaded GIF file to "Drive: \Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Template\images".

- **SharePoint 2007**: Edit the file "Drive: \Program Files\Common Files\Microsoft Shared\Web server extensions\12\Template\Xml\DOCICON.XML".

- **SharePoint 2010**: Edit the file "Drive: \Program Files\Common Files\Microsoft Shared\Web server extensions\14\Template\Xml\DOCICON.XML".

To edit the file, please refer to the following steps:

- **a.** Right-click DOCICON.XML file > click Open With > select Notepad.
- **b.** Add an entry for the file with .pdf extension and take it as the file’s name. For example, type the ICPDF as the name of the .gif file:
  
  ```xml
  <Mapping Key="pdf" Value="pdficon.gif" OpenControl="FoxitPhantomPDF.OpenDocuments"/>
  ```

- **c.** Click Save on the File menu, and then quit Notepad.
Perform an iisreset:

a. Click Start > Run > type “cmd” in the Open dialog box > click OK > type “iisreset” in the command prompt window > click Enter.

b. Close the windows.

Quick Start for Azure Active Directory Rights Management

1. Enable Windows Azure AD Rights Management for your organization:
   - Download the Windows Azure AD Rights Management administration module (WindowsAzureADRightsManagementAdministration.exe) for Windows PowerShell from here.
   - In the local folder where you downloaded and saved the Rights Management installer file, double-click the file WindowsAzureADRightsManagementAdministration.exe to launch installation of the Rights Management administration module.
   - Open Windows PowerShell.
   - Type the following commands:
     - Import-Module AADRM
     - Connect-AadrmService -Verbose
   - Enter your Office 365 credentials when prompted, for example “user@company.onmicrosoft.com”.
   - Type the following commands:
     - Enable-Aadrm
     - Disconnect-AadrmService

2. Install Active Directory Rights Management Service Client 2.1:

X86 Download
Web Service Configuration

To use the features of dynamic revocation, number of accesses and number of prints (additional access rights control), you should configure the web service and SQL first. Please follow the steps as below:

1. Configure the Web Service on your on-premise RMS server.

   a) Log on RMS server as Administrator.
   b) Download the Web Service zip from:

      For X86:
      http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/WebService_32.zip

      For X64:
      http://cdn01.foxitsoftware.com/pub/foxit/rms/configtool/WebService_64.zip

   c) Unzip the Web Service zip and get the fxrmsext from it.
   d) Copy the fxrmsext to C:\inetpub\wwwroot\_wmcs.

   e) Run “Internet Information Services” (IIS).
   f) Right-click “_wmcs”, and then choose “Add Application...”.

X64 Download
g) Input the following information into the **Add Application** dialog box.

- Alias: fxrmsext
- Physical path: C:\inetpub\wwwroot\_wmcs\fxrmsext

h) To avoid repeated authentication, we should disable the Windows Authentication and enable the Anonymous Authentication. Click “fxmsext” in Connections Pane, and then double-click “Authentication”.

**NOTE:** For data communication security, PDFs will be encrypted with AES algorithm by default.
i) Enable the "Anonymous Authentication" and disable the "Windows Authentication".

2. Configure the SQL.

   a) Navigate to C:\inetpub\wwwroot\_wmcs\fxrmsext.
   b) Right-click "Web.config" file -> "Open with" -> "Notepad".
c) If you want to log on to the SQL Server through Windows Authentication, you just need to alter the SQL Server information by inputting the IP address or computer name and then saving the change.

```xml
<appSettings>
  <add key="MyDB" value="Server=SQL2005; DataBase=RMSExtService; Integrated Security=SSPI; Persist Security Info=False" />
</add>
```

**NOTE:** If the computer name include `'`, please ensure you are using SQL 2012 version or higher.

d) If you want to log on to the SQL Server through SQL Server Authentication, please follow the steps:

i. Copy “Server=SQL2005; DataBase=RMSExtService; User ID=myUsername; Password=myPassword”.

ii. Paste and replace “Server=SQL2005; DataBase=RMSExtService; Integrated Security=SSPI; Persist Security Info=False”.

iii. Alter the SQL Server information. You can input the IP address or the computer name.

iv. Alter the “User ID” and “Password”.

v. Save changes.

e) Create the database and tables.

i. Log on to the SQL Server as Administrator.
ii. Get the .sql file from the Web Service zip you downloaded before.

iii. Double-click this file to create the database and tables, and then click “Execute”.

f) Grant RMS administrator the database operations rights.

i. Open “Internet Information Services” (IIS).

ii. Click “Application Pools” in Connections Pane. Then you can get the account information from Identity column.

iii. Open SQL Server management.


v. Check if the RMS administrator account is listed.
If yes, skip to Step vi.
If not, right-click “Logins”, then click “New Login”.

Input the Login name, click **OK**.
vi. Grant RMS administrator as the database owner.

g) Set up the firewall.
i. In SQL Server Configuration Manager, expand SQL Native Client Configuration, and
click “Client Protocols” and right-click “TCP/IP Properties” to get the default port.

ii. Run “Windows Firewall” and click “Advanced settings”.

iii. Click “Inbound Rules”.

322
iv. Click "New Rule...".

v. Select "Port" and then click "Next".
vi. Select “TCP”, then select “Specific local ports”, type the SQL port number, and click “Next”.

vii. Select “Allow the connection”, and then click “Next”.

---

324
viii. Choose when to apply the rule.

ix. Specify the name and description of the rule and then click “Finish”.

325
Work with PhantomPDF via VBA scripts in Excel

Foxit PhantomPDF allows you to use VBA scripts in Microsoft Excel to automate PDF tasks, including PDF creation, form filling, and adding watermarks. This section offers instruction on preparation and settings before you use Excel VBA scripts to perform PDF tasks with Foxit PhantomPDF.

Prepare Microsoft Excel

With similar operations in Excel versions, take Excel 2016 for example. In Excel 2016, there is no Developer tab in the ribbon by default. To add the tab, click File > Options > Customize Ribbon in Excel 2016, and check Developer in Main Tabs on the right part of the Excel Options dialog box, as the screenshot shown below.
Then you can see the **Developer** tab in the Ribbon.

![Developer tab in the Ribbon](image)

**Configure the VBA Editor**

Open the VBA Editor (i.e. the “Microsoft Visual Basic for Applications” dialog box) in Excel first. There are three methods to open the VBA Editor:

1. Press shortcuts **Alt+F11**.
2. Click **Visual Basic** in the **Developer** tab.
3. Right-click a sheet and choose **View Code** in the context menu.

The VBA Editor pops up to continue.

Click **Tools > References**, and check **PhantomPDF** in the pop-up dialog box shown as the screenshot below. Click **OK** to exit the dialog box.
Click View > Object Browser in the VBA Editor. In the pop-up dialog box, click the <All Libraries> box and you can see PhantomPDF has been successfully referenced.

Now we've completed all necessary preparation and settings. For the API reference to communicate with PhantomPDF, please refer to API Reference for Application Communication.

**Keyboard Shortcuts**

There are number of keyboard shortcuts that you can use to speed up your navigation within the Foxit PhantomPDF. You can both use the default keyboard shortcuts and customize your own shortcuts.

To customize the keyboard shortcuts, please do as below:

Right-click any area on the ribbon and choose Customize Quick Access Toolbar .... In the pop-up Customize Tools dialog box, choose Keyboard tab.

Some particularly important ones are listed here.
File Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open File</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Close File</td>
<td>Ctrl + W, or Ctrl + F4</td>
</tr>
<tr>
<td>Save As</td>
<td>Ctrl + Shift + S</td>
</tr>
<tr>
<td>Close All</td>
<td>Ctrl + Shift + W</td>
</tr>
<tr>
<td>Print a Document</td>
<td>Ctrl + P</td>
</tr>
<tr>
<td>Exit Foxit PhantomPDF</td>
<td>Ctrl + Q, or Alt+F4</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Create PDF from file</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Document Properties</td>
<td>Ctrl + D</td>
</tr>
</tbody>
</table>

View Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Screen</td>
<td>F11</td>
</tr>
<tr>
<td>Exit Full Screen Mode</td>
<td>ESC, or F11</td>
</tr>
<tr>
<td>Switch to Text Viewer</td>
<td>Ctrl + 6</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl + +</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl + -</td>
</tr>
<tr>
<td>Zoom To</td>
<td>Ctrl + M</td>
</tr>
<tr>
<td>Actual Size</td>
<td>Ctrl + 1</td>
</tr>
<tr>
<td>Fit to Page</td>
<td>Ctrl + 0</td>
</tr>
<tr>
<td>Fit Width</td>
<td>Ctrl + 2</td>
</tr>
<tr>
<td>Fit Visible</td>
<td>Ctrl + 3</td>
</tr>
<tr>
<td>Rotate Clockwise</td>
<td>Ctrl + Shift + Plus</td>
</tr>
<tr>
<td>Rotate Counterclockwise</td>
<td>Ctrl + Shift + Minus</td>
</tr>
<tr>
<td>AutoScroll</td>
<td>Ctrl + Shift + H</td>
</tr>
<tr>
<td>Stop AutoScroll</td>
<td>ESC</td>
</tr>
<tr>
<td>Switch between tabs</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>View file in read mode</td>
<td>Ctrl + H</td>
</tr>
<tr>
<td>Preview page by page in Print Preview</td>
<td>Page Up/Down</td>
</tr>
</tbody>
</table>
### Go to Page
- **Ctrl + G**

### First Page
- **Ctrl + Home**

### Previous Page
- **Ctrl + Page Up**

### Next Page
- **Ctrl + Page Down**

### Last Page
- **Ctrl + End**

### Previous View
- **Alt + Left**

### Next View
- **Alt + Right**

### Marquee Zoom
- **Alt + 5**

### Read Current Page
- **Ctrl + Shift + V**

### Read from Current Page
- **Ctrl + Shift + B**

### Stop
- **Ctrl + Shift + E**

### Rulers
- **Ctrl + R**

### Show or hide Navigation pane
- **F4**

## Edit Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Ctrl + C, or Ctrl + Insert</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
</tr>
<tr>
<td>Undo (Undo an action)</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo (Redo or repeat an action)</td>
<td>Ctrl + Shift + Z</td>
</tr>
<tr>
<td>Select All (Select all items in a document or window)</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Add Bookmark</td>
<td>Ctrl + B</td>
</tr>
<tr>
<td>Preferences</td>
<td>Ctrl + K</td>
</tr>
<tr>
<td>Go to fillable field by tab order</td>
<td>Tab</td>
</tr>
<tr>
<td>Go to fillable field by tab in reversed order</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Duplicate pages</td>
<td>Ctrl + U</td>
</tr>
</tbody>
</table>

## Tool Keys

<table>
<thead>
<tr>
<th>Tool</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hand Tool</td>
<td>Alt + 3</td>
</tr>
<tr>
<td>Select Text and Image</td>
<td>Alt + 6</td>
</tr>
<tr>
<td>----------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Snapshot</td>
<td>Alt + 7</td>
</tr>
<tr>
<td>Find Text (Open the Navigation task pane to search document.)</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>Find Next</td>
<td>F3</td>
</tr>
<tr>
<td>Find Previous</td>
<td>Shift + F3</td>
</tr>
<tr>
<td>Search</td>
<td>Ctrl + Shift + F</td>
</tr>
</tbody>
</table>

**Document Keys**

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Down</td>
<td>Space</td>
</tr>
<tr>
<td>Page Up</td>
<td>Shift + Space</td>
</tr>
<tr>
<td>Expand the selected area to the next character on the right</td>
<td>Shift + Right</td>
</tr>
<tr>
<td>Expand the selected area to the next character on the left</td>
<td>Shift + Left</td>
</tr>
<tr>
<td>Expand the selected area to the end of a word</td>
<td>Ctrl + Shift + Right</td>
</tr>
<tr>
<td>Expand the selected area to the beginning of a word</td>
<td>Ctrl + Shift + Left</td>
</tr>
<tr>
<td>Expand the selected area to the end of a row</td>
<td>Shift + End</td>
</tr>
<tr>
<td>Expand the selected area to the beginning of a row</td>
<td>Shift + Home</td>
</tr>
<tr>
<td>Expand the selected area next Row</td>
<td>Shift + Down</td>
</tr>
<tr>
<td>Expand the selected area previous Row</td>
<td>Shift + Up</td>
</tr>
<tr>
<td>Expand the selected area to the beginning of a document</td>
<td>Ctrl + Shift + Home</td>
</tr>
<tr>
<td>Expand the selected area to the end of a document</td>
<td>Ctrl + Shift + End</td>
</tr>
<tr>
<td>Move left by a character</td>
<td>Left</td>
</tr>
<tr>
<td>Move right by a character</td>
<td>Right</td>
</tr>
<tr>
<td>Move left by a word</td>
<td>Ctrl + Left</td>
</tr>
<tr>
<td>Move right by a word</td>
<td>Ctrl + Right</td>
</tr>
<tr>
<td>Move up by a row</td>
<td>Up</td>
</tr>
<tr>
<td>Move down by a row</td>
<td>Down</td>
</tr>
<tr>
<td>Move to the end</td>
<td>End</td>
</tr>
<tr>
<td>Move to the beginning</td>
<td>Home</td>
</tr>
</tbody>
</table>
Move to the top of next page  
Move to the top of previous page  
Move to the end of the document  
Move to the beginning of the document

Help Keys

<table>
<thead>
<tr>
<th>Result</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help</td>
<td>F1</td>
</tr>
</tbody>
</table>

Single-key Accelerators

You can select some commands and perform some actions with single-key accelerators. To enable single-key accelerators, please go to File > Preferences > General, and check Use single-key accelerators to access tools option in the Basic Tools group.

Keys for Selecting Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hand</td>
<td>H</td>
</tr>
<tr>
<td>Temporarily select Hand</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select Text and Image</td>
<td>V</td>
</tr>
<tr>
<td>Marquee</td>
<td>Z</td>
</tr>
<tr>
<td>Cycle through zoom commands: Marquee, Loupe, Magnifier</td>
<td>Shift + Z</td>
</tr>
<tr>
<td>Temporarily zoom out (when the Marquee command is selected)</td>
<td>Ctrl</td>
</tr>
<tr>
<td>Temporarily select Zoom In</td>
<td>Ctrl + Spacebar</td>
</tr>
<tr>
<td>Select Annotation</td>
<td>R</td>
</tr>
<tr>
<td>Edit Object</td>
<td>O</td>
</tr>
<tr>
<td>Crop Pages</td>
<td>C</td>
</tr>
<tr>
<td>Link</td>
<td>L</td>
</tr>
<tr>
<td>Text Field</td>
<td>F</td>
</tr>
</tbody>
</table>
# Foxit PhantomPDF User Manual

## Keys for Working with Comments

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sticky Note</td>
<td>S</td>
</tr>
<tr>
<td>Replace Text</td>
<td>E</td>
</tr>
<tr>
<td>Stamp</td>
<td>K</td>
</tr>
<tr>
<td>Current highlighting command</td>
<td>U</td>
</tr>
<tr>
<td>Cycle through highlighting tools: Highlight, Underline, Strikeout</td>
<td>Shift + U</td>
</tr>
<tr>
<td>Current drawing markup command</td>
<td>D</td>
</tr>
<tr>
<td>Cycle through drawing markup commands: Cloud, Arrow, Line, Rectangle, Oval, Polygon Line, Polygon, Pencil, Eraser</td>
<td>Shift + D</td>
</tr>
<tr>
<td>Cloud</td>
<td>Q</td>
</tr>
<tr>
<td>Text Box</td>
<td>X</td>
</tr>
<tr>
<td>Current Stamp or Attach File command</td>
<td>J</td>
</tr>
<tr>
<td>Cycle through Stamp and Attach File</td>
<td>Shift + J</td>
</tr>
<tr>
<td>Move focus to next comment or form field</td>
<td>Tab</td>
</tr>
<tr>
<td>Move focus to previous comment or form field</td>
<td>Shift + Tab</td>
</tr>
<tr>
<td>Open pop-up note (or text field in Comments List) for comment that has focus</td>
<td>Enter</td>
</tr>
<tr>
<td>Close pop-up (or text field in Comments List) for comment that has focus</td>
<td>Esc</td>
</tr>
</tbody>
</table>
### Keys for Navigating a PDF Document

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous screen</td>
<td>Page Up</td>
</tr>
<tr>
<td>Next screen</td>
<td>Page Down</td>
</tr>
<tr>
<td>First page</td>
<td>Home</td>
</tr>
<tr>
<td>Last page</td>
<td>End</td>
</tr>
<tr>
<td>Previous page</td>
<td>Left Arrow or Ctrl + Page Up</td>
</tr>
<tr>
<td>Next page</td>
<td>Right Arrow or Ctrl + Page Down</td>
</tr>
<tr>
<td>Scroll up</td>
<td>Up Arrow</td>
</tr>
<tr>
<td>Scroll down</td>
<td>Down Arrow</td>
</tr>
<tr>
<td>Scroll (when Hand command is selected)</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Zoom in</td>
<td>Ctrl + Equal Sign</td>
</tr>
<tr>
<td>Zoom out</td>
<td>Ctrl + Hyphen</td>
</tr>
</tbody>
</table>

### Keys for Working with Forms

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align selected fields left</td>
<td>L</td>
</tr>
<tr>
<td>Align selected fields right</td>
<td>R</td>
</tr>
<tr>
<td>Align selected fields top</td>
<td>T</td>
</tr>
<tr>
<td>Align selected fields bottom</td>
<td>B</td>
</tr>
<tr>
<td>Align selected fields horizontal</td>
<td>H</td>
</tr>
<tr>
<td>Align selected fields vertical</td>
<td>V</td>
</tr>
<tr>
<td>Center fields horizontally</td>
<td>Shift + H</td>
</tr>
<tr>
<td>Center fields vertically</td>
<td>Shift + V</td>
</tr>
<tr>
<td>Highlight fields</td>
<td>Shift + L</td>
</tr>
<tr>
<td>Show tab numbers</td>
<td>Shift + N</td>
</tr>
<tr>
<td>Document JavaScript</td>
<td>Shift + D</td>
</tr>
</tbody>
</table>

### Keys for Working with PDF Portfolios

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move focus to the next or previous row when in the body of the file list on the left</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>Action</td>
<td>Single-key Accelerator</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td>If pressed in the body of the file list, navigate one level up from within a folder</td>
<td>Backspace</td>
</tr>
<tr>
<td>If pressed when focus is on a row in the file list representing a subfolder, navigate to a subfolder, or open an attachment in Preview mode.</td>
<td>Enter</td>
</tr>
<tr>
<td>If in the body of the file list, move to the first or last row</td>
<td>Home or End</td>
</tr>
<tr>
<td>If in the body of the file list, move to the next or last set of rows to fit the screen</td>
<td>Page Down or Page Up</td>
</tr>
<tr>
<td>Select or deselect all files</td>
<td>Ctrl + A or Shift + Ctrl + A</td>
</tr>
<tr>
<td>If in the body of the file list, extend the selection by adding the next row above or below the selected row</td>
<td>Shift + Up Arrow or Shift + Down Arrow</td>
</tr>
<tr>
<td>Change whether the row with focus is in the selection</td>
<td>Ctrl + Spacebar</td>
</tr>
<tr>
<td>Move focus up or down one row without changing the selection</td>
<td>Ctrl + Up Arrow or Ctrl + Down Arrow</td>
</tr>
</tbody>
</table>

### Keys for Navigating Task Panes

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigate to the next item in the panel</td>
<td>Tab</td>
</tr>
<tr>
<td>Open or close the Task pane</td>
<td>Shift + F4</td>
</tr>
</tbody>
</table>

### Keys for General Navigating

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move focus to Ribbon</td>
<td>F10</td>
</tr>
<tr>
<td>Move to next open document tab (when multiple documents are open in same window)</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Move to previous open document tab (when multiple documents are open in same window)</td>
<td>Ctrl + Shift + Tab</td>
</tr>
<tr>
<td>Close current document</td>
<td>Ctrl + F4</td>
</tr>
<tr>
<td>Close all open documents</td>
<td>Ctrl + Shift + W</td>
</tr>
<tr>
<td>Move focus to document pane</td>
<td>F5</td>
</tr>
<tr>
<td>Move focus to next comment, link, or form field in the document pane</td>
<td>Tab</td>
</tr>
<tr>
<td>Move focus to previous comment, link, or form field in the document pane</td>
<td>Shift + Tab</td>
</tr>
</tbody>
</table>
### Activate selected tool, item (such as a movie clip or bookmark), or command
- Spacebar or Enter

### Open context menu
- Shift + F10

### Close context menu
- F10

### Return to Hand command or Select command
- Esc

### Move focus to next tab in a tabbed dialog box
- Ctrl + Tab

### Move to previous search result and highlight it in the document
- Shift + F3

### Move to next search result and highlight it in the document
- F3

### Search previous document (with Search results displaying multiple files)
- Alt + Shift + Left Arrow

### Search next document (with Search results displaying multiple files)
- Alt + Shift + Right Arrow

### Select text (with Select command selected)
- Shift + Arrow Keys

### Select next word or deselect previous word (with Select command selected)
- Shift + Ctrl + Right Arrow or Left Arrow

### Keys for Working with Navigation Panels

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open and move focus to navigation pane</td>
<td>Ctrl + Shift + F5</td>
</tr>
<tr>
<td>Move focus among the document, status bar and navigation panels</td>
<td>F6</td>
</tr>
<tr>
<td>Move focus to previous pane or panel</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Move among the elements of the active navigation panel</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous or next navigation panel and make it active (when focus is on the panel button)</td>
<td>Up Arrow or Down Arrow</td>
</tr>
<tr>
<td>Move to next navigation panel and make it active (when focus is anywhere in the navigation pane)</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Expand the current bookmark (focus on Bookmarks panel)</td>
<td>Right Arrow or Shift + Plus Sign</td>
</tr>
<tr>
<td>Collapse the current bookmark (focus on Bookmarks panel)</td>
<td>Left Arrow or Minus Sign</td>
</tr>
<tr>
<td>Expand all bookmarks</td>
<td>Shift + *</td>
</tr>
<tr>
<td>Collapse selected bookmark</td>
<td>Forward Slash (/)</td>
</tr>
<tr>
<td>Move focus to next item in a navigation panel</td>
<td>Down Arrow</td>
</tr>
</tbody>
</table>
Foxit PhantomPDF User Manual

Keys for Navigating the Help Window

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Help window</td>
<td>F1</td>
</tr>
</tbody>
</table>

Keys for Accessibility

<table>
<thead>
<tr>
<th>Action</th>
<th>Single-key Accelerator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change reading settings for the current document</td>
<td>Shift + Ctrl + S</td>
</tr>
<tr>
<td>Reflow a tagged PDF, and return to unreflowed view</td>
<td>Ctrl + 4</td>
</tr>
<tr>
<td>Activate and deactivate Read Out Loud</td>
<td>Shift + Ctrl + Y</td>
</tr>
<tr>
<td>Read only the current page out loud</td>
<td>Shift + Ctrl + V</td>
</tr>
<tr>
<td>Read out loud from the current page to the end of the document</td>
<td>Shift + Ctrl + B</td>
</tr>
<tr>
<td>Pause reading out loud</td>
<td>Shift + Ctrl + C</td>
</tr>
<tr>
<td>Stop reading out loud</td>
<td>Shift + Ctrl + E</td>
</tr>
</tbody>
</table>

Command Lines

Here are some command lines that can be used to Foxit PhantomPDF:

```
<Reader Path> [/register] | [PDF Path] [/pwd] /A [...] [...] | [/pwd] /p | /t <PDF Path> [Printer]
```

<table>
<thead>
<tr>
<th>Command</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>-Register</td>
<td>Set Foxit PhantomPDF as default reader.</td>
</tr>
<tr>
<td>-pwd&lt;password&gt;</td>
<td>Input the password of the protected PDF documents.</td>
</tr>
<tr>
<td>/p &lt;PDF path&gt;</td>
<td>Print the document with default printer</td>
</tr>
<tr>
<td>/t &lt;PDF Path&gt; [Printer]</td>
<td>Print the document with designated printer</td>
</tr>
<tr>
<td>&lt;PDF Path&gt; /A [...] [...]</td>
<td>Open a PDF document with a command to exactly specify what to display and how to display</td>
</tr>
<tr>
<td>&lt;PDF Path&gt; /A reverse=1/0</td>
<td>Read in reverse view with the value of “1”; normal view with “0”.</td>
</tr>
</tbody>
</table>
Contact Us

Feel free to contact us should you need any information or have any problems with our products. We are always here, ready to serve you better.

- **Office Address:**
  Foxit Software Incorporated  
  41841 Albrae Street  
  Fremont, CA 94538  
  USA

- **Sales:**
  1-866-680-3668

- **Support & General:**
  1-866-MYFOXIT, 1-866-693-6948, or 1-510-438-9090

- **Fax:**
  1-510-405-9288

- **Website:**
  www.foxitsoftware.com

- **E-mail:**
  Sales - sales@foxitsoftware.com  
  Marketing - marketing@foxitsoftware.com  
  Technical Support - enter a trouble ticket via our Support Portal  
  Website Questions - webmaster@foxitsoftware.com