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END USER LICENSE AGREEMENT  

  

IMPORTANT NOTICE 

 

Thank you for choosing Foxit PDF Editor Product (PDF Editor). This license is the 

legal agreement (Agreement) between you, the customer who has acquired PDF 

Editor (―You‖) and Foxit Corporation (―Foxit‖). Please read this agreement 

carefully.  

 

Foxit is only willing to provide PDF Editor to you on the condition that you accept 

all of the terms contained in this Agreement. You accept all of the terms by 

installing or using PDF Editor. 

  

If you did not acquire PDF Editor from Foxit, or an authorized Foxit distributor, 

then you may not enter into this Agreement or use PDF Editor. No other party 

has the right to transfer a copy of PDF Editor to you.  

 

If you are unwilling to accept this Agreement, do not use PDF Editor. If you have 

already paid for PDF Editor with having a prior opportunity to review this 

Agreement, and are now unwilling to agree to these terms, you may, within 

thirty (30) days after the date on which you acquired PDF Editor, return it to 

Foxit, or the authorized distributor from whom you acquired it, along with its 

original packaging and proof-of-purchase, for a full refund. 

 

Notwithstanding anything herein to the contrary, Foxit authorized distributors 

do not act as agents of Foxit, and such distributors may not enter into any 

contracts on behalf of Foxit Corporation. No authorized distributor has the 

authority to modify the terms of this Agreement.  

 

1. OWNERSHIP 

 

PDF Editor (exclusive of its physical packaging) is licensed. It is not sold, even if 

for convenience we make reference to words such as ―sale‖ or ―purchase.‖ PDF 

Editor is protected by copyrights and other intellectual property rights. You 

agree that all worldwide copyright and other intellectual property rights in PDF 

Editor and all copies of PDF Editor, however made, are the exclusive property of 

Foxit. All rights in PDF Editor not expressly granted to you in this Agreement are 

reserved by Foxit. There are no implied licenses under this Agreement. 

 

2. GRANT of LICENSE 
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This agreement grants you the following rights: 

Installation and Usages - You may install and use one copy of PDF Editor on a 

single computer at a time and only by one user at a time. 

 

Network Storage/Use - You may also store or install a copy of PDF Editor on a 

storage device, such as a network server, used only to install or run PDF Editor 

on your other computers over an internal network; however, you must acquire 

and dedicate a license for each separate computer on which PDF Editor is 

installed or run from the storage device. 

 

Concurrent Use - A license for PDF Editor may not be used concurrently on 

different computers, however, this agreement does allow a licensed user to 

install PDF Editor on both a work computer and a home computer, provided the 

PDF Editor is not in use on both machines at the same time. 

 

3. OTHER RIGHTS AND LIMITATIONS 

 

Limitations on Reverse Engineering, Decompilation, and Disassembly - You may 

not reverse engineer, decompile, or disassemble PDF Editor, except and only to 

the extent that such activity is expressly permitted by applicable law not 

withstanding this limitation. 

 

Separation of Components – PDF Editor is licensed as a single product. Its 

component parts may not be separated for use on more than one computer. 

 

Rental - You may not rent or lease PDF Editor. 

 

Software Transfer - You may permanently transfer all of your rights under this 

Agreement, provided you retain no copies, you transfer all of PDF Editor 

(including all component parts, the media and printed materials, any upgrades 

and this Agreement), and the recipient agrees to the terms of this Agreement. 

If your copy of PDF Editor is an upgrade, any transfer must include all prior 

versions of PDF Editor. 

 

Termination - Without prejudice to any other rights, Foxit Corporation may 

terminate this Agreement if you fail to comply with the terms and conditions of 

this Agreement. In such event, you must destroy all copies of PDF Editor and all 

of its component parts. 

 

Development License Restrictions - These restrictions apply to a licensee who 

develops Application Software that utilizes PDF Editor in a commercially 

distributed application. 

 

(i) Must purchase a license of PDF Editor for each copy of the Application 
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Software sold; 

(ii) PDF Editor is not the sole or primary component of such Application 

Software;  

(iii) You must give proper acknowledgment of the copyright of Foxit 

Corporation;  

(iv) Must not be used to create a software application that competes with or is 

intended to compete, directly or indirectly, with PDF Editor;  

(v) The Application Software must add significant value to the PDF Editor. 

 

All other uses that fall outside the scope of this Agreement must receive the 

written permission of Foxit. 

 

4. DOCUMENT COPYRIGHTS 

 

You should not use PDF Editor to alter protected PDF documents without a valid 

password or permission granted by the copyrights owner. Furthermore, for 

unprotected PDF documents, you must also observe the copyrights of the 

documents. Foxit will not be liable to any loss caused directly or indirectly by 

copyrights infringing when you use PDF Editor to alter documents in any 

improper way. 

 

5. LIMITED WARRANTY 

 

Foxit, warrants that PDF Editor contained herein will, for a period of thirty (30) 

days from the date of delivery, perform substantially in accordance with the 

accompanying documentation. NO OTHER WARRANTIES. Foxit disclaims all 

other warranties, either express or implied, including but not limited to implied 

warranties of merchantability and fitness for a particular purpose, with respect 

to the Software, the accompanying written materials. 

 

In the event of any breach of warranty or other duty owed by Foxit, Foxit's 

entire liability and your exclusive remedy shall be, at Foxit’s option, either (a) 

return of the price paid by you for the product (not to exceed the suggested U.S. 

retail price) if any, (b) repair or replacement of the defective product. This 

Limited Warranty is void if failure of the product has resulted from accident, 

abuse, or misapplication. Any replacement product will be warranted for the 

remainder of the original warranty period or ten (10) days, whichever is longer. 

 

6. NO LIABILITY FOR CONSEQUENTIAL DAMAGES 

 

In no event shall Foxit be liable for any damages whatsoever (including but not 

limited to damages for loss of business profits, business interruption, loss of 

business information, or any other pecuniary loss) which results from the use or 

inability to use PDF Editor, even if Foxit has been advised of the possibility of 
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such damages. Because some states/jurisdictions do not allow the exclusion or 

limitation of consequential or incidental damages, the above limitations may not 

apply to you. 

 

7. UPDATES AND SUPPORTS 

 

When you purchase a Foxit Editor license from Foxit, you receive more than the 

usual right to use the current version of the software. Along with a perpetual 

license to the current official version of the product, you receive the following:  

 

 Unlimited access to software updates for one year from the date of license 

purchase, with no limit on minor or major release.  

 Unlimited free technical support by e-mail for one year.  

 

To receive the above services, you need to register your purchased copy of PDF 

Editor with Foxit. Upon registration, Foxit will collect your information including 

name of you or your organization, email address as well as unique CD key of 

your purchased copy of PDF Editor. Foxit will retain those information for 

providing the above services. Foxit will not reveal your information to any third 

party unless required doing so by law. 

 

8. GOVERNING LAWS  

 

If PDF Editor was purchased in the United States, this Agreement is governed by 

the laws of the state of California; otherwise, local laws may apply. 

 

9. GENERAL PROVISIONS 

 

If any part of this Agreement is found void and unenforceable, it will not affect 

the validity of the balance of this Agreement, which shall remain valid and 

enforceable according to its terms. This Agreement shall not prejudice the 

statutory rights of any party dealing as a consumer. This Agreement may only 

be modified by a writing signed by an authorized officer of Foxit. Updates may 

be licensed to you by Foxit with additional or different terms. This is the entire 

agreement between Foxit and you relating to PDF Editor and it supersedes any 

prior representations, discussions, undertakings, communications or 

advertising relating to PDF Editor. 

 

Should you have any questions concerning this Agreement or if you desire to 

contact Foxit Corporation for any reason, please write to Foxit Corporation, 

39819 Paseo Padre Parkway, Fremont, CA 94538, USA, or send us an email at 

sales@foxitsoftware.com. 

 

mailto:sales@foxitsoftware.com
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Chapter 1 – Overview 
 

The Foxit PDF Editor extends the usability of PDF documents by enabling the 

user to edit PDF files in a What You See Is What You Get (WYSIWYG) way. Foxit 

PDF Editor is proud to be the first, and up to the time when this manual was 

printed, the only PDF Editor that allows you to modify existing PDF documents in 

an easy and efficient way, yet retain all rich features for viewing and printing 

provided by PDF document format.  

The Foxit PDF Editor is a revolutionary program in editing PDF files. Its goal is to 

give the user a friendly editing interface and make the user feel that they are 

editing a common document, like with a common editor. Foxit PDF Editor offers 

the user flexibility to modify or customize anything in the page contents of a PDF 

file. 

PDF Document Concepts 

PDF stands for Portable Document Format, which can be used to exchange and 

distribute documents in a manner independent of the application software, 

hardware, and operating system used to create it. 

A PDF document contains one or more pages. Each page in the document may 

comprise a sequence of objects. An object can be a text object which contains 

a number of text characters, a graph object which contains straight lines, 

rectangles, and cubic curves, an image object which is made of a set of colored 

pixels, or a shading object which contains a smooth transition between colors 

across an area. 

Each object contains a series of attributes that determine what the object looks 

like. Text Objects use fonts to specify how the characters look, and font sizes 

to specify how large those characters are. Graph objects have attributes like 

line width, and fill type and more. Shading objects offers linear and radial 

gradients. All objects have common attributes like position, size, and 

orientation. There are many more attributes defined for PDF page objects, 

please refer to the following chapters for a detailed explanation of all object 

attributes. 
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Why Foxit PDF Editor   

Edit PDF documents directly! As PDF becomes more important in the field of 

document publishing, there is an increasing need to use and edit PDF 

documents.  

This demand had led to the conversion of PDF to other types of files, such as 

Microsoft Word file. However, this usually causes data or format loss during the 

conversion process. Furthermore, PDF files are converted into other types of 

files and then converted back. Often, things have been changed during the 

double conversion. Hence, users have to almost rebuild the whole document 

structure frequently. 

What if there is a way to edit PDF documents directly that is reliable, and easy 

to use? The answer is Foxit PDF Editor, the first and only REAL editor for PDF 

files. 

PDF Document Copyrights Issue 

Many PDF documents come with copyrights reserved by the author, or owner of 

the intellectual property. And in many cases the owner of copyrights may 

prohibit anyone else to alter the document in any way. 

Foxit PDF Editor by no means is designed to breach those copyrights. However, 

it’s up to the users of Foxit PDF Editor to observe the copyright, if the document 

is not protected in any technical way. 

With Foxit PDF Editor, you are able to edit any user password protected 

documents. But you can only Save As the document if you have no password. If 

a document is not protected by password but is encrypted with modification 

permission prohibited, it cannot be edited by Foxit PDF Editor. 

Updating Foxit PDF Editor 

Checking for updates detects new versions of Foxit PDF Editor and keeps you 

updated with the latest release. You can detect updates from the Help menu, 

and then download the latest version directly from Foxit website.  

 Choose Help > Check for Updates Now… 

 Foxit PDF Editor will automatically check if there is an update to the latest 

version. 

 If your Editor is the latest version, it will tell you ―This is the latest version‖. 
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 If an update is available to the latest release version, click ―Yes‖ to know 

more information about this new version. 

 Click to visit http://www.foxitsoftware.com/downloads/index.php . 

 Select and download the latest version of Foxit PDF Editor to finish updating. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.foxitsoftware.com/downloads/index.php
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Chapter 2 – What’s New 

What’s new in Version 2.1 

Foxit PDF Editor 2.1 has introduced some new features and enhancements: 

 Shading Object Support 

Enables users to create or edit a shading object, which has a smooth 

transition between colors across an area. Foxit PDF Editor offers linear and 

radial gradients for users to choose. 

 Converting Text to Path 

Able to convert the selected text object(s) into path(s), which will meet the 

pre-press requirement. For those computers which do not support or 

display certain embedded fonts, this new feature helps to overcome that 

issue. Foxit PDF Editor also offers a menu option for users to convert the 

entire text in a PDF to path. 

 Adding Shapes in Non-Graphics Editing Mode 

Provides several simple auto shapes that users can insert into a PDF in the 

non-graphics editing mode. With this new version, users can easily add a 

simple shape in the main interface of Foxit PDF Editor without having to 

enter into the graphics editor.  

 Removing all evaluation marks at once 

Removes all the evaluation marks on a PDF file that was added by Foxit PDF 

Editor 2.1 all at once by selecting "Remove Evaluation Marks" under the 

Help menu for registered users. 

 Alignment Support 

Automatically places or aligns the selected objects evenly with the Objects 

Align button on the toolbar. This feature helps to make your structured PDF 

pages more professional. 

 Image Transparency Support 

This allows users the ability to set image transparency with alpha channel. 



14 
 

By inputting values of between 0% and 100% in Image Alpha text field, the 

image goes from fully transparent to fully opaque. 

 Checking for Update 

This option under the Help menu detects the new version of Foxit PDF Editor 

and keeps you updated with the latest release. 

 Improved Text Objects Creating 

Adds an Object attributes option in Add new text objects dialog box, making 

it easier for users to set preferences for text objects, such as font size, text 

mode, word space, color, etc. 

 Property List Setting 

This setting determines to either show or hide the Property List when 

launching Foxit PDF Editor by doing settings in the Options dialog box. 

 New Shortcut Keys 

Adds several new shortcut keys to make Foxit PDF Editor easier to use, i.e. 

ESC is shortcut for saving and exiting the in-place editing mode, Alt+Delete 

fills a selection with the foreground color, Ctrl+Delete fills a selection with 

the background color, and Ctrl+D deselects a selection. 

Many Bug Fixes 

What’s new in Version 2.0 

The following is a list of improvement introduced in Foxit PDF Editor 2.0. 

 New Toolbars 

Toolbars have been renovated thoroughly. New buttons for many functions 

have been added to the toolbars. These toolbars look professional and will 

greatly increase users’ productivity. 

 Improved Status Bar 

 Now, users can specify page number or zooming factor in status bar. 

 Floating Property List 

Newly-designed property list can be dragged anywhere on screen and be 
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hidden or shown at anytime. This allows users to view any part of a page. 

Users will be able to modify object properties and see the changes instantly. 

In addition, special setting dialogs can be invoked for users to change 

complex settings, such as colors setting, clipping setting and dashing line 

setting. 

 Default Settings 

Version 2.0 allows users to specify more default settings of parameters and 

behaviors inside Edit/Option dialog. 

 Drag Action 

In previous versions, users had to explicitly enter values to specify 

parameters. Now with Version 2.0, users can use a mouse to drag the 

control points of an object to manipulate it and set the parameter implicitly. 

For instance, a user can drag the control point of a text object to resize it. 

 Flexible Image Editor 

Users may double click on an image to enter the image editor.  

 Several new tools have been added to image editor, including Magic 

Wand tool, Polygonal Lasso tool, and Layer tool.  

 Other tools have been improved, including Selection tool, Dodge tool, 

and Burn tool.  

 In previous versions, users can only undo or redo the latest action in 

Image Editor. This new version allows users to Undo/Redo multiple 

steps, as long as the program doesn’t reach the memory limit of the PC.  

 With Version 2.0, users can edit images from multiple PDF files at the 

same time. Image areas can also be copy and pasted across different 

files.  

 Several short-cut keys have been added to speed up image operations. 

 

 Intuitive Layout, Graphics, and Clipping Editor 

In previous versions, layout, graphics, and clipping path are edited in 

separate small dialogs which do not show the PDF page content behind the 

path. This is very counter-intuitive. Version 2.0 allows users to edit them in 

the main window, with a bigger and consistent view showing the PDF 

content behind them.  

 Editing Encrypted PDF 
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Version 2.0 allows users to read and edit encrypted PDF files, which is a new 

and useful feature. 

 Extensibility 

Version 2.0 adopts a new framework consolidating different function 

modules and allows for future extension to add more modules, e.g. form 

design module. 
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Chapter 3 – Getting Started 
 

This section gives you an overview of Foxit PDF Editor 2.1, including system 

requirement, installation, registration, work area, un-installation, etc. 

Installing Foxit PDF Editor 

Windows System Requirements 

Foxit PDF Editor runs successfully on:  

 Windows 2000         

 Windows XP     

 Windows Server 2003  

 Windows Vista  

 Windows 7 

How to Install? 

Step One – Download the Package 

Foxit PDF Editor is distributed via web download. If you have downloaded full 

retail package, you just need to UNZIP the package into a temporary folder, and 

then start the ―setup.exe‖ application.  

Step Two – Installing the Software 

After running the Foxit PDF Editor setup program, you will need to execute the 

following steps to finish setup: 

1. Welcome Screen – Click Next button to continue, click Cancel button to 

abort the setup. 
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Welcome Screen 

 

2. License Agreement -- What you are seeing is Foxit PDF Editor License 

Agreement (see the following figure). This is common for nearly all software. 

Only after you click "I agree" button can you continue to install. 

 

 

License Agreement 

 

3. Choose Installation Type: 
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Installation Type Choosing Screen 

 

In this screen you can click Default button to expressly finish Foxit PDF Editor 

Setup, or click Custom button to complete the setup step by step.  

 

 If you select Default, you agree to use the default setup configuration for 

the installation, and the setup progress will proceeds in the background. 

Here is a list of the default setup configurations: 

 

 The destination folder is set to ―C:\Program Files\Foxit Software\PDF 

Editor‖. 

 A desktop shortcut Foxit PDF Editor.exe is created. 

 A "Program Group" called "Foxit PDF Editor" is created, it includes two 

shortcuts, the first is Uninstall, and the second is PDF Editor.   

 The program is added to the Control Panel > Add or Delete Program. 

 A registry key is created as" HKEY_LOCAL_MACHINE\Software\ Foxit 

Software\PDF Editor ". 

 The Foxit PDF Editor installation directory is added to the system path.  

 Foxit PDF Editor automatically runs after setup is finished. 

 

 If you select Custom, you can change the default settings, but have to 

configure the setup one by one. Here are steps you will go through: 

 

First, after you click Custom button, you will see the following screen: 
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Settings Screen 

 

 Destination folder: You can directly input a destination path in this box, or 

click on Browse button to select a destination folder for Foxit PDF Editor. 

 

 Add a desktop shortcut: Check the box will create a shortcut of Foxit PDF 

Editor.exe on desktop. If you don’t want a desktop shortcut, uncheck it. 

 

 Add an Icon in the Start Menu: Check the box will create a shortcut of 

Foxit PDF Editor.exe on the Start menu. If you don’t want a Start menu shortcut, 

uncheck it. 

  

Now, click Next button to continue the setup, and you should see the following 

screen： 

 

 
Confirmation Screen 
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This screen lists all setup settings you have selected in the previous step. You 

can click Back to change the settings, or click Install to enter into the next 

screen show as below: 

 

 
Finishing Screen 

 

The Run Foxit PDF Editor is checked by default. And when you click Finish 

button the Foxit PDF Editor program will automatically launch. If you don’t want 

to run Foxit PDF Editor after installation, uncheck the box. 

 

Installing License Key 

1. If you purchase online, you will be able to immediately download a small 

temporary key. 

 

 Downloading a Temporary License Key 

 

1) Make sure you know the folder where you have put PDF Editor. If you 

don't know, please do a search on your computer for "pdfedit.exe".  

The default is: ―C:\Program Files\Foxit Software\PDF Editor‖. 

 

2) Immediately after you purchase Foxit PDF Editor, you will be asked to 

download a temporary license key. 

 

3) Press the "Download Temporary License Key" button as shown below: 
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4) In the file download prompt box, click Save button to store the key file 

into where the PDF Editor is saved. The temp key file name is 

―pedkey.txt‖.  

 

Notes:  

    

 The key file must keep its original name (pedkey.txt). 

 The key file must store into the same folder with PDF Editor.  

 

Finally, double click on PDF Editor or pdfedit.exe to run the application without 

any limitation. 

 

2. After your online purchase order verified, Foxit will send you a formal license 

key within an email. The license key is sent as a attachment with its name as 

―pedkey.txt‖ 

  

   Here are two examples on how you can save the license key in the Outlook 

Express and Open Web Mail. 

 

Using Outlook Express  

 

1) Close Foxit PDF Editor, and open the Foxit mail with formal license key in 

your Outlook mail list. 

 

2) Click the attachment file, and click Save Attachment menu. 

  

3) In the pop-up Save As dialog box, click Browse button to search the 

folder where PDFEditor.exe is saved, and then save the pedkey.txt into 

that folder.  

 

4) Note: pedkey.txt must be stored into the right place where 

PDFEditor.exe exists; otherwise the product will not be licensed. 

 

5) Restart Foxit PDF Editor. It is now licensed. 
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Using Open Web Mail 

 

1) Double click the Foxit mail with formal license key in the Inbox of your 

Open Web Mail. 

 

2) Scroll down the Message Display window to the message bottom, and 

you can find a small attachment prompt box shown as below: 

 

3) Right click the Download link and Choose Save Target As menu. 

 

4) In the pop-up Save As dialog box, click Browse button to search the 

folder where PDFEditor.exe is saved, and then save the pedkey.txt into 

that folder.  

 

Note: pedkey.txt must be stored into the right place where 

PDFEditor.exe exists; otherwise the product will not be licensed. 

 

5) Restart Foxit PDF Editor. It is now licensed. 

Registering Foxit PDF Editor 

After purchasing Foxit PDF Editor, please do one of the following to register your 

key:  

 Close Foxit PDF Editor, save the key file into the directory where you 

installed the application. 

 Run Foxit PDF Editor > Help > Install License Key > A registration box will 

pop up. Open the received key file, copy the key contents into the box 

indicated > click the Register the Key button. 

Note:  

 To check if you have registered successfully, please go to ―Help‖ > ―About 

PDF Editor‖ and see if your name is shown at the bottom left corner.  

 After registering successfully, you can remove all the evaluation marks 

which are added by Foxit PDF Editor 2.1 at one time before you purchase it. 

To remove all the evaluation marks, please select ―Help‖ > ―Remove 

Evaluation Marks‖. 
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Uninstalling Foxit PDF Editor 

To uninstall Foxit PDF Editor, do one of the following: 

 Click Start > All Program Files, and find Foxit PDF Editor, and last click 

Uninstall. 

 Select Control Panel > Delete or Add Program, and then select Foxit 

PDF Editor to uninstall. 

 Find the PDF Editor installation directory named ―Foxit Software‖, and then 

select Uninstall.  

Work Area 

The Foxit PDF Editor workspace consists of the main application window (see 

Figure3-1) where by default contains the Title bar, Menu bar, Tool bar, and 

areas called Document Pane, Properties Pane, and Status bar.  There is also an 

Image Editor (see Figure3-2), Graphic Editor (see Figure3-3), Shading Editor 

(see Figure3-4) and Layout Editor (see Figure3-5) and where you can edit 

images, modify graphics, create or edit a shading object, and design page 

layout. 

 

Figure3-1: The Document window 

 

Properties Pane 

Navigation Toolbar 

Documents Pane 

Title Bar 

Menu Bar 

Tool Bar 
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Figure3-2: The Image Editor window 

 

 

Figure3-3: The Graphic Editor Window 
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Figure3-4: The Shading Editor Window 

 

 

Figure3-5: The Page Layout Editor Window 
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Customizing the Work Area 

 

As you get acquainted with Foxit PDF Editor, you can set up your Editor work 

environment. The more you learn about its potential, the more you can take 

advantage of its features, tools, and options. 

 

About Title Bar 

 

The Title bar displays the name of program itself and the file name of a 

document currently displayed in the Document pane. 

 

About Menu Bar 

 

The Menu bar provides full access to the functions of the Foxit PDF Editor. You 

can access the menu by either using the mouse or keyboard. Keyboard 

shortcuts, when available, are printed on the right of the menu item. 

 

About Toolbars 

In addition to menu commands, you can access several features using toolbar 

buttons. When you point to a button, the "Ready" on the left side of Status bar 

can synchronously report action for you. 

The toolbar can be repositioned, you can move the toolbar to the top area, or 

you can drag the toolbar into the document pane to create a floating toolbar. You 

can drag the bar back to its original position. 

The following briefly describes each toolbar and its default buttons. 

      A                B          C            D                  E 

                     

F               

A. Main Toolbar    B. Edit Toolbar    C. Zoom Toolbar    D. Page Toolbar   E. 

Text Toolbar     F. Object Toolbar 
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Main Toolbar: Use the main file tools to create a new page, open, save, or print 

a PDF document. 

Edit Toolbar: Use the edit tools to cut, copy, and paste object in a PDF 

document, and to undo and redo changes that you might have made to a PDF 

file. 

Zoom Toolbar: It helps you adjust the view of your PDF documents, and it 

included simple tools as Zoom In and Zoom Out. 

Page Toolbar: These tools allow you to navigate the pages in a PDF document 

(forward and backward) by jumping to the first or last page in a document, lay 

out a page design, or to insert or delete a page. 

Text Toolbar: These tools allow you to input graphics keyboard, merge or split 

text, remove font kerning, and import Windows fonts. 

Object Toolbar: Use the object tools to edit, rotate, delete selected objects, 

add text, graphic, image or shading objects, or create new images for the 

document. You can select a type of object mode to edit the object. 

About Status Bar 

The Status Bar reports the current cursor actions. It also allows you to navigate 

one page at a time, jump to the first or last page, go to a specified page number, 

or set the page view magnification.  

 

 

 

 

The Document Window 

The Document Pane is the main area for viewing the document and editing the 

page contents. You can use the toolbars and Properties pane to work with the 

document. You can use the navigation toolbar to page through a document, use 

zoom tool to magnify or reduce a view, and use scroll bar to scroll up or down a 

page. Within a page, you can also drag selected object(s) to any location you 

want. When you drag an object, the cursor will change to a hand. 

In addition, you can also use the Context Menu to work in the document pane. 

View magnification Navigation Tools 
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Simply right-click anywhere in a page and the Context Menu will pop up at once. 

The Properties Pane 

The Properties pane provides easy access to the tools without cluttering your 

workspace. The Properties pane can include one or more tabs, each containing 

common attributes. For example, the Text tab can include attributes common to 

texts, the Image tab can include attributes common to images, the Path tab can 

include attributes common to graphics, and the General tab can include 

attributes common to all the above objects. 

                      A     B    C     D      E     F 

 

 

                   

 

              

 

 

 

 

 

 

 

 

 

 

 

 

You can arrange the Properties pane in the workspace to suit your preferences. 

For example, you can drag it over the workspace, drag one of the borders to 

adjust its size, or hide/show it. If the Properties pane is hidden, use the View 

menu or right-click Context menu to check the Properties List to show it again. 

 

As you select a type of object in the Document pane, a corresponding object tab 

will appear in the Properties pane. For example, you select a text object, and a 

Text tab will appear. If you select more than one type of objects, a General tab 

which includes common attributes will appear too. For example, you select a 

text and an image object, and then the Text tab, the Image tab and the General 

tab will be presented at the same time in the Properties pane. 

Object Properties Name List Object Properties Value List 
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A. Page Tab: This tab only applies to layout edit mode. When your screen is 

switched to the Layout Editor window, this tab will be activated for work. 

B. Text Tab: When a text object is selected in the Document pane, this Text tab 

will appear in the Properties pane including all properties that apply to the 

selected object. 

C. Path Tab: When a graphic object is selected in the Document pane, this Path 

tab will appear in the Properties pane including all properties that apply to the 

selected object. 

D. Image Tab: When an image object is selected in the Document pane, this 

Image tab will appear in the Properties pane including all properties that apply 

to the selected object. 

E. General Tab: When more than one type of objects is selected in the 

Document pane, this General tab will appear in the Properties pane,  containing 

all properties that are common to all the selected objects. 

F. Shading Tab: When a shading object is selected in the document page, this 

Shading tab will appear in the Properties pane, containing all properties that 

apply to the selected object. 
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Chapter 4 – Using Foxit PDF 

Editor 
 

 

This section gives a short overview on how to get started using PDF Editor. Use 

this section to learn how to launch Foxit PDF Editor, to open documents, and to 

perform common editing operations.  

Launching PDF Editor 

From the Programs Group 

 Click on Windows ―start‖ button, select ―All Programs‖, click on ―Foxit PDF 

Editor‖ group, then click on ―Foxit PDF Editor‖ icon; 

From the Desktop 

 Go to your desktop, find the ―Foxit PDF Editor‖ icon, double click on it;  

From the Installation Directory 

 Go to the directory where you installed Foxit PDF Editor, double click on the 

PDFEDIT.EXE icon. 

From the Run command line 

 Click Start, click Run, in the Open field, input the full path where Foxit PDF 

Editor locates, and then click Ok button. 

Opening PDF Documents  

There are several ways to load PDF documents from the PDF Editor application. 

Using File Menu 

 Select File menu from the Menu bar, and select Open command. In the Open 

dialog box, select and open one or several PDF documents. 

 Foxit PDF Editor can record the reading history, and list out four PDF 

documents at most. So you can select one or several PDF document listed 

under File menu to continue reading. 

Using Open Toolbar 
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 In the Toolbar, click the  Open button, and then in the Open dialog box, 

select one or several PDF documents to open. 

Using Shortcut Key 

 Directly press Ctrl + O to pop up the Open dialog box, and then select one 

or several PDF documents to open in this dialog box. 

Using Command Line 

 Enter the path for the PDF document right after ―pdfedit.exe‖ in the 

command line box. 

The loaded PDF documents are displayed in the Document pane; you can view 

and edit them. 

Viewing PDF Documents  

Foxit PDF Editor provides tools that can help you navigate a PDF file and find 

your way around a large document. Pages can be resized and scrolled to make 

them easier to see. You can jump directly to a page number and step through a 

document page by page. 

Zooming in or zooming out 

To magnify or reduce the view, do one of the following: 

 Choose View > Zoom In or Zoom Out on Menu Bar. 

 Use the keyboard shortcut Alt + + or Alt + -. 

 Click the Zoom In icon  or Zoom Out icon  on the Toolbar. 

 Select or input a magnification percentage in the Magnification Percentage 

Area on the Status Bar, and press Enter. 

Navigating pages 

To move around in multiple-page documents, do the following: 

1. Going to the next or previous page 

Do one of the following: 
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 Choose Document > Previous page or Next Page on Menu Bar. 

 Use the keyboard shortcut Alt + P or Alt + N. 

 Click the Previous Page icon  or the Next Page  icon on 

Toolbar or Status Bar. 

2. Going to the first or last page 

Do one of the following: 

 Choose Document > First Page or Last Page on Menu Bar.  

 Use the keyboard shortcut Alt + T or Alt + L. 

   Click the First Page icon  or the Last Page icon  on 

Toolbar or Status Bar. 

3. Going to a specific page 

Do one of the following: 

 Choose Document > Go to page… > input the specific page    

number > OK. 

 Select or input the specific page number on the Current Page 

Number Box   on the Status Bar, and press Enter. 

 Use the keyboard shortcut Ctrl + G. 

 Select Go to page… in the right-click Context Menu. 

Scrolling 

 Use the scroll bars to scroll around a view in case parts of the page are not 

visible. 

 

Creating PDF Documents 

Using Foxit PDF Editor, not only can you easily create a new PDF document, but 

you can customize the page and content size according to user’s output needs. 

In the following, we briefly describe the process of creating a simple PDF 

document. 

To create a new blank document: 

The New command lets you to create a blank document. 
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1. First do one of the following: 

 Click the New button  on the Toolbar 

 Select File > New from the Menu bar 

 Press Ctrl + N on the keyboard 

 

2. If desired, on the pop-up New Page Attributes dialog box, set up the Page 

Size, or click the Allow Specify Content Size button to set up the Content 

Size. 

 

Note: If you want to insert multiple pages with same settings, you can use 

the Page options in the Options dialog box to set your preferences.  

 

3. Click Ok button to produce the blank document. 

 

To write content in the blank document 

 

At present, Foxit PDF Editor doesn’t support direct writing on the page. There 

are several substituted ways to input contents described in the following. 

 

 Copy -- You can copy a page or part of a page into the clipboard, then paste 

into the blank document.  

 

 Insert -- You can use the Add feature to insert text, image and graph 

objects into the blank document. For information how to insert objects, 

please see Inserting New Objects. 

 

To add more pages to the new document 

 

At present, Foxit PDF Editor allows you to create a document starting with one 

page. There is not an option for you to specify how many pages you want to 

create. Therefore, if you want to make the document with more than one page, 

you can use Insert Page feature to add more blank pages to the new document.   

 

See also: Inserting Blank Pages. 

 

To save the new document 

 

Use the save command to save the document. Now, a new PDF document is 

produced. 
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Undoing and Redoing 

Foxit PDF Editor provides chances for you to undo and redo previous actions. 

You can undo and redo any type of editing (insert, delete, or change) you have 

done. You can also set an option to decide the size of the undo buffer. For details, 

please refer to Setting Options.   

To undo previous actions, do one of the following: 

 Select Edit > Undo from the Menu bar. 

 Use keyboard shortcut Ctrl + Z.  

To redo previous actions, do one of the following 

 Select Edit > Redo from the Menu bar. 

 Use keyboard shortcut Ctrl + Y.  

Saving PDF Documents 

In Foxit PDF Editor, you can choose to save a modified PDF file with the same 

name or use another name. When you directly save the changed file, Foxit PDF 

Editor will pop up a warning prompt asking you if you want to continue the save 

operation. 

To save a PDF file, use one of the following ways: 

 Select File > Save from the Menu bar. 

 Click the Save button on the toolbar. 

 Use the keyboard shortcut Ctrl + S. 

To save a PDF file with another file name, do one of the following: 

 Select File > Save As from the Menu bar, enter a new name for the file and 

click Save. 

 Use the keyboard shortcut Ctrl + Shift + S, enter a new name for the file 

and click Save. 

Rollback Saving 

With Foxit PDF Editor, you can not only undo the modification actions, also can 

undo the saving actions by rollback saving. 
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Rollback Saving is something to make the document on your hard drive restore 

to its original modified state when it is open, while keeping modifications in the 

current document untouched.  

To undo saving actions, do the following: 

 Select File from the Menu bar, and select Rollback Saving in drop-down list.  

 

Closing PDF Documents 

 

1. To close a document while keeping the program window open, do one of the 

following: 

 

 Select File > Close from the Menu bar. 

 

 Simply click the Close button on the Menu bar 

 

Note: The close button on the Title bar will close the application. 

 

2. To close all open documents while keeping the program window open:  

 

• Select File > Close All from the Menu bar. 

Setting Options 

You can use the Options dialog box in Foxit PDF Editor to define a default page 

layout, customize preferences for text objects, customize styles for graphic 

objects, and specify other settings for the document. 

To set options 

1. Select Edit > Options from the menu bar, or press Alt + O keyboard. 

2. In the Options dialog box, select one of the options from the left list. 

3. Set options for that feature and then click Ok. Click the Restore Default 

button to leave the settings unchanged. 

Page Options 

Choose the Page Options brings up the page options dialog box (see figure 

below). This controls where the inserting page will display, and allows you to 

specify the page size to suit your preference. 
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Note: After you exit the program, all the page settings will be restored to be 

default.   

The following options for Page can be set: 

Insert Page 

 Before Current Page -- The new page will always be created prior to 

the current displayed page. By default, this option is checked. 

  After Current Page -- The new page will always be created after the 

current displayed page.  

 Page/Content Size  

 Left margin --   Sets the distance between the left edge of the page and 

the left edge of left-aligned lines. 

 Bottom margin -- Sets the distance between the bottom of the page and 

the bottom of the last line on the page. 

 Width --   Enter dimensions for the width of the paper/content size  

 Height --   Enter dimensions for the height of the paper/content size  

Note: Only when you click Allow Specify Content Size, the options under 

Content Size can be activated for edit. 

Text Options 

Choosing the Text option brings up the Text option dialog box (see figure below), 
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which allows you set your preferences for inserting text. 

 

Note: After you exit the program, all the settings will be restored to default.  

The following options for Text can be set: 

 Font name -- Displays the font information included in a document. You 

can click the Import Windows Font button to import a Windows font.  

Note: If you want the imported windows font to be the default font when 

you insert text every time, you must check the option ―set as default font 

after being imported‖ and ―set as default‖ in the Other option tab. 

 Font size – Sets the font size. 

 Horizontal Scale – Sets how the text will be scaled in the horizontal level. 

 Text mode – Specifies how the text will be filled and stroked. 

 Char space -- Specifies the displacement between two characters. 

 Word space --Specifies the displacement between two words. 

 Line gap -- Specifies the desired spacing between lines of text. 

Color Options  

Choosing Color option brings up the Color option dialog box (see figure below), 

which allows you set your color preferences for inserting text and graphics. 

The default color options are RGB. If you want it to be changed to the CMYK color, 

you should go to Other options tab, and check CMYK under the Color Space 
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Settings. And if you want to set CMYK color as default, check the Save as Default 

box. 

 

Note: After you exit the program, all the color settings will be restored to 

default.  

The following options for Color can be set: 

 Fill Color -- The fill color is used to paint the interior of objects and text 

characters that are filled. To configure the fill color, simply drag the color 

adjusting bar until the color in the Preview is what you want.  

 Stroke Color -- The stroke color is used to paint the border of paths and 

text that are stroked. To configure the stroke color, simply drag the color 

adjusting bar until the color in the Preview is what you want. 

Graphics Options  

Choosing the Graphics option brings up the graphics style dialog box (see figure 

below), which allows you set your preferences for inserting graphics. 



40 
 

 

The following styles for Graphics can be set: 

 Line join style -- Specifies the shape to be used at the corners of paths that 

are stroked. The choices are Miter joins, Round joins and Bevel joins. 

 Line cap style -- Specifies the shape to be used at the ends of open sub 

paths when they are stroked. The choices are Butt end caps, Round end caps 

and Projecting Square End. 

 Miter limit -- Specifies the line join style; the default value is 10. 

 Line Width -- specifies the thickness of the line used to stroke a path and is 

measured in user space units. 

See Also: Path Properties 

Other Options 
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The following options are available in the Other dialog box: 

Save As Default 

Save all changes as default. Every time when Foxit PDF Editor starts, it sets 

these settings as default. 

Buffer 

 Undo Buffer Size – Here, you can set the amount of the undo buffer. 300 

is the default size, which means you can undo 300 times.  

Object Selection Mode   

Here you can select the edit type in accordance with the objects you are 

modifying. 

 All -- Allows you to modify any visible objects in a PDF page. (Default) 

 Text only-- Allows you to modify objects only. 

 Path only-- Allows you to modify graphics objects only. 

 Image only-- Allows you to modify image objects only. 

 Shading only– Allows you to modify image objects only. 
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Clipping Action when Moving Objects 

Many times there are objects containing clip layer. And some clip layer may help 

to construct a complete object, but some remain unnecessary. When 

serviceable clip layer is removed from the object, in most cases, it will affect the 

displaying of the object. By default, a clip object always moves along with the 

object. Yet, the default setting can be changed by the Clip Action.  

The following options exist to allow you to select a way to determine if the 

clipping could be moved along with the object.  

 Move clipping: Allows you to move the object along with clip. 

 Keep clipping: Allows you to move the object but keep its clip in its 

original place. 

Color Space Settings 

 Use Original Color Space (if supported)  

―If supported‖ means that if the PDF file uses any of the following color 

spaces: RGB, CMYK, Color Mapping, high-fidelity or multi-tone color, and 

the user has checked this option, Foxit PDF Editor will show the original color 

as specified in the file. Once this box is checked, you will not able to stroke 

other colors, except gray. 

 Default Color Space  

RGB and CMYK are the most common color systems. If you do not like using 

other abstract colors, you can simply choose RGB or CMYK as your default 

color space. Foxit PDF Editor uses the RGB color system as default. If you 

want to set CMYK color for the objects in your editing work, you must select 

it. 

Other 

 Set as default font after being imported 

The font you imported in the Text tab will be regarded as the default font for text 

input. 

 Show page setting dialog when inserting a new page 

When you insert a page, a dialog box will always pop up for you to set the page 

attributes. If you don’t want this dialog box to appear, simply uncheck this 

option. 
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 Do not show Property Sheet as launching Foxit PDF Editor 

Every time Foixt PDF Editor launches it will pop up the Property List. If you don’t 

wish to display this dialog box, uncheck this option. 

Selecting Objects 

You can select one single object or a group of objects in a page. When (an) 

object(s) is/are selected, a constantly moving dotted line and a rectangle 

enabling you to resize and rotate the object (appears only when an object is 

selected) will appear around it, so you can clearly identify which object(s) is/are 

selected. And the object selected in the General Tab of the Properties pane will 

show the number of currently selected objects, as well as other information 

about selected object(s). 

To select a single object 

Just simply click on an object in the Document Pane to select it. 

To select multiple objects 

Select an object, and then hold down Ctrl key when select additional objects. 

To select all objects within a page 

 Choose Edit > Select All on Menu Bar to select all objects in page 

 Use the keyboard shortcut Ctrl + A to select all objects in a page. 

To select overlapped objects 

Sometimes, there is more than one object overlapping with another object (for 

example, background or foreground graph objects), and you might need to 

repeat clicking to make sure the object is selected (you can check the type of 

selected object in the Properties List). 

 

To unselect objects 

 

 To unselect a selected object from multiple selections, hold Ctrl key and click 

on the object. 

 To unselect all selected objects, click on a point outside of any object. 

 

Note: you can check the type of selected object in the Properties List. If you are 

selecting different types of objects, the value for object type will be read as 

“mixed”. 
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Object Selection Mode 

A page may contain several different editable objects. In Foxit PDF Editor, users 

can select one project mode to edit, and not need to worry about changing other 

types of objects in unconscious operations. If you are aiming at editing text 

objects, for example, you can choose text selection mode, thus everything but 

text objects will be kept intact no matter what editing way you take. 

Here is a list of selection modes in Foxit PDF Editor: 

 

 All modes: The default mode, all types of page objects (text, path, image 

and shading) can be selected for editing. 

 Text mode: Only text objects can be selected for editing. 

 Path mode: Only path objects can be selected for editing. 

 Image mode: Only image objects can be selected for editing. 

 Shading mode: Only shading objects can be selected for editing. 

 

The selection mode can be accessed by one of the following ways: 

 

Using Tool Bar 

 Drop down the selection mode icon  from the Toolbar, and select a 

selection mode. 

Using File Menu  

 Select Edit > Options. 

 Click Other button on the left of the pop up Option dialog box. 

 In the part of Object Selection Mode, you can select a selection mode, such 

as All, Text only, Path only, image Only and Shading only. 

Editing Objects  

You can also freely edit any selected object(s) by the related toolbar.  

Text Objects 

1. Open the PDF document to be edited, and you can use the Text toolbar to 

edit the text. 
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2. Use the Split Text  to split the whole text into parts. 

 

3. Use the Merge Text  to merge objects in a line.  

 

 

 

 

 

 

 

4. Use the Graphics Keyboard  to insert fonts, especially the imbedded 

fonts. 

Text Toolbar 



46 
 

 

5. Converting Text to Path 

Foxit PDF Editor is able to convert the selected text object(s) into path(s), which 

will meet the pre-press requirement. For those computers which do not support 

or display certain embedded fonts, this new feature helps to overcome that 

issue. Foxit PDF Editor also offers a menu option for users to convert the entire 

text in a PDF to path. 

 Select the text objects which you want to convert to paths.  

 Select the Convert selected text to path button , and finish converting. 

 Select Object menu > Convert Selected Text to Path, and finish converting. 

Graphic Objects 

1. Open the PDF file to be edited, double click the graphic you want to modify, 

and then you will be switched to the Graphic Editor window. 
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2. In the Graphic Editor window, you can only modify the selected object, but 

you can use the Path tools to work with it. After you are done, click the Save 

and Exit button  to get back to the main window. 

 

3. Adding Shapes in Non-Graphics Editing Mode 

Foxit PDF Editor provides several simple auto shapes that users can insert into 

a PDF in the non-graphics editing mode. With this new version, users can easily 

add a simple shape in the main interface of Foxit PDF Editor without having to 

enter into the graphics editor.  

 

 Select the pull-down menu  on the Toolbar. 

 Select the graphics you want to draw, included Line, Rectangle, Filled 

Rectangle, Ellipse and Filled Ellipse.  
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Image Objects 

1. Open the PDF file to be edited, double click the image you want to modify, 

and then you will be switched to the Image Editor window. 

 

2. In the Image Editor window, you can use the toolbar to work with the image. 

After you are done, click the Save to go back to the main window. 
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Shading Objects 

1. Open the PDF file to be edited, double click the shading you want to modify, 

and then you will be switched to the Shading Editor window. 

 

2. In the Shading Editor window, you can only modify the selected object. You 

can use the Path tools to work with it. When you are done, click the Save 

and Exit button  to get back to the main window. 
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Modifying Objects  

Moving Objects 

There are several ways to move objects. When an object that contains clip 

elements is moved, you can set an option to determine whether the clip should 

be moved along with the object.     

Using Dragging Action 

 Select the object(s) you wish to move, and hold down the left mouse button 

to drag it over to the place you desire. 

Note: When an object is being dragged, an equivalent blank rectangle is 

used to represent the object.  

Example: The following is an example of dragging an object. The dotted 

object is the object that will be moved, and the blank rectangle represents 

where the object is moved. Once you stop holding down the mouse button, 

the object is moved to that place. 

 

Using Cursor key 

 Select the object(s) you wish to move, and press (Ctrl +) the cursor key to 

move it in the up, down, right or left direction. In this method, you can also 

hold down the cursor key until the object reaches the place you desire. 

Using the Properties Pane 

 Select the object(s) you wish to move, and in the Properties pane, double 
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click the item of Position X(point) and/or Position Y(point)  (see the 

following figure.), and then enter values in the text filed, and finally press  

Enter to finish. 

 

Note: If you only want to move one type of object, for example, text object, 

you can change Position values in the Text tab of the Properties pane. If you 

want to move different types of objects at the same time, you can change 

Position values in the General tab of the Properties. 

                   

Deleting Objects  

There are several ways to delete objects in Foxit PDF Editor:  

Using Object Menu 

 Select the object(s) you want to delete in the Document window, and then 

click Object > Delete Objects from the menu. 

Using Context Menu  

 Select the object(s) you want to delete in the Document window, and then 

right click the object(s), in the pop up Context Menu, select Delete 

Object.  

Using Delete key  

 Select the object(s) you want to delete in the Document window, and then 

simply press the Delete key.   
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Using Object Toolbar 

 Select the object(s) you want to delete in the Document window, and then 

click the Delete button on the Object toolbar. 

Copying/Cutting/Pasting 

Foxit PDF Editor allows you to copy and paste in a PDF document. You can copy 

and paste some types of objects. For text and image objects, you can copy from 

or paste to other Windows applications, like text editor, word processor, or 

image editor. 

To copy or cut, select the objects you want to copy or cut, then press CTRL + C 

to copy, or CTRL + X to cut. You can then go to other place of the PDF document, 

or another Windows application, to perform paste operation. 

To paste into Foxit PDF Editor, simply press CTRL + V. The pasted objects will 

appear at the upper left corner of the page view. You can also use right click on 

a place in your PDF page, then select Paste to paste objects at the clicked 

position. 

Aligning Selected Objects 

Automatically places or aligns the selected objects evenly with the Objects Align 

button  on the toolbar. This feature helps to make your structured PDF 

pages more professional. There are six kinds of aligning: Align Left, Right, Top, 

Bottom, Center and Middle.  

 

Objects Align 

 Select the objects which you want to align.  

 Click one of the six align types from the pull-down menu of Objects Align, 

and finish aligning.  
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Note: For more information about selecting objects, please refer to Selecting 

Objects.  

Dragging to Resize Object 

Objects can be dragged to resize so that their aspect ratio is retained.  

Using Cursor Action 

1. Select the object (text, graphics or image) you want to resize; 

2. Point to the one of the corner sizing handles;  

3. When the pointer becomes a double-headed arrow, drag the handle to 

resize the object by the same width and height. 

 

Corner Sizing Handle 

 

Sizing Handle 

 

 

Rotating Objects 

You can rotate objects by a counterclockwise or clockwise angle, and change in 

any degree. Rotating turns the object around the reference axis and its rotating 

direction is determined by the value you enter, negative or positive.  

Using Toolbar button 

 Select the object you want to rotate, and then click the  or on the 

Object toolbar to rotate the object counter-clockwise or clockwise. 

Using the Properties Pane 

1. Select the object you wish to rotate, and in the Properties pane, double 

click the Rotate text field (see the following figure.); 

2. In the text field, enter a positive value like 5, 13, 30, 90 to rotate the object 

counter-clockwise; enter a negative value like -5, -13, -30, -90 to rotate 

object clockwise. 
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Note:  In the Properties pane, click General tab if you want to rotate group 

types of objects, otherwise click an object tab, like Text tab, Image tab or Path 

tab if you only want to rotate the type of object you selected. 

Shearing Objects 

You can shear objects horizontally. 

 

Using the Properties Pane 

 

 Select the object you wish to shear, and in the Properties pane, double 

click the Shear text field (see the following figure.), and then enter values 

in the text field. After you are done, press the Enter key to finish. 

 

 

Note:  In the Properties pane, click General tab if you want to shear group 

types of objects, otherwise click an object tab, like Text tab, Image tab or Path 

tab if you only want to shear the type of object you selected. 

Scaling Objects 

Scaling enlarges or reduces objects relative to its reference axis. You can scale 

horizontally, vertically, or both horizontally and vertically. 

Using the Properties Pane 

 Select the object you wish to scale, and in the Properties pane, double 

click the Scale X and/or Scale Y text field (see the following figure.), and 

then enter values in the text filed. After you are done, press the Enter key to 

finish. 

 

Note:  In the Properties pane, click General tab if you want to scale group 

types of objects, otherwise click an object tab, like Text tab, Image tab or Path 

tab if you only want to scale the type of object you selected. 
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Setting Objects to Front/Back   

An object may be overlapped with one or several objects at the same position. 

For example you might have a text object as foreground, and then at the same 

location, there is a background graph object with filled color. You can control 

whether the current selected object(s) to appear as foreground, or background. 

Using Object Menu 

 Select the object in the Document Pane, drop down the Object Menu, and 

then select Set to Foreground, or Set to Background. 

Using Context Menu 

 Select the object in the Document Pane, right click it, and then choose Set 

to Foreground or Set to Background in the pop- up Context Menu. 

Using Shortcut Key 

 Select the object in the Document, then use the keyboard shortcut Alt+2 to 

Set to Foreground, and Alt + 1 to Set to Background. 

Creating Clip Layers for Objects 

Foxit PDF Editor allows you to create clip layers for objects. This feature ensures 

only parts of the object are visible, and is often useful for images where you may 

want to hide the background. 

To create clipping masks, do the following: 

1. Click the object you want to add clipping masks in your Document window 

(see example1); 

2. In the Properties pane, click the Clipping value field, and click the edit 

button  (see example 2); 

3. You will be switched to the Graphics Editor window; 

4. In the Graphics Editor window, use the Path tools to create clip layers to the 

image (see example 3); 

Note: The Clipping value lists all layers that the selected object contains. 

Null means no layer for the current selection.  

5. After you are done, click the Save and Exit button  to close the Graphics 

Editor window and get back to your Document window and the clip layer has 
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been added (see example 4). 

Example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Removing Clip Layers for Objects 

Foxit PDF Editor allows you to remove clip layers from objects. This feature is 

often useful for revealing the entire object or making parts of object visible. 

To remove clipping masks, do the following: 

1. Click the object you want to remove clip layers in your Document window 

(see example1); 

2. In the Properties pane, click the Clipping value field, and click the 

remove button ; 

Note: The Clipping value lists all layers that the selected object contains. 

 

① Here, we select an image object with Null clip 

layer in the Document window 

 

③ Here, we use the Ellipse tool to draw a clip 

layer in Graphics Editor window 

 

④ The clip layer has now been added to the 

image. 

② Click the Edit button to enter into 

Graphics Editor window 
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Null means no layer for the current selection. You can select to delete one 

of the layers or all layers. 

3. The clip layer is removed (see examples 3 and 5). You can use the Undo 

action to retrieve it.  

Example: 

 Here, we select an image object with two clip layers in the Document 

window 

 

 Select Clip Layer1 to remove. You can select 2 Layers in Total to remove 

layers immediately. 

 

 The Clip Layer1 is removed 

 

 

 Select Clip Layer2 to remove.   

 

 The Clip Layer2 is removed and the entire image becomes visible. 
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Setting Default Color for Objects 

Foxit PDF Editor takes RGB (Red, Green, and Blue) color as default. If you want 

to set object color in CMYK (Cyan, Magenta, Yellow, and Key (Black)), you must 

use the Options dialog box to change the setting first.  

To change the color setting, do the following: 

1. Select Edit>Options in the menu bar, and click Other tab; 

2. Under Color Space Settings, check the CMYK box. 

3. Check Save as Default box if you want to keep the setting for next time.  

Note: If you check Use Original Color Space in the Other Options tab, you will 

not be able to stroke other colors except Gray. 

Setting Properties for New objects 

Before inserting new objects such as text objects or graphics, you can assign 

properties for them so that you an easily insert several objects with same 

attributes.  

Using the Options dialog box 

 Select Edit in the Menu bar; 

 Select Options in the drop down menu; 

 On the pop-up Options dialog box (see the figure below), you can set 

attributes for new inserting objects.  



59 
 

 

Inserting New Objects 

With Foxit PDF Editor, you can insert text objects, image objects, shading object 

and graphic shapes like curve, straight line, etc. into your PDF. However, you 

may like to set its attributes prior to inserting a new object. For details, see 

Setting New Object Attributes. 

Using Object Menu 

 Point to the region you want to insert a new object, drop down the Object 

menu, and select the command to add the object. 

 

 

 

 

 

 

 

 

 

 

 

 

Object Insert Options in the menu 
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Using Context Menu 

 Point to the region you want to insert a new object, right click your mouse, 

and select the add object command in the pop-up context menu to add the 

object. 

Using Toolbar 

 Point to the region you want to insert a new object, and then click an 

inserting button in the toolbar (see below). 

 

Note: If you select the button , a text object input dialog box will pop up 

for you to write text. If you select the button , you will be switched to 

Graphics Editor screen. If you select the button , an Open dialog box will 

pop up for you to load an existing image. If you select the button  

Text Object 

From the Object toolbar, click Add Text Objects button . In the Add new 

text objects dialog box, input any text you want, and click OK to insert. 
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Note: To insert more than one line, you can simply press Ctrl + Enter to start a 

new line. 

Blank Page 

Open an existing PDF file to be edited, and insert a blank page using button . 

On the left is the example of a new blank page. 

 

 

 

 

 

 

 

 

 

Add Text Objects 

Please input text here 

Insert a Blank Page 
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Graphics Object 

From the Object toolbar, click Add a Graphic Object button , and you will 

be switched to the Graphic Editor window. Select a tool from the Path Toolbar to 

draw a path you want.  

 

 

 

 

 

 

 

Image Object 

To insert an existing image from file, click Loading an Existing Image button

 to insert the image. To insert a self-created image, click Create a New 

Image button , or go to Object > Add Image > New Image, or press Ctrl + 

I. 

 

 

 

 

 

 

Path Toolbar 
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Shading Object 

From the Object toolbar, click Add a Shading Object button , and you will 

be switched to the Shading Editor window. 

Select a tool from the Path Toolbar to draw a path you want.  

 

 

 

 

 

 

 

 

 

 

Path Toolbar 
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Object Properties 

Viewing Object Properties 

Before changing an object, you may like to know what attributes are included in 

the object, for example, object position, font information, fill or stroke color, etc. 

You may also want to know what sort of object you are selecting. In Foxit PDF 

Editor, you can use the Properties pane to view the selected object properties 

and their values. 

When you select an object in the Document pane, the object tab that appears in 

the Properties pane changes to reflect the selected object. For example, if you 

select a text object, the Text tab will appear in the Properties pane and displays 

most of the information about the text. 

Changing Object Attributes 

The Properties pane provides an easy way to change any selected objects. If the 

Properties pane is hidden, select the View menu and check Properties list to 

show the Properties pane. 

Select an object or objects in the document, and then do the following: 

 Use the Text tab to change the text object properties. 

 Use the Image tab to change image properties. 

 Use the Path tab to change the graphics properties. 

 Use the General tab to change the properties common to the above 

attributes. 

 Use the Shading tab to change shading properties. 

1. Open an existing PDF file that you want to be edited. Select an object, or 

hold down CTRL to select multiple objects. Here we select the text, graphic, 

image and shading objects as example. 
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2. The Properties pane changes to reflect the object you select. You can use 

the General tab to change the common attributes to the objects you 

selected. Or, you can use the Text tab to change text attributes, Path tab to 

change the graphic attribute, Image tab to change the image attributes, or 

shading tab to change the shading attribute. After you are done, press the 

Enter key. 

 

 

 

 

 

 

 

 

 

3. General Properties.  

You can specify a number of properties that are common to all objects in the 
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General properties. 

 Position X and Y: Allow you to set the precise horizontal and vertical 

position of the objects. 

 Rotate: Move the object clockwise or counter-clockwise around the 

reference axis. 

 Shear: Allows you to slant an item horizontally. 

 Scale X and Y: Make an object bigger or smaller. You can scale 

horizontally or vertically.  

 Fill Color: The fill color is used to paint the interior of paths and text 

characters that are filled. 

 Stroke Color: The stroke color is used to paint the border of paths and 

text that are stroked. 

 Clipping: When the selected object contains any clip inside, the clip 

value displaying as ―mixed‖. Otherwise it displays as ―Null‖. You can click 

the rubber button next to the clipping text field to remove the clipping.  

 Objects Selected: Shows the number of objects you currently have 

selected.  

 Objects Type: Shows what type of object you currently have selected. 

When different types of objects are selected, its type is ―mixed‖. 

4. Text Properties 

 Text: Shows the contents of the text. 

 Text Mode: The Text Mode determines whether text is stroked or filled. 

There are four types of text modes as shown in the following figure, in which 

a stroke color of black and a fill color of light gray are used.  

   

 

1.Fill text (default) 

 

2.Stroke text 3.Fill then stroke text 4. Text with no fill and 

no stroke (invisible) 

 Character (Char) Space: The Char Space value is a number specified in 

text space units. It is added to the displacement between the origin of one 

character and the origin of the next.  

In the default coordinate system, the positive direction of the x-axis points 

to the right, and the positive direction of the y-axis points upward. So, for 

horizontal writing, a positive value of Char Space has the effect of 

expanding the space between characters; see the following figure. For 

vertical writing, however, a negative value of Char Space has the effect of 
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expanding the space between characters. 

Character 0 (default) 

C h a r a c t e r 0.25 

Char Space for Horizontal Writing 

 Word Space: The Word Space value is a number specified in text space 

units. It works in the same way as character spacing. 

For horizontal writing, a positive value for Word Space has the effect of 

increasing the spacing between words. For vertical writing, a positive value 

Word Space decreases the space between words, since the positive 

direction of the y-axis points upward; therefore a negative value will 

increase the space between words. The following figure illustrates the effect 

of word space in horizontal writing. 

Word Space 0(default) 

Word  Space 2.5 

Effect of word space in horizontal writing 

 Font: Font is a font in the current resources dictionary. The following lists 

the standard 14 fonts which are guaranteed to be available to Foxit PDF 

Editor.   

 Font Size: Font Size is a number expressed in the text space units. 

 Horizontal Scale: The Horizontal Scaling adjusts the width of characters 

by stretching or shrinking them in the horizontal direction. The scaling is 

specified as a percent of the normal width of the characters, with 100 being 

the normal width. The following figure shows the effect of horizontal scaling. 

The scaling always applies to the x coordinate, independent of the writing 

mode. 

 

100 (default) 

 

 

 

50 

 

Horizontal Scaling 

 Line Gap: The Line Gap specifies the vertical distance between the lines of 

text, as shown in the following figure. The initial value for Line Gap is 0. 
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Line Gap 

5. Path Properties 

 Fill Type: The Fill Type specifies how the interior of a path is determined. 

There are three types of fill: No Fill, Alternate, and Winding.  

 No Fill means the enclosed regions of the path are transparent. 

 Winding means that if a ray is drawn in any direction from a given point 

to infinity and the places where the path intersects the ray are tested, 

the point is inside of the path if and only if the result that the path 

crosses the ray from left to right does not equal the result that the path 

crosses the ray from right to left. If the result is equal (zero), the point 

is outside of the path. See the following illustrations for the winding 

effect. 

       

 Alternate or called EVEN_ODD, uses a slightly different rule. Instead of 

testing for a result of zero, alternate uses a test to determine whether 

the result is even or odd. If the result is odd, the point is inside the path; 

if the result is even, the point is outside. See the following illustration 

for the winding effect. 

 

 Line Width: The line width specifies the thickness of the line used to stroke 

a path and is measured in user space units. A line width of 0 specifies the 

thinnest line that can be rendered on the output device. The default value is 
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1. 

Note: A line width of 0 is an inherently device-dependent value. Its use is 

discouraged because the line may be nearly invisible when printing on 

high-resolution devices. 

 Miter limit: When two line segments meet at a sharp angle it is called a 

Miter join and have been specified as the line join style. It is possible for the 

miter to extend far beyond the thickness of the line stroking the path. The 

miter limit imposes a maximum on the ratio of the miter length to the line 

width, as shown in the following figure. When the limit is exceeded, the join 

is converted from a miter to a bevel. 

The value for miter limit is a number that must be greater than or equal to 

1, and has a default value of 10.  

  

Miter length 

 Line Cap Style: The line cap style specifies the shape to be used at the 

ends of open sub paths when they are stroked. Allowed values are Butt end 

caps, Round end caps, and Projecting Square End. 

 Butt end caps (default) --- the stroke is squared off at the endpoint 

of the path. 

 

 Round end caps: --- a semicircular arc with a diameter equal to the 

line width is drawn around the endpoint and filled in. 

 

 Projecting square end: --- the stroke extends beyond the end of the 

line by a distance which is half the line width and is squared off. 

 

                    

Butt end caps           Round end caps      Projecting square end 

 Line Join Style: The line join style specifies the shape to be used at the 

corners of paths that are stroked. The allowed values are Miter joins, Round 

joins and Bevel joins. 

 Miter joins — the outer edges of the strokes for the two segments are 

continued until they meet. If the extension projects too far, as 

determined by the miter limit, a bevel join is used instead.  
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 Round joins — a circular arc with a diameter equal to the line width is 

drawn around the point where the segments meet and filled in, 

producing a rounded corner. 

 

 Bevel joins — the two path segments are drawn with butt end caps 

(see the discussion of line cap style), and the resulting notch beyond 

the ends of the segments is filled in with a triangle. 

                     

Miter joins                Round joins           Bevel join 

Butt end caps          Round end caps       Projecting square end 

6. Image Properties 

 Width and Height: Displays the selected image’s width and Height values;  

displays the largest values if you select a number of different images.  

 Resolution X and Y: Displays the precise horizontal and vertical resolution 

of the image objects.  

 Alpha: Allows users to set image transparency by inputting values between 

0% and 100% in the Alpha text field; the image goes from fully transparent 

to fully opaque.  

7. Shading Properties 

 Shading Type: Displays as Linear if you selected one Linear shading or two 

types’ shading. Otherwise, displays as Radial. 

 Extend: Extend is an optional array of two Boolean values that specify 

whether or not to extend the start and end colors past the start and 

endpoints, respectively. The default value for each element of the array is 

true.  

There are four kinds of Extend values to choose, including ―true true‖, ―true 

false‖, ―false true‖ and ―false false‖. 

 Start X and Y: Allows you to set the precise horizontal and vertical position 

of the shading’s start point.  

 End X and Y: Allows you to set the precise horizontal and vertical position 

of the shading’s end point.  

 Alpha: Allows users to set shading transparency, by inputting values of 

between 0% and 100% in the Alpha text field, the shading goes from fully 

transparent to fully opaque. 



71 
 

Editing Page Layout 

1. Go to the page you want to edit its layout, click the Page Layout button  

from the Page toolbar, and then you will be switched to the Layout Editor 

window. 

 

 

 

 

 

 

 

 

2. Use the Layout toolbar to resize the page size or content size, the Page 

Properties to change the page attributes, and Reset to cancel all actions. 

After you are done, click the Save and Exit button to get back to main 

window. 

 

 

Page Toolbar 
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Modifying Pages 

There are several ways you can do modifications on pages. 

 Insert new page  

When you insert a new page, you can customize the page attributes like the 

page dimension and/or content measurement. To insert page, you can 

select Page > Insert Page on the menu bar. 

 Copy Pages  

You can copy a whole page into another page, just like cloning. To copy page, 

simply perform copy and paste command.  

 Import and Export pages 

You can insert pages from other PDF document into your document; and 

extract pages from your document into an existing PDF document. 

 Delete Page:  

You can delete an unwanted page. To delete the page, you can select Page > 

Delete Page on the menu bar. 

See Also: Work with Pages 

 

Layout Toolbar 
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Chapter 5 – Working with Pages 
 

 

Foxit PDF Editor allows you to insert and delete the pages in a PDF document, 

import pages from other PDF documents into your document, and export the 

pages from your document. You can also reorganize the pages by Page Layout 

Editor. 

About Page Toolbar 

Page tools can be found on the toolbar (see the following figure), which by 

default is located on the Toolbar. 

 

Page Toolbar 

 Click the Previous Page icon  or the Next Page icon  to go to the 

previous or next page. 

 Click the First Page icon  or the Last Page icon  to go to the first or 

last page.  

 Click layout button  to switch to the Page Layout Editor window, so you 

can reorganize the page layout. 

 Click the Insert a Blank Page button , and you can set the blank page 

attributes in the pop-up dialog box.  

 Click the Delete Current Page button  to delete a current page in your 

PDF document. 

Note: If you find the Page Toolbar is invisible, Select View > Page Toolbar in 
the menu to show it. 

Setting Page Options 

Before inserting a page, you might like to preset some options so that you can 

easily insert pages with your personalized preferences. 
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To set page options, do the following: 

1. Select Edit > Options from the menu bar, or press Alt + O keyboard. 

2. In the pop-up Options dialog box, click Page. 

3. In the Page tab, change the values to suit your preferences. 

4. After you are done, click the Ok button. Click the Restore Default button 

to leave the settings unchanged.  

Note: After you exit the program, all the changes are restored to default. 

Inserting Blank Pages 

Foxit PDF Editor allows you to insert a blank page into your PDF document. To 

insert blank pages, please do the following: 

1. Locate the page where you want to insert a blank page before or after. 

 

2. Do one of the following: 

 Point to the Page toolbar, and click Insert a Blank Page button  

 Select document > Insert Page on the Menu bar 

3. On the pop-up New Page Attributes dialog box, assign the new attributes 

you want. 

Note: 

 

 You can use the Options dialog box to preset the page attributes for the 

inserting page. 

 If you do not want the New Page Attributes dialog box to show up when 

you insert a page,  you can uncheck the option ―show page setting 

dialog when inserting a page‖ in the Other Options tab. 

 

See also: 

Page Options in Setting Options 

Other Options in Setting Options 

Importing and Exporting Pages 

Foxit PDF Editor allows you to import pages from other PDF documents, and 

insert into your PDF document; and also allows you to export pages from your 

PDF document into an existing PDF document. 

To import pages, do the following: 
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1. Select Document > Import Page(s) item from the Menu bar in your 

Document window. 

2. In the following pop-up dialog box, do the following: 

 Under Position, check one of items to decide where to insert the pages. 

 Under File, click the Open button  to look for the document you 

would like to export pages from. Then the Total Page(s) field will 

display the total page numbers of the document. 

 Under Page Range, check one of the items to select how many pages 

or which page you want to import. 

 In Document Preview, you can navigate in the document to look over 

the pages before importing. 

 

3. After you are done, click the Ok button to insert the page and close the 

dialog box. 

To export pages, do the following: 

1. Select Document > Export Page(s) item from the Menu bar in your 

document window. 

2. In the following pop-up dialog box, do the following: 

 Under Destination, click the Open button to look for the existing 

document that you will export the pages into.  

 Under Page Range, check one of the items to select the page(s) you 

want to export and the Total Page(s) displays your current document 
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total page number. 

 In Document Preview, you can navigate in the document to look over 

the pages before exporting. 

 

Note: Exporting pages to an existing document will cover all the document 
pages. 

3. After you are done, click the Ok button to insert the page and close the 
dialog box. 

Deleting Pages 

Foxit PDF Editor allows you to delete a current page in your PDF document. 

To delete a current page, do the following: 

1. Locate the page which you want to delete. 

2. Do one of the following: 

 Point to the Page toolbar, and click Delete Current Page button  

 Select Document > Delete Page on the Menu bar 

 Press keyboard shortcut Alt + Del 

3. A warning message pops up to confirm your deleting action. 

4. Click the Ok button to delete the page.  
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Deleting Warning Message 

About the Page Layout Editor 

Foxit PDF Editor allows you to reorganize the page layout, such as, to change 

the page size, adjust the content size, and rotate pages.  

To adjust page layout settings, do the following: 

1. Point to the Object toolbar. 

2. Click the Page Layout button . 

3. You will be switched to the Page Layout Editor window. 

4. In the Layout Editor window, use the available tools to change the page 

layout. 

5. After you are done, click the Save and Exit button  to close the Page 

Layout window and go back to your Document window. 

As you click layout button  in the Main window of Foxit PDF Editor, you will 

be guided to the Page Layout Editor window as shown in the following figure. 

The Layout pane is especially useful when you want to specify the page layout 

for user preview or print. When you resize the page or clip the content size, the 

page will be surrounded by a red media box or a green crop box with Sizing 

Handle. You can drag the Sizing Handle to adjust the size. 
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The Page Layout Editor window consists of a Layout Toolbar to reorganize the 

page, a Zoom Toolbar to magnify or reduce the page, and a Page Properties 

Pane to set up the page by specifying the actual value. 

1. The Layout Toolbar contains the main tools for you to work with the page 

layout. 

 

           

 

2. All the tools on the layout toolbar can be accessed from the Context Menu as 

shown in the following figure. 

 

    

 

Size Handle 

Red Media Box for Resizing Page 

 

Clip Content    Reset     Save and Exit 

 

Resize Page   Rotate Page  Exit without Save  
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Context Menu 

3. When you adjust the page size, you may use the Zoom Toolbar to zoom 

in/out your page for easy operation. 

 

Zoom Toolbar 

4. If you would like to reorganize the page layout by specifying the actual value, 

you can use the Page Properties Pane (see the following figure). Just 

double-click the value field, and input your desired value.  

 
Page Properties Pane 
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To resize a page 

Resizing a page is actually to enlarge or reduce the red Media Box of a page 

currently displayed in the layout window. It is very useful if there are documents 

with different page size (for example the dimensions of A4 and A3 ) which you 

want to make unified in as the same size (for example A4). When you resize a 

page, you may like to zoom out to the best fit size for easy operation.  

To resize a page, you can use the Resize button, the Context menu, or the Page 

Properties Pane. 

Using the Resize Page button 

1. Click on Resize Page button  on Layout Toolbar, and you will see the 

following change: 

2. The page rectangle in layout window is highlighted in red with sizing handles. 

This rectangle is called the media box, and it is the natural size of a page.  

3. Drag one of the sizing handles to any size you want. 

4. After you are done, click the Save and Exit button  to go back to the 

Main Window, or click the Reset button  to take back the change and 

redo. 

Note: Please be aware that the intersection between the page's size and the 

content size is the region that is viewed or printed. The content size’s default is 

the value of media box. So, on one hand, when you shrink the page's size 

without reducing the content size accordingly, the portion outside of the page 

size will not be displayed in the Viewer (see the following example). On the 

other hand, if you enlarge the page size without resizing the content size, the 

displaying content is kept intact, while the page size is expanded (for example 

expanded from A4 to A3). This will affect your printing result. 

Example:   

The following example shows a page size with a red media box that is reduced 

in Layout Editor and its result got displayed in a reader.  
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①    ②    ③  

 

Example ①: Shows the original PDF page.  

Example ②: Shows the page is resized in Layout Editor. The *red box* indicates 

the page size you pick.  

Example ③: Shows the result page layout in PDF Reader  

Using the Page Properties Pane 

1. Double-click the value field next to the Width (Page Size) or Height 

(Page Size) in Page Properties pane;  

 

2. Type the size value you want; 

3. Click any other place, or press Enter to take the change effect. 

To clip a page content 

Clipping content is actually to adjust the page's green crop box (see the 

following figure), so to adjust the file display, the output file page size and the 

file print. When you clip content, you may like to zoom out your page to the best 

fit size for easy operation. 

 

 

Green Crop Box for 

Content Clipping 

Sizing Handle 
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To clip the content, you can use the Clip Content button on the Layout toolbar, 

the Context menu, or the Page Properties Pane. 

Using the Clip Content button 

1. Click on Clip Content button  on the Layout Toolbar, and you will see the 

following change: 

2. The page rectangle in layout window is highlighted in green with sizing 

handles. This rectangle is called a crop box, its default is the value of page 

size. 

3. Drag the sizing handles to any size you want. 

4. After you are done, click the Save and Exit button  to go back to the 

Main Window, or click Reset button  to take back the change and redo. 

Using the Page Properties Pane 

1. Double-click the value field next to the following properties name in Page 

Properties pane: 

 

2. Type the size value you want. 

3. Click any other place or press Enter for the change to take effect. 

To rotate a page 

Rotating content will change the orientation of the currently displayed page's 

content. This will change its actual orientation of the page, and can be saved 

and generated into a PDF file.  

To rotate the content, you can use the Clip Content button on the Layout toolbar, 

the Context menu, or the Page Properties Pane. 

Using the Rotate Page button 

1. Click on Rotate Page button  on Layout Toolbar.  

2. Click the page to rotate the page 90 degrees. 

3. After you are done, click the Save and Exit button  to go back to the 

Main Window, or click the Reset button  to take back the changes and 
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redo. 

Using the Page Properties Pane 

1. Double-click the value field next to Page Rotate in Page Properties 

pane:  

 

 

2. Drop down the combo box and select an orientation degree to rotate. 

3. Click any other place or press Enter for the change to take effect. 
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Chapter 6 – Working on Text 

Objects 
 

 

A text object consists of one or more characters that can be placed anywhere on 

the page and in any orientation. Text Objects can be stroked or filled, and uses 

fonts to specify what the characters look like, and font sizes to specify how 

large those characters are. 

About Text Toolbar 

Text tools can be found on the toolbar (see the following figure), which by 

default is located on the Toolbar. 

 

Text Toolbar 

Note: If you find the text toolbar is invisible, Select View > Text Object 

Toolbar in the menu to show it. 

To Use Graphics Keyboard 

The Graphics Keyboard is helpful for you to intuitively view all characters 

contained in a text font and to selectively input the characters. 

When a type of font text, including embedded font text, is selected or dotted, 

the graphics keyboard button is activated, otherwise it is disabled. By clicking 

the Graphics Keyboard button , you can bring about a dialog box for 

modifying the font (see the following figure). 
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The Text Object field displays the current selected text, and the Characters 

Pane displays all characters contained in the selected text font. 

To use graphics keyboard, do the following: 

1. Select a block of text in the page. 

2. Click the Graphics Keyboard button on the Text toolbar. 

3. Click the Text Object field, and use the Backspace Key to delete the 

characters you do not want. 

4. Click the character you desire in the Characters Pane, which will be 

displayed into the space where the cursor rests in the Text Object field. 

5. After you are done, click Ok to finish. 

To Merge Text 

Blocks of text may be merged together when you need to join text as one 

object.  

To merge text, do the following: 

1. Select blocks of text you want to merge in a same line. 

2. Click the Merge Text button on the Text toolbar to merge the text. 

3. After merging, the dash rectangle is switched to selection status ready for 

dragging. 

 

 

Text before merging 

 

  

Graphics Keyboard 

 

 

 

 

Text Object field 

Characters Pane 
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Text after Merging 

 

Note: You can only merge blocks of text in a same line  

To Split Text 

A block of text can be divided up into several parts.  

To split text, do the following: 

1. Select a block of text you want to split. 

2. Click Split Text button  on the Text toolbar. 

3. In the Split Text dialog box, click the desired place where a split mark will 

appear. 

4. Click Ok button to finish. 

 

Before Splitting 

 

 

In the process of splitting 

 

 

After splitting 

 

To Import Windows Fonts 

You may find that you would like to use a font that is not in the current font 

resources. In this case, you can import fonts installed on your Windows system. 

Split Mark 
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1. To import a Windows font, do the following: 

 Click Import Font button  on the Text toolbar. 

 In the Import Windows Font dialog box (see the following figure), select 

your desired font. 

 Click the Ok button to finish. 

 

Import Windows Font 

2. To set the imported font as default 

After importing a font in a current document, you may want it to be your default 

font so that you can easily insert text with that same font many times. To set the 

imported font as default, do the following: 

 Select Edit > Options in the menu bar. 

 Click Other options dialog box in the Options dialog box. 

 Check Set as default font after being imported. By default, this option is 

checked. 

To Convert Selected Text to Path 

Foxit PDF Editor is able to convert the selected text object(s) into path(s), which 

will meet the pre-press requirement. For those computers which do not support 

or display certain embedded fonts, this new feature helps to overcome that 

issue. Foxit PDF Editor also offers a menu option for users to convert the entire 

text in a PDF to path. 

 Select the text objects which you want to convert to paths.  

 Select the Convert selected text to path button , and finish converting. 

 Or select Object menu > Convert Selected Text to Path, and finish 

converting. 
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Setting Text Options 

Before inserting text, you might like to preset some options so that you can 

easily insert text with your personalized preferences. 

To set text options, do the following: 

1. Select Edit > Options from the menu bar, or press Alt + O. 

2. In the pop-up Options dialog box, click Text. 

3. In the Text tab, change the values to suit your preferences. 

4. After you are done, click the Ok button. Click the Restore Default button 

to leave settings unchanging.  

Note: After you exit the program, all the changes are restored to default except 

the Font option. You can set it as default for the next time in the Other Options 

tab. 

Selecting Text Mode 

To modify text objects, you can select to work in a text state, so that you can 

easily and solely interact with those text objects without affecting any other 

type of objects.  

To select text state, do one of the following: 

1. Select Text from the drop down list of Choose Selected Objects’ Type 

in the Menu Bar.  

2. Select Edit > Options. In the pop-up dialog box, select the Other tab, and 

check ―Text only‖ under Objects Selection Mode.  

Inserting New Text  

With Foxit PDF Editor, you can insert new text objects, using the standard 14 

fonts, embedded, non-embedded fonts, or Windows fonts. 

To insert a new text object, do the following: 

1. Point to a region where you want to insert new text, and then do one of the 

following: 

1) Click the button  on the Object toolbar 
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2) Select Object > Add Text on the Menu bar 

3) Use the keyboard shortcut CTRL+T  

4) Right-click the mouse in the Document window, and select Add Text in 

the context menu. 

2. In the pop-up Add New Text Objects dialog box (see the following figure), 

enter text in the text editing field, press CTRL+ENTER to start a new line. 

 

Add New Text Objects Dialog Box 

3. Click the Object attributes option, and users can set preferences for text 

objects more easily, such as font size, text mode, word space, color, etc. 

4. After you are done, click the Ok button to insert. 

Note:  

 If you want to insert blocks of texts with the same properties, you can 

also use the Text Options dialog box to preset preferences for 

inserting text. 

 After inserting text, you can use the Text Properties Tab to change 

the text attributes. Or use the text toolbar to edit it. 

Editing Text Objects 

To change text contents  

1. Select the text and click the Edit Object button , or double-click a string 

of text you want to change in your page to enter in-place editing mode. 

2. In the in-place editing mode, the text you selected appears highlighted. 

Please move your mouse cursor directly to the proper place you wish to edit.  

3. You can click the Undo button  to undo previous actions. After modifying 

the text, click Save and Exit button  or Exit without Save button  to 
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exit the in-place editing mode. 

Notes:  

 Double-click to enter the in-place editing mode may be unavailable 

when multiple objects overlap. 

 You can only change a block of text at a time.  

 Note that a text object consists of a group of characters, if the 

characters you typed are not in the group, they will not be displayed in 

the page. You can use the Graphics Keyboard to intuitively view all the 

characters in the font. 

See Also: To Use Graphics Keyboard 

To adjust character space  

1. Select the characters you want to change in your page. 

2. In the Text Properties tab, click the text field next to Char Space.  

3. In the text field, input the spacing value, and click any other place to 

change. 

To adjust word space 

1. Select the words you want to change in your page. 

2. In the Text Properties tab, click the text field next to Word Space.  

3. In the text field, input the spacing value, and click any other place to 

change. 

To change text font 

1. Select a string of text you want to change. 

2. In the Text Properties tab, drop down the font list box next to Font.  

3. If you want a font that is not listed, you can use the Import Font button on 

the Object toolbar to import fonts installed on your Windows system. 

To change font size 

1. Select a string of text you want to change in your page. 

2. In the Text Properties tab, click the text field next to Font Size.   

3. In the text field, input the spacing value, and click any other place to 

change. 
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To fill/stroke text color in RGB/CMYK 

1. Select a string of text you want to fill/stroke in your page. 

2. In the Text Properties tab, click the text field next to Fill Color/Stroke 

Color.   

3. Click the arrow button  on the right to view the current value. 

4. Click the Edit button on the right and drag the color bar match the color. 

5. After you are done, click the  button to make the change effect.   

            

RGB Fill/Stroke Color Box                CMYK Fill/Stroke Color Box 

Note: Foxit PDF Editor takes RGB color as default; if you want to set text color 

in CMYK, you must use the Options dialog box to change the setting first.  

See Also: Setting Default Color for Objects 

To change text mode for fill/stroke color 

There are four types of text modes, and Foxit PDF Editor takes Fill Text as a 

default setting. If you find the text you selected cannot be stroked, you must 

change the text mode to Stroke Text mode or Fill then stroke text mode.  

To change text mode, do the following: 

1. Click the Text Properties tab in the Properties pane. 

2. Drop down the Text Mode box and select a type of text mode. 

3. After you are done, click any other place the take change effect. 

To modify text objects 

Foxit PDF Editor allows users to move, delete, rotate, shear, scale and align 

objects, and create clip layers for Text Objects, etc.  

More information about modifying, please refer to Modifying Objects. 
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Chapter 7 – Working on Image 

Objects 
 

 

An image object consists of a set of samples using a specified color model. 

Images can be placed anywhere on a page and in any orientation. 

Selecting Image Mode 

Before modifying image objects, you can select to work in an image state, so 

that you can easily and solely interact with those image objects without 

affecting any other type of objects.  

To select image state, do one of the following: 

1. Select Image from the drop down list of Choose Selected Objects’ Type 

in the Menu Bar.  

2. Select Edit > Options. In the pop-up dialog box, select the Other tab, and 

check ―Image only‖ under Objects Selection Mode.  

Insert New Image 

 

With Foxit PDF Editor, you can insert an existing image from file, insert a new 

image created by yourself, or embed an image from the clipboard. 

To insert an image from file 

Locate the page where you want to insert the image in your document, and then 

do one of the following: 

1. Locate the page where you want to insert the image in your document, and 

then do one of the following: 

 Point to the Object toolbar, and click the Load an Existing Image  

button . 

 Right click the page, and select Add Image > From File on the 

Context menu. 

 Point to Object menu, and select Add Image > From File. 

2. In the pop-up Open dialog box, find your desired image, and click on Open 
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button.  

3. You current Main window is switched to the Image Editor window (see the 

following figure). Click the Close button to exit if you don’t want to do any 

changes to the image. 

4. Once you are back to the Main window, the image is inserted. You can resize 

the image and drag it to any place you want. 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Inserted image in the main window 

 

 

 

To insert a self-created image  

1. Locate the page where you want to insert the image in the document, and 

then do one of the following: 

Current main window 

 

Open dialog box 

  

Your desired image 

Image Editor Window 
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 Point to the Object toolbar, and click the Add an New Image button 

 

 Right click the page, and select Add Image > New Image on the 

Context menu  

 Point to the Object menu, and select Add Image > New Image 

2. A New Image dialog box pops up (see the following figure). You may 

change the parameters, and then click the Ok button  

3. You are now in the Image Editor window, and you can use the toolbar and 

filter tools to draw your image from scratch.  

4. After you are done, click Save to exit and get back to the Document 

window.  

5. Once you are back to the Document window, the image is inserted. You can 

resize the image and drag it to any place you want. 

 

 

To embed an image from clipboard 

1. Locate the page where you want to embed the image in the document from 

the clipboard. 

2. On the Edit menu, click Paste, or press Ctrl + V.   

3. You current Main window is switched to the Image Editor window, just click 

the Close button to exit if you don’t want to do any changes to image. 

4. You are back to the Main window, and the image is inserted. You can resize 

the image and drag it to any place you want. 

About the Image Editor 

 

Image Editor is an image editing program that is part of Foxit PDF Editor. You will 

be directed to the Image Editor Window (see the following figure) when taking 

one of the following procedures in the Main window of Foxit PDF Editor: 

 

 Select Create a New Image in the Main window  

 Double click a current object in the page 
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 Select to Open an Existing Image in the Main Window 

 Paste an image from the clipboard 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Image Editor Window 

To edit image with Image Editor, do the following: 

1. Double-click the image you want to edit in the Document window. 

2. You will be switched to the Image Editor window. 

3. In the Image Editor window, you can use the toolbar together with the filter 

tools to edit the image. 

4. After you done, click Save to exit and get back to your Document window. 

Currently, the Image Editor Window consists of the following components: 

Filter Menu 

The filter menu holds tools for applying filters for special effects. (See also: 

Using Filters) 

Toolbox 

The toolbox holds tools for creating and editing images. (See also: Using the 

Toolbox) 

Options Palette  

Color Palette 

 

Options Palette 

 

Layer Palette 

Histogram Palette 
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The options palette provides options for using a tool. (See also: Using the 

Options Palette) 

Layer Palette  

Layer Palette helps you monitor and modify images. (See also: Using the Layer 

Palette) 

Color Palette 

Color Palette displays the color values for the current foreground and 

background colors. (See also: Using the Color Palette) 

Histogram Palette 

The histogram of an image normally refers to a histogram of the pixel intensity 

values. This histogram is a graph showing the number of pixels in an image at 

each different intensity value found in that image. (See also: Using the 

Histogram Palette) 

Replacing an Image 

1. On the Toolbox, click Replace button . 

2. In the pop-up Open dialog box, search the image file you want and click 

Open button. 

Note: Only BMP, PCX, TIF, and JPEG format file can be opened. 

3. You get a confirmation message asking you if you want to continue to 

replace the current active image. If yes, click the Ok button to finish. 

Note: The replaced image will never be recovered. 

Saving Images 

1. On the Toolbox, click Save to File button .  

2. In the File name box of the Save dialog box, type a new name for the image.  

Note: Currently the file format type is limited to save as BMP. 
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Zooming Images 

You can use the zoom tool  to magnify or reduce your view. 

To zoom in 

Select the zoom tool  on the Toolbox. The pointer becomes a magnifying 

glass with a plus sign in its center . Click the area you want to magnify. 

To zoom out 

Select the zoom tool. The pointer becomes a magnifying glass with a minus sign 

in its center . Click the center of the area of the image you want to reduce. 

Using the Toolbox 

The first time you start the application, the toolbox appears on the left side of 

the screen. Some tools in the toolbox have options that appear in the tool 

options palette (See using the tool options palette).   

You can select a tool by clicking its icon in the toolbox. Positioning the pointer 

over a tool displays a tool tip with the tool's name. 

To show or hide the toolbox: 

Choose View > Image Toolbar > Tools. A check mark indicates the item is 

showing. 

To move the toolbox: 

Drag the toolbox by its title bar to move. 

 

Selecting tools include Rectangle tool, Magic Wand tool and Lasso tools. 

Painting tools include Eyedropper tool, Bush tool, Paint Bucket tool, Dodge 

tool, Burn Tool and Eraser tool. 

Flipping tool is to flip the entire image horizontally or vertically. 
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Selecting Tools 

Using the rectangle tool 

 Select the rectangle tool  from the Toolbox. 

 Drag over the area you want to select. 

Using the magic wand tool 

The magic wand tool lets you select a consistently colored area without having 

to trace its outline. You can specify the tolerance for the magic wand tool's 

selection. 

 Select the magic wand tool . 

 In the Options palette, drag the slider to specify the Tolerance, or enter a 

value ranging from 0 to 255. 

 To select only adjacent areas using the same colors, select Contiguous. 

Otherwise, all pixels using the same colors will be selected. 

 In the image, click the color you want to select. If Contiguous is selected, 

all adjacent pixels within the tolerance range are selected. Otherwise, all 

pixels in the tolerance range are selected. 

Using the lasso tools 

The lasso and polygonal lasso tools let you draw both straight-edged and 

freehand segments of a selection border.  

To use the lasso tool 

 Select the lasso tool  from the Toolbox. 

 Drag to draw a freehand selection border. 

To use the polygonal lasso tool 

 Select the lasso tool  from the Toolbox. 

 Click in the image to set the starting point. 

 Double click the image to close the selection. 

Cutting, copying, and pasting selections 

 Select the area you want to cut /copy.  

 Choose Cut out tool  or Copy tool  from the Toolbox. 

 Paste the selection into the same image or another application. 
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Deleting selections  

 To delete a selection, select the part you want to delete, and press the Del 

key.  

 To cut a selection to the Clipboard, click Cut out tool  from the Toolbox. 

Painting Tools 

1.   Setting options for painting 

You can set options for a painting tool in the Options palette. 

Selecting a blending mode 

The blending mode specified in the Options palette controls how pixels in the 

image are affected by a painting or editing tool. 

 To select a blending mode for a tool 

Choose from the Mode drop-down menu in the options palette. 

 Normal  

Edits or paints each pixel to make it the result color. This is the default mode. 

 Color Burn   

Looks at the color information in each channel and darkens the base color to 

reflect the blend color by increasing the contrast. Blending with white produces 

no change. 

 Color Dodge 

Looks at the color information in each channel and brightens the base color to 

reflect the blend color by decreasing the contrast. Blending with black produces 

no change. 

 Darken  

Looks at the color information in each channel and selects the base or blend 

color--whichever is darker--as the result color. Pixels lighter than the blend 

color are replaced, and pixels darker than the blend color do not change.  

 Difference  
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Looks at the color information in each channel and subtracts either the blend 

color from the base color or the base color from the blend color, depending on 

which has the greater brightness value. Blending with white inverts the base 

color values; blending with black produces no change. 

 Exclusion  

Creates an effect similar to but lower in contrast than the Difference mode. 

Blending with white inverts the base color values. Blending with black produces 

no change. 

 Hard Light 

Multiplies or screens the colors, depending on the blend color. The effect is 

similar to shining a harsh spotlight on the image.  

 Lighten 

Looks at the color information in each channel and selects the base or blend 

color--whichever is lighter--as the result color. Pixels darker than the blend 

color are replaced, and pixels lighter than the blend color do not change.  

 Linear Light 

Burns or dodges the colors by decreasing or increasing the brightness, 

depending on the blend color. If the blend color (light source) is lighter than 

50% gray, the image is lightened by increasing the brightness. If the blend 

color is darker than 50% gray, the image is darkened by decreasing the 

brightness.  

 Multiply 

Looks at the color information in each channel and multiplies the base color by 

the blend color. The result color is always a darker color. Multiplying any color 

with black produces black. Multiplying any color with white leaves the color 

unchanged. When you're painting with a color other than black or white, 

successive strokes with a painting tool produce progressively darker colors. The 

effect is similar to drawing on the image with multiple magic markers.  

 Overlay  

Multiplies or screens the colors, depending on the base color. Patterns or colors 

overlay the existing pixels while preserving the highlights and shadows of the 

base color. The base color is not replaced but is mixed with the blend color to 

reflect the lightness or darkness of the original color.  
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 Pin Light   

Replaces the colors, depending on the blend color. If the blend color (light 

source) is lighter than 50% gray, pixels darker than the blend color are replaced, 

and pixels lighter than the blend color do not change. If the blend color is darker 

than 50% gray, pixels lighter than the blend color are replaced, and 

pixels darker than the blend color do not change. This is useful for adding 

special effects to an image. 

 Screen  

Looks at each channel's color information and multiplies the inverse of the blend 

and base colors. The result color is always a lighter color. Screening with black 

leaves the color unchanged. Screening with white produces white. The effect is 

similar to projecting multiple photographic slides on top of each other.  

 Soft Light 

Darkens or lightens the colors, depending on the blend color. The effect is 

similar to shining a diffused spotlight on the image.  

Specifying opacity or flow  

You can specify opacity or flow for the following tools:  

 Opacity specifies the maximum amount of paint coverage applied by the 

brush, pencil, clone stamp, and paint bucket tools.  

 Flow specifies how quickly paint is applied by the brush tool. 

To specify opacity or flow 

Enter a value, or drag the slider for Opacity or Flow in the Options palette. 

Opacity or flow can range from 1% to 100%. For transparent paint or a weak 

effect, specify a low percentage value; for more opaque paint or a strong effect, 

specify a high value.  

2.   Using the eyedropper tool 

The eyedropper tool samples color to designate a new foreground or 

background color. You can sample from the active image. You can also specify 

the area sampled by the eyedropper tool. For example, you can set the 

eyedropper to sample the color values of a 3-by-3-pixel area under the pointer. 

To sample color with the eyedropper tool: 
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 Select the eyedropper tool  from the Toolbox. 

 In the Options palette, choose an option from the Sample Size menu. 

Note: 3 by 3 Average or 5 by 5 Average to read the average value of the 

specified number of pixels within the area you click. 

 Click the area containing the color you want to copy. 

3.    Using the brush tool  

Image Editor provides the brush tool to let you paint with the current foreground 

color.  

 Select the Brush tool from the Toolbox. 

 Do one of the following in the Options palette: 

 Click the triangle next to Brush, and set brush options: Diameter to 

control the size of the brush. Hardness to control the size of the brush's 

hard center 

 Specify a blending mode(See Selecting a blending mode) 

 Specify an opacity and a flow rate (See Specifying opacity or flow) 

 Drag the image to paint. 

4.    Using the paint bucket tool 

The paint bucket tool fills adjacent pixels that are similar in color value to the 

pixels you click.  

 Select the Brush tool  from the Toolbox. 

 Do one of the following in the Options palette: 

 Specify a blending mode(See Selecting a blending mode) 

 Specify an opacity (See Specifying opacity or flow) 

 Specify a tolerance   

Note: The tolerance defines how similar in color a pixel must be to be filled. 

Values can range from 0 to 255. A low tolerance fills pixels within a range of 

color values very similar to the pixel you click. A high tolerance fills pixels 

within a broader range. 

 Click the part of the image you want to fill. 

5.    Using the dodge tool 

The dodge tool is used to lighten areas of the image. 

To use the dodge tool: 
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 Select the dodge tool . 

 Do the following in the options palette:  

 Set brush options: Diameter to control the size of the brush. (See Using 

the brush tool)  

 Select what to change in the image: Shadows to change the dark areas; 

Highlights to change the light areas.  

 Drag over the part of the image you want to modify. 

6.    Using the burn tool  

The burn tool is used to darken areas of the image. 

To use the burn tool: 

 Select the burn tool . 

 Do the following in the options palette: 

 Set brush options: Diameter to control the size of the brush. Hardness 

to control the size of the brush's hard center (See Using the brush tool)  

 Select what to change in the image: Shadows to change the dark areas; 

Highlights to change the light areas.  

 Drag over the part of the image you want to modify. 

7.    Using the eraser tool 

 Select the Eraser tool  from the Toolbox. 

 Do one of the following in the Options palette: 

 Click the triangle next to Brush, and set brush options 

 Specify an opacity and a flow rate (See Specifying opacity or flow). 

 Drag the pointer over the area you want to erase. 

8.    Choosing foreground and background colors 

You can use the Color Picker to select the foreground or background color by 

choosing from a color spectrum or by defining colors numerically. 

You can designate a new foreground or background color using the eyedropper 

tool, the Color palette, or the Color Picker. (See Using the eyedropper tool and 

Using the color palette) 

The default foreground color is black, and the default background color is white.  

To display the Color Picker: 

Do one of the following: 
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 Click the foreground or background color selection box in the Toolbox.  

 Click the active color selection box in the Color palette.  

Flipping, Repairing and Cloning 

 Flipping entire images     

 Using the healing brush tool 

 Using the clone stamp tool 

1.    Flipping entire images 

 In the Toolbox, click  or  to flip the entire image horizontally or 

vertically. 

 To flip the image you select, click Rectangle tool or Lasso tool to select an 

area, and click Flip tool or . 

2.    Using the spot healing brush tool 

The spot healing brush tool effortlessly removes dust, scratches, blemishes, and 

other flaws and automatically preserves the shading, lighting, and texture of the 

original image. 

To use the healing brush tool: 

 Select the spot healing brush tool . 

 Do the following in the options palette: 

 Specify the diameter option to control the size of the brush.  

 Specify the roundness option to control the ratio between the brush's 

short and long axes. 

 Press down Alt key and click an area to define a source to repair. 

3.    Using the clone stamp tool 

The clone stamp tool takes a sample of an image, which you can then apply over 

another image or part of the same image. Each stroke of the tool paints on more 

of the sample.  

To use the clone stamp tool: 

 Select the clone stamp tool . 

 Do one of the following in the Options palette: 

 Click the triangle button next to Brush in the Options palette, and set 

brush options: Diameter to control the size of the brush. Hardness to 

control the size of the brush's hard center 
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 Specify a blending mode(See Selecting a blending mode) 

 Specify opacity and a flow rate (See Specifying opacity or flow). 

 Drag in the image. 

Using Filters 

1. On the menu bar, select the Filters menu. 

2. Select an item from the drop-down menu to add an effect to the image.  

Using the Options Palette 

Most tools have options that are displayed in the tool options palette. The 

options bar changes as different tools are selected. Some settings in the options 

bar are common to several tools, and some are specific to one tool.  

You can move the options bar anywhere in the work area. 

To display the tool options palette: 

Choose View > Image Toolbar > Options.  

 

Brush options palette 

To move the options bar: 

Drag the options bar by its title bar. 

Using the Layer Palette 

The Layers palette lets you set layer opacity, fill layers and choose a blending 

mode. 
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Layer palette 

Displaying the Layer palette 

Choose View > Image Toolbar > Layer. 

Setting layer opacity 

A layer's opacity determines to what degree it obscures or reveals the layer 

beneath it. A layer with 1% opacity appears nearly transparent, while one with 

100% opacity appears completely opaque. 

To specify opacity for a layer   

1. Select a layer or layer set in the Layers palette.  

2. In the Layer palette, enter a value in the Opacity text box or drag the Opacity 

slider.  

Using the Color Palette 

The Color palette displays the color values for the current foreground and 

background colors. Using the sliders in the Color palette, you can edit the 

foreground and background colors according to several different color models.  

Note: Image Editor uses RGB mode to work with images. 

 
Color palette 

To display the Color palette: 

Choose View > Image Toolbar > Color. 
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To select the foreground or background color:  

1. To edit the foreground or background color, make sure that its color selection 

box is active (outlined in black). To make the foreground or background color 

selection box active, click the box.  

2. Do one of the following:  

 Drag the color sliders. By default, the slider colors change as you drag.  

 Enter values next to the color sliders.  

Using the Histogram Palette 

A histogram can tell you whether or not your image has been properly exposed, 

whether the lighting is harsh or flat, and what adjustments will work best. This 

can show you whether the image contains enough detail in the shadows (shown 

in the left part of the histogram), midtones (shown in the middle), 

and highlights (shown in the right part) to make a good correction. 

 

Example Histogram 

To display the histogram for an image:  

Choose View > Image Toolbar > Histogram. 

Quit Image Editor 

1. Click the Close button on the upper right corner of the Image Editor 

window. 

 

2. You get a confirmation message asking you whether you want to save the 

modified image to the PDF file. Click Yes to save the changes to the PDF file, 

click No to abort the changes on the image and return to the Main window; 

click Cancel to continue working in the Image Editor window. 
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Chapter 8 – Working on Graphics 

Objects 
 

 

A graphics object is an arbitrary shape made of straight lines, rectangles, and 

cubic curves. A path may contain multiple sub-paths (or path segments). A path 

object can be painted (filled and stroked), and the unpainted (―invisible‖) path 

objects are sometimes used as placeholders or to denote text bounds. 

Setting Graphics Options 

Before inserting graphics, you might like to preset some options so that you can 

easily insert graphics with your personalized preferences. 

To set graphics options, do the following: 

 Select Edit > Options from the menu bar, or press Alt + O keyboard. 

 In the pop-up Options dialog box, click Graphics. 

 In the Graphics tab, change the values to suit your preferences. 

 After you are done, click the Ok button. Click Restore Default button to 

leave settings unchanged.  

Note: After you exit the program, all the changes are restored to default. 

Selecting Graphics Mode 

Before modifying graphics objects, you can select to work in a graphics state, so 

that you can easily and solely interact with those graphics objects without 

affecting any other type of objects.  

To select graphics state, do one of the following: 

1. Select Path from the drop down list of Choose Selected Objects’ Type 

in the Menu Bar.  

2. Select Edit > Options. In the pop-up dialog box, select the Other tab, and 

check ―Path only‖ under Objects Selection Mode.  
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Inserting New Graphic Objects  

With Foxit PDF Editor, you can swiftly insert graphic objects by a simple and 

useful Graphic Editor. 

  

To insert graph objects, do the following: 

 

1. Locate the page where you want to insert the image in your document, and 

then do one of the following: 

 Point to the Object toolbar, and click the Add a Graphics Object 

button  

 Select Object > Add Graphics on the Menu bar 

 Use keyboard shortcut CTR+R 

2. Your current Document window is switched to the Graphics Editor window 

(see example 2) 

3. Select one of path tools, and draw in the place where you want to insert the 

graphics (see example 3) 

4. After you are done, click the Save button  to exit and get back to the 

Document window.  

5. You are back to the Document window, and the graphic object is inserted 

(see example 4). You can adjust its size by dragging the sizing handles, or 

change its fill/stroke color.  

Example 1: Current Document Window 

 

Example 2: Graphics Editor Window 
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Example 3: Drawing a Graphic object 

 

Example 4: Inserted graphic in the Document window 
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Changing Graphics Properties 

To alter line width  

1. Click the graphics you want to change in your page (see example 1). 

2. In the Path Properties tab, click the value field next to Line Width. 

3. Input the value you want, and click any other place to change. 

See also: Line Width in Path Properties. 

Example: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

① Selected Graphics with 

Line Width value at 1 

 

② In the value filed, we 

input 10 to change the 

width 

 

③ The result graphics 

with line width at 10 
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To alter miter limit 

1. Click the graphics you want to change in your page. 

2. In the Path Properties tab, click the value field next to Miter Limit. 

3. Input the value you want, and click any other place to change. 

See also: Miter Limit in Path Properties. 

To alter line cap style 

1. Click the graphics you want to change in your page. 

2. In the Path Properties tab, drop down the combo box next to Line Cap 

Style. 

3. Select a style you want. 

See also: Line Cap Style in Path Properties. 

To alter line join style 

1. Click the graphics you want to change in your page. 

2. In the Path Properties tab, drop down the combo box next to Line Join 

Style. 

3. Select a style you want. 

See also: Line Join Style in Path Properties. 

To alter line dash pattern 

You can change the line to be a dashed or a solid pattern. 

1. Click the graphics you want to change in your page (see example 1). 

2. In the Path Properties tab, click the Dash value field, and click the edit 

button  next to it (see example 2). 

3. In the Edit box, input any negative numbers in the Dash Count, and 

change the Array value according to your preference (see example 3). 

4. Click any other place for the change to take effect. 

5. If you do not want a dashed line, input ―0‖ in the Dash Count. 
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Example: 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To fill/stroke graphics color in RGB/CMYK 

1. Click the graphics object you want to fill/stroke in your page. 

2. In the Path Properties tab, click the text field next to Fill Color/Stroke 

Color.   

3. Click the  button on the right to view current value. 

4. Click the Edit button on the right, drag the color bar match the color. 

5. After you done, click the  button to make the change. 

 

① Here, we click a round rectangle in 

the Document window 

 

②  Click the Dash value field and 

click Edit button 

 

③ Here we input 3 in the Dash 

Count, and 6 in the Array【0】， 

5 in the Array【1】， and 4 in the 

Array【2】 

 

④ The result graphics with Dash 

Count at 3. 
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RGB Fill/Stroke Color Box                             CMYK Fill/Stroke Color Box 

 

See Also: Setting Default Color for Objects 

To change the fill type for graphics fill color 

There are three different fill types to use, and Foxit PDF Editor takes No Fill as a 

default setting. If you find the text you selected cannot be filled, you must 

change the fill type to Alternate or Winding type. 

To change the fill type, do the following: 

 Click the Path Properties tab in the Properties pane. 

 Drop down the Fill Type box; and select a style of fill types. 

 After you are done, click any other place for the changes to take effect. 

See Also: Fill type in Path Properties. 

To change the stroke type for graphics stroke color 

Foxit PDF Editor takes No Stroke as a default setting. If you find the text you 

selected cannot be stroked, you must change the stroke type to Yes. 

To change the stroke type, do the following: 

1. Click the Path Properties tab in the Properties pane. 

2. Drop down the Stroke Type box and select Yes. 

3. After you are done, click any other place for the changes to take effect. 

About the Graphics Editor 

As you select to insert a graphic object in the Main window of Foxit PDF Editor, 

or double click a graphic object, you will be switched to the Graphics Editor 
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Window as shown in the following figure: 

 

Graphics Editor Window 

You can use the Path toolbar to add a line, rectangle, circle, or other shapes and 

then you can change and enhance these objects with colors and borders in the 

Main window.  

When you are drawing a shape, it stays selected until you click elsewhere on the 

page and a wireframe with sizing handles appears to let you adjust the size and 

shape. 

Note: Sizing handles are the small circles or squares that appear at the corners 

and sides of a selected object. You drag these handles to change the size of the 

object 

When drawing a graphic shape, you can press the Ctrl + Z or Ctrl+ Y to undo or 

redo your operation. After creating the graphics you intended, click the Save 

and Exit tool on the Path toolbar to go back to the Main window. 

 

 

 

 

 

   A  B    C    D  E   F    G   H    I    J   K   L   M    N 

 

A. Line tool B. Rectangle tool C. Ellipse tool D. Round Rectangle tool E. Polygon 

tool F. Polyline tool G. Polybezier tool H. Curve tool I. Delete tool J. Fit Window 
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tool K. Select tool L. Point Select tool M. Exit without Saving tool N. Save and 

Exit tool 

Note: If you don't see the Path toolbar in the program window, point to the 

View menu and then click Path toolbar. 

Drawing Graphics 

To draw a straight line 

1. Point to the Path toolbar and then click the Line tool . 

2. Click a region in the document where you want to create the drawing and 

draw the line. 

3. Drag the handles to adjust the line size if necessary. 

4. Click outside the shape when you are done to set the line. 

To draw a rectangle  

1. Point to the Path toolbar and then click the Rectangle tool  to create a 

square-cornered shape, or click the Rounded Rectangle tool  to create 

a round-cornered shape. 

2. Click a region in the document where you want to create the drawing and 

draw a rectangle. 

3. Drag the sizing handle diagonally in the direction you want. 

To draw an ellipse 

1. Point to the Path toolbar and then click the Ellipse tool . 

2. Drag the pointer to draw the ellipse. 

3. Click outside the shape when you are done to set the ellipse. 

To draw a polygon, polyline, or polybezier 

 Point to the Path toolbar and then click the Polygon tool , Polyline tool 

,or Polybezier tool . 

 Drag the pointer to draw a straight line. 

 Click once at each position where you want a new line segment to appear. 

 Click outside the shape when you are done to set the shape. 

To draw a curved line or a curved shape 
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1. Point to the Path toolbar and then click the Curved tool ; 

2. Draw a straight line by dragging the pointer.  

3. Click once at each position where you want a new line segment to appear.  

4. Click outside the shape when you are done, and then drag the sizing handle 

to adjust the curve. 

Editing Graphics 

You can use Image Editor to edit your graphics. 

To edit graphics, do the following: 

1. Double -click the image you want to edit in the Document window. 

2. You will be switched to the Graphics Editor window. 

3. In the Graphics Editor window, you can change the shape of the graphics, or 

add another graphics object onto it. 

4. After you are done, click the Save and Exit button  to close the Graphics 

Editor window and get back to your Document window. 

To sketch the shape 

1. Point to the Path toolbar and then click the Select tool . 

2. Click the object you want to sketch. 

3. Drag the sizing handle diagonally, horizontally, or vertically. 

To adjust the view   

 To fit the view, point to the Path toolbar, and click the Fit Window tool 

. 

 To zoom in/out the view, point to the Path toolbar, and click the zoom 

in/out tool . 

 To magnify or reduce the view in a percent degree, point to the Status 

bar and drop down the Zoom box, and then select a percent.  

To change the graphics 

1. Point to the Path toolbar and then click the Point Select tool . 

2. Click the graphics you want to change the shape of. 

3. Drag the handles to change the graphic shape. 

To resize the shape 

ms-its:C:/WINDOWS/Help/mspaint.chm::/paint_curves.htmHELP=glossary.hlp%20TOPIC=gls_drag
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1. Position the pointer over one of the sizing handles. 

2. Drag the sizing handle until the object is the shape and size you want. 

 To increase or decrease the size in one or more directions, drag the mouse 

away from or toward the center. 

 To maintain the object's proportions, drag one of the corner sizing handles.  

To shear the graphics 

1. Point to the Path toolbar and then click the Select tool . 

2. Double-click the graphics you want to shear. 

3. Drag the double arrow  to shear the graphic shape. 

4. Click outside the graphic shape to set the shearing. 

To rotate the graphics 

1. Point to the Path toolbar and then click the Select tool . 

2. Double-click the graphics you want to rotate. 

3. Drag the rotate handle on the graphics in the direction you want to 

rotate it.  

4. Click outside the graphic shape to set the rotation. 

To delete the graphics 

 Point to the Path toolbar and then click the Select tool . 

 Click the graphics you want to delete. 

 Click Delete tool  on the path toolbar or press DEL key. 

Quit Graphics Editor 

1. Click the Close button on the upper right corner of the Graphics Editor 

window. 

2. You get a confirmation message asking you whether you want to save the 

modified graphics to the PDF file. Click Yes to save the changes to the PDF 

file, click No to abort the changes on the graphics and return to the Main 

window; click Cancel to continue working in the Graphics Editor window. 
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Chapter 9 – Working on Shading 

Objects 
 

A shading starts at a certain point on the page with a given color and ends at a 

second point with different colors. Shading is used for many purposes like 

shadows, three dimensional appearances or simply to make a nice background 

for a diagram.  

A shading object has a smooth transition between colors across an area, and 

Foxit PDF Editor offers linear and radial gradients for users to choose.  

Selecting Shading Mode 

To modify shading objects, you can select to work in a shading state, so that you 

can easily and solely interact with those shading objects without affecting any 

other type of objects.    

To select shading state, do one of the following:  

1. Select Shading from the drop down list of Choose Selected Objects’ Type 

in the Menu Bar.  

2. Select Edit > Options. In the pop-up dialog box, select the Other tab, and 

check ―Shading only‖ under Objects Selection Mode.  

Inserting New Shading 

With Foxit PDF Editor, you can insert shading objects easily, just do the 

following: 

1. Locate the page where you want to insert the shading objects in your PDF 

document; 

2. From the Insert Object toolbar, click Add a Shading Object button , or 

select Object > Add Shading on the Menu bar.  

3. Your current Document window will be switched to the Shading Editor 

window.  

4. Select a tool from the Path Toolbar to draw a path anywhere within the 

current page. 

5. Select one shading color from the Select Shading Style which box popped up 
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in Shading Editor Window.  

6. Select Linear  or Radial  gradient, and drag mouse to draw a line 

within the path area or anywhere in the current page of PDF document, so 

that finish inserting new shading object. 

7. Edit colors to a shading, such as clicking underneath the preview bar to add 

colors, and clicking and dragging to move the colors and change the shading 

effect.  

8. Click the Save button  to save and exit to get back to the Document 

window. 

 

About the Shading Editor   

As you select to add a shading object in the Main window of Foxit PDF Editor, or 

double click a shading object, you will be switched to the Shading Editor 

window. 

Path Toolbar 

Shading Object 

 

Preset shading color 

Preview bar 

Linear and Radial gradients 



121 
 

 
Shading Editor Window 

Shading Object 

Foxit PDF Editor offers linear and radial gradients for users to choose. After 

drawing a path, you can select one shading color from the Select Shading Style 

box and choose Linear  or Radial  gradients from Shading Object. 

 

Shading Object 

Path Toolbar 

Select a tool from the Path Toolbar to draw a path anywhere within the current 

page, like adding a rectangle, circle, etc.  

Note: More information about drawing path, please see Drawing Graphics. 

 



122 
 

Select Shading Style 

Select Shading Style box will be popped up while switching to Shading Editor 

window. Here you can preset and edit the shading color. 

 

You can select the different shading colors from the Preset box, and to preview 

the shading effect of the path you drew in the current document page, please do 

one of the following: 

 If you check Apply option , you can automatically preview the 

shading effect of the path after choosing one shading color.  

 If you don’t check Apply option, you should click Apply button  

after selecting one shading color to preview the shading effect.  

After presetting shading color, you can also edit the shading color, like add new 

colors, delete existed colors, etc.  

Move colors 

Each color can be moved by clicking and dragging. 

  

Change colors to a shading 

Double click one color, and select the color you like in the Color dialog box. Also, 
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you can click the small square box  and choose one color you like. 

 

Add colors to a shading 

Select one color you like at first and click underneath the preview bar. There will 

be new colors added to a shading.  

 

Delete colors to a shading 

Click one color you want to delete, and click Delete button . Also, you 

can move it away from the preview bar, the color will be removed from shading.  

 

Drawing New Shading 

Linear shading 

Linear shading defines a field of color that varies along the line between the 

start and end coordinates and extends infinitely away from the line. Linear is 

just one form of interpolation that can be used to define the gradient fill of the 

shading.  

In the Shading Editor window, select a tool from the Path Toolbar to draw a path, 

and select Linear  on the Tool Bar and select one shading color in the Select 

Shading Style box. Now you can drag the mouse to draw a line within the path 

area or anywhere in the current page of PDF document. 

Note: More information about drawing path, please see Drawing Graphics. 
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You can drag either start or end point to move it individually, or drag the line to 

move them both at the same time. This moving will change the shading effect. 

Compare with Shading 1, Shading 2 is dragging the start point to move, Shading 

3 is dragging the end point to move, and Shading 4 is dragging the line to move.  

    

Shading 1             Shading 2           Shading 3            Shading 4 

Select one shading color from the Select Shading Style to preset, and you can 

edit shading color on the preview bar.  

To preset different shading colors 

You can select the different shading colors from the Preset box, and to preview 

the shading effect in the shading area.  

                 

For linear shading, the start 

and end point are shown, 

connected by a line. The 

transition from one color to 

another varies linearly 

along the line. The color 

gradient begins at the start 

point and finishes at the end 

point. 

 

Shading Area 

End Point 

Start Point 
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To edit shading colors 

You can add new colors, delete existed colors, or move any colors.  

Compare with shading 1, Shading 2 is dragging the color to move and changing 

the shading color order, Shading 3 is adding new colors, and Shading 4 is 

deleting the existed colors. 

       

Shading 1             Shading 2            Shading 3            Shading 4 

Note: For more information about presetting and editing shading colors, please 

see Select Shading Style. 

Radial shading 

Radial shading defines a color gradient fill between two circles or cylinders. This 

method is most commonly used to produce the visual effect of a 

three-dimensional sphere or cone. Radial shading is accomplished by 

one-dimensional interpolation along the radius of the circle, form the center of 

the circle outward. The resulting path can be either circular or elliptical. 

In the Shading Editor window, select a tool from the Path Toolbar to draw a path, 

and select Radial  on the Tool Bar and select one shading color in the Select 

Shading Style dialog box. Now you can drag the mouse to draw a line within the 

path area or anywhere in the current page of PDF document. 

Note: More information about drawing path, please see Drawing Graphics. 
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To bring out the inner circle 

When first creating radial shading, the inner circle has no radius; you really just 

see one circle. To bring out the inner circle and let its radius be greater than zero, 

first dissociate the circles’ centers by dragging the center point, then click and 

drag the inner circle’s center point to bring out the inner circle you like.  

   

Shading 1                    Shading 2                  Shading 3 

To move one of the circles 

To move one of the circles individually, click and drag the center point of the 

circle you wish to move. 

Compare with Shading 1, Shading 2 is dragging the inner circle’s center, and 

Shading 3 is dragging the outer circle’s center. 

For radial shading, both the 

inner and outer circle is 

shown, together with their 

centers. When first creating 

Radial shading, the centers 

are exactly on top of each 

other, and the inner circle 

has no radius.  

 

Inner Circle 

Inner Circle Center 

Outer Circle Center 

Outer Circle 

Shading Area 
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Shading 1                Shading 2             Shading 3 

To move both circles 

To move both inner circles and outer circles at the same time, just click and drag 

the line which connects the two circles’ centers.  

            

To resize the circles 

To resize one of the circles, click and drag the circumference of the circle.  
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Editing a Shading 

To edit an existing shading in the Shading Editor window, just do the following: 

1. Double-click the shading you want to edit in the Document window, or select 

the shading object and click Edit Object button  in the Menu Bar. 

2. You will be switched to the Shading Editor window. 

3. In the Shading Editor window, you can change the shape of the shading area 

and edit the shading colors. 

4. After done, click the Save and Exit button  to close the Shading Editor 

window and get back to your Document window. 

To sketch the shading objects 

Click the Select tool  and drag the sizing handle diagonally, horizontally, 

and vertically to sketch the shading objects.  

                 

To adjust the shading objects’ shape 

Click the Select Point tool  and drag the handles to change the shading 

area’s shape.  
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Note: There are four kinds of sizing handles, included yellow , green , blue 

and red small square.  

 The yellow small square is the start point of the path.  

 The green one is the center point fo the path, click and drag it to move the 

whole path.  

 The blue one is to pull the endpoint which connects two curves. 

 The red one will be shown if there are curves in the path, and it is to adjust 

the curve which is conneted by two blue squares, and the bule squares are 

adjacent to the red small square. 

To edit the shading colors 

Click one shading color to preset in the Select Shading Style, or edit colors on 

the preview bar.  

More information of editing shading colors, please see Select Shading Style. 

To rotate the shading objects 

 Click the Select tool  and then double-click the path you want to rotate. 

 Drag the handle  around the path to rotate the shading object.  

 When finished, click outside the path shape to set the rotation.  

 Also, you can change the Rotate values  in the Properties 

Pane in the Document window. 

                                   

To shear the shading objects 

 Click the Select tool  and then double-click the path you want to shear. 

 Drag the handle  around the path to shear the shading object.  

 When finished, click outside the path shape to set the shearing. 
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 Also, you can change the Shear values  in the Properties 

Pane in the Document window. 

                   

Quit Shading Editor window 

To quit the Shading Editor window, just do the following: 

1. Click the Close button on the upper right corner of the Shading Editor 

window. 

2. You get a confirmation message asking you whether you want to save the 

modified shading to the PDF file. Click Yes to save the changes to the PDF file; 

click No to abort the changes on the shading and return to the Main window; 

click Cancel to continue working in the Shading Editor window.  

3. Also, you can click Exit without save button  on the Menu bar, if you just 

want to exit and return to the Document window without saving any 

changes to the PDF file  

About shading properties 

In the Document window, you can check the shading properties and modify the 

related values in the Properties Pane.  

Extend is an optional array of two Boolean values that specify whether or not to 

extend the start and end colors past the start and endpoints, respectively. The 

default value for each element of the array is true.  

1. If the Extend Boolean values are true, the field may also extend infinitely far 

along the line, past either or both endpoints, using the constant color of that 

endpoint. 

2. If the Extend Boolean values are false, the field may stop extending past 
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either or both endpoints, using the constant color of that endpoint. 

Setting the Extend values to ―true‖ will extend the gradient fill towards the 

drawing direction with the color where it leaves off or starts.  

 In the shading object with ―true true‖ Extend values, the start and end color 

will separately extend to the fields past the start and end points. 

 In the shading object with ―false false‖ Extend values, the start and end 

color will stop extending to the fields past the start and end points. 

 In the shading object with ―true false‖ Extend values, the start color will 

extend to the field past the start point, and the end color will stop extending 

the field past the end point.  

 In the shading object with ―false true‖ Extend values, the start color will 

stop extending to the field past the start point, and the end color will extend 

the field past the end point.  

    

true true             true false             false true            false false 

 

  

true true             true false             false true           false false 

 

       

true true             true false             false true           false false 
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Keyboard Shortcuts 

There are number of keyboard shortcuts that you can use to speed up your 

navigation within the Foxit PDF Editor. Some particularly important ones are 

listed here: 

Zoom out    Alt + - 

Zoom in    Alt + + 

Set to background  Alt + 1 

Set to foreground  Alt + 2 

Go to a specified page   Ctrl + G 

Load image   Ctrl +I 

Insert Text Ctrl + T 

Insert Graphics Ctrl + R 

Modify Object  Ctrl + M 

Import Font Alt + I 

First page   Alt + T      

Next page   Alt +N      

Previous page    Alt + P     

Last Page   Alt + L 

Undo    Ctrl +Z     

Redo    Ctrl +Y 

Delete Selected object    Delete 

Page Delete Alt + Del 

Move one point  up , down, left, right arrows 

Move ten point  Ctrl +( up , down, left, right 

arrows) 

File top    Home 

File End    End 

Select All Ctrl + A 

Copy    Ctrl + C        

Paste     Ctrl + V   

Cut   Ctrl + X    

New File Ctrl + N 

File Print Ctrl + P 

File Open Ctrl + O 

Set Options Alt + O 

Saving and exiting the in-place editing mode ESC 

Fill a selection with the foreground color Alt + Delete 

Fill a selection with the background color Ctrl + Delete 

Deselect a selection Ctrl + D 
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Contact Us 

Feel free to contact us should you need any information or have any problems 

with our products. We are always here, ready to serve you better. 

 Office Address: 

Foxit Corporation 

39819 Paseo Padre Parkway 

Fremont CA 94538 

USA 

 Mailing Address: 

Foxit Corporation 

39819 Paseo Padre Parkway 

Fremont CA 94538 

USA 

 Sales: 

1-866-MYFOXIT or 1-866-693-6948 (8AM-5PM PST Monday - Friday)  

510-438-9090 (8AM-5PM PST Monday - Friday) 

408-307-9358 (8AM-5PM PST Monday - Friday) 

 Support: 

1-866-MYFOXIT or 1-866-693-6948 (8AM-5PM PST Monday - Friday) 

979-446-0280 (6AM-5PM PST Monday - Friday) 

 Fax: 

510-405-9288 

 Website: 

www.foxitsoftware.com 

 E-mail: 

Sales and Information - sales@foxitsoftware.com 

Technical Support - support@foxitsoftware.com 

Marketing Service - marketing@foxitsoftware.com 

http://www.foxitsoftware.com/
mailto:sales@foxitsoftware.com
mailto:support@foxitsoftware.com
mailto:webmaster@foxitsoftware.com
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