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END USER LICENSE AGREEMENT 

 

Foxit Form Designer End User License Agreement 

 

IMPORTANT NOTICE 

 

Thank you for choosing Foxit Form Designer. This license is the legal agreement 

(Agreement) between you, the customer who has acquired Foxit Form Designer 

(“You”) and Foxit Software Company (“Foxit”). Please read this agreement 

carefully.  

 

Foxit is only willing to provide Foxit Form Designer to you on the condition that you 

accept all of the terms contain in this Agreement. You accept all of the terms by 

using Foxit Form Designer. 

  

If you did not acquire Foxit Form Designer from Foxit, or an authorized Foxit 

distributor, then you may not enter into this Agreement or use Foxit Form Designer. 

No other party has the right to transfer a copy of Foxit Form Designer to you.  

 

If you are unwilling to accept this Agreement, do not use Foxit Form Designer. If 

you have already paid for Foxit Form Designer with having a prior opportunity to 

review this Agreement, and are now unwilling to agree to these terms, you may, 

within thirty (30) days after the date on which you acquired Foxit Form Designer, 

return it to Foxit, or the authorized distributor from whom you acquired it, along 

with its original packaging and proof-of-purchase, for a full refund. 

 

Notwithstanding anything herein to the contrary, Foxit authorized distributors do 

not act as agents of Foxit, and such distributors may not enter into any contracts 

on behalf of Foxit Software Company. No authorized distributor has the authority 

to modify the terms of this Agreement.  

 

1. OWNERSHIP 

 

Foxit Form Designer is licensed. It is not sold, even if for convenience we make 

reference to words such as “sale” or “purchase.” Foxit Form Designer is protected 

by copyrights and other intellectual property rights. You agree that all worldwide 

copyright and other intellectual property rights in Foxit Form Designer, however 

made, are the exclusive property of Foxit. All rights in Foxit Form Designer not 

expressly granted to you in this Agreement are reserved by Foxit. There are no 

implied licenses under this Agreement. 
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2. GRANT of LICENSE 

 

This agreement grants you the following rights: 

 

Usages - You may use one copy of Foxit Form Designer on a single computer at a 

time and only by one user at a time. 

 

Network Storage/Use - You may also store a copy of Foxit Form Designer on a 

storage device, such as a network server, used only to run Foxit Form Designer on 

your other computers over an internal network; however, you must acquire and 

dedicate a license for each separate computer on which Foxit Form Designer is 

installed or run from the storage device. 

 

Concurrent Use - A license for Foxit Form Designer may not be used concurrently 

on different computers, however, this agreement does allow a licensed user to 

install Foxit Form Designer on both a work computer and a home computer, 

provided the Foxit Form Designer is not in use on both machines at the same time. 

 

3. OTHER RIGHTS AND LIMITATIONS 

 

Limitations on Reverse Engineering, Decompilation, and Disassembly - You may 

not reverse engineer, decompile, or disassemble Foxit Form Designer, except and 

only to the extent that such activity is expressly permitted by applicable law not 

withstanding this limitation. 

 

Separation of Components – Foxit Form Designer is licensed as a single product. Its 

component parts may not be separated for use on more than one computer. 

 

Rental - You may not rent or lease Foxit Form Designer. 

 

Software Transfer - You may permanently transfer all of your rights under this 

Agreement, provided you retain no copies, you transfer all of Foxit Form Designer 

(including all component parts, the media and printed materials, any upgrades 

and this Agreement), and the recipient agrees to the terms of this Agreement.  

 

Termination - Without prejudice to any other rights, Foxit Software Company may 

terminate this Agreement if you fail to comply with the terms and conditions of this 

Agreement. In such event, you must destroy all copies of Foxit Form Designer and 

all of its component parts. 

 

Development License Restrictions - These restrictions apply to a licensee who 

develops Application Software that utilizes Foxit Form Designer in a commercially 

distributed application. 
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(i) Must purchase a license of Foxit Form Designer for each copy of the 

Application Software sold; 

(ii) Foxit Form Designer is not the sole or primary component of such Application 

Software;  

(iii) You must give proper acknowledgment of the copyright of Foxit Software 

Company;  

(iv) Must not be used to create a software application that competes with or is 

intended to compete, directly or indirectly, with Foxit Form Designer;  

(v) The Application Software must add significant value to the Foxit Form Designer. 

 

All other uses that fall outside the scope of this Agreement must receive the 

written permission of Foxit. 

 

4. DOCUMENT COPYRIGHTS 

 

Foxit Form Designer does not allow you to alter PDF documents protected by a 

password, or without password but encrypted, and with modification permission 

disabled by the copyrights owner. However, for otherwise unprotected PDF 

documents, you must also observe the copyrights of the documents. Foxit will not 

be liable to any loss caused directly or indirectly by copyrights infringing when you 

use Foxit Form Designer to alter documents illegally. 

 

5. LIMITED WARRANTY 

 

Foxit, warrants that Foxit Form Designer contained herein will, for a period of thirty 

(30) days from the date of delivery, perform substantially in accordance with the 

accompanying documentation. NO OTHER WARRANTIES. Foxit disclaims all other 

warranties, either express or implied, including but not limited to implied warranties 

of merchantability and fitness for a particular purpose, with respect to the 

Software, the accompanying written materials. 

 

In the event of any breach of warranty or other duty owed by Foxit, Foxit’s entire 

liability and your exclusive remedy shall be, at Foxit’s option, either (a) return of the 

price paid by you for the product (not to exceed the suggested U.S. retail price) if 

any, (b) repair or replacement of the defective product. This Limited Warranty is 

void if failure of the product has resulted from accident, abuse, or misapplication. 

Any replacement product will be warranted for the remainder of the original 

warranty period or ten (10) days, whichever is longer. 

 

6. NO LIABILITY FOR CONSEQUENTIAL DAMAGES 

 

In no event shall Foxit be liable for any damages whatsoever (including but not 

limited to damages for loss of business profits, business interruption, loss of business 

information, or any other pecuniary loss) which results from the use or inability to 
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use Foxit Form Designer, even if Foxit has been advised of the possibility of such 

damages. Because some states/jurisdictions do not allow the exclusion or 

limitation of consequential or incidental damages, the above limitations may not 

apply to you. 

 

7. UPDATES AND SUPPORTS 

 

When you purchase a Foxit Form Designer license from Foxit, you receive more 

than the usual right to use the current version of the software. Along with a 

perpetual license to the current official version of the product, you receive the 

following:  

 

 Unlimited access to software updates for one year from the date of license 

purchase, with no limit on minor or major release.  

 Unlimited free technical support by e-mail for one year.  

 

To receive the above services, you need to register your purchased copy of Foxit 

Form Designer with Foxit. Upon registration, Foxit will collect your information 

including name of you or your organization, email address as well as unique CD 

key of your purchased copy of Foxit Form Designer. Foxit will retain those 

information for providing the above services. Foxit will not reveal your information 

to any third party unless required doing so by law. 

 

8. GOVERNING LAWS  

 

If Foxit Form Designer was purchased in the United States, this Agreement is 

governed by the laws of the state of California; otherwise, local laws may apply. 

 

9. GENERAL PROVISIONS 

 

If any part of this Agreement is found void and unenforceable, it will not affect the 

validity of the balance of this Agreement, which shall remain valid and 

enforceable according to its terms. This Agreement shall not prejudice the 

statutory rights of any party dealing as a consumer. This Agreement may only be 

modified by a writing signed by an authorized officer of Foxit. Updates may be 

licensed to you by Foxit with additional or different terms. This is the entire 

agreement between Foxit and you relating to Foxit Form Designer and it 

supersedes any prior representations, discussions, undertakings, communications 

or advertising relating to Foxit Form Designer. 

 

Should you have any questions concerning this Agreement or if you desire to 

contact Foxit Software Company for any reason, please write to Foxit Software 

Company, 39819 Paseo Padre Parkway, Fremont, CA 94538, USA, or send us an 

email at sales@foxitsoftware.com. 

mailto:sales@foxitsoftware.com
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Foxit Form Designer 

Foxit Form Designer is a group of tools in Foxit Reader that can be used to create 

interactive forms. With Foxit Form Designer, you are able to add push buttons, text 

fields, check boxes, combo boxes, list boxes or radio buttons to create an 

interactive PDF form and specify their properties. The easy-to-use Foxit Form 

Designer enables you to quickly design forms and make changes to the PDF forms 

if you are authorized to modify them. 

Foxit Form Designer is not free. You may evaluate form designer functions before 

buying it. If you do so, evaluation marks will be added to the top-right corner of 

the modified pages. But after you purchase a license of Foxit Form Designer, you 

will be able to get rid of the evaluation marks.  

Note: The license automatically covers all the features that are available in Pro 

Pack. Also, you will be authorized to use Form Filler and Spell Checker if you 

purchase Foxit Form Designer.  

Overview 

Foxit Form Designer offers six basic tools for you to create a form. The following is a 

table of the six form tools and their respective descriptions. 

Six Basic Tools 

Button 
Tool 

Name 
Description 

 

Push 

Button 

Tool 

Creates an interactive form element to initiate certain 

predefined actions, such as opening a file, submitting data 

to a web server, or resetting a form. This button can also be 

customized with images and text. 

 

Radio 

Button 

Tool 

Presents a group of choices from which the user can select 

only one item. 

 
Check 

Box Tool 

Presents yes-or-no choices for individual items. If the form 

contains multiple check boxes, users can select what they 

want. 

 
Combo 

Box Tool 

Lets the user either choose an item from a pop-up menu or 

type in a value. 

 
List Box 

Tool 
Displays a list of options the user can select. 

 
Text Field 

Tool 

Lets the user type in text, such as name, address, phone 

number, etc. 
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A PDF Form 

In Foxit Reader, you can create form fields by dragging the selected form field on 

the document page to your preferred location. You can name the form field and 

define the size either using the mouse or through the attribute setting. For each 

field type, you can set a variety of options through the form field Properties dialog 

box. 

Text 

Field 

Push Button 

Check Box 

Combo Box 

List 

Box 

Radio 

Button 
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Using push button tool 

You can create a new push button with push button tool. 

Creating a new push button 

In Foxit Reader, select push button tool by clicking its button  on Form Toolbar 

or choosing Tools > Advanced Editing Tools > Push Button on Menu Bar, and do 

one of the following: 

 Drag to create a push button of the required size. 

 Double-click the page to create a push button using the default size. 

 In the Button Properties dialog box which opens automatically, select 

property options to specify the push button behavior.  

See also 

“Setting push button properties” . 

Moving and resizing a push button 

After you create a push button, you may need to move or resize it to give the 

page a cleaner, more professional look. 

 To move a push button, select Annotation Selection Tool  or push button 

tool , click and drag the button to move it to a new location. 

 To resize a push button, select Annotation Selection Tool  or push button 

tool , click to select the button, and then drag a border handle.  

Deleting a push button 

 Select Annotation Selection Tool  or push button tool , click the push 

button you want to delete. 

 Press Delete, or right-click the push button > Delete. 

Creating multiple copies of a push button 

You can create multiple copies of a push button. The new push button names are 

based on the original push buttons and appended with a number. However, you 

are able to create them with the same names. In addition, all the new push 

buttons are created sequentially, using standard array format. 

 Select one or more push buttons that you want to copy (press Shift or Ctrl 
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when clicking to select more buttons).  

 Right-click one of the buttons > Create Multiple Copies… 

 In the Create Multiple Copies of Fields dialog box, do the following: 

 

The Create Multiple Copies of Fields dialog box 

A. To specify the rows to be created, enter or select a number in Copy 

Selected fields across (times). The default number is set to 2. 

B. To specify the columns to be created, enter or select a number in Copy 

Selected fields across (times). The default number is set to 2. 

C. To specify the width of the area in which the columns of fields appear, 

enter or select a number in Change Width (in). The default number is set to 

0.06. 

D. To specify the height of the area in which the columns of fields appear, 

enter or select a number in Change Height (in). The default number is set 

to 0.06. 

Note: The width and height values don’t change the dimensions of individual 

fields but designate the size of the entire area for all the selected and newly 

created fields. 

E. To change the position of buttons, use the Up, Down, Left, and Right 
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buttons in the dialog box. 

F. Click Preview to apply the results. 

G. Click Same Name to apply the names of original buttons to the newly 

created buttons, and click OK. 

Note: Copies of push buttons function independently of each other. You can 

use a different procedure to duplicate push buttons, creating an information- 

sharing relationship among these buttons. 

Duplicating a push button across multiple pages 

 Select the push button that you want to duplicate. 

 Right-click the button > Duplicate… 

Note: The Duplicate command isn’t available for forms with only one page. 

 Do one of the following: 

A. To duplicate the push button on every page in the form, select All, and 

click OK. 

B. To duplicate the push button on a limited range of pages, click the From 

button, and type the starting and ending pages on which you want the 

button to appear. Click OK. 

Note: Enter the page number including or not including the page on which the  

button originally appears doesn’t affect the duplication process. Including that  

page won’t create a second copy on top of the original one, and not including it  

won’t remove the original button. 

Setting push button properties 

How a push button behaves is determined by settings in the Button Properties 

dialog box. You can set properties that apply formatting, determine the 

appearance and actions, and so forth. 

The push button has a General tab, Appearance tab, Actions tab, and an 

Options tab. Besides, there are two items on every tab: 

 Locked – When selected, prevents any further changes to any push button 

properties. 

 Close – Applies and saves the current button properties, and closes the 

button properties dialog box. 

Note: If you select Locked on any tab, it will lock all options for the button, but not 

just the options on that tab. 
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1. General tab for the button properties 

The General tab in push button properties contains the following options: 

 Name – Specifies the unique name of the selected push button. 

 Tooltip – Displays text that the hesitant user may find helpful in clicking the 

button. Tooltips appear when the pointer hovers over the push button. 

 Form Field – Specifies whether the push button can be seen, either on screen 

or in print. There are four choices for you: Visible, Hidden, Visible but doesn’t 

print, and Hidden but printable. 

 Orientation – Rotates the push button by 0, 90, 180, or 270 Degrees. 

 Read Only – Prevents the user from clicking the push button. 

 Required – This option is not available for the push button. 

2. Appearance tab for the button properties 

The Appearance properties determine how the push button looks on the page. 

The Appearance tab in push button properties contains the following options: 

 Line Style – Alters the appearance of the frame. Select Solid, Dashed, Beveled, 

Inset or Underline. 

                          

Solid          Dashed          Beveled           Inset          Underline 

The appearances of Push Button with different line styles 

Note: You may not see the differences if no color is chosen as the border color. 

 Thickness – Specifies the width of the frame surrounding the push button: Thin, 

Medium, or Thick. 

 Border Color – Opens a color picker in which you can select a color for the 

frame surrounding the button. To leave the button without a frame, select No 

color. 

 Fill Color – Opens a color picker in which you can select a color for the button. 

To leave the button uncolored, select No color. 

Note: A Fill Color choice other than No color will block any images on the PDF 

page that are behind the button. 

 Font Size – Sets the size of the label for the button. You can either choose Auto, 

various preset values, or type in a different value.  

 Text Color – Opens a color picker in which you can select a color for the label. 
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 Font – Lists the fonts available on your computer. 

 

Push Button 

3. Actions tab for the button properties 

The Actions properties specify any actions that you want to associate with the 

push button, such as jumping to a specific page or going to a web site. The 

Actions tab in push button properties contains the following options: 

 Select Trigger – Specifies the user action that initiates an action: Mouse Up, 

Mouse Down, Mouse Enter, Mouse Exit, On Focus, or On Blur. 

 Select Action – Specifies the event that occurs when the user triggers the 

action: Go to a page view, Open/execute a file, Open a web link, Show/hide 

a field, Execute a named command, Submit a form, Reset a form, Import from 

data, and Run a JavaScript. 

A. Go to a page view – designate to a specific page view. You can not only 

designate to a page in the current PDF, but also to the page in another 

PDF. Also, you may change the current zoom setting and then set the 

position. 

   To go to a page view, choose this option, click Add button and do one of 

the following: 

 Set the position in current document – scroll the current document, go to 

a new position where you want to set and click Set this position. 

 Set the position in another PDF document – click the Open button  on 

the toolbar > select the PDF you want to set position > scroll this document 

and go to a position where you want to set > click Set this position.  

Note: The new PDF document should be opened in the existing window but not 

a new window. 

 Change the view magnification -- scroll in the current document or 

another document > go to a new position where you want to set > 

change the magnification of the position > click Set this position.  

 Click Cancel to revoke your operation. 

B. Open/execute a file – designate to open another file. To do this, please 

Font Size: 30 

Text Color: Green 

Font: Times New Roman 
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follow the steps below: 

 Choose Open/execute a file > click Add button > select the destination 

file and click Select. 

C. Open a web link – designate to open a web link. Do the following: 

 Choose Open a web link > click Add button > enter the URL of the 

destination web page.    

D. To show/hide a field, select the option > click Add… > choose to show or 

hide the selected button when the user triggers the action, and click OK. 

E. To execute a named command, select the option > click Add… > select 

one of the named commands in Execute a named command dialog box, 

and click OK. 

F. To submit a form, select the option > click Add… > choose the submission 

method, decide which fields should be submitted, and click OK. 

G. To reset a form, select the option > click Add… > select the fields that will 

be reset, and click OK. 

H. To import form data, select the option > click Add… > choose the FDF file 

that contains the form data you want to import, and click Open. 

I. To run a JavaScript, select the option > click Add… > Enter JavaScript, and 

click Save and Close. 

 Actions – Displays the list of triggers and actions that you have defined. 

 Up and down buttons – Change the order in which the selected action 

appears listed under the trigger. (Available only when you have defined 

multiple actions for the same trigger.) 

 Edit – Opens a dialog box with specific options for the selected action. You 

can also double-click the actions to open a dialog box. 

 Delete – Removes the selected action. 

4. Options tab for the button properties 

The Options properties determine how labels and icons appear on the button. A 

button can have a label, an icon, or both. The Options tab in push button 

properties enables you to add any labels you like. The Options tab in push button 

properties contains the following options: 

 Layout – Specifies the layout of label and icon of the button. There are seven 

choices: 
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   A           B          C          D          E           F          G 

A. Label only  B. Icon only  C. Icon top, label bottom  D. Label top, icon bottom  E. Icon left, 

label right  F. Label left, icon right  G. Label over icon 

Button Layouts 

 Advanced – Does the details settings to the icon.  

    A. When to scale – choose when to scale the icon you insert. There are four 

options: 

      Always: scale the icon to fit the button you draw. 

      Icon is too Big: zoom out the icon to fit the button if the former one is bigger 

than the latter one, or show the icon with its original size. 

      Icon is too Small: zoom in the icon to fit the button if the former one is 

smaller than the latter one, or show the icon with its 

original size. 

      Never: never scale the icon. Show the icon with its original size all the time. 

    B. Scale – choose to scale the icon non-proportionally or proportionally. This  

option will be disabled when you select Never in the field of When to scale. 

      Non-proportionally: scale the icon to fit the button when the magnification 

is changed. 

      Proportionally: scale the icon in its proportion. 

C. Fit to bounds – check this option to scale the icon to fit fully within the 

bounds of the button without taking into consideration the line width of the 

border. 

D. Border – drag and move the scroll bar to change icon’s position in the 

button. The coordinates change when you move the scroll bar. 

 

 Behavior – Specifies the display of the button when clicked. The button 

behavior options include: 

None: Keeps the appearance of the button the same. 

Push: Specifies appearances for the Up, Down, and Rollover states of the 

mouse. Select an option under State, and then specify a label or icon option: 

Up: Determines what the button looks like when the mouse button is not 

clicked. 

Down: Determines what the button looks like when the mouse is clicked on the 
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button, but before it is released. 

Rollover: Determines what the button looks like when the pointer is held over 

the button. 

Outline: Highlights the button border. 

Invert: Reverses the dark and light shades of the button. 

                

 

The Button Behaviors 

 To define the label or icon that appears on the button, do the following: 

A. If a label option is selected form the Layout menu, type the text in the 

Label box. 

B. If an icon option is selected from the Layout menu, click Choose icon… > 

click Browse… > Select the file type from the Objects of Type menu, 

double-click the file name, and click OK. (To remove the selected icon, 

click Clear button.) 

 Click Close to accept these display properties. 

Setting push button properties as default 

After setting button properties for a new push button, you can set your settings as 

the new default for all the push buttons you create in future. 

 

To set the current properties as default, right-click the push button > select Use  

Current Properties as New Defaults. 

Using radio button tool 

A radio button is a type of graphical user interface widget that allows you to 

choose one of a predefined set of options. 

Creating a new radio button 

Please refer to “Creating a new push button” . 

Note: Related radio buttons must have exactly the same form field name but 

different export values. This ensures that the radio buttons toggle and that the 

correct values will be collected in the database. 

Push 
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Moving and resizing a radio button 

Please refer to “Moving and resizing a push button” . 

Deleting a radio button 

Please refer to “Deleting a push button”. 

Creating multiple copies of a radio button 

Please refer to “Creating multiple copies of a push button” . 

Duplicating a radio button across multiple pages 

Please refer to “Duplicating a push button across multiple pages” . 

Setting radio button properties 

How a radio button behaves is determined by settings in the Radio Button 

Properties dialog box. You can set properties that apply formatting, determine the 

appearance and actions, and so forth. 

The radio button has a General tab, Appearance tab, Actions tab, and an 

Options tab as push button. Also, there are two items on every tab: 

 Locked – When selected, prevents any further changes to any radio button 

properties. 

 Close – Applies and saves the current button properties, and closes the 

button properties dialog box. 

Note: If you select Locked on any tab, it will lock all options for the button, but not 

just the options on that tab. 

1. General tab for the radio button properties 

The General tab in radio button properties contains the following options: 

 Name – Specifies the unique name of the selected radio button. 

 Tooltip – Displays text that the hesitant user may find helpful in clicking the 

button. Tooltips appear when the pointer hovers over the radio button. 

 Form Field – Specifies whether the radio button can be seen, either on screen 

or in print. There are four choices for you: Visible, Hidden, Visible but does not 

print, and Hidden but printable. 

 Orientation – Rotates the radio button by 0, 90, 180, or 270 Degrees. 

 Read Only – Prevents the user from clicking the radio button. 

 Required – Forces the user to click the radio button. If the user attempts to 
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submit the form while a required radio button is not chosen, an error message 

appears. 

2. Appearance tab for the radio button properties 

The Appearance properties determine how the radio button looks on the page. 

The Appearance tab in push button properties contains the following options: 

 Line Style – Alters the appearance of the frame. Select Solid, Dashed, Beveled, 

Inset or Underline. 

                                            

Solid           Dashed        Beveled           Inset           Underline 

The appearances of Radio Button with different line styles 

Note: You may not see the difference if no color is chosen as the border color. 

 Thickness – Specifies the width of the frame surrounding the radio button: Thin, 

Medium, or Thick. 

 Border Color – Opens a color picker in which you can select a color for the 

frame surrounding the button. To leave the button without a frame, select No 

color. 

 Fill Color – Opens a color picker in which you can select a color for the 

background behind the button. To leave the background uncolored, select 

No color. 

Note: A Fill Color choice other than No color will block any images on the PDF 

page that are behind the button. 

 Text Color – Opens a color picker in which you can select a color for the 

button. 

   

Radio Button 

3. Actions tab for the radio button properties 

 Please refer to “Actions tab for the button properties” . 

Border color 

Text color 

Fill color 
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4. Options tab for the radio button properties 

The Options tab in radio button properties enables you to change the button 

style and do other additional settings. The Options tab in radio button properties 

contains the following options: 

 Button style – Specifies the shape of the maker that appears inside the button 

when the user selects it. There’re six choices in total: Check, Circle (the 

default), Cross, Diamond, Square, or Star. This property does not alter the 

shape of the radio button itself. 

 Export Value – Identifies the radio button and differentiates it from other radio 

buttons that share the same Name value. The statuses of a radio button are 

“on” and “off”. You can give them other names with this box. 

 Checked by default – Sets the selection state of the button when the user first 

opens the form. 

 Radio buttons with the same name and value are selected in unison – Allows 

single-click selection of multiple related radio buttons. If the user selects a 

radio button that has the same field name and export value as another, both 

radio buttons are selected. 

 Click Close to accept these display properties. 

Setting radio button properties as default 

After setting radio button properties for a new radio button, you can set your  

settings as the new default for all the radio buttons you create in future. 

 

To set the current properties as default, right-click the radio button > select Use  

Current Properties as New Defaults. 

Using check box tool 

Please refer to “Using radio button tool” . 

Using combo box tool 

A combo box is a commonly-used GUI widget. It is a combination of a drop-down 

list or list box and a single-line textbox, allowing the user either to type a value 

directly into the control or choose from the list of existing options. 

Creating a new combo box 

Please refer to “Creating a new push button” . 
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Moving and resizing a combo box 

Please refer to “Moving and resizing a push button” . 

Deleting a combo box 

Please refer to “Deleting a push button” . 

Creating multiple copies of a combo box 

Please refer to “Creating multiple copies of a push button” . 

Duplicating a combo box across multiple pages 

Please refer to “Duplicating a push button across multiple pages” . 

Setting combo box properties 

How a combo box behaves is determined by settings in the Combo Box Properties 

dialog box. You can set properties that apply formatting, determine the 

appearance and actions, perform mathematical operations, and so forth. 

The combo box has a General tab, Appearance tab, Actions tab, Options tab, 

Format tab, Validate tab, and a Calculate tab. There are two items on every tab: 

 Locked – When selected, prevents any further changes to any combo box 

properties. 

 Close – Applies and saves the current properties, and closes the combo box 

properties dialog box. 

Note: If you select Locked on any tab, it will lock all options for this combo box, but 

not just the options on that tab. 

1. General tab for the combo box properties 

Please refer to “General tab for the radio button properties” . 

2. Appearance tab for the combo box properties 

Please refer to “Appearance tab for the button properties” . 

3. Actions tab for the combo box properties 

Please refer to “Actions tab for the button properties” . 
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4. Options tab for the combo box properties 

You can create a list of items from which the user selects with the Options tab. 

 Item – Accepts the text that you type for options that you want to appear in 

the menu for the field. 

 Add – Moves the current entry in Item to Item List. 

 Export value – Where you type in a value to represent the item if the data will 

be exported. If left blank, the entry for Name in the General tab is used as the 

export value. 

 Item list – Displays the choices that will be available in the list.  

Note: The highlighted item in the Item List box appears as the default selected 

item in the combo box field. To change the default item, highlight another item 

from the list. 

 Up and Down arrows – Change the order in which the items are listed in the 

combo box list. These buttons are not available if Sort Items is selected. 

 Delete – Removes the selected item from the list. 

 Sort items – Arranges the listed items numerically and alphabetically. A 

numerical sort (if applicable) is performed before an alphabetical sort. 

 Allow user to enter custom text – Enable users to enter a value other than the 

ones in the list. 

 Commit selected value immediately – Saves the value as soon as the user 

selects it. If this option is not selected, the value is saved only when the user 

tabs out of the current field or clicks another form field. 

5. Format tab for the combo box properties 

The Format tab in the combo box properties dialog box enables you to format the 

field values. Select one of the categories listed below: 

 None – No additional options are available. The input in a combo box with this 

property does not require any specific formatting. 

 Number – Automatically imposes the selected formatting options on numeric 

data entries. 

A. Decimal places – Sets the number of digits that appear to the right of the 

decimal point. 

B. Separator style – Sets the placement of commas and periods. 

C. Currency symbol – Sets the type of currency, such as Dollars, Euros, or 

Pounds. 

D. Negative Number Style – Sets how negative numbers are displayed. You 

can choose Show parentheses, Use red text, neither, or both. 
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 Percentage – Automatically imposes the selected formatting options on 

numeric data expressed as a percentage. 

A. Decimal places – Sets the number of digits that appear to the right of the 

decimal point. 

B. Separator style – Sets the placement of commas and periods. 

 Date – The list includes one-, two-, and four-digit variations where d stands for 

the day, m stands for the month, and y stands for the year. Also, you can 

choose Custom option and type your format. 

 Time – The list includes display variations where h stands for the hour on a 

12-hour clock, H stands for the hour on a 24-hour clock, MM stands for minutes, 

ss stands for the seconds, and tt stands for AM or PM. Also, you can choose 

the Custom option and type your format. 

 Special – There are five options for you: 

 

A. Zip Code – For a five-digit postal code. 

B. Zip Code + 4 – For a nine-digit postal code. 

C. Phone Number – For a ten-digit telephone number. 

D. Social Security Number – For a nine-digit US Social Security Number.  

E. Arbitrary Mask -- Changes the format category to Custom and makes 

another text box available, in which you can type a custom format. Use 

this option to specify which types of characters the user can enter in any 

given position, and how the data displays in the field. 

 

a. A -- Accepts only letters (A–Z, a–z). 

b. X -- Accepts spaces and most printable characters, including all 

characters available on a standard keyboard and ANSI characters in 

the ranges of 32–126 and 128–255.  

c. O -- The letter “O” accepts alphanumeric characters (A–Z, a–z, and 

0–9).  

d. 9 -- Accepts only numeric characters (0–9).  

For example, a mask setting of AAA--p#999 accepts the input BDF--p#367. 

A mask setting of OOOOO@XXX accepts the input vad12@3Up. 
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Example of an Arbitrary Mask entry 

 Custom -- Makes additional options available to form designers who want to 

write their own JavaScripts for formatting and keystrokes. For example, a 

custom script could define a new currency format or limit the user entry to 

specific keystroke characters. 

A. Custom Format Script – Displays any custom scripts you have added for 

formats. The Edit button opens a JavaScript Edition dialog box in which 

you can write and add new scripts. 

B. Custom Keystroke Script –Displays any custom scripts you have added to 

validate keystrokes. The Edit button opens a JavaScript Edition dialog box 

in which you can write and add new scripts. 

6. Validate tab for the combo box properties 

The Validate properties restrict entries to specified ranges, values, or characters, 

ensuring that users enter the appropriate data for a combo box. 

 Field value is not validated – Turns off validation. 
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 Field value is in range – Sets a numeric range for a combo box using values 

you enter in either as a number or a percentage. It is available only when 

Number or Percentage is selected in Format tab. 

 Run custom validation script – Validates by a JavaScript that you create or 

provide. The Edit button opens a JavaScript Edition dialog box in which you 

can write and add new scripts. 

7. Calculate tab for the combo box properties 

With this option, you can perform mathematical operations on existing form field 

entries and display the result. 

 Value is not calculated – Select this option if you want the users to type. 

 Value is the – Select this to make further options available: 

A. The List includes the mathematical functions to apply to the selected 

fields. Choose Sum to add the values entered in the selected fields, 

Product to multiply them, Average, Minimum, or Maximum. 

B. Pick – Opens a Field Selection dialog box with a list of the available fields 

in the form that you select to add or deselect to remove from the 

calculation. 

 Simplified field notation -- Uses JavaScript with field names and simple 

arithmetic signs. The Edit button opens a JavaScript Edition dialog box in 

which you can write, edit, and add scripts. 

 Custom calculation script -- Displays any custom scripts you have added for 

calculations. The Edit button opens a JavaScript Edition dialog box in which 

you can write and add new JavaScripts. 

Setting combo box properties as default 

After setting combo box properties for a new combo box, you can set your  

settings as the new default for all the combo boxes you create in future. 

 

To set the current properties as default, right-click the combo box > select Use  

Current Properties as New Defaults. 

Using list box tool 

A list box is a GUI widget that allows the user to select one or more items from a list 

contained within a static, multiple line text box. Also, you can set a list box 

property that enables the user to Shift-click or Ctrl-click/Control-click to select 

multiple items on the list.  
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Creating a new list box 

Please refer to “Creating a new push button” . 

Moving and resizing a list box 

Please refer to “Moving and resizing a push button” . 

Deleting a list box 

Please refer to “Deleting a push button” . 

Creating multiple copies of a list box 

Please refer to “Creating multiple copies of a push button” . 

Duplicating a list box across multiple pages 

Please refer to “Duplicating a push button across multiple pages” . 

Setting list box properties 

How a list box behaves is determined by the settings in the List Box Properties 

dialog box. You can set properties that apply formatting, determine the 

appearance and actions, and so forth. 

The combo box has a General tab, Appearance tab, Actions tab, Options tab, 

and a Selection Change tab. Also, there are two items on every tab: 

 Locked – When selected, prevents any further changes to any list box 

properties. 

 Close – Applies and saves the current properties, and closes the list box 

properties dialog box. 

Note: If you select Locked on any tab, it will lock all options for this list box, but not 

just the options on that tab. 

1. General tab for the list box properties 

Please refer to “General tab for the button properties” . 

2. Appearance tab for the list box properties 

Please refer to “Appearance tab for the button properties” . 
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3. Actions tab for the list box properties 

Please refer to “Actions tab for the button properties” . 

4. Options tab for the list box properties 

You can create a list of items from which the user selects with the Options tab. 

 Item – Accepts the text that you type for options that you want to appear in 

the menu for the field. 

 Add – Moves the current entry in Item to Item List. 

 Export value – Where you type in a value to represent the item if the data will 

be exported. If left blank, the entry for Name in the General tab is used as the 

export value. 

 Item list – Displays the choices that will be available in the list.  

 Up and Down arrows – Change the order in which the items are listed in the list 

box. These buttons are not available if Sort Items is selected. 

 Delete – Removes the selected item from the list. 

 Sort items – Arranges the listed items numerically and alphabetically. A 

numerical sort (if applicable) is performed before an alphabetical sort. 

 Multiple selection – Enable users to choose more than one item in the list. 

 Commit selected value immediately – Saves the value as soon as the user 

selects it. If this option is not selected, the value is saved only when the user 

tabs out of the current field or clicks another form field. 

5. Selection Change tab for the list box properties 

Decide the action of the list box when the selection changes: 

 Do nothing – Nothing happens when the list box selection changes. 

 Execute this script – Execute any custom scripts you have added for the list 

box. The Edit button opens a JavaScript Edition dialog box in which you can 

write and add new JavaScripts. 

Setting list box properties as default 

After setting list box properties for a new list box, you can set your settings as the  

new default for all the list boxes you create in future. 

 

To set the current properties as default, right-click the list box > select Use Current  

Properties as New Defaults. 
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Using text field tool 

A text field is a common element of graphical user interface of computer 

programs, as well as the corresponding type of widget used when programming 

GUIs, which let the user type in text, such as name, address, phone number, etc. 

Creating a new text field 

Please refer to “Creating a new push button” . 

Moving and resizing a text field 

Please refer to “Moving and resizing a push button” . 

Deleting a text field 

Please refer to “Deleting a push button” . 

Creating multiple copies of a text field 

Please refer to “Creating multiple copies of a push button” . 

Duplicating a text field across multiple pages 

Please refer to “Duplicating a push button across multiple pages” . 

Setting text field properties 

Although most of the properties are common to those of combo boxes, the 

Options tab is exclusive. 

1. For all the other properties of a text field, please refer to “Setting combo box 

properties”. 

2. Options tab for the text field properties 

 Alignment – Aligns the text left, right, or center within the field. 

 Default Value – Specifies the text that appears until the user overwrites it by 

typing in the field. Enter the default value by typing in this option. 

 Multi-line – Allows more than a single-line entry in the text field. 

 Scroll long text – Compensates for text that extends beyond the boundaries of 

the text field. 

 Allow Rich Text Formatting – Allows users to apply styling information to the text, 

such as bold or italic. This might be useful in certain text fields where such 

styling information is important to the meaning of the text, such as an essay. 
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 Limit of Characters – Allows entries of up to the number of characters you 

specify. 

 

Note: If you entered a default value, that value is clipped to this limit. 

 Password – Displays the user-entered text as a series of asterisks (*). This option 

is available only if Check Spelling is deselected. 

 Field is used for file selection – Allows the user to enter a file path as the field’s 

value when a file is submitted along with the form. This option is available only 

when Scroll long text is the only selected option in the Options tab. 

 Check spelling – Checks the spelling of user-entered text. 

 Comb of Characters -- Spreads the user-entered text evenly across the width 

of the text field. If a border color is specified, Solid or Dashed Line is selected in 

the Appearance tab, each character entered in the field is separated by 

lines of that color. This option is available only when no other check box is 

selected. 

                  

A                                       B 

A. Text field with a border color, using the Comb property 

B. Text field without the Comb property 

Text fields with and without the Comb property 

Setting text field properties as default 

After setting text field properties for a new text field, you can set your settings as  

the new default for all the text fields you create in future. 

 

To set the current properties as default, right-click the text field > select Use  

Current Properties as New Defaults. 

Arranging form fields 

After you create form fields, you may need to rearrange them to give the page a 

cleaner, more professional look.  

Selecting multiple form fields 

To arrange the form fields, you have to select multiple form fields that you want to 

arrange first. 
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To select multiple form fields, do one of the following: 

 Choose the Annotation Selection tool  > Shift-click or Ctrl-click each form 

field. 

 Choose the Annotation Selection tool  > drag a selection marquee 

around the area to select them.  

To deselect an individual form field, Ctrl-click the specific field. 

Note: The form field highlighted in red is the anchor. When you select multiple form 

fields by clicking, the last field selected is the anchor. 

Aligning multiple form fields 

You can align the selected form fields left, right, top, bottom, vertically or 

horizontally. Select one of the form fields as the anchor, the rest of the form fields 

will be placed respectively to the left edge, right edge, top edge, bottom edge, 

vertical axis or horizontal axis of the anchor form field. 

 Select two or more form fields that you want to align. 

 Right-click the anchor, and then choose a command as follows: 

A. To align a column of form fields, choose Left, Right, or Vertically to align 

them respectively to the left edge, right edge, or vertical axis of the 

anchor form field. 

B. To align a row of form fields, choose Top, Bottom, or Horizontally to align 

them respectively to the top edge, bottom edge, or horizontal axis of the 

anchor form field. 

Note: When you right-click or Ctrl-click one of the selected form fields, it will be 

highlighted in red, indicating that it’s the anchor form field. The align menu 

commands move the other selected form fields to line up with the edges of the 

anchor form fields. 

Centering multiple form fields 

This function enables you to center the rectangle enclosed by the form fields you 

select vertically, horizontally or both. 

 Select form fields. You can imagine that these form fields consist of an area 

with the shape of rectangle. 

 Right-click one of the form fields > Center > Vertically/Horizontally/Both. You 

will find that the rectangle is centered respectively vertically, horizontally or 

both in the page. 
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Distributing multiple form fields 

This function will be available when selecting three or more form fields. 

 To distribute the form fields evenly between the topmost and bottommost form 

fields, choose Distribute > Vertically. 

 To distribute the form fields evenly between the leftmost and rightmost form 

fields, choose Distribute > Horizontally. 

Resizing multiple form fields 

You can adjust multiple form fields with the same height, width, or both. Select 

one of the form fields as the anchor, and the rest of the form fields will be resized 

with the same height or width as that of the anchor form field. For example, 

 Select form field A and B. Suppose that you want to set A as the anchor form 

field. 

 Right-click A > Size > Height/Width/Both. And you’ll see that the height/width/ 

height and width of B is resized to be the same as that of A. 

 

Setting form-field tab order 

After you create the form fields, you can set the tab order with ease. If you 

deselect to set the tab order, it will be automatically determined in a normal 

order. 

Do the following: 

 With the Annotation Selection Tool  selected, right-click a form field, and 

choose Set Tab Order. 

 Click anywhere in the field that you want to be first in the tabbing order. The 

number in the upper left corner is set as 1. 

 Click each of the other fields in the order that you want tabbing to occur. 

Note: If you decide not to change the tabbing order, click a blank area of the 

page or a part of the page that is not part of a field. This hides the tabbing order 

numbers so that clicking a field no longer changes the tabbing order. 

Setting calculation order 

When you define two or more calculations in a form, the order in which they are 
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carried out is the order in which you defined the calculations. In some cases, you 

may need to modify the calculation order to obtain correct results.  

For example, if you wanted to use the result obtained from calculating two form 

fields to calculate the value of a third form field, the first two form fields must be 

calculated together first to obtain the correct final results. 

 Choose Advanced > Form Utilities > Set calculation order… 

The Calculate Order dialog box displays all calculable fields in your form and the 

order in which the calculations are performed. 

 To change the field calculation order, select the field from the list, and then 

click the Up or Down button as needed. 

 Click OK. 

Setting properties of multiple form fields 

 Select multiple form fields > right-click one of them > Properties… 

 There pops up a dialog with a General tab and an Appearance tab, and then 

follow the steps specified above. 
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Contact us 

Feel free to contact us should you need any information or have any problems 

with our products. We are always here, ready to serve you better. 

 Office Address: 

Foxit Software Company 

39819 Paseo Padre Parkway 

Fremont, CA 94538 

USA 

 Mailing Address: 

Foxit Software Company 

PO Box 612588 

San Jose CA 95161 

USA 

 Sales: 

510-438-9090, 408-307-9358 and 408-507-8778 

 Support: 

408-329-7976 

 Fax: 

510-405-9288 

 Website: 

www.foxitsoftware.com 

 E-mail: 

Sales and Information - sales@foxitsoftware.com 

Technical Support - support@foxitsoftware.com 

Website Questions - webmaster@foxitsoftware.com 

 

http://www.foxitsoftware.com/
mailto:sales@foxitsoftware.com
mailto:support@foxitsoftware.com
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