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What’s new?
If you are familiar with Foxit Advanced PDF Editor version 2, here is a summary of 
the major enhancements to version 3. 

•	 “Commenting toolbar” on page 24
•	 “Joining multiple PDFs” on page 27
•	 “PDF photo albums” on page 28
•	 “Reducing PDF file size” on page 102
•	 “Inserting new images” on page 41
•	 “Object borders” on page 42
•	 “Layout grid” on page 46
•	 “Layout guides” on page 47
•	 “Line arrows” on page 48
•	 “Layers” on page 49

•	 “Redacting text” on page 59
•	 “Background colour” on page 68

•	 “Remapping fonts” on page 90
•	 “Cloning objects across pages” on page 93
•	 “Deleting objects across pages” on page 97

•	 “Find & Replace in hyperlinks” on page 120

•	 “Page margins” on page 128
•	 “Watermarking pages” on page 129
•	 “Page labels” on page 131

•	 “Comments catalogue” on page 142
•	 “Stamps and signatures” on page 147
•	 “Text highlighting” on page 151
•	 “Bookmark font filters” on page 158
•	 “Article threads” on page 164

•	 “Exporting images & illustrations” on page 171
•	 “Exporting tabular information” on page 175
•	 “Exporting article threads” on page 178
•	 “ePub” on page 181

•	 “Preferences” on page 191
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Basic text editing
Foxit Advanced PDF Editor enables you to edit text in a PDF document as if you 
were using a regular word processor.

Open the PDF to be edited.

In this example there is an ‘r’ missing 
from ‘you’.

From the toolbar select the  
Text tool.

Click the mouse on the text to be edited. 
After a short pause, while Foxit Advanced 
PDF Editor prepares the page for editing, 
you can start editing.

Edit the text - in this example the letter 
“r” has been added to “your”. 

The red box indicates that the text box is 
too small to show all the text. 

In the next step the text box will be re-
sized to reveal this hidden text.

1

2

3

Continued...

Notes
•	 The new ‘r’ is displayed in red because Show changes is enabled in the Preferences 

dialogue. This change highlighting is only visible in Foxit Advanced PDF Editor and 
not in any other PDF viewer. 
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To reveal the missing text, resize the text 
box.

Drag the left & right resize handles 
outwards to make the box slightly wider.

3

4

The text now fits on two lines as before.

Save the changes you have made to your 
PDF.

If you have the free version of Foxit 
Advanced PDF Editor you will see this 
dialogue box.

You have the option to save your PDF 
with a watermark added to edited pages. 
These watermarks can be safely removed 
at a later date if you decide to purchase 
the software.

The second option activates your copy 
of Foxit Advanced PDF Editor using 
the activation key supplied when you 
purchased the product. After activation 
watermarks are no longer added to PDFs. 

To remove existing watermarks from 
documents edited earlier, save them 
again from the activated version of Foxit 
Advanced PDF Editor.

5

Continued from previous page
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Form filling
Foxit Advanced PDF Editor can be used to quickly fill-in basic PDF forms. These 
are simply PDF versions of traditional paper forms that would otherwise have to be 
printed out, filled-in by hand then scanned back into the computer. 

Using Foxit Advanced PDF Editor you can speed up the entire process while keeping 
the form entirely digital and available to email to a third party.

Foxit Advanced PDF Editor Form Filler offers simplified menus and toolbars for the 
purpose of filling-in forms. In this mode Foxit Advanced PDF Editor does not add 
watermarks to edited documents.

Open a PDF to be filled-in.

If your PDF has interactive elements (not 
just a simple form) you will be asked if 
you want to remove them.

If you leave them in and fill-out the form, 
the interactive elements may obscure 
your answers when viewed in other 
PDF viewers. If you only intend to view 
or print your document using Foxit 
Advanced PDF Editor, it doesn’t matter 
which option you choose.

Select the Text Plus tool.

As you move the mouse over the 
form, Foxit Advanced PDF Editor will try 
to highlight the areas to be filled-in. 

Click on a highlighted area to begin 
typing into it.

Hold the Control key when you click to 
ignore Foxit Advanced PDF Editor’s guess 
and create a small, single-line text box.

1

2

Continued...
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If Foxit Advanced PDF Editor determines 
that the item under the mouse looks like 
a check-box, it changes the cursor to a 
pointing hand.

Click to mark the box with an X.  
Click again to remove the X.

Hold the Control key and click to ignore 
the check-box and create a small, single-
line text box.

Hold Control+Shift to force Foxit Advanced 
PDF Editor to create an X even when 
it doesn’t recognise the area as being a 
checkbox.

Notes
•	 Use the Text Plus tool to create new text boxes in any kind of PDF not just form-style 

documents.
•	 The Text Plus tool does not edit existing text - only text created by the tool either 

during this session or from when the PDF was last edited.
•	 Since Foxit Advanced PDF Editor is making a guess as the shape and location of 

editable areas, it may sometimes arrive at an incorrect decision. In this case, hold 
down Control as you click to ignore the guess. 

•	 Filled-in forms are normal PDFs that can be viewed and printed by any PDF viewing 
application.

Continued from previous page
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OCR corrections
Foxit Advanced PDF Editor can be used to adjust the hidden text associated with a 
scanned document. This text is generated by OCR (Optical Character Recognition) 
software from a scanned image of a printed page. 

The OCR text is hidden in the PDF so that it can be searched. Often there are errors 
in the hidden text that can be difficult to fix because it is hidden.

Open the PDF to be corrected then 
choose Document->OCR Corrections->Start

The example shows a scanned page in 
which the text added by the OCR process 
is hidden.

Since OCR mode could cause a PDF to be 
substantially changed, you will be asked 
to confirm your choice.

Always make sure you have a backup of 
the PDF before you start this mode.

Choose the “Start OCR mode” option to 
begin. 

The hidden text becomes visible, the 
scanned image faded and locked to make 
editing easier.

You can now edit the text whilst making 
reference to the original content in the 
image.

1

2

3
Continued...
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This example shows some corrections 
(shown in red because Show Changed 
Text has been enabled in the Preferences 
dialogue box).

After all corrections have been done, 
choose: Document->OCR Corrections->Finish 

The OCR text, including any edits you 
made will become invisible and the 
scanned image restored to its normal 
density.

Notes
•	 If your document happened to contain any non-ocr text added after the scanning 

process, this too will be hidden at the end of the correction process.
•	 Choose View->Text Boundaries to see the boundaries between different blocks of text.
•	 Changing the colour of the OCR text can make it easier to distinguish from the 

background image. This will not effect the finished PDF.
•	 Some OCR packages create many small text blocks that are difficult to edit. Use the 

“Rebuilding text boxes” on page 85 in Foxit Advanced PDF Editor to merge disjoint 
blocks of text into a single, editable text block.

4

Continued from previous page
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Activating your software
Foxit Advanced PDF Editor adds watermarks to saved PDFs unless you activate the 
software using the code supplied when purchased.

Activations codes are usually provided as part of a purchase receipt email. If you 
cannot find your code, please contact sales@foxitsoftware.com

Continued...

Choose Help->Buy/Activate... from the main 
menu bar to display the Buy/Activate Foxit 
Advanced PDF Editor dialogue box.

If you have your activation key code to 
hand, press Activate...

If you have not yet purchased Foxit 
Advanced PDF Editor, press Purchase. 

This will attempt to open the Foxit 
Advanced PDF Editor web page using 
your web browser.

Once you have bought a license and have 
an activation key, press the Activate... 
button.

1

On-line Activation

Your code may be a number or sequence 
of numbers and letters or your email 
address.

On-line activation is the quickest method. 

If your computer does not have an 
internet connection, uncheck this box.

2
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Continued from previous page

Potential Problems
If you computer is behind a fire wall or web access is blocked in some way, the 
activation may not succeed. If this is the case, follow the off-line activation 
instructions below.

Off-line activation
Uncheck the Activate on-line check box to reveal the lower part of the dialogue box.

Continued...

This is the code you should send to 
Foxit (your code will be different to that 
pictured) . The code changes every time 
you install Foxit Advanced PDF Editor.

Press the Copy button to copy the code 
to the clipboard (to avoid copying it by 
hand)

3
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Continued from previous page

Foxit will use the code you send to 
generate an off-line activation key- 
normally within 24 hours (except at 
weekends)

When you receive your off-line key enter 
it here.

The key will only work on the computer 
you used to generate the code. 

It will not work if you have re-installed 
Foxit Advanced PDF Editor on that 
computer since you requested the off-line 
activation.

4
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Toolbars
The first three toolbars and the status bar are shown by default, the others are 
hidden. 

All of the toolbars shown below can be shown or hidden by using the View->Toolbars 
menu. 

Edit toolbar - see page 22

Navigation toolbar

Text formatting toolbar

Drawing toolbar - see page 23

Navigation toolbar - see page 24

Alignment toolbar

Status bar - see “Status bar” on page 25
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Hand tool - grab the document and pan around to view hidden areas.

Zoom tool - click to zoom in. Control-click to zoom out. Drag out a box to zoom 
into a region.

Object tool - click to select objects, move and resize by dragging the re-size 
handles. Drag our a box to select a group of objects. See page 30.

Rotate tool - only active when objects have been selected with the Object tool. 
Click to change rotation origin. Drag to rotate the selection.  
See page 33.

Text tool - click to edit existing text.

Text plus tool - click to add a new text box or edit an existing box added with 
the tool. Drag to create a new, larger text box.

Linked text tool - click on blocks of text to link them together in order. Click 
again to unlink. Text will flow between linked blocks.

Crop tool - click and drag to create a crop box. Resize the crop box then press 
Return to perform the crop. 

Hyperlink tool - drag out a box to create a new hyperlink, table or image 
annotation.

Article tool - drag out a new article box around text. Link article boxes 
together for easier reading and export.

Pipette tool - click on an object to copy its fill & stroke colours to the currently 
selected object(s). See page 37

Colour picker - click to change the fill or stroke colours of the selection. Also 
changes the line-width used for stroking. See page 35

Edit toolbar
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Drawing toolbar
Choose View->Toolbars->Drawing to show/hide the toolbar.

Pencil (Freehand) - create freehand line drawings. 

Rectangle - hold down SHIFT while dragging to create squares.

Pen - connected straight lines. 

Ovals - hold down SHIFT while dragging to create circles.

Single lines - single straight lines. Can have arrows applied to their ends.

End arrows - the size of the applied decoration is related to 
the line width.

Start arrows - apply various types of arrowhead to the start 
of a line or group of connected lines.

Toggle border - place a simple border around the selected object(s). Useful for 
placing a border around images.
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Commenting toolbar
Choose View->Toolbars->Commenting to show/hide the toolbar. 

Similar to the drawing tools, these tools allow you to add a comment to each 
annotation. Unlike the drawing tools, the annotations do not form part of the PDF 
page but are placed in a separate layer that floats over the page.

The annotations you create also appear summarised in the Comments catalogue.  
(View->Comments).

Sticky note - Drag out a box to the size of the required sticky note. 

Rectangle note - drag out a rectangle. Hold SHIFT while dragging for squares. 
Double click to edit the attached note.

Circle note - drag to create an oval. Hold SHIFT while dragging to create a 
circle.

Polygon note - create connected straight line shapes. 

Scribble (Freehand) note - create freehand line drawings. 

Line note - create a single line

Text highlight - toggles a highlight on the selected text. Select text with the 
Text tool, then press this button to highlight it.

Stamp tool - add a predefined stamp to a page such as “Confidential”, “Draft”, 
“Sign here”. Also add your signature to a page. 

Right-click the mouse over an annotation 
and choose Properties... to access the 
Properties dialogue from where you 
can change the colour and style of the 
annotation.
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Status bar
The status bar (View->Status Bar) provides at-a-glance information and short cuts to 
commonly used functions and dialogue boxes.

Lock icon - visible only when the 
current document has security 
restrictions.

Double-click to open the 
Document Security dialogue

The dimensions of the currently 
selected object(s). 

Only visible when using the 
Object Select tool.

Rendering mode - shows either Preview 
or Outlines depending upon the current 
rendering mode.

Outline is quicker to draw and makes 
editing quicker. It has no permanent effect 
on the PDF, only while viewed in Foxit 
Advanced PDF Editor. 

Double click to toggle between modes.

Page label - only present if the 
PDF uses page labels.

Double-click to edit document’s 
page labels. 

Dimensions of the 
current page
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Converting PDF to other formats
To convert a PDF into HTML, text or RTF or to export the images within a PDF, 
use file File->Export menu. 

Foxit Advanced PDF Editor can export a document on a page-by-page basis or an 
article-by-article bases.

Exporting a range of pages
Choose File->Export->Pages as...

Choose the range you wish to export.

Near the bottom of the dialogue box is a 
summary of the output format that will 
be used for the export. To change the 
output format, press Format... 

The output options available are detailed 
in “General export settings” on page 
179.

Exporting by article thread
Choose File->Export->Articles as...

If your document contains no article 
threads you will need to create some. See 
“Adding article threads” on page 164.

Choose to export just the articles 
beginning on the current page, or all 
articles in the document. If no articles 
begin on the current page, only one 
option will be available.

Near the bottom of the dialogue box is a 
summary of the output format that will 
be used for the export. To change the 
output format, press Format... 

The output options available are detailed 
in “General export settings” on page 
179.
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Joining multiple PDFs
Foxit Advanced PDF Editor can quickly join multiple PDF documents into a single 
document.

Drag & drop any number of PDF files onto an open but empty Foxit Advanced PDF 
Editor window or choose File->Join...

Adding files
Add further files or entire 
folders full of files using the Add 
Files... and Add Folder... buttons. 
When adding folders, any 
PDF found in the folder or its 
sub-folders will be added to 
the list. There is no limit on 
the number of files that can be 
added.

Re-ordering documents
The order of the files in the list is the order in which they will be joined together. To 
change the order, select a file then press Up or Down to move it higher or lower in the 
list.

Joining
Press Join to begin the process 
of merging the documents 
together. Foxit Advanced 
PDF Editor will prompt for a 
filename for the new merged 
document.

Once the process is complete, 
Foxit Advanced PDF Editor 
will ask if you wish to open the 
new file.

Notes
•	 To add page numbers to a document after merging see “Cloning objects across 

pages” on page 93.
•	 Foxit Advanced PDF Editor will reject encrypted PDFs. Remove any passwords and 

encryption from all files before trying to join. See “Security settings” on page 135
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PDF photo albums
Drag & drop any number of images onto Foxit Advanced PDF Editor and the 
software will create a new PDF in which each page shows one of the images 
dropped.

Ensure no documents are open in Foxit 
Advanced PDF Editor.

Foxit Advanced PDF Editor will construct 
a new PDF in which each page contains 
one of the dropped images.

Drag & drop a selection of JPEG, 
Tiff, PNG or BMP images onto Foxit 
Advanced PDF Editor.

1

2

3



Editing Graphics & Images

☞☞ Aligning objects
☞☞ Changing colour & line width (CMYK)
☞☞ Copying colours between objects
☞☞ Grouping objects
☞☞ Hiding objects
☞☞ Inserting new images
☞☞ Layers
☞☞ Layout grid
☞☞ Layout guides
☞☞ Line arrows
☞☞ Locking objects
☞☞ Object borders
☞☞ Replacing images
☞☞ Rotating objects
☞☞ Scaling objects
☞☞ Selecting objects
☞☞ Stretching objects
☞☞ Swatches catalogue

29
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Select the Object tool from the tool 
bar.

Click on a single object to select it.

If objects overlap, the top-most object is 
selected. 

Ctrl+Shift to select the next object 
underneath the current object. Each time 
you Ctrl+Shift, the next object down is 
selected.

Selecting objects

Drag out a box to select all objects 
touching the box.

Hold Shift to remove objects from the 
current selection.

Cut/Copy/Paste may be used on single 
objects or groups of objects.

Notes
•	 Press Backspace or Delete on your keyboard to delete selected objects.
•	 Click and drag to move the object or selection of objects to a new position. 
•	 Use the cursor keys to move selected objects by 1 point (1/72 inch). Hold the Shift key 

as well to move by 10 points.
•	 Copy/Paste of graphics between Foxit Advanced PDF Editor & other applications is 

not supported.

Some pages are littered with invisible objects making selections difficult. These 
objects can usually be safely removed without altering the appearance of the page.

To see invisible objects, choose View->Outlines or double-click on the Preview in the 
status bar at the bottom of the main Foxit Advanced PDF Editor window.
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Stretching objects
Selected objects can be stretched by dragging the handles on the sides or corners of 
the selection box. Alternatively, choose Object->Scale Selection...

Select the object(s) to be stretched 
using the Object tool.

Drag one of the four side-handles or four 
corner-handles to stretch.

To retain the aspect ration of the original 
shape(s), hold down the SHIFT key while 
dragging. Doing so in this example would 
result in a larger circle, not a large oval.

The selected objects will be stretched to 
fit the box you dragged out.

Using the Object tool to stretch a text box 
will stretch the text. To resize a text box 
without stretching the text, use the Text 
tool.

1

2

Notes
•	 Line widths are not affected when stretching in this way. To scale these too, use  

Object->Scale Selection... dialogue box.
•	 Objects and selection may also be scales using Object->Transform Selection... 
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Scaling objects
Select the objects to be scaled using 
the Object tool.  
Then choose Object->Scale selection... 
from the main menu.

Using the Scale dialogue box you can 
scale the selection by a single value or 
different values of the X and Y scales.

You can also specify whether the line 
width of objects being scaled is also 
scaled.

Press the Copy button to scale a new copy 
of the selection.

1

2

3
The image on the left shows the effect of a 200% scale which also scaled the line width. The 
image on the right was scaled without effecting line widths.

Notes
•	 Objects and selection may also be scaled using Object->Transform Selection...
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Rotating objects
Selected objects can be freely rotated by any angle. Alternatively, choose  
Object->Rotate Selection... 

Select the object(s) to be rotated 
using the Object tool.

Now choose the Rotate tool.

Drag the selection’s outline to the desired 
orientation.

Hold down the Shift key while dragging 
to constrain rotation to 45˚ angles (0, 45 ,̊ 
90 ,̊ 135˚ etc.)

Stop dragging to complete the rotation.

After rotation, the Object tool will 
become active again. 

1

2

3

Continued...

Notes
•	 Objects and selection may also be rotated (or sheared) using Object->Transform 

Selection... 
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Changing rotation origin
Objects can be rotated around an arbitrary point.

Select the object(s) to be rotated 
then select the Rotate tool.

Click the left mouse button to 
reposition the origin. 

Drag the selection’s outline to the desired 
orientation.

Hold down the Shift key while dragging 
to constrain rotation to 45˚ angles (0, 45 ,̊ 
90 ,̊ 135˚ etc.)

Stop dragging to complete the 
rotation.

After rotation, the Object tool will become 
active again. 

Rectangle’s origin has been moved to the centre 
of the circle1

2

3

Continued from previous page
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Changing colour & line width
Foxit Advanced PDF Editor lets you change the fill and stroke colours of selected 
objects. Various different selection methods are offered including a CMYK colour 
picker.

1

2

Line colour

Fill colour

Short cuts for transparent, 
white & black

Press Swatches... to see a catalogue of all 
the colours currently in use in the PDF.

Swap fill/line colours

Press the Colour button to open the colour 
picker dialogue box. 

The fill and stroke colours are both 
included on the same toolbar button.

Notes
•	 If the selected objects use a different colour space (such as CMYK), Foxit Advanced 

PDF Editor converts the RGB value into CMYK. This can cause a slight difference in 
appearance of the colour which is unavoidable when converting between light and 
ink-based colour spaces.

•	 All versions of Foxit Advanced PDF Editor retain the original colour space of an 
object.
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Swatches catalogue
The Swatches window shows all the colours used in a PDF. It can also be used to 
change the colour of selected objects.

2

Choose View->Swatches... to open the 
swatches catalogue.

Alternatively, press the Swatches... button 
from within the CMYK colour picker 
dialogue box.

There may be a short delay while the 
catalogue is built.

The catalogue shows the component 
values of each colour and (if available), 
the names of separation colours.

Double-click on a colour to change any 
selected objects.

CMYK, Gray and Separation colour 
values are shown as a percentages from 
0 to 100.

RGB values range from 0 to 255

Choose between fill or line 
colour by clicking on the 
shape. 

Click on the black arrows to 
swap fill & line colours.

Notes
•	 You can restrict the colour available during editing to just those in the PDF or in a 

special hidden resource page. See User Restrictions for more information.
•	 The swatches catalogue is populated only when a PDF is opened.
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Next choose the Pipette tool from 
the toolbar.

Using the Object tool, select the 
object(s) whose colour you wish to 
change.

Copying colours between objects
Use the Pipette tool to copy the colour from one object to another.

1

2

Click the Pipette on an object whose 
colour you want to copy.

3

The fill colour, line colour and line width 
of the chosen object is copied to the 
selected objects.
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Aligning objects
Objects may be aligned relative to other. You can also align objects relative to fixed 
guides. See Guides for more details.

Choose the Object tool from the 
toolbar.

Select the objects to be aligned. 

Choose Object->Align->Top to align the tops 
of the objects together. 

All objects in the selection are aligned to 
the top-most object.

Notes
•	 The order in which you select items for alignment is not important.
•	 Aligning text blocks does not affect the paragraph alignment (justification) of within 

the text blocks.

All the alignment styles are available 
from the Object Alignment toolbar.

To show this toolbar choose: 
 View->Toolbars->Object Alignment
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Replacing images
You can substitute an existing image for another loaded from disc. Supported image 
formats are JPEG, TIFF, PNG, BMP and PDF.

Choose the Object tool from the 
toolbar.

Select the image to be replaced, then 
choose Edit->Images->Replace Existing...

You can also click the right mouse button 
to see a similar menu.

In this example a picture of a Volkswagen 
Beetle has replaced the old image.

The new image is placed inside the 
clipping mask (pink outline) used by the 
old image. 

The new image is automatically selected 
after being inserted.

Scale the new image by dragging one of 
the resize handles outwards. 

Hold the Shift key at the same time to 
ensure the aspect ratio is maintained.

2

3

1

Continued...
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The new image needs to be moved to the 
centre of the clip mask.

Drag it to its new position using the 
mouse or nudge it using the cursor keys 
(and Shift for larger steps).

The finished result after scaling and 
repositioning the new image.

5

4

Continued from previous page

Notes
•	 Foxit Advanced PDF Editor supports images up to a maximum of 8-bits per colour 

channel
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Inserting new images
Images can be quickly added to a page using drag & drop.

1

2

Drag & drop multiple image files onto an 
open document in Foxit Advanced PDF 
Editor to insert them into the current 
page.

Or, choose Edit->Images->Insert... then 
choose a single image from the file 
selector.

Choose from JPEG, PNG, TIFF and BMP 
image formats.

3

New images are pasted into the page on 
top of each other. Use the object tool to 
move and stretch them to the correct size.

Drag & drop multiple 
images onto an open 
document

Notes
•	 Foxit Advanced PDF Editor supports images up to a maximum of 8-bits per colour 

channel
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Object borders
Foxit Advanced PDF Editor can add simple borders around objects. This is most 
effective when used around an image. 

Select the objects which are to have 
a border placed around them.

Choose Object->Border->2 pt

or press the border button on the 
Drawing toolbar.  
(View->Toolbars->Drawing)

The border width can be changed by 
choose another point size from the: 
Object->Border sub-menu.

Borders can be applied to any object, not 
just images.

To remove the borders, press the border 
button again,

or choose Object->Border->No Border

Notes
•	 Borders are always black.

1

2
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Locking objects
Objects can be locked to inhibit accidental editing.

To Lock:
1.	 Using the Object tool, select the object(s) to be locked.	

2.	 Choose Object->Lock Selection or

3.	 Right-click the mouse and choose Lock Selection

Objects will remain locked even after the PDF is saved and re-opened (provided 
Foxit Advanced PDF Editor Layout is preserved in the PDF. See “Store layout info in 
PDF” on page 195).

Unlocking Individual Objects:
1.	 Choose the Object tool and move the mouse cursor over the object.	

2.	 Right-click the mouse and choose Unlock Object/s.

The object(s) under the mouse cursor will be unlocked and selected.

Unlocking All Objects
1.	 Choose Object->Unlock All
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Hiding objects
To make editing complex artwork easier, objects can be temporarily hidden. 

Hiding:
1.	 Using the Object tool, select the object(s) to be hidden	

2.	 Choose Object->Hide Selection

Hidden objects will become visible again the next time the PDF is loaded.

Showing:
1.	 Choose Object->Show All
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Grouping objects
Objects may be grouped together to make editing easier. 

Grouping:
1.	 Using the Object tool, select the object(s) to be grouped	

2.	 Choose Object->Group Selection or 

3.	 Right-click the mouse and choose Group Selection

Groupings remain even after the PDF has been saved and reopened (provided Foxit 
Advanced PDF Editor Layout is preserved in the PDF. See “Store layout info in PDF” 
on page 195).

Ungrouping:
Select the group(s) to be ungrouped using the Object tool

4.	 Choose Object->Ungroup Selection or

5.	 Right-click the mouse and choose Ungroup Selection
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Layout grid
You can use a grid to help when aligning objects on a page. When displayed, this 
grid makes your pages look like graph paper. You can also make objects ‘snap’ to the 
lines of the grid when you move them.

The distance between grid lines and the snapping behaviour can be controlled by 
you.

Choose View->Grid & Guides->Show Grid to 
display the grid.

The grid has major (darker) and minor 
(lighter) grid-lines.

To make objects “snap” to the grid lines 
when creating, moving or resizing, choose 
View->Grid & Guides->Snap to Grid

Choose View->Grid & Guides->Grid Spacing...

Spacing is the distance between the major 
(darker) grid lines.

Control the number of minor (lighter) 
grid-lines by specifying a value for Divided 
into:

Grid spacing

Notes
•	 The visibility and spacing of the grid are stored in the PDF and will be used (by Foxit 

Advanced PDF Editor only) next time the PDF is opened.
•	 If visible, grids will be included when printing a document.
•	 To change the units used for the grid, choose File->Preferences... and click on the 

Editing tab.
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Layout guides
You can create multiple horizontal and vertical guides to help with layout and 
positioning on a page. Objects ‘snap’ to guides when moved close to them making it 
simpler to align objects.

To create a horizontal guide, click in the 
horizontal ruler at the top of the window 
and drag down to position the resulting 
guide.

To create a vertical guide, click in the 
vertical ruler at the left hand side of the 
window and drag across to position the 
resulting guide.

Vertical ruler bar

Notes
•	 Guides are stored in the PDF (if Store layout in PDF is enabled) for use next time 

the document is edited by Foxit Advanced PDF Editor.
•	 Once guides have been created they can be moved and deleted using the 

Object tool as if they were normal objects.
•	 To temporarily hide all guides (or stop them from printing) choose  

View->Grid & Guides->Hide Guides

Vertical guides

Horizontal guides
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Line arrows
Foxit Advanced PDF Editor can add various kinds of arrow heads to either the start 
or end of lines and polygonal shapes.

Choose View->Toolbars->Drawing to view the 
drawing tools. 

The start and end arrow menus display 
the currently chosen arrow type for the 
selected object(s).

Click on the start/end arrows menus 
to change the arrows of the current 
selection.

Tear off either menu to convert it into a 
floating toolbar.

Use the Line or Polygon tools to 
draw.

Notes
•	 Lines and their arrows always have the same colour.
•	 The size of the arrow head is proportional to the line width.
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Layers
Foxit Advanced PDF Editor offers a simple way of editing documents which include 
layers. Using the layers panel you can show and hide individual layers in a document 
to make editing easier. You can also move objects between layers.

Choose View->Layers to open the layers 
panel.

Drag the title bar of the layers panel to 
make it into a floating window.

Click on the check box next to each layer 
to  show or hide it from view.

Click on the layer name to rename it. Any 
name change is stored in the PDF when it 
is next saved.

When you click on an object during 
editing, the containing layer is 
highlighted (if the layers panel is open).

Since Foxit Advanced PDF Editor ignores 
objects in hidden layers, it can make 
editing much more responsive if you hide 
all irrelevant objects before you begin to 
edit.

Notes
•	 Foxit Advanced PDF Editor cannot create or delete layers.
•	 Changing the visibility of layers affects only the way it is displayed in Foxit Advanced 

PDF Editor. No permanent change is made to the PDF.
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Moving objects between layers
To move objects from one layer to 
another, select the objects with the 
selection tool.

The selected text in this example resides 
in ‘Layer 2’.

Select the layer to which you wish to send 
the objects.

Here, ‘Layer 1’ is selected.

Choose Object->Arrange->Send To ‘Layer 1’

The object will be marked as belonging 
to the selected layer. This change will be 
stored in the PDF next time it is saved.

1

2

3
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On-screen display
1. Select the Text tool from the tool bar.

2. Click on a block of text to begin editing.

The formatting bar and ruler will activate and a text box will be drawn around the 
text block being edited. 

Notes
•	 When you begin editing, spaces, paragraph marks and line-breaks will show up in 

pink. These will become invisible again when you finish editing. 
•	 Choose View->Show Invisibles to disable this behaviour.	  
•	 See Fonts In PDF for details of how certain fonts can make editing difficult.
•	 Choose View->Text Box Frames to outline all text boxes during text editing.

Ruler & MarginsFormatting toolbar

Space character  
(pink dot)

Paragraph End 
(Return)

Text box with 4 
resize handles

Line-break 
(Shift+Return)

Caret (black bar)  
Text is inserted here
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Using the Text tool
New text can be added at any time by dragging out a new text box of the required 
size.

2

Select the Text tool from the toolbar.

Click and drag to create a new text 
box.

After a short delay, the text box will be 
created ready for editing.

Choose the required font and size from 
the formatting bar before editing.

Using the Text Plus tool
A new, single-line text box can be added at any time.

Select the Text Plus tool from the 
toolbar.

Click to create a new, fixed size text box. 
As you type into this box it will stretch.

The box can be resized by dragging on the 
North, South, East, West resize handles as 
normal.

Text boxes created this way will be 
editable in all the free versions of Foxit 
Advanced PDF Editor.

1

Creating new text boxes
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Select the Linked text tool from the 
toolbar.

Click the mouse in the middle of each 
column you wish to link together.

The box will highlight and a number will 
be displayed in the middle. This number 
shows the order in which text will flow 
between the boxes.

If you click the same box twice it will be 
removed from the flow and the rest of the 
text boxes renumbered.

Keep adding further boxes by clicking the 
mouse. You can change pages and add 
text from different pages to the flow.

Editing text across columns & pages 
Link multiple text boxes into a chain and reflow the text across the whole chain.

1

2

3

Notes
•	 The text boxes will remain linked together even after you close and re-open the PDF 

provided Store layout in PDF is enabled. See “Store layout info in PDF” on page 195.

When you are ready to begin 
editing select the Text tool from the 
toolbar.
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Overset text
When there is too much text to fit into a text box, the text that overflows is hidden 
and is called “overset” text.

To reveal the overset text, make the text box larger or connect it to another text box 
so the text can flow between them.

3

This text contains overset text. This is 
indicated by the small red square in the 
bottom right of the frame. 

Resize the box to reveal the hidden text.

Alternatively, 
1. click on the overset symbol 
2. drag-out a new text box.

The overset text will flow from the old text box into the new one. 
Continue linking new text boxes until all the text becomes visible.

Notes
•	 When saving a PDF, Foxit Advanced PDF Editor checks for overset text and reports 

the first instance found.

1

2
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Inserting special characters
Use the Character Palette dialogue to insert characters that are difficult to enter 
directly from the keyboard.

Click on some text to begin editing using the Text tool.

Choose Text->Character Palette...

Use the font menu to choose 
the required font from the PDF’s 
fonts and your computer’s 
system fonts. Next/Previous font

Click on a glyph to 
select it. 

Double-click to insert it 
into the PDF.

Poorly formed Type3 
fonts may display 
upside-down. Press 
Invert to rectify this.

Press to re-define 
the meaning of badly 
mapped glyphs.  
See  “Remapping 
fonts” on page 90.

Information about the selected glyph:

• name as used in the PDF (not always available) 
• official Unicode description 
• type of the font from which it comes
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Performing a spell check
After editing it is useful to check the spelling of any new text added. You can check 
the spelling of words in three ways:

• check just the words in a text selection 
• check words in active text blocks 
• check the whole document (if there is no active text block)

The spell check dialogue box is accessed from Edit->Check Spelling... menu or by 
pressing the F7 function key.

The Spelling dialogue box

Double-click on a suggestion to make the 
change or single-click then press Change 
All.

Misspelled word is shown here.

Type corrections here
Ignore this word and move onto next 
suspect

Ignore this word for the rest of the check.

Adds suspect word to user dictionary 
(See Appendix, “Custom Spelling 
Dictionaries”)

Replace suspect word with correctly spelled 
alternative.

Replace suspect word for correctly spelled 
alternative this time and every other time 
for this checking session.

Language used for spell check. Click on the link 
to change the current language.

Continued...
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Start the spell check by choosing  
Edit->Check Spelling... or press F7.

As each suspect word is displayed in the 
dialogue box, Foxit Advanced PDF Editor 
will also highlight the word on the page.

You can type a new word into the  
Change To: box or select one of the words 
Foxit Advanced PDF Editor has suggested 
then press Change.

When the selected text has been checked, 
you will be asked if you wish to check the 
rest of the PDF. 

Notes
•	 See Fonts In PDF for details of how fonts can effect the editing of text.
•	 Be careful when changing text in paragraphs with unusual shapes (such as those that 

flow around graphics). When the paragraphs are reflowed, their layout may be lost. 
See Advanced Editing for methods of dealing with this.

•	 If the words shown in the Suspect: window seem garbled or include strange 
characters it indicates that the text cannot be extracted correctly from the PDF. This 
is caused by improper encoding of the PDF’s fonts and cannot be remedied with Foxit 
Advanced PDF Editor.

•	 You can edit the contents of the spelling dictionary - see Custom Spelling Dictionaries.
•	 Foxit Advanced PDF Editor will warn you if the replacement text cannot be rendered 

in the font used by the misspelled text. In this case, you may have to choose a 
different font for the text.

•	 Words that include numbers cannot be learnt by the spell checker. You can however, 
skip checking such words using the Ignore All button.

1

2

Continued from previous page



	 Editing Text	 59

Redacting text
Foxit Advanced PDF Editor can be used to reliably redact text of a sensitive nature. 
A block of text can be rendered illegible to the extent that it’s original content no 
longer forms part of the page marking stream.

Technically, redaction is a two stage process:

1. Foxit Advanced PDF Editor replaces the selected text with a repeated character 
- usually ‘x’ though other characters may be used if the original font does not 
contain ‘x’.

2. The replaced characters are further obscured by a wide strike-through covering 
the entire selection.

Using the Text tool, select the span 
of text to be redacted. This can be 
anything from a single word to an 
entire story.

The choose Text->Redact.

The text has been redacted.

You can undo this change whilst editing, 
but once you save the document the 
redaction becomes permanent and can 
not be undone.

Foxit Advanced PDF Editor tries to keep 
the total width of the redacted text the 
same as the original  selection though 
some amount of reflow may still occur.

Underneath the strike-through, 
the original text has been 
replaced by sequences of ‘x’.

1

2
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Underline
You can underline a character or words using the Underline button available on the 
formatting toolbar.

Select some text, or move the caret into 
a word and press the underline button on 
the formatting toolbar.

For more control over the width, colour 
and position of the underline choose the 
Text->Style->Underline Options... menu item.

Using the Underline Options dialogue 
box, you can change the colour of an 
underline.

Continued...
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Example underline effects
Offset to -20 points

Offset  +6 points on 12 point text

Weight of 0 points (hairline)

Adding a background to text

Notes
•	 Text is always drawn after its underline decoration.
•	 Text is always drawn before its strike-through decoration.

Continued from previous page
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Strike-through
Strike-through can be applied to any word or selection of words by choosing: 
Text->Style->Strike-through whilst in text editing mode.

Additional options are available to control 
the look of the strike-through decoration. 
To access these choose: 
Text->Style->Strike-through Options...

Strike-through

Strike-through

Strike-through

Example strike-through styles

Offset of -6 points on 12 pt text

Offset of 12 points

Weight of 6 points on 12 pt text
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Margins & indents
You can control the left, right and first-line indents for paragraph text. These 
indents apply to the entire paragraph.

Select the Text tool and click on a block of text to begin editing.

Place the caret inside a paragraph or select a block of text spanning multiple 
paragraphs.

To change a margin, drag the margin 
triangle to the position required. 

The picture shows the “First Line Indent” 
triangle being dragged.

As you drag the margin, a dotted line 
allows you to line-up the margin with 
other objects on the page.

White portions shows width of 
text block

Left margin (triangle shape) 
Drag small rectangle beneath triangle to 
move left & first-line margins together

Right margin

First-line indent

The first-line indent has been changed so 
that the paragraph starts with an indent.

Continued...

1

2

First-line indent
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Notes
•	 For finer control of indents especially for text that flows around shapes, see Advanced 

Editing.

To create a hanging indent as shown in 
image 2, move the left-margin inward 
without moving the first-line indent.

If you drag the little rectangle underneath 
the left margin arrow, then both the first-
line indent and left margin will move.

Ruler units
You can change the ruler’s unit of measurement. Choose from Centimetres, Inches, 
Points and Picas via the Preferences dialogue box.

Choose File->Preferences... then click on the 
Editing tab to change the ruler’s units.

1

2

This paragraph now has a hanging indent.

Continued from previous page

Left margin & hanging indents
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Bold, overprint & italic text
Foxit Advanced PDF Editor includes buttons to switch between normal, bold and 
italic versions of a font. These buttons may not operate in the manner you expect 
since in some cases Foxit Advanced PDF Editor can simulate the effect required if 
the appropriate font is not available.

Actual Bold
Using the Text tool, select some text.

Press the Bold button or Ctrl+B.

If the bold version of the font is available, 
Foxit Advanced PDF Editor switches 
fonts.

In this example, the font has changed 
from Bitstream Vera Sans to Bitstream Vera Sans 
Bold, both available in the PDF.

Simulated Bold
If the bold versions of the selected 
characters are not available Foxit 
Advanced PDF Editor will simulate bold 
by overprinting the characters.

This text, written using Minion-
DisplayRegular has no bold equivalent in 
the PDF or on disc.

Pressing Bold causes Foxit Advanced PDF 
Editor to overprint the text to simulate 
the bold effect. Notice that the font name 
has not changed in the font drop-down.

Continued...
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Italic
If the italic version of the selected text is 
not available in the PDF or on disc, then 
Foxit Advanced PDF Editor will show this 
warning.

Foxit Advanced PDF Editor cannot 
simulate italic text in the way that it can 
bold text.

Notes
•	 When editing starts, Foxit Advanced PDF Editor scans for overprinted text and 

classifies it as bold. This behaviour can be disabled - see “Diagnostic editing mode” 
on page 193

•	 Foxit Advanced PDF Editor does not simulate italic text.
•	 Italics cannot be undone if the non-italic font is not available on disc or in the PDF.
•	 Bold text cannot be undone if the plain font is not available, unless it was previously 

only simulated bold.
•	 The simulated bold (overprint) effect will be detected again by Foxit Advanced PDF 

Editor when the PDF is re-loaded.

Continued from previous page
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Background colour
You can specify that a text block has a white, black or transparent background 
colour. This can be useful when you want new text to obscure existing, background 
text.

In this example we want to obscure the 
name ‘Wilhelm Korte’ on the scanned 
page with a new name ‘Hans Keppler’.

The new text is shown in red due to the 
Show changed text in: preference. See “Show 
changed text in:” on page 192.

When placed on top of the existing 
scanned name, both names are visible.

Choose: 
Text->Text Boxes->Background Colour->White  
to give the text box a white background.

For simplicity Foxit Advanced PDF 
Editor only offers black, white or clear 
backgrounds.

For other colours, create a coloured 
rectangle shape using the drawing tools 
and place it between the new and old text.

1

2

3
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Line Spacing
Use the Line Spacing dialogue box to set line spacing values other than Single, 1.5 and 
Double.

While in text edit mode, choose  
Text->Line Spacing... from the main menu 
bar. 

The Letter Spacing dialogue box offers  
At Least, Exactly & Multiple spacing modes.

This paragraph shows the effect of the  
At Least mode in which you tell Foxit 
Advanced PDF Editor the minimum gap 
between lines (measured in points).

To stop the “wheels” line (shown 
left) from colliding with the previous 
line, Foxit Advanced PDF Editor has 
automatically increased its line spacing.

This paragraph shows the effect of the 
Exactly setting in which you tell Foxit 
Advanced PDF Editor the exact gap size 
between lines (measured in points). 

Foxit Advanced PDF Editor has used 
exactly the same spacing for each line 
regardless of whether or not they collide.

Continued...

At Least

Exactly
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Use Multiple mode to specify gaps such as 
“2.5 lines” meaning that the gap will be at 
least 2.5 times the line height.

Setting multiples of 1, 1.5 or 2 is the 
same as pressing the single, 1.5 or double 
spacing buttons on the formatting 
toolbar.

Continued from previous page

Multiple
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Paragraph spacing
You can create a gap between paragraphs in two ways:

1.	 Use the Text tool to insert blank lines between paragraphs

2.	 Use the Text tool and the Paragraph Spacing dialogue box available from the  
Text->Paragraph Spacing...

Using the second method allows you to dictate the exact size of gap in points -  1/72 
inch.

There is no gap between any of the 
paragraphs show left.

Choose Text->Paragraph Spacing... from the 
main menu bar.

Here the value has been changed to 6 
points.

The paragraphs are now 6 points apart.

Select multiple paragraphs to alter the 
spacing of them all at once.

1

2

3

6 points gap
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Letter spacing
The space between individual letters can be controlled to an accuracy of 1/1000 em. 
This is useful for achieving layout effects such as fitting text into a particular area by 
reducing or expanding the spacing.

Letter space & word space
Due to the nature of PDF documents, you can also control the gap between words 
caused by space characters though this is generally not as widely used as letter 
spacing.

1 em

Letter spacing is measured in ‘ems’ with 1 em 
being the width of a capital letter ‘M’ in any 
font.

Letter space Word space

The letter spacing dialogue box uses units 
of 1/1000th em.

You can control the gaps between letters 
and words by entering positive or negative 
values.

The word spacing value is ignored when 
text is fully justified.

Notes
•	 Increase/decrease the letter spacing of selected text using the keyboard short cuts 

Ctrl+Shift+] and Ctrl+Shift+[
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Select the Text tool and begin editing 
a block of text.

Select the characters whose spacing is to 
be changed.

In this example the spacing is being 
changed to 100/1000th em. This will change 
the gap to be 1/10th of the width of the 
letter ‘M’ in this font.

The additional spacing is clearly visible 
and the text now covers a wider area.

Starting with the original text, the word 
spacing could be changed instead.

The word spacing is changed to 400/1000th 
em or 0.4 x width of ‘M’.

The new, enlarged gap between the words 
is clearly visible.

Using letter spacing

Using word spacing

2

3
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1
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Tabstops
Use tabstops to create sophisticated text layouts. Choose from left, centre and right 
justified tabs with or without leader dots.

Creating/deleting tabs
Click on the ruler bar at the position you want to create a new tab.  

Click & drag an existing tab-stop to move it to a new position.

Click & drag an existing tab right off the ruler bar to delete it.

left tab centre tab right tab

Notes

•	 Tabstops are remembered even after closing and re-opening a PDF.
•	 As you add or move an existing tabs their numeric position is shown in the status bar 

at the bottom of the window.
•	 Tabstops may be positioned beyond the left & right margins of the text box.

Tab characters are shown 
as small pink arrows during 
editing

On-screen display
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Creating centre & right tabs
Position the mouse cursor over an 
existing left tab then press the right 
mouse button to see the Tab menu.

Choose Centre or Right to change the type.

Tab leaders
From the Tab Options... dialogue box, you can set the leader character or modify the 
way tabs wrap across lines.

Position the mouse cursor over the 
tabstop you want to modify.

Press the right mouse button to display 
the tab menu and choose Tab Options...

To add leader dots to your tabstop, type 
a single ‘.’ (period) into the Leader Character 
text box.

You can type any single character into 
this box for use as a tab leader.

2

1
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Trailing tab leaders
Use the Tab Options... dialogue to control the way tab leaders are drawn for wrapped 
lines.

Position the mouse cursor over the 
tabstop you want to modify.

Press the right mouse button to display 
the tab menu and choose Tab Options...

When Trailing Leaders is checked, Foxit 
Advanced PDF Editor will add leader dots 
to the end of a line which wraps because 
of a tab stop.

Trailing leaders have been 
added by Foxit Advanced 
PDF Editor.

Notes

•	 Trailing leaders cannot be selected or edited with the text or object select tools. The 
caret will skip over them when moving through text.

•	 Trailing tab leaders extend up to the right edge of the text box.

1

2
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Text Colours
All text has two colours associated with it - the outline colour (stroke) and the 
interior (fill) colour. Either colour may be invisible (but not both).

The colours are set in the same way as for graphics.  
See “Changing colour & line width” on page 35

 T
Outlined (stroked) with no fill colour Solid stroke and fill colour
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Vertical text alignment
Foxit Advanced PDF Editor can align text inside a text box so that it sits at the top, 
middle or bottom of a text box. It can also make text automatically fit its text box by 
altering various aspects of the text formatting (see Text Box Fitting)

While editing a text box using the 
Text tool then choose: 
Text->Box Alignment->Top.

The text shown here is top aligned which 
is the default alignment.

Text->Box Alignment->Middle.

Text->Box Alignment->Bottom.

Notes
•	 Text Box Alignment reverts to “Top” for linked text boxes.



	 Advanced Editing	 80

Automatic text fitting
Foxit Advanced PDF Editor can alter various aspects of text formatting in order to 
make text fit inside its text box.

Edit a text box using the Text tool 
then choose: 
Text->Align->Full...

The text shown here is top aligned which 
is the default alignment.

Use the Text Box Fitting Limits dialogue box 
to select the aspects of formatting which 
should be modified and by how much.

During fitting, Foxit Advanced PDF 
Editor tries altering the enabled aspects of 
formatting in the order they are listed in 
the dialogue.

The fitting process stops as soon as an 
acceptable result has been achieved even 
if all metrics have not yet been used.

Deactivate fitting metrics by unchecking 
their check boxes.

The first two metrics simply adjust the 
word and letter spacing of text to try to 
achieve a fit.

The adjustment is between the supplied 
limits and is in addition to any spacing 
metrics already in effect on the text.

Continued...
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The Leading Scale metric modifies the  
leading and paragraph spacing of text 
within the percentage limits supplied.

In this example, leading and paragraph 
spacing could be increased from their 
initial values by as much as 200% during 
fitting (or reduced to 75%)

Fitting may be restricted to text that 
overflows its text box (overset text).

Continued from previous page

Adjust the gap between paragraphs 
independently of the leading via this 
metric.

Adjustments range between the Min and 
Max point values supplied. If Min is set 
to 0 then paragraph spacing will never 
be reduced. If Max is set to 0, paragraph 
spacing will never be increased.

The final metric adjusts the font size of all 
text in a text box by the same number of 
points in order to obtain best fitting.

Continued...

The alignment to be used on 
underset text (text which does 
not require fitting)
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Notes
•	 Text fitting is time consuming. It is not advisable to edit text with full fitting 

activated. Apply it only once editing is complete.
•	 Text Box alignment is remembered even after closing and re-opening PDFs.
•	 Original formatting (font size, leading & spacing) is restored once full fitting is 

turned off.
•	 Unlike the other alignment modes, full text fitting can be applied across linked text 

boxes.

Default “Top” alignment for two linked text boxes

“Full Alignment” applied across both linked text boxes.

Continued from previous page
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Flowing text around graphics
In order to retain the contour of a paragraph that flows around a graphic the widths 
of lines should be locked during editing. 

Select the Text tool from the tool bar 
and click inside the paragraph to 
begin editing.

Select lines whose shape follows the 
contour of the graphic. Lines that do not 
follow the shape need not be selected.

In this example every line of the 
paragraph needs to be selected.

Choose Text->Fix Line Width from the menu 
bar to lock the selected lines.

“Fixed” lines have an addition border 
showing the shape of the line.

Continued...

1

2

3
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Edit the text as normal.

Although the text will reflow, the shapes 
of the fixed lines will not alter.

You can alter the shape of each line by 
moving the left or right margin for that 
line.

Finish editing as normal.

In this example, each line has been 
reshaped to ensure the new text curves 
around the blue oval.

Note
•	 You cannot use Text->Fix Line Widths on rotated text.

Make sure the alignment is correct. Foxit 
Advanced PDF Editor may have chosen 
the wrong alignment due to unusual 
shape of the paragraph.

Continued from previous page

4
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Rebuilding text boxes
Foxit Advanced PDF Editor can grab the text from multiple text blocks within a 
specific area of the page, sort it and build a new text box containing all the grabbed 
text. This can be useful for documents that have many disjoint text blocks making 
editing difficult.

Owing to the way in which this example 
PDF was produced, Foxit Advanced PDF 
Editor has created many overlapping text 
blocks which make editing difficult.

In some cases, lines from two distinct 
columns of text have been grouped into a 
single, extra wide, text block.

(View->Show Text Frames has been enabled to 
show the outline of each text box)

Choose the Text tool and drag-out 
a new text box large enough to 
enclose all of the text you wish to 
grab. 

Choose: 
Text->Text Boxes->Rebuild

Any text enclosed by the new text box 
will be stolen from the existing text 
boxes.

The stolen text is then sorted using a 
simple x-y sort and placed into the new 
text box.

Original text boxes that become empty as 
a result will be deleted.

Usually the text placed in the new text 
box will have more accurate paragraph 
structure and be easier to edit.

1

2

3
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Merging text boxes
Vertically aligned text boxes may be joined together when you need text to reflow as 
one. 

1

2

3

In this example, Foxit Advanced PDF 
Editor has split the text into three boxes. 

This will produce the wrong results when 
the text is reflowed.

While using the Linked text tool 
choose: 
Text->Text Boxes->Merge Vertically to 
join the three separate boxes into one.

Boxes in the same vertical row will be 
joined into one.

Continued...
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4

Text will now flow as a single column and 
the results should look better.

Continued from previous page
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Splitting text boxes
Text blocks can be split at paragraph boundaries. This can make editing large blocks 
of text faster and helps to avoid reflowing text that does not need it.

1

2

Use the Linked text tool to select the 
text box to be split.

The example shows a large block of text 
with complicating formatting.

To edit just the middle paragraph without 
reflowing any of the other text, the text 
box should be split.

Choose Text->Text Boxes->Split Paragraphs.

The single box is split so that each 
paragraph becomes a box, not linked to 
any other. 

Although the new text boxes are not 
linked together, for clarity they have been 
linked together in this image to highlight 
the effect of splitting.

Continued...
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3

After splitting, Foxit Advanced 
PDF Editor switches to the Text tool 
ready for editing.

Continued from previous page
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Remapping fonts
Every font in PDF includes a mapping from the glyph shapes to their meaning. 
Without this mapping editing would not be possible nor would content export.

In some PDF documents these mappings are incorrect or corrupted. You can train 
Foxit Advanced PDF Editor to deal with particular mapping problems as they arise. 
This training does not fix the PDF but does enable editing, content export and 
translation.

Choose Text->Remap Fonts... to open the font mapping dialogue box.

The dialogue box is similar to the Character Palette dialogue (see “Inserting special 
characters” on page 56)

The ‘meaning’ of the selected glyph. 
When editing or exporting, Foxit 
Advanced PDF Editor will treat the glyph 
as if it were Unicode 38.

The glyph shape “6”

Currently maps to ‘&’  
(an incorrect mapping) 

Mapping contained in the PDF. 
(May or may not be correct)

Bad or missing mapping.

User supplied mapping. 
(A remapped glyph)

The mapping for each glyph is shown in 
one of three colours:

Continued...
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Continued from previous page

Editing font mappings
The quickest way to edit or fix a font map is to select the first incorrectly mapped 
glyph in the map, then press the key to which is should map. The mapping will be 
set and the next glyph will be selected. Repeat until all incorrect glyphs are mapped.

In this example. 6 characters have already 
been re-mapped. The selected glyph has 
moved into ‘h’. 

Press ‘h’ on the keyboard to change the 
mapping to ‘h’.

The mapping for ‘h’ has been recorded 
and now, the ‘e’ glyph has been selected.

If the destination character cannot be 
entered from the keyboard such as fi 
(latin small ligature fi) then enter it’s 
Unicode value into one of the edit boxes - 
FB01 is the code for fi  in hexadecimal.

1

2

Notes
•	 Mappings are stored in a mappings file maintained by Foxit Advanced PDF Editor. 
•	 Mappings are applied whenever a document with a matching font is opened.
•	 Mappings are used during editing and when exporting PDF to other formats.
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Numbering pages
You can renumber a range of pages by cloning a page number text field on each page 
in the range using the cloning facility. Each time the text field is placed on a page in 
the range, it is incremented by one.

Page number fields do not update when pages are added or removed from a PDF. 
Instead you should re-clone the numbering on the affected pages.

See “Cloning objects across pages” on page 93 for details of cloning objects (not 
just page number fields) across pages.   

In this example we want to have a 
numbered footer at the bottom of each 
page, of the form (Page n).

Using the Text tool, create and edit 
the footer on the first page of the 
range.

Choose Text->Insert Page Number... to insert 
the text field where the page number 
should be.

Choose the Numbering Style for the 
number. 

Note that whatever format is chosen, the 
font used must encode all the characters 
that will be required as the number 
changes across the page range.

You can verify this by looking at the font 
using the character palette (choose  
Text->Character Palette...)

Finally, specify the Numbering Offset.

In the example shown, a numbering offset 
of -3 has been given which means the first 
page number generated will be 1.

SInce it is being inserted on physical page 4 of 
the PDF, with a numbering offset of -3, the first 
page number generated will be 1.
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Cloning objects across pages
Foxit Advanced PDF Editor can replicate a selection of objects across a range of 
pages. The objects are placed at the same position on each page in the range, on 
top of any existing contents. This facility can be used for adding repeating page 
furniture such as logos, headers, footers and page numbers.

Using the Line tool add a horizontal 
line to the top of the page. Use Copy 
and Paste to place a similar line in 
the footer region.

Both lines are then selected using 
the Object tool (by clicking on each 
line whilst holding SHIFT to add to 
the selection).

Choose Edit->Clone Across Pages...

This example will show how to add a 
header and footer rule plus a page number 
to a 300+ page book.

New header rule (horizontal line)

New page number 
style, replacing existing 
number.

New footer rule

1

Continued...
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Next, specify the range of pages to be 
covered. In this case we wish to place the 
borders on all pages from 3 onwards.

You could restrict the range to even or 
odd pages only if you wanted to apply 
different graphics to each set of pages.

Selected Delete existing objects... to remove 
any existing lines at this position before 
placing the new lines. 

In this example, we are going to change 
the style of the page numbering - 
currently a simple number.

Selected the existing page number 
using the Text tool and insert “Page” 
in front of the number.

Then delete the original number (“4”) and 
choose Text->Insert Page Number... which will 
display the page numbering dialogue.

Choose the numbering scheme for the 
new page number.

You can also provide a Numbering Offset 
that gets added to the page number. Leave 
this as 0 for no offset.

Press OK to insert the page number.

2

3

4

Continued...

Continued from previous page
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The finished format, showing the page 
number, all centre aligned. 

The number is actually a field which is 
why Foxit Advanced PDF Editor shows it 
highlighted. This highlighting does not 
affect the PDF and can be turned off by 
choosing View->Field Shading.

During the clone operation this field 
will update as it is copied to each page in 
order to show the correct page number.

The final change is to change it to an 
italic version of the Constantia font. 

Since the page number field will be cloned 
across a wide range of pages, all numbers 
from 0-9 will eventually be needed. 

We need to ensure the font we choose 
has all numbers otherwise the cloning 
process will fail part way through.

You can check the characters available in 
a font by choose Text->Character Palette...

Carefully select both lines and text 
using the Object tool, clicking on 
each whilst holding SHIFT to ensure 
they are added to the selection.

Choose Edit->Clone Across Pages...

Page with top and bottom 
lines plus page number 
selected.

5

6

7

Continued...

Continued from previous page
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Select the Page range: for the operation. 
In this example, we will be cloning from 
page 3 onwards, even though we drew the 
original items on page 4.

Select Delete existing objects... to ensure that 
any existing page numbers are removed 
before applying the new version.

Press Clone to begin the process.

Foxit Advanced PDF Editor will show the 
progress of the operation as it goes.

Every 100 or so pages, the partially 
complete document will be saved to disc 
(under a new name) and the process will 
resume.

The finished document will also have a 
new name.

Notes
•	 Page number fields are not updated when pages are inserted or deleted in a 

document. To update page numbers, perform the clone operation again ensuring that 
Delete existing objects... is selected.

•	 Hyperlinks and annotations are excluded from the cloning process.

8

9

Continued from previous page
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Deleting objects across pages
Foxit Advanced PDF Editor can automatically delete objects in the same location 
across a range of pages. This is very handy for removing unwanted logos, header, 
footers or other page furniture.

You are strongly advised to make a backup of your document before using this facility.

Select the object(s) to be deleted 
using the Object select tool.

In this case, a single logo has been 
selected that repeats across most of the 
document.

Any objects matching or entirely 
contained within the individual bounding 
boxes of objects in the selection, will be 
deleted from the pages you specify next.

Choose Edit->Delete Across Pages...

Choose the page range you wish to effect 
and whether you want to limit the process 
to just even or odd pages.

Press Delete.

You can halt the process part way 
through by pressing Stop.

1

2

3
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Converting text into vector outlines
To ensure that a PDF prints correctly and avoid any possibility of font problems at 
the printer, you can convert text to vector outlines. 

Some points to note about the conversion:

• converted text will no longer be editable or searchable by Foxit Advanced PDF 
Editor or any other application without the intervention of OCR

• outlined characters will not benefit from font hinting which is used when viewing 
at low resolutions. However, at the kind of resolutions used by printers, font hinting 
is not necessary.

• after conversion, you are guaranteed to avoid all font related printing problems 
since fonts will no longer play a part in the PDF (it will just be pages of line-art).

• the conversion encompasses all text across all pages of the PDF and cannot be 
undone.

To covert text to outlines choose Text->Create Outlines
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Clipping mask creation
Any object or group of objects can have a clipping mask applied. The mask ensures 
only parts of the object are visible. This is often useful for images where you may 
want to hide the background for example.

3

2

1

In this example, we want to apply a 
clipping mask to the image of the car.

A shape is drawn using the drawing tools.  

This shape will be used to make the 
clipping mask.

Any path may be used as clipping path, 
not simply those created using the built-in 
drawing tools.

With the new shape selected, choose 
Object->Clipping Mask->Convert To Clip.

The shape will then become a pink 
outline.

Now select both the clip path and the 
image and choose :  
Object->Clipping Mask->Add To Clip.

Continued...
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Notes
•	 Any empty clipping masks are automatically removed when a PDF is opened.
•	 Clip paths have no line width, fill or stroke colour
•	 Clip paths can be moved independently of the objects being clipped.

Continued from previous page

4

The image has now been added to the 
clipping mask. The parts of the image that 
are “outside” the mask are not displayed.

You can still move the mask and objects 
within it independently.
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Clipping mask removal
Clipped objects can be moved independently of their clip masks. Objects can also be 
“popped” from their clip masks revealing the entire object.

Choose the Object tool.

The car image (selected) is clipped 
by the oval clipping mask (shown in pink).

To remove the image from its clipping 
mask choose : 
Object->Clipping Mask->Remove From Clip.

The image is now fully visible. 

The clipping mask still exists and is 
shown in pink behind the image.

1

2

Note
•	 Clip masks only become visible (outlined in pink) when the Object Select tool is active.
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Reducing PDF file size
Foxit Advanced PDF Editor can resample images to make the overall PDF size 
smaller and quicker to load.

To resample all images in the document or across a range of pages choose: 
Edit->Images->Resample...

To resample specific images, select the images using the object select tool, 
then choose Resample Image(s)... from the right-mouse menu. 

The Resample Images dialogue offers a similar set of options for the three classes of 
images - colour, grey-scale and monochrome.

Converting colour images to grey-scale will reduce the overall size of the PDF file.

JPEG compression is a “lossy” format well suited to colour and grey-scale 
photographs. When choosing JPEG, you can set the quality of the compressed 
image anywhere from 1% (worst quality / smallest image size) to 100% (best quality 
/ largest image size).

PNG is a loss-less compression method better suited to colour and grey-scale 
diagrams, charts and line drawings.

Remove all hidden image data 
Foxit Advanced PDF Editor is able to remove the hidden parts of images that are 
painted through a clipping mask. Depending upon how the PDF was made, this can 
reduce the overall size of the PDF quite dramatically. 
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Notes
•	 If you have a word selected when the dialogue box opens, the word will be copied into 

the Find: box automatically.
•	 Be careful when changing text in paragraphs with unusual shapes (such as those that 

flow around graphics). When paragraphs are reflowed, their layout may be altered. 
See “Flowing text around graphics” on page 83 for methods of avoiding this.

Find & Replace text
Use the Find and Replace dialogue boxes to search for and replace words  
and phrases in a text selection, across a range of pages or throughout an entire PDF.

To replace the fonts used by a document, use the Find & Replace Font dialogue (see 
“Find & Replace fonts” on page 105).

During replacement Foxit Advanced PDF Editor will reflow the affected text. It is 
important you tell Foxit Advanced PDF Editor how you want the text reflowed as, 
depending upon your document, it may drastically alter its layout. See “Text reflow 
modes” on page 112 for details.

Check this box if 
capitalisation is important 

to your search

Press to see previous 
searches 

Unchecked, a search for “in” 
would match “running” and 
“ingrowing”

Type the word(s) you 
are searching for here.

Click here to 
limit searching 

to specific 
pages

Opens an 
interactive listing 
of all found text
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Find & Replace fonts
Foxit Advanced PDF Editor can change the fonts used throughout a document 
using the Find and Replace Font dialogue box. This dialogue presents a simplified 
interface to the more sophisticated facilities offered by the Find & Replace dialogue.

Before doing a font replacement ensure 
that you have a recent backup of 
your document since the operation is 
potentially disruptive.

To begin choose Edit->Replace Font... 
or 
choose Document->Fonts... then select a 
particular font and press Replace...

Choose the target font from any of those 
currently used in the document.

Alternatively, you can enter a wildcard 
expression in order to match a family of 
fonts. 

For example, Times* will match all fonts 
whose names start with Times such as 
Time-Roman, Times-Roman Italic etc.

F? would match all two-letter font names 
such as F0, F1 etc.

Continued...

1

2
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Continued from previous page

Choose the replacement font from the 
drop-down list. You may choose any font 
currently used in the document or any 
system font on your computer.

Whatever font you choose, especially 
if it is one currently used in your 
document, be aware that it may not have 
all the characters (glyphs) needed. Foxit 
Advanced PDF Editor will warn you 
during the replacement if this occurs.

Click Replace to begin the operation. 

Foxit Advanced PDF Editor will process 
the entire document, examining all text. 
If you want to restrict the process to 
a specific page range, text box or text 
selection, use the advanced features of the 
Find & Replace dialogue available in Foxit 
Advanced PDF Editor.

Hit the Stop button at any time to abort 
the process.

3

4

Once finished, Foxit Advanced PDF 
Editor will report the number of runs of 
text that were modified.

If more than 100 pages were processed, 
Foxit Advanced PDF Editor will have 
saved the document as it went along, 
renaming it each time. 

Save the finished version now. 
5
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Find & Replace (advanced)
Foxit Advanced PDF Editor’s Find & Replace dialogue box is a more sophisticated 
version of that offered by Foxit Advanced PDF Editor (see “Find & Replace text” on 
page 104). Not only can you search and replace text, you can modify the styles of 
text and change the contents of hyperlink URLs. 

See “Find & Replace text styles” on page 
108 for details of the Find: and Replace: 
check boxes.

Click the hyperlinks to limit searches 
to a particular style and to dictate the 
style of the replacement text,

Search & replace within the 
URL of hyperlinks only

Check to activate wild card matching. 
Available wild cards are:  
	 *	 to match zero or more characters  
	 +	 to match 1 or more characters 
	 ? 	 to match a single character
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Find & Replace text styles
You can restrict your target text by font, colour or size. You can also dictate the 
font, size and colour of the replacement text. You can even change the style of text 
without changing the text itself (more flexible than “Find & Replace fonts” on page 
105).

Before doing any kind of replacement operation ensure that you have a recent 
backup of your document since automated operations are potentially disruptive.

Minion-Italic, 7 point 

1

2

Choose Edit->Replace... to open the Replace 
dialogue box.

The selected text will appear in the Find: 
box.

To change all the character names in a 
Shakespeare play so that they appear in 
blue...

Using the text edit tool, select an 
example of the text to be changed. 

To find all text with the same style, 
uncheck the Find: check box. The target 
text will grey-out.

Continued...

Next, click on the Character format 
hyperlink to open the formatting dialogue 
box.

3
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Whenever a format is active for a search, 
a brief summary of the styles chosen is 
shown next to the Find: text box.

3

Continued from previous page

4

The Find Format dialogue reflects the 
formatting of the text from your initial 
selection, though it remains inactive until 
you press OK.

Press OK to activate the formatting.

Click on the hyperlink next to the 
Replace: text box to open the Replace Format 
dialogue box.

5

The Replace Format dialogue box displays 
the formatting of the initial text selection.

Click on Apply Style since we want to 
change the colour of text.

Click on the Fill colour check box to 
enable the colour picker button next to it. 

Click on the colour button to choose a 
new colour.

(In the example image a blue colour has 
already been chosen)

6

Continued...
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7

Continued from previous page

Reflow and alignment changes should 
be kept to a minimum (we only want to 
change text colour).

Ensure that Reflow: is New Text Only and 
Alignment: is Left.

Then press OK to activate the formatting.

8

Uncheck the box next to Replace:. The 
replace text box will grey-out.

This means we do not want the text itself 
changed, only its style.

Press the OK button to activate the format 
settings.

The Replace dialogue box 
should look something like 
this.

Press Replace All to start the 
process which may take 
some time to finish.9

Continued...
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Continued from previous page

Once finished, all character names have 
been changed to blue throughout the PDF.

The same technique can be used to 
change the font, font size or stroke colour 
of specific text.

10

Notes
•	 To remove any Find: formatting click the formatting hyperlink next to the Find: text 

box and set both Font & Font Size to Any then uncheck both colour check boxes.
•	 Replace: formatting can be disabled in the same way as detailed above.
•	 Foxit Advanced PDF Editor will save a partial copy of the PDF every 100 or so pages 

during a long find & replace operation.
•	 To cancel a find & replace operation, press Escape or close the dialogue box.
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Text reflow modes
Foxit Advanced PDF Editor offers three modes 
for controlling the way text is reflowed during 
search and replace:

•	 New Text Only
This mode is useful when dealing with tabular 
data, headers, footers or other single lines where retaining the original spacing and 
gaps between words is important. 

The minimum reflow is done. The new text is left, centre or right aligned within the 
space occupied by the text being replaced.

In this mode, you may end up with words printed on top of each other if the 
replacement text is much longer than the original.

•	 Containing Line Only (default mode)
This mode is useful when you wish to cause minimum changes to existing 
paragraphs whilst ensuring changed lines blend in correctly. 

Only the line(s) containing the search text will be reflowed after replacement. Lines 
can be left, centre or right aligned regardless of the alignment of their paragraphs. 

The auto option will use the containing paragraph’s current alignment.

•	 Containing Paragraph
The entire paragraph (and those near it) may be reflowed according to their current 
alignment. You cannot dictate the alignment used in this mode.

If a paragraph grows longer after reflowing, some of the text may become 
‘overset’ (See “Overset text” on page 55). This is signified by a red square on the 
bottom-right edge of the text box. You may need to make the text box bigger to 
accommodate the text once the search and replace is complete.

Reset Letter Spacing
When only the font is changed as a result of a search & replace operation the 
existing letter spacings may not be appropriate for the new font.

Checking Reset Letter Spacing will cause both inter-character and inter-word spacing 
to be set to 0 for every character affected.

Continued...
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Reflow: New Text Only

1

In this example, the header text is to be 
altered whilst retaining the gap between 
the page number and the text.

Choose the Edit->Replace... menu item. 

Fill in the Find: and Replace: text boxes.  
Press the blue, underlined hyperlink next to the Replace: text box. 

To ensure that the new text is right-
aligned and that the page number is left 
where it is -

Choose New Text Only from the Reflow: pop-
up menu

Choose Right from the Alignment: pop-up 
menu

Continued...
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Continued from previous page
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Editing Graphics                 13

	        Editing Graphics 13

        Editing Graphics         13

Align: Left 
New text is aligned with the start of the old 
text. If new text is longer than old, it may 
overflow and collide with page number.

Align: Centre 
New text is aligned with the centre of the 
old text. If it becomes longer it will extend 
beyond the original left/right bounds of the 
old text.

Align: Right 
New text is aligned with the end of the old 
text. If new text is longer than old, it may 
extend beyond the left extent of the original 
text.

Editing Graphics 13
Reflow: Containing Paragraph 
The entire line is reflowed and left justified. 
The page number is moved during the 
reflow.

Reflow: New Text Only

Editing Graphics & Images 13Original text

Continued from previous page

Continued...
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To make room, the words have been 
moved closer together on the first line. 

None of the other lines has been altered.

2

“Cigar Club” -> “Old Smoking Society”

There is not enough room for the 
replacement text on the line so words 
have begun to run-in to each other.

This is the same replacement using 
Alignment: Left. 

The text has grown beyond the edge of 
the text box.

Potential Problems

Reflow: Containing Line Only
“Cigar Club” -> “Smoking Society” 

In this example, “Cigar Club” is replaced 
by “Smoking Society”, reflowing only one 
line of the paragraph.

1

Continued from previous page

Notes
•	 Use Reflow: Containing Paragraph option only if you are confident that reflowing the 

paragraph will not destroy any existing indentation or special layout.
•	 When using Reflow:New Text Only the new text may collide with existing text if it is 

longer than the original text.
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Find & Replace in long documents
During find & replace in a long PDF (more than 100 pages), Foxit Advanced PDF 
Editor will save the partially-complete PDF every 100 pages.

On completion, the finished PDF MyDoc.pdf will be renamed MyDoc-01.pdf. The 
original PDF (before the find & replace) will remain unchanged.

If you perform further search and replace operations on the new document, it will 
be renamed MyDoc-02.pdf and so on.
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Find & Replace in files
Foxit Advanced PDF Editor can automatically perform a Find & Replace operation 
on multiple files. This can be useful when the same changes need to be made to 
many files.

Choose Edit->Find & Replace In Files... to open the dialogue. There does not have to be a 
document already open in order to access the dialogue.

Upper part of the dialogue is 
like the Replace dialogue box. 
See “Find & Replace (advanced)” 
on page 107

Lower part of the dialogue 
is where you add files to be  
searched.

Click to add files to the list

Continued...

Deletes files from the 
list (does not delete 
them from disc)

1

2

Click to add all the 
PDF files in a folder 
(and its sub-folders)

Click to open and view the 
selected document.  
If already processed, Foxit 
Advanced PDF Editor will open 
the processed version
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Continued from previous page

Once your search has been setup and you 
have added some files to the list, press 
Replace All...

The Setup Folders dialogue will open.

Supply a location in which to save the 
processed files. 

If you do not use this option, your original 
files will be over written (a backup will 
not be made). 

You are strongly advised to ensure you 
have a backup of the original files.

You may also give an optional folder for 
error files. 

Errors can occur when there is no suitable 
font for substitution for example.

3

4

5

Continued...

Setup Folders
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During the search, the dialogue shows 
the number of changes made, and current 
page being searched.

When doing Find In Files, pressing Show 
Results will display the results list. This list 
is updated as the search proceeds. 

Once the search has finished, double 
clicking on a result will open the relevant 
PDF and show the text.

Continued from previous page

6

The current PDF being searched is 
highlighted in the list of files.
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Find & Replace in hyperlinks
Foxit Advanced PDF Editor can perform find and replace operations on the content 
of hyperlinks throughout a document. This can be useful for changing the web 
address of hyperlinks.

The ability to limit searching to hyperlinks is available in the Find, Replace and Find & 
Replace In Files dialogue boxes.

Finding all hyperlinks in a document
Choose Edit->Find... to display the Find 
dialogue.

Check the Hyperlinks checkbox to limit the 
search.

Enter “http:” into the Find: text box which 
should match all web-based hyperlinks.

Press Find All... which will begin the search 
and open the Find Results window.

As the find progresses, results will be 
added to the Find Results window.

Once finished, double-clicking on a result 
will display the hyperlink in the main 
window of Foxit Advanced PDF Editor.

When Hyperlinks is checked, 
a few other options become 
unavailable. There is no concept 
of font styles or reflow modes 
when dealing with hyperlinks 
which are just text data.

1

2
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Inserting new pages
You can insert any number of new pages into any PDF document.

Open a PDF then choose Document->Pages->Insert New...  from the main menu bar.

1 432 5

Choose how many new pages you 
want to add (the default is 1).

Choose whether you want to insert 
the new page before or after an 

existing page.

Inserting a new page 
After the First Page

Inserting a new page before 
Last Page

Notes
•	 The size of new pages is determined by the page being viewed when the instruction is 

given.

Choose Use Current Size to make 
the new pages the same size as the 

currently displayed page.

The remaining options are the same 
as those in the New Document 

dialogue box.
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Reordering pages
A page or group of pages may be moved from one part of a PDF to another. You may 
have to alter page numbers printed on the pages after relocating.

213 4 5

5431 2

Open a PDF and choose: 
Document->Pages->Re-order...

Choose the range of pages you wish to 
relocate.

Then choose where you want them to be 
moved to.

Relocating pages 1 
and 2 to page 4.



	 Page Operations	 124

Resizing pages
A page or group of pages can be resized. This scales all objects on the page then 
adjusts the media box (paper-size). 
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As demand grows and budgets 

shrink for new educational 

facilities, many school districts 

are turning to wood-frame 

construction for its cost 

effectiveness. However, they’re 

also fi nding that, in addition to 

less expensive material costs, 

wood offers other advantages—

such as speed of construction, 

design versatility and the ability 

to meet green building goals—

while creating positive learning 

environments and meeting all 

code and safety requirements.

woodworks.org

W O O D  D E S I G N  &  B U I L D I N G  S E R I E S

Designing 
Wood Schools

When it comes to designing an educational facility, architects and designers 
must balance the reality of limited fi nancial resources with the desire to provide 
students with an exceptional learning environment that is warm and enriching. As 
a result, many are choosing to use wood as both a structural and fi nish material. 

SHW Group, recognized by Engineering News-Record as one of the top 
fi ve education design fi rms in America, likes to use wood in schools as often 
as possible. “Our mantra is that learning happens everywhere, not just in 
the classroom,” said Konrad Judd, a lead designer and principal at the fi rm’s 
Dallas offi ce. “The environments we create outside the classroom are just as 
critical for learning. That’s why we often use wood in common, public spaces 
which are used for casual and informal learning because we think exposed 
wood has a positive effect on the overall learning environment.”

Wood is an environmentally-friendly, energy-effi cient building material 
approved for use in schools by the International Building Code (IBC). Safety 
and durability are critically important in school facilities, and wood delivers 
value on both counts. Wood is also cost effective, saving school districts time 
and money for both materials and installation costs.

Green Building is Red Hot for Schools
A study released in 2007 by McGraw-Hill Construction found that the education 
sector was the fastest growing market for green building. The report also noted 
“an increasingly widespread adoption of policies that require public buildings to 
have green characteristics.”

Widely recognized for its environmental attributes, wood is well-
positioned to help schools meet their green building requirements. 

Wood is the 
only major building 
material that is 
both renewable 
and sustainable 
over the long 
term—and the only 
material with third-
party certifi cation 
programs in place to 
verify that products 
being sold originate 
from a sustainably 
managed resource. At Andy Dekaney High School in Houston, Texas (above and 

top of page), architects from SHW Group used exposed wood 

to create a warm learning environment that positively affects 

students’ sense of community. Credit: Richard Payne Photography
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As demand grows and budgets 

shrink for new educational 

facilities, many school districts 

are turning to wood-frame 

construction for its cost 

effectiveness. However, they’re 

also fi nding that, in addition to 

less expensive material costs, 

wood offers other advantages—

such as speed of construction, 

design versatility and the ability 

to meet green building goals—

while creating positive learning 

environments and meeting all 

code and safety requirements.

woodworks.org

W O O D  D E S I G N  &  B U I L D I N G  S E R I E S

Designing 
Wood Schools

When it comes to designing an educational facility, architects and designers 
must balance the reality of limited fi nancial resources with the desire to provide 
students with an exceptional learning environment that is warm and enriching. As 
a result, many are choosing to use wood as both a structural and fi nish material. 

SHW Group, recognized by Engineering News-Record as one of the top 
fi ve education design fi rms in America, likes to use wood in schools as often 
as possible. “Our mantra is that learning happens everywhere, not just in 
the classroom,” said Konrad Judd, a lead designer and principal at the fi rm’s 
Dallas offi ce. “The environments we create outside the classroom are just as 
critical for learning. That’s why we often use wood in common, public spaces 
which are used for casual and informal learning because we think exposed 
wood has a positive effect on the overall learning environment.”

Wood is an environmentally-friendly, energy-effi cient building material 
approved for use in schools by the International Building Code (IBC). Safety 
and durability are critically important in school facilities, and wood delivers 
value on both counts. Wood is also cost effective, saving school districts time 
and money for both materials and installation costs.

Green Building is Red Hot for Schools
A study released in 2007 by McGraw-Hill Construction found that the education 
sector was the fastest growing market for green building. The report also noted 
“an increasingly widespread adoption of policies that require public buildings to 
have green characteristics.”

Widely recognized for its environmental attributes, wood is well-
positioned to help schools meet their green building requirements. 

Wood is the 
only major building 
material that is 
both renewable 
and sustainable 
over the long 
term—and the only 
material with third-
party certifi cation 
programs in place to 
verify that products 
being sold originate 
from a sustainably 
managed resource. At Andy Dekaney High School in Houston, Texas (above and 

top of page), architects from SHW Group used exposed wood 

to create a warm learning environment that positively affects 

students’ sense of community. Credit: Richard Payne Photography

Open a PDF and choose: 
Document->Pages->Resize...

Choose to scale X & Y axis independently 
or click Constrain Proportions to maintain 
the aspect ratio.

Choose the units for scaling - percent,  
inches, points or centimetres

This illustrations shows a page being 
resized by 50% on both axes.

4.13 in

5.50 in

Uncheck this box to re-size the page only; objects on 
the page will not be altered. This is especially useful 
for re-sizing empty pages.
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Inserting pages from other documents
Pages from one document can be imported into the current PDF. There are two 
methods for doing this:

With your PDF already open, choose 
Document->Insert From Document... then 
choose the PDF you wish to insert using 
the file selection dialogue.

Or

Drag & drop a PDF file onto your open 
document.

After dropping the file, choose: 
Insert the PDF...

1

Continued...

2

3
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1 432 5

4

Finally, specify where you want the new 
document inserted.

Inserting a group of pages 
After the First Page

Inserting a group of 
pages Before the 
Last Page

Continued from previous page
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Placing a page from another document
You can place the contents of an entire page from another PDF into the current page 
of your PDF. There are two ways of doing this:

Method 1:

1

You can drag & drop a PDF file onto your 
open document to place a page.

You will then have the choice of opening 
or inserting the new PDF.

Choose the Place a page... option then press 
OK.

With your PDF already open, choose:  
File->Place PDF...

Then choose the PDF you want to place.

If the PDF you are placing has multiple 
pages, choose the page you wish to place 
(if it has only one page, you will not be 
prompted to choose)

1

2

3

Method 2: Drag & drop
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Page margins
Foxit Advanced PDF Editor can add margins to a range of pages to make editing 
easier. These margins act as fixed guides. See “Layout guides” on page 47 for an 
explanation of how guides work.

Choose Document->Pages->Margins...

Enter your required margins in the boxes. 
Checking Tie values together ensures that 
all boxes have the same value. This works 
when you move from one box to the next 
by pressing tab or clicking the mouse.

Notes
•	 To change the units used (cm in this case), close the dialogue and choose  

File->Preferences... and click on the Editing tab.
•	 After adding margins, they will become visible on all pages. Choose  

View->Guides->Hide Guides to hide them.
•	 Margins, like other guides, are retained in the PDF for Foxit Advanced PDF Editor 

to use next time you edit the document. They will have no effect on and will not be 
visible in any other PDF viewer.
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Watermarking pages
You can apply a fixed watermark to the foreground or background of the pages 
in a document. The watermark itself is defined in another PDF and can contain 
anything you like such as a logo or text.

With the document to be watermarked 
already open, choose: 
Document->Watermark->Add...

Into From PDF: enter the filename of the 
PDF you wish to use as the watermark or 
press the Browse... button.

Press Built in... to show the selection of 
predefined watermark PDFs that ships 
with the software. 

If the chosen PDF has multiple pages, 
Foxit Advanced PDF Editor will use only 
the first as the watermark.

Choose whether you want the watermark 
to appear in front of or behind the 
existing page contents on each page.

You can also choose to resize the 
watermark so that it fits the pages it 
is being applied to. When resizing, 
Foxit Advanced PDF Editor scales the 
watermark so that it’s crop box matches 
the destination page.

1

2

Continued...

When scaling is enabled, 
the crop box of the 
watermark is scaled to 
match the destination 
page.

If scaling were not used in 
these two examples, they 
would both give the same 
result - picture A.

A
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Finally choose the page range over which 
you wish to apply the watermark then 
press Apply.

You can have different watermarks for 
different parts of your document.

The finished page with a foreground, 
solid,  “Approved” watermark. 

Continued from previous page

4

5

Notes
•	 Watermarks behave like locked objects. If unlocked, a watermark can be edited as a 

normal object.
•	 A page may contain only one watermark at a time. When adding a new watermark to 

a page Foxit Advanced PDF Editor first removes any existing watermark.

The watermark can be shown with 
various degrees of transparency from 
completely solid to very faint.

3
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Page labels
A page label is an optional number or phrase displayed along with each page in 
Foxit Advanced PDF Editor or other PDF viewers. It is independent of, though often 
related to, the physical page number printed on each page.

Foxit Advanced PDF Editor displays page labels in the status bar.

Foxit Advanced PDF Editor status bar showing page label Quick Start: 9

Editing page labels
Choose Document->Pages->Labels... or 
double-click the page label in the status 
bar to open the Page Labels dialogue box.

Clicking on an existing label will copy 
its details into the edit boxes beneath the 
table.

Details of selected 
label shown here

Each label has a Start Page, an optional Prefix (such as “Appendix:”) and a Start Number. 
Labels remain in effect until the start page for another label is reached.

Numbering of labelled pages can be done in a number of ways as shown in the pop-
up list next to the Start Number edit box. 

Continued...

1

2
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Continued from previous page

Once a label has been modified be sure to 
press Add to store the changes back into 
the PDF.

If the Start Number clashes with an existing 
label, the new details will overwrite the 
existing label. Otherwise a new label with 
that Start Number will be added to the list.

Creating new page labels
To create a new label, fill-in the details in the lower portion of the dialogue box 
ensuring that the Start Page number isn’t already used in the table above.  
Press Add to store the new label’s details in the PDF.

3
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Full path name of the PDF 
and its size on disc.

Document properties
A summary of the settings, dates, author and other information about the current 
PDF can be viewed by choosing Document->Properties...

Click on the Modified: date to open the 
PDF’s Change Log.

Click on the Security: hyperlink to open 
the Document Security dialogue box.
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Security settings
Using PDF security settings you can limit what other people can do with your PDF. 
For example, you can stop other people editing or printing your PDF. 

View current settings
To check the security settings for a PDF, choose Document->Security... from the main 
menu.

If the document has been secured, the security dialogue box will display with most 
controls inactive. However the controls still show the current security settings such 
as whether or not editing is allowed.

If enabled, click Unlock... to 
change security settings.

Inactive controls show the 
current security settings 
for the PDF.

If the PDF has an existing Master 
password, you will have to enter it now.

If you do not know the password, you will 
not be able to alter any of the security 
settings.

1

2
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Document security
Using Foxit Advanced PDF Editor you can add or modify security settings on PDFs. 
Foxit Advanced PDF Editor supports the following password-based security levels:

• None 
• Acrobat 3 onwards (48 bit) 
• Acrobat 5 onwards (128-bit) 
• Acrobat 6 onwards (128-bit) 
• Acrobat 7 onwards (128-bit AES)

Acrobat 7 AES security is harder to defeat and offers finer control over the 
operations allowed on your PDF. Older style (Acrobat 5 onwards) security is more 
compatible.

User Password: 
If set, a password must be entered before the 
PDF can be viewed or printed.

The things other people are allowed to do with 
this PDF.

For example, if you want people to be able 
to add sticky notes without being able to 
change the content of the PDF, choose Editing: 
Comments & Form-filling

Notes
•	 If you forget the User password, you will not be able to open the PDF.
•	 If you forget the Master password, you will not be able to alter the security settings in 

future.

If unchecked, users will have to supply the Master 
password to be able to unlock locked objects. This can be 
useful when distributing templates.

Master Password: 
If set, a password must be supplied before 
changes can be made to security settings.
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Tracking changes
Foxit Advanced PDF Editor can highlight text that has been modified during 
previous editing sessions. It also records the date, author and page number of all 
changes made to PDFs (see step 3 below).

1

2

3

Choose File->Preferences...

Ensure Show changed text in: is enabled.

You can also choose the colour used for 
highlighting.

Text that has been modified in this or 
previous sessions will be highlighted 
using the colour chosen in the preferences 
dialogue box.

In this example, the ‘change’ colour is red.

To see a complete history of all pages 
modified using Foxit Advanced PDF 
Editor (version 2 or later) choose 
Document->Change Log.

Continued...
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Notes
•	 Foxit Advanced PDF Editor cannot highlight text that has been deleted. It will 

however, record that a modification has been made to the page that used to contain 
the text.

Continued from previous page

User Guy modified the PDF on Thursday, 25th October, 
2007. No particular page was edited (Perhaps security 
settings were modified.)

User warrenstone modified pages 2 to 25 around 11.14am 
on Tuesday 24th August 2010.
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Document font catalogue
Foxit Advanced PDF Editor can list all of the fonts used in a PDF plus additional 
information about the nature of each font.

Choose Document->Fonts... to view the font catalogue.

Select a font then click Replace... to replace all occurrences of the font in the PDF 
with another. See “Find & Replace fonts” on page 105. 

Or press Remap... to change the characters mappings of the font. See “Remapping 
fonts” on page 90.

Fonts introduced during the current 
editing session will not appear until 
the PDF is saved.

Names prefixed with “XXXXXX+” 
represent subset fonts (embedded with 
only a subset of their full character set).

Font types can include any that are 
supported by the PDF standard - 
TrueType, Type1, Type3, OpenType etc..

During editing, Foxit Advanced PDF 
Editor can only embed TrueType fonts 
taken from your computer’s system.

If the font is embedded in the PDF it will be used 
and labelled embedded. 

If the font is not embedded in the PDF the font 
substitute chosen by Foxit Advanced PDF Editor 
will be shown. This may be from Foxit Advanced 
PDF Editor’s built-in fonts or from your computer’s 
system fonts.

“Yes” indicates that 
the font has a built-in 
mapping to Unicode 

The number of 
character shapes 
defined by the font.

Notes
•	 When editing text, choose Text->Character Palette... to view all of the glyphs contained 

in a font.
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Flight check
Foxit Advanced PDF Editor includes a basic flight-checking function. A check for 
overset text (see “Overset text” on page 55) is always made prior to saving a PDF. 

Two additional checks are available:

	 • a check for images of less than 300dpi resolution 
	 • a check for non CMYK colour spaces 

Choose File->Flightcheck... to open the Flight Check Report dialogue box.

Uncheck to skip tests

Shows the numbers of problems 
found for each kind of test  
(even if the test is disabled)

Describes each problem found giving the 
kind of object effected and the page.

When saving a PDF, the flight check 
dialogue always checks for overset text.

Press Save Anyway... to ignore any problems 
and save the PDF.
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Comments catalogue
Foxit Advanced PDF Editor offers a summary of all comments found in a PDF. This 
catalogue is divided into three sections each containing the same information but 
sorted by:

•	 Page
•	 Comment type
•	 Author.

•	Choose View->Comments to show the 
comments catalogue.

•	Click on a comment’s entry in the 
catalogue to see the page on which it 
occurs.

•	Click on a comment and press Delete 
to remove the comment from the 
catalogue and the document.

When you edit the contents of the pop-
up note window, the comments catalogue 
updates at the same time.

Drag and dock the comments panel to 
any side of the main Foxit Advanced PDF 
Editor window to make it easier to read.

Drag the panel away from the main 
window to convert it into a floating 
window.
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Sticky notes
You can create new or edit existing “sticky note” annotations in PDFs. These are 
small pop-up windows designed to contain short messages such as approval or 
editorial comments.

Anatomy of a sticky note
Stick note icon. 

This can be moved around independently of the sticky 
note window.

Double-click the icon to toggle the main note window 
open or closed.

Close box

Resize box

Title bar - shows name of note 
author, title, date and time of last 
modification.

Message area 
with scroll bar

Notes
•	 If you can not see the sticky-note window after double-clicking on the sticky note 

icon, try scrolling the page or zooming out. It may be off the screen somewhere.
•	 There are a number of alternative icons available - see Stick Note Properties for details.
•	 To change the author’s name assigned to new notes, choose 

File->Preferences... from the main menu.
•	 Sticky notes are not included when printing PDFs.
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The sticky note tool is available on the 
Commenting toolbar. To show the toolbar 
choose View->Toolbars->Commenting

Drag-out a box to denote the size of the 
new sticky note. 

Alternatively, single-click the left mouse 
button to create a standard-sized sticky 
note window.

Creating sticky notes

Deleting sticky notes
Sticky notes can be deleted in two ways:

Using the Hand Tool or Sticky 
Note Tool, click on the sticky 
note icon to select it.

Then press Backspace or Delete on the 
keyboard.

a selected sticky 
note icon

1

Using the Hand Tool or Sticky Note Tool, 
right-click on the sticky note icon and 
choose Delete.

2

If you have not already set up a user name 
using File->Preferences..., Foxit Advanced 
PDF Editor will now ask you to supply 
one.

This user name will be recorded in each 
sticky note (or other comment) you make.

2

1
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Sticky note properties
Various properties of sticky notes can be modified such as the icon and colour can 
be changed using the Sticky Note Properties dialogue box.

1 Select the Hand tool or Sticky 
Note tool from the toolbar.

Click the right mouse button over the 
sticky note icon and choose Properties...

2

Use the dialogue box to change icon, 
colour, title and author.

The modification time cannot be altered 
manually.

Comment

? Help

Insert

NP

Key

New Paragraph

Note (default)

¶ Paragraph

Sticky Note Icons
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Graphical comments and notes
As well as simple Sticky Notes, Foxit Advanced PDF Editor offers a selection of 
graphical notations. These pair a simple shape with a pop-up note and can be used 
to draw attention to particular items on a page.

An example of a graphical 
comment made using the Circle note 
tool.

If the Commenting toolbar is not already 
visible, choose View->Toolbars->Commenting

The default colour for a graphical 
comment is red. This can be changed 
by right-clicking the mouse over the 
annotation shape (not the note window) 
and choosing Properties...

A graphical comment has an optional Fill 
colour, Line colour and a Line width (default 3 
points).

You can also vary the Opacity of the 
comment to allow the contents of the 
page underneath to show through.

Circle note tool selected
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Stamps and signatures
Foxit Advanced PDF Editor offers a selection of predefined stamps - 
graphical labels - that can be placed, resized and coupled with a pop-up 
note window.

An example of a Sign Here stamp and its 
associated pop-up note window.

Stamp tool selected

Adding a stamp to a page
1.	 The Stamp tool is available on the 

Commenting toolbar. To show the 
toolbar choose  
View->Toolbars->Commenting

2.	 Click and hold the Stamp tool icon to see 
the menu of available stamps. 

3.	 Select one of the stamp types then click 
in your page to create a standard-size 
stamp.

4.	 Alternatively, drag-out a box to denote 
the size of the new stamp. 

5.	 Double-click the stamp to open its 
associated note window.

Signature is a special 
case and is covered in 
the next section. Continued...
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Continued from previous page

Using the Hand tool or any one of the 
commenting tools, right-click over the 
stamp and choose Properties...

You can change the Appearance of the 
stamp as well as alter it’s Opacity - handy if 
you want the pages contents underneath 
the stamp to show through.

Stamp properties

1

2a

You can also change the appearance of 
a stamp by selecting it with one of the 
commenting tools then holding down the 
stamp tool to reveal the stamp menu. 

The current stamp style will be show with 
a check-mark next to it. Select a different 
style and the stamp will be changed.

2b
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Adding a signature to a page
If you have scanned a copy of your signature, it can easily be stamped onto a 
document  - avoiding the need to print the document and sign it. 

Foxit Advanced PDF Editor remembers your signature and the size at which it 
should be used to make signing documents quick and easy in the future.

To add your signature, choose: 
Edit->Signature->Insert... 
or  
press and hold the Stamp tool button 
on the Commenting toolbar and choose 
Signature from the bottom of the pop-up 
menu.

To show the Commenting toolbar choose 
View->Toolbars->Commenting. 

The first time you add a signature, Foxit 
Advanced PDF Editor will ask you to 
choose an image file to use as your 
signature. This can be any JPEG, PNG, 
Tiff or BMP image.

Foxit Advanced PDF Editor will make a 
copy of this file and use it in future.

To redefine your signature at a later date, 
choose Edit->Signature->Define...

We want to add a 
signature here

The signature chosen in this 
example is a high-resolution, 

JPEG, grey scale scan 

Continued...

1

2
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Continued from previous page

After initial placement, the signature 
image will need to be resized.

Whilst holding down the SHIFT key, drag 
one of the resize handles to scale the 
image, retaining its original aspect ratio.

The signature function places the image 
so that it’s white background remains 
transparent.

The finished size of the signature image is 
recorded by Foxit Advanced PDF Editor 
so that next time a signature is placed in 
this way, you should not need to resize it.

3

4

Notes
•	 Signatures placed in this way are not annotations in the same way as sticky notes etc. 

They do not have associated pop-up note windows, do not appear in the comments 
panel and are always included during printing.
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Text highlighting
Use the text highlight button to add a coloured, semi-transparent highlight around 
selected text. Like other annotations, the highlight has an associated pop-up note 
window.

Using the Text tool select a span of 
text to be highlighted.

Make the Commenting toolbar visible by 
choosing View->Toolbars->Commenting

Press the Text Highlight button to 
highlight the selected text.

The text will be highlighted and 
the associated pop-up note window will 
appear, pre-filled with the content of the 
highlight.

Notes
•	 Text highlights are annotations that sit on-top of the PDF page like other 

annotations. They do not track the text they apply to so which means that if you edit 
the text on the page after highlighting, the text may move underneath the highlight.

•	 A similar result can be achieved using the underline facility - this will track edited 
text but does not have an associated pop-up note window.  
See “Underline” on page 61

1

2
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3

Choose the link type from the selection 
available. The “Foxit” link types are used 
during the conversion of PDF into other 
formats (See “Exporting Content” on page 
169)

Changing the Action Type: option will 
cause the bottom section of the dialogue 
box to change.

Hyperlinks
Use hyperlink annotations to create interactive boxes which, when activated by the 
reader, will jump to another part of the same PDF, a different PDF or web address 
(using an external HTML browser).

2

Click on the Link tool button in the 
main toolbar.

Drag-out a box to denote the shape of the 
hyperlink region.

1

After drawing the hyperlink box, the Link 
Properties dialogue box is displayed.

The bottom half of the dialogue changes 
to suit the type of link chosen in the top 
half.

Continued...

Email: sales@foxitsoftware.com
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Type: Go To View

Continued...

4a

Choose Go To View

Whilst the dialogue is still open, return 
to the main PDF window and navigate to 
the page and position you want displayed 
when someone clicks on the new 
hyperlink.

Back in the dialogue choose the Zoom: for 
the destination view.

Press OK to create the hyperlink.

4b

Type: Open File

Press Browse... to choose the file to be 
opened when the hyperlink is activated.

Next, choose how you want the new file 
opened: in a new window, in the same 
window or leave the choice up to the 
user’s preference (dictated by their own 
PDF viewer’s preferences)

Choose Open File

Continued from previous page
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Specify the destination address.

Web addresses should begin with “http://”

4c

Type: World Wide Web Link

Choose World Wide Web Link

Continued from previous page

Foxit Image Box & Foxit Table Box annotations
These Foxit Advanced PDF Editor-specific annotation types can be used to export 
images and tabular information. There use in this way is detailed in “Exporting 
Content” on page 169.

They can also be used for automating the extraction of tagged data from laboratory 
reports as part of a LIM (Laboratory Information Management) system.
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Bookmarks
Bookmarks allow readers to quickly navigate to specific places in a PDF and 
are especially helpful in long PDFs. Using Foxit Advanced PDF Editor you can 
automatically add bookmarks to a PDF as well as modify and delete existing 
bookmarks.

On screen display
To see a PDF’s bookmarks choose View->Bookmarks or press the F9 function key.

Notes
•	 Drag a bookmark on the title of another to nest the bookmark within the other.
•	 Drag a bookmark on the icon of another to move without nesting within the other.

Bookmarks toolbar

Add new bookmark

Delete bookmark

Click on a bookmark to view the associated 
page in the PDF.

Click again to begin editing the title of the 
bookmark.

View/Edit font filters

Automatic bookmarks
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Automatic bookmarks
Foxit Advanced PDF Editor can create bookmarks automatically. This is especially 
useful for long PDFs that have no bookmarks. 

You can optionally limit the process so that only text written using specific fonts is 
eligible for inclusion in the resulting bookmark tree.

Choose View->Bookmarks to make the 
bookmark catalogue visible.

Navigate to the page from where you wish 
bookmark creation to begin. 

For example, if you wanted to omit the 
document’s table of contents from the 
bookmarks, go to the first page after it 
before starting bookmark creation.

Press the magic wand icon on the 
bookmark panel’s toolbar.

If the PDF already has bookmarks, 
Foxit Advanced PDF Editor will prompt 
you to proceed. If you do, all existing 
bookmarks will be removed before the 
new ones are added.

Press Yes to begin bookmark creation.

Depending upon the length and 
complexity of your document, the process 
may take a little while to complete.

You can cancel the process at any time by 
pressing Stop. Though this may leave the 
document’s bookmark catalogue in an 
incomplete state.

1

2

3

Continued...
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Continued from previous page

In this example bookmark creation has 
produced a fair result. 

It can be improved now by deleting 
unwanted items. 

The stage directions such as [Enter a 
Gentleman] are not wanted and too 
numerous to delete by hand. 

This can be avoided by instructing Foxit 
Advanced PDF Editor to ignore the fonts 
in which they are written. See “Bookmark 
font filters” on page 158 for details.

Unwanted items. Use the 
Font filter mechanism to avoid 
adding these stage directions.

4
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Bookmark font filters
To avoid adding unwanted items to the bookmark tree during automatic bookmark 
creation, you can instruct Foxit Advanced PDF Editor to consider only text written 
in specific fonts. 

Using the Text tool, select some text 
of the kind you wish to include in 
the bookmark tree.

In this case ACT III is the kind of bookmark 
we want.

Press the Font filters button on the 
bookmark panel’s toolbar.

The Bookmark Font Filters dialogue shows a 
list of all the fonts that Foxit Advanced 
PDF Editor will consider during 
automatic bookmark creation.

Initially the list contains only one entry: 
All fonts

Any font not mentioned in the list will 
be ignored during automatic bookmark 
creation.

Press Add to filters to add the selected text’s 
font to the list.

Continue selecting and adding fonts to 
the list of filters until you have all those 
you wish for your automatic bookmarks.

To delete a font from the list, select it and 
press Delete.

1

2

3
Continued...
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Continued from previous page

This time the bookmarks have been 
created without any of the stage 
directions and look much more useful.

Notes
•	 The list of font filters is not stored by Foxit Advanced PDF Editor and will need to be 

re-created if you close the document.

4
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Creating bookmarks
A bookmark records the page number, location and zoom setting used to view the 
page at the time the bookmark was created.

Choose View->Bookmarks to ensure that the 
bookmark catalogue is visible. 

Navigate through your PDF to the page 
you want to bookmark, zooming and 
scrolling to the exact position you want to 
record.

Press the New bookmark button on 
the bookmark panel’s toolbar to 
create a new bookmark.

The new bookmark will be created and 
named “New Bookmark”.

See “Renaming bookmarks” on page 161 
for details of how to rename the new 
bookmark.

1

22

1
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Renaming bookmarks

Click on an existing bookmark to select 
it.

After a short delay, click again to start 
renaming. The name of the bookmark 
will become selected, ready for editing.

Deleting bookmarks

Click to select the bookmark item to be 
deleted.

Press the Delete or Backspace key to delete.

Note
•	 If you delete a bookmark item that has sub-items (as shown above), the sub-items will 

also be deleted.

1

2
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Moving bookmarks
You can move bookmarks to different parts of the bookmark tree.

Click to select the bookmark to be moved.

Drag the bookmark and drop it onto 
the icon of the bookmark you want it to 
appear after.

The bookmark will appear after the 
bookmark you dropped it onto and at the 
same nesting level.

Moving to the top
Move the bookmark you intend to be top 
so that it is second in the list (as shown 
above). 

Then select the first item in the list.

Drag the first item and drop it onto the 
icon of the second item (the one you want 
to be top).

The two bookmarks will switch places.

1

2

3

1

2

3
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Nesting bookmarks
Click on the bookmark you wish to nest.

Drag the bookmark onto the title of the 
bookmark in which it will be nested.

The bookmark is nested within the one 
on which it was dropped.

De-nesting Bookmarks
Click on a nested bookmark you wish to 
move to a lower nesting level.

Drag the bookmark and drop it on the 
icon of any bookmark with the nesting 
level you want.

The bookmark’s nesting will be changed 
so it matches the one on which it was 
dropped.

1

2

3
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Article threads
Articles are invisible, linked boxes 
used to aid the reader in following 
the flow of a story through a PDF.

When a viewing application such 
as Adobe Reader detects an article 
thread, it is able to present the text 
boxes in turn for easier reading of 
the complete article. 

Some applications can use articles 
to reflow the PDF or convert and 
export stories into other formats 
such as HTML (see “Exporting 
article threads” on page 178).

There is no limit on the number of article threads a document can have.

Open the page containing the start 
of the story you wish to annotate 
and select the Article tool from the 
toolbar. 

Carefully drag out a box around the first 
column of text in the article. Continue 
dragging out boxes around subsequent 
columns, changing pages as needed to 
follow the story’s flow.

An article box can be moved, resized or 
deleted after drawing as long as the Article 
tool remains selected.

Continued...

Adding article threads

1
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When the last box has been drawn, press 
the Escape key to finish the article.

Now select one of the new article boxes 
and choose Edit->Article Thread->Properties... 
to display the Article Properties dialogue 
box.

You can also display this dialogue by 
double-clicking on an article box.

The information you supply here is used 
by some PDF viewers to present an article 
catalogue to users so they may choose an 
article to read.

Foxit Advanced PDF Editor makes use 
of Title during export of Article threads 
into other formats such as HTML (see 
“Exporting article threads” on page 178)

For details of the Duplicate facility, see 
“Duplicating article boxes” on page 167.

If there is enough room, Foxit Advanced 
PDF Editor displays the article’s title in 
each box plus then sequence number of 
the article.

If there isn’t enough room for both, just 
the sequence number is shown.

Continued from previous page

2
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Extending existing articles
You can add or insert a new article box in an existing thread.

Open the page containing the 
article box you want to link to 
and select the Article tool from the 
toolbar. 

In this example we are going insert a new 
link between link 2 and 3 of the “Cycle 
Parking” article thread.

Click on box 2 to selected it then click 
again on the plus icon in the bottom right 
hand corner of the box.

To link a new article box to an 
existing box, first click on the plus 
icon in the existing box.

Boxes after the new one have been renumbered.

Drag out a new article box.

When you finish dragging, the new box 
will be numbered 3 and the box that 
was formally numbered 3 will now be 
numbered 4.

The new box has been inserted between 
2 and 3.
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Duplicating article boxes
Foxit Advanced PDF Editor can duplicate an article box across a range of pages. This 
is useful when you need to form a long article spanning multiple, similar pages such 
as a book or report.

Using the Article tool, drag-out a 
new article box to fit the size of 
the content on this page and all 
following pages in the range you intend to 
cover.

If you want this new box to be linked 
to an existing thread, first click on the 
link icon in the bottom 
right hand corner of the 
preceding article box 
before drawing this new 
one.

Choose Edit->Article Thread->Properties... to 
display the Article Properties dialogue box.

You can also display this dialogue by 
double-clicking on an article box.

Click on Duplicate and enter the end page 
for the new article boxes to be created.

On pressing OK Foxit Advanced PDF 
Editor will clone this article box on every 
page from the current page up to and 
including the end page specified, linking 
all the cloned boxes together.2

1
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Deleting articles
You can delete an article box, a range of boxes or an entire article thread. This does 
not affect the content of the PDF (the text in the stories themselves is unaffected).

Using the Article tool select the 
article box to be deleted.

Choose Edit->Article Thread->Delete... 
or press the Delete key.

The delete dialogue box gives you the 
option of deleting the entire article 
thread,  the currently selected article 
bead (in this case bead 1), all beads in a 
range of IDs or all beads across a range of 
pages.

We have selected the first 
article box (bead) in this article 
thread.

For example, to delete beads 2 and 3 only, 
you could choose Beads with IDs then enter 
2 to 3 in the edit boxes and press OK.

1

2

3
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Exporting pages
Foxit Advanced PDF Editor can convert an entire PDF or range of pages to other 
formats such as HTML and ePub. The conversion reformats the text and images, 
areas marked for rendering and tabular regions. You can export by page range or by 
article thread (see “Exporting article threads” on page 178), individual images or 
tables.

Open the document you intend to export. 
Choose File->Export->Pages As... to reveal 
the Export Pages dialogue box.

Specify the range of pages you wish to 
export.

To change the format of the export or 
to choose whether to export text only, 
images only or both press the Format... 
button.

The various options available within the 
format dialogue are described in “General 
export settings” on page 179

This is a summary of the export 
options currently in effect.

Notes
•	 Foxit Advanced PDF Editor analyses the pages to be exported and ranks fonts by 

size to work out what should correspond to the various levels of heading (H1,H2 
etc) available in the output format. For the export formats that rely on this ranking, 
the results can differ if you export a subset of pages to when you export the entire 
document.

• 	 Use the Crop tool prior to export to exclude parts of the page (for example to stop 
headers & footers being exported).

1
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Exporting images & illustrations
Foxit Advanced PDF Editor can export images stored in a PDF into various popular 
image formats. However, when it comes to exporting an illustration made from 
line-drawings, Foxit Advanced PDF Editor needs to be told which parts of the page 
form the illustration.

That is because there is no universal means of determining which parts of a page 
are an illustration and which parts are just normal page contents. For example, is 
the rectangle in the header on this page an illustration to be exported or just page 
furniture?

How do you tell if a picture needs marking-up? 
If the quality of the picture appears to degrade or become more blocky and 
pixelated as you zoom in to it, then it is a bitmap and does not need marking - Foxit 
Advanced PDF Editor can detect these without any assistance. 

If however, the quality remains high, no matter how far you zoom, it is probably a 
line-art, composed of vector drawing commands. You will need to mark the area in 
order to export it at its best.

Markup up an image

Choose the Hyperlink tool from the 
main toolbar.

Carefully drag out a box around the area 
to be exported.

Everything included within the rectangle 
you make will be rendered by Foxit 
Advanced PDF Editor and included in the 
export.

Continued...

In this example an illustration 
including text and a light green 
background is to be exported.

1
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Continued from previous page

After marking out the image, the Link 
Properties dialogue box will appear.

Change the Type: pop-up to Foxit Image Box.

Enter a title for the table in the Label: box. 
This is used during export in HTML 
based formats.

You can now choose to repeat this 
markup across a range of pages. This 
is useful if your document contains a 
similar image, repeated across several 
pages.

Press OK.

The are is displayed by Foxit Advanced 
PDF Editor together, if there is room, with 
the (optional) image label.

In this example, the illustration is on a 
light green background - part of original 
page design.

To avoid exporting the background 
as well, use the Object tool to select 
the background rectangle and then 
choose Object->Hide Selection. 

Not only is it hidden from view in the 
main viewing window, it will be hidden 
when Foxit Advanced PDF Editor renders 
the marked area for export.

The rectangle can be revealed again (after 
export) by choosing Object->Show All. 

Continued...
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Continued from previous page

Exporting individual images
Once a picture has been marked up (see previous page), it can be exported 
immediately and in isolation - without exporting the rest of the page or document. 

Select the Hand tool from the main 
toolbar.

Click on the marked image to 
display the Render Image Box dialogue box.

The red image rectangle is only visible 
while the Hyperlink tool is selected.

From the Resolution: pop-up menu, choose 
the resolution to be used for rendering the 
area. Higher resolutions result in better 
image quality, longer rendering time and 
larger image files.

As a guide, 300 dpi is usually sufficient for 
most types of colour printing.

From the Format: pop-up, choose the 
file format for the image.  JPEG tends to 
produce the smallest file sizes. PNG and 
TIFF retain the highest quality.

The file format affects the choice of colour 
depth. The JPEG file format cannot be 
used for purely black and white (bi-level) 
images, so these options will be greyed 
out should you choose JPEG.

Continued...
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Continued from previous page

Finally, choose the Colour Depth: to be used 
for rendering.

For most purposes RGB will be the best 
option (full colour).

An example of each of the image formats 
is shown below.

RGB (full colour), 
largest file size

Dithered (bi-
level), small file 
size

Bitmap (bi-level), 
smallest file size

Grey scale

4
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Exporting tabular information
To obtain the best results when exporting tabular information, Foxit Advanced PDF 
Editor needs to be told which areas to treat as tables. Without this information, 
table are treated as normal paragraphs and columns resulting in poor output.

Marking up a table
Navigate to the table to be marked up. 

Select the Hyperlink tool from the 
main toolbar.

Carefully drag-out a box around 
the table. Exclude any non-tabular data 
that could confuse the analysis process.

After marking out the table, the Link 
Properties dialogue box will appear.

Change the Type: pop-up to Foxit Table Box.

Enter a title for the table in the Label: box. 
This is used during export in HTML 
based formats.

You can now choose to repeat this 
markup across a range of pages. This 
is useful if your document contains a 
similar table, repeated across several 
pages.

Foxit Advanced PDF Editor will look 
at the appearance of the tabular area, 
including any borders used to delineate 
rows and columns. In some cases, it may 
be best to ignore these lines and analyse 
only the non-graphical content in order 
to discern the structure of the table. In 
this case, check Ignore borders....

Press OK.

Continued...
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Continued from previous page

Foxit Advanced PDF Editor will then 
display the table link box together with its 
label (if there is room).

When you next export the document, 
this markup-up area will be treated as a 
table which should improve the output.

The blue table boxes are only visible in 
Foxit Advanced PDF Editor when the 
Hyperlink tool is selected.

Exporting individual tables
Once a table has been marked up (see previous page), it can be exported 
immediately and in isolation - without exporting the rest of the page or document. 
This instant approach is the only way to export to SYLK format.

1.	 Select the Hand tool from the 
main toolbar.

2.	 Click on the marked-up table.

3.	 Choose a name for the file into which 
the table will be exported.

4.	 Choose the format for the export.

SYLK (an popular format for encoding 
spreadsheet information) is only available 
when exporting in this instant way.

Shown is the table marked-up in the 
previous page, exported as HTML 4.

The HTML generated by Foxit Advanced 
PDF Editor is deliberately kept simply so 
that it can easily be edited or included in 
other documents. 

3
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Cropping for export
To exclude parts of a page from exporting then you can use the crop tool to 
temporarily crop a range of pages in your document. Anything outside of the crop 
box will be ignored during the export.

Use the Crop tool to drag out a box. 
In this example, the page header 
and footer remain outside of the 
box to exclude them from the export 
process.

Once the export has been done, the crop 
can be removed by choosing: 
Document->Pages->Remove Crop...

Notes
•	 The Foxit Crop Box hyperlink that can be created using the Hyperlink tool is for use 

with the Argus extraction engine. It is used to specify the automatic crop box applied 
to documents as they are processed.
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Exporting article threads
Foxit Advanced PDF Editor can use article threads as a guide to the order in which 
text is exported from a document. For example, a story in a newspaper typically 
consists of many columns of text and may even span multiple pages. By marking 
each of these as parts of a single article in the correct order, Foxit Advanced PDF 
Editor can extract the text in reading order.

For details of how to add articles to a PDF see “Adding article threads” on page 
164.

when exporting articles from a PDF, Foxit Advanced PDF Editor will also attempt to 
join-up any paragraphs broken across article boundaries. When exporting by page, 
this joining does not occur.

If you have a document which does not output in the correct reading order, the 
application of article threads to the problem areas should improve export of both 
articles and pages.

Open the document you wish to export 
then choose File->Export->Articles As...

Foxit Advanced PDF Editor will warn 
you if there are no article threads in the 
document. In this case, you will need to 
add some before you try to export again. 
See “Adding article threads” on page 164 
for details. 

Press Format... to change the format used 
for the export (HTML, ePub, etc).

If the Create file for every page/article option 
in the Text tab of the Export Format dialogue 
is selected (see “Create file for every page 
/ article” on page 185), Foxit Advanced 
PDF Editor will write each complete 
article to a different file

Furthermore, when using HTML output 
with article mode, Foxit Advanced PDF 
Editor will produce a table of contents 
linking to each article output.

This is a summary of the export 
options currently in effect.

The Export Format dialogue box

1
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General export settings
Use this panel to select the main text 
and image output options to be used 
when exporting a PDF. It acts as a short 
cut for changing the major features 
of output, keeping the more specific 
settings hidden in other tabs.

Text Output
Check this item to export the text 
content of your PDF. Either Text Output 
or Image Output (or both) must always be 
enabled.

Text Format Pop-up
Foxit Advanced PDF Editor supports 
a varied range of text output formats 
including a set of XML based formats, plain text and RTF for use with Microsoft 
Word and other applications.

Foxit Advanced PDF Editor can also export table data in SYLK format but only 
when clicking on a table that has been marked-up with a Table Box annotation (See 
“Exporting individual tables” on page 176).

Each of the available text formats is described below.

•	 Plain Text
ASCII text, readable with any text editor or word processor. When layout is 
retained using this format, spaces are inserted to ensure words and paragraphs 
are placed into the right location.

•	 RTF
Microsoft’s Rich Text Format, readable by virtually every word processor. An 
ideal input format for Microsoft Office. Foxit Advanced PDF Editor can embed all 
document images in a single RTF file.

When exporting to RTF with Retain Layout, you may encounter difficulties if your 
original document’s page size is larger then 55cm (width or height). Some versions 
of Microsoft Word cannot deal with such large page sizes.

Continued...
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•	 Simple HTML
HTML using only a few simple tags. This is readable by all web browsers, but 
some formatting may not be preserved. Images are linked from the document 
rather than shown in-line.

A list of document bookmarks will be output at the top of the first page. If Create 
file for every page/article is active a cover page, a bookmarks page and individual 
contents pages will be produced, each hyper linked together.

When Try to preserve layout is active, this format inserts spaces making use of the 
<PRE> tag in HTML to force the browser to honour every space character.

•	 HTML 3.2
More complex HTML allowing for a wider range of styling. In-line images are 
used. Meta-tags are added to the document using the creator, author and title 
information stored in the PDF. Different character sizes are rendered using the 
tags <H1>, <H2> etc. 

If Create file for every page/article is active, a bookmarks page (if bookmark output 
is enabled) and several data pages will be output. When frames are enabled the 
index page uses frames to show the bookmarks on the left while viewing each 
page on the right.

When Try to preserve layout is active, this format uses a complex HTML table for 
each page. Font sizes in layout mode are selected using the FONT SIZE+/- technique 
rather than <H1>, <H2> etc. since this gives better results.

•	 HTML 4
As HTML 3, but CSS (Cascading Style Sheet) tags are used to render fonts and 
sizes. This should be compatible with most modern web browsers.

If Create file for every page/article is active, a separate file is output containing all of 
the CSS style elements used by the rest of the output pages. Edit this style sheet 
file to quickly alter the look of the rest of the document.

When Try to preserve layout is active, this format uses a complex HTML table in 
the same way as HTML 3.2. However, fonts and sizes still use CSS1 mark-up for 
better results.

•	 HTML 4 CSS
Using HTML with Cascading Style Sheets (v2) provides the most accurate 
depiction of PDF content for the web. When preserving layout all fonts and 
positioning are closely replicated. 

Continued from previous page

Continued...
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When Try to preserve layout is active, a separate CSS file is produced which describes 
the styles of all fonts used. Edit this CSS style sheet if any adjustments need to be 
made to the look of the converted document. 

•	 ePub
Exports a single .epub file with no digital rights management, with or without 
images using basic formatting.

•	 ePub CSS
Similar to ePub except that the formatting is specified in a separate .css file held 
inside the ePub package.

Right-to-left reading order
When enabled, Foxit Advanced PDF Editor assumes the contents of the PDF are to 
be read right-to-left (as is the case in Hebrew). It attempts to replicate this reading 
order in the output produced.

Image Output
Check this item to export the image content of your PDF including those marked 
with Image Box annotations. Either Text Output or Image Output (or both) must always 
be enabled.

Image Format
Foxit Advanced PDF Editor supports a range of image formats: JPEG, Tiff, BMP and 
PNG. Each of these formats has different properties and is suitable for a different 
purpose.

Tiff supports CMYK which may give improved colour fidelity when converting 
magazine and newspaper pictures.

Tiff (multi-page) will place all images within the same file. You will need a Tiff 
viewer capable of handling multi-image files in order to view these correctly.

Convert each page into an image
Check this option to render the contents of each page. When checked, text output is 
disabled since the entire contents of each page will be contained in the image file(s) 
produced.

Continued from previous page
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Place images in sub-folders
This option causes images files to be stored in a sub folder named ‘images’. This also 
effects the path used in the IMG tag for HTML output.



	 Exporting PDF Contents	 183

Text export settings
Use the settings on this panel to control 
the way text is output in all formats. 
Additional settings which effect only 
HTML output are grouped separately in 
the HTML settings panel.

The options in the this tab are placed 
into two sub-groups named Text Flow and 
Text Appearance. This is simply to make 
the panel a little easier to read.

Identify image captions
Selecting this option will cause Foxit 
Advanced PDF Editor to identify image 
captions and output them along with 
images, rather than in the main body of text. If image output is selected and the 
image format supports it (Tiff, JPEG, PNG), captions will also be embedded within 
the image data.

Try to preserve layout
In all text formats except ePub, this option causes Foxit Advanced PDF Editor to 
position words as closely as possible to the original page layout. The way in which 
the positioning is achieved depends upon the output format used.

Plain text with the layout retained should be viewed without line wrapping in a 
mono-spaced font (such as Courier). Most output text documents will be very wide. 
Simple HTML will be formatted as with plain text using letter spacing to position 
page elements.

HTML 3 and 4 use tables to position page elements. HTML 4 CSS uses the absolute 
positioning functionality available with CCS2. This may not be compatible with 
some older browsers.

With all output formats there may be some deviation from the original document 
layout requiring a degree of manual adjustment. 

Render text in vector artwork
When enabled, text will be included in rendered artwork but not in the normal text 
output stream. When not selected, the converse is true. That is, text will not appear 
in rendered artwork but will appear in the text output stream.

Continued...
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If you find that some text you expected to see in your output is missing, check to see 
if this options is enabled. 

Recognize Speech Marks
When Preserve Line Break is off, Foxit Advanced PDF Editor attempts to reflow text 
into paragraphs. The process is fairly reliable but may occasionally make mistakes. 

However, when it comes to reported speech of the kind that may be found in a 
conversation in a novel, it is vital that the correct line-breaks are retained; in speech, 
the line-break is the reader’s main indication of a change in speaker.

When this option is on, Foxit Advanced PDF Editor pays particular attention to 
quotation marks, especially those at the beginning of a line or paragraph. The result 
is that it is much more successful in retaining these important line breaks.

When processing documents unlikely to contain any reported speech, it is best to 
disable this option. 

Preserve line breaks
Selecting this option will ensure that Foxit Advanced PDF Editor honours all line 
breaks in the original document. Furthermore, it will stop Foxit Advanced PDF 
Editor from removing hyphenation.

Enabling this option can make editing the output more difficult since lines of 
text will not re-flow after insertions or deletions. However, it may improve the 
appearance if layout is important. 

De-hyphenate Words
When enabled, Foxit Advanced PDF Editor will rejoin words split by a hyphen at the 
end of a line. Words with hard hyphens such as “442-squadron” are not altered.

To help in making the decision to leave or remove hyphens, Foxit Advanced PDF 
Editor consults the language dictionary currently selected for spell checking 
(see “Spelling preferences” on page 196). However, should a particular word be 
unknown in the dictionary or be in a different language, it is possible the software 
may take a wrong decision. 

When disabled, Foxit Advanced PDF Editor does not remove any hyphens and 
words will remain split as they are in the original document. 

When Try to preserve layout or Preserve Line Breaks is enabled, word de-hyphenation is 
automatically disabled.

Continued...
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Create file for every page / article
Cause Foxit Advanced PDF Editor to output each page to a separate file. When 
outputting to HTML output files will be hyperlinked together. It is not applicable to 
ePub output which always produces a single file.

When outputting article threads, Foxit Advanced PDF Editor will place each article 
in a separate file.

Hyperlinks
If Foxit Advanced PDF Editor detects any embedded hypertext links within a PDF, it 
will try to retain these in the output. This is not possible for plain-text output.

Bookmarks
When enabled, Foxit Advanced PDF Editor will retain a document’s bookmarks as 
hypertext destinations in all but plain text output modes.

When disabled, no bookmarks will be output.

Page Breaks
When enabled, Foxit Advanced PDF Editor will output the given text at the end of 
each page produced. For HTML for example, <HR> may be used as a simple page 
break.

Continued from previous page
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HTML export settings
This tab contains options for tailoring 
the way Foxit Advanced PDF Editor 
produces HTML output.

Background
This group of options allows a 
background colour or image to be 
specified for each page output in HTML. 

Whatever is entered in the Colour: box is 
included in the <COLOR> attribute of the 
<BODY> tag of each page output. Colour 
could be the word “yellow” or a colour 
definition such as “#FFFFFF”.

The Image: box is used to enter a 
filename of a image. This name is placed into the BACKGROUND attribute of the 
<BODY> tag for each page. Be careful about the name entered here since it will be 
included exactly as typed. 

The image name need not refer to an actual image on your hard disc but may for 
example, refer to an image which is or will be stored on the computer used to host 
the web pages once they are complete.

Header and footer files
The header and footer file boxes are used to specify files on disc whose contents 
will be merged into each page of HTML output by Foxit Advanced PDF Editor. For 
example you may wish to add your company’s own corporate graphics to the top 
and bottom of each page output. 

The contents of the header file will be output just after the <BODY> tag of a page but 
before any extracted text or images. Similarly, the contents of the footer file are 
output just before the closing </BODY> tag of each page.

You cannot type into the text boxes directly so instead use the Browse... buttons to 
select existing files. 

Page-to-page links
When Foxit Advanced PDF Editor is processing in File-Per-Page mode as set in the 
Text Settings tab, each page of a document is stored in a new file and navigation links 
to the previous, first and next pages are placed on each page for convenience.

Continued...
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The controls in this group allow the appearance of these navigation links to be 
changed. Whatever is entered into either of the Previous, First or Next boxes will be 
output instead of the words “Previous”, “First” and “Next”.

This facility may be useful when converting documents for a non-English speaking 
audience or if navigation images are required rather than text.

Image Borders
When enabled, images will have a border around them generated using the border 
attribute of the HTML <IMG> tag

Frames
This setting only takes effect when bookmark output is enabled (see “Bookmarks” 
on page 185).

When enabled, Foxit Advanced PDF Editor creates a two-frame frameset definition 
which places the bookmarks frame on the left hand side of the screen and the 
extracted content on the right hand side. Clicking on a bookmark, changes the page 
in the right hand side.

When disabled, no frameset is created and bookmark destinations do not reference 
a target frame.

Continued from previous page
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Image export settings
When image output is enabled in the 
General format tab, Foxit Advanced PDF 
Editor produces copies of all images 
stored in the PDF. 

The options in this tab are mainly 
concerned with the scaling or size of the 
images output.

Foxit Advanced PDF Editor can deal 
with two types of image in PDF: vector 
illustrations consisting of lines, curves, 
filled areas and bitmap images or 
photographs made up of many colored 
pixels. 

Foxit Advanced PDF Editor cannot 
output vector formats directly but will instead convert any such illustrations into a 
bitmap format by a process called rasterization.

Auto-identify vector artwork
Many PDF documents may contain vector artwork or line-art. However, due to the 
nature of PDF, it is not always possible for a computer program to determine where 
on a page such artwork occurs since each page is stored as a general mix of text, 
images and line-art.

Foxit Advanced PDF Editor is capable to an extent, of identifying such artwork on a 
page.  Selecting this option will cause Foxit Advanced PDF Editor to automatically 
convert vector artwork in the original into images in the output format selected. 

If you are not sure whether a document contains vector artwork or bitmaps, zoom 
in on the picture. If it becomes blocky or pixelated then it is a bitmap image. If it 
stays sharp and detailed, it is probably a vector-based drawing.

If you encounter problems with illustrations not being correctly identified, use the 
Hyperlink tool to mark them up with Image Box links. See “Exporting individual 
images” on page 173 for details. 

Foxit Advanced PDF Editor can only output images in bitmap formats not vector 
graphics formats. If images do not appear in your final output documents, try 
turning this option on or placing an image box around the missing images.

Continued...
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Use original OPI name if available
If your PDF contains OPI placement information for the images within it, Foxit 
Advanced PDF Editor will use the original filename for images it exports. 

You can check if an image has associated OPI information by selected the image 
with the object tool, then click the right mouse button and choose Image Properties... 

Image Scaling
This set of options allows you to set the output scaling of the images that Foxit 
Advanced PDF Editor extracts from a PDF. 

When disabled, images are output as they are found in the PDF. This may give very 
large images since many PDF documents contain high-resolution versions of an 
image which are then scaled by the PDF viewer to the correct size.

Fix image resolution at:
This option scales output images so that they are all at the same resolution in dpi 
(dots per inch). Resolutions available are: 72, 100, 150, 300, 400, 600, 720, 800 and 
1200 dpi.

This setting is particularly important when rendering vector artwork.

Advanced Scaling Pop-up
Three types of advanced scaling can be selected from the drop down menu. For 
each kind of scaling, if either width or height is set to zero, then an image’s aspect 
ratio is maintained.

•	 Set image size
Enables exact image sizes to be specified in pixels. Images will be sub-sampled or 
expanded accordingly.

•	Maximum size
Enables a maximum image size to be specified. If an image is smaller than the 
width and height values given then the scaling is unchanged. When Max scaling 
occurs, the aspect ratio is maintained. So, for example an image which is 800 
by 400 when output at a Max of 200 by 200 will be rendered as 200 by 100 - the 
shape of the image is maintained.

•	 Scale
Will resize images according to a percentage value.

Continued...
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Colour depth to use when rendering
This pop-up tell Foxit Advanced PDF Editor how to render any marked-up regions 
during export. It also controls how pages are rendered if the Convert each page into 
an image option is enabled in the General tab. It has no effect on the export of non-
rendered images such as photos - these are, in most cases, output with the colour 
depth at which they are stored in the PDF. 

You can determine the colour depth of images stored in a PDF by clicking on an 
image using the object select tool, then choosing Image Properties... from then right-
mouse button menu.

Continued from previous page
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Editing preferences

Unit of measurement
Choose from Inches, Centimetres, 
Millimetres, Points and Picas. This 
setting affects the ruler display and the 
units used in most dialogue boxes when 
a distance or size value is required. 

Show changed text in:
When enabled (checked) Foxit Advanced 
PDF Editor will highlight edited text in 
the chosen colour. This highlighting will 
only be visible when the PDF is viewed or printed from Foxit Advanced PDF Editor 
and will not show in any other PDF viewer.

Insert smart quotes
When enabled, Foxit Advanced PDF Editor will try to convert plain quotation 
marks as typed from the keyboard into “curly quotes”. This may not be possible if 
the font used does not contain either the opening or closing curly quotation mark.

Detect bold / overprint text
Some documents simulate bold text by overprinting text rather than using a bold 
version of a font. Normally Foxit Advanced PDF Editor identifies overprinted 
characters on each page and converts those found into single bold characters. 

This check can be disabled to improve speed on complex pages or if Foxit Advanced 
PDF Editor is incorrectly identifying overprinted characters.

Detect tabs and Leader dots
Prior to editing, Foxit Advanced PDF Editor searches for sequences of dots often 
used as spacers in tabular layouts such as the table of contents in a book. These 
leader-dot sequences are then given special treatment by Foxit Advanced PDF 
Editor and converted into a leader tab. This means that during editing, the leader 
dots will grow/shrink correctly.

Foxit Advanced PDF Editor also searches for large gaps between words and inserts 
equivalent tabstops instead. This too makes it easier to edit tabular data and bullet-
lists.

Occasionally this may adversely effect the layout of a page. In this case, disable the 
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feature.

Detect underlined / strike-through text
Prior to editing, Foxit Advanced PDF Editor searches for all text close to a graphic 
line of similar length. It then removes the line and assumes the text was either 
underlines or strike-through depending upon the position of the line relative to the 
text.

Occasionally this may yield undesirable results and can be disabled for this reason.

Include cropped text when editing
When editing begins, Foxit Advanced PDF Editor normally grabs all text on a 
page and converts it into a form ready for interactive editing. When this option 
is enabled, it will grab all text, even that hidden from view by a page crop. This is 
useful for searching text that would otherwise be missed.

When disabled, you can use a page crop to limit the amount of text on a page 
that Foxit Advanced PDF Editor will ‘see’. This is useful for narrowing the 
effect of a search and replace or for reducing unwanted layout changes at the 
start of editing.

For example, doing a search and replace on a document’s page headers is difficult if 
the page header uses the same font and size text as the rest of the document. How 
do you tell Foxit Advanced PDF Editor to only search in the header and ignore the 
rest of the page contents?

The answer is to disable this feature, place a crop around the header area using the 
Crop tool ,  then do the search and replace operation.  

Foxit Advanced PDF Editor will not only limit the search to text within the crop, 
it will also leave all other text completely unaltered. After the search has finished, 
the crop can be removed by choosing Document->Pages->Remove Crop... to reveal the 
complete page text. 

Diagnostic editing mode
This option is included for diagnostic use only. It stops Foxit Advanced PDF Editor 
from converting the text on a page into an editable form. Objects may still be 
manipulated but no text editing can be performed whilst this option is enabled. 

The option is turned off each time Foxit Advanced PDF Editor is started.
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Loading preferences

Default zoom
This is the zoom level used when a 
document is opened. It does not alter the 
PDF in any way.

Ignore suggested zoom
When enabled, Foxit Advanced PDF 
Editor will ignore any initial-zoom 
suggestion contained within the PDF and 
use the Default Zoom specified above. 

Initial View, Zoom & Page
When you change these values, they get 
stored in your document the next time you save it. Most PDF viewers will try to 
respect the settings you make, and display the document according to your chosen 
values. 
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Saving preferences

Autosave every:
When active, Foxit Advanced PDF Editor 
saves a recovery backup of the current 
PDF every few minutes. A gap of around 
10 minutes is reasonable. You may wish 
to increase the interval or disable auto-
save for large files or when saving over 
slow networks.

If you need to recover changes to a 
document after a crash, open the 
document you were editing. Foxit 
Advanced PDF Editor will detect any 
autosave file that exists and ask you if you want to open that instead.

Make a backup when saving files
When using File->Save... Foxit Advanced PDF Editor can make an backup of the 
original file named “Backup of myfile.pdf”

This can be disabled for large files or when saving over networks.

Store layout info in PDF
When saving an edited PDF Foxit Advanced PDF Editor stores additional 
information such as tab-stop positions, paragraph alignments, indents and margins 
etc. This makes it easier to edit the PDF using Foxit Advanced PDF Editor at a later 
date.

Choose Never if you want to keep the PDF file as small as possible and do not need to 
keep the information.

Choose Always if the increase in file size is less important than ease of editing.

Choose Sometimes to let Foxit Advanced PDF Editor decide. This is the default. 

User name
This is the name that will be stored in the change log (see “Tracking changes” on 
page 137) generated whenever edits are made to a PDF. It is also used to name any 
sticky-notes, stamps or other annotations you place on the document.
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Spelling preferences

Language
This specifies the language to use for 
spell-checking and for hyphenation. 
It is important that this setting always 
matches the language in your PDF 
document. If it does not, the spell-
checker will be ineffective and the reflow 
of your text will not work correctly.

Foxit Advanced PDF Editor ships with 
only UK and USA English language 
spelling dictionaries but does include all 
hyphenation dictionaries. If you choose 
a non-English language Foxit Advanced PDF Editor will ask you if you wish to 
download the installer from Foxit’s website.

Though checked by Foxit, these installers are prepared by third parties and install 
the spelling data required by the ASpell system used by Foxit Advanced PDF Editor.  
If you have access to more up-to-date spelling dictionaries, then these can be used 
instead of the ones hosted on Foxit’s website.

Ignore words in UPPERCASE
Instructs the spell-checker system to skip words consisting of all upper-case letters.

Ignore words with numbers
Instructs the spell-checker system to skip words that contain numbers such as 
“HT4”

Hyphenate words
To better fit text within its text box, Foxit Advanced PDF Editor will hyphenate 
certain words according to language-specific hyphenation rules. This is mainly used 
on fully-justified paragraphs but can also effect normally justified text. Disabling 
this feature will have a document-wide effect. 

To disable hyphenation on a per-paragraph basis, press the right-mouse button 
when editing the paragraph and choose Disable hyphenation.
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Editing non-English text
When editing PDFs written in various different languages please remember the 
following:

•	 hyphenation will only work if the correct language is chosen using the  
File->Preferences... menu option. If the correct language is not available, it may 
be better to disable hyphenation.

•	 spell check requires the correct language to be specified using the  
File->Preferences... menu.

•	 Foxit Advanced PDF Editor only supports editing of text read left-to-right. 
This means editing of Arabic & Hebrew texts is not supported.

Double byte support
Foxit Advanced PDF Editor fully supports copy/paste of double-byte characters.

A double-byte character can be typed directly by holding down Alt while entering 
the decimal value of the character using the numeric keypad (ensure that 
‘NumLock’ is lit on your keyboard). The character will be inserted when you release 
the Alt key.

For example: Alt+0190 = ¾ 
(you do not need to type the ‘+’ character)

The character codes can be found by using the Character Map utility in most versions 
of Microsoft Windows. 

Display of double-byte Characters
When a PDF does not include a required font, Foxit Advanced PDF Editor 
substitutes one of its built-in fonts. These fonts cover the standard Latin character 
sets plus Hiragana, Katakana and a selection of special characters. 

Characters for which no substitute exists will appear as squares in Foxit Advanced 
PDF Editor but may display correctly in other viewers.
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Fonts in PDF
To be truly portable, a PDF must include all the fonts it needs to display correctly. 
These embedded fonts describe the way in which each character is drawn.

Typically there will be some characters in a font that are not used in a PDF. In this 
case, a font-subset may be embedded to help reduce the size of the PDF.

A PDF may also simply name the fonts it needs rather than include them. Provided 
the viewer’s computer has the named fonts installed, the PDF will display correctly. 
If not, the viewer program will try to use a substitute font that is similar in 
appearance.

Certain fonts are always available on every computer that can view PDFs. These are 
Courier, Times, Helvetica and Symbol. Consequently these fonts are not commonly 
embedded.

Font considerations 
Editing text written with a font that is embedded does not normally present any 
problems - all of the font’s characters are available.

When just a subset of a font is embedded, Foxit Advanced PDF Editor will search for 
the required font within your computer’s system fonts and will automatically load 
and use it if found.

If no match can be found, you will have to use a different font instead.

For example, a PDF that contains a single headline written in the font “Marker Felt-
Wide”:

may include character definitions for the following letters only:
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Custom spelling dictionaries
When you press the Add button during spell check, Foxit Advanced PDF Editor 
records the word you are adding in a custom dictionary file on disc. 

If you add a word by mistake you can edit the custom dictionary by hand using any 
standard text editor (such as Notepad).

If you already have a custom dictionary you want Foxit Advanced PDF Editor to use 
you can add its contents to Foxit Advanced PDF Editor’s existing dictionary using a 
text editor.

Locating the custom dictionary
All of the personal word list files (*.pws) for each language are stored in the same 
folder. A *.pws file is only created if you have added words during a spell check,.

On Windows XP, the default installation path would be:  
C:\Documents and Settings\<username>\Application Data\Aspell\personal

On Windows Vista and Windows 7: 
C:\Users\<username>\AppData\Roaming\Aspell\Dictionaries

where <username> should be changed for your username.

Format of custom dictionary
The *.pws dictionary file is a simple list of words, each on a new line. An example is 
shown below:

personal_ws-1.1 es 7  
Adstract 
Technology 
Foxit 
Ltd 
Bushnell 
Norwich 
Guy

The number at the end of the first line is the count of words in the list. The language 
code is prior to that - in this case ‘es’ for Spanish.

Changes to the custom dictionary will take effect the next time Foxit Advanced 
PDF Editor is launched.
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