%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Welcome | Comments on this topic
See Also

Glossary Item Box

Foxit PDF SDK for .NET

This document contains Foxit PDF Rasterizer for .NET SDK

For the complete Class Library Reference click on the link below:

  • Reference Section

Please feel free to contact us with any questions you may have about our products.

Foxit Software
Foxit Corporation
42840 Christy Street, Suite 201
Fremont, CA 94538
USA

http://www.foxitsoftware.com

Sales E-Mail
Support E-Mail

Sales Telephone: 1-866-680-3668 (24/7)
Support & General: 1-866-MYFOXIT or 1-866-693-6948(24/7)
Fax: 510-405-9288

See Also

Foxit PDF Rasterizer for .NET SDK

© Copyright 2013, Foxit Software


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Foxit PDF Rasterizer for .NET SDK | Comments on this topic

Glossary Item Box

Foxit PDF SDK for .NET

Foxit PDF Rasterizer is an easy to use .NET class library for converting PDF documents into different image file formats. Rasterization is the process of taking a vector based format (in our case PDF) and converting it into raster image (pixel-based). Most conversions can be accomplished in only two lines of .NET code and the output files are created very quickly and efficiently. Foxit PDF Rasterizer supports the conversion of PDF files to TIFF (including multipage), PNG, JPEG, GIF, BMP and System.Drawing.Bitmap formats.

Foxit PDF Rasterizer Namespaces

The Foxit PDF Rasterizer for .NET SDK utilizes the below namespaces.

  • Foxit.PDF.Rasterizer

Further Reading

Getting Started
Topics on getting started with Foxit PDF Rasterizer.
Programming with Foxit PDF Rasterizer
Introduces how to program with Foxit PDF Rasterizer.
Foxit PDF Rasterizer Class Library
Detailed reference of the Foxit PDF Rasterizer Class Library.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Getting Started | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Getting Started

Glossary Item Box

In This Section

Product Evaluation
Provides details on evaluating the product.
Features
Details the features available within the product.
Product Limitations
Explains limitations of the product.
Examples
Lists the examples that are included with the product.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Product Evaluation | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Getting Started > Product Evaluation

Glossary Item Box

There is a fully functional evaluation edition of Foxit PDF Rasterizer that can be downloaded from the Foxit Software website, http://www.foxitsoftware.com. This evaluation edition contains all features present in the licensed copy and does not expire or run out. The only limitation of the evaluation edition is that a watermark is displayed on the final rasterized image marking it as having been created using an evaluation copy of the product. Purchasing and correctly applying a license to the assemblies will cause the watermark to no longer be displayed on any newly rasterized documents.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Features | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Getting Started > Features

Glossary Item Box

Below is a list of the main features of our Foxit PDF Rasterizer for .NET SDK. This list was current in May 2013 and is subject to change. Please visit our website for the latest information at www.foxitsoftware.com.

If you have any questions as to the features or functionality of this product we provide a fully functional, never-expiring evaluation edition that can be downloaded from our website. If there are still additional questions as to the abilities of the component feel free to contact our support team at support@foxitsoftware.com.

  • Rasterized output files include: JPEG, PNG, TIFF (including multi page TIFF), GIF and BMP
  • Output to System.Drawing.Bitmap object
  • Supports Image Transparency (TIFF and PNG)
  • Full support for rendering PDF documents v1.1 - v1.7
  • Full support for all PDF color-spaces
  • Supports all PDF compression types
  • Supports all PDF font types
  • Supports RGB, RGBA, Monochrome, Gray-scale and Indexed color-formats
  • Supports Quantization and Dithering in Indexed color-format
  • Supports custom or user color palettes
  • Supports Form Field rasterization
  • Supports Annotation rasterization


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Product Limitations | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Getting Started > Product Limitations

Glossary Item Box

External Images - Foxit PDF Rasterizer does not support rendering the images that are not embedded directly in the PDF. An example of this would be an image path is embedded within the PDF document instead of the image itself.

XFA Forms - Depending on the features being utilized within the XFA fields certain XFA forms are not supported in Foxit PDF Rasterizer.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Examples | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Getting Started > Examples

Glossary Item Box

The following examples are included with Foxit PDF Rasterizer for .NET SDK. If the examples are chosen to be installed during the installation process (by default they are) then a link to the examples folder is added on the start menu.

6 Console Examples and 3 Web Examples
There are 6 console and 3 web examples included with the class library. They are available for Visual Basic .NET and C# and are included in Visual Studio .NET 2005, Visual Studio .NET 2008, Visual Studio .NET 2010 and Visual Studio .NET 2012 versions. The examples are as follows:
Console Examples
  • Indexed Image - Demonstrates rasterizing a PDF to an Indexed image.
  • Jpeg Image - Demonstrates rasterizing a PDF to a JPEG image.
  • Monochrome Image - Demonstrates rasterizing a PDF to a Monochrome color image.
  • Multi Page Tiff Image - Demonstrates rasterizing a PDF to a multi page TIFF image.
  • Rgba Image - Demonstrates rasterizing a PDF to a RGBA color image.
  • Tiff Image - Demonstrates rasterizing a PDF into a TIFF image.
Web Examples
  • Gif Image With Web Palette - Demonstrates rasterizing a PDF to a GIF image with web color palette.
  • Png Image With Rgb Color - Demonstrates rasterizing a PDF to PNG Image with RGB color.
  • Png Image With User Palette - Demonstrates rasterizing a PDF to a PNG image with user specified color palette.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Programming with Foxit PDF Rasterizer | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer

Glossary Item Box

In This Section

Overview
An overview of programming with Foxit PDF Rasterizer for .NET SDK.
Referencing The Assembly
Explains how to reference the assembly.
Deployment
Explains how to deploy your application.
Output File Names
Explains the different options for naming the output image files.
Output Image Format
Explains the different options for defining the type of output image.
Output Image Size
Explains the different options for defining the size of the output images.
Image Transparency
Explains how to achieve transparency in the output images.
Color Quantization and Color Palettes
Explains about color quantization and different types of color palette and quantization algorithm available with Rasterizer and provides a guideline for using those options.
Dithering
Explains about dithering and different types of dithering algorithm available with Rasterizer and provides a guideline for using those options.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit software
Overview | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Overview

Glossary Item Box

Foxit PDF Rasterizer always creates a rasterized image (JPEG, BMP, PNG, GIF, TIFF) out of a PDF document.

The object model for Foxit PDF Rasterizer is very straight forward. The flow of most applications written against the Rasterizer dll will be as follows:

  • Specify the PDF Input File: Create a PdfRasterizer class object and Specify PDF Input file path in the constructor.
  • Define the Output Image Format and Output Image Size: Defining an ImageFormat object specifies the image type (JPEG, BMP, PNG, GIF, TIFF) while defining an ImageSize object will specify the output image size.
  • Specify the Output File Name and Location: Finally, specify the file name and location of the output file.

See Also

Output Image Format
Output Image Size
Output File Names


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit software
Referencing The Assembly | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Referencing The Assembly

Glossary Item Box

There are six .NET assemblies included that are compiled for use with the .NET Framework 2.0, 3.0, 3.5 and 4.0/4.5. The table below gives the details of each assembly.

Assembly Name | Framework Version | Platform
Foxit.PDF.Rasterizer.20.x86.dll | 2.0 and 3.0 | x86
Foxit.PDF.Rasterizer.20.x64.dll | 2.0 and 3.0 | x64
Foxit.PDF.Rasterizer.35.x86.dll | 3.5 | x86
Foxit.PDF.Rasterizer.35.x64.dll | 3.5 | x64
Foxit.PDF.Rasterizer.40.x86.dll | 4.0 and 4.5 | x86
Foxit.PDF.Rasterizer.40.x64.dll | 4.0 and 4.5 | x64

Referencing the Assembly in Visual Studio, 32-bit (x86) Version

To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x86 (Framework 2.0 and 3.0)" from the list on the ".NET" tab. Hit OK to complete this.

To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x86 (Framework 3.5)" from the list on the ".NET" tab. Hit OK to complete this.

To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x86 (Framework 4.0 and 4.5)" from the list on the ".NET" tab. Hit OK to complete this.

Referencing the Assembly in Visual Studio, 64-bit (x64) Version

To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project's and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x64 (Framework 2.0 and 3.0)" from the list on the ".NET" tab. Hit OK to complete this.

To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x64 (Framework 3.5)" from the list on the ".NET" tab. Hit OK to complete this.

To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Rasterizer for .NET SDK x64 (Framework 4.0 and 4.5)" from the list on the ".NET" tab. Hit OK to complete this.

NOTE: Make sure you have not placed more than one of the above assemblies in your applications bin folder. Placing more than one of them in your bin folder can cause errors and unpredictable results. The accompanying xml files are for intelli-sense and do not need to be distributed with your product.

See Also

Programming with Foxit PDF Rasterizer


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Deployment | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Deployment

Glossary Item Box

To deploy your application using XCOPY, it is prerequisite to have Microsoft Visual C++ 2008 Redistributable Package for .NET 2.0/3.0/3.5 application and Microsoft Visual C++ 2010 Redistributable Package for.NET 4.0/4.5 application.

To deploy the application using your own setup program, it is required to include the following redistributables (Merge modules) which need to be installed along with the application.

For .NET 2.0/3.0/3.5 applications
  1. Visual C++ 9.0 CRT (x86) WinSXS MSM
  2. Visual C++ 9.0 CRT (x64) WinSXS MSM
For .NET 4.0/4.5 applications
  1. Visual C++ 10.0 CRT (x86) WinSXS MSM
  2. Visual C++ 10.0 CRT (x64) WinSXS MSM
Licensing
In additional to deploying the dll files with your application, a license key must be added to remove the watermark. A license key can either be added to a .config file or it can be added as a line of code in the application. License keys can be retrieved from the Customer Area of our website, http://www.foxitsoftware.com/CustomerArea, after the purchase of an appropriate serial number.

See Also

Programming with Foxit PDF Rasterizer
Referencing The Assembly


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Output File Names | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Output File Names

Glossary Item Box

Default Output File Names

When using the PdfRasterizer's Draw method to convert the PDF document to an image file, there will be one image file created for each page specified in the PDF. These output files will be based on the name specified in the first parameter of the Draw method but will have a one based digit appended to the portion of the string before the extension. The code below demonstrates a typical conversion:

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
MyRasterizer.Draw("C:\DocumentA_Page.png", ImageFormat.Png, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
rasterizer.Draw("C:\\DocumentA_Page.png", ImageFormat.Png, ImageSize.Dpi72);

So if the PDF (DocumentA.pdf) contained 3 pages then after the execution of the Draw method the newly created files would be "DocumentA_Page1.png", "DocumentA_Page2.png" and "DocumentA_Page3.png".

Manual Control of Output File Names

If you would like more control of the files names for the output images this can be achieved by looping over the collection of Pages in your PdfRasterizer object and calling the Draw method individually for each page. Since calling the Draw method on individual pages of the PDF document only outputs one image file at a time you can then name each page individually and uniquely.

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
Dim i As Integer
For i = 0 To MyRasterizer.Pages.Count - 1
        MyRasterizer.Pages(i).Draw("C:\Page" & i & "_DocumentA.png", ImageFormat.Png,   ImageSize.Dpi72)
Next

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
for(int i = 0; i < rasterizer.Pages.Count; i++)
{
        rasterizer.Pages[i].Draw("C:\\Page" + i +"_DocumentA.png", ImageFormat.Png, ImageSize.Dpi72);
}

See Also

PdfRasterizer Class
ImageFormat Class


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Output Image Format | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Output Image Format

Glossary Item Box

ImageFormat class allows you to define the type of image created by Rasterizer. Several static ImageFormats are defined for quick use. These static members simplify your code significantly when image output types do not need a lot of customization. These static ImageFormats are as follows:

  • ImageFormat.Bmp
  • ImageFormat.Gif
  • ImageFormat.Jpeg
  • ImageFormat.Png
  • ImageFormat.TiffWithCcitGroup3
  • ImageFormat.TiffWithCcitGroup4
  • ImageFormat.TiffWithLzw

The below example illustrates the syntax that would be needed to rasterize a PDF document into a PNG image using a static PNG ImageFormat.

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
MyRasterizer.Draw("C:\Document_Page.png", ImageFormat.Png, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
rasterizer.Draw("C:\\DocumentA_Page.png", ImageFormat.Png, ImageSize.Dpi72);

Alternatively you can just instantiate the ImageFormat type that you need to use and set up it's properties directly. In this case you need to instantiate one of the following objects to pass into the PdfRasterizer's Draw method:

  • Foxit.PDF.Rasterizer.BmpImageFormat
  • Foxit.PDF.Rasterizer.GifImageFormat
  • Foxit.PDF.Rasterizer.JpegImageFormat
  • Foxit.PDF.Rasterizer.PngImageFormat
  • Foxit.PDF.Rasterizer.TiffImageFormat

The below example illustrates the syntax that would be needed to rasterize a PDF document into a PNG with transparency.

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf”)
Dim MyPng As PngImageFormat = New PngImageFormat(PngColorFormat.RgbA)
MyRasterizer.Draw("C:\Document_Transparent_Page.png", MyPng, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
PngImageFormat png = new PngImageFormat(PngColorFormat.RgbA);
rasterizer.Draw("C:\\DocumentA_Transparent_Page.png", png, ImageSize.Dpi72);

See Also

ImageFormat Class


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Output Image Size | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Output Image Size

Glossary Item Box

ImageSize specifies the height, width, horizontal resolution and vertical resolution of the generated image. Several static ImageSizes are defined for quick use. These static ImageSizes and their defined values are as follows:

  • Foxit.PDF.Rasterizer.ImageSize.Dpi150
    • Horizontal DPI(Dots Per Inch): 150
    • Vertical DPI: 150
  • Foxit.PDF.Rasterizer.ImageSize.Dpi300
    • Horizontal DPI: 300
    • Vertical DPI: 300
  • Foxit.PDF.Rasterizer.ImageSize.Dpi600
    • Horizontal DPI: 600
    • Vertical DPI: 600
  • Foxit.PDF.Rasterizer.ImageSize.Dpi72
    • Horizontal DPI: 72
    • Vertical DPI: 72
  • Foxit.PDF.Rasterizer.ImageSize.Dpi96
    • Horizontal DPI: 96
    • Vertical DPI: 96
  • Foxit.PDF.Rasterizer.ImageSize.FaxStandard
    • Horizontal DPI: 204
    • Vertical DPI: 98
  • Foxit.PDF.Rasterizer.ImageSize.FaxFine
    • Horizontal DPI: 204
    • Vertical DPI: 196
  • Foxit.PDF.Rasterizer.ImageSize.FaxSuperfine
    • Horizontal DPI: 200
    • Vertical DPI: 400

The below example illustrates the syntax that would be needed to rasterize a PDF document into a JPEG image using a static ImageSize.

[Visual Basic]
 Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
 MyRasterizer.Draw("C:\DocumentA_Page.jpg", ImageFormat.Jpeg, ImageSize.Dpi150)

[C#]
 PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
 rasterizer.Draw("C:\\DocumentA_Page.jpg", ImageFormat.Jpeg, ImageSize.Dpi150);

Alternatively to using one of the above static image sizes you can just instantiate any object that inherits from the ImageSize object and use that as one of the arguments to pass into the PdfRasterizer's Draw method. These ImageSize objects and there uses are as follows:

  • Foxit.PDF.Rasterizer.DpiImageSize - Allows any horizontal and vertical DPI(Dots Per Inch) to be defined for the output image.
  • Foxit.PDF.Rasterizer.FixedImageSize - Allows any height and width to be defined for the output image.
  • Foxit.PDF.Rasterizer.MaxImageSize - Allows any height and width to be defined for the output image but MaxImageSize will only output the final image as big as you have defined while still maintaining the original document proportions.
  • Foxit.PDF.Rasterizer.PercentageImageSize - Allows any horizontal or vertical percentage (of the original document) to be defined for the output image.

The below example illustrates the syntax that would be needed to rasterize a PDF document into a JPEG that is exactly 200 points in height and 200 points in width.

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
Dim MyJpegSize As FixedImageSize = New FixedImageSize(200, 200)
MyRasterizer.Draw("C:\DocumentA_Fixed200_Page.jpg", ImageFormat.Jpeg, MyJpegSize)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
FixedImageSize jpegSize = new FixedImageSize(200, 200);
rasterizer.Draw("C:\\DocumentA_Fixed200_Page.jpg", ImageFormat.Jpeg, jpegSize);

See Also

ImageSize Class


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Image Transparency | Comments on this topic
See Also
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Image Transparency

Glossary Item Box

Currently, both the PNG and TIFF image formats can be output with transparency. To accomplish this, the appropriate ImageFormat needs to be defined with a ColorFormat of type RGBA. This will produce a rasterized image that contains the transparency.

Transparent PNG Example

[Visual Basic]
 Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
 Dim MyPng As PngImageFormat = New PngImageFormat(PngColorFormat.RgbA)
 MyRasterizer.Draw("C:\Document_Transparent_Page.png", MyPng, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
PngImageFormat png = new PngImageFormat(PngColorFormat.RgbA);
rasterizer.Draw("C:\\DocumentA_Transparent_Page.png", png, ImageSize.Dpi72);

Transparent TIFF Example

[Visual Basic]
Dim MyRasterizer As PdfRasterizer = New PdfRasterizer("C:\DocumentA.pdf")
Dim MyTiff As TiffImageFormat = New TiffImageFormat(TiffColorFormat.RgbA)
MyRasterizer.Draw("C:\DocumentA_Transparent_Page.tif", MyTiff, ImageSize.Dpi150)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
TiffImageFormat tiff = new TiffImageFormat(TiffColorFormat.RgbA);
rasterizer.Draw("C:\\DocumentA_Transparent_Page.tif", tiff, ImageSize.Dpi150);

See Also

ImageFormat Class


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Color Quantization and Color Palettes | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Color Quantization and Color Palettes

Glossary Item Box

Color Quantization

Color Quantization is a process that reduces the number of distinct colors used in an image (based on a specified or automatically-found color palette), without much affect on the quality of the image. A quantized image has fewer colors and smaller file size compared to the original one, while keeping the visual essence of the original true-colored image intact. Color quantization is a lossy process. Dithering can also be applied to quantized images to improve the quality of the final image.

Color Palettes

When creating an indexed image using Foxit PDF Rasterizer, the number of distinct colors is reduced to 256 or less. This can be done by using one of the predefined color palette (Web or Windows Palette), a custom palette (User Palette) or by using an algorithm to automatically determine the palette (Auto Palette). These four types of palette; Web palette, Windows palette, Auto palette and User palette are outlined below:

Web Palette
Web palette contains only 216 web safe colors .This palette can be used to create images used in web pages. These 216 colors, are recognized by all web browsers and operating systems, which means these colors will look about the same within any browser.
Windows Palette
Windows palette contains 216 web safe colors and 20 windows specific colors .This palette is suitable for creating ordinary images.
User Palette
User palette or custom palette gives complete freedom to users to select the colors and the number of colors present in the image. Output image only contains user specified colors.
Auto Palette
Auto Palette is the default color palette Foxit PDF Rasterizer uses this for creation of indexed images. Auto Palette will use a quantization algorithm to automatically determine the best color palette to use based on existing image specific colors. The auto palette can use either the Octree or Medium Cut algorithms in determining the color palette and has an option to specify the number of colors to be used in the output image. The quality of the output image is better when using auto palette as compared to using other palettes. By default, the Auto Palette uses the Octree quantization algorithm and a maximum palette size of 256.

The below example illustrates rasterizing a PDF document into an indexed PNG image using the Windows Color Palette:

[Visual Basic]
Dim rasterizer As New PdfRasterizer("C:\DocumentA.pdf")
Dim pngIndexedColorFormat As New PngIndexedColorFormat(Palette.WindowsPalette)
Dim pngIndexed As New PngImageFormat(pngIndexedColorFormat)
rasterizer.Draw("C:\DocumentA_WindowsPalette_Page.png", pngIndexed, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(Palette.WindowsPalette);
PngImageFormat pngIndexed = new PngImageFormat(pngIndexedColorFormat);
rasterizer.Draw("C:\\DocumentA_WindowsPalette_Page.png", pngIndexed, ImageSize.Dpi72);


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dithering | Comments on this topic
Foxit PDF Rasterizer for .NET SDK > Programming with Foxit PDF Rasterizer > Dithering

Glossary Item Box

Dithering

Dithering is a technique used in computer graphics to reduce the visual side effects of color quantization. A quantized image may contain flat areas and patches of color that may significantly affect the quality of the quantized image. Dithering creates an illusion of more color and more detail by a certain kind of mixing of available colors. Factors such as quality of the original image, dithering algorithm, dithering percentage and color palette can affect the resulting quality of the dithered image.

Guidelines for selecting Dithering Algorithms

Foxit PDF Rasterizer supports two dithering algorithms, Floyd-Steinberg algorithm and Bayer algorithm.

Floyd-Steinberg algorithm
Floyd-Steinberg is a high-quality, error-diffusion method. It is the default dithering algorithm Foxit PDF Rasterizer uses during the creation of indexed images. This method can be used for creating both monochrome images and color images. Floyd-Steinberg algorithm gives good-quality images compared to Bayer algorithm, but is slower than Bayer algorithm.
Bayer algorithm
Bayer algorithm is an Ordered dithering algorithm. Bayer algorithm can be used for creating both monochrome images and color images. Bayer algorithm is faster than Floyd-Steinberg algorithm, but image quality may be lower.

Guidelines for selecting Dithering Percentage

Foxit PDF Rasterizer allows the Dithering percentage to be set (from 0 to 100) which specifies the percentage of pixels that will undergo dithering.

Zero percentage dithering means no pixels are dithered and the resulting image may contain bands and patches. A higher dithering percentage creates an illusion of more color and more detail, but increases the file size. Low dithering percentages can be applied if file size is more important than the quality of the image. Images with primarily solid colors (Example: A PDF e-book’s pages converted to image) may work well with low dithering percentage. Images with gradients and more number of colors (ordinary images) may require high dithering percentages to prevent color banding. A high dithering percentage slightly affects performance also.

The below example illustrates rasterizing a PDF document into an indexed PNG using the Floyd-Steinberg dithering algorithm at a dithering percentage of 100:

[Visual Basic]
Dim rasterizer As New PdfRasterizer("C:\DocumentA.pdf")
Dim autoPalette As New AutoPalette(QuantizationAlgorithm.Octree, 256)
Dim pngIndexedColorFormat As New PngIndexedColorFormat(autoPalette, 100, DitheringAlgorithm.FloydSteinberg)
Dim png As New PngImageFormat(pngIndexedColorFormat)
rasterizer.Draw("C:\DocumentA_Dithered_Page.png", png, ImageSize.Dpi72)

[C#]
PdfRasterizer rasterizer = new PdfRasterizer("C:\\DocumentA.pdf");
AutoPalette autoPalette = new AutoPalette(QuantizationAlgorithm.Octree, 256);
PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(autoPalette, 100, DitheringAlgorithm.FloydSteinberg);
PngImageFormat png = new PngImageFormat(pngIndexedColorFormat);
rasterizer.Draw("C:\\DocumentA_Dithered_Page.png", png, ImageSize.Dpi72);


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Class Library Reference | Comments on this topic

Glossary Item Box

Foxit PDF SDK for .NET

This topic contains reference to Foxit PDF Rasterizer for .NET SDK.


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Foxit.PDF.Rasterizer Namespace | Comments on this topic
See Also Inheritance Hierarchy
Foxit.PDF.Rasterizer Assembly : Foxit.PDF.Rasterizer Namespace

Classes

 | Class | Description
Class | AutoPalette | Represents an AutoPalette class which can be used to create an image specific palette.
Class | BmpColorFormat | Base class that represents an color format supported by BMP image format. BmpColorFormat's derived classes are: BmpRgbColorFormat, BmpMonochromeColorFormat
Class | BmpImageFormat | Represents a BMP image format.
Class | BmpMonochromeColorFormat | Represents a monochrome color format supported by BMP.
Class | BmpRgbColorFormat | Represents a RGB color format supported by BMP image.
Class | DocumentLoadException | Represents a DocumentLoadException
Class | DpiImageSize | Represents a DPI image size.
Class | FixedImageSize | Represents a fixed image size.
Class | GifImageFormat | Represents a GIF image format.
Class | ImageFormat | Base class that represents an image format. ImageFormat's derived classes are: BmpImageFormat, GifImageFormat, JpegImageFormat, PngImageFormat and TiffImageFormat. See the Output Image Format topic for more on Image Formats.
Class | ImageSize | Base class which represents an image size. ImageSize's derived classes are: DpiImageSize, FixedImageSize, MaxImageSize and PercentageImageSize. See the Output Image Size topic for more on Image Sizes.
Class | InputPdf | Represents an input PDF.
Class | InputPdfPage | Represents a page in an input PDF.
Class | InputPdfPageList | Represents a list of input PDF pages.
Class | InvalidPasswordException | Represents a InvalidPasswordException
Class | JpegImageFormat | Represents a JPEG image format.
Class | LicensingException | Represents a licensing exception.
Class | MaxImageSize | Represents a maximum image size.
Class | Palette | Base class that represents a palette. Palette's derived classes are: AutoPalette, UserPalette, WebPalette, WindowsPalette.
Class | PdfRasterizer | Represents a PDF rasterizer.
Class | PdfRasterizerException | Represents a PdfRasterizerException
Class | PdfRasterizerPage | Represents a page of the PDF rasterizer.
Class | PdfRasterizerPageList | Represents a list of pages to rasterize.
Class | PercentageImageSize | Represents a percentage image size.
Class | PngColorFormat | Base class that represents an color format supported by PNG image format. PngColorFormat's derived classes are: PngGrayscaleColorFormat, PngMonochromeColorFormat, PngRgbColorFormat, PngRgbAColorFormat and PngIndexedColorFormat.
Class | PngGrayscaleColorFormat | Represents a grayscale color format supported by PNG.
Class | PngImageFormat | Represents a PNG image format.
Class | PngIndexedColorFormat | Represents a indexed color format supported by PNG.
Class | PngMonochromeColorFormat | Represents a monochrome color format supported by PNG.
Class | PngRgbAColorFormat | Represents a RGBA color format supported by PNG.
Class | PngRgbColorFormat | Represents a RGB color format supported by PNG.
Class | TiffColorFormat | Base class that represents an color format supported by TIFF image format. TiffColorFormat's derived classes are: TiffGrayscaleColorFormat, TiffMonochromeColorFormat, TiffRgbColorFormat, TiffRgbAColorFormat and TiffIndexedColorFormat.
Class | TiffGrayscaleColorFormat | Represents a grayscale color format supported by TIFF.
Class | TiffImageFormat | Represents a TIFF image format
Class | TiffIndexedColorFormat | Represents a indexed color format supported by TIFF.
Class | TiffMonochromeColorFormat | Represents a monochrome color format supported by TIFF.
Class | TiffRgbAColorFormat | Represents a RGBA color format supported by TIFF.
Class | TiffRgbColorFormat | Represents a RGB color format supported by TIFF.
Class | UnitConverter | Utility for converting to and from typesetting points.
Class | UserPalette | Represents a UserPalette class which can be used to specify a color palette.
Class | WebPalette | Represents a Web palette.
Class | WindowsPalette | Represents a Windows palette.

Enumerations

 | Enumeration | Description
Enumeration | BitmapColorFormat | Represents Bitmap color formats.
Enumeration | DitheringAlgorithm | Represents different dithering algorithms.
Enumeration | QuantizationAlgorithm | Represents different kind of quantization methods.
Enumeration | TiffMonochromeCompressionType | Represents compression formats supported by TIFF monochrome format.
Enumeration | UnitType | Represents a UnitType value.

See Also

Reference

Foxit.PDF.Rasterizer Assembly


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : AutoPalette Class

Represents an AutoPalette class which can be used to create an image specific palette.

Object Model

AutoPalette Class

Syntax

Visual Basic (Declaration)
Public Class AutoPalette
   Inherits Palette
C#
public class AutoPalette : Palette

Example

This example demonstrates how to rasterize a pdf document to PNG image with an image specific palette.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a pngIndexedColorFormat object.
        Dim pngIndexedColorFormat As PngIndexedColorFormat  = New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100)

        ' Set the ColorPalette property to  AutoPalette.
        pngIndexedColorFormat.ColorPalette = New AutoPalette(QuantizationAlgorithm.Octree, 256)

        ' Create a pngImageFormat using pngIndexedColorFormat object.
        Dim pngImageFormat As PngImageFormat  = New PngImageFormat(pngIndexedColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a pngIndexedColorFormat object.
        PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100);

        // Set the ColorPalette property to  AutoPalette.
        pngIndexedColorFormat.ColorPalette = new AutoPalette(QuantizationAlgorithm.Octree, 256);

        // Create a pngImageFormat using pngIndexedColorFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(pngIndexedColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.AutoPalette

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : AutoPalette Class

The following tables list the members exposed by AutoPalette.

Public Constructors

 | Name | Description
Public Constructor | AutoPalette Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | MaxPaletteSize | Gets or sets maximum size of the palette.
Public Property | QuantizationAlgorithm | Gets or sets palette selection.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

AutoPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class : AutoPalette Constructor

Overload List

Overload | Description
AutoPalette Constructor(QuantizationAlgorithm,Int32) | Initializes a new instance of the AutoPalette class.
AutoPalette Constructor(QuantizationAlgorithm) | Initializes a new instance of the AutoPalette class.
AutoPalette Constructor() | Initializes a new instance of the AutoPalette class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Constructor(QuantizationAlgorithm,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class > AutoPalette Constructor : AutoPalette Constructor(QuantizationAlgorithm,Int32)

quantizationAlgorithm
Variable of type QuantizationAlgorithm which can be used to specify quantization algorithm.
maxPaletteSize
Maximum size of palette.
Initializes a new instance of the AutoPalette class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal quantizationAlgorithm As QuantizationAlgorithm, _
   ByVal maxPaletteSize As Integer _
)
C#
public AutoPalette(
   QuantizationAlgorithm quantizationAlgorithm,
   int maxPaletteSize
)

Parameters

quantizationAlgorithm
Variable of type QuantizationAlgorithm which can be used to specify quantization algorithm.
maxPaletteSize
Maximum size of palette.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Constructor(QuantizationAlgorithm) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class > AutoPalette Constructor : AutoPalette Constructor(QuantizationAlgorithm)

quantizationAlgorithm
Variable of type QuantizationAlgorithm which can be used to specify quantization algorithm.
Initializes a new instance of the AutoPalette class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal quantizationAlgorithm As QuantizationAlgorithm _
)
C#
public AutoPalette(
   QuantizationAlgorithm quantizationAlgorithm
)

Parameters

quantizationAlgorithm
Variable of type QuantizationAlgorithm which can be used to specify quantization algorithm.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Constructor() | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class > AutoPalette Constructor : AutoPalette Constructor()

Initializes a new instance of the AutoPalette class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AutoPalette()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : AutoPalette Class

For a list of all members of this type, see AutoPalette members.

Public Properties

 | Name | Description
Public Property | MaxPaletteSize | Gets or sets maximum size of the palette.
Public Property | QuantizationAlgorithm | Gets or sets palette selection.
Top

See Also

Reference

AutoPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxPaletteSize Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class : MaxPaletteSize Property

Gets or sets maximum size of the palette.

Syntax

Visual Basic (Declaration)
Public Property MaxPaletteSize As Integer
C#
public int MaxPaletteSize {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
QuantizationAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > AutoPalette Class : QuantizationAlgorithm Property

Gets or sets palette selection.

Syntax

Visual Basic (Declaration)
Public Property QuantizationAlgorithm As QuantizationAlgorithm
C#
public QuantizationAlgorithm QuantizationAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPalette Class
AutoPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpColorFormat Class

Base class that represents an color format supported by BMP image format. BmpColorFormat's derived classes are: BmpRgbColorFormat, BmpMonochromeColorFormat

Object Model

BmpColorFormat ClassBmpMonochromeColorFormat ClassBmpRgbColorFormat Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class BmpColorFormat
C#
public abstract class BmpColorFormat

Remarks

BmpColorFormat's derived classes are: BmpRgbColorFormat, BmpMonochromeColorFormat

Example

This example demonstrates how to rasterize a pdf document to a Bmp image using BmpColorFormat.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()
        'Create a PdfRasterizer object.
        Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

        'Create a BmpColorFormat object.
        Dim bmpColorFormat As BmpColorFormat = bmpColorFormat.Rgb

        'Create a BmpImageFormat object using BmpColorFormat object.
        Dim bmpImageFormat As New BmpImageFormat(bmpColorFormat)

        'Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72)
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        //Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        //Create a BmpColorFormat object.
        BmpColorFormat bmpColorFormat = BmpColorFormat.Rgb;

        //Create a BmpImageFormat object using BmpColorFormat object.
        BmpImageFormat bmpImageFormat = new BmpImageFormat(bmpColorFormat);

        // Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72);
    }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.BmpColorFormat
Foxit.PDF.Rasterizer.BmpMonochromeColorFormat
Foxit.PDF.Rasterizer.BmpRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpColorFormat Class

The following tables list the members exposed by BmpColorFormat.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Monochrome | Gets a default BmpMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default BmpRgbColorFormat class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpColorFormat Class

For a list of all members of this type, see BmpColorFormat members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Monochrome | Gets a default BmpMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default BmpRgbColorFormat class.
Top

See Also

Reference

BmpColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Monochrome Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpColorFormat Class : Monochrome Property

Gets a default BmpMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Monochrome As BmpMonochromeColorFormat
C#
public static BmpMonochromeColorFormat Monochrome {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpColorFormat Class
BmpColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Rgb Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpColorFormat Class : Rgb Property

Gets a default BmpRgbColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Rgb As BmpRgbColorFormat
C#
public static BmpRgbColorFormat Rgb {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpColorFormat Class
BmpColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpImageFormat Class

Represents a BMP image format.

Object Model

BmpImageFormat ClassBmpColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class BmpImageFormat
   Inherits ImageFormat
C#
public class BmpImageFormat : ImageFormat

Example

This example demonstrates how to rasterize a PDF document to BMP image.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

         ' Create a BmpImageFormat object.
        Dim bmpImageFormat As BmpImageFormat = New BmpImageFormat(BmpColorFormat.Rgb)

        ' Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a BmpImageFormat object.
        BmpImageFormat bmpImageFormat = new BmpImageFormat(BmpColorFormat.Rgb);

        // Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.BmpImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpImageFormat Class

The following tables list the members exposed by BmpImageFormat.

Public Constructors

 | Name | Description
Public Constructor | BmpImageFormat Constructor | Initializes a new instance of the BmpImageFormat class.
Top

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the BMP color format.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpImageFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpImageFormat Class : BmpImageFormat Constructor

colorFormat
Color format of the BMP image.
Initializes a new instance of the BmpImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorFormat As BmpColorFormat _
)
C#
public BmpImageFormat(
   BmpColorFormat colorFormat
)

Parameters

colorFormat
Color format of the BMP image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpImageFormat Class
BmpImageFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpImageFormat Class

For a list of all members of this type, see BmpImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the BMP color format.
Top

See Also

Reference

BmpImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorFormat Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpImageFormat Class : ColorFormat Property

Gets or sets the BMP color format.

Syntax

Visual Basic (Declaration)
Public Property ColorFormat As BmpColorFormat
C#
public BmpColorFormat ColorFormat {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpImageFormat Class
BmpImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpMonochromeColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpMonochromeColorFormat Class

Represents a monochrome color format supported by BMP.

Object Model

BmpMonochromeColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class BmpMonochromeColorFormat
   Inherits BmpColorFormat
C#
public class BmpMonochromeColorFormat : BmpColorFormat

Example

This example demonstrates how to rasterize a PDF document to BMP monochrome images.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a BmpRgbColorFormat object.
        Dim bmpColorFormat As BmpMonochromeColorFormat  = New BmpMonochromeColorFormat(DitheringAlgorithm.FloydSteinberg, 90)

         ' Create a BmpImageFormat object.
        Dim bmpImageFormat As BmpImageFormat = New BmpImageFormat(bmpColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a BmpRgbColorFormat object.
        BmpMonochromeColorFormat bmpColorFormat = new BmpMonochromeColorFormat(DitheringAlgorithm.FloydSteinberg, 90);

        // Create a BmpImageFormat object.
        BmpImageFormat bmpImageFormat = new BmpImageFormat(bmpColorFormat);

        // Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.BmpColorFormat
Foxit.PDF.Rasterizer.BmpMonochromeColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpMonochromeColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpMonochromeColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpMonochromeColorFormat Class

The following tables list the members exposed by BmpMonochromeColorFormat.

Public Constructors

 | Name | Description
Public Constructor | BmpMonochromeColorFormat Constructor | Initializes a new instance of the BmpMonochromeColorFormat class.
Top

Public Properties

 | Name | Description
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpMonochromeColorFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpMonochromeColorFormat Class : BmpMonochromeColorFormat Constructor

ditheringAlgorithm
Specify a dithering algorithm.
ditheringPercent
Specify value of dithering in percentage.
Initializes a new instance of the BmpMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ditheringAlgorithm As DitheringAlgorithm, _
   ByVal ditheringPercent As Integer _
)
C#
public BmpMonochromeColorFormat(
   DitheringAlgorithm ditheringAlgorithm,
   int ditheringPercent
)

Parameters

ditheringAlgorithm
Specify a dithering algorithm.
ditheringPercent
Specify value of dithering in percentage.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpMonochromeColorFormat Class
BmpMonochromeColorFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpMonochromeColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpMonochromeColorFormat Class

For a list of all members of this type, see BmpMonochromeColorFormat members.

Public Properties

 | Name | Description
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

See Also

Reference

BmpMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpMonochromeColorFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpMonochromeColorFormat Class
BmpMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > BmpMonochromeColorFormat Class : DitheringPercent Property

Gets or sets the value of dithering in percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpMonochromeColorFormat Class
BmpMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpRgbColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpRgbColorFormat Class

Represents a RGB color format supported by BMP image.

Object Model

BmpRgbColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class BmpRgbColorFormat
   Inherits BmpColorFormat
C#
public class BmpRgbColorFormat : BmpColorFormat

Example

This example demonstrates how to rasterize a PDF document to BMP RGB images.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

         ' Create a BmpImageFormat object.
        Dim bmpImageFormat As BmpImageFormat = New BmpImageFormat(BmpColorFormat.Rgb)

        ' Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a BmpImageFormat object.
        BmpImageFormat bmpImageFormat = new BmpImageFormat(BmpColorFormat.Rgb);

        // Save the image.
        rasterizer.Draw("Output.bmp", bmpImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.BmpColorFormat
Foxit.PDF.Rasterizer.BmpRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BmpRgbColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpRgbColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpRgbColorFormat Class

The following tables list the members exposed by BmpRgbColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DocumentLoadException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DocumentLoadException Class

Represents a DocumentLoadException

Object Model

DocumentLoadException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DocumentLoadException
   Inherits PdfRasterizerException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class DocumentLoadException : PdfRasterizerException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Rasterizer.PdfRasterizerException
Foxit.PDF.Rasterizer.DocumentLoadException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentLoadException Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DocumentLoadException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DocumentLoadException Class

The following tables list the members exposed by DocumentLoadException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DpiImageSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DpiImageSize Class

Represents a DPI image size.

Object Model

DpiImageSize Class

Syntax

Visual Basic (Declaration)
Public Class DpiImageSize
   Inherits ImageSize
C#
public class DpiImageSize : ImageSize

Example

This example demonstrates how to rasterize a pdf document to a specific DPI.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat(PngColorFormat.Rgb)

        ' Create a ImageSize object.
        Dim ImageSize As DpiImageSize = New DpiImageSize(72.0F, 72.0F)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(PngColorFormat.Rgb);

        // Create a ImageSize object.
        DpiImageSize imagesize = new DpiImageSize(72.0f, 72.0f);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, imagesize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.DpiImageSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DpiImageSize Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DpiImageSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DpiImageSize Class

The following tables list the members exposed by DpiImageSize.

Public Constructors

 | Name | Description
Public Constructor | DpiImageSize Constructor | Initializes a new instance of the DpiImageSize class.
Top

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets the horizontal resolution of the image.
Public Property | VerticalDpi | Overridden. Gets or sets the vertical resolution of the image.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DpiImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DpiImageSize Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > DpiImageSize Class : DpiImageSize Constructor

horizontalDpi
verticalDpi
Initializes a new instance of the DpiImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal horizontalDpi As Single, _
   ByVal verticalDpi As Single _
)
C#
public DpiImageSize(
   float horizontalDpi,
   float verticalDpi
)

Parameters

horizontalDpi
verticalDpi

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DpiImageSize Class
DpiImageSize Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DpiImageSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DpiImageSize Class

For a list of all members of this type, see DpiImageSize members.

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets the horizontal resolution of the image.
Public Property | VerticalDpi | Overridden. Gets or sets the vertical resolution of the image.
Top

See Also

Reference

DpiImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > DpiImageSize Class : HorizontalDpi Property

Gets or sets the horizontal resolution of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property HorizontalDpi As Single
C#
public override float HorizontalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DpiImageSize Class
DpiImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > DpiImageSize Class : VerticalDpi Property

Gets or sets the vertical resolution of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property VerticalDpi As Single
C#
public override float VerticalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DpiImageSize Class
DpiImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : FixedImageSize Class

Represents a fixed image size.

Object Model

FixedImageSize Class

Syntax

Visual Basic (Declaration)
Public Class FixedImageSize
   Inherits ImageSize
C#
public class FixedImageSize : ImageSize

Example

This example demonstrates how to rasterize a PDF document to a fixed image size.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a JpegImageFormat object.
        Dim jpegImageFormat As JpegImageFormat = New JpegImageFormat(90)

        ' Create a FixedImageSize object.
        Dim fixedImageSize As FixedImageSize = New FixedImageSize(500.0F, 500.0F)

        ' Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, fixedImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a JpegImageFormat object.
        JpegImageFormat jpegImageFormat = new JpegImageFormat(90);

        // Create a FixedImageSize object.
        FixedImageSize fixedImageSize = new FixedImageSize(500.0f, 500.0f);

        // Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, fixedImageSize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.FixedImageSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : FixedImageSize Class

The following tables list the members exposed by FixedImageSize.

Public Constructors

 | Name | Description
Public Constructor | FixedImageSize Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Height | Gets or sets height of the image.
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal DPI of the image.
Public Property | UnitType | Gets or sets unit type of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical DPI of the image.
Public Property | Width | Gets or sets width of the image.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FixedImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : FixedImageSize Constructor

Overload List

Overload | Description
FixedImageSize Constructor(Single,Single,Single,Single,UnitType) | Initializes a new instance of the FixedImageSize class.
FixedImageSize Constructor(Single,Single,UnitType) | Initializes a new instance of the FixedImageSize class.
FixedImageSize Constructor(Single,Single) | Initializes a new instance of the FixedImageSize class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Constructor(Single,Single,Single,Single,UnitType) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class > FixedImageSize Constructor : FixedImageSize Constructor(Single,Single,Single,Single,UnitType)

width
Width of the image.
height
Height of the image.
horizontalDpi
Horizondal dpi of the image.
verticalDpi
Vertical dpi of the image.
units
Unit type of the image.
Initializes a new instance of the FixedImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal horizontalDpi As Single, _
   ByVal verticalDpi As Single, _
   ByVal units As UnitType _
)
C#
public FixedImageSize(
   float width,
   float height,
   float horizontalDpi,
   float verticalDpi,
   UnitType units
)

Parameters

width
Width of the image.
height
Height of the image.
horizontalDpi
Horizondal dpi of the image.
verticalDpi
Vertical dpi of the image.
units
Unit type of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Constructor(Single,Single,UnitType) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class > FixedImageSize Constructor : FixedImageSize Constructor(Single,Single,UnitType)

width
Width of the image.
height
Height of the image.
units
Unit type of the image.
Initializes a new instance of the FixedImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single, _
   ByVal units As UnitType _
)
C#
public FixedImageSize(
   float width,
   float height,
   UnitType units
)

Parameters

width
Width of the image.
height
Height of the image.
units
Unit type of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Constructor(Single,Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class > FixedImageSize Constructor : FixedImageSize Constructor(Single,Single)

width
height
Initializes a new instance of the FixedImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal width As Single, _
   ByVal height As Single _
)
C#
public FixedImageSize(
   float width,
   float height
)

Parameters

width
height

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : FixedImageSize Class

For a list of all members of this type, see FixedImageSize members.

Public Properties

 | Name | Description
Public Property | Height | Gets or sets height of the image.
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal DPI of the image.
Public Property | UnitType | Gets or sets unit type of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical DPI of the image.
Public Property | Width | Gets or sets width of the image.
Top

See Also

Reference

FixedImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Height Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : Height Property

Gets or sets height of the image.

Syntax

Visual Basic (Declaration)
Public Property Height As Single
C#
public float Height {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : HorizontalDpi Property

Gets or sets horizontal DPI of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property HorizontalDpi As Single
C#
public override float HorizontalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UnitType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : UnitType Property

Gets or sets unit type of the image.

Syntax

Visual Basic (Declaration)
Public Property UnitType As UnitType
C#
public UnitType UnitType {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : VerticalDpi Property

Gets or sets vertical DPI of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property VerticalDpi As Single
C#
public override float VerticalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Width Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > FixedImageSize Class : Width Property

Gets or sets width of the image.

Syntax

Visual Basic (Declaration)
Public Property Width As Single
C#
public float Width {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FixedImageSize Class
FixedImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : GifImageFormat Class

Represents a GIF image format.

Object Model

GifImageFormat ClassPalette Class

Syntax

Visual Basic (Declaration)
Public Class GifImageFormat
   Inherits ImageFormat
C#
public class GifImageFormat : ImageFormat

Example

This example demonstrates how to rasterize a PDF document to GIF images.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Save the image.
        rasterizer.Draw("Output.gif", ImageFormat.Gif, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Save the image.
        rasterizer.Draw("Output.gif", ImageFormat.Gif, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.GifImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : GifImageFormat Class

The following tables list the members exposed by GifImageFormat.

Public Constructors

 | Name | Description
Public Constructor | GifImageFormat Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

GifImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class : GifImageFormat Constructor

Overload List

Overload | Description
GifImageFormat Constructor(Palette,Int32,DitheringAlgorithm) | Initializes a new instance of the GifImageFormat class.
GifImageFormat Constructor(Palette,Int32) | Initializes a new instance of the GifImageFormat class.
GifImageFormat Constructor(Palette) | Initializes a new instance of the GifImageFormat class.
GifImageFormat Constructor() | Initializes a new instance of the GifImageFormat class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Constructor(Palette,Int32,DitheringAlgorithm) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class > GifImageFormat Constructor : GifImageFormat Constructor(Palette,Int32,DitheringAlgorithm)

colorPalette
Color palette of the image.
ditheringPercent
Dithering Percentage of the image.
ditheringAlgorithm
Dithering Algorithm of the image.
Initializes a new instance of the GifImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer, _
   ByVal ditheringAlgorithm As DitheringAlgorithm _
)
C#
public GifImageFormat(
   Palette colorPalette,
   int ditheringPercent,
   DitheringAlgorithm ditheringAlgorithm
)

Parameters

colorPalette
Color palette of the image.
ditheringPercent
Dithering Percentage of the image.
ditheringAlgorithm
Dithering Algorithm of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Constructor(Palette,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class > GifImageFormat Constructor : GifImageFormat Constructor(Palette,Int32)

colorPalette
Color palette of the image.
ditheringPercent
Dithering Percentage of the image.
Initializes a new instance of the GifImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer _
)
C#
public GifImageFormat(
   Palette colorPalette,
   int ditheringPercent
)

Parameters

colorPalette
Color palette of the image.
ditheringPercent
Dithering Percentage of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Constructor(Palette) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class > GifImageFormat Constructor : GifImageFormat Constructor(Palette)

colorPalette
Color palette of the image.
Initializes a new instance of the GifImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette _
)
C#
public GifImageFormat(
   Palette colorPalette
)

Parameters

colorPalette
Color palette of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Constructor() | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class > GifImageFormat Constructor : GifImageFormat Constructor()

Initializes a new instance of the GifImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public GifImageFormat()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : GifImageFormat Class

For a list of all members of this type, see GifImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering percentage.
Top

See Also

Reference

GifImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class : ColorPalette Property

Gets or sets a palette type.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As Palette
C#
public Palette ColorPalette {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > GifImageFormat Class : DitheringPercent Property

Gets or sets the value of dithering percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GifImageFormat Class
GifImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageFormat Class

Base class that represents an image format. ImageFormat's derived classes are: BmpImageFormat, GifImageFormat, JpegImageFormat, PngImageFormat and TiffImageFormat. See the Output Image Format topic for more on Image Formats.

Object Model

ImageFormat ClassBmpImageFormat ClassPalette ClassGifImageFormat ClassJpegImageFormat ClassPngImageFormat ClassTiffImageFormat ClassTiffImageFormat ClassTiffImageFormat Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ImageFormat
C#
public abstract class ImageFormat

Remarks

ImageFormat's derived classes are: BmpImageFormat, GifImageFormat, JpegImageFormat, PngImageFormat and TiffImageFormat. See the Output Image Format topic for more on Image Formats.

Example

This example demonstrates how to rasterize a PDF document to Gif image usnig ImageFormat class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

   Sub Main()
       'Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       'Set the size.
       Dim fixedImageSize As New FixedImageSize(595, 841)
       'Save the image.
       rasterizer.Draw("Output.Gif", ImageFormat.Gif, fixedImageSize)

   End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       //Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       //Set the size.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       //Save the image.
       rasterizer.Draw("Output.Gif", ImageFormat.Gif, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.BmpImageFormat
Foxit.PDF.Rasterizer.GifImageFormat
Foxit.PDF.Rasterizer.JpegImageFormat
Foxit.PDF.Rasterizer.PngImageFormat
Foxit.PDF.Rasterizer.TiffImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageFormat Class

The following tables list the members exposed by ImageFormat.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value.
static (Shared in Visual Basic) | Bmp | Gets a default BmpImageFormat class.
static (Shared in Visual Basic) | DefaultColorPalette | Gets or Sets the default color palette.
static (Shared in Visual Basic) | DefaultDitheringAlgorithm | Gets or Sets the default dithering algorithm.
static (Shared in Visual Basic) | DefaultDitheringPercent | Gets or Sets the default dithering percentage.
static (Shared in Visual Basic) | Gif | Gets a default GifImageFormat class.
static (Shared in Visual Basic) | Jpeg | Gets a default JpegImageFormat class.
static (Shared in Visual Basic) | Png | Gets a default PngImageFormat class.
static (Shared in Visual Basic) | TiffWithCcitGroup3 | Gets a default TiffImageFormat class with CCIT Group 3 compression specified.
static (Shared in Visual Basic) | TiffWithCcitGroup4 | Gets a default TiffImageFormat class with CCIT Group 4 compression specified.
static (Shared in Visual Basic) | TiffWithLzw | Gets a default TiffImageFormat class with JPEG compression specified.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageFormat Class

For a list of all members of this type, see ImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value.
static (Shared in Visual Basic) | Bmp | Gets a default BmpImageFormat class.
static (Shared in Visual Basic) | DefaultColorPalette | Gets or Sets the default color palette.
static (Shared in Visual Basic) | DefaultDitheringAlgorithm | Gets or Sets the default dithering algorithm.
static (Shared in Visual Basic) | DefaultDitheringPercent | Gets or Sets the default dithering percentage.
static (Shared in Visual Basic) | Gif | Gets a default GifImageFormat class.
static (Shared in Visual Basic) | Jpeg | Gets a default JpegImageFormat class.
static (Shared in Visual Basic) | Png | Gets a default PngImageFormat class.
static (Shared in Visual Basic) | TiffWithCcitGroup3 | Gets a default TiffImageFormat class with CCIT Group 3 compression specified.
static (Shared in Visual Basic) | TiffWithCcitGroup4 | Gets a default TiffImageFormat class with CCIT Group 4 compression specified.
static (Shared in Visual Basic) | TiffWithLzw | Gets a default TiffImageFormat class with JPEG compression specified.
Top

See Also

Reference

ImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AntiAliasing Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : AntiAliasing Property

Gets or Sets the AntiAliasing value.

Syntax

Visual Basic (Declaration)
Public Property AntiAliasing As Boolean
C#
public bool AntiAliasing {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Bmp Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : Bmp Property

Gets a default BmpImageFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Bmp As BmpImageFormat
C#
public static BmpImageFormat Bmp {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DefaultColorPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : DefaultColorPalette Property

Gets or Sets the default color palette.

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultColorPalette As Palette
C#
public static Palette DefaultColorPalette {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DefaultDitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : DefaultDitheringAlgorithm Property

Gets or Sets the default dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultDitheringAlgorithm As DitheringAlgorithm
C#
public static DitheringAlgorithm DefaultDitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DefaultDitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : DefaultDitheringPercent Property

Gets or Sets the default dithering percentage.

Syntax

Visual Basic (Declaration)
Public Shared Property DefaultDitheringPercent As Integer
C#
public static int DefaultDitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Gif Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : Gif Property

Gets a default GifImageFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Gif As GifImageFormat
C#
public static GifImageFormat Gif {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Jpeg Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : Jpeg Property

Gets a default JpegImageFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Jpeg As JpegImageFormat
C#
public static JpegImageFormat Jpeg {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Png Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : Png Property

Gets a default PngImageFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Png As PngImageFormat
C#
public static PngImageFormat Png {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffWithCcitGroup3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : TiffWithCcitGroup3 Property

Gets a default TiffImageFormat class with CCIT Group 3 compression specified.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TiffWithCcitGroup3 As TiffImageFormat
C#
public static TiffImageFormat TiffWithCcitGroup3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffWithCcitGroup4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : TiffWithCcitGroup4 Property

Gets a default TiffImageFormat class with CCIT Group 4 compression specified.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TiffWithCcitGroup4 As TiffImageFormat
C#
public static TiffImageFormat TiffWithCcitGroup4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffWithLzw Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageFormat Class : TiffWithLzw Property

Gets a default TiffImageFormat class with JPEG compression specified.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property TiffWithLzw As TiffImageFormat
C#
public static TiffImageFormat TiffWithLzw {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageFormat Class
ImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageSize Class

Base class which represents an image size. ImageSize's derived classes are: DpiImageSize, FixedImageSize, MaxImageSize and PercentageImageSize. See the Output Image Size topic for more on Image Sizes.

Object Model

ImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize ClassDpiImageSize Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class ImageSize
C#
public abstract class ImageSize

Remarks

ImageSize's derived classes are: DpiImageSize, FixedImageSize, MaxImageSize and PercentageImageSize. See the Output Image Size topic for more on Image Sizes.

Example

This This example demonstrates the usage of ImageSize class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

   Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Save the image with 72 dots per inch vertical and horizontal resolution.
       rasterizer.Draw("Output.gif", ImageFormat.Gif, ImageSize.Dpi72)

   End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Save the image with 72 dots per inch vertical and horizontal resolution.
       rasterizer.Draw("Output.gif", ImageFormat.Gif, ImageSize.Dpi72);
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.DpiImageSize
Foxit.PDF.Rasterizer.FixedImageSize
Foxit.PDF.Rasterizer.MaxImageSize
Foxit.PDF.Rasterizer.PercentageImageSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageSize Class

The following tables list the members exposed by ImageSize.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Dpi150 | Gets a default DpiImageSize class set to 150 DPI.
static (Shared in Visual Basic) | Dpi300 | Gets a default DpiImageSize class set to 300 DPI.
static (Shared in Visual Basic) | Dpi600 | Gets a default DpiImageSize class set to 600 DPI.
static (Shared in Visual Basic) | Dpi72 | Gets a default DpiImageSize class set to 72 DPI.
static (Shared in Visual Basic) | Dpi96 | Gets a default DpiImageSize class set to 96 DPI.
static (Shared in Visual Basic) | FaxFine | Gets a default DpiImageSize class set to the fine fax DPI.
static (Shared in Visual Basic) | FaxStandard | Gets a default DpiImageSize class set to the standard fax DPI.
static (Shared in Visual Basic) | FaxSuperfine | Gets a default DpiImageSize class set to the super fine fax DPI.
Public Property | HorizontalDpi | Gets or sets the horizontal DPI of an image.
Public Property | VerticalDpi | Gets or sets the vertical DPI of an image.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageSize Class

For a list of all members of this type, see ImageSize members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Dpi150 | Gets a default DpiImageSize class set to 150 DPI.
static (Shared in Visual Basic) | Dpi300 | Gets a default DpiImageSize class set to 300 DPI.
static (Shared in Visual Basic) | Dpi600 | Gets a default DpiImageSize class set to 600 DPI.
static (Shared in Visual Basic) | Dpi72 | Gets a default DpiImageSize class set to 72 DPI.
static (Shared in Visual Basic) | Dpi96 | Gets a default DpiImageSize class set to 96 DPI.
static (Shared in Visual Basic) | FaxFine | Gets a default DpiImageSize class set to the fine fax DPI.
static (Shared in Visual Basic) | FaxStandard | Gets a default DpiImageSize class set to the standard fax DPI.
static (Shared in Visual Basic) | FaxSuperfine | Gets a default DpiImageSize class set to the super fine fax DPI.
Public Property | HorizontalDpi | Gets or sets the horizontal DPI of an image.
Public Property | VerticalDpi | Gets or sets the vertical DPI of an image.
Top

See Also

Reference

ImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dpi150 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : Dpi150 Property

Gets a default DpiImageSize class set to 150 DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Dpi150 As DpiImageSize
C#
public static DpiImageSize Dpi150 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dpi300 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : Dpi300 Property

Gets a default DpiImageSize class set to 300 DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Dpi300 As DpiImageSize
C#
public static DpiImageSize Dpi300 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dpi600 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : Dpi600 Property

Gets a default DpiImageSize class set to 600 DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Dpi600 As DpiImageSize
C#
public static DpiImageSize Dpi600 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dpi72 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : Dpi72 Property

Gets a default DpiImageSize class set to 72 DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Dpi72 As DpiImageSize
C#
public static DpiImageSize Dpi72 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dpi96 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : Dpi96 Property

Gets a default DpiImageSize class set to 96 DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Dpi96 As DpiImageSize
C#
public static DpiImageSize Dpi96 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FaxFine Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : FaxFine Property

Gets a default DpiImageSize class set to the fine fax DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FaxFine As DpiImageSize
C#
public static DpiImageSize FaxFine {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FaxStandard Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : FaxStandard Property

Gets a default DpiImageSize class set to the standard fax DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FaxStandard As DpiImageSize
C#
public static DpiImageSize FaxStandard {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FaxSuperfine Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : FaxSuperfine Property

Gets a default DpiImageSize class set to the super fine fax DPI.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property FaxSuperfine As DpiImageSize
C#
public static DpiImageSize FaxSuperfine {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : HorizontalDpi Property

Gets or sets the horizontal DPI of an image.

Syntax

Visual Basic (Declaration)
Public MustOverride Property HorizontalDpi As Single
C#
public abstract float HorizontalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > ImageSize Class : VerticalDpi Property

Gets or sets the vertical DPI of an image.

Syntax

Visual Basic (Declaration)
Public MustOverride Property VerticalDpi As Single
C#
public abstract float VerticalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ImageSize Class
ImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdf Class

Represents an input PDF.

Object Model

InputPdf ClassInputPdfPageList Class

Syntax

Visual Basic (Declaration)
Public Class InputPdf
   Implements System.IDisposable
C#
public class InputPdf : System.IDisposable

Example

This example demonstrates how to rasterize a PDF document to JPEG.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a InputPdf object.
        Dim input As InputPdf = New InputPdf("InputPdfFile.pdf")

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer(input)

        ' Create a JpegImageFormat object.
        Dim jpegImageFormat As JpegImageFormat = New JpegImageFormat(80)

        ' Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a InputPdf object.
        InputPdf input = new InputPdf("InputPdfFile.pdf");

        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer(input);

        // Create a JpegImageFormat object.
        JpegImageFormat jpegImageFormat = new JpegImageFormat(80);

        // Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat,ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.InputPdf

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdf Class

The following tables list the members exposed by InputPdf.

Public Constructors

 | Name | Description
Public Constructor | InputPdf Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | Pages | Gets the InputPdfPageList containing the pages of the input PDF.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : InputPdf Constructor

Overload List

Overload | Description
InputPdf Constructor(Byte[],String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(Stream,String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(String,String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(Byte[]) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(Stream) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(String) | Initializes a new instance of the InputPdf class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(Byte[],String) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Byte[],String)

data
Byte array of the input PDF data.
password
Password to open the PDF file.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte, _
   ByVal password As String _
)
C#
public InputPdf(
   byte[] data,
   string password
)

Parameters

data
Byte array of the input PDF data.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(Stream,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Stream,String)

stream
System.IO.Streamcontaining the PDF data.
password
Password to open the PDF file.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String _
)
C#
public InputPdf(
   Stream stream,
   string password
)

Parameters

stream
System.IO.Streamcontaining the PDF data.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(String,String)

filePath
Physical file path of the PDF.
password
Password to open the PDF file.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal password As String _
)
C#
public InputPdf(
   string filePath,
   string password
)

Parameters

filePath
Physical file path of the PDF.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(Byte[]) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Byte[])

data
Byte array of the input PDF data.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte _
)
C#
public InputPdf(
   byte[] data
)

Parameters

data
Byte array of the input PDF data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(Stream) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Stream)

stream
System.IO.Streamcontaining the PDF data.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
C#
public InputPdf(
   Stream stream
)

Parameters

stream
System.IO.Streamcontaining the PDF data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Constructor(String) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(String)

filePath
Physical file path of the PDF.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String _
)
C#
public InputPdf(
   string filePath
)

Parameters

filePath
Physical file path of the PDF.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdf Class

For a list of all members of this type, see InputPdf members.

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdf Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdf Class

For a list of all members of this type, see InputPdf members.

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | Pages | Gets the InputPdfPageList containing the pages of the input PDF.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Author Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Author Property

Gets the author property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Author As String
C#
public string Author {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Creator Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Creator Property

Gets the creator property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Creator As String
C#
public string Creator {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Keywords Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Keywords Property

Gets the keywords property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keywords As String
C#
public string Keywords {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Pages Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Pages Property

Gets the InputPdfPageList containing the pages of the input PDF.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As InputPdfPageList
C#
public InputPdfPageList Pages {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Producer Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Producer Property

Gets the producer property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Producer As String
C#
public string Producer {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Subject Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Subject Property

Gets the subject property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subject As String
C#
public string Subject {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Title Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Title Property

Gets the title property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Title As String
C#
public string Title {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPage Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPage Class

Represents a page in an input PDF.

Object Model

InputPdfPage Class

Syntax

Visual Basic (Declaration)
Public Class InputPdfPage
   Implements System.IDisposable
C#
public class InputPdfPage : System.IDisposable

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.InputPdfPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPage Class

The following tables list the members exposed by InputPdfPage.

Public Properties

 | Name | Description
Public Property | Height | Gets the width of the page in points.
Public Property | Width | Gets the width of the page in points.
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPage Class

For a list of all members of this type, see InputPdfPage members.

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPage Class : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPage Class

For a list of all members of this type, see InputPdfPage members.

Public Properties

 | Name | Description
Public Property | Height | Gets the width of the page in points.
Public Property | Width | Gets the width of the page in points.
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Height Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPage Class : Height Property

Gets the width of the page in points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
C#
public double Height {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Width Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPage Class : Width Property

Gets the width of the page in points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
C#
public double Width {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPageList Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPageList Class

Represents a list of input PDF pages.

Object Model

InputPdfPageList ClassInputPdfPage Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class InputPdfPageList
   Implements System.IDisposable
C#
[DefaultMemberAttribute("Item")]
public class InputPdfPageList : System.IDisposable

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.InputPdfPageList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPageList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPageList Class

The following tables list the members exposed by InputPdfPageList.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in the list.
Public Property | Item | Gets a page by index.
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPageList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPageList Class

For a list of all members of this type, see InputPdfPageList members.

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPageList Class : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InputPdfPageList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InputPdfPageList Class

For a list of all members of this type, see InputPdfPageList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in the list.
Public Property | Item | Gets a page by index.
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPageList Class : Count Property

Gets the number of pages in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPageList Class : Item Property

index
The index of the page.
Gets a page by index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As InputPdfPage
C#
public InputPdfPage this[
   int index
]; {get;}

Parameters

index
The index of the page.

Property Value

Returns a %%.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InvalidPasswordException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InvalidPasswordException Class

Represents a InvalidPasswordException

Object Model

InvalidPasswordException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class InvalidPasswordException
   Inherits PdfRasterizerException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class InvalidPasswordException : PdfRasterizerException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Rasterizer.PdfRasterizerException
Foxit.PDF.Rasterizer.InvalidPasswordException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InvalidPasswordException Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InvalidPasswordException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
JpegImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : JpegImageFormat Class

Represents a JPEG image format.

Object Model

JpegImageFormat Class

Syntax

Visual Basic (Declaration)
Public Class JpegImageFormat
   Inherits ImageFormat
C#
public class JpegImageFormat : ImageFormat

Example

This example demonstrates how to draw a PDF document to a JPEG images.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a JpegImageFormat.
        Dim jpegImageFormat As JpegImageFormat = New JpegImageFormat(80)

        ' Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a JpegImageFormat.
        JpegImageFormat jpegImageFormat = new JpegImageFormat(80);

        // Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.JpegImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

JpegImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
JpegImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : JpegImageFormat Class

The following tables list the members exposed by JpegImageFormat.

Public Constructors

 | Name | Description
Public Constructor | JpegImageFormat Constructor | Initializes a new instance of the JpegImageFormat class.
Top

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | Quality | Gets or sets of the image quality.The value ranges from 0 to 100.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

JpegImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
JpegImageFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > JpegImageFormat Class : JpegImageFormat Constructor

quality
Quality of the jpeg image.
Initializes a new instance of the JpegImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal quality As Integer _
)
C#
public JpegImageFormat(
   int quality
)

Parameters

quality
Quality of the jpeg image.

Remarks

The value ranges from 0 to 100,where 0 indicates highly compressed and low quality and 100 indicates high quality and less compressed image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

JpegImageFormat Class
JpegImageFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
JpegImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : JpegImageFormat Class

For a list of all members of this type, see JpegImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | Quality | Gets or sets of the image quality.The value ranges from 0 to 100.
Top

See Also

Reference

JpegImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Quality Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > JpegImageFormat Class : Quality Property

Gets or sets of the image quality.The value ranges from 0 to 100.

Syntax

Visual Basic (Declaration)
Public Property Quality As Integer
C#
public int Quality {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

JpegImageFormat Class
JpegImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
LicensingException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : LicensingException Class

Represents a licensing exception.

Object Model

LicensingException Class

Syntax

Visual Basic (Declaration)
Public Class LicensingException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class LicensingException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Rasterizer.LicensingException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
LicensingException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : LicensingException Class

The following tables list the members exposed by LicensingException.

Public Constructors

 | Name | Description
Public Constructor | LicensingException Constructor | Initializes a new instance of LicensingException.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
LicensingException Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > LicensingException Class : LicensingException Constructor

message

Message for the licensing exception.

Initializes a new instance of LicensingException.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public LicensingException(
   string message
)

Parameters

message

Message for the licensing exception.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Class
LicensingException Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : MaxImageSize Class

Represents a maximum image size.

Object Model

MaxImageSize Class

Syntax

Visual Basic (Declaration)
Public Class MaxImageSize
   Inherits ImageSize
C#
public class MaxImageSize : ImageSize

Remarks

Maintains the aspect ratio of the image.

Example

This example demonstrates how to rasterize a PDF document to the maximum size while maintaining its aspect ratio.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a JpegImageFormat object.
        Dim jpegImageFormat As JpegImageFormat = New JpegImageFormat(90)

        ' Create a MaxImageSize object.
        Dim maxImageSize As MaxImageSize = New MaxImageSize(800.0F, 400.0F)

        ' Save the image.
        rasterizer.Draw("Output.jpg", jpegImageFormat, maxImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a JpegImageFormat object.
        JpegImageFormat jpegImageFormat =  new JpegImageFormat(90);

        // Create a MaxImageSize object.
        MaxImageSize maxImageSize = new MaxImageSize(800.0f, 400.0f);

        // Save the image.
        rasterizer.Draw("Output.jpg",jpegImageFormat,maxImageSize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.MaxImageSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : MaxImageSize Class

The following tables list the members exposed by MaxImageSize.

Public Constructors

 | Name | Description
Public Constructor | MaxImageSize Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal DPI of the image.
Public Property | MaxHeight | Gets or sets maximum height of the image.
Public Property | MaxWidth | Gets or sets maximum width of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical DPI of the image.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MaxImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class : MaxImageSize Constructor

Overload List

Overload | Description
MaxImageSize Constructor(Single,Single,Single,Single,UnitType) | Initializes a new instance of the MaxImageSize class.
MaxImageSize Constructor(Single,Single,UnitType) | Initializes a new instance of the MaxImageSize class.
MaxImageSize Constructor(Single,Single) | Initializes a new instance of the MaxImageSize class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Constructor(Single,Single,Single,Single,UnitType) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class > MaxImageSize Constructor : MaxImageSize Constructor(Single,Single,Single,Single,UnitType)

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.
horizontalDpi
Horizondal dpi of the image.
verticalDpi
Vertical dpi of the image.
units
Initializes a new instance of the MaxImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal maxWidth As Single, _
   ByVal maxHeight As Single, _
   ByVal horizontalDpi As Single, _
   ByVal verticalDpi As Single, _
   ByVal units As UnitType _
)
C#
public MaxImageSize(
   float maxWidth,
   float maxHeight,
   float horizontalDpi,
   float verticalDpi,
   UnitType units
)

Parameters

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.
horizontalDpi
Horizondal dpi of the image.
verticalDpi
Vertical dpi of the image.
units

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Constructor(Single,Single,UnitType) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class > MaxImageSize Constructor : MaxImageSize Constructor(Single,Single,UnitType)

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.
units
Initializes a new instance of the MaxImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal maxWidth As Single, _
   ByVal maxHeight As Single, _
   ByVal units As UnitType _
)
C#
public MaxImageSize(
   float maxWidth,
   float maxHeight,
   UnitType units
)

Parameters

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.
units

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Constructor(Single,Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class > MaxImageSize Constructor : MaxImageSize Constructor(Single,Single)

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.
Initializes a new instance of the MaxImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal maxWidth As Single, _
   ByVal maxHeight As Single _
)
C#
public MaxImageSize(
   float maxWidth,
   float maxHeight
)

Parameters

maxWidth
Maximum width of the image.
maxHeight
Maximum height of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : MaxImageSize Class

For a list of all members of this type, see MaxImageSize members.

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal DPI of the image.
Public Property | MaxHeight | Gets or sets maximum height of the image.
Public Property | MaxWidth | Gets or sets maximum width of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical DPI of the image.
Top

See Also

Reference

MaxImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class : HorizontalDpi Property

Gets or sets horizontal DPI of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property HorizontalDpi As Single
C#
public override float HorizontalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxHeight Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class : MaxHeight Property

Gets or sets maximum height of the image.

Syntax

Visual Basic (Declaration)
Public Property MaxHeight As Single
C#
public float MaxHeight {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxWidth Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class : MaxWidth Property

Gets or sets maximum width of the image.

Syntax

Visual Basic (Declaration)
Public Property MaxWidth As Single
C#
public float MaxWidth {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > MaxImageSize Class : VerticalDpi Property

Gets or sets vertical DPI of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property VerticalDpi As Single
C#
public override float VerticalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MaxImageSize Class
MaxImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Palette Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : Palette Class

Base class that represents a palette. Palette's derived classes are: AutoPalette, UserPalette, WebPalette, WindowsPalette.

Object Model

Palette ClassWebPalette ClassWindowsPalette Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class Palette
C#
public abstract class Palette

Remarks

Palette's derived classes are: AutoPalette, UserPalette, WebPalette, WindowsPalette.

Example

This This example demonstrates the usage of Palette class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a GifImageFormat.
       Dim gifImageFormat As New GifImageFormat()

       ' Set the Colorpalette property to WebPalette.
       gifImageFormat.ColorPalette = Palette.WebPalette

       ' Set the size.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       ' Save the image.
       rasterizer.Draw("Output.Gif", gifImageFormat, fixedImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Create a GifImageFormat.
       GifImageFormat gifImageFormat = new GifImageFormat();

       // Set the Colorpalette property to WebPalette.
       gifImageFormat.ColorPalette = Palette.WebPalette;

       // Set the size.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       // Save the image.
       rasterizer.Draw("Output.Gif", gifImageFormat, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.AutoPalette
Foxit.PDF.Rasterizer.UserPalette
Foxit.PDF.Rasterizer.WebPalette
Foxit.PDF.Rasterizer.WindowsPalette

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Palette Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Palette Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : Palette Class

The following tables list the members exposed by Palette.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | WebPalette | Gets a default WebPalette class.
static (Shared in Visual Basic) | WindowsPalette | Gets a default WindowsPalette class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Palette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Palette Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : Palette Class

For a list of all members of this type, see Palette members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | WebPalette | Gets a default WebPalette class.
static (Shared in Visual Basic) | WindowsPalette | Gets a default WindowsPalette class.
Top

See Also

Reference

Palette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WebPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > Palette Class : WebPalette Property

Gets a default WebPalette class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WebPalette As WebPalette
C#
public static WebPalette WebPalette {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Palette Class
Palette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WindowsPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > Palette Class : WindowsPalette Property

Gets a default WindowsPalette class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property WindowsPalette As WindowsPalette
C#
public static WindowsPalette WindowsPalette {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Palette Class
Palette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizer Class

Represents a PDF rasterizer.

Object Model

PdfRasterizer ClassPdfRasterizerPageList Class

Syntax

Visual Basic (Declaration)
Public Class PdfRasterizer
   Implements System.IDisposable
C#
public class PdfRasterizer : System.IDisposable

Example

This example demonstrates how to rasterize a PDF document.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Save the image.
        rasterizer.DrawToMultiPageTiff("Output.tif", TiffImageFormat.TiffWithLzw, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Save the image.
        rasterizer.DrawToMultiPageTiff("Output.tif", TiffImageFormat.TiffWithLzw, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PdfRasterizer

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizer Class

The following tables list the members exposed by PdfRasterizer.

Public Constructors

 | Name | Description
Public Constructor | PdfRasterizer Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Pages | Gets the PdfRasterizerPageList containing the pages to rasterize.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | Append | Overloaded. Append the entire the pages of the pdf document to the PdfRasterizerPageList.
Public Method | Dispose |
Public Method | Draw | Overloaded. Rasterizes all pages in the page list to an image and stores the image to the given filename.
Public Method | DrawToMultiPageTiff | Overloaded. Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given stream.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizer Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : PdfRasterizer Constructor

Overload List

Overload | Description
PdfRasterizer Constructor(InputPdf,Int32,Int32) | Initializes a new instance of the PdfRasterizer class.
PdfRasterizer Constructor(String,Int32,Int32) | Initializes a new instance of the PdfRasterizer class.
PdfRasterizer Constructor(InputPdf) | Initializes a new instance of the PdfRasterizer class.
PdfRasterizer Constructor(String) | Initializes a new instance of the PdfRasterizer class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Constructor(InputPdf,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > PdfRasterizer Constructor : PdfRasterizer Constructor(InputPdf,Int32,Int32)

inputPdf
Represents an input PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.
Initializes a new instance of the PdfRasterizer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inputPdf As InputPdf, _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer _
)
C#
public PdfRasterizer(
   InputPdf inputPdf,
   int startPageNumber,
   int pageCount
)

Parameters

inputPdf
Represents an input PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Constructor(String,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > PdfRasterizer Constructor : PdfRasterizer Constructor(String,Int32,Int32)

filePath
Physical file path of the PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.
Initializes a new instance of the PdfRasterizer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer _
)
C#
public PdfRasterizer(
   string filePath,
   int startPageNumber,
   int pageCount
)

Parameters

filePath
Physical file path of the PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Constructor(InputPdf) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > PdfRasterizer Constructor : PdfRasterizer Constructor(InputPdf)

inputPdf
Represents an input PDF to rasterize.
Initializes a new instance of the PdfRasterizer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal inputPdf As InputPdf _
)
C#
public PdfRasterizer(
   InputPdf inputPdf
)

Parameters

inputPdf
Represents an input PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Constructor(String) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > PdfRasterizer Constructor : PdfRasterizer Constructor(String)

filePath
Physical file path of the PDF to rasterize.
Initializes a new instance of the PdfRasterizer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String _
)
C#
public PdfRasterizer(
   string filePath
)

Parameters

filePath
Physical file path of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizer Class

For a list of all members of this type, see PdfRasterizer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | Append | Overloaded. Append the entire the pages of the pdf document to the PdfRasterizerPageList.
Public Method | Dispose |
Public Method | Draw | Overloaded. Rasterizes all pages in the page list to an image and stores the image to the given filename.
Public Method | DrawToMultiPageTiff | Overloaded. Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given stream.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizer Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AddLicense Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : AddLicense Method

licenseKey
The license key to add.
Adds a license key.

Syntax

Visual Basic (Declaration)
Public Shared Function AddLicense( _
   ByVal licenseKey As String _
) As Boolean
C#
public static bool AddLicense(
   string licenseKey
)

Parameters

licenseKey
The license key to add.

Return Value

A boolean value indicating if the license is valid.

Remarks

This method accepts a license key, not a serial number.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Append Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : Append Method

Append the entire the pages of the pdf document to the PdfRasterizerPageList.

Overload List

Overload | Description
Append(InputPdf,Int32,Int32) | Append the entire the pages of the pdf document to the PdfRasterizerPageList.
Append(String,Int32,Int32) | Append the entire PDF document to the list of pages to rasterize.
Append(InputPdf) | Append the entire PDF document to the list of pages to rasterize.
Append(String) | Append the entire PDF document to the list of pages to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Append(InputPdf,Int32,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Append Method : Append(InputPdf,Int32,Int32) Method

inputPdf
Represents an input PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.
Append the entire the pages of the pdf document to the PdfRasterizerPageList.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal inputPdf As InputPdf, _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer _
)
C#
public void Append(
   InputPdf inputPdf,
   int startPageNumber,
   int pageCount
)

Parameters

inputPdf
Represents an input PDF to rasterize.
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Append(String,Int32,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Append Method : Append(String,Int32,Int32) Method

filePath
Physical file path of the Pdf
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.
Append the entire PDF document to the list of pages to rasterize.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal filePath As String, _
   ByVal startPageNumber As Integer, _
   ByVal pageCount As Integer _
)
C#
public void Append(
   string filePath,
   int startPageNumber,
   int pageCount
)

Parameters

filePath
Physical file path of the Pdf
startPageNumber
Starting page number of the PDF to rasterize.
pageCount
Total page count of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Append(InputPdf) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Append Method : Append(InputPdf) Method

inputPdf
Represents an input PDF to rasterize.
Append the entire PDF document to the list of pages to rasterize.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal inputPdf As InputPdf _
)
C#
public void Append(
   InputPdf inputPdf
)

Parameters

inputPdf
Represents an input PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Append(String) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Append Method : Append(String) Method

filePath
Physical file path of the PDF to rasterize.
Append the entire PDF document to the list of pages to rasterize.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Append( _
   ByVal filePath As String _
)
C#
public void Append(
   string filePath
)

Parameters

filePath
Physical file path of the PDF to rasterize.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : Draw Method

Rasterizes all pages in the page list to an image and stores the image to the given filename.

Overload List

Overload | Description
Draw(String,ImageFormat,ImageSize) | Rasterizes all pages in the page list to an image and stores the image to the given filename.
Draw(ImageFormat,ImageSize) | Rasterizes all pages in the page list to an array of byte arrays containing the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw(String,ImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Draw Method : Draw(String,ImageFormat,ImageSize) Method

fileName
Physical file path of the image.
imageFormat
Represents the image format to use.
imageSize
Represents image size to use.
Rasterizes all pages in the page list to an image and stores the image to the given filename.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal fileName As String, _
   ByVal imageFormat As ImageFormat, _
   ByVal imageSize As ImageSize _
)
C#
public void Draw(
   string fileName,
   ImageFormat imageFormat,
   ImageSize imageSize
)

Parameters

fileName
Physical file path of the image.
imageFormat
Represents the image format to use.
imageSize
Represents image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw(ImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > Draw Method : Draw(ImageFormat,ImageSize) Method

imageFormat
Represents the image format to use.
imageSize
Represents image size to use.
Rasterizes all pages in the page list to an array of byte arrays containing the image data.

Syntax

Visual Basic (Declaration)
Public Overloads Function Draw( _
   ByVal imageFormat As ImageFormat, _
   ByVal imageSize As ImageSize _
) As Byte()
C#
public byte[] Draw(
   ImageFormat imageFormat,
   ImageSize imageSize
)

Parameters

imageFormat
Represents the image format to use.
imageSize
Represents image size to use.

Return Value

Returns the array of byte arrays containing the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToMultiPageTiff Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : DrawToMultiPageTiff Method

Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given stream.

Overload List

Overload | Description
DrawToMultiPageTiff(Stream,TiffImageFormat,ImageSize) | Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given stream.
DrawToMultiPageTiff(TiffImageFormat,ImageSize) | Rasterizes all pages in the page list to an multi-page TIFF image and returns it as a byte array.
DrawToMultiPageTiff(String,TiffImageFormat,ImageSize) | Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given filename.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToMultiPageTiff(Stream,TiffImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > DrawToMultiPageTiff Method : DrawToMultiPageTiff(Stream,TiffImageFormat,ImageSize) Method

stream
System.IO.Streamcontaining the Pdf data.
tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.
Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawToMultiPageTiff( _
   ByVal stream As Stream, _
   ByVal tiffImageFormat As TiffImageFormat, _
   ByVal imageSize As ImageSize _
)
C#
public void DrawToMultiPageTiff(
   Stream stream,
   TiffImageFormat tiffImageFormat,
   ImageSize imageSize
)

Parameters

stream
System.IO.Streamcontaining the Pdf data.
tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToMultiPageTiff(TiffImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > DrawToMultiPageTiff Method : DrawToMultiPageTiff(TiffImageFormat,ImageSize) Method

tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.
Rasterizes all pages in the page list to an multi-page TIFF image and returns it as a byte array.

Syntax

Visual Basic (Declaration)
Public Overloads Function DrawToMultiPageTiff( _
   ByVal tiffImageFormat As TiffImageFormat, _
   ByVal imageSize As ImageSize _
) As Byte()
C#
public byte[] DrawToMultiPageTiff(
   TiffImageFormat tiffImageFormat,
   ImageSize imageSize
)

Parameters

tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToMultiPageTiff(String,TiffImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class > DrawToMultiPageTiff Method : DrawToMultiPageTiff(String,TiffImageFormat,ImageSize) Method

fileName
Physical filepath of the image.
tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.
Rasterizes all pages in the page list to an multi-page TIFF image and stores it to the given filename.

Syntax

Visual Basic (Declaration)
Public Overloads Sub DrawToMultiPageTiff( _
   ByVal fileName As String, _
   ByVal tiffImageFormat As TiffImageFormat, _
   ByVal imageSize As ImageSize _
)
C#
public void DrawToMultiPageTiff(
   string fileName,
   TiffImageFormat tiffImageFormat,
   ImageSize imageSize
)

Parameters

fileName
Physical filepath of the image.
tiffImageFormat
Represents the TIFF image format to use.
imageSize
Represents image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizer Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizer Class

For a list of all members of this type, see PdfRasterizer members.

Public Properties

 | Name | Description
Public Property | Pages | Gets the PdfRasterizerPageList containing the pages to rasterize.
Top

See Also

Reference

PdfRasterizer Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Pages Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : Pages Property

Gets the PdfRasterizerPageList containing the pages to rasterize.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PdfRasterizerPageList
C#
public PdfRasterizerPageList Pages {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerException Class

Represents a PdfRasterizerException

Object Model

PdfRasterizerException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class PdfRasterizerException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class PdfRasterizerException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Rasterizer.PdfRasterizerException
Foxit.PDF.Rasterizer.DocumentLoadException
Foxit.PDF.Rasterizer.InvalidPasswordException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerException Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerException Class

The following tables list the members exposed by PdfRasterizerException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfRasterizerException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPage Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPage Class

Represents a page of the PDF rasterizer.

Object Model

PdfRasterizerPage Class

Syntax

Visual Basic (Declaration)
Public Class PdfRasterizerPage
   Implements System.IDisposable
C#
public class PdfRasterizerPage : System.IDisposable

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PdfRasterizerPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPage Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPage Class

The following tables list the members exposed by PdfRasterizerPage.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Rasterizes the page to an image and stores it to the given stream.
Public Method | DrawToBitmap | Overloaded. Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizerPage Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPage Class

For a list of all members of this type, see PdfRasterizerPage members.

Public Methods

 | Name | Description
Public Method | Draw | Overloaded. Rasterizes the page to an image and stores it to the given stream.
Public Method | DrawToBitmap | Overloaded. Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizerPage Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class : Draw Method

Rasterizes the page to an image and stores it to the given stream.

Overload List

Overload | Description
Draw(Stream,ImageFormat,ImageSize) | Rasterizes the page to an image and stores it to the given stream.
Draw(String,ImageFormat,ImageSize) | Rasterizes the page to an image and stores it to the given file path.
Draw(ImageFormat,ImageSize) | Rasterizes the page to a byte array containing the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw(Stream,ImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class > Draw Method : Draw(Stream,ImageFormat,ImageSize) Method

stream
The System.IO.Stream containing the Pdf data.
imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.
Rasterizes the page to an image and stores it to the given stream.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal stream As Stream, _
   ByVal imageFormat As ImageFormat, _
   ByVal imageSize As ImageSize _
)
C#
public void Draw(
   Stream stream,
   ImageFormat imageFormat,
   ImageSize imageSize
)

Parameters

stream
The System.IO.Stream containing the Pdf data.
imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw(String,ImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class > Draw Method : Draw(String,ImageFormat,ImageSize) Method

filePath
Physical file path of the image.
imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.
Rasterizes the page to an image and stores it to the given file path.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Draw( _
   ByVal filePath As String, _
   ByVal imageFormat As ImageFormat, _
   ByVal imageSize As ImageSize _
)
C#
public void Draw(
   string filePath,
   ImageFormat imageFormat,
   ImageSize imageSize
)

Parameters

filePath
Physical file path of the image.
imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Draw(ImageFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class > Draw Method : Draw(ImageFormat,ImageSize) Method

imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.
Rasterizes the page to a byte array containing the image data.

Syntax

Visual Basic (Declaration)
Public Overloads Function Draw( _
   ByVal imageFormat As ImageFormat, _
   ByVal imageSize As ImageSize _
) As Byte()
C#
public byte[] Draw(
   ImageFormat imageFormat,
   ImageSize imageSize
)

Parameters

imageFormat
Represents the image format to use.
imageSize
Represents the image size to use.

Return Value

Returns a byte array containing the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToBitmap Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class : DrawToBitmap Method

Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.

Overload List

Overload | Description
DrawToBitmap(BitmapColorFormat,ImageSize,Boolean) | Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.
DrawToBitmap(BitmapColorFormat,ImageSize) | Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToBitmap(BitmapColorFormat,ImageSize,Boolean) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class > DrawToBitmap Method : DrawToBitmap(BitmapColorFormat,ImageSize,Boolean) Method

colorFormat
Represents the color format to use for the Bitmap.
imageSize
Represents the image size to use.
antiAliasing
Set to false to turn off anti-aliasing.
Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.

Syntax

Visual Basic (Declaration)
Public Overloads Function DrawToBitmap( _
   ByVal colorFormat As BitmapColorFormat, _
   ByVal imageSize As ImageSize, _
   ByVal antiAliasing As Boolean _
) As Bitmap
C#
public Bitmap DrawToBitmap(
   BitmapColorFormat colorFormat,
   ImageSize imageSize,
   bool antiAliasing
)

Parameters

colorFormat
Represents the color format to use for the Bitmap.
imageSize
Represents the image size to use.
antiAliasing
Set to false to turn off anti-aliasing.

Return Value

Returns a System.Drawing.Bitmap contain the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DrawToBitmap(BitmapColorFormat,ImageSize) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPage Class > DrawToBitmap Method : DrawToBitmap(BitmapColorFormat,ImageSize) Method

colorFormat
Represents the color format to use for the Bitmap.
imageSize
Represents the image size to use.
Rasterizes the page and returns it as a System.Drawing.Bitmap object containing the image data.

Syntax

Visual Basic (Declaration)
Public Overloads Function DrawToBitmap( _
   ByVal colorFormat As BitmapColorFormat, _
   ByVal imageSize As ImageSize _
) As Bitmap
C#
public Bitmap DrawToBitmap(
   BitmapColorFormat colorFormat,
   ImageSize imageSize
)

Parameters

colorFormat
Represents the color format to use for the Bitmap.
imageSize
Represents the image size to use.

Return Value

Returns a System.Drawing.Bitmap contain the image data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPage Class
PdfRasterizerPage Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPageList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPageList Class

Represents a list of pages to rasterize.

Object Model

PdfRasterizerPageList ClassPdfRasterizerPage Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PdfRasterizerPageList
   Implements System.IDisposable
C#
[DefaultMemberAttribute("Item")]
public class PdfRasterizerPageList : System.IDisposable

Example

This example demonstrates usage of PdfRasterizerPageList class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Set the size.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       ' Getting the output bmp image.
       Dim bmp As System.Drawing.Bitmap = rasterizer.Pages(0).DrawToBitmap(BitmapColorFormat.Rgb, fixedImageSize)

       ' Save the image.
       bmp.Save("Output.bmp")

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Set the size.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       // Getting the output bmp image.
       System.Drawing.Bitmap bmp = rasterizer.Pages[0].DrawToBitmap(BitmapColorFormat.Rgb, fixedImageSize);

       // Save the image.
       bmp.Save("Output.bmp");
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PdfRasterizerPageList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPageList Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPageList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPageList Class

The following tables list the members exposed by PdfRasterizerPageList.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in page list.
Public Property | Item | Gets a page by index.
Top

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizerPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPageList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPageList Class

For a list of all members of this type, see PdfRasterizerPageList members.

Public Methods

 | Name | Description
Public Method | Dispose |
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfRasterizerPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPageList Class : Dispose() Method

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPageList Class
PdfRasterizerPageList Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerPageList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerPageList Class

For a list of all members of this type, see PdfRasterizerPageList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in page list.
Public Property | Item | Gets a page by index.
Top

See Also

Reference

PdfRasterizerPageList Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPageList Class : Count Property

Gets the number of pages in page list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPageList Class
PdfRasterizerPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPageList Class : Item Property

index
Gets a page by index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PdfRasterizerPage
C#
public PdfRasterizerPage this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPageList Class
PdfRasterizerPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PercentageImageSize Class

Represents a percentage image size.

Object Model

PercentageImageSize Class

Syntax

Visual Basic (Declaration)
Public Class PercentageImageSize
   Inherits ImageSize
C#
public class PercentageImageSize : ImageSize

Remarks

Specifies PercentageImageSize as a single parameter horizontal percentage and vertical percentage is same value.

Example

This example demonstartes how to rasterize a PDF document with a given percentage of its original size.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PercentageImageSize object.
        Dim percentageImageSize As PercentageImageSize = New PercentageImageSize(25)

        ' Save the image.
        rasterizer.Draw("Output.gif", ImageFormat.Gif, percentageImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PercentageImageSize object.
        PercentageImageSize percentageImageSize = new PercentageImageSize(25);

        // Save the image.
        rasterizer.Draw("Output.gif", ImageFormat.Gif, percentageImageSize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.PercentageImageSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PercentageImageSize Class

The following tables list the members exposed by PercentageImageSize.

Public Constructors

 | Name | Description
Public Constructor | PercentageImageSize Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal resolution of the image.
Public Property | HorizontalPercentage | Get or sets horizontal percentage of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical resolution of the image.
Public Property | VerticalPercentage | Gets or sets vertical percentage of the image.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PercentageImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class : PercentageImageSize Constructor

Overload List

Overload | Description
PercentageImageSize Constructor(Single,Single,Single,Single) | Initializes a new instance of the PercentageImageSize class.
PercentageImageSize Constructor(Single,Single) | Initializes a new instance of the PercentageImageSize class.
PercentageImageSize Constructor(Single) | Initializes a new instance of the PercentageImageSize class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Constructor(Single,Single,Single,Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class > PercentageImageSize Constructor : PercentageImageSize Constructor(Single,Single,Single,Single)

horizontalPercentage
Horizontal percentage of the image.
verticalPercentage
Vertical percentage of the image.
horizontalDpi
Horizondal DPI of the image.
verticalDpi
Vertical DPI of the image.
Initializes a new instance of the PercentageImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal horizontalPercentage As Single, _
   ByVal verticalPercentage As Single, _
   ByVal horizontalDpi As Single, _
   ByVal verticalDpi As Single _
)
C#
public PercentageImageSize(
   float horizontalPercentage,
   float verticalPercentage,
   float horizontalDpi,
   float verticalDpi
)

Parameters

horizontalPercentage
Horizontal percentage of the image.
verticalPercentage
Vertical percentage of the image.
horizontalDpi
Horizondal DPI of the image.
verticalDpi
Vertical DPI of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Constructor(Single,Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class > PercentageImageSize Constructor : PercentageImageSize Constructor(Single,Single)

horizontalPercentage
Horizontal percentage of the image.
verticalPercentage
Vertical percentage of the image.
Initializes a new instance of the PercentageImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal horizontalPercentage As Single, _
   ByVal verticalPercentage As Single _
)
C#
public PercentageImageSize(
   float horizontalPercentage,
   float verticalPercentage
)

Parameters

horizontalPercentage
Horizontal percentage of the image.
verticalPercentage
Vertical percentage of the image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Constructor(Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class > PercentageImageSize Constructor : PercentageImageSize Constructor(Single)

percentage
Percentage of the original image.
Initializes a new instance of the PercentageImageSize class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal percentage As Single _
)
C#
public PercentageImageSize(
   float percentage
)

Parameters

percentage
Percentage of the original image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PercentageImageSize Class

For a list of all members of this type, see PercentageImageSize members.

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Overridden. Gets or sets horizontal resolution of the image.
Public Property | HorizontalPercentage | Get or sets horizontal percentage of the image.
Public Property | VerticalDpi | Overridden. Gets or sets vertical resolution of the image.
Public Property | VerticalPercentage | Gets or sets vertical percentage of the image.
Top

See Also

Reference

PercentageImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class : HorizontalDpi Property

Gets or sets horizontal resolution of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property HorizontalDpi As Single
C#
public override float HorizontalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
HorizontalPercentage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class : HorizontalPercentage Property

Get or sets horizontal percentage of the image.

Syntax

Visual Basic (Declaration)
Public Property HorizontalPercentage As Single
C#
public float HorizontalPercentage {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class : VerticalDpi Property

Gets or sets vertical resolution of the image.

Syntax

Visual Basic (Declaration)
Public Overrides Property VerticalDpi As Single
C#
public override float VerticalDpi {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
VerticalPercentage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PercentageImageSize Class : VerticalPercentage Property

Gets or sets vertical percentage of the image.

Syntax

Visual Basic (Declaration)
Public Property VerticalPercentage As Single
C#
public float VerticalPercentage {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentageImageSize Class
PercentageImageSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngColorFormat Class

Base class that represents an color format supported by PNG image format. PngColorFormat's derived classes are: PngGrayscaleColorFormat, PngMonochromeColorFormat, PngRgbColorFormat, PngRgbAColorFormat and PngIndexedColorFormat.

Object Model

PngColorFormat ClassPngGrayscaleColorFormat ClassPngIndexedColorFormat ClassPngMonochromeColorFormat ClassPngRgbColorFormat ClassPngRgbAColorFormat Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PngColorFormat
C#
public abstract class PngColorFormat

Remarks

PngColorFormat's derived classes are: PngGrayscaleColorFormat, PngMonochromeColorFormat, PngRgbColorFormat, PngRgbAColorFormat and PngIndexedColorFormat.

Example

This example demonstrates the usage of PngColorFormat class for creating a PNG image.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a FixedImageSize object with required width and height.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       'Create a PngImageFormat object with indexed color.
       Dim oPngImageFormat As New PngImageFormat(PngColorFormat.Indexed)

       ' Save the image.
       rasterizer.Draw("Output.png", oPngImageFormat, fixedImageSize)

    End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Create a FixedImageSize object with required width and height.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       //Create a PngImageFormat object with indexed color.
       PngImageFormat oPngImageFormat = new PngImageFormat(PngColorFormat.Indexed);

       // Save the image.
       rasterizer.Draw("Output.png", oPngImageFormat, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngGrayscaleColorFormat
Foxit.PDF.Rasterizer.PngIndexedColorFormat
Foxit.PDF.Rasterizer.PngMonochromeColorFormat
Foxit.PDF.Rasterizer.PngRgbAColorFormat
Foxit.PDF.Rasterizer.PngRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngColorFormat Class

The following tables list the members exposed by PngColorFormat.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Grayscale | Gets a default PngGrayscaleColorFormat class.
static (Shared in Visual Basic) | Indexed | Gets a default PngIndexedColorFormat class.
static (Shared in Visual Basic) | Monochrome | Gets a default PngMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default PngRgbColorFormat class.
static (Shared in Visual Basic) | RgbA | Gets a default PngRgbAColorFormat class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngColorFormat Class

For a list of all members of this type, see PngColorFormat members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Grayscale | Gets a default PngGrayscaleColorFormat class.
static (Shared in Visual Basic) | Indexed | Gets a default PngIndexedColorFormat class.
static (Shared in Visual Basic) | Monochrome | Gets a default PngMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default PngRgbColorFormat class.
static (Shared in Visual Basic) | RgbA | Gets a default PngRgbAColorFormat class.
Top

See Also

Reference

PngColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Grayscale Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngColorFormat Class : Grayscale Property

Gets a default PngGrayscaleColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Grayscale As PngGrayscaleColorFormat
C#
public static PngGrayscaleColorFormat Grayscale {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Class
PngColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Indexed Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngColorFormat Class : Indexed Property

Gets a default PngIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Indexed As PngIndexedColorFormat
C#
public static PngIndexedColorFormat Indexed {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Class
PngColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Monochrome Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngColorFormat Class : Monochrome Property

Gets a default PngMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Monochrome As PngMonochromeColorFormat
C#
public static PngMonochromeColorFormat Monochrome {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Class
PngColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Rgb Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngColorFormat Class : Rgb Property

Gets a default PngRgbColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Rgb As PngRgbColorFormat
C#
public static PngRgbColorFormat Rgb {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Class
PngColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
RgbA Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngColorFormat Class : RgbA Property

Gets a default PngRgbAColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RgbA As PngRgbAColorFormat
C#
public static PngRgbAColorFormat RgbA {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngColorFormat Class
PngColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngGrayscaleColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngGrayscaleColorFormat Class

Represents a grayscale color format supported by PNG.

Object Model

PngGrayscaleColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class PngGrayscaleColorFormat
   Inherits PngColorFormat
C#
public class PngGrayscaleColorFormat : PngColorFormat

Example

This example demonstrates how to rasterize a PDF document to a PNG grayscale image format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat( PngColorFormat.Grayscale)

        ' Create a ImageSize object.
        Dim imageSize As DpiImageSize = New DpiImageSize(72.0F, 72.0F)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, imageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat( PngColorFormat.Grayscale);

        // Create a ImageSize object.
        DpiImageSize imagesize = new DpiImageSize(72.0f, 72.0f);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, imagesize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngGrayscaleColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngGrayscaleColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngGrayscaleColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngGrayscaleColorFormat Class

The following tables list the members exposed by PngGrayscaleColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngGrayscaleColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngImageFormat Class

Represents a PNG image format.

Object Model

PngImageFormat ClassPngColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class PngImageFormat
   Inherits ImageFormat
C#
public class PngImageFormat : ImageFormat

Example

This example demonstrates how to rasterize a PDF document to PNG.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat(PngColorFormat.Rgb)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(PngColorFormat.Rgb);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.PngImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngImageFormat Class

The following tables list the members exposed by PngImageFormat.

Public Constructors

 | Name | Description
Public Constructor | PngImageFormat Constructor | Initializes a new instance of the PngImageFormat class.
Top

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the PNG color format.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngImageFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngImageFormat Class : PngImageFormat Constructor

pngColorFormat
Color format of the PNG image.
Initializes a new instance of the PngImageFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal pngColorFormat As PngColorFormat _
)
C#
public PngImageFormat(
   PngColorFormat pngColorFormat
)

Parameters

pngColorFormat
Color format of the PNG image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngImageFormat Class
PngImageFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngImageFormat Class

For a list of all members of this type, see PngImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the PNG color format.
Top

See Also

Reference

PngImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorFormat Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngImageFormat Class : ColorFormat Property

Gets or sets the PNG color format.

Syntax

Visual Basic (Declaration)
Public Property ColorFormat As PngColorFormat
C#
public PngColorFormat ColorFormat {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngImageFormat Class
PngImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngIndexedColorFormat Class

Represents a indexed color format supported by PNG.

Object Model

PngIndexedColorFormat ClassPalette Class

Syntax

Visual Basic (Declaration)
Public Class PngIndexedColorFormat
   Inherits PngColorFormat
C#
public class PngIndexedColorFormat : PngColorFormat

Example

This example demonstrates how to rasterize a PDF document to PNG indexed image format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngIndexedColorFormat object.
        Dim pngColorFormat As PngIndexedColorFormat  = New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg,100)
        pngColorFormat.ColorPalette = Palette.WindowsPalette

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat(pngColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngIndexedColorFormat object.
        PngIndexedColorFormat pngColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg,100);
        pngColorFormat.ColorPalette = Palette.WindowsPalette;

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(pngColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngIndexedColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngIndexedColorFormat Class

The following tables list the members exposed by PngIndexedColorFormat.

Public Constructors

 | Name | Description
Public Constructor | PngIndexedColorFormat Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class : PngIndexedColorFormat Constructor

Overload List

Overload | Description
PngIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm) | Initializes a new instance of the PngIndexedColorFormat class.
PngIndexedColorFormat Constructor(Palette,Int32) | Initializes a new instance of the PngIndexedColorFormat class.
PngIndexedColorFormat Constructor(Palette) | Initializes a new instance of the PngIndexedColorFormat class.
PngIndexedColorFormat Constructor() | Initializes a new instance of the PngIndexedColorFormat class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class > PngIndexedColorFormat Constructor : PngIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm)

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage .
ditheringAlgorithm
Specify a dithering algorithm .
Initializes a new instance of the PngIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer, _
   ByVal ditheringAlgorithm As DitheringAlgorithm _
)
C#
public PngIndexedColorFormat(
   Palette colorPalette,
   int ditheringPercent,
   DitheringAlgorithm ditheringAlgorithm
)

Parameters

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage .
ditheringAlgorithm
Specify a dithering algorithm .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Constructor(Palette,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class > PngIndexedColorFormat Constructor : PngIndexedColorFormat Constructor(Palette,Int32)

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage.
Initializes a new instance of the PngIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer _
)
C#
public PngIndexedColorFormat(
   Palette colorPalette,
   int ditheringPercent
)

Parameters

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Constructor(Palette) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class > PngIndexedColorFormat Constructor : PngIndexedColorFormat Constructor(Palette)

colorPalette
Specify a color palette.
Initializes a new instance of the PngIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette _
)
C#
public PngIndexedColorFormat(
   Palette colorPalette
)

Parameters

colorPalette
Specify a color palette.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Constructor() | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class > PngIndexedColorFormat Constructor : PngIndexedColorFormat Constructor()

Initializes a new instance of the PngIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PngIndexedColorFormat()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngIndexedColorFormat Class

For a list of all members of this type, see PngIndexedColorFormat members.

Public Properties

 | Name | Description
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

See Also

Reference

PngIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class : ColorPalette Property

Gets or sets a palette type.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As Palette
C#
public Palette ColorPalette {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngIndexedColorFormat Class : DitheringPercent Property

Gets or sets the value of dithering in percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngIndexedColorFormat Class
PngIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngMonochromeColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngMonochromeColorFormat Class

Represents a monochrome color format supported by PNG.

Object Model

PngMonochromeColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class PngMonochromeColorFormat
   Inherits PngColorFormat
C#
public class PngMonochromeColorFormat : PngColorFormat

Example

This example demonstrates how to rasterize a PDF document to PNG monochrome image format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngMonochromeColorFormat object.
        Dim pngColorFormat As PngMonochromeColorFormat  = New PngMonochromeColorFormat(DitheringAlgorithm.FloydSteinberg,100)

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat(pngColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngMonochromeColorFormat object.
        PngMonochromeColorFormat pngColorFormat = new PngMonochromeColorFormat(DitheringAlgorithm.FloydSteinberg,100);

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(pngColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngMonochromeColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngMonochromeColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngMonochromeColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngMonochromeColorFormat Class

The following tables list the members exposed by PngMonochromeColorFormat.

Public Constructors

 | Name | Description
Public Constructor | PngMonochromeColorFormat Constructor | Initializes a new instance of the PngMonochromeColorFormat class.
Top

Public Properties

 | Name | Description
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngMonochromeColorFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngMonochromeColorFormat Class : PngMonochromeColorFormat Constructor

ditheringAlgorithm
Specify a dithering algorithm .
ditheringPercent
Specify value of dithering in percentage .
Initializes a new instance of the PngMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal ditheringAlgorithm As DitheringAlgorithm, _
   ByVal ditheringPercent As Integer _
)
C#
public PngMonochromeColorFormat(
   DitheringAlgorithm ditheringAlgorithm,
   int ditheringPercent
)

Parameters

ditheringAlgorithm
Specify a dithering algorithm .
ditheringPercent
Specify value of dithering in percentage .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngMonochromeColorFormat Class
PngMonochromeColorFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngMonochromeColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngMonochromeColorFormat Class

For a list of all members of this type, see PngMonochromeColorFormat members.

Public Properties

 | Name | Description
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

See Also

Reference

PngMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngMonochromeColorFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngMonochromeColorFormat Class
PngMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PngMonochromeColorFormat Class : DitheringPercent Property

Gets or sets the value of dithering in percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngMonochromeColorFormat Class
PngMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbAColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbAColorFormat Class

Represents a RGBA color format supported by PNG.

Object Model

PngRgbAColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class PngRgbAColorFormat
   Inherits PngColorFormat
C#
public class PngRgbAColorFormat : PngColorFormat

Example

This example demonstrates how to rasterize a PDF document to PNG image in RGBA color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat( PngColorFormat.RgbA)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat( PngColorFormat.RgbA);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngRgbAColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngRgbAColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbAColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbAColorFormat Class

The following tables list the members exposed by PngRgbAColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngRgbAColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbColorFormat Class

Represents a RGB color format supported by PNG.

Object Model

PngRgbColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class PngRgbColorFormat
   Inherits PngColorFormat
C#
public class PngRgbColorFormat : PngColorFormat

Example

This example demonstrates how to rasterize a PDF document to PNG image in RGB color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a PngImageFormat object.
        Dim pngImageFormat As PngImageFormat = New PngImageFormat( PngColorFormat.Rgb)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngImageFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat( PngColorFormat.Rgb);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PngRgbColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbColorFormat Class

The following tables list the members exposed by PngRgbColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffColorFormat Class

Base class that represents an color format supported by TIFF image format. TiffColorFormat's derived classes are: TiffGrayscaleColorFormat, TiffMonochromeColorFormat, TiffRgbColorFormat, TiffRgbAColorFormat and TiffIndexedColorFormat.

Object Model

TiffColorFormat ClassTiffGrayscaleColorFormat ClassTiffIndexedColorFormat ClassTiffMonochromeColorFormat ClassTiffRgbColorFormat ClassTiffRgbAColorFormat Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class TiffColorFormat
C#
public abstract class TiffColorFormat

Remarks

TiffColorFormat's derived classes are: TiffGrayscaleColorFormat, TiffMonochromeColorFormat, TiffRgbColorFormat, TiffRgbAColorFormat and TiffIndexedColorFormat.

Example

This example demonstrates how to rasterize a PDF document to Tiff image using TiffColorFormat.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a FixedImageSize object with required width and height.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       'Create a TiffImageFormat object with rgb color.
       Dim oTiffImageFormat As New TiffImageFormat(TiffColorFormat.Rgb)

       ' Save the image.
       rasterizer.Draw("Output.tif", oTiffImageFormat, fixedImageSize)

    End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Create a FixedImageSize object with required width and height.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       //Create a TiffImageFormat object with rgb color.
       TiffImageFormat oTiffImageFormat = new TiffImageFormat(TiffColorFormat.Rgb);

       // Save the image.
       rasterizer.Draw("Output.tif", oTiffImageFormat, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffGrayscaleColorFormat
Foxit.PDF.Rasterizer.TiffIndexedColorFormat
Foxit.PDF.Rasterizer.TiffMonochromeColorFormat
Foxit.PDF.Rasterizer.TiffRgbAColorFormat
Foxit.PDF.Rasterizer.TiffRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffColorFormat Class

The following tables list the members exposed by TiffColorFormat.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Grayscale | Gets a default TiffGrayscaleColorFormat class.
static (Shared in Visual Basic) | Indexed | Gets a default TiffIndexedColorFormat class.
static (Shared in Visual Basic) | Monochrome | Gets a default TiffMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default TiffRgbColorFormat class.
static (Shared in Visual Basic) | RgbA | Gets a default TiffRgbAColorFormat class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffColorFormat Class

For a list of all members of this type, see TiffColorFormat members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Grayscale | Gets a default TiffGrayscaleColorFormat class.
static (Shared in Visual Basic) | Indexed | Gets a default TiffIndexedColorFormat class.
static (Shared in Visual Basic) | Monochrome | Gets a default TiffMonochromeColorFormat class.
static (Shared in Visual Basic) | Rgb | Gets a default TiffRgbColorFormat class.
static (Shared in Visual Basic) | RgbA | Gets a default TiffRgbAColorFormat class.
Top

See Also

Reference

TiffColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Grayscale Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffColorFormat Class : Grayscale Property

Gets a default TiffGrayscaleColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Grayscale As TiffGrayscaleColorFormat
C#
public static TiffGrayscaleColorFormat Grayscale {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Class
TiffColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Indexed Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffColorFormat Class : Indexed Property

Gets a default TiffIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Indexed As TiffIndexedColorFormat
C#
public static TiffIndexedColorFormat Indexed {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Class
TiffColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Monochrome Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffColorFormat Class : Monochrome Property

Gets a default TiffMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Monochrome As TiffMonochromeColorFormat
C#
public static TiffMonochromeColorFormat Monochrome {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Class
TiffColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Rgb Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffColorFormat Class : Rgb Property

Gets a default TiffRgbColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Rgb As TiffRgbColorFormat
C#
public static TiffRgbColorFormat Rgb {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Class
TiffColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
RgbA Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffColorFormat Class : RgbA Property

Gets a default TiffRgbAColorFormat class.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property RgbA As TiffRgbAColorFormat
C#
public static TiffRgbAColorFormat RgbA {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffColorFormat Class
TiffColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffGrayscaleColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffGrayscaleColorFormat Class

Represents a grayscale color format supported by TIFF.

Object Model

TiffGrayscaleColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class TiffGrayscaleColorFormat
   Inherits TiffColorFormat
C#
public class TiffGrayscaleColorFormat : TiffColorFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image in grayscale color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(TiffColorFormat.Grayscale)

        ' Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(TiffColorFormat.Grayscale);

        // Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffGrayscaleColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffGrayscaleColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffGrayscaleColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffGrayscaleColorFormat Class

The following tables list the members exposed by TiffGrayscaleColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffGrayscaleColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffImageFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffImageFormat Class

Represents a TIFF image format

Object Model

TiffImageFormat ClassTiffColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class TiffImageFormat
   Inherits ImageFormat
C#
public class TiffImageFormat : ImageFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(TiffColorFormat.Rgb)

        ' Create a PercentageImageSize object.
        Dim percentageImageSize As PercentageImageSize = New PercentageImageSize(50)

        ' Save the image.
        rasterizer.Draw("Output.tif", tiffImageFormat, percentageImageSize)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(TiffColorFormat.Rgb);

        // Create a PercentageImageSize object.
        PercentageImageSize percentageImageSize = new PercentageImageSize(50);

        // Save the image.
        rasterizer.Draw("Output.tif", tiffImageFormat,percentageImageSize);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.TiffImageFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffImageFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffImageFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffImageFormat Class

The following tables list the members exposed by TiffImageFormat.

Public Constructors

 | Name | Description
Public Constructor | TiffImageFormat Constructor | Initializes a new instance of the class.TiffImageFormat
Top

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the Tiff color format.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffImageFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffImageFormat Class : TiffImageFormat Constructor

colorFormat
Color format of the tiff image.
Initializes a new instance of the class.TiffImageFormat

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorFormat As TiffColorFormat _
)
C#
public TiffImageFormat(
   TiffColorFormat colorFormat
)

Parameters

colorFormat
Color format of the tiff image.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffImageFormat Class
TiffImageFormat Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffImageFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffImageFormat Class

For a list of all members of this type, see TiffImageFormat members.

Public Properties

 | Name | Description
Public Property | AntiAliasing | Gets or Sets the AntiAliasing value. (Inherited from Foxit.PDF.Rasterizer.ImageFormat)
Public Property | ColorFormat | Gets or sets the Tiff color format.
Top

See Also

Reference

TiffImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorFormat Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffImageFormat Class : ColorFormat Property

Gets or sets the Tiff color format.

Syntax

Visual Basic (Declaration)
Public Property ColorFormat As TiffColorFormat
C#
public TiffColorFormat ColorFormat {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffImageFormat Class
TiffImageFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffIndexedColorFormat Class

Represents a indexed color format supported by TIFF.

Object Model

TiffIndexedColorFormat ClassPalette Class

Syntax

Visual Basic (Declaration)
Public Class TiffIndexedColorFormat
   Inherits TiffColorFormat
C#
public class TiffIndexedColorFormat : TiffColorFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image in indexed color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a instance of TiffIndexedColorFormat class.
        Dim tiffColorFormat As TiffIndexedColorFormat  = New TiffIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 90)
        tiffColorFormat.ColorPalette = Palette.WebPalette

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(tiffColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a instance of TiffIndexedColorFormat class.
        TiffIndexedColorFormat tiffColorFormat = new TiffIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 90);
        tiffColorFormat.ColorPalette = Palette.WebPalette;

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(tiffColorFormat);

        // Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffIndexedColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffIndexedColorFormat Class

The following tables list the members exposed by TiffIndexedColorFormat.

Public Constructors

 | Name | Description
Public Constructor | TiffIndexedColorFormat Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class : TiffIndexedColorFormat Constructor

Overload List

Overload | Description
TiffIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm) | Initializes a new instance of the TiffIndexedColorFormat class.
TiffIndexedColorFormat Constructor(Palette,Int32) | Initializes a new instance of the TiffIndexedColorFormat class.
TiffIndexedColorFormat Constructor(Palette) | Initializes a new instance of the TiffIndexedColorFormat class.
TiffIndexedColorFormat Constructor() | Initializes a new instance of the TiffIndexedColorFormat class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class > TiffIndexedColorFormat Constructor : TiffIndexedColorFormat Constructor(Palette,Int32,DitheringAlgorithm)

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage .
ditheringAlgorithm
Specify a dithering algorithm .
Initializes a new instance of the TiffIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer, _
   ByVal ditheringAlgorithm As DitheringAlgorithm _
)
C#
public TiffIndexedColorFormat(
   Palette colorPalette,
   int ditheringPercent,
   DitheringAlgorithm ditheringAlgorithm
)

Parameters

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage .
ditheringAlgorithm
Specify a dithering algorithm .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Constructor(Palette,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class > TiffIndexedColorFormat Constructor : TiffIndexedColorFormat Constructor(Palette,Int32)

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage.
Initializes a new instance of the TiffIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette, _
   ByVal ditheringPercent As Integer _
)
C#
public TiffIndexedColorFormat(
   Palette colorPalette,
   int ditheringPercent
)

Parameters

colorPalette
Specify a color palette.
ditheringPercent
Specify value of dithering in percentage.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Constructor(Palette) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class > TiffIndexedColorFormat Constructor : TiffIndexedColorFormat Constructor(Palette)

colorPalette
Specify a color palette.
Initializes a new instance of the TiffIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal colorPalette As Palette _
)
C#
public TiffIndexedColorFormat(
   Palette colorPalette
)

Parameters

colorPalette
Specify a color palette.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Constructor() | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class > TiffIndexedColorFormat Constructor : TiffIndexedColorFormat Constructor()

Initializes a new instance of the TiffIndexedColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public TiffIndexedColorFormat()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffIndexedColorFormat Class

For a list of all members of this type, see TiffIndexedColorFormat members.

Public Properties

 | Name | Description
Public Property | ColorPalette | Gets or sets a palette type.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

See Also

Reference

TiffIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ColorPalette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class : ColorPalette Property

Gets or sets a palette type.

Syntax

Visual Basic (Declaration)
Public Property ColorPalette As Palette
C#
public Palette ColorPalette {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffIndexedColorFormat Class : DitheringPercent Property

Gets or sets the value of dithering in percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffIndexedColorFormat Class
TiffIndexedColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffMonochromeColorFormat Class

Represents a monochrome color format supported by TIFF.

Object Model

TiffMonochromeColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class TiffMonochromeColorFormat
   Inherits TiffColorFormat
C#
public class TiffMonochromeColorFormat : TiffColorFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image in monochrome color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a instance of TiffMonochromeColorFormat class.
        Dim tiffColorFormat As TiffMonochromeColorFormat  = New TiffMonochromeColorFormat(TiffMonochromeCompressionType.CcitGroup4)
        tiffColorFormat.DitheringAlgorithm = DitheringAlgorithm.FloydSteinberg
        tiffColorFormat.DitheringPercent = 75

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(tiffColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a instance of TiffMonochromeColorFormat class.
        TiffMonochromeColorFormat tiffColorFormat = new TiffMonochromeColorFormat(TiffMonochromeCompressionType.CcitGroup4);
        tiffColorFormat.DitheringAlgorithm = DitheringAlgorithm.FloydSteinberg;
        tiffColorFormat.DitheringPercent = 75;

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(tiffColorFormat);

        // Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffMonochromeColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffMonochromeColorFormat Class

The following tables list the members exposed by TiffMonochromeColorFormat.

Public Constructors

 | Name | Description
Public Constructor | TiffMonochromeColorFormat Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CompressionType | Gets or sets the compression type for TIFF monochrome image format.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class : TiffMonochromeColorFormat Constructor

Overload List

Overload | Description
TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType,DitheringAlgorithm,Int32) | Initializes a new instance of the TiffMonochromeColorFormat class.
TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType) | Initializes a new instance of the TiffMonochromeColorFormat class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType,DitheringAlgorithm,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class > TiffMonochromeColorFormat Constructor : TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType,DitheringAlgorithm,Int32)

compressionType
Specify a compression type.
ditheringAlgorithm
Specify a dithering algorithm .
ditheringPercent
Specify value of dithering in percentage .
Initializes a new instance of the TiffMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compressionType As TiffMonochromeCompressionType, _
   ByVal ditheringAlgorithm As DitheringAlgorithm, _
   ByVal ditheringPercent As Integer _
)
C#
public TiffMonochromeColorFormat(
   TiffMonochromeCompressionType compressionType,
   DitheringAlgorithm ditheringAlgorithm,
   int ditheringPercent
)

Parameters

compressionType
Specify a compression type.
ditheringAlgorithm
Specify a dithering algorithm .
ditheringPercent
Specify value of dithering in percentage .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType) | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class > TiffMonochromeColorFormat Constructor : TiffMonochromeColorFormat Constructor(TiffMonochromeCompressionType)

compressionType
Specify a compression type.
Initializes a new instance of the TiffMonochromeColorFormat class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal compressionType As TiffMonochromeCompressionType _
)
C#
public TiffMonochromeColorFormat(
   TiffMonochromeCompressionType compressionType
)

Parameters

compressionType
Specify a compression type.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffMonochromeColorFormat Class

For a list of all members of this type, see TiffMonochromeColorFormat members.

Public Properties

 | Name | Description
Public Property | CompressionType | Gets or sets the compression type for TIFF monochrome image format.
Public Property | DitheringAlgorithm | Gets or sets a dithering algorithm.
Public Property | DitheringPercent | Gets or sets the value of dithering in percentage.
Top

See Also

Reference

TiffMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
CompressionType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class : CompressionType Property

Gets or sets the compression type for TIFF monochrome image format.

Syntax

Visual Basic (Declaration)
Public Property CompressionType As TiffMonochromeCompressionType
C#
public TiffMonochromeCompressionType CompressionType {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class : DitheringAlgorithm Property

Gets or sets a dithering algorithm.

Syntax

Visual Basic (Declaration)
Public Property DitheringAlgorithm As DitheringAlgorithm
C#
public DitheringAlgorithm DitheringAlgorithm {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > TiffMonochromeColorFormat Class : DitheringPercent Property

Gets or sets the value of dithering in percentage.

Syntax

Visual Basic (Declaration)
Public Property DitheringPercent As Integer
C#
public int DitheringPercent {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffMonochromeColorFormat Class
TiffMonochromeColorFormat Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbAColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbAColorFormat Class

Represents a RGBA color format supported by TIFF.

Object Model

TiffRgbAColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class TiffRgbAColorFormat
   Inherits TiffColorFormat
C#
public class TiffRgbAColorFormat : TiffColorFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image in RGBA color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(TiffColorFormat.RgbA)

        ' Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(TiffColorFormat.RgbA);

        // Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffRgbAColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffRgbAColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbAColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbAColorFormat Class

The following tables list the members exposed by TiffRgbAColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffRgbAColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbColorFormat Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbColorFormat Class

Represents a RGB color format supported by TIFF.

Object Model

TiffRgbColorFormat Class

Syntax

Visual Basic (Declaration)
Public Class TiffRgbColorFormat
   Inherits TiffColorFormat
C#
public class TiffRgbColorFormat : TiffColorFormat

Example

This example demonstrates how to rasterize a PDF document to TIFF image in RGB color format.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a TiffImageFormat object.
        Dim tiffImageFormat As TiffImageFormat = New TiffImageFormat(TiffColorFormat.Rgb)

        ' Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a TiffImageFormat object.
        TiffImageFormat tiffImageFormat = new TiffImageFormat(TiffColorFormat.Rgb);

        // Save the image.
        rasterizer.Draw("Output.tiff", tiffImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffRgbColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TiffRgbColorFormat Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbColorFormat Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbColorFormat Class

The following tables list the members exposed by TiffRgbColorFormat.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UnitConverter Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UnitConverter Class

Utility for converting to and from typesetting points.

Object Model

UnitConverter Class

Syntax

Visual Basic (Declaration)
Public Class UnitConverter
C#
public class UnitConverter

Licensing

This class is a Foxit PDF Rasterizer feature. The following license is required for non-evaluation usage:
  • Foxit PDF Rasterizer for .NET SDK

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.UnitConverter

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UnitConverter Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UnitConverter Class

The following tables list the members exposed by UnitConverter.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
static (Shared in Visual Basic) | InchesToPoints | Converts from inches to typesetting points.
static (Shared in Visual Basic) | MillimetersToPoints | Converts from millimeters to typesetting points.
static (Shared in Visual Basic) | PointsToInches | Converts from typesetting points to inches.
static (Shared in Visual Basic) | PointsToMillimeters | Converts from typesetting points to millimeters.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UnitConverter Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UnitConverter Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UnitConverter Class

For a list of all members of this type, see UnitConverter members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
static (Shared in Visual Basic) | InchesToPoints | Converts from inches to typesetting points.
static (Shared in Visual Basic) | MillimetersToPoints | Converts from millimeters to typesetting points.
static (Shared in Visual Basic) | PointsToInches | Converts from typesetting points to inches.
static (Shared in Visual Basic) | PointsToMillimeters | Converts from typesetting points to millimeters.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UnitConverter Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InchesToPoints Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UnitConverter Class : InchesToPoints Method

size
Size in inches.
Converts from inches to typesetting points.

Syntax

Visual Basic (Declaration)
Public Shared Function InchesToPoints( _
   ByVal size As Double _
) As Double
C#
public static double InchesToPoints(
   double size
)

Parameters

size
Size in inches.

Return Value

The size in inches.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MillimetersToPoints Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UnitConverter Class : MillimetersToPoints Method

size
Size in millimeters.
Converts from millimeters to typesetting points.

Syntax

Visual Basic (Declaration)
Public Shared Function MillimetersToPoints( _
   ByVal size As Double _
) As Double
C#
public static double MillimetersToPoints(
   double size
)

Parameters

size
Size in millimeters.

Return Value

The size in typesetting points.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PointsToInches Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UnitConverter Class : PointsToInches Method

size
Size in points.
Converts from typesetting points to inches.

Syntax

Visual Basic (Declaration)
Public Shared Function PointsToInches( _
   ByVal size As Double _
) As Double
C#
public static double PointsToInches(
   double size
)

Parameters

size
Size in points.

Return Value

The size in inches.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PointsToMillimeters Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UnitConverter Class : PointsToMillimeters Method

size
Size in points.
Converts from typesetting points to millimeters.

Syntax

Visual Basic (Declaration)
Public Shared Function PointsToMillimeters( _
   ByVal size As Double _
) As Double
C#
public static double PointsToMillimeters(
   double size
)

Parameters

size
Size in points.

Return Value

The size in typesetting points.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UserPalette Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UserPalette Class

Represents a UserPalette class which can be used to specify a color palette.

Object Model

UserPalette Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class UserPalette
   Inherits Palette
C#
[DefaultMemberAttribute("Item")]
public class UserPalette : Palette

Example

This example demonstrates how to rasterize a PDF document to PNG image with a user palette.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        Dim pngIndexedColorFormat As PngIndexedColorFormat  = New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100)

        Dim color() As System.Drawing.Color = New System.Drawing.Color() {System.Drawing.Color.FromArgb(255, 0, 0, 0), System.Drawing.Color.FromArgb(255, 255, 255, 255), System.Drawing.Color.FromArgb(255, 255, 0, 0), System.Drawing.Color.FromArgb(255, 0, 255, 0), System.Drawing.Color.FromArgb(255, 0, 0, 255), System.Drawing.Color.FromArgb(255, 255, 255, 0), System.Drawing.Color.FromArgb(255, 0, 255, 255)}
        Dim userpalette As UserPalette  = New UserPalette(color)

        ' Set a user selected color palette.
        pngIndexedColorFormat.ColorPalette = userpalette
        Dim pngImageFormat As PngImageFormat  = New PngImageFormat(pngIndexedColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100);

        System.Drawing.Color[] color = new System.Drawing.Color[] { System.Drawing.Color.FromArgb(255,0,0,0),System.Drawing.Color.FromArgb(255,255,255,255),System.Drawing.Color.FromArgb(255,255,0,0),System.Drawing.Color.FromArgb(255,0,255,0),System.Drawing.Color.FromArgb(255,0,0,255),System.Drawing.Color.FromArgb(255,255,255,0),System.Drawing.Color.FromArgb(255,0,255,255),System.Drawing.Color.FromArgb(255,255,0,255)};
        UserPalette userpalette = new UserPalette(color);

        // Set a user selected color palette.
        pngIndexedColorFormat.ColorPalette = userpalette;

        PngImageFormat pngImageFormat = new PngImageFormat(pngIndexedColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.UserPalette

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UserPalette Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UserPalette Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UserPalette Class

The following tables list the members exposed by UserPalette.

Public Constructors

 | Name | Description
Public Constructor | UserPalette Constructor | Initializes a new instance of the UserPalette class.
Top

Public Properties

 | Name | Description
Public Property | Item | Gets or sets color at specific index.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UserPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UserPalette Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UserPalette Class : UserPalette Constructor

palette
A color palette.
Initializes a new instance of the UserPalette class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal palette() As Color _
)
C#
public UserPalette(
   Color[] palette
)

Parameters

palette
A color palette.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UserPalette Class
UserPalette Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UserPalette Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UserPalette Class

For a list of all members of this type, see UserPalette members.

Public Properties

 | Name | Description
Public Property | Item | Gets or sets color at specific index.
Top

See Also

Reference

UserPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > UserPalette Class : Item Property

index
Gets or sets color at specific index.

Syntax

Visual Basic (Declaration)
Public Default Property Item( _
   ByVal index As Integer _
) As Color
C#
public Color this[
   int index
]; {get; set;}

Parameters

index

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UserPalette Class
UserPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WebPalette Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WebPalette Class

Represents a Web palette.

Object Model

WebPalette Class

Syntax

Visual Basic (Declaration)
Public Class WebPalette
   Inherits Palette
C#
public class WebPalette : Palette

Example

This example demonstrates how to rasterize a PDF document to PNG image with Web palette.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        Dim pngIndexedColorFormat As PngIndexedColorFormat  = New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100)
        pngIndexedColorFormat.ColorPalette = Palette.WebPalette

        Dim pngImageFormat As PngImageFormat  = New PngImageFormat(pngIndexedColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100);
        pngIndexedColorFormat.ColorPalette = Palette.WebPalette;

        PngImageFormat pngImageFormat = new PngImageFormat(pngIndexedColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.WebPalette

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

WebPalette Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WebPalette Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WebPalette Class

The following tables list the members exposed by WebPalette.

Public Constructors

 | Name | Description
Public Constructor | WebPalette Constructor | Initializes a new instance of the WebPalette class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

WebPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WebPalette Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > WebPalette Class : WebPalette Constructor

Initializes a new instance of the WebPalette class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WebPalette()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

WebPalette Class
WebPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WindowsPalette Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WindowsPalette Class

Represents a Windows palette.

Object Model

WindowsPalette Class

Syntax

Visual Basic (Declaration)
Public Class WindowsPalette
   Inherits Palette
C#
public class WindowsPalette : Palette

Example

This example demonstrates how to rasterize a PDF document to PNG image with Windows palette.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()

        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        Dim pngIndexedColorFormat As PngIndexedColorFormat  = New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100)
        pngIndexedColorFormat.ColorPalette = Palette.WindowsPalette

        Dim pngImageFormat As PngImageFormat  = New PngImageFormat(pngIndexedColorFormat)

        ' Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72)

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100);
        pngIndexedColorFormat.ColorPalette = Palette.WindowsPalette;

        PngImageFormat pngImageFormat = new PngImageFormat(pngIndexedColorFormat);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, ImageSize.Dpi72);
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.WindowsPalette

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

WindowsPalette Members
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WindowsPalette Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WindowsPalette Class

The following tables list the members exposed by WindowsPalette.

Public Constructors

 | Name | Description
Public Constructor | WindowsPalette Constructor | Initializes a new instance of the WindowsPalette class.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

WindowsPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WindowsPalette Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > WindowsPalette Class : WindowsPalette Constructor

Initializes a new instance of the WindowsPalette class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public WindowsPalette()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

WindowsPalette Class
WindowsPalette Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BitmapColorFormat Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BitmapColorFormat Enumeration

Represents Bitmap color formats.

Syntax

Visual Basic (Declaration)
Public Enum BitmapColorFormat
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum BitmapColorFormat : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Grayscale | Color format Grayscale.
Monochrome | Color format Monochrome.
Rgb | Color format Rgb.
RgbA | Color format RgbA.

Example

This example demonstrates the use of BitmapColorFormat class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

    Sub Main()
        ' Create a PdfRasterizer object.
        Dim rasterizer As PdfRasterizer = New PdfRasterizer("InputPdfFile.pdf")

        ' Create a FixedImageSize object with required width,height and UnitType.
        Dim fixedImageSize As FixedImageSize = New FixedImageSize(595, 841, UnitType.Point)

        ' Get the Bitmap.
        Dim bmp As System.Drawing.Bitmap = rasterizer.Pages(0).DrawToBitmap(BitmapColorFormat.Grayscale, fixedImageSize)

        ' Save the image.
        bmp.Save("Output.gif")

    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
    static void Main(string[] args)
    {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a FixedImageSize object with required width,height and UnitType.
        FixedImageSize fixedImageSize = new FixedImageSize(595, 841, UnitType.Point);

        // Get the Bitmap.
        System.Drawing.Bitmap bmp = rasterizer.Pages[0].DrawToBitmap(BitmapColorFormat.Grayscale, fixedImageSize);

        // Save the image.
        bmp.Save("Output.gif");
    }

}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Rasterizer.BitmapColorFormat

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DitheringAlgorithm Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DitheringAlgorithm Enumeration

Represents different dithering algorithms.

Syntax

Visual Basic (Declaration)
Public Enum DitheringAlgorithm
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum DitheringAlgorithm : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Bayer | Bayer's pattern based algorithm.
FloydSteinberg | Floyd-Steinberg diffusion kind of algorithm.

Example

This example demonstrates how to rasterize a PDF document to Gif image using FloydSteinberg dithering.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

Sub Main()
    'Create a PdfRasterizer object.
    Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

    'Create a GifImageFormat object.
    Dim gifImageFormat As New GifImageFormat()

    'Set the DitheringAlgorithm to FloydSteinberg.
    gifImageFormat.DitheringAlgorithm = DitheringAlgorithm.FloydSteinberg

    'Set the size.
    Dim fixedImageSize As New FixedImageSize(595, 841)

    'Save the image.
    rasterizer.Draw("Output.Gif", gifImageFormat, fixedImageSize)

End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
 static void Main(string[] args)
 {
     //Create a PdfRasterizer object.
     PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

     //Create a GifImageFormat object.
     GifImageFormat gifImageFormat = new GifImageFormat();

     //Set the DitheringAlgorithm to FloydSteinberg.
     gifImageFormat.DitheringAlgorithm = DitheringAlgorithm.FloydSteinberg;

     //Set the size.
     FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

     //Save the image.
     rasterizer.Draw("Output.Gif", gifImageFormat, fixedImageSize);
 }

}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Rasterizer.DitheringAlgorithm

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
QuantizationAlgorithm Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : QuantizationAlgorithm Enumeration

Represents different kind of quantization methods.

Syntax

Visual Basic (Declaration)
Public Enum QuantizationAlgorithm
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum QuantizationAlgorithm : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
MedianCut | Represents MedianCut type of quantization.
Octree | Represents Octree type of quantization.

Example

This example demonstrates the usage of QuantizationAlgorithm enum in indexed image creation.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

   Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a PngIndexedColorFormat object.
       Dim pngIndexedColorFormat As New PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100)

       ' Set the Colorpalette property to AutoPalette.
       pngIndexedColorFormat.ColorPalette = New AutoPalette(QuantizationAlgorithm.Octree, 256)

       ' Create a PngImageFormat using PngIndexedColorFormat object.
       Dim pngImageFormat As New PngImageFormat(pngIndexedColorFormat)

       ' Set the size.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       ' Save the image.
       rasterizer.Draw("Output.png", pngImageFormat, fixedImageSize)

   End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
        // Create a PdfRasterizer object.
        PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

        // Create a PngIndexedColorFormat object.
        PngIndexedColorFormat pngIndexedColorFormat = new PngIndexedColorFormat(DitheringAlgorithm.FloydSteinberg, 100);

        // Set the Colorpalette property to AutoPalette.
        pngIndexedColorFormat.ColorPalette = new AutoPalette(QuantizationAlgorithm.Octree, 256);

        // Create a PngImageFormat using PngIndexedColorFormat object.
        PngImageFormat pngImageFormat = new PngImageFormat(pngIndexedColorFormat);

        // Set the size.
        FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

        // Save the image.
        rasterizer.Draw("Output.png", pngImageFormat, fixedImageSize);

   }

}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Rasterizer.QuantizationAlgorithm

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeCompressionType Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffMonochromeCompressionType Enumeration

Represents compression formats supported by TIFF monochrome format.

Syntax

Visual Basic (Declaration)
Public Enum TiffMonochromeCompressionType
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum TiffMonochromeCompressionType : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
CcitGroup3 | Compression of type CCIT Group3.
CcitGroup4 | Compression of type CCIT Group4.

Example

This example demonstrates how to rasterize a PDF document to TIFF Monochromeimage with CcitGroup4 Compression.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

   Sub Main()

       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a FixedImageSize object with required width and height.
       Dim fixedImageSize As New FixedImageSize(595, 841)

       'Create a TiffMonochromeColorFormat object with CcitGroup3 compression.
       Dim oTiffColorFormat As TiffColorFormat = New TiffMonochromeColorFormat(TiffMonochromeCompressionType.CcitGroup4)

       'Create a TiffImageFormat object with monocrome color.
       Dim oTiffImageFormat As New TiffImageFormat(oTiffColorFormat)

       ' Save the image.
       rasterizer.Draw("Output.tif", oTiffImageFormat, fixedImageSize)

   End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Create a FixedImageSize object with required width and height.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841);

       //Create a TiffMonochromeColorFormat object with CcitGroup3 compression.
       TiffColorFormat oTiffColorFormat = new TiffMonochromeColorFormat(TiffMonochromeCompressionType.CcitGroup4);

       //Create a TiffImageFormat object with monocrome color.
       TiffImageFormat oTiffImageFormat = new TiffImageFormat(oTiffColorFormat);

       // Save the image.
       rasterizer.Draw("Output.tif", oTiffImageFormat, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Rasterizer.TiffMonochromeCompressionType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UnitType Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UnitType Enumeration

Represents a UnitType value.

Syntax

Visual Basic (Declaration)
Public Enum UnitType
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum UnitType : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Inch | Unit values in Inches.
Millimeter | Unit values in Millimeters.
Point | Unit values in Typesetting Points.

Example

This example demonstrates the use of UnitType class.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Rasterizer

Module MyModule

   Sub Main()
       ' Create a PdfRasterizer object.
       Dim rasterizer As New PdfRasterizer("InputPdfFile.pdf")

       ' Create a FixedImageSize object with required width,height and UnitType.
       Dim fixedImageSize As New FixedImageSize(595, 841, UnitType.Point)

       ' Save the image.
       rasterizer.Draw("Output.gif", ImageFormat.Gif, fixedImageSize)

   End Sub

End Module
C# Copy Code
using System;
using Foxit.PDF.Rasterizer;

class MyClass
{
   static void Main(string[] args)
   {
       // Create a PdfRasterizer object.
       PdfRasterizer rasterizer = new PdfRasterizer("InputPdfFile.pdf");

       // Create a FixedImageSize object with required width,height and UnitType.
       FixedImageSize fixedImageSize = new FixedImageSize(595, 841, UnitType.Point);

       // Save the image.
       rasterizer.Draw("Output.gif", ImageFormat.Gif, fixedImageSize);
   }

}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Rasterizer.UnitType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Rasterizer Namespace


%%ItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Compatibility Considerations | Comments on this topic

Glossary Item Box

Foxit PDF Rasterizer V1 and V2:

In Rasterizer v1, there were no quantization and dithering options for the GIF image format. Therefore, in version 1 of Rasterizer, the default GIF image was created using an RGB 24-bit image data passed into the System.Drawing.Bitmap class.

However, since Rasterizer v2 has introduced quantization and dithering options, the default GIF image will now use the Auto color palette, a dithering algorithm of Floyd-Steinberg and a dithering percentage of 25%. This results in a better image quality output GIF.


%%phrase%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Foxit.PDF.Rasterizer Assembly | Comments on this topic
See Also

Namespaces

Namespace | Description
Foxit.PDF.Rasterizer |


$$GETTING_STARTED$$ - %%projecttitle%%

Foxit Software Help Library for .NET - May 2013
Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Foxit Software Help Library for .NET - May 2013
Introduction
Send Feedback


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
AutoPalette Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : AutoPalette Class

For a list of all members of this type, see AutoPalette members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

AutoPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpColorFormat Class

For a list of all members of this type, see BmpColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpImageFormat Class

For a list of all members of this type, see BmpImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpMonochromeColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpMonochromeColorFormat Class

For a list of all members of this type, see BmpMonochromeColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
BmpRgbColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : BmpRgbColorFormat Class

For a list of all members of this type, see BmpRgbColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BmpRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DocumentLoadException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DocumentLoadException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
DpiImageSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : DpiImageSize Class

For a list of all members of this type, see DpiImageSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DpiImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
FixedImageSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : FixedImageSize Class

For a list of all members of this type, see FixedImageSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FixedImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
GifImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : GifImageFormat Class

For a list of all members of this type, see GifImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

GifImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageFormat Class

For a list of all members of this type, see ImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
ImageSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : ImageSize Class

For a list of all members of this type, see ImageSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPageList Class : Dispose Method

Overload List

Overload | Description
Dispose |

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdfPage Class : Dispose Method

Overload List

Overload | Description
Dispose |

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > InputPdf Class : Dispose Method

Overload List

Overload | Description
Dispose |

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InvalidPasswordException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
InvalidPasswordException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
JpegImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : JpegImageFormat Class

For a list of all members of this type, see JpegImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

JpegImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
LicensingException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
LicensingException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
MaxImageSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : MaxImageSize Class

For a list of all members of this type, see MaxImageSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MaxImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Palette Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : Palette Class

For a list of all members of this type, see Palette members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Palette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerException Class

For a list of all members of this type, see PdfRasterizerException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfRasterizerException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PdfRasterizerException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PdfRasterizerException Class

For a list of all members of this type, see PdfRasterizerException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfRasterizerException Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizerPageList Class : Dispose Method

Overload List

Overload | Description
Dispose |

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizerPageList Class
PdfRasterizerPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace > PdfRasterizer Class : Dispose Method

Overload List

Overload | Description
Dispose |

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfRasterizer Class
PdfRasterizer Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PercentageImageSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PercentageImageSize Class

For a list of all members of this type, see PercentageImageSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PercentageImageSize Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngColorFormat Class

For a list of all members of this type, see PngColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngGrayscaleColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngGrayscaleColorFormat Class

For a list of all members of this type, see PngGrayscaleColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngGrayscaleColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngImageFormat Class

For a list of all members of this type, see PngImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngIndexedColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngIndexedColorFormat Class

For a list of all members of this type, see PngIndexedColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngMonochromeColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngMonochromeColorFormat Class

For a list of all members of this type, see PngMonochromeColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbAColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbAColorFormat Class

For a list of all members of this type, see PngRgbAColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngRgbAColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
PngRgbColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : PngRgbColorFormat Class

For a list of all members of this type, see PngRgbColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PngRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffColorFormat Class

For a list of all members of this type, see TiffColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffGrayscaleColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffGrayscaleColorFormat Class

For a list of all members of this type, see TiffGrayscaleColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffGrayscaleColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffImageFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffImageFormat Class

For a list of all members of this type, see TiffImageFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffImageFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffIndexedColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffIndexedColorFormat Class

For a list of all members of this type, see TiffIndexedColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffIndexedColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffMonochromeColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffMonochromeColorFormat Class

For a list of all members of this type, see TiffMonochromeColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffMonochromeColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbAColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbAColorFormat Class

For a list of all members of this type, see TiffRgbAColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffRgbAColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
TiffRgbColorFormat Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : TiffRgbColorFormat Class

For a list of all members of this type, see TiffRgbColorFormat members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TiffRgbColorFormat Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
UserPalette Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : UserPalette Class

For a list of all members of this type, see UserPalette members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UserPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WebPalette Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WebPalette Class

For a list of all members of this type, see WebPalette members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

WebPalette Class
Foxit.PDF.Rasterizer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
WindowsPalette Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Rasterizer Assembly > Foxit.PDF.Rasterizer Namespace : WindowsPalette Class

For a list of all members of this type, see WindowsPalette members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

WindowsPalette Class
Foxit.PDF.Rasterizer Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Foxit Software Help Library for .NET - May 2013 | Foxit Software
Foxit.PDF.Rasterizer Namespace Inheritance Hierarchy | Comments on this topic
See Also
Foxit.PDF.Rasterizer Assembly : Foxit.PDF.Rasterizer Namespace

Inheritance Hierarchy

System.Object
Foxit.PDF.Rasterizer.BmpColorFormat
Foxit.PDF.Rasterizer.BmpMonochromeColorFormat
Foxit.PDF.Rasterizer.BmpRgbColorFormat
Foxit.PDF.Rasterizer.ImageFormat
Foxit.PDF.Rasterizer.BmpImageFormat
Foxit.PDF.Rasterizer.GifImageFormat
Foxit.PDF.Rasterizer.JpegImageFormat
Foxit.PDF.Rasterizer.PngImageFormat
Foxit.PDF.Rasterizer.TiffImageFormat
Foxit.PDF.Rasterizer.ImageSize
Foxit.PDF.Rasterizer.DpiImageSize
Foxit.PDF.Rasterizer.FixedImageSize
Foxit.PDF.Rasterizer.MaxImageSize
Foxit.PDF.Rasterizer.PercentageImageSize
Foxit.PDF.Rasterizer.InputPdf
Foxit.PDF.Rasterizer.InputPdfPage
Foxit.PDF.Rasterizer.InputPdfPageList
Foxit.PDF.Rasterizer.Palette
Foxit.PDF.Rasterizer.AutoPalette
Foxit.PDF.Rasterizer.UserPalette
Foxit.PDF.Rasterizer.WebPalette
Foxit.PDF.Rasterizer.WindowsPalette
Foxit.PDF.Rasterizer.PdfRasterizer
Foxit.PDF.Rasterizer.PdfRasterizerPage
Foxit.PDF.Rasterizer.PdfRasterizerPageList
Foxit.PDF.Rasterizer.PngColorFormat
Foxit.PDF.Rasterizer.PngGrayscaleColorFormat
Foxit.PDF.Rasterizer.PngIndexedColorFormat
Foxit.PDF.Rasterizer.PngMonochromeColorFormat
Foxit.PDF.Rasterizer.PngRgbAColorFormat
Foxit.PDF.Rasterizer.PngRgbColorFormat
Foxit.PDF.Rasterizer.TiffColorFormat
Foxit.PDF.Rasterizer.TiffGrayscaleColorFormat
Foxit.PDF.Rasterizer.TiffIndexedColorFormat
Foxit.PDF.Rasterizer.TiffMonochromeColorFormat
Foxit.PDF.Rasterizer.TiffRgbAColorFormat
Foxit.PDF.Rasterizer.TiffRgbColorFormat
Foxit.PDF.Rasterizer.UnitConverter
System.Exception
Foxit.PDF.Rasterizer.LicensingException
Foxit.PDF.Rasterizer.PdfRasterizerException
Foxit.PDF.Rasterizer.DocumentLoadException
Foxit.PDF.Rasterizer.InvalidPasswordException

See Also

Reference

Foxit.PDF.Rasterizer Assembly