%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Welcome | Comments on this topic
See Also

Glossary Item Box

Foxit PDF SDK for .NET

This document contains help for Foxit PDF PrintManager for .NET SDK.

For the complete Class Library Reference click on the link below:

  • Reference Section

Please feel free to contact us with any questions you may have about our products.

Foxit Software
Foxit Corporation
42840 Christy Street, Suite 201
Fremont, CA 94538
USA

http://www.foxitsoftware.com

Sales E-Mail
Support E-Mail

Sales Telephone: 1-866-680-3668 (24/7)
Support & General: 1-866-MYFOXIT or 1-866-693-6948(24/7)
Fax: 510-405-9288

See Also

Foxit PDF PrintManager for .NET SDK

© Copyright 2013, Foxit Software


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit PDF PrintManager for .NET SDK | Comments on this topic
See Also

Glossary Item Box

Foxit PDF SDK for .NET

Foxit PDF PrintManager is an easy to use component for dynamically sending PDF documents to be printed. Now from within any .NET application you can manage print jobs, verify printer settings and handle successful or unsuccessful prints all from within our easy to use API.

Foxit PDF PrintManager Namespaces

The Foxit PDF PrintManager for .NET SDK utilizes the below namespaces.

  • Foxit.PDF.Printing

Further Reading

Getting Started
Topics on getting started with Foxit PDF PrintManager.
Programming With Foxit PDF PrintManager
Introduces how to program with Foxit PDF PrintManager.
Foxit PDF PrintManager Class Library
Detailed reference of the Foxit PDF PrintManager Class Library.

See Also

Getting Started
Programming with Foxit PDF PrintManager


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Getting Started | Comments on this topic
See Also
Foxit PDF PrintManager for .NET SDK > Getting Started

Glossary Item Box

In This Section

Product Evaluation
Includes details on evaluating the product.
Features
Details the features available within the product.
Product Limitations
Explains limitations of the product.
Examples
Lists the examples that are included with the product.

See Also

Overview


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Product Evaluation | Comments on this topic
See Also
Foxit PDF PrintManager for .NET SDK > Getting Started > Product Evaluation

Glossary Item Box

The full and complete version of Foxit PDF PrintManager for .NET SDK is free to download at any time from the Foxit Software website, http://www.foxitsoftware.com. This download will allow anyone to evaluate all the features and functions of the PrintManager API and will never expire. The only limitation is that a watermark will be displayed on any PDF documents that are sent to the printer. Removing the watermark is as simple as purchasing the appropriate product and adding a license key to your application. This allows customers to fully evaluate all the product features while providing a seamless integration from evaluation into testing and production.

See Also

Features
Deployment


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Features | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Getting Started > Features

Glossary Item Box

Below is a list of the main features of our Foxit PDF PrintManager for .NET SDK. This list was current as of June 2013 and is subject to change. Please visit our website for the latest information at www.foxitsoftware.com.

If you have any questions as to the features or functionality of this product we provide a fully functional, never-expiring evaluation edition that can be downloaded from our website. If there are still additional questions as to the abilities of the component feel free to contact our support team at support@foxitsoftware.com.

  • Print Individual or Multiple PDF Documents in the same Print Job
  • Print to Any Specified Printer
  • Print to Microsoft Fax Service
  • Specify Fax Cover Page Options
  • Specify Page Ranges
  • Print PDF Documents from a Byte Array
  • Monitor Print Job Status
  • Event Management (Success, Failure, Update)
  • Optional Annotation Printing
  • Color Printing
  • Collated Printing
  • Duplex Printing
  • Specify Paper Trays
  • Many More Printing Options Including: Scaling, Number of Copies, Orientation, Paper Size, Resolution, Horizontal and Vertical Alignment
  • Ability to specify Paper or Media Type
  • Ability to set the output file name and to redirect the printer output to the specified file


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Product Limitations | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Getting Started > Product Limitations

Glossary Item Box

External Images - Foxit PDF PrintManager does not support rendering and printing the images that are not embedded directly in the PDF. An example of this would be an image path is embedded within the PDF document instead of the image itself.

XFA Forms - Depending on the features being utilized within the XFA fields certain XFA forms are not supported in Foxit PDF PrintManager.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Examples | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Getting Started > Examples

Glossary Item Box

Several already working examples will be included with the product download. These examples are used to demonstrate the different functionality of the product and are available in both C# and VB.NET. The examples are included in Visual Studio 2005, Visual Studio 2008 and Visual Studio 2010 and Visual Studio 2012. These will be in the "%ProgramFiles%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\Examples" on 32-bit machines and "%ProgramFiles(x86)%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\Examples" on 64-bit machines by default.

These examples include the following:

  • PrintSimple - Demonstrates a simple print example
  • PrintToDefaultPrinter - Demonstrates sending a print job to the default printer.
  • PrintPageRange - Demonstrates sending a print job to a printer with a specific page range.
  • PrintFromByteArray - Demonstrates sending a PDF document to the printer from a byte array.
  • PrintWithEvents - Demonstrates handling events when printing.
  • PrintWithSettingSimpleOptions - Demonstrates printing a PDF document using some simple options.
  • PrintSettingAllOptions - Demonstrates printing a PDF document with all available options.
  • PrintMultiplePDFs - Demonstrates sending multiple PDF documents to the printer in the same print job.
  • PrintChangeTrayForPage - Demonstrates how to change the print tray for a print job.
  • ShowPrintersOptions - Gathers all the options for a specified printer and outputs them to the console.
  • PrintToFile - Demonstrates redirecting a PDF document to a file instead of actual printing.
  • FaxSimple - Demonstrates sending a simple fax.
  • FaxSettingFaxOptions - Demonstrates sending a fax while setting some of the options.
  • FaxWithCoverPage - Demonstrates sending a fax while setting up a cover page.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Programming with Foxit PDF PrintManager | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager

Glossary Item Box

In This Section

Overview
An overview of programming with Foxit PDF PrintManager for .NET SDK.
Referencing The Assembly
Explains how to reference the assembly.
Deployment
Explains how to deploy your application.
Simple Print Example
Demonstrates how to send a PDF document to a specified printer.
Multiple PDF Print Example
Demonstrates how to send multiple PDF documents to the default printer all as one print job.
Print Options Example
Demonstrates how to send a particular PDF document to the printer while setting the document to print 2 copies, in color, actual size scaling and without annotations.
Handling Events Example
Demonstrates how to handle the "Failed", "Succeeded" and "Updated" events for the PrintJob.
Fax Example
Demonstrates how to send a PDF document as a fax.
Redirecting to File Example
Demonstrates how to redirect a PDF document to a file insted of actual printing.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Overview | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Overview

Glossary Item Box

The PrintManager API is very easy to use while at the same time it provides a huge feature set for printing PDF documents. Developers new to the component will find that understanding the object model comes very quickly and adding PDF printing functionality to your .NET application has never been easier.

A basic understanding of the PrintManager API can be had by getting to know 3 main classes; the PrintJob class, the Printer class and the PrintOptions class. These three are explained below.

The PrintJob Class

The main class you need to use is the PrintJob class. The PrintJob is where you will specify the PDF document(s), the printer and the print options to use when sending the job to the actual printer. This is also where you can manage events (print success, print failure, update, etc.) associated with that print job.

The Printer Class

Determining the supported features and functions of a specified printer is all done via the Printer class. The Printer class does not typically need to be instantiated individually but can be accessed directly as a property of the PrintJob class. The properties of the Printer class are read-only and simply show what a certain printer can handle. For instance you can tell if a printer can print in color, if a printer supports duplex or what paper sizes are available. Reading the Printer properties is similar to opening the printer’s properties dialog box to see what is or is not available for that printer.

The PrintOptions Class

Setting up the specific options that the PrintJob will use to send the PDF document(s) to the printer is done in the PrintOptions class. The PrintOptions class is accessed off of the PrintJob class (PrintJob.PrintOptions). The PrintOptions is where developers can specify options such as a certain duplex mode to use (if supported by your printer) or the orientation or scaling of the print job. Setting the PrintOptions is the programmatic equivalent of selecting certain options from the print dialog box when manually sending your file to the printer.

Example

A good example that illustrates these three classes is written below. This shows sending a PDF document to the default printer, checking to see if that printer supports duplex printing and if it does then setting the print job to print in vertical duplex mode.

[Visual Basic]
Dim MyPrintJob As New PrintJob(Printer.Default, "C:\Temp\Print.pdf")
If (MyPrintJob.Printer.Duplex) Then
    MyPrintJob.PrintOptions.DuplexMode = DuplexMode.DuplexVertical
End If
MyPrintJob.Print()

[C#]
PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\Print.pdf");
if (printJob.Printer.Duplex)
    printJob.PrintOptions.DuplexMode = DuplexMode.DuplexVertical;
printJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Referencing the Assembly | Comments on this topic
See Also
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Referencing the Assembly

Glossary Item Box

The Foxit PDF PrintManager v2.x for .NET SDK assemblies are installed at "%ProgramFiles%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\bin" on 32-bit machines and "%ProgramFiles(x86)%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\bin" on 64-bit machines by default. There are two .NET assemblies included that are compiled for use with the .NET Framework 2.0/3.0, two assemblies targeting the .NET Framework 3.5 and two assemblies targeting the .NET Framework 4.0/4.5. The table below gives the details of each assembly. These .NET assemblies use both managed as well as native code. Make sure that the environment where these assemblies are being deployed supports this.

Assembly Name | Assembly Version | Framework Version | Platform
Foxit.PDF.Printing.20.x86.dll | 2.x.x.20 | 2.0 and 3.0 | x86
Foxit.PDF.Printing.35.x86.dll | 2.x.x.35 | 3.5 | x86
Foxit.PDF.Printing.40.x86.dll | 2.x.x.40 | 4.0 and 4.5 | x86
Foxit.PDF.Printing.20.x64.dll | 2.x.x.20 | 2.0 and 3.0 | x64
Foxit.PDF.Printing.35.x64.dll | 2.x.x.35 | 3.5 | x64
Foxit.PDF.Printing.40.x64.dll | 2.x.x.40 | 4.0 and 4.5 | x64

Adding assembly reference by selecting “Add Reference”.

  1. Visual Studio in Windows x86

    To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x86 (Framework 2.0 and 3.0)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x86 (Framework 3.5)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x86 (Framework 4.0 and 4.5)" from the list on the ".NET" tab. Hit OK to complete this.

  2. Visual Studio in Windows x64

    To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project's and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x64 (Framework 2.0 and 3.0)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x64 (Framework 3.5)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF PrintManager for .NET SDK x64 (Framework 4.0 and 4.5)" from the list on the ".NET" tab. Hit OK to complete this.

    By default Foxit PDF PrintManager will be installed in the following location.

    For 32-bit machines: “%ProgramFiles%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\bin”.

    For 64-bit machines: “%ProgramFiles(x86)%\Foxit Software\Foxit PDF PrintManager v2.x.x for .NET SDK\bin”.

    NOTE: Make sure you have not placed more than one of the above assemblies in your applications bin folder. Placing more than one of them in your bin folder can cause errors and unpredictable results. The accompanying xml files are for intelli-sense and do not need to be distributed with your product.

See Also

Programming with Foxit PDF PrintManager
Deployment


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Deployment | Comments on this topic
See Also
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Deployment

Glossary Item Box

Deploying Foxit PDF PrintManager with your application requires three things:

  1. The Foxit PDF PrintManager DLL must be included in your application’s bin folder.

  2. The runtime components for Visual C++ must be installed on the machine.

  3. A License Key must be added to your application (this removes the watermark).

Foxit PDF PrintManager DLL

Foxit PDF PrintManager for .NET SDK is contained in the Foxit.PDF.PrintManager assembly (Foxit.PDF.PrintManager.XX.dll). You will need to ensure that this assembly is in your application's bin folder (a proper reference to the assembly from Visual Studio will put this in the bin folder). You can then deploy the assemblies along with your application using XCOPY or your own setup program.

Visual C++

The components required for Visual C++ can either be installed by downloading and running the Visual C++ Redistributable Package directly on the target deployment machine or by having your setup program use the appropriate merge modules to take care of it. Details on both of these methods are below.

Redistributable Package

If you would like to run the redistributable package directly on the target deployment machine, the Microsoft Download Center offers the Visual C++ Redistributable free to download and install. For applications targeting .NET 2.0, 3.0 or 3.5 download “Visual C++ Redistributable 2008”. For applications targeting .NET 4.0/4.5 download “Visual C++ Redistributable 2010”.

Setup Program

If you would like to have your setup program take care of this then it must contain the following merge modules:

  • Visual C++ 9.0 CRT Policy(X64) Win SXS MSM

  • Visual C++ 9.0 CRT Policy(X64) Win SXS MSM

  • Visual C++ 9.0 (X64) Win SXS MSM

  • Visual C++ 10.0 CRT (X86) MSM

  • Visual C++ 10.0 CRT (X64) MSM

License Key

A license key can either be added to a .config file or it can be added as a line of code in the application. License keys can be retrieved from the Customer Area of our website, http://www.foxitsoftware.com/CustomerArea, after the purchase of an appropriate serial number.

See Also

Programming with Foxit PDF PrintManager
Referencing the Assembly


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Simple Print Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Simple Print Example

Glossary Item Box

Print to Specified Printer

The below simple example demonstrates how to send a PDF document to a specified printer. Replace the string "Printer Name" with the actual name of the printer you wish to send the PDF document to.

[Visual Basic]
Dim MyPrintJob As New PrintJob("Printer Name", "C:\Temp\DocumentA.pdf")
MyPrintJob.Print()

[C#]
PrintJob printJob = new PrintJob("Printer Name", "C:\\Temp\\DocumentA.pdf");
printJob.Print();

Print to Default Printer

Sending the PDF document to the defined default printer without needing to know the actual name of the printer can be done using the static method "Default" off the Printer class. This is demonstrated in the example code below.

[Visual Basic]
Dim MyPrintJob As New PrintJob(Printer.Default, "C:\Temp\DocumentA.pdf")
MyPrintJob.Print()

[C#]
PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");
printJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Multiple PDF Print Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Multiple PDF Print Example

Glossary Item Box

The below example demonstrates how to send multiple PDF documents to the default printer all as one print job. The below example prints to the system's default printer (using the static property "Printer.Default"). If a printer other than the system default printer is desired, simply supply the PrintJob constructor with the actual string name of a printer to be used.

[Visual Basic]
Dim MyPrintJob As New PrintJob(Printer.Default)

MyPrintJob.Pages.Add("C:\Temp\DocumentA.pdf")
MyPrintJob.Pages.Add("C:\Temp\DocumentB.pdf")
MyPrintJob.Pages.Add("C:\Temp\DocumentC.pdf")

MyPrintJob.Print()

[C#]
PrintJob printJob = new PrintJob(Printer.Default);

printJob.Pages.Add("C:\\Temp\\DocumentA.pdf");
printJob.Pages.Add("C:\\Temp\\DocumentB.pdf");
printJob.Pages.Add("C:\\Temp\\DocumentC.pdf");

printJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Print Options Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Print Options Example

Glossary Item Box

The below example demonstrates how to send a particular PDF document to the printer while setting the document to print 2 copies, in color, actual size scaling and without annotations.

Note here that in order to set a certain option on a particular PrintJob you use the PrintOption's properties (i.e. printJob.PrintOptions.Color) . If however you wanted to check if a particular printer supported a certain feature, this can be checked using the Printer's properties (i.e. printJob.Printer.Color).

Setting options on a print job (in the PrintOptions class) that are not supported by the specified printer will throw an exception. For example if you set your PrintJob.PrintOptions.Color to true but the specified printer does not support color, an exception will be thrown.

[Visual Basic]
Dim MyPrintJob As New PrintJob(Printer.Default, "C:\Temp\DocumentA.pdf")

If (MyPrintJob.Printer.Color) Then
    MyPrintJob.PrintOptions.Color = True
End If

MyPrintJob.PrintOptions.Copies = 2
MyPrintJob.PrintOptions.Scaling = PageScaling.ActualSize ' Can also use AutoPageScaling or PercentagePageScaling objects
MyPrintJob.PrintOptions.PrintAnnotations = False

MyPrintJob.Print()

[C#]
PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");

if (printJob.Printer.Color)
    printJob.PrintOptions.Color = true;

printJob.PrintOptions.Copies = 2;
printJob.PrintOptions.Scaling = PageScaling.ActualSize; // Can also use AutoPageScaling or PercentagePageScaling objects
printJob.PrintOptions.PrintAnnotations = false;

printJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Handling Events Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Handling Events Example

Glossary Item Box

The below example demonstrates how to handle the "Failed", "Succeeded" and "Updated" events for the PrintJob.

[Visual Basic]
Imports System
Imports Foxit.PDF.Printing

Namespace PrintManagerConsole
    Module Module1
        Sub Main()
            Dim MyPrintJob As PrintJob = New PrintJob(Printer.Default, "C:\Temp\DocumentA.pdf")

            AddHandler MyPrintJob.Failed, AddressOf Printer_PrintJobFailed
            AddHandler MyPrintJob.Succeeded, AddressOf Printer_PrintJobSucceeded
            AddHandler MyPrintJob.Updated, AddressOf Printer_PrintJobUpdated
            MyPrintJob.Print()
        End Sub
        Sub Printer_PrintJobFailed(ByVal sender As Object, ByVal e As PrintJobFailedEventArgs)
            Console.WriteLine("Print Failed : JobID = " & e.PrintJob.JobId & " Exception.Message = " & e.Exception.Message)
        End Sub
        Sub Printer_PrintJobSucceeded(ByVal sender As Object, ByVal e As PrintJobEventArgs)
            Console.WriteLine("Print Succeeded : JobID = " & e.PrintJob.JobId)
        End Sub
        Sub Printer_PrintJobUpdated(ByVal sender As Object, ByVal e As PrintJobEventArgs)
            Console.WriteLine("PrintJob Updated : JobID = " & e.PrintJob.JobId & ", Status = " & e.PrintJob.Status & ", Pages Printed = " & e.PrintJob.PagesPrinted)
        End Sub
    End Module
End Namespace

[C#]
using System;
using Foxit.PDF.Printing;

namespace PrintManagerConsole
{
    class Program
    {
        static void Main(string[] args)
        {
            PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");

            printJob.Failed += new PrintJobFailedEventHandler(printer_PrintJobFailed);
            printJob.Succeeded += new PrintJobEventHandler(printer_PrintJobSucceeded);
            printJob.Updated += new PrintJobEventHandler(printer_PrintJobUpdated);

            printJob.Print();
        }
        static void printer_PrintJobFailed(object obj, PrintJobFailedEventArgs e)
        {
            Console.WriteLine("Print Failed : JobID = " + e.PrintJob.JobId + " Exception.Message = " + e.Exception.Message);
        }
        static void printer_PrintJobSucceeded(object obj, PrintJobEventArgs e)
        {
            Console.WriteLine("Print Succeeded : JobID = " + e.PrintJob.JobId);
        }
        static void printer_PrintJobUpdated(object obj, PrintJobEventArgs e)
        {
            Console.WriteLine("PrintJob Updated : JobID = " + e.PrintJob.JobId + ", Status = " + e.PrintJob.Status + ", Pages Printed = " + e.PrintJob.PagesPrinted);
        }
    }
}


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | ceTe Software
Fax Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Fax Example

Glossary Item Box

Simple Fax Example

The below example demonstrates how to send a PDF document as a fax. Sending a fax is very similar to sending a PDF to a print except you should use the FaxPrintJob instead of the PrintJob and you will want to use the name of the fax service instead of the name of the printer.

[Visual Basic]
Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "9,1-555-389-4567", "C:\Temp\DocumentA.pdf")
MyFaxPrintJob.Print()

[C#]
FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "9,1-555-389-4567", "C:\\Temp\\DocumentA.pdf");
faxPrintJob.Print();

Fax with Cover Page Example

This example demonstrates how to add a cover page to a PDF document and send it as a fax.

[Visual Basic]
Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "9,1-555-389-4567", "C:\Temp\DocumentA.pdf")
MyFaxPrintJob.FaxOptions.CoverPage = New ServerCoverPage("confdent2")  ' If FaxOptions.CoverPage is null, no cover page is added
'MyFaxPrintJob.FaxOptions.CoverPage = new LocalCoverPage("C:\Temp\Custom.cov"); ' uses a local .cov file

MyFaxPrintJob.FaxOptions.CoverPage.Note = "Note"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle"
MyFaxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip"
MyFaxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress"
MyFaxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany"
MyFaxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment"
MyFaxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber"
MyFaxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone"
MyFaxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName"
MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation"
MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone"
MyFaxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle"
MyFaxPrintJob.FaxOptions.CoverPage.Subject = "Subject"
MyFaxPrintJob.Print()

[C#]
FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "9,1-555-389-4567", "C:\\Temp\\DocumentA.pdf");
faxPrintJob.FaxOptions.CoverPage = new ServerCoverPage("confdent2"); // If FaxOptions.CoverPage is null, no cover page is added
//faxPrintJob.FaxOptions.CoverPage = new LocalCoverPage("C:\\Temp\\Custom.cov"); // uses a local .cov file

faxPrintJob.FaxOptions.CoverPage.Note = "Note";
faxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity";
faxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany";
faxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry";
faxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment";
faxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber";
faxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone";
faxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName";
faxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation";
faxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone";
faxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState";
faxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress";
faxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle";
faxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip";
faxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress";
faxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany";
faxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment";
faxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber";
faxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone";
faxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName";
faxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation";
faxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone";
faxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle";
faxPrintJob.FaxOptions.CoverPage.Subject = "Subject";
faxPrintJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Redirecting to File Example | Comments on this topic
Foxit PDF PrintManager for .NET SDK > Programming with Foxit PDF PrintManager > Redirecting to File Example

Glossary Item Box

The below example demonstrates how to redirect a PDF document to a file insted of actual printing.

[Visual Basic]
    Dim printJob As New PrintJob(Printer.Default, "C:\Temp\DocumentA.pdf")
    printJob.PrintToFileName = "C:\Temp\DocumentA.prn"
    printJob.Print()

[C#]
    PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");
    printJob.PrintToFileName = "C:\\Temp\\DocumentA.prn";
    printJob.Print();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Class Library Reference | Comments on this topic

Glossary Item Box

Foxit PDF SDK for .NET

This topic contains reference to Foxit PDF PrintManager for .NET SDK.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Printing Namespace | Comments on this topic
See Also Inheritance Hierarchy
Foxit.PDF.Printing Assembly : Foxit.PDF.Printing Namespace

Classes

 | Class | Description
Class | ActualSizePageScaling | Represents the actual page scaling size for the job page .
Class | AutoPageScaling | Represents auto page scaling size for the job page .
Class | DocumentLoadException | Represents a document load exception.
Class | FaxCoverPage | Represents a cover page for the fax.
Class | FaxOptions | Represents the fax options.
Class | FaxPrintJob | Represents a job that can be sent to a printer for printing a fax.
Class | InputPdf | Represents a pdf containing the pages to be added to the print job.
Class | InputPdfPage | Represents a page of pdf to be added to the print job.
Class | InputPdfPageList | Represents the list of pdf pages to be added to the print job.
Class | InvalidPasswordException | Represents a invalid password exception.
Class | LicensingException | Represents a licensing exception.
Class | LocalCoverPage | Represents a cover page.
Class | MediaType | Represents a media type.
Class | MediaTypeList | Represents a list of media types.
Class | PageOrientation | Represents the page orientation.
Class | PageScaling | Represents the scaling for the page to be printed.
Class | PaperSize | Represents a paper.
Class | PaperSizeList | Represents a list of papers.
Class | PaperSource | Represents the paper source.
Class | PaperSourceList | Represents a list of paper sources.
Class | PercentagePageScaling | Represents the class that allows to specify page scaling size in percentage.
Class | Printer | Represents a printer that can be used for print jobs.
Class | PrintFailedException | Represents a print failed exception.
Class | PrintingException | Represents a exception thrown while printing.
Class | PrintJob | Represents a job that can be sent to a printer.
Class | PrintJobEventArgs | Represents the print job event's arguments.
Class | PrintJobFailedEventArgs | Represents the print job failed event's arguments.
Class | PrintJobPage | Represents a page of pdf added to the print job.
Class | PrintJobPageList | Represents a list of pdf pages added to the print job.
Class | PrintJobPagePrintOptions | Represents print options for the page to be added to the print job.
Class | PrintJobPrintOptions | Represents the printing options for a job.
Class | Resolution | Represents the resolution of the printer.
Class | ResolutionList | Represents a list of resolutions.
Class | ServerCoverPage | Represents a cover page.
Class | UnitConverter | Utility for converting to and from typesetting points.

Delegates

 | Delegate | Description
Delegate | PrintJobEventHandler | Represents the method that is called when a job succeeds or is updated.
Delegate | PrintJobFailedEventHandler | Represents the method that is called when a job fails.

Enumerations

 | Enumeration | Description
Enumeration | DuplexMode | Represents duplex modes.
Enumeration | HorizontalAlign | Represents the horizontal alignment to use when printing pages.
Enumeration | OrientationType | Represents the type of orientation.
Enumeration | PrintJobStatus | Represents the status of print.
Enumeration | ScaleTo | Represents the page scaling type.
Enumeration | VerticalAlign | Represents the vertical alignment to use when printing pages.

See Also

Reference

Foxit.PDF.Printing Assembly


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActualSizePageScaling Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ActualSizePageScaling Class

Represents the actual page scaling size for the job page .

Object Model

ActualSizePageScaling Class

Syntax

Visual Basic (Declaration)
Public Class ActualSizePageScaling
   Inherits PageScaling
C#
public class ActualSizePageScaling : PageScaling

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the scaling propety to actual size and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the scaling
        MyPrintJob.PrintOptions.Scaling = PageScaling.ActualSize

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the scaling
        printJob.PrintOptions.Scaling = PageScaling.ActualSize;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PageScaling
Foxit.PDF.Printing.ActualSizePageScaling

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ActualSizePageScaling Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActualSizePageScaling Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ActualSizePageScaling Class

The following tables list the members exposed by ActualSizePageScaling.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ActualSizePageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : AutoPageScaling Class

Represents auto page scaling size for the job page .

Object Model

AutoPageScaling Class

Syntax

Visual Basic (Declaration)
Public Class AutoPageScaling
   Inherits PageScaling
C#
public class AutoPageScaling : PageScaling

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the scaling propety to auto page scaling and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the scaling
        Dim MyAutoPageScaling As AutoPageScaling = New AutoPageScaling(ScaleTo.PagePrintableArea, True, True)
        MyPrintJob.PrintOptions.Scaling = MyAutoPageScaling

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the scaling
        AutoPageScaling autoPageScaling = new AutoPageScaling(ScaleTo.PagePrintableArea, true, true);
        printJob.PrintOptions.Scaling = autoPageScaling;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PageScaling
Foxit.PDF.Printing.AutoPageScaling
Foxit.PDF.Printing.PercentagePageScaling

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : AutoPageScaling Class

The following tables list the members exposed by AutoPageScaling.

Public Constructors

 | Name | Description
Public Constructor | AutoPageScaling Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AutoExpand | Gets or sets a value indicating if the page scaling size can be expanded.
Public Property | AutoShrink | Gets or sets a value indicating if the page scaling size can be shrunk.
Public Property | ScaleTo | Gets or sets a value indicating the boundaries on the page to use for the scaling.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

AutoPageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class : AutoPageScaling Constructor

Overload List

Overload | Description
AutoPageScaling Constructor(ScaleTo,Boolean,Boolean) | Initializes a new instance of the AutoPageScaling class.
AutoPageScaling Constructor(ScaleTo) | Initializes a new instance of the AutoPageScaling class.
AutoPageScaling Constructor() | Initializes a new instance of the AutoPageScaling class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Constructor(ScaleTo,Boolean,Boolean) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class > AutoPageScaling Constructor : AutoPageScaling Constructor(ScaleTo,Boolean,Boolean)

scaleTo
A ScaleTo value specifying the boundaries of the page to use for scaling.
shrinkIfNeeded
Boolean value indicating if the page scale size can be shrunk.
expandIfNeeded
Boolean value indicating if the page scale size can be expanded.
Initializes a new instance of the AutoPageScaling class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scaleTo As ScaleTo, _
   ByVal shrinkIfNeeded As Boolean, _
   ByVal expandIfNeeded As Boolean _
)
C#
public AutoPageScaling(
   ScaleTo scaleTo,
   bool shrinkIfNeeded,
   bool expandIfNeeded
)

Parameters

scaleTo
A ScaleTo value specifying the boundaries of the page to use for scaling.
shrinkIfNeeded
Boolean value indicating if the page scale size can be shrunk.
expandIfNeeded
Boolean value indicating if the page scale size can be expanded.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Constructor(ScaleTo) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class > AutoPageScaling Constructor : AutoPageScaling Constructor(ScaleTo)

scaleTo
A ScaleTo value specifying the boundaries of the auto page scaling.
Initializes a new instance of the AutoPageScaling class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scaleTo As ScaleTo _
)
C#
public AutoPageScaling(
   ScaleTo scaleTo
)

Parameters

scaleTo
A ScaleTo value specifying the boundaries of the auto page scaling.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Constructor() | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class > AutoPageScaling Constructor : AutoPageScaling Constructor()

Initializes a new instance of the AutoPageScaling class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public AutoPageScaling()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : AutoPageScaling Class

For a list of all members of this type, see AutoPageScaling members.

Public Properties

 | Name | Description
Public Property | AutoExpand | Gets or sets a value indicating if the page scaling size can be expanded.
Public Property | AutoShrink | Gets or sets a value indicating if the page scaling size can be shrunk.
Public Property | ScaleTo | Gets or sets a value indicating the boundaries on the page to use for the scaling.
Top

See Also

Reference

AutoPageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoExpand Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class : AutoExpand Property

Gets or sets a value indicating if the page scaling size can be expanded.

Syntax

Visual Basic (Declaration)
Public Property AutoExpand As Boolean
C#
public bool AutoExpand {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoShrink Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class : AutoShrink Property

Gets or sets a value indicating if the page scaling size can be shrunk.

Syntax

Visual Basic (Declaration)
Public Property AutoShrink As Boolean
C#
public bool AutoShrink {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ScaleTo Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > AutoPageScaling Class : ScaleTo Property

Gets or sets a value indicating the boundaries on the page to use for the scaling.

Syntax

Visual Basic (Declaration)
Public Property ScaleTo As ScaleTo
C#
public ScaleTo ScaleTo {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

AutoPageScaling Class
AutoPageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : DocumentLoadException Class

Represents a document load exception.

Object Model

DocumentLoadException Class

Syntax

Visual Basic (Declaration)
Public Class DocumentLoadException
   Inherits PrintingException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class DocumentLoadException : PrintingException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Printing.PrintingException
Foxit.PDF.Printing.DocumentLoadException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentLoadException Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : DocumentLoadException Class

The following tables list the members exposed by DocumentLoadException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxCoverPage Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxCoverPage Class

Represents a cover page for the fax.

Object Model

FaxCoverPage Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class FaxCoverPage
C#
public abstract class FaxCoverPage

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a fax print job, sets the cover page values and sends the fax.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a fax print job
        Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "1-555-465-1177", "C:\MyDocument.pdf")

        ' Add a local cover page
        MyFaxPrintJob.FaxOptions.CoverPage = New LocalCoverPage("C:\Custom.cov")

        ' Set the cover page values
        MyFaxPrintJob.FaxOptions.CoverPage.Note = "Note"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.Subject = "Subject"

        ' Send the fax
        MyFaxPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a fax print job
        FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "1-555-465-1177", @"C:\MyDocument.pdf");

        // Add a local cover page
        faxPrintJob.FaxOptions.CoverPage = new LocalCoverPage(@"Custom.cov");

        // Set the cover page values
        faxPrintJob.FaxOptions.CoverPage.Note = "Note";
        faxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity";
        faxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany";
        faxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry";
        faxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment";
        faxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState";
        faxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress";
        faxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle";
        faxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip";
        faxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress";
        faxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany";
        faxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment";
        faxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle";
        faxPrintJob.FaxOptions.CoverPage.Subject = "Subject";

        // Send the fax
        faxPrintJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.FaxCoverPage
Foxit.PDF.Printing.LocalCoverPage
Foxit.PDF.Printing.ServerCoverPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxCoverPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxCoverPage Class

The following tables list the members exposed by FaxCoverPage.

Public Properties

 | Name | Description
Public Property | Note | Gets or sets the content of the note field.
Public Property | RecipientCity | Gets or sets the city of the recipient.
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient.
Public Property | RecipientCountry | Gets or sets the country of the recipient.
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient.
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient.
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient.
Public Property | RecipientName | Gets or sets the name of the recipient.
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient.
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient.
Public Property | RecipientState | Gets or sets the state of the recipient.
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient.
Public Property | RecipientTitle | Gets or sets the title associated with the recipient.
Public Property | RecipientZip | Gets or sets the zip code of the recipient.
Public Property | SenderAddress | Gets or sets the address of the sender.
Public Property | SenderCompany | Gets or sets the company name associated with the sender.
Public Property | SenderDepartment | Gets or sets the department name associated with the sender.
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender.
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender.
Public Property | SenderName | Gets or sets the name associated with the sender.
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender.
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender.
Public Property | SenderTitle | Gets or sets the title title associated with the sender.
Public Property | Subject | Gets or sets the subject for the fax to be sent.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FaxCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxCoverPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxCoverPage Class

For a list of all members of this type, see FaxCoverPage members.

Public Properties

 | Name | Description
Public Property | Note | Gets or sets the content of the note field.
Public Property | RecipientCity | Gets or sets the city of the recipient.
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient.
Public Property | RecipientCountry | Gets or sets the country of the recipient.
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient.
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient.
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient.
Public Property | RecipientName | Gets or sets the name of the recipient.
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient.
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient.
Public Property | RecipientState | Gets or sets the state of the recipient.
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient.
Public Property | RecipientTitle | Gets or sets the title associated with the recipient.
Public Property | RecipientZip | Gets or sets the zip code of the recipient.
Public Property | SenderAddress | Gets or sets the address of the sender.
Public Property | SenderCompany | Gets or sets the company name associated with the sender.
Public Property | SenderDepartment | Gets or sets the department name associated with the sender.
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender.
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender.
Public Property | SenderName | Gets or sets the name associated with the sender.
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender.
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender.
Public Property | SenderTitle | Gets or sets the title title associated with the sender.
Public Property | Subject | Gets or sets the subject for the fax to be sent.
Top

See Also

Reference

FaxCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Note Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : Note Property

Gets or sets the content of the note field.

Syntax

Visual Basic (Declaration)
Public Property Note As String
C#
public string Note {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientCity Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientCity Property

Gets or sets the city of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientCity As String
C#
public string RecipientCity {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientCompany Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientCompany Property

Gets or sets the company name associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientCompany As String
C#
public string RecipientCompany {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientCountry Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientCountry Property

Gets or sets the country of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientCountry As String
C#
public string RecipientCountry {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientDepartment Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientDepartment Property

Gets or sets the department associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientDepartment As String
C#
public string RecipientDepartment {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientFaxNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientFaxNumber Property

Gets or sets the fax number associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientFaxNumber As String
C#
public string RecipientFaxNumber {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientHomePhone Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientHomePhone Property

Gets or sets the home phone number associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientHomePhone As String
C#
public string RecipientHomePhone {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientName Property

Gets or sets the name of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientName As String
C#
public string RecipientName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientOfficeLocation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientOfficeLocation Property

Gets or sets the office location of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientOfficeLocation As String
C#
public string RecipientOfficeLocation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientOfficePhone Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientOfficePhone Property

Gets or sets the office phone number associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientOfficePhone As String
C#
public string RecipientOfficePhone {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientState Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientState Property

Gets or sets the state of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientState As String
C#
public string RecipientState {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientStreetAddress Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientStreetAddress Property

Gets or sets the street address of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientStreetAddress As String
C#
public string RecipientStreetAddress {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientTitle Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientTitle Property

Gets or sets the title associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientTitle As String
C#
public string RecipientTitle {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientZip Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : RecipientZip Property

Gets or sets the zip code of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientZip As String
C#
public string RecipientZip {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderAddress Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderAddress Property

Gets or sets the address of the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderAddress As String
C#
public string SenderAddress {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderCompany Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderCompany Property

Gets or sets the company name associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderCompany As String
C#
public string SenderCompany {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderDepartment Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderDepartment Property

Gets or sets the department name associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderDepartment As String
C#
public string SenderDepartment {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderFaxNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderFaxNumber Property

Gets or sets the fax number associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderFaxNumber As String
C#
public string SenderFaxNumber {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderHomePhone Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderHomePhone Property

Gets or sets the home phone number associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderHomePhone As String
C#
public string SenderHomePhone {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderName Property

Gets or sets the name associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderName As String
C#
public string SenderName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderOfficeLocation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderOfficeLocation Property

Gets or sets the office location of the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderOfficeLocation As String
C#
public string SenderOfficeLocation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderOfficePhone Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderOfficePhone Property

Gets or sets the office phone number associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderOfficePhone As String
C#
public string SenderOfficePhone {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderTitle Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : SenderTitle Property

Gets or sets the title title associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderTitle As String
C#
public string SenderTitle {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Subject Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxCoverPage Class : Subject Property

Gets or sets the subject for the fax to be sent.

Syntax

Visual Basic (Declaration)
Public Property Subject As String
C#
public string Subject {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxCoverPage Class
FaxCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxOptions Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxOptions Class

Represents the fax options.

Object Model

FaxOptions ClassFaxCoverPage Class

Syntax

Visual Basic (Declaration)
Public Class FaxOptions
C#
public class FaxOptions

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a fax print job, sets fax options and sends the fax.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a fax print job
        Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "1-555-389-4567", "C:\MyDocument.pdf")

        ' Set fax option values
        MyFaxPrintJob.FaxOptions.RecipientName = "RecipientName"
        MyFaxPrintJob.FaxOptions.SenderBillingCode = "SenderBillingCode"
        MyFaxPrintJob.FaxOptions.SenderCompany = "CompanyName"
        MyFaxPrintJob.FaxOptions.SenderDept = "DepartmentName"
        MyFaxPrintJob.FaxOptions.SenderName = "SenderName"

        ' Send the fax
        MyFaxPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a fax print job
        FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "1-555-465-1177", @"C:\MyDocument.pdf");

        // Set fax option values
        faxPrintJob.FaxOptions.RecipientName = "RecipientName";
        faxPrintJob.FaxOptions.SenderBillingCode = "SenderBillingCode";
        faxPrintJob.FaxOptions.SenderCompany = "CompanyName";
        faxPrintJob.FaxOptions.SenderDept = "DepartmentName";
        faxPrintJob.FaxOptions.SenderName = "SenderName";

        // Send the fax
        faxPrintJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.FaxOptions

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxOptions Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxOptions Class

The following tables list the members exposed by FaxOptions.

Public Properties

 | Name | Description
Public Property | CoverPage | Gets or sets the FaxCoverPage object that represents the cover page for the fax document.
Public Property | RecipientName | Gets or sets the name of the recipient.
Public Property | RecipientNumber | Gets or sets the fax number associated with the recipient.
Public Property | SenderBillingCode | Gets or sets the billing code associated with the sender.
Public Property | SenderCompany | Gets or sets the company name of the sender.
Public Property | SenderDept | Gets or sets the department associated with the sender.
Public Property | SenderName | Gets or sets the name of the sender.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FaxOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxOptions Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxOptions Class

For a list of all members of this type, see FaxOptions members.

Public Properties

 | Name | Description
Public Property | CoverPage | Gets or sets the FaxCoverPage object that represents the cover page for the fax document.
Public Property | RecipientName | Gets or sets the name of the recipient.
Public Property | RecipientNumber | Gets or sets the fax number associated with the recipient.
Public Property | SenderBillingCode | Gets or sets the billing code associated with the sender.
Public Property | SenderCompany | Gets or sets the company name of the sender.
Public Property | SenderDept | Gets or sets the department associated with the sender.
Public Property | SenderName | Gets or sets the name of the sender.
Top

See Also

Reference

FaxOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CoverPage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : CoverPage Property

Gets or sets the FaxCoverPage object that represents the cover page for the fax document.

Syntax

Visual Basic (Declaration)
Public Property CoverPage As FaxCoverPage
C#
public FaxCoverPage CoverPage {get; set;}

Remarks

If this value is null (Nothing in VB), no cover page will be added. To add a cover page, create a Foxit.PDF.Printing.LocalFaxCoverPage or Foxit.PDF.Printing.ServerFaxCoverPage object and set it to this property. See the appropriate classes for an example.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : RecipientName Property

Gets or sets the name of the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientName As String
C#
public string RecipientName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RecipientNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : RecipientNumber Property

Gets or sets the fax number associated with the recipient.

Syntax

Visual Basic (Declaration)
Public Property RecipientNumber As String
C#
public string RecipientNumber {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderBillingCode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : SenderBillingCode Property

Gets or sets the billing code associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderBillingCode As String
C#
public string SenderBillingCode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderCompany Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : SenderCompany Property

Gets or sets the company name of the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderCompany As String
C#
public string SenderCompany {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderDept Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : SenderDept Property

Gets or sets the department associated with the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderDept As String
C#
public string SenderDept {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SenderName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxOptions Class : SenderName Property

Gets or sets the name of the sender.

Syntax

Visual Basic (Declaration)
Public Property SenderName As String
C#
public string SenderName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxOptions Class
FaxOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxPrintJob Class

Represents a job that can be sent to a printer for printing a fax.

Object Model

FaxPrintJob ClassFaxOptions ClassPrintJobPageList ClassPrintJobPage ClassPrinter ClassPrintJobPrintOptions Class

Syntax

Visual Basic (Declaration)
Public Class FaxPrintJob
   Inherits PrintJob
   Implements System.IDisposable
C#
public class FaxPrintJob : PrintJob, System.IDisposable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a fax print job and sends the fax.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a fax print job
        Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "1-555-389-4567", "C:\MyDocument.pdf")

        ' Send the fax
        MyFaxPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a fax print job
        FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "1-555-465-1177", @"C:\MyDocument.pdf");

        // Send the fax
        faxPrintJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJob
Foxit.PDF.Printing.FaxPrintJob

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Class Members | Comments on this topic
See Also Properties Methods Events
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxPrintJob Class

The following tables list the members exposed by FaxPrintJob.

Public Constructors

 | Name | Description
Public Constructor | FaxPrintJob Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DocumentName | Gets or sets the name of the document that is to be shown in the print spooler. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | FaxOptions | Gets the FaxOptionsobject.
Public Property | JobId | Gets the ID of the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Pages | Gets a PrintJobPageList object that represents the pages to be printed by the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PagesPrinted | Gets a value indicating how many pages have been printed. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Printer | Gets the Printer object that is targeted by the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PrintOptions | Gets a PrintJobPrintOptions objects that represents the printing options for the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PrintToFileName | (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Status | Gets the current status of the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Top

Public Methods

 | Name | Description
Public Method | Dispose() | Releases resources used by the FaxPrintJob object. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | Print | Prints the job to the printer. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

Public Events

 | Name | Description
Public Event | Failed | Occurs when a job fails. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Event | Succeeded | Occurs when a job succeeds. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Event | Updated | Occurs when a job's status or pages printed is updated. (Inherited from Foxit.PDF.Printing.PrintJob)
Top

See Also

Reference

FaxPrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class : FaxPrintJob Constructor

Overload List

Overload | Description
FaxPrintJob Constructor(String,String,String,Int32,Int32) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(String,String,String) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(String,String,InputPdf,Int32,Int32) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(String,String,InputPdf) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(String,String) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(Printer,String,String,Int32,Int32) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(Printer,String,InputPdf,Int32,Int32) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(Printer,String,String) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(Printer,String,InputPdf) | Initializes a new instance of the FaxPrintJob class.
FaxPrintJob Constructor(Printer,String) | Initializes a new instance of the FaxPrintJob class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(String,String,String,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(String,String,String,Int32,Int32)

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal recipientNumber As String, _
   ByVal pdfFileName As String, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public FaxPrintJob(
   string printerName,
   string recipientNumber,
   string pdfFileName,
   int startPage,
   int pageCount
)

Parameters

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(String,String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(String,String,String)

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal recipientNumber As String, _
   ByVal pdfFileName As String _
)
C#
public FaxPrintJob(
   string printerName,
   string recipientNumber,
   string pdfFileName
)

Parameters

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(String,String,InputPdf,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(String,String,InputPdf,Int32,Int32)

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal recipientNumber As String, _
   ByVal inputPdf As InputPdf, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public FaxPrintJob(
   string printerName,
   string recipientNumber,
   InputPdf inputPdf,
   int startPage,
   int pageCount
)

Parameters

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(String,String,InputPdf) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(String,String,InputPdf)

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal recipientNumber As String, _
   ByVal inputPdf As InputPdf _
)
C#
public FaxPrintJob(
   string printerName,
   string recipientNumber,
   InputPdf inputPdf
)

Parameters

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(String,String)

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal recipientNumber As String _
)
C#
public FaxPrintJob(
   string printerName,
   string recipientNumber
)

Parameters

printerName
The name of the fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(Printer,String,String,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(Printer,String,String,Int32,Int32)

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal recipientNumber As String, _
   ByVal pdfFileName As String, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public FaxPrintJob(
   Printer printer,
   string recipientNumber,
   string pdfFileName,
   int startPage,
   int pageCount
)

Parameters

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(Printer,String,InputPdf,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(Printer,String,InputPdf,Int32,Int32)

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal recipientNumber As String, _
   ByVal inputPdf As InputPdf, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public FaxPrintJob(
   Printer printer,
   string recipientNumber,
   InputPdf inputPdf,
   int startPage,
   int pageCount
)

Parameters

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
startPage
The first page from the InputPdf to be added to the fax print job.
pageCount
The number of pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(Printer,String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(Printer,String,String)

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal recipientNumber As String, _
   ByVal pdfFileName As String _
)
C#
public FaxPrintJob(
   Printer printer,
   string recipientNumber,
   string pdfFileName
)

Parameters

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
pdfFileName
The file path to the PDF containing the pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(Printer,String,InputPdf) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(Printer,String,InputPdf)

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal recipientNumber As String, _
   ByVal inputPdf As InputPdf _
)
C#
public FaxPrintJob(
   Printer printer,
   string recipientNumber,
   InputPdf inputPdf
)

Parameters

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
inputPdf
The InputPdf object containing the pages to be added to the fax print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Constructor(Printer,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class > FaxPrintJob Constructor : FaxPrintJob Constructor(Printer,String)

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.
Initializes a new instance of the FaxPrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal recipientNumber As String _
)
C#
public FaxPrintJob(
   Printer printer,
   string recipientNumber
)

Parameters

printer
The fax printer used by the fax print job.
recipientNumber
The fax number associated with the recipient.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxPrintJob Class

For a list of all members of this type, see FaxPrintJob members.

Public Properties

 | Name | Description
Public Property | DocumentName | Gets or sets the name of the document that is to be shown in the print spooler. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | FaxOptions | Gets the FaxOptionsobject.
Public Property | JobId | Gets the ID of the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Pages | Gets a PrintJobPageList object that represents the pages to be printed by the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PagesPrinted | Gets a value indicating how many pages have been printed. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Printer | Gets the Printer object that is targeted by the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PrintOptions | Gets a PrintJobPrintOptions objects that represents the printing options for the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | PrintToFileName | (Inherited from Foxit.PDF.Printing.PrintJob)
Public Property | Status | Gets the current status of the job. (Inherited from Foxit.PDF.Printing.PrintJob)
Top

See Also

Reference

FaxPrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxOptions Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class : FaxOptions Property

Gets the FaxOptionsobject.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FaxOptions As FaxOptions
C#
public FaxOptions FaxOptions {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdf Class

Represents a pdf containing the pages to be added to the print job.

Object Model

InputPdf ClassInputPdfPageList ClassInputPdfPage Class

Syntax

Visual Basic (Declaration)
Public Class InputPdf
   Implements System.IDisposable
C#
public class InputPdf : System.IDisposable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, adds PDF pages to print the job and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName")

        ' Create an InputPdf object to hold the source PDF
        Dim MyInputPdf As InputPdf = New InputPdf("C:\MyDocument.pdf", "password")

        ' Add the InputPdf's pages to the print job
        MyPrintJob.Pages.Add(MyInputPdf)

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName");

        // Create an InputPdf object to hold the source PDF
        InputPdf inputPdf = new InputPdf(@"C:\MyDocument.pdf", "password");

        // Add the InputPdf's pages to the print job
        printJob.Pages.Add(inputPdf);

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.InputPdf

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdf Class

The following tables list the members exposed by InputPdf.

Public Constructors

 | Name | Description
Public Constructor | InputPdf Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | Pages | Gets the InputPdfPageList object that represents a collection of pages.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdf object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : InputPdf Constructor

Overload List

Overload | Description
InputPdf Constructor(String,String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(Byte[],String) | Initializes a new instance of the InputPdf class.
InputPdf Constructor(Byte[]) | Initializes a new instance of the InputPdf class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Constructor(String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(String,String)

filePath
The file path of the PDF document.
password
The string containing the password.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal password As String _
)
C#
public InputPdf(
   string filePath,
   string password
)

Parameters

filePath
The file path of the PDF document.
password
The string containing the password.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Constructor(String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(String)

filePath
The file path of the PDF document.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String _
)
C#
public InputPdf(
   string filePath
)

Parameters

filePath
The file path of the PDF document.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Constructor(Byte[],String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Byte[],String)

data
The byte array containing the PDF document.
password
The string containing the password.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte, _
   ByVal password As String _
)
C#
public InputPdf(
   byte[] data,
   string password
)

Parameters

data
The byte array containing the PDF document.
password
The string containing the password.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Constructor(Byte[]) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class > InputPdf Constructor : InputPdf Constructor(Byte[])

data
The byte array containing the Pdf document.
Initializes a new instance of the InputPdf class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte _
)
C#
public InputPdf(
   byte[] data
)

Parameters

data
The byte array containing the Pdf document.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members
Overload List


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdf Class

For a list of all members of this type, see InputPdf members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdf object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Dispose() Method

Releases resources used by the InputPdf object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdf Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdf Class

For a list of all members of this type, see InputPdf members.

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | Pages | Gets the InputPdfPageList object that represents a collection of pages.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Top

See Also

Reference

InputPdf Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Author Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Author Property

Gets the author property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Author As String
C#
public string Author {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Creator Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Creator Property

Gets the creator property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Creator As String
C#
public string Creator {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Keywords Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Keywords Property

Gets the keywords property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keywords As String
C#
public string Keywords {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Pages Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Pages Property

Gets the InputPdfPageList object that represents a collection of pages.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As InputPdfPageList
C#
public InputPdfPageList Pages {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Producer Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Producer Property

Gets the producer property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Producer As String
C#
public string Producer {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Subject Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Subject Property

Gets the subject property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subject As String
C#
public string Subject {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Title Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Title Property

Gets the title property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Title As String
C#
public string Title {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPage Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPage Class

Represents a page of pdf to be added to the print job.

Object Model

InputPdfPage Class

Syntax

Visual Basic (Declaration)
Public Class InputPdfPage
   Implements System.IDisposable
C#
public class InputPdfPage : System.IDisposable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, adds PDF pages to print job and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName")

        ' Create an InputPdf object to hold the source PDF
        Dim MyInputPdf As InputPdf = New InputPdf("C:\MyDocument.pdf")

        ' Get pages from the input PDF
        Dim MyFirstPage As InputPdfPage = MyInputPdf.Pages(0)
        Dim MyFourthPage As InputPdfPage = MyInputPdf.Pages(3)

        ' Add pages to the print job
        MyPrintJob.Pages.Add(MyFirstPage)
        MyPrintJob.Pages.Add(MyFourthPage)

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName");

        // Create an InputPdf object to hold the source PDF
        InputPdf inputPdf = new InputPdf(@"C:\MyDocument.pdf");

        // Get pages from the input PDF
        InputPdfPage firstPage = inputPdf.Pages[0];
        InputPdfPage fourthPage = inputPdf.Pages[3];

        // Add pages to the print job
        printJob.Pages.Add(firstPage);
        printJob.Pages.Add(fourthPage);

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.InputPdfPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPage Class

The following tables list the members exposed by InputPdfPage.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the PDF page.
Public Property | Width | Gets the width of the PDF page.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdfPage object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPage Class

For a list of all members of this type, see InputPdfPage members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdfPage object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPage Class : Dispose() Method

Releases resources used by the InputPdfPage object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPage Class

For a list of all members of this type, see InputPdfPage members.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the PDF page.
Public Property | Width | Gets the width of the PDF page.
Top

See Also

Reference

InputPdfPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Height Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPage Class : Height Property

Gets the height of the PDF page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
C#
public double Height {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Width Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPage Class : Width Property

Gets the width of the PDF page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
C#
public double Width {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPageList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPageList Class

Represents the list of pdf pages to be added to the print job.

Object Model

InputPdfPageList ClassInputPdfPage Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class InputPdfPageList
   Implements System.Collections.Generic.IEnumerable(Of InputPdfPage), System.Collections.IEnumerable, System.IDisposable
C#
[DefaultMemberAttribute("Item")]
public class InputPdfPageList : System.Collections.Generic.IEnumerable<InputPdfPage>, System.Collections.IEnumerable, System.IDisposable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, adds PDF pages to print job and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName")

        ' Create an InputPdf object to hold the source PDF
        Dim MyInputPdf As InputPdf = New InputPdf("C:\MyDocument.pdf")

        ' Get a list of the input PDF's pages
        Dim MyInputPdfPages As InputPdfPageList = MyInputPdf.Pages

        ' Add pages to the print job
        MyPrintJob.Pages.Add(MyInputPdfPages(0)) ' First Page
        MyPrintJob.Pages.Add(MyInputPdfPages(3)) ' Fourth Page

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName");

        // Create an InputPdf object to hold the source PDF
        InputPdf inputPdf = new InputPdf(@"C:\MyDocument.pdf");

        // Get a list of the input PDF's pages
        InputPdfPageList inputPdfPages = inputPdf.Pages;

        // Add pages to the print job
        printJob.Pages.Add(inputPdfPages[0]); // First Page
        printJob.Pages.Add(inputPdfPages[3]); // Fourth Page

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.InputPdfPageList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPageList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPageList Class

The following tables list the members exposed by InputPdfPageList.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in the list.
Public Property | Item | Gets the InputPdfPage object that represents the PDF page.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdfPageList object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPageList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPageList Class

For a list of all members of this type, see InputPdfPageList members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the InputPdfPageList object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPageList Class : Dispose() Method

Releases resources used by the InputPdfPageList object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPageList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InputPdfPageList Class

For a list of all members of this type, see InputPdfPageList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the number of pages in the list.
Public Property | Item | Gets the InputPdfPage object that represents the PDF page.
Top

See Also

Reference

InputPdfPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPageList Class : Count Property

Gets the number of pages in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPageList Class : Item Property

index
Gets the InputPdfPage object that represents the PDF page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As InputPdfPage
C#
public InputPdfPage this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InvalidPasswordException Class

Represents a invalid password exception.

Object Model

InvalidPasswordException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidPasswordException
   Inherits PrintingException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class InvalidPasswordException : PrintingException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Printing.PrintingException
Foxit.PDF.Printing.InvalidPasswordException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InvalidPasswordException Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LicensingException Class

Represents a licensing exception.

Object Model

LicensingException Class

Syntax

Visual Basic (Declaration)
Public Class LicensingException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class LicensingException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Printing.LicensingException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LicensingException Class

The following tables list the members exposed by LicensingException.

Public Constructors

 | Name | Description
Public Constructor | LicensingException Constructor | Initializes a new instance of LicensingException.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > LicensingException Class : LicensingException Constructor

message
Initializes a new instance of LicensingException.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public LicensingException(
   string message
)

Parameters

message

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Class
LicensingException Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LocalCoverPage Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LocalCoverPage Class

Represents a cover page.

Object Model

LocalCoverPage Class

Syntax

Visual Basic (Declaration)
Public Class LocalCoverPage
   Inherits FaxCoverPage
C#
public class LocalCoverPage : FaxCoverPage

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a fax print job, sets the cover page values and sends the fax.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a fax print job
        Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "1-555-465-1177", "C:\MyDocument.pdf")

        ' Add a local cover page
        MyFaxPrintJob.FaxOptions.CoverPage = New LocalCoverPage("C:\Custom.cov")

        ' Set the cover page values
        MyFaxPrintJob.FaxOptions.CoverPage.Note = "Note"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.Subject = "Subject"

        ' Send the fax
        MyFaxPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a fax print job
        FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "1-555-465-1177", @"C:\MyDocument.pdf");

        // Add a local cover page
        faxPrintJob.FaxOptions.CoverPage = new LocalCoverPage(@"Custom.cov");

        // Set the cover page values
        faxPrintJob.FaxOptions.CoverPage.Note = "Note";
        faxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity";
        faxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany";
        faxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry";
        faxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment";
        faxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState";
        faxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress";
        faxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle";
        faxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip";
        faxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress";
        faxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany";
        faxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment";
        faxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle";
        faxPrintJob.FaxOptions.CoverPage.Subject = "Subject";

        // Send the fax
        faxPrintJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.FaxCoverPage
Foxit.PDF.Printing.LocalCoverPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LocalCoverPage Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LocalCoverPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LocalCoverPage Class

The following tables list the members exposed by LocalCoverPage.

Public Constructors

 | Name | Description
Public Constructor | LocalCoverPage Constructor | Initializes a new instance of the LocalCoverPage class.
Top

Public Properties

 | Name | Description
Public Property | FilePath | Gets or sets the file path of the local cover page (*.cov) file.
Public Property | Note | Gets or sets the content of the note field. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCity | Gets or sets the city of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCountry | Gets or sets the country of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientName | Gets or sets the name of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientState | Gets or sets the state of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientTitle | Gets or sets the title associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientZip | Gets or sets the zip code of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderAddress | Gets or sets the address of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderCompany | Gets or sets the company name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderDepartment | Gets or sets the department name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderName | Gets or sets the name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderTitle | Gets or sets the title title associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | Subject | Gets or sets the subject for the fax to be sent. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LocalCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LocalCoverPage Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > LocalCoverPage Class : LocalCoverPage Constructor

filePath
The file path of the local cover page (*.cov) file.
Initializes a new instance of the LocalCoverPage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String _
)
C#
public LocalCoverPage(
   string filePath
)

Parameters

filePath
The file path of the local cover page (*.cov) file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LocalCoverPage Class
LocalCoverPage Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LocalCoverPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LocalCoverPage Class

For a list of all members of this type, see LocalCoverPage members.

Public Properties

 | Name | Description
Public Property | FilePath | Gets or sets the file path of the local cover page (*.cov) file.
Public Property | Note | Gets or sets the content of the note field. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCity | Gets or sets the city of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCountry | Gets or sets the country of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientName | Gets or sets the name of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientState | Gets or sets the state of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientTitle | Gets or sets the title associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientZip | Gets or sets the zip code of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderAddress | Gets or sets the address of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderCompany | Gets or sets the company name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderDepartment | Gets or sets the department name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderName | Gets or sets the name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderTitle | Gets or sets the title title associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | Subject | Gets or sets the subject for the fax to be sent. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Top

See Also

Reference

LocalCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FilePath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > LocalCoverPage Class : FilePath Property

Gets or sets the file path of the local cover page (*.cov) file.

Syntax

Visual Basic (Declaration)
Public Property FilePath As String
C#
public string FilePath {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LocalCoverPage Class
LocalCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaType Class

Represents a media type.

Object Model

MediaType Class

Syntax

Visual Basic (Declaration)
Public Class MediaType
C#
public class MediaType

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, and selects the media type from the printer media type list and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim printJob As New PrintJob(Printer.[Default], "C:\Temp\DocumentA.pdf")

        ' Find media types available for default printer
        Dim mediaTypeList As MediaTypeList = Printer.[Default].MediaTypes

        ' Set appropriate media type.
        If mediaTypeList.Standard IsNot Nothing Then
        printJob.PrintOptions.MediaType = mediaTypeList.Standard
        End If

        ' Print the job
        printJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");
        // Find media types available for default printer
        MediaTypeList mediaTypeList = Printer.Default.MediaTypes;

        // Set appropriate media type.
        if(mediaTypeList.Standard!= null)
        printJob.PrintOptions.MediaType = mediaTypeList.Standard;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.MediaType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaType Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaType Class

The following tables list the members exposed by MediaType.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the media type.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MediaType Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaType Class

For a list of all members of this type, see MediaType members.

Public Properties

 | Name | Description
Public Property | Name | Gets the name of the media type.
Top

See Also

Reference

MediaType Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Name Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaType Class : Name Property

Gets the name of the media type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaType Class
MediaType Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaTypeList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaTypeList Class

Represents a list of media types.

Object Model

MediaTypeList ClassMediaType Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class MediaTypeList
   Implements System.Collections.Generic.IEnumerable(Of MediaType), System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class MediaTypeList : System.Collections.Generic.IEnumerable<MediaType>, System.Collections.IEnumerable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, and selects the media type from the printer media type list and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim printJob As New PrintJob(Printer.[Default], "C:\Temp\DocumentA.pdf")

        ' Find media types available for default printer
        Dim mediaTypeList As MediaTypeList = Printer.[Default].MediaTypes

        ' Set appropriate media type.
        If mediaTypeList.Standard IsNot Nothing Then
        printJob.PrintOptions.MediaType = mediaTypeList.Standard
        End If

        ' Print the job
        printJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob(Printer.Default, "C:\\Temp\\DocumentA.pdf");
        // Find media types available for default printer
        MediaTypeList mediaTypeList = Printer.Default.MediaTypes;

        // Set appropriate media type.
        if(mediaTypeList.Standard!= null)
        printJob.PrintOptions.MediaType = mediaTypeList.Standard;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.MediaTypeList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaTypeList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaTypeList Class

The following tables list the members exposed by MediaTypeList.

Public Properties

 | Name | Description
Public Property | Count | Gets the media type count.
Public Property | Glossy | Gets the glossy media type if it is specified by the printer.
Public Property | Item | Overloaded. Gets the media type by its index.
Public Property | Standard | Gets the standard media type if it is specified by the printer.
Public Property | Transperancy | Gets the transperancy media type if it is specified by the printer.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MediaTypeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaTypeList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaTypeList Class

For a list of all members of this type, see MediaTypeList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the media type count.
Public Property | Glossy | Gets the glossy media type if it is specified by the printer.
Public Property | Item | Overloaded. Gets the media type by its index.
Public Property | Standard | Gets the standard media type if it is specified by the printer.
Public Property | Transperancy | Gets the transperancy media type if it is specified by the printer.
Top

See Also

Reference

MediaTypeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class : Count Property

Gets the media type count.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Glossy Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class : Glossy Property

Gets the glossy media type if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Glossy As MediaType
C#
public MediaType Glossy {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class : Item Property

Gets the media type by its index.

Overload List

Overload | Description
Item(String) |
Item(Int32) | Gets the media type by its index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(String) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class > Item Property : Item(String) Property

name

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As MediaType
C#
public MediaType Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(Int32) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class > Item Property : Item(Int32) Property

index
Gets the media type by its index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As MediaType
C#
public MediaType Item(
   int index
) {get;}

Parameters

index

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Standard Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class : Standard Property

Gets the standard media type if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Standard As MediaType
C#
public MediaType Standard {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Transperancy Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > MediaTypeList Class : Transperancy Property

Gets the transperancy media type if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Transperancy As MediaType
C#
public MediaType Transperancy {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

MediaTypeList Class
MediaTypeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageOrientation Class

Represents the page orientation.

Object Model

PageOrientation Class

Syntax

Visual Basic (Declaration)
Public Class PageOrientation
C#
public class PageOrientation

Example

The following examples creates a print job, sets the orientation and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job containing the first four pages of the PDF
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf", 1, 4)

        ' Set the orientation for the print job
        MyPrintJob.PrintOptions.Orientation.Type = OrientationType.Landscape

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job containing the first four pages of the PDF
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf", 1, 4);

        // Set the orientation for the print job
        printJob.PrintOptions.Orientation.Type = OrientationType.Landscape;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PageOrientation

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageOrientation Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageOrientation Class

The following tables list the members exposed by PageOrientation.

Public Properties

 | Name | Description
Public Property | Rotated | Gets or sets the value indicating if the page is to be rotated 180 degrees.
Public Property | Type | Gets or sets the orientation type for the page to be printed.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageOrientation Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageOrientation Class

For a list of all members of this type, see PageOrientation members.

Public Properties

 | Name | Description
Public Property | Rotated | Gets or sets the value indicating if the page is to be rotated 180 degrees.
Public Property | Type | Gets or sets the orientation type for the page to be printed.
Top

See Also

Reference

PageOrientation Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PageOrientation Class : Rotated Property

Gets or sets the value indicating if the page is to be rotated 180 degrees.

Syntax

Visual Basic (Declaration)
Public Property Rotated As Boolean
C#
public bool Rotated {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageOrientation Class
PageOrientation Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Type Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PageOrientation Class : Type Property

Gets or sets the orientation type for the page to be printed.

Syntax

Visual Basic (Declaration)
Public Property Type As OrientationType
C#
public OrientationType Type {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageOrientation Class
PageOrientation Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageScaling Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageScaling Class

Represents the scaling for the page to be printed.

Object Model

PageScaling ClassActualSizePageScaling Class

Syntax

Visual Basic (Declaration)
Public MustInherit Class PageScaling
C#
public abstract class PageScaling

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the scaling propety to actual size and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the scaling
        MyPrintJob.PrintOptions.Scaling = PageScaling.ActualSize

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the scaling
        printJob.PrintOptions.Scaling = PageScaling.ActualSize;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PageScaling
Foxit.PDF.Printing.ActualSizePageScaling
Foxit.PDF.Printing.AutoPageScaling

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageScaling Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageScaling Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageScaling Class

The following tables list the members exposed by PageScaling.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ActualSize | Gets the actual scaling size for the page to be print.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageScaling Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageScaling Class

For a list of all members of this type, see PageScaling members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ActualSize | Gets the actual scaling size for the page to be print.
Top

See Also

Reference

PageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActualSize Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PageScaling Class : ActualSize Property

Gets the actual scaling size for the page to be print.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property ActualSize As ActualSizePageScaling
C#
public static ActualSizePageScaling ActualSize {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageScaling Class
PageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSize Class

Represents a paper.

Object Model

PaperSize Class

Syntax

Visual Basic (Declaration)
Public Class PaperSize
C#
public class PaperSize

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the paper size and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get a paper size from the list
        Dim MyPaperSize As PaperSize = MyPrintJob.Printer.PaperSizes.Letter

        ' Set the paper size if it is supported by the printer
        If (Not MyPaperSize Is Nothing) Then
            MyPrintJob.PrintOptions.PaperSize = MyPaperSize
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get a paper size from the list
        PaperSize paperSize = printJob.Printer.PaperSizes.Letter;

        // Set the paper size if it is supported by the printer
        if (paperSize != null)
        {
            printJob.PrintOptions.PaperSize = paperSize;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PaperSize

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSize Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSize Class

The following tables list the members exposed by PaperSize.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the paper.
Public Property | Name | Gets the name of the paper size.
Public Property | Width | Gets the width of the paper.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSize Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSize Class

For a list of all members of this type, see PaperSize members.

Public Properties

 | Name | Description
Public Property | Height | Gets the height of the paper.
Public Property | Name | Gets the name of the paper size.
Public Property | Width | Gets the width of the paper.
Top

See Also

Reference

PaperSize Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Height Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSize Class : Height Property

Gets the height of the paper.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Height As Double
C#
public double Height {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSize Class
PaperSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Name Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSize Class : Name Property

Gets the name of the paper size.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSize Class
PaperSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Width Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSize Class : Width Property

Gets the width of the paper.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Width As Double
C#
public double Width {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSize Class
PaperSize Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSizeList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSizeList Class

Represents a list of papers.

Object Model

PaperSizeList ClassPaperSize Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PaperSizeList
   Implements System.Collections.Generic.IEnumerable(Of PaperSize), System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class PaperSizeList : System.Collections.Generic.IEnumerable<PaperSize>, System.Collections.IEnumerable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the paper size and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get the list of available paper sizes for the printer
        Dim MyPaperSizes As PaperSizeList = MyPrintJob.Printer.PaperSizes

        ' Set the paper size
        MyPrintJob.PrintOptions.PaperSize = MyPaperSizes(0)

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get the list of available paper sizes for the printer
        PaperSizeList paperSizes = printJob.Printer.PaperSizes;

        // Set the paper size
        printJob.PrintOptions.PaperSize = paperSizes[0];

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PaperSizeList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSizeList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSizeList Class

The following tables list the members exposed by PaperSizeList.

Public Properties

 | Name | Description
Public Property | A2 | Gets the A2 paper size if it is specified by the printer.
Public Property | A3 | Gets the A3 paper size if it is specified by the printer.
Public Property | A3Extra | Gets the A3 extra paper size if it is specified by the printer.
Public Property | A3ExtraTransverse | Gets the A3 extra transverse paper size if it is specified by the printer.
Public Property | A3Rotated | Gets the A3 rotated paper size if it is specified by the printer.
Public Property | A3Transverse | Gets the A3 transverse paper size if it is specified by the printer.
Public Property | A4 | Gets the A4 paper size if it is specified by the printer.
Public Property | A4Extra | Gets the A4 extra paper size if it is specified by the printer.
Public Property | A4Plus | Gets the A4 plus paper size if it is specified by the printer.
Public Property | A4Rotated | Gets the A4 rotated paper size if it is specified by the printer.
Public Property | A4Small | Gets the A4 small paper size if it is specified by the printer.
Public Property | A4Transverse | Gets the A4 transverse paper size if it is specified by the printer.
Public Property | A5 | Gets the A5 paper size if it is specified by the printer.
Public Property | A5Extra | Gets the A5 extra paper size if it is specified by the printer.
Public Property | A5Rotated | Gets the A5 rotated paper size if it is specified by the printer.
Public Property | A5Transverse | Gets the A5 transverse paper size if it is specified by the printer.
Public Property | A6 | Gets the A6 paper size if it is specified by the printer.
Public Property | A6Rotated | Gets the A6 rotated paper size if it is specified by the printer.
Public Property | APlus | Gets the A plus paper size if it is specified by the printer.
Public Property | B4 | Gets the B4 paper size if it is specified by the printer.
Public Property | B4JisRotated | Gets the B4 JIS rotated paper size if it is specified by the printer.
Public Property | B5 | Gets the B5 paper size if it is specified by the printer.
Public Property | B5Extra | Gets the B5 extra paper size if it is specified by the printer.
Public Property | B5JisRotated | Gets the B5 JIS rotated paper size '' if it is specified by the printer.
Public Property | B6Jis | Gets the B6 JIS paper size if it is specified by the printer.
Public Property | B6JisRotated | Gets the B6 JIS rotated paper size if it is specified by the printer.
Public Property | BPlus | Gets the B plus paper size if it is specified by the printer.
Public Property | Count | Gets the number of paper sources in the list.
Public Property | CSheet | Gets the C sheet paper size if it is specified by the printer.
Public Property | DblJapanesePostcard | Gets the double Japanese postcard paper size if it is specified by the printer.
Public Property | DblJapanesePostcardRotated | Gets the double Japanese postcard rotated paper size if it is specified by the printer.
Public Property | DSheet | Gets the D sheet paper size if it is specified by the printer.
Public Property | Envelope10 | Gets the envelope 10 paper size if it is specified by the printer.
Public Property | Envelope11 | Gets the envelope 11 paper size if it is specified by the printer.
Public Property | Envelope12 | Gets the envelope 12 paper size if it is specified by the printer.
Public Property | Envelope14 | Gets the envelope 14 paper size if it is specified by the printer.
Public Property | Envelope9 | Gets the envelope 9 paper size if it is specified by the printer.
Public Property | EnvelopeB4 | Gets the envelope B4 paper size if it is specified by the printer.
Public Property | EnvelopeB5 | Gets the envelope B5 paper size if it is specified by the printer.
Public Property | EnvelopeB6 | Gets the envelope B6 paper size if it is specified by the printer.
Public Property | EnvelopeC3 | Gets the envelope C3 paper size if it is specified by the printer.
Public Property | EnvelopeC4 | Gets the envelope C4 paper size if it is specified by the printer.
Public Property | EnvelopeC5 | Gets the envelope C5 paper size if it is specified by the printer.
Public Property | EnvelopeC6 | Gets the envelope C6 paper size if it is specified by the printer.
Public Property | EnvelopeC65 | Gets the envelope C65 paper size if it is specified by the printer.
Public Property | EnvelopeDL | Gets the envelope DL paper size if it is specified by the printer.
Public Property | EnvelopeInvite | Gets the envelope invite paper size if it is specified by the printer.
Public Property | EnvelopeItaly | Gets the envelope Italy paper size if it is specified by the printer.
Public Property | EnvelopeMonarch | Gets the envelope monarch paper size if it is specified by the printer.
Public Property | EnvelopePersonal | Gets the envelope personal paper size if it is specified by the printer.
Public Property | ESheet | Gets the E sheet paper size if it is specified by the printer.
Public Property | Executive | Gets the executive paper size if it is specified by the printer.
Public Property | FanfoldLegalGerman | Gets the German fanfold legal paper size if it is specified by the printer.
Public Property | FanfoldStandardGerman | Gets the German fanfold standard paper size if it is specified by the printer.
Public Property | FanfoldUs | Gets the US fanfold paper size if it is specified by the printer.
Public Property | Folio | Gets the folio paper size if it is specified by the printer.
Public Property | IsoB4 | Gets the ISO B4 paper size if it is specified by the printer.
Public Property | Item | Overloaded. Gets a PaperSize object by index.
Public Property | JapaneseEnvelopeChou3 | Gets the Japanese envelope Chou 3 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou3Rotated | Gets the Japanese envelope Chou 3 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou4 | Gets the Japanese envelope Chou 4 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou4Rotated | Gets the Japanese envelope Chou 4 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku2 | Gets the Japanese envelope Kaku 2 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku2Rotated | Gets the Japanese envelope Kaku 2 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku3 | Gets the Japanese envelope Kaku 3 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku3Rotated | Gets the Japanese envelope Kaku 3 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeYou4 | Gets the Japanese envelope You 4 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeYou4Rotated | Gets the Japanese envelope You 4 rotated paper size if it is specified by the printer.
Public Property | JapanesePostcard | Gets the Japanese postcard paper size if it is specified by the printer.
Public Property | JapanesePostcardRotated | Gets the Japanese postcard rotated paper size if it is specified by the printer.
Public Property | Last | Gets the last paper size if it is specified by the printer.
Public Property | Ledger | Gets the ledger paper size if it is specified by the printer.
Public Property | Legal | Gets the US Legal paper size if it is specified by the printer.
Public Property | LegalExtra | Gets the legal extra paper size if it is specified by the printer.
Public Property | Letter | Gets the US Letter paper size if it is specified by the printer.
Public Property | LetterExtra | Gets the letter extra paper size if it is specified by the printer.
Public Property | LetterExtraTransverse | Gets the letter extra transverse paper size if it is specified by the printer.
Public Property | LetterRotated | Gets the letter rotated paper size if it is specified by the printer.
Public Property | LetterSmall | Gets the letter small paper size if it is specified by the printer.
Public Property | LetterTransverse | Gets the letter transverse paper size if it is specified by the printer.
Public Property | Note | Gets the note paper size if it is specified by the printer.
Public Property | Prc16K | Gets the PRC 16K paper size if it is specified by the printer.
Public Property | Prc16KRotated | Gets the PRC 16K rotated paper size if it is specified by the printer.
Public Property | Prc32K | Gets the PRC 32K paper size if it is specified by the printer.
Public Property | Prc32KBig | Gets the PRC 32K big paper size if it is specified by the printer.
Public Property | Prc32KBigRotated | Gets the PRC 32K big rotated paper size if it is specified by the printer.
Public Property | Prc32KRotated | Gets the PRC 32K rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope1 | Gets the PRC envelope 1 paper size if it is specified by the printer.
Public Property | PrcEnvelope10 | Gets the PRC envelope 10 paper size if it is specified by the printer.
Public Property | PrcEnvelope10Rotated | Gets the PRC envelope 10 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope1Rotated | Gets the PRC envelope 1 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope2 | Gets the PRC envelope 2 paper size if it is specified by the printer.
Public Property | PrcEnvelope2Rotated | Gets the PRC envelope 2 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope3 | Gets the PRC envelope 3 paper size if it is specified by the printer.
Public Property | PrcEnvelope3Rotated | Gets the PRC envelope 3 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope4 | Gets the PRC envelope 4 paper size if it is specified by the printer.
Public Property | PrcEnvelope4Rotated | Gets the PRC envelope 4 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope5 | Gets the PRC envelope 5 paper size if it is specified by the printer.
Public Property | PrcEnvelope5Rotated | Gets the PRC envelope 5 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope6 | Gets the PRC envelope 6 paper size if it is specified by the printer.
Public Property | PrcEnvelope6Rotated | Gets the PRC envelope 6 rotated size if it is specified by the printer.
Public Property | PrcEnvelope7 | Gets the PRC envelope 7 paper size if it is specified by the printer.
Public Property | PrcEnvelope7Rotated | Gets the PRC envelope 7 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope8 | Gets the PRC envelope 8 paper size if it is specified by the printer.
Public Property | PrcEnvelope8Rotated | Gets the PRC envelope 8 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope9 | Gets the PRC envelope 9 paper size if it is specified by the printer.
Public Property | PrcEnvelope9Rotated | Gets the PRC envelope 9 rotated paper size if it is specified by the printer.
Public Property | Quatro | Gets the quatro paper size if it is specified by the printer.
Public Property | Size10By11 | Gets the paper size 10 by 11 if it is specified by the printer.
Public Property | Size10By14 | Gets the paper size 10 by 14 if it is specified by the printer.
Public Property | Size11By17 | Gets the paper size 11 by 17 if it is specified by the printer.
Public Property | Size12By11 | Gets the paper size 12 by 11 if it is specified by the printer.
Public Property | Size15By11 | Gets the paper size 15 by 11 if it is specified by the printer.
Public Property | Size9By11 | Gets the paper size 9 by 11 if it is specified by the printer.
Public Property | Statement | Gets the statement paper size if it is specified by the printer.
Public Property | Tabloid | Gets the tabloid paper size if it is specified by the printer.
Public Property | TabloidExtra | Gets the tabloid extra paper size if it is specified by the printer.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSizeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSizeList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSizeList Class

For a list of all members of this type, see PaperSizeList members.

Public Properties

 | Name | Description
Public Property | A2 | Gets the A2 paper size if it is specified by the printer.
Public Property | A3 | Gets the A3 paper size if it is specified by the printer.
Public Property | A3Extra | Gets the A3 extra paper size if it is specified by the printer.
Public Property | A3ExtraTransverse | Gets the A3 extra transverse paper size if it is specified by the printer.
Public Property | A3Rotated | Gets the A3 rotated paper size if it is specified by the printer.
Public Property | A3Transverse | Gets the A3 transverse paper size if it is specified by the printer.
Public Property | A4 | Gets the A4 paper size if it is specified by the printer.
Public Property | A4Extra | Gets the A4 extra paper size if it is specified by the printer.
Public Property | A4Plus | Gets the A4 plus paper size if it is specified by the printer.
Public Property | A4Rotated | Gets the A4 rotated paper size if it is specified by the printer.
Public Property | A4Small | Gets the A4 small paper size if it is specified by the printer.
Public Property | A4Transverse | Gets the A4 transverse paper size if it is specified by the printer.
Public Property | A5 | Gets the A5 paper size if it is specified by the printer.
Public Property | A5Extra | Gets the A5 extra paper size if it is specified by the printer.
Public Property | A5Rotated | Gets the A5 rotated paper size if it is specified by the printer.
Public Property | A5Transverse | Gets the A5 transverse paper size if it is specified by the printer.
Public Property | A6 | Gets the A6 paper size if it is specified by the printer.
Public Property | A6Rotated | Gets the A6 rotated paper size if it is specified by the printer.
Public Property | APlus | Gets the A plus paper size if it is specified by the printer.
Public Property | B4 | Gets the B4 paper size if it is specified by the printer.
Public Property | B4JisRotated | Gets the B4 JIS rotated paper size if it is specified by the printer.
Public Property | B5 | Gets the B5 paper size if it is specified by the printer.
Public Property | B5Extra | Gets the B5 extra paper size if it is specified by the printer.
Public Property | B5JisRotated | Gets the B5 JIS rotated paper size '' if it is specified by the printer.
Public Property | B6Jis | Gets the B6 JIS paper size if it is specified by the printer.
Public Property | B6JisRotated | Gets the B6 JIS rotated paper size if it is specified by the printer.
Public Property | BPlus | Gets the B plus paper size if it is specified by the printer.
Public Property | Count | Gets the number of paper sources in the list.
Public Property | CSheet | Gets the C sheet paper size if it is specified by the printer.
Public Property | DblJapanesePostcard | Gets the double Japanese postcard paper size if it is specified by the printer.
Public Property | DblJapanesePostcardRotated | Gets the double Japanese postcard rotated paper size if it is specified by the printer.
Public Property | DSheet | Gets the D sheet paper size if it is specified by the printer.
Public Property | Envelope10 | Gets the envelope 10 paper size if it is specified by the printer.
Public Property | Envelope11 | Gets the envelope 11 paper size if it is specified by the printer.
Public Property | Envelope12 | Gets the envelope 12 paper size if it is specified by the printer.
Public Property | Envelope14 | Gets the envelope 14 paper size if it is specified by the printer.
Public Property | Envelope9 | Gets the envelope 9 paper size if it is specified by the printer.
Public Property | EnvelopeB4 | Gets the envelope B4 paper size if it is specified by the printer.
Public Property | EnvelopeB5 | Gets the envelope B5 paper size if it is specified by the printer.
Public Property | EnvelopeB6 | Gets the envelope B6 paper size if it is specified by the printer.
Public Property | EnvelopeC3 | Gets the envelope C3 paper size if it is specified by the printer.
Public Property | EnvelopeC4 | Gets the envelope C4 paper size if it is specified by the printer.
Public Property | EnvelopeC5 | Gets the envelope C5 paper size if it is specified by the printer.
Public Property | EnvelopeC6 | Gets the envelope C6 paper size if it is specified by the printer.
Public Property | EnvelopeC65 | Gets the envelope C65 paper size if it is specified by the printer.
Public Property | EnvelopeDL | Gets the envelope DL paper size if it is specified by the printer.
Public Property | EnvelopeInvite | Gets the envelope invite paper size if it is specified by the printer.
Public Property | EnvelopeItaly | Gets the envelope Italy paper size if it is specified by the printer.
Public Property | EnvelopeMonarch | Gets the envelope monarch paper size if it is specified by the printer.
Public Property | EnvelopePersonal | Gets the envelope personal paper size if it is specified by the printer.
Public Property | ESheet | Gets the E sheet paper size if it is specified by the printer.
Public Property | Executive | Gets the executive paper size if it is specified by the printer.
Public Property | FanfoldLegalGerman | Gets the German fanfold legal paper size if it is specified by the printer.
Public Property | FanfoldStandardGerman | Gets the German fanfold standard paper size if it is specified by the printer.
Public Property | FanfoldUs | Gets the US fanfold paper size if it is specified by the printer.
Public Property | Folio | Gets the folio paper size if it is specified by the printer.
Public Property | IsoB4 | Gets the ISO B4 paper size if it is specified by the printer.
Public Property | Item | Overloaded. Gets a PaperSize object by index.
Public Property | JapaneseEnvelopeChou3 | Gets the Japanese envelope Chou 3 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou3Rotated | Gets the Japanese envelope Chou 3 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou4 | Gets the Japanese envelope Chou 4 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeChou4Rotated | Gets the Japanese envelope Chou 4 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku2 | Gets the Japanese envelope Kaku 2 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku2Rotated | Gets the Japanese envelope Kaku 2 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku3 | Gets the Japanese envelope Kaku 3 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeKaku3Rotated | Gets the Japanese envelope Kaku 3 rotated paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeYou4 | Gets the Japanese envelope You 4 paper size if it is specified by the printer.
Public Property | JapaneseEnvelopeYou4Rotated | Gets the Japanese envelope You 4 rotated paper size if it is specified by the printer.
Public Property | JapanesePostcard | Gets the Japanese postcard paper size if it is specified by the printer.
Public Property | JapanesePostcardRotated | Gets the Japanese postcard rotated paper size if it is specified by the printer.
Public Property | Last | Gets the last paper size if it is specified by the printer.
Public Property | Ledger | Gets the ledger paper size if it is specified by the printer.
Public Property | Legal | Gets the US Legal paper size if it is specified by the printer.
Public Property | LegalExtra | Gets the legal extra paper size if it is specified by the printer.
Public Property | Letter | Gets the US Letter paper size if it is specified by the printer.
Public Property | LetterExtra | Gets the letter extra paper size if it is specified by the printer.
Public Property | LetterExtraTransverse | Gets the letter extra transverse paper size if it is specified by the printer.
Public Property | LetterRotated | Gets the letter rotated paper size if it is specified by the printer.
Public Property | LetterSmall | Gets the letter small paper size if it is specified by the printer.
Public Property | LetterTransverse | Gets the letter transverse paper size if it is specified by the printer.
Public Property | Note | Gets the note paper size if it is specified by the printer.
Public Property | Prc16K | Gets the PRC 16K paper size if it is specified by the printer.
Public Property | Prc16KRotated | Gets the PRC 16K rotated paper size if it is specified by the printer.
Public Property | Prc32K | Gets the PRC 32K paper size if it is specified by the printer.
Public Property | Prc32KBig | Gets the PRC 32K big paper size if it is specified by the printer.
Public Property | Prc32KBigRotated | Gets the PRC 32K big rotated paper size if it is specified by the printer.
Public Property | Prc32KRotated | Gets the PRC 32K rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope1 | Gets the PRC envelope 1 paper size if it is specified by the printer.
Public Property | PrcEnvelope10 | Gets the PRC envelope 10 paper size if it is specified by the printer.
Public Property | PrcEnvelope10Rotated | Gets the PRC envelope 10 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope1Rotated | Gets the PRC envelope 1 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope2 | Gets the PRC envelope 2 paper size if it is specified by the printer.
Public Property | PrcEnvelope2Rotated | Gets the PRC envelope 2 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope3 | Gets the PRC envelope 3 paper size if it is specified by the printer.
Public Property | PrcEnvelope3Rotated | Gets the PRC envelope 3 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope4 | Gets the PRC envelope 4 paper size if it is specified by the printer.
Public Property | PrcEnvelope4Rotated | Gets the PRC envelope 4 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope5 | Gets the PRC envelope 5 paper size if it is specified by the printer.
Public Property | PrcEnvelope5Rotated | Gets the PRC envelope 5 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope6 | Gets the PRC envelope 6 paper size if it is specified by the printer.
Public Property | PrcEnvelope6Rotated | Gets the PRC envelope 6 rotated size if it is specified by the printer.
Public Property | PrcEnvelope7 | Gets the PRC envelope 7 paper size if it is specified by the printer.
Public Property | PrcEnvelope7Rotated | Gets the PRC envelope 7 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope8 | Gets the PRC envelope 8 paper size if it is specified by the printer.
Public Property | PrcEnvelope8Rotated | Gets the PRC envelope 8 rotated paper size if it is specified by the printer.
Public Property | PrcEnvelope9 | Gets the PRC envelope 9 paper size if it is specified by the printer.
Public Property | PrcEnvelope9Rotated | Gets the PRC envelope 9 rotated paper size if it is specified by the printer.
Public Property | Quatro | Gets the quatro paper size if it is specified by the printer.
Public Property | Size10By11 | Gets the paper size 10 by 11 if it is specified by the printer.
Public Property | Size10By14 | Gets the paper size 10 by 14 if it is specified by the printer.
Public Property | Size11By17 | Gets the paper size 11 by 17 if it is specified by the printer.
Public Property | Size12By11 | Gets the paper size 12 by 11 if it is specified by the printer.
Public Property | Size15By11 | Gets the paper size 15 by 11 if it is specified by the printer.
Public Property | Size9By11 | Gets the paper size 9 by 11 if it is specified by the printer.
Public Property | Statement | Gets the statement paper size if it is specified by the printer.
Public Property | Tabloid | Gets the tabloid paper size if it is specified by the printer.
Public Property | TabloidExtra | Gets the tabloid extra paper size if it is specified by the printer.
Top

See Also

Reference

PaperSizeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A2 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A2 Property

Gets the A2 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A2 As PaperSize
C#
public PaperSize A2 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A3 Property

Gets the A3 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A3 As PaperSize
C#
public PaperSize A3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A3Extra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A3Extra Property

Gets the A3 extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A3Extra As PaperSize
C#
public PaperSize A3Extra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A3ExtraTransverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A3ExtraTransverse Property

Gets the A3 extra transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A3ExtraTransverse As PaperSize
C#
public PaperSize A3ExtraTransverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A3Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A3Rotated Property

Gets the A3 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A3Rotated As PaperSize
C#
public PaperSize A3Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A3Transverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A3Transverse Property

Gets the A3 transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A3Transverse As PaperSize
C#
public PaperSize A3Transverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4 Property

Gets the A4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4 As PaperSize
C#
public PaperSize A4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4Extra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4Extra Property

Gets the A4 extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4Extra As PaperSize
C#
public PaperSize A4Extra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4Plus Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4Plus Property

Gets the A4 plus paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4Plus As PaperSize
C#
public PaperSize A4Plus {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4Rotated Property

Gets the A4 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4Rotated As PaperSize
C#
public PaperSize A4Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4Small Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4Small Property

Gets the A4 small paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4Small As PaperSize
C#
public PaperSize A4Small {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A4Transverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A4Transverse Property

Gets the A4 transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A4Transverse As PaperSize
C#
public PaperSize A4Transverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A5 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A5 Property

Gets the A5 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A5 As PaperSize
C#
public PaperSize A5 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A5Extra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A5Extra Property

Gets the A5 extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A5Extra As PaperSize
C#
public PaperSize A5Extra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A5Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A5Rotated Property

Gets the A5 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A5Rotated As PaperSize
C#
public PaperSize A5Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A5Transverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A5Transverse Property

Gets the A5 transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A5Transverse As PaperSize
C#
public PaperSize A5Transverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A6 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A6 Property

Gets the A6 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A6 As PaperSize
C#
public PaperSize A6 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
A6Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : A6Rotated Property

Gets the A6 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property A6Rotated As PaperSize
C#
public PaperSize A6Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
APlus Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : APlus Property

Gets the A plus paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property APlus As PaperSize
C#
public PaperSize APlus {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B4 Property

Gets the B4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B4 As PaperSize
C#
public PaperSize B4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B4JisRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B4JisRotated Property

Gets the B4 JIS rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B4JisRotated As PaperSize
C#
public PaperSize B4JisRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B5 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B5 Property

Gets the B5 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B5 As PaperSize
C#
public PaperSize B5 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B5Extra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B5Extra Property

Gets the B5 extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B5Extra As PaperSize
C#
public PaperSize B5Extra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B5JisRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B5JisRotated Property

Gets the B5 JIS rotated paper size '' if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B5JisRotated As PaperSize
C#
public PaperSize B5JisRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B6Jis Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B6Jis Property

Gets the B6 JIS paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B6Jis As PaperSize
C#
public PaperSize B6Jis {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
B6JisRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : B6JisRotated Property

Gets the B6 JIS rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property B6JisRotated As PaperSize
C#
public PaperSize B6JisRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
BPlus Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : BPlus Property

Gets the B plus paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BPlus As PaperSize
C#
public PaperSize BPlus {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Count Property

Gets the number of paper sources in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CSheet Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : CSheet Property

Gets the C sheet paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CSheet As PaperSize
C#
public PaperSize CSheet {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DblJapanesePostcard Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : DblJapanesePostcard Property

Gets the double Japanese postcard paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DblJapanesePostcard As PaperSize
C#
public PaperSize DblJapanesePostcard {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DblJapanesePostcardRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : DblJapanesePostcardRotated Property

Gets the double Japanese postcard rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DblJapanesePostcardRotated As PaperSize
C#
public PaperSize DblJapanesePostcardRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DSheet Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : DSheet Property

Gets the D sheet paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property DSheet As PaperSize
C#
public PaperSize DSheet {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope10 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Envelope10 Property

Gets the envelope 10 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope10 As PaperSize
C#
public PaperSize Envelope10 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope11 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Envelope11 Property

Gets the envelope 11 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope11 As PaperSize
C#
public PaperSize Envelope11 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope12 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Envelope12 Property

Gets the envelope 12 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope12 As PaperSize
C#
public PaperSize Envelope12 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope14 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Envelope14 Property

Gets the envelope 14 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope14 As PaperSize
C#
public PaperSize Envelope14 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope9 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Envelope9 Property

Gets the envelope 9 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope9 As PaperSize
C#
public PaperSize Envelope9 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeB4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeB4 Property

Gets the envelope B4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeB4 As PaperSize
C#
public PaperSize EnvelopeB4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeB5 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeB5 Property

Gets the envelope B5 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeB5 As PaperSize
C#
public PaperSize EnvelopeB5 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeB6 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeB6 Property

Gets the envelope B6 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeB6 As PaperSize
C#
public PaperSize EnvelopeB6 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeC3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeC3 Property

Gets the envelope C3 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeC3 As PaperSize
C#
public PaperSize EnvelopeC3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeC4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeC4 Property

Gets the envelope C4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeC4 As PaperSize
C#
public PaperSize EnvelopeC4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeC5 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeC5 Property

Gets the envelope C5 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeC5 As PaperSize
C#
public PaperSize EnvelopeC5 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeC6 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeC6 Property

Gets the envelope C6 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeC6 As PaperSize
C#
public PaperSize EnvelopeC6 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeC65 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeC65 Property

Gets the envelope C65 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeC65 As PaperSize
C#
public PaperSize EnvelopeC65 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeDL Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeDL Property

Gets the envelope DL paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeDL As PaperSize
C#
public PaperSize EnvelopeDL {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeInvite Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeInvite Property

Gets the envelope invite paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeInvite As PaperSize
C#
public PaperSize EnvelopeInvite {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeItaly Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeItaly Property

Gets the envelope Italy paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeItaly As PaperSize
C#
public PaperSize EnvelopeItaly {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeMonarch Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopeMonarch Property

Gets the envelope monarch paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeMonarch As PaperSize
C#
public PaperSize EnvelopeMonarch {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopePersonal Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : EnvelopePersonal Property

Gets the envelope personal paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopePersonal As PaperSize
C#
public PaperSize EnvelopePersonal {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ESheet Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : ESheet Property

Gets the E sheet paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ESheet As PaperSize
C#
public PaperSize ESheet {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Executive Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Executive Property

Gets the executive paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Executive As PaperSize
C#
public PaperSize Executive {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FanfoldLegalGerman Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : FanfoldLegalGerman Property

Gets the German fanfold legal paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FanfoldLegalGerman As PaperSize
C#
public PaperSize FanfoldLegalGerman {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FanfoldStandardGerman Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : FanfoldStandardGerman Property

Gets the German fanfold standard paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FanfoldStandardGerman As PaperSize
C#
public PaperSize FanfoldStandardGerman {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FanfoldUs Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : FanfoldUs Property

Gets the US fanfold paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FanfoldUs As PaperSize
C#
public PaperSize FanfoldUs {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Folio Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Folio Property

Gets the folio paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Folio As PaperSize
C#
public PaperSize Folio {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
IsoB4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : IsoB4 Property

Gets the ISO B4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsoB4 As PaperSize
C#
public PaperSize IsoB4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Item Property

Gets a PaperSize object by index.

Overload List

Overload | Description
Item(String) |
Item(Int32) | Gets a PaperSize object by index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(String) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class > Item Property : Item(String) Property

name

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As PaperSize
C#
public PaperSize Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(Int32) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class > Item Property : Item(Int32) Property

index
The index of the paper size to be returned.
Gets a PaperSize object by index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperSize
C#
public PaperSize Item(
   int index
) {get;}

Parameters

index
The index of the paper size to be returned.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeChou3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeChou3 Property

Gets the Japanese envelope Chou 3 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeChou3 As PaperSize
C#
public PaperSize JapaneseEnvelopeChou3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeChou3Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeChou3Rotated Property

Gets the Japanese envelope Chou 3 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeChou3Rotated As PaperSize
C#
public PaperSize JapaneseEnvelopeChou3Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeChou4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeChou4 Property

Gets the Japanese envelope Chou 4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeChou4 As PaperSize
C#
public PaperSize JapaneseEnvelopeChou4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeChou4Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeChou4Rotated Property

Gets the Japanese envelope Chou 4 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeChou4Rotated As PaperSize
C#
public PaperSize JapaneseEnvelopeChou4Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeKaku2 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeKaku2 Property

Gets the Japanese envelope Kaku 2 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeKaku2 As PaperSize
C#
public PaperSize JapaneseEnvelopeKaku2 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeKaku2Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeKaku2Rotated Property

Gets the Japanese envelope Kaku 2 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeKaku2Rotated As PaperSize
C#
public PaperSize JapaneseEnvelopeKaku2Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeKaku3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeKaku3 Property

Gets the Japanese envelope Kaku 3 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeKaku3 As PaperSize
C#
public PaperSize JapaneseEnvelopeKaku3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeKaku3Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeKaku3Rotated Property

Gets the Japanese envelope Kaku 3 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeKaku3Rotated As PaperSize
C#
public PaperSize JapaneseEnvelopeKaku3Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeYou4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeYou4 Property

Gets the Japanese envelope You 4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeYou4 As PaperSize
C#
public PaperSize JapaneseEnvelopeYou4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapaneseEnvelopeYou4Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapaneseEnvelopeYou4Rotated Property

Gets the Japanese envelope You 4 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapaneseEnvelopeYou4Rotated As PaperSize
C#
public PaperSize JapaneseEnvelopeYou4Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapanesePostcard Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapanesePostcard Property

Gets the Japanese postcard paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapanesePostcard As PaperSize
C#
public PaperSize JapanesePostcard {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JapanesePostcardRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : JapanesePostcardRotated Property

Gets the Japanese postcard rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JapanesePostcardRotated As PaperSize
C#
public PaperSize JapanesePostcardRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Last Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Last Property

Gets the last paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Last As PaperSize
C#
public PaperSize Last {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Ledger Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Ledger Property

Gets the ledger paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Ledger As PaperSize
C#
public PaperSize Ledger {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Legal Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Legal Property

Gets the US Legal paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Legal As PaperSize
C#
public PaperSize Legal {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LegalExtra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LegalExtra Property

Gets the legal extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LegalExtra As PaperSize
C#
public PaperSize LegalExtra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Letter Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Letter Property

Gets the US Letter paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Letter As PaperSize
C#
public PaperSize Letter {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LetterExtra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LetterExtra Property

Gets the letter extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LetterExtra As PaperSize
C#
public PaperSize LetterExtra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LetterExtraTransverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LetterExtraTransverse Property

Gets the letter extra transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LetterExtraTransverse As PaperSize
C#
public PaperSize LetterExtraTransverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LetterRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LetterRotated Property

Gets the letter rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LetterRotated As PaperSize
C#
public PaperSize LetterRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LetterSmall Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LetterSmall Property

Gets the letter small paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LetterSmall As PaperSize
C#
public PaperSize LetterSmall {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LetterTransverse Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : LetterTransverse Property

Gets the letter transverse paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LetterTransverse As PaperSize
C#
public PaperSize LetterTransverse {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Note Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Note Property

Gets the note paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Note As PaperSize
C#
public PaperSize Note {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc16K Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc16K Property

Gets the PRC 16K paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc16K As PaperSize
C#
public PaperSize Prc16K {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc16KRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc16KRotated Property

Gets the PRC 16K rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc16KRotated As PaperSize
C#
public PaperSize Prc16KRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc32K Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc32K Property

Gets the PRC 32K paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc32K As PaperSize
C#
public PaperSize Prc32K {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc32KBig Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc32KBig Property

Gets the PRC 32K big paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc32KBig As PaperSize
C#
public PaperSize Prc32KBig {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc32KBigRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc32KBigRotated Property

Gets the PRC 32K big rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc32KBigRotated As PaperSize
C#
public PaperSize Prc32KBigRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Prc32KRotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Prc32KRotated Property

Gets the PRC 32K rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Prc32KRotated As PaperSize
C#
public PaperSize Prc32KRotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope1 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope1 Property

Gets the PRC envelope 1 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope1 As PaperSize
C#
public PaperSize PrcEnvelope1 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope10 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope10 Property

Gets the PRC envelope 10 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope10 As PaperSize
C#
public PaperSize PrcEnvelope10 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope10Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope10Rotated Property

Gets the PRC envelope 10 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope10Rotated As PaperSize
C#
public PaperSize PrcEnvelope10Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope1Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope1Rotated Property

Gets the PRC envelope 1 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope1Rotated As PaperSize
C#
public PaperSize PrcEnvelope1Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope2 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope2 Property

Gets the PRC envelope 2 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope2 As PaperSize
C#
public PaperSize PrcEnvelope2 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope2Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope2Rotated Property

Gets the PRC envelope 2 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope2Rotated As PaperSize
C#
public PaperSize PrcEnvelope2Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope3 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope3 Property

Gets the PRC envelope 3 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope3 As PaperSize
C#
public PaperSize PrcEnvelope3 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope3Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope3Rotated Property

Gets the PRC envelope 3 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope3Rotated As PaperSize
C#
public PaperSize PrcEnvelope3Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope4 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope4 Property

Gets the PRC envelope 4 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope4 As PaperSize
C#
public PaperSize PrcEnvelope4 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope4Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope4Rotated Property

Gets the PRC envelope 4 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope4Rotated As PaperSize
C#
public PaperSize PrcEnvelope4Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope5 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope5 Property

Gets the PRC envelope 5 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope5 As PaperSize
C#
public PaperSize PrcEnvelope5 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope5Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope5Rotated Property

Gets the PRC envelope 5 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope5Rotated As PaperSize
C#
public PaperSize PrcEnvelope5Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope6 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope6 Property

Gets the PRC envelope 6 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope6 As PaperSize
C#
public PaperSize PrcEnvelope6 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope6Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope6Rotated Property

Gets the PRC envelope 6 rotated size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope6Rotated As PaperSize
C#
public PaperSize PrcEnvelope6Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope7 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope7 Property

Gets the PRC envelope 7 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope7 As PaperSize
C#
public PaperSize PrcEnvelope7 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope7Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope7Rotated Property

Gets the PRC envelope 7 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope7Rotated As PaperSize
C#
public PaperSize PrcEnvelope7Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope8 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope8 Property

Gets the PRC envelope 8 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope8 As PaperSize
C#
public PaperSize PrcEnvelope8 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope8Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope8Rotated Property

Gets the PRC envelope 8 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope8Rotated As PaperSize
C#
public PaperSize PrcEnvelope8Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope9 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope9 Property

Gets the PRC envelope 9 paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope9 As PaperSize
C#
public PaperSize PrcEnvelope9 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrcEnvelope9Rotated Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : PrcEnvelope9Rotated Property

Gets the PRC envelope 9 rotated paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrcEnvelope9Rotated As PaperSize
C#
public PaperSize PrcEnvelope9Rotated {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Quatro Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Quatro Property

Gets the quatro paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Quatro As PaperSize
C#
public PaperSize Quatro {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size10By11 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size10By11 Property

Gets the paper size 10 by 11 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size10By11 As PaperSize
C#
public PaperSize Size10By11 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size10By14 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size10By14 Property

Gets the paper size 10 by 14 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size10By14 As PaperSize
C#
public PaperSize Size10By14 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size11By17 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size11By17 Property

Gets the paper size 11 by 17 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size11By17 As PaperSize
C#
public PaperSize Size11By17 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size12By11 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size12By11 Property

Gets the paper size 12 by 11 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size12By11 As PaperSize
C#
public PaperSize Size12By11 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size15By11 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size15By11 Property

Gets the paper size 15 by 11 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size15By11 As PaperSize
C#
public PaperSize Size15By11 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Size9By11 Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Size9By11 Property

Gets the paper size 9 by 11 if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Size9By11 As PaperSize
C#
public PaperSize Size9By11 {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Statement Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Statement Property

Gets the statement paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Statement As PaperSize
C#
public PaperSize Statement {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Tabloid Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : Tabloid Property

Gets the tabloid paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tabloid As PaperSize
C#
public PaperSize Tabloid {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TabloidExtra Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSizeList Class : TabloidExtra Property

Gets the tabloid extra paper size if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TabloidExtra As PaperSize
C#
public PaperSize TabloidExtra {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSizeList Class
PaperSizeList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSource Class

Represents the paper source.

Object Model

PaperSource Class

Syntax

Visual Basic (Declaration)
Public Class PaperSource
C#
public class PaperSource

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the paper source and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get a paper source from the list
        Dim MyPaperSource As PaperSource = MyPrintJob.Printer.PaperSources.Automatic

        ' Set the paper source if it is supported by the printer
        If (Not MyPaperSource Is Nothing) Then
            MyPrintJob.PrintOptions.PaperSource = MyPaperSource
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get a paper source from the list
        PaperSource paperSource = printJob.Printer.PaperSources.Automatic;

        // Set the paper source if it is supported by the printer
        if (paperSource != null)
        {
            printJob.PrintOptions.PaperSource = paperSource;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PaperSource

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSource Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSource Class

The following tables list the members exposed by PaperSource.

Public Properties

 | Name | Description
Public Property | Name | Gets the paper source name.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSource Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSource Class

For a list of all members of this type, see PaperSource members.

Public Properties

 | Name | Description
Public Property | Name | Gets the paper source name.
Top

See Also

Reference

PaperSource Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Name Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSource Class : Name Property

Gets the paper source name.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSource Class
PaperSource Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSourceList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSourceList Class

Represents a list of paper sources.

Object Model

PaperSourceList ClassPaperSource Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PaperSourceList
   Implements System.Collections.Generic.IEnumerable(Of PaperSource), System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class PaperSourceList : System.Collections.Generic.IEnumerable<PaperSource>, System.Collections.IEnumerable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the paper source and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get the list of available paper sources for the printer
        Dim MyPaperSourceList As PaperSourceList = MyPrintJob.Printer.PaperSources

        ' Set the paper source if it is supported by the printer
        If (Not MyPaperSourceList.Automatic Is Nothing) Then
            MyPrintJob.PrintOptions.PaperSource = MyPaperSourceList.Automatic
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get the list of available paper sources for the printer
        PaperSourceList paperSourceList = printJob.Printer.PaperSources;

        // Set the paper source if it is supported by the printer
        if (paperSourceList.Automatic != null)
        {
            printJob.PrintOptions.PaperSource = paperSourceList.Automatic;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PaperSourceList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSourceList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSourceList Class

The following tables list the members exposed by PaperSourceList.

Public Properties

 | Name | Description
Public Property | Automatic | Gets the 'Automatic' paper source if it is specified by the printer.
Public Property | Cassette | Gets the 'Cassette' paper source if it is supported by the printer.
Public Property | Count | Gets the number of paper sources in the list.
Public Property | Envelope | Gets the 'Envelope' paper source if it is specified by the printer.
Public Property | EnvelopeManual | Gets the 'EnvelopeManual' paper source if it is specified by the printer.
Public Property | First | Gets the 'First' paper source if it is specified by the printer.
Public Property | FormSource | Gets the 'FormSource' paper source if it is specified by the printer.
Public Property | Item | Overloaded. Gets a PaperSource object by index.
Public Property | LargeCapacity | Gets the 'LargeCapacity' paper source if it is specified by the printer.
Public Property | LargeFormat | Gets the 'LargeFormat' paper source if it is specified by the printer.
Public Property | Last | Gets the 'Last' paper source if it is specified by the printer.
Public Property | Lower | Gets the 'Lower' paper source if it is specified by the printer.
Public Property | Manual | Gets the 'Manual' paper source if it is specified by the printer.
Public Property | Middle | Gets the 'Middle' paper source if it is specified by the printer.
Public Property | OnlyOne | Gets the 'OnlyOne' paper source if it is specified by the printer.
Public Property | SmallFormat | Gets the 'SmallFormat' paper source if it is specified by the printer.
Public Property | Tractor | Gets the 'Tractor' paper source if it is specified by the printer.
Public Property | Upper | Gets the 'Upper' paper source if it is specified by the printer.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSourceList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSourceList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSourceList Class

For a list of all members of this type, see PaperSourceList members.

Public Properties

 | Name | Description
Public Property | Automatic | Gets the 'Automatic' paper source if it is specified by the printer.
Public Property | Cassette | Gets the 'Cassette' paper source if it is supported by the printer.
Public Property | Count | Gets the number of paper sources in the list.
Public Property | Envelope | Gets the 'Envelope' paper source if it is specified by the printer.
Public Property | EnvelopeManual | Gets the 'EnvelopeManual' paper source if it is specified by the printer.
Public Property | First | Gets the 'First' paper source if it is specified by the printer.
Public Property | FormSource | Gets the 'FormSource' paper source if it is specified by the printer.
Public Property | Item | Overloaded. Gets a PaperSource object by index.
Public Property | LargeCapacity | Gets the 'LargeCapacity' paper source if it is specified by the printer.
Public Property | LargeFormat | Gets the 'LargeFormat' paper source if it is specified by the printer.
Public Property | Last | Gets the 'Last' paper source if it is specified by the printer.
Public Property | Lower | Gets the 'Lower' paper source if it is specified by the printer.
Public Property | Manual | Gets the 'Manual' paper source if it is specified by the printer.
Public Property | Middle | Gets the 'Middle' paper source if it is specified by the printer.
Public Property | OnlyOne | Gets the 'OnlyOne' paper source if it is specified by the printer.
Public Property | SmallFormat | Gets the 'SmallFormat' paper source if it is specified by the printer.
Public Property | Tractor | Gets the 'Tractor' paper source if it is specified by the printer.
Public Property | Upper | Gets the 'Upper' paper source if it is specified by the printer.
Top

See Also

Reference

PaperSourceList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Automatic Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Automatic Property

Gets the 'Automatic' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Automatic As PaperSource
C#
public PaperSource Automatic {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cassette Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Cassette Property

Gets the 'Cassette' paper source if it is supported by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Cassette As PaperSource
C#
public PaperSource Cassette {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Count Property

Gets the number of paper sources in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Envelope Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Envelope Property

Gets the 'Envelope' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Envelope As PaperSource
C#
public PaperSource Envelope {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
EnvelopeManual Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : EnvelopeManual Property

Gets the 'EnvelopeManual' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property EnvelopeManual As PaperSource
C#
public PaperSource EnvelopeManual {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
First Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : First Property

Gets the 'First' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property First As PaperSource
C#
public PaperSource First {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FormSource Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : FormSource Property

Gets the 'FormSource' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FormSource As PaperSource
C#
public PaperSource FormSource {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Item Property

Gets a PaperSource object by index.

Overload List

Overload | Description
Item(String) |
Item(Int32) | Gets a PaperSource object by index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(String) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class > Item Property : Item(String) Property

name

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As PaperSource
C#
public PaperSource Item(
   string name
) {get;}

Parameters

name

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(Int32) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class > Item Property : Item(Int32) Property

index
The index of the paper source to be returned.
Gets a PaperSource object by index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As PaperSource
C#
public PaperSource Item(
   int index
) {get;}

Parameters

index
The index of the paper source to be returned.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LargeCapacity Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : LargeCapacity Property

Gets the 'LargeCapacity' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LargeCapacity As PaperSource
C#
public PaperSource LargeCapacity {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LargeFormat Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : LargeFormat Property

Gets the 'LargeFormat' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property LargeFormat As PaperSource
C#
public PaperSource LargeFormat {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Last Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Last Property

Gets the 'Last' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Last As PaperSource
C#
public PaperSource Last {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Lower Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Lower Property

Gets the 'Lower' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Lower As PaperSource
C#
public PaperSource Lower {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Manual Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Manual Property

Gets the 'Manual' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Manual As PaperSource
C#
public PaperSource Manual {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Middle Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Middle Property

Gets the 'Middle' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Middle As PaperSource
C#
public PaperSource Middle {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
OnlyOne Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : OnlyOne Property

Gets the 'OnlyOne' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property OnlyOne As PaperSource
C#
public PaperSource OnlyOne {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SmallFormat Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : SmallFormat Property

Gets the 'SmallFormat' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SmallFormat As PaperSource
C#
public PaperSource SmallFormat {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Tractor Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Tractor Property

Gets the 'Tractor' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Tractor As PaperSource
C#
public PaperSource Tractor {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Upper Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PaperSourceList Class : Upper Property

Gets the 'Upper' paper source if it is specified by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Upper As PaperSource
C#
public PaperSource Upper {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PaperSourceList Class
PaperSourceList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PercentagePageScaling Class

Represents the class that allows to specify page scaling size in percentage.

Object Model

PercentagePageScaling Class

Syntax

Visual Basic (Declaration)
Public Class PercentagePageScaling
   Inherits AutoPageScaling
C#
public class PercentagePageScaling : AutoPageScaling

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the page scaling and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Create a PercentagePageScaling object set to 10%
        Dim MyPercentagePageScaling As PercentagePageScaling = New PercentagePageScaling(10.0F)

        ' Set the scaling
        MyPrintJob.PrintOptions.Scaling = MyPercentagePageScaling

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Create a PercentagePageScaling object set to 10%
        PercentagePageScaling percentagePageScaling = new PercentagePageScaling(10f);

        // Set the scaling
        printJob.PrintOptions.Scaling = percentagePageScaling;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PageScaling
Foxit.PDF.Printing.AutoPageScaling
Foxit.PDF.Printing.PercentagePageScaling

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PercentagePageScaling Class

The following tables list the members exposed by PercentagePageScaling.

Public Constructors

 | Name | Description
Public Constructor | PercentagePageScaling Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AutoExpand | Gets or sets a value indicating if the page scaling size can be expanded. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | AutoShrink | Gets or sets a value indicating if the page scaling size can be shrunk. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | ScaleTo | Gets or sets a value indicating the boundaries on the page to use for the scaling. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | ScaleX | Gets the horizontal page scaling in percentage.
Public Property | ScaleY | Gets the vertical page scaling in percentage.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PercentagePageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PercentagePageScaling Class : PercentagePageScaling Constructor

Overload List

Overload | Description
PercentagePageScaling Constructor(Single,Single) | Initializes a new instance of the PercentagePageScaling class.
PercentagePageScaling Constructor(Single) | Initializes a new instance of the PercentagePageScaling class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Class
PercentagePageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Constructor(Single,Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PercentagePageScaling Class > PercentagePageScaling Constructor : PercentagePageScaling Constructor(Single,Single)

scaleX
A value indicating horizontal page scaling in percentage.
scaleY
A value indicating vertical page scaling in percentage.
Initializes a new instance of the PercentagePageScaling class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scaleX As Single, _
   ByVal scaleY As Single _
)
C#
public PercentagePageScaling(
   float scaleX,
   float scaleY
)

Parameters

scaleX
A value indicating horizontal page scaling in percentage.
scaleY
A value indicating vertical page scaling in percentage.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Class
PercentagePageScaling Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Constructor(Single) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PercentagePageScaling Class > PercentagePageScaling Constructor : PercentagePageScaling Constructor(Single)

scale
A value indicating page scaling in percentage.
Initializes a new instance of the PercentagePageScaling class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal scale As Single _
)
C#
public PercentagePageScaling(
   float scale
)

Parameters

scale
A value indicating page scaling in percentage.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Class
PercentagePageScaling Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PercentagePageScaling Class

For a list of all members of this type, see PercentagePageScaling members.

Public Properties

 | Name | Description
Public Property | AutoExpand | Gets or sets a value indicating if the page scaling size can be expanded. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | AutoShrink | Gets or sets a value indicating if the page scaling size can be shrunk. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | ScaleTo | Gets or sets a value indicating the boundaries on the page to use for the scaling. (Inherited from Foxit.PDF.Printing.AutoPageScaling)
Public Property | ScaleX | Gets the horizontal page scaling in percentage.
Public Property | ScaleY | Gets the vertical page scaling in percentage.
Top

See Also

Reference

PercentagePageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ScaleX Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PercentagePageScaling Class : ScaleX Property

Gets the horizontal page scaling in percentage.

Syntax

Visual Basic (Declaration)
Public Property ScaleX As Single
C#
public float ScaleX {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Class
PercentagePageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ScaleY Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PercentagePageScaling Class : ScaleY Property

Gets the vertical page scaling in percentage.

Syntax

Visual Basic (Declaration)
Public Property ScaleY As Single
C#
public float ScaleY {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PercentagePageScaling Class
PercentagePageScaling Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Printer Class

Represents a printer that can be used for print jobs.

Object Model

Printer ClassPrinter ClassPrinter ClassMediaTypeList ClassMediaType ClassPaperSizeList ClassPaperSize ClassPaperSourceList ClassPaperSource ClassResolutionList ClassResolution Class

Syntax

Visual Basic (Declaration)
Public Class Printer
C#
public class Printer

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job using a Printer object, sets print job print options based on the Printer object and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a printer using its name
        Dim MyPrinter As Printer = New Printer("PrinterName")

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob(MyPrinter, "C:\MyDocument.pdf")

        ' Set the collating if it is supported by the printer
        If (MyPrinter.Collate) Then
            MyPrintJob.PrintOptions.Collate = True
        End If

        ' Set the color if it is supported by the printer
        If (MyPrinter.Color) Then
            MyPrintJob.PrintOptions.Color = True
        End If

        ' Set the duplex  printing if it is supported by the printer
        If (MyPrinter.Duplex) Then
            MyPrintJob.PrintOptions.DuplexMode = DuplexMode.DuplexHorizontal
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a printer using its name
        Printer printer = new Printer("PrinterName");

        // Create a print job
        PrintJob printJob = new PrintJob(printer, @"C:\MyDocument.pdf");

        // Set the collating if it is supported by the printer
        if (printer.Collate)
        {
            printJob.PrintOptions.Collate = true;
        }

        // Set the color if it is supported by the printer
        if (printer.Color)
        {
            printJob.PrintOptions.Color = true;
        }

        // Set the duplex  printing if it is supported by the printer
        if (printer.Duplex)
        {
            printJob.PrintOptions.DuplexMode = DuplexMode.DuplexHorizontal;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.Printer

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Printer Class

The following tables list the members exposed by Printer.

Public Constructors

 | Name | Description
Public Constructor | Printer Constructor | Initializes a new instance of the Printer class.
Top

Public Properties

 | Name | Description
Public Property | Collate | Gets a value indicating if the printer supports collating.
Public Property | Color | Gets a value indicating if the printer supports color printing.
static (Shared in Visual Basic) | Default | Gets the system's default printer.
Public Property | Duplex | Gets a value indicating if the printer supports duplex printing.
Public Property | Fax | Gets a value indicating if the printer supports fax printing.
Public Property | MaxCopies | Gets the maximum number of copies supported by the printer.
Public Property | MaxPaperHeight | Gets the maximum paper height supported by the printer in typesetting points.
Public Property | MaxPaperWidth | Gets the maximum paper width supported by the printer in typesetting points.
Public Property | MediaTypes | Gets a MediaTypeList object that represents the available media types for the printer.
Public Property | MinPaperHeight | Gets the minimum paper height supported by the printer in typesetting points.
Public Property | MinPaperWidth | Gets the minimum paper width supported by the printer in typesetting points.
Public Property | Name | Gets the name of the printer.
Public Property | PaperSizes | Gets a PaperSizeList object that represents the available paper sizes for the printer.
Public Property | PaperSources | Gets a PaperSourceList object that represents the available paper sources (trays) for the printer.
Public Property | Resolutions | Gets a ResolutionList object that represents the available resolutions for the printer.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
static (Shared in Visual Basic) | GetLocalPrinters | Returns an array of the system's local printers.
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Printer Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Printer Constructor

printerName
The name of the printer.
Initializes a new instance of the Printer class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String _
)
C#
public Printer(
   string printerName
)

Parameters

printerName
The name of the printer.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Printer Class

For a list of all members of this type, see Printer members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
static (Shared in Visual Basic) | GetLocalPrinters | Returns an array of the system's local printers.
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Printer Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GetLocalPrinters Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : GetLocalPrinters Method

Returns an array of the system's local printers.

Syntax

Visual Basic (Declaration)
Public Shared Function GetLocalPrinters() As Printer()
C#
public static Printer[] GetLocalPrinters()

Return Value

An array of Printer objects.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Printer Class

For a list of all members of this type, see Printer members.

Public Properties

 | Name | Description
Public Property | Collate | Gets a value indicating if the printer supports collating.
Public Property | Color | Gets a value indicating if the printer supports color printing.
static (Shared in Visual Basic) | Default | Gets the system's default printer.
Public Property | Duplex | Gets a value indicating if the printer supports duplex printing.
Public Property | Fax | Gets a value indicating if the printer supports fax printing.
Public Property | MaxCopies | Gets the maximum number of copies supported by the printer.
Public Property | MaxPaperHeight | Gets the maximum paper height supported by the printer in typesetting points.
Public Property | MaxPaperWidth | Gets the maximum paper width supported by the printer in typesetting points.
Public Property | MediaTypes | Gets a MediaTypeList object that represents the available media types for the printer.
Public Property | MinPaperHeight | Gets the minimum paper height supported by the printer in typesetting points.
Public Property | MinPaperWidth | Gets the minimum paper width supported by the printer in typesetting points.
Public Property | Name | Gets the name of the printer.
Public Property | PaperSizes | Gets a PaperSizeList object that represents the available paper sizes for the printer.
Public Property | PaperSources | Gets a PaperSourceList object that represents the available paper sources (trays) for the printer.
Public Property | Resolutions | Gets a ResolutionList object that represents the available resolutions for the printer.
Top

See Also

Reference

Printer Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Collate Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Collate Property

Gets a value indicating if the printer supports collating.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Collate As Boolean
C#
public bool Collate {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Color Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Color Property

Gets a value indicating if the printer supports color printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Color As Boolean
C#
public bool Color {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Default Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Default Property

Gets the system's default printer.

Syntax

Visual Basic (Declaration)
Public Shared ReadOnly Property Default As Printer
C#
public static Printer Default {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Duplex Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Duplex Property

Gets a value indicating if the printer supports duplex printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Duplex As Boolean
C#
public bool Duplex {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Fax Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Fax Property

Gets a value indicating if the printer supports fax printing.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Fax As Boolean
C#
public bool Fax {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MaxCopies Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MaxCopies Property

Gets the maximum number of copies supported by the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxCopies As Integer
C#
public int MaxCopies {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MaxPaperHeight Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MaxPaperHeight Property

Gets the maximum paper height supported by the printer in typesetting points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxPaperHeight As Double
C#
public double MaxPaperHeight {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MaxPaperWidth Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MaxPaperWidth Property

Gets the maximum paper width supported by the printer in typesetting points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MaxPaperWidth As Double
C#
public double MaxPaperWidth {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaTypes Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MediaTypes Property

Gets a MediaTypeList object that represents the available media types for the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MediaTypes As MediaTypeList
C#
public MediaTypeList MediaTypes {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MinPaperHeight Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MinPaperHeight Property

Gets the minimum paper height supported by the printer in typesetting points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinPaperHeight As Double
C#
public double MinPaperHeight {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MinPaperWidth Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : MinPaperWidth Property

Gets the minimum paper width supported by the printer in typesetting points.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MinPaperWidth As Double
C#
public double MinPaperWidth {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Name Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Name Property

Gets the name of the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Name As String
C#
public string Name {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSizes Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : PaperSizes Property

Gets a PaperSizeList object that represents the available paper sizes for the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperSizes As PaperSizeList
C#
public PaperSizeList PaperSizes {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSources Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : PaperSources Property

Gets a PaperSourceList object that represents the available paper sources (trays) for the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PaperSources As PaperSourceList
C#
public PaperSourceList PaperSources {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolutions Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Resolutions Property

Gets a ResolutionList object that represents the available resolutions for the printer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Resolutions As ResolutionList
C#
public ResolutionList Resolutions {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintFailedException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintFailedException Class

Represents a print failed exception.

Object Model

PrintFailedException Class

Syntax

Visual Basic (Declaration)
Public Class PrintFailedException
   Inherits PrintingException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class PrintFailedException : PrintingException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Printing.PrintingException
Foxit.PDF.Printing.PrintFailedException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintFailedException Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintFailedException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintFailedException Class

The following tables list the members exposed by PrintFailedException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintFailedException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintingException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintingException Class

Represents a exception thrown while printing.

Object Model

PrintingException Class

Syntax

Visual Basic (Declaration)
Public Class PrintingException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class PrintingException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Printing.PrintingException
Foxit.PDF.Printing.DocumentLoadException
Foxit.PDF.Printing.InvalidPasswordException
Foxit.PDF.Printing.PrintFailedException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintingException Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintingException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintingException Class

The following tables list the members exposed by PrintingException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJob Class

Represents a job that can be sent to a printer.

Object Model

PrintJob ClassPrintJobPageList ClassPrintJobPage ClassPrinter ClassPrintJobPrintOptions Class

Syntax

Visual Basic (Declaration)
Public Class PrintJob
   Implements System.IDisposable
C#
public class PrintJob : System.IDisposable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job containing the first four pages of the PDF
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf", 1, 4)

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job containing the first four pages of the PDF
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf", 1, 4);

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJob
Foxit.PDF.Printing.FaxPrintJob

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Class Members | Comments on this topic
See Also Properties Methods Events
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJob Class

The following tables list the members exposed by PrintJob.

Public Constructors

 | Name | Description
Public Constructor | PrintJob Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DocumentName | Gets or sets the name of the document that is to be shown in the print spooler.
Public Property | JobId | Gets the ID of the job.
Public Property | Pages | Gets a PrintJobPageList object that represents the pages to be printed by the job.
Public Property | PagesPrinted | Gets a value indicating how many pages have been printed.
Public Property | Printer | Gets the Printer object that is targeted by the job.
Public Property | PrintOptions | Gets a PrintJobPrintOptions objects that represents the printing options for the job.
Public Property | PrintToFileName |
Public Property | Status | Gets the current status of the job.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | Dispose | Releases resources used by the PrintJob object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | Print | Prints the job to the printer.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

Public Events

 | Name | Description
Public Event | Failed | Occurs when a job fails.
Public Event | Succeeded | Occurs when a job succeeds.
Public Event | Updated | Occurs when a job's status or pages printed is updated.
Top

See Also

Reference

PrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : PrintJob Constructor

Overload List

Overload | Description
PrintJob Constructor(String,String,Int32,Int32) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(String,String) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(String,InputPdf,Int32,Int32) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(String,InputPdf) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(String) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(Printer,String,Int32,Int32) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(Printer,String) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(Printer,InputPdf,Int32,Int32) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(Printer,InputPdf) | Initializes a new instance of the PrintJob class.
PrintJob Constructor(Printer) | Initializes a new instance of the PrintJob class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(String,String,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(String,String,Int32,Int32)

printerName
The name of the printer targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal pdfFileName As String, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public PrintJob(
   string printerName,
   string pdfFileName,
   int startPage,
   int pageCount
)

Parameters

printerName
The name of the printer targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(String,String)

printerName
The name of the printer targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal pdfFileName As String _
)
C#
public PrintJob(
   string printerName,
   string pdfFileName
)

Parameters

printerName
The name of the printer targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(String,InputPdf,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(String,InputPdf,Int32,Int32)

printerName
The name of the printer targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal inputPdf As InputPdf, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public PrintJob(
   string printerName,
   InputPdf inputPdf,
   int startPage,
   int pageCount
)

Parameters

printerName
The name of the printer targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(String,InputPdf) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(String,InputPdf)

printerName
The name of the printer targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String, _
   ByVal inputPdf As InputPdf _
)
C#
public PrintJob(
   string printerName,
   InputPdf inputPdf
)

Parameters

printerName
The name of the printer targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(String)

printerName
The name of the printer targeted by the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printerName As String _
)
C#
public PrintJob(
   string printerName
)

Parameters

printerName
The name of the printer targeted by the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(Printer,String,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,String,Int32,Int32)

printer
The Printer object targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal pdfFileName As String, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public PrintJob(
   Printer printer,
   string pdfFileName,
   int startPage,
   int pageCount
)

Parameters

printer
The Printer object targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(Printer,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,String)

printer
The Printer object targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal pdfFileName As String _
)
C#
public PrintJob(
   Printer printer,
   string pdfFileName
)

Parameters

printer
The Printer object targeted by the print job.
pdfFileName
The file path to the PDF containing the pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(Printer,InputPdf,Int32,Int32) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,InputPdf,Int32,Int32)

printer
The Printer object targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal inputPdf As InputPdf, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public PrintJob(
   Printer printer,
   InputPdf inputPdf,
   int startPage,
   int pageCount
)

Parameters

printer
The Printer object targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(Printer,InputPdf) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer,InputPdf)

printer
The Printer object targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer, _
   ByVal inputPdf As InputPdf _
)
C#
public PrintJob(
   Printer printer,
   InputPdf inputPdf
)

Parameters

printer
The Printer object targeted by the print job.
inputPdf
The InputPdf object containing the pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Constructor(Printer) | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class > PrintJob Constructor : PrintJob Constructor(Printer)

printer
The Printer object targeted by the print job.
Initializes a new instance of the PrintJob class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal printer As Printer _
)
C#
public PrintJob(
   Printer printer
)

Parameters

printer
The Printer object targeted by the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members
Overload List


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJob Class

For a list of all members of this type, see PrintJob members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | Dispose | Releases resources used by the PrintJob object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | Print | Prints the job to the printer.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AddLicense Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : AddLicense Method

licenseKey
The license key to add.
Adds a license key.

Syntax

Visual Basic (Declaration)
Public Shared Function AddLicense( _
   ByVal licenseKey As String _
) As Boolean
C#
public static bool AddLicense(
   string licenseKey
)

Parameters

licenseKey
The license key to add.

Return Value

A boolean value indicating if the license key is valid.

Remarks

This method accepts a license key, not a serial number.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Dispose() Method

Releases resources used by the PrintJob object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Print Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Print Method

Prints the job to the printer.

Syntax

Visual Basic (Declaration)
Public Sub Print()
C#
public void Print()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJob Class

For a list of all members of this type, see PrintJob members.

Public Properties

 | Name | Description
Public Property | DocumentName | Gets or sets the name of the document that is to be shown in the print spooler.
Public Property | JobId | Gets the ID of the job.
Public Property | Pages | Gets a PrintJobPageList object that represents the pages to be printed by the job.
Public Property | PagesPrinted | Gets a value indicating how many pages have been printed.
Public Property | Printer | Gets the Printer object that is targeted by the job.
Public Property | PrintOptions | Gets a PrintJobPrintOptions objects that represents the printing options for the job.
Public Property | PrintToFileName |
Public Property | Status | Gets the current status of the job.
Top

See Also

Reference

PrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : DocumentName Property

Gets or sets the name of the document that is to be shown in the print spooler.

Syntax

Visual Basic (Declaration)
Public Property DocumentName As String
C#
public string DocumentName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
JobId Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : JobId Property

Gets the ID of the job.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property JobId As Integer
C#
public int JobId {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Pages Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Pages Property

Gets a PrintJobPageList object that represents the pages to be printed by the job.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Pages As PrintJobPageList
C#
public PrintJobPageList Pages {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PagesPrinted Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : PagesPrinted Property

Gets a value indicating how many pages have been printed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PagesPrinted As Integer
C#
public int PagesPrinted {get;}

Remarks

This property is dependent on the printer driver to update the value. It is not generally accurate when printing to network printers.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Printer Property

Gets the Printer object that is targeted by the job.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Printer As Printer
C#
public Printer Printer {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintOptions Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : PrintOptions Property

Gets a PrintJobPrintOptions objects that represents the printing options for the job.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintJobPrintOptions
C#
public PrintJobPrintOptions PrintOptions {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintToFileName Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : PrintToFileName Property

Syntax

Visual Basic (Declaration)
Public Property PrintToFileName As String
C#
public string PrintToFileName {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Status Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Status Property

Gets the current status of the job.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Status As PrintJobStatus
C#
public PrintJobStatus Status {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%% $$Events$$

Foxit Software Help Library for .NET - June 2013 Foxit Software
PrintJob Class Events
See Also Send Feedback
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJob Class

For a list of all members of this type, see PrintJob members.

Public Events

 | Name | Description
Public Event | Failed | Occurs when a job fails.
Public Event | Succeeded | Occurs when a job succeeds.
Public Event | Updated | Occurs when a job's status or pages printed is updated.
Top

See Also

Reference

PrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
Failed Event
See Also Send Feedback
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Failed Event

Occurs when a job fails.

Syntax

Visual Basic (Declaration)
Public Event Failed As PrintJobFailedEventHandler
C#
public event PrintJobFailedEventHandler Failed

Event Data

The event handler receives an argument of type PrintJobFailedEventArgs containing data related to this event. The following PrintJobFailedEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception thrown.
PrintJob | Gets the print job that caused the event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
Succeeded Event
See Also Send Feedback
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Succeeded Event

Occurs when a job succeeds.

Syntax

Visual Basic (Declaration)
Public Event Succeeded As PrintJobEventHandler
C#
public event PrintJobEventHandler Succeeded

Event Data

The event handler receives an argument of type PrintJobEventArgs containing data related to this event. The following PrintJobEventArgs properties provide information specific to this event.

Property | Description
PrintJob | Gets the print job that caused the event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
Updated Event
See Also Send Feedback
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Updated Event

Occurs when a job's status or pages printed is updated.

Syntax

Visual Basic (Declaration)
Public Event Updated As PrintJobEventHandler
C#
public event PrintJobEventHandler Updated

Event Data

The event handler receives an argument of type PrintJobEventArgs containing data related to this event. The following PrintJobEventArgs properties provide information specific to this event.

Property | Description
PrintJob | Gets the print job that caused the event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobEventArgs Class

Represents the print job event's arguments.

Object Model

PrintJobEventArgs ClassPrintJob Class

Syntax

Visual Basic (Declaration)
Public Class PrintJobEventArgs
C#
public class PrintJobEventArgs

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobEventArgs Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobEventArgs Class

The following tables list the members exposed by PrintJobEventArgs.

Public Properties

 | Name | Description
Public Property | PrintJob | Gets the print job that caused the event.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobEventArgs Class

For a list of all members of this type, see PrintJobEventArgs members.

Public Properties

 | Name | Description
Public Property | PrintJob | Gets the print job that caused the event.
Top

See Also

Reference

PrintJobEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobEventArgs Class : PrintJob Property

Gets the print job that caused the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintJob As PrintJob
C#
public PrintJob PrintJob {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobEventArgs Class
PrintJobEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobFailedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobFailedEventArgs Class

Represents the print job failed event's arguments.

Object Model

PrintJobFailedEventArgs ClassPrintFailedException ClassPrintJob Class

Syntax

Visual Basic (Declaration)
Public Class PrintJobFailedEventArgs
C#
public class PrintJobFailedEventArgs

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobFailedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobFailedEventArgs Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobFailedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobFailedEventArgs Class

The following tables list the members exposed by PrintJobFailedEventArgs.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown.
Public Property | PrintJob | Gets the print job that caused the event.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobFailedEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobFailedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobFailedEventArgs Class

For a list of all members of this type, see PrintJobFailedEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception thrown.
Public Property | PrintJob | Gets the print job that caused the event.
Top

See Also

Reference

PrintJobFailedEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Exception Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobFailedEventArgs Class : Exception Property

Gets the exception thrown.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As PrintFailedException
C#
public PrintFailedException Exception {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobFailedEventArgs Class
PrintJobFailedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJob Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobFailedEventArgs Class : PrintJob Property

Gets the print job that caused the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintJob As PrintJob
C#
public PrintJob PrintJob {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobFailedEventArgs Class
PrintJobFailedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPage Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPage Class

Represents a page of pdf added to the print job.

Object Model

PrintJobPage ClassInputPdfPage ClassPrintJobPagePrintOptions Class

Syntax

Visual Basic (Declaration)
Public Class PrintJobPage
C#
public class PrintJobPage

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets print options on the last page and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job containing the first four pages of the PDF
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf", 1, 4)

        ' Get the last page and set its print options
        Dim MyPrintJobPage As PrintJobPage = MyPrintJob.Pages(MyPrintJob.Pages.Count - 1)
        MyPrintJobPage.PrintOptions.Inherit = False
        MyPrintJobPage.PrintOptions.HorizontalAlign = HorizontalAlign.Right
        MyPrintJobPage.PrintOptions.Orientation.Type = OrientationType.Landscape
        MyPrintJobPage.PrintOptions.PrintAnnotations = True

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job containing the first four pages of the PDF
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf", 1, 4);

        // Get the last page and set its print options
        PrintJobPage printJobPage = printJob.Pages[printJob.Pages.Count - 1];
        printJobPage.PrintOptions.Inherit = false;
        printJobPage.PrintOptions.HorizontalAlign = HorizontalAlign.Right;
        printJobPage.PrintOptions.Orientation.Type = OrientationType.Landscape;
        printJobPage.PrintOptions.PrintAnnotations = true;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPage Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPage Class

The following tables list the members exposed by PrintJobPage.

Public Properties

 | Name | Description
Public Property | InputPdfPage | Gets the InputPdfPage object that represents the PDF page.
Public Property | PrintOptions | Gets the PrintJobPagePrintOptions object that represents print options for the page.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPage Class

For a list of all members of this type, see PrintJobPage members.

Public Properties

 | Name | Description
Public Property | InputPdfPage | Gets the InputPdfPage object that represents the PDF page.
Public Property | PrintOptions | Gets the PrintJobPagePrintOptions object that represents print options for the page.
Top

See Also

Reference

PrintJobPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InputPdfPage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPage Class : InputPdfPage Property

Gets the InputPdfPage object that represents the PDF page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InputPdfPage As InputPdfPage
C#
public InputPdfPage InputPdfPage {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPage Class
PrintJobPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintOptions Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPage Class : PrintOptions Property

Gets the PrintJobPagePrintOptions object that represents print options for the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PrintOptions As PrintJobPagePrintOptions
C#
public PrintJobPagePrintOptions PrintOptions {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPage Class
PrintJobPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPageList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPageList Class

Represents a list of pdf pages added to the print job.

Object Model

PrintJobPageList ClassPrintJobPage Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class PrintJobPageList
   Implements System.Collections.Generic.IEnumerable(Of PrintJobPage), System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class PrintJobPageList : System.Collections.Generic.IEnumerable<PrintJobPage>, System.Collections.IEnumerable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets print options for the last page and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job containing the first four pages of the PDF
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf", 1, 4)

        ' Get the list of pages in the print job
        Dim MyPrintJobPageList As PrintJobPageList = MyPrintJob.Pages

        ' Get the last page and set its print options
        Dim MyPrintJobPage As PrintJobPage = MyPrintJobPageList(MyPrintJobPageList.Count - 1)
        MyPrintJobPage.PrintOptions.Inherit = False
        MyPrintJobPage.PrintOptions.HorizontalAlign = HorizontalAlign.Right
        MyPrintJobPage.PrintOptions.Orientation.Type = OrientationType.Landscape
        MyPrintJobPage.PrintOptions.PrintAnnotations = True

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job containing the first four pages of the PDF
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf", 1, 4);

        // Get the list of pages in the print job
        PrintJobPageList printjobPageList = printJob.Pages;

        // Get the last page and set its print options
        PrintJobPage printJobPage = printjobPageList[printjobPageList.Count - 1];
        printJobPage.PrintOptions.Inherit = false;
        printJobPage.PrintOptions.HorizontalAlign = HorizontalAlign.Right;
        printJobPage.PrintOptions.Orientation.Type = OrientationType.Landscape;
        printJobPage.PrintOptions.PrintAnnotations = true;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobPageList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPageList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPageList Class

The following tables list the members exposed by PrintJobPageList.

Public Properties

 | Name | Description
Public Property | Count | Gets the value indicating the number of pages in a list.
Public Property | Item | Gets a PrintJobPage object by index.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a pdf document .
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPageList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPageList Class

For a list of all members of this type, see PrintJobPageList members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add a pdf document .
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class : Add Method

Add a pdf document .

Overload List

Overload | Description
Add(String,Int32,Int32) | Add a pdf document .
Add(String,Int32) | Add a pdf document .
Add(String) | Add a pdf document .
Add(InputPdfPage) | Add pdf page PrintJobPage.
Add(InputPdf,Int32,Int32) | Add pdf to the list.
Add(InputPdf) | Add all the pages of a PDF to the list.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(String,Int32,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(String,Int32,Int32) Method

pdfFilePath
The file path to the PDF to be added to the print job.
startPage
The first page from the PDF to be added to the print job.
pageCount
The number of pages to be added to the print job.
Add a pdf document .

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal pdfFilePath As String, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public void Add(
   string pdfFilePath,
   int startPage,
   int pageCount
)

Parameters

pdfFilePath
The file path to the PDF to be added to the print job.
startPage
The first page from the PDF to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(String,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(String,Int32) Method

pdfFilePath
The file path to the PDF to be added to the print job.
pageNumber
The page number of the page to be added to the print job.
Add a pdf document .

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal pdfFilePath As String, _
   ByVal pageNumber As Integer _
) As PrintJobPage
C#
public PrintJobPage Add(
   string pdfFilePath,
   int pageNumber
)

Parameters

pdfFilePath
The file path to the PDF to be added to the print job.
pageNumber
The page number of the page to be added to the print job.

Return Value

An PrintJobPage object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(String) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(String) Method

pdfFilePath
The file path to the PDF to be added to the print job.
Add a pdf document .

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal pdfFilePath As String _
)
C#
public void Add(
   string pdfFilePath
)

Parameters

pdfFilePath
The file path to the PDF to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(InputPdfPage) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(InputPdfPage) Method

page
The InputPdfPage object to be added to the print job.
Add pdf page PrintJobPage.

Syntax

Visual Basic (Declaration)
Public Overloads Function Add( _
   ByVal page As InputPdfPage _
) As PrintJobPage
C#
public PrintJobPage Add(
   InputPdfPage page
)

Parameters

page
The InputPdfPage object to be added to the print job.

Return Value

An PrintJobPage object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(InputPdf,Int32,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(InputPdf,Int32,Int32) Method

pdf
The InputPdf containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.
Add pdf to the list.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal pdf As InputPdf, _
   ByVal startPage As Integer, _
   ByVal pageCount As Integer _
)
C#
public void Add(
   InputPdf pdf,
   int startPage,
   int pageCount
)

Parameters

pdf
The InputPdf containing the pages to be added to the print job.
startPage
The first page from the InputPdf to be added to the print job.
pageCount
The number of pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Add(InputPdf) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class > Add Method : Add(InputPdf) Method

pdf
The InputPdf containing the pages to be added to the print job.
Add all the pages of a PDF to the list.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal pdf As InputPdf _
)
C#
public void Add(
   InputPdf pdf
)

Parameters

pdf
The InputPdf containing the pages to be added to the print job.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPageList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPageList Class

For a list of all members of this type, see PrintJobPageList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the value indicating the number of pages in a list.
Public Property | Item | Gets a PrintJobPage object by index.
Top

See Also

Reference

PrintJobPageList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class : Count Property

Gets the value indicating the number of pages in a list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPageList Class : Item Property

index
The index of the page to be returned.
Gets a PrintJobPage object by index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As PrintJobPage
C#
public PrintJobPage this[
   int index
]; {get;}

Parameters

index
The index of the page to be returned.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPageList Class
PrintJobPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPagePrintOptions Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPagePrintOptions Class

Represents print options for the page to be added to the print job.

Object Model

PrintJobPagePrintOptions ClassMediaType ClassPageOrientation ClassPaperSize ClassPaperSource ClassPageScaling Class

Syntax

Visual Basic (Declaration)
Public Class PrintJobPagePrintOptions
C#
public class PrintJobPagePrintOptions

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets print options for the last page and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job containing the first four pages of the PDF
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf", 1, 4)

        ' Get the last page and set its print options
        Dim MyPrintJobPage As PrintJobPage = MyPrintJob.Pages(MyPrintJob.Pages.Count - 1)
        Dim MyPagePrintOptions As PrintJobPagePrintOptions = MyPrintJobPage.PrintOptions
        MyPagePrintOptions.Inherit = False
        MyPagePrintOptions.HorizontalAlign = HorizontalAlign.Left
        MyPagePrintOptions.PrintAnnotations = False

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job containing the first four pages of the PDF
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf", 1, 4);

        // Get the last page and set its print options
        PrintJobPage printJobPage = printJob.Pages[printJob.Pages.Count - 1];
        PrintJobPagePrintOptions pagePrintOptions = printJobPage.PrintOptions;
        pagePrintOptions.Inherit = false;
        pagePrintOptions.HorizontalAlign = HorizontalAlign.Left;
        pagePrintOptions.PrintAnnotations = false;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobPagePrintOptions

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPagePrintOptions Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPagePrintOptions Class

The following tables list the members exposed by PrintJobPagePrintOptions.

Public Properties

 | Name | Description
Public Property | HorizontalAlign | Gets or sets the horizontal alignment for the page.
Public Property | Inherit | Gets or sets the value indicating if the print options should be inherited from the print job.
Public Property | MediaType |
Public Property | Orientation | Gets or sets the page orientation for the page.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PrintAnnotations | Gets or sets the value indicating it PDF annotations should be printed for this page.
Public Property | Scaling | Gets or sets the scaling size for the page.
Public Property | VerticalAlign | Gets or sets the vertical alignment for the page.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | SetMediaTypeByName |
Public Method | SetPaperSizeByName | Sets the paper size by name for the page.
Public Method | SetPaperSourceByName | Sets the paper source by name for the page.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPagePrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPagePrintOptions Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPagePrintOptions Class

For a list of all members of this type, see PrintJobPagePrintOptions members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | SetMediaTypeByName |
Public Method | SetPaperSizeByName | Sets the paper size by name for the page.
Public Method | SetPaperSourceByName | Sets the paper source by name for the page.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPagePrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetMediaTypeByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : SetMediaTypeByName Method

name

Syntax

Visual Basic (Declaration)
Public Function SetMediaTypeByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetMediaTypeByName(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetPaperSizeByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : SetPaperSizeByName Method

name
String containing paper size.
Sets the paper size by name for the page.

Syntax

Visual Basic (Declaration)
Public Function SetPaperSizeByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetPaperSizeByName(
   string name
)

Parameters

name
String containing paper size.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetPaperSourceByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : SetPaperSourceByName Method

name
String containing paper source.
Sets the paper source by name for the page.

Syntax

Visual Basic (Declaration)
Public Function SetPaperSourceByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetPaperSourceByName(
   string name
)

Parameters

name
String containing paper source.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPagePrintOptions Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPagePrintOptions Class

For a list of all members of this type, see PrintJobPagePrintOptions members.

Public Properties

 | Name | Description
Public Property | HorizontalAlign | Gets or sets the horizontal alignment for the page.
Public Property | Inherit | Gets or sets the value indicating if the print options should be inherited from the print job.
Public Property | MediaType |
Public Property | Orientation | Gets or sets the page orientation for the page.
Public Property | PaperSize | Gets or sets the paper size for the page.
Public Property | PaperSource | Gets or sets the paper source for the page.
Public Property | PrintAnnotations | Gets or sets the value indicating it PDF annotations should be printed for this page.
Public Property | Scaling | Gets or sets the scaling size for the page.
Public Property | VerticalAlign | Gets or sets the vertical alignment for the page.
Top

See Also

Reference

PrintJobPagePrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HorizontalAlign Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : HorizontalAlign Property

Gets or sets the horizontal alignment for the page.

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlign As HorizontalAlign
C#
public HorizontalAlign HorizontalAlign {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Inherit Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : Inherit Property

Gets or sets the value indicating if the print options should be inherited from the print job.

Syntax

Visual Basic (Declaration)
Public Property Inherit As Boolean
C#
public bool Inherit {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : MediaType Property

Syntax

Visual Basic (Declaration)
Public Property MediaType As MediaType
C#
public MediaType MediaType {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Orientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : Orientation Property

Gets or sets the page orientation for the page.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : PaperSize Property

Gets or sets the paper size for the page.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSize
C#
public PaperSize PaperSize {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : PaperSource Property

Gets or sets the paper source for the page.

Syntax

Visual Basic (Declaration)
Public Property PaperSource As PaperSource
C#
public PaperSource PaperSource {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintAnnotations Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : PrintAnnotations Property

Gets or sets the value indicating it PDF annotations should be printed for this page.

Syntax

Visual Basic (Declaration)
Public Property PrintAnnotations As Boolean
C#
public bool PrintAnnotations {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Scaling Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : Scaling Property

Gets or sets the scaling size for the page.

Syntax

Visual Basic (Declaration)
Public Property Scaling As PageScaling
C#
public PageScaling Scaling {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VerticalAlign Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPagePrintOptions Class : VerticalAlign Property

Gets or sets the vertical alignment for the page.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As VerticalAlign
C#
public VerticalAlign VerticalAlign {get; set;}

Remarks

You must set the Inherit property to false before setting this property.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPagePrintOptions Class
PrintJobPagePrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPrintOptions Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPrintOptions Class

Represents the printing options for a job.

Object Model

PrintJobPrintOptions ClassMediaType ClassPageOrientation ClassPaperSize ClassPaperSource ClassResolution ClassPageScaling Class

Syntax

Visual Basic (Declaration)
Public Class PrintJobPrintOptions
   Implements System.IDisposable
C#
public class PrintJobPrintOptions : System.IDisposable

Example

The following examples creates a print job, sets print options and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set all the print options
        If (MyPrintJob.Printer.Color) Then ' If the printer supports color printing
            MyPrintJob.PrintOptions.Color = True
        End If
        If (MyPrintJob.Printer.Duplex) Then ' If the printer supports duplex printing
            MyPrintJob.PrintOptions.DuplexMode = DuplexMode.DuplexVertical
        End If
        MyPrintJob.PrintOptions.Copies = 1
        MyPrintJob.PrintOptions.HorizontalAlign = HorizontalAlign.Left
        MyPrintJob.PrintOptions.PrintAnnotations = False
        MyPrintJob.PrintOptions.Scaling = PageScaling.ActualSize
        MyPrintJob.PrintOptions.SetPaperSizeByName("Legal")
        MyPrintJob.PrintOptions.SetPaperSourceByName("Tray 2")
        MyPrintJob.PrintOptions.SetResolutionByDpi(300)
        MyPrintJob.PrintOptions.VerticalAlign = VerticalAlign.Top

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set all the print options
        if (printJob.Printer.Color) // If the printer supports color printing
        {
            printJob.PrintOptions.Color = true;
        }
        if (printJob.Printer.Duplex) // If the printer supports duplex printing
        {
            printJob.PrintOptions.DuplexMode = DuplexMode.DuplexVertical;
        }
        printJob.PrintOptions.Copies = 1;
        printJob.PrintOptions.HorizontalAlign = HorizontalAlign.Left;
        printJob.PrintOptions.PrintAnnotations = false;
        printJob.PrintOptions.Scaling = PageScaling.ActualSize;
        printJob.PrintOptions.SetPaperSizeByName("Legal");
        printJob.PrintOptions.SetPaperSourceByName("Tray 2");
        printJob.PrintOptions.SetResolutionByDpi(300);
        printJob.PrintOptions.VerticalAlign = VerticalAlign.Top;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.PrintJobPrintOptions

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPrintOptions Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPrintOptions Class

The following tables list the members exposed by PrintJobPrintOptions.

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating if the job's copies should be collated.
Public Property | Color | Gets or sets a value indicating if the job should printed in color.
Public Property | Copies | Gets or sets a value indicating the number of copies to print.
Public Property | DuplexMode | Gets or sets a value indicating the duplex mode to use when printing the pages.
Public Property | HorizontalAlign | Gets or sets a value indicating the horizontal alignment to use when printing the pages.
Public Property | MediaType |
Public Property | Orientation | Gets a value indicating the orientation to use when printing the pages.
Public Property | PaperSize | Gets or sets a value indicating the size of paper to use when printing the pages.
Public Property | PaperSource | Gets or sets a value indicating the paper source (tray) to use when printing.
Public Property | PrintAnnotations | Gets or sets a value indicating if annotations from the PDF should be printed.
Public Property | Resolution | Gets or sets a value indicating the resolution to use when printing.
Public Property | Scaling | Gets or sets a value indicating the page scaling to use when printing the pages.
Public Property | VerticalAlign | Gets or sets a value indicating the vertical alignment to use when printing the pages.
Top

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the PrintJobPrintOptions object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | SetMediaTypeByName |
Public Method | SetPaperSizeByName | Sets the size of paper to use based on its name.
Public Method | SetPaperSourceByName | Sets the paper source (tray) to use based on its name.
Public Method | SetResolutionByDpi | Overloaded. Sets the resolution to use based on its DPI.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPrintOptions Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPrintOptions Class

For a list of all members of this type, see PrintJobPrintOptions members.

Public Methods

 | Name | Description
Public Method | Dispose | Releases resources used by the PrintJobPrintOptions object.
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | SetMediaTypeByName |
Public Method | SetPaperSizeByName | Sets the size of paper to use based on its name.
Public Method | SetPaperSourceByName | Sets the paper source (tray) to use based on its name.
Public Method | SetResolutionByDpi | Overloaded. Sets the resolution to use based on its DPI.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose() Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Dispose() Method

Releases resources used by the PrintJobPrintOptions object.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
C#
public void Dispose()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetMediaTypeByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : SetMediaTypeByName Method

name

Syntax

Visual Basic (Declaration)
Public Function SetMediaTypeByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetMediaTypeByName(
   string name
)

Parameters

name

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetPaperSizeByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : SetPaperSizeByName Method

name
The name of the paper size to set.
Sets the size of paper to use based on its name.

Syntax

Visual Basic (Declaration)
Public Function SetPaperSizeByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetPaperSizeByName(
   string name
)

Parameters

name
The name of the paper size to set.

Return Value

A boolean value indicating if the paper size name is valid for this printer.

Remarks

If the specified paper size is not supported by the printer, the paper size will not be changed and this method will return false.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetPaperSourceByName Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : SetPaperSourceByName Method

name
The name of the paper source (tray) to set.
Sets the paper source (tray) to use based on its name.

Syntax

Visual Basic (Declaration)
Public Function SetPaperSourceByName( _
   ByVal name As String _
) As Boolean
C#
public bool SetPaperSourceByName(
   string name
)

Parameters

name
The name of the paper source (tray) to set.

Return Value

A boolean value indicating if the paper source (tray) name is valid for this printer.

Remarks

If the specified paper source (tray) is not supported by the printer, the paper source (tray) will not be changed and this method will return false.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetResolutionByDpi Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : SetResolutionByDpi Method

Sets the resolution to use based on its DPI.

Overload List

Overload | Description
SetResolutionByDpi(Int32,Int32) | Sets the resolution to use based on its DPI.
SetResolutionByDpi(Int32) | Sets the resolution to use based on its DPI.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetResolutionByDpi(Int32,Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class > SetResolutionByDpi Method : SetResolutionByDpi(Int32,Int32) Method

horizontalDpi
The horizontal DPI to set.
verticalDpi
The vertical DPI to set.
Sets the resolution to use based on its DPI.

Syntax

Visual Basic (Declaration)
Public Overloads Function SetResolutionByDpi( _
   ByVal horizontalDpi As Integer, _
   ByVal verticalDpi As Integer _
) As Boolean
C#
public bool SetResolutionByDpi(
   int horizontalDpi,
   int verticalDpi
)

Parameters

horizontalDpi
The horizontal DPI to set.
verticalDpi
The vertical DPI to set.

Return Value

A boolean value indicating if the DPI is valid for this printer.

Remarks

If the specified DPI is not supported by the printer, the DPI will not be changed and this method will return false.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SetResolutionByDpi(Int32) Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class > SetResolutionByDpi Method : SetResolutionByDpi(Int32) Method

dpi
The horizontal and vertical DPI to set.
Sets the resolution to use based on its DPI.

Syntax

Visual Basic (Declaration)
Public Overloads Function SetResolutionByDpi( _
   ByVal dpi As Integer _
) As Boolean
C#
public bool SetResolutionByDpi(
   int dpi
)

Parameters

dpi
The horizontal and vertical DPI to set.

Return Value

A boolean value indicating if the DPI is valid for this printer.

Remarks

If the specified DPI is not supported by the printer, the DPI will not be changed and this method will return false.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPrintOptions Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPrintOptions Class

For a list of all members of this type, see PrintJobPrintOptions members.

Public Properties

 | Name | Description
Public Property | Collate | Gets or sets a value indicating if the job's copies should be collated.
Public Property | Color | Gets or sets a value indicating if the job should printed in color.
Public Property | Copies | Gets or sets a value indicating the number of copies to print.
Public Property | DuplexMode | Gets or sets a value indicating the duplex mode to use when printing the pages.
Public Property | HorizontalAlign | Gets or sets a value indicating the horizontal alignment to use when printing the pages.
Public Property | MediaType |
Public Property | Orientation | Gets a value indicating the orientation to use when printing the pages.
Public Property | PaperSize | Gets or sets a value indicating the size of paper to use when printing the pages.
Public Property | PaperSource | Gets or sets a value indicating the paper source (tray) to use when printing.
Public Property | PrintAnnotations | Gets or sets a value indicating if annotations from the PDF should be printed.
Public Property | Resolution | Gets or sets a value indicating the resolution to use when printing.
Public Property | Scaling | Gets or sets a value indicating the page scaling to use when printing the pages.
Public Property | VerticalAlign | Gets or sets a value indicating the vertical alignment to use when printing the pages.
Top

See Also

Reference

PrintJobPrintOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Collate Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Collate Property

Gets or sets a value indicating if the job's copies should be collated.

Syntax

Visual Basic (Declaration)
Public Property Collate As Boolean
C#
public bool Collate {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Color Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Color Property

Gets or sets a value indicating if the job should printed in color.

Syntax

Visual Basic (Declaration)
Public Property Color As Boolean
C#
public bool Color {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Copies Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Copies Property

Gets or sets a value indicating the number of copies to print.

Syntax

Visual Basic (Declaration)
Public Property Copies As Integer
C#
public int Copies {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DuplexMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : DuplexMode Property

Gets or sets a value indicating the duplex mode to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property DuplexMode As DuplexMode
C#
public DuplexMode DuplexMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HorizontalAlign Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : HorizontalAlign Property

Gets or sets a value indicating the horizontal alignment to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property HorizontalAlign As HorizontalAlign
C#
public HorizontalAlign HorizontalAlign {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : MediaType Property

Syntax

Visual Basic (Declaration)
Public Property MediaType As MediaType
C#
public MediaType MediaType {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Orientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Orientation Property

Gets a value indicating the orientation to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property Orientation As PageOrientation
C#
public PageOrientation Orientation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : PaperSize Property

Gets or sets a value indicating the size of paper to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property PaperSize As PaperSize
C#
public PaperSize PaperSize {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : PaperSource Property

Gets or sets a value indicating the paper source (tray) to use when printing.

Syntax

Visual Basic (Declaration)
Public Property PaperSource As PaperSource
C#
public PaperSource PaperSource {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintAnnotations Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : PrintAnnotations Property

Gets or sets a value indicating if annotations from the PDF should be printed.

Syntax

Visual Basic (Declaration)
Public Property PrintAnnotations As Boolean
C#
public bool PrintAnnotations {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolution Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Resolution Property

Gets or sets a value indicating the resolution to use when printing.

Syntax

Visual Basic (Declaration)
Public Property Resolution As Resolution
C#
public Resolution Resolution {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Scaling Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Scaling Property

Gets or sets a value indicating the page scaling to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property Scaling As PageScaling
C#
public PageScaling Scaling {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VerticalAlign Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : VerticalAlign Property

Gets or sets a value indicating the vertical alignment to use when printing the pages.

Syntax

Visual Basic (Declaration)
Public Property VerticalAlign As VerticalAlign
C#
public VerticalAlign VerticalAlign {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolution Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Resolution Class

Represents the resolution of the printer.

Object Model

Resolution Class

Syntax

Visual Basic (Declaration)
Public Class Resolution
C#
public class Resolution

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets the resolution to 600 dpi if it is supported by the printer and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get the 600 dpi resolution from the printer
        Dim MyResolution As Resolution = MyPrintJob.Printer.Resolutions(600, 600)

        ' Set the resolution if it is supported by the printer
        If (Not MyResolution Is Nothing) Then
            MyPrintJob.PrintOptions.Resolution = MyResolution
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get the 600 dpi resolution from the printer
        Resolution resolution = printJob.Printer.Resolutions[600, 600];

        // Set the resolution if it is supported by the printer
        if (resolution != null)
        {
            printJob.PrintOptions.Resolution = resolution;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.Resolution

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Resolution Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolution Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Resolution Class

The following tables list the members exposed by Resolution.

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Gets the horizontal resolution.
Public Property | VerticalDpi | Gets the vertical resolution.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Resolution Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolution Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Resolution Class

For a list of all members of this type, see Resolution members.

Public Properties

 | Name | Description
Public Property | HorizontalDpi | Gets the horizontal resolution.
Public Property | VerticalDpi | Gets the vertical resolution.
Top

See Also

Reference

Resolution Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HorizontalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Resolution Class : HorizontalDpi Property

Gets the horizontal resolution.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HorizontalDpi As Integer
C#
public int HorizontalDpi {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Resolution Class
Resolution Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VerticalDpi Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Resolution Class : VerticalDpi Property

Gets the vertical resolution.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VerticalDpi As Integer
C#
public int VerticalDpi {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Resolution Class
Resolution Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ResolutionList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ResolutionList Class

Represents a list of resolutions.

Object Model

ResolutionList ClassResolution Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class ResolutionList
   Implements System.Collections.Generic.IEnumerable(Of Resolution), System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class ResolutionList : System.Collections.Generic.IEnumerable<Resolution>, System.Collections.IEnumerable

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a print job, sets resolution to 600 dpi if it is supported by the printer and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Get the list of available resolutions for the printer
        Dim MyResolutions As ResolutionList = MyPrintJob.Printer.Resolutions

        ' Set the resolution to 600 dpi if it is supported by the printer
        If (Not MyResolutions(600, 600) Is Nothing) Then
            MyPrintJob.PrintOptions.Resolution = MyResolutions(600, 600)
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Get the list of available resolutions for the printer
        ResolutionList resolutions = printJob.Printer.Resolutions;

        // Set the resolution to 600 dpi if it is supported by the printer
        if (resolutions[600, 600] != null)
        {
            printJob.PrintOptions.Resolution = resolutions[600, 600];
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.ResolutionList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ResolutionList Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ResolutionList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ResolutionList Class

The following tables list the members exposed by ResolutionList.

Public Properties

 | Name | Description
Public Property | Count | Gets the value indicating the number of printer resolutions in the list.
Public Property | Item | Overloaded. Gets a printer resolution by index.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ResolutionList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ResolutionList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ResolutionList Class

For a list of all members of this type, see ResolutionList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the value indicating the number of printer resolutions in the list.
Public Property | Item | Overloaded. Gets a printer resolution by index.
Top

See Also

Reference

ResolutionList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ResolutionList Class : Count Property

Gets the value indicating the number of printer resolutions in the list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ResolutionList Class
ResolutionList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ResolutionList Class : Item Property

Gets a printer resolution by index.

Overload List

Overload | Description
Item(Int32,Int32) |
Item(Int32) | Gets a printer resolution by index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ResolutionList Class
ResolutionList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(Int32,Int32) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ResolutionList Class > Item Property : Item(Int32,Int32) Property

horizontalDpi
verticalDpi

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal horizontalDpi As Integer, _
   ByVal verticalDpi As Integer _
) As Resolution
C#
public Resolution Item(
   int horizontalDpi,
   int verticalDpi
) {get;}

Parameters

horizontalDpi
verticalDpi

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ResolutionList Class
ResolutionList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item(Int32) Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ResolutionList Class > Item Property : Item(Int32) Property

index
The index of the resolution to be returned.
Gets a printer resolution by index.

Syntax

Visual Basic (Declaration)
Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Resolution
C#
public Resolution Item(
   int index
) {get;}

Parameters

index
The index of the resolution to be returned.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ResolutionList Class
ResolutionList Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ServerCoverPage Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ServerCoverPage Class

Represents a cover page.

Object Model

ServerCoverPage Class

Syntax

Visual Basic (Declaration)
Public Class ServerCoverPage
   Inherits FaxCoverPage
C#
public class ServerCoverPage : FaxCoverPage

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Example

The following examples creates a fax print job, sets cover page values and sends the fax.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a fax print job
        Dim MyFaxPrintJob As FaxPrintJob = New FaxPrintJob("FaxPrinterName", "1-555-465-1177", "C:\MyDocument.pdf")

        ' Add a local cover page
        MyFaxPrintJob.FaxOptions.CoverPage = New ServerCoverPage("FileName")

        ' Set the cover page values
        MyFaxPrintJob.FaxOptions.CoverPage.Note = "Note"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone"
        MyFaxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle"
        MyFaxPrintJob.FaxOptions.CoverPage.Subject = "Subject"

        ' Send the fax
        MyFaxPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a fax print job
        FaxPrintJob faxPrintJob = new FaxPrintJob("FaxPrinterName", "1-555-465-1177", @"C:\MyDocument.pdf");

        // Add a local cover page
        faxPrintJob.FaxOptions.CoverPage = new ServerCoverPage("FileName");

        // Set the cover page values
        faxPrintJob.FaxOptions.CoverPage.Note = "Note";
        faxPrintJob.FaxOptions.CoverPage.RecipientCity = "RecipientCity";
        faxPrintJob.FaxOptions.CoverPage.RecipientCompany = "RecipientCompany";
        faxPrintJob.FaxOptions.CoverPage.RecipientCountry = "RecipientCountry";
        faxPrintJob.FaxOptions.CoverPage.RecipientDepartment = "RecipientDepartment";
        faxPrintJob.FaxOptions.CoverPage.RecipientFaxNumber = "RecipientFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.RecipientHomePhone = "RecipientHomePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientName = "RecipientName";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficeLocation = "RecipientOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.RecipientOfficePhone = "RecipientOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.RecipientState = "RecipientState";
        faxPrintJob.FaxOptions.CoverPage.RecipientStreetAddress = "RecipientStreetAddress";
        faxPrintJob.FaxOptions.CoverPage.RecipientTitle = "RecipientTitle";
        faxPrintJob.FaxOptions.CoverPage.RecipientZip = "RecipientZip";
        faxPrintJob.FaxOptions.CoverPage.SenderAddress = "SenderAddress";
        faxPrintJob.FaxOptions.CoverPage.SenderCompany = "SenderCompany";
        faxPrintJob.FaxOptions.CoverPage.SenderDepartment = "SenderDepartment";
        faxPrintJob.FaxOptions.CoverPage.SenderFaxNumber = "SenderFaxNumber";
        faxPrintJob.FaxOptions.CoverPage.SenderHomePhone = "SenderHomePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderName = "SenderName";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficeLocation = "SenderOfficeLocation";
        faxPrintJob.FaxOptions.CoverPage.SenderOfficePhone = "SenderOfficePhone";
        faxPrintJob.FaxOptions.CoverPage.SenderTitle = "SenderTitle";
        faxPrintJob.FaxOptions.CoverPage.Subject = "Subject";

        // Send the fax
        faxPrintJob.Print();
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.FaxCoverPage
Foxit.PDF.Printing.ServerCoverPage

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ServerCoverPage Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ServerCoverPage Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ServerCoverPage Class

The following tables list the members exposed by ServerCoverPage.

Public Constructors

 | Name | Description
Public Constructor | ServerCoverPage Constructor | Initializes a new instance of the ServerCoverPage class.
Top

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the the server cover page.
Public Property | Note | Gets or sets the content of the note field. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCity | Gets or sets the city of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCountry | Gets or sets the country of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientName | Gets or sets the name of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientState | Gets or sets the state of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientTitle | Gets or sets the title associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientZip | Gets or sets the zip code of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderAddress | Gets or sets the address of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderCompany | Gets or sets the company name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderDepartment | Gets or sets the department name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderName | Gets or sets the name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderTitle | Gets or sets the title title associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | Subject | Gets or sets the subject for the fax to be sent. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ServerCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ServerCoverPage Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ServerCoverPage Class : ServerCoverPage Constructor

name
The name of the server the cover page.
Initializes a new instance of the ServerCoverPage class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal name As String _
)
C#
public ServerCoverPage(
   string name
)

Parameters

name
The name of the server the cover page.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ServerCoverPage Class
ServerCoverPage Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ServerCoverPage Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ServerCoverPage Class

For a list of all members of this type, see ServerCoverPage members.

Public Properties

 | Name | Description
Public Property | Name | Gets or sets the name of the the server cover page.
Public Property | Note | Gets or sets the content of the note field. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCity | Gets or sets the city of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCompany | Gets or sets the company name associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientCountry | Gets or sets the country of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientDepartment | Gets or sets the department associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientFaxNumber | Gets or sets the fax number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientHomePhone | Gets or sets the home phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientName | Gets or sets the name of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficeLocation | Gets or sets the office location of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientOfficePhone | Gets or sets the office phone number associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientState | Gets or sets the state of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientStreetAddress | Gets or sets the street address of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientTitle | Gets or sets the title associated with the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | RecipientZip | Gets or sets the zip code of the recipient. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderAddress | Gets or sets the address of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderCompany | Gets or sets the company name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderDepartment | Gets or sets the department name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderFaxNumber | Gets or sets the fax number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderHomePhone | Gets or sets the home phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderName | Gets or sets the name associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficeLocation | Gets or sets the office location of the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderOfficePhone | Gets or sets the office phone number associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | SenderTitle | Gets or sets the title title associated with the sender. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Public Property | Subject | Gets or sets the subject for the fax to be sent. (Inherited from Foxit.PDF.Printing.FaxCoverPage)
Top

See Also

Reference

ServerCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Name Property | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > ServerCoverPage Class : Name Property

Gets or sets the name of the the server cover page.

Syntax

Visual Basic (Declaration)
Public Property Name As String
C#
public string Name {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ServerCoverPage Class
ServerCoverPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
UnitConverter Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : UnitConverter Class

Utility for converting to and from typesetting points.

Object Model

UnitConverter Class

Syntax

Visual Basic (Declaration)
Public Class UnitConverter
C#
public class UnitConverter

Licensing

This class is a Foxit PDF PrintManager feature. The following license is required for non-evaluation usage:
  • Foxit PDF PrintManager for .NET SDK

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.UnitConverter

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
UnitConverter Class Members | Comments on this topic
See Also Methods
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : UnitConverter Class

The following tables list the members exposed by UnitConverter.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
static (Shared in Visual Basic) | InchesToPoints | Converts from inches to typesetting points.
static (Shared in Visual Basic) | MillimetersToPoints | Converts from millimeters to typesetting points.
static (Shared in Visual Basic) | PointsToInches | Converts from typesetting points to inches.
static (Shared in Visual Basic) | PointsToMillimeters | Converts from typesetting points to millimeters.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UnitConverter Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
UnitConverter Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : UnitConverter Class

For a list of all members of this type, see UnitConverter members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
static (Shared in Visual Basic) | InchesToPoints | Converts from inches to typesetting points.
static (Shared in Visual Basic) | MillimetersToPoints | Converts from millimeters to typesetting points.
static (Shared in Visual Basic) | PointsToInches | Converts from typesetting points to inches.
static (Shared in Visual Basic) | PointsToMillimeters | Converts from typesetting points to millimeters.
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

UnitConverter Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InchesToPoints Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > UnitConverter Class : InchesToPoints Method

size
Size in inches.
Converts from inches to typesetting points.

Syntax

Visual Basic (Declaration)
Public Shared Function InchesToPoints( _
   ByVal size As Double _
) As Double
C#
public static double InchesToPoints(
   double size
)

Parameters

size
Size in inches.

Return Value

The size in inches.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MillimetersToPoints Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > UnitConverter Class : MillimetersToPoints Method

size
Size in millimeters.
Converts from millimeters to typesetting points.

Syntax

Visual Basic (Declaration)
Public Shared Function MillimetersToPoints( _
   ByVal size As Double _
) As Double
C#
public static double MillimetersToPoints(
   double size
)

Parameters

size
Size in millimeters.

Return Value

The size in typesetting points.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PointsToInches Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > UnitConverter Class : PointsToInches Method

size
Size in points.
Converts from typesetting points to inches.

Syntax

Visual Basic (Declaration)
Public Shared Function PointsToInches( _
   ByVal size As Double _
) As Double
C#
public static double PointsToInches(
   double size
)

Parameters

size
Size in points.

Return Value

The size in inches.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PointsToMillimeters Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > UnitConverter Class : PointsToMillimeters Method

size
Size in points.
Converts from typesetting points to millimeters.

Syntax

Visual Basic (Declaration)
Public Shared Function PointsToMillimeters( _
   ByVal size As Double _
) As Double
C#
public static double PointsToMillimeters(
   double size
)

Parameters

size
Size in points.

Return Value

The size in typesetting points.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

UnitConverter Class
UnitConverter Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DuplexMode Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : DuplexMode Enumeration

Represents duplex modes.

Syntax

Visual Basic (Declaration)
Public Enum DuplexMode
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum DuplexMode : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
DuplexHorizontal | Duplex mode that flips the page horizontally.
DuplexVertical | Duplex mode that flips the page vertically.
Simplex | Simplex (non duplex) mode.

Example

The following examples creates a print job, sets the duplex mode if it is supported by the printer and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the duplex mode if it is supported by the printer
        If (MyPrintJob.Printer.Duplex) Then
            MyPrintJob.PrintOptions.DuplexMode = DuplexMode.DuplexHorizontal
        End If

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the duplex mode if it is supported by the printer
        if (printJob.Printer.Duplex)
        {
            printJob.PrintOptions.DuplexMode = DuplexMode.DuplexHorizontal;
        }

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.DuplexMode

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HorizontalAlign Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : HorizontalAlign Enumeration

Represents the horizontal alignment to use when printing pages.

Syntax

Visual Basic (Declaration)
Public Enum HorizontalAlign
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum HorizontalAlign : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Center | Center horizontal alignment.
Left | Left horizontal alignment.
Right | Right horizontal alignment.

Example

The following examples creates a print job, sets the horizontal align to left and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the horizontal alignment
        MyPrintJob.PrintOptions.HorizontalAlign = HorizontalAlign.Left

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the horizontal alignment
        printJob.PrintOptions.HorizontalAlign = HorizontalAlign.Left;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.HorizontalAlign

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
OrientationType Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : OrientationType Enumeration

Represents the type of orientation.

Syntax

Visual Basic (Declaration)
Public Enum OrientationType
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum OrientationType : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Auto | Automatically select the orientation based on the page and the output paper sizes.
Landscape | Landscape orientation.
Portrait | Portrait orientation.

Example

The following examples creates a print job, sets the orientation and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the orientation
        MyPrintJob.PrintOptions.Orientation = OrientationType.Landscape

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the orientation
        printJob.PrintOptions.Orientation = OrientationType.Landscape;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.OrientationType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobStatus Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobStatus Enumeration

Represents the status of print.

Syntax

Visual Basic (Declaration)
Public Enum PrintJobStatus
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum PrintJobStatus : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Complete | Indicates that a print job has been sent to the printer.
Deleted | Indicates that a print job has been deleted.
Deleting | Indicates that a print job is being deleted.
Error | Indicates that an error occured while printing.
NotStarted | Indicates that a print job has not started.
Paused | Indicates that a print job is paused.
Printed | Indicates that a print job has printed.
PrinterOffline | Indicates that a printer is offline.
PrinterOutOfPaper | Indicates that a printer is out of paper.
Printing | Indicates that a print job is printing.
RequiresUserIntervention | Indicates that a printer has an issue that requires the user to do something.
Restarting | Indicates that a print job has been restarted.
Spooling | Indicates that a print job is spooling.
StatusUnAvailable | Indicates that a print job's status is not available and have been removed from the printer queue.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.PrintJobStatus

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ScaleTo Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ScaleTo Enumeration

Represents the page scaling type.

Syntax

Visual Basic (Declaration)
Public Enum ScaleTo
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum ScaleTo : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
PageEdges | Scale to the edges of a page.
PagePrintableArea | Scale to the printable area of a page.

Example

The following examples creates a print job, sets the scaling to printable area of the page and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the scaling
        Dim MyAutoPageScaling As AutoPageScaling = New AutoPageScaling(ScaleTo.PagePrintableArea, True, True)
        MyPrintJob.PrintOptions.Scaling = MyAutoPageScaling

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the scaling
        AutoPageScaling autoPageScaling = new AutoPageScaling(ScaleTo.PagePrintableArea, true, true);
        printJob.PrintOptions.Scaling = autoPageScaling;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.ScaleTo

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VerticalAlign Enumeration | Comments on this topic
Example See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : VerticalAlign Enumeration

Represents the vertical alignment to use when printing pages.

Syntax

Visual Basic (Declaration)
Public Enum VerticalAlign
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum VerticalAlign : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Bottom | Bottom vertical alignment.
Middle | Middle vertical alignment.
Top | Top vertical alignment.

Example

The following examples creates a print job, sets the vertical align to top and prints the job.

Visual Basic Copy Code
Imports System
Imports Foxit.PDF.Printing

Module MyModule

    Sub Main()

        ' Create a print job
        Dim MyPrintJob As PrintJob = New PrintJob("PrinterName", "C:\MyDocument.pdf")

        ' Set the vertical alignment
        MyPrintJob.PrintOptions.VerticalAlign = VerticalAlign.Top

        ' Print the job
        MyPrintJob.Print()
    End Sub
End Module
C# Copy Code
using System;
using Foxit.PDF.Printing;

class MyClass
{
    static void Main()
    {
        // Create a print job
        PrintJob printJob = new PrintJob("PrinterName", @"C:\MyDocument.pdf");

        // Set the vertical alignment
        printJob.PrintOptions.VerticalAlign = VerticalAlign.Top;

        // Print the job
        printJob.Print();
    }
}

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Printing.VerticalAlign

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobEventHandler Delegate

sender
e
Represents the method that is called when a job succeeds or is updated.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintJobEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintJobEventArgs _
)
C#
public delegate void PrintJobEventHandler(
   object sender,
   PrintJobEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobEventHandler Members
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobFailedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobFailedEventHandler Delegate

sender
e
Represents the method that is called when a job fails.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PrintJobFailedEventHandler( _
   ByVal sender As Object, _
   ByVal e As PrintJobFailedEventArgs _
)
C#
public delegate void PrintJobFailedEventHandler(
   object sender,
   PrintJobFailedEventArgs e
)

Parameters

sender
e

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobFailedEventHandler Members
Foxit.PDF.Printing Namespace


%%phrase%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Printing Assembly | Comments on this topic
See Also

Namespaces

Namespace | Description
Foxit.PDF.Printing |


$$GETTING_STARTED$$ - %%projecttitle%%

Foxit Software Help Library for .NET - June 2013
Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Foxit Software Help Library for .NET - June 2013
Introduction
Send Feedback


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActualSizePageScaling Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ActualSizePageScaling Class

For a list of all members of this type, see ActualSizePageScaling members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ActualSizePageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AutoPageScaling Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : AutoPageScaling Class

For a list of all members of this type, see AutoPageScaling members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

AutoPageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxCoverPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxCoverPage Class

For a list of all members of this type, see FaxCoverPage members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FaxCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxOptions Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxOptions Class

For a list of all members of this type, see FaxOptions members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FaxOptions Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Events$$

Foxit Software Help Library for .NET - June 2013 Foxit Software
FaxPrintJob Class Events
See Also Send Feedback
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxPrintJob Class

For a list of all members of this type, see FaxPrintJob members.

Public Events

 | Name | Description
Public Event | Failed | Occurs when a job fails. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Event | Succeeded | Occurs when a job succeeds. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Event | Updated | Occurs when a job's status or pages printed is updated. (Inherited from Foxit.PDF.Printing.PrintJob)
Top

See Also

Reference

FaxPrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FaxPrintJob Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : FaxPrintJob Class

For a list of all members of this type, see FaxPrintJob members.

Public Methods

 | Name | Description
Public Method | Dispose() | Releases resources used by the FaxPrintJob object. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | Print | Prints the job to the printer. (Inherited from Foxit.PDF.Printing.PrintJob)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FaxPrintJob Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > FaxPrintJob Class : Dispose Method

Releases resources used by the FaxPrintJob object.

Overload List

Overload | Description
Dispose() | Releases resources used by the FaxPrintJob object. (Inherited from Foxit.PDF.Printing.PrintJob)

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FaxPrintJob Class
FaxPrintJob Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPageList Class : Dispose Method

Releases resources used by the InputPdfPageList object.

Overload List

Overload | Description
Dispose | Releases resources used by the InputPdfPageList object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPageList Class
InputPdfPageList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdfPage Class : Dispose Method

Releases resources used by the InputPdfPage object.

Overload List

Overload | Description
Dispose | Releases resources used by the InputPdfPage object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdfPage Class
InputPdfPage Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > InputPdf Class : Dispose Method

Releases resources used by the InputPdf object.

Overload List

Overload | Description
Dispose | Releases resources used by the InputPdf object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InputPdf Class
InputPdf Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LocalCoverPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : LocalCoverPage Class

For a list of all members of this type, see LocalCoverPage members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LocalCoverPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaType Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaType Class

For a list of all members of this type, see MediaType members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MediaType Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MediaTypeList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : MediaTypeList Class

For a list of all members of this type, see MediaTypeList members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

MediaTypeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageOrientation Class

For a list of all members of this type, see PageOrientation members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageOrientation Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageScaling Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PageScaling Class

For a list of all members of this type, see PageScaling members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSize Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSize Class

For a list of all members of this type, see PaperSize members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSize Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSizeList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSizeList Class

For a list of all members of this type, see PaperSizeList members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSizeList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSource Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSource Class

For a list of all members of this type, see PaperSource members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSource Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PaperSourceList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PaperSourceList Class

For a list of all members of this type, see PaperSourceList members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PaperSourceList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PercentagePageScaling Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PercentagePageScaling Class

For a list of all members of this type, see PercentagePageScaling members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PercentagePageScaling Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Printer Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > Printer Class : Printer Constructor

Overload List

Overload | Description
Printer Constructor | Initializes a new instance of the Printer class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Printer Class
Printer Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintFailedException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintFailedException Class

For a list of all members of this type, see PrintFailedException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintFailedException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintFailedException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintFailedException Class

For a list of all members of this type, see PrintFailedException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintFailedException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintingException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintingException Class

For a list of all members of this type, see PrintingException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintingException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintingException Class

For a list of all members of this type, see PrintingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PrintingException Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobEventArgs Class

For a list of all members of this type, see PrintJobEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobFailedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobFailedEventArgs Class

For a list of all members of this type, see PrintJobFailedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobFailedEventArgs Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PrintJobPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : PrintJobPage Class

For a list of all members of this type, see PrintJobPage members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PrintJobPage Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJobPrintOptions Class : Dispose Method

Releases resources used by the PrintJobPrintOptions object.

Overload List

Overload | Description
Dispose | Releases resources used by the PrintJobPrintOptions object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJobPrintOptions Class
PrintJobPrintOptions Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace > PrintJob Class : Dispose Method

Releases resources used by the PrintJob object.

Overload List

Overload | Description
Dispose | Releases resources used by the PrintJob object.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PrintJob Class
PrintJob Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Resolution Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : Resolution Class

For a list of all members of this type, see Resolution members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Resolution Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ResolutionList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ResolutionList Class

For a list of all members of this type, see ResolutionList members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ResolutionList Class
Foxit.PDF.Printing Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ServerCoverPage Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Printing Assembly > Foxit.PDF.Printing Namespace : ServerCoverPage Class

For a list of all members of this type, see ServerCoverPage members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ServerCoverPage Class
Foxit.PDF.Printing Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Printing Namespace Inheritance Hierarchy | Comments on this topic
See Also
Foxit.PDF.Printing Assembly : Foxit.PDF.Printing Namespace

Inheritance Hierarchy

System.Object
Foxit.PDF.Printing.FaxCoverPage
Foxit.PDF.Printing.LocalCoverPage
Foxit.PDF.Printing.ServerCoverPage
Foxit.PDF.Printing.FaxOptions
Foxit.PDF.Printing.InputPdf
Foxit.PDF.Printing.InputPdfPage
Foxit.PDF.Printing.InputPdfPageList
Foxit.PDF.Printing.MediaType
Foxit.PDF.Printing.MediaTypeList
Foxit.PDF.Printing.PageOrientation
Foxit.PDF.Printing.PageScaling
Foxit.PDF.Printing.ActualSizePageScaling
Foxit.PDF.Printing.AutoPageScaling
Foxit.PDF.Printing.PercentagePageScaling
Foxit.PDF.Printing.PaperSize
Foxit.PDF.Printing.PaperSizeList
Foxit.PDF.Printing.PaperSource
Foxit.PDF.Printing.PaperSourceList
Foxit.PDF.Printing.Printer
Foxit.PDF.Printing.PrintJob
Foxit.PDF.Printing.FaxPrintJob
Foxit.PDF.Printing.PrintJobEventArgs
Foxit.PDF.Printing.PrintJobFailedEventArgs
Foxit.PDF.Printing.PrintJobPage
Foxit.PDF.Printing.PrintJobPageList
Foxit.PDF.Printing.PrintJobPagePrintOptions
Foxit.PDF.Printing.PrintJobPrintOptions
Foxit.PDF.Printing.Resolution
Foxit.PDF.Printing.ResolutionList
Foxit.PDF.Printing.UnitConverter
System.Exception
Foxit.PDF.Printing.LicensingException
Foxit.PDF.Printing.PrintingException
Foxit.PDF.Printing.DocumentLoadException
Foxit.PDF.Printing.InvalidPasswordException
Foxit.PDF.Printing.PrintFailedException

See Also

Reference

Foxit.PDF.Printing Assembly