%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Welcome | Comments on this topic
See Also

Glossary Item Box

Foxit PDF for .NET

This document contains help for Foxit PDF Viewer for .NET.

  • Foxit PDF Viewer for .NET - A customizable PDF viewer that can be fully embedded into any WinForm application.

For the complete Class Library Reference click on the link below:

  • Reference Section

Please feel free to contact us with any questions you may have about our products.

Foxit Software
Foxit Corporation
42840 Christy Street, Suite 201
Fremont, CA 94538
USA

http://www.foxitsoftware.com

Sales E-Mail
Support E-Mail

Sales Telephone: 1-866-680-3668 (24/7)
Support & General: 1-866-MYFOXIT or 1-866-693-6948(24/7)
Fax: 510-405-9288

See Also

Foxit PDF Viewer for .NET

© Copyright 2013, Foxit Software


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit PDF Viewer for .NET | Comments on this topic

Glossary Item Box

Foxit PDF for .NET

Foxit PDF Viewer is a highly efficient and lightweight .NET PDF viewing control that allows PDF viewing capabilities to be embedded within .NET Windows Form applications. It uses the Foxit PDF rendering engine which is the same rendering engine that is used by the popular Foxit PDF Reader. Foxit PDF Viewer for .NET seamlessly integrates with our other Foxit PDF products allowing applications to display PDF output from our other Foxit PDF tools or any other existing PDF file regardless of producer. It is compatible with PDF version v1.1 to v1.7.

Foxit PDF Viewer Namespaces

The Foxit PDF Viewer for .NET utilizes the below namespace.

  • Foxit.PDF.Viewer

Further Reading

Getting Started
Topics on getting started with Foxit PDF Viewer.
Programming With Foxit PDF Viewer
Introduces how to program with Foxit PDF Viewer.
Foxit PDF Viewer Class Library
Detailed reference of the Foxit PDF Viewer Class Library.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Getting Started | Comments on this topic
Foxit PDF Viewer for .NET > Getting Started

Glossary Item Box

In This Section

Product Evaluation
Includes details on evaluating the product.
Features
Details the features available.
Product Limitations
Explains limitations of the product.
Examples
Lists the examples that are included with the product.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Product Evaluation | Comments on this topic
Foxit PDF Viewer for .NET > Getting Started > Product Evaluation

Glossary Item Box

There is a fully functional evaluation edition of Foxit PDF Viewer for .NET that can be downloaded from the Foxit Software website, http://www.foxitsoftware.com. This evaluation edition contains all features present in the licensed copy and does not expire or run out. The only limitation of the evaluation edition is that a watermark is displayed on the PDF being displayed within the Viewer window. Purchasing and correctly applying a license key will cause the watermark to no longer be displayed on PDF documents being viewed within the Viewer control.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Features | Comments on this topic
Foxit PDF Viewer for .NET > Getting Started > Features

Glossary Item Box

Below is a list of the main features of our Foxit PDF Viewer for .NET. This list was current as of June 2013 and is subject to change. Please visit our website for the latest information at www.foxitsoftware.com.

If there are any questions as to the features or functionality of this product we provide a fully-functional, never-expiring evaluation edition that can be downloaded from our website. If there are still additional questions as to the abilities of the component feel free to contact our support team at support@foxitsoftware.com with those questions.

  • Display a PDF from File or Byte Array
  • Open a Password Protected/Encrypted PDF
  • Display Without Toolbars
  • Customize the Viewing Window
  • Display Form Field Content (Flattens Fields)
  • Navigate to specific Pages
  • Control Page Zoom and Viewable Area
  • Navigate Forward and Back
  • Retrieve Outlines (Bookmarks)
  • Search and Highlight Keywords
  • Print a PDF
  • Retrieve Document Permissions
  • Retrieve Page Count
  • Retrieve Document Properties (Title, Author, Keywords, etc.)
  • Retrieve the current View and retain it later
  • Able to track Pages and its position in display


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Product Limitations | Comments on this topic
Foxit PDF Viewer for .NET > Getting Started > Product Limitations

Glossary Item Box

  • External Images - Foxit PDF Viewer supports displaying images that are embedded directly in the PDF (as most are). While PDF documents can support images in which the image path is embedded in PDF instead of the actual image contents, these types of images will not render within Foxit PDF Viewer.
  • XFA Forms - Depending on the features being utilized within the XFA fields certain XFA forms are not supported in Foxit PDF Viewer.
  • Editing form field values is not supported in this version.
  • Portfolio PDFs are not supported.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Examples | Comments on this topic
Foxit PDF Viewer for .NET > Getting Started > Examples

Glossary Item Box

The evaluation edition of Foxit PDF Viewer for .NET (which can be downloaded here: http://www.foxitsoftware.com/products/sdk/) includes the examples listed below.

The default installation location for the evaluation edition examples is as follows:

x86 Installer: %ProgramFiles%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\Examples

x64 Installer: %ProgramFiles(x86)%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\Examples

Evaluation edition examples are as follows:

  • SimplePDFViewer - This example demonstrates the Foxit PDF Viewer Window with all of its default behaviour.
  • HiddenToolbars - This example demonstrates hiding all the toolbars within the Viewer window and creating a few custom buttons to expose limited functionality to the user (Open, Print and Close)
  • ParallelView - This example demonstrates adding two Viewer instances into one window for the purpose of document comparison. Any viewing option specified in the left pane will be mimicked in the right pane.
  • CustomToolStrip - This example demonstrates how to replace the default toolbar items with custom toolbar items. Toggling between the custom and default is possible.
  • CustomSearchDialog - This example demonstrates how to override the default search window with a custom search dialog.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Programming with Foxit PDF Viewer | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer

Glossary Item Box

In This Section

Overview
Steps you through the creation of first project using Foxit PDF Viewer.
Referencing the Control
Explains how to reference the control.
Deployment
Explains how to deploy your application.
Opening a PDF
Open using control different way to open a pdf's through code.
Reading Metadata

Foxit PDF Viewer supports reading metadata like Author, Title etc., and the document permissions.

Customizing the Viewer Control
Different optionals available for customizing the default Foxit PDF Viewer control behaviours.
Navigation
Explain ways to navigate through the pdf within Foxit PDF Viewer control.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Overview | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Overview

Glossary Item Box

Below is a walkthrough of getting Foxit PDF Viewer up and working within a simple Visual Studio 2010, C# Windows Form application. Before proceeding through these steps, make sure that you download the latest version of Foxit PDF Viewer for .NET from our website (http://www.foxitsoftware.com/products/sdk/) and setup the demonstration example.

1. Create or open a C# Windows Form application in Visual Studio 2010.

2. Open the Toolbox (Ctrl + Alt + X).

3. If Foxit PDF Viewer tab is not present in the Toolbox.

4. Right click inside the Toolbox and select "Choose Items…".

("Visual Studio allows only 32-bit version of the control to be added into its toolbox. All the controls that are added by Foxit PDF Viewer into the toolbox will also be 32 bit.")

5. From the "Choose Toolbox Items" dialog, click on the ".NET Framework Components" tab and select the "PdfViewer" control from the list and click OK.

Note: If the PdfViewer control does not appear under the “.NET Framework Components” tab, you can browse directly to the location in which it was installed (by default that location is “%ProgramFiles%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin” on 32-bit machines and “%ProgramFiles(x86)%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin” on 64-bit machines) and the DLL begins with “Foxit.PDF.Viewer”.

6. From the Toolbox, drag the FoxitPDFViewer control onto the form.

7. Select the control and set its Name property to "pdfViewer".

8. Re-size, position and set any additional properties as needed.

9. Double click on an empty part of the form and add the following line of code to the Form_Load method:

pdfViewer.Open(@"C:\Temp\HelloWorld.pdf");

Note: Make sure there is a valid PDF document in whatever location you specify above.

10. Run the application to see the PDF specified in step 9 appear on the form.

Note:These instructions will work with older versions of Visual Studio as well, with a few slight differences.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Referencing the Control | Comments on this topic
See Also
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Referencing the Control

Glossary Item Box

The Assemblies used for Foxit PDF Viewer v1.x.x for .NET are installed at "%ProgramFiles%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin" on 32-bit machines and "%ProgramFiles(x86)%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin" on 64-bit machines by default. There are six .NET assemblies included that are compiled for use with the .NET Framework 2.0, 3.0, 3.5 and 4.0/4.5. The table below gives the details of each assembly.

Assembly Name | Framework Version | Platform
Foxit.PDF.Viewer.20.x86.dll | 2.0 and 3.0 | x86
Foxit.PDF. Viewer.20.x64.dll | 2.0 and 3.0 | x64
Foxit.PDF. Viewer.35.x86.dll | 3.5 | x86
Foxit.PDF. Viewer.35.x64.dll | 3.5 | x64
Foxit.PDF. Viewer.40.x86.dll | 4.0 and 4.5 | x86
Foxit.PDF. Viewer.40.x64.dll | 4.0 and 4.5 | x64

Adding assembly reference by selecting the PdfViewer control from Visual Studio toolbox.

Please add the Foxit PDF Viewer control to the toolbox of all Visual Studio that are selected for integration during installation.

Note: Visual Studio allows only 32-bit version of the control to be added into its toolbox. All the controls that are added by Foxit PDF Viewer into the toolbox will also be 32 bit. For adding reference of “Foxit PDF Viewer” assembly for projects targeting x64 bit platform refer “Adding assembly reference by selecting Add Reference” topic below.

If the toolbox does not contain the PdfViewer control, refer the steps 4 & 5 in the Overview topic for adding it manually.

A Visual Studio toolbox will contain one or more PdfViewer Control inside its toolbox based on the .NET version of the project.

  1. Visual Studio 2005

    Click on “Foxit PDF Viewer for .NET 2.0 & 3.0” control which presents under “Foxit PDF Viewer” tab and place it inside in the Windows Forms.

    Figure 1 – Visual Studio 2005 Toolbox Integration Viewer Control

  2. Visual Studio 2008

    There will be two controls present under “Foxit PDF Viewer” tab in the Visual Studio toolbox. Select the control based on the .NET framework of the target project.

    For .NET 2.0 and 3.0 framework projects select the “Foxit PDF Viewer for .NET 2.0 & 3.0” control from the toolbox.

    For .NET 3.5 framework projects select the “Foxit PDF Viewer for .NET 3.5” control from the toolbox.

    Note: Visual Studio will filter the unsupported framework control based on the current project’s .Net framework. If the current project’s .NET framework is .NET 2.0 or 3.0, then “Foxit PDF Viewer for .NET 3.5” will not be present in the toolbox.

    Figure 2 – Visual Studio 2008 Toolbox Integration Viewer Control

  3. Visual Studio 2010 & 2012

    There will be three different tabs inside the Visual Studio toolbox containing the PdfViewer control for the respective framework.

    For .NET 2.0 & 3.0 projects select the PdfViewer control present under “Foxit PDF Viewer for .NET 2.0 & 3.0”

    For .NET 3.5 projects select the PdfViewer control present under “Foxit PDF Viewer for .NET 3.5”

    For .NET 4.0 & 4.5 projects select the PdfViewer control present under “Foxit PDF Viewer for .NET 4.0 & 4.5”

    Note: Visual Studio will filter the unsupported framework control based on the current project’s .Net framework. If the current project’s .NET framework is .NET 2.0 or 3.0 or 3.5, then “Foxit PDF Viewer for .NET 4.0 & 4.5” tab and its control will not be present in the toolbox.

    Figure 3 – Visual Studio 2010 Toolbox Integration Viewer Control Figure 4 – Visual Studio 2012 Toolbox Integration Viewer Control

    Note: Adding multiple PdfViewer control of different .NET framework inside a same form or different form in the same project will add multiple references of Foxit PDF Viewer assembly to the project. This will raise a compiler error.

Adding assembly reference by selecting “Add Reference”.

  1. Visual Studio in Windows x86

    To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Viewer for .NET x86 (Framework 2.0 and 3.0)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Viewer for .NET x86 (Framework 3.5)" from the list on the ".NET" tab. Hit OK to complete this.

    To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select the "Foxit PDF Viewer for .NET x86 (Framework 4.0 and 4.5)" from the list on the ".NET" tab. Hit OK to complete this.

  2. Visual Studio in Windows x64

    To reference our assembly from Visual Studio 2005 open your project's references window (right click on the project's and select "Add Reference..."). From the Add Reference window select Browse and choose the assembly Foxit.PDF.Viewer.20.x64.dll. It will be inside the bin folder located at the Foxit PDF Viewer installed location.

    To reference our assembly from Visual Studio 2008 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select Browse and choose the assembly Foxit.PDF.Viewer.35.x64.dll. It will be inside the bin folder located at the Foxit PDF Viewer installed location.

    To reference our assembly from Visual Studio 2010 and Visual Studio 2012 open your project's references window (right click on the project and select "Add Reference..."). From the Add Reference window select Browse and choose the assembly Foxit.PDF.Viewer.40.x64.dll. It will be inside the bin folder located at the Foxit PDF Viewer installed location.

    By default Foxit PDF Viewer will be installed in the following location.

    For 32-bit machines: “%ProgramFiles%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin”.

    For 64-bit machines: “%ProgramFiles(x86)%\Foxit Software\Foxit PDF Viewer v1.x.x for .NET\bin”.

    Note: Make sure you have not placed more than one of the above assemblies in your applications bin folder. Placing more than one of them in your bin folder can cause errors and unpredictable results. The accompanying xml files are for intelli-sense and do not need to be distributed with your product.

Visual Studio Designer and PdfViewer Control x64

Visual Studio’s designer cannot open any 64-bit form control (since the Visual Studio IDE is a 32-bit process). Because of this, whenever you attempt to open the design view of a Windows Form application that contains a reference to the x64 version of the Foxit PDF Viewer assembly, Visual Studio will throw an error and fail to open it. If there is a need for the design view to be opened, the referenced version of the Foxit PDF Viewer control needs to be changed to the 32-bit version. Keep in mind however that building and debugging of an x64 platform application using the Foxit PDF Viewer x64 control will work without any issue.

See Also

Programming with Foxit PDF Viewer


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Deployment | Comments on this topic
See Also
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Deployment

Glossary Item Box

To deploy your application using XCOPY, it is prerequisite to have Microsoft Visual C++ 2008 Redistributable Package for .NET 2.0/3.0/3.5 application and Microsoft Visual C++ 2010 Redistributable Package for.NET 4.0/4.5 application.

To deploy the application using your own setup program, it is required to include the following redistributables (Merge modules) which need to be installed along with the application.

For .NET 2.0/3.0/3.5 applications
  1. Visual C++ 9.0 CRT (x86) WinSXS MSM
  2. Visual C++ 9.0 CRT (x64) WinSXS MSM
For .NET 4.0/4.5 applications
  1. Visual C++ 10.0 CRT (x86) WinSXS MSM
  2. Visual C++ 10.0 CRT (x64) WinSXS MSM
Licensing
In additional to deploying the dll files with your application, a license key must be added to remove the watermark. A license key can either be added to a .config file or it can be added as a line of code in the application. License keys can be retrieved from the Customer Area of our website, http://www.foxitsoftware.com/CustomerArea, after the purchase of an appropriate serial number.

See Also

Programming with Foxit PDF Viewer
Referencing the Control


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Opening a PDF

Glossary Item Box

Below are examples for opening a PDF within Foxit PDF Viewer for .NET control within a Windows Application.These simple examples demonstrate opening a PDF from a file, opening an encrypted PDF from a file and opening a PDF directly from a byte array.

Opening a PDF from File
Opening a PDF from Byte Array
Opening a Password Protected (Encrypted) PDF
Opening a PDF from Stream

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our Foxit PDFViewer control has been added to your toolbox inside of Visual Studio.Once that has been done, drag FoxitPDFViewer from the toolbox onto your form. For more details on this procedure please review the Overview section above.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from File | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Opening a PDF > Opening a PDF from File

Glossary Item Box

A PDF file can be opened using the Open method.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the Overview section above.

The below example assume that the form’s name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfViewer.Open("C:\MyDocument.pdf")

[C#]
pdfViewer.Open(@"C:\MyDocument.pdf");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from Byte Array | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Opening a PDF > Opening a PDF from Byte Array

Glossary Item Box

To open a PDF directly from a byte array, first create a PdfDocument object out of the byte array then pass that PdfDocument to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the Overview section above.

The below example assume that the form’s name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument(MyPdfBytes)
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(pdfData);
pdfViewer.Open(pdfDocument");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a Password Protected PDF | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Opening a PDF > Opening a Password Protected PDF

Glossary Item Box

If the PDF is encrypted and protected with a password, first create a PdfDocument object specifying the file path and password in the constructor then pass that PdfDocument object to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the Overview section above.

The below example assume that the form’s name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument("C:\MyDocument.pdf", "password")
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(@"C:\MyDocument.pdf", "password");
pdfViewer.Open(pdfDocument");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from Stream | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Opening a PDF > Opening a PDF from Stream

Glossary Item Box

To open a PDF directly from a System.IO.Stream object, first create a PdfDocument object out of the stream then pass that PdfDocument to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the Overview section above.

The below example assume that the form’s name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument(MyStream)
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(pdfStream);
pdfViewer.Open(pdfDocument);


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Reading Metadata | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Reading Metadata

Glossary Item Box

The following example displays a message box with the metadata information for the given PDF.

[Visual Basic]

Dim MyDocument As New PdfDocument("MyDocument.pdf")
Dim DocumentMetaData As String

DocumentMetaData = "Author :" + MyDocument.Author + vbCrLf + "Subject :" + MyDocument.Subject + vbCrLf + "Title :" + MyDocument.Title
MessageBox.Show(DocumentMetaData)

[C#]

PdfDocument document = new PdfDocument(“Document.pdf”);
string metadata = "Author :" + document.Author + "\nSubject :" + document.Subject + "\nTitle :" + document.Title;
MessageBox.Show(metadata);


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Customizing the Viewer Control | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Customizing the Viewer Control

Glossary Item Box

The Foxit PDF Viewer window can be customized so only the elements that you want to appear will be visible on the control. You can even set it so that only the PDF viewing portion is visible and create your own buttons and toolbars to control navigation for the user. This code will cause only the PDF viewing window and title bar to be displayed.

The below example assume that the Foxit PDF Viewer control's name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfViewer.Open("C:\MyDocument.pdf")
MyPdfViewer.ShowBookmarkIcon = False
MyPdfViewer.ShowThumbnailIcon = False

[C#]
pdfViewer.Open(@"C:\MyDocument.pdf");
pdfViewer.ShowBookmarkIcon = false;
pdfViewer.ShowThumbnailIcon = false;


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Navigation | Comments on this topic
Foxit PDF Viewer for .NET > Programming with Foxit PDF Viewer > Navigation

Glossary Item Box

Foxit PDF Viewer supports navigating to a specific page, previous view or to a specified outline.

The below example assume that the Foxit PDF Viewer control's name in C# is pdfViewer and in VB.NET is MyPdfViewer.

Opening a Specific Page

[Visual Basic]
MyPdfViewer.Open("C:\MyDocument.pdf")
MyPdfViewer.Goto(pageNumber)

[C#]
pdfViewer.Open(@"C:\MyDocument.pdf");
pdfViewer.Goto(pageNumber);

Navigating to previous View

[Visual Basic]
MyPdfViewer.Open("C:\MyDocument.pdf")
MyPdfViewer.NavigateToPreviousView()

[C#]
pdfViewer.Open(@"C:\MyDocument.pdf");
pdfViewer.NavigateToPreviousView();


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Class Library Reference | Comments on this topic

Glossary Item Box

Foxit PDF for .NET

This topic contains reference to Foxit PDF Viewer for .NET.


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Viewer Namespace | Comments on this topic
See Also Inheritance Hierarchy
Foxit.PDF.Viewer Assembly : Foxit.PDF.Viewer Namespace

Classes

 | Class | Description
Class | Action | Specifies the action information of the link.
Class | Bookmark | Represents a bookmark.
Class | BookmarkList | Represents a collection of bookmarks.
Class | ContextMenuShowingEventArgs | Provides data for the ContextMenuShowing event.
Class | CursorModeChangedEventArgs | Provides data for the CursorModeChanged event.
Class | DocumentDisplayedEventArgs | Provides data for the DocumentDisplayed event.
Class | DocumentDisplayingEventArgs | Provides data for the DocumentDisplaying event.
Class | DocumentLoadException | Represents a DocumentLoadException
Class | FileOpenDialogShowingEventArgs | Provides data for the FileOpenDialogShowing event.
Class | FileOpenedEventArgs | Provides data for the FileOpened event.
Class | FileOpenFailedEventArgs | Provides data for the FileOpenFailed event.
Class | FileOpeningEventArgs | Provides data for the FileOpening event.
Class | GoToAction | Specifies the GoTo action type for the link.
Class | InvalidPasswordException | Represents a InvalidPasswordException
Class | LaunchAction | Specifies the Launch action type for the link.
Class | LicensingException | Represents a licensing exception.
Class | LinkClickedEventArgs | Provides data for the LinkClicked event.
Class | PageVisibleArea | Provides the details of visible area of a page.
Class | PasswordRequiredEventArgs | Provides data for the PasswordRequired event.
Class | PdfDocument | Represents a Pdf document.
Class | PdfViewer | Represents the PdfViewer control.
Class | PdfViewerException | Represents a PdfViewerException
Class | PdfViewerMouseEventArgs | Provides data for the PdfViewerMouseClick and PdfViewerMouseMove event.
Class | Permission | Provides information about the permissions of the PdfDocument.
Class | RemoteGoToAction | Specifies the RemoteGoTo action type for the link.
Class | SearchDialogShowingEventArgs | Provides data for the SearchDialogShowing event.
Class | SearchedEventArgs | Provides data for the Searched event.
Class | SearchProgressingEventArgs | Provides data for the SearchProgressing event.
Class | TextSelectedEventArgs | Provides data for the TextSelected event.
Class | TextSelectingEventArgs | Provides data for the TextSelecting event.
Class | URIAction | Specifies the URI action type for the link.
Class | View | Represents the view containing the attributes which defines the display.
Class | ViewChangedEventArgs | Provides data for the ViewChanged event.

Delegates

 | Delegate | Description
Delegate | ContextMenuShowingEventHandler | Represents the method that will handle the ContextMenuShowing event.
Delegate | CursorModeChangedEventHandler | Represents the method that will handle the CursorModeChanged event.
Delegate | DocumentDisplayedEventHadler | Represents the method that will handle the DocumentDisplayed event.
Delegate | DocumentDisplayingEventHandler | Represents the method that will handle the DocumentDisplaying event.
Delegate | FileOpenDialogShowingEventHandler | Represents the method that will handle the FileOpenDialogShowing event.
Delegate | FileOpenedEventHandler | Represents the method that will handle the FileOpened event.
Delegate | FileOpenFailedEventHandler | Represents the method that will handle the FileOpenFailed event.
Delegate | FileOpeningEventHandler | Represents the method that will handle the FileOpening event.
Delegate | LinkClickEventHandler | Represents the method that will handle the LinkClicked event.
Delegate | PasswordRequiredEventHandler | Represents the method that will handle the PasswordRequired event.
Delegate | PdfViewerMouseEventHandler | Represents the method that will handle the PdfViewerMouseClick or PdfViewerMouseMove event.
Delegate | SearchDialogShowingEventHandler | Represents the method that will handle the SearchDialogShowing event.
Delegate | SearchedEventHandler | Represents the method that will handle the Searched event.
Delegate | SearchProgressingEventHandler | Represents the method that will handle the SearchProgressing event.
Delegate | TextSelectedEventHandler | Represents the method that will handle the TextSelected event.
Delegate | TextSelectingEventHandler | Represents the method that will handle the TextSelecting event.
Delegate | ViewChangedEventHandler | Represents the mehtod that will handle the ViewChanged event.

Enumerations

 | Enumeration | Description
Enumeration | ActionType | Specifies the action types of the links.
Enumeration | ContextType | Specifies the type of context.
Enumeration | CursorMode | Specifies the cursor modes.
Enumeration | MatchOptions | Specifies the match options for the search.
Enumeration | NavigationPane | Specifies the Navigation window type shown when the PDF file is being viewed.
Enumeration | Orientation | Specifies the orientation types for a page.
Enumeration | PageDisplayMode | Represents the collection of page display mode types.
Enumeration | Zoom | Specifies the zoom mode types.

See Also

Reference

Foxit.PDF.Viewer Assembly


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Action Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Action Class

Specifies the action information of the link.

Object Model

Action Class

Syntax

Visual Basic (Declaration)
Public Class Action
C#
public class Action

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.GoToAction
Foxit.PDF.Viewer.LaunchAction
Foxit.PDF.Viewer.RemoteGoToAction
Foxit.PDF.Viewer.URIAction

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Action Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Action Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Action Class

The following tables list the members exposed by Action.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Action Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Action Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Action Class

For a list of all members of this type, see Action members.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link.
Top

See Also

Reference

Action Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActionType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > Action Class : ActionType Property

Gets the action type of the link.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ActionType As ActionType
C#
public ActionType ActionType {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Action Class
Action Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmark Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Bookmark Class

Represents a bookmark.

Object Model

Bookmark ClassBookmarkList ClassBookmark Class

Syntax

Visual Basic (Declaration)
Public Class Bookmark
C#
public class Bookmark

Example

The following example will get a bookmark from the child bookmark list.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        Dim MyDocument As PdfDocument = New PdfDocument("C:\MyDocument.pdf")

        ' Get the bookmark list from PDF document object.
        Dim MyBookmarksList As BookmarkList = MyDocument.Bookmarks

        ' Get a single bookmark from the list by specifying the index between 0 and count of bookmarks.
        Dim MyBookmark As Bookmark = MyBookmarksList(1)

        ' Open the document in Viewer.
        MyPdfViewer.Open(MyDocument)

        ' Navigate to the selected bookmark.
        MyPdfViewer.Navigate(MyBookmark)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load+=new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");

            // Get the bookmark list from PDF document object.
            BookmarkList bookmarksList = document.Bookmarks;

            // Get a single bookmark from the list by specifying the index between 0 and count of bookmarks.
            Bookmark bookmark = bookmarksList[2];

            // Open the document in Viewer.
            pdfViewer.Open(document);

            // Navigate to the selected bookmark.
            pdfViewer.Navigate(bookmark);
        }
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Bookmark

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Bookmark Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmark Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Bookmark Class

The following tables list the members exposed by Bookmark.

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets the collection of child bookmarks present in the document.
Public Property | Text | Gets the text of the bookmark.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Bookmark Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmark Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Bookmark Class

For a list of all members of this type, see Bookmark members.

Public Properties

 | Name | Description
Public Property | Bookmarks | Gets the collection of child bookmarks present in the document.
Public Property | Text | Gets the text of the bookmark.
Top

See Also

Reference

Bookmark Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmarks Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > Bookmark Class : Bookmarks Property

Gets the collection of child bookmarks present in the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As BookmarkList
C#
public BookmarkList Bookmarks {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Bookmark Class
Bookmark Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Text Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > Bookmark Class : Text Property

Gets the text of the bookmark.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Text As String
C#
public string Text {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Bookmark Class
Bookmark Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
BookmarkList Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : BookmarkList Class

Represents a collection of bookmarks.

Object Model

BookmarkList ClassBookmark Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public Class BookmarkList
   Implements System.Collections.IEnumerable
C#
[DefaultMemberAttribute("Item")]
public class BookmarkList : System.Collections.IEnumerable

Example

The following example will get the collection of bookmarks from PdfDocument object.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")

        ' Get the Bookmark List from PDF document object.
        Dim MyBookmarksList As BookmarkList = MyDocument.Bookmarks

        ' Get the count of bookmarks as below.
        Dim MyBookmarksCount As Integer = MyBookmarksList.Count

    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");

            // Get the Bookmark List from PDF document object.
            BookmarkList bookmarkList = document.Bookmarks;

            // Get the count of bookmarks as below.
            int bookmarksCount = bookmarkList.Count;

        }
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.BookmarkList

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BookmarkList Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
BookmarkList Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : BookmarkList Class

The following tables list the members exposed by BookmarkList.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of the bookmarks present in the PdfDocument.
Public Property | Item | Gets a bookmark from bookmark list.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetEnumerator | Returns an enumerator that iterates through a collection of bookmarks.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BookmarkList Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
BookmarkList Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : BookmarkList Class

For a list of all members of this type, see BookmarkList members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetEnumerator | Returns an enumerator that iterates through a collection of bookmarks.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

BookmarkList Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GetEnumerator Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > BookmarkList Class : GetEnumerator Method

Returns an enumerator that iterates through a collection of bookmarks.

Syntax

Visual Basic (Declaration)
Public Overridable Function GetEnumerator() As IEnumerator
C#
public virtual IEnumerator GetEnumerator()

Return Value

An System.Collections.IEnumerator object that can be used to iterate through the collection of bookmarks.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BookmarkList Class
BookmarkList Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
BookmarkList Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : BookmarkList Class

For a list of all members of this type, see BookmarkList members.

Public Properties

 | Name | Description
Public Property | Count | Gets the count of the bookmarks present in the PdfDocument.
Public Property | Item | Gets a bookmark from bookmark list.
Top

See Also

Reference

BookmarkList Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > BookmarkList Class : Count Property

Gets the count of the bookmarks present in the PdfDocument.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BookmarkList Class
BookmarkList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Item Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > BookmarkList Class : Item Property

index
Gets a bookmark from bookmark list.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Bookmark
C#
public Bookmark this[
   int index
]; {get;}

Parameters

index

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

BookmarkList Class
BookmarkList Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextMenuShowingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextMenuShowingEventArgs Class

Provides data for the ContextMenuShowing event.

Object Model

ContextMenuShowingEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class ContextMenuShowingEventArgs
   Inherits System.EventArgs
C#
public class ContextMenuShowingEventArgs : System.EventArgs

Example

For example refer to ContextMenuShowing event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.ContextMenuShowingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ContextMenuShowingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextMenuShowingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextMenuShowingEventArgs Class

The following tables list the members exposed by ContextMenuShowingEventArgs.

Public Properties

 | Name | Description
Public Property | AssignedContextMenu | Gets or sets the context menu of the control.
Public Property | Cancel | Gets or sets the boolean value.
Public Property | MenuContextType | Gets the context type.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ContextMenuShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextMenuShowingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextMenuShowingEventArgs Class

For a list of all members of this type, see ContextMenuShowingEventArgs members.

Public Properties

 | Name | Description
Public Property | AssignedContextMenu | Gets or sets the context menu of the control.
Public Property | Cancel | Gets or sets the boolean value.
Public Property | MenuContextType | Gets the context type.
Top

See Also

Reference

ContextMenuShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AssignedContextMenu Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ContextMenuShowingEventArgs Class : AssignedContextMenu Property

Gets or sets the context menu of the control.

Syntax

Visual Basic (Declaration)
Public Property AssignedContextMenu As ContextMenuStrip
C#
public ContextMenuStrip AssignedContextMenu {get; set;}

Remarks

If assigned context menu is not set viewer will sets its own context menu for the control.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ContextMenuShowingEventArgs Class
ContextMenuShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ContextMenuShowingEventArgs Class : Cancel Property

Gets or sets the boolean value.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ContextMenuShowingEventArgs Class
ContextMenuShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MenuContextType Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ContextMenuShowingEventArgs Class : MenuContextType Property

Gets the context type.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MenuContextType As ContextType
C#
public ContextType MenuContextType {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ContextMenuShowingEventArgs Class
ContextMenuShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorModeChangedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorModeChangedEventArgs Class

Provides data for the CursorModeChanged event.

Object Model

CursorModeChangedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class CursorModeChangedEventArgs
   Inherits System.EventArgs
C#
public class CursorModeChangedEventArgs : System.EventArgs

Example

For example refer to CursorModeChanged event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.CursorModeChangedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

CursorModeChangedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorModeChangedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorModeChangedEventArgs Class

The following tables list the members exposed by CursorModeChangedEventArgs.

Public Properties

 | Name | Description
Public Property | CursorMode | Gets the cursor mode.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

CursorModeChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorModeChangedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorModeChangedEventArgs Class

For a list of all members of this type, see CursorModeChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | CursorMode | Gets the cursor mode.
Top

See Also

Reference

CursorModeChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > CursorModeChangedEventArgs Class : CursorMode Property

Gets the cursor mode.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CursorMode As CursorMode
C#
public CursorMode CursorMode {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

CursorModeChangedEventArgs Class
CursorModeChangedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayedEventArgs Class

Provides data for the DocumentDisplayed event.

Object Model

DocumentDisplayedEventArgs ClassPdfDocument Class

Syntax

Visual Basic (Declaration)
Public Class DocumentDisplayedEventArgs
   Inherits System.EventArgs
C#
public class DocumentDisplayedEventArgs : System.EventArgs

Example

For example refer to DocumentDisplayed event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.DocumentDisplayedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayedEventArgs Class

The following tables list the members exposed by DocumentDisplayedEventArgs.

Public Properties

 | Name | Description
Public Property | Document | Gets the PdfDocument.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DocumentDisplayedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayedEventArgs Class

For a list of all members of this type, see DocumentDisplayedEventArgs members.

Public Properties

 | Name | Description
Public Property | Document | Gets the PdfDocument.
Top

See Also

Reference

DocumentDisplayedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Document Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayedEventArgs Class : Document Property

Gets the PdfDocument.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PdfDocument
C#
public PdfDocument Document {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayedEventArgs Class
DocumentDisplayedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayingEventArgs Class

Provides data for the DocumentDisplaying event.

Object Model

DocumentDisplayingEventArgs ClassPdfDocument Class

Syntax

Visual Basic (Declaration)
Public Class DocumentDisplayingEventArgs
   Inherits System.EventArgs
C#
public class DocumentDisplayingEventArgs : System.EventArgs

Example

For example refer to DocumentDisplaying event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.DocumentDisplayingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayingEventArgs Class

The following tables list the members exposed by DocumentDisplayingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | Document | Gets the PdfDocument.
Public Property | InitialOrientation | Gets or sets the value of page orientation when displaying a document.
Public Property | InitialPage | Gets or sets the value of initial page when displaying a document.
Public Property | InitialPageMode | Gets or sets the value of page mode when displaying a document.
Public Property | InitialVisibleNavigationPane | Gets or sets the value of navigation pane to be visible when displaying a document.
Public Property | InitialZoomMode | Gets or sets the value of page zoom mode when displaying a document.
Public Property | InitialZoomPercent | Gets or sets the value of page zoom percent when displaying a document.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DocumentDisplayingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayingEventArgs Class

For a list of all members of this type, see DocumentDisplayingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | Document | Gets the PdfDocument.
Public Property | InitialOrientation | Gets or sets the value of page orientation when displaying a document.
Public Property | InitialPage | Gets or sets the value of initial page when displaying a document.
Public Property | InitialPageMode | Gets or sets the value of page mode when displaying a document.
Public Property | InitialVisibleNavigationPane | Gets or sets the value of navigation pane to be visible when displaying a document.
Public Property | InitialZoomMode | Gets or sets the value of page zoom mode when displaying a document.
Public Property | InitialZoomPercent | Gets or sets the value of page zoom percent when displaying a document.
Top

See Also

Reference

DocumentDisplayingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Remarks

True will cancel the PDF document displaying and FileOpenFailed event will be raised.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Document Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : Document Property

Gets the PdfDocument.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Document As PdfDocument
C#
public PdfDocument Document {get;}

Remarks

Gets the PDF document PdfViewer going to display.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialOrientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialOrientation Property

Gets or sets the value of page orientation when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialOrientation As Nullable(Of Orientation)
C#
public Nullable<Orientation> InitialOrientation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialPage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialPage Property

Gets or sets the value of initial page when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialPage As Nullable(Of Integer)
C#
public Nullable<int> InitialPage {get; set;}

Remarks

The value should be a positive number and it will be 0 by default in case if it exceeds the total number of pages or not set.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialPageMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialPageMode Property

Gets or sets the value of page mode when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialPageMode As Nullable(Of PageDisplayMode)
C#
public Nullable<PageDisplayMode> InitialPageMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialVisibleNavigationPane Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialVisibleNavigationPane Property

Gets or sets the value of navigation pane to be visible when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialVisibleNavigationPane As Nullable(Of NavigationPane)
C#
public Nullable<NavigationPane> InitialVisibleNavigationPane {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialZoomMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialZoomMode Property

Gets or sets the value of page zoom mode when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialZoomMode As Nullable(Of Zoom)
C#
public Nullable<Zoom> InitialZoomMode {get; set;}

Remarks

If zoom percent mode is selected then the value of InitialZoomPercent has to be specified. Otherwise it will be .01f by default.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialZoomPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > DocumentDisplayingEventArgs Class : InitialZoomPercent Property

Gets or sets the value of page zoom percent when displaying a document.

Syntax

Visual Basic (Declaration)
Public Property InitialZoomPercent As Nullable(Of Single)
C#
public Nullable<float> InitialZoomPercent {get; set;}

Remarks

This value ranges from .01f to 64.0f.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventArgs Class
DocumentDisplayingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentLoadException Class

Represents a DocumentLoadException

Object Model

DocumentLoadException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class DocumentLoadException
   Inherits PdfViewerException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class DocumentLoadException : PdfViewerException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Viewer.PdfViewerException
Foxit.PDF.Viewer.DocumentLoadException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentLoadException Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentLoadException Class

The following tables list the members exposed by DocumentLoadException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenDialogShowingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenDialogShowingEventArgs Class

Provides data for the FileOpenDialogShowing event.

Object Model

FileOpenDialogShowingEventArgs ClassPdfDocument Class

Syntax

Visual Basic (Declaration)
Public Class FileOpenDialogShowingEventArgs
   Inherits System.EventArgs
C#
public class FileOpenDialogShowingEventArgs : System.EventArgs

Example

For example refer to FileOpenDialogShowing event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.FileOpenDialogShowingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenDialogShowingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenDialogShowingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenDialogShowingEventArgs Class

The following tables list the members exposed by FileOpenDialogShowingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | InitialDirectory | Gets or sets initial directory of the displaying file dialog.
Public Property | PdfDocument | Gets or sets the PdfDocument.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenDialogShowingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenDialogShowingEventArgs Class

For a list of all members of this type, see FileOpenDialogShowingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | InitialDirectory | Gets or sets initial directory of the displaying file dialog.
Public Property | PdfDocument | Gets or sets the PdfDocument.
Top

See Also

Reference

FileOpenDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenDialogShowingEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenDialogShowingEventArgs Class
FileOpenDialogShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialDirectory Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenDialogShowingEventArgs Class : InitialDirectory Property

Gets or sets initial directory of the displaying file dialog.

Syntax

Visual Basic (Declaration)
Public Property InitialDirectory As String
C#
public string InitialDirectory {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenDialogShowingEventArgs Class
FileOpenDialogShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenDialogShowingEventArgs Class : PdfDocument Property

Gets or sets the PdfDocument.

Syntax

Visual Basic (Declaration)
Public Property PdfDocument As PdfDocument
C#
public PdfDocument PdfDocument {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenDialogShowingEventArgs Class
FileOpenDialogShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenedEventArgs Class

Provides data for the FileOpened event.

Object Model

FileOpenedEventArgs ClassPdfDocument Class

Syntax

Visual Basic (Declaration)
Public Class FileOpenedEventArgs
   Inherits System.EventArgs
C#
public class FileOpenedEventArgs : System.EventArgs

Example

For example refer to FileOpened event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.FileOpenedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenedEventArgs Class

The following tables list the members exposed by FileOpenedEventArgs.

Public Properties

 | Name | Description
Public Property | PdfDocument | Gets the PDF document.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenedEventArgs Class

For a list of all members of this type, see FileOpenedEventArgs members.

Public Properties

 | Name | Description
Public Property | PdfDocument | Gets the PDF document.
Top

See Also

Reference

FileOpenedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenedEventArgs Class : PdfDocument Property

Gets the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PdfDocument As PdfDocument
C#
public PdfDocument PdfDocument {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenedEventArgs Class
FileOpenedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenFailedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenFailedEventArgs Class

Provides data for the FileOpenFailed event.

Object Model

FileOpenFailedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class FileOpenFailedEventArgs
   Inherits System.EventArgs
C#
public class FileOpenFailedEventArgs : System.EventArgs

Example

For example refer to FileOpenFailed event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.FileOpenFailedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenFailedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenFailedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenFailedEventArgs Class

The following tables list the members exposed by FileOpenFailedEventArgs.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception related to the PDF file open failure.
Public Property | ShowFileOpenFailedDialog | Gets or sets a boolean.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenFailedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenFailedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenFailedEventArgs Class

For a list of all members of this type, see FileOpenFailedEventArgs members.

Public Properties

 | Name | Description
Public Property | Exception | Gets the exception related to the PDF file open failure.
Public Property | ShowFileOpenFailedDialog | Gets or sets a boolean.
Top

See Also

Reference

FileOpenFailedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Exception Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenFailedEventArgs Class : Exception Property

Gets the exception related to the PDF file open failure.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Exception As Exception
C#
public Exception Exception {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenFailedEventArgs Class
FileOpenFailedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ShowFileOpenFailedDialog Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpenFailedEventArgs Class : ShowFileOpenFailedDialog Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property ShowFileOpenFailedDialog As Boolean
C#
public bool ShowFileOpenFailedDialog {get; set;}

Remarks

false value will hide the file open failed message dialog.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenFailedEventArgs Class
FileOpenFailedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpeningEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpeningEventArgs Class

Provides data for the FileOpening event.

Object Model

FileOpeningEventArgs ClassPdfDocument Class

Syntax

Visual Basic (Declaration)
Public Class FileOpeningEventArgs
   Inherits System.EventArgs
C#
public class FileOpeningEventArgs : System.EventArgs

Example

For example refer to FileOpening event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.FileOpeningEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpeningEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpeningEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpeningEventArgs Class

The following tables list the members exposed by FileOpeningEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | FilePath | Gets or sets the PDF document file path.
Public Property | PdfDocument | Gets or sets the PDF document.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpeningEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpeningEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpeningEventArgs Class

For a list of all members of this type, see FileOpeningEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | FilePath | Gets or sets the PDF document file path.
Public Property | PdfDocument | Gets or sets the PDF document.
Top

See Also

Reference

FileOpeningEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpeningEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FilePath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpeningEventArgs Class : FilePath Property

Gets or sets the PDF document file path.

Syntax

Visual Basic (Declaration)
Public Property FilePath As String
C#
public string FilePath {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > FileOpeningEventArgs Class : PdfDocument Property

Gets or sets the PDF document.

Syntax

Visual Basic (Declaration)
Public Property PdfDocument As PdfDocument
C#
public PdfDocument PdfDocument {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpeningEventArgs Class
FileOpeningEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToAction Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : GoToAction Class

Specifies the GoTo action type for the link.

Object Model

GoToAction Class

Syntax

Visual Basic (Declaration)
Public Class GoToAction
   Inherits Action
C#
public class GoToAction : Action

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.GoToAction

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GoToAction Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToAction Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : GoToAction Class

The following tables list the members exposed by GoToAction.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | PageNumber | Gets the destination page number associated with the link action.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

GoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToAction Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : GoToAction Class

For a list of all members of this type, see GoToAction members.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | PageNumber | Gets the destination page number associated with the link action.
Top

See Also

Reference

GoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > GoToAction Class : PageNumber Property

Gets the destination page number associated with the link action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

GoToAction Class
GoToAction Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : InvalidPasswordException Class

Represents a InvalidPasswordException

Object Model

InvalidPasswordException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class InvalidPasswordException
   Inherits PdfViewerException
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class InvalidPasswordException : PdfViewerException, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Viewer.PdfViewerException
Foxit.PDF.Viewer.InvalidPasswordException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

InvalidPasswordException Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : InvalidPasswordException Class

The following tables list the members exposed by InvalidPasswordException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LaunchAction Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LaunchAction Class

Specifies the Launch action type for the link.

Object Model

LaunchAction Class

Syntax

Visual Basic (Declaration)
Public Class LaunchAction
   Inherits Action
C#
public class LaunchAction : Action

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.LaunchAction

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LaunchAction Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LaunchAction Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LaunchAction Class

The following tables list the members exposed by LaunchAction.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | FilePath | Gets the file path of the document associated with the link action.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LaunchAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LaunchAction Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LaunchAction Class

For a list of all members of this type, see LaunchAction members.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | FilePath | Gets the file path of the document associated with the link action.
Top

See Also

Reference

LaunchAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FilePath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > LaunchAction Class : FilePath Property

Gets the file path of the document associated with the link action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilePath As String
C#
public string FilePath {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LaunchAction Class
LaunchAction Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LicensingException Class

Represents a licensing exception.

Object Model

LicensingException Class

Syntax

Visual Basic (Declaration)
Public Class LicensingException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
public class LicensingException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Viewer.LicensingException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LicensingException Class

The following tables list the members exposed by LicensingException.

Public Constructors

 | Name | Description
Public Constructor | LicensingException Constructor | Initializes a new instance of LicensingException.
Top

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > LicensingException Class : LicensingException Constructor

message
Message for the licensing exception.
Initializes a new instance of LicensingException.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
C#
public LicensingException(
   string message
)

Parameters

message
Message for the licensing exception.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LicensingException Class
LicensingException Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LinkClickedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LinkClickedEventArgs Class

Provides data for the LinkClicked event.

Object Model

LinkClickedEventArgs ClassAction Class

Syntax

Visual Basic (Declaration)
Public Class LinkClickedEventArgs
   Inherits System.EventArgs
C#
public class LinkClickedEventArgs : System.EventArgs

Example

For example refer to LinkClicked event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.LinkClickedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LinkClickedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LinkClickedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LinkClickedEventArgs Class

The following tables list the members exposed by LinkClickedEventArgs.

Public Properties

 | Name | Description
Public Property | Action | Gets the Action object which contains the information about the hyperlink.
Public Property | Cancel | Gets or sets the boolean.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LinkClickedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LinkClickedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LinkClickedEventArgs Class

For a list of all members of this type, see LinkClickedEventArgs members.

Public Properties

 | Name | Description
Public Property | Action | Gets the Action object which contains the information about the hyperlink.
Public Property | Cancel | Gets or sets the boolean.
Top

See Also

Reference

LinkClickedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Action Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > LinkClickedEventArgs Class : Action Property

Gets the Action object which contains the information about the hyperlink.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Action As Action
C#
public Action Action {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LinkClickedEventArgs Class
LinkClickedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > LinkClickedEventArgs Class : Cancel Property

Gets or sets the boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Remarks

If cancel variable is set to true the control will not follow the link action.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LinkClickedEventArgs Class
LinkClickedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageVisibleArea Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PageVisibleArea Class

Provides the details of visible area of a page.

Object Model

PageVisibleArea Class

Syntax

Visual Basic (Declaration)
Public Class PageVisibleArea
C#
public class PageVisibleArea

Example

The following example will show how we can get the array of PageVisibleArea for a view.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' Load and Open the document in Viewer.
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")
        MyPdfViewer.Open(MyDocument)

        'Get a view to calculate visible page area
        Dim MyCurrentView As Foxit.PDF.Viewer.View = MyPdfViewer.GetCurrentView()

        'Get the array of pages with their visible area
        Dim MyVisibleAreaArray As PageVisibleArea() = MyPdfViewer.GetPageVisibleArea(MyCurrentView)

        'Get the details of visible page area
        Dim pageNumber As Integer = MyVisibleAreaArray(0).PageNumber
        Dim left As Single = MyVisibleAreaArray(0).Left
        Dim top As Single = MyVisibleAreaArray(0).Top
        Dim right As Single = MyVisibleAreaArray(0).Right
        Dim bottom As Single = MyVisibleAreaArray(0).Bottom

    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Load and Open the document in Viewer.
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");
            pdfViewer.Open(document);

            // Get a view to calculate visible page area
            Foxit.PDF.Viewer.View currentView = pdfViewer.GetCurrentView();

            // Get the array of pages with their visible area
            PageVisibleArea[] visibleAreaArray = pdfViewer.GetPageVisibleArea(currentView);

            // Get the details of visible page area
            int pageNumber = visibleAreaArray[0].PageNumber;
            float left = visibleAreaArray[0].Left;
            float top = visibleAreaArray[0].Top;
            float right = visibleAreaArray[0].Right;
            float bottom = visibleAreaArray[0].Bottom;
        }
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.PageVisibleArea

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageVisibleArea Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PageVisibleArea Class

The following tables list the members exposed by PageVisibleArea.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the bottom value of the page.
Public Property | Left | Gets the left value of the page.
Public Property | PageNumber | Gets the page number.
Public Property | Right | Gets the right value of the page.
Public Property | Top | Gets the top value of the page.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageVisibleArea Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageVisibleArea Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PageVisibleArea Class

For a list of all members of this type, see PageVisibleArea members.

Public Properties

 | Name | Description
Public Property | Bottom | Gets the bottom value of the page.
Public Property | Left | Gets the left value of the page.
Public Property | PageNumber | Gets the page number.
Public Property | Right | Gets the right value of the page.
Public Property | Top | Gets the top value of the page.
Top

See Also

Reference

PageVisibleArea Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bottom Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PageVisibleArea Class : Bottom Property

Gets the bottom value of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bottom As Single
C#
public float Bottom {get;}

Remarks

This value ranges from from value of displayed propertion to '1' and is equal to the portion of the page lying inside the bottom edge of the display.If the full page is inside the bottom edge then bottom value will be '0'. We can get the percentage of page on display vertically then calculation is (Bottom - Top) * 100 .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Class
PageVisibleArea Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Left Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PageVisibleArea Class : Left Property

Gets the left value of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Left As Single
C#
public float Left {get;}

Remarks

This value ranges from '0' to '1' and is equal to the portion of the page lying outside the left edge of the display.If the page is inside the display then left value will be '0'. We can get the percentage of page on display horizontally then calculation is (Right - Left) * 100 .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Class
PageVisibleArea Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PageVisibleArea Class : PageNumber Property

Gets the page number.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Class
PageVisibleArea Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Right Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PageVisibleArea Class : Right Property

Gets the right value of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Right As Single
C#
public float Right {get;}

Remarks

This value ranges from '0' to '1' and is equal to the portion of the page lying inside the Right edge of the display.If the full page is inside the right edge then right value will be '1'. We can get the percentage of page on display then calculation is (Right - Left) * 100 .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Class
PageVisibleArea Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Top Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PageVisibleArea Class : Top Property

Gets the top value of the page.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Top As Single
C#
public float Top {get;}

Remarks

This value ranges from value of displayed propertion to '1' and is equal to the portion of the page lying outside the top edge of the display.If the page is inside the display then top value will be '0'. We can get the percentage of page on display vertically then calculation is (Bottom - Top) * 100 .

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PageVisibleArea Class
PageVisibleArea Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PasswordRequiredEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PasswordRequiredEventArgs Class

Provides data for the PasswordRequired event.

Object Model

PasswordRequiredEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PasswordRequiredEventArgs
   Inherits System.EventArgs
C#
public class PasswordRequiredEventArgs : System.EventArgs

Example

For example refer to PasswordRequired event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.PasswordRequiredEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PasswordRequiredEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PasswordRequiredEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PasswordRequiredEventArgs Class

The following tables list the members exposed by PasswordRequiredEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | MaxAttempts | Gets or sets the maximum number of attempts to re-entry, when incorrect password is given.
Public Property | Password | Gets or sets the PDF document password.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PasswordRequiredEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PasswordRequiredEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PasswordRequiredEventArgs Class

For a list of all members of this type, see PasswordRequiredEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | MaxAttempts | Gets or sets the maximum number of attempts to re-entry, when incorrect password is given.
Public Property | Password | Gets or sets the PDF document password.
Top

See Also

Reference

PasswordRequiredEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PasswordRequiredEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MaxAttempts Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PasswordRequiredEventArgs Class : MaxAttempts Property

Gets or sets the maximum number of attempts to re-entry, when incorrect password is given.

Syntax

Visual Basic (Declaration)
Public Property MaxAttempts As Integer
C#
public int MaxAttempts {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Password Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PasswordRequiredEventArgs Class : Password Property

Gets or sets the PDF document password.

Syntax

Visual Basic (Declaration)
Public Property Password As String
C#
public string Password {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PasswordRequiredEventArgs Class
PasswordRequiredEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfDocument Class

Represents a Pdf document.

Object Model

PdfDocument ClassBookmarkList ClassBookmark ClassPermission Class

Syntax

Visual Basic (Declaration)
Public Class PdfDocument
   Implements System.IDisposable
C#
public class PdfDocument : System.IDisposable

Example

This example demonstrates how to load a PDF file in PdfViewer control using PdfDocument.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' Load and Open the document in Viewer.
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")
        MyPdfViewer.Open(MyDocument)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Load and Open the document in Viewer.
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");
            pdfViewer.Open(document);
        }
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.PdfDocument

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfDocument Class

The following tables list the members exposed by PdfDocument.

Public Constructors

 | Name | Description
Public Constructor | PdfDocument Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Bookmarks | Gets the collection of bookmarks present in the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | InitialPage | Gets the initial page to be displayed.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | PageCount | Gets the page count PDF document.
Public Property | PageMode | Gets the initial page mode of the document.
Public Property | Permissions | Gets the Permission information of the document.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Public Property | VisibleNavigationPane | Gets the initial navigation pane of the document.
Public Property | ZoomMode | Gets the initial zoom mode of the document.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfDocument Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : PdfDocument Constructor

Overload List

Overload | Description
PdfDocument Constructor(Byte[],String) | Initializes a new instance of the PdfDocument class.
PdfDocument Constructor(Stream,String) | Initializes a new instance of the PdfDocument class.
PdfDocument Constructor(String,String) | Initializes a new instance of the PdfDocument class.
PdfDocument Constructor(Byte[]) | Initializes a new instance of the PdfDocument class.
PdfDocument Constructor(Stream) | Initializes a new instance of the PdfDocument class.
PdfDocument Constructor(String) | Initializes a new instance of the PdfDocument class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(Byte[],String) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(Byte[],String)

data
Byte array of the input PDF data.
password
Password to open the PDF file.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte, _
   ByVal password As String _
)
C#
public PdfDocument(
   byte[] data,
   string password
)

Parameters

data
Byte array of the input PDF data.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(Stream,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(Stream,String)

stream
System.IO.Streamcontaining the PDF data.
password
Password to open the PDF file.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal password As String _
)
C#
public PdfDocument(
   Stream stream,
   string password
)

Parameters

stream
System.IO.Streamcontaining the PDF data.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(String,String) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(String,String)

filePath
Physical file path of the PDF.
password
Password to open the PDF file.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String, _
   ByVal password As String _
)
C#
public PdfDocument(
   string filePath,
   string password
)

Parameters

filePath
Physical file path of the PDF.
password
Password to open the PDF file.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(Byte[]) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(Byte[])

data
Byte array of the input PDF data.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal data() As Byte _
)
C#
public PdfDocument(
   byte[] data
)

Parameters

data
Byte array of the input PDF data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(Stream) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(Stream)

stream
System.IO.Streamcontaining the PDF data.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
C#
public PdfDocument(
   Stream stream
)

Parameters

stream
System.IO.Streamcontaining the PDF data.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Constructor(String) | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class > PdfDocument Constructor : PdfDocument Constructor(String)

filePath
Physical file path of the PDF.
Initializes a new instance of the PdfDocument class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filePath As String _
)
C#
public PdfDocument(
   string filePath
)

Parameters

filePath
Physical file path of the PDF.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members
Overload List


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfDocument Class

For a list of all members of this type, see PdfDocument members.

Public Properties

 | Name | Description
Public Property | Author | Gets the author property of the PDF document.
Public Property | Bookmarks | Gets the collection of bookmarks present in the PDF document.
Public Property | Creator | Gets the creator property of the PDF document.
Public Property | InitialPage | Gets the initial page to be displayed.
Public Property | Keywords | Gets the keywords property of the PDF document.
Public Property | PageCount | Gets the page count PDF document.
Public Property | PageMode | Gets the initial page mode of the document.
Public Property | Permissions | Gets the Permission information of the document.
Public Property | Producer | Gets the producer property of the PDF document.
Public Property | Subject | Gets the subject property of the PDF document.
Public Property | Title | Gets the title property of the PDF document.
Public Property | VisibleNavigationPane | Gets the initial navigation pane of the document.
Public Property | ZoomMode | Gets the initial zoom mode of the document.
Top

See Also

Reference

PdfDocument Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Author Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Author Property

Gets the author property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Author As String
C#
public string Author {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmarks Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Bookmarks Property

Gets the collection of bookmarks present in the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Bookmarks As BookmarkList
C#
public BookmarkList Bookmarks {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Creator Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Creator Property

Gets the creator property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Creator As String
C#
public string Creator {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialPage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : InitialPage Property

Gets the initial page to be displayed.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InitialPage As Nullable(Of Integer)
C#
public Nullable<int> InitialPage {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Keywords Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Keywords Property

Gets the keywords property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Keywords As String
C#
public string Keywords {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageCount Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : PageCount Property

Gets the page count PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageCount As Integer
C#
public int PageCount {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : PageMode Property

Gets the initial page mode of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageMode As Nullable(Of PageDisplayMode)
C#
public Nullable<PageDisplayMode> PageMode {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Permissions Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Permissions Property

Gets the Permission information of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Permissions As Permission
C#
public Permission Permissions {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Producer Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Producer Property

Gets the producer property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Producer As String
C#
public string Producer {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Subject Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Subject Property

Gets the subject property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Subject As String
C#
public string Subject {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Title Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : Title Property

Gets the title property of the PDF document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Title As String
C#
public string Title {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VisibleNavigationPane Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : VisibleNavigationPane Property

Gets the initial navigation pane of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property VisibleNavigationPane As Nullable(Of NavigationPane)
C#
public Nullable<NavigationPane> VisibleNavigationPane {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ZoomMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfDocument Class : ZoomMode Property

Gets the initial zoom mode of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ZoomMode As Nullable(Of Zoom)
C#
public Nullable<Zoom> ZoomMode {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfDocument Class
PdfDocument Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewer Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewer Class

Represents the PdfViewer control.

Object Model

PdfViewer ClassView ClassView ClassPageVisibleArea Class

Syntax

Visual Basic (Declaration)
<ToolboxBitmapAttribute()>
<DescriptionAttribute("PDF Viewer for WinForms(Managed).")>
<ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<DisplayNameAttribute("Foxit PDF Viewer for .NET SDK")>
Public Class PdfViewer
   Inherits System.Windows.Forms.Control
   Implements System.ComponentModel.IComponent, System.ComponentModel.ISynchronizeInvoke, System.IDisposable, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
C#
[ToolboxBitmapAttribute()]
[DescriptionAttribute("PDF Viewer for WinForms(Managed).")]
[ToolboxItemAttribute(ToolboxItemType=System.Drawing.Design.ToolboxItem, ToolboxItemTypeName="System.Drawing.Design.ToolboxItem, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[DisplayNameAttribute("Foxit PDF Viewer for .NET SDK")]
public class PdfViewer : System.Windows.Forms.Control, System.ComponentModel.IComponent, System.ComponentModel.ISynchronizeInvoke, System.IDisposable, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window

Example

This example shows, how to load a PDF document in PdfViewer.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' Load and Open the document in Viewer.
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")
        MyPdfViewer.Open(MyDocument)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Load and Open the document in Viewer.
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");
            pdfViewer.Open(document);
        }
    }
}

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Foxit.PDF.Viewer.PdfViewer

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewer Class Members | Comments on this topic
See Also Properties Methods Events
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewer Class

The following tables list the members exposed by PdfViewer.

Public Constructors

 | Name | Description
Public Constructor | PdfViewer Constructor | Initializes a new instance of the PdfViewer class.
Top

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CursorMode | Gets or sets the cursor mode for the document.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | FilePath | Gets the file path of the document on display.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | HasNextView | Gets a boolean value to show if next view history contains any view or not.
Public Property | HasPreviousView | Gets a boolean value to show if previous view history contains any view or not.
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InitialOrientation | Gets or sets the value of page orientation when displaying a document.
Public Property | InitialPage | Gets or sets the value of initial page when displaying a document.
Public Property | InitialPageMode | Gets or sets the value of page mode when displaying a document.
Public Property | InitialVisibleNavigationPane | Gets or sets the value of navigation pane to be visible when displaying a document.
Public Property | InitialZoomMode | Gets or sets the value of page zoom mode when displaying a document.
Public Property | InitialZoomPercent | Gets or sets the value of page zoom percent when displaying a document.
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | NavigationPanelWidth | Gets or sets the navigation panel width.
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageColor | Gets or sets the Page Color of the document.
Public Property | PageMode | Gets or sets the Page Display mode of the document.
Public Property | PageOrientation | Gets or sets the Orientation of the page.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | ShowBookmarkIcon | Gets or sets the value to show/hide the bookmarks icon in navigation panel.
Public Property | ShowThumbnailIcon | Gets or sets the value to show/hide thumbnails icon in navigation panel.
Public Property | ShowToolbar | Gets or sets the boolean to show/hide the toolbar.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | ViewerToolbar | Gets or sets the toolbar of the viewer control.
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleNavigationPane | Gets or sets the value of navigation pane to be visible for displayed document.
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the Zoom Mode of the document.
Public Property | ZoomPercent | Gets or sets the value of page zoom percent for displayed document.
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ClearSearchHighlights | Clear all the highlights in the document.
Public Method | ClearViewHistory | Clears all the View present in the history.
Public Method | Close | Closes the opened PDF.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | Equals | (Inherited from object)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetCurrentView | Retrieves the current View of the document displayed.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetInitialView | Retrieves the initial View of the document displayed.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPageVisibleArea | Retrieves an array of pages present in View specified with respective visible area.
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | GoTo | Moves to the page specified as parameter.
Public Method | GoToFirstPage | Moves to the first page of the document.
Public Method | GoToLastPage | Moves to the last page of the document.
Public Method | GoToNextPage | Moves to next page.
Public Method | GoToPreviousPage | Moves to the previous page.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Highlight | Highlights the specified string throughout the document.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | Navigate | Overloaded. Navigate to the destination stored in the Action object of the link.
Public Method | NavigateToNextView | Navigates to the View in next history.
Public Method | NavigateToPreviousView | Navigates to the View in previous history.
Public Method | Open | Overloaded. Opens a new PDF using PdfDocument.
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | Print | Prints the document.
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | SearchBackward | Searches the string specified in backward direction.
Public Method | SearchForward | Searches the string specified in forward direction.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

Public Events

 | Name | Description
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuShowing | Occurs when the control's context menu is being displayed.
Public Event | CursorModeChanged | Occurs when the cursor mode is changed.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DocumentDisplayed | Occurs after the PDF document is displayed.
Public Event | DocumentDisplaying | Occurs before the PDF document is displayed.
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FileOpenDialogShowing | Occurs when the file open dialog is being displayed.
Public Event | FileOpened | Occurs after the PDF file is opened.
Public Event | FileOpenFailed | Occurs when the PDF file open failed.
Public Event | FileOpening | Occurs before the PDF file is opened.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LinkClicked | Occurs when user clicks on a link.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PasswordRequired | Occurs when the PDF file needed a password to open.
Public Event | PdfViewerMouseClick | Occurs when user clicks on a PdfViewer control.
Public Event | PdfViewerMouseMove | Occurs when user moves the mouse pointer on a PdfViewer control.
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SearchDialogShowing | Occurs when the search dialog is being displayed.
Public Event | Searched | Occurs when the search term is found successfully.
Public Event | SearchProgressing | Occurs when the search for a string is in progress.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextSelected | Occurs when the text selection is completed.
Public Event | TextSelecting | Occurs when the text is being selected.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | ViewChanged | Occurs each time when the view of the display is changed.
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

PdfViewer Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewer Constructor | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PdfViewer Constructor

Initializes a new instance of the PdfViewer class.

Syntax

Visual Basic (Declaration)
Public Function New()
C#
public PdfViewer()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewer Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewer Class

For a list of all members of this type, see PdfViewer members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddLicense | Adds a license key.
Public Method | BeginInvoke | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | Brings the control to the front of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | ClearSearchHighlights | Clear all the highlights in the document.
Public Method | ClearViewHistory | Clears all the View present in the history.
Public Method | Close | Closes the opened PDF.
Public Method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | Creates the System.Drawing.Graphics for the control. (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from System.MarshalByRefObject)
Public Method | Dispose() | (Inherited from System.ComponentModel.Component)
Public Method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the System.IAsyncResult passed. (Inherited from System.Windows.Forms.Control)
Public Method | Equals | (Inherited from object)
Public Method | FindForm | Retrieves the form that the control is on. (Inherited from System.Windows.Forms.Control)
Public Method | Focus | Sets input focus to the control. (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | Returns the next System.Windows.Forms.ContainerControl up the control's chain of parent controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetCurrentView | Retrieves the current View of the document displayed.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetInitialView | Retrieves the initial View of the document displayed.
Public Method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from System.Windows.Forms.Control)
Public Method | GetPageVisibleArea | Retrieves an array of pages present in View specified with respective visible area.
Public Method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from System.Windows.Forms.Control)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | GoTo | Moves to the page specified as parameter.
Public Method | GoToFirstPage | Moves to the first page of the document.
Public Method | GoToLastPage | Moves to the last page of the document.
Public Method | GoToNextPage | Moves to next page.
Public Method | GoToPreviousPage | Moves to the previous page.
Public Method | Hide | Conceals the control from the user. (Inherited from System.Windows.Forms.Control)
Public Method | Highlight | Highlights the specified string throughout the document.
Public Method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from System.Windows.Forms.Control)
Public Method | Navigate | Overloaded. Navigate to the destination stored in the Action object of the link.
Public Method | NavigateToNextView | Navigates to the View in next history.
Public Method | NavigateToPreviousView | Navigates to the View in previous history.
Public Method | Open | Overloaded. Opens a new PDF using PdfDocument.
Public Method | PerformLayout | Overloaded. Forces the control to apply layout logic to all its child controls. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from System.Windows.Forms.Control)
Public Method | Print | Prints the document.
Public Method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from System.Windows.Forms.Control)
Public Method | ResetText | Resets the System.Windows.Forms.Control.Text property to its default value. (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. Resumes usual layout logic. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | SearchBackward | Searches the string specified in backward direction.
Public Method | SearchForward | Searches the string specified in forward direction.
Public Method | Select | Activates the control. (Inherited from System.Windows.Forms.Control)
Public Method | SelectNextControl | Activates the next control. (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | Sends the control to the back of the z-order. (Inherited from System.Windows.Forms.Control)
Public Method | SetBounds | Overloaded. Sets the bounds of the control to the specified location and size. (Inherited from System.Windows.Forms.Control)
Public Method | Show | Displays the control to the user. (Inherited from System.Windows.Forms.Control)
Public Method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.ComponentModel.Component)
Public Method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

PdfViewer Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AddLicense Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : AddLicense Method

licenseKey
The license key to add.
Adds a license key.

Syntax

Visual Basic (Declaration)
Public Shared Function AddLicense( _
   ByVal licenseKey As String _
) As Boolean
C#
public static bool AddLicense(
   string licenseKey
)

Parameters

licenseKey
The license key to add.

Return Value

A boolean value indicating if the license key is valid.

Remarks

This method accepts a license key, not a serial number.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ClearSearchHighlights Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ClearSearchHighlights Method

Clear all the highlights in the document.

Syntax

Visual Basic (Declaration)
Public Sub ClearSearchHighlights()
C#
public void ClearSearchHighlights()

Example

The following example will show how to clear all the highlights from the document.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Clear all the highlights.
        MyPdfViewer.ClearSearchHighlights()
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in viewer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Clear all the highlights.
            pdfViewer.ClearSearchHighlights();
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ClearViewHistory Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ClearViewHistory Method

Clears all the View present in the history.

Syntax

Visual Basic (Declaration)
Public Sub ClearViewHistory()
C#
public void ClearViewHistory()

Example

The following example will show how to clear all the views present in the history.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Clear all the views.
        MyPdfViewer.ClearViewHistory()
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load += new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Clear all the views.
            pdfViewer.ClearViewHistory();
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Close Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Close Method

Closes the opened PDF.

Syntax

Visual Basic (Declaration)
Public Sub Close()
C#
public void Close()

Example

This example shows, how to load a PDF document in PdfViewer and close it.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Dim MyCloseButton As New Button()
        MyCloseButton.Text = "CloseButton"
        Me.Controls.Add(MyCloseButton)
        AddHandler MyCloseButton.Click, New EventHandler(AddressOf MyCloseButton_Click)

        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open the document in Viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")
    End Sub

    Private Sub MyCloseButton_Click(ByVal sender As Object, ByVal e As EventArgs)
        MyPdfViewer.Close()
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            Button CloseButton = new Button();
            CloseButton.Text = "CloseButton";
            this.Controls.Add(CloseButton);
            CloseButton.Click+= new EventHandler(CloseButton_Click);

            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load +=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            pdfViewer.Open(@"C:\MyDocument.pdf");
        }

        private void CloseButton_Click(object sender, EventArgs e)
        {
            pdfViewer.Close();
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GetCurrentView Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GetCurrentView Method

Retrieves the current View of the document displayed.

Syntax

Visual Basic (Declaration)
Public Function GetCurrentView() As View
C#
public View GetCurrentView()

Return Value

This method returns the current View of the document on display.

Example

The following example will show how to get current view and its associated data.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in Viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Get current view on display.
        Dim MyCurrentView As Foxit.PDF.Viewer.View = MyPdfViewer.GetCurrentView()

        ' Get the details of view.
        Dim pageNo As Integer = MyCurrentView.StartPageNumber
        Dim zoomValue As Single = MyCurrentView.ZoomPercent
        Dim MyDisplayMode As PageDisplayMode = MyCurrentView.PageDisplayMode
        Dim MySoomMode As Zoom = MyCurrentView.ZoomMode
        Dim MyPageOrientation As Foxit.PDF.Viewer.Orientation = MyCurrentView.PageOrientation
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load +=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in viewer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Get current view on display.
            Foxit.PDF.Viewer.View currentView = pdfViewer.GetCurrentView();

            // Get the details of view.
            int pageNo = currentView.StartPageNumber;
            float zoomValue = currentView.ZoomPercent;
            PageDisplayMode displayMode = currentView.PageDisplayMode;
            Zoom zoomMode = currentView.ZoomMode;
            Foxit.PDF.Viewer.Orientation pageOrientation = currentView.PageOrientation;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GetInitialView Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GetInitialView Method

Retrieves the initial View of the document displayed.

Syntax

Visual Basic (Declaration)
Public Function GetInitialView() As View
C#
public View GetInitialView()

Return Value

This method returns the initial View of the document on display.

Example

The following example will show how to get the initial view and its associated details.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' Open the document in Viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        'Get initial view of the document.
        Dim MyInitialView As Foxit.PDF.Viewer.View = MyPdfViewer.GetInitialView()

        ' Get the details of view.
        Dim pageNo As Integer = MyInitialView.StartPageNumber
        Dim zoomValue As Single = MyInitialView.ZoomPercent
        Dim MyDisplayMode As PageDisplayMode = MyInitialView.PageDisplayMode
        Dim MyZoomMode As Zoom = MyInitialView.ZoomMode
        Dim MyPageOrientation As Foxit.PDF.Viewer.Orientation = MyInitialView.PageOrientation
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in PdfViewwer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            //Get initial view of the document.
            Foxit.PDF.Viewer.View  initialView = pdfViewer.GetInitialView();

            // Get the details of view.
            int pageNo = initialView.StartPageNumber;
            float zoomValue = initialView.ZoomPercent;
            PageDisplayMode displayMode =  initialView.PageDisplayMode;
            Zoom zoomMode = initialView.ZoomMode;
            Foxit.PDF.Viewer.Orientation pageOrientation = initialView.PageOrientation;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GetPageVisibleArea Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GetPageVisibleArea Method

view
The View whose visible area is required.
Retrieves an array of pages present in View specified with respective visible area.

Syntax

Visual Basic (Declaration)
Public Function GetPageVisibleArea( _
   ByVal view As View _
) As PageVisibleArea()
C#
public PageVisibleArea[] GetPageVisibleArea(
   View view
)

Parameters

view
The View whose visible area is required.

Example

For example refer PageVisibleArea class.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoTo Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GoTo Method

pageNumber
The page number to move to.
Moves to the page specified as parameter.

Syntax

Visual Basic (Declaration)
Public Sub GoTo( _
   ByVal pageNumber As Integer _
)
C#
public void GoTo(
   int pageNumber
)

Parameters

pageNumber
The page number to move to.

Remarks

The page number should be a non zero based index.

Example

The following example will show how to move to a page by specifying its number.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Move to a page.
        ' PageNumber ranges from '1' to 'count' of the pages in the document.
        MyPdfViewer.GoTo(1)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in viewer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Move to a page.
            // PageNumber ranges from '1' to 'count' of the pages in the document.
            pdfViewer.GoTo(1);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToFirstPage Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GoToFirstPage Method

Moves to the first page of the document.

Syntax

Visual Basic (Declaration)
Public Sub GoToFirstPage()
C#
public void GoToFirstPage()

Example

The following example will show how to move to first page of the document.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in Viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Move to first page.
        MyPdfViewer.GoToFirstPage()
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in Viewer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Move to first page.
            pdfViewer.GoToFirstPage();
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToLastPage Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GoToLastPage Method

Moves to the last page of the document.

Syntax

Visual Basic (Declaration)
Public Sub GoToLastPage()
C#
public void GoToLastPage()

Example

The following example will show how to move to last page of the document.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in viewer.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Move to last page.
        MyPdfViewer.GoToLastPage()
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load += new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in viewer.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Move to last page.
            pdfViewer.GoToLastPage();
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToNextPage Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GoToNextPage Method

Moves to next page.

Syntax

Visual Basic (Declaration)
Public Function GoToNextPage() As Boolean
C#
public bool GoToNextPage()

Return Value

True if successfully moved to next page else false.

Example

The following example will show how to move to next page.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Move to next page.
        Dim bResult As Boolean = MyPdfViewer.GoToNextPage()

        If bResult Then
            MessageBox.Show("Successfully moved to next page")
        Else
            MessageBox.Show("There's no next page to move")
        End If
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Move to next page.
            bool bResult = pdfViewer.GoToNextPage();

            if(bResult)
                MessageBox.Show("Successfully moved to next page");
            else
                MessageBox.Show("There's no next page to move");
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToPreviousPage Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : GoToPreviousPage Method

Moves to the previous page.

Syntax

Visual Basic (Declaration)
Public Function GoToPreviousPage() As Boolean
C#
public bool GoToPreviousPage()

Return Value

True if successfully moved to previous page else false.

Example

The following example will show how to move to previous page.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Move to previous page.
        Dim bResult As Boolean = MyPdfViewer.GoToPreviousPage()

        If bResult Then
            MessageBox.Show("Successfully moved to previous page")
        Else
            MessageBox.Show("There's no previous page to move")
        End If
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Move to previous page.
            bool bResult = pdfViewer.GoToPreviousPage();

            if(bResult)
                MessageBox.Show("Successfully moved to previous page");
            else
                MessageBox.Show("There's no previous page to move");
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Highlight Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Highlight Method

searchTerm
The string to be highlighted.
option
The match option to be used to search and highlight the string.
Highlights the specified string throughout the document.

Syntax

Visual Basic (Declaration)
Public Sub Highlight( _
   ByVal searchTerm As String, _
   ByVal option As MatchOptions _
)
C#
public void Highlight(
   string searchTerm,
   MatchOptions option
)

Parameters

searchTerm
The string to be highlighted.
option
The match option to be used to search and highlight the string.

Example

The following example will show how to highlight a string throughout the document with a match option.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Highlights a string throughout the document.
        MyPdfViewer.Highlight("string", MatchOptions.WholeWordOnly)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
             this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Highlights a string throughout the document.
            pdfViewer.Highlight("string" , MatchOptions.WholeWordOnly);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Navigate Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Navigate Method

Navigate to the destination stored in the Action object of the link.

Overload List

Overload | Description
Navigate(Action) | Navigate to the destination stored in the Action object of the link.
Navigate(Bookmark) | Navigate to the Bookmark specified.
Navigate(View) | Navigates to the View specified.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Navigate(Action) Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class > Navigate Method : Navigate(Action) Method

action
The Action object containing the information about the link.
Navigate to the destination stored in the Action object of the link.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Navigate( _
   ByVal action As Action _
)
C#
public void Navigate(
   Action action
)

Parameters

action
The Action object containing the information about the link.

Remarks

In case of remote goto user needs to open the file first and then navigate to the action.

Example

The following example will show how to get a Action object and navigate to it.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.LinkClicked, AddressOf MyPdfViewer_LinkClicked
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub MyPdfViewer_LinkClicked(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.LinkClickedEventArgs)
        ' Get the action associated with the link.
        Dim Myction As Foxit.PDF.Viewer.Action = e.Action

        ' Navigate to the action.
        Me.MyPdfViewer.Navigate(Myction)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
             InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.LinkClicked += new Foxit.PDF.Viewer.LinkClickEventHandler(this.pdfViewer_LinkClicked);
        }

        private void pdfViewer_LinkClicked(object sender, Foxit.PDF.Viewer.LinkClickedEventArgs e)
        {
            // Get the action associated with the link.
            Foxit.PDF.Viewer.Action action = e.Action;

            // Navigate to the action.
            this.pdfViewer.Navigate(action);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Navigate(Bookmark) Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class > Navigate Method : Navigate(Bookmark) Method

bookmark
The Bookmark to move to.
Navigate to the Bookmark specified.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Navigate( _
   ByVal bookmark As Bookmark _
)
C#
public void Navigate(
   Bookmark bookmark
)

Parameters

bookmark
The Bookmark to move to.

Example

The following example will show how to get a Bookmark and navigate to it.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Get a PDF document object and open in viewer.
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")
        MyPdfViewer.Open(MyDocument)

        ' Get a bookmark from PDF document object.
        Dim MyBookmarkList As BookmarkList = MyDocument.Bookmarks

        ' Get a bookmark from the list
        ' Index ranges from 0 to n(count-1) of the bookmarks
        Dim MyBookmark As Bookmark = MyBookmarkList(0)

        'Navigate to a bookmark passed as parameter.
        MyPdfViewer.Navigate(MyBookmark)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Get a PDF document object and open in viewer.
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");
            pdfViewer.Open(document);

            // Get a bookmark from PDF document object.
            BookmarkList bookmarkList = document.Bookmarks;

            // Get a bookmark from the list.
            // Index ranges from 0 to n(count-1) of the bookmarks
            Bookmark bookmark = bookmarkList[0];

            // Navigate to a bookmark passed as parameter.
            pdfViewer.Navigate(bookmark);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Navigate(View) Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class > Navigate Method : Navigate(View) Method

View
The View to move to.
Navigates to the View specified.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Navigate( _
   ByVal View As View _
)
C#
public void Navigate(
   View View
)

Parameters

View
The View to move to.

Example

The following example will show how to navigate to a view given as parameter.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Get initial view.
        Dim MyInitView As Foxit.PDF.Viewer.View = MyPdfViewer.GetInitialView()

        ' Navigate to view passed as parameter.
        MyPdfViewer.Navigate(MyInitView)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Get initial view.
            Foxit.PDF.Viewer.View initView = pdfViewer.GetInitialView();

            // Navigate to view passed as parameter.
            pdfViewer.Navigate(initView);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
NavigateToNextView Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : NavigateToNextView Method

Navigates to the View in next history.

Syntax

Visual Basic (Declaration)
Public Function NavigateToNextView() As Boolean
C#
public bool NavigateToNextView()

Return Value

True if successfully moved to next view else false.

Example

The following example will show how to Navigate to the next view.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Navigate to next view.
        Dim bResult As Boolean = MyPdfViewer.NavigateToNextView()

        If bResult Then
            MessageBox.Show("Successfully moved to previous view")
        Else
            MessageBox.Show("There's no next view to navigate")
        End If
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Navigate to next view.
            bool bResult = pdfViewer.NavigateToNextView();

            if(bResult)
                MessageBox.Show("Successfully moved to next view");
            else
                MessageBox.Show("There's no next view to navigate");
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
NavigateToPreviousView Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : NavigateToPreviousView Method

Navigates to the View in previous history.

Syntax

Visual Basic (Declaration)
Public Function NavigateToPreviousView() As Boolean
C#
public bool NavigateToPreviousView()

Return Value

True if successfully moved to previous view else false.

Example

The following example will show how to Navigate to the previous view.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Navigate to previous view.
        Dim bResult As Boolean = MyPdfViewer.NavigateToPreviousView()

        If bResult Then
            MessageBox.Show("Successfully moved to previous view")
        Else
            MessageBox.Show("There's no previous view to navigate")
        End If
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Navigate to previous view.
            bool bResult = pdfViewer.NavigateToPreviousView();

            if(bResult)
                MessageBox.Show("Successfully moved to previous view");
            else
                MessageBox.Show("There's no previous view to navigate");
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Open Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Open Method

Opens a new PDF using PdfDocument.

Overload List

Overload | Description
Open(PdfDocument) | Opens a new PDF using PdfDocument.
Open(String) | Opens a PDF document.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Open(PdfDocument) Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class > Open Method : Open(PdfDocument) Method

document
Opens a new PDF using PdfDocument.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal document As PdfDocument _
)
C#
public void Open(
   PdfDocument document
)

Parameters

document

Example

This example shows, how to load a PDF document in PdfViewer using PdfDocument.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' Load and open the document in Viewer.
        Dim MyDocument As New PdfDocument("C:\MyDocument.pdf")
        MyPdfViewer.Open(MyDocument)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Load and open the document in Viewer.
            PdfDocument document = new PdfDocument(@"C:\MyDocument.pdf");
            pdfViewer.Open(document);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Open(String) Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class > Open Method : Open(String) Method

filePath
Opens a PDF document.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Open( _
   ByVal filePath As String _
)
C#
public void Open(
   string filePath
)

Parameters

filePath

Example

This example shows, how to load a PDF document in PdfViewer.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs) Handles MyBase.Load
        ' open the document using the file path.
        MyPdfViewer.Open("C:\MyDocument.pdf")
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
            this.Load += new EventHandler(Form1_Load);
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // open the document using the file path.
            pdfViewer.Open(@"C:\MyDocument.pdf");
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members
Overload List


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Print Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Print Method

Prints the document.

Syntax

Visual Basic (Declaration)
Public Sub Print()
C#
public void Print()

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchBackward Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : SearchBackward Method

searchTerm
The string to be searched.
option
The match option to use for searching.
Searches the string specified in backward direction.

Syntax

Visual Basic (Declaration)
Public Sub SearchBackward( _
   ByVal searchTerm As String, _
   ByVal option As MatchOptions _
)
C#
public void SearchBackward(
   string searchTerm,
   MatchOptions option
)

Parameters

searchTerm
The string to be searched.
option
The match option to use for searching.

Example

The following example will show how to search a string in backward direction with match option.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Searches string in backward direction.
        MyPdfViewer.SearchBackward("string", MatchOptions.WholeWordOnly)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Searches string in backward direction.
            pdfViewer.SearchBackward("string" , MatchOptions.WholeWordOnly);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchForward Method | Comments on this topic
See Also Example
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : SearchForward Method

searchTerm
The string to be searched.
option
The match option to use for searching.
Searches the string specified in forward direction.

Syntax

Visual Basic (Declaration)
Public Sub SearchForward( _
   ByVal searchTerm As String, _
   ByVal option As MatchOptions _
)
C#
public void SearchForward(
   string searchTerm,
   MatchOptions option
)

Parameters

searchTerm
The string to be searched.
option
The match option to use for searching.

Example

The following example will show how to search a sring in forward direction with match option.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Searches string in forward direction.
        MyPdfViewer.SearchForward("string", MatchOptions.WholeWordOnly)
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Searches string in forward direction.
            pdfViewer.SearchForward("string" , MatchOptions.WholeWordOnly);
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewer Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewer Class

For a list of all members of this type, see PdfViewer members.

Public Properties

 | Name | Description
Public Property | AccessibilityObject | Gets the System.Windows.Forms.AccessibleObject assigned to the control. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from System.Windows.Forms.Control)
Public Property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollOffset | Gets or sets where this control is scrolled to in System.Windows.Forms.ScrollableControl.ScrollControlIntoView(System.Windows.Forms.Control). (Inherited from System.Windows.Forms.Control)
Public Property | BackColor | Gets or sets the background color for the control. (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | Gets or sets the System.Windows.Forms.BindingContext for the control. (Inherited from System.Windows.Forms.Control)
Public Property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from System.Windows.Forms.Control)
Public Property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from System.Windows.Forms.Control)
Public Property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Controls | Gets the collection of controls contained within the control. (Inherited from System.Windows.Forms.Control)
Public Property | Created | Gets a value indicating whether the control has been created. (Inherited from System.Windows.Forms.Control)
Public Property | CursorMode | Gets or sets the cursor mode for the document.
Public Property | DataBindings | Gets the data bindings for the control. (Inherited from System.Windows.Forms.Control)
Public Property | DisplayRectangle | Gets the rectangle that represents the display area of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Disposing | Gets a value indicating whether the base System.Windows.Forms.Control class is in the process of disposing. (Inherited from System.Windows.Forms.Control)
Public Property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from System.Windows.Forms.Control)
Public Property | FilePath | Gets the file path of the document on display.
Public Property | Focused | Gets a value indicating whether the control has input focus. (Inherited from System.Windows.Forms.Control)
Public Property | Handle | Gets the window handle that the control is bound to. (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from System.Windows.Forms.Control)
Public Property | HasNextView | Gets a boolean value to show if next view history contains any view or not.
Public Property | HasPreviousView | Gets a boolean value to show if previous view history contains any view or not.
Public Property | Height | Gets or sets the height of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from System.Windows.Forms.Control)
Public Property | InitialOrientation | Gets or sets the value of page orientation when displaying a document.
Public Property | InitialPage | Gets or sets the value of initial page when displaying a document.
Public Property | InitialPageMode | Gets or sets the value of page mode when displaying a document.
Public Property | InitialVisibleNavigationPane | Gets or sets the value of navigation pane to be visible when displaying a document.
Public Property | InitialZoomMode | Gets or sets the value of page zoom mode when displaying a document.
Public Property | InitialZoomPercent | Gets or sets the value of page zoom percent when displaying a document.
Public Property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from System.Windows.Forms.Control)
Public Property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from System.Windows.Forms.Control)
Public Property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from System.Windows.Forms.Control)
Public Property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from System.Windows.Forms.Control)
Public Property | Margin | Gets or sets the space between controls. (Inherited from System.Windows.Forms.Control)
Public Property | MaximumSize | Gets or sets the size that is the upper limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | MinimumSize | Gets or sets the size that is the lower limit that System.Windows.Forms.Control.GetPreferredSize(System.Drawing.Size) can specify. (Inherited from System.Windows.Forms.Control)
Public Property | Name | Gets or sets the name of the control. (Inherited from System.Windows.Forms.Control)
Public Property | NavigationPanelWidth | Gets or sets the navigation panel width.
Public Property | Padding | Gets or sets padding within the control. (Inherited from System.Windows.Forms.Control)
Public Property | PageColor | Gets or sets the Page Color of the document.
Public Property | PageMode | Gets or sets the Page Display mode of the document.
Public Property | PageOrientation | Gets or sets the Orientation of the page.
Public Property | Parent | Gets or sets the parent container of the control. (Inherited from System.Windows.Forms.Control)
Public Property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | Gets the product name of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from System.Windows.Forms.Control)
Public Property | Region | Gets or sets the window region associated with the control. (Inherited from System.Windows.Forms.Control)
Public Property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | ShowBookmarkIcon | Gets or sets the value to show/hide the bookmarks icon in navigation panel.
Public Property | ShowThumbnailIcon | Gets or sets the value to show/hide thumbnails icon in navigation panel.
Public Property | ShowToolbar | Gets or sets the boolean to show/hide the toolbar.
Public Property | Site | Gets or sets the site of the control. (Inherited from System.Windows.Forms.Control)
Public Property | Size | Gets or sets the height and width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from System.Windows.Forms.Control)
Public Property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from System.Windows.Forms.Control)
Public Property | Tag | Gets or sets the object that contains data about the control. (Inherited from System.Windows.Forms.Control)
Public Property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from System.Windows.Forms.Control)
Public Property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost System.Windows.Forms.Form that the control is contained in. (Inherited from System.Windows.Forms.Control)
Public Property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from System.Windows.Forms.Control)
Public Property | ViewerToolbar | Gets or sets the toolbar of the viewer control.
Public Property | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from System.Windows.Forms.Control)
Public Property | VisibleNavigationPane | Gets or sets the value of navigation pane to be visible for displayed document.
Public Property | Width | Gets or sets the width of the control. (Inherited from System.Windows.Forms.Control)
Public Property | ZoomMode | Gets or sets the Zoom Mode of the document.
Public Property | ZoomPercent | Gets or sets the value of page zoom percent for displayed document.
Top

See Also

Reference

PdfViewer Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : CursorMode Property

Gets or sets the cursor mode for the document.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property CursorMode As CursorMode
C#
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public CursorMode CursorMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FilePath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : FilePath Property

Gets the file path of the document on display.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
Public ReadOnly Property FilePath As String
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public string FilePath {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HasNextView Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : HasNextView Property

Gets a boolean value to show if next view history contains any view or not.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
Public ReadOnly Property HasNextView As Boolean
C#
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public bool HasNextView {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
HasPreviousView Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : HasPreviousView Property

Gets a boolean value to show if previous view history contains any view or not.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
Public ReadOnly Property HasPreviousView As Boolean
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public bool HasPreviousView {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialOrientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialOrientation Property

Gets or sets the value of page orientation when displaying a document.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("Initial Preferences")>
<DescriptionAttribute("Gets or sets the value of page orientation when displaying a document.")>
Public Property InitialOrientation As Nullable(Of Orientation)
C#
[BrowsableAttribute(true)]
[CategoryAttribute("Initial Preferences")]
[DescriptionAttribute("Gets or sets the value of page orientation when displaying a document.")]
public Nullable<Orientation> InitialOrientation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialPage Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialPage Property

Gets or sets the value of initial page when displaying a document.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Initial Preferences")>
<DescriptionAttribute("Gets or sets the value of initial page when displaying a document.")>
<BrowsableAttribute(True)>
Public Property InitialPage As Nullable(Of Integer)
C#
[CategoryAttribute("Initial Preferences")]
[DescriptionAttribute("Gets or sets the value of initial page when displaying a document.")]
[BrowsableAttribute(true)]
public Nullable<int> InitialPage {get; set;}

Remarks

The value should be a positive number and it will be 0 by default in case if it exceeds the total number of pages or not set.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialPageMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialPageMode Property

Gets or sets the value of page mode when displaying a document.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the value of page mode when displaying a document.")>
<CategoryAttribute("Initial Preferences")>
Public Property InitialPageMode As Nullable(Of PageDisplayMode)
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the value of page mode when displaying a document.")]
[CategoryAttribute("Initial Preferences")]
public Nullable<PageDisplayMode> InitialPageMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialVisibleNavigationPane Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialVisibleNavigationPane Property

Gets or sets the value of navigation pane to be visible when displaying a document.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the value of navigation pane to be visible when displaying a document.")>
<CategoryAttribute("Initial Preferences")>
<BrowsableAttribute(True)>
Public Property InitialVisibleNavigationPane As Nullable(Of NavigationPane)
C#
[DescriptionAttribute("Gets or sets the value of navigation pane to be visible when displaying a document.")]
[CategoryAttribute("Initial Preferences")]
[BrowsableAttribute(true)]
public Nullable<NavigationPane> InitialVisibleNavigationPane {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialZoomMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialZoomMode Property

Gets or sets the value of page zoom mode when displaying a document.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the value of page zoom mode when displaying a document.")>
<CategoryAttribute("Initial Preferences")>
<BrowsableAttribute(True)>
Public Property InitialZoomMode As Nullable(Of Zoom)
C#
[DescriptionAttribute("Gets or sets the value of page zoom mode when displaying a document.")]
[CategoryAttribute("Initial Preferences")]
[BrowsableAttribute(true)]
public Nullable<Zoom> InitialZoomMode {get; set;}

Remarks

If zoom percent mode is selected then the value of InitialZoomPercent has to be specified. Otherwise it will be .01f by default.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InitialZoomPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : InitialZoomPercent Property

Gets or sets the value of page zoom percent when displaying a document.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Initial Preferences")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the value of page zoom percent when displaying a document.")>
Public Property InitialZoomPercent As Nullable(Of Single)
C#
[CategoryAttribute("Initial Preferences")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the value of page zoom percent when displaying a document.")]
public Nullable<float> InitialZoomPercent {get; set;}

Remarks

This value ranges from .01f to 64.0f.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
NavigationPanelWidth Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : NavigationPanelWidth Property

Gets or sets the navigation panel width.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Preferences")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the navigation panel width.")>
Public Property NavigationPanelWidth As Integer
C#
[CategoryAttribute("Preferences")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the navigation panel width.")]
public int NavigationPanelWidth {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageColor Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PageColor Property

Gets or sets the Page Color of the document.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<DescriptionAttribute("Gets or sets the Page Color of the document.")>
<CategoryAttribute("Preferences")>
Public Property PageColor As Color
C#
[BrowsableAttribute(true)]
[DescriptionAttribute("Gets or sets the Page Color of the document.")]
[CategoryAttribute("Preferences")]
public Color PageColor {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PageMode Property

Gets or sets the Page Display mode of the document.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property PageMode As PageDisplayMode
C#
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public PageDisplayMode PageMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PageOrientation Property

Gets or sets the Orientation of the page.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(False)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute()>
Public Property PageOrientation As Orientation
C#
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute()]
public Orientation PageOrientation {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ShowBookmarkIcon Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ShowBookmarkIcon Property

Gets or sets the value to show/hide the bookmarks icon in navigation panel.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("Preferences")>
<DescriptionAttribute("Gets or sets the value to show/hide the bookmarks icon in navigation panel.")>
<BrowsableAttribute(True)>
Public Property ShowBookmarkIcon As Boolean
C#
[CategoryAttribute("Preferences")]
[DescriptionAttribute("Gets or sets the value to show/hide the bookmarks icon in navigation panel.")]
[BrowsableAttribute(true)]
public bool ShowBookmarkIcon {get; set;}

Remarks

True value will show the bookmark icon in the navigation panel.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ShowThumbnailIcon Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ShowThumbnailIcon Property

Gets or sets the value to show/hide thumbnails icon in navigation panel.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the value to show/hide thumbnails icon in navigation panel.")>
<CategoryAttribute("Preferences")>
<BrowsableAttribute(True)>
Public Property ShowThumbnailIcon As Boolean
C#
[DescriptionAttribute("Gets or sets the value to show/hide thumbnails icon in navigation panel.")]
[CategoryAttribute("Preferences")]
[BrowsableAttribute(true)]
public bool ShowThumbnailIcon {get; set;}

Remarks

True value will show the thumbnail icon in the navigation panel.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ShowToolbar Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ShowToolbar Property

Gets or sets the boolean to show/hide the toolbar.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Gets or sets the value to show/hide the toolbar.")>
<CategoryAttribute("Preferences")>
<BrowsableAttribute(True)>
Public Property ShowToolbar As Boolean
C#
[DescriptionAttribute("Gets or sets the value to show/hide the toolbar.")]
[CategoryAttribute("Preferences")]
[BrowsableAttribute(true)]
public bool ShowToolbar {get; set;}

Remarks

True value will show the toolbar.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewerToolbar Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ViewerToolbar Property

Gets or sets the toolbar of the viewer control.

Syntax

Visual Basic (Declaration)
<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
Public Property ViewerToolbar As ToolStrip
C#
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public ToolStrip ViewerToolbar {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
VisibleNavigationPane Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : VisibleNavigationPane Property

Gets or sets the value of navigation pane to be visible for displayed document.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
Public Property VisibleNavigationPane As NavigationPane
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public NavigationPane VisibleNavigationPane {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ZoomMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ZoomMode Property

Gets or sets the Zoom Mode of the document.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(False)>
<EditorBrowsableAttribute()>
Public Property ZoomMode As Zoom
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute()]
public Zoom ZoomMode {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ZoomPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ZoomPercent Property

Gets or sets the value of page zoom percent for displayed document.

Syntax

Visual Basic (Declaration)
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute()>
<BrowsableAttribute(False)>
Public Property ZoomPercent As Single
C#
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute()]
[BrowsableAttribute(false)]
public float ZoomPercent {get; set;}

Remarks

This value ranges from .01f to 64.0f.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%% $$Events$$

Foxit Software Help Library for .NET - June 2013 Foxit Software
PdfViewer Class Events
See Also Send Feedback
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewer Class

For a list of all members of this type, see PdfViewer members.

Public Events

 | Name | Description
Public Event | ClientSizeChanged | Occurs when the value of the System.Windows.Forms.Control.ClientSize property changes. (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuShowing | Occurs when the control's context menu is being displayed.
Public Event | CursorModeChanged | Occurs when the cursor mode is changed.
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DocumentDisplayed | Occurs after the PDF document is displayed.
Public Event | DocumentDisplaying | Occurs before the PDF document is displayed.
Public Event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | Occurs when the System.Windows.Forms.Control.Enabled property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Enter | Occurs when the control is entered. (Inherited from System.Windows.Forms.Control)
Public Event | FileOpenDialogShowing | Occurs when the file open dialog is being displayed.
Public Event | FileOpened | Occurs after the PDF file is opened.
Public Event | FileOpenFailed | Occurs when the PDF file open failed.
Public Event | FileOpening | Occurs before the PDF file is opened.
Public Event | FontChanged | Occurs when the System.Windows.Forms.Control.Font property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | Occurs when the System.Windows.Forms.Control.ForeColor property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | GiveFeedback | Occurs during a drag operation. (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | Occurs when the control receives focus. (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | Occurs when a handle is created for the control. (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from System.Windows.Forms.Control)
Public Event | HelpRequested | Occurs when the user requests help for a control. (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | Occurs when the System.Windows.Forms.Control.ImeMode property has changed. (Inherited from System.Windows.Forms.Control)
Public Event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from System.Windows.Forms.Control)
Public Event | Layout | Occurs when a control should reposition its child controls. (Inherited from System.Windows.Forms.Control)
Public Event | Leave | Occurs when the input focus leaves the control. (Inherited from System.Windows.Forms.Control)
Public Event | LinkClicked | Occurs when user clicks on a link.
Public Event | LocationChanged | Occurs when the System.Windows.Forms.Control.Location property value has changed. (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | Occurs when the control loses focus. (Inherited from System.Windows.Forms.Control)
Public Event | MarginChanged | Occurs when the control's margin changes. (Inherited from System.Windows.Forms.Control)
Public Event | Move | Occurs when the control is moved. (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | Occurs when the control's padding changes. (Inherited from System.Windows.Forms.Control)
Public Event | Paint | Occurs when the control is redrawn. (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | Occurs when the System.Windows.Forms.Control.Parent property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | PasswordRequired | Occurs when the PDF file needed a password to open.
Public Event | PdfViewerMouseClick | Occurs when user clicks on a PdfViewer control.
Public Event | PdfViewerMouseMove | Occurs when user moves the mouse pointer on a PdfViewer control.
Public Event | QueryAccessibilityHelp | Occurs when System.Windows.Forms.AccessibleObject is providing help to accessibility applications. (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | Occurs when the value of the System.Windows.Forms.Control.Region property changes. (Inherited from System.Windows.Forms.Control)
Public Event | Resize | Occurs when the control is resized. (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftChanged | Occurs when the System.Windows.Forms.Control.RightToLeft property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | SearchDialogShowing | Occurs when the search dialog is being displayed.
Public Event | Searched | Occurs when the search term is found successfully.
Public Event | SearchProgressing | Occurs when the search for a string is in progress.
Public Event | SizeChanged | Occurs when the System.Windows.Forms.Control.Size property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | Occurs when the control style changes. (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | Occurs when the system colors change. (Inherited from System.Windows.Forms.Control)
Public Event | TabIndexChanged | Occurs when the System.Windows.Forms.Control.TabIndex property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TabStopChanged | Occurs when the System.Windows.Forms.Control.TabStop property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | Occurs when the System.Windows.Forms.Control.Text property value changes. (Inherited from System.Windows.Forms.Control)
Public Event | TextSelected | Occurs when the text selection is completed.
Public Event | TextSelecting | Occurs when the text is being selected.
Public Event | Validated | Occurs when the control is finished validating. (Inherited from System.Windows.Forms.Control)
Public Event | Validating | Occurs when the control is validating. (Inherited from System.Windows.Forms.Control)
Public Event | ViewChanged | Occurs each time when the view of the display is changed.
Public Event | VisibleChanged | Occurs when the System.Windows.Forms.Control.Visible property value changes. (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

PdfViewer Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
ContextMenuShowing Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ContextMenuShowing Event

Occurs when the control's context menu is being displayed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("PDF Viewer")>
<BrowsableAttribute(True)>
<DescriptionAttribute("Occurs when the control's context menu is being displayed.")>
Public Event ContextMenuShowing As ContextMenuShowingEventHandler
C#
[CategoryAttribute("PDF Viewer")]
[BrowsableAttribute(true)]
[DescriptionAttribute("Occurs when the control's context menu is being displayed.")]
public event ContextMenuShowingEventHandler ContextMenuShowing

Event Data

The event handler receives an argument of type ContextMenuShowingEventArgs containing data related to this event. The following ContextMenuShowingEventArgs properties provide information specific to this event.

Property | Description
AssignedContextMenu | Gets or sets the context menu of the control.
Cancel | Gets or sets the boolean value.
MenuContextType | Gets the context type.

Example

This example demonstrates, how to hide/show the context menu , override the context menu of the control with a new one and setting the type context using ContextMenuShowingEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.ContextMenuShowing, AddressOf MyPdfViewer_ContextMenuShowing
    End Sub

    Private Sub MyPdfViewer_ContextMenuShowing(ByVal sender As Object, ByVal e As ContextMenuShowingEventArgs)
        ' Suppress the control's existing context menu with a new context menu.
        e.AssignedContextMenu = New ContextMenuStrip()

        ' Create new ToolStripMenuItem and add it to AssignedContextMenu.
        Dim MyToolStripMenuitem1 As New ToolStripMenuItem()
        MyToolStripMenuitem1.Text = "Rotate"
        e.AssignedContextMenu.Items.Add(MyToolStripMenuitem1)

        ' Create new ToolStripMenuItem and add it to AssignedContextMenu.
        Dim MyToolStripMenuitem2 As New ToolStripMenuItem()
        MyToolStripMenuitem2.Text = "View"
        e.AssignedContextMenu.Items.Add(MyToolStripMenuitem2)

        ' Set the value to hide/show the context menu.
        e.Cancel = True
     End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
             InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.ContextMenuShowing += new Foxit.PDF.Viewer.ContextMenuShowingEventHandler(this.pdfViewer_ContextMenuShowing);
        }

        private void pdfViewer_ContextMenuShowing(object sender, Foxit.PDF.Viewer.ContextMenuShowingEventArgs e)
        {
            // Suppress the control's existing context menu with a new context menu.
            e.AssignedContextMenu = new ContextMenuStrip();

            // Create new ToolStripMenuItem and add it to AssignedContextMenu.
            ToolStripMenuItem toolStripMenuitem1 = new ToolStripMenuItem();
            toolStripMenuitem1.Text = "Rotate";
            e.AssignedContextMenu.Items.Add(toolStripMenuitem1);

            // Create new ToolStripMenuItem and add it to AssignedContextMenu.
            ToolStripMenuItem toolStripMenuitem2 = new ToolStripMenuItem();
            toolStripMenuitem2.Text = "View";
            e.AssignedContextMenu.Items.Add(toolStripMenuitem2);

            // Set the value to hide/show the context menu.
            e.Cancel = true;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
CursorModeChanged Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : CursorModeChanged Event

Occurs when the cursor mode is changed.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs when the cursor mode is changed.")>
Public Event CursorModeChanged As CursorModeChangedEventHandler
C#
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs when the cursor mode is changed.")]
public event CursorModeChangedEventHandler CursorModeChanged

Event Data

The event handler receives an argument of type CursorModeChangedEventArgs containing data related to this event. The following CursorModeChangedEventArgs properties provide information specific to this event.

Property | Description
CursorMode | Gets the cursor mode.

Example

This example demonstrates, how to get the current cursor mode using CursorModeChangedEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.CursorModeChanged, AddressOf MyPdfViewer_CursorModeChanged
    End Sub

    Private Sub MyPdfViewer_CursorModeChanged(ByVal sender As Object, ByVal e As CursorModeChangedEventArgs)
        ' Get the current cursor mode.
        Dim MyCursorMode As CursorMode = e.CursorMode
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.CursorModeChanged += new Foxit.PDF.Viewer.CursorModeChangedEventHandler(this.pdfViewer_CursorModeChanged);
        }

        private void pdfViewer_CursorModeChanged(object sender, Foxit.PDF.Viewer.CursorModeChangedEventArgs e)
        {
            // Get the current cursor mode.
            CursorMode cursorMode = e.CursorMode;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
DocumentDisplayed Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : DocumentDisplayed Event

Occurs after the PDF document is displayed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs after the PDF document is displayed.")>
<CategoryAttribute("PDF Viewer")>
<BrowsableAttribute(True)>
Public Event DocumentDisplayed As DocumentDisplayedEventHadler
C#
[DescriptionAttribute("Occurs after the PDF document is displayed.")]
[CategoryAttribute("PDF Viewer")]
[BrowsableAttribute(true)]
public event DocumentDisplayedEventHadler DocumentDisplayed

Event Data

The event handler receives an argument of type DocumentDisplayedEventArgs containing data related to this event. The following DocumentDisplayedEventArgs properties provide information specific to this event.

Property | Description
Document | Gets the PdfDocument.

Example

This example shows, how to get displayed PDF document details using DocumentDisplayed event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.DocumentDisplayed, AddressOf MyPdfViewer_DocumentDisplayed
    End Sub

    Private Sub MyPdfViewer_DocumentDisplayed(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.DocumentDisplayedEventArgs)
        ' Get the displayed PDF document details.
        Dim Author As String = e.Document.Author
        Dim MyBookmarks As BookmarkList = e.Document.Bookmarks
        Dim Creator As String = e.Document.Creator
        Dim Keywords As String = e.Document.Keywords
        Dim PageCount As Integer = e.Document.PageCount
        Dim Producer As String = e.Document.Producer
        Dim Subject As String = e.Document.Subject
        Dim Title As String = e.Document.Title
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.DocumentDisplayed += new Foxit.PDF.Viewer.DocumentDisplayedEventHadler(this.pdfViewer_DocumentDisplayed);
        }

        private void pdfViewer_DocumentDisplayed(object sender, Foxit.PDF.Viewer.DocumentDisplayedEventArgs e)
        {
            // Get the displayed PDF document details.
            string Author = e.Document.Author;
            BookmarkList Bookmarks = e.Document.Bookmarks;
            string Creator = e.Document.Creator;
            string Keywords = e.Document.Keywords;
            int PageCount = e.Document.PageCount;
            string Producer = e.Document.Producer;
            string Subject = e.Document.Subject;
            string Title = e.Document.Title;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
DocumentDisplaying Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : DocumentDisplaying Event

Occurs before the PDF document is displayed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs before the PDF document is displayed.")>
<CategoryAttribute("PDF Viewer")>
<BrowsableAttribute(True)>
Public Event DocumentDisplaying As DocumentDisplayingEventHandler
C#
[DescriptionAttribute("Occurs before the PDF document is displayed.")]
[CategoryAttribute("PDF Viewer")]
[BrowsableAttribute(true)]
public event DocumentDisplayingEventHandler DocumentDisplaying

Event Data

The event handler receives an argument of type DocumentDisplayingEventArgs containing data related to this event. The following DocumentDisplayingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.
Document | Gets the PdfDocument.
InitialOrientation | Gets or sets the value of page orientation when displaying a document.
InitialPage | Gets or sets the value of initial page when displaying a document.
InitialPageMode | Gets or sets the value of page mode when displaying a document.
InitialVisibleNavigationPane | Gets or sets the value of navigation pane to be visible when displaying a document.
InitialZoomMode | Gets or sets the value of page zoom mode when displaying a document.
InitialZoomPercent | Gets or sets the value of page zoom percent when displaying a document.

Example

This example shows, how to cancel a PDF file opening using DocumentDisplaying event

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.DocumentDisplaying, AddressOf MyPdfViewer_DocumentDisplaying
    End Sub

    Private Sub MyPdfViewer_DocumentDisplaying(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.DocumentDisplayingEventArgs)
        ' Setting the navigation panel's visible tab while displaying the document.
        e.InitialVisibleNavigationPane = Foxit.PDF.Viewer.NavigationPane.Bookmark
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.DocumentDisplaying += new Foxit.PDF.Viewer.DocumentDisplayingEventHandler(this.pdfViewer_DocumentDisplaying);
        }

        private void pdfViewer_DocumentDisplaying(object sender, Foxit.PDF.Viewer.DocumentDisplayingEventArgs e)
        {
            // Setting the navigation panel's visible tab while displaying the document.
            e.InitialVisibleNavigationPane = Foxit.PDF.Viewer.NavigationPane.Bookmark;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
FileOpenDialogShowing Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : FileOpenDialogShowing Event

Occurs when the file open dialog is being displayed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the file open dialog is being displayed.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event FileOpenDialogShowing As FileOpenDialogShowingEventHandler
C#
[DescriptionAttribute("Occurs when the file open dialog is being displayed.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event FileOpenDialogShowingEventHandler FileOpenDialogShowing

Event Data

The event handler receives an argument of type FileOpenDialogShowingEventArgs containing data related to this event. The following FileOpenDialogShowingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.
InitialDirectory | Gets or sets initial directory of the displaying file dialog.
PdfDocument | Gets or sets the PdfDocument.

Example

This example shows, how to set initial directory of displaying file dialog using FileOpenDialogShowing event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.FileOpenDialogShowing, AddressOf MyPdfViewer_FileOpenDialogShowing
    End Sub

    Private Sub MyPdfViewer_FileOpenDialogShowing(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.FileOpenDialogShowingEventArgs)
        ' Set the initial directory for the file dialog window.
        e.InitialDirectory = "MyFolderPath"
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.FileOpenDialogShowing += new Foxit.PDF.Viewer.FileOpenDialogShowingEventHandler(this.pdfViewer_FileOpenDialogShowing);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void pdfViewer_FileOpenDialogShowing(object sender, Foxit.PDF.Viewer.FileOpenDialogShowingEventArgs e)
        {
            // Set the initial directory for the file dialog window.
            e.InitialDirectory = "MyFolderPath";
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
FileOpened Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : FileOpened Event

Occurs after the PDF file is opened.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs after the PDF file is opened.")>
Public Event FileOpened As FileOpenedEventHandler
C#
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs after the PDF file is opened.")]
public event FileOpenedEventHandler FileOpened

Event Data

The event handler receives an argument of type FileOpenedEventArgs containing data related to this event. The following FileOpenedEventArgs properties provide information specific to this event.

Property | Description
PdfDocument | Gets the PDF document.

Example

This example shows, how to get displayed PDF document details using FileOpened event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.FileOpened, AddressOf MyPdfViewer_FileOpened
    End Sub

    Private Sub MyPdfViewer_FileOpened(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.FileOpenedEventArgs)
        ' Get the displayed PDF document details.
        Dim Author As String = e.PdfDocument.Author
        Dim MyBookmarks As BookmarkList = e.PdfDocument.Bookmarks
        Dim Creator As String = e.PdfDocument.Creator
        Dim Keywords As String = e.PdfDocument.Keywords
        Dim PageCount As Integer = e.PdfDocument.PageCount
        Dim Producer As String = e.PdfDocument.Producer
        Dim Subject As String = e.PdfDocument.Subject
        Dim Title As String = e.PdfDocument.Title
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.FileOpened += new Foxit.PDF.Viewer.FileOpenedEventHandler(this.pdfViewer_FileOpened);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void pdfViewer_FileOpened(object sender, Foxit.PDF.Viewer.FileOpenedEventArgs e)
        {
            // Getting displayed PDF document details.
            string Author = e.PdfDocument.Author;
            BookmarkList Bookmarks = e.PdfDocument.Bookmarks;
            string Creator = e.PdfDocument.Creator;
            string Keywords = e.PdfDocument.Keywords;
            int PageCount = e.PdfDocument.PageCount;
            string Producer = e.PdfDocument.Producer;
            string Subject = e.PdfDocument.Subject;
            string Title = e.PdfDocument.Title;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
FileOpenFailed Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : FileOpenFailed Event

Occurs when the PDF file open failed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the PDF file open failed.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event FileOpenFailed As FileOpenFailedEventHandler
C#
[DescriptionAttribute("Occurs when the PDF file open failed.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event FileOpenFailedEventHandler FileOpenFailed

Event Data

The event handler receives an argument of type FileOpenFailedEventArgs containing data related to this event. The following FileOpenFailedEventArgs properties provide information specific to this event.

Property | Description
Exception | Gets the exception related to the PDF file open failure.
ShowFileOpenFailedDialog | Gets or sets a boolean.

Example

This example shows ,how to access exception details using FileOpenFailed event, in the case of PDF document open failure.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.FileOpenFailed, AddressOf MyPdfViewer_FileOpenFailed
    End Sub

    Private Sub MyPdfViewer_FileOpenFailed(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.FileOpenFailedEventArgs)
        ' Get the exception.
        Dim failReason As String = e.Exception.Message
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.FileOpenFailed += new Foxit.PDF.Viewer.FileOpenFailedEventHandler(this.pdfViewer_FileOpenFailed);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void pdfViewer_FileOpenFailed(object sender, Foxit.PDF.Viewer.FileOpenFailedEventArgs e)
        {
            // Get the exception.
            string failReason = e.Exception.Message;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
FileOpening Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : FileOpening Event

Occurs before the PDF file is opened.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs before the PDF file is opened.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event FileOpening As FileOpeningEventHandler
C#
[DescriptionAttribute("Occurs before the PDF file is opened.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event FileOpeningEventHandler FileOpening

Event Data

The event handler receives an argument of type FileOpeningEventArgs containing data related to this event. The following FileOpeningEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.
FilePath | Gets or sets the PDF document file path.
PdfDocument | Gets or sets the PDF document.

Example

This example shows, how to cancel a PDF file open using the FileOpening event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.FileOpening, AddressOf MyPdfViewer_FileOpening
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub MyPdfViewer_FileOpening(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.FileOpeningEventArgs)
        ' Cancel the file open.
        e.Cancel = True
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.FileOpening += new Foxit.PDF.Viewer.FileOpeningEventHandler(this.pdfViewer_FileOpening);
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void pdfViewer_FileOpening(object sender, Foxit.PDF.Viewer.FileOpeningEventArgs e)
        {
            // Cancel the file open.
            e.Cancel = true;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
LinkClicked Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : LinkClicked Event

Occurs when user clicks on a link.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs when user clicks on a link.")>
<BrowsableAttribute(True)>
Public Event LinkClicked As LinkClickEventHandler
C#
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs when user clicks on a link.")]
[BrowsableAttribute(true)]
public event LinkClickEventHandler LinkClicked

Event Data

The event handler receives an argument of type LinkClickedEventArgs containing data related to this event. The following LinkClickedEventArgs properties provide information specific to this event.

Property | Description
Action | Gets the Action object which contains the information about the hyperlink.
Cancel | Gets or sets the boolean.

Example

This example demonstrates, how to get the link Action and how to cancel the action associated with the link using LinkClickedEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.LinkClicked, AddressOf MyPdfViewer_LinkClicked
    End Sub

    Private Sub MyPdfViewer_LinkClicked(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.LinkClickedEventArgs)
        ' Get the action associated with the link.
        Dim MyAction As Foxit.PDF.Viewer.Action = e.Action

        ' Get the action type.
        Dim MyActionType As Foxit.PDF.Viewer.ActionType = MyAction.ActionType

        ' Cancel the action associated with the link
        e.Cancel = True
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
             InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.LinkClicked += new Foxit.PDF.Viewer.LinkClickEventHandler(this.pdfViewer_LinkClicked);
        }

        private void pdfViewer_LinkClicked(object sender, Foxit.PDF.Viewer.LinkClickedEventArgs e)
        {
            // Get the action associated with the link.
            Foxit.PDF.Viewer.Action action = e.Action;

            // Get the action type.
            Foxit.PDF.Viewer.ActionType actionType = action.ActionType;

            // Cancel the action associated with the link
            e.Cancel = true;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
PasswordRequired Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PasswordRequired Event

Occurs when the PDF file needed a password to open.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the PDF file needed a password to open.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event PasswordRequired As PasswordRequiredEventHandler
C#
[DescriptionAttribute("Occurs when the PDF file needed a password to open.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event PasswordRequiredEventHandler PasswordRequired

Event Data

The event handler receives an argument of type PasswordRequiredEventArgs containing data related to this event. The following PasswordRequiredEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.
MaxAttempts | Gets or sets the maximum number of attempts to re-entry, when incorrect password is given.
Password | Gets or sets the PDF document password.

Example

This example shows,how to set password of a PDF file using PasswordRequired event

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.PasswordRequired, AddressOf pdfViewer_PasswordRequired
    End Sub

    Private Sub pdfViewer_PasswordRequired(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.PasswordRequiredEventArgs)
        ' Setting PDF password to open the file.
        e.Password = "mypassword"
    End Sub

    End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.PasswordRequired += new Foxit.PDF.Viewer.PasswordRequiredEventHandler(this.pdfViewer_PasswordRequired);
        }

        private void pdfViewer_PasswordRequired(object sender, Foxit.PDF.Viewer.PasswordRequiredEventArgs e)
        {
            // Setting PDF password to open the file.
            e.Password = "mypassword";
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
PdfViewerMouseClick Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PdfViewerMouseClick Event

Occurs when user clicks on a PdfViewer control.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when user clicks on a PdfViwer control.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event PdfViewerMouseClick As PdfViewerMouseEventHandler
C#
[DescriptionAttribute("Occurs when user clicks on a PdfViwer control.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event PdfViewerMouseEventHandler PdfViewerMouseClick

Event Data

The event handler receives an argument of type PdfViewerMouseEventArgs containing data related to this event. The following PdfViewerMouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the Button object which contains the information about the mouse button associated with the event.
Clicks | Gets the number of times the mouse button was pressed and released.
Location | Gets the location of the mouse during the generating mouse event.
PageNumber | Gets the page number of the PDF page during the generating mouse event.
PageX | Gets the x-coordinate of the mouse on PDF page during the generating mouse event.
PageY | Gets the y-coordinate of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Example

This example demonstrates, how to get the click event with information about the page co-ordinates using PdfViewerMouseEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.PdfViewerMouseClick, AddressOf MyPdfViewer_MouseClicked
    End Sub

    Private Sub MyPdfViewer_MouseClicked(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.PdfViewerMouseEventArgs)
        ' Get the co-ordinates on the control.
        Dim ControlCoordinate As Point = e.Location

        ' Get the page number.
        Dim PageNumber As Integer = e.PageNumber

        ' Get the co-ordinates on the page (in PDF points).
        Dim PageCoordinateX As Integer = e.PageX
        Dim PageCoordinateY As Integer = e.PageY
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
             InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.PdfViewerMouseClick += new Foxit.PDF.Viewer.PdfViewerMouseEventHandler(this.pdfViewer_MouseClicked);
        }

        private void pdfViewer_MouseClicked(object sender, Foxit.PDF.Viewer.PdfViewerMouseEventArgs e)
        {
            // Get the co-ordinates on the control.
            Point controlCoordinate = e.Location;

            // Get the page number.
             int pageNumber = e.PageNumber;

            // Get the co-ordinates on the page (in PDF points).
            int pageCoordinateX = e.PageX;
            int pageCoordinateY = e.PageY;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
PdfViewerMouseMove Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : PdfViewerMouseMove Event

Occurs when user moves the mouse pointer on a PdfViewer control.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when user moves the mouse pointer on a PdfViewer control.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event PdfViewerMouseMove As PdfViewerMouseEventHandler
C#
[DescriptionAttribute("Occurs when user moves the mouse pointer on a PdfViewer control.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event PdfViewerMouseEventHandler PdfViewerMouseMove

Event Data

The event handler receives an argument of type PdfViewerMouseEventArgs containing data related to this event. The following PdfViewerMouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets the Button object which contains the information about the mouse button associated with the event.
Clicks | Gets the number of times the mouse button was pressed and released.
Location | Gets the location of the mouse during the generating mouse event.
PageNumber | Gets the page number of the PDF page during the generating mouse event.
PageX | Gets the x-coordinate of the mouse on PDF page during the generating mouse event.
PageY | Gets the y-coordinate of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Example

This example demonstrates, how to get the mouse move event with information about the page co-ordinates using PdfViewerMouseEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.PdfViewerMouseMove, AddressOf MyPdfViewer_MouseMoved
    End Sub

    Private Sub MyPdfViewer_MouseMoved(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.PdfViewerMouseEventArgs)
        ' Get the co-ordinates on the control.
        Dim ControlCoordinate As Point = e.Location

        ' Get the page number.
        Dim PageNumber As Integer = e.PageNumber

        ' Get the co-ordinates on the page (in PDF points).
        Dim PageCoordinateX As Integer = e.PageX
        Dim PageCoordinateY As Integer = e.PageY
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
             InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.PdfViewerMouseMove += new Foxit.PDF.Viewer.PdfViewerMouseEventHandler(this.pdfViewer_MouseMoved);
        }

        private void pdfViewer_MouseMoved(object sender, Foxit.PDF.Viewer.PdfViewerMouseEventArgs e)
        {
            // Get the co-ordinates on the control.
            Point controlCoordinate = e.Location;

            // Get the page number.
             int pageNumber = e.PageNumber;

            // Get the co-ordinates on the page (in PDF points).
            int pageCoordinateX = e.PageX;
            int pageCoordinateY = e.PageY;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
SearchDialogShowing Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : SearchDialogShowing Event

Occurs when the search dialog is being displayed.

Syntax

Visual Basic (Declaration)
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs when the search dialog is being displayed.")>
Public Event SearchDialogShowing As SearchDialogShowingEventHandler
C#
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs when the search dialog is being displayed.")]
public event SearchDialogShowingEventHandler SearchDialogShowing

Event Data

The event handler receives an argument of type SearchDialogShowingEventArgs containing data related to this event. The following SearchDialogShowingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.
MatchOption | Gets or Sets the match option to use for searching.

Example

This example shows, how to hide the search dialog and set the match option for search using SearchDialogShowing event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.SearchDialogShowing, AddressOf MyPdfViewer_SearchDialogShowing
    End Sub

    Private Sub MyPdfViewer_SearchDialogShowing(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.SearchDialogShowingEventArgs)
        ' Hide the search dialog.
        e.Cancel = True

        ' Set the match option for search
        e.MatchOption = MatchOptions.WholeWordOnly
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.SearchDialogShowing += new Foxit.PDF.Viewer.SearchDialogShowingEventHandler(this.pdfViewer_SearchDialogShowing);
        }

        private void pdfViewer_SearchDialogShowing(object sender, Foxit.PDF.Viewer.SearchDialogShowingEventArgs e)
        {
            // Hide the search dialog.
            e.Cancel = true;

            // Set the match option for search
            e.MatchOption = MatchOptions.WholeWordOnly;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
Searched Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Searched Event

Occurs when the search term is found successfully.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the search term is found successfully.")>
<CategoryAttribute("PDF Viewer")>
<BrowsableAttribute(True)>
Public Event Searched As SearchedEventHandler
C#
[DescriptionAttribute("Occurs when the search term is found successfully.")]
[CategoryAttribute("PDF Viewer")]
[BrowsableAttribute(true)]
public event SearchedEventHandler Searched

Event Data

The event handler receives an argument of type SearchedEventArgs containing data related to this event. The following SearchedEventArgs properties provide information specific to this event.

Property | Description
Completed | Gets a boolean value which shows the search is completed or not.
Count | Gets the count of successful search result.
ShowSearchCompleteDialog | Gets or sets a boolean.

Example

This example demonstrates, how to get the count of successful search results and status of search completion using SearchedEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.Searched, AddressOf pdfViewer_Searched
    End Sub

    Private Sub pdfViewer_Searched(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.SearchedEventArgs)
        ' Get the status of search completion.
        Dim isCompleted As Boolean = e.Completed

        ' Get the count of search results found.
        Dim count As Integer = e.Count
    End Sub
End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.Searched += new Foxit.PDF.Viewer.SearchedEventHandler(this.pdfViewer_Searched);
        }

        private void pdfViewer_Searched(object sender, Foxit.PDF.Viewer.SearchedEventArgs e)
        {
            // Get the status of search completion.
            bool isCompleted = e.Completed;

            // Get the count of search results found.
            int count = e.Count;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
SearchProgressing Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : SearchProgressing Event

Occurs when the search for a string is in progress.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the search for a string is in progress.")>
<BrowsableAttribute(True)>
<CategoryAttribute("PDF Viewer")>
Public Event SearchProgressing As SearchProgressingEventHandler
C#
[DescriptionAttribute("Occurs when the search for a string is in progress.")]
[BrowsableAttribute(true)]
[CategoryAttribute("PDF Viewer")]
public event SearchProgressingEventHandler SearchProgressing

Event Data

The event handler receives an argument of type SearchProgressingEventArgs containing data related to this event. The following SearchProgressingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets the value whether to cancel the search or not.
CurrentPageNumber | Gets the page number where the search is happening.
MatchOption | Gets the match option used for search.
SearchTerm | Gets the search string.

Remarks

To cancel the search which is in progress set the value of Cancel to true otherwise by default it is false.

Example

This example demonstrates, how to get the search term, match option used, current page numberwhere search is going on and cancelling the search using SearchProgressingEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.SearchProgressing, AddressOf MyPdfViewer_SearchProgressing
    End Sub

    Private Sub MyPdfViewer_SearchProgressing(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.SearchProgressingEventArgs)
        ' Get the search string.
        Dim MysearchTerm As String = e.SearchTerm

        ' Get the Match option used for searching.
        Dim [option] As MatchOptions = DirectCast(e.MatchOption, MatchOptions)

        ' If user wants to cancel the search. Use the below commented code.
        'e.Cancel = true;

        ' Get the current page number where search is in progress.
        Dim pagenumber As Integer = e.CurrentPageNumber
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.SearchProgressing += new Foxit.PDF.Viewer.SearchProgressingEventHandler(this.pdfViewer_SearchProgressing);
        }

        private void pdfViewer_SearchProgressing(object sender, Foxit.PDF.Viewer.SearchProgressingEventArgs e)
        {
            // Get the search string.
            string searchTerm = e.SearchTerm;

            // Get the Match option used for searching.
            MatchOptions option = (MatchOptions)e.MatchOption;

            // If user wants to cancel the search. Use the below commented code.
            //e.Cancel = true;

            // Get the current page number where search is in progress.
            int pagenumber = e.CurrentPageNumber;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
TextSelected Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : TextSelected Event

Occurs when the text selection is completed.

Syntax

Visual Basic (Declaration)
<DescriptionAttribute("Occurs when the text selection is completed.")>
<CategoryAttribute("PDF Viewer")>
<BrowsableAttribute(True)>
Public Event TextSelected As TextSelectedEventHandler
C#
[DescriptionAttribute("Occurs when the text selection is completed.")]
[CategoryAttribute("PDF Viewer")]
[BrowsableAttribute(true)]
public event TextSelectedEventHandler TextSelected

Event Data

The event handler receives an argument of type TextSelectedEventArgs containing data related to this event. The following TextSelectedEventArgs properties provide information specific to this event.

Property | Description
SelectedText | Gets selected text.

Example

This example shows how to get selected text, when text selection done using TextSelected event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.TextSelected, AddressOf MyPdfViewer_TextSelected
    End Sub

    Private Sub MyPdfViewer_TextSelected(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.TextSelectedEventArgs)
        ' Get the selected text.
        Dim MySelectedText As String = e.SelectedText
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.TextSelected += new Foxit.PDF.Viewer.TextSelectedEventHandler(this.pdfViewer_TextSelected);
        }

        private void pdfViewer_TextSelected(object sender, Foxit.PDF.Viewer.TextSelectedEventArgs e)
        {
            // Get the selected text.
            string selectedText = e.SelectedText;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
TextSelecting Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : TextSelecting Event

Occurs when the text is being selected.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs when the text is being selected.")>
<BrowsableAttribute(True)>
Public Event TextSelecting As TextSelectingEventHandler
C#
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs when the text is being selected.")]
[BrowsableAttribute(true)]
public event TextSelectingEventHandler TextSelecting

Event Data

The event handler receives an argument of type TextSelectingEventArgs containing data related to this event. The following TextSelectingEventArgs properties provide information specific to this event.

Property | Description
Cancel | Gets or sets a boolean.

Example

This example shows how to disable or cancel text selection using TextSelecting event.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.TextSelecting, AddressOf MyPdfViewer_TextSelecting
    End Sub

    Private Sub MyPdfViewer_TextSelecting(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.TextSelectingEventArgs)
        ' Cencel the text selection.
        e.Cancel = True
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : System.Windows.Forms.Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.TextSelecting += new Foxit.PDF.Viewer.TextSelectingEventHandler(this.pdfViewer_TextSelecting);
        }

        private void pdfViewer_TextSelecting(object sender, Foxit.PDF.Viewer.TextSelectingEventArgs e)
        {
            // Cancel the text selection.
            e.Cancel = true;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

[image]
Foxit Software Help Library for .NET - June 2013
ViewChanged Event
See Also Example Send Feedback
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : ViewChanged Event

Occurs each time when the view of the display is changed.

Syntax

Visual Basic (Declaration)
<CategoryAttribute("PDF Viewer")>
<DescriptionAttribute("Occurs each time when the view of the display is changed.")>
<BrowsableAttribute(True)>
Public Event ViewChanged As ViewChangedEventHandler
C#
[CategoryAttribute("PDF Viewer")]
[DescriptionAttribute("Occurs each time when the view of the display is changed.")]
[BrowsableAttribute(true)]
public event ViewChangedEventHandler ViewChanged

Event Data

The event handler receives an argument of type ViewChangedEventArgs containing data related to this event. The following ViewChangedEventArgs properties provide information specific to this event.

Property | Description
AddViewToHistory | Gets or set the boolean to store view to history or not.
CurrentView | Gets the current view.
PreviousView | Gets the previous view.

Example

This example demonstrates, how to get the changed view and add it to history using ViewChangedEventArgs class.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler MyPdfViewer.ViewChanged, AddressOf MyPdfViewer_ViewChanged
    End Sub

    Private Sub MyPdfViewer_ViewChanged(ByVal sender As Object, ByVal e As Foxit.PDF.Viewer.ViewChangedEventArgs)
        ' Get the changed view.
        Dim changedView As Foxit.PDF.Viewer.View = e.PreviousView

        ' Setting to false, will exclude this view from storing into the view history.
        e.AddViewToHistory = False
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            pdfViewer.ViewChanged += new Foxit.PDF.Viewer.ViewChangedEventHandler(this.pdfViewer_ViewChanged);
        }

        private void pdfViewer_ViewChanged(object sender, Foxit.PDF.Viewer.ViewChangedEventArgs e)
        {
            // Get the changed view.
            Foxit.PDF.Viewer.View changedView = e.PreviousView;

            // Setting to false, will exclude this view from storing into the view history.
            e.AddViewToHistory = false;
        }
    }
}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerException Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerException Class

Represents a PdfViewerException

Object Model

PdfViewerException Class

Syntax

Visual Basic (Declaration)
<SerializableAttribute()>
Public Class PdfViewerException
   Inherits System.Exception
   Implements System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable
C#
[SerializableAttribute()]
public class PdfViewerException : System.Exception, System.Runtime.InteropServices._Exception, System.Runtime.Serialization.ISerializable

Inheritance Hierarchy

System.Object
System.Exception
Foxit.PDF.Viewer.PdfViewerException
Foxit.PDF.Viewer.DocumentLoadException
Foxit.PDF.Viewer.InvalidPasswordException

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerException Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerException Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerException Class

The following tables list the members exposed by PdfViewerException.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfViewerException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerMouseEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerMouseEventArgs Class

Provides data for the PdfViewerMouseClick and PdfViewerMouseMove event.

Object Model

PdfViewerMouseEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class PdfViewerMouseEventArgs
   Inherits System.EventArgs
C#
public class PdfViewerMouseEventArgs : System.EventArgs

Example

For example refer to PdfViewerMouseClick event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.PdfViewerMouseEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerMouseEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerMouseEventArgs Class

The following tables list the members exposed by PdfViewerMouseEventArgs.

Public Properties

 | Name | Description
Public Property | Button | Gets the Button object which contains the information about the mouse button associated with the event.
Public Property | Clicks | Gets the number of times the mouse button was pressed and released.
Public Property | Location | Gets the location of the mouse during the generating mouse event.
Public Property | PageNumber | Gets the page number of the PDF page during the generating mouse event.
Public Property | PageX | Gets the x-coordinate of the mouse on PDF page during the generating mouse event.
Public Property | PageY | Gets the y-coordinate of the mouse during the generating mouse event.
Public Property | X | Gets the x-coordinate of the mouse during the generating mouse event.
Public Property | Y | Gets the y-coordinate of the mouse during the generating mouse event.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfViewerMouseEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerMouseEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerMouseEventArgs Class

For a list of all members of this type, see PdfViewerMouseEventArgs members.

Public Properties

 | Name | Description
Public Property | Button | Gets the Button object which contains the information about the mouse button associated with the event.
Public Property | Clicks | Gets the number of times the mouse button was pressed and released.
Public Property | Location | Gets the location of the mouse during the generating mouse event.
Public Property | PageNumber | Gets the page number of the PDF page during the generating mouse event.
Public Property | PageX | Gets the x-coordinate of the mouse on PDF page during the generating mouse event.
Public Property | PageY | Gets the y-coordinate of the mouse during the generating mouse event.
Public Property | X | Gets the x-coordinate of the mouse during the generating mouse event.
Public Property | Y | Gets the y-coordinate of the mouse during the generating mouse event.
Top

See Also

Reference

PdfViewerMouseEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Button Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : Button Property

Gets the Button object which contains the information about the mouse button associated with the event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Button As MouseButtons
C#
public MouseButtons Button {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Clicks Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : Clicks Property

Gets the number of times the mouse button was pressed and released.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Clicks As Integer
C#
public int Clicks {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Location Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : Location Property

Gets the location of the mouse during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Location As Point
C#
public Point Location {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : PageNumber Property

Gets the page number of the PDF page during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageNumber As Integer
C#
public int PageNumber {get;}

Remarks

Page number starts from 1. If the event is generated out side of the PDF page then its value will be set to -1.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageX Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : PageX Property

Gets the x-coordinate of the mouse on PDF page during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageX As Integer
C#
public int PageX {get;}

Remarks

If the event is generated out side of the PDF page then its value will be set to -1.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageY Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : PageY Property

Gets the y-coordinate of the mouse during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageY As Integer
C#
public int PageY {get;}

Remarks

If the event is generated out side of the PDF page then its value will be set to -1.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
X Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : X Property

Gets the x-coordinate of the mouse during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property X As Integer
C#
public int X {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Y Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewerMouseEventArgs Class : Y Property

Gets the y-coordinate of the mouse during the generating mouse event.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Y As Integer
C#
public int Y {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventArgs Class
PdfViewerMouseEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Permission Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Permission Class

Provides information about the permissions of the PdfDocument.

Object Model

Permission Class

Syntax

Visual Basic (Declaration)
Public Class Permission
C#
public class Permission

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Permission

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Permission Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Permission Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Permission Class

The following tables list the members exposed by Permission.

Public Properties

 | Name | Description
Public Property | AllowContentCopying | Gets the copy permission of the document.
Public Property | AllowPrinting | Gets the print permission of the document.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Permission Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Permission Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Permission Class

For a list of all members of this type, see Permission members.

Public Properties

 | Name | Description
Public Property | AllowContentCopying | Gets the copy permission of the document.
Public Property | AllowPrinting | Gets the print permission of the document.
Top

See Also

Reference

Permission Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AllowContentCopying Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > Permission Class : AllowContentCopying Property

Gets the copy permission of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowContentCopying As Boolean
C#
public bool AllowContentCopying {get;}

Remarks

True value indicates that the document is copy protected.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Permission Class
Permission Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AllowPrinting Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > Permission Class : AllowPrinting Property

Gets the print permission of the document.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property AllowPrinting As Boolean
C#
public bool AllowPrinting {get;}

Remarks

True value indicates that the document is print protected.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Permission Class
Permission Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RemoteGoToAction Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : RemoteGoToAction Class

Specifies the RemoteGoTo action type for the link.

Object Model

RemoteGoToAction Class

Syntax

Visual Basic (Declaration)
Public Class RemoteGoToAction
   Inherits Action
C#
public class RemoteGoToAction : Action

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.RemoteGoToAction

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

RemoteGoToAction Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RemoteGoToAction Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : RemoteGoToAction Class

The following tables list the members exposed by RemoteGoToAction.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | FilePath | Gets the file path of the document associated with the link action.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

RemoteGoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RemoteGoToAction Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : RemoteGoToAction Class

For a list of all members of this type, see RemoteGoToAction members.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | FilePath | Gets the file path of the document associated with the link action.
Top

See Also

Reference

RemoteGoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FilePath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > RemoteGoToAction Class : FilePath Property

Gets the file path of the document associated with the link action.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FilePath As String
C#
public string FilePath {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

RemoteGoToAction Class
RemoteGoToAction Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchDialogShowingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchDialogShowingEventArgs Class

Provides data for the SearchDialogShowing event.

Object Model

SearchDialogShowingEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SearchDialogShowingEventArgs
   Inherits System.EventArgs
C#
public class SearchDialogShowingEventArgs : System.EventArgs

Example

For example refer to SearchDialogShowing event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.SearchDialogShowingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchDialogShowingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchDialogShowingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchDialogShowingEventArgs Class

The following tables list the members exposed by SearchDialogShowingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | MatchOption | Gets or Sets the match option to use for searching.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchDialogShowingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchDialogShowingEventArgs Class

For a list of all members of this type, see SearchDialogShowingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Public Property | MatchOption | Gets or Sets the match option to use for searching.
Top

See Also

Reference

SearchDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchDialogShowingEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchDialogShowingEventArgs Class
SearchDialogShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MatchOption Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchDialogShowingEventArgs Class : MatchOption Property

Gets or Sets the match option to use for searching.

Syntax

Visual Basic (Declaration)
Public Property MatchOption As MatchOptions
C#
public MatchOptions MatchOption {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchDialogShowingEventArgs Class
SearchDialogShowingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchedEventArgs Class

Provides data for the Searched event.

Object Model

SearchedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SearchedEventArgs
   Inherits System.EventArgs
C#
public class SearchedEventArgs : System.EventArgs

Remarks

This event is fired after every successful search.

Example

For example refer to Searched event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.SearchedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchedEventArgs Class

The following tables list the members exposed by SearchedEventArgs.

Public Properties

 | Name | Description
Public Property | Completed | Gets a boolean value which shows the search is completed or not.
Public Property | Count | Gets the count of successful search result.
Public Property | ShowSearchCompleteDialog | Gets or sets a boolean.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchedEventArgs Class

For a list of all members of this type, see SearchedEventArgs members.

Public Properties

 | Name | Description
Public Property | Completed | Gets a boolean value which shows the search is completed or not.
Public Property | Count | Gets the count of successful search result.
Public Property | ShowSearchCompleteDialog | Gets or sets a boolean.
Top

See Also

Reference

SearchedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Completed Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchedEventArgs Class : Completed Property

Gets a boolean value which shows the search is completed or not.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Completed As Boolean
C#
public bool Completed {get;}

Remarks

True value indicates search is completed.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchedEventArgs Class
SearchedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Count Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchedEventArgs Class : Count Property

Gets the count of successful search result.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
C#
public int Count {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchedEventArgs Class
SearchedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ShowSearchCompleteDialog Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchedEventArgs Class : ShowSearchCompleteDialog Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property ShowSearchCompleteDialog As Boolean
C#
public bool ShowSearchCompleteDialog {get; set;}

Remarks

false value will hide the search complete message dialog.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchedEventArgs Class
SearchedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchProgressingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchProgressingEventArgs Class

Provides data for the SearchProgressing event.

Object Model

SearchProgressingEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class SearchProgressingEventArgs
   Inherits System.EventArgs
C#
public class SearchProgressingEventArgs : System.EventArgs

Example

For example refer to SearchProgressing event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.SearchProgressingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchProgressingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchProgressingEventArgs Class

The following tables list the members exposed by SearchProgressingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets the value whether to cancel the search or not.
Public Property | CurrentPageNumber | Gets the page number where the search is happening.
Public Property | MatchOption | Gets the match option used for search.
Public Property | SearchTerm | Gets the search string.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchProgressingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchProgressingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchProgressingEventArgs Class

For a list of all members of this type, see SearchProgressingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets the value whether to cancel the search or not.
Public Property | CurrentPageNumber | Gets the page number where the search is happening.
Public Property | MatchOption | Gets the match option used for search.
Public Property | SearchTerm | Gets the search string.
Top

See Also

Reference

SearchProgressingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchProgressingEventArgs Class : Cancel Property

Gets or sets the value whether to cancel the search or not.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Remarks

True value will abort the search process.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventArgs Class
SearchProgressingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CurrentPageNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchProgressingEventArgs Class : CurrentPageNumber Property

Gets the page number where the search is happening.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentPageNumber As Integer
C#
public int CurrentPageNumber {get;}

Remarks

It is a non zero based index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventArgs Class
SearchProgressingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MatchOption Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchProgressingEventArgs Class : MatchOption Property

Gets the match option used for search.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property MatchOption As Enum
C#
public Enum MatchOption {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventArgs Class
SearchProgressingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchTerm Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > SearchProgressingEventArgs Class : SearchTerm Property

Gets the search string.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SearchTerm As String
C#
public string SearchTerm {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventArgs Class
SearchProgressingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectedEventArgs Class

Provides data for the TextSelected event.

Object Model

TextSelectedEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TextSelectedEventArgs
   Inherits System.EventArgs
C#
public class TextSelectedEventArgs : System.EventArgs

Example

For example refer to TextSelected event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.TextSelectedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectedEventArgs Class

The following tables list the members exposed by TextSelectedEventArgs.

Public Properties

 | Name | Description
Public Property | SelectedText | Gets selected text.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TextSelectedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectedEventArgs Class

For a list of all members of this type, see TextSelectedEventArgs members.

Public Properties

 | Name | Description
Public Property | SelectedText | Gets selected text.
Top

See Also

Reference

TextSelectedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SelectedText Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > TextSelectedEventArgs Class : SelectedText Property

Gets selected text.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectedText As String
C#
public string SelectedText {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectedEventArgs Class
TextSelectedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectingEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectingEventArgs Class

Provides data for the TextSelecting event.

Object Model

TextSelectingEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class TextSelectingEventArgs
   Inherits System.EventArgs
C#
public class TextSelectingEventArgs : System.EventArgs

Example

For example refer to TextSelecting event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.TextSelectingEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectingEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectingEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectingEventArgs Class

The following tables list the members exposed by TextSelectingEventArgs.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TextSelectingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectingEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectingEventArgs Class

For a list of all members of this type, see TextSelectingEventArgs members.

Public Properties

 | Name | Description
Public Property | Cancel | Gets or sets a boolean.
Top

See Also

Reference

TextSelectingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Cancel Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > TextSelectingEventArgs Class : Cancel Property

Gets or sets a boolean.

Syntax

Visual Basic (Declaration)
Public Property Cancel As Boolean
C#
public bool Cancel {get; set;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectingEventArgs Class
TextSelectingEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
URIAction Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : URIAction Class

Specifies the URI action type for the link.

Object Model

URIAction Class

Syntax

Visual Basic (Declaration)
Public Class URIAction
   Inherits Action
C#
public class URIAction : Action

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.URIAction

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

URIAction Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
URIAction Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : URIAction Class

The following tables list the members exposed by URIAction.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | URIpath | Gets the Universal Resource Identifier, including web pages and other Internet based resources.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

URIAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
URIAction Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : URIAction Class

For a list of all members of this type, see URIAction members.

Public Properties

 | Name | Description
Public Property | ActionType | Gets the action type of the link. (Inherited from Foxit.PDF.Viewer.Action)
Public Property | URIpath | Gets the Universal Resource Identifier, including web pages and other Internet based resources.
Top

See Also

Reference

URIAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
URIpath Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > URIAction Class : URIpath Property

Gets the Universal Resource Identifier, including web pages and other Internet based resources.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property URIpath As String
C#
public string URIpath {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

URIAction Class
URIAction Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
View Class | Comments on this topic
Members Example See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : View Class

Represents the view containing the attributes which defines the display.

Object Model

View Class

Syntax

Visual Basic (Declaration)
Public Class View
C#
public class View

Example

The following example will show how to get a view and its associated data.

Visual Basic Copy Code
Imports System
Imports System.Windows.Forms
Imports Foxit.PDF.Viewer

Public Class Form1
    Inherits System.Windows.Forms.Form

    Private MyPdfViewer As PdfViewer

    Sub New()
        InitializeComponent()
    End Sub

    Shared Sub Main()
        Application.Run(New Form1())
    End Sub

    Private Sub InitializeComponent()
        Me.MyPdfViewer = New PdfViewer()
        Me.Controls.Add(MyPdfViewer)
        AddHandler Me.Load, New EventHandler(AddressOf Form1_Load)
    End Sub

    Private Sub Form1_Load(ByVal sender As Object, ByVal e As EventArgs)
        ' Open document in viewwe.
        MyPdfViewer.Open("C:\MyDocument.pdf")

        ' Get current view on display
        Dim MyCurrentView As Foxit.PDF.Viewer.View = MyPdfViewer.GetCurrentView()

        ' Get Initial view of the document
        Dim MyInitialView As Foxit.PDF.Viewer.View = MyPdfViewer.GetInitialView()

        ' Get the details from a view
        Dim pageNumber As Integer = MyCurrentView.StartPageNumber
        Dim zoomValue As Single = MyCurrentView.ZoomPercent
        Dim MyDisplayMode As PageDisplayMode = MyCurrentView.PageDisplayMode
        Dim MyZoomMode As Zoom = MyCurrentView.ZoomMode
        Dim pageOrientation As Foxit.PDF.Viewer.Orientation = MyCurrentView.PageOrientation
    End Sub

End Class
C# Copy Code
using System;
using System.Windows.Forms;
using Foxit.PDF.Viewer;

namespace PDFViewerDemo
{
    public class Form1 : Form
    {
        private Foxit.PDF.Viewer.PdfViewer pdfViewer;

        public Form1()
        {
            InitializeComponent();
        }

        [STAThread]
        static void Main()
        {
            Application.Run(new Form1());
        }

        private void InitializeComponent()
        {
            this.pdfViewer = new PdfViewer();
            this.Controls.Add(pdfViewer);
            this.Load+=new EventHandler(Form1_Load);
        }

        private void Form1_Load(object sender, EventArgs e)
        {
            // Open document in viewwe.
            pdfViewer.Open(@"C:\MyDocument.pdf");

            // Get current view on display
            Foxit.PDF.Viewer.View currentView = pdfViewer.GetCurrentView();

            // Get Initial view of the document
            Foxit.PDF.Viewer.View initialView = pdfViewer.GetInitialView();

            // Get the details from a view
            int pageNumber = currentView.StartPageNumber;
            float zoomValue = currentView.ZoomPercent;
            PageDisplayMode displayMode = currentView.PageDisplayMode;
            Zoom zoomMode = currentView.ZoomMode;
            Foxit.PDF.Viewer.Orientation pageOrientation = currentView.PageOrientation;
        }
    }
}

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.View

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
View Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : View Class

The following tables list the members exposed by View.

Public Properties

 | Name | Description
Public Property | PageDisplayMode | Gets the page display mode of the view.
Public Property | PageOrientation | Gets the page orientation of the view.
Public Property | StartPageNumber | Gets the start page number of the view.
Public Property | ZoomMode | Gets the zoom mode of the view.
Public Property | ZoomPercent | Gets the zoom percent of the view.
Top

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified View object is equal to the current View object.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

View Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
View Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : View Class

For a list of all members of this type, see View members.

Public Methods

 | Name | Description
Public Method | Equals | Determines whether the specified View object is equal to the current View object.
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

View Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Equals Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : Equals Method

obj
View object to compare with current View object.
Determines whether the specified View object is equal to the current View object.

Syntax

Visual Basic (Declaration)
Public Overrides Function Equals( _
   ByVal obj As Object _
) As Boolean
C#
public override bool Equals(
   object obj
)

Parameters

obj
View object to compare with current View object.

Remarks

true if the specified View> object is equal to the current View object otherwise, false.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
View Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : View Class

For a list of all members of this type, see View members.

Public Properties

 | Name | Description
Public Property | PageDisplayMode | Gets the page display mode of the view.
Public Property | PageOrientation | Gets the page orientation of the view.
Public Property | StartPageNumber | Gets the start page number of the view.
Public Property | ZoomMode | Gets the zoom mode of the view.
Public Property | ZoomPercent | Gets the zoom percent of the view.
Top

See Also

Reference

View Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageDisplayMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : PageDisplayMode Property

Gets the page display mode of the view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageDisplayMode As PageDisplayMode
C#
public PageDisplayMode PageDisplayMode {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageOrientation Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : PageOrientation Property

Gets the page orientation of the view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PageOrientation As Orientation
C#
public Orientation PageOrientation {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
StartPageNumber Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : StartPageNumber Property

Gets the start page number of the view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property StartPageNumber As Integer
C#
public int StartPageNumber {get;}

Remarks

It is a non zero based index.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ZoomMode Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : ZoomMode Property

Gets the zoom mode of the view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ZoomMode As Zoom
C#
public Zoom ZoomMode {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ZoomPercent Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > View Class : ZoomPercent Property

Gets the zoom percent of the view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ZoomPercent As Single
C#
public float ZoomPercent {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

View Class
View Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewChangedEventArgs Class | Comments on this topic
Members See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ViewChangedEventArgs Class

Provides data for the ViewChanged event.

Object Model

ViewChangedEventArgs ClassView ClassView Class

Syntax

Visual Basic (Declaration)
Public Class ViewChangedEventArgs
   Inherits System.EventArgs
C#
public class ViewChangedEventArgs : System.EventArgs

Example

For example refer to ViewChanged event.

Inheritance Hierarchy

System.Object
System.EventArgs
Foxit.PDF.Viewer.ViewChangedEventArgs

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ViewChangedEventArgs Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Members$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewChangedEventArgs Class Members | Comments on this topic
See Also Properties Methods
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ViewChangedEventArgs Class

The following tables list the members exposed by ViewChangedEventArgs.

Public Properties

 | Name | Description
Public Property | AddViewToHistory | Gets or set the boolean to store view to history or not.
Public Property | CurrentView | Gets the current view.
Public Property | PreviousView | Gets the previous view.
Top

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ViewChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewChangedEventArgs Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ViewChangedEventArgs Class

For a list of all members of this type, see ViewChangedEventArgs members.

Public Properties

 | Name | Description
Public Property | AddViewToHistory | Gets or set the boolean to store view to history or not.
Public Property | CurrentView | Gets the current view.
Public Property | PreviousView | Gets the previous view.
Top

See Also

Reference

ViewChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
AddViewToHistory Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ViewChangedEventArgs Class : AddViewToHistory Property

Gets or set the boolean to store view to history or not.

Syntax

Visual Basic (Declaration)
Public Property AddViewToHistory As Boolean
C#
public bool AddViewToHistory {get; set;}

Remarks

Setting this value to true may result in inaappropriate behaviour while moving to previous view or next view, viewer is using this internally on some conditions.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ViewChangedEventArgs Class
ViewChangedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CurrentView Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ViewChangedEventArgs Class : CurrentView Property

Gets the current view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentView As View
C#
public View CurrentView {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ViewChangedEventArgs Class
ViewChangedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PreviousView Property | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > ViewChangedEventArgs Class : PreviousView Property

Gets the previous view.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviousView As View
C#
public View PreviousView {get;}

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ViewChangedEventArgs Class
ViewChangedEventArgs Members


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ActionType Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ActionType Enumeration

Specifies the action types of the links.

Syntax

Visual Basic (Declaration)
Public Enum ActionType
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum ActionType : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
GoTo | Go to a destination within current document.
Launch | Launch an application or open a file.
RemoteGoTo | Go to a destination within another document.
UnSupported | Unsupported action type.
URI | Universal Resource Identifier, including web pages and other Internet based resources.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.ActionType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextType Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextType Enumeration

Specifies the type of context.

Syntax

Visual Basic (Declaration)
Public Enum ContextType
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum ContextType : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
General | Indicates the general context when there are no applicable conditions.
TextSelected | Indicates the context when the text is selected.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.ContextType

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorMode Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorMode Enumeration

Specifies the cursor modes.

Syntax

Visual Basic (Declaration)
Public Enum CursorMode
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum CursorMode : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
PanningMode | Cursor mode for panning.
TextSelectionMode | Cursor mode for text selection.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.CursorMode

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
MatchOptions Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : MatchOptions Enumeration

Specifies the match options for the search.

Syntax

Visual Basic (Declaration)
Public Enum MatchOptions
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum MatchOptions : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
All | Searches the term both by matching the case and whole word.
CaseSensitive | Search the term by matching the character case.
None | Searches the term with no option.
WholeWordOnly | Searches the term by matching only the whole word.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.MatchOptions

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
NavigationPane Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : NavigationPane Enumeration

Specifies the Navigation window type shown when the PDF file is being viewed.

Syntax

Visual Basic (Declaration)
Public Enum NavigationPane
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum NavigationPane : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Bookmark | Shows that Bookmark window is visible.
None | Shows that no navigation window is visible.
PageThumbnail | Shows that Thumbnail window is visible.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.NavigationPane

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Orientation Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Orientation Enumeration

Specifies the orientation types for a page.

Syntax

Visual Basic (Declaration)
Public Enum Orientation
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum Orientation : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
Normal | Shows that page is not rotated.
Rotated180d | Shows that page is rotated to 180 degree.
RotatedClockwise90d | Shows that page is rotated clockwise to 90 degree.
RotatedCounterClockwise90d | Shows that page is rotated counter clockwise to 90 degree.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.Orientation

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageDisplayMode Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PageDisplayMode Enumeration

Represents the collection of page display mode types.

Syntax

Visual Basic (Declaration)
Public Enum PageDisplayMode
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum PageDisplayMode : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
SinglePage | Shows the single page view.
SinglePageContinuous | Shows the single page view with scrolling enabled.
TwoUp | Shows the twp up page view.
TwoUpContinous | Shows two up page view with scrolling enabled.
TwoUpContinousWithCoverPage | Shows the two up page view with cover page and scrolling enabled.
TwoUpWithCoverPage | Shows the two up page view with cover page.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.PageDisplayMode

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Zoom Enumeration | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Zoom Enumeration

Specifies the zoom mode types.

Syntax

Visual Basic (Declaration)
Public Enum Zoom
   Inherits System.Enum
   Implements System.IComparable, System.IConvertible, System.IFormattable
C#
public enum Zoom : System.Enum, System.IComparable, System.IConvertible, System.IFormattable

Members

Member | Description
ActualSize | Shows the page in its actual size.
FitHeight | Make the page to fit on the display only vertical.
FitPage | Make the page to fit on the display both vertical and horizontal.
FitWidth | Make the page to fit on the display only horizontal.
ZoomPercent | Shows the page at a zoom factor specified by the user.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Foxit.PDF.Viewer.Zoom

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextMenuShowingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextMenuShowingEventHandler Delegate

sender
The source of the event.
e
A ContextMenuShowingEventArgs that contains the event data.
Represents the method that will handle the ContextMenuShowing event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ContextMenuShowingEventHandler( _
   ByVal sender As Object, _
   ByVal e As ContextMenuShowingEventArgs _
)
C#
public delegate void ContextMenuShowingEventHandler(
   object sender,
   ContextMenuShowingEventArgs e
)

Parameters

sender
The source of the event.
e
A ContextMenuShowingEventArgs that contains the event data.

Remarks

When you create a ContextMenuShowingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to ContextMenuShowing event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ContextMenuShowingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorModeChangedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorModeChangedEventHandler Delegate

sender
The source of the event.
e
A CursorModeChangedEventArgs that contains the event data.
Represents the method that will handle the CursorModeChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub CursorModeChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As CursorModeChangedEventArgs _
)
C#
public delegate void CursorModeChangedEventHandler(
   object sender,
   CursorModeChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A CursorModeChangedEventArgs that contains the event data.

Remarks

When you create a CursorModeChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to CursorModeChanged event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

CursorModeChangedEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayedEventHadler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayedEventHadler Delegate

sender
The source of the event.
e
A DocumentDisplayedEventArgs that contains the event data.
Represents the method that will handle the DocumentDisplayed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DocumentDisplayedEventHadler( _
   ByVal sender As Object, _
   ByVal e As DocumentDisplayedEventArgs _
)
C#
public delegate void DocumentDisplayedEventHadler(
   object sender,
   DocumentDisplayedEventArgs e
)

Parameters

sender
The source of the event.
e
A DocumentDisplayedEventArgs that contains the event data.

Remarks

When you create a DocumentDisplayedEventHadler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to DocumentDisplayed event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayedEventHadler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayingEventHandler Delegate

sender
The source of the event.
e
A DocumentDisplayingEventArgs that contains the event data.
Represents the method that will handle the DocumentDisplaying event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub DocumentDisplayingEventHandler( _
   ByVal sender As Object, _
   ByVal e As DocumentDisplayingEventArgs _
)
C#
public delegate void DocumentDisplayingEventHandler(
   object sender,
   DocumentDisplayingEventArgs e
)

Parameters

sender
The source of the event.
e
A DocumentDisplayingEventArgs that contains the event data.

Remarks

When you create a DocumentDisplayingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to DocumentDisplaying event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

DocumentDisplayingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenDialogShowingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenDialogShowingEventHandler Delegate

sender
The source of the event.
e
A FileOpenDialogShowingEventArgs that contains the event data.
Represents the method that will handle the FileOpenDialogShowing event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub FileOpenDialogShowingEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileOpenDialogShowingEventArgs _
)
C#
public delegate void FileOpenDialogShowingEventHandler(
   object sender,
   FileOpenDialogShowingEventArgs e
)

Parameters

sender
The source of the event.
e
A FileOpenDialogShowingEventArgs that contains the event data.

Remarks

When you create a FileOpenDialogShowingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to FileOpenDialogShowing event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenDialogShowingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenedEventHandler Delegate

sender
The source of the event.
e
A FileOpenedEventArgs that contains the event data.
Represents the method that will handle the FileOpened event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub FileOpenedEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileOpenedEventArgs _
)
C#
public delegate void FileOpenedEventHandler(
   object sender,
   FileOpenedEventArgs e
)

Parameters

sender
The source of the event.
e
A FileOpenedEventArgs that contains the event data.

Remarks

When you create a FileOpenedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to FileOpened event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenedEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenFailedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenFailedEventHandler Delegate

sender
The source of the event.
e
A FileOpenFailedEventArgs that contains the event data.
Represents the method that will handle the FileOpenFailed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub FileOpenFailedEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileOpenFailedEventArgs _
)
C#
public delegate void FileOpenFailedEventHandler(
   object sender,
   FileOpenFailedEventArgs e
)

Parameters

sender
The source of the event.
e
A FileOpenFailedEventArgs that contains the event data.

Remarks

When you create a FileOpenFailedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to FileOpenFailed event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpenFailedEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpeningEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpeningEventHandler Delegate

sender
The source of the event.
e
A FileOpeningEventArgs that contains the event data.
Represents the method that will handle the FileOpening event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub FileOpeningEventHandler( _
   ByVal sender As Object, _
   ByVal e As FileOpeningEventArgs _
)
C#
public delegate void FileOpeningEventHandler(
   object sender,
   FileOpeningEventArgs e
)

Parameters

sender
The source of the event.
e
A FileOpeningEventArgs that contains the event data.

Remarks

When you create a FileOpeningEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to FileOpening event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

FileOpeningEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LinkClickEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LinkClickEventHandler Delegate

sender
The source of the event.
e
A LinkClickedEventArgs that contains the event data.
Represents the method that will handle the LinkClicked event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub LinkClickEventHandler( _
   ByVal sender As Object, _
   ByVal e As LinkClickedEventArgs _
)
C#
public delegate void LinkClickEventHandler(
   object sender,
   LinkClickedEventArgs e
)

Parameters

sender
The source of the event.
e
A LinkClickedEventArgs that contains the event data.

Remarks

When you create a LinkClickEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to LinkClicked event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

LinkClickEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PasswordRequiredEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PasswordRequiredEventHandler Delegate

sender
The source of the event.
e
A PasswordRequiredEventArgs that contains the event data.
Represents the method that will handle the PasswordRequired event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PasswordRequiredEventHandler( _
   ByVal sender As Object, _
   ByVal e As PasswordRequiredEventArgs _
)
C#
public delegate void PasswordRequiredEventHandler(
   object sender,
   PasswordRequiredEventArgs e
)

Parameters

sender
The source of the event.
e
A PasswordRequiredEventArgs that contains the event data.

Remarks

When you create a PasswordRequiredEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to PasswordRequired event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PasswordRequiredEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerMouseEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerMouseEventHandler Delegate

sender
The source of the event.
e
A PdfViewerMouseEventArgs that contains the event data.
Represents the method that will handle the PdfViewerMouseClick or PdfViewerMouseMove event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub PdfViewerMouseEventHandler( _
   ByVal sender As Object, _
   ByVal e As PdfViewerMouseEventArgs _
)
C#
public delegate void PdfViewerMouseEventHandler(
   object sender,
   PdfViewerMouseEventArgs e
)

Parameters

sender
The source of the event.
e
A PdfViewerMouseEventArgs that contains the event data.

Remarks

When you create a PdfViewerMouseEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to PdfViewerMouseClick event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewerMouseEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchDialogShowingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchDialogShowingEventHandler Delegate

sender
The source of the event.
e
A SearchDialogShowingEventArgs that contains the event data.
Represents the method that will handle the SearchDialogShowing event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SearchDialogShowingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SearchDialogShowingEventArgs _
)
C#
public delegate void SearchDialogShowingEventHandler(
   object sender,
   SearchDialogShowingEventArgs e
)

Parameters

sender
The source of the event.
e
A SearchDialogShowingEventArgs that contains the event data.

Remarks

When you create a SearchDialogShowingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to SearchDialogShowing event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchDialogShowingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchedEventHandler Delegate

sender
The source of the event.
e
A SearchedEventArgs that contains the event data.
Represents the method that will handle the Searched event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SearchedEventHandler( _
   ByVal sender As Object, _
   ByVal e As SearchedEventArgs _
)
C#
public delegate void SearchedEventHandler(
   object sender,
   SearchedEventArgs e
)

Parameters

sender
The source of the event.
e
A SearchedEventArgs that contains the event data.

Remarks

When you create a SearchedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to Searched event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchedEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchProgressingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchProgressingEventHandler Delegate

sender
The source of the event.
e
A SearchProgressingEventArgs that contains the event data.
Represents the method that will handle the SearchProgressing event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub SearchProgressingEventHandler( _
   ByVal sender As Object, _
   ByVal e As SearchProgressingEventArgs _
)
C#
public delegate void SearchProgressingEventHandler(
   object sender,
   SearchProgressingEventArgs e
)

Parameters

sender
The source of the event.
e
A SearchProgressingEventArgs that contains the event data.

Remarks

When you create a SearchProgressingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to SearchProgressing event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

SearchProgressingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectedEventHandler Delegate

sender
The source of the event.
e
A TextSelectedEventArgs that contains the event data.
Represents the method that will handle the TextSelected event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TextSelectedEventHandler( _
   ByVal sender As Object, _
   ByVal e As TextSelectedEventArgs _
)
C#
public delegate void TextSelectedEventHandler(
   object sender,
   TextSelectedEventArgs e
)

Parameters

sender
The source of the event.
e
A TextSelectedEventArgs that contains the event data.

Remarks

When you create a TextSelectedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to TextSelected event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectedEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectingEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectingEventHandler Delegate

sender
The source of the event.
e
A TextSelectingEventArgs that contains the event data.
Represents the method that will handle the TextSelecting event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub TextSelectingEventHandler( _
   ByVal sender As Object, _
   ByVal e As TextSelectingEventArgs _
)
C#
public delegate void TextSelectingEventHandler(
   object sender,
   TextSelectingEventArgs e
)

Parameters

sender
The source of the event.
e
A TextSelectingEventArgs that contains the event data.

Remarks

When you create a TextSelectingEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to TextSelecting event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

TextSelectingEventHandler Members
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewChangedEventHandler Delegate | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ViewChangedEventHandler Delegate

sender
The source of the event.
e
A ViewChangedEventArgs that contains the event data.
Represents the mehtod that will handle the ViewChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub ViewChangedEventHandler( _
   ByVal sender As Object, _
   ByVal e As ViewChangedEventArgs _
)
C#
public delegate void ViewChangedEventHandler(
   object sender,
   ViewChangedEventArgs e
)

Parameters

sender
The source of the event.
e
A ViewChangedEventArgs that contains the event data.

Remarks

When you create a ViewChangedEventHandler delegate, you identify the method that will handle the event. To associate the event with your event handler, add an instance of the delegate to the event. The event handler is called whenever the event occurs, unless you remove the delegate.

Example

For example refer to ViewChanged event.

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

ViewChangedEventHandler Members
Foxit.PDF.Viewer Namespace


%%phrase%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Viewer Assembly | Comments on this topic
See Also

Namespaces

Namespace | Description
Foxit.PDF.Viewer |


$$GETTING_STARTED$$ - %%projecttitle%%

Foxit Software Help Library for .NET - June 2013
Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Foxit Software Help Library for .NET - June 2013
Introduction
Send Feedback


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Action Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Action Class

For a list of all members of this type, see Action members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Action Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Bookmark Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Bookmark Class

For a list of all members of this type, see Bookmark members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Bookmark Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ContextMenuShowingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ContextMenuShowingEventArgs Class

For a list of all members of this type, see ContextMenuShowingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ContextMenuShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
CursorModeChangedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : CursorModeChangedEventArgs Class

For a list of all members of this type, see CursorModeChangedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

CursorModeChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayedEventArgs Class

For a list of all members of this type, see DocumentDisplayedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DocumentDisplayedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentDisplayingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentDisplayingEventArgs Class

For a list of all members of this type, see DocumentDisplayingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

DocumentDisplayingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
DocumentLoadException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : DocumentLoadException Class

For a list of all members of this type, see DocumentLoadException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

DocumentLoadException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenDialogShowingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenDialogShowingEventArgs Class

For a list of all members of this type, see FileOpenDialogShowingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenedEventArgs Class

For a list of all members of this type, see FileOpenedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpenFailedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpenFailedEventArgs Class

For a list of all members of this type, see FileOpenFailedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpenFailedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
FileOpeningEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : FileOpeningEventArgs Class

For a list of all members of this type, see FileOpeningEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

FileOpeningEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
GoToAction Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : GoToAction Class

For a list of all members of this type, see GoToAction members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

GoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
InvalidPasswordException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : InvalidPasswordException Class

For a list of all members of this type, see InvalidPasswordException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

InvalidPasswordException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LaunchAction Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LaunchAction Class

For a list of all members of this type, see LaunchAction members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LaunchAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LicensingException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LicensingException Class

For a list of all members of this type, see LicensingException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

LicensingException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
LinkClickedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : LinkClickedEventArgs Class

For a list of all members of this type, see LinkClickedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

LinkClickedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PageVisibleArea Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PageVisibleArea Class

For a list of all members of this type, see PageVisibleArea members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PageVisibleArea Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PasswordRequiredEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PasswordRequiredEventArgs Class

For a list of all members of this type, see PasswordRequiredEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PasswordRequiredEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfDocument Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfDocument Class

For a list of all members of this type, see PdfDocument members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfDocument Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerException Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerException Class

For a list of all members of this type, see PdfViewerException members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetBaseException | When overridden in a derived class, returns the System.Exception that is the root cause of one or more subsequent exceptions. (Inherited from System.Exception)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetObjectData | When overridden in a derived class, sets the System.Runtime.Serialization.SerializationInfo with information about the exception. (Inherited from System.Exception)
Public Method | GetType | Gets the runtime type of the current instance. (Inherited from System.Exception)
Public Method | ToString | Creates and returns a string representation of the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfViewerException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Properties$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerException Class Properties | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerException Class

For a list of all members of this type, see PdfViewerException members.

Public Properties

 | Name | Description
Public Property | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from System.Exception)
Public Property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from System.Exception)
Public Property | InnerException | Gets the System.Exception instance that caused the current exception. (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from System.Exception)
Public Property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from System.Exception)
Public Property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from System.Exception)
Public Property | TargetSite | Gets the method that throws the current exception. (Inherited from System.Exception)
Top

See Also

Reference

PdfViewerException Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
PdfViewerMouseEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : PdfViewerMouseEventArgs Class

For a list of all members of this type, see PdfViewerMouseEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

PdfViewerMouseEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Dispose Method | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace > PdfViewer Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, Windows Vista, Windows 7, Windows Server 2008 family.

See Also

Reference

PdfViewer Class
PdfViewer Members


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Permission Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : Permission Class

For a list of all members of this type, see Permission members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

Permission Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
RemoteGoToAction Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : RemoteGoToAction Class

For a list of all members of this type, see RemoteGoToAction members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

RemoteGoToAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchDialogShowingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchDialogShowingEventArgs Class

For a list of all members of this type, see SearchDialogShowingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchDialogShowingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchedEventArgs Class

For a list of all members of this type, see SearchedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
SearchProgressingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : SearchProgressingEventArgs Class

For a list of all members of this type, see SearchProgressingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

SearchProgressingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectedEventArgs Class

For a list of all members of this type, see TextSelectedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TextSelectedEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
TextSelectingEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : TextSelectingEventArgs Class

For a list of all members of this type, see TextSelectingEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

TextSelectingEventArgs Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
URIAction Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : URIAction Class

For a list of all members of this type, see URIAction members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

URIAction Class
Foxit.PDF.Viewer Namespace


%%PageItemTitle%% $$Methods$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
ViewChangedEventArgs Class Methods | Comments on this topic
See Also
[image]
Foxit.PDF.Viewer Assembly > Foxit.PDF.Viewer Namespace : ViewChangedEventArgs Class

For a list of all members of this type, see ViewChangedEventArgs members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from object)
Public Method | GetHashCode | Serves as a hash function for a particular type. System.Object.GetHashCode is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from object)
Public Method | GetType | Gets the System.Type of the current instance. (Inherited from object)
Public Method | ToString | Returns a System.String that represents the current System.Object. (Inherited from object)
Top

See Also

Reference

ViewChangedEventArgs Class
Foxit.PDF.Viewer Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Foxit.PDF.Viewer Namespace Inheritance Hierarchy | Comments on this topic
See Also
Foxit.PDF.Viewer Assembly : Foxit.PDF.Viewer Namespace

Inheritance Hierarchy

System.Object
Foxit.PDF.Viewer.Action
Foxit.PDF.Viewer.GoToAction
Foxit.PDF.Viewer.LaunchAction
Foxit.PDF.Viewer.RemoteGoToAction
Foxit.PDF.Viewer.URIAction
Foxit.PDF.Viewer.Bookmark
Foxit.PDF.Viewer.BookmarkList
Foxit.PDF.Viewer.PageVisibleArea
Foxit.PDF.Viewer.PdfDocument
Foxit.PDF.Viewer.Permission
Foxit.PDF.Viewer.View
System.EventArgs
Foxit.PDF.Viewer.ContextMenuShowingEventArgs
Foxit.PDF.Viewer.CursorModeChangedEventArgs
Foxit.PDF.Viewer.DocumentDisplayedEventArgs
Foxit.PDF.Viewer.DocumentDisplayingEventArgs
Foxit.PDF.Viewer.FileOpenDialogShowingEventArgs
Foxit.PDF.Viewer.FileOpenedEventArgs
Foxit.PDF.Viewer.FileOpenFailedEventArgs
Foxit.PDF.Viewer.FileOpeningEventArgs
Foxit.PDF.Viewer.LinkClickedEventArgs
Foxit.PDF.Viewer.PasswordRequiredEventArgs
Foxit.PDF.Viewer.PdfViewerMouseEventArgs
Foxit.PDF.Viewer.SearchDialogShowingEventArgs
Foxit.PDF.Viewer.SearchedEventArgs
Foxit.PDF.Viewer.SearchProgressingEventArgs
Foxit.PDF.Viewer.TextSelectedEventArgs
Foxit.PDF.Viewer.TextSelectingEventArgs
Foxit.PDF.Viewer.ViewChangedEventArgs
System.Exception
Foxit.PDF.Viewer.LicensingException
Foxit.PDF.Viewer.PdfViewerException
Foxit.PDF.Viewer.DocumentLoadException
Foxit.PDF.Viewer.InvalidPasswordException
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Foxit.PDF.Viewer.PdfViewer

See Also

Reference

Foxit.PDF.Viewer Assembly


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a Password Protected PDF | Comments on this topic

Glossary Item Box

If the PDF is encrypted and protected with a password, first create a PdfDocument object specifying the file path and password in the constructor then pass that PdfDocument object to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed it on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the OverView section above.

The below example assume that the form’s Name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument("C:\MyDocument.pdf", "password")
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(@"C:\MyDocument.pdf", "password");
pdfViewer.Open(pdfDocument");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from Byte Array | Comments on this topic

Glossary Item Box

To open a PDF directly from a byte array, first create a PdfDocument object out of the byte array then pass that PdfDocument to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the OverView section above.

The below example assume that the form’s Name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument(MyPdfBytes)
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(pdfData);
pdfViewer.Open(pdfDocument");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from File | Comments on this topic

Glossary Item Box

A PDF file can be opened using the Open method.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the OverView section above.

The below example assume that the form’s Name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfViewer.Open("C:\MyDocument.pdf")

[C#]
pdfViewer.Open(@"C:\MyDocument.pdf");


%%ItemTitle%%

Foxit Software Help Library for .NET - June 2013 | Foxit Software
Opening a PDF from Stream | Comments on this topic

Glossary Item Box

To open a PDF directly from a System.IO.Stream object, first create a PdfDocument object out of the stream then pass that PdfDocument to the Open method of the Viewer control.

If this is the first time using Foxit PDF Viewer make sure that you have downloaded (http://www.foxitsoftware.com/products/sdk/) and installed on this machine and make sure that our PdfViewer control has been added to your toolbox inside of Visual Studio. Once that has been done, drag PdfViewer from the toolbox onto your form. For more details on this procedure please review the OverView section above.

The below example assume that the form’s Name in C# is pdfViewer and in VB.NET is MyPdfViewer.

[Visual Basic]
MyPdfDocument as PdfDocument = New PdfDocument(MyStream)
MyPdfViewer.Open(MyPdfDocument)

[C#]
PdfDocument pdfDocument = new PdfDocument(pdfStream);
pdfViewer.Open(pdfDocument);